How to configure HFM to allow loading of EOM and AVG rates?

I am new to HFM and would appreciate some assistance with loading of Exchange rates. I have created the currency members in the Value and Account Dimensions, and have also created two additional accounts (in the Accounts dimension) to capture the EOM and AVG rates, and tagged these as "currencyrate" in account type. How do I get the rates to appear in C1 and C2 so that I can load EOM and AVG rates? Firstly, the TO and FROM rates do not appear in C1 & C2 for me to select (via a Grid).  And when I tried to load the data via a flat file, the system highlights that the intersection is invalid..
Scenario;Year;Period;View;Entity;Value;Account;ICP;C1;C2;C3;C4;Amount
Actual;2013;Jul;YTD;[None];<Entity Currency>;EOMRate;[ICP None];AUD;USD;[None];[None];X.XXXX
When I tried creating the currencies in C1 & C2, the system rejected the members due to duplication (ie in the Value dimension)
Assistance appreciated.
Thanks
JC

Hi JC,
To view/load the rates in a grid you'll want to select [Currencies] from View option in your Member Selection.  View is the first of the three icons at the top of the screen (View, Filters, and Options).  Once you select [Currencies] you'll see a list comprised of all members you've previously added to the Value dimension.
Your flat file looks good, however, you might try loading to [None] in the Value dimension rather than <Entity Currency>.  Also, confirm the members to which you're loading in C1 and C2 exist in the Value dimension.
Note: you can also view/load rates using HsSetValue formulas.
Thanks,
Erich

Similar Messages

  • How to configure OraMTS to allow WCF using MSDTC access  OracleDB  On unix?

    How to configure OraMTS to allow WCF using distributed transactions to access the ORACLE database On Linux/Unix ?
    Env:
    1. DB-tier node , ORACLE database (version: 11.2.0.1.0) on Redhat Linux server ;
    2. middle-tier node ,Both the client, the MS DTC and Oracle MTS run on the same computer , Win7 x64 OS , installed .Netframework 4.0, ODP.net (ODAC112030), and configure the component services in a distributed transaction;
    Has done the configuration:
    1. ORACLE database on a Linux server (version: 11.2.0.1.0) has execute oramtsadmin.sql script;
    2.ORACLE database on a Linux server (version: 11.2.0.1.0) has execute the following script, Creating an Access Control List (ACL);
    BEGIN
    -- Create the new ACL, naming it "OraMTSadmin.xml", with a description.
    -- This provides the OraMTS administrative user e.g. MTSADMIN user FOO
    -- the privilege to connect
    DBMS_NETWORK_ACL_ADMIN.CREATE_ACL('OraMTSadmin.xml',
    'Allow usage to the UTL network packages',
    'ORAMTS', TRUE, 'connect');
    -- Now grant privilege to resolve DNS names to the OraMTS administrative user
    DBMS_NETWORK_ACL_ADMIN.ADD_PRIVILEGE('OraMTSadmin.xml' ,
    'ORAMTS', TRUE,'resolve');
    -- Specify which hosts this ACL applies to, in this case we are allowing
    -- access to all hosts. if one knew the list of all Windows middle-tier,
    -- these could be added one by one.
    DBMS_NETWORK_ACL_ADMIN.ASSIGN_ACL('OraMTSadmin.xml','*');
    END;
    3. ORACLE database on a Linux server has set JOB_QUEUE_PROCESSES = 1000;
    4. restart Oralce;
    5.Test code as follows :
    using System;
    using System.Collections.Generic;
    using System.Linq;
    using System.Text;
    using JetSun.Infrastructure;
    using Microsoft.VisualStudio.TestTools.UnitTesting;
    using JetSun.Infrastructure.ServiceModel;
    using JetSun.DataModel.Cis;
    using JetSun.TestFramework;
    using System.IO;
    using System.Data.EntityClient;
    using System.Data.Objects;
    using ConsoleApplicationTest;
    using System.Transactions;
    namespace Core.Tests
    [TestClass]
    public class EfOracleTest
    public TestContext TestContext { get; set; }
    [TestMethod]
    public void GetEntities()
    //string cn = "DATA SOURCE=HIS30;DBA PRIVILEGE=SYSDBA;PASSWORD=jetsun;PERSIST SECURITY INFO=True;USER ID=SYS;enlist=true";
    string cn = "DATA SOURCE=HIS30;DBA PRIVILEGE=SYSDBA;PASSWORD=mtssys;PERSIST SECURITY INFO=True;USER ID=mtssys;enlist=true";
    DbsSetting s = new DbsSetting(Dbs.IP, DbsProvider.Oracle, cn);
    Runtime.SetDeploymentDir(TestContext.TestDeploymentDir);
    File.Copy("E:\\VSTS\\MedicalHealth\\bin\\Debug\\DataModel.Cis.Oracle.dll", Path.Combine(TestContext.TestDeploymentDir, "DataModel.Cis.Oracle.dll"));
    //File.Copy(@"E:\VSTS\MedicalHealth\DataModel\Oracle\DataModel.Cis\EdmDiagnose.csdl", Path.Combine(TestContext.TestDeploymentDir, "EdmDiagnose.csdl"));
    //File.Copy(@"E:\VSTS\MedicalHealth\DataModel\Oracle\DataModel.Cis\EdmDiagnose.ssdl", Path.Combine(TestContext.TestDeploymentDir, "EdmDiagnose.ssdl"));
    //File.Copy(@"E:\VSTS\MedicalHealth\DataModel\Oracle\DataModel.Cis\EdmDiagnose.msl", Path.Combine(TestContext.TestDeploymentDir, "EdmDiagnose.msl"));
    File.Copy(@"D:\vsts_test\ConsoleApplicationTest\ConsoleApplicationTest\bin\Debug\Model1.csdl", Path.Combine(TestContext.TestDeploymentDir, "Model1.csdl"));
    File.Copy(@"D:\vsts_test\ConsoleApplicationTest\ConsoleApplicationTest\bin\Debug\Model1.ssdl", Path.Combine(TestContext.TestDeploymentDir, "Model1.ssdl"));
    File.Copy(@"D:\vsts_test\ConsoleApplicationTest\ConsoleApplicationTest\bin\Debug\Model1.msl", Path.Combine(TestContext.TestDeploymentDir, "Model1.msl"));
    string connectionString = s.ToEdmConnectionString(typeof(EdmEncounter), false);
    //// Initialize the EntityConnectionStringBuilder.
    //EntityConnectionStringBuilder entityBuilder =
    // new EntityConnectionStringBuilder();
    ////Set the provider name.
    //entityBuilder.Provider = s.Provider.Provider;
    //// Set the provider-specific connection string.
    //entityBuilder.ProviderConnectionString = cn;
    //// Set the Metadata location.
    //entityBuilder.Metadata = string.Format(@"res://{0}/EdmDiagnose.csdl|res://{0}/EdmDiagnose.ssdl|res://{0}/EdmDiagnose.msl", "DataModel.Cis.Oracle, Version=3.0.0.0, Culture=neutral, PublicKeyToken=null");
    //entityBuilder.Metadata = string.Format(@".\Model1.csdl|.\Model1.ssdl|.\Model1.msl", "DataModel.Cis.Oracle, Version=3.0.0.0, Culture=neutral, PublicKeyToken=null");
    //connectionString = entityBuilder.ToString();
    ////using (Entities edm = new Entities(connectionString))
    //// foreach (var item in edm.ENCOUNTERs.Take(10))
    //// Console.WriteLine("{0}\t{1}", item.ENCOUNTERID, item.DISPLAYNAME);
    //entityBuilder.Metadata = string.Format(@"res://*/EdmDiagnose.csdl|.\EdmDiagnose.ssdl|.\EdmDiagnose.msl", "DataModel.Cis.Oracle, Version=3.0.0.0, Culture=neutral, PublicKeyToken=null");
    //entityBuilder.Metadata = string.Format(@"res://{0}/", "DataModel.Cis.Oracle, Version=3.0.0.0, Culture=neutral, PublicKeyToken=null");
    connectionString = s.ToEdmConnectionString(typeof(EdmFeeInfo), false);
    try
    //using (TransactionScope tx = new TransactionScope())
    using (TransactionScope scope = new TransactionScope(TransactionScopeOption.Required, new TimeSpan(0, 0, 30)))
    //using (var dbcn = s.Provider.CreateConnect(connectionString))
    using (EdmFeeInfo edm = new EdmFeeInfo(connectionString))
    //edm.Connection.CheckOpen();
    //using (edm.Connection.BeginTransaction())
    foreach (var item in edm.FeeInfos.Take(100))
    TestContext.WriteLine("{0}\t{1}", item.EncounterId, item.Amount);
    item.Amount = item.Amount * -1;
    edm.SaveChanges();
    // using (EdmFeeInfo edm2 = new EdmFeeInfo(connectionString))
    // edm2.Connection.CheckOpen();
    // edm2.Connection.EnlistTransaction(Transaction.Current);
    // foreach (var item in edm2.FeeInfos.Take(100))
    // item.Amount = item.Amount * -1;
    // edm2.SaveChanges();
    // throw new NotImplementedException();
    TestContext.WriteLine("-----------1---------------");
    using (EdmFeeInfo edm = new EdmFeeInfo(connectionString))
    foreach (var item in edm.FeeInfos.Take(100))
    TestContext.WriteLine("{0}\t{1}", item.EncounterId, item.Amount);
    throw new NotImplementedException();
    catch (Exception ex)
    TestContext.WriteLine((ex.InnerException ?? ex).Message);
    TestContext.WriteLine("-------------2-------------");
    using (EdmFeeInfo edm = new EdmFeeInfo(connectionString))
    foreach (var item in edm.FeeInfos.Take(100))
    TestContext.WriteLine("{0}\t{1}", item.EncounterId, item.Amount);
    6. the test results are as follows:
    4 125
    4 835.45
    4 3458
    4 2350
    4 200
    4 100
    4 300
    4 123
    4 234
    无法列入分布式事务处理 (Could not be included in the Distributed Transaction)
    -------------2-------------
    4 125
    4 835.45
    4 3458
    4 2350
    4 200
    4 100
    4 300
    4 123
    The main error message:无法列入分布式事务处理 (Could not be included in the Distributed Transaction) , not use distributed transaction everything is normal.
    My test environment MS DTC and Oracle MTS Recovery Service run on the same computer, but OracleMTSRecoveryService registry values under£º HKEY_LOCAL_MACHINE \ SOFTWARE \ Wow6432Node \ ORACLE \ OracleMTSRecoveryService ,not under HKEY_LOCAL_MACHINE \ SOFTWARE \ ORACLE,I do not know that there is no relationship.
    Is not configured incorrectly?Who can help me, thank you very much!

    Do you really have a requirement to push data from Oracle to Access rather than pulling data from Oracle to Access? It would be exceptionally unusual to push data from Oracle to Access.
    Pushing from Oracle to Access would means that you want some Oracle process running that is updating Access. But you said that your Access database was on your "local desktop" which implies that it is not running on a server where it is always available. So that means that the Oracle process is going to regularly encounter (and report) errors because the Access database is not available. In turn, that's going to mean that your push process is either going to cause the underlying transaction to fail or it's going to mean that the push process is going to have to implement a fair amount of code to queue data to be pushed at a later date (and track all those changes) which is no small task. None of that seems particularly pleasant.
    On the other hand, Access is designed to pull data from real relational databases like Oracle. That's the far more normal approach architecturally. It doesn't require an Oracle process, it doesn't generate errors on the Oracle database when the local desktop is down, etc.
    And, of course, I'm assuming that introducing Access is even architecturally reasonable. Most organizations would be extremely hesitant to allow data from an Oracle database to get moved into Access because that quickly means that they lose control of the data from a security standpoint, that there are now multiple copies of the data floating around when changes & corrections are made, etc. That causes all sorts of headaches normally above and beyond the headaches that pushing from Oracle to Access would create.
    Justin

  • How do I configure ACE30 to allow server to server and server to VIP communications

           I have a ACE30 with 2 client vlans and 2 server vlans in a 2-arm routed mode.  I want to allow  server initiated traffic from either server vlan to access both client vlans via a VIP and also allow server to server traffic between the 2 server vlans via the server IP address.  This is all in a single context. Attached is a diagram of the environment.  The server's gateway is the ACE interface for that particular vlan.
    so servers on vlan 206 will initiate traffic to either vlan 296 or 298 and therefore load balance to servers on either vlan 206 or 216.  same goes for server vlan 216. 
    In conjunction with that how do i configure the ACE so that the servers in one vlan can talk to the servers in the other via directly via their IP address.  for instance the source would be vlan 206 and the destination would be vlan.
    Thank you
    Tony.

    Chris,  does this look correct based on your description of how to configure:
    class-map match-all REAL-SERVERS-VL226
      2 match source-address 10.192.34.0 255.255.255.0
    class-map match-all REAL-SERVERS-VL246
      2 match source-address 10.192.44.0 255.255.255.0
    policy-map multi-match INTRA-server_P
      class LYNCP2F_C
        loadbalance vip inservice
        loadbalance policy LYNCP2F_P
        loadbalance vip icmp-reply active
        nat dynamic 5 vlan 246
      class LYNCP-FE_C
        loadbalance vip inservice
        loadbalance policy LYNCP-FE_P
        loadbalance vip icmp-reply active
      class REAL-SERVERS-VL226
         nat dynamic 1 vlan 226
      class REAL-SERVERS-VL246
         nat dynamic 2 vlan 246
    interface vlan 226
      description Intranet Services Server Vlan 226
      ip address 10.192.34.2 255.255.255.0
      alias 10.192.34.1 255.255.255.0
      peer ip address 10.192.34.3 255.255.255.0
      no icmp-guard
      access-group input ALL-IN
      nat-pool 1 10.192.34.254 10.192.34.254 netmask 255.255.255.0 pat
      service-policy input INTRA-server_P
      no shutdown
    interface vlan 246
      description Intranet Services Server Vlan 246
      ip address 10.192.44.2 255.255.255.0
      alias 10.192.44.1 255.255.255.0
      peer ip address 10.192.44.3 255.255.255.0
      no icmp-guard
      access-group input ALL-IN
      nat-pool 2 10.192.44.254 10.192.44.254 netmask 255.255.255.0 pat
      service-policy input INTRA-server_P
      no shutdown
    interface vlan 292
      description Intranet Services Client Vlan 292
      ip address 10.192.8.4 255.255.254.0
      alias 10.192.8.6 255.255.254.0
      peer ip address 10.192.8.5 255.255.254.0
      mac-sticky enable
      no icmp-guard
      access-group input ALL-IN
      no shutdown
    interface vlan 294
      description Intranet Services Client Vlan 294
      ip address 10.192.6.4 255.255.254.0
      alias 10.192.6.6 255.255.254.0
      peer ip address 10.192.6.5 255.255.254.0
      mac-sticky enable
      no icmp-guard
      access-group input ALL-IN
      no shutdown

  • How to configure global transaction wthin Oracle AS JMS and Oracle JMS

    How to configure global transaction if I take a message from Oracle JMS(AQ) and send it to the Oracle JMS?

    Which version of OC4J are you working on?
    In OC4J 10.1.3.x, presume your OC4J JMS listens messages via MDB which uses a resource adapter as a message listener. The resouce adaper could be the generic JMS adapter deployed in OC4J as the default.
    Resource adapter configuration to support MDBs is included in the standard ra.xml file, which lists the message listener types that the resource adapter supports.
    The MDB developer or deployer configures the MDB in the ejb-jar.xml file, through a <message-driven> element.
    In addition to above, configuration in the ejb-jar.xml file specifies whether an MDB uses transactions.
    1) The <transaction-type> subelement of <message-driven> in ejb-jar.xml has a value of Container, and the <trans-attribute> subelement of <container-transaction> (under the <assembly-descriptor> element) has a value of Required. In this circumstance, if there is an imported transaction, then message delivery and related work are performed within that transaction. If there is no imported transaction, OC4J creates a transaction, and message delivery and related work are performed within that transaction.
    2) The <transaction-type> subelement of <message-driven> in ejb-jar.xml has a value of Bean. In this circumstance, the MDB manages the transaction. If a transaction is imported, OC4J will suspend it before the message delivery method call to the MDB, in order to avoid conflict.
    Message delivery is not transacted if the <transaction-type> subelement of <message-driven> in ejb-jar.xml has a value of Container, but the <trans-attribute> element has a value of NotSupported. If there is an imported transaction in this circumstance, OC4J will suspend the transaction before the message delivery method call to the MDB.
    Details could be found from OC4J Resource Adapter Guide.

  • How to configure for GPlus Adapter with SAP Phone and SAP CRM

    Hi All Basis Adm,
                   Please consider as an urgent basis i need the information that how to configure  GPlus Adapter with SAP Phone and SAP CRM . My server is CRM 5.0 (kernel 7) with Oracle Database. This information is require to connect Webclient to Sap Phone with GPlus Adapter (Genesys Adapter 7.1).  If u have any document regarding mentioned above than that will be acceptable. 
    Regds,
    Govinda

    Hi Prasad,
    In you case, it's a file to file scenario.
    Go thro' this link for a solution:-
    /people/venkat.donela/blog/2005/03/02/introduction-to-simplefile-xi-filescenario-and-complete-walk-through-for-starterspart1
    /people/venkat.donela/blog/2005/03/03/introduction-to-simple-file-xi-filescenario-and-complete-walk-through-for-starterspart2
    Regards.
    Praveen

  • How to configure my keyboard to portuguese from brazil and can type "c̡", "é", "ã", etc?

    How can I configure my keyboard to portuguese from brazil, and can write "c̡", "á", "ã", etc ?

    System Preferences > Language and Text > Input Sources tab. Top of the left column, tick (check) "Keyboard and Character Viewer", Bottom of window next to search field, tick "Show input menu in menu bar"
    Enable Portuguese keyboard layout.
    System Preferences > Keyboard > Keyboard tab; tick "show keyboard and character viewers in menu bar"
    If you open Keyboard Viewer and press the alt (option) key, the location of the diacritics will be revealed. Note that five of them are highlighted in orange; these are the ones which can be used with multiple  letters (acute, umlaut, gràve, circumflex and tilde)
    Shift+Alt will show more.
    If you want to use the Portuguese layout, go to the flag symbol in the menu bar and change the keyboard in the dropdown, then use Keyboard viewer again to see where the characters are in relation to your own keyboard.

  • How to configure for music file loading

    I don't know if you can help with this one.
    If so, great. If not, I'm not insulted.
    I have a pair of Oakley Thumps, which are sunglasses with a built in MP3 player.
    I used to have little if any problem loading music on to them from my old windows based Dell computer, by way of the Media Player.
    We just got our mac last Sunday (G5 - Tiger version of OS-X), and today was the first day that I hooked up my Thumps. The mac recognized them as Thump 128 (for the memory size) and there is an icon on my desktop. However, the files that were stored were changed to a document file, and now won't play. I tried loading iTunes songs, but they won't play, since they are MP4 (Thumps only play/recognize MP3, WMA and WAV files).
    Do you have any tips for how I can go about configuring iTunes, or any other program on my wonderful new mac, to allow me to load songs onto my Thumps?

    You will not be able to put (or play)purchased music files onto the device but you should be able to "drag" any .mp3 file onto it.
    If you mount the device and double click to open it there may be a folder structure that needs to be followed.
    The current files may be in Media Player format (.wma) and can be opened with the WMP for Mac.

  • How to configure ASA to allow activesync connections ?

    To allow Activesync connections (between smartphones and an internal Exchange server) thru an ASA, I think about 3 or 4 potential solutions :
    1) do a NAT on the Exchange server and allow  activesync TCP connections from any IP to the Exchange server : I tested that and this works, but it is not the most secure solution we can imagine;
    2) use a Clienless VPN SSL  ASA configuration : I tried it, but got problems certaintly related to the fact that the Activesync client, installed on my Android/Samsung smartphone, does not seem to be able vto pass properly thru the ASA Portal to reach the Exchange server;
    3) use an Anyconnect VPN ASA configuration : I tried it , but did not manage to install or use any of the Samsung Anyconnect client available on Android Market; by the way, I saw, in the Anyconnect VPN Client Admin Guide 2.4, that an ActiveSync MSI is available from CISCO (
    anyconnect-wince-ARMv4I-activesync-AnyConnectRelease_Number-k9.msi), but I don't see any details about how it is supposed to be used except that it is for Windows environment only, so, not for an Android phone, but I have Windows Mobile smartphones to integrate too, so, maybe it can help me in this case ;
    4) if Clientless nor Anyconnect solutions can't work, it might be better to use the ASA Cut-Through proxy function to get a more secure solution than the first one listed above; but I was not successful either with this cut-through proxy function
    Any ideas or examples about how to allow activesync connections thru ASA would be welcomed
    thanks in advance

    Hi,
    Generally ASA with CSC will support HTTP,FTP,SMTP,POP3 Scaning and Filtering.
    From version ASA IOS 8.4.2 and CSC  6.6.1125.0, it will support HTTPS filtering also.
    But here one limitation is that Https filtering will not support earlier versions of internet explorer 9, i.e if you want HTTPS filtering you must use Internet explorer 9 or after versions( As you know that Windows XP machines won't support internet explorer 9). But with firefox HTTPS filtering will support from versions 4.
    For your reference use below 8.4.2 release guide
    http://www.cisco.com/en/US/docs/security/asa/asa84/release/notes/asarn84.html
    Release notes for CSC version 6.6.1125
    http://www.cisco.com/en/US/docs/security/csc/csc66/release/notes/cscrn66.pdf
    Basic configuration of the CSC
    http://www.cisco.com/en/US/docs/security/csc/csc6.1.1569.0/administration/guide/cscappa.pdf
    Sending traffic to the CSC module (using ASDM and CLI)
    http://www.cisco.com/en/US/products/ps6120/products_configuration_example09186a00808dea62.shtml
    The troubleshooting guide:
    http://www.cisco.com/en/US/docs/security/csc/csc63/administration/guide/csc8.html#wp1147829
    Hope this will help you...
    Do rate help ful posts..
    Regards,
    Janardhan

  • How to configure SSL on Cisco Load Balancer

    I want to configure SSL termination on cisco LB. i just want to know is there any license required for this deployment ? please share me some configuration steps to deploy the SSL.
    Thanks
    Irfan Hussain

    Check the following basic ssl config
    http://docwiki.cisco.com/wiki/Cisco_Application_Control_Engine_%28ACE%29_Configuration_Examples_--_SSL_Configuration_Examples
    I think you do get a little of ssl resource without a license.
    Gilles.

  • How to configure a port channel with VLAN trunking (and make it work..)

    We're trying to configure a port channel group with trunked ports to connect a NetApp HA pair. We want to create two data LIFs and connect them to the switch stack.  We are trying to create 2 data lifs, one for cifs and one for nfs that are on different vlans.
    We want the same ports to be able to allow multiple vlans to communicate. (trunked)
    These data lifs should be able to fail over to different nodes in the HA pair and still be able to communicate on the network.
    What this means is that we have to connect 4 ports each for each node in the NetApp HA Pair to the switches and create a port channel of some type that allows for trunked vlans. When we configure the ports, the configuration is as follows (below):
    We are only able to configure an IP on one of the vlans.
    When we configure an IP from another vlan for the data lif, it does not respond to a ping.
    Does anyone have any idea what I'm doing wrong on the Cisco switch?
    interface GigabitEthernet4/0/12
    description Netapp2-e0a
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 10,20,511,519
    channel-protocol lacp
    channel-group 20 mode active
    end
    interface GigabitEthernet4/0/13
    description Netapp2-e0c
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 10,20,511,519
    channel-protocol lacp
    channel-group 20 mode active
    end
    interface GigabitEthernet6/0/12
    description Netapp2-e0b
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 10,20,511,519
    channel-protocol lacp
    channel-group 20 mode active
    end
    interface GigabitEthernet6/0/13
    description Netapp2-e0d
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 10,20,511,519
    channel-protocol lacp
    channel-group 20 mode active
    end
    interface Port-channel20
    description Netapp2-NFS
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 10,20,511,519
    spanning-tree portfast
    spanning-tree bpduguard enable
    end

    Our problem was fixed by the storage people.  They changed the server end to trunk, and the encapsulation / etherchannel.
    I like all the suggestions, and they probably helped out with the configuration getting this to work.
    Thanks!
    interface Port-channel20
    description Netapp2-NFS
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 10,20,511,519
    switchport mode trunk
    interface GigabitEthernet4/0/12
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 10,20,511,519
    switchport mode trunk
    channel-protocol lacp
    channel-group 20 mode active
    interface GigabitEthernet4/0/13
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 10,20,511,519
    switchport mode trunk
    channel-protocol lacp
    channel-group 20 mode active
    interface GigabitEthernet6/0/12
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 10,20,511,519
    switchport mode trunk
    channel-protocol lacp
    channel-group 20 mode active
    interface GigabitEthernet6/0/13
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 10,20,511,519
    switchport mode trunk
    channel-protocol lacp
    channel-group 20 mode active

  • How to configure Spring Data JPA to handle sdo_geometry and Timestamp(0)?

    Hi all,
    I'm new to this community, not sure if I'm posting in the right place.
    I'm an Oracle old-hand, but new to Spring Data, having done a bit on postGIS, but now trying to apply it to Oracle.
    My problem:  I have a new maven project, with Entity and Repository classes, and a JUnit test program that uses DbUnit to preload test data.
    The current config uses a beans.xml file to set up:
      <bean id="entityManagerFactory"
        class="org.springframework.orm.jpa.LocalContainerEntityManagerFactoryBean">...
        <property name="jpaProperties">....
      <bean id="vendorAdapter"
        class="org.springframework.orm.jpa.vendor.HibernateJpaVendorAdapter">
        <property name="databasePlatform" value="org.hibernate.dialect.Oracle10gDialect" />
        <property name="generateDdl" value="false" />
      </bean>
      <bean id="dataSource" class="com.mchange.v2.c3p0.ComboPooledDataSource"
        destroy-method="close">
        <property name="driverClass" value="oracle.jdbc.OracleDriver" />
        <property name="jdbcUrl"
         value="jdbc:oracle:thin:@localhost:2632:BLADE" />...
    <bean id="transactionManager" class="org.springframework.orm.jpa.JpaTransactionManager">
      <property name="entityManagerFactory" ref="entityManagerFactory" />
    </bean>
    Test of repos.count() works ok.
    Test to call repos.findByName(String) fails, (stack below).
    Now, the current setup doesn't handle SDO_GEOMETRY, or TIMESTAMP(0), but will manage TIMESTAMP(6).
    The warnings below show that I'm  using "DefaultDataTypeFactory" and should probably be using OracleDataTypeFactory.
    I've also found the OracleDataSource class, and tried that, but still get the same data type issues.
    Ok, the big questions:
    1. Can anyone point me at an example to configure the dataSource, or vendorAdapter, to use the OracleDataTypeFactory, and retrieve these data types?
    2. What data type should I be using in Java for the geometry column?
    Thanks,
    Phil
    Test output warnings:
    16:24:05.846 [main] INFO  org.springframework.test.context.transaction.TransactionalTestExecutionListener - Began transaction (2) for test context [DefaultTestContext@990034 testClass = NotamRepositoryTest, testInstance = com.thalesgroup.uk.airscape.common.data.domain.dao.notam.NotamRepositoryTest@3ff1d6, testMethod = testNotamFetchByDatasetName@NotamRepositoryTest, testException = [null], mergedContextConfiguration = [MergedContextConfiguration@1346193 testClass = NotamRepositoryTest, locations = '{classpath:testBeans.xml}', classes = '{}', contextInitializerClasses = '[]', activeProfiles = '{}', contextLoader = 'org.springframework.test.context.support.DelegatingSmartContextLoader', parent = [null]]]; transaction manager [org.springframework.orm.jpa.JpaTransactionManager@1f1fe9d]; rollback [true]
    16:24:08.674 [main] WARN  org.dbunit.dataset.AbstractTableMetaData - Potential problem found: The configured data type factory 'class org.dbunit.dataset.datatype.DefaultDataTypeFactory' might cause problems with the current database 'Oracle' (e.g. some datatypes may not be supported properly). In rare cases you might see this message because the list of supported database products is incomplete (list=[derby]). If so please request a java-class update via the forums.If you are using your own IDataTypeFactory extending DefaultDataTypeFactory, ensure that you override getValidDbProducts() to specify the supported database products.
    16:24:08.674 [main] WARN  org.dbunit.util.SQLHelper - DATA_SET.SEC_TAG_MODIFIED data type (1111, 'TIMESTAMP(0)') not recognized and will be ignored. See FAQ for more information.
    16:24:08.674 [main] WARN  org.dbunit.util.SQLHelper - DATA_SET.CREATED data type (1111, 'TIMESTAMP(0)') not recognized and will be ignored. See FAQ for more information.
    16:24:08.674 [main] WARN  org.dbunit.util.SQLHelper - DATA_SET.MODIFIED data type (1111, 'TIMESTAMP(0)') not recognized and will be ignored. See FAQ for more information.
    16:24:08.690 [main] WARN  org.dbunit.util.SQLHelper - DATA_SET.VALID_FROM data type (1111, 'TIMESTAMP(0)') not recognized and will be ignored. See FAQ for more information.
    16:24:08.690 [main] WARN  org.dbunit.util.SQLHelper - DATA_SET.VALID_TO data type (1111, 'TIMESTAMP(0)') not recognized and will be ignored. See FAQ for more information.
    16:24:08.690 [main] WARN  org.dbunit.dataset.AbstractTableMetaData - Potential problem found: The configured data type factory 'class org.dbunit.dataset.datatype.DefaultDataTypeFactory' might cause problems with the current database 'Oracle' (e.g. some datatypes may not be supported properly). In rare cases you might see this message because the list of supported database products is incomplete (list=[derby]). If so please request a java-class update via the forums.If you are using your own IDataTypeFactory extending DefaultDataTypeFactory, ensure that you override getValidDbProducts() to specify the supported database products.
    16:24:08.690 [main] WARN  org.dbunit.util.SQLHelper - NOTAM.Q_POINT data type (1111, 'SDO_GEOMETRY') not recognized and will be ignored. See FAQ for more information.
    16:24:08.690 [main] WARN  org.dbunit.util.SQLHelper - NOTAM.Q_RANGE_RING data type (1111, 'SDO_GEOMETRY') not recognized and will be ignored. See FAQ for more information.
    java.lang.UnsupportedOperationException
        at org.hibernate.spatial.GeometrySqlTypeDescriptor.getExtractor(GeometrySqlTypeDescriptor.java:57)
        at org.hibernate.type.AbstractStandardBasicType.nullSafeGet(AbstractStandardBasicType.java:267)
        at org.hibernate.type.AbstractStandardBasicType.nullSafeGet(AbstractStandardBasicType.java:263)
        at org.hibernate.type.AbstractStandardBasicType.nullSafeGet(AbstractStandardBasicType.java:253)
        at org.hibernate.type.AbstractStandardBasicType.hydrate(AbstractStandardBasicType.java:338)
        at org.hibernate.persister.entity.AbstractEntityPersister.hydrate(AbstractEntityPersister.java:2969)
        at org.hibernate.loader.Loader.loadFromResultSet(Loader.java:1695)
        at org.hibernate.loader.Loader.instanceNotYetLoaded(Loader.java:1627)
        at org.hibernate.loader.Loader.getRow(Loader.java:1514)
        at org.hibernate.loader.Loader.getRowFromResultSet(Loader.java:725)
        at org.hibernate.loader.Loader.processResultSet(Loader.java:952)
        at org.hibernate.loader.Loader.doQuery(Loader.java:920)
        at org.hibernate.loader.Loader.doQueryAndInitializeNonLazyCollections(Loader.java:354)
        at org.hibernate.loader.Loader.doList(Loader.java:2553)
        at org.hibernate.loader.Loader.doList(Loader.java:2539)
        at org.hibernate.loader.Loader.listIgnoreQueryCache(Loader.java:2369)
        at org.hibernate.loader.Loader.list(Loader.java:2364)
        at org.hibernate.loader.hql.QueryLoader.list(QueryLoader.java:496)
        at org.hibernate.hql.internal.ast.QueryTranslatorImpl.list(QueryTranslatorImpl.java:387)
        at org.hibernate.engine.query.spi.HQLQueryPlan.performList(HQLQueryPlan.java:231)
        at org.hibernate.internal.SessionImpl.list(SessionImpl.java:1264)
        at org.hibernate.internal.QueryImpl.list(QueryImpl.java:103)
        at org.hibernate.jpa.internal.QueryImpl.list(QueryImpl.java:573)
        at org.hibernate.jpa.internal.QueryImpl.getResultList(QueryImpl.java:449)
        at org.hibernate.jpa.criteria.compile.CriteriaQueryTypeQueryAdapter.getResultList(CriteriaQueryTypeQueryAdapter.java:67)
        at org.springframework.data.jpa.repository.query.JpaQueryExecution$CollectionExecution.doExecute(JpaQueryExecution.java:81)
        at org.springframework.data.jpa.repository.query.JpaQueryExecution.execute(JpaQueryExecution.java:59)
        at org.springframework.data.jpa.repository.query.AbstractJpaQuery.doExecute(AbstractJpaQuery.java:97)
        at org.springframework.data.jpa.repository.query.AbstractJpaQuery.execute(AbstractJpaQuery.java:88)
        at org.springframework.data.repository.core.support.RepositoryFactorySupport$QueryExecutorMethodInterceptor.doInvoke(RepositoryFactorySupport.java:384)
        at org.springframework.data.repository.core.support.RepositoryFactorySupport$QueryExecutorMethodInterceptor.invoke(RepositoryFactorySupport.java:344)
        at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:179)
        at org.springframework.transaction.interceptor.TransactionInterceptor$1.proceedWithInvocation(TransactionInterceptor.java:98)
        at org.springframework.transaction.interceptor.TransactionAspectSupport.invokeWithinTransaction(TransactionAspectSupport.java:262)
        at org.springframework.transaction.interceptor.TransactionInterceptor.invoke(TransactionInterceptor.java:95)
        at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:179)
        at org.springframework.dao.support.PersistenceExceptionTranslationInterceptor.invoke(PersistenceExceptionTranslationInterceptor.java:136)
        at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:179)
        at org.springframework.data.jpa.repository.support.CrudMethodMetadataPostProcessor$CrudMethodMetadataPopulatingMethodIntercceptor.invoke(CrudMethodMetadataPostProcessor.java:111)
        at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:179)
        at org.springframework.aop.interceptor.ExposeInvocationInterceptor.invoke(ExposeInvocationInterceptor.java:92)
        at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:179)
        at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynamicAopProxy.java:207)
        at com.sun.proxy.$Proxy67.findByDataSetNameAndDeletedIsNull(Unknown Source)
        at com.thalesgroup.uk.airscape.common.data.domain.dao.notam.NotamRepositoryTest.testNotamFetchByDatasetName(NotamRepositoryTest.java:103)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:606)
        at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:47)
        at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:12)
        at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:44)
        at org.junit.internal.runners.statements.InvokeMethod.evaluate(InvokeMethod.java:17)
        at org.springframework.test.context.junit4.statements.RunBeforeTestMethodCallbacks.evaluate(RunBeforeTestMethodCallbacks.java:74)
        at org.springframework.test.context.junit4.statements.RunAfterTestMethodCallbacks.evaluate(RunAfterTestMethodCallbacks.java:83)
        at org.springframework.test.context.junit4.statements.SpringRepeat.evaluate(SpringRepeat.java:72)
        at org.springframework.test.context.junit4.SpringJUnit4ClassRunner.runChild(SpringJUnit4ClassRunner.java:233)
        at org.springframework.test.context.junit4.SpringJUnit4ClassRunner.runChild(SpringJUnit4ClassRunner.java:87)
        at org.junit.runners.ParentRunner$3.run(ParentRunner.java:238)
        at org.junit.runners.ParentRunner$1.schedule(ParentRunner.java:63)
        at org.junit.runners.ParentRunner.runChildren(ParentRunner.java:236)
        at org.junit.runners.ParentRunner.access$000(ParentRunner.java:53)
        at org.junit.runners.ParentRunner$2.evaluate(ParentRunner.java:229)
        at org.springframework.test.context.junit4.statements.RunBeforeTestClassCallbacks.evaluate(RunBeforeTestClassCallbacks.java:61)
        at org.springframework.test.context.junit4.statements.RunAfterTestClassCallbacks.evaluate(RunAfterTestClassCallbacks.java:71)
        at org.junit.runners.ParentRunner.run(ParentRunner.java:309)
        at org.springframework.test.context.junit4.SpringJUnit4ClassRunner.run(SpringJUnit4ClassRunner.java:176)
        at org.eclipse.jdt.internal.junit4.runner.JUnit4TestReference.run(JUnit4TestReference.java:50)
        at org.eclipse.jdt.internal.junit.runner.TestExecution.run(TestExecution.java:38)
        at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:459)
        at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:675)
        at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(RemoteTestRunner.java:382)
        at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.main(RemoteTestRunner.java:192)

    Hi
    You can use T-code NACE and then select your application based on your output type you can assign your  Print program and Form.
    Reward points, if it is helpful.
    Regards
    Raja.

  • How to configure sync rules involving a CSV file and portal self service

    Hello,
     I need to configure some FIM sync rules for the following scenario:
     User account details are entered from a HR CSV file and exported to AD  Users have the ability to modify their own AD attributes in the
    FIM portal (there is not a requirement for them to view their  HR CSV data in the portal). The FIM portal modifications will be exported to AD as expected.  
    My setup is as follows:
    CSV file - name, last name, employee ID, address.
    CSV MA - has direct attribute flows configured in the MA between the data source and MV Portal self service attributes –      
    users can edit mobile, display name and photo
    I've also set the CSV MA as precedent for the attributes
    FIM MA – attribute flows defined for MV to Data Source as usual (i.e. firstname to firstname, accountname to accountname, etc).
    AD MA – no attribute flows defined as inbound and outbound sync rules have been configured in the portal using the Set\MPR\Triple.
    I’m thinking of using the following run profiles:
    CSV MA – full import and delta sync (imports HR data)
    FIM MA –  export and delta import (imports portal changes)
    FIM MA – delta sync (syncs any portal changes)
    AD MA – export and delta import
    If my understanding is correct this should sync HR data from CSV to AD, as well as user attribute self service updates from the portal to AD.
    If I wanted to just do a HR CSV sync could I get away with just steps 1 & 4 ? (presumably not as my rules are in the FIM portal?)
    If I wanted to do just a portal sync, could I get away steps 2-4?
    Any advice on how to improve my setup is much appreciated - cheers
    IT Support/Everything

    The truth is that your design should be done in the way that it doesn't matter which profiles in which order you will execute. At the end, if you will run all import, synch and export profiles on each data source you should get same result. This is beauty
    of synch engine here.
    Your steps from 1-4 will synch data to your data sources and at the end will give you expected result. But not because of the order you are executing them but because of correct attribute flows. If flows from CSV file and from FIM portal might be done for
    the same attributes you need to think also about attribute precedence.   
    Tomek Onyszko, memberOf Predica FIM Team (http://www.predica.pl), IdAM knowledge provider @ http://blog.predica.pl

  • Fire fox wont load properly keepd flashing on and off for about 15 minutes before it loads properly then says its in safe mode. How do i get it to load straight away and not in safe mode

    Firefox wont open straight away.
    I use to use Firefox all the time until a friend sent me a message that needed me to install Bandoo and I haven't been able to use Firefox since.
    I unistalled Bandoo and Firefox still wouldn't load for me so i uninstalled it and re installed Firefox now when i try to open it ,it just keeps flashing on and off my screen for about 15 minutes and when it does load to comes up to welcome to Firefox 4 and a popup comes up saying that firefox is in safe mode
    HOW DO I FIX THIS PLEASE??????

    BJB
    Suspect it has "dozed" off.  Can we get your event viewer logs
    Please provide us with your Event Viewer administrative logs by following these steps:
    Click Start Menu
    Type eventvwr into Search programs and files (do not hit enter)
    Right click eventvwr.exe and click Run as administrator
    Expand Custom Views
    Click Administrative Events
    Right click Administrative Events
    Save all Events in Custom View As...
    Save them in a folder where you will remember which folder and save as Errors.evtx
    Go to where you saved Errors.evtx
    Right click Errors.evtx -> send to -> compressed (zipped) folder
    Upload the .zip file to Onedrive or a file sharing service and put a link to it in your next post
    If you have updated to win 8.1 and you get the error message "the system cannot find the file specified" it is a known problem.
     The work around is to edit the registry.  If you are not comfortable doing this DONT.  If you are, backup the key before you do
    Press Win+"R" and input regedit
    Navigate to:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WINEVT\Channels. Delete "Microsoft-Windows-DxpTaskRingtone/Analytic"
    Wanikiya and Dyami--Team Zigzag

  • How much storage am I allowed on my website and how do I check the amount?

    I post a lot of videos on my website. I know they eat storage space. How do I check to see if I'm running out of space? Or, is this a question I should post on the MM discussion?

    Just to clarify: I know I am allowed 20 GB of storage on iDisk. I wasn't clear as to whether some of that is just storage, or whether I could post all 20 on my website. Sorry, but I would really appreciate it if you would confirm that is the case. Thanks for helping! (I'm just a gramma. My site is to keep family and friends informed about my physically disabled grandson. I really appreciate that there are users who are willing to take time to help!)

  • How to configure traps when using snmpv3 for Airwave and controller communication

    Requirement:
    Airwave monitoring or managing controllers, using SNMPv3 for communication.
    Solution:
    Usage of SNMP v3 for communication over SNMP V2c is increasing rapidly for its enhanced security. Like wise, SNMP v3 informs are also more secured compare to SNMP v2c traps.
    SNMP v3 informs work differently, when compared to SNMP v2c traps.  As, informs would need a received receipt from the trap receiver. Therefore it requires more configuration from Airwave side as well.
    Configuration:
    We need to configure the SNMP v3 inform user on Airwave, under device setup --> communication as shown below:
    We need to use the same user name to configure on the controller as well, as shown below:
    Controller GUI > Configuration > under management > SNMP > Trap recievers:
    Verification
    After the configuration, we could see the traps(Informs) showing on the Airwave GUI, System --> Syslogs & Traps, as shown below:
    We could also see in the packet capture taken from Airwave, that the controller is sending the Traps and Airwave is Acknowledging them as shown below:
    In the above example, .116 is the Airwave IP and .231 is the controller IP.

    My first question is how to create Sync-Async bridge in XI without using BPM.
    Just make a search on SDN, there is blog which mentiones how to do Sync_Async bridge without BPM (for JMS)
    "how to route this Interface mapping in Integration directory as in this case there is no backend call....its just the Java
    mapping inside an Interface mapping"
    Include the Interface mapping in the appropriate Interface Determination in ID for a particular set of source and target.
    and third I m trying to call an IDOC which is populated with the response of the Java mapping....but how to route it in
    Integration Directory ??
    same as mentioned for Q2....in Interface Determination....if it is a Sync call then the Request & Response Mapping will be in same Interface Mapping and then in same Interface Determination......it is the normal way.....I hope that i have not missed/ overlooked something from your queries!
    Regards,
    Abhishek.

Maybe you are looking for