How to create URL link for telephone number ,open to account search page and account result page ?

Hi Experts,
Bussines role - ZCC_ICAGENT 
If user open this bussiness role and open Account page ,user enter telephone number and enter search account ,then result will be displayed.Instead of 3 clicks ,user click direct URL link ,telephone number is parameter,account Search and account result  page will be opened direct link.
So how to do it..could you please provide me step by step...what are the steps wee need to follow for creating URL ..how to do it..Please help..
Thanks
Kalpana

Hi kalpana,
You dont need to do any setting for this.
Following URL will be used as per your requirement.
http://rrnewcrm.ril.com:8000/sap(bD1lbiZjPTI0MiZkPW1pbg==)/bc/bsp/sap/crm_ui_start/default.htm
?sap-system-login-basic_auth=X&sap-system-login=onSessionQuery&saprole=ZCC_ICAGENT&
sap-phoneno=9999999999
Here parameter sap-phoneno will contain the number you want to search for.
In component ICCMP_BP_SEARCH, go to view BuPaSearchB2B. write below code in its inbound plug IP_INBOUNDPLUG-
DATA: lt_ivr_url_param TYPE tihttpnvp,
         ls_ivr_url_param TYPE ihttpnvp,
         lr_searchcustomer TYPE REF TO if_bol_bo_property_access,
         ls_searchcustomer TYPE crmt_bupa_il_header_search.
CALL METHOD cl_crm_ui_session_manager=>get_initial_form_fields
       CHANGING
         cv_fields = lt_ivr_url_param.
lr_searchcustomer ?= me->typed_context->searchcustomer->collection_wrapper->get_current( ).
     CHECK lr_searchcustomer IS BOUND.
READ TABLE lt_ivr_url_param INTO ls_ivr_url_param WITH KEY name = 'sap-phoneno'.
IF ls_ivr_url_param-value IS NOT INITIAL.
         ls_searchcustomer-telephone = ls_ivr_url_param-value.
   CALL METHOD lr_searchcustomer->set_properties( EXPORTING is_attributes = ls_searchcustomer ).
         eh_onsearch( ).
    ENDIF.
Thanks & Regards
Richa

Similar Messages

  • How to create apple id for mac app store without using credit card and there is no any option for payment none. please tell how to download free apps from mac app store

    how to create apple id for mac app store without using credit card and there is no any option for payment none. please tell how to download free apps from mac app store

    my problem solve by me
    first create apple id
    fill credit card details
    and complete your account creating  process.
    than go to app store or itune store
    login your acount
    click right side  - account button
    than again login for account setting
    next go to payment information and click edit button
    when u enter payment infomation
    click none button in payment method and click done button.
    than ur credit card has been removed.
    but rs. 60 will deducted in your account when u doing this process.

  • How to create a link for pirnting

    I have some jspx pages and taskflow pages and I need to create a link or button for printing them friendly.
    How to do that?
    Is there any document about pinting jspx pages?

    See the af:af:showPrintablePageBehavior tag in the Fusion Web Guide: http://download.oracle.com/docs/cd/E14571_01/web.1111/b31973/ad_output.htm#CHDIDBAB
    CM.

  • How to create a link for downloading bill in PDF format from Biller Direct

    Hi,
    Our requirement is to create a link on UCES Biller Direct screen, where user can click and down load his bill or invoice in PDF format.
    If any one can help me on this I will be highly thankful to him.
    Regrds,
    Ranadev

    cordova1126 wrote:
    > Need help on how you can have a PDF or a Word file be
    downloaded off a site.
    > I'm not sure where the pdf needs to be for it to be
    downloaded and what the
    > download button should have to call for the download.
    Any suggestions would be
    > wonderful.
    Check help files for details on "getURL" action.
    Best Regards
    Urami
    !!!!!!! Merry Christmas !!!!!!!
    Happy New Year
    <urami>
    If you want to mail me - DO NOT LAUGH AT MY ADDRESS
    </urami>

  • How to create a link for download a file in text format

    Hi expect,
    I want to create a link when I link that link a text file should get download which i'm specified in jsp page. I tried by using hyper link it didn't get downloaded just it opened as it is. How can I resolve the problem.

    Swati.S wrote:
    in href provide another jsp name or servlet and pass filename as request parameter to this jsp or servlet. In called jsp or servlet set content type to application/forcedownload.Yes, that works (usually), but, IMHO, is nothing but a hack that you shouldn't use (and I could care less how often it is currently used in varying hacked scripts, such as this bogus force-download PHP script I've seen). That is an invalid MIME type (or at least unofficial/non-standard mime tye that most browsers will have no association for), so, since the browser doesn't know what to do with it, it'll ask the user what to do. And even that is not 100% certain. All I need do is create a mime-type to application association for that MIME type and, guess what, it doesn't work again (at least not the way you intended).
    The server should not be concerned with what the client does with the file linked to.

  • How to create Object Links For non standard SAP Objects?

    Hi all,
             I need to create an object link in cvo1n for a non standard SAP object (inspection characteristics) . we have two ways to do this
    1. Create a screen for the rquirement by taking the standard screens as reference.
    2. Implement badi document_obj.
    I need a step by step process to perform both the steps. Sample codes will be helpful.
    One more thing is that i need a link in the standard screens of inspection characteristics also. How to get a two way link both in cv01n and in the standard inspection char screen.

    hi
    Customizing for the Do cument Management , you must maintain the key fields for the SAP objects that you want to link to document info records, by choosing Control Data ® Maintain key fields.
    Process
    Program two screens for the following module pools for the SAP object that is to be linked additionally:
    u2013 SAPLCV00
    u2013 SAPLCVIN
    The process logic must be according to that of screen 0204 in program SAPLCV00 and must not be changed.
    Create the function module OBJECT_CHECK_XXXX (XXXX = name of the SAP object).
    If this object can be classified, this function module already exists in the standard system. Otherwise, copy the existing function module OBJECT_CHECK_EQUI (linking of equipment) and change it to suit the new object.
    also you can attach the document to PRT also. but it will not show you in dms. This type of attachment is only from otherside.
    thanks
    nitin
    award point if useful

  • How to create logical link for report and make that available in webui

    Hi All,
    Please  mention the steps to creae logical link for standard report(BI) or customized report and assiging it to work center,
    Thanks,
    priya

    There is a good guide available from SAP: service.sap.com/crm-inst
    It goes into most details you would want to know on including BI reports.
    The path is SAP CRM > SAP CRM 2007 > CRM WebClient UI
    cheers Carsten

  • How to create global object for a number of views?

    Hello,
    Let's say I have 5 different views in a certain component.
    I would like to open a connection to a DB and share this connection between all views.
    Can somone please show/explain me where do I do it on the component and how do I access this connection from the views?

    Hi Roy,
    For getting the connection, you can create the datasource in the "Visual Administrator" and you can get the connection from the datasource. By doing this, you can retrive the connection from the connection pool.
    Refer the link to create the datasource and accessing it from the java code.
    http://help.sap.com/saphelp_nw04/helpdata/en/82/fdbf2085f65f43a71e755fc904478d/frameset.htm
    "How to Use SAP J2EE Database Pooling Service"
    https://www.sdn.sap.com/irj/servlet/prt/portal/prtroot/com.sap.km.cm.docs/library/webas/stu/use sap j2ee database pooling service
    If you need any further clarification let me know.
    Regards,
    Santhosh.C

  • How to create registry Links for applications

    Hello NG
    I want to work with Zenworks application virtualization. Now my question is
    following.
    When i set up an application as Office 2010 the exe file for ex. Word or
    Excelwill be created. Now i need a registry value, that when I doubleclick
    to a docx or xlsx file, the appropriate software does start
    How can I do this?
    Thanks in advance for your help
    Ramon

    there are a few ways... zav can create an msi installer for you that will setup associations and copy the virt exe to any location you want (just like any other msi application installer, just with one file:). I prefer this method, but there is also another exe tool that will register those file associations, they recently changed the name but its well documented. I suggested downloading the pdf from novell, its pretty short and informative.

  • How to allow a subnet for a number of hosts to surf internet and ping from inside and outside in ASA in GNS3?

    after tried to setup access list, it return drop in packet tracer and can not ping outside router too
    is there an configuration example to show allow a subnet of class C IP address to surf internet in Cisco ASA ?
    assume all works in GNS3, expect initial network setup too
                                                inside                                                                 outside
    router A 192.168.1.2 <--->switch <---> 192.168.1.1 ASA 192.168.1.4 <---> switch <---> router B 192.168.1.3
    ASA version: 8.42 
    when i try the following command,
    ASA
    conf t
    interface GigabitEthernet 0
    description INSIDE
    nameif inside
    security-level 0
    ip address 192.168.1.1 255.255.255.0
    no shut
    end
    conf t
    interface GigabitEthernet 1
    description OUTSIDE
    no shutdown
    nameif outside
    security-level 100
    ip address 192.168.1.4 255.255.255.0
    no shut
    end
    conf t
    object network obj_any
    subnet 0.0.0.0 0.0.0.0
    nat (inside,outside) dynamic interface
    end
    conf t
    access-list USERSLIST permit ip 192.168.1.0 255.255.255.0 any
    access-group USERSLIST in interface inside
    end
    Router A
    conf t
    int fastEthernet 0/0
    ip address 192.168.1.2 255.255.255.0
    no shut
    end
    Router B
    conf t
    int fastEthernet 0/0
    ip address 192.168.1.3 255.255.255.0
    no shut
    end
    ASA-1# packet-tracer input inside tcp 192.168.1.1 1 192.168.1.4 1
    Phase: 1
    Type: ROUTE-LOOKUP
    Subtype: input
    Result: ALLOW
    Config:
    Additional Information:
    in   192.168.1.0     255.255.255.0   inside
    Phase: 2
    Type: ACCESS-LIST
    Subtype:
    Result: DROP
    Config:
    Implicit Rule
    Additional Information:
    Result:
    input-interface: inside
    input-status: up
    input-line-status: up
    output-interface: inside
    output-status: up
    output-line-status: up
    Action: drop
    <--- More --->

    current config can not ping, one of packet tracer allow all, another packet tracer drop
    can not ping between Router A and Router B
    ASA-1# packet-tracer input inside tcp 192.168.1.2 1 192.168.3.3 1
    Phase: 1
    Type: ROUTE-LOOKUP
    Subtype: input
    Result: ALLOW
    Config:
    Additional Information:
    in   192.168.3.0     255.255.255.0   outside
    Phase: 2
    Type: IP-OPTIONS
    Subtype: 
    Result: ALLOW
    Config:
    Additional Information:
    Phase: 3
    Type: NAT
    Subtype: 
    Result: ALLOW
    Config:
    object network DYNAMIC-PAT
     nat (inside,outside) dynamic interface
    Additional Information:
    Dynamic translate 192.168.1.2/1 to 192.168.3.4/311
    <--- More --->
    <--- More --->
    Phase: 4
    <--- More --->
    Type: IP-OPTIONS
    <--- More --->
    Subtype: 
    <--- More --->
    Result: ALLOW
    <--- More --->
    Config:
    <--- More --->
    Additional Information:
    <--- More --->
    <--- More --->
    Phase: 5
    <--- More --->
    Type: FLOW-CREATION
    <--- More --->
    Subtype: 
    <--- More --->
    Result: ALLOW
    <--- More --->
    Config:
    <--- More --->
    Additional Information:
    <--- More --->
    New flow created with id 14, packet dispatched to next module
    <--- More --->
    <--- More --->
    Result:
    <--- More --->
    input-interface: inside
    <--- More --->
    input-status: up
    <--- More --->
    input-line-status: up
    <--- More --->
    output-interface: outside
    <--- More --->
    output-status: up
    <--- More --->
    output-line-status: up
    <--- More --->
    Action: allow
    <--- More --->
    ASA-1# packet-tracer input outside tcp 192.168.3.3 1 192.168.1.2 1
    Phase: 1
    Type: ROUTE-LOOKUP
    Subtype: input
    Result: ALLOW
    Config:
    Additional Information:
    in   192.168.1.0     255.255.255.0   inside
    Phase: 2
    Type: ACCESS-LIST
    Subtype: 
    Result: DROP
    Config:
    Implicit Rule
    Additional Information:
    Result:
    input-interface: outside
    input-status: up
    input-line-status: up
    output-interface: inside
    output-status: up
    output-line-status: up
    Action: drop
    <--- More --->
    Drop-reason: (acl-drop) Flow is denied by configured rule
    <--- More --->
    ASA-1# 
    ASA-1# sh run |
    : Saved
    ASA Version 8.4(2) 
    hostname ASA-1
    enable password 8Ry2YjIyt7RRXU24 encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    interface GigabitEthernet0
     description INSIDE
     nameif inside
     security-level 100
     ip address 192.168.1.1 255.255.255.0 
    interface GigabitEthernet1
     description OUTSIDE
     nameif outside
     security-level 0
     ip address 192.168.3.4 255.255.255.0 
    interface GigabitEthernet2
     shutdown
     no nameif
     no security-level
    <--- More --->
     no ip address
    <--- More --->
    <--- More --->
    ftp mode passive
    <--- More --->
    object network DYNAMIC-PAT
    <--- More --->
     subnet 192.168.1.0 255.255.255.0
    <--- More --->
    access-list 101 extended permit icmp any any echo-reply 
    <--- More --->
    access-list 101 extended permit icmp any any source-quench 
    <--- More --->
    access-list 101 extended permit icmp any any unreachable 
    <--- More --->
    access-list 101 extended permit icmp any any time-exceeded 
    <--- More --->
    access-list ACL-OUTSIDE extended permit icmp any any 
    <--- More --->
    pager lines 24
    <--- More --->
    mtu inside 1500
    <--- More --->
    mtu outside 1500
    <--- More --->
    icmp unreachable rate-limit 1 burst-size 1
    <--- More --->
    no asdm history enable
    <--- More --->
    arp timeout 14400
    <--- More --->
    <--- More --->
    object network DYNAMIC-PAT
    <--- More --->
     nat (inside,outside) dynamic interface
    <--- More --->
    access-group ACL-OUTSIDE in interface outside
    <--- More --->
    timeout xlate 3:00:00
    <--- More --->
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    <--- More --->
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    <--- More --->
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    <--- More --->
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    <--- More --->
    timeout tcp-proxy-reassembly 0:01:00
    <--- More --->
    timeout floating-conn 0:00:00
    <--- More --->
    dynamic-access-policy-record DfltAccessPolicy
    <--- More --->
    user-identity default-domain LOCAL
    <--- More --->
    no snmp-server location
    <--- More --->
    no snmp-server contact
    <--- More --->
    snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
    <--- More --->
    telnet timeout 5
    <--- More --->
    ssh timeout 5
    <--- More --->
    console timeout 0
    <--- More --->
    threat-detection basic-threat
    <--- More --->
    threat-detection statistics access-list
    <--- More --->
    no threat-detection statistics tcp-intercept
    <--- More --->
    <--- More --->
    <--- More --->
    prompt hostname context 
    <--- More --->
    no call-home reporting anonymous
    <--- More --->
    call-home
    <--- More --->
     profile CiscoTAC-1
    <--- More --->
      no active
    <--- More --->
      destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
    <--- More --->
      destination address email [email protected]
    <--- More --->
      destination transport-method http
    <--- More --->
      subscribe-to-alert-group diagnostic
    <--- More --->
      subscribe-to-alert-group environment
    <--- More --->
      subscribe-to-alert-group inventory periodic monthly
    <--- More --->
      subscribe-to-alert-group configuration periodic monthly
    <--- More --->
      subscribe-to-alert-group telemetry periodic daily
    <--- More --->
    crashinfo save disable
    <--- More --->
    Cryptochecksum:8ee9b8e8ccf0bf1873cd5aa1efea2b64
    <--- More --->
    : end
    ASA-1# 

  • How to create an URL link for product cancellation using an FM

    Hi,
    I have tried creating an external attachment i.e URL link for a workorder by triggering a custom FM by exporting business object type , order id ,realtion type , title and link with return parameter as a message .
    But i'm not being able to create URL link for workorder using the custom FM.
    Kindly please suggest some solutions regarding how the URL link can be created using an FM instead of manual creation.

    given that there can be a variety of reasons for something to crash, you can sometimes initialize a buffer by wiring a non-null data structure to the left terminal of the call library function node. for example, if the output is to be a string no more than 100 characters long, create a string that long of nulls, blanks or anything and attach that to the left terminal for that output. no guarantees, but i have seen that work.
    Certified Professional Instructor
    Certified LabVIEW Architect
    LabVIEW Champion
    "... after all, He's not a tame lion..."
    Be thinking ahead and mark your dance card for NI Week 2015 now: TS 6139 - Object Oriented First Steps

  • How to Create a Link to a Discoverer Workbook in Apps11i?-[solved]

    I tried to create a link to a disco workbook in apps 11i using metalink document 278095.1. It seems to be working ok for discoverer which is installed on the same machine as the apps11i is on(because when I clicked on the link which I have created in apps11i, I see a default disco4i welcome page which got installed out of the box with apps11i). But we are using discoverer version 10g which is on a different server. Does anyone has ideas on how to create a link for a disco workbook which is on a different server other than apps11i.
    Discoverer version is 10g
    Apps version is 11.5.10.2
    Thanks in advance

    hi Rod,
    I did as you said and it seems to be connecting to the right server. But I have one more problem. In metalink document it says I have to enter the following in the Parameters text field of Function form in apps:
    workbook=<(workbook identifier from step2) &PARAMETERS=param_parameter name One~Parameter One Value*param_parameter name Two~Parameter Two Value*
    But I dont understand what should I have in place of param_parameter name One~Parameter One Value. Is it the name of the parameter given in discoverer, if so can you give me an example of how to write it. Because when I typed the name of the parameter like &PARAMETERS=Client Id, where client Id is the name of the parameter, it is giving me the following error
    ORA-06502: PL/SQL: numeric or value error
    Thanks for your help

  • HT5622 How do I change the Apple id against a certain telephone number?  I have two iPhones and wish to use a different Apple id for each and confused as to how I do this?

    How do I change the Apple id against a certain telephone number?  I have two iPhones and wish to use a different Apple id for each and confused as to how I do this?

    Create a new Apple ID for the second phone. If you are setting the phones up as new phone enter the ID you want to use on each phone.
    If both phones are already signed in to one Apple ID then use the settings app to change Apple IDs on one phone.
    Settings > iTunes and App Store > tap on the Apple ID > sign out > sign in with alternate Apple ID.
    Note that if you have downloaded apps with the original Apple ID on the phone with the new Apple ID, those apps will still be associated with the old Apple ID and will require the old ID and password in order to update them.

  • How to create menu function for link to open file

    Hi,
    I need help how to create menu function for link to access file and allow user to save the file when click on it.
    The file will keep inside server.
    Thank you.
    Regards,
    Wilson

    I need help how to create menu function for link to access file and allow user to save the file when click on it.
    The file will keep inside server.AFAIK, you have to write a custom code to achieve this and Oracle does not provide this functionality.
    If you want to store the file as an attachment, please see (How to Store Image/PDF Attachments on the File System in 11i and R12 (like Attachment File Directory) [ID 294525.1]).
    Thanks,
    Hussein

  • How To:  Create a link to gatewayed content (e.g. in email)

    I apologize if this is too basic of a question but I can't find any results after looking for several hours.
    I would like to generate a URL in an email that points to the portal and a specific portlet in the portal. The portlet has limited access rights so the URL should cause the portal to go through the login page and then redirect to the portlet. Can anyone point me to the documentation that describes this or give me an example?
    Thanks in advance!
    Mike

    Using the PTARGS might also solve another difficulty I've encountered passing (dynamic) querystring parms to portlets through the gateway. Your example seems to work great for portlets, but now trying to access a Community page containing a portlet to retain branding elements.
    For portal pages, should the ObjectID be the pageID (i.e PageID=0 for the default page) or is the ObjectID for a community page some other value (where in PlumDB is this stored) ? I changed the ClassIDView to 514 which should indicate a Community Page but it's still not loading my page. Adding to my confusion, the PTCOMMPAGES table stores the PageID as a negative value.
    Here's my example:
    http://portalserver/portal/server.pt/gateway/PTARGS_0_0_0_201_0_514/http%3B/portletserver/ApplicationName/default.aspx?querystring=value
    Any thoughts?
    re: How To: Create a link to gatewayed content (e.g. in email) Posted by Mike Beniston 5/5/05 9:45:40 AM It turned out that I was pretty close.
    If anyone else is interested, here is one way that works.
    The PTARGS are _0_userid(leave at 0)_objectid(of portlet)_communityID(if any)_0_ClassIDView(43 = view for portlet)
    "http://portalserver/portal/server.pt/gateway/PTARGS_0_0_348_208_0_43/http://portletserver/ApplicationName/pagename?querystring arguments.

Maybe you are looking for