IChat Load Balancing or failover solution?

Hello, I am working a plan to develop a iChat server. I think a Mac Mini would be a good start for a group of 50 users. The users are all over the country and my role is to unite them all in a iChat domain. I thought about building two Mac Mini servers and have them run a same domain where all users are registered in. So, we would not be impacted when one of them goes down.
Anyway, the question is how can I have a load balancing or failover solution for the iChat domain?

On the issue of load balancing, whilst I don't have any experience with macMini's, you will not need to worry about load balancing with 50 users. I'm sure you can probably put a few naughts on the end of that before you need to worry.
The design you are proposing will not work for iChat services / and for that matter most of Apple server services. For high availability services (e.g. transparent failover) I think you are going to struggle to get this working and it 'seems' Apple no longer offers guidance on this subject on 10.6.x.
You will increase availability by using an Xserve with dual PSUs and raid disks. If you are only running high availability ichat services, I would buy a pair of second hand xserves with 10.5 OS and set the ipfailover services running. Personally I would buy one and a service kit and not bother with HA - as you will find the servers are very reliable.
If you have to use mini's then just have one live and keep a near constant clone of it on another ready to manually swap out if you have a hardware failure.
Your proposed design will not work without a lot of effort non of which is supported by Apple - although it would be rewarding if you did get it working. You cannot have server to server traffic for the same domain as all your application data needs to be stored centrally. OD only provides services for authentication. The ichat server also has its own data store and this is not distributed nor can it be. It is possible to move the data store over to say an enterprise version of mysql and have that distributed.

Similar Messages

  • Network Load Balancing and failover for AFP Sharing

    Dear all,
    Somebody kindly teach me to use round robin DNS to perform the network load balancing, it's success but not the failover.
    I have 4 xserve and want to do the load balancing and failover at the same time.
    I have read the IP failover document and setup it successfully, but anyone know is it possible to do the IP failover for more than 2 server?
    For example, 4 server serving the AFP service at the same time, maybe I have 1 more extra server to do the IP failover for thoese 4 servers.
    As I know, IP failover require Firewire as the heartbeat detection. But one xserve only have 2 firewire ports. May I setting up the IP failover only by a ethernet port and an IP address? does it possible to detect and failover to any server after server down has been detected?
    I believe load balancer maybe the best solution but its cost is too high.
    Thanks any advance!
    Karllee

    well, u have 2 options here
    software load balancing
    request comes it foo.com -> ws7u2 hosting foo.com is configured to run as reverse proxy . this server sends any incoming requests to one of the four back end web server 7 handling your incoming request
    hardware load balancing (this you need to invest)
    request comes to hardware load balancer who responds for foo.com -> sends requests to four ws7 server hosting your application
    you could try out how software load balancing works out for you before you invest in hardware load balancing
    here is more instruction on configuring ws7 + reverse proxy (software load configuration)
    - install ws7 on foo.com
    - create a new configuration (choose port 80, disable java

  • Load balancing and Failover

    Hello,
    We are wondering how load-balancing and failover of tpcall() work with
    WTC:
    The scenario:
    We have one WLS Domain and two Tuxedo Domains. The Tuxedo Domains offer
    the same set of services.
    In the bdmconfig.xml, we specify connection_policy as 'ON_STARTUP' for
    both Remote Tuxedo Domains. We also Import (T_DM_IMPORT) the same
    Tuxedo Service from both Tuxedo Domains.
    Questions:
    1. Is there any load-balancing of the tpcall between the two Domains? If
    so, is it round-robin? If round-robin, what determines the order?
    2. If it is ONLY Failover, what determines the order of the tpcall? And,
    is the Failover automatic? Or do we need to code for retry on failure?
    3. ON_DEMAND vs ON_STARTUP: Does ON_DEMAND drop the connection to the
    remote domain upon tpterm? And does ON_STARTUP use a pool of
    TuxedoConnection objects?
    4. Are there any configuration parameters for
    'max_number-of_connections? What determines how many simultaneous
    connections can be made?
    Thanks,
    Suresh Mohan.

    Hi Suresh,
    The following are my answers to your questions.
    Suresh Mohan wrote:
    Hello,
    We are wondering how load-balancing and failover of tpcall() work with
    WTC:
    The scenario:
    We have one WLS Domain and two Tuxedo Domains. The Tuxedo Domains offer
    the same set of services.
    In the bdmconfig.xml, we specify connection_policy as 'ON_STARTUP' for
    both Remote Tuxedo Domains. We also Import (T_DM_IMPORT) the same
    Tuxedo Service from both Tuxedo Domains.
    Questions:
    1. Is there any load-balancing of the tpcall between the two Domains? If
    so, is it round-robin? If round-robin, what determines the order?Yes there is a load balancing between two remote Tuxedo TDomain Gateways.
    The algorithm is random, not RR. Over time this should give equal
    opportunities to both remote TDomain.
    >
    2. If it is ONLY Failover, what determines the order of the tpcall? And,
    is the Failover automatic? Or do we need to code for retry on failure?The load balancing is always there. The failover is automatic. When a
    connection to a remote TDomain encountered a problem (ie network) the remote
    domain will be put on retry open connection (in ON_STARTUP) and the load
    balancing will not select it until the connection re-established.
    However, the tpcall() that encountered the error will not be retried to send
    to different destination. It is up to the application to decide whether it
    want to resend. Any requests called after the error will not select the
    failed Remote TDomain.
    >
    3. ON_DEMAND vs ON_STARTUP: Does ON_DEMAND drop the connection to the
    remote domain upon tpterm? And does ON_STARTUP use a pool of
    TuxedoConnection objects?TPTERM() only terminate your application session to WTC. WTC still maintain
    a secured T-session to remote Tuxedo TDomain. WTC does not use a pool of
    TuxedoConnection Objects, the object stored in the JNDI refers to WTC.
    >
    4. Are there any configuration parameters for
    'max_number-of_connections? What determines how many simultaneous
    connections can be made?No. As described in #3, there is no need to use connection pool in WTC. WTC
    uses session and virtual circuit design concept as Tuxedo TDOMAIN, the
    logical pool is created/destroyed dynamically. That is the reason why you
    can have a lot of TPACALL() outstanding at the same time. (The limitation is
    the availability system resource.)
    >
    >
    Thanks,
    Suresh Mohan.Regards,
    Hong-Hsi :-)

  • Load Balancing and Failover with 10G Standard Edition

    Hi,
    I am new to Oracle Replication and need some help setting up replication for load balancing and failover. Is this possible using Oracle 10G Standard Edition? I plan on having all updates done on the master site and both databases will be for reads. In case of failure of the master site, I would need to be able to failover to the other database.
    Also, if anyone knows of any documention for Basic Replication in 10G, please let me know.
    Thanks.

    Simple nnapshot replication of data would require significant manual effort to configure to load balance or failover. One the load balancing side, you would generally be limited to to static load balancing-- assigning half the users to one machine and the other half of the users to the other machine, regardless of who is actively using the machine. Failover would be a significant manual effort, particularly to bring the failed machine back into the cluster. You would be implementing the guts of multi-master replication.
    Frankly, if you actually have a system which is valuable enough to need load balancing and disaster recovery, I'm going to wager that it will be far cheaper even in the short run to buy more boxes and/or enterprise edition licenses than to try to implement this sort of thing yourself. In the long run, it will be far cheaper, since it will be far easier to maintain. Building all this yourself would probably be penny wise and pound foolish.
    Justin
    Distributed Database Consulting, Inc.
    http://www.ddbcinc.com/askDDBC

  • Load balancing and failover in Embedded LDAP in weblogic

    How to handle load balancing and failover in Embedded LDAP in weblogic server?

    You should consider posting this to the Weblogic and/or LDAP support forums. This forum is meant for Sun Web Server questions.
    Thanks
    Manish

  • Distributed HA cluster with load-balancing and failover: advice?

    My workplace has a Xeon Xserve, which acts as our primary external server, with an attached ActiveStorage XRAID. We have just purchased a second Xserve/XRAID set to act as a mirror, which we will colocate. Both have Leopard Server installed, along with an array of additional software.
    What we want to do is have both servers load-balance between the two, with failover in case of a server or XRAID fault. I plan on using RSYNC to mirror static files between the two, and I'm looking into PostgreSQL replication and load-balancing solutions for our database. I gather that Apache supports web-server failover and load-balancing, as well. But, that still leaves the actual host and network setup to arrange.
    Does Leopard server support such a thing? The only information I found on IP failover instructs the user to place the two servers on the same subnet, directly connected via ethernet cable; obviously, this would not work in my case.
    Ideally, what we'd end up with is a situation in which the two systems kept each other in sync, both in static files and database data, and load-balanced between themselves; in cases of failure, the remaining system would transparently assume all duties until the other was restored, at which time they would resynchronize
    Any suggestions on how I could arrange such a thing?

    Interesting. Does this DNS-based approach support session tracking, though? I would need to have a user directed to just one of the two servers for the duration of their session, to avoid having to synchronize temporary files and such.
    You can't have it both ways. You need to build tolerance into the app.
    At the simplest level where you run all traffic to one site and use the second site as a failover/standby site you'll be OK most of the time - all users will go to the same server and their sessions will be intact.
    However, under any failover situation (your primary site is down for some reason), there is going to be some level of session traffic that it going to switch over to the other site. If your site depends on sessions then you're going to need to tolerate this kind of situation - your app will need to be able to fail gracefully if a user comes in with an invalid session cookie.
    Note, though, that this may be less of an issue than you at first think - all DNS clients will cache DNS data for whatever TTL you set. This means that if a user looks up your site name and you return an IP address with a 30 minute TTL, then that user is going to use the same IP address for the next 30 minutes and isn't going to ask the server again. This should negate most chance of a user suddenly switching from one server location to the other in mid-session.
    The trick comes in setting the DNS TTL low enough to effect a failover, yet not so long that you impact performance - e.g. you don't want the user to perform a DNS lookup on every page load. You may find that 10 minutes is appropriate. Just bear in mind that this affects how long a user could see your site 'down' before the failover DNS kicks in. Clearly you don't want to set the DNS TTL to a day since that may prevent the user switching to the secondary site for 24 hours by which time, hopefully, the primary site is back up, anyway.
    The 'right' TTL value may take some analysis on your traffic to see how long a typical user 'session' is. If the average user spends 20 minutes on your site, then it would make sense to set your TTL to somewhere around 20 minutes to give the best chance of their entire session staying on the same server.

  • Load balancing with failover questions

    If we install 2 multi-role Exchange servers in our building and a 3rd multi-role server in our remote data center, what is the best way to load balance them?  Do we need two load balancers or is there some way to span a single load balancer across the
    WAN ?
    What about using Windows NLB as an alternative to using round robin internally?
    Can a load balancer keep our interoffice Exchange CAS traffic from leaving our LAN and only failover to using the 3rd CAS/mailbox sever for internal users if both internal Exchange servers are offline?
    We would also like remote users to "prefer" to use the data center CAS unless it is down. Right now we point our smart host directly to a CAS, but if we had a load balancer there, we could point the smart host to the IP of the load balancer and
    the load balancer could normally send it to data center CAS if it's up and forward it to one of the servers in the office otherwise.
    Is it possible to do all this without a very complicated and expensive solution?

    Depends... what is the connectivity speed between two sites, is it good enough?
    You can use load balance in front of all the 3 CAS if your inter-site connectivity is very good.
    What about using Windows NLB as an alternative to using round robin internally? WNLB and round robin is different,. You can use DNS Roud Robin if you want to or WNLB for all three CAS Server. Or Hardware loadbalancer for all three CAS servers
    Can a load balancer keep our interoffice Exchange CAS traffic from leaving our LAN and only failover to using the 3rd CAS/mailbox sever for internal users if both internal Exchange servers are offline? If you want to use the load balancer then you don't
    need to fail them over one by one -- again you can use DNS Round Robing so the request will go to eah CAS servers one by one or use Hardware Load balance.
    We would also like remote users to "prefer" to use the data center CAS unless it is down. Right now we point our smart host directly to a CAS, but if we had a load balancer there, we could point the smart host to the IP of the load balancer and
    the load balancer could normally send it to data center CAS if it's up and forward it to one of the servers in the office otherwise.
    Use DNS Server and point the A record to the Primary Data center load balanced CAS server instead using IP or host file.
    Hope that helps
    Where Technology Meets Talent

  • Load Balancing and Failover in RMI.

    Hi All,
    I have just one RMI object doing mathematical
    calculations.I want failover (and perhaps load
    balancing also) for this rmi object.Few Application
    servers(like weblogic) provide a wrapper over sun's
    rmi to produce replica aware rmi stubs but they force
    to use vendor specific (like weblogic rmi-registry)
    rmi-registry, which runs within the app server.
    My problem is :
    I dont want to run the whole app server to just run
    one rmi object ?
    Is there a way using which I can make replica aware
    rmi stubs without using the app server ?
    Thanks in advance for the help !!
    Regards
    Rais

    your question is pretty vague. In case you are trying to do load balancing using load balancers then your application layer is actually supposed to be blind as far as the working of the networking layer is concerned (and thats where the load balancers exist). Then the question would also be do you want to achieve this to make the system highly available or make it more resilient and improvr performance. There would be different implementations for both of them. However if you are planning to introduce load balancing programmatically you need to start more than one rmi services.

  • IOS NAT Load Balancing w/ Failover Problem

    Greetings, i am currently using the configuration below to provide failover between two DSL connections, all is working fine but i had expected outbound connections to be load balanced between the two DSL links on a round robin basis, however looking at the nat translations shows that only one of the links is being used, failover on the other hand works without issue.
    track 1 ip sla 1 reachability
    interface FastEthernet0/0
    ip address 10.50.1.254 255.255.255.0
    ip nat inside
    ip tcp adjust-mss 1452
    interface FastEthernet0/1
    ip address 192.168.1.6 255.255.255.0
    ip nat inside
    ip tcp adjust-mss 1452
    interface Dialer0
    description WAN Interface
    mtu 1492
    ip address **********
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nat outside
    encapsulation ppp
    dialer pool 1
    interface Dialer1
    description WAN Interface
    mtu 1492
    ip address **********
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nat outside
    encapsulation ppp
    dialer pool 2
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 212.74.102.15 track 1
    ip route 0.0.0.0 0.0.0.0 213.246.177.200 10
    ip nat translation timeout 2
    ip nat translation tcp-timeout 2
    ip nat translation udp-timeout 2
    ip nat translation icmp-timeout 2
    ip nat inside source route-map opal interface Dialer1 overload oer
    ip nat inside source route-map pipex interface Dialer0 overload oer
    ip access-list extended dynamicNat
    permit ip 10.50.1.0 0.0.0.255 any
    permit ip 192.168.1.0 0.0.0.255 any
    deny ip any any
    ip sla 1
    icmp-echo 212.74.102.15
    frequency 5
    ip sla schedule 1 life forever start-time now
    route-map opal permit 10
    match ip address dynamicNat
    set ip next-hop 213.246.177.200
    route-map pipex permit 10
    match ip address dynamicNat
    set ip next-hop verify-availability 212.74.102.15 1 track 1
    Any assistance would be much appreciated.
    Regards

    Hi 
    Thank you for this post man ! this have been so useful. I experienced almost the same problem the router was load balancing well, but the failover was not occuring well between both equal default route.
    After using those command: ip nat translation timeout for tcp icmp and udp all the system has worked propertly.  yeah you need a Big bottle of Jack Daniel  :)    the funniest thing behind is that help me 5 years After......................!!!!

  • ASA Vpn load balancing and failover

    Hello all.
    We have two asa5520 configured as primary and standby unit in failover configuration, and all is working properly.
    Is it possible, with this configuration (failover), to configure vpn load balancing/clustering?
    Thanks
    Daniele

    Hi Wajih,
    I am testing this right now. In my case, I want A and B are failover pairs with A as the primary, (A+B) together as one member in cluster with other ASAs C and D. Here is what I found out:
    1, After the active/standby working, configure the load banlancing in the master, the cluster IP worked.
    2, after "no fail ac" in A, cluster IP stopped working. Seems the vpn load banlance configuration wasn't copied over to the standby B.
    3, In the active (now it's the secondary B), manually configure vpn load banlancing, then the cluster IP worked.
    4, "no fail ac" in the B and make the the primary A active, the cluster IP still worked.
    5, after "no fail ac" in A, cluster IP stopped working. show vpn load and found out the load banlance was disabled.
    6, "no fail ac" in the B and make the the primary A active, the cluster IP then worked.
    Based on above, the secondary B's VPN load banlance will be disabled when B becomes active in failover role. If that's true, these two features can't work together. Or maybe there is some configuration I'm missing -- maybe having C or D as the cluster master will help. The ASAs are 5510 with 8.4(2)
    Thanks,
    Rick.

  • Load Balance and failover over 2 lines.

    We have 2 x Cat 6509 with Sup720 and are running Native IOS.
    On Switch A, we have a 1GB link configured as an access link on Vlan 2 to DR site connected to a Cat 3550
    On Switch B, we have a 1GB Link configured as a trunk to the same DR connected to another Cat 3550
    We configured devices to be in VLAN 2 as we want them to use the 1GB link. And the 2nd 1GB link is a logical extension of our main site.
    Now, I want to configure these 2 x 1GB link so that they now act as failover as well as Load balancing.
    1. How do I do this?
    2. Will I need to move the 1GB link on Switch A to switch B
    3. Should I configure the Switch A link also as Trunk?
    Please help.
    Thanks

    Do your 3550s run EMI or SMI? If they run EMI, why not run dynamic routing protocol between the 3550s and the 6500s? OSPF would be a good one to use, if you have hierarchical IP addressing. If your addressing is not hierarchical, then use EIGRP.
    Other than this, the only other possible way I can think of is GLBP (http://www.cisco.com/en/US/products/sw/iosswrel/ps1839/products_white_paper09186a00801541c8.shtml)
    Prior to GLBP, you could also have used HSRP. But it's a bloody nuisance to configure, 'cuz you need to configure two different HSRP groups for the same pair of switches, then manually assigning different hosts/PCs to use different default gateways. As I said, bloody nuisance.
    HTH.

  • Load Balancing and Failover in Dual Ethernet

    I have a cisco 2911/K9 router with two 4Mbps Leased line connection from two different ISPs to my remote office. Remote office has cisco 2811 router
    Main office has MPLS connection with static Ip routing apart from the two leased lines
    All handoffs are ethernet
    Is it possible to do load sharing as well as fail over between the two ISPs, if so how am i to achieve that
    Kindly help me

    Disclaimer
    The   Author of this posting offers the information contained within this   posting without consideration and with the reader's understanding that   there's no implied or expressed suitability or fitness for any purpose.   Information provided is for informational purposes only and should not   be construed as rendering professional advice of any kind. Usage of  this  posting's information is solely at reader's own risk.
    Liability Disclaimer
    In   no event shall Author be liable for any damages whatsoever (including,   without limitation, damages for loss of use, data or profit) arising  out  of the use or inability to use the posting's information even if  Author  has been advised of the possibility of such damage.
    Posting
    If your MPLS vendor supports no dynamic routing, they why do you ask about BGP?  Or, do they only support dynamic routing with BGP?
    You can do equal cost multi-path with BGP (may require a hidden command to fully utilize).
    You could do GRE tunnels across the MPLS cloud and dynamically route between them using your choice of a dynamic routing protocol.
    Both your devices should support OER/PfR (may require a feature upgrade).  OER/PfR will actually dynamically load balance.
    SLA features should also be available on both your routers, those too might require a IOS feature upgrade.
    Configuration examples might be found on Cisco's main web site.

  • 1841 Load Balancing and Failover

    I have an 1841 router with a HWIC-4ESW (4port switch) card installed. The 4ESW is setup as VLAN1 and serves the internal network as the default gateway. The FE0/0 and FE0/1 interfaces are each connected to a ADSL Router. I currently have one WAN interface working fine passing trafic etc I want to add the second interface to act as a backup and aslo do load balancing if possible. Any ideas on how I go about setting up the 1841 to do this. I have attached my current config file that does not have the second WAN interface configured (FE0/1)
    Thanks

    While you can get the HWIC-1GE-SFP for the 1841 you need to consider how much traffic you intend to pass over it. It's rated for 87Mbps so if it is less than that, you should be fine and the 1841 is the box for you. Note that the ethernet switching modules for the 1841 will let you do layer 3 termination.
    To get load-balancing over 2 links, simply configure two static default routes (with the same AD) and enable CEF which will give you per-destination load-sharing

  • Dual WLAN links with load balancing and failover

    Hello,
    I am in a scenario where I am in need of two WLAN links between two buildings. There is a distance of 100-150 meters and minimum bandwidth required for both links together is 300Mbit/s. The thing is that both links should use load balancing between them and if one of them goes down, the last one should act as fail over.
    I have been looking at Cisco Aironet 1550 Series though I have no idea what is needed to get load balancing and fail over to work, so I am searching here for suggestions on what equipment is needed.
    Something like this:
                  ---------------WLAN Link 150-300Mbit/s-----------
    Building                    Load balancing and fail over               Building
                  ---------------WLAN Link 150-300Mbit/s-----------
    Thanks in advance!

    Several points.
    When an AP is doing 300Mbps, that's NOT the real throughput you have. It's the data rate at which traffic is sent.
    All in all, if your AP/client are doing 300MBps association, you will see max 150Mbps with a file transfer.
    From there, I'm not even sure that 11n supports dual spatial streams over such long distances (you can't have multipath in open air) so afaik the 1550 only do 150Mbps association rate (=dual channel with one spatial stream). That means 75Mbps real speed.
    I couldn't test a 1550 yet so don't take my word for official statement but that's what I'm thinking.
    the wireless links will always be both up and they can be on different channels.
    That will then mean that it will be "as if" the remote switch was connected directly to the central switch (where WLC is connected) as the WLC tunnels traffic all the way. So you could do a spanning-tree config on this one I guess to block the port onthe remote switch.
    Regards,
    Nicolas

  • Jms in cluster / load balancing and failover

              Did I get it right ???
              I have 1 admin server and 4 managed servers in a 2 clusters, a development cluster
              and a test cluster.
              I now want to have loadbalancing with my jms server and I want to be able to migrate
              my jms server in case of failer.
              for each cluster I have created
              connectionFactory targeted to the cluster
              Distributed destination with 2 queue members
              One JMSServer migratable targeted on managed server 1, with destination 1 from
              the ditributed destination
              One JMSServer migratable targeted on managed server 2, with destination 2 from
              the ditributed destination
              I expect this to make loadbalancing between the 2 servers in the cluster, and
              I can migrate the jms server if one of the server fails to the running server.
              One thing is now.....If one server fails and I migrate the jms server to the other
              server that is running, and I then restart the server that was down, what is then
              happening, do I then have 3 jms servers ???
              [config.xml]
              

              "Kris" <[email protected]> wrote in message news:[email protected]...
              >
              > "Kawaljit Singh Sunny" <[email protected]> wrote:
              > >
              > >"Kris" <[email protected]> wrote in message
              > >news:[email protected]...
              > >>
              > >> Did I get it right ???
              > >>
              > >> I have 1 admin server and 4 managed servers in a 2 clusters, a
              development
              > >cluster
              > >> and a test cluster.
              > >> I now want to have loadbalancing with my jms server and I want to be
              > >able
              > >to migrate
              > >> my jms server in case of failer.
              > >>
              > >> for each cluster I have created
              > >> connectionFactory targeted to the cluster
              > >> Distributed destination with 2 queue members
              > >> One JMSServer migratable targeted on managed server 1, with destination
              > >1
              > >from
              > >> the ditributed destination
              > >> One JMSServer migratable targeted on managed server 2, with destination
              > >2
              > >from
              > >> the ditributed destination
              > >
              > >If the server where your JMSConnections are loadBalanced to goes down,
              > >the
              > >producers and consumers using this JMSConnection are closed.
              > >You have to recreate these producers and consumers.
              > >If the server where your Destination resides goes dow, the consumers
              > >are
              > >closed.
              > >If the producers JMSConnection is not on this server, the producer stays
              > >up.
              > >
              > >>
              > >>
              > >> I expect this to make loadbalancing between the 2 servers in the
              cluster,
              > >and
              > >> I can migrate the jms server if one of the server fails to the running
              > >server.
              > >>
              > >> One thing is now.....If one server fails and I migrate the jms server
              > >to
              > >the other
              > >> server that is running, and I then restart the server that was down,
              > >what
              > >is then
              > >> happening, do I then have 3 jms servers ???
              > >
              > >No you still have 2 JMSServers. JMS Migration is manual.
              > >
              > >>
              >
              > you say : No you still have 2 JMSServers. JMS Migration is manual.
              >
              > But if I manual migrate the jmsserver that was down to the running wls
              server,
              > that already have one jms server running, this wls server must then have 2
              jms
              > servers. And I boot the wls server that hosted the jms server that was
              down, this
              > will now have a running jms server. isn't that 3 jms servers ?
              Once you migrate a JMSServer from a WeblogicServer1 to WeblogicServer2,
              and then you boot WeblogicServer1, this JMSServer which was migrated should
              NOT be on WeblogicServer1.
              (You have migrated the JMSServer from WeblogicServer1 to WeblogicServer2)
              >
              > But I was thinking about that I could spare the migration part. If I have
              2 wls
              > servers and a jms server on each of them, and a destributed destination
              with 2
              > queue members that are persistent in a database. If a wls og just a jms
              server
              > goes down, I just have to reboot the server and it will run again. This
              way I
              > dont have to think about migration, or what ?
              Yes that is true.
              Irrespective of whether you have migration or not,
              only thing you need to do take care is to reconnect to weblogic server, if
              the the server where your JMSConnection is loadBalanced to goes down.
              There is no failover of JMSConnections. Producers inside this JMSConnection
              will be closed. You will have to create a new JMSConnection and a new
              Producer and continue with your production of JMS Messages.
              -sunny
              

Maybe you are looking for

  • How Do I fix a -2009 error on IMovie

    Hello, I recieved an error message while trying to export a movie project from IMovie to my desktop. The error read: Unable to prepare project for publishing. The project could not be prepared for publishing because of an error occuring (-2009). How

  • How to find the Check table for a field ?

    Hello All,         I have the filed name f1. Now I want to know the check table of this field programatically and if this field has a configuration table then I need that table also. eg: if werks is the field the Master         Table is : MARC       

  • Problems with a purchase...

    So I tried to purchase some music on the iTunes store tonight. Earlier I used a gift card and there is $.15 left on it...when I try to purchase a song, I get this message..."Your credit balance is out of date. Click Ok to refresh, and try your purcha

  • Get the correct order of the tones for DTMF Decoder

    I am trying to decoder the DTMF stream signal (contains mutiple tones, delay, noise), however, I have the problem to seperate each tone in the stream signal in order to input into the Goertzel for further analysis.  The phone number is 534-343-3436.

  • Cursor positiong at POV

    Hi, my customer's requirement is to move a cursor at the end of PROCESS ON VALUE REQUEST on one subscreen field to another field.  Details: during sales order item creation (VA01) the cursor is positioned automatically at the field for Material (prog