ID CS4 get xmp-description

Hallo,
I've got a picture (picture = downloadlink ;-) ) and the metadata seems to be stored in namespace "http://purl.org/dc/elements/1.1/".
ID CS 5.5 hasn't got a problem with it. It easy accessable over the linkXmp.description but CS 4 doesn't give any info.
CS4 Bridge gives the info for the namespace:
#target Bridge
var thumb= new Thumbnail (File ('~/Desktop/37oc4040.jpg'));
var md = thumb.metadata;  
   md.synchronousMetadata; 
  var nameSpaces = new Array ("http://purl.org/dc/elements/1.1/"); 
for (var i = 0; i < nameSpaces.length; i++)  { 
    var currameSpace = nameSpaces[i] 
  md.namespace = currameSpace
    currDescription = md.description; 
    alert(currDescription)
   thumb.refresh() 
but
app.selection[0].itemLink.linkXmp.getProperty("http://purl.org/dc/elements/1.1/", "description");
throws a error
Any advise?
Hans-Gerd Claßen

Ok, guess I found a solution in this forum:
app.selection[0].itemLink.linkXmp.getProperty("http://purl.org/dc/elements/1.1/", "title/*[1]"/* and so on "subject/*[1]""creator/*[1]" "description/*[1]"*/);

Similar Messages

  • HOW CAN I GET A DESCRIPTION OF ALL OF THE FRATURES IN lION 10.7.4

    How can I get a description of all of the programs that came with my mac pro without spending an arm and a leg?

    This is a good place to start and follow the links to all the Mac 101 articles.
    http://www.apple.com/support/mac101/
    Regards,
    Captfred

  • Function module to get table description

    Is there any function module to get table description on passing table name

    Hi,
    We need to use : 'G_RW_TABLE_DESCRIPTION_GET' function module.
    we pass the table name and the language.
    call function 'G_RW_TABLE_DESCRIPTION_GET'
        exporting
          rw_table = p_table
          langu    = sy-langu
        importing
          tab_text = l_tabtext
        exceptions
          others   = 1.
    thanx.

  • How to get field description for custom field just like orgeh in SQ01 Repor

    Good Day Friends,
    I want to share one of my issue with you.Hope you will resolve it easily .
    I have enhaced standard infotype 0001 to maintain JOB CODE field, i also have maintained the
    JOB CODE, JOB CODE DESCRIPTION in one custom table  ( ZHR_JOBDISC ) .
    I have given farigen key relation between this custom table ( ZHR_JOBDISC ) and PA0001. i also have created one search help and assigned to the Field JOB CODE.
    But when i am trying to write the query in SQ01 . i am unable to fetch description.
    if you observe the standard fields position (PLANS), Organisational Unit (ORGEH).while writing query if you right click on PLANS will show the description of position, similarly  if you right click on ORGEH it will show the description org unit.
    but i am unable to get the description of my custom field.
    Please give clarification where i am doing wrong ?

    Good day Ravindra,
    Please, could you consider as reference notes 367585, 332842 and 491403.
    This is well described in the documentation for the interface of IF_TEXT_IDENTIFIER.
    Transaction SE24, enter IF_TEXT_IDENTIFIER, Display' function and check
    the 'Interface documentation'. Please choose "HR Class" upon executing for Text Recognition.
    Additionally check the following website:
    http://help.sap.com/erp2005_ehp_03/helpdata/EN/d9/9958e0c50a11d396f80000
    e82de14a/frameset.htm
    Hope this information helps.
    Kind regards,
    Graziela

  • Not getting Line Description in Account Analysis Report

    Hi Friends,
    There is requirement to get line description for account analysis report...
    Source - Cost Management
    Category - Receiving
    Event Type - Receipt into Receiving
    I have done required setup(Application Accounting Definition) to get the line description .I am getting line description for Debit transaction but for the same source and event type i am not getting line description for credit transactions..
    Is there any way to get line description for Credit transaction.
    Please suggest...

    Please friend...share knowledge on this...

  • RSS Feed from rss generator's new app has changed the feed. Now the description of apps is not showing. the rest is the same. Anyone has an idea why ?  and how do I get the description? if I fetch it from itunes pages would that be considered violation of

    RSS Feed from rss generator's new app has changed the feed. Now the description of apps is not showing. the rest is the same. Anyone has an idea why ?  and how do I get the description? if I fetch it from itunes pages would that be considered violation of apple's terms and conditions? Please help

    See this post.
    tt2

  • How do I get enumeration description from simple type?

    Hello!
    I want to display the value of a simple type in a table and display the description in a tool tip for the cell, how do I do that?
    I'm using Web dynpro for java 7.0 ehp1.
    I'm using an enumeration with 5 possible values with corresponding descriptions.
    If I use a (read only) dropdownByKey the description is shown in the drop down, but I only want to show it as a tooltip since it takes up some screen space.
    I would like to use a textview, is there a simple way to get the description as a tooltip? I thought about doing a calculated attribute that gets the description but I'm not sure about how to do it or if its the easiest way.
    Thank you for any help!

    Hi Richard,
    for getting the description of the simple type attribute ( Ex.X) create a context attribute of type string (Ex. Y) and bind it to the tooltip property of table cell editor.
    Set the read only and calculated property of the attribute Y to true.
    Put this code in the automatic generated method for calculated attribute :-
    String value1 = nodeElement.getX;
    IWDAttributeInfo attInfo = wdContext.getNodeInfo().getAttribute("X");
    ISimpleValueSet valueset = attInfo.getModifiableSimpleType().getSVServices().getValues();
    if(valueset.containsKey(value1)){
    String value2 = valueset.getText(value1);
    wdContext.node<NodeName>.setY(value2);
    By this way you can set the description of the simple type as tooltip but by using dropdown by key and index you cannot  show the valueof the simple type in the UI.
    So another way is bind the simple type attribute to a inputfield uielement in the table column.  Your simple type enumeration data will come as a F4 help in the UI and after selection you will be able to see value in inputt field and description as a tooltip.
    Regards
    Ravindra

  • 891W to 5505 EZVPN issue...No peer struct to get peer description

    Hey everyone,
    I've been on the forums looking for a solution to my issue in my lab....
    I'm getting the No peer struct to get peer description error in my debug.  I've done a search on these forums but the changes that I made did not work for me
    It has to be something simple.....
    I am able to ping out to my ASA
    891Demo#ping 38.98.226.100
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 38.98.226.100, timeout is 2 seconds:
    Success rate is 100 percent (5/5), round-trip min/avg/max = 100/106/116 ms
    I did a few show commands listed below if anyone wants to take a look...
    891Demo#sho run
    Building configuration...
    Current configuration : 6370 bytes
    ! Last configuration change at 20:47:45 UTC Fri Jan 10 2014 by admin
    version 15.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname 891Demo
    boot-start-marker
    boot-end-marker
    logging buffered 52000
    aaa new-model
    aaa authentication login default local
    aaa authentication login ciscocp_vpn_xauth_ml_1 local
    aaa authorization exec default local
    aaa authorization network ciscocp_vpn_group_ml_1 local
    aaa session-id common
    service-module wlan-ap 0 bootimage autonomous
    crypto pki trustpoint TP-self-signed-1670941714
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-1670941714
    revocation-check none
    rsakeypair TP-self-signed-1670941714
    crypto pki certificate chain TP-self-signed-1670941714
    certificate self-signed 01
      3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
      31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
      69666963 6174652D 31363730 39343137 3134301E 170D3133 30393130 31383038
      31305A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
      4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 36373039
      34313731 3430819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
      8100A613 DCE81A2F 27DC53B6 6ED91D5E 167EEAEA D9793CB3 33C39BBE CBC5AF0B
      029C1605 3FC09722 C7811B2D 173B5887 2C87A9C7 4DDAC1C4 AE13A1C3 743B940E
      A5A7AF56 26A83081 2330E910 1BA8317A BE0BC37A 631D858D E307DC04 2F76D648
      1500DB09 2BC1B92A 92C0B8FE 59434385 A3D1B19D 5665D3A9 07956793 F2B98EDA
      EA870203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
      551D2304 18301680 1489C50C C4C16781 28F37E31 DABE13A9 2EE9967E 58301D06
      03551D0E 04160414 89C50CC4 C1678128 F37E31DA BE13A92E E9967E58 300D0609
      2A864886 F70D0101 05050003 81810053 FD39A299 CFF9E763 C89846EE 9BE0DAE4
      31B890D0 969764F0 98A21C63 FD103ADB 29BA7DB4 98C142B9 1EA60C71 1D6C4BE5
      921224F5 BE5FC348 2A2A4858 A5D0E680 23346C0E 8EA55314 435CE650 5167C796
      1EB4EFAD 1D045B2C 84031255 C2A9F5B7 C8542ACF 3C69C46E DE0230AE EA3587EE
      464A0AC0 3987D917 47A4ABDB 5B6022
            quit
    ip cef
    ip dhcp excluded-address 10.10.10.7 10.10.10.254
    891Demo#sh run
    Building configuration...
    Current configuration : 6370 bytes
    ! Last configuration change at 20:47:45 UTC Fri Jan 10 2014 by admin
    version 15.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname 891Demo
    boot-start-marker
    boot-end-marker
    logging buffered 52000
    aaa new-model
    aaa authentication login default local
    aaa authentication login ciscocp_vpn_xauth_ml_1 local
    aaa authorization exec default local
    aaa authorization network ciscocp_vpn_group_ml_1 local
    aaa session-id common
    service-module wlan-ap 0 bootimage autonomous
    crypto pki trustpoint TP-self-signed-1670941714
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-1670941714
    revocation-check none
    rsakeypair TP-self-signed-1670941714
    crypto pki certificate chain TP-self-signed-1670941714
    certificate self-signed 01
      3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
      31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
      69666963 6174652D 31363730 39343137 3134301E 170D3133 30393130 31383038
      31305A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
      4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 36373039
      34313731 3430819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
      8100A613 DCE81A2F 27DC53B6 6ED91D5E 167EEAEA D9793CB3 33C39BBE CBC5AF0B
      029C1605 3FC09722 C7811B2D 173B5887 2C87A9C7 4DDAC1C4 AE13A1C3 743B940E
      A5A7AF56 26A83081 2330E910 1BA8317A BE0BC37A 631D858D E307DC04 2F76D648
      1500DB09 2BC1B92A 92C0B8FE 59434385 A3D1B19D 5665D3A9 07956793 F2B98EDA
      EA870203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
      551D2304 18301680 1489C50C C4C16781 28F37E31 DABE13A9 2EE9967E 58301D06
      03551D0E 04160414 89C50CC4 C1678128 F37E31DA BE13A92E E9967E58 300D0609
      2A864886 F70D0101 05050003 81810053 FD39A299 CFF9E763 C89846EE 9BE0DAE4
      31B890D0 969764F0 98A21C63 FD103ADB 29BA7DB4 98C142B9 1EA60C71 1D6C4BE5
      921224F5 BE5FC348 2A2A4858 A5D0E680 23346C0E 8EA55314 435CE650 5167C796
      1EB4EFAD 1D045B2C 84031255 C2A9F5B7 C8542ACF 3C69C46E DE0230AE EA3587EE
      464A0AC0 3987D917 47A4ABDB 5B6022
            quit
    ip cef
    ip dhcp excluded-address 10.10.10.7 10.10.10.254
    ip dhcp pool ccp-pool
    import all
    network 10.10.10.0 255.255.255.0
    default-router 10.10.10.1
    lease 0 2
    ip domain name yourdomain.com
    no ipv6 cef
    ipv6 multicast rpf use-bgp
    multilink bundle-name authenticated
    license udi pid CISCO891W-AGN-A-K9 sn FTX171783D3
    username admin privilege 15 password 0 password
    redundancy
    csdb tcp synwait-time 30
    csdb tcp idle-time 3600
    csdb tcp finwait-time 5
    csdb tcp reassembly max-memory 1024
    csdb tcp reassembly max-queue-length 16
    csdb udp idle-time 30
    csdb icmp idle-time 10
    csdb session max-session 65535
    crypto isakmp policy 50
    encr 3des
    authentication pre-share
    group 2
    crypto isakmp key D1l2w3r4 address 38.98.226.100
    crypto isakmp client configuration group VPNGroupZLAB
    key D1l2w3r4
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    mode tunnel
    crypto ipsec transform-set ESP-3DES-SHA1 esp-3des esp-sha-hmac
    mode tunnel
    crypto ipsec client ezvpn CISCOCP_EZVPN_CLIENT_1
    connect auto
    group DefaultL2LGroup key D1l2w3r4
    mode client
    peer 38.98.226.100
    username ztest password D1l2w3r4
    xauth userid mode local
    crypto map SDM_CMAP_1 1 ipsec-isakmp
    description Tunnel to38.98.226.100
    set peer 38.98.226.100
    set transform-set ESP-3DES-SHA
    match address 102
    interface FastEthernet0
    no ip address
    interface FastEthernet1
    no ip address
    interface FastEthernet2
    no ip address
    interface FastEthernet3
    no ip address
    interface FastEthernet4
    no ip address
    interface FastEthernet5
    no ip address
    interface FastEthernet6
    no ip address
    interface FastEthernet7
    no ip address
    interface FastEthernet8
    no ip address
    shutdown
    duplex auto
    speed auto
    interface Virtual-Template1 type tunnel
    no ip address
    tunnel mode ipsec ipv4
    interface GigabitEthernet0
    ip address dhcp
    ip nat outside
    ip virtual-reassembly in
    duplex auto
    speed auto
    crypto map SDM_CMAP_1
    interface wlan-ap0
    description Service module interface to manage the embedded AP
    ip unnumbered Vlan1
    arp timeout 0
    interface Wlan-GigabitEthernet0
    description Internal switch interface connecting to the embedded AP
    no ip address
    interface Vlan1
    description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
    ip address 10.10.10.1 255.255.255.248
    ip nat inside
    ip virtual-reassembly in
    ip tcp adjust-mss 1452
    interface Async1
    no ip address
    encapsulation slip
    ip forward-protocol nd
    ip http server
    ip http access-class 23
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    ip dns server
    ip nat inside source route-map SDM_RMAP_1 interface GigabitEthernet0 overload
    ip route 0.0.0.0 0.0.0.0 192.168.1.1 254
    ip route 0.0.0.0 0.0.0.0 GigabitEthernet0 192.168.1.1 254
    ip route 0.0.0.0 0.0.0.0 GigabitEthernet0 dhcp 254
    ip access-list extended protect_traffic
    permit ip host 10.10.10.1 host 10.1.11.1
    no cdp run
    route-map SDM_RMAP_1 permit 1
    match ip address 101
    access-list 23 permit 10.10.10.0 0.0.0.7
    access-list 100 remark CCP_ACL Category=4
    access-list 100 remark IPSec Rule
    access-list 100 permit ip 10.10.10.0 0.0.0.255 10.1.11.0 0.0.0.255
    access-list 101 remark CCP_ACL Category=2
    access-list 101 remark IPSec Rule
    access-list 101 deny   ip 10.10.10.0 0.0.0.255 10.1.11.0 0.0.0.255
    access-list 101 permit ip 10.10.10.0 0.0.0.7 any
    access-list 102 remark CCP_ACL Category=4
    access-list 102 remark IPSec Rule
    access-list 102 permit ip 10.10.10.0 0.0.0.255 10.1.11.0 0.0.0.255
    control-plane
    mgcp behavior rsip-range tgcp-only
    mgcp behavior comedia-role none
    mgcp behavior comedia-check-media-src disable
    mgcp behavior comedia-sdp-force disable
    mgcp profile default
    line con 0
    line 1
    modem InOut
    speed 115200
    flowcontrol hardware
    line 2
    no activation-character
    no exec
    transport preferred none
    transport input all
    transport output pad telnet rlogin udptn ssh
    line aux 0
    line vty 0 4
    access-class 23 in
    transport input telnet ssh
    transport output telnet ssh
    line vty 5 15
    access-class 23 in
    transport input telnet ssh
    transport output telnet ssh
    end
    =============================================
    =============================================
    891Demo#sh crypto ipsec sa
    interface: GigabitEthernet0
        Crypto map tag: SDM_CMAP_1, local addr 10.0.0.35
       protected vrf: (none)
       local  ident (addr/mask/prot/port): (10.10.10.0/255.255.255.0/0/0)
       remote ident (addr/mask/prot/port): (10.1.11.0/255.255.255.0/0/0)
       current_peer 38.98.226.100 port 500
         PERMIT, flags={origin_is_acl,}
        #pkts encaps: 0, #pkts encrypt: 0, #pkts digest: 0
        #pkts decaps: 0, #pkts decrypt: 0, #pkts verify: 0
        #pkts compressed: 0, #pkts decompressed: 0
        #pkts not compressed: 0, #pkts compr. failed: 0
        #pkts not decompressed: 0, #pkts decompress failed: 0
        #send errors 0, #recv errors 0
         local crypto endpt.: 10.0.0.35, remote crypto endpt.: 38.98.226.100
         path mtu 1500, ip mtu 1500, ip mtu idb GigabitEthernet0
         current outbound spi: 0x0(0)
         PFS (Y/N): N, DH group: none
         inbound esp sas:
         inbound ah sas:
         inbound pcp sas:
         outbound esp sas:
         outbound ah sas:
         outbound pcp sas:
    =============================================
    =============================================
    891Demo#sho crypto se
    Crypto session current status
    Interface: GigabitEthernet0
    Session status: DOWN
    Peer: 38.98.226.100 port 500
      IPSEC FLOW: permit ip 10.10.10.0/255.255.255.0 10.1.11.0/255.255.255.0
            Active SAs: 0, origin: crypto map
    891Demo#
    *Jan 10 20:56:15.327: No peer struct to get peer description
    =============================================
    =============================================
    891Demo#sh crypto isakmp default pol
    Default IKE policy
    Default protection suite of priority 65507
            encryption algorithm:   AES - Advanced Encryption Standard (128 bit keys).
            hash algorithm:         Secure Hash Standard
            authentication method:  Rivest-Shamir-Adleman Signature
            Diffie-Hellman group:   #5 (1536 bit)
            lifetime:               86400 seconds, no volume limit
    Default protection suite of priority 65508
            encryption algorithm:   AES - Advanced Encryption Standard (128 bit keys).
            hash algorithm:         Secure Hash Standard
            authentication method:  Pre-Shared Key
            Diffie-Hellman group:   #5 (1536 bit)
            lifetime:               86400 seconds, no volume limit
    Default protection suite of priority 65509
            encryption algorithm:   AES - Advanced Encryption Standard (128 bit keys).
            hash algorithm:         Message Digest 5
            authentication method:  Rivest-Shamir-Adleman Signature
            Diffie-Hellman group:   #5 (1536 bit)
            lifetime:               86400 seconds, no volume limit
    Default protection suite of priority 65510
            encryption algorithm:   AES - Advanced Encryption Standard (128 bit keys).
            hash algorithm:         Message Digest 5
            authentication method:  Pre-Shared Key
            Diffie-Hellman group:   #5 (1536 bit)
            lifetime:               86400 seconds, no volume limit
    Default protection suite of priority 65511
            encryption algorithm:   Three key triple DES
            hash algorithm:         Secure Hash Standard
            authentication method:  Rivest-Shamir-Adleman Signature
            Diffie-Hellman group:   #2 (1024 bit)
            lifetime:               86400 seconds, no volume limit
    Default protection suite of priority 65512
            encryption algorithm:   Three key triple DES
            hash algorithm:         Secure Hash Standard
            authentication method:  Pre-Shared Key
            Diffie-Hellman group:   #2 (1024 bit)
            lifetime:               86400 seconds, no volume limit
    Default protection suite of priority 65513
            encryption algorithm:   Three key triple DES
            hash algorithm:         Message Digest 5
            authentication method:  Rivest-Shamir-Adleman Signature
            Diffie-Hellman group:   #2 (1024 bit)
            lifetime:               86400 seconds, no volume limit
    Default protection suite of priority 65514
            encryption algorithm:   Three key triple DES
            hash algorithm:         Message Digest 5
            authentication method:  Pre-Shared Key
            Diffie-Hellman group:   #2 (1024 bit)
            lifetime:               86400 seconds, no volume limit
    Any insight to this would be appreciated, i'm still going to try and figure it out as well

    It is the host site not transmitting. The ACL that i see thats blocking is for a client based VPN.
    Phase: 1
    Type: ROUTE-LOOKUP
    Subtype: input
    Result: ALLOW
    Config:
    Additional Information:
    in   0.0.0.0         0.0.0.0         Outside
    Phase: 2
    Type: ROUTE-LOOKUP
    Subtype: input
    Result: ALLOW
    Config:
    Additional Information:
    in   192.168.180.0   255.255.254.0   Inside
    Phase: 3
    Type: ACCESS-LIST
    Subtype: log
    Result: ALLOW
    Config:
    access-group Inside_access_in in interface Inside
    access-list Inside_access_in extended permit ip object obj_any any
    Additional Information:
    Phase: 4
    Type: IP-OPTIONS
    Subtype:
    Result: ALLOW
    Config:
    Additional Information:
    Phase: 5
    Type: NAT
    Subtype:
    Result: ALLOW
    Config:
    nat (Inside,Outside) source static DM_INLINE_NETWORK_20 DM_INLINE_NETWORK_20 destination static AT_Remote AT_Remote no-proxy-arp route-lookup
    Additional Information:
    Static translate 192.168.180.232/12345 to 192.168.180.232/12345
    Phase: 6
    Type: ACCESS-LIST
    Subtype: vpn-user
    Result: DROP
    Config:
    Additional Information:
    Result:
    input-interface: Inside
    input-status: up
    input-line-status: up
    output-interface: Outside
    output-status: up
    output-line-status: up
    Action: drop
    Drop-reason: (acl-drop) Flow is denied by configured rule

  • Where can get detail description of functions in tsapicvi.h?

    there are lot of API functions in tsapicvi.h,some of them I can get the description in teststand help file,for example, if I want to know TS_EngineGetUIMessage, I search the "GetUIMessage" in teststand help file,it will get the description.but some API I can not get description in help file,for example ,TS_EngineGetStationOptions,TS_StationOptionsSetTracingEnabled......, why? where I can find all function's description?thanks.

    Hi,
    The examples you mentioned are Properties rather methods,
    eg TS_EngineGetStationOptions: is StationOptions
    http://zone.ni.com/reference/en-XX/help/370052H-01/tsapiref/reftopics/engine_stationoptions_p/
    Hope this helps
    Regards
    Ray Farmer
    Regards
    Ray Farmer

  • When I go to the app store on the iPad and tap on an app to get a description of it, it won't do anything. I have not noticed this problem on I tunes.

    When I go to the app store on the I pad and tap on an app to get a description, it does not do anything. I have my iPad 2 for just a few days and it did not start doing this until just a few minutes ago. Any suggestions?

    I understand that your App Store does not show your app updates. Please follow the steps below to help resolve the issue.
    1. Close All Apps on iPad: http://support.apple.com/kb/ht5137
    2. Sign out of iTunes & App Stores: Settings > iTunes & App Stores > Tap AppleID > Sign out
    3. Reset All Settings: Settings > General > Reset > Reset All Settings
    4. Reboot iPad
    5. Sign back into iTunes and App Stores: Settings > iTunes & App Stores > Sign In with AppleID
    Thank you for being an iTunes store customer. Apple appreciates your business.

  • How to get material description from material number.

    Hello ABAP Pundits,
    I have got the material number MATNR.
    I need to get Material Description MAKTX using this material number.
    Now MAKTX is not a table that I can go and fetch it.
    What function module do I require to fetch that material description field ?
    Points will be surely awarded..
    Tushar.

    Do a select against <b>MAKT</b>.
    parmaters: p_matnr type mara-matnr.
    data: xmaktx type makt-maktx.
    Select maktx into xmaktx from makt
              where matnr = p_matnr
                and spras = sy-langu.
    Regards,
    Rich HEilman

  • How to get XMP MetaData as an XML String in a process?

    Hi there,
    I have a process where I would like to export a documents XMP MetaData, manipulate the XMP MetaData and then import the MetaData again to the document.
    I thougt first I will use the service Name "XMPUtilityService" with the Service Operation "Export XMP" to export the XMP MetaData as a document.
    Hoewer I am not sure how to manipulate the output document from the Export XMP service.
    When I print out the document.toString() in a execute Script Service I get the following:
    <document state="active" senderVersion="0" persistent="false" senderPersistent="false" passivated="false" senderPassivated="false" deserialized="false" senderHostId="null" callbackId="0" senderCallbackId="0" callbackRef="null" isLocalizable="true" isTransactionBound="false" defaultDisposalTimeout="600" disposalTimeout="600" maxInlineSize="65536" defaultMaxInlineSize="65536" inlineSize="3440" contentType="null" length="-1"><cacheId/><localBackendId/><globalBackendId/><senderLocalBackendId/><senderGl obalBackendId/><inline><?xpacket begin="" id="W5M0MpCehiHzreSzNTczkc9d"?>
    <x:xmpmeta xmlns:x="adobe:ns:meta/" x:xmptk="A...</inline><senderPullServantJndiName/><attributes/></document>
    Actually I expected something like this:
    <?xpacket begin="" id="W5M0MpCehiHzreSzNTczkc9d"?>
    <x:xmpmeta xmlns:x="adobe:ns:meta/" x:xmptk="Adobe XMP Core 5.0-jc006 DEBUG-1.0, 2009 Jun 23 11:07:21-PDT">
       <rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#">
          <rdf:Description rdf:about=""
                xmlns:pdf="http://ns.adobe.com/pdf/1.3/">
             <pdf:Producer>Adobe LiveCycle PDF Generator ES2</pdf:Producer>
          </rdf:Description>
          <rdf:Description rdf:about=""
                xmlns:xmp="http://ns.adobe.com/xap/1.0/">
             <xmp:ModifyDate>2010-04-20T20:43:59+02:00</xmp:ModifyDate>
             <xmp:MetadataDate>2010-04-20T20:43:59+02:00</xmp:MetadataDate>
          </rdf:Description>
          <rdf:Description rdf:about=""
                xmlns:xmpMM="http://ns.adobe.com/xap/1.0/mm/">
             <xmpMM:DocumentID>uuid:0cf2c6c6-2fba-2b39-5fb6-33ad8ccf58aa</xmpMM:DocumentID>
             <xmpMM:InstanceID>uuid:187bc5a2-acb0-2fa9-711d-33ad8ccf58aa</xmpMM:InstanceID>
          </rdf:Description>
       </rdf:RDF>
    </x:xmpmeta>
    <?xpacket end="w"?>
    What do I need to do to get the XMPMeta data as an XML String from a document within a process?
    Thanks in advance!
    Paul

    Hi,
    thanks for the answer.
    I know that I can retrieve the XMPUtilityMetadata object, but this object provides only access to a few information suche as creator, subject, producer, etc.
    However I would like to retrieve the whole XML String of the XMP Metadata.
    How is this possible?
    Thanks.
    Paul

  • CS4 - Getting error when opening a .gif file - file-format module cannot parse the file.

    I am getting this popup error when trying to open a .gif file:
    "Could not complete your request because the file-format module cannot parse the file."
    This comes up every time I try to open a .gif file.  Even if I make a .gif file (like the image included in this post), save it and then try to open it again, I get the same error.  I tried reinstalling CS4, but the error is still there.  I have also done the reset on start-up and nothing.  Some have suggested that I open it in (Windows XP Pro) MS Paint and then save it again.  Did it and this does NOT work for me, either. 
    I know it's a Photoshop problem because I can see this file everywhere, except Photoshop.  It will open here, there and everywhere, except for Photoshop.
    I've searched the Adobe Commmunity and it looks like no one has come up with a fix for this.  I'm just currious after 5 years with this problem, has there been a solution?
    Scott

    One of the files that has the error is in my first post.
    Adobe Photoshop Version: 11.0
    Operating System: Windows XP 32-bit
    Version: 5.1 Service Pack 3
    System architecture: AMD CPU Family:15, Model:10, Stepping:0 with MMX, SSE Integer, SSE FP, SSE2
    Physical processor count: 6
    Processor speed: 3210 MHz
    Video Card: NVIDIA GeForce GTX 460
    Video Mode: 1280 x 1024 x 4294967296 colors
    Video Card Driver: nv4_disp.dll
    Driver Version: 6.14.13.0623
    Built-in memory: 3289 MB
    Free memory: 257 MB
    Memory available to Photoshop: 1677 MB
    Memory used by Photoshop: 69 %
    Image cache levels: 4
    Serial number: xxxxxxxxxxxxxxx
    Application folder: C:\Program Files\Adobe\Adobe Photoshop CS4\
    Temporary file path: C:\DOCUME~1\xxxxxx\LOCALS~1\Temp\
    Photoshop scratch has async I/O enabled
    Scratch volume(s):
      F:\, 233.7G, 145.7G free
    Primary Plug-ins folder: C:\Program Files\Adobe\Adobe Photoshop CS4\Plug-ins\
    Additional Plug-ins folder: not set
    Installed components:
       ACE.dll   ACE 2008/08/27-18:10:41     
       AdobeLinguistic.dll   Adobe Linguisitc Library   4.0.0  
       AdobeLM.dll   AdobeLM   3.0.11.10077    53.352460
       AdobeLM_libFNP.dll   FLEXnet Publisher (32 bit)   11.5.0.1 build 57427  
       AdobeOwl.dll   Adobe Owl
       AdobeOwlCanvas.dll   Adobe Owl Canvas  
       AdobePDFL.dll   PDFL 2008/08/20-20:15:08  
       AdobeUpdater.dll   Adobe Updater Library   
       AdobeXMP.dll   Adobe XMP Core 
       AdobeXMPFiles.dll   Adobe XMP Files   4.2.2   53.352624
       AdobeXMPScript.dll   Adobe XMP Script   4.2.2   53.352624
       adobe_caps.dll   Adobe CAPS   2,0,99,0   2.135373
       adobe_epic.dll   Adobe EPIC   3.0.1.10077    53.352460
       adobe_eula.dll   Adobe EPIC EULA   3.0.1.10077
       AFlamingo.dll   AFlamingo
       AGM.dll   AGM      
       ahclient.dll    AdobeHelp Dynamic Link Library   1, 3, 12, 0  
       aif_core.dll   AIF   1.0 
       aif_ogl.dll   AIF   1.0  
       amtlib.dll   AMTLib   2.0.1.10077    53.352460
       amtservices.dll   AMTServices   2.0.1.10077    53.352460
       ARE.dll   ARE 2008/08/27-18:10:41     
       asneu.dll    AsnEndUser Dynamic Link Library   1, 6, 0, 8  
       authplay.dll        
       AXE8SharedExpat.dll   AXE8SharedExpat
       AXEDOMCore.dll   AXEDOMCore
       Bib.dll   BIB      
       BIBUtils.dll   BIBUtils      
       cg.dll   NVIDIA Cg Runtime   2.0.0015  
       cgGL.dll   NVIDIA Cg Runtime   2.0.0015  
       CoolType.dll   CoolType 2008/08/27-18:10:41     
       data_flow.dll   AIF   1.0   53.352475
       ExtendScript.dll   ExtendScript      
       FileInfo.dll   Adobe XMP FileInfo   4.2.2  
       FNP_Act_Installer.dll   FLEXnet Publisher (32 bit)     
       icucnv36.dll 
       icudt36.dll     
       image_flow.dll   AIF   1.0   53.352475
       image_runtime.dll   AIF   1.0   53.352475
       JP2KLib.dll   JP2KLib 2008/06/11-20:19:53   53.100857   53.100857
       libifcoremd.dll   Intel(r) Visual Fortran Compiler   10.0 (Update A)  
       libmmd.dll   Intel(r) C Compiler, Intel(r) C++ Compiler, Intel(r) Fortran Compiler   10.0  
       MPS.dll   MPS 2008/07/07-10:33:04   53.350311   53.350311
       msvcp71.dll   Microsoft® Visual Studio .NET   7.10.3077.0  
       msvcr71.dll   Microsoft® Visual Studio .NET   7.10.3052.4  
       pdfsettings.dll   Adobe PDFSettings   1.04  
       Photoshop.dll   Adobe Photoshop CS4   CS4  
       Plugin.dll   Adobe Photoshop CS4   CS4  
       PlugPlug.dll   Adobe(R) CSXS PlugPlug Standard Dll (32 bit)   1.0.0.73  
       PSArt.dll   Adobe Photoshop CS4   CS4  
       PSViews.dll   Adobe Photoshop CS4   CS4  
       registration.dll   Registration   
       SCCore.dll   ScCore      
       shfolder.dll   Microsoft(R) Windows (R) 2000 Operating System     
       WRServices.dll   WRServices
    Installed plug-ins:
       3D Studio 11.0
       ADM 3.11x01
       Accented Edges 11.0
       Angled Strokes 11.0
       Average 11.0
       BMP 11.0
       Bas Relief 11.0
       Camera Raw 5.0
       Chalk & Charcoal 11.0
       Charcoal 11.0
       Chrome 11.0
       Cineon 11.0   
       Clouds 11.0
       Collada 11.0
       Color Halftone 11.0
       Colored Pencil 11.0
       CompuServe GIF 11.0
       Conté Crayon 11.0
       Craquelure 11.0
       Crop and Straighten Photos 11.0
       Crop and Straighten Photos Filter 11.0
       Crosshatch 11.0
       Crystallize 11.0
       Cutout 11.0
       Dark Strokes 11.0
       De-Interlace 11.0
       Dicom 11.0
       Difference Clouds 11.0
       Diffuse Glow 11.0
       Displace 11.0
       Dry Brush 11.0
       Embed Watermark 3.0
       Entropy 11.0
       Extrude 11.0
       FXG 11.0
       FastCore Routines 11.0
       Fibers 11.0
       Film Grain 11.0
       Filmstrip 11.0
       Filter Gallery 11.0
       Fresco 11.0
       Glass 11.0
       Glowing Edges 11.0
       Google Earth 4 11.0
       Grain 11.0
       Graphic Pen 11.0
       HDRMergeUI 11.0
       Halftone Pattern 11.0
       IFF Format 11.0
       Ink Outlines 11.0
       Kurtosis 11.0
       Lens Blur 11.0
       Lens Correction 11.0
       Lens Flare 11.0
       Lighting Effects 11.0
       Liquify 11.0
       MMXCore Routines 11.0
       Matlab Operation 11.0
       Maximum 11.0
       Mean 11.0
       Measurement Core 11.0
       Median 11.0
       Mezzotint 11.0
       Minimum 11.0
       Mosaic Tiles 11.0
       Multiprocessor Support 11.0
       NTSC Colors 11.0
       Neon Glow 11.0
       Note Paper 11.0
       Ocean Ripple 11.0
       OpenEXR 11.0
       PCX 11.0
       PNG 11.0
       Paint Daubs 11.0
       Palette Knife 11.0
       Patchwork 11.0
       Paths to Illustrator 11.0
       Photocopy 11.0
       Photoshop 3D Engine 11.0
       Picture Package Filter 11.0
       Pinch 11.0
       Pixar 11.0
       Plaster 11.0
       Plastic Wrap 11.0
       Pointillize 11.0
       Polar Coordinates 11.0
       Portable Bit Map 11.0
       Poster Edges 11.0
       Radial Blur 11.0
       Radiance 11.0
       Range 11.0
       Read Watermark 3.0
       Reticulation 11.0
       Ripple 11.0
       Rough Pastels 11.0
       Save for Web & Devices 11.0
       ScriptingSupport 11.0
       Send Video Preview to Device 11.0
       Shear 11.0
       Skewness 11.0
       Smart Blur 11.0
       Smudge Stick 11.0
       Solarize 11.0
       Spatter 11.0
       Spherize 11.0
       Sponge 11.0
       Sprayed Strokes 11.0
       Stained Glass 11.0
       Stamp 11.0
       Standard Deviation 11.0
       Sumi-e 11.0
       Summation 11.0
       Targa 11.0
       Texturizer 11.0
       Tiles 11.0
       Torn Edges 11.0
       Twain Acquire 11.0
       Twain Select 11.0
       Twirl 11.0
       U3D 11.0
       Underpainting 11.0
       Vanishing Point 11.0
       Variance 11.0
       Variations 11.0 (11.0x001)
       Video Preview 11.0
       WIA Support 11.0
       Water Paper 11.0
       Watercolor 11.0
       Wave 11.0
       Wavefront|OBJ 11.0
       Wind 11.0
       Wireless Bitmap 11.0
       ZigZag 11.0
    Plug-ins that failed to load: NONE
    Flash:
       Connections
       Kuler
    Installed TWAIN devices:
       WIA-hp officejet 6100 series
       hp officejet 6100 series TWAIN

  • When launching InDesign CS4, getting CS4 has stopped working

    When I check the application event viewer,
    Log Name:      Application
    Source:        Application Error
    Date:          4/19/2011 9:30:13 AM
    Event ID:      1000
    Task Category: (100)
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      .casto.local
    Description:
    Faulting application name: InDesign.exe, version: 6.0.0.352, time stamp: 0x48bf8dab
    Faulting module name: AGM.dll, version: 4.19.26.1744, time stamp: 0x48b60248
    Exception code: 0xc0000005
    Fault offset: 0x00244fc5
    Faulting process id: 0x1784
    Faulting application start time: 0x01cbfe95e76be0a9
    Faulting application path: C:\Program Files\Adobe\Adobe InDesign CS4\InDesign.exe
    Faulting module path: C:\Program Files\Adobe\Adobe InDesign CS4\AGM.dll
    Report Id: 274a3009-6a89-11e0-981e-000ffec30344
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Application Error" />
        <EventID Qualifiers="0">1000</EventID>
        <Level>2</Level>
        <Task>100</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2011-04-19T13:30:13.000000000Z" />
        <EventRecordID>2740</EventRecordID>
        <Channel>Application</Channel>
        <Computer>natws-pshah.casto.local</Computer>
        <Security />
      </System>
      <EventData>
        <Data>InDesign.exe</Data>
        <Data>6.0.0.352</Data>
        <Data>48bf8dab</Data>
        <Data>AGM.dll</Data>
        <Data>4.19.26.1744</Data>
        <Data>48b60248</Data>
        <Data>c0000005</Data>
        <Data>00244fc5</Data>
        <Data>1784</Data>
        <Data>01cbfe95e76be0a9</Data>
        <Data>C:\Program Files\Adobe\Adobe InDesign CS4\InDesign.exe</Data>
        <Data>C:\Program Files\Adobe\Adobe InDesign CS4\AGM.dll</Data>
        <Data>274a3009-6a89-11e0-981e-000ffec30344</Data>
      </EventData>
    </Event>
    This is a new install of CS4 on a new workstation running Windows 7 32bit.  All other parts of CS4 work ok.

    HI Peter
    Thank you so much for this link.  I tried installing it but it seems that I already have the patch installed.
    I am having a problem launching both InDesign and Illustrator for CS4 but get the error message below when I launch the program.
    Do you have any suggestions on this please?
    I am using Win7 32bit.  I have not installed Adobe Acrobat or Photoshop from CS4 as I am using that from the Adobe eLearning Suite 2.5
    Would appreciate any help if you have the time.
    Thanking you
    Rajesh

  • [CS3][CS4][JS] XMP dictionary for Lablegraphics.jsx

    I was working on the LableGraphics.jsx trying to figure out how to get other xmp information out of a linked graphic into Indesign CS3 or CS4.
    Can someone point me to a dictionary or help with the fix?
    Would be very interesting to get the copyright and location (not the gps or such - just the text location) into InDesign.

    Yes, it's scriptable. Assuming the operator has placed the image, you'd duplicate the frame. Then in each you'd use the "graphic layer options" property of the image to get a reference to the graphic layer option, which has graphic layers as elements. You can then change the "current visibility" property of the layers.
    So something like this (untested):
    tell application "Adobe InDesign CS4"
    set theFrame to item 1 of selection
    set newFrame to duplicate theFrame
    set glOptions to graphic layer options of image 1 of theFrame
    set current visibility of graphic layer 2 of glOptions to false
    set glOptions to graphic layer options of image 1 of newFrame
    set current visibility of graphic layer 1 of glOptions to false
    end tell
    Shane Stanley <[email protected]>
    AppleScript Pro, April 2010, Florida <http://www.applescriptpro.com>

Maybe you are looking for

  • Taking long time to initialize planning area.

    Hi All, Few questions on initalizing planning are. We have about 500000 CVC and 8 millions records in it.  We have recently upgradd to SCM 7.0. I am noticing now that every time we run background job to create CVC and initialize planning are, I notic

  • Configuring Lync 2010 Mobility with Front end and Edge Server

    I have been racking my brain the past week trying to figure out how to get the lync edge server working properly and how to get the mobility service working properly. Currently I have 1 front end server that is configured and working.  I have one edg

  • I accidentally deleted the "Recently Added" playlist from my iTunes Library

    I accidentally deleted my "Recently Added" file that comes as one of the standard files with the iTunes program. I have been unable to get it back and sure would like this file as it is easier to trace new additions. Anyone know how I can do this? I

  • What's best practice to make batteries last longer?

    Hi I've recently had to replace my Macbook Pro 6,1 (Mid 2010) laptop battery, it had about 440 cycles. I'm not that keen on having to fork out for another one in the future. So what's the best way to keep your macbook pro battery in good condition, r

  • Network backups?  Anyone tried Retrospect with Mozi?

    I'll admit it, I'm still working on my overall backup strategy.. I've got 2 mac's, a couple of PC's and now a deprecated FreeBSD server waiting to find a new home. Currently all of my important data is on my Mac Mini server. In perusing my options, I