LabPython does not function after being built into an executable application (am i missing DLLs or Paths?)

Greetings!!
I have recently been playing around with the amazing power of Python in Labview and have built some very functional VIs that utilize this tactic. However I now find myself at a bind. Everything runs great in the IDE, but not so great as a standalone application.
i am running:
Windows 7 64bit
Labview 2012 32bit
Python 2.7.3 32bit
My build specifications configuration attempts have all failed to run Python, and the application typically always return a very non descriptive error such as:
PYTHON New Session__ogtk.vi->NameOfMyVIFile.vi
I have tried adding DLLs to the "always include" section of the build spec.
DLLs such as:
Lvpython.dll
pytscript.dll
and I have even tried including them in both the support directory and the caller's directory to no avail. I have even tried placing the entire application + supporting files in my main Labview and python directories just to see their behavior with no apparent differences.
so now I’m left with no options that i can think of. and I'm sure I have crawled around Google so much now that I’ve read all the same posts and websites nearly three times already.
Please help me debug this!! I’m sure it’s something super simple but not very obvious that I’m missing.
I hope everyone has a great day, and thank you!
Grant.
Solved!
Go to Solution.

My python installation folder is "C:\Python27" and python27.dll is located in there.
initially i ran the "PYTHON Set Server Path" with an input string equal to: 'C:\Python27\python27.dll' while in the IDE. i have read however that (as long as the system path in windows is configured correctly) passing a string of just 'python27.dll' would work, but i did not try this.
after that the "PYTHON Script Node" is what i used to test LabPython and all's ok in the IDE but not in applications.
i have also tried this as an executable:
Which porduces this:

Similar Messages

  • Firewire does not function after uninstalling macfuse and an out of date version of NTFS32 and then installed latest version of Tuxera NTFS for Mac.

    I purchased a 3TB HDD (WD USB 3.0 $100) to replace the 2TB Seagate for a new Time Machine HDD. The 2B was full and backups were deleting older files. The 3TB was formatted NTFS and I want to "recover" the included SW before I reformatted the HDD for the iMac. I discovered that MacFuse was out of date and unsupported and my NTFS-32 was also out of date so I uninstalled both and then installed the most recent version of Tuxera NTFS for Mac. I rebooted and discovered that the FW800 port was unresponsive. Below is the EtreCheck report:
    Problem description:
    Firewire does not function after uninstalling macfuse and an out of date version of NTFS32 and then installed Tuxera NTFS for Mac.
    EtreCheck version: 2.0.8 (95)
    Report generated October 30, 2014 7:11:17 PM EDT
    Hardware Information: ℹ️
      iMac (24-inch Mid 2007) (Verified)
      iMac - model: iMac7,1
      1 2.8 GHz Intel Core 2 Duo CPU: 2-core
      4 GB RAM
      BANK 0/DIMM0
      2 GB DDR2 SDRAM 667 MHz ok
      BANK 1/DIMM1
      2 GB DDR2 SDRAM 667 MHz ok
      Bluetooth: Old - Handoff/Airdrop2 not supported
      Wireless:  en1: 802.11 a/b/g/n
    Video Information: ℹ️
      ATI,RadeonHD2600 - VRAM: 256 MB
      iMac 1920 x 1200
    System Software: ℹ️
      OS X 10.8.5 (12F45) - Uptime: 0:17:34
    Disk Information: ℹ️
      WDC WD5000AAKS-40TMA0 disk0 : (500.11 GB)
      S.M.A.R.T. Status: Verified
      disk0s1 (disk0s1) <not mounted> : 210 MB
      ML 10.8 (disk0s2) /  [Startup]: 499.25 GB (20.92 GB free)
      Recovery HD (disk0s3) <not mounted>  [Recovery]: 650 MB
    USB Information: ℹ️
      Apple Inc. Built-in iSight
      Apple Computer, Inc. IR Receiver
      Logitech USB Receiver
      Apple Inc. Bluetooth USB Host Controller
    Gatekeeper: ℹ️
      Mac App Store and identified developers
    Kernel Extensions: ℹ️
      /Applications/Hardware Monitor ƒ/HardwareMonitor.app
      [loaded] com.bresink.driver.BRESINKx86Monitoring (7.0) Support
      /Applications/Parallels Desktop.app
      [not loaded] com.parallels.kext.hidhook (8.0 18615.948847) Support
      [not loaded] com.parallels.kext.hypervisor (8.0 18615.948847) Support
      [not loaded] com.parallels.kext.netbridge (8.0 18615.948847) Support
      [not loaded] com.parallels.kext.usbconnect (8.0 18615.948847) Support
      [not loaded] com.parallels.kext.vnic (8.0 18615.948847) Support
      /Applications/Toast Titanium v11.1/Spin Doctor.app
      [not loaded] com.hzsystems.terminus.driver (4) Support
      /Applications/Toast Titanium/Toast Titanium v11.1 (1072).app
      [not loaded] com.roxio.TDIXController (2.0) Support
      /Library/Application Support/Symantec/AntiVirus
      [loaded] com.symantec.kext.SymAPComm (12.2f1 - SDK 10.6) Support
      /System/Library/Extensions
      [loaded] com.Logitech.Control Center.HID Driver (3.9.0 - SDK 10.6) Support
      [loaded] com.eltima.ElmediaPlayer.kext (1.58 - SDK 10.4) Support
      [not loaded] com.hzsystems.driver.CDSDAudioCaptureSupport (1.5) Support
      [not loaded] com.increw.kext.speedit (0.32) Support
      [loaded] com.logitech.manager.kernel.driver (4.10.0 - SDK 10.8) Support
      [not loaded] com.olympus.CamBlockCommandsDevice (2.0.0) Support
      [not loaded] com.olympus.CamBlockCommandsDeviceUP (2.0.0) Support
      [not loaded] com.palm.ClassicNotSeizeDriver (3.2.1) Support
      [not loaded] com.roxio.BluRaySupport (1.1.6) Support
      [not loaded] com.seagate.driver.PowSecDriverCore (5.1.1) Support
      [loaded] com.symantec.kext.internetSecurity (5.2f1 - SDK 10.6) Support
      [loaded] com.symantec.kext.ips (3.5f1 - SDK 10.6) Support
      [loaded] com.symantec.kext.ndcengine (1.0f1 - SDK 10.6) Support
      [loaded] com.taoeffect.ispy.kext (2.0.2 - SDK 10.2) Support
      /System/Library/Extensions/OlympusDSCDriver.kext/Contents/PlugIns
      [not loaded] com.olympus.CamFWSerialBusProtocolTransport (2.0.0) Support
      [not loaded] com.olympus.CamUSBMassStorageClass (2.0.0) Support
      /System/Library/Extensions/Seagate Storage Driver.kext/Contents/PlugIns
      [not loaded] com.seagate.driver.PowSecLeafDriver_10_4 (5.1.1) Support
      [not loaded] com.seagate.driver.PowSecLeafDriver_10_5 (5.1.1) Support
      [not loaded] com.seagate.driver.SeagateDriveIcons (5.1.1) Support
      /Users/[redacted]/Downloads/LCC Installer.app
      [not loaded] com.Logitech.Unifying.HID Driver (1.3.1 - SDK 10.8) Support
    Startup Items: ℹ️
      TuxeraNTFSUnmountHelper: Path: /Library/StartupItems/TuxeraNTFSUnmountHelper
      Startup items are obsolete and will not work in future versions of OS X
    Launch Agents: ℹ️
      [running] com.canon.MFManager.plist Support
      [not loaded] com.cooliris.SetLaunchArch.plist Support
      [loaded] com.google.keystone.agent.plist Support
      [running] com.Logitech.Control Center.Daemon.plist Support
      [running] com.logitech.manager.daemon.plist Support
      [running] com.micromat.TechToolProAgent.plist Support
      [loaded] com.oracle.java.Java-Updater.plist Support
      [running] com.seagate.SeagateStorageGauge.plist Support
      [running] com.symantec.uiagent.application.plist Support
    Launch Daemons: ℹ️
      [loaded] com.adobe.fpsaud.plist Support
      [running] com.cleverfiles.cfbackd.plist Support
      [running] com.eltima.ElmediaPlayer.daemon.plist Support
      [loaded] com.embraceware.awaken.plist Support
      [loaded] com.google.keystone.daemon.plist Support
      [loaded] com.macpaw.CleanMyMac2.Agent.plist Support
      [running] com.micromat.TechToolProDaemon.plist Support
      [loaded] com.microsoft.office.licensing.helper.plist Support
      [loaded] com.oracle.java.Helper-Tool.plist Support
      [loaded] com.oracle.java.JavaUpdateHelper.plist Support
      [loaded] com.prosofteng.DriveGenius.locum.plist Support
      [running] com.smithmicro.schedulerdaemon.plist Support
      [loaded] com.symantec.liveupdate.daemon.ondemand.plist Support
      [failed] com.symantec.liveupdate.daemon.plist Support
      [not loaded] com.symantec.sep.migratesettings.plist Support
      [running] com.symantec.sharedsettings.plist Support
      [running] com.symantec.symdaemon.plist Support
      [running] com.taoeffect.ispyd.plist Support
      [running] com.wdc.drivemanagerservice.plist Support
    User Launch Agents: ℹ️
      [loaded] com.adobe.ARM.[...].plist Support
      [loaded] com.macpaw.CleanMyMac2Helper.diskSpaceWatcher.plist Support
      [loaded] com.macpaw.CleanMyMac2Helper.scheduledScan.plist Support
      [loaded] com.macpaw.CleanMyMac2Helper.trashWatcher.plist Support
      [running] com.prosofteng.DGMonitor.plist Support
      [running] com.smithmicro.cleaning.schedulermailer.plist Support
      [running] com.taoeffect.EspionageHelper.plist Support
    User Login Items: ℹ️
      Speedy Mac Application (/Applications/Speedy Mac/Speedy Mac.app)
      AwakenHelper Application (/Users/[redacted]/Library/Application Support/Awaken/AwakenHelper.app)
      GetBackupAgent Application (/Users/[redacted]/Library/Application Support/BeLight Software/Get Backup 2/GetBackupAgent.app)
      WDDriveUtilityHelper Application (/Users/[redacted]/Downloads/WD/WD Drive Utilities.app/Contents/Resources/WDDriveUtilityHelper.app)
      ClustersHelper Application (/Library/PreferencePanes/Clusters.prefPane/Contents/Resources/ClustersHelper.a pp)
      RealPlayer Downloader Agent Application (/Users/[redacted]/Library/Application Support/RealNetworks/RealPlayer Downloader Agent.app)
      SAVDiskMountNotify UNKNOWN (missing value)
      ScanNotification UNKNOWN (missing value)
      Launch Nikon Message Center 2 Application (/Applications/Nikon Software/Nikon Message Center 2/Nikon Message Center 2.app/Contents/SharedSupport/Launch Nikon Message Center 2.app)
    Internet Plug-ins: ℹ️
      EPPEX Plugin: Version: 10.0 Support
      Flash Player: Version: 15.0.0.189 - SDK 10.6 Support
      AdobePDFViewer: Version: 9.4.6 Support
      Unity Web Player: Version: UnityPlayer version 3.5.3f3 - SDK 10.6 Support
      NPVirtools: Version: 4.0 Support
      iPhotoPhotocast: Version: 7.0 - SDK 10.8
      RealPlayer Plugin: Version: (null) Support
      DirectorShockwave: Version: 11.6.8r638 Support
      QuickTime Plugin: Version: 7.7.1
      FlashPlayer-10.6: Version: 15.0.0.189 - SDK 10.6 Support
      GarminGpsControl: Version: 2.9.3.0 Release Support
      ToontownBundleManager: Version: (null) Support
      CANONiMAGEGATEWAYDL: Version: 3.1.0.2 Support
      Silverlight: Version: 5.1.10411.0 - SDK 10.6 Support
      OVSHelper: Version: 1.0 Support
      CoolirisWebKitPlugin: Version: (null) Support
      Google Earth Web Plug-in: Version: 6.1 Support
      Flip4Mac WMV Plugin: Version: 3.2.0.16   - SDK 10.8 Support
      SharePointBrowserPlugin: Version: 14.4.4 - SDK 10.6 Support
      JavaAppletPlugin: Version: Java 7 Update 67 Check version
      OfficeLiveBrowserPlugin: Version: 12.3.6 Support
    User Internet Plug-ins: ℹ️
      BrowserPlus_2.9.2: Version: 2.9.2 Support
      Picasa: Version: 1.0 Support
    Safari Extensions: ℹ️
      DivX Plus Web Player HTML5 <video>
      Open in Internet Explorer
      DivX HiQ
      Aimersoft Video Converter
    3rd Party Preference Panes: ℹ️
      BrowserPlus  Support
      Clusters  Support
      Déjà Vu  Support
      Flash Player  Support
      Flip4Mac WMV  Support
      Java  Support
      Logitech Control Center  Support
      Logi Preference Manager  Support
      MenuMeters  Support
      Perian  Support
      Symantec QuickMenu  Support
      TechTool Protection  Support
      Tuxera NTFS  Support
    Time Machine: ℹ️
      Skip System Files: NO
      Auto backup: YES
      Destinations:
      iMac TimeMachine [Local]
      Total size: 2 TB
      Total number of backups: 80
      Oldest backup: 2011-09-18 05:21:33 +0000
      Last backup: 2014-10-05 20:18:55 +0000
      Size of backup disk: Excellent
      Backup size 2 TB > (Disk size 0 B X 3)
      /sbin excluded from backup!
      /usr excluded from backup!
      /System excluded from backup!
      /bin excluded from backup!
      /private excluded from backup!
      /Library excluded from backup!
      /Applications excluded from backup!
    Top Processes by CPU: ℹ️
          2% WindowServer
          0% Speedy
          0% SystemUIServer
          0% RealPlayer Downloader Agent
          0% ps
    Top Processes by Memory: ℹ️
      288 MB SymDaemon
      150 MB Speedy
      137 MB Safari
      82 MB WebProcess
      82 MB coreservicesd
    Virtual Memory Information: ℹ️
      2.17 GB Free RAM
      1.46 GB Active RAM
      148 MB Inactive RAM
      518 MB Wired RAM
      388 MB Page-ins
      0 B Page-outs
    I hope someone has some ideas! TIA.

    Do you have another cable you can test with? Do you have access to another computer with Firewire you can test with?
    FireWire Device not Working
    FireWire/USB - Quick Assist

  • Satellite L870-165 does not work after being repaired by their service

    Laptop Toshiba warranty does not work after being repaired by their service twice.
    Model: Satellite L870-165
    Computer will not boot, stays with black screen stating: No bootable device-Please restart your system
    After reboot still happening the same.
    I called Toshiba phone incident and after trying several options I said take him to repair the service.
    They first told me it was the hard drive, then phoned me to indicate that reinstalling and finally it was the motherboard, which supposedly changed. The day after being picked computer repair returned to give exactly the same error, only malfunctioned one evening.
    After another call to 902 the Toshiba warranty service, I went back to take the service, this time I changed the hard drive. When I got home the computer did not start even once, again gives the same error.
    I believe that this team comes with a factory default so that its solution is not easy because even the technical service told me that I did not know what else to do with it.

    >Computer will not boot, stays with black screen stating: No bootable device-Please restart your system
    This message pops up because the notebook cannot find the Windows system.
    There could be either an problem with the HDD or maybe the HDD is OK but the Windows system isnt preinstalled properly.
    You said that the service agent changed the HDD. But did someone install the Windows system?
    You can try to do it yourself take your recovery disk (hopefully you created such disk in the past) and boot from the recovery disk in order to install the system.
    In case booting from the Disk would not be possible, go to BIOS (F2) and disable the secure boot and change from UEFI to CSM mode

  • "Finder" does not function after installing Leopard on Mac G5

    After successfully installing Leopard on my (new) MacBook Pro and on my (old:2003) iMac PowerMac 6,1 I tried installing Leopard on my 2005 iMac G5.
    The installation seemed successful, but after restarting the computer I was asked to choose the wireless network from a list. This was not possible. I do not use the Airport on this computer so tried to press "cancel". Could not do this and got the turning rainbow circle which never stopped.
    *The Finder does not function and cannot be restarted. This seems to be the main problem.
    I cannot log off or shut down and have to use the powerbutton to shut down.
    When starting up I do not get the Startup sound. Do get login and can login. But, all my desktop buttons have disappeared and I immediately get a notice that OS X shut down unexpectedly, asking me to cancel or send a report. Neither of these options are possible and the turning rainbow reappears. It's driving me crazy!
    I can sometimes open programs but no longer "system preferences".
    Is there anybody out there who can help me??
    I am especially frustrated since the other two installations on an older and on a newer Mac went well. I use the exact same programs on all three computers.
    HELP!

    After successfully installing Leopard on my (new) MacBook Pro and on my (old:2003) iMac PowerMac 6,1 I tried installing Leopard on my 2005 iMac G5.
    The installation seemed successful, but after restarting the computer I was asked to choose the wireless network from a list. This was not possible. I do not use the Airport on this computer so tried to press "cancel". Could not do this and got the turning rainbow circle which never stopped.
    *The Finder does not function and cannot be restarted. This seems to be the main problem.
    I cannot log off or shut down and have to use the powerbutton to shut down.
    When starting up I do not get the Startup sound. Do get login and can login. But, all my desktop buttons have disappeared and I immediately get a notice that OS X shut down unexpectedly, asking me to cancel or send a report. Neither of these options are possible and the turning rainbow reappears. It's driving me crazy!
    I can sometimes open programs but no longer "system preferences".
    Is there anybody out there who can help me??
    I am especially frustrated since the other two installations on an older and on a newer Mac went well. I use the exact same programs on all three computers.
    HELP!

  • IPad 3 Why 3G does not work after being on WiFi

    When I take my iPad 3 out of my house, I have to reboot it to get a 3G connection. The 3g icon shows that it is connected but when I try and access any connection it says no internet connection. My iPad 1 seemed to work ok. I've also tried putting it in Airplane mode and back again but this has no effect.
    Any suggestions please? Many thanks.

    All of you are not ALONE ! Most of us here in Singapore be it with Singtel, Starhub or M1 3G network, all of us with the "NewiPad" are sharing the same pain of this "Cellular data not connected" problem. When this problem occurred, one must power cycle or at least reset network setting to get the 3G data connection work again. A daily of power cycle 3~5 times for my new iPad was need. All methods like below tried but still DOES NOT fix the problem.
    1. Reset Network setting.
    2. Reset iPad back to default.
    3. Changed Singtel APN name from "e-ideas" to "internet" still the same.
    4. Changed a complete brand new sim card.
    My current fixed was, called up Singtel ISP to reset my iPad 21Mbps 3G Line in their system. In my end, I need to power off my new iPad to complete the cycle. So far it has been working fine for 42 hours now.
    By looking at the "General > About > Cellular Data Number" was "Unknown". This lead me to think it might be a bug in current new iPad iOS 5.1. To be more precise, it might narrow down to the "Big & Bad Qualcomm Radio chipset Driver" problem?
    If that was true, jess.. I truly dislike "Qualcomm inside" devices. It make me come to remembered Dopod/HTC D810 the most funniest released WM device in history. When D810 first hit the market, it does not features any gps function at all when in true fact D810 did come with "Qualcomm" GPS chipset built-in since day 1. Dopod/HTC took more than 6 months to release a very crippled firmware that included Qualcomm GPS chipset driver with lots of trouble and start announce all the customers in the world, including those who's bought D810 more than 6 months ago. What a joke!
    That's not all the "Qualcomm" funny facts. They then hit the wall again with Dopod/HTC Tytn-II, another WM cellphone with "Qualcomm 3D Graphic chip built-in, BUT WITH NO 3D DRIVER BUILT-IN". Hahaha.. what another big "QUALCOMM" historical joke of all time.
    Anyway, hopefully Apple can found the actual trouble or fixed "might be Qualcomm driver problem again?" in the next iOS 5.2 release.
    Until then, I've wishes everyone with the cellular data connection trouble eventually manage to solved your headache in any solutions provided by many and living happier with your new iPad, the same for me.

  • A pop-up window requiring a response does not close after being responded to.

    A club membership database uses pop-up windows to request preferences for displaying information on the database. The window should close after the preference is saved. This closing occurs with Internet Explorer, but not with Firefox. The requested information cannot be retrieved unless the pop-up closes.

    Force Quit .
    Press command + option + esc keys together at the same time.    Wait.
    When Force Quit window appears, select  Safari, if not already.
    Press Force Quit button at the bottom of the window.      Wait.
    Application will quit.
    If this does not help, press the power button for 7 or more seconds.
    Computer will shut down.
    Restart.
    Hold the shift key down and launch Safari.
    Best.

  • Keyboard does not function after mac mini goes idle

    Hi. Interesting issue. New keyboard on my mac mini. Identification of keyboard (cheap Dynex) works fine. If I let mini go idle/screensaver, when it wakes up, it does not recognize the keyboard at all. Cannot manually force it to recognize either. Restart works like a charm and all is good until it goes idle again.
    Anyone seen this? Any ideas?
    Thanks.

    I used a couple of cheapo PC oriented USB keyboards when I got my first Mac mini. They had issues where they would stop working after sleep, screen saver activation, or would start doing double key strokes, and other glitches. Honestly, if it's not an Apple keyboard or specifically made for the Mac, I've always had the keyboard develop issues at some point. I strongly suggest getting a proper Apple or made for Mac keyboard. It has solved all of my keyboard issues.

  • ASA5505 L2L VPN does not function after move and reconfiguration

                       I have an ASA5505 that had multiple VPNs to both Cisco5505's and other Vendor security appliances.  The one in question that moved to a new IP address checks out on isa sa, ipsec sa and nat, yet there is no communication accross the tunnel.  This behavior is consistent accross all remote sites. The remote sites function normally. Below is the output with some show commands.
    ASA Version 8.4(4)
    hostname RitterBars
    names
    name 67.231.37.42 RitterLAB-ASA
    name 67.231.37.45 RitterLAB-LB-WAN1
    name 64.233.131.94 RitterLAB-LB-WAN3
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    switchport access vlan 3
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.1.1 255.255.255.0
    interface Vlan2
    description Port 7 on 9108
    nameif outside
    security-level 0
    ip address dhcp setroute
    interface Vlan3
    no forward interface Vlan2
    nameif CoreNetwork
    security-level 0
    ip address 172.20.10.22 255.255.255.128
    boot system disk0:/asa844-k8.bin
    ftp mode passive
    clock timezone CST -6
    clock summer-time CST recurring
    object network obj-192.168.1.0
    subnet 192.168.1.0 255.255.255.0
    object network obj-192.168.9.0
    subnet 192.168.9.0 255.255.255.0
    object network obj-192.168.85.0
    subnet 192.168.85.0 255.255.255.0
    object network obj-10.200.1.0
    subnet 10.200.1.0 255.255.255.0
    object network obj-192.168.3.0
    subnet 192.168.3.0 255.255.255.0
    object network obj-192.168.1.2
    host 192.168.1.2
    object service obj-tcp-source-eq-22
    service tcp source eq ssh
    object service obj-tcp-source-eq-5922
    service tcp source eq 5922
    object network obj-192.168.1.10
    host 192.168.1.10
    object service obj-tcp-source-eq-5125
    service tcp source eq 5125
    object service obj-tcp-source-eq-80
    service tcp source eq www
    object network obj-192.168.1.119
    host 192.168.1.119
    object service obj-udp-source-eq-69
    service udp source eq tftp
    object network obj-192.168.1.51
    host 192.168.1.51
    object service obj-tcp-source-eq-443
    service tcp source eq https
    object service obj-tcp-source-eq-5980
    service tcp source eq 5980
    object network obj-192.168.1.114
    host 192.168.1.114
    object network obj-96.43.39.27
    host 96.43.39.27
    object network obj-xxx.xxx.xxx.xxx
    host xxx.xxx.xxx.xxx
    object-group network Inside
    network-object 192.168.1.0 255.255.255.0
    access-list split-tunnel extended permit ip 192.168.1.0 255.255.255.0 192.168.9.0 255.255.255.0
    access-list no_nat extended permit ip 192.168.1.0 255.255.255.0 192.168.9.0 255.255.255.0
    access-list no_nat extended permit ip 192.168.1.0 255.255.255.0 192.168.85.0 255.255.255.0
    access-list no_nat extended permit ip 192.168.1.0 255.255.255.0 10.200.1.0 255.255.255.0
    access-list no_nat extended permit ip 192.168.1.0 255.255.255.0 192.168.3.0 255.255.255.0
    access-list VPN2LAB extended permit ip 192.168.1.0 255.255.255.0 192.168.85.0 255.255.255.0
    access-list VPN2LAB extended permit ip 192.168.1.0 255.255.255.0 10.200.1.0 255.255.255.0
    access-list Barracudalab extended permit ip 192.168.1.0 255.255.255.0 192.168.3.0 255.255.255.0
    access-list inat extended permit ip 192.168.1.0 255.255.255.0 any
    access-list vnat extended permit ip 192.168.1.0 255.255.255.0 host 216.163.29.244
    access-list out2in extended permit tcp host 64.233.128.6 host 192.168.1.2 eq ssh
    access-list out2in extended permit tcp 64.233.128.0 255.255.255.0 host 192.168.1.2 eq ssh
    access-list out2in extended permit tcp 64.233.128.0 255.255.255.0 host 192.168.1.10 eq 5125
    access-list out2in extended permit tcp 64.233.128.0 255.255.255.0 host 192.168.1.10 eq www
    access-list out2in extended permit udp 64.233.128.0 255.255.255.0 host 192.168.1.119 eq tftp
    access-list out2in extended permit tcp 64.233.128.0 255.255.255.0 host 192.168.1.51 eq https
    access-list out2in extended permit ip 64.233.128.0 255.255.255.0 192.168.1.0 255.255.255.0
    access-list out2in extended permit tcp any host 192.168.1.10 eq 5125
    access-list out2in extended permit tcp any host 192.168.1.10 eq www
    access-list out2in extended permit tcp any 192.168.1.0 255.255.255.0 eq ftp
    access-list out2in extended permit tcp any 192.168.1.0 255.255.255.0 eq ftp-data
    access-list out2in extended permit udp any host 192.168.1.119 eq tftp
    access-list out2in extended permit tcp any host 192.168.1.51 eq https
    access-list out2in extended permit icmp any any
    pager lines 24
    logging console alerts
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    mtu CoreNetwork 1500
    ip local pool vpn-pool 192.168.9.10-192.168.9.250
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-649.bin
    no asdm history enable
    arp timeout 14400
    nat (inside,any) source static obj-192.168.1.0 obj-192.168.1.0 destination static obj-192.168.9.0 obj-192.168.9.0 no-proxy-arp
    nat (inside,any) source static obj-192.168.1.0 obj-192.168.1.0 destination static obj-192.168.85.0 obj-192.168.85.0 no-proxy-arp
    nat (inside,any) source static obj-192.168.1.0 obj-192.168.1.0 destination static obj-10.200.1.0 obj-10.200.1.0 no-proxy-arp
    nat (inside,any) source static obj-192.168.1.0 obj-192.168.1.0 destination static obj-192.168.3.0 obj-192.168.3.0 no-proxy-arp
    nat (inside,outside) source static obj-192.168.1.2 interface service obj-tcp-source-eq-22 obj-tcp-source-eq-5922
    nat (inside,outside) source static obj-192.168.1.10 interface service obj-tcp-source-eq-5125 obj-tcp-source-eq-5125
    nat (inside,outside) source static obj-192.168.1.10 interface service obj-tcp-source-eq-80 obj-tcp-source-eq-80
    nat (inside,outside) source static obj-192.168.1.119 interface service obj-udp-source-eq-69 obj-udp-source-eq-69
    nat (inside,outside) source static obj-192.168.1.51 interface service obj-tcp-source-eq-443 obj-tcp-source-eq-5980
    nat (inside,outside) source static obj-192.168.1.114 obj-96.43.39.27
    nat (inside,CoreNetwork) source dynamic obj-192.168.1.0 interface destination static obj-xxx.xxx.xxx.xxx obj-xxx.xxx.xxx.xxx
    nat (inside,outside) source dynamic Inside interface
    nat (inside,outside) after-auto source dynamic any interface
    access-group out2in in interface outside
    route CoreNetwork 172.20.30.0 255.255.255.248 172.20.10.1 1
    route CoreNetwork 216.163.29.244 255.255.255.255 172.20.10.1 1
    timeout xlate 3:00:00
    timeout pat-xlate 0:00:30
    timeout conn 0:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    user-identity default-domain LOCAL
    aaa authentication ssh console LOCAL
    http server enable
    http 192.168.1.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec ikev1 transform-set psset esp-aes-256 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto map samap 1 match address VPN2LAB
    crypto map samap 1 set peer RitterLAB-ASA
    crypto map samap 1 set ikev1 transform-set ESP-AES-256-SHA
    crypto map samap 2 match address Barracudalab
    crypto map samap 2 set peer RitterLAB-LB-WAN1 RitterLAB-LB-WAN3
    crypto map samap 2 set ikev1 transform-set ESP-3DES-SHA
    crypto map samap interface outside
    crypto isakmp identity address
    crypto ikev1 enable outside
    crypto ikev1 policy 10
    authentication pre-share
    encryption aes-256
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 11
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    telnet timeout 5
    ssh 192.168.1.0 255.255.255.0 inside
    ssh timeout 5
    ssh key-exchange group dh-group1-sha1
    console timeout 0
    management-access inside
    dhcpd dns 64.233.128.10 64.233.128.11
    dhcpd auto_config outside
    dhcpd address 192.168.1.100-192.168.1.150 inside
    dhcpd enable inside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    ntp server 66.187.233.4 source outside
    ntp server 64.99.80.30 source outside
    webvpn       
    username xxx.xxx.xxx.xxx password xxx.xxx.xxx.xxx encrypted privilege 15
    username xxx.xxx.xxx.xxx attributes
    vpn-group-policy WebVPNpolicy
    username xxx.xxx.xxx.xxx password xxx.xxx.xxx.xxx encrypted privilege 15
    username xxx.xxx.xxx.xxx attributes
    vpn-group-policy WebVPNpolicy
    tunnel-group 67.231.37.42 type ipsec-l2l
    tunnel-group 67.231.37.42 ipsec-attributes
    ikev1 pre-shared-key xxx.xxx.xxx.xxx
    tunnel-group 67.231.37.45 type ipsec-l2l
    tunnel-group 67.231.37.45 ipsec-attributes
    ikev1 pre-shared-key xxx.xxx.xxx.xxx
    tunnel-group 64.233.131.94 type ipsec-l2l
    tunnel-group 64.233.131.94 ipsec-attributes
    ikev1 pre-shared-key xxx.xxx.xxx.xxx
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect netbios
      inspect rsh
      inspect rtsp
      inspect skinny 
      inspect esmtp
      inspect sqlnet
      inspect sunrpc
      inspect xdmcp
      inspect ip-options
      inspect tftp
    service-policy global_policy global
    prompt hostname context
    no call-home reporting anonymous
    call-home
    profile CiscoTAC-1
      no active
      destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
      destination address email [email protected]
      destination transport-method http
      subscribe-to-alert-group diagnostic
      subscribe-to-alert-group environment
      subscribe-to-alert-group inventory periodic monthly
      subscribe-to-alert-group configuration periodic monthly
      subscribe-to-alert-group telemetry periodic daily
    Cryptochecksum:bcdf7281cbf323ff6af7457149529a5b
    : end
    RitterBars# sh isa sa
    IKEv1 SAs:
       Active SA: 2
        Rekey SA: 0 (A tunnel will report 1 Active and 1 Rekey SA during rekey)
    Total IKE SA: 2
    1   IKE Peer: 67.231.37.45
        Type    : L2L             Role    : responder
        Rekey   : no              State   : MM_ACTIVE
    2   IKE Peer: 67.231.37.42
        Type    : L2L             Role    : initiator
        Rekey   : no              State   : MM_ACTIVE
    There are no IKEv2 SAs
    RitterBars# sh ipsec sa
    interface: outside
        Crypto map tag: samap, seq num: 1, local addr: 96.43.41.168
          access-list VPN2LAB extended permit ip 192.168.1.0 255.255.255.0 192.168.85.0 255.255.255.0
          local ident (addr/mask/prot/port): (192.168.1.0/255.255.255.0/0/0)
          remote ident (addr/mask/prot/port): (192.168.85.0/255.255.255.0/0/0)
          current_peer: 67.231.37.42
          #pkts encaps: 4, #pkts encrypt: 4, #pkts digest: 4
          #pkts decaps: 0, #pkts decrypt: 0, #pkts verify: 0
          #pkts compressed: 0, #pkts decompressed: 0
          #pkts not compressed: 4, #pkts comp failed: 0, #pkts decomp failed: 0
          #pre-frag successes: 0, #pre-frag failures: 0, #fragments created: 0
          #PMTUs sent: 0, #PMTUs rcvd: 0, #decapsulated frgs needing reassembly: 0
          #send errors: 0, #recv errors: 0
          local crypto endpt.: 96.43.41.168/0, remote crypto endpt.: 67.231.37.42/0
          path mtu 1500, ipsec overhead 74, media mtu 1500
          current outbound spi: 6F98A015
          current inbound spi : 6DD466F0
        inbound esp sas:
          spi: 0x6DD466F0 (1842636528)
             transform: esp-aes-256 esp-sha-hmac no compression
             in use settings ={L2L, Tunnel, }
             slot: 0, conn_id: 1122304, crypto-map: samap
             sa timing: remaining key lifetime (kB/sec): (4374000/28182)
             IV size: 16 bytes
             replay detection support: Y
             Anti replay bitmap:
              0x00000000 0x00000001
        outbound esp sas:
          spi: 0x6F98A015 (1872273429)
             transform: esp-aes-256 esp-sha-hmac no compression
             in use settings ={L2L, Tunnel, }
             slot: 0, conn_id: 1122304, crypto-map: samap
             sa timing: remaining key lifetime (kB/sec): (4373999/28182)
             IV size: 16 bytes
             replay detection support: Y
             Anti replay bitmap:
              0x00000000 0x00000001
        Crypto map tag: samap, seq num: 2, local addr: 96.43.41.168
          access-list Barracudalab extended permit ip 192.168.1.0 255.255.255.0 192.168.3.0 255.255.255.0
          local ident (addr/mask/prot/port): (192.168.1.0/255.255.255.0/0/0)
          remote ident (addr/mask/prot/port): (192.168.3.0/255.255.255.0/0/0)
          current_peer: 67.231.37.45
          #pkts encaps: 0, #pkts encrypt: 0, #pkts digest: 0
          #pkts decaps: 0, #pkts decrypt: 0, #pkts verify: 0
          #pkts compressed: 0, #pkts decompressed: 0
          #pkts not compressed: 0, #pkts comp failed: 0, #pkts decomp failed: 0
          #pre-frag successes: 0, #pre-frag failures: 0, #fragments created: 0
          #PMTUs sent: 0, #PMTUs rcvd: 0, #decapsulated frgs needing reassembly: 0
          #send errors: 0, #recv errors: 0
          local crypto endpt.: 96.43.41.168/0, remote crypto endpt.: 67.231.37.45/0
          path mtu 1500, ipsec overhead 58, media mtu 1500
          current outbound spi: 51AF17EA
          current inbound spi : 859BC586
        inbound esp sas:
          spi: 0x859BC586 (2241578374)
             transform: esp-3des esp-sha-hmac no compression
             in use settings ={L2L, Tunnel, }
             slot: 0, conn_id: 1118208, crypto-map: samap
             sa timing: remaining key lifetime (sec): 28152
             IV size: 8 bytes
             replay detection support: Y
             Anti replay bitmap:
              0x00000000 0x00000001
        outbound esp sas:
          spi: 0x51AF17EA (1370429418)
             transform: esp-3des esp-sha-hmac no compression
             in use settings ={L2L, Tunnel, }
             slot: 0, conn_id: 1118208, crypto-map: samap
             sa timing: remaining key lifetime (sec): 28152
             IV size: 8 bytes
             replay detection support: Y
             Anti replay bitmap:
              0x00000000 0x00000001
    RitterBars# sh nat int inside
    Manual NAT Policies (Section 1)
    1 (inside) to (any) source static obj-192.168.1.0 obj-192.168.1.0   destination static obj-192.168.9.0 obj-192.168.9.0 no-proxy-arp
        translate_hits = 0, untranslate_hits = 0
    2 (inside) to (any) source static obj-192.168.1.0 obj-192.168.1.0   destination static obj-192.168.85.0 obj-192.168.85.0 no-proxy-arp
        translate_hits = 18, untranslate_hits = 0
    3 (inside) to (any) source static obj-192.168.1.0 obj-192.168.1.0   destination static obj-10.200.1.0 obj-10.200.1.0 no-proxy-arp
        translate_hits = 0, untranslate_hits = 0
    4 (inside) to (any) source static obj-192.168.1.0 obj-192.168.1.0   destination static obj-192.168.3.0 obj-192.168.3.0 no-proxy-arp
        translate_hits = 0, untranslate_hits = 0
    5 (inside) to (outside) source static obj-192.168.1.2 interface   service obj-tcp-source-eq-22 obj-tcp-source-eq-5922
        translate_hits = 0, untranslate_hits = 0
    6 (inside) to (outside) source static obj-192.168.1.10 interface   service obj-tcp-source-eq-5125 obj-tcp-source-eq-5125
        translate_hits = 0, untranslate_hits = 9094
    7 (inside) to (outside) source static obj-192.168.1.10 interface   service obj-tcp-source-eq-80 obj-tcp-source-eq-80
        translate_hits = 0, untranslate_hits = 126
    8 (inside) to (outside) source static obj-192.168.1.119 interface   service obj-udp-source-eq-69 obj-udp-source-eq-69
        translate_hits = 0, untranslate_hits = 0
    9 (inside) to (outside) source static obj-192.168.1.51 interface   service obj-tcp-source-eq-443 obj-tcp-source-eq-5980
        translate_hits = 0, untranslate_hits = 195
    10 (inside) to (outside) source static obj-192.168.1.114 obj-96.43.39.27 
        translate_hits = 0, untranslate_hits = 0
    11 (inside) to (CoreNetwork) source dynamic obj-192.168.1.0 interface   destination static obj-216.163.29.244 obj-216.163.29.244
        translate_hits = 107, untranslate_hits = 0
    12 (inside) to (outside) source dynamic Inside interface 
        translate_hits = 35387, untranslate_hits = 2940
    Manual NAT Policies (Section 3)
    1 (inside) to (outside) source dynamic any interface 
        translate_hits = 291, untranslate_hits = 78

    I just recently got the triple play package from verizon with fios too.  And of course the Actiontec is total crap.  The very first night it rebooted over and over again.  What good is an internet connection you can't use right... Anyways, I have a cisco 831 that i use for a VPN to work, and so, I decided to put that up front.
    Anyways, had the same problem.  First I setup my router to bridge the connetion from the Actiontec to my router.  So it goes Broadband Moca -> Actiontec LAN -(eth cable)-> Cisco WAN port.  This worked great, except now my vod didn't work.  So then I found this article....
    http://www.dslreports.com/forum/r19559467-How-To-MI424WR-Network-Bridge-working-FIOS-TV
    It was genius, add a second bridge from the Cisco LAN -(eth cable)-> Actiontec WAN -> local Moca.    And then put DHCP relay on the bridge.  Everything worked again, hooray.  then I added an access list, and there went my vod again. 
    So then I spent about two hours turning ports on and off and such, finally I figured it out.  You'll need to allow inbound established tcp connections that internal hosts create.  This will get back your guide and allow the vod menu to work again.  then you have to allow inbound connections on udp port 21310.  I applied it and lo and behold vod is back.  Now my only problem is that the 831 only has a 10 Mb/s ethernet WAN, so I can't get HD VOD but ah well.  I'll upgrade one of these days to an 851 or 871.
    Here's what the access lists should look like in IOS:
    permit tcp any host (your external IP address) established
    permit udp any host (your external IP address) eq 21310
    probably is going to be a little bit different since you have an ASA but I think you get the idea.

  • 5112 trig input does not function after selfcalibration ?

    After starting the selfcalibration on 5112, the Trig input seems not to function as before.
    This occurred after installation of a new driver "NI-SCOPE 2.90"
    Driver: NI-SCOPE 2.90, Model: NI PXI-5112, Compiler: MSVC 7.10, Engine: IVI 2.04, Compiler: MSVC 7.10, Components: VISA-Spec 3.00
    Can i revert to factory default ?
    Thanks in advance, John

    Correction !!
    This behavior was not caused by the driver installation but the trigger input has an 500mV accuracy.
    My signal was smaller then 500mVtt so the self calibration calibrated
    the levels of the trigger input somewhat different and my triggering
    was lost.
    Thats why my conclusion was wrong!!
    John

  • Hyperlinks Not Function After Being Published

    Hello,
    I've recently switched over to iWeb 08 and really dig all the new functions. I am running into one spot of trouble and hope that someone might shed some light on it for me.
    I've got a few images that I use as hyperlinks rather than text. The hyperlinks are fully functional while in iWeb and everything is fine in the inspector window, yet when I publish the site, the links are no longer operational. Some of the text links have now decided to stop working as well.
    The non-functioning thumbnail links are at:
    http://www.lolabydesign.com/LolaByDesign/Bead_Gallery.html
    The non-functioning text links are at:
    http://www.lolabydesign.com/LolaByDesign/Shop_Instructions.html
    I publish to my desktop, then use Fetch to upload the files to my host at netrfirms.
    This seems kind of random as other links on the site work fine, and I have never run into this problem before.
    Anyone have a quick fix for this one? As the images are thumbnails which point towards the full-size image, using text is not an option in this case.
    Thanks in advance!
    ~Lola

    Hi,
    there's this shapeimage
    http://www.lolabydesign.com/LolaByDesign/ShopInstructions_files/shapeimage4.png
    in front of the links, thus they do not work.
    If you can send that to back (select, ctrlclicksend back)
    Regards,
    Cédric

  • Ir remote does'not function after upgrading from Vista to Windows 7

    I just upgraded to Windows 7 Pro from Vista Home Premium. I was able to get most of my drivers to work; however, I was not able to find th edrivers/software for my IR remote control. Has anyone else figured this issue out, or what drivers/software I should get fix the error? Thank you.

    ArtAppreciator,  I have the same problem. Installed Windows 7 and now my HP USB TV Tuner is not working. Worked fine on Vista. I can get passed the signal setup but get an error when Media Center tries to detect the IR receiver. Any thoughts?

  • Microphone does not function after installing Windows 7 RC on a HP Mini 1000 (1030NR)

    Hi. I recently purchased a HP Mini 1000 (1030NR) and upgraded it to Windows 7 Release Canidate. After install, I added the trackpad drivers, and everything else works fine except for the microphone. The computer recognizes it but when I speak nothing happens. The volume is turned up, and if I turn up the Mic Boost, all I hear is static. I have installed what I think are the correct drivers from another poster, to no avail. Also, there are no errors in the device manager. ANy ideas?
    Thank you in advance. 

    As a tempory measure search for SP40662 this package will enable the mic but there is a catch (isnt there always). The catch is that the mic is going to be recognized as the external one and if you plug in headphones you will have to reboot the mini to use the internal mic again. Im using the same set up right now and it works fairly well. Just hope that HP decides to bestow upon us the proper drivers for the mini soon.

  • VI works in IDE, not after being built

    This is going to be a little long, but I'm not sure I have a choice. I'm using Mark Yedinak's SNMP v1 driver in LV2014 32-bit to talk to a Dell G756N rack mounted power distribution unit (think fancy power strip). My code works just fine in the IDE, but causes the program to freeze after I have built it into an executable. I have no idea what is wrong. I built a simpler example VI intending to have an easy example project (Classy Talker.vi in the SNMP Talk project) of where the VI breaks down, but it seems to work even after being built into an .exe. I built the InitializePDU.vi (the one that works) in the SNMP Talk project by dragging the innards of the problem vi (InitializeEquipment.vi in the Dell Power Supply Testing project, this one doesn't work after being built), so they should be identical.
    Using logs, I've been able to track which one is the problem vi. It's the Get snmp Item(s).vi in Mark's snmp communication.llb. Here is a picture of where it fails according to my LVLog.txt file:
    To recap:
    In the Dell Power Supply Testing project
    The Data Collection Quick Shot.vi under "Main" calls Initialize All Equipment Data-Clock.vi. The Initialize All Equipment Data-Clock.vi is responsible for reading the Equipment Config.xml file and presenting the user with choices of equipment to use with the program. The .vi then uses a factory pattern to initialize chosen equipment. 5 of the equipment types work, but the Power Distribution Unit will not complete verification after being built into an executable (this is event 10, "PDU Verifiy), but works fine in the IDE. Using logs, the probelm occurs after the class is cast to the specific class in the InitializeEquipment.vi found under "Hardware\Power Distribution Unit\DellG756N\" when it call Mark Yedinak's Get snmp Item(s).vi from his snmp communications.llb.
    The SNMP Talk project was created to be similar to the problem areas of the Dell Power Supply Testing project. I was hoping it would be a simpler example so that I could get help, but to my suprise it works just fine even after being built into an executable.
    The Classy Talker.vi casts the GenericPDU class to the DellG756N class, and uses the InitializePDU.vi which is the equivalent to the problem vi InitializeEquipment.vi in the Dell Power Supply Testing project. It then just reads the manufacturer and part number from the supply, which is also done in the same manner as the InitializePDU.vi.
    Any help on why one built executable work and the other does not would be really appreciated.
    Thanks,
    Simon
    P.S. I couldn't power the Power Supply Testing project here because it is 54MB, so here is a link to it in my dropbox:
    https://dl.dropboxusercontent.com/u/10871313/Power​%20Supply%20Testing.zip
    Solved!
    Go to Solution.
    Attachments:
    SNMP Talk.zip ‏1123 KB
    LVLog.txt ‏1 KB
    snmp communication.zip ‏470 KB

    To follow up, Drew Pierce from NI came down to look at the issue. The morning before he came I was expanding my use of log files and finally had an executable build work. I was a little too quick to think I had the issue solved and threw a 2ms wait where the last log file was thinking it was a timing issue. Nope, it was broken again. So I put all of the logging functions back in, then took them out 1 by 1 until I found the one that fixed it. I have no idea why it fixes it, but it does. The offending vi is Mark Yedinak's SNMP Get Request. Here is the fix:
    And the Write Log:
    I have no idea why this works and just putting a wait doesn't:
    If anyone has a theory I'd love to know.
    Thanks,
    Simon
    P.S. I want to be clear that I'm not saying Mark's code is bad, it works flawlessly elsewhere and I'm very thankful he provided it. It has saved my life on this project.

  • 10.2.8 Finder does not load after getting into OS X

    I am pretty sure this happened to a lot of people, as I have read many many messages on this issue.
    My computer is a Powerbook 867 with 128built in DDR and 512 added.
    40Gb internal HDD and a 40GB firewire 3G ipod (the old 3G).
    Here's the problem:
    Last night just when I finishsed watching some divx on VLC running on 10.2.8, I quitted VLC using apple+Q, then closed the finder window i opened with apple+W. They both closed, but then the finder just did not respond (or have quitted). There isn't a little triangle below my finder icon on the dock. Everything else on the dock works perfectly fine. Desktop icons have disappeared.
    Now I have restarted, nothing helps; went on apple discussion and found some "HELPFUL" solutions - deleting the finder preferences. First how was I suppose to delete it? ok... I installed a 10.2.3 on my ipod and boot it through there, also did a repair permission on my internal HDD. Finally deleted the com.apple.finder.plist.. So I booted up using my internal again. But still... finder DOES NOT LOAD after I got into my OS X.
    Please if anyone can give me a solution to this problem!
    P.S. the finder on my ipod is working fine. AND I do not want to reinstall OS X on my interal because I only did it last week after it went to service after a HDD fail (it has been replaced).
    Powerbook 867Mhz 128+512MbDDR   Mac OS X (10.2.x)   10.2.8

    Check System Preferences - Accounts
    Choose you account - login items: If iTunesHelper
    shows up - remove it it will prevent re-installation.
    It did not have iTunes in the list, just mail and iCal alarm. Deadlines and emails are vital in my home office.
    Now that I think about it, adding Mail to the list was the only thing that I had changed to the computer when this happened, but I can't imagine how that would alter permission to install on the OS.
    Eric
    Note: I saw a G5 1.2 for $1,500 CAN. I was tempted.

  • Passing arrays with Call Library Function does not work after application builder

    Calling a DLL with Call Library Function which requires an array of data works correctly in Labview, but after building an exe with application builder, the call no longer works.  Dereferecing the pointer in the DLL retuns all 0s and not the actual values.
    Solved!
    Go to Solution.
    Attachments:
    TEST.zip ‏28 KB

    I did not run your code because it is a little unclear to me what it does.
    Two things:
    First, is the DLL you are calling the DLL-ified version of PopUpNames.vi? Then the problem is likely that the panel is not being built into the DLL.
    When LabView builds an application / dll, it strips the front panel and block diagram from all VIs that it doesn't think need to show a panel at run time. This reduces file size and increases code security. The App Builder's panel inclusion logic can be overridden by Build Specifications -> Source File Settings -> Remove front panel. A better method is to put a property node on a control in a window you want to show marking it "visible"; this is sufficient to tell the App Builder it should keep the panel.
    Currently Source File Settings shows "no dependencies" (clearly incorrect---another evil side effect of Express VIs I guess) but if you change the settings as shown below to keep ALL panels, one might hope the App Builder can figure it to keep the panel when it deconstructs the Express VI. (Alternatively convert the Express VI into a regular one.)
    A second comment: I am a bit flummoxed at the larger goal here. You are calling LabView DLL from LabView, which doesn't make a lot of sense, so I assume your larger goal is to call LabView from C or vice-versa. In that case be aware that your DLL is x86 (32-bit) but you are passing 64-bit ints as your pointers. In this case it is 32-bit LabView with 32-bit pointers in embedeed in 64-bit containers calling 32-bit LabView with 32-bit pointers in embedeed in 64-bit containers, so it all works, but if your going to call this from C or whatnot you're going to have to follow that same design.
    When calling C code the LabView Call Library Function does have a "unsigned pointer-sized integer" data type that always appears to be 64 bits in the dev env but which actually passes a 64 or 32-bit int to the DLL depending on the environment. The "pointer sized int" has to be 64 bits in the "LabView" part of the code because LabView's strong typing requires the data type to be determined at compile time. Casting all pointers to the largest data type in LabView makes it possible to write platform-independent code, but down at the Call Library level you still have to put the right number of bytes on the stack.

Maybe you are looking for

  • DVD from USA on a Mac in germany!

    Hi everybody! I have a MacBook Pro (os x lion), i bought it 4 moths ago. I've just realized, that my mac cannot read DVD from USA. So my question, is there way to change this so that my mac can read every formate? If yes how? Thank you all

  • How to automate loading data from a text file ?

    Hi, I need to load a data form a text file automatically. (for example: every day at 6.p.m) . It is possible to use DBMS_SCHEDULER with SQL LOADER ? or maybe u have others idea ? regards,

  • Cant install on a 64-bit browser

    I cant download Flash Player on my computer.  I get redirected to a page that tells me:  Adobe Flash Player is not supported for playback in a 64-bit browser. However, you can run Flash Player in a 32- browser running on a 64-bit operating system. Ho

  • Auto Changing Screen Resolution

    Can anyone tell me if it possible to get Director to change the screen resolution setting of a PC or Mac when playing a Projector. At the moment my projector is set to run at 1024 x 768 but our boardroom PC displays at 1920 x 1200. I don't want users

  • Skype number inactive

    I recently purchased a Kindle Fire HD 7" and installed Skype on it.  I paid for the subscription and Skype credits.  My bank shows both of those transactions, but when I open Skype it shows the credits, but says my Skype number is not active.  When I