Local host test

Hey All ,
I am starting of a new project and wanted to work on remotelogin
I thought of starting with a basic code where i can test [b]echoserver in local host itself first .
I want to know whether it is possible to do it in Java as i did that in C earlier and it did work .
If yes please let me know How ?
Thanx
Messy

http://java.sun.com/docs/books/tutorial/networking/sockets/
gothrough the above link... U will find it helpful.
jogesh

Similar Messages

  • Cisco ASA 5505 Cannot ping local traffic and local hosts cannot get out

    I have, what I believe to be, a simple issue - I must be missing something.
    Site to Site VPN with Cisco ASA's. VPN is up, and remote hosts can ping the inside int of ASA (10.51.253.209).
    There is a PC (10.51.253.210) plugged into e0/1.
    I know the PC is configured correctly with Windows firewall tuned off.
    The PC cannot get to the ouside world, and the ASA cannot ping 10.51.253.210.
    I have seen this before, and I deleted VLAN 1, recreated it, and I could ping the local host without issue.
    Basically, the VPN is up and running but PC 10.51.253.210 cannot get out.
    Any ideas? Sanitized Config is below. Thanks !
    ASA Version 7.2(4)
    hostname *****
    domain-name *****
    enable password N7FecZuSHJlVZC2P encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    interface Vlan1
    nameif Inside
    security-level 100
    ip address 10.51.253.209 255.255.255.248
    interface Vlan2
    nameif Outside
    security-level 0
    ip address ***** 255.255.255.248
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    shutdown
    interface Ethernet0/3
    shutdown
    interface Ethernet0/4
    shutdown
    interface Ethernet0/5
    shutdown
    interface Ethernet0/6
    shutdown
    interface Ethernet0/7
    shutdown
    ftp mode passive
    dns server-group DefaultDNS
    domain-name *****
    access-list No_NAT extended permit ip 10.51.253.208 255.255.255.248 10.1.7.0 255.255.255.0
    access-list No_NAT extended permit ip 10.51.253.208 255.255.255.248 host 10.1.10.250
    access-list No_NAT extended permit ip 10.51.253.208 255.255.255.248 host 10.1.3.200
    access-list No_NAT extended permit ip 10.51.253.208 255.255.255.248 host 10.1.3.9
    access-list No_NAT extended permit ip 10.51.253.208 255.255.255.248 host 10.10.10.14
    access-list No_NAT extended permit ip 10.51.253.208 255.255.255.248 host 10.10.10.15
    access-list No_NAT extended permit ip 10.51.253.208 255.255.255.248 host 10.10.10.16
    access-list No_NAT extended permit ip 10.51.253.208 255.255.255.248 10.1.9.0 255.255.255.0
    access-list No_NAT extended permit ip 10.51.253.208 255.255.255.248 10.10.9.0 255.255.255.0
    access-list No_NAT extended permit ip 10.51.253.208 255.255.255.248 ***** 255.255.255.240
    access-list Outside_VPN extended permit ip 10.51.253.208 255.255.255.248 10.1.7.0 255.255.255.0
    access-list Outside_VPN extended permit ip 10.51.253.208 255.255.255.248 host 10.1.10.250
    access-list Outside_VPN extended permit ip 10.51.253.208 255.255.255.248 host 10.1.3.200
    access-list Outside_VPN extended permit ip 10.51.253.208 255.255.255.248 host 10.1.3.9
    access-list Outside_VPN extended permit ip 10.51.253.208 255.255.255.248 host 10.10.10.14
    access-list Outside_VPN extended permit ip 10.51.253.208 255.255.255.248 host 10.10.10.15
    access-list Outside_VPN extended permit ip 10.51.253.208 255.255.255.248 host 10.10.10.16
    access-list Outside_VPN extended permit ip 10.51.253.208 255.255.255.248 10.1.9.0 255.255.255.0
    access-list Outside_VPN extended permit ip 10.51.253.208 255.255.255.248 10.10.9.0 255.255.255.0
    access-list Outside_VPN extended permit ip 10.51.253.208 255.255.255.248 ***** 255.255.255.240
    pager lines 24
    mtu Outside 1500
    mtu Inside
    icmp unreachable rate-limit 1 burst-size 1
    icmp permit any Outside
    no asdm history enable
    arp timeout 14400
    global (Outside) 1 interface
    nat (Inside) 0 access-list No_NAT
    route Outside 0.0.0.0 0.0.0.0 ***** 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    aaa authentication enable console LOCAL
    aaa authentication serial console LOCAL
    aaa authentication ssh console LOCAL
    http server enable
    no snmp-server location
    no snmp-server contact
    snmp-server community *****
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set DPS_Set esp-3des esp-md5-hmac
    crypto map DPS_Map 10 match address Outside_VPN
    crypto map DPS_Map 10 set peer *****
    crypto map DPS_Map 10 set transform-set *****
    crypto map DPS_Map interface Outside
    crypto isakmp enable Outside
    crypto isakmp policy 10
    authentication pre-share
    encryption 3des
    hash md5
    group 2
    lifetime 28800
    crypto isakmp policy 65535
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    telnet timeout 5
    ssh 0.0.0.0 0.0.0.0 Outside
    ssh timeout 60
    console timeout 0
    management-access Inside
    username test password P4ttSyrm33SV8TYp encrypted
    tunnel-group ***** type ipsec-l2l
    tunnel-group ***** ipsec-attributes
    pre-shared-key *
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect netbios
      inspect rsh
      inspect rtsp
      inspect skinny
      inspect esmtp
      inspect sqlnet
      inspect sunrpc
      inspect tftp
      inspect sip
      inspect xdmcp
    service-policy global_policy global
    prompt hostname context
    Cryptochecksum:8d0adca63eab6c6c738cc4ab432f609d
    : end
    1500

    Hi Martin,
    Which way you are trying. Sending traffic via site to site is not working or traffic which you generate to outside world is not working?
    But you say ASA connected interface to PC itself is not pinging that is strange. But try setting up the specific rules for the outgoing connection and check. Instead of not having any ACL.
    If it is outside world the you may need to check on the NAT rules which is not correct.
    If it is site to site then you may need to check few other things.
    Please do rate for the helpful posts.
    By
    Karthik

  • Do I need to have my site uploaded to a remote host for embeded formscentral form  to work? I am getting a broken section of header with a warning sign on top corner saying "!Local host." Cheers

    Hey there all.
    I am wondering if there is something wrong with my embedded form or if it is simply because
    I have not uploaded my site to remote host yet? I am only getting a broken part of the header with
    no actual form, with a warning "!local host" in top left hand corner. If anyone could enlighten
    me on this problem it would be greatly appreciated, it is my first time making forms

    Cheers, I noticed some browsers were treating the form differently. I am uploading to a test server tomorrow, hopefully all goes well, thanks for your reply  

  • Auto Sync Files not working with Local Host

    Hi,
    I am developing a site locally and testing on a local host. I have my working files in Adobe cloud and then 'upload' to my local host to test.
    This works fine when I click upload, or control+shift+u, but its extremely annoying.
    I have checked the box that says 'automatically upload files to server on save' but it doesn't do it.
    The only thing I can think of it that it has to be an actual live server? Nothing else can explain it. My setting are fine and like I said, doing it manually works no problem.
    I have the most recent version of DW CC
    Thanks,
    Jake

    Hi,
    I am developing a site locally and testing on a local host. I have my working files in Adobe cloud and then 'upload' to my local host to test.
    This works fine when I click upload, or control+shift+u, but its extremely annoying.
    I have checked the box that says 'automatically upload files to server on save' but it doesn't do it.
    The only thing I can think of it that it has to be an actual live server? Nothing else can explain it. My setting are fine and like I said, doing it manually works no problem.
    I have the most recent version of DW CC
    Thanks,
    Jake

  • Setting up local host

    I am trying to set up a local host for testing PHP per David Powers book. I am doing something wrong because I keep getting a 404 error. I am probably screwing up the locations of my site folders and/or the url address. Can someone help me out?

    The more information you provide the more likely you are to receive a response that will assist you. To avoid volunteer contributors from asking you 20 questions about the steps you've taken so far why not list in detail the steps you've taken to get to the point you're at now? Expect the amount of effort you put into your post to be reciprocated by others who respond. A three sentence post that vaguely describes your symptoms and methods will most likely be replied with the same minimal effort.

  • Simulate GSS in local host file

    Hi,
    I would like to test out the GSS without publishing it on the internet DNS.
    So the only way I think is to update the local host file (Win XP). What would be an equivalent entry in local host file for the below in Internet DNS
    abc.com IN NS gss.abc.com
    gss.abc.com IN A 22.11.22.11
    Mapping a domain/hostname to IP is straight foward, but how can an NS record be added.
    Thanks.

    Thanks. But I would like to avoid DNS effort and just manage with the local host file. So I would like to know whether it is possible to enter NS record in the local host file.
    If I were to ask for hostname abc.com, the process should be
    1. Check local host file for abc.com
    2. abc.com is pointed to NS record in local host file.
    3. The Name Server has a IP mapping in the local host file.
    All of the above without any DNS setup. A local host file at the moment is like
    abc.com 22.11.22.11
    which I want to change to
    abc.com IN NS gss1.abc.com
    gss1.abc.com 22.11.22.10 (GSS IP)
    How can I acheive 'abc.com IN NS gss1.abc.com' in local host file.

  • Wordpress on local host?

    I have a simple (only 2 posts and no pages) test WP blog installed on a remote web host. I'm trying to work on a copy of it off-line on my localhost. I started by adding a new wordpress to my local host, then copied the wp-include folder from remote host to the new localhost wordpress. Export/Import databse. Start and install WP and follow steps to create config.php file.
    All works as should. Blog appears on localhost with the 2 posts and the theme appearance and etc just as it does on remote host.
    Problem - When, in the WP dashboard Posts section,  I click on "view" post I get page not found error 404. I have been advised that I need to go to Settings>Permalinks and then click save. As soon as I select Settings>Permalinks a .htaccess file is added to the WP on localhost, the dashboard display becomes not correct and if I click save I get server error 500 message. From that point on I cannot access the blog on localhost at all. If I delete the .htaccess file I get back to where everything works except as described at the top of this post.
    So I believe I need to configure the .htaccess file and/or possibly some other configuration settings I need to change. I just can't figure out what I need to do to get this working correctly. A link to the .htaccess files is below. One file from original remote host the other created by WP when I go to Settings>Permalinks
    http://www.openrangeimaging.com/Test/htacess.jpg
    someone suggested to me that I just work on my localhost without the .htaccess file but that doesn't seem right to me and I want to get this sorted out and working 100% correctly.
    I know this is not realy a DW question. I have posted on the WP forum but not received any replies. I have gotten al lot of gret help and advice here so I am posting this in hopes someone can help me with this. Any advice on how I might get this resolved will be very much appreciated

    Disable permalinks when working locally.
    Nancy O.

  • Extremely slow download (8 kbps) and using "show local-host" to troubleshoot

    I have a USB device that gets firmware updates from the manufacture, the download of the firmware is very fast at other sites and at home except 1 site.  I found the following difference on the 2 ASAs (one where the download is fast the other where the download is very slow and cannot be completed) using "sh local-host" command. I think the ESP connection is the problem but I am not sure why its there - and I can see the byte count increment very slowly.  What would cause this connection to use ESP?
    At the sites where the download is fast
    DMZFW#  sh local-host 10.51.40.18 connection
    local host: <10.51.40.18>,
        TCP flow count/limit = 1/unlimited
        TCP embryonic count to host = 0
        TCP intercept watermark = unlimited
        UDP flow count/limit = 0/unlimited
      Conn:
        TCP Outside 70.42.140.65:80 inside 10.51.40.18:54632, idle 0:00:00, bytes 19480442, flags UIO
    ... ... (repeat the above command)
      Conn:
        TCP Outside 70.42.140.65:80 inside 10.51.40.18:54632, idle 0:00:00, bytes 24182974, flags UIO
    At the site where the download is extremely slow (like 8 kbps)
    DMZFW# sh local-host 10.1.40.74 connection
    local host: <10.1.40.74>,
        TCP flow count/limit = 1/unlimited
        TCP embryonic count to host = 0
        TCP intercept watermark = unlimited
        UDP flow count/limit = 0/unlimited
      Xlate:
        PAT Global X.X.X.X(30020) Local 10.1.40.74(50582) 
      Conn:
        ESP outside 70.42.140.65 inside 10.1.40.74, idle 0:02:48, bytes 0
        TCP outside 70.42.140.65:80 inside 10.1.40.74:50582, idle 0:00:00, bytes 2308822, flags UIO
    ... ... (repeat the above command)
      Conn:
        ESP outside 70.42.140.65 inside 10.1.40.74, idle 0:02:51, bytes 0
        TCP outside 70.42.140.65:80 inside 10.1.40.74:50582, idle 0:00:00, bytes 2318474, flags UIO

    I managed to run the test again a few minutes ago, was a bit quicker this time
    Test1 comprises of two tests 1.
    Best Effort Test: -provides background information.
    Download Speed 7 Kbps 0 Kbps 2000 Kbps
    Max Achievable Speed Download speedachieved during the test was - 7 Kbps For your connection, the acceptable range of speeds is 800-2000 Kbps.
    Additional Information: Your DSL Connection Rate :2167 Kbps(DOWN-STREAM), 955 Kbps(UP-STREAM) IP Profile for your line is - 1911 Kbps
    2. Upstream Test: -provides background information. Upload Speed 588 Kbps 0 Kbps 955 Kbps Max Achievable Speed >Upload speed achieved during the test was - 588 Kbps Additional Information: Upstream Rate IP profile on your line is - 955 Kbps This test was not conclusive and further testing is required.This might be useful for your ISP to investigate the fault.

  • Using local host XAMPP with Wordpress and Dreamweaver

    I hope this is within the scope of this forum. It's probably more of a WP than DW topic but I have found this forum to be very helpful on a wide scope of general web design/build topics so here goes.
    I have a static html/css web site created with DW. I've got it as a local site on my computer and also have it uploaded to a remote host server (fatcow). It's using a temporary domain/address while under development and will replace an exisitng site when completed.
    http://www.prospectrealty1.fatcow.com/index.html
    I have installed WP on the remote host and created a Blog thru the WP Dashboard. There is a link in the navigation of the static site to the WP Blog. When clicked a new tab opens and the user is taken to the seperate blog.
    http://prospectrealty1.fatcow.com/blog/
    I want to be able to work on a copy of the blog "offline" on my local computer.
    So I have xampp installed and it is working correctly  on the C drive of my computer. Next I copied my entire local site folder into a folder under the htdocs/xampp. So  Next I copied the folder I created that contains the wordpress install from the remote host at fatcow (I named it "blog"), and pasted it into my local install. So now I have localhost/xampp/prospect-blog-test/blog.

    geez, I was editing  the post above but got an error and it didn't save my edits and left out the problem.  so here's the trouble.
    After trying what I described above I made a new install of all of the WP files and put it here localhost/xampp/prospect-blog-test/. did this just to "start from scratch" Planning to export the WP files from the fatcow host and import into new local host install. I type localhost/xampp/prospect-blog-test into my browser and the WP splash screen appears and askis about creating the config file. First step is to specify the database. That's where I am having trouble.
    Using mySQL on the fatcow host and following the seemingly simple instructions on the WP codex I export the database .sql file. Then I go to mySQL on my local host and try to import the .sql file.
    I am getting the following error message.
    http://www.openrangeimaging.com/Test/local-host-MySQL.jpg
    Not sure what I'm doing wrong. Any help or advice or point me to a resource will be much appreciated.
    thanks in advance

  • How do I change an IP address of SQL Server which is locally hosted and is not on cluster?

    Hi All,
    How do I change an IP address of SQL Server which is locally hosted and is not on cluster?
    I am asking about IP for SQL Server, is there a way we can assign a different IP to SQL Server other than the server's(host) IP address? like the same what we do in a clustered env.
    aa

    Full explanation can seen here:
    SQL Server: Configure Listening IP, Port, and Named pipe
    http://ariely.info/Blog/tabid/83/EntryId/151/SQL-Server-Configure-Listening-IP-Port-and-Named-pipe.aspx
    [Personal Site] [Blog] [Facebook]

  • Is there a way to run using local host ip (127.0.0.1)?

    I am trying to get a working system at home. Obviously I cannot use a dialup
    dynamic IP address, but is there a way to enable iAS 6.0 SP3 to use the
    local host address of 127.0.0.1?
    kas.exe complains 'value of admin host in registry is invalid (localhost IP
    is not acceptable)'. I am running Windows 2000 and I do have a network card
    that I sporadically use to connect a laptop. It appears that with Windows
    2000, I can not use my Ethernet cards PI address unless I actually have it
    connected to a network.
    Any assistance would be appreciated.
    Thanks,
    Bret Hansen

    Yes. Use the loopback adapter.
    Bret Hansen wrote:
    I am trying to get a working system at home. Obviously I cannot use a dialup
    dynamic IP address, but is there a way to enable iAS 6.0 SP3 to use the
    local host address of 127.0.0.1?

  • How to set up a JSP local host server?

    I am trying to set up a local host JSP server, do you know any good youtube or tutorials in general that would help me set up a local host JSP server? Or could you post the steps here and your source (if any).
    I am looking for something similar to XAMPP as in this youtube tutorial: http://ca.youtube.com/watch?v=KWRB-maTVyM&feature=rec-fresh However, any help would be greatly appreciated.
    By the way, I am very new to JSP and was wondering, XAMPP includes Apache, is Apache a JSP server?
    -Direction needed.
    Edited by: watwatacrazy on Aug 31, 2008 6:51 AM

    You need a Java web container to run JSP/Servlets. A commonly used one is Apache Tomcat. It is not the same as Apache HTTP Server which can only serve static files.
    You can find Tomcat here: [http://tomcat.apache.org].
    How to install/use it, just check the User Guide: [http://tomcat.apache.org/tomcat-6.0-doc/index.html].

  • Error on invoking a webservice by giving ip address instead of local host

    Hi,
    I created a web service through jdeveloper and tried accessing the webservice generated WSDl file by giving ip address of my machine , but it throws me an error stating IE cannot display the web page . The same web service is running fine when giving local host on the Web service URL .
    Looking frwd fr sme help
    Thanks in advance
    Ragaven

    Hi,
    your WebLogic server is not setup to listen for the IP address. You can change this in the WLS console for the server configuration. Note that when you install WLS and don't define any hostname then it will listen to all addresses (which also is the default for the integrated WLS)
    Frank

  • Event ID 1012 - There was an error while attempting to read the local hosts file

    When I start my Computer after it has been turned off overnight (switched off at the Power supply) I get a Blue screen and have to reboot the PC. in the Event log it has this error: Event ID 1012 - DNS client events - There was an error while attempting
    to read the local hosts file.
    Once the PC has booted evrything is O.K. I can restart the PC with no problems, it only seems to happen if the PC has been switched off for a while.
    I am connected to the net via an Netgear dg834v4 Modem/Router
    Windows 7 Ultimate
    Intel Q8200 CPU
    2 x 360 Gb HDD
    ATI 4680 !Gb Video Card
    Digital HDA X-Mystique 7.1 Sound Card
    Aver media 777 TV Tuner card.
    Thank you
    jeepers01
    After further Investigation it seems that this error is Not responsible for my Blue screening......I started my PC after leaving it off all night, and it started normally, but i still have this error in the Event Log - System.....I have searched the Technet
    forums (and there is a lot of ID 1012 errors) but non relating to my problem....If anyone knows what is causing this error and how to fix it, i'd be Grateful....although it does not seem to affect the PC in any way that i can see.
    thanks
    jeepers01

    Since Windows system uses separated user mode and kernel mode memory space, stop errors are always caused by kernel portion components, such as a third-party device drivers, backup software or anti-virus services (buggy services).
    The system goes to a BSOD because there is some exceptions happened in the kernel (either the device driver errors or the service errors), and Windows implements this mechanism: When it detects some errors occur in the kernel, it will kill the box in case
    some more severe damage happens. Then we get a blue screen or the system reboots (it depends on what the system settings are).
    To troubleshoot this kind of kernel crash issue, we need to debug the crashed system dump. Unfortunately, debugging is beyond what we can do in the forum. A suggestion would be to contact Microsoft Customer Service and Support (CSS) via telephone so that
    a dedicated Support Professional can assist with your request. Please be advised that contacting phone support will be a charged call.
    To obtain the phone numbers for specific technology request please take a look at the web site listed below:
    Microsoft - Help and Support
    If you are outside the US please see
    Microsoft Worldwide Home for regional support phone numbers.
    Meantime we can try some available steps as a general troubleshoot.
    1. Please remove the antivirus and run the system with a period. If the issue does not occur, mainly focus on antivirus settings and compatibility. 
    2. Disable Automatic Restart and see detail information on the blue screen.
    1).Click Start, in the Start Search box enter sysdm.cpl.
    2).Click the tab Advanced. Under Startup and Recovery, click the Settings button.
    3). Uncheck “Automatically restart”.
    4). On the drop-down menu “Write debugging information”, choose “Small memory dump”.
    5). Click OK.
    When Blue Screen displays, you may find some useful information.
    Arthur Xie - MSFT

  • How to run local host web application in win 7 64 bit with oracle database?

    Hi all,
    Hope doing well,
    sir i am running my local host web application with oracle database in win 7 32 bit. it's working fine.
    but when i am running the same thing in win 7 64 bit. it's showing login error.
    not going to home page even i checked with this published file open in visual studio it's working fine.
    how to run it correctly?
    thanks in advance.

    The number of times you have been asked to post sufficient details for your questions, we would expect you to have got the message by now... but clearly not.
    952646 wrote:
    but when i am running the same thing in win 7 64 bit. it's showing login error.What error? You haven't posted an error. There are millions of possible errors in computing and you're expecting people to guess which one.
    not going to home page even i checked with this published file open in visual studio it's working fine.
    how to run it correctly?No code, no database version, no details...... = NO HELP.
    When are you going to learn.

Maybe you are looking for

  • C309 won't scan to computer

    I can no longer  from my C309 to my laptop.  Starting the scan from the computer does not offer me a pdf option.  I have recently bought a new laptop (a Dell) after experiencing the same problem with my previous laptop (a Toshiba).  At first the scan

  • SOFFICEINTEGRATION231 when editing standard text in Recruitment

    I'm trying to edit standard correspondence text within the Recruitment module, but instead of getting the friendly Word like editor, I get the standard sapscript editor and the following error message: SOFFICEINTEGRATION231 "Unable to find template".

  • Issue with calling url using custom uri from page loaded in stagewebview

    I am using stageWebView for showing webpage in my mobile app but don't know how to move back to my app once it gets loaded. In application descriptor file, I had already registered custom uri scheme (myapp://) for IOS devices and from the loaded page

  • Premiere Elements 9.0 will not open

    In August 2011 I purchased Adobe Premiere Elements 9.0 with a new Dell PC using Windows 7 64-bit. Since then I have used Premiere Elements many times for video editing without problems. The last time I used it was about 3 months ago. This week I trie

  • Song Help

    Does anyone know how to transfer songs from your iPod to your library? They got deleted, and I don't know how to get them back!!! Thanks for your help!!