Migration Repository DESIGNER 2000 (from 6 to 6i)

Hi everybody,
I'd like to know where can I find the script 'migrate_repos_privs.sql'. The propose of this script is to migrato users from the old repository version to 6i.
I start with repository version 6 and I try to execute this script. The source of this script try to call 'jr_sys_privs.ins' package internally but it doesn't exist in old repository. The result obviously is an error 'pl/sql called not found'.
This is the fouth step (4/5) in the tutorial instructions. Next I'm going to push the 'migrate repository' button in the tool to complete the migrate process.
Thanks. (Please, send me copy of your answers to: [email protected] )
Best regards:
Richard.

Hi,
The MIGRATE_REPOS_USERS.SQL script is generated when you run the the CKGENUSR.SQL script (step 12.1 of the insallation guide). In the box at the beginning of '12:Migration of subordinate users'it describes how when you run CKGENUSR.SQL it generates the MIGRATE_REPOS_USERS.SQL to your working directory.
check your working directory after running CKGENUSR.SQL you should find the script there.
Rgds
Susan Duncan
Oracle Designer Product Management

Similar Messages

  • Migrating to Designer 6i from earlier version

    Hi,
    I'm attempting to migrate our old repository to that of Des6i. I have gone through the steps to set up a new repository, and am now at the crucial point where I run the 6i Repository Admin Utility and hit "Migrate A Repository". I entered the username/password for our old repository, and I get the error:
    "A Designer/2000 Repository has been detected. However its version is not compatible with the Migration Process.
    Migration is supported for Designer/2000 Repositories at version:
    Oracle Designer/2000 Repository (TM): Release 7.0.4.0.0 Production
    The Designer/2000 Repository you have nominated is at version:
    Oracle Designer/2000 Repository (TM): Release 6.0.9.0.0 Production"
    However, as far as I'm aware (based on the Installation Guide that was installed with Des6i), it SHOULD work - in the "Migrate data from an existing repository into a new one" section, it reads:
    "To use a repository from a release of Oracle Designer earlier than 6i, you must migrate the data in it from a live Release 2.1.2 or Release 6.0 repository...into a Release 6i repository that you have already created."
    Is this not correct? Or am I being tripped up in the wacky world of Oracle version numbering?
    Any advice appreciated.
    -a

    <BLOCKQUOTE><font size="1" face="Verdana, Arial">quote:</font><HR>Originally posted by wspotter:
    Help Migration specialist
    I get about a third into the migration of a 6.0 to 6i migration when I get an error message that says something about not able to create table upg_rm_text_lines. This error causes further errors which lead to an incomplete migration. What do I do?<HR></BLOCKQUOTE>
    I have exactly the same problem. Did you get a solution for it?

  • Migration of Designer DB from NT to AIX possible?

    The Designer Repository is running under NT with version 6i on OracleRdbms8. Are there any restrictions for migrating the Database/Repository from NT to Database8i on a AIX Server ? We don't use any "external "files or either generating Forms out of the Designer, just the database.
    Thanking you in advance.

    Apologies for the delay responding to this.
    You should be able to transfer the whole database using the Export utility (not the export feature in the RAU, which only exports the repository). Create a database on the AIX server and import the exported dmp file. Strongly recommend reading the server admin docs first (can't see any on OTN that go back as far as 8i)
    Regards, Keith.

  • Migration of Designer Owner from 7.3.4 to 8.1.7

    My goal is database import from Oracle 7.3.4(Windows NT 4.0) to Oracle
    8.1.7( Linux 7.1).
    But, I have problem with importing Objects of Designer Repository Owner(
    no matter whether Designer 2.1 or Designer6.0).I gave Designer Repository
    Owner all necessary privileges an roles,but import just hangs! I can't
    find in log some exact information.
    Thanks in advance!

    I do that-full export,then full import.Then I found out that Designer Owner makes problem.
    I tried to import only Designer Owner, but it didn't work again!

  • Any problems with migrating In Design files from Mac to PC?

    My wife is a commercial artist, and we are considering getting CS4 here at home on our PC.  She has a Mac at work.  Are there any problems with switching files between the Mac and the PC so she can get some work done on the same files at both the office and at home?
    Thanks!

    One recurring problem I have is the different types of the Symbol font. Mac InDesign insists on adding (TT) -- "Symbol (TT)" -- to 'Windows' documents, and vice versa. I think the root of the problem is Symbol on Windows is an OTF font, whereas on the Mac it's still a 'regular' TTF. My Mac compadres tell me it's not easy to transfer the Windows font to the Mac -- its own version apparently being rooted deep inside the system.
    However, it's not a big issue, as we by default encapsulate Symbol with a character style. So when ID alerts us, all we have to do is redefine this style, be it on Windows or on Mac. Fortunately I've never seen text reflowing because of this (knocks on plywood desk).

  • User name & password for oracle designer 2000

    Hi,
    I have downloaded the oracle designer 2000 from oracle . I need user name & password to enter the screen. If anyone knows pl. help me

    The username and password you are looking for is that of the Database you are connecting to. I.e. where you have installed the designer repository.
    If you have not installed the repository, follow the instruction to create the oracle user (repository owner), install the designer repository and use it to login.
    The best thing will be to download the documentation the way you downloaded the software. It is important

  • Cross platform migrate repository and oms, gets "EM Key Verification Error"

    Hello,
    I am trying to cross platform migrate repository and oms from Sun Solaris Sparc 64 bit to Linux x86-64bit.
    Environment:
    Original repository Oracle 10.2.0.3, OMS 10.2.0.5, Sun Solaris Sparc 64 bit
    New repositoy Oracle 10.2.0.3, OMS 10.2.0.5, Linux x86-64bit
    Following metalink note:
    Subject: How To Move Grid Control Oms & Repository To Another Server
    Doc ID: 853293.1
    to step 4:
    4. Point the new OMS to the new repository
    can't get over emkey corrupt issue, gets error:
    2009-10-13 14:07:24,570 [AJPRequestHandler-ApplicationServerThread-11] ERROR conn.ConnectionService verifyRepositoryEx.918 - EM Key Verification Error = Em key does not match with repos verifier
    2009-10-13 14:07:27,910 [Shutdown] ERROR em.notification unregisterOMS.2573 - Error unregistering: EM Key is Missing java.sql.SQLException: EM Key is Missing
    The newly installed additional OMS can only point to the original repository and can't point to the newly migrated repository.
    Steps I did:
    Install an addition OMS to point to original repository (make sure emkey is in repository)
    create a new empty database on new host with a new name (is new name caused problem?)
    migrate old repository to new (use export/import)
    point new OMS to new repository by modifing emoms.properties
    startup oms and gets emkey corrupt error
    This metalink note does not help either:
    Subject: The Em Key is not configured properly. Run "emctl status emkey" for more details.
    Doc ID: 817035.1
    I also have a SR open but still have no help from Oracle support. I did make sure the emkey is in the repository before migrate. There may be tricks that I don't know.
    Can anyone shed some light on this?
    Thank you for your help in advance.
    Edited by: user1062137 on Oct 16, 2009 2:14 PM

    Hi, I'm having the same issue.
    Our original installation was on Windows 32bit with the repository and OMS on the same host. I want to move the repository to a linux 64bit host to make more resource available for everything. The new database is 11.1.0.7 though. As the Grid control release is 10.2.0.5 Oracle Support have confirmed that the 11g database is OK to use.
    In the log I see a lot of this:
    [AJPRequestHandler-ApplicationServerThread-5] ERROR conn.ConnectionService verifyRepositoryEx.911 - Invalid Connection Pool. ERROR = ORA-01031: insufficient privileges
    ORA-06512: at "SYSMAN.MGMT_USER", line 10296
    ORA-06512: at "SYSMAN.SETEMUSERCONTEXT", line 17
    ORA-06512: at line 1
    2009-11-05 18:54:57,254 [AJPRequestHandler-ApplicationServerThread-7] ERROR conn.FGAConnection _setConnContext.326 - java.sql.SQLException: ORA-01031: insufficient privileges
    ORA-06512: at "SYSMAN.MGMT_USER", line 10296
    ORA-06512: at "SYSMAN.SETEMUSERCONTEXT", line 17
    ORA-06512: at line 1
    java.sql.SQLException: ORA-01031: insufficient privileges
    ORA-06512: at "SYSMAN.MGMT_USER", line 10296
    ORA-06512: at "SYSMAN.SETEMUSERCONTEXT", line 17
    ORA-06512: at line 1
    2009-11-05 18:54:59,973 [Shutdown] ERROR em.notification unregisterOMS.2573 - Error unregistering: EM Key is Missing
    java.sql.SQLException: EM Key is Missing
    Unfortunately that package is wrapped so I can't see what privs are required.
    The instructions say (simplified here) either datapump or exp/imp to the new database, run some admin scripts, then update the emoms.properties with the new connection information. Thats it - start OMS again and it should work.
    Thankfully I can turn the old repository back on while I sift through these logs.

  • Error and crash durring creation of Designer 2000 repository

    I am a student learning to use Oracle and have run accross a problem when I tried to generate a Designer 2000 repository.
    I have installed Oracle 8i Personal Edition Release 8.1.5 on Windows 98.
    I logged on to Oracle using the internal id and began generating a repository, at the point in the process when it reaches these details:
    Stage Details
    CKTRIG
    Creating the repository triggers
    Object Details
    TRIGGER
    CDI_EL_CREATE_AUDIT
    Staus Information
    Submitting Definition/Statement..
    cdapitrg.sql
    I get the following error message:
    ora-04089: Cannot create triggers on objects owned by SYS
    I have tried skipping the step until it reaches one it accepts and then received a fatal error which closed the whole program down. I have also tried uninstalling and reinstalling and starting the process from the beginning and ended with the same results.
    Does anyone know why this is happening and more importantly how I can get around it?
    Thanks.

    Am not sure if you were able to resolve the issue but below are some points:
    a. I think the dlls sfabol and msa are not any more registerable, since they are more of VB.NET components and here assembly is registered and not the dll.
    b. For logging into the application just ensure that you have user id in table SMOUSER and the employee for that user in SMOMITABT table.
    c. If this is fine, then ensure that you have the latest BDOC metadata information on your laptop. I think in 5.0 also you need to use Clientconsole to download this information.
    d. If this is all okay, then try running SQL profiler and check if the query to the ides db is being executed by the framework. If the query is fired then it means application seems to behave properly but the query is not retrieving relevant details.
    For further details feel free to contact me..
    thanks,
    Piyush

  • Got Error when migrate repository from obiee10g to obiee 11g

    Hi all,
    i'm testing to migrate repository from obiee10g to obiee 11g , when i done the migration repository and check gobal consistency . It show an error below
    of repository's 11g , but when i check repository's 10g .It doesn' throw any error .Any suggestion ?
    ERRORS:
    BUSINESS MODEL PTTCH Core:
    [nQSError: 15037] Table, PTTCH - Dim - Value Center, has multiple key level associations: Detail and [].
    [nQSError: 15001] Could not load navigation space for subject area PTTCH Core.

    Check this thread:
    Re: nQSerror 15037
    Adil

  • Can we migrate SharePoint Designer 2013 workflows from DEV to UAT to Live without any issues? Any bad experiences?

    Hi there,
    1. Can we migrate SharePoint Designer 2013 workflows from DEV to UAT to Live without any issues? Any bad experiences?
    2. When we deploy these workflows - does IIS need a restart?
    Thank you.

    That depends, did you create reusable workflows? Those can be deployed to another environment (of course depending on dependencies within the workflow itself)
    Kind regards,
    Margriet Bruggeman
    Lois & Clark IT Services
    web site: http://www.loisandclark.eu
    blog: http://www.sharepointdragons.com

  • Question on Migrating repository files from Brio8 version to Interactive Reporting version11

    We are migrating from Brio 8.3.1 version (unix) to Interactive reporting version 11.1.2.1 (linux)environment. I am referring hs_migration.pdf this is for 11.1.1.1 I couldnot find better version than that. There I can see migrating repository files on page 154 I attached screen shot and pdf for your reference. Here repository files means what are those .bqy reporting files or normal repository files?
    Is it possible to migrate .bqy files, .oce files and folder structure in the Brio web application to Hyperion Interactive reporting workspace using the migration utility tool? As per my knowledge .bqy files sits on the unix server but not on the schema (repository) which we used for installation and configuration of Brio 8 environment. so repository files means not .bqy files I think that is my doubt.
    I need your help in clarifying my doubts.

    That means to move .bqy files and .oce files should I connect to existing Unix Reporting server keeping it as source and existing Linux server as target? or should I connect only to Brio8 repository as source and Interactive reporting repository as target?
    Can you please share your contact number? I will call you.

  • Connecting from Oracle designer 2000 Forms 4.5 to 9i

    Hi,
    a)We have installed Oracle designer 2000 and are able to connect to a 9.0.1.0.0 database.
    The Versions we have used are as follows:-
    Forms [32 Bit] Version 4.5.7.1.6 (Production)
    Oracle9i Enterprise Edition Release 9.0.1.0.0 - Production
    With the Partitioning option
    JServer Release 9.0.1.0.0 - Production
    Oracle Toolkit Version 2.3.6.9.0 (Production)
    PL/SQL Version 1.2.1.5.0 (Production)
    Oracle Procedure Builder V1.5.6.15.3 - Production
    Oracle Virtual Graphics System Version 2.1.10.7.0 (Production)
    Oracle Tools GUI Utilities Version 1.2.0.10.0 (Production)
    Oracle Multimedia Version 2.0.7.9.0 (Production)
    Oracle Tools Integration Version 1.2.0.4.0 (Production)
    Oracle Tools Common Area Version 2.0.0.9.0
    Oracle CORE Version 3.5.2.0.0 - Production
    b)We are able to connect from SQL 3.1 to a 9.0.1.0.0 database also.
    1)Does Oracle support this configuration?
    2)Will my Oracle 4.5 forms builder be able to use all the objects available in the 9.0.1.0.0 database?
    3)Is there a possibility that my forms will not run properly because of this configuration?

    Strictly speaking we only certify the upgrade from 6i to 9i, however, the technical details of going from 4.5 directly to 9i are the same and in many cases should work as going from 6i to 9i.
    Regards
    Grant ROnald
    Forms Product Management

  • Upgrade design 2000 v1.3.2 to v 2.1

    Dear Sir/Madam,
    I'm using Oracle Design 2000 v1.3.2 with personal Oracle data
    ver 7.2.2.3.1. How can I upgrade to new version of Design 2000
    (v2.1)?
    Can I backup data ,reinstall design v2.1 and then restore data ?
    Thanks very much for your help.
    BACH
    null

    Hi Nguyen,
    I have done something similar (migrating from Des1.2/Oracle7.2
    to Des2.1/Oracle8.0) but in a NT environment and this is how I
    went about it.
    1. First you have to export the current repository on using the
    Des1.3.2 RAU (Repository Admin. Utility) facility.
    2. Then install the new version of your Des2.1 (on server
    and client in my case).
    3. Create a new repository using Des2.1.
    4. Import back using the export file from Des1.3.2 and the
    Des2.1 RAU.
    Usually the Des2000 booklet from Oracle gives a detailed step by
    step procedure to migrate from one ver to another. You might be
    better off if you have that book with you too.
    Hope this info could at least help you to get started.
    Headstart Team (guest) wrote:
    : Nguyen Pham Bach (guest) wrote:
    : : Dear Sir/Madam,
    : : I'm using Oracle Design 2000 v1.3.2 with personal Oracle
    data
    : : ver 7.2.2.3.1. How can I upgrade to new version of Design
    2000
    : : (v2.1)?
    : : Can I backup data ,reinstall design v2.1 and then restore
    data
    : : Thanks very much for your help.
    : : BACH
    : This is a Headstart-only discussion group. Please address your
    : question to Oracle Customer Support, or visit the Support
    : web-site: metalink.oracle.com.
    null

  • How to run Integration Repository Designer

    Hello,
    I have installed NetWeaver 2004S SR2 ABAP+Java, Windows 2003 32-bit with MS SQL Server 2005. Did not install anything beyond that.
    The goal for me is to create the connectivity between our own application and SAP NW with use of PI module.
    Now, I'm trying to follow step-by-step guide "Step-By-Step Approach for Implementing XI" Scenarios(SAP on DB2 for Linux, UNIX, and Windows) and at certain point they ask to open the Integration Repository Designer, which I cannot find on my system.
    Questions:
    1. Do I need to install anything beyond already installed components to get access to PI/XI design and runtime tools?
    2. If not, how can I run this Integration Repository Designer?
    Thanks,
    Maxim.

    After running the transaction mentioned, I just get the Windows Explorer popped up with the folder "C:\Documents and Settings\Sap\SapWorkDir"
    Those are the files in this folder:
    SAP_Cache_Sap\
    SAPHistorySAP.mdb
    SAPHistorySAP.ldb
    sapfewdll_01_0007_00_692_1716.err.trc
    errorlog.gui
    No errors or any other messages in the SAP System window. Any suggestions?
    Maybe I'm not good at terminology, but saying "...while installing XI/PI..." did you mean I need to install that separately from the installation I ran from the SAP Solution Manager disc, providing NW Kernel 7.0 as a part of that installation?
    Thanks,
    Maxim.

  • Creation of application in designer 2000 ver 6

    Following messgae is shown while try to create new appliocation in designer 2000.
    ORA-6502 PL/SQL numeric or value error.
    The detail error is follows.
    RME-00222: Failed to dispatch operation to Repository
    RME-02124: Failed to execute SQL statement: declare
    pl1 CIOAPPLICATION_SYSTEM.data;
    utility varchar2(3);
    begin
    rmmes.clear;
    savepoint rm_dispatch;
    pl1.i.NAME := true;
    pl1.v.NAME := :p3;
    pl1.i.DATAWAREHOUSE_FLAG := true;
    pl1.v.DATAWAREHOUSE_FLAG := :p4;
    pl1.i.APPLICATION_TYPE := true;
    pl1.v.APPLICATION_TYPE := :p5;
    CIOAPPLICATION_SYSTEM.INS(:p1,pl1);
    :p2 := pl1.v.id;
    :errcnt := 0;
    exception when others then
    rmmes.get_error_state(utility,:excode);
    rmmes.get_product(utility,:exprod);
    :exutil := utility;
    :errcnt := rmmes.getsize;
    :sqlcod := SQLCODE;
    :sqlmsg := SQLERRM;
    rollback to savepoint rm_dispatch;
    end;
    RME-02105: Oracle error occurred...
    ORA-06502: PL/SQL: numeric or value error: character string buffer too small
    ORA-06512: at line 22
    ORA-06500: PL/SQL: storage error
    ORA-06512: at "DES.RMMES", line 38
    ORA-06512: at "DES.CIOAPPLICATION_SYSTEM", line 193
    ORA-04031: unable to allocate 1036 bytes of shared memory ("large pool","unknown object","session heap","pliost struct")
    ORA-04088: error during execution of trigger 'DES.CDI_EL_CREATE_AUDIT'
    ORA-06502: PL/SQL: numeric or value error.
    Please help.
    Madhukar
    null

    I had a similar problem which was resolved by increasing the LARGE_POOL_SIZE to 2 MB
    Good Luck!
    <BLOCKQUOTE><font size="1" face="Verdana, Arial">quote:</font><HR>Originally posted by Madhukar Srivastava ([email protected]:
    Following messgae is shown while try to create new appliocation in designer 2000.
    ORA-6502 PL/SQL numeric or value error.
    The detail error is follows.
    RME-00222: Failed to dispatch operation to Repository
    RME-02124: Failed to execute SQL statement: declare
    pl1 CIOAPPLICATION_SYSTEM.data;
    utility varchar2(3);
    begin
    rmmes.clear;
    savepoint rm_dispatch;
    pl1.i.NAME := true;
    pl1.v.NAME := :p3;
    pl1.i.DATAWAREHOUSE_FLAG := true;
    pl1.v.DATAWAREHOUSE_FLAG := :p4;
    pl1.i.APPLICATION_TYPE := true;
    pl1.v.APPLICATION_TYPE := :p5;
    CIOAPPLICATION_SYSTEM.INS(:p1,pl1);
    :p2 := pl1.v.id;
    :errcnt := 0;
    exception when others then
    rmmes.get_error_state(utility,:excode);
    rmmes.get_product(utility,:exprod);
    :exutil := utility;
    :errcnt := rmmes.getsize;
    :sqlcod := SQLCODE;
    :sqlmsg := SQLERRM;
    rollback to savepoint rm_dispatch;
    end;
    RME-02105: Oracle error occurred...
    ORA-06502: PL/SQL: numeric or value error: character string buffer too small
    ORA-06512: at line 22
    ORA-06500: PL/SQL: storage error
    ORA-06512: at "DES.RMMES", line 38
    ORA-06512: at "DES.CIOAPPLICATION_SYSTEM", line 193
    ORA-04031: unable to allocate 1036 bytes of shared memory ("large pool","unknown object","session heap","pliost struct")
    ORA-04088: error during execution of trigger 'DES.CDI_EL_CREATE_AUDIT'
    ORA-06502: PL/SQL: numeric or value error.
    Please help.
    Madhukar
    <HR></BLOCKQUOTE>
    null

Maybe you are looking for