MPLS VPN / BGP Netflow Issue

I have followed all of the configuration steps given for egress accounting with netflow on a MPLS VPN link. However, it is only showing flows coming into the router. I need to be able to account both ways- any recommendations? Config below:
interface Multilink12
mtu 1580
ip address XX.XX.XX.XX 255.255.255.252
no ip redirects
no ip unreachables
ip pim sparse-mode
ip route-cache flow
mpls netflow egress
mpls label protocol ldp
mpls ip
ppp multilink
ppp multilink group 12
ip flow-export source FastEthernet0/0/0.10
ip flow-export version 5
ip flow-export destination XX.XX.XX.XX 9996
IP packet size distribution (10730093 total packets):
1-32 64 96 128 160 192 224 256 288 320 352 384 416 448 480
.000 .098 .645 .011 .016 .012 .009 .010 .000 .001 .000 .001 .000 .000 .000
512 544 576 1024 1536 2048 2560 3072 3584 4096 4608
.000 .000 .000 .002 .185 .000 .000 .000 .000 .000 .000
IP Flow Switching Cache, 4456704 bytes
4 active, 65532 inactive, 464700 added
6109192 ager polls, 0 flow alloc failures
Active flows timeout in 1 minutes
Inactive flows timeout in 15 seconds
IP Sub Flow Cache, 336520 bytes
0 active, 16384 inactive, 20706 added, 20706 added to flow
0 alloc failures, 0 force free
1 chunk, 1 chunk added
last clearing of statistics never
Protocol Total Flows Packets Bytes Packets Active(Sec) Idle(Sec)
-------- Flows /Sec /Flow /Pkt /Sec /Flow /Flow
TCP-Telnet 7 0.0 20 233 0.0 7.0 11.3
TCP-FTP 3 0.0 1 40 0.0 0.4 1.6
TCP-WWW 5757 0.0 6 389 0.0 1.1 3.0
TCP-SMTP 7 0.0 1 40 0.0 0.7 1.6
TCP-X 244 0.0 1 54 0.0 0.0 1.5
TCP-other 304762 0.2 7 346 1.6 2.2 4.8
UDP-DNS 346 0.0 1 127 0.0 0.0 15.4
UDP-NTP 3323 0.0 1 80 0.0 0.0 15.4
UDP-other 131041 0.0 62 341 5.4 17.6 13.2
ICMP 64291 0.0 1 79 0.0 0.0 15.4
Total: 509781 0.3 21 341 7.1 5.9 8.3
SrcIf SrcIPaddress DstIf DstIPaddress Pr SrcP DstP Pkts
Mu12 10.50.66.218 Null 10.105.0.1 11 0675 00A1 84
Mu12 10.50.66.218 Null 10.105.19.10 11 0675 00A1 2
Mu12 10.50.66.218 Null 10.105.19.3 11 0675 00A1 4
Mu12 10.50.66.42 Null 10.105.19.10 06 0B3C 01BD 12

Update on this- Im now receiving all traffic incoming into the interface, but am tracking only about 10% of the outgoing traffic- revised config below:
ip flow-cache timeout active 1
ip flow-cache mpls label-positions 1 2 3
ipv6 flow-cache mpls label-positions 1 2 3
interface Multilink12
mtu 1580
ip address XX.XX.XX.XX 255.255.255.252
no ip redirects
no ip unreachables
ip flow ingress
ip flow egress
ip pim sparse-mode
ip route-cache flow
mpls netflow egress
mpls label protocol ldp
mpls ip
ppp multilink
ppp multilink group 12
service-policy output cbwfq-voice20per
ip flow-export source FastEthernet0/0/0.10
ip flow-export version 9 origin-as
ip flow-export destination XX.XX.XX.XX 9996

Similar Messages

  • Traceroute issue- MPLS VPN on directly connected interfaces

    I have 2 Catalyst 6509 Switches that Im trying to bring up and MPLS VPN connection between.  The loopbacks can ping each other, as well as the directly connected interfaces (the interfaces travel through 2 switches, but no routing etc in between).  An OSPF neighbor relationship DOES come up, and the routing tables appear normal.  However, the MPLS VPN does NOT come up.  
    After further review, I found that the routing tables are correct on either side for the loopbacks (public addresses X’d out on first 3 octets):
    SWITCH A:
    Bryan-26th-CAT-2#sh ip route 10.255.2.2
    Routing entry for 10.255.2.2/32
      Known via "ospf 23532", distance 110, metric 2, type intra area
      Last update from X.X.X.70 on Vlan65, 00:10:25 ago
      Routing Descriptor Blocks:
      * X.X.X.70, from 10.255.2.2, 00:10:25 ago, via Vlan65
          Route metric is 2, traffic share count is 1
    SWITCH B:
    DAL-COLO-6509-1#sh ip route 10.255.2.3
    Routing entry for 10.255.2.3/32
      Known via "ospf 23532", distance 110, metric 2, type intra area
      Last update from X.X.X.69 on Vlan65, 02:26:50 ago
      Routing Descriptor Blocks:
      * X.X.X.69, from 10.255.2.3, 02:26:50 ago, via Vlan65
          Route metric is 2, traffic share count is 1
    This is exactly the same for the directly connected interfaces on VLAN65.  (X.X.X.69 and X.X.X.70).  The ARP cache also shows to be correct:
    SWITCH A:
    Bryan-26th-CAT-2#sh arp
    Protocol  Address          Age (min)  Hardware Addr   Type   Interface
    Internet  X.X.X.70           147   0009.b6a4.b800  ARPA   Vlan65
    Internet  X.X.X.69             -   001c.b144.5800  ARPA   Vlan65
    SWITCH B:
    DAL-COLO-6509-1#sh arp
    Protocol  Address          Age (min)  Hardware Addr   Type   Interface
    Internet  X.X.X.70             -   0009.b6a4.b800  ARPA   Vlan65
    Internet  X.X.X.69           141   001c.b144.5800  ARPA   Vlan65
    And once again, the OSPF Neighbor relationship does come up:
    SWITCH A:
    Bryan-26th-CAT-2# sh ip ospf neigh
    Neighbor ID     Pri   State           Dead Time   Address         Interface
    10.255.2.2        1   FULL/BDR        00:00:30    X.X.X.70     Vlan65
    SWITCH B:
    DAL-COLO-6509-1#sh ip ospf neig
    Neighbor ID     Pri   State           Dead Time   Address         Interface
    10.255.2.3        1   FULL/DR         00:00:33    X.X.X.69     Vlan65
    In the Troubleshooting MPLS VPN manuals- it shows to test trace routes.  All of our other connections like this the trace routes work fine.  In this case though, I cannot trace route not only between the loopback interfaces, but between the DIRECTLY CONNECTED interfaces.  I don’t know what this is.  It should simply be a one hop trace route.  I believe this is what is keeping the MPLS VPN from coming up.  Any ideas?  Here are the relevant OSPF configs and interface configs as well:
    SWITCH A:
    interface Vlan65
     description Connection to DAL-COLO-6509-2
     mtu 1580
     ip address X.X.X.69 255.255.255.252
     no ip redirects
     no ip unreachables
     ip pim sparse-dense-mode
     ip ospf mtu-ignore
     mpls label protocol ldp
     mpls ip
    router ospf 23532
     log-adjacency-changes
     redistribute connected subnets
     redistribute static subnets
     passive-interface default
     no passive-interface Vlan65
     network 10.255.2.3 0.0.0.0 area 0
     network X.X.X.69 0.0.0.0 area 0
    SWITCH B:
    interface Vlan65
     description Connection to Bryan-26th-CAT-2
     mtu 1580
     ip address X.X.X.70 255.255.255.252
     no ip redirects
     no ip unreachables
     ip pim sparse-dense-mode
     ip ospf mtu-ignore
     mpls label protocol ldp
     mpls ip
    router ospf 23532
     log-adjacency-changes
     redistribute connected subnets
     redistribute static subnets
     passive-interface default
     no passive-interface Vlan65
     network 10.255.2.2 0.0.0.0 area 0
     network X.X.X.70 0.0.0.0 area 0
    Any ideas would be appreciated.
    Thanks
    Greg

    Greg,
    Can you explain more about your issue?. When you say MPLS VPN is not coming up, do you mean the ping (or traffic) from CE connected to one 6509 is not traversing the MPLS cloud to otehr CE connected to remote 6509?.
    Do you have VRF enabled with respective RT import/export?. Do you have MP-BGP with VPNv4 AF enabled?.
    To confirm if basic MPLS is working fine, Can you check if you have LDP neighborship up and running?. Use "show mpls ldp neighbor" to see the session.
    Also do a "ping mpls ipv4 <remote-loopback> <mask>" and see if it works?.
    -Nagendra

  • MPLS VPN L3 BGP to Customer CPE

    Hello,
    I am learning how to setup MPLS VPN L3. I am running OSPF in the MPLS Core and have configured MP-BGP between PE. I am running BGP between the PE and CPE in my lab, and I can see redistributed routes from the CPE in the vrf routing table for that customer on the PE router. My question is how to reditribute the vrf routes into my MPLS core to transmit the traffic to the customer other site on the same vpn. Below is what my config looks like.
    PE
    ip vrf customerA
    rd 100:101
    route-target export both 100:1000
    int fa0/0
    ip vrf forwarding customerA
    ip address x.x.x.x x.x.x.x
    router ospf 1
    loopback  in area0
    networks in area0
    router bgp 65000
    neighbor to other PE routers in AS 65000 (MPLS Network)
    address family vpn4
    neighbor other PE routers activate
    neighbor other PE routers send community
    ip address ipv4 vrf customerA
    neighbor to customerA in AS 55000
    CPE
    router ospf 1
    loopback in area 0
    networks in area 0
    router bgp 55000
    neighbor to PE router in AS 65000
    redistribute ospf 1

    Hi
    You dont have to redistribute your routes into mpls core. The vpnv4 bgp session that you have has already sent your ce routes to the remote pe router, provided you have the vrf configured on the other end.
    For more detaiked explanation please check a presentation available in the current running Ask The Expert event in the support community.

  • MPLS/VPN network load balancing in the core

    Hi,
    I've an issue about cef based load-balancing in the MPLS core in MPLS/VPN environment. If you consider flow-based load balancing, the path (out interface) will be chosen based on source-destination IP address. What about in MPLS/VPN environment? The hash will be based on PE router src-dst loopback addresses, or vrf packet src-dst in P and PE router? The topology would be:
    CE---PE===P===PE---CE
    I'm interested in load balancing efficiency if I duplicate the link between P and PE routers.
    Thank you for your help!
    Gabor

    Hi,
    On the PE router you could set different types and 2 levels of load-balancing.
    For instance, in case of a DUAL-homed site, subnet A prefix for VPN A could be advertised in the VPN by PE1 or PE2.
    PE1 receives this prefix via eBGP session from CE1 and keep this route as best due to external state.
    PE2 receives this prefix via eBGP session from CE2 and keep this route as best due to external state.
                                 eBGP
                         PE1 ---------CE1
    PE3----------P1                          Subnet A
                         PE2----------CE2 /
                                eBGP
    Therefore from PE3 point of view, 2 routes are available assuming that IGP metric for PE3/PE1 is equal to PE3/PE2.
    The a 1rst level of load-sharing can be achieve thanks to the maximum-paths ibgp number command.
    2 MP-BGP routes are received on PE3:
    PE3->PE1->CE1->subnet A
    PE3->PE2->CE2->subnet A
    To use both routes you must set the number at 2 at least : maximum-paths ibgp 2
    But gess what, in the real world an MPLS backbone hardly garantee an equal IGP cost between 2 Egress PE for a given prefix.
    So it is often necessary to ignore the IGP metric by adding the "unequal-cost" keyword: maximum-paths unequal-cost ibgp 2
    By default the load-balancing is called "per-session": source and destination addresses are considered to choose the path and the outgoing interface avoiding reordering the packets on the target site. Overwise it is possible to use "per-packet" load-balancing.
    Then a 2nd load-sharing level can occur.
    For instance:
             __P1__PE1__CE1
    PE3           \/                   Subnet A
            \ __P2__PE2__CE2
    There is still 2 MP-BGP paths :
    PE3->P1->PE1->CE1->subnet A
    PE3->P1->PE2->CE2->subnet A
    But this time for 2 MP-BGP paths 4 IGP path are available:
    PE3->P1->PE1->CE1->subnet A
    PE3->P1->PE2->CE2->subnet A
    PE3->P2->PE1->CE1->subnet A
    PE3->P2->PE2->CE2->subnet A
    For a load-balancing to be active between those 4 paths, they must exist in the routing table thanks to the "maximum-path 4 "command in the IGP (ex OSPF) process.
    Therefore if those 4 paths are equal-cost IGP paths then a 2nd level load-balancing is achieved. the default behabior is the same source destination mechanism to selected the "per-session" path as mentionned before.
    On an LSP each LSR could use this feature.
    BR

  • Central Site Internet Connectivity for MPLS VPN User

    What are the solutions of Central site Internet connectivity for a MPLS VPN user, and what is the best practice?

    Hello,
    Since you mentioned that Internet Access should be through a central site, it is clear that all customer sites (except the central) will somehow have a default (static/dynamic) to reach the central site via the normal VPN path for unknown destinations. Any firewall that might be needed, would be placed at the central site (at least). So, the issue is how the central site accesses the Internet.
    Various methods exist to provide Internet Access to an MPLS VPN. I am not sure if any one of them is considered the best. Each method has its pros and cons, and since you have to balance various factors, those factors might conflict at some point. It is hard to get simplicity, optimal routing, maximum degree of security (no matter how you define "security"), reduced memory demands and cover any other special requirements (such as possibility for overlapping between customer addresses) from a single solution. Probably the most secure VPN is the one which is not open to the Internet. If you open it to the Internet, some holes also open inevitably.
    One method is to create a separate Internet_Access VPN and have other VPNs create an extranet with that Internet_Access VPN. This method is said to be very secure (at least in terms of backbone exposure). However, if full routing is a requirement, the increased memory demands of this solution might lead you to prefer to keep the internet routing table in the Global Routing Table (GRT). You might have full routing in the GRT of PEs and Ps or in PEs only (second is probably better).
    Some names for solutions that exist are: static default routing, dynamic default routing, separate BGP session between PE and CE (via separate interface, subinterface or tunnel), extranet with internet VRF (mentioned earlier), extranet with internet VRF + VRF-aware NAT.
    The choice will depend on the requirements of your environment. I cannot possibly describe all methods here and I do not know of a public document that does. If you need an analysis of MPLS VPN security, you may want to take a look at Michael Behringer's great book with M.Morrow "MPLS VPN Security". Another book that describes solutions is "MPLS and VPN Architectures" by Ivan Pepelnjak. There is a Networkers session on MPLS VPNs that lists solutions. There is also a relevant document in CCO:
    http://www.cisco.com/en/US/tech/tk436/tk428/technologies_configuration_example09186a00801445fb.shtml (covering static default routing option).
    Kind Regards,
    M.

  • Injecting Global default Routes into a MPLS VPN

    Hi,
    I have a PE router running MPBGP which receives two default routes to the internet through an IPV4 BGP session. I need to import these routes in to a VRF and export them to different customer VRFs so that these VRFs are able to access Internet.
    I have used the feature called "BGP Support for IP Prefix Import from Global Table into a VRF Table" (URL:http://www.cisco.com/en/US/products/sw/iosswrel/ps5207/products_feature_guide09186a00803b8db9.html#wp1063870)
    and imported these routes into a VRF.
    The issue is these routes are not propagated to any of the other PE routers which has customer VRFs configured.
    Has anybody tried this or a similar method to inject a dynamic default route into a MPLS VPN.
    Any suggestions would be highly appreciated.
    Thanks
    Subhash

    Hi Subhash,
    is there anything preventing you from terminating your internet BGP sessions in a VRF? Then everything should go smoothly, i.e. standard VRF import/export.
    So possibility A) create a VRF Internet, move bgp neighbor commands there and use filters preventing anything but the default route, then use route targets to distribute the default route into other VRFs.
    Possibility B) use static routing with packet leaking. Could look like this:
    ip route vrf Internet 0.0.0.0 0.0.0.0 global
    ip route vrf Internet 0.0.0.0 0.0.0.0 global 250
    ip route Serial0/0 !assuming this is where the customer router connects.
    Note: the BGP peer IP does not have to be directly connected! There has to be a LDP label for it though. so include your BGP peers network into your IGP and the backup will work, when you loose the link to the peer.
    Hope this helps! Please rate all posts.
    Regards, Martin

  • RIP Between CPE & PE in a MPLS VPN

    When RIP is used as the dynamic routing protocol between dual homed CPE and PE in a MPLS VPN scenario with a backdoor link, there are chances of loops occurring and traffic transiting low bandwidth links. What precautions or actions can be taken to prevent these behaviors with RIP?
                   CPE
                      |
    CPE-------PE---P
        |                      |
    CPE-------PE---P
                     |
                  CPE

    Hi,
    When you redistribute the MP-BGP routes into RIP on PE, you have an option of specifying the metric with which RIP redistributes the routes. You can make use of this feature, set the RIP metric accordingly while you redistribute the RIP of remote CE location into local CE location. Also make the metric over the backdoor link less or more preferrable (whichever way you opt for) with offset list on that specific interface. By this way local CE receives updates with two different metric (one over MPLS provider and other over backdoor link) and the one with least metric is preferred.
    Also you have to stop advertising the LAN prefixes of remote CE router  to unwanted interfaces by using distribute list command. This can be done on the interface of CE connecting to PE routers where distribute list contains LAN of remote CE locations. Though split horizon stops advertising I am bit skeptical about the prefixes with different metrics works with split horizon.
    If the backdoor is TDM or the ethernet link where physical layer is going down on Layer 1 issues, then better option is to have static routing with higher/lower AD than RIP over backdoor link. There is no chance of looping in this case and you have better control.
    HTH
    Arun

  • Centralize internet access in MPLS VPN

    Can i implement Centralize internet access (the Hub CE Router to performs NAT) in cisco MPLS VPN solution?
    If so, is there any example about that? i can't find it at CCO~
    Thanks a lot~

    If you run dynamic routing protocol in PE-CE,like rip2,ospf,bgp,do the following task.
    1:set a default route in HUB CE;and generate the default route under its dynamic protocol.
    2:in other CEs, make sure they can learn this route.
    If you run static route and vrf static route between CE and PE,do the following task.
    1.set default route in HUB CE, and set default route in other CEs.
    2.In all PEs,redistribute the connected and static rotues to address-family ipv4 of customer vrf.
    3.set the customer vrf default route in all PE which connected your all CEs.
    Note: make sure all PEs can reach the GW address of vrf deafult route. GW IP address is the interface of which HUB CE towards PE.
    command: "ip route vrf 0.0.0.0 0.0.0.0 global.
    TRY

  • Selective Route Import/Export in MPLS VPN

    Champs
    I have multiple brach locations and 3 DC locations.DC locations host my internal applications , DC's  also have central Internet breakout for the region. My requirement is to have full mesh MPLS-VPN but at same time brach location Internet access should be from nearest IDC in the region  if nearest IDC is not availalbe it should go to second nearest DC for internet.I have decided which are primary and seconday DC for Internet breakout. How can this be achieved in MPLS-VPN scenario.Logically i feel , i have to announce specific LAN subnet and default route(with different BGP attribute like AS Path)  from all 3 DCs. Spokes in the specific region should be able to import default route  from primary DC and secondary DCs only  using some route filter?
    Regards
    V

    Hello Aaron,
    the route example works for all routers except the one, where the VRF vpn2 is configured. What you can do for management purposes is either to connect through a neighbor router using packet leaking or configure another Loopback into VRF vpn2.
    The last option (and my recommendation) is to establish another separate IP connection from your NMS to the MPLS core. Once VRFs are failing (for whatever reason, f.e. erroneously deleted) you might just not get connectivity to your backbone anymore to repair what went wrong.
    So I would create an "interconnection router" with an interface in the VRF vpn2 and one interface in global IP routing table. This way you will still be able to access PEs, even if VRFs or MBGP is gone.
    Hope this helps! Please rate all posts.
    Regards, Martin

  • Redundant access from MPLS VPN to global routing table

    Several our customers have MPLS VPNs deployed over our infrastructure. Part of them requires access to Internet (global routing table in our case).
    As I'm not aware of any methods how to dynamicaly import/export routes between VRF/Global routing tables, at the moment there are static routes configured - one inside VRF pointing to global next hop, another one in global routing table, pointing to interface inside VRF.
    Task is to configure redundant access to Internet. By redundancy I mean using several exit points (primary and backup), what physically represents separate boxes.
    Here comes tricky part - both global static routes (on both boxes, meaning) are valid and reachable in all cases - no matter if specific prefix is reachable in VRF or not. What I'd like to achieve is that specific static route becomes valid only if specific prefix is reachable inside VRF. Yea, sounds like dynamic routing :), I know
    OK, hope U got the idea. Any solutions/recommendations ? Running all Internet routing inside VRF isn't an option, at least for now :(

    Hi Andris,
    I did not mean to have a VRF on the CE. The CE would have both PVCs in the global routing table - his ONLY routing table in fact. One PVC would be used to announce routes into the customer specific VPN (VRF configured on the PE). The other PVC would allow for internet access through the PE (global IP routing table on the PE).
    dot1q will be ok as well.
    This way the CE can be a normal BGP peer to the PE, i.e. there is no MPLS VPN involved here. This allows all options of customer-ISP connectivity.
    Example:
    PE config:
    interface Serial0/0
    encapsulation frame-relay
    interface Serial0/0.1 point-to-point
    description customer VPN access
    ip vrf customer
    ip address 10.1.1.1 255.255.255.252
    interface Serial0/0.2 point-to-point
    description customer Internet access
    ip address 192.168.1.1 255.255.255.252
    router rip
    address-family ipv4 vrf customer
    version 2
    network 10.0.0.0
    no auto-summary
    redistribute bgp 65000 metric 5
    router bgp 65000
    neighbor 192.168.1.2 remote-as 65001
    address-family ipv4 vrf customer
    redistribute rip
    CE config:
    interface Serial0/0
    encapsulation frame-relay
    interface Serial0.1 point-to-point
    description VPN access
    ip address 10.1.1.2 255.255.255.252
    interface Serial0.2 point-to-point
    description Internet access
    ip address 192.168.1.2 255.255.255.252
    router bgp 65001
    neighbor 192.168.1.1 remote-as 65000
    router rip
    version 2
    network 10.0.0.0
    no auto-summary
    Of course you can replace RIP with whatever is suitable for you. And don´t sue me when you do not apply required BGP filters for internet access... ;-)
    The other option ("mini internet") would be feasible as well. Just make sure your BGP filters are NEVER messed up and additionally apply a limit on the numbers of prefixes in your VRF mini-internet.
    Regards
    Martin

  • Managing Route-Map based MPLS VPN

    1) How to derive the VPN information of the MPLS VPN configured using route-maps? As I understand, stitching route-maps information to derive VPN is complex as it is difficult to derive & correlate the filters tied to each of the route-maps that are tied to a VRF :(
    2) Is there any MIB to get from the MIB
    a) Route-maps tied to each VRF
    b) What is the filter associated with each route-map?
    c) Definition of each of the above filter
    It would have been nice if the route-maps' name had global-significance within AS, so that we could have treated route-maps, pretty much like the route-tragets. Alas, I doubt it is :(
    It should be noted here that if the MPLS VPN is configured using route targets, the VPN information derivation is fairly straight forward throught MplsVpn MIB.
    So, the question is what is the simplest way to derive the MPLS VPN info given that they are configured using route-maps in BGP for labelled-route-distribution & for the pkt association with the VRFs.
    Thanks,
    Suresh R

    Each CE in a customer VPN is also added to the management VPN by selecting the Join the management VPN option in the service request user interface.
    The function of the management route map is to allow only the routes to the specific CE into the management VPN. The Cisco IOS supports only one export route map and one import route map per VRF.
    http://www.cisco.com/en/US/products/sw/netmgtsw/ps4748/products_user_guide_chapter09186a0080353ac3.html

  • How can I find the all path available for a MPLS VPN in SP network

    How can I find the all path available for a MPLS VPN in SP network between PE to PE and CE to CE?

    Hi There
    If we need to find all the available paths for a remote CE from a local PE it will depend upon whether its a RR or non-RR design. If the MP-iBGP deisgn is non-RR  the below vrf specific command
    sh ip bgp vpnv4 vrf "vrf_name"  will show us the MP-iBGP RT for that particular VPN. It will show us the next hop. Checking the route for same in the Global RT will show us the path(s) available for same ( load-balancing considered) .Then we can do a trace using the Local PE MP-iBGP loopback as source to remote PE's MP-iBGP loopback to get the physical Hops involved.
    However if the design is RR-based there might be complications involved when the RR is in the forwarding path ie we have NHS being set to RR-MP-iBGP loopback and the  trace using the Local PE MP-iBGP loopback as source to remote PE's MP-iBGP loopback will get us the physical Hops involved.
    If we have redundant RRs being used with NHS being set then the output of sh ip bgp vpnv4 vrf "vrf_name" will show us two different available paths for the remote CE destination but just one being used.
    RR-based design with no NHS being used will always to cater to single path for the remote CE detsination.
    So in any case the actual path used for the remote CE connectivity would be a single unless we are using load-balancing.
    Hope this helps you a bit on your requirement
    Thanks & Regards
    Vaibhava Varma

  • MPLS VPN load sharing when multihoming

    Any one know of best practices for outbound load balancing when multihoming to 2 different service providers in an mpls vpn.
    I have referred to this document (http://www.cisco.com/warp/public/459/40.html) which states the only way to do this is by assigning metrics/weights to a certain range of prefixes learned from one provider, hence load sharing.
    Turning up bgp multipath on the CE would be optimal but since AS PATHs are different the best path selection will be different. Could we possibly turn of best path selection for AS paths (bgp bestpath as-path ignore) and make multipath work? Would that install 2 routes for the same prefix in the RIB?
    Thanks
    Ariful Huq

    Yes you can turn off best path selection for AS path and have multipath work. For a route to be populated in routing table BGP has various metrics for its selection. AS path is one of the metrics it uses for best route selection, so I dont think there should be any problem with it.

  • MPLS VPN DC/DR

    Hi,
    In VPN n/w i have DC & DR. Both DC & DR r geographically separate. Server IP pool used both in DC & DR is different. Need to configure MPLS VPN in such way that when DC is active spoke should not able to access DR. when DC becomes unvailable spoke shoould able to access DR.
    I m thinkin of conditional BGP. Let me know if you have any suggestion on conditional BGP or different solution.
    Thanks...

    Hello Sachin,
    in your case what could help is BGP conditional advertising:
    the PE routers (or the CE routers) of the DR site start to advertise the DR ip subnets when the DC subnets disappear from the VRF routing table.
    see
    http://www.cisco.com/en/US/docs/ios/12_1/iproute/configuration/guide/1cdbgp.html#wp1023602
    Hope to help
    Giuseppe

  • Filtering methods inside a VRF in MPLS VPN

    Hi,
    we have a network with MPLS VPN and several VRFs involved.
    Inside a certain VRF I need to avoid that two particular networks can talk to each other.
    Can you give me a hint of what can be a solution to implement this ?
    Thanks
    Regards
    Marco

    Hi Marco,
    To prevent connectivity between two networks where a MPLS VPN is involved you can apply the same methods as in a "normal" router network. Just think of the complete MPLS VPN (PE to PE) as being one big "router simulator".
    You could either implement ACLs on the interfaces connecting to the PE or filter routing updates between sites - depending on your topology. When filtering routing updates seems the way to go, you should also have a look into selective import or export. With the help of a route-map one can selectively insert single networks into a VPN by selectively attaching route-targets to BGP updates.
    Regards, Martin

Maybe you are looking for

  • In Flash CS4, how do you select multiple anchor points across separate layers?

    I am talking about anchor points on a line, not a keyframe. They are also called "handles". I can select the anchor points as "white" quickly, but I can't get them to be "solid"without doing it layer by layer, which is tedious. What I want is way to

  • How to set FBL1N T code Layout to default to all the users using this T cod

    Dear Friends I have created a new layout by modifying the some of the fields in FBL1N T code output.  I want to set as default layout to all the users using this T Code. Is there any way we can set the  custom layout as default layout  to all the use

  • Copying files into event browser

    Hi all, So if I copy my files into the event browser, that means its duplicating the files and taking up more harddrive space. Does this also mean I could delete the files outside of the program because FCPX has its own copy within the application? T

  • 50D + Lightroom 2

    Hi, i have a new canon 50 D. and am having trouble importing files to lightroom 2. i keep getting the error msg "the file appears to be unsupported or damaged" . i can view the images on camera and they are fine. i imported using the canon 'Digital P

  • Moving from 2009 Mac Pro to 2012

    I have an early 2009 Mac Pro, and a mid-2012 Mac Pro. Can I simply pull the hard-drives out of the 2009 and put them in the 2012 and be good to go, or are there hardware-specific aspects of the installation (i.e., Apple stuff) that will not work beca