Multiple Application Instances Accessing Same DAQ Device

I have a fairly straightforward application that reads from a wireless DAQ device (NI-9205 connected to NI WLS-9163).  I'd like to run multiple instances of the executable, but I get error -201105 (resource reserved) when the DAQmx task is started on the second instance.  Each instance is attempting to acquire from different channels from the same DAQ device.  Is this an issue with the DAQ device in particular, or with DAQmx in general?  Thanks.
-Joe
Solved!
Go to Solution.

Hi Joe,
Unfortunately you can only access one type of channel with each program.  For example you could have one program access AI and another use AO, but you cannot have two different programs access AI from the same card.  This is common among all of NI DAQ devices.

Similar Messages

  • Can Multiple Applications Access same DAQ ni usB-6289 device?

    I have to Run Multiple Instances of a LabVIEW Executable Simultaneously. Is it possible to access the same DAQ ni usB-6289 device for all of the LabVIEW instance?
    Thanks.

    dianageorge a écrit :
    I have to Run Multiple Instances of a LabVIEW Executable Simultaneously. Is it possible to access the same DAQ ni usB-6289 device for all of the LabVIEW instance?
    Thanks.
    Never tried it but I doubt you will be able to acces the DAQ simultaneously, To verify it try accesing the DAQ in LabVIEW and in MAX at the same time.
    Ben64

  • Sharing VISA Resources With Multiple Application Instances

    I have noticed a strange behavior when attempting to communicate with a
    slow, single shared VISA resource (GPIB device) from multiple
    stand-alone LabView 5 applications.
    Initially, I developed some code which first attempts to acquire
    exclusive access to the device using VISA lock with a reasonably large
    timeout. After the lock is acquired, the code performs its IO, then
    releases the lock.
    I then wrote some wrapper code which basically tries to enter the (lock,
    IO, unlock) code as fast as possible. I built a stand-alone application,
    and ran 3 seperate instances. Basically, I could see that each
    instance would eventually acquire a lock, perform its IO, and unlock.
    However, some of the instances "starved" for access to the device,
    enough so that the timeout was sometime reached (each IO would take
    perhaps 2 seconds, and I set the lock timeout to say 10 seconds).
    Ideally, each instance should receive the lock in the order by which the
    lock was requested. It appears that VISA is doing something else.
    I've verified that this issue also exists with "faster" GPIB devices
    (say 200ms IO turnaround), but is less noticable because the
    communications are faster.
    To get around this, I wrote another application which basically acts as
    a resource server. Using VI server, each instance which wants access to
    the resource sends a "lock" request to the server. Specifically, the
    "client" calls a re-entrant "Interface" VI via VI Server. The
    "interface" VI then adds the "lock" request to the queue, and then waits
    for "Notification" from the server process. The server parses the
    request queue, and when the resource is available, it sends a
    notification to the appropriate "interface" VI. This whole time, the
    client is waiting for the interface VI to return, just like when it's
    waiting for a normal lock. When the client is done with the device, it
    sends an "unlock" message to the interface VI. The server then gives
    the resource to the next item in the queue.
    To me, this is a bit kludgey. My solution requires that this "server"
    application is running at all times, and it is a bit slower than the
    usual manner. Has anyone come up with a better solution?
    Thanks,
    Andy

    My answer depends how stand alone your applications are. I don't know what happens if you have several independant executable files but the simplest solution in the development environment is to have one vi that handles all send/receive requests to the instrument. In this way, without extra overhead, you guarantee single parts of each program access too your instrument. (don't make this vi reentrant naturally)
    This approach has another advantage. You separate in a better way the instrument and your aplication, so changing to another instrument is easier to do.
    greetings from the Netherlands

  • Can Multiple DOE users access same client

    Dear All,
    I have a use case where manager and his team have to use the same physical device ( It mean same client in the handheld and also the same application). Manager and all the team members are DOE Users.
    As far as i know, we will have multiple local users in the client and mapped to single doe user, where as synchronization will happen through DOE sync user, who is configured in the client. During Sync DOE authenticates this user.
    But in my use case, DOE should authenticate all the users (user with which i am synchronizing the data). Is this possible in the standard client? Is there any possibility to achieve this?
    Regards,
    Kiran.

    HI,
    Your requirement is a standard behavior and there is nothing like  all the local client users are mapped to DOE users in default client.
    If each local client user has a corresponding DOE server username(i guess it need to be the same username or so) , with a user logged in , he/she can provide their own sync password which will take sync user as the currently logged in local client user.
    Only catch here that irrespective of which user is synching, all the messages in the queue (new data,modifications etc ) created by all the users will be send to server with this sync.
    Regards,
    Liji

  • Multiple browser instances receiving same session ID

    I am using Firefox with OC4J, and I've discovered that multiple simultaneous instances of the browser are receiving the same session ID. This is a pretty serious problem I beleive, as it prevents the ability to safely store one browser instance's state information safely in the session. In other words, one browser instance's behavior can stomp on another browser instance's state data.
    Does anyone know what criteria OC4J is using to determine session IDs, and whether to create a new session or deliver an existing one?
    Thanks,
    Brad

    Tugdual,
    Another comment -- the case where the cookie does not exist or is expired isn't the problem. The problem is when the cookie is valid and another browser instance is opened. Since the browser instances access the same cookie, you have no way of knowing on the server side that you are actually talking to two different browser instances. Hence, any storage of state information that is contextual has the potential to be stomped on by the other browser instances.
    In my case, one browser instance (the result of a new window spawn in a UIX page) was knocking over the original window, because it was overwriting some important state infomration.
    Brad

  • Multiple AIA instances on same Linux box

    H,
    Can multiple SOA instances be deployed on same linux box then with AIA on top of it.
    Can some one pls answer this?
    Regards,
    Rakesh

    Yes you can but:
    Each SOA installation must be in his own ORACLE_HOME directory.
    Each AIA installation must be in his own ORACLE_HOME directory.
    You must point to different databases. You can not have mulitple SOA schema's in one sinlge database.
    Marc
    http://orasoa.blogspot.com

  • Multiple AIA instances on same server?

    Hi,
    Does anyone know how to install multiple AIA instances on the same SOA server? The installer hints that this might be possible, although I have not seen how this is done because the installer expects an empty oracle home path. The only information I have found so far is for an earlier 2.x release of AIA and that suggested:
    "Each SOA installation must be in his own ORACLE_HOME directory.
    Each AIA installation must be in his own ORACLE_HOME directory.
    You must point to different databases. You can not have mulitple SOA schema's in one sinlge database."
    Is this true?
    Thanks,
    Kev.

    957354 wrote:
    Hi Laxman,
    If its a testing purpose its ok to have a one oracle_home and single listener for multiple DB. One problem when applying oracle patches for one of the instances running in a multiple DB running then you need to bring all the DB running in that host since the oracle_home is sharing between all db instances.
    Thanks
    Sunil Rajesh K.C.Starting with 11g, patchset updates are full installs and done into a new home. This makes it possible to migrate one instance at a time. However, your point would be a consideration for one-off patches like CPUs.
    However, please note ... OP --- PLEASE NOTE even with multiple oracle homes, you still only need a single listener.

  • Multiple DMVPN Instances on Same WAN Interface

    Hi Folks,
    Is it possible to run Multiple DMVPN Instances on a single WAN Interface ? Can we for example configure 3 Tunnels on a Router using one same WAN Interface but running separate EIGRP Instances for each Tunnel ? Kindly let me know , Alioune

    Hi Alioune,
    Yes you can create DMVPN as you said with one WAN interface that is possible..... you can have multiple tunnel interfaces pointed to a WAN interface as the source interface which resides in public zone..... with different public ip's as the destination tunnel...
    interface Tunnel1
    description ** A-VPN Tunnel **
    bandwidth 100000
    ip vrf forwarding red
    ip address 10.0.252.2 255.255.255.252
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip mtu 1500
    load-interval 60
    tunnel source GigabitEthernet0/0 (WAN Interface)
    tunnel destination  1.1.1.1
    tunnel protection ipsec profile dmvpn
    interface Tunnel1
    description ** B-VPN Tunnel **
    bandwidth 100000
    ip vrf forwarding red
    ip address 10.0.252.5 255.255.255.252
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip mtu 1500
    load-interval 60
    tunnel source GigabitEthernet0/0 (WAN Interface)
    tunnel destination  2.1.1.1
    tunnel protection ipsec profile dmvpn
    like the above..... shown sample...
    Please rate if the given information helps!!!

  • Multiple dialog instances on same host for different System

    Dear Sir,
    I install two dialog instances on same host ,one for DEV one for QAS.
    First I install dialog instance for DEV and startup with no error.
    Second dialog instance for QAS install with success end ,but can not start dispatchers.
    Service
    sapmsDEV     3600/tcp     # SAP System Message Port
    sapmsQAS     3601/tcp     # SAP System Message Port
    sapdp01s  4701/tcp  # SAP System Dispatcher Security Port
    sapgw01s  4801/tcp    # SAP System Gateway Security Port
    sapdp00       3200/tcp     # SAP System Dispatcher Port
    sapdp00s  4700/tcp # SAP System Dispatcher Security Port
    sapgw00       3300/tcp # SAP System Gateway Central Instance Port
    sapgw00s  4800/tcp # SAP System Gateway Security Port
    Disp_dev
    ***LOG Q0I=> NiPConnect2: SiPeekPendConn (10061: WSAECONNREFUSED: Connection refused) [nixxi.cpp 8716]
    ERROR => MsIAttachEx: NiBufConnect to sap-qas/sapmsQAS failed (rc=NIECONN_REFUSED) [msxxi.c      633]
    ***LOG Q0L=> DpLoopInit, nomscon () [dpxxdisp.c   1549]
    Stderr
    D:\usr\sap\QAS\D01\work>ntscmgr start MSSQLSERVER -m sap-qas
    failure: StartService, NT ErrorMessage: An instance of the service is already running. StartService SUCCESS
    D:\usr\sap\QAS\D01\work>ntscmgr start SQLSERVERAGENT -m sap-qas
    failure: StartService, NT ErrorMessage: An instance of the service is already running. StartService SUCCESS
    It seem that first startup dialog instance already start MSSQLSERVER -m sap-dev and SQLSERVERAGENT -m sap-dev, so next instance can not start again ,and cause NICONN_REFUSED.
    Could someone help me?
    Thanks
    Regards,
    Matt

    It appears to be possible, at least in IDM 7.1
    The release notes and Installation guide reference a setting called waveset.serverId that you set in your application server startup script like so:
    -Dwaveset.serverId=Name
    This would allow each JVM to identify itself differently from any others running on the same physical server.
    I haven't tried this yet myself, so caveat emptor.
    Jason

  • How to avoid multiple users to access same tcode

    Hi all,
    Am creating one z tcode to display the material details for the particular reservation number. How can  I avoid multiple users to access the same tcode simultaneously. If anybody works over that tcode then no other user should be able to access the same tcode until or unless the first user works over it.
    Regards,
    Ramya

    HI,
    you can even use import and export logic and check if user has entered the transaction ..
    Regards,
    Santosh
    Message was edited by:
            Santosh Kumar Patha

  • How to open multiple applications at the same time

    I need to open several applications at the same time: Dreamweaver, BBEdit, and Acrobat. Is there a way to smooth this process, so pressing an icon in the dock will open them all for me?

    You could create an applescript to do it.
    tell application "Dreamweaver's Full Name"
    activate
    end tell
    tell application "BBEdit's Full Name"
    activate
    end tell
    tell application "Acrobat's Full Name"
    activate
    end tell
    Replace the quoted text (leaving the quotes) with the full name of the application, and save the applescript as an application bundle, and put it in your dock.
    NOTE: You may have to put the full path to the application for it to work (I.E. /Applications/Dreamweaver.app). If you do, encase the full path in quotes.
    Good luck!
    Message was edited by: joshz

  • Multiple application instances and inter process communication.

    Hi,
    I am looking at having a main application instance spawn individual application instances. But when launching another instance I need to message the main application so it can spawn a window.
    How do I go about communicating between application instances in order to do this ?
    Many thanks in advance,
    Aaron

    RMI is your best bet - or, if the IPC is pretty simple, then you could just open a simple socket listener in the primary app...
    - K

  • Multiple application instance on the same server instance

    Can we have multiple instances of the same application on a single WLS?? For ex, can I have two app.ear files in different application directories??
              

    Hi Nilesh,
    Can you please clarify your landscape as this will help in getting answers to your question.
    In general adding instances (and/or server nodes) should be considered for increasing capacity rather than impoving performance. Specifcially, adding instances (and/or server nodes on the same host you risk a situation where the processes compete for resources which will have a negative effect on performance. If you do need to combine instances on the same host, make sure there is enough hardware (specifically memory in case of JAVA).
    Hope this helps,
    Best regards, Walter

  • Multiple IDM instances on same host

    Can multiple Identity Manager app server instances be run on the same host, connecting to the same db? If so, how is this accomplished. From what I see Identity Manager instances attempt to register themselves using the host name. Is there a property in the properties file that can set a unique name?

    It appears to be possible, at least in IDM 7.1
    The release notes and Installation guide reference a setting called waveset.serverId that you set in your application server startup script like so:
    -Dwaveset.serverId=Name
    This would allow each JVM to identify itself differently from any others running on the same physical server.
    I haven't tried this yet myself, so caveat emptor.
    Jason

  • Bug - multiple related instances of same class

    We've discovered a rather subtle bug in the process by which Kodo
    searches for reachable related objects to persist. If an instance of a
    PC class (A) has two relationships to the same PC class (B), and both
    related instances of B have the same value for their PK-field, then only
    one of the related instances of B will be persisted.
    Obviously, this problem only occurs in the context of application
    identity. We've only encountered it when all the instances involved are
    newly created and being made persistent for the first time (else the
    instances would have different PK-values). It should also be noted that
    we're assigning PK-values in jdoPreStore(). Here's the specific
    situation we encountered:
    Class A has two relationships to class B, represented by fields "B b1"
    and "B b2". In our case, A.b1 is the many-side of a bidirectional
    one-to-many relationship; the one-side is implemented by a field "List
    aList" in B. A.b2 is the navigable side of a unidirectional
    relationship; there is no corresponding field in B. (We haven't checked
    whether or how the cardinality or navigability of the relationships
    affects the problem.)
    Let "a1" be the sole instance of A. If a1.b1 is set to an instance of B
    but a1.b2 is null, and makePersistent( a1 ) is called, then a1 and b1
    are persisted correctly and the relation field b2_id in TableA is NULL.
    However, if a1.b2 is set to a second instance of B and both instances of
    B have the same initial value of their PK-field, then a.b2 is not
    persisted. Only one record is added to TableB; it corresponds to A.b1.
    Interestingly, in this case the relation field b2_id in TableA is not
    NULL, but has the default value of b2's PK-field. jdoPreStore() is not
    called on b2 and b2 is not persisted, but its PK-field is read in the
    process of persisting a1.
    Since we've placed the jdoPreStore() callback in a common non-persistent
    adapter superclass, we're currently able to work around the problem with
    a static "seed" PK value that is incremented in the superclass default
    constructor to provide a unique initial value for each PK-field. If
    anyone would like the code for this approach we'll post it, although
    it'll become unnecessary when the problem is fixed.
    Jerry Pulley
    Sr. Developer
    Commerce Technologies, Inc.

    I'm curious what behavior, besides throwing an exception, could even be
    possible. If the pm discovers two object with the same id, it seems that it
    has to choose one of them to make persistent. How could it possibly resolve
    differences in the fields of the two instances in deciding which one is the
    correct one to put in the db? Additionally, allowing this behavior could
    lead to subtle, difficult to detect bugs in your program, since ( as Abe
    points out ) JDO promises that there will only be one instance of an object
    with a given primary key per PM. Other code may make decisions based on
    this expectation ( like refreshing one of the objects after making a change
    in a different PM ), that would lead to problems for code still hanging on
    to the second instance.
    IMHO, it should throw an exception.
    -Eric
    "Abe White" <[email protected]> wrote in message
    news:[email protected]...
    Thanks for the bug report! However, I'm not entirely sure that this is a
    bug (at least not the bug you think it is); either way it's an extremely
    interesting case. The reason I say it might not be a bug is thatassigning
    pk values in jdoPreStore seems suspect.
    We know that a single PM cannot at any time contain multiple instances
    with the same oid value, app id or otherwise. This is obvious from the
    getObjectById method -- only one object can have a particular oid.
    We also know that jdoPreStore is called only for instances managed by a
    PM (duh!).
    Thus it should not be possible to see a case where jdoPreStore is
    called for 2 objects with the same initial oid.
    Now, I realize that when you're dealing with persistence-by-reachability
    things become less clear. However, I think the general point stands: at
    the time that the objects are made persistent they all must have unique
    oid values, and objects must be made persistent before jdoPreStore is
    called.
    Technically we could get around this. The current
    persistence-by-reachability algorithm is something like:
    flushed = {}
    while flushed.size < persistent.size:
    for each persistent instance:
    if instance not in flushed:
    instance.jdoPreStore // may persist more instances
    instance.persistFirstClassFields // may persist more too
    flushed += instance
    In sum this is a breadth-first method of persisting relations. It could
    be changed to a depth-first system instead of persisting all first class
    fields each one is persisted and then immediately the algorithm is
    repeated for that object before the other fields are touched. However,
    this seems like it might lead to other unexpected behavior.
    Generally, it just seems like waiting till jdoPreStore to assign the oid
    of an object seems like a bad idea. I think the real bug is that Kodo is
    not throwing an exception as soon as 2 object with the same oid are
    detected (currently it just lets one overwrite the other in the cache,
    which results in the behavior you see).
    Does anyone else have an opinion on this? I'm certainly not fixed on my
    interpretation of things; if you disagree I'd be very interested in
    hearing other arguments.

Maybe you are looking for

  • Can't open/run itunes

    I upgraded to itunes 5.0 and haven't been able to open itunes ever since. When I try to open it I get the following: iTunes has encountered a problem and needs to close. We are sorry for the inconvenience. Does anyone have any suggestions? I have uni

  • Need to read a XML file and store multilingual data

    I am having an XML file which contains multiple records and each maybe in a different language .identified EN -english ES-Spanish etc - <Document xmlns="http://www.xxxxx.com/ws/integration/toolkit/2011/05"> - <Attributes> <Attribute name="duration">0

  • Web services wizard hangs

    Hi, I am trying to create a stub/skeleton for an external wsdl file. I click the next button and the tool just hangs. Eventually it comes back with "cannot locate wsdl file". I have tried with proxy turned on and off but I get the same result. Howeve

  • Action Event

    Hi, Slight problem with an action event, have a workaround but want to make sure there isnt another way! Basically I have 2 combo boxes, Make and Model. When an item is selected in one of them the following happens: Gets the value selected, runs a qu

  • Cannot edit document text

    I selected Edit Document Text under Tools | Content | Edit Text & Objects. I place my cursor on the pdf and nothing happens. I then thought that the problem might be that Acrobat does not recognize the text. So I enabled OCR. I then placed my cursor