Multiple Ports in WSDL

Hi
WSDL apparently supports more than one 'Port' definition within
a Service defintion.
I am wondering whether this would be possible at all in WL6.1, using wsgen ? Basically,
I have a couple of session beans that
I want to expose as webservices, thru a single WSDL file. Each bean would become
a distinct PortType and ultimately Port in the
WSDL Service definition. However, it looks like the wsgen tool
cannot do this. Am I (hopefully!) wrong ?
Also, the WL client-side examples show the following code to
access a webservice:
Trader service = (Trader)context.lookup(<webservice_uri>);
If the <webservice_uri> has multiple Ports (and PortTypes), that
say, correspond to multiple beans, how would the above resolve
to the right bean ?
thanks
-john

Hi John,
No, this is not possible using wsgen. However you can manually edit the files
in a WebLogic Web Services to do this. Actually, the concept of having a single
Web Service, that exposes methods from multiple EJBs is pretty cool. Really shows
that distinction between "service interface" and "service implementation" ;-)
Anyway, the attached zip contains most of the files you would have to manually
edit, and a sample client.
Regards,
Mike Wooten
"john mani" <[email protected]> wrote:
>
Hi
WSDL apparently supports more than one 'Port' definition within
a Service defintion.
I am wondering whether this would be possible at all in WL6.1, using
wsgen ? Basically,
I have a couple of session beans that
I want to expose as webservices, thru a single WSDL file. Each bean would
become
a distinct PortType and ultimately Port in the
WSDL Service definition. However, it looks like the wsgen tool
cannot do this. Am I (hopefully!) wrong ?
Also, the WL client-side examples show the following code to
access a webservice:
Trader service = (Trader)context.lookup(<webservice_uri>);
If the <webservice_uri> has multiple Ports (and PortTypes), that
say, correspond to multiple beans, how would the above resolve
to the right bean ?
thanks
-john
[multibindings.zip]

Similar Messages

  • Extended acl - multiple ports on same acl line

    hello
    i'm working on a (long) acl and have started looking at putting multiple ports on the same line
    e.g.
    instead of:
    ip access-list extended test3
    permit tcp any host 10.10.10.1 eq 80
    permit tcp any host 10.10.10.1 eq 443
    i'd use:
    ip access-list extended test3
    permit tcp any host 10.10.10.1 eq 80 443
    its shortening the acl considerably but the question is:
    does this method reduce the TCAM resources required (compared to writing the acl in long hand)?
    what are the maximum number of ports that can be included on the same line - is it platform/ios dependant?
    thanks
    andy

    Hello
    No. I went ahead with the acl with multiple ports in each ACE and it worked fine. It was deployed on an old WS-C3750G-24PS-E and worked pretty well. When I checked the tcam on the switch I got the following output:
    Cisco3750#show platform tcam utilization
    CAM Utilization for ASIC# 0                      Max            Used
                                                             Masks/Values    Masks/values
    IPv4 security aces:                          1024/1024         33/33
    Note: Allocation of TCAM entries per feature uses
    a complex algorithm. The above information is meant
    to provide an abstract view of the current TCAM utilization
    As there were other ACLs on the switch it was difficult to gauge if the multiple ports per ACE approach to ACLs actually saved any TCAM resources. If you find anything out post back - I'd be interested to hear.
    thanks
    Andy

  • Multiple ports on single node cannot communicate

    I am a Sr. Tech Architect from SBC that it evaluating your product for utilization in our enterprise online order application in combination with the Solarmetric Kodo product.
    I was able to install and utilize your application and line command, sample applications no problem on a single jvm utilizing multiple ports and all the members were being recognized no problem. Suddenly, they are no longer being picked up. I am using the packaged configuration xml files as is, just running multiple dos windows on a Win 2k box and launching the line command application. The only other development work I have been doing on the box is test deploys to Apache of the product along with the integration of the Kodo product in a WSAD 5.1 environment, however, I have both those applications shut down and rebooted the machine with no success. I tried running the multicast test just for kicks and got no response back. Scratching my head as to what my be the problem all of a sudden.
    Thanks,
    Scott

    Scott,
    Did you, by any chance, install and enable "Microsoft Loopback Adapter"? If so, you'd need to disable it. If not, could you please e-mail me the command line and some output of the multicast test.
    Thanks,
    Gene
    [email protected]

  • Scan multiple ports on multiple computers

    Hey guys,
    I wrote the following batch script to use along with portqry tool which is availabe from microsoft download center.
    The tool can scan multiple ports on a single computer, but it is not capable of scanning multiple ports on multiple computers in one attempt. Also it gives a big output which is a bit tough if you are trying to prepare a report.
    Here is the batch file which takes input from server.txt where all the computer names present and scans for the below ports on each computer and gives you output in a beautiful way.
    TCP: 135, 445, 1433, 1434, 1024, 1040
    UDP: 1433, 1434
    Copy and paste the below code in a batch file and use it along with portqry.exe.
    echo off
    for /f "tokens=* delims= " %%a in (server.txt) do call :vk %%a
    :vk
    portqry -n %1 -e 1434 -q -p udp
    if errorlevel = 2 goto filtered_1434
    if errorlevel = 1 goto failed_1434
    if errorlevel = 0 goto success_1434
    goto 135
    :filtered_1434
    Echo %1 udp Port 1434 is listening or filtered
    goto 135
    :failed_1434
    Echo %1 udp Port 1434 is not listening
    Goto 135
    :success_1434
    Echo %1 udp Port 1434 is listening
    goto 135
    :135
    portqry -n %1 -e 135 -q -p tcp
    if errorlevel = 2 goto filtered_135
    if errorlevel = 1 goto failed_135
    if errorlevel = 0 goto success_135
    goto 445
    :filtered_135
    Echo %1 tcp Port 135 is listening or filtered
    goto 445
    :failed_135
    Echo %1 tcp Port 135 is not listening
    Goto 445
    :success_135
    Echo %1 tcp Port 135 is listening
    goto 445
    :445
    portqry -n %1 -e 445 -q -p tcp
    if errorlevel = 2 goto filtered_445
    if errorlevel = 1 goto failed_445
    if errorlevel = 0 goto success_445
    goto 1433_tcp
    :filtered_445
    Echo %1 tcp Port 445 is listening or filtered
    goto 1433_tcp
    :failed_445
    Echo %1 tcp Port 445 is not listening
    Goto 1433_tcp
    :success_445
    Echo %1 tcp Port 445 is listening
    goto 1433_tcp
    :1433_tcp
    portqry -n %1 -e 1433 -q -p tcp
    if errorlevel = 2 goto filtered_1433_tcp
    if errorlevel = 1 goto failed_1433_tcp
    if errorlevel = 0 goto success_1433_tcp
    goto 1434_tcp
    :filtered_1433_tcp
    Echo %1 tcp Port 1433 is listening or filtered
    goto 1434_tcp
    :failed_1433_tcp
    Echo %1 tcp Port 1433 is not listening
    Goto 1434_tcp
    :success_1433_tcp
    Echo %1 tcp Port 1433 is listening
    goto 1434_tcp
    :1434_tcp
    portqry -n %1 -e 1434 -q -p tcp
    if errorlevel = 2 goto filtered_1434_tcp
    if errorlevel = 1 goto failed_1434_tcp
    if errorlevel = 0 goto success_1434_tcp
    goto 1024
    :filtered_1434_tcp
    Echo %1 tcp Port 1434 is listening or filtered
    goto 1024
    :failed_1434_tcp
    Echo %1 tcp Port 1434 is not listening
    Goto 1024
    :success_1434_tcp
    Echo %1 tcp Port 1434 is listening
    goto 1024
    :1024
    portqry -n %1 -e 1024 -q -p tcp
    if errorlevel = 2 goto filtered_1024
    if errorlevel = 1 goto failed_1024
    if errorlevel = 0 goto success_1024
    goto 1040
    :filtered_1024
    Echo %1 tcp Port 1024 is listening or filtered
    goto 1040
    :failed_1024
    Echo %1 tcp Port 1024 is not listening
    Goto 1040
    :success_1024
    Echo %1 tcp Port 1024 is listening
    goto 1040
    :1040
    portqry -n %1 -e 1040 -q -p tcp
    if errorlevel = 2 goto filtered_1040
    if errorlevel = 1 goto failed_1040
    if errorlevel = 0 goto success_1040
    goto 1433
    :filtered_1040
    Echo %1 tcp Port 1040 is listening or filtered
    goto 1433
    :failed_1040
    Echo %1 tcp Port 1040 is not listening
    Goto 1433
    :success_1040
    Echo %1 tcp Port 1040 is listening
    goto 1433
    :1433
    portqry -n %1 -e 1433 -q -p udp
    if errorlevel = 2 goto filtered_1433
    if errorlevel = 1 goto failed_1433
    if errorlevel = 0 goto success_1433
    goto end
    :filtered_1433
    Echo %1 udp Port 1433 is listening or filtered
    goto end
    :failed_1433
    Echo %1 udp Port 1433 is not listening
    Goto end
    :success_1433
    Echo %1 udp Port 1433 is listening
    goto end
    :End

    For what it's worth, I wrote a PowerShell script that does something like this a while back.
    http://gallery.technet.microsoft.com/scriptcenter/97119ed6-6fb2-446d-98d8-32d823867131

  • ISE 1.2 and ACL's with multiple ports

    When creating a DACL for my groups I used the Syntax " permit tcp any 192.168.20.0 0.0.0.255 eq 22 443" for one of my acl's inside the DACL and the syntax check validated it. When I pushed it to my groups it also worked but I have heard that this type of multiple port ACL in ISE is not supported. Does anyone know if this is accurate?

    Thanks for the response but it's wrong. Cisco supports stacked ports in 1.2 for wired users. They carried over 1.1documentation to 1.2 and never updated it. We have it in writing from Cisco tac. 

  • ACE: a class-map with multiple ports... what about the probe/serverfarm?

    Hello Gilles,
    One question about something I was not able to find in the documentation.
    Lets say I have one class-map which includes 2 ports (in this case https and 5061).
    Can I associate this class-map to just 1 generic serverfarm and probe for both ports or I have to specify 2 serverfarms/rservers/probes?
    So, by not specifying the ports on the rserver, if a request is received on port 443 (or 5061), it is sent to the same respective port on the rserver?
    The same way is valid for the generic probe.  ACE module is able to probe both ports based on the class-map?
    Thanks and have a great day!!
    Giulio.
    probe tcp PROBE_GENERIC_TCP
      description This probe works for all TCP services by inheriting the VIP port.
      interval 15
      faildetect 2
      passdetect interval 15
      passdetect count 2
      open 2
    rserver host SERVER1_ACCESS
      ip address <1AC>
      inservice
    rserver host SERVER2_ACCESS
      ip address <2AC>
      inservice
    serverfarm host ACCESS-SFARM
      probe PROBE_GENERIC_TCP
      rserver SERVER1_ACCESS
        inservice
      rserver SERVER2_ACCESS
        inservice
    class-map match-any OCS_L4ACCESS
      2 match virtual-address x.x.x.176 tcp eq https
      2 match virtual-address x.x.x.176 tcp eq 5061
    policy-map type loadbalance first-match OCS_L4ACCESS
      class class-default
        sticky-serverfarm ACCESS_STICKY
    policy-map multi-match POLICY
    class OCS_L4ACCESS
    loadbalance vip inservice
    loadbalance policy OCS_L4ACCESS
    loadbalance vip icmp-reply active
    connection advanced-options OCS_VIPTIMEOUT
    nat dynamic XXX vlan 503

    Even if you use the 4710 appliance or expect the inheritance in the module software, it's worth considering if this is really what you want. If you keep multiple ports in the L3/L4 class-map you can't handle the services independently. You will have a common serverfarm for both https and 5061. If https service stops on one rserver, the ACE will place that rserver (and not that service) in out-of-operation state and it won't receive any 5061 traffic either. (You have the fail-on-all probe option but I wouldn't say it's a better choice. In that case, https traffic would be sent to the rserver even if https port is closed as long as there is at least one working service on it.) That's why I prefer a separate class-map and separate serverfarm for each service. (They can contain the same rservers, no need to duplicate.) BUT if the software supports probe port inheritance, you can benefit from it even in this scenario: serverfarm-443 and serverfarm-5061 can both use your PROBE_GENERIC_TCP.

  • Error when creating Logical Port via WSDL on SOAMANAGER

    Hi,
    When  creating Logical Port via WSDL on SOAMANAGER we're getting the following error:
    "Uninstantiated object u201Csubject sidl serviceu201D in method IF_SRT_WSP_CONFIG_SIDL~CREATE_CLNT_CFG_FROM_WSDL_D of class CL_SRT_WSP_CONFIG_SIDL".
    We're consuming a WS provided by a .NET application.
    Our system is ECC 6.0 NW 7.01SP 7.
    Anyone have faced this error before?.

    hI,
    Please go through this link , you will get the solution
    http://www.sdn.sap.com/irj/scn/go/portal/prtroot/docs/media/uuid/20eb3174-41ab-2a10-a383-907faf60eed3

  • Need to setup monitoring aon multiple ports for IDS

    I have a cisco 3845. I need to need to setup monitoring aon multiple ports for IDS on 2 ports. How do I do this.
    Also,
    Is there a way to make ports on the switch portion act like hubs.
    Thanks

    I assume that you are referring to the Ethernet Switch Module in the 3845. If so it should support SPAN. Here is a SPAN configurations guide:
    http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122newft/122limit/122z/122zj15/fz1636nm.htm#1820129

  • Listen on multiple ports for smtp?

    Traditionally, we've provided setup smtp to listen on an additional port to 25 for travellers who find themselves on an ISP which blocks that port. We used a line in master.cf like:
    <newportnumber> inet n - y - - smtpdproxywrite unix - - n - 1 proxymap
    This seems to make snow leopard's postfix unhappy. It also doesn't work. I'd be grateful if anybody could tell me:
    * what is or where to look for info on setting up postfix to do multiple ports? I've tried Apple docs and found nothing and only old-style in postfix docs -- though I could be missing something obvious as always.
    * is this the modern and preferred way to get around the blocked port 25 problem or is it better to do some fancy-schmancy port redirection eg at the firewall to map multiple ports on to port 25 for postfix?
    thanks and allbests,

    In the past I've used the following with great success. Add the following line to /etc/postfix/master.cf file:
    2525 inet n - n - - smtpd
    Stop and start the mail service. Then test with telnet to ensure that the port is responding. Sadly, this still appears to be the best way, sans the use of a VPN, to get around ISP blocking.
    Obviously port 25 needs to be open to receive mail. But instead of opening additional port in the firewall, you could drive all users to VPN.
    I just tested the above line in 10.6.1 and it is responding.
    Hope this helps

  • Multiple Port Mapping

    Hey all, I've bounced around here and the knowledge base a bit and couldnt find my answer.
    I have a range of 120 ports that I need to forward to my computer. I've already got everything with static IP and a couple ports working like a top.
    Basiclly I'm wondering if its possible to forward a range of ports instead of having to 120 seperate entries.
    I'm aware of the dmz option but would rather not have it wide open.
    Thanks all!

    You're correct in your analysis and this would have worked. Turns out the telephone adapter, TA, is a router (although ATT Callvantage said it was not). I brought in a local apple dealer's network sensei and he first changed the IP address of the TA to 10.1.1.201, just outside the range that my APE assigned to my computers and APE's. But, the TA needed multiple ports forwarded, including the range of 10,000 to 11,000. This killed that approach. What was done is that the TA was connected between the APE and the DSL modem. This seems to be working very well.
    The network tech saidn that the lack of ability of the APE to both forward more than 20 ports and no ability to forward a range of ports is a huge drawback. The tech said that he uses a Linksys router for his own personal network.
    I f I didn't use wireless printing and the APE with my iTunes, I'd betempted to can the APE. I am very disappointed in Apple.
    Regards, Axxel

  • SM59 : change the field comment (logical Port by wsdl)

    Hello,
    I consume a webservice.
    I have created a logical Port by wsdl in the soamanager. After saving the logical Port, a http connection is created in SM59.
    In the transaction SM59 'HTTP CONNECTIONS TO EXTERNAL SERVER" <Automatische Web Service Konfiguration> is automatically written into the comment field.
    http://www.pictureupload.de/originals/pictures/090312102328_sm59_G_typ.JPG
    My problem is, this comment cannot be changed by hand.
    Does anybody know, how I can change the field comment by hand in SM59 (when I have created a logical Port in the soamanager)?
    best regards,
    Stephan

    hI,
    Please go through this link , you will get the solution
    http://www.sdn.sap.com/irj/scn/go/portal/prtroot/docs/media/uuid/20eb3174-41ab-2a10-a383-907faf60eed3

  • Static unicast MAC entry in multiple ports Cat6500VSS

    Hello, I'm trying to configure a static mapping of a MAC address in two different ports on a Catalyst 6500 switch.
    My situation is: I've configured a Cluster of Firewalls which exposes a unicast MAC addres for the cluster virtual interface. The situation is that the MAC address is a unicast one, and when the swith sees the MAC from multiple ports, it gets confused and starts doing flooding in all the VLAN.
    The configuration I'm trying to do is for a McAfee Firewall conected to 2 Catalyst 6500 in VSS mode. Here is the article of the firewall vendor with the recommended configuration: https://kc.mcafee.com/corporate/index?page=content&id=KB61307&actp=null&viewlocale=en_US&showDraft=false&platinum_status=false&locale=es_ES
    What i want to do is to configure unicast mirrored mode, and in that mode, I have to run this command on Catalyst 6500 and I can't:
    mac-address-table static 000e.a210.440a GigabitEthernet 1/1/3 GigabitEthernet 2/1/3
    Note that the mac address is a unicast one
    How can I do That? Any help will be appreciated

    Hello,
    There is a fundamental architecture difference between the 2 platforms regarding the internal forwarding of frames. With the 3550 the notification packet is sent after a lookup and the results index can contain more than one entry where as with other architectures the results are limited to a single entry. Basically that is why you can configure an ARP entry to point to different ports on the 3550 versus other platforms.
    Hope that helps.
    Regards,
    James

  • PXI 6511 reading multiple ports in parallel

    I am reading multiple ports in parallel, and it seems to be working fine until I send out data on the MIL STND 1553 bus then the 6511 readings are whacky. Don't know how the 1553 affects the 6511, but am wondering if there is a better way to read the 2 ports in parallel, maybe some of the instability (?) may go away.
    Grasping at straws but figure this is something I can confirm through the community.
    Is there anything obviously wrong (or flakey) about how I am reading these two ports? Is there a better way?
    TIA
    lmd2
    Message Edited by lmd2 on 03-28-2006 02:18 PM
    Lawrence M. David Jr.
    Certified LabVIEW Architect
    cell: 516.819.9711
    http://www.aleconsultants.com
    [email protected]
    Attachments:
    6511 Read 2ports.vi ‏122 KB

    Thanx
    this is a very good tip, I didn't know that multiple ports could be input with a comma delimiter.
    the 1553 bus seems to not be an issue (?) but the circuit had a bad IC that was engaged by the 1553 command.
    Anyway I rally appreciate the tip  -   that will come in handy for sure.
    lmd2
    Lawrence M. David Jr.
    Certified LabVIEW Architect
    cell: 516.819.9711
    http://www.aleconsultants.com
    [email protected]

  • Opening multiple ports on Airport Extreme

    I need to open multiple ports on an Airport Extreme to allow for ftps service (about 500 ports). In port forwarding, it appears that I would have to enter 500 entries to do that (e.g. port 4001, 4002, 4003 etc.) Sounds wacky. In other routers (or linux sortware), multiple entries can be entered like "400, 4000-4500". Apple docs don't address this (from what I could find). Is there a syntax for multiple port forwarding?

    Are you using the round 802.11b/g AirPort Extreme base station (AEBS) or the square 802.11b/g/n AEBS?
    The round AEBS does not allow you to enter ranges. The only solution for a great number of ports is to use the default host option and send ALL the ports to the designated computer.
    I believe that the square AEBS allows you to enter ranges.

  • ERROR OWS-04045 during accessing multiple ports based web service

    I use WSA to publish a web service which have multiple ports.
    The ant build script :
    <oracle:assemble appName="${app.name}" ear="${app.name}.ear"
    targetNamespace="http://www.xxx.com" classpath="${domestic.class.path}"
    input="${web.home.path}/WEB-INF/classes" output="${archive.output.path}"
    style="rpc" mappingFileName="type-mapping.xml" appendToExistingDDs="true"
    serviceName="${app.name}">
    <oracle:porttype interfaceName="com.xxx.service.ICompanyDefinerWebService"
    className="com.xxx.CompanyWebServiceImpl">
    <oracle:port name="company" uri="company" />
    </oracle:porttype>
    <oracle:porttype interfaceName="com.xxx.IUserDefinerWebService"
    className="com.xxx.UserProfileWebServiceImpl">
    <oracle:port name="userprofile" uri="userprofile" />
    </oracle:porttype>
    </oracle:assemble>
    There is a class name UserDTO which extends another class AbstractDTO, which locates in another package. I used a type-mapping file for giving them different namespaces.
    After deployment, I can use the url http://localhost:8888/xxx/userprofile to access the web service. OC4J provided a javascript based stub for testing.
    But I met some problems. When I use the web stub to access it , error occurs.
    ERROR OWS-04045 Malformed Request Message:Caught exception while handling request: unexpected element name: expected={http://www.xxx.com/framework/bean}operationRecord, actual={http://www.xxx.com/user/dto}operationRecord
    I switched the form to display in xml before invoke, I found there are different and correct namespaces on these 2 elements (UserDTO and OperationLog) .So, I'm very strange why the server will response such a fault information.
    In addition, if I use default style (just document-wrapped) to publish web service, almost all methods can not be accessed on web stub which is provided by oracle.
    Surely, the problem is caused by multiple port. The soap specification is 1.2 and JDK is SUN 1.5.0-b6, OC4J is 10.1.3.3
    I just want to konw whether oracle have some better practices or suggestion for publishing a web service which will have multiple ports.
    The other problem is we can not use abstract class(only support interface) when we want to use WSA to assemble a web service based EAR.

    Is it possible to use several "class L4VIPCLASS" inside the "policy-map multi-match VIPs" in order to have several VIPs to load-balance services for several serverfarms?
    Something like this:
    class-map match-all L4VIPCLASS-1
    2 match virtual-address 172.16.1.1 tcp eq www
    class-map match-all L4VIPCLASS-2
    2 match virtual-address 172.16.1.2 tcp eq www
    class-map match-all L4VIPCLASS-3
    2 match virtual-address 172.16.1.3 tcp eq 8081
    policy-map type loadbalance http first-match WEB_POLICY-1
    class class-default
    serverfarm-1
    policy-map type loadbalance http first-match WEB_POLICY-2
    class class-default
    serverfarm-2
    policy-map type loadbalance http first-match WEB_POLICY-3
    class class-default
    serverfarm-3
    policy-map multi-match VIPs
    class L4VIPCLASS-1
    loadbalance vip inservice
    loadbalance policy WEB_POLICY-1
    loadbalance vip icmp-reply active
    loadbalance vip advertise active
    nat dynamic 1 vlan 11
    class L4VIPCLASS-2
    loadbalance vip inservice
    loadbalance policy WEB_POLICY-2
    loadbalance vip icmp-reply active
    loadbalance vip advertise active
    nat dynamic 2 vlan 22
    class L4VIPCLASS-3
    loadbalance vip inservice
    loadbalance policy WEB_POLICY-3
    loadbalance vip icmp-reply active
    loadbalance vip advertise active
    nat dynamic 3 vlan 33
    interface vlan XX
    service-policy input VIPs
    Many thanks for your support.

Maybe you are looking for