NAT is not working for VRF partially

Hello!
I have a diagram like this:
VRF_A  and VRF_B have overlapping addressing plans from series 192.168.x.x.
As routing protocol in both of VRFs adopted RIP (I tried all, but effect much the same).
The closest to PE1 network is 172.16.0.0/24.
PE1:
ip vrf VRF_A rd 65001:1 route-target export 65001:1 route-target import 65001:1ip vrf VRF_B rd 65001:2 route-target export 65001:2 route-target import 65001:2ip nat inside source list 10 interface FastEthernet0/0 vrf VRF_A overloadip nat inside source list 10 interface FastEthernet0/0 vrf VRF_B overloadip route vrf VRF_A 0.0.0.0 0.0.0.0 FastEthernet0/0 172.16.0.1 globalip route vrf VRF_B 0.0.0.0 0.0.0.0 FastEthernet0/0 172.16.0.1 globalinterface FastEthernet0/0 ip address 172.16.0.24 255.255.255.0 ip nat outside duplex fullinterface FastEthernet1/0 ip vrf forwarding VRF_A ip address 192.168.0.2 255.255.255.0 ip nat inside duplex full
interface FastEthernet4/0 ip vrf forwarding VRF_B ip address 192.168.0.2 255.255.255.0 ip nat inside duplex full
When I try ti ping 172.16.0.1 from CE11, CE21 and from VRF_A and VRF_B on PE1 - all if fine! NAT is performed and ping is OK.
But when I tried to ping from others (PE2 and CE21 and CE22) NAT is not performed, I see 192.168.x.x at Internet Router and ping is failled.
I'm in stupor. What could it be??? And how to avoid this situation? Are there "exits"?
I forgot to mention that there is a full connectivity inside both of VRFs. Routing protocols and redistribution work fine.
Kind regard,
Ellad

It's wrong:
PE1interface toward P1 ip nat insideinterface toward P2 ip nat inside
Here is PE1:Current configuration : 2829 bytes
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
hostname PE1
boot-start-marker
boot-end-marker
no aaa new-model
ip subnet-zero
ip vrf VRF_A
rd 65001:1
route-target export 65001:1
route-target import 65001:1
ip vrf VRF_B
rd 65001:2
route-target export 65001:2
route-target import 65001:2
ip cef
ip audit po max-events 100
mpls label protocol ldp
interface Loopback0
ip address 10.0.2.1 255.255.255.255
interface FastEthernet0/0
ip address 172.16.0.24 255.255.255.0
ip nat outside
duplex full
interface FastEthernet1/0
ip vrf forwarding VRF_A
ip address 192.168.0.2 255.255.255.0
ip nat inside
duplex full
interface FastEthernet2/0 ip address 10.0.23.1 255.255.255.0
duplex full
tag-switching mtu 1512
tag-switching ip
interface FastEthernet3/0
ip address 10.0.24.1 255.255.255.0
duplex full
tag-switching mtu 1512
tag-switching ip
interface FastEthernet4/0
ip vrf forwarding VRF_B
ip address 192.168.0.2 255.255.255.0
ip nat inside
duplex full
router ospf 1
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0
router rip
version 2
no auto-summary
address-family ipv4 vrf VRF_B
redistribute bgp 65001 metric 1
network 192.168.0.0
no auto-summary
exit-address-family
router bgp 65001
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.0.5.1 remote-as 65001
neighbor 10.0.5.1 update-source Loopback0
address-family vpnv4
neighbor 10.0.5.1 activate
neighbor 10.0.5.1 next-hop-self
neighbor 10.0.5.1 send-community both
exit-address-family
address-family ipv4 vrf VRF_B
redistribute static
redistribute rip
no auto-summary
no synchronization
exit-address-family
address-family ipv4 vrf VRF_A
no auto-summary
no synchronization
exit-address-family
ip nat inside source list 10 interface FastEthernet0/0 vrf VRF_A overload
ip nat inside source list 10 interface FastEthernet0/0 vrf VRF_B overload
ip classless
ip route vrf VRF_A 0.0.0.0 0.0.0.0 FastEthernet0/0 172.16.0.1 global
ip route vrf VRF_B 0.0.0.0 0.0.0.0 FastEthernet0/0 172.16.0.1 global
no ip http server
no ip http secure-server
ip extcommunity-list 1 permit soo 65002:901
access-list 1 deny   10.1.8.1
access-list 1 deny   10.0.8.1
                          access-list 1 deny   10.1.2.1
access-list 1 deny   10.0.2.1
access-list 1 permit any
access-list 10 permit 192.168.0.0 0.0.255.255
access-list 10 permit 192.168.1.0 0.0.0.255
route-map rm-soo permit 10
set extcommunity soo 65002:901!
route-map rm-soo-action deny 10
match extcommunity 1
route-map rm-soo-action permit 20
match ip address 1
gatekeeper
shutdown
line con 0
exec-timeout 144 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
end
1.0.5.1 is Loopback0 of P3. It's a route-reflector for all PEs. I study.
And all what you see above - Dynamipses. Internet router - real Ubuntu server.

Similar Messages

  • Cisco 871 NAT configuration not working

    The problem is that NAT is not working for the "internal" network.
    If i own the ip 10.0.0.15 for example and i try to reach x.x.x.x:65009 i will not work.
    what's the problem?
    here is the configuration:
    interface FastEthernet0
    interface FastEthernet1
    interface FastEthernet2
    interface FastEthernet3
    interface FastEthernet4
    description $FW_OUTSIDE$$ES_WAN$$ETH-WAN$
    ip address x.x.x.x 255.255.255.192
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nat outside
    ip virtual-reassembly
    ip route-cache flow
    duplex auto
    speed auto
    interface Vlan1
    ip address 10.0.0.1 255.255.255.192
    ip access-group 2 in
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nat inside
    ip virtual-reassembly
    ip route-cache flow
    ip tcp adjust-mss 1452
    ip nat inside source list 1 interface FastEthernet4 overload
    ip nat inside source static tcp 10.0.0.12 60022 x.x.x.x 65000 extendable
    ip nat inside source static tcp 10.0.0.12 80 x.x.x.x 65001 extendable
    ip nat inside source static tcp 10.0.0.12 21 x.x.x.x 65002 extendable
    ip nat inside source static tcp 10.0.0.12 389 x.x.x.x 65003 extendable
    ip nat inside source static tcp 10.0.0.12 3306 x.x.x.x 65004 extendable
    ip nat inside source static tcp 10.0.0.12 10000 x.x.x.x 65005 extendable
    ip nat inside source static tcp 10.0.0.12 443 x.x.x.x 65007 extendable
    ip nat inside source static tcp 10.0.0.21 80 x.x.x.x 65009 extendable
    ip nat inside source static tcp 10.0.0.21 22 x.x.x.x 65010 extendable
    ip nat inside source static tcp 10.0.0.12 8080 x.x.x.x 65011 extendable
    ip nat inside source static tcp 10.0.0.21 21 x.x.x.x 65012 extendable
    ip nat inside source static tcp 10.0.0.21 3306 x.x.x.x 65013 extendable
    logging trap debugging
    access-list 1 remark SDM_ACL Category=2
    access-list 1 permit 10.0.0.0 0.0.0.63
    access-list 2 deny 10.0.0.8
    access-list 2 deny 10.0.0.2
    access-list 2 deny 10.0.0.3
    access-list 2 deny 10.0.0.6
    access-list 2 deny 10.0.0.7
    access-list 2 deny 10.0.0.4
    access-list 2 deny 10.0.0.5
    access-list 2 permit 0.0.0.0 10.0.0.63
    Posted by WebUser ??????? ???

    No, the ranges are not the same. That is, they share the same B-class stats, but no C-class.
    Incidentally, the extendable parameter is present in this ios version. When I change the parameter interface dialer0 to the ip address associated with the interface, extendable is addedd automatically. No joy however.
    Today I'm going to try and downgrade the ios, another router with 12.4(4)T1 does have functional port mappings....

  • Half Day LOP / Unpaid Absence not working for payroll india

    Dear Gurus,
    I have created Unpaid leave which is working correctly when we maintain full day absence in infotype 2001.
    But it is not working for partial absence ie, half day.
    I would really appreciate if you help me out on this issue.
    Thanks,
    Rajesh Badita

    Dear Venkey / Rajesh,
    My issue is resolved. We have tried with Custom PCR which will convert absence days into hours. With this we are able to achieve the desired result.
    Copied from standard PCR "INP1" to "ZNP1" and modified "/801 partial period factor 1" logic. Below is the PCR for your kind reference.
    RTE=TKSOLL
    RTE*8
    RTE-TSAU**
    RTE/8
    RTE*KGENAU
    RTE/TKDIVI
    ADDWT *
    Kindly go through the below link which is very useful. Hence closing the thread. Thanks for your valuable inputs.
    http://wiki.sdn.sap.com/wiki/display/sandbox/PCRmodificationincaseofHalfdayUnpaidLeave(LOP),IndiaPayroll
    Thanks & Regards,
    Rajesh Badita
    Edited by: Rajesh Badita - ABAP HR on Oct 13, 2011 7:05 AM
    Edited by: Rajesh Badita - ABAP HR on Oct 13, 2011 7:08 AM

  • I have an event in my calendar that was sent by someone who does not work for the company anymore and I am reminded 2 times a week. How can I remove it?

    I have an event in my calendar that was sent by someone that does not work for the company anymore and I am reminded 2 times a week. How do I delete it?

    Tap on the event to open the event. Click the 'Edit' button in the event bubble, then press the 'Delete Event' button at the bottom of the Edit pop-up. It's a little different for events that come through Microsoft Exchange, you tap the event to bring up bubble and click the 'Details' button, and then press 'Decline' to remove the event.

  • IPhone 6 External Mic not working for Siri/Dictation

    I am finding that the external mic on my iPhone 6 works for phone calls and voice memos, but does not work for Siri/Dictation.  When I plug in the earbuds, they work for everything (including Siri/Dictation).
    Was chatting to Apple support who had me reset all settings.  I thought that worked, but realized that after a reset, Siri is off and I was talking to "Voice control" (which works).  When I turned Siri back on, it does not work.
    I have two questions for the community to see if you can help:
    1- I have been assuming this must be a software problem since the mic does work for non-Siri access.  But is that true?  Is there a hardware component that Siri depends on which could be faulty here?
    2- If it is software, what action should I try to address it?  I have done a reset all settings already and that did not help.
    Doug

    Hi, everyone.  I talked to Apple Genius at Apple Store last week, she said it should be a software issue and I needed to reset my iphone 6 plus as a new device and I can not use the backup restore from my iCloud, it was because the microphone bug or glitch can be in the backup also. Ok, followed her advice, erased all contents and set my iphone as a new device , the microphone worked for an hour, but went bad again.  I used "voice memo" app from Apple to test the microphone. It is the best tool since it doesn't involve any provider's network and it doesn't need another person's phone to listen and test.  If you can hear your voice recording clearly, then the mic works.  I tested it 3-4 times a day for a few days now, half of the time the mic doesn't work.  So, set as a new device isn't working. The issue is intermittent and it comes and goes as it likes, so very annoying. I carry my Apple EarPods with me in these past few days ust in case I need to make important phone calls.  Will need to go back to Apple Genius this weekend for sure.  Will give update after the weekend.

  • CALLER ID not working for International incoming calls

    Hi,
    I've a strange issue where CALLER ID not working for International incoming calls, it shows INTERNATIONAL UNKNOWN NUMBER in the phone display, but the number shows correclty in Verizon Call assistant !!!
    Any clue?

    yashshankar wrote:
    Hi
    I recently  purschased an Online number but the caller id does not work for incoming calls.How do we resolve this problem?.
    Regards
    Yash
    You didn't mention what country your Online Number is in.  Not all of Skype's Online Numbers are eligible for use as Caller ID when calling telephones or sending SMS messages.  If your number is from one of these countries (Chile, Denmark, Estonia, Hong Kong, Poland, Sweden, the UK and the US), then it can be used this way.  Otherwise, you can use a mobile number from countries other than Japan or Mexico as Caller ID with Skype, after the number goes through a verification process where Skype sends SMS messages with codes to that number.
    To get to these settings, log into your Skype account here on the Skype web site using the "Account" link at the top of this page.  You'll see a screen that would include your current Caller ID settings, and a link to change that.  If your Online Number is from one of those countries I referenced above, just select it and you're done. 
    Hope that helps!
    Patrick
    Location/Ubicacion: Arizona USA
    Time Zone/Hora Local: UTC/GMT -7
    If this message has adequately addressed your issue, please click on the “Accept as Solution” button. If you found a post useful then please "Give Kudos" at the bottom of my post, so that this information can benefit others.
    Si esto mensaje le ha ayudado, por favor haga clic en "Aceptar como solución". Si encuentra un mensaje útil, por favor "Da Kudos" al final del mensaje, por lo que esta información puede beneficiar a otros.
    I am not a Skype employee. No soy un empleado de Skype.

  • Select All in a table does not work for Drag and Drop

    Hi. I am using Jdeveloper 11.1.1.2 but have also reproduced in 11.1.1.3.
    I am trying to implement drag and drop rows from one table to another. Everything works fine except when I do a Select All (ctrl-A) in a table, the table visually looks like all rows are selected, but when I try to click on one of the selected rows to drag to the other table, only the row I click on is dragged.
    I tried setting Range Size -1, fetch mode to FETCH_ALL, content delivery to "immediate" but nothing works.
    I even have reproduced not using a view object but just a List of beans with only 5 or 10 beans showing in the table.
    Does anyone know how to get Select All to work for a Drag Source?
    Thanks.
    -Ed

    Frank-
    OK, thanks for looking into that. I also submitted this service request, which includes a simple sample app to demonstrate the problem:
    SR #3-2387481211: ADF Drag and Drop does not work for rows in table using Select All
    Thanks again for the reply.
    -Ed

  • Form Designed in LiveCycle will not work for End User

    Please Help!
    I am a newbie to Adobe LiveCycle but recognized the utility in the program, so decided to give it a while to try and streamline some of my employer's forms.  After spending too much time learning how to design a form (much to the dislike of my boss), I am finally going to have to ask for some help.  So here's the deal:
    I've designed a dynamic pdf in LiveCycle with two master pages and two repeating flowed subforms.  The first repeating subform is basically an expanding table intended to be used as a photographer's log where they can log each photo taken with the camera.  The expanding table has some code with a button at the top for the end user to enter the number of photos on the photo roll, click submit, and table expands to however many instances of rows are needed for each photo that was taken.  The second subform is basically an image field and text fields used as photo captions/photo compilation pages.  When the end user clicks submit on the first subform to expand the table, I also have javascript in that click event to also create same amouint of instances of the second subform (the photo compilation page(s)).  Each text field for the photo caption on the second subform is populated by the data entered into the photo log table cells.  I was able to find a script to correctly populate those fields for each instance of the table.  Wish I had the form here, but it's at work at the moment.
    My problem is this: I've scratched and clawed to get all of the forms expanding correctly and the scripts populating each instance of the fields correctly and everything works great in LiveCycle preview.  I then saved the form as PDF for use by my field crew personnel (whom all use, at the very least, Adobe Pro 9, but most Pro X).  I sent the new form to them and they move it to their desktop, open it with Adobe Pro, and populate all of the fields and everything works swimmingly.  However, once they save it, it gets all jumbled and they can't even print it.  We even thought we found a workaround by entering all data and printing to PDF, but even that has turned out to not work.  I checked to make sure that I designed and saved the form in LiveCycle for use with the Adobe Pro versions, but still not working for my end users.
    Anyone have any thoughts on my long explanation??  Please HELLLLPPPP!

    The error(s) occur when trying to save the document.  I want each user to tell the first page how many rows they will need in the photo log table, so they would enter however many photos were taken in the box: "Number of Photos on Roll:"  ---> Then click the "Submit" cmd button.  That should expand the table.  Once it expands, it should also add the same amount of instances of the photo compilation page (2nd Page) as there are rows in 1st page table.  Then the user will populate each cell of the table on page 1 with data.  The data entered into the page 1 table cells will populate the text fields (photo caption) in Page 2 once the user clicks on the "Populate Captions!" cmd button in the lower left corner of the table on Page 1. 
    The problem is in the distributing of the form to the user so they can save the form after populating the data.  I did a test run this morning and for some reason it did do the "print to PDF" correctly for 5 photos on the roll (though this has not been happening every time and especially for a large number of pages, ie. 80 photos).  However, after entering the data for 5 rows on page 1 and then populating the 5 photo compilation pages, I saved a copy as "Save As PDF" and closed the document.  Then re-opened the copy in Acrobat Pro X.  The new copy:
    -had 5 additional rows added to Page 1
    -Duplicates of some of the fields
    -Only retained the 1st instance of the Second Page (Photo w/ Caption) and not all fields were populated
    Again, this all works fine in the LiveCycle Preview but not anywhere else.  I do not have this set up to be linked to an external data source (YET) but there is javascript in the cmd buttons.  I also do not want to distribute this form to end users and then collect the data back from them.  I want them to be able to save a copy of my LiveCycle designed form, open in Adobe Pro, populate the data and save as many copies as needed for form production.

  • Wake on Demand: Not working for some services, others OK

    I haven't been able to figure this problem out... Wake on Demand for a previous generation Mac mini running Snow Leopard 10.6.8 works for things like a CrashPlan automated backup but does not work for things like remote SSH login or Screen Sharing. In all cases, the services are being originated on a latest generation iMac running Mac OS X Lion (10.7.2).
    While it's not an earth-shattering event to get off my backside and walk over to the Mac mini across the house to press its Shift key to waken the thing, it gets rather old to have to keep doing so, especially since CrashPlan automated backups are taking place while the Mac mini is otherwise asleep (the sleep indicator is slowly pulsing).
    I've been through the Apple tech notes regarding Wake on Demand for Snow Leopard 10.6 and have ensured that AirPort and its network are at the top-most position in their respective lists. Other than that, I'm not sure what else I can do. Wake on Network is enabled in the Snow Leopard Mac mini's network System Preferences and there doesn't seem to be any on/off option in the AirPort Extreme base station (just recently updated to 7.6 firmware).
    Any thoughts... hints... suggestions?
    One final note: this Mac mini is new as of July 2011; just days before the latest generation of Mac mini came out. It came pre-installed with Snow Leopard and, as soon as the users of this mini find software replacements for the old PPC style applicaitons they're used to using, will be upgraded to Lion. However, I feel a bit unsettled in making the move to Lion if I can't get a Snow Leopard feature to work properly. There's no telling if the Lion upgrade will actually fix this behavior or make it worse.
    Thanks in advance.

    I don't think you can wake on network with a closed lid. Try keeping the lid open and putting the machine to sleep. Does it work?

  • DNS not working for some computers

    We have a SRP521W router and is set up with one SSID for wireless. In our office all the computers (5) can connect but only some may get on the internet. I have a laptop I am testing with and it will not connect, wired or wireless.
    I found an article relating to flushing DNS, tried that, no luck.
    I found another that said I should try setting my DNS to 208.67.222.222 and this worked, internet works fine.
    I tried rebooting the DSL modem and router, tried many different things but am not a networking guru so I am just not sure why the DNS is not working for one computer but works for another, connected to same LAN or SSID.
    Thanks,
    Brad

    Though what Don posted is one way to accomplish it, I never add anything to my DNS and it works fine.  Windows DNS, in a default installation, will automatically forward to the root (.com, .edu, .gov, etc.).  So I always just point my workstations
    to my Domain Controller as their DNS and everything works just fine without any additional configuration.
    Guess I'm one of those who won't even trust Google for sharing a DNS, particularly when I have never needed to set up any forwarders.
    .:|:.:|:. tim

  • Thunderbird Mission Control Desktop/AutoConfig not working for some users

    I have the file: "C:\Program Files (x86)\Mozilla Thunderbird\defaults\pref\custom.js"
    It contains:
    pref("general.config.obscure_value", 0);
    pref("general.config.filename", "TMcustom.cfg");
    I have the file: "C:\Program Files (x86)\Mozilla Thunderbird\TMcustom.cfg"
    It contains:
    var promptService = Components.classes["@mozilla.org/embedcomp/prompt-service;1"]
    .getService(Components.interfaces.nsIPromptService);
    promptService.alert(null, "title", "testing");
    For most of my users the alert pops up fine when I start Thunderbird, but for a few it doesn't. All of the machines where setup with the same install script. If I log into one of the machines where it's not working as a different user, then it works fine, so I know the files are in the right spot. So why would it not work for specific users? Is there something in the user's Windows profile that could cause it to not work? Or are there any other suggestions?

    As it turns out this was a known bug that was corrected in the recent release of Java 7_65 and Java 8_11. Here is a link to the bug description in the database.
    Bug ID: JDK-8019274 RMI thread can no longer call out to AWT thread for webstart app

  • After Upgradation BPF is not working for some users

    Hi All,
    We have recently upgraded from BPC 5.1 to 7MS SP7.  we are having multi server setup with one application / reporting server (windows 2003 and one sql server 2008 (windows 2003 64 bit).
    Intially before upgradation we don't have any issues with BPF and it worked fine for all users. But post upgradation tasks within the BPF  does not work for other users except for the first two people who first  used it. Other users have the same rights as the ones who can access the tasks.
    when they  click on the link it gets them to eExcel and the right application but doesnt open the package or report assigned to the task. It doesn't give us any errors, on the status bar we get a message finalising but does  not getting any thing.
    Any inputs ??

    Hi,
    Are you sure that those users have installed BPC 7 SP7 clients on their machine? Meaning that you uninstalled 5.1 clients and installed the new client from http://servername/Osoft?
    If yes, you should maybe run a client diagnostic on the machines and also check the Management Console for any error messages.
    Hope this will drive you to a potential solution.
    Best Regards,
    Patrick

  • Outlook autodiscover is not working for some users in coexistence

    Hi
    We are doing exchnage 2013/2010 coexistence
    Most everything is ok BUT outlook autodiscover is not working for some exchange 2010 users now that 2013 is in the front!!!.  We end up creating the profiles manually.  It has affected some but not all the users.
    I followed the instructions here but it didn't help.
    http://blogs.technet.com/b/tips_from_the_inside/archive/2012/01/11/autodiscover-fails-for-one-or-more-users.aspx
    Using outlook 2010, 2013, patches, .... didn't make a difference
    Would you please help?
    Thank you

    Hi 
    If it is affecting only few handful of users i could suspect a mailbox corruption and would recommend to move mailbox and see the results.
    Also you can try below
    You need to set the values MaxFieldLength, MaxRequestBytes & MaxTokenSize to below on Exchange 2010 CAS servers as well as Exchange 2013 CAS servers
    Path: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\HTTP\Parameters
    Name: MaxFieldLength
    Type: DWORD
    Value: 65534
    Path: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\HTTP\Parameters
    Name: MaxRequestBytes
    Type: DWORD
    Value: 16777216
    Path: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\Kerberos\Parameters
    Name: MaxTokenSize
    Type: REG_DWORD
    Value: 48000 
    Just reboot the servers once its done and you will be good to go.
     References
    https://social.technet.microsoft.com/Forums/en-US/cc2929ac-4d36-4e84-a567-ce9b3bec1398/http-400-bad-request-on-iis-8-exchange-2013-cu2-on-windows-server-2012-autodiscovery-is-not?forum=exchangesvrgeneral
    http://blogs.technet.com/b/kristinw/archive/2013/03/28/recommended-changes-and-enhancements-to-support-exchange-in-an-enterprise-environment-whew.aspx
    Remember to mark as helpful if you find my contribution useful or as an answer if it does answer your question.That will encourage me - and others - to take time out to help you Check out my latest blog posts on http://exchangequery.com Thanks Sathish
    (MVP)

  • Software Update Point Switching is not working for some Clients

    Hi there,
    I found nothing similar here and I hope this is the right section.
    I´m running ConfigMgr 2012 R2 where one of the Site Systems from one of the Primaries is located in an untrusted Forest in a perimeter Network. The Site System there has the MP, SUP and DB Roles. In general it works great. The Systems in that untrusted Forest
    get the SCCM Agent pushed, see and can install published Software packages and receive Windows Updates. But there are a few systems where everything works, except Windows Updates.
    So I had a deeper look at what is happening and found out that the SUP switching is not working for them. They always try to contact the SUP from the Primary, which they cannot reach (this is intended).
    From how I understand SUP switching as described here
    http://blogs.technet.com/b/configmgrteam/archive/2013/03/27/software-update-points-in-cm2012sp1.aspx#pi140062=1
    the Windows Update Agent tries to connect to a SUP every 30 minutes and after 4 failed attempts he will try to connect to the next one until he finds one which works.
    As I said before, this seems to work for most systems in the untrusted forest, but some do not make any intentions to switch the SUP.
    So my next step was to find out from where the Update Agent can get the information of the available SUPs. I think they either don´t receive the information that other SUPs exist, or if the Information is there, they don´t realize that there´s an error and
    make no attempt to switch.
    I used the System Center Support Center to gather all Information from some of the systems with that problems (Log Files, WMI information, registry information, policies etc.) but I cannot find where SCCM or the Update Agent store the information which SUPs
    are available in my environment.
    I´m sure the problem is on the Systems which fail to connect to the right SUP and not in the SCCM infrastructure itself, because for most of the systems everything is working just perfect. Unfortunately in the Blog Post above there´s also no information
    where this information is stored and how it is obtained by the clients. In the comments there´s even one post which describes the same problem I have here, but there was no answer. I hope someone can point me into the right direction, because I´m stuck currently.
    Things I tried additionally to all the log file / WMI / registry sniffing:
    Removing the Software Distribution Folder and restarting the Windows Update Agent
    Removing the WindowsUpdate Registry folder in the HKLM\SOFTWARE\Policies\Windows section in the Registry and restarting the Windows Update Agent.
    Tried to reset the WUAgent with wuauclt /Resetauthorization additionally to the steps above.
    I also tried to manually set the WUServer and WUStatusServer Keys in the registry to the new Server, but as soon as the next Update Scan cycle runs, the value is set back to the URL of the Primary Sites SUP
    Is someone having additional ideas? It seems to me older systems are more affected (which were configured for a standard WSUS before SCCM 2012 was deployed) than newer ones which were installed when SCCM was in place already. But I don´t know what else to
    "reset" on those machines without reinstalling them.

    Thank you very much for your response. I must have missed that one by looking through numerous Logfiles. In this, there´s indeed a list of all available SUPs. So according to the LocationServices.log the machine should have a choice.
    The WMI Key however, contains just one entry and this is the URL of the Primaries SUP which is not reachable in the untrusted forest. Is it OK that the WMI entry includes only one entry? If yes, what process is putting the results from the LocationServices
    into WMI? It seems like the Windows Update Agent is feeded from the WMI Key then. If this is the case my problems seems to be the "communication path" between these two components.
    Is this the job from the SCCM Agent, the Windows Update Agent or maybe some third component I´m not aware of? I wonder how I can fix this.

  • My apple id is not working for my iPhone activation. Please help me.

    my apple id is not working for my iPhone activation. Please help me.
    i'll just restore it.

    Not working in what way?
    Only the Apple ID that was used to enable "Find My iPhone" on the device can be used to bypass Activation Lock.

Maybe you are looking for

  • Why the sound on my Apple TV is not working?

    How do I get the sound on my Apple TV to work

  • Windows 8.1 update not shown after factory reset

    I had the windows 8.1 update shown on my app store but due to some problems i factory reset the laptop. when i opened it after the restore i was unable to find the update on my store. Rather it shows 96 apps to be updated

  • Help - Database Growth and loading best practice

    Dear all, I'm using NW 7.1 my data are consuming lots of space. I notice my data are grow at 20Gb per 2 month. I wonder why the growth is so fast. I using process chain to load my data and I always delete my data before full update my cube. I kept on

  • Sharing files important answer quick

    Hello i need help with some java i need to know how to give files to ppl not like the .class and stuff that you need the command line for i need to know how to make any type of file i dont care what extention preferably .exe but doesnt have to be so

  • ABAP Query and BW Report

    Need an understanding of how do we judge or make out that for a particular report we can go for ABAP query and for one we can go for BW report.??? Please provide clear answer with example.. Thanks