NAT on ADSL Connection

I am having a ADSL connection with dynamic IP from my ISP, I am using a Cisco 837 router.
I need to access one of my servers from the internet. I am using a dyndns agent in my server so that I will know the updated IP address. I tried setting NAT on the dialer0 interface, but it did not work. I need to NAT 2 ports (port 22 and 122) to a LAN server: 192.168.5.11
Here is the original config file:
Please see attached.
I searched the web and I tried this:
config t
interface dialer0
ip access-group 104 in
exit
access-list 104 permit tcp any any eq 22
access-list 104 permit tcp any any eq 122
ip nat inside source static tcp 192.168.5.11 25 interface dialer0 22
ip nat inside source static tcp 192.168.5.11 25 interface dialer0 122
After I entered these command, I can no longer access the internet.
May I know where did I do wrong?
Can anyone assist me?
Thanks.

You should be using "inspection" on the internal and external interfaces.
Inspection will create dynamic holes in the firewall to facilitate traffic in the return path, and will simplify your interface ACLs.
The internal interface ACL should be configured to permit the specific protocols permitted (by security policy) for outbound communication. Applying inspection on the internal interface will provision the return path by opening dynamic holes in the outside interface ACL.
The same is done on the external interface. An ACL is created to permit connections from external hosts to your internal servers. Inspection is applied there to facilitate packets returning from your servers, by opening dynamic holes in the internal interface's ACL.
Inspection would be a better choice that using the established key word in ACLs.
e.g.: A simple inspection example:
ip inspect log drop-pkt
ip inspect audit-trail
ip inspect name our-insp tcp
ip inspect name our-insp udp
ip inspect name our-insp icmp
ip inspect name our-insp dns
ip inspect name our-insp ftp
ip inspect name our-insp pop3
interface Ethernet0
description ~5Mbps Exposed to Internet
ip inspect our-insp in
interface FastEthernet0
description Internal Network
ip inspect our-insp in
Note: Ideally you would migrate to Granular Protocol Inspection and avoid the generic UDP and TCP inspection, but that is up to you.
I've not looked at your NAT issues, just the lack of Internet connectivity following application of the limited ACL on the external interface.

Similar Messages

  • Two adsl connection on router

    Hi Guys,
    I have a router with two adsl connection, one of them is working fine. The another one I cannot see any packet going to the ISP. The interface atm is up, there is no reset, error, etc but the router doesn't try to connect to ISP, I see this when I enable debug ppp authentication.
    The two links are from the same service provider, so I have swap the links to be sure that both are working. I had no issues with links. The configuration are the same as you can see below, just the username and password are different.
    Any idea where is the issue?
    interface atm0
     no shut
     no ip address
     pvc 8/35
      encapsulation aal5mux ppp dialer
      dialer pool-member 1
    interface dialer1
     ip address negotiated
     no ip directed-broadcast
     ip nat outside
     encapsulation ppp
     dialer pool 1
     ppp chap hostname [email protected]
     ppp chap password 123A
     ppp pap sent-username [email protected] password 123A
    interface atm1
     no shut
     no ip address
     pvc 8/35
      encapsulation aal5mux ppp dialer
      dialer pool-member 2
    interface dialer1
     ip address negotiated
     no ip directed-broadcast
     ip nat outside
     encapsulation ppp
     dialer pool 2
     ppp chap hostname [email protected]
     ppp chap password 123B
     ppp pap sent-username [email protected] password 123B
    Cheers

    Hi Vasilii,
    Thank you for your reply. Actually the IOS was the issue, that one that I was using doesn't support the configs that I need. After the upgrade it started to work straightaway.
    Tks

  • Lost my adsl connection via Airport Extreme?

    Hi
    Been running my adsl connection via winXP SP1 laptop thru AE (also iBook /Imac FP} with no problems - now whilst i was trying to access files on the win machine (using iFelix guide) i seem to have messed up!!!
    I have the 'Wireless Network Connection' icon in the system tray showing my network and 'excellent' signal - as previous.
    When i try to get on the net the 'dial-up' box keeps coming up trying to dial my previous dial-up account - i believe i hace altered something here!!!
    When i click on 'status' in the sys tray icon - 'general' shows - connected but 'support' does not show address type / IP address etc all show "unavailable" - 'Repair' is greyed out.
    When I 'View available networks" i get the 'connect to wireless network' box my network is shown as available and requests my wep ket to connect!!!
    'Advanced' shows my network in both the available and preferred boxes - opening preferences shows wep enabled and my network key already entered!!!
    I've now deleted the old dial-up settings so there is nothing showing in the dial window.
    Any ideas please - i need to get this win machine operational before my partner returns - and then persuade him to get a mac!!!
    thanks
    ianjh
    norfolk
    uk

    It's possible that the message you got was to update the AirPort Express Base Station's (AX) firmware...and that something might have gone wrong during the upgrade.
    Let's start by performing a "factory default" reset on the AX to get it back to it's original "out-of-the-box" condition.
    Then, let's set it up to work with your cable modem...
    AirPort Express Base Station Setup (AX) w/High-Speed Cable Modem
    Modem/Router Power ReCycling (optional)
    - Power-off the Cable modem, AX, & computer(s). (Wait at least 30 minutes. If possible, leave the modem off overnight.)
    - Power-on the Cable modem; Wait at least 30 minutes.
    - Power-on the AX; Wait at least 5 minutes.
    - Power-on the computer(s)
    Setup the AX
    With the network components powered down, set up the AX, using the AirPort Admin Utility, either connect to the AX's wireless network or connect your computer directly (using an Ethernet cable) to the Ethernet port of the AX, and then, try these settings:
    AirPort tab
    - Base Station Name: <whatever you wish or use the default>
    - AirPort Network Name: <whatever you wish or use the default>
    - Create a closed network (unchecked)
    - Wireless Security: Not enabled
    - Channel: Automatic
    - Mode: 802.11b/g Compatible
    Internet tab
    - Connect Using: Ethernet
    - Configure: Using DHCP
    - WAN Ethernet Port: Automatic
    Network tab
    - Distribute IP addresses (checked)
    - Share a single IP address (using DHCP & NAT) (enabled)
    Do not, at this point, set up any security (i.e., WEP/WPA encryption, closed network, etc.) to first make sure the AX is operating properly. Try to access the Internet wirelessly with your MacBook. If you're successful, go ahead and add any security features you wish.

  • Using IP SLA and EEM to provide 3G backup to ADSL connection on CISCO887VAG+7-K9 router

    On a Cisco887VAG+7-K9 router, I want to be able to use IP SLA and EEM to track connectivity to an external address via my ADSL line, if connectivity is UP then I want the 3G interface to be admin shutdown.  If connectivity is down, then I want the 3G interface to be activated and connectivity to resume via 3G.
    I have configured this and it works apart from one problem.  If the config on the router is written to startup memory while the 3G interface is admin shutdown, we subsequently have a problem with the ADSL line and the router is then rebooted, then the EEM does not seem to re-activate the 3G interface so all connectivity is lost until the ADSL is returned to service.   i.e. it seems to be the case that if the IP SLA starts off as "Down" then the EEM doesn't take any action.  The IP SLA has to have gone into the "up" state before it starts working?  Does that make sense and, if so, is there any way round it?
    For info, here is my IP SLA and EEM config:
    ip sla 1
    icmp-echo 8.8.8.8 source-interface dialer2
    timeout 60000
    ip sla schedule 1 life forever start-time now
    track 1 ip sla 1 reachability
    ip route 0.0.0.0 0.0.0.0 Dialer2 track 1
    ip route 0.0.0.0 0.0.0.0 Dialer1 20
    event manager applet 3G-ACTIVATE
    event track 1 state down
    action 10 cli command "enable"
    action 20 cli command "configure terminal"
    action 30 cli command "interface Cellular0"
    action 40 cli command "no shutdown"
    action 50 cli command "end"
    event manager applet 3G-DEACTIVATE
    event track 1 state up
    action 10 cli command "enable"
    action 20 cli command "configure terminal"
    action 30 cli command "interface Cellular0"
    action 40 cli command "shutdown"
    action 50 cli command "end"
    Any assistance/advice on getting this to work effectively would be appreciated!
    Thanks.

    Yes, basically, when the tracked object is not reachable on initial router boot, the router doesn’t detect a transition of the tracking object from up to down and therefore does not execute the associated EEM script. 
    So, in my case, if I have an ADSL fault and the 3G interface has taken over, if the router is subsequently rebooted, all connectivity will be lost because the startup config of the router has the 3G interface as admin down and the EEM script to activate it does not kick in.
    I've tried using "default-state up" under the track config but this didn't seem to have any effect - the reachability of my IP SLA was still down after a router reboot with no ADSL connection.
    I also tried your script but this gave the errors:
    %HA_EM-3-FMPD_ACTION_NOTRACK: bump-track: unable to set state for tracking object number 1; object does not exist or is not a stub-object.
    Mar 19 10:23:00.005: %HA_EM-3-FMPD_ERROR: Error executing applet bump-track statement 1.0 %HA_EM-3-FMPD_ACTION_NOTRACK: bump-track: unable to set state for tracking object number 1; object does not exist or is not a stub-object.
    Mar 19 10:23:00.005: %HA_EM-3-FMPD_ERROR: Error executing applet bump-track statement 1.0
    I'm not sure how to resolve that?
    Any further advice would be welcome!  Thanks.

  • ISDN backup for ADSL connected sites using separate router

    In our set-up we have a central site with a large number of remote sites connected.
    We have moved a number of remote sites from ISDN connections to ADSL connections. However, we would like to keep the ISDN and use it for backup.
    The problem I have is - how do I implement ISDN backup with our current set-up? From the documentation, I can see how to do this for more "straightforward" set-ups but not for the set-up we have! Let me explain:
    At the central site, we have a Cisco 7206 router. The ISDN connected sites connect directly to this router (which is configured with a large number of dialer map statements for each site)
    The 7206 connects to a PIX515E firewall. The ADSL connected sites connect over the public internet using IPSEC with the tunnels terminating on the PIX.
    The 7206 router contains static routes for the ADSL connected sites, pointing to the firewall.
    At the remote sites, we have a Cisco 837 router for the ADSL connection.
    This is connected (via ethernet) to the router we want to use for ISDN backup - a Cisco 800. The 837 and 800 are configured with HSRP.
    However, at the moment, if the 837 or the ADSL link was to go down, there would be no means to connect to the central site. How can we configure this to use the 2nd router for ISDN backup, given our set-up?
    Any suggestions would be greatly appreciated!
    (incidentally, I have only recently joined this company and have taken this over, without any information to go on as to why things are set up as they are !)

    Hello again,
    I think you can pretty much ignore my last message. I've done a bit more digging and I think I have a better idea of what you mean now!
    Lets see if I've got this about right. To recap:
    I need to set up a GRE tunnel between the remote site and 7206 router at head office, which in turn would be using IPSEC tunnel between remote router and PIX.
    So, steps required:
    1) set up IPSec tunnel to to PIX (this is the way it is already currenly configured - am I right in thinking no further configuration would be required as far as the PIX is concerned, for the new set-up?)
    2) set up GRE tunnel between remote ADSL router and 7206 - requires tunnel interface on both router with start point and end point configured. Use GRE keepalive to enable the line protocol to be brought down if the far end cannot be reached.
    3) Add static routes on ADSL router to reach head office network via tunnel interface
    4) Add static route on 7206 router to reach remote network via tunnel interface
    5) Configure ISDN map statement on 7206 mapping remote network to ISDN number
    6) Configure "floating" static routes on 7206 to use ISDN to reach remote network
    7) Configure HSRP on ADSL and ISDN routers with tracking of tunnel interface. If tunnel interface goes down, then ISDN router takes over as active.
    8) Configure static routes on ISDN router to point to head office network using BRI0 interface.
    So, under normal operation, traffic between head office and remote office will be routed across the GRE tunnel using the ADSL link.
    If the ADSL link was to go down then the GRE tunnel would also go down. So, the 7206 would then use the floating static routes to reach the remote network via the ISDN connection.
    The ISDN router would take over as active at the remote site since the tunnel interface would have gone down, forcing the HSRP to failover.
    Does that all sound about right? Is there anything I've missed?
    I'll start trying to put some configurations together when I get the chance - but, if its ok, I'll probably run these past you too, just to make sure they seem correct!
    Thanks,
    Neil

  • I try to upgrade my ios to 4.3.1 the downloading times out even on an adsl connection. can anyone guide?

    i try to upgrade my ios to 4.3.1 the downloading times out even on an adsl connection. can anyone guide?

    Before beginning the download, temporarily disable your antivirus, anti-adware, anti-spyware, and any other anti-whatever that is required with that swiss cheese for security OS your computer is running.

  • MPLS Handling of Aggregated ADSL-connected sites

    I'm familiar with serially-connected sites entering an MPLS core, where there is a physical connection associated with each site, and so the site is simply identifiable to the MPLS PE by virtue of a physical port. However, I'm trying to get my head round how to handle ADSL connections, where many sites' traffic is aggregated into one bearer. How does the MPLS network associate the right traffic with the right site under these conditions? Sorry if this is a bit of a "dumb newbie" question, but I've googled extensively, and just haven't got to the stage where I feel confident in my understanding.
    Jim

    Hi Jim,
    When using DSL most architectures use PPPoA/PPPoE (you could just bridge at the dslam and use no PPP but that would result in a subinterface a VRF could be configured on).
    PPP will create a virtual-access interface per PPP authentication (username).
    When the virtual interface is being created the provider router (LNS) will ask a radius server if the user can be granted access. If yes, the radius can also give the router configuration information which can include IP address and VRF.
    Ultimately the traffic is kept separate because point to point logical sessions can be built on top of a multi access network (PPPoE).
    Hope this helps,
    Matt Ayre

  • 2 x 2911 HSEC router 3 ADSL connections each Site ti Site VPN Load Balancing Failover

    Hello,
    My senario is as described in Title.
    Site A Headquarters. The router is Cisco 2911HSEC with 3 ADSL connections
    Site B Remote Office. The router is Cisco 2911HSEC with 3 ADSL connections and 10 Users.
    All ADSL connections have static IPs and belong to same ISP.
    Need - Site to Site VPN between the routers.
    Client requests to load balance the traffic, due to poor ADSL speed and have a failover senarion in case an ADSL line goes down.
    Any help will be appreciated.

    I don't believe you will find a One solution for this. 
    An idea would be to have all three ADSLs paired with ADSL on the other side. 
    Have 3 VTI (or GRE) tunnels up all the time (VRF-lite anybody?) and advertise routes to the other side with same metric. 
    This will cause IOS to load balance natively. 
    Potential problem: return path might not be the same as forward path, but it should not matter much for most applications. 
    Potential cool thing you can do: All the "magical" things in routing world (Did I head PfR?). FlexVPN on top to make it more flexible. 
    Benefit: Rely on IKE to bring down connections which are going down. Little-to-no management once it's up and running. 

  • Correct route for ADSL connection

    Hi
    I found a couple of threads on this topic but none of them seemed to be plain enough for a newbie to understand. I use an ADSL connection for my home box. The connection uses pppoe for authentication. When I start the computer, I have to run the following commands on every run to get access to internet:
    su
    route del default
    route add default gw 81.91.128.10
    Here is what my rc.conf reads:
    # /etc/rc.conf - Main Configuration for Arch Linux
    # LOCALIZATION
    # LOCALE: available languages can be listed with the 'locale -a' command
    # HARDWARECLOCK: set to "UTC" or "localtime"
    # TIMEZONE: timezones are found in /usr/share/zoneinfo
    # KEYMAP: keymaps are found in /usr/share/kbd/keymaps
    # CONSOLEFONT: found in /usr/share/kbd/consolefonts (only needed for non-US)
    # CONSOLEMAP: found in /usr/share/kbd/consoletrans
    # USECOLOR: use ANSI color sequences in startup messages
    LOCALE="en_US.utf8"
    HARDWARECLOCK="localtime"
    TIMEZONE="Asia/Tehran"
    KEYMAP="us"
    CONSOLEFONT=
    CONSOLEMAP=
    USECOLOR="yes"
    # HARDWARE
    # Scan hardware and load required modules at bootup
    MOD_AUTOLOAD="yes"
    # Module Blacklist - modules in this list will never be loaded by udev
    MOD_BLACKLIST=(pcspkr)
    # Modules to load at boot-up (in this order)
    # - prefix a module with a ! to blacklist it
    MODULES=(mii slhc via-rhine ac97_bus snd-mixer-oss snd-pcm-oss snd-seq-oss snd-seq-device snd-seq-midi-event snd-seq snd-page-alloc snd-pcm snd-rawmidi snd-timer snd snd-mpu401-uart snd-mpu401 snd-ac97-codec snd-via82xx soundcore fuse)
    # Scan for LVM volume groups at startup, required if you use LVM
    USELVM="no"
    # NETWORKING
    HOSTNAME="localhost"
    # Use 'ifconfig -a' or 'ls /sys/class/net/' to see all available
    # interfaces.
    # Interfaces to start at boot-up (in this order)
    # Declare each interface then list in INTERFACES
    # - prefix an entry in INTERFACES with a ! to disable it
    # - no hyphens in your interface names - Bash doesn't like it
    # Note: to use DHCP, set your interface to be "dhcp" (eth0="dhcp")
    lo="lo 127.0.0.1"
    eth0="dhcp"
    INTERFACES=(lo eth0)
    # Routes to start at boot-up (in this order)
    # Declare each route then list in ROUTES
    # - prefix an entry in ROUTES with a ! to disable it
    gateway="default gw 81.91.128.10"
    ROUTES=(gateway)
    # Enable these network profiles at boot-up. These are only useful
    # if you happen to need multiple network configurations (ie, laptop users)
    # - set to 'menu' to present a menu during boot-up (dialog package required)
    # - prefix an entry with a ! to disable it
    # Network profiles are found in /etc/network-profiles
    #NET_PROFILES=(main)
    # DAEMONS
    # Daemons to start at boot-up (in this order)
    # - prefix a daemon with a ! to disable it
    # - prefix a daemon with a @ to start it up in the background
    DAEMONS=(syslog-ng network netfs crond dbus hal adsl privoxy tor keytouch)
    # End of file
    Here's my ifconfig output:
    eth0 Link encap:Ethernet HWaddr 00:05:5D:C8:A5:AA
    inet addr:192.168.1.3 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::205:5dff:fec8:a5aa/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:93252 errors:0 dropped:0 overruns:0 frame:0
    TX packets:69563 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:106552708 (101.6 Mb) TX bytes:6338531 (6.0 Mb)
    Interrupt:5 Base address:0xd000
    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:931 errors:0 dropped:0 overruns:0 frame:0
    TX packets:931 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:1886158 (1.7 Mb) TX bytes:1886158 (1.7 Mb)
    ppp0 Link encap:Point-to-Point Protocol
    inet addr:91.184.72.216 P-t-P:81.91.128.10 Mask:255.255.255.255
    UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
    RX packets:92873 errors:0 dropped:0 overruns:0 frame:0
    TX packets:69152 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:3
    RX bytes:104480285 (99.6 Mb) TX bytes:4801320 (4.5 Mb)
    What should I do to get the thing done without any manual intervention?

    Please refer to this wiki for the detailed and correct steps to set it up:
    http://wiki.archlinux.org/index.php/PPP … _with_pppd
    And remember to set eth0 up in rc.conf as follow:
    eth0="eth0 0.0.0.0 up"
    I don't know why you have to set route up manually. I thought that the pppd daemon will do it for you.
    And... just use /etc/rc.d/pppd not /etc/rc.d/adsl.
    Hope this helps.
    BR,
    bsdson.tw

  • Doing proper NAT to FTP connections on non-standard port

    Router 1712, IOS 12.3
    There is an article from Cisco, "Using Non-Standard FTP Port Numbers with NAT".
    http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a0080094e76.shtml
    It explains how to enable NATting router to perform proper translation of NAT-sensitive protocols, in this case FTP.
    The article assumes that the FTP server in question is on the inside interface of the router.
    The configuration proposed by the article is as follows:
    interface Ethernet0
    ip address 10.1.1.2 255.255.255.0
    ip nat inside
    interface Serial0
    ip address 192.168.10.1 255.255.255.252
    ip nat outside
    ip nat service list 10 ftp tcp port 2021
    ip nat inside source static 10.1.1.1 20.20.20.1
    access-list 10 permit 10.1.1.1
    In my case, the FTP server in question is on the outside interface. The router is performing source NAT for outbound connections. An example of my config is below:
    interface Ethernet0
    ip address 12.34.56.1 255.255.255.0
    ip nat outside
    interface Vlan324
    ip address 10.1.1.2 255.255.255.0
    ip nat inside
    ip nat service list 10 ftp tcp port 2021
    ip nat inside source static 10.1.1.100 12.34.56.100
    access-list 10 permit 12.34.56.200
    With this configuration, Layer 3 NAT is working. I'm able to establish an FTP control channel and issue FTP commands. However, I think that the IP addresses inside FTP control channel are not translated properly (to 12.34.56.100). Therefore, the FTP data channel is not working.
    I tried to enable the following debug, however didn't see any entries related to FTP control channel translation:
    debug ip nat
    debug ip nat detailed
    debug ip snat
    debug ip snat detailed
    debug ip ftp
    debug ftpserver
    My question is:
    Is the "ip nat service list <acl> ftp tcp <port>" command supposed to work when the FTP server in question is on the outside interface of the translating router ?

    Hi,
    I see that this question was asked quite some time ago but I have come across the same issue, i.e when the server is on the outside interface the ip in the "PORT" command from the client is not translated.
    Did you ever get a fix for it?
    Thanks

  • Help me set up ADSL connection

    Hi everybody!
    I'm new to this forum, and I'm using Arch linux for about a week or two. I'm using Linux for about 2 years, though, so I'm not a newbie Linux user.
    However, I'm having troubles with my adsl connection to internet. I have Thomson SpeedTouch 530 v5 adsl modem, connected via integrated Realtec network card. I have internet as long I as I don't start adsl service. But when I start adsl service I can't access internet anymore.
    Any help regarding this matter is highly appreciated.
    P.S. I have already read a bunch of simillar topics on this forum, but nothing actually helped me.

    Hi vogt!
    First to say that my modem began to acting strange last few days. Even on my Mandriva system sometimes it gives me troubles.
    I have dynamical IP, and my current setup on Arch is this:
    rc.conf wrote:
    HOSTNAME="demon"
    lo="lo 127.0.0.1"
    #eth0="eth0 0.0.0.0 up"
    eth0="dhcp"
    INTERFACES=(lo eth0)
    gateway="dhcp"
    ROUTES=(!gateway)
    DAEMONS=(@syslog-ng network adsl @httpd @mysqld @netfs @crond @ntpd @sensors @cpufreq alsa hal fam kdm)
    /etc/ppp/pppoe.conf wrote:ETH='eth0'
    USER='pejakm@adsl'
    DEMAND=no
    DNSTYPE=SPECIFY
    PEERDNS=no
    DNS1=81.93.64.1
    DNS2=81.93.64.9
    DEFAULTROUTE=yes
    CONNECT_TIMEOUT=30
    CONNECT_POLL=2
    ACNAME=
    SERVICENAME=
    PING="."
    CF_BASE=`basename $CONFIG`
    PIDFILE="/var/run/$CF_BASE-pppoe.pid"
    SYNCHRONOUS=yes
    CLAMPMSS=1412
    LCP_INTERVAL=20
    LCP_FAILURE=3
    PPPOE_TIMEOUT=80
    FIREWALL=NONE
    LINUX_PLUGIN=
    PPPOE_EXTRA=""
    PPPD_EXTRA=""
    RETRY_ON_FAILURE=no
    and I had to blank /etc/ppp/options
    and to change "/usr/sbin/pppoe-start" to "/usr/sbin/pppoe-connect" in /etc/rc.d/adsl script so I could even start pppoe.
    But at the moment I don't get what I want: still no ppp0 interface, but I have internet connection. I need ppp0 interface, because I have apache web server running (so I can access it from outside using current ip address - this works in Mandriva).

  • Stealth mode attempts slowing adsl connection or killing it!

    G'day,
    I found this topic in another thread somewhere in here, but for some reason it was closed down. :confused:
    For the last two weeks I have found in the Console log that I have been getting stealth mode and UDP communications attackes when I hook my P/Book up to my wireless network via A/port Express which is linked to my A/port Extreme Base Station. I have set up the Firewall to detect stealth mode attacks, block UDP communications etc., and when I get these attacks it is either drastically slowing my net connection down or causing me to lose connection altogether.
    What can I do to stop these attacks from killing my ADSL connection?
    I haven't installed any secuirity updates as I'm very wary of them killing my Macs, as they have done in the past.
    This situation is really pinging me off big time and if anyone could help out I'd be really greatful.
    Thanks in advance for your help.

    http://discussions.apple.com/thread.jspa?messageID=12592096#12592096

  • Starting adsl connection busy then fail

    when trying what they wrote in the wiki guide about starting adsl i get this error.
    how can I correct this so I will have adsl connection?
    any suggestion appreciated
    thanks

    Usually this occurs on failed connection attempts.
    Either your connection setup is in error. Or there are too short timeouts.
    My adsl sometimes (seldom) needs a minute to get a stable connection.
    There should be "pppd" messages in /var/log/everything.log.

  • Problems bringing up my ADSL connection with mu own kernel

    Hey guys,
    I got some problems.
    I'm running arch linux (v0.6) 4th day already and I think this distro is awesome. Now about my problem.
    When I've installed arch linux i've installed a IDE kernel from CD. it's v2.4.21. Like always, everything runs well except my sound card. I can use the internet with it, but I need sound (DOH! . So I decided to compile my custom kernel (v2.4.25). In menuconfig I select everythink that my computer needs (Realtek card drivers, sound drivers (my soundcard is SBAWE 32) and other things.) When I boot new kernel I can't bring up my ADSL connection. I use a PPPoE mode ([computer] ->- [eth0] ->- [adsl splitter] ->- [adsl modem] ->- [telephone line]). When I compile kernel I compile in (not as a module) ppp and pppoe support. I use rp-pppoe software to connect to the internet. It just can't bring my adsl connection up Maybe I forgot something to compile in my kernel? I've compared the new kernel's /proc/pci with the old /proc/pci... all information is the same.
    Can you suggest me something?
    p.s. my adsl modem is Ericcson HM210dp

    ah nevermind, problem solved. I recompiled kernel 1hr ago, and compiled in support for "async" and "sync" ports (or smth like that). now everything is OK. :twisted:

  • Adsl connection not working? Please help

    Hey guys,
    I'm going crazy trying to get my cisco 1701 adsl modem to work.
    My setting are below, please tell me what is wrong???
    User Access Verification
    Password:
    Gateway>enable
    Password:
    Gateway#show run
    Building configuration...
    Current configuration : 1517 bytes
    ! Last configuration change at 01:33:16 UTC Fri Mar 1 2002
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname Gateway
    boot-start-marker
    boot-end-marker
    enable secret xxx.
    enable password *******
    no aaa new-model
    ip subnet-zero
    ip dhcp excluded-address 192.168.1.254
    ip dhcp pool Haqsta
    network 192.168.1.0 255.255.255.0
    default-router 192.168.1.254
    dns-server 203.x.x.191
    ip cef
    ip audit notify log
    ip audit po max-events 100
    ip ssh break-string
    vpdn enable
    vpdn-group pppoe
    request-dialin
    protocol pppoe
    no ftp-server write-enable
    no scripting tcl init
    no scripting tcl encdir
    no crypto isakmp enable
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    pvc 8/35
    pppoe-client dial-pool-number 1
    dsl operating-mode auto
    interface BRI0
    no ip address
    shutdown
    interface FastEthernet0
    ip address 192.168.1.254 255.255.255.0
    ip nat inside
    ip tcp adjust-mss 1452
    speed auto
    full-duplex
    interface Dialer1
    mtu 1492
    ip address negotiated
    ip nat outside
    encapsulation ppp
    dialer pool 1
    ppp pap sent-username *****@*****.net.au password 0 ********
    ip nat inside source list 1 interface Dialer1 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip http server
    ip http secure-server
    access-list 1 permit 0.0.0.254 255.255.255.0
    control-plane
    line con 0
    line aux 0
    line vty 0 4
    password ******
    login
    end
    Gateway#

    No that did not help.
    This is the exact document i have followed.
    Sample Configurations
    DSL Router With Built-In Modem - DHCP
    o DHCP and DSL requires you to get a pppoe password and username from your ISP. Most ISPs have a homepage where you can register to get the username and password, ask customer service for the URL. You should substitute this username and password for PPP "username" and "password" listed below.
    o Cisco IOS doesn't support DHCP DSL and NAT. If this is so, then putting an Internet accessible web server on your home network would be impossible using the routers mentioned above in this configuration.
    o Here is a sample configuration for a Cisco home router. Some of the commands listed are part of Cisco's default settings. Do the "show run" command before starting to configure your router to see what commands you'll really need.
    o Remember to be in "config" mode to enter these commands and remember to do a "write memory" at the end to permanently save the configuration
    Cisco DSL Router With Built-in Modem Configuration (DHCP)
    !vpdn enableno vpdn logging !--- Configure the router's PPPoE client so that it!--- can setup a session with the ISP!vpdn-group pppoe request-dialin protocol pppoe !--- Configure the home / SOHO network interface's!--- IP address!--- The "ip nat" statement tells your router that!--- this interface:!--- 1) uses NAT!--- 2) is the inside "private" interface!interface FastEthernet0 ip address 192.168.1.1 255.255.255.0 ip nat inside !--- Configure the DSL interface!--- Your ISP may provide you with a different pvc!--- value not necesarily "1/1"!interface ATM0 no ip address no atm ilmi-keepalive bundle-enable dsl operating-mode auto hold-queue 224 in!interface ATM0.1 point-to-point pvc 1/1 pppoe-client dial-pool-number 1 !--- Cisco prefers to run the PPPoE client on a virtual!--- "dialer" interface!--- This is tied to the real ATM DSL interface with the !--- "dialer pool" command. The default ethernet MTU!--- size has been reduced from 1500 to accommodate!--- the PPPoE header overhead.!!--- The "ip nat" statement tells your router that!--- this interface:!--- 1) uses NAT!--- 2) is the outside "public" interface!interface Dialer1 ip address negotiated ip mtu 1492 ip nat outside encapsulation ppp dialer pool 1 !--- Here are the commands to configure authentication!--- with with your ISP. This example uses the "CHAP"!--- method.!--- Commands for using the "PAP" method are included at!--- the end of this box! ppp authentication chap callin ppp chap hostname ppp chap password ! !--- Tells the router to NAT all traffic that passes!--- through it:!--- 1) From the inside to the outside,!--- 2) And whose IP address is in the 192.168.1.0 network!--- as given in access list 1!--- 3) Giving it an outside "public" address that is the!--- same as interface Dialer1 gets from the PPPoE!--- connection!ip nat inside source list 1 interface Dialer1 overloadip classlessip route 0.0.0.0 0.0.0.0 dialer1no ip http server!access-list 1 permit 192.168.1 0.0.0.255
    o If your ISP tells you that you need to do the PAP, and not the CHAP, type of authentication then you'll have to replace the lines:
    ppp authentication chap callin
    ppp chap hostname
    ppp chap password
    with only these two:
    ppp authentication pap callin
    ppp pap sent-username password
    Can some please help me fix what i am missing or have done wrong.

Maybe you are looking for

  • Can I separate out for analysis multiple responses to one question?

    I created my first survey without realizing that by creating a question that allows the respondent to choose multiple responses, I might have a problem parsing out the responses for analysis.  I have been downloading (exporting) the responses into an

  • I just got Vista and my library is gone.

    I just got a new computer with Windows Vista. I downloaded iTunes from online, but the only songs in my library are the songs I bought from iTunes. Is there anyway I can get the rest of my songs on my new computer?   Other OS  

  • SBO Error #-111: Failed to Connect to SBOCommon

    I have recently moved my databases to a SQL 2008 server on a 64bit platform. When doing so, I installed the SQL Native Client to support the client access. I can go into SAP/b1 and access everything as I did before. (Previously SQL 2005.) When I move

  • Access true path of KM directory

    Hello everyone, I'm using a file system repository in KM to access a remote shared folder in a windows system. everythings works fine, but i still have a doubt: is it possible in a web dynpro application, using the KM API, to access the true path of

  • Desk top for CS5 used for magazine /ad design?

    Can anyone recommend a ready-built desk top suitable for using CS5 for magazine / ad design and video editing and cost. Our budget is $1500, with a little flexibility. Thanks!