Need help adding a barcode annotation in Acrobat X with C#

Hello All,
I am trying to add a barcode into a PDF document using a new annotation but I can't find a way to set the font.
Please help and thanks,
Bob

I found the field api in the AFORMAUTLib dll.
Here is what I am trying to accomplish.
Use C# .Net
Open a new pdf document that will have multiple single pdf file pages inserted in.
Add annotations for each sheet that includes a bar code.
Save the multi page pdf file
I was able to combine multiple pdfs in PDDoc but I could not add a PDAnnot with a font pointed to my bar code font.
Thanks for any help you can provide,
Bob

Similar Messages

  • I need help adding a mouse motion listner to my game. PLEASE i need it for

    I need help adding a mouse motion listner to my game. PLEASE i need it for a grade.
    i have a basic game that shoots target how can use the motion listner so that paint objects (the aim) move with the mouse.
    i am able to shoot targets but it jus clicks to them ive been using this:
    public void mouse() {
    dotX = mouseX;
    dotY = mouseY;
    int d = Math.abs(dotX - (targetX + 60/2)) + Math.abs(dotY - (targetY + 60/2));
    if(d < 15) {
    score++;
    s1 = "" + score;
    else {
    score--;
    s1 = "" + score;
    and here's my cross hairs used for aiming
    //lines
    page.setStroke(new BasicStroke(1));
    page.setColor(Color.green);
    page.drawLine(dotX-10,dotY,dotX+10,dotY);
    page.drawLine(dotX,dotY-10,dotX,dotY+10);
    //cricle
    page.setColor(new Color(0,168,0,100));
    page.fillOval(dotX-10,dotY-10,20,20);
    please can some1 help me

    please can some1 help meNot when you triple post a question:
    http://forum.java.sun.com/thread.jspa?threadID=5244281
    http://forum.java.sun.com/thread.jspa?threadID=5244277

  • Need help adding schedule to xcode 4

    I need help adding a tour schedule for an iphone app building an app for 13 djs and they want thier tour schedules added these need to be updated monthly is there a way to add this????

    I don't know if this is the easiest way but it works for me. I connect the DVD player to my camcorder (so it's the 3 plugs yellow/red/white on one end and a single jack into the camera). Then I connect my camcorder to the computer (I think it's through a firewire port). Then I just play the DVD and the footage is digitized via the camcorder and I import it into iMovie 4 as it's playing. I believe the camcorder is just in VCR mode.
    I have also used this method to transfer VHS tapes onto DVDs via the camera by connecting the VCR to the camera.
    I haven't had much luck with movies over about 40 minutes on iMovie. But if it's home movies, there may be a logical break. Do maybe 20 minute segments (it's also really easy on iMovie to add a soundtrack if these are OLD films with no sound.
    As you can see, I'm low tech!
    Good luck!
    Powerbook G4   Mac OS X (10.3.9)  

  • Needs help to know the different versions of forms with their compatibility

    Needs help to know the different versions of forms with their compatibility with different databases and operating systems.
    Kindly give the details or any suitable link for the same.
    please consider it as on urgent basis.
    regards,
    rajesh

    Rajesh,
    the certification matrix is available on metalink.oracle.com. You need a support contract to access this information.
    Frank

  • HT2480 I need help syncing my computer outlook email (through Yahoo) with my Iphone. when I delete an email on my computer is it still in my inbox on my phone.  Any help is appreciated.

    I need help syncing my computer outlook email (through Yahoo) with my iphone.  When I delete an email on my computer it is still in my inbox on my phone. Please help.

    Your computer is probably set up to access your Yahoo mail using POP3. POP3 does not synchronize with the server. For full synchronization, you will need to use IMAP instead. See the Yahoo mail help pages for instructions on how to configure your mail client.

  • Need help adding Arch to Grub

    I am trying to dual boot Arch Linux and Ubuntu. When I try to boot there is no option for Arch. I have added it to the menu.lst file in ubuntu. Arch is installed on sdb1 according to sudo fdisk -l  I need help!

    Fdisk -l
    Disk /dev/sda: 80.0 GB, 80026361856 bytes
    255 heads, 63 sectors/track, 9729 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0xb38ab38a
       Device Boot      Start         End      Blocks   Id  System
    /dev/sda1   *           1        9544    76662148+  83  Linux
    /dev/sda2            9545        9729     1486012+   5  Extended
    /dev/sda5            9545        9729     1485981   82  Linux swap / Solaris
    Disk /dev/sdb: 40.9 GB, 40992473088 bytes
    255 heads, 63 sectors/track, 4983 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x0002eb1f
       Device Boot      Start         End      Blocks   Id  System
    /dev/sdb1   *           1        4891    39286926   83  Linux
    Disk /dev/sdc: 250.0 GB, 250059350016 bytes
    255 heads, 63 sectors/track, 30401 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x000ea9be
       Device Boot      Start         End      Blocks   Id  System
    /dev/sdc1               1       30401   244196001    7  HPFS/NTFS
    I think Arch is on the 40GB partition
    Menu.lst
    # menu.lst - See: grub(8), info grub, update-grub(8)
    #            grub-install(8), grub-floppy(8),
    #            grub-md5-crypt, /usr/share/doc/grub
    #            and /usr/share/doc/grub-doc/.
    ## default num
    # Set the default entry to the entry number NUM. Numbering starts from 0, and
    # the entry number 0 is the default if the command is not used.
    # You can specify 'saved' instead of a number. In this case, the default entry
    # is the entry saved with the command 'savedefault'.
    # WARNING: If you are using dmraid do not use 'savedefault' or your
    # array will desync and will not let you boot your system.
    default        0
    ## timeout sec
    # Set a timeout, in SEC seconds, before automatically booting the default entry
    # (normally the first entry defined).
    timeout        0
    ## hiddenmenu
    # Hides the menu by default (press ESC to see the menu)
    hiddenmenu
    # Pretty colours
    #color cyan/blue white/blue
    ## password ['--md5'] passwd
    # If used in the first section of a menu file, disable all interactive editing
    # control (menu entry editor and command-line)  and entries protected by the
    # command 'lock'
    # e.g. password topsecret
    ## password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
    # password topsecret
    # examples
    # title        Windows 95/98/NT/2000
    # root        (hd0,0)
    # makeactive
    # chainloader    +1
    # title        Linux
    # root        (hd0,1)
    # kernel    /vmlinuz root=/dev/hda2 ro
    # Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST
    ### BEGIN AUTOMAGIC KERNELS LIST
    ## lines between the AUTOMAGIC KERNELS LIST markers will be modified
    ## by the debian update-grub script except for the default options below
    ## DO NOT UNCOMMENT THEM, Just edit them to your needs
    ## ## Start Default Options ##
    ## default kernel options
    ## default kernel options for automagic boot options
    ## If you want special options for specific kernels use kopt_x_y_z
    ## where x.y.z is kernel version. Minor versions can be omitted.
    ## e.g. kopt=root=/dev/hda1 ro
    ##      kopt_2_6_8=root=/dev/hdc1 ro
    ##      kopt_2_6_8_2_686=root=/dev/hdc2 ro
    # kopt=root=UUID=ce3a864f-3f72-480b-96b3-54516b307170 ro
    ## default grub root device
    ## e.g. groot=(hd0,0)
    # groot=ce3a864f-3f72-480b-96b3-54516b307170
    ## should update-grub create alternative automagic boot options
    ## e.g. alternative=true
    ##      alternative=false
    # alternative=true
    ## should update-grub lock alternative automagic boot options
    ## e.g. lockalternative=true
    ##      lockalternative=false
    # lockalternative=false
    ## additional options to use with the default boot option, but not with the
    ## alternatives
    ## e.g. defoptions=vga=791 resume=/dev/hda5
    # defoptions=quiet splash
    ## should update-grub lock old automagic boot options
    ## e.g. lockold=false
    ##      lockold=true
    # lockold=false
    ## Xen hypervisor options to use with the default Xen boot option
    # xenhopt=
    ## Xen Linux kernel options to use with the default Xen boot option
    # xenkopt=console=tty0
    ## altoption boot targets option
    ## multiple altoptions lines are allowed
    ## e.g. altoptions=(extra menu suffix) extra boot options
    ##      altoptions=(recovery) single
    # altoptions=(recovery mode) single
    ## controls how many kernels should be put into the menu.lst
    ## only counts the first occurence of a kernel, not the
    ## alternative kernel options
    ## e.g. howmany=all
    ##      howmany=7
    # howmany=all
    ## specify if running in Xen domU or have grub detect automatically
    ## update-grub will ignore non-xen kernels when running in domU and vice versa
    ## e.g. indomU=detect
    ##      indomU=true
    ##      indomU=false
    # indomU=detect
    ## should update-grub create memtest86 boot option
    ## e.g. memtest86=true
    ##      memtest86=false
    # memtest86=true
    ## should update-grub adjust the value of the default booted system
    ## can be true or false
    # updatedefaultentry=false
    ## should update-grub add savedefault to the default options
    ## can be true or false
    # savedefault=false
    ## ## End Default Options ##
    title        Ubuntu 9.04
    uuid        ce3a864f-3f72-480b-96b3-54516b307170
    kernel        /boot/vmlinuz-2.6.28-11-generic root=UUID=ce3a864f-3f72-480b-96b3-54516b307170 ro quiet splash
    initrd        /boot/initrd.img-2.6.28-11-generic
    quiet
    #title        Ubuntu 9.04, kernel 2.6.28-11-generic (recovery mode)
    #uuid        ce3a864f-3f72-480b-96b3-54516b307170
    #kernel        /boot/vmlinuz-2.6.28-11-generic root=UUID=ce3a864f-3f72-480b-96b3-54516b307170 ro  single
    #initrd        /boot/initrd.img-2.6.28-11-generic
    #title        Ubuntu 9.04, memtest86+
    #uuid        ce3a864f-3f72-480b-96b3-54516b307170
    #kernel        /boot/memtest86+.bin
    #quiet
    # (0) Arch Linux
    title  Arch Linux 
    root   (hd1,0)
    kernel /vmlinuz26 root=/dev/sda3 ro
    initrd /kernel26.img
    ### END DEBIAN AUTOMAGIC KERNELS LIST
    title Arch
    rootnoverify (hd0,1)
    chainloader +1

  • I have a godaddy website with a welcome page- I need help adding a few additional pages with a hyperlink to my welcome page.

    I need help attaching a few hyperlinks my godaddy welcome page. I have 2 more ipages articles, I also converted them to pdf. Godaddy only helped (last year) with the 1st article.  I do not know how to attach a hyperlink to the artlcles and add the hyperlinks to my welcome page.

    The program is called Pages not iPages. Just let us know if you do not speak English and what language you do speak so we can adjust for that.
    The issues are to do with your web page not with Pages.
    I think you are asking how to link from your web page to your pdf articles. You must first copy those pdfs to your web server, or some other web location, and then provide html links on your welcome page to those pdf files.
    The pdfs themselves may contain links to other locations but I can not see that that is what you are asking for.
    Nor to what those links would be to.
    From your heading I think you may have confused the name of Pages, the word processing program, with web pages which are two different things.
    Peter

  • ComboBox (dropdown) Need Help Adding URL links!!!

    I am somewhat of a newbie....Anybody know how to use URL
    links in a ComboBox dropdown menu? NEED HELP!!!!!!! I'm trying to
    make it so that after selecting an option, the user is directed to
    another URL within the same browser window. Using flash 8!
    Thanks,

    Im a bit a newbie myslef but i think you make flash
    commuincate to javascript wich will make the browser goto the URL.
    do a search on getURL and javascript together and i am sure
    you will find something.
    And when slecting to redirct i think its on?(onPress)
    something so maybe look throught the help section in flash 8 and
    look at componets. I think there is some actionscript help there.
    Sorry i could not be more helpful.

  • Need help in configuring Client to Site IPSec VPN with Hairpinning on Cisco ASA5510 8.2(1)

    Need urgent help in configuring Client to Site IPSec VPN with Hairpinning on Cisco ASA5510 - 8.2(1).
    The following is the Layout:
    There are two Leased Lines for Internet access - 1.1.1.1 & 2.2.2.2, the latter being the Standard Default route, the former one is for backup.
    I have been able to configure  Client to Site IPSec VPN
    1) With access from Outside to only the Internal Network (172.16.0.0/24) behind the asa
    2) With Split tunnel with simultaneous assess to internal LAN and Outside Internet.
    But I have not been able to make tradiotional Hairpinng model work in this scenario.
    I followed every possible sugestions made in this regard in many Discussion Topics but still no luck. Can someone please help me out here???
    Following is the Running-Conf with Normal Client to Site IPSec VPN configured with No internat Access:
    LIMITATION: Can't Boot into any other ios image for some unavoidable reason, must use 8.2(1)
    running-conf  --- Working  normal Client to Site VPN without internet access/split tunnel
    ASA Version 8.2(1)
    hostname ciscoasa
    domain-name cisco.campus.com
    enable password xxxxxxxxxxxxxx encrypted
    passwd xxxxxxxxxxxxxx encrypted
    names
    interface GigabitEthernet0/0
    nameif internet1-outside
    security-level 0
    ip address 1.1.1.1 255.255.255.240
    interface GigabitEthernet0/1
    nameif internet2-outside
    security-level 0
    ip address 2.2.2.2 255.255.255.224
    interface GigabitEthernet0/2
    nameif dmz-interface
    security-level 0
    ip address 10.0.1.1 255.255.255.0
    interface GigabitEthernet0/3
    nameif campus-lan
    security-level 0
    ip address 172.16.0.1 255.255.0.0
    interface Management0/0
    nameif CSC-MGMT
    security-level 100
    ip address 10.0.0.4 255.255.255.0
    boot system disk0:/asa821-k8.bin
    boot system disk0:/asa843-k8.bin
    ftp mode passive
    dns server-group DefaultDNS
    domain-name cisco.campus.com
    same-security-traffic permit inter-interface
    same-security-traffic permit intra-interface
    object-group network cmps-lan
    object-group network csc-ip
    object-group network www-inside
    object-group network www-outside
    object-group service tcp-80
    object-group service udp-53
    object-group service https
    object-group service pop3
    object-group service smtp
    object-group service tcp80
    object-group service http-s
    object-group service pop3-110
    object-group service smtp25
    object-group service udp53
    object-group service ssh
    object-group service tcp-port
    object-group service udp-port
    object-group service ftp
    object-group service ftp-data
    object-group network csc1-ip
    object-group service all-tcp-udp
    access-list INTERNET1-IN extended permit ip host 1.2.2.2 host 2.2.2.3
    access-list CSC-OUT extended permit ip host 10.0.0.5 any
    access-list CAMPUS-LAN extended permit tcp 172.16.0.0 255.255.0.0 any eq www
    access-list CAMPUS-LAN extended permit tcp 172.16.0.0 255.255.0.0 any eq https
    access-list CAMPUS-LAN extended permit tcp 172.16.0.0 255.255.0.0 any eq ssh
    access-list CAMPUS-LAN extended permit tcp 172.16.0.0 255.255.0.0 any eq ftp
    access-list CAMPUS-LAN extended permit udp 172.16.0.0 255.255.0.0 any eq domain
    access-list CAMPUS-LAN extended permit tcp 172.16.0.0 255.255.0.0 any eq smtp
    access-list CAMPUS-LAN extended permit tcp 172.16.0.0 255.255.0.0 any eq pop3
    access-list CAMPUS-LAN extended permit ip any any
    access-list csc-acl remark scan web and mail traffic
    access-list csc-acl extended permit tcp any any eq smtp
    access-list csc-acl extended permit tcp any any eq pop3
    access-list csc-acl remark scan web and mail traffic
    access-list INTERNET2-IN extended permit tcp any host 1.1.1.2 eq 993
    access-list INTERNET2-IN extended permit tcp any host 1.1.1.2 eq imap4
    access-list INTERNET2-IN extended permit tcp any host 1.1.1.2 eq 465
    access-list INTERNET2-IN extended permit tcp any host 1.1.1.2 eq www
    access-list INTERNET2-IN extended permit tcp any host 1.1.1.2 eq https
    access-list INTERNET2-IN extended permit tcp any host 1.1.1.2 eq smtp
    access-list INTERNET2-IN extended permit tcp any host 1.1.1.2 eq pop3
    access-list INTERNET2-IN extended permit ip any host 1.1.1.2
    access-list nonat extended permit ip 172.16.0.0 255.255.0.0 172.16.0.0 255.255.0.0
    access-list DNS-inspect extended permit tcp any any eq domain
    access-list DNS-inspect extended permit udp any any eq domain
    access-list capin extended permit ip host 172.16.1.234 any
    access-list capin extended permit ip host 172.16.1.52 any
    access-list capin extended permit ip any host 172.16.1.52
    access-list capin extended permit ip host 172.16.0.82 host 172.16.0.61
    access-list capin extended permit ip host 172.16.0.61 host 172.16.0.82
    access-list capout extended permit ip host 2.2.2.2 any
    access-list capout extended permit ip any host 2.2.2.2
    access-list campus-lan_nat0_outbound extended permit ip 172.16.0.0 255.255.0.0 192.168.150.0 255.255.255.0
    pager lines 24
    logging enable
    logging buffered debugging
    logging asdm informational
    mtu internet1-outside 1500
    mtu internet2-outside 1500
    mtu dmz-interface 1500
    mtu campus-lan 1500
    mtu CSC-MGMT 1500
    ip local pool vpnpool1 192.168.150.2-192.168.150.250 mask 255.255.255.0
    ip verify reverse-path interface internet2-outside
    ip verify reverse-path interface dmz-interface
    ip verify reverse-path interface campus-lan
    ip verify reverse-path interface CSC-MGMT
    no failover
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-621.bin
    no asdm history enable
    arp timeout 14400
    global (internet1-outside) 1 interface
    global (internet2-outside) 1 interface
    nat (campus-lan) 0 access-list campus-lan_nat0_outbound
    nat (campus-lan) 1 0.0.0.0 0.0.0.0
    nat (CSC-MGMT) 1 10.0.0.5 255.255.255.255
    static (CSC-MGMT,internet2-outside) 2.2.2.3 10.0.0.5 netmask 255.255.255.255
    access-group INTERNET2-IN in interface internet1-outside
    access-group INTERNET1-IN in interface internet2-outside
    access-group CAMPUS-LAN in interface campus-lan
    access-group CSC-OUT in interface CSC-MGMT
    route internet2-outside 0.0.0.0 0.0.0.0 2.2.2.5 1
    route internet1-outside 0.0.0.0 0.0.0.0 1.1.1.5 2
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    dynamic-access-policy-record DfltAccessPolicy
    aaa authentication ssh console LOCAL
    aaa authentication enable console LOCAL
    http server enable
    http 10.0.0.2 255.255.255.255 CSC-MGMT
    http 10.0.0.8 255.255.255.255 CSC-MGMT
    http 1.2.2.2 255.255.255.255 internet2-outside
    http 1.2.2.2 255.255.255.255 internet1-outside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group5
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
    crypto map internet2-outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map internet2-outside_map interface internet2-outside
    crypto ca trustpoint _SmartCallHome_ServerCA
    crl configure
    crypto ca certificate chain _SmartCallHome_ServerCA
    certificate ca xyzxyzxyzyxzxyzxyzxyzxxyzyxzyxzy
            a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as
        a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as
        a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as
        a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as
        a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as
        a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as
        a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as
        a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as
        a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as
        a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as
        a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as
        a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as
        a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as
        a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as a67a897as
        a67a897as a67a897as a67a897as a67a897as a67a897as
      quit
    crypto isakmp enable internet2-outside
    crypto isakmp policy 10
    authentication pre-share
    encryption aes
    hash md5
    group 2
    lifetime 86400
    telnet 10.0.0.2 255.255.255.255 CSC-MGMT
    telnet 10.0.0.8 255.255.255.255 CSC-MGMT
    telnet timeout 5
    ssh 1.2.3.3 255.255.255.240 internet1-outside
    ssh 1.2.2.2 255.255.255.255 internet1-outside
    ssh 1.2.2.2 255.255.255.255 internet2-outside
    ssh timeout 5
    console timeout 0
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    group-policy VPN_TG_1 internal
    group-policy VPN_TG_1 attributes
    vpn-tunnel-protocol IPSec
    username ssochelpdesk password xxxxxxxxxxxxxx encrypted privilege 15
    username administrator password xxxxxxxxxxxxxx encrypted privilege 15
    username vpnuser1 password xxxxxxxxxxxxxx encrypted privilege 0
    username vpnuser1 attributes
    vpn-group-policy VPN_TG_1
    tunnel-group VPN_TG_1 type remote-access
    tunnel-group VPN_TG_1 general-attributes
    address-pool vpnpool1
    default-group-policy VPN_TG_1
    tunnel-group VPN_TG_1 ipsec-attributes
    pre-shared-key *
    class-map cmap-DNS
    match access-list DNS-inspect
    class-map csc-class
    match access-list csc-acl
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum 512
    policy-map global_policy
    class csc-class
      csc fail-open
    class cmap-DNS
      inspect dns preset_dns_map
    service-policy global_policy global
    prompt hostname context
    Cryptochecksum: y0y0y0y0y0y0y0y0y0y0y0y0y0y
    : end
    Neither Adding dynamic NAT for 192.168.150.0/24 on outside interface works, nor does the sysopt connection permit-vpn works
    Please tell what needs to be done here, to hairpin all the traffic to internet comming from VPN Clients.
    That is I need clients conected via VPN tunnel, when connected to internet, should have their IP's NAT'ted  against the internet2-outside interface address 2.2.2.2, as it happens for the Campus Clients (172.16.0.0/16)
    I'm not much conversant with everything involved in here, therefore please be elaborative in your replies. Please let me know if you need any more information regarding this setup to answer my query.
    Thanks & Regards
    maxs

    Hi Jouni,
    Thanks again for your help, got it working. Actually the problem was ASA needed some time after configuring to work properly ( ?????? ). I configured and tested several times within a short period, during the day and was not working initially, GUI packet tracer was showing some problems (IPSEC Spoof detected) and also there was this left out dns. Its working fine now.
    But my problem is not solved fully here.
    Does hairpinning model allow access to the campus LAN behind ASA also?. Coz the setup is working now as i needed, and I can access Internet with the NAT'ed ip address (outside-interface). So far so good. But now I cannot access the Campus LAN behind the asa.
    Here the packet tracer output for the traffic:
    packet-tracer output
    asa# packet-tracer input internet2-outside tcp 192.168.150.1 56482 172.16.1.249 22
    Phase: 1
    Type: ACCESS-LIST
    Subtype:
    Result: ALLOW
    Config:
    Implicit Rule
    Additional Information:
    MAC Access list
    Phase: 2
    Type: FLOW-LOOKUP
    Subtype:
    Result: ALLOW
    Config:
    Additional Information:
    Found no matching flow, creating a new flow
    Phase: 3
    Type: ROUTE-LOOKUP
    Subtype: input
    Result: ALLOW
    Config:
    Additional Information:
    in   172.16.0.0      255.255.0.0     campus-lan
    Phase: 4
    Type: ROUTE-LOOKUP
    Subtype: input
    Result: ALLOW
    Config:
    Additional Information:
    in   192.168.150.1   255.255.255.255 internet2-outside
    Phase: 5
    Type: ACCESS-LIST
    Subtype: log
    Result: ALLOW
    Config:
    access-group internnet1-in in interface internet2-outside
    access-list internnet1-in extended permit ip 192.168.150.0 255.255.255.0 any
    Additional Information:
    Phase: 6
    Type: IP-OPTIONS
    Subtype:
    Result: ALLOW
    Config:
    Additional Information:
    Phase: 7
    Type: CP-PUNT
    Subtype:
    Result: ALLOW
    Config:
    Additional Information:
    Phase: 8
    Type: VPN
    Subtype: ipsec-tunnel-flow
    Result: ALLOW
    Config:
    Additional Information:
    Phase: 9
    Type: NAT-EXEMPT
    Subtype: rpf-check
    Result: ALLOW
    Config:
    Additional Information:
    Phase: 10
    Type: NAT
    Subtype:     
    Result: DROP
    Config:
    nat (internet2-outside) 1 192.168.150.0 255.255.255.0
      match ip internet2-outside 192.168.150.0 255.255.255.0 campus-lan any
        dynamic translation to pool 1 (No matching global)
        translate_hits = 14, untranslate_hits = 0
    Additional Information:
    Result:
    input-interface: internet2-outside
    input-status: up
    input-line-status: up
    output-interface: internet2-outside
    output-status: up
    output-line-status: up
    Action: drop
    Drop-reason: (acl-drop) Flow is denied by configured rule
    The problem here as you can see is the Rule for dynamic nat that I added to make hairpin work at first place
    dynamic nat
    asa(config)#nat (internet2-outside) 1 192.168.150.0 255.255.255.0
    Is it possible to access both
    1)LAN behind ASA
    2)INTERNET via HAIRPINNING  
    simultaneously via a single tunnel-group?
    If it can be done, how do I do it. What changes do I need to make here to get simultaneous access to my LAN also?
    Thanks & Regards
    Abhijit

  • Need help adding video to a site

    Hi Everyone:
    I really need some help please. The owner of a site I am
    working on sent me a DVD with video's he has taken and wants them
    put on his site.
    The files are VIDEO_TS and are MPEG files. How can I add the
    video's to the site so that when I user clicks on the link, they
    are able to either view the site or download the video to watch
    later. I have other video's added to the site but I was able to
    copy them and safe them the way there were added. The owner sells
    products from the site I copied them from.
    The site I am working on is www.buggyworld.net. Most of the
    individual pages for the vehilces have videos on them and I am
    trying to add these new ones the same way. I have never done this
    before so really not sure how to. The videos that are already added
    at Windows Media Audio/Video Files and that is how I would like to
    convert this video to.
    Any help would be so greatly appreciated.. thank you
    Linda

    Best bet would be to make Flash video so that everyone who
    wants to (and has
    the Flash Player plugin) can see them. Do you have Flash?
    Murray --- ICQ 71997575
    Adobe Community Expert
    (If you *MUST* email me, don't LAUGH when you do so!)
    ==================
    http://www.dreamweavermx-templates.com
    - Template Triage!
    http://www.projectseven.com/go
    - DW FAQs, Tutorials & Resources
    http://www.dwfaq.com - DW FAQs,
    Tutorials & Resources
    http://www.macromedia.com/support/search/
    - Macromedia (MM) Technotes
    ==================
    "Frank Branker" <[email protected]> wrote in
    message
    news:f4ph73$rcd$[email protected]..
    > What?s the size of your MPG file?
    >
    > It?s better if you convert your file to a wmv file
    format because it?s
    > important to keep your file size under 6 Megs. Do you
    have the software to
    > do
    > this?
    > Windows Movie maker might be able to do this you can
    find it in your
    > program
    > files on your computer.
    >
    > If not we will have to work with what you have and do a
    quick and dirty
    > but I
    > don?t advise that.
    >
    > Below is a list of tools you may want to consider
    owning.
    >
    > Ripping Software
    > This software will rip from a dvd to just about any
    format including WMV
    >
    http://www.imtoo.com/dvd-ripper.html
    >
    > Compressing software
    > Sorenson Squeeze Suite 4.5 is the industry-leading video
    encoding tool
    >
    http://www.sorensonmedia.com/pages/?pageID=2
    >
    >
    >

  • Need help adding AM/PM to my clock program

    Hi everyone
    I would be grateful if you could help me adding AM/PM to my clockDisplay program, been trying but i'm not very familiar with Java.
    Thanks
    I have used 2 classes:
    NumberDisplay and ClockDisplay
    the clock automatically convert hours after 12 noon such as 14:34 to 02:34 so all i need is to add PM and AM accordingly.
    NumberDisplay classs:
    public class NumberDisplay
        private int limit;
        private int value;
        public NumberDisplay(int rollOverLimit)
            limit = rollOverLimit;
            value = 0;
        public int getValue()
            return value;
        public String getDisplayValue()
            if(value < 10)
                return "0" + value;
            else
                return "" + value;
        public void setValue(int replacementValue)
            if((replacementValue >= 0) && (replacementValue < limit))
                value = replacementValue;
            else if ( (replacementValue>=limit) && (replacementValue>=0) )
               value=replacementValue-12;
        public void increment()
            value = (value + 1) % limit;
    }ClockDisplay class:
    public class ClockDisplay
        private NumberDisplay hours;
        private NumberDisplay minutes;
        private String displayString;    // simulates the actual display
        public ClockDisplay()
            hours = new NumberDisplay(12);
            minutes = new NumberDisplay(60);
            updateDisplay();
        public ClockDisplay(int hour, int minute)
            hours = new NumberDisplay(12);
            minutes = new NumberDisplay(60);
            setTime(hour, minute);
        public void timeTick()
            minutes.increment();
            if(minutes.getValue() == 0) {
                hours.increment();
            updateDisplay();
        public void setTime(int hour, int minute)
            hours.setValue(hour);
            minutes.setValue(minute);
             updateDisplay(); 
        public String getTime()
            return displayString;
        private void updateDisplay()
            displayString = hours.getDisplayValue() + ":" +
                            minutes.getDisplayValue();
    }As you see value=replacementValue-12; do the job.
    i tried do this:
    if(hours.setValue(hour)>=12)
    updateDisplayPm();
    else
    updateDisplay();
    and for
    private void updateDisplayPm()
    displayString = hours.getDisplayValue() + ":" +
                            minutes.getDisplayValue() + "PM";but it didnt work.
    so should iwrite if statemnt in NumberDisplay class and refer it to ClockDisplay or i can do something in clockDisplay.
    Looking forward to hear from you
    thanks

    solved
    public class NumberDisplay
        private int limit;
        private int value;
        private boolean isam;
        public NumberDisplay(int rollOverLimit)
            limit = rollOverLimit;
            value = 0;
        public int getValue()
            return value;
          public boolean getAm()
                 return isam;
        public String getDisplayValue()
            if(value < 10)
                return "0" + value;
            else
                return "" + value;
        public void setValue(int replacementValue)
            if((replacementValue >= 0) && (replacementValue < limit))
                value = replacementValue;
                isam=true;
            else if ( (replacementValue>=limit) && (replacementValue>=0) )
               value=replacementValue-12;
               isam=false;
        public void increment()
            value = (value + 1) % limit;
    public class ClockDisplay
        private NumberDisplay hours;
        private NumberDisplay minutes;
        private String displayString;    // simulates the actual display
        private NumberDisplay amCheck;
        public ClockDisplay()
            hours = new NumberDisplay(12);
            minutes = new NumberDisplay(60);
            updateDisplay();
        public ClockDisplay(int hour, int minute)
            hours = new NumberDisplay(12);
            minutes = new NumberDisplay(60);
            setTime(hour, minute);
        public void timeTick()
            minutes.increment();
            if(minutes.getValue() == 0) {
                hours.increment();
            updateDisplay();
        public void setTime(int hour, int minute)
            hours.setValue(hour);
            minutes.setValue(minute);
           updateDisplay(); 
        public String getTime()
            return displayString;
        private void updateDisplay()
            if(hours.getAm())
            displayString = hours.getDisplayValue() + ":" +  minutes.getDisplayValue() + "AM";
            else
             displayString = hours.getDisplayValue() + ":" +  minutes.getDisplayValue() + " PM";
    }

  • Need help adding footer to PDF

    I have Adobe Acrobat XI and I am trying to add a footer to a PDF, but I only receive a pop up message: You do not have sufficient permissions to perform this task.  Please help!!

    I think what you actually need is a dynamic stamp. Try searching these forums and also acrobatusers.com . There's a lot of information about it.

  • Need Help Adding Parameters to addWatermarkFromText using VBA

    After three days of banging my head on a wall, I got this to work:
    Public Sub AddText()
        Dim pdApp As Acrobat.AcroApp
        Dim pdDoc As Acrobat.AcroPDDoc
        Dim jso As Object
        Set pdDoc = CreateObject("AcroExch.PDDoc")
        pdDoc.Open ("c:\Test\Test.pdf")
        Set jso = pdDoc.GetJSObject
        jso.addWatermarkFromText ("Test")
        pdDoc.Save 1, "c:\Test\Test.pdf"
        pdDoc.Close
        Set pdDoc = Nothing
        MsgBox "Done"
    End Sub
    However, every time I try to add parameters to jso.addWatermarkFromText I get an error message - something is wrong with my syntax I suppose but i have tried every example I could find and nothing is working for me.  Please help - all of the default parameters are find, just need the text to be at the top of the page, not the center.

    Where did you get the impression that you can execute JavaScript in Acrobat
    using this method? You really (let me repeat that REALLY) have to read the
    SDK documentation. There no no way around that. Anything that is not
    described in the documentation will not work. There is only one way to
    execute JavaScript using the IAC API, and that is using this call:
    http://livedocs.adobe.com/acrobat_sdk/11/Acrobat11_HTMLHelp/IAC_API_FormsIntro.108.45.html
    However, in this case there is no need to use the executeThisJavaScript
    function, you can use the JSO to add your watermark. Everything you need is
    in the documentation, and as I mentioned before, there is no way around
    reading and understanding the docs. You cannot just google your way through
    a complex problem and try to piece together a solution based on bits and
    pieces you find online. Why do I know this? Because oftentimes I get called
    in after somebody tries that approach to save some money. I then get to
    clean up the mess they made, and then it's not going to be cheap... And
    this is one of the reasons why people are reluctant to provide code samples
    in this forum.
    Using a complex API as the Acrobat SDK requires you to climb a pretty steep
    learning curve, and you have to spend weeks and months (and sometimes
    years) reading and experimenting until you understand how things work. And
    that is why it's usually cheaper and faster to hire somebody to do that
    work for you.
    Back to  your  problem. What have you tried? I only remember seeing your
    call to addWatermarkFromText using just the text argument. BTW: There was
    no need to start a new thread, you should have kept everything in the first
    thread you started, this way everything is in one place. If you've posted
    more in the other thread, then you are making it much harder for us to
    provide help.
    So again, what have you tried and what results have you gotten? What error
    messages did the system produce? When? When you compiled the code, or when
    you tried to execute it?
    Karl Heinz Kremer
    PDF Acrobatics Without a Net
    PDF Software Development, Training and More...
    [email protected]
    http://www.khkonsulting.com
    On Sat, Jul 27, 2013 at 8:31 AM, I Love Mustangs

  • I need help adding text!

    I need some help with PE 12 and adding text...

    this forum is for photoshop elements and photoshop elements doesn't support editing GIF.
    You might want to post to photoshop community Photoshop General Discussion

  • Need help adding a second page on reports builder, paper layout.

    Hi,
    I have a requirement where I need to create a paper layout using Reports Builder (10.1.2.0.2). This report will print out the following:
    1) Invoice
    2) VAT Slip (on a separate page)
    So far I have created the invoice part and it is printing properly. Now I want to add the Vat slip. When I use the "Trailer Section" on the rdf report, I create a frame and inserted some text. The report ran just fine. Then in the same frame, I added a repeating frame. And now the report is completing with the following error:
    APPLLCSP Environment Variable set to :
    Current NLS_LANG and NLS_NUMERIC_CHARACTERS Environment Variables are :
    American_America.UTF8
    stat_low = 86
    stat_high = 0
    emsg:was terminated by signal 6
    Enter Password:
    MSG-00100: DEBUG: AfterPForm_Trigger +
    MSG-00100: DEBUG: Multi Org established.
    MSG-00100: DEBUG: AfterParam_Procs.Get_Country_Details
    MSG-00100: DEBUG: Get_Country_Description.
    MSG-00100: DEBUG: AfterParam_Procs.Switch_On_Debug
    MSG-00100: Running in debug mode
    MSG-00100: DEBUG: AfterParam_Procs.Get_Trx_Number_Low
    MSG-00100: DEBUG: AfterParam_Procs.Get_Trx_Number_High
    MSG-00100: DEBUG: AfterParam_Procs.Get_Tax_Option
    MSG-00100: DEBUG: AfterPForm_Trigger -
    *** glibc detected *** ora_rw20_run: munmap_chunk(): invalid pointer: 0x09067b10 ***
    Anyone have any idea why this is happening? Any help is much appreciated.
    Or is there any way I can add a page that has to be printed after the invoice?
    Thanks
    -Nelly

    If you have created your own template (but it sounds like you haven't) you will need to 'capture' that page so it repeats on following pages.
    The whole process is described here:
    "Letterhead and follower sets"
    http://www.freeforum101.com/iworktipsntrick/viewtopic.php?t=182&mforum=iworktips ntrick
    Peter

Maybe you are looking for