Need Help for Array with Object

hey there guys... am trying to complete my project which is to create a Library System. Was able to create a list to show the books available when they select the book and click a borrow button it can print out the book.
what problem i have now is that when a student click borrow... the value how can i transfer to an array inside the object student.
i am usin a main screen (ms) who is controlling all the functions. been trying and trying on this for very long hopefully there will be those who are able to help me out.
my customer screen would be like this... but how can i add in the array for books borrowed
import javax.swing.*;
class Customer
     private String name;
     private int accNo;
     private String password;
     private double balance;
     private Books borrow[]=new Books[5];
     int borrowCount=0;
     static int customerCount=0;
     private MainScreen ms;
     Customer(String n, int no, String p, double b)
          name=n;
          accNo=no;
          password=p;
          balance=b;
          customerCount++;
          JOptionPane.showMessageDialog(null,name +" record created");
          display();
/* Trying to Create the Array to store information
     public void setStudentBorrow(String a)
          borrow[borrowCount]=a;
          borrowCount++;
          JOptionPane.showMessageDialog(null,"Book Borrowed");
     public String getStudentBorrow()
          for(int i=0;i<borrowCount-1;i++)
          {     return borrow;     }
     public String getPassword()
     {     return password;     }
     public String getName()
     {     return name;          }
     public int getAccNo()
     {     return accNo;     }
     public double getBalance()
     {     return balance;     }
     public void setName(String n)
     {     name=n;     }
     public void setPassword(String p)
     {     password=p;     }
     public void setBalance(double b)
     {     balance=b;     }
     public void setAccNo(int no)
     {     accNo=no;     }
     public void display()
          JOptionPane.showMessageDialog(null,
          "\nCutomer Number : "+ customerCount+
          "\nName :"+name+
          "\nAccount Number: "+accNo+
          "\nBalance (RM): "+balance,"Customer record",
          JOptionPane.INFORMATION_MESSAGE     );

Cross Post:
http://forum.java.sun.com/thread.jspa?threadID=779224&messageID=4433689#4433689

Similar Messages

  • Need help for array counting

    Any help for array question
    Hello to All:
    I want to tally or count some of the elements that I have in array but not sure how.
    I have for example: int myArray[] = {90,93,80,81,71,72,73,74};My objective is to tally all of the 90's, tally all of the 80's and tally all of the 70's.
    So, the result that I want to have would look something like the following:
    System.out.println ("The total tally number of 90's is " 2 );
    System.out.println ("The total tally number of 80's is " 2 );
    System.out.println ("The total tally number of 70's is " 4 );I do not want to add these numbers, just want to count them.
    Also I want to use a "forloop" to achieve the result intead of just declaring it at 2 or 4 etc..
    Any help Thankyou

    [u]First , This is not exactly what I have to
    do for homework. There is a lot more, a lot more
    involved with the program that I am working on.
    Second, this is an example, an example, an
    example of something that I need to achieve.
    Third, you are asking for a code, to me that
    sounds as if your asking for homework. Fourth,
    I did not ask for any rude comments. Fith, in
    the future please do not reply to my messages at ALL
    if you can not help!!!!
    Sixth, We did not ask for lazy goofs to post here.
    Seventh, In the future please do not post here. Take a hike - there's the virtual door.

  • Need help for deadline with timing issues

    Hello everyone,
    (I'm still using the '08 versions of iLife)
    I have to meet a deadline within a week, and am having a problem with timing. I have a group f 32 slides, which I want to sync with an existing narrative soundtrack. I've attempted this in Keynote, GarageBand, and iMovie, with identical results...
    When I preview the presentation in any of those apps, it all looks fine. But when I save it as a movie, and play it, the images do not change at the times I had set for them. In QuickTime, if I hit "pause", and then "play", the image jumps to the correct one, but during normal playback, it seems to "hang" on certain images, while the soundtrack continues to play smoothly. I've got to meet my deadline with this project. Can anyone help?
    Thanks in advance.

    Hi Namrata,
    Requirement is very clear, you need to handle it in different PCR's need to be called in single PCR.
    ex. ZSS1 in call ZSS2 and ZSS3.
    Create a Constant in T511k and maintain dates of your payroll periods.
    And then write as below:
    AMT=1
    * <then call new calculation PCR>
    < <then call Old calculation PCR>
    Thank you,
    Sreenvaas.

  • Need help for filterFunction with special char

    Hi,
    I'm doing a simple search/filter process to a dataGrid collection upon text inputs with filterFunction. What I'm facing problem is, in one of my column field (on which I'm filtering) has dot "." as a suffix and it doesn't includes in the search process.
    Say I've a few values like - i_24., i_245., i_256.
    Now with the present filterfunction when an user inputs i_24. it shows the other record as well - i_245., where the expected entry should only be i_24. (since i_245. is not i_24.5)
    But it seems the search function is not taking the dot "." as a character in the search process, or at least when it is stays as suffix.
    I thouht maybe some RegExp could overcome the problem, but I'm not good in that either.
    Please, help.
    Thank you.
    Regards,
    Santanu

    aSuitableBoy,
    Use the String's "indexOf" method.  (http://help.adobe.com/en_US/FlashPlatform/reference/actionscript/3/String.html#indexOf()).
    The syntax would be: "String(<YOUR_COLLECTION>.<FIELD_TO_FILTER_ON>).indexOf(<COMPARE_STRING_FROM_TEXT_INPUT>)
    Here's a really small code snippet that I just wrote up, that works:
    <mx:Application xmlns:mx="http://www.adobe.com/2006/mxml" layout="absolute" creationComplete="cc();">
              <mx:Script>
                        <![CDATA[
                             import mx.controls.Alert;
                             import mx.collections.ArrayCollection;
                             [Bindable] private var ac:ArrayCollection = new ArrayCollection();
                        private function cc():void
                                       var o:Object = new Object();
                                       o.field1 = "Value 1:";
                                       o.field2 = "i_24.";
                                       o.field3 = "Some other value...";
                                       ac.addItem(o);
                                       o = new Object();
                                       o.field1 = "Value 2:";
                                      o.field2 = "i_245.";
                                       o.field3 = "Some other value...";
                                       ac.addItem(o);
                                       o = new Object();
                                      o.field1 = "Value 3:";
                                       o.field2 = "i_256.";
                                       o.field3 = "Some other value...";
                                       ac.addItem(o);
                        private function filterFunc(o:Object):Boolean
                                       return String(o.field2).indexOf("i_24.") != -1;
                        ]]>
              </mx:Script>
              <mx:HBox width="100%" height="100%">
                             <mx:DataGrid id="dg" height="100%" width="100%" dataProvider="{ac}">
                                            <mx:columns>
                                                           <mx:DataGridColumn headerText="Column 1" dataField="field1" />
                                                           <mx:DataGridColumn headerText="Column 2" dataField="field2" />
                                                           <mx:DataGridColumn headerText="Column 3" dataField="field3" />
                                            </mx:columns>
                             </mx:DataGrid>
                             <mx:Button id="b1" label="Filter" click="{ac.filterFunction = filterFunc; ac.refresh();}" />
              </mx:HBox>
    </mx:Application>

  • Need help for array

    it said this is not a statement,
    and i cannot access keys[j] as well.
    any help would be great thank you~
    char[] = keys;
    package arry;
    import javax.swing.JOptionPane;
    * @author chris
    public class Main {
         * @param args the command line arguments
        public static void main(String[] args) {
            char[][] answers = {
                {'A' , 'B', 'A', 'C', 'C', 'D', 'E', 'A', 'D' , 'D' },
                {'D' , 'B', 'A', 'B', 'C', 'A', 'A', 'E', 'A', 'D'}
            //char[] keys = {'D' , 'B' , 'D' , 'C', 'C', 'D', 'A', 'E', 'A', 'D'};
            char[] = keys;
            for(int k = 0; k < 10; k++)
                String answerschar = JOptionPane.showInputDialog("Enter the Grade");
                //char[] keys = answerschar.toCharArray();
                keys[k] = answerschar.charAt(0);
            for(int i=0; i< answers.length; i++)
                int correctcount = 0;
                for(int j=0 ; j < answers.length; j++)
    if(answers[i][j] == keys[j])
    correctcount++;
    System.out.println("Student " + i + " s' correct answer is " + correctcount);

    flounder ur tips are always helpful..i figure it out now
    the code should be like this : )
    char[] keys =  new char[10];
            for(int k = 0; k < keys.length ; k++)
                String answerschar = JOptionPane.showInputDialog("Enter the Grade");
                //char[] keys = answerschar.toCharArray();
                keys[k] = answerschar.charAt(0);
            }

  • Need help for finding objects impacted by size change for an infoobject

    hi all,
    need help for finding objects impacted by size change
    for xxx infoobject, due to some requirements, the size to be changed from
    char(4) to char(10), in the source database tables as well as adjustment
    to be done in BI side.
    this infoobject xxx is nav attribute of YYY as well as for WWW
    infoobjects. and xxx is loaded from infopkg for www infoobject load.
    now that i have to prepare an impact analysis doc for BI side.
    pls help me with what all could be impacted and what to be done as a
    solution to implement the size change.
    FYI:
    where used list for xxx infoobject - relveals these object types :
    infocubes,
    infosources,
    tranfer rules,
    DSO.
    attribute of characteristic,
    nav attribute,
    ref infoobject,
    in queries,
    in variables

    Hi Swetha,
    You will have to manually make the table adjustments in all the systems using SE14 trans since the changes done using SE14 cannot be collected in any TR.
    How to adjust tables :
    Enter the table name in SE14. For ex for any Z master data(Say ZABCD), master data table name would be /BIC/PZABCD, text table would be /BIC/TZABCD. Similarly any DSO(say ZXYZ) table name would be /BIC/AZXYZ00 etc.
    Just enter the table name in SE14 trans --> Edit --> Select the radio button "Save Data" --> Click on Activate & adjust database table.
    NOTE : Be very careful in using SE14 trans since there is possibility that the backend table could be deleted.
    How to collect the changes in TR:
    You can collect only the changes made to the IO --> When you activate, it will ask you for the TR --> Enter the correct package name & create a new TR. If it doesn't prompt you for TR, just goto Extras --> Write transport request from the IO properties Menu screen. Once these IO changes are moved successfully, then the above proceduce can be followed using SE14 trans.
    Hope it helps!
    Regards,
    Pavan

  • I have problem with buying in games , I got the massage that the purchased can not be completed , please contact iTunes support.. I need help for my case please

    I have problem with buying in games , I got the massage that the purchased can not be completed , please contact iTunes support.. I need help for my case please

    http://www.apple.com/support/itunes/contact/

  • Need help for setFilterPredicate

    Hello community,
    beeing quite new with the fascinating Xcode environment, I need your help for a simple thing of NSPredicate.
    ( Well, only simple for those who know...)
    I like to display a set of values in a tableview (tblView), and to filter it with the nice search field (searchField).
    What I tried:
    1.) creating an array with objects defined in MyData.h with a property named mytext
    2.) creating a NSArrayController, contens is the array of 1.
    3.) creating an NSPredicate filter in MyModel.m (see below)
    4.) Binding the filter to the ArrayController in the "filter predicate"-section : bind to MyModel, model Key Path = myPredicate
    Everything looks fine when the app starts. But when I try to change the filter in my search field, I get the message:
    [<MyModel 0x100141660> setValue:forUndefinedKey:]: this class is not key value coding-compliant for the key myPredicate.
    Here are the codes of interest, all in the implementation section of MyModel.
    Whats wrong with it ?
    -(id)myPredicate {
              NSString *theString    = [searchField stringValue ];
              NSPredicate *theResult = [NSPredicate predicateWithFormat:@"mytext like %@",theString];
              NSArray *hasFound      = [theData filteredArrayUsingPredicate:theResult];
              printf("Items found : %d\n",(int)[hasFound count]);
              return theResult;
    -(IBAction)updateFilter:(id)sender
              NSString *theString    = [searchField stringValue ];
      printf(".. recognize search changes \n");
              NSPredicate *theResult = [NSPredicate predicateWithFormat:@"mytext like %@",theString];
              [arrayCtrl setFilterPredicate:theResult];
              [tblView reloadData];
    Thanks for helping me out of the mess !

    Here is the manual for the HP Business Consultant II (HP-19B Financial Calculator)

  • Need help for flash builder

    i need help for flash builder 4 and papervison 3d. I need to create a slider with it ranges of value from 10 to 50 to adjust the camera values for the camera.fov and also need to create it for the yaw of the object from 0 to 360. I try to look for any slider event and classes in this program but cant find any, btw, i need to use the AS only project file.
    here is my codes:
    can you please tell me how i should modify the codes?
    package
        import flash.display.BitmapData;
        import flash.display.Sprite;
        import flash.events.Event;
        import org.papervision3d.materials.BitmapFileMaterial;
        import org.papervision3d.materials.BitmapMaterial;
        import org.papervision3d.objects.primitives.Sphere;
        import org.papervision3d.view.BasicView;
        [SWF (width="800", height="600", backgroundColor="0x000000",frameRate="30")]
        public class EarthBitmap extends BasicView
            private var sphere:Sphere;
            public function EarthBitmap()
                super(800 , 600);
                var earthmaterial:BitmapFileMaterial = new BitmapFileMaterial("../assets/Earth.jpg");
                sphere = new Sphere(earthmaterial,100,20,18);
                camera.fov = 25;
                scene.addChild(sphere);
                addEventListener(Event.ENTER_FRAME,rotateSphere);
            public function rotateSphere(evt:Event):void
                sphere.yaw(0.2);
                singleRender();

    Turn the click handler into a full on separate function. Then store all the views in an array and use Math.rand() to randomly choose one.
    Something like this:
    <fx:Script>
         <![CDATA[
              var questionsArray:Array = {question2,question3,question5,questionRed,questionGeography};
              function buttonClickHandler(event:MouseEvent){
                   var randomProblem:int = Math.floor(Math.random()*(questionsArray.length));     //generates a random integer between 0 and the total number of questions in the array (arrays are 0-based)
                   navigator.pushView(questionsArray[randomProblem]);
         ]]>
    </fx:Script>
    <s:Button id="randomProblemButton" label="Next Problem" click="buttonClickHandler(event)" />
    Haven't tested that, but something along that line should work

  • Need help for importing oracle 10G dump into 9i database

    hi, Someone help me to import oracle 10G dump into 9i database. I'm studying oracle . Im using oracle 10G developer suite(downloaded from oracle) and oracle 9i database. I saw some threads tat we can't import the higher version dumps into lower version database. But i'm badly need help for importing the dump...
    or
    someone please tell me the site to download oracle 9i Developer suite as i can't find it in oracle site...

    I didnt testet it to import a dump out of a 10g instance into a 9i instance if this export has been done using a 10g environment.
    But it is possible to perform an export with a 9i environment against a 10g instance.
    I am just testing this with a 9.2.0.8 environment against a 10.2.0.4.0 instance and is working so far.
    The system raises an EXP-00008 / ORA-37002 error after exporting the data segments (exporting post-schema procedural objects and actions).
    I am not sure if it is possible to perform an import to a 9i instance with this dump but maybe worth to give it a try.
    It should potentially be possible to export at least 9i compatible objects/segments with this approach.
    However, I have my doubts if this stunt is supported by oracle ...
    Message was edited by:
    user434854

  • Need help for Format HD

    Hi I need Help for Formating HD so Wat Key need hold on start up for format HD I apprciated you Help

    Jesus:
    Formatting, Partitioning Erasing a Hard Disk Drive
    Warning! This procedure will destroy all data on your Hard Disk Drive. Be sure you have an up-to-date, tested backup of at least your Users folder and any third party applications you do not want to re-install before attempting this procedure.
    • With computer shut down insert install disk in optical drive.
    • Hit Power button and immediately after chime hold down the "C" key.
    • Select language
    • Go to the Utilities menu (Tiger) Installer menu (Panther & earlier) and launch Disk Utility.
    • Select your HDD (manufacturer ID) in left side bar.
    • Select Partition tab in main panel. (You are about to create a single partition volume.)
    • _Where available_ +Click on Options button+
    +• Select Apple Partition Map (PPC Macs) or GUID Partition Table (Intel Macs)+
    +• Click OK+
    • Select number of partitions in pull-down menu above Volume diagram.
    (Note 1: One partition is normally preferable for an internal HDD.)
    • Type in name in Name field (usually Macintosh HD)
    • Select Volume Format as Mac OS Extended (Journaled)
    • Click Partition button at bottom of panel.
    • Select Erase tab
    • Select the sub-volume (indented) under Manufacturer ID (usually Macintosh HD).
    • Check to be sure your Volume Name and Volume Format are correct.
    • Click Erase button
    • Quit Disk Utility.
    cornelius

  • Need help for my requirement...

    Need help for my requirement...
    Hello Experts,
    I have report where users can input the company, housebank, account ID and posting date.
    Now in one column of my report named 'Cash in Bank', I need to get all postings from cash
    accounts with GL code ending in '0'. Now, I know that I can get the amounts in BSIS/BSAS
    but how do I link it with the proper bank and account?
    For example:
                       Cash in Bank
    Bank A
      Account ID 1     1,000,000
      Account ID 2     25,000,000
    Hope you can help me guys. Thank you and take care!

    hi Viraylab,
    each house bank you can find in table T012, in T012K you'll find the bank accounts to the housebank, the G/L account will be in T012K-HKONT.
    hope this helps
    ec

  • Need Help for Nokia 6500 slide

    Hi all I'm A new Guy here ,
    But I do really need help for hard reset my phone
    I already try *#7073# But It doesn't work ,
    If Anybody know to make a hard reset please help

    rwss wrote:
    I'v got te same problem with my 6500 Slide, is there a button combination that we have to press
    to hard reset the 6500 Slide?!
    How does the 6500 slide hard reset?
    That's simple.
    All you have to do is:
    From MENU goto SETTINGS, When there scroll down and select 'Restore Factory Setting'.
    There are two options in there:
    "Restore Settings only"
    and
    "Restore all"
    Select "Restore All"
    When done the phone will delete every thing on the Phone memory(C:\)(contacts,picture,messages etc)
    and also restore phone to its original settings and will restart.
    This proceedure is mostly common on S40 phone.
    Hope this explain and solve the problem.

  • Need help for publishing web intelligence document (universe) into InfoView

    Post Author: mirage
    CA Forum: Publishing
    Hello all,
    I need help for publishing web intelligence document (universe) into InfoView.
    can't find this information in Business Objects Designer's Guide and in Business Objects Administrator Guide.
    Can somebody give short instructions how can I do it?
    Regards, Slava

    If the change between the 2 types of data has to happen dynamically during run time them
    1. Use 2 dataproviders
         a. Current
         b. Historic
    2. Merge the 2 dimensions
    3. Use Webi variable to switch between the measure of the current and historic universe
    Ex  if [year] < 2010 then historic.[expense] else current.[expense]
    Hope this helps,
    Divya

  • Need help for access list problem

    Cisco 2901 ISR
    I need help for my configuration.... although it is working fine but it is not secured cause everybody can access the internet
    I want to deny this IP range and permit only TMG server to have internet connection. My DHCP server is the 4500 switch.
    Anybody can help?
             DENY       10.25.0.1 – 10.25.0.255
                              10.25.1.1 – 10.25.1.255
    Permit only 1 host for Internet
                    10.25.7.136  255.255.255.192 ------ TMG Server
    Using access-list.
    ( Current configuration  )
    object-group network IP
    description Block_IP
    range 10.25.0.2 10.25.0.255
    range 10.25.1.2 10.25.1.255
    interface GigabitEthernet0/0
    ip address 192.168.2.3 255.255.255.0
    ip nat inside
    ip virtual-reassembly in max-fragments 64 max-reassemblies 256
    duplex auto
    speed auto
    interface GigabitEthernet0/1
    description ### ADSL WAN Interface ###
    no ip address
    pppoe enable group global
    pppoe-client dial-pool-number 1
    interface ATM0/0/0
    no ip address
    no atm ilmi-keepalive
    interface Dialer1
    description ### ADSL WAN Dialer ###
    ip address negotiated
    ip mtu 1492
    ip nat outside
    no ip virtual-reassembly in
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication pap callin
    ppp pap sent-username xxxxxxx password 7 xxxxxxxxx
    ip nat inside source list 101 interface Dialer1 overload
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip route 10.25.0.0 255.255.0.0 192.168.2.1
    access-list 101 permit ip 10.25.0.0 0.0.255.255 any
    access-list 105 deny   ip object-group IP any
    From the 4500 Catalyst switch
    ( Current Configuration )
    interface GigabitEthernet0/48
    no switchport
    ip address 192.168.2.1 255.255.255.0 interface GigabitEthernet2/42
    ip route 0.0.0.0 0.0.0.0 192.168.2.3

    Hello,
    Host will can't get internet connection
    I remove this configuration......         access-list 101 permit ip 10.25.0.0 0.0.255.255 any
    and change the configuration ....      ip access-list extended 101
                                                                5 permit ip host 10.25.7.136 any
    In this case I will allow only host 10.25.7.136 but it isn't work.
    No internet connection from the TMG Server.

Maybe you are looking for

  • Package for Business Objects Explorer

    Hello, can anyone say what the "name" of the package is that we have to order to get access to ASP Business Objects Explorer software? We want to use the non accelerated version of Explorer first. I am asking here to speed up the process - I want to

  • Internal Table Logic Needed

    Hi all, I have a requirement regarding data processing in a internal table, internal table consists of filelds Vendor,Material and Scheduling Dates and Total Qty. Here i need to fill the field Total Quantity, individual addition of quanties of that m

  • How to find which photo have assigned place, and which not?

    Hi! My problem seams to be trivial, but after extensive search in built-in help and many tries, I'm giving up. Is there any way to make smart folder with all of my photos, that have no geotags at all? It would be great to have such folder, so tagged

  • ICal server with alternate LDAP

    Hi, In the (very, very brief) documentation for iCal Server, it says: To run iCal service, you need: User names and passwords stored in a Mac OS X version 10.5 Open Directory system, an Active Directory system (using the Active Directory plug-in for

  • How can I download Photoshop Elements 8?

    How can I download Photoshop Elements 8?