Need help for File to Http Scenario

Hello all,
   I want to send flat file source to destination . my source side Adapter is File, destination adapter is Http. What are the steps need to do.
Thanks

1) Define the Data types ,message type , message interface for source and target messages.
2) Create the required mapping and associate it to an interface mapping
3) Create a communication channel for the sender (file adapter) and one for the receiver
4) Create the 4 collaboration objects in directory

Similar Messages

  • Need Help for redirect to HTTPS

    Hello forum members,
    i have difficulty while configuring http to https while accessing specific url.
    the case:
    i have www.foo-bar.com.god in http, in the web page there is www.foo-bar.com.god/trust/* that must be accessing in https
    is there any spesific line of config to apply in my config,
    my config is below.
    ### start
    access-list INBOUND line 8 extended permit ip any any
    parameter-map type http PERSISTENCE-REBALANCE
    persistence-rebalance
    parameter-map type ssl SSL_END_to_END
      cipher RSA_WITH_RC4_128_SHA priority 10
      cipher RSA_WITH_3DES_EDE_CBC_SHA priority 7
      cipher RSA_WITH_AES_128_CBC_SHA priority 9
      cipher RSA_WITH_AES_256_CBC_SHA priority 8
      session-cache timeout 600
    rserver host PORTAL-A
    ip address 10.49.30.200
    inservice
    action-list type modify http FORCE-HTTPS
    ssl url rewrite location "www\.foo\-\bar\.com\.god\trust\*"
    header insert  response Cache-Control header-value "private, no-cache, no-store, must-revalidate"
    header rewrite response Server header-value "" replace "BLANK"
    serverfarm host PORTAL-SFARM
    rserver PORTAL-A 80
       inservice
    ssl-proxy service PORTAL-CERT
    key portal.key
    cert portal.crt
    sticky ip-netmask 255.255.255.255 address source SOURCEIP-STICKY-HTTP-SFARM
    replicate sticky
    serverfarm PORTAL-SFARM
    class-map match-all SSL-VIP
    2 match virtual-address 10.49.30.230 tcp eq https
    class-map match-all HTTP-VIP
    2 match virtual-address 10.49.30.230 tcp eq www
    class-map type management match-any remote_access
    202 match protocol icmp any
    204 match protocol ssh any
    207 match protocol snmp any
    208 match protocol telnet any
    209 match protocol http any
    210 match protocol https any
    211 match protocol xml-https any
    policy-map type management first-match management
    class remote_access
       permit
    policy-map type loadbalance first-match LB-PORTAL-L7-POLICY
    class class-default
       sticky-serverfarm SOURCEIP-STICKY-HTTP-SFARM
       action FORCE-HTTPS
    policy-map multi-match LB-PORTAL-L4-POLICY
    class SSL-VIP
       loadbalance vip inservice
       loadbalance policy LB-PORTAL-L7-POLICY
       loadbalance vip icmp-reply
       nat dynamic 1 vlan 260
       appl-parameter http advanced-options PERSISTENCE-REBALANCE
       ssl-proxy server PORTAL-CERT
    interface vlan 260
    description "User-Access"
    ip address 10.49.30.231 255.255.255.192
    peer ip address 10.49.30.232 255.255.255.192
    access-group input INBOUND
    nat-pool 1 10.49.30.252 10.49.30.252 netmask 255.255.255.255
    service-policy input management
    service-policy input LB-PORTAL-L4-POLICY
    no shutdown
    ### End
    need for review the config
    thanks and regards
    hamzah

    Hi Singh,
    thank you for reply,
    i just change the config so hope fully the web can redirecting properly.
    but when i apply the config, the Browser say, the connection was reset.
    Need help
    here is my full config
    crypto chaingroup portal-verySign
      cert portal.pem
    access-list everyone line 8 extended permit ip any any
    rserver host PORTAL-A
      ip address 10.49.30.200
      inservice
    rserver redirect PORTAL_REDIR_HTTPS
      webhost-redirection https://%h%p 302
      inservice
    serverfarm redirect PORTAL_HTTPS_SFARM
      rserver PORTAL_REDIR_HTTPS
        inservice
    serverfarm host WWW_PORTAL_SFARM
      rserver PORTAL-A 80
        inservice
    parameter-map type http PERSISTENCE-REBALANCE
      persistence-rebalance
    parameter-map type ssl SSL_END_to_END
      cipher RSA_WITH_RC4_128_SHA priority 10
      cipher RSA_WITH_3DES_EDE_CBC_SHA priority 7
      cipher RSA_WITH_AES_128_CBC_SHA priority 9
      cipher RSA_WITH_AES_256_CBC_SHA priority 8
      session-cache timeout 600
    sticky http-cookie PORTAL-STICKY STICKY-PORTAL-1
      serverfarm WWW_PORTAL_SFARM
    sticky ip-netmask 255.255.255.255 address source SOURCEIP-STICKY-HTTP-SFARM
      replicate sticky
      serverfarm WWW_PORTAL_SFARM
    action-list type modify http HTTP_MODIFICATION
      header insert request X-Forwarded-Proto header-value "%pd"
      header insert request Via header-value "1.1 web:%pd"
      header insert response Via header-value "1.1 web:ps"
      ssl url rewrite location ".*"
      ssl header-insert session Id
    ssl-proxy service CLIENT_PORTAL
      ssl advanced-options SSL_END_to_END
    ssl-proxy service SERVER_PORTAL
      key portal-key.pem
      cert portal.pem
      chaingroup portal-verySign
      ssl advanced-options SSL_END_to_END
    class-map type http loadbalance match-any PORTAL-SSL
      2 match http url .*
    class-map match-all VIP-SSL-PORTAL
      2 match virtual-address 10.49.30.230 tcp eq https
    class-map match-all VIP-WWW-PORTAL
      2 match virtual-address 10.49.30.230 tcp eq www
    policy-map type loadbalance first-match PORTAL_HTTPS_DEFAULT
      class class-default
        compress default-method gzip
        sticky-serverfarm SOURCEIP-STICKY-HTTP-SFARM
        action HTTP_MODIFICATION
        ssl-proxy client CLIENT_PORTAL
    policy-map type loadbalance first-match PORTAL_HTTP_DEFAULT
      class class-default
        serverfarm PORTAL_HTTPS_SFARM
    policy-map multi-match L4_PORTAL_LB
      class VIP-WWW-PORTAL
        loadbalance vip inservice
        loadbalance policy PORTAL_HTTP_DEFAULT
        loadbalance vip icmp-reply active
        nat dynamic 1 vlan 260
      class VIP-SSL-PORTAL
        loadbalance vip inservice
        loadbalance policy PORTAL_HTTPS_DEFAULT
        loadbalance vip icmp-reply active
        nat dynamic 1 vlan 260
        appl-parameter http advanced-options PERSISTENCE-REBALANCE
        ssl-proxy server SERVER_PORTAL
    interface vlan 260
      description User-Access
      ip address 10.49.30.231 255.255.255.192
      peer ip address 10.49.30.232 255.255.255.192
      access-group input everyone
      nat-pool 1 10.49.30.252 10.49.30.252 netmask 255.255.255.255
      service-policy input L4_PORTAL_LB
      no shutdown
    ip route 0.0.0.0 0.0.0.0 10.49.30.195
    ip route 10.0.0.0 255.255.255.0 10.49.30.193
    need your advice

  • Need help for file upload - reposted for Steve Muench

    Hi Steve,
    I have been involved developing a web application that requires a file upload operation. I have studied your example on Upload Text File and Image Example in the Not Yet Documented ADF Sample Applications section. I got the file upload part worked but could not get the original file name to populate the name field..i.e. if I upload myFile.txt to the database, the name field will be myFile.txt (not the name enter by user). Is there a way to capture the filename info? or is it possible to do so within ADF framework? I am using ADF/Struts/JSP with ORDDoc data type. Thanks very much.
    Bill

    Hello Nani,
    You need to change any settings in 'FILE' transaction. This transaction is used to set up Logical file paths. ( In general it will be set already for your system).
    You can use the following code.
      DATA: LC_LOGICAL_FILENAME_EXPSRC LIKE RCGIEDIAL-IEFILE
                                                    VALUE 'EHS_IMP_SOURCES'.
      DATA:      L_EMERGENCY_FLAG            TYPE C.
      DATA:      L_FILE_FORMAT               LIKE FILENAME-FILEFORMAT.
      data : X_RCGIEDIAL LIKE  RCGIEDIAL occurs 0 with HEADER LINE.
      read the default pathname on application server
        CALL FUNCTION 'FILE_GET_NAME'
             EXPORTING
                CLIENT                  = SY-MANDT
                  LOGICAL_FILENAME        = LC_LOGICAL_FILENAME_EXPSRC
                  OPERATING_SYSTEM        = SY-OPSYS
                parameter_1             = ' '
                PARAMETER_2             = ' '
                USE_PRESENTATION_SERVER = ' '
                WITH_FILE_EXTENSION     = ' '
                USE_BUFFER              = ' '
             IMPORTING
                  EMERGENCY_FLAG          = L_EMERGENCY_FLAG
                  FILE_FORMAT             = L_FILE_FORMAT
                  FILE_NAME               = X_RCGIEDIAL-IEFILE
             EXCEPTIONS
                  FILE_NOT_FOUND          = 1
                  OTHERS                  = 2.
        write :/ 'file format', L_FILE_FORMAT,
               / 'file name', X_RCGIEDIAL-IEFILE.
    Thanks,
    Jyothi

  • Alert Configuration for File to IDoc scenario

    I have followed Alerts : Step-by-Step /people/michal.krawczyk2/blog/2005/06/28/xipi-faq-frequently-asked-questions
    and configured Alerts for file to IDoc scenario.
    But the problem is, I did not notice any alerts being generated. I could notice the IDocs being posted to destination system. So I was going through Alerts-Troubleshoute Guide. In intension to maintain monitoring level, I clicked Configuration tab. But I did not notice my sender and receiver system there to maintain.
    Can any body help me to detail out the procedure to add sender and receiver systems to maintain the monitoring level?
    Regards,
    Suraj Kumar

    hi Suraj,
    WHich SP version are you on??
    If you are on Sp14 or above, then unfortunately, Michal's Trouble Shooting for Alerts will not help.
    From SP14 onwards, activation of end to end monitoring is not needed for Alerting. Refer to this note <b>870232</b> for this info.
    Next, to test if your Alerts have been defined correctly, go to SE38. In the program , type RSALERTTEST and then click on EXECUTE button ( F8 ). In the next window, it will ask you for your ALERTCATEGORY. Just give the name of your ALERT CATEGORY and click EXECUTE.
    If you have configured your alerts correctly, you will receive a message that tells ALERT IS GENERATED and will give the ALERT ID.
    Now, go to your Run TIme workbench and then select ALERT INBOX and see if you have got the ALERT message in your ALERT INBOX.
    If this is working fine, then the last step, implement the note 913858.
    Regards,
    Bhavesh

  • Need help for Transfer PO

    need help for Transfer PO.
    i need help for to transfer PO from one season to onther season. pleas ehelp me how to proceed and how 2 approach the process.
    if any code is there please provide  me

    follow the link
    it may help you
    MM SCENARIO
    https://www.sdn.sap.com/irj/sdn/advancedsearch?cat=sdn_all&query=abapcodetotransferpurchaseorder&adv=true&sdn_author_name=&sdn_allusernamesofthread=&sdn_category=&sdn_forum=&sdn_updated_on_comparator=GE&sdn_updated_on=&sortby=cm_rnd_rankvalue
    reward if helpful
    Edited by: sharad narayan on Apr 8, 2008 3:16 PM

  • File to Http Scenario

    Hello All,
            My Requirement is File to HTTP Scenario Where i would read a  xml file and send the data to webpage using Http receiver adapter. what are the steps for this scenario.  How to configure Http adapter.
    Thanks

    Hi san
    check these threads
    HTTP to File ??
    File to HTTP scenario
    See here how u need to configure the reciever HTTP adapter.
    /people/bla.suranyi/blog/2006/07/10/xi--sap-business-connector-integration-using-the-http-adapter
    /people/siva.maranani/blog/2005/09/15/push-data-to-mvc-architectured-application-using-xi
    Regards
    BILL

  • Pls i need help for this simple problem. i appreciate if somebody would share thier ideas..

    pls i need help for this simple problem of my palm os zire 72. pls share your ideas with me.... i tried to connect my palm os zire72 in my  desktop computer using my usb cable but i can't see it in my computer.. my palm has no problem and it works well. the only problem is that, my  desktop computer can't find my palm when i tried to connect it using usb cable. is thier any certain driver or installer needed for it so that i can view my files in my palm using the computer. where i can download its driver? is there somebody can help me for this problem? just email me pls at [email protected] i really accept any suggestions for this problem. thanks for your help...

    If you are using Windows Vista go to All Programs/Palm and click on the folder and select Hot Sync Manager and then try to sync with the USB cable. If you are using the Windows XP go to Start/Programs/Palm/Hot Sync Manager and then try to sync. If you don’t have the palm folder at all on your PC you have to install it. Here is the link http://kb.palm.com/wps/portal/kb/common/article/33219_en.html that version 4.2.1 will be working for your device Zire 72.

  • I am setting up a new iMac and need help syncing files to Dropbox.  On my old computer I had it set where when I saved a document, it was saved on my hard drive, as well as to a folder in Dropbox.  I can't remember how I set this up.  Any help?

    I am setting up a new iMac and need help syncing files to Dropbox.  On my old computer I had it set where when I saved a document, it was saved on my hard drive, as well as to a folder in Dropbox.  I can't remember how I set this up.  Any help?

    The way that Dropbox works is that it keeps a copy of all your files in your local Dropbox folder on your hard drive (which is, by default, directly under your home folder). Adding files to that folder will sync them to the Dropbox server.
    You do of course have to download the Dropbox application to enable this (download link at the top right of http://dropbox.com ).
    Matt

  • Namespace Creation for file to idoc scenario

    Hi ,
    while creating new  namespace in integration repository for file-> XI-> idoc scenario ( that is data is to be pushed from a file to R/3 using idoc ) we have to enter the connection data viz:
                                           system :..............
                                           Client .................
    Pl confirm the above system and client to be mentioned is of XI server or R/3 system.
    Further when we go for
                                   imported objetcs ->
                                                IDOCS -import of sap object-->
                                                Application server Name :....................
                                                System No:..............................
                                                User :.................
                                                Name :................
                                                Pwd:.................
    Pl confirm the above data to be mentioned is of XI server or R/3 system.
    pl help.

    Hi,
    <b>while creating new namespace in integration repository for file-> XI-> idoc scenario ( that is data is to be pushed from a file to R/3 using idoc ) we have to enter the connection data viz:
    system :..............
    Client .................
    Pl confirm the above system and client to be mentioned is of XI server or R/3 system.</b>
    Ans <b>R/3</b>
    <b>Further when we go for
    imported objetcs ->
    IDOCS -import of sap object-->
    Application server Name :....................
    System No:..............................
    User :.................
    Name :................
    Pwd:.................
    Pl confirm the above data to be mentioned is of XI server or R/3 system.</b>
    Ans: <b>R/3</b>
    Regards,

  • Need help for flash builder

    i need help for flash builder 4 and papervison 3d. I need to create a slider with it ranges of value from 10 to 50 to adjust the camera values for the camera.fov and also need to create it for the yaw of the object from 0 to 360. I try to look for any slider event and classes in this program but cant find any, btw, i need to use the AS only project file.
    here is my codes:
    can you please tell me how i should modify the codes?
    package
        import flash.display.BitmapData;
        import flash.display.Sprite;
        import flash.events.Event;
        import org.papervision3d.materials.BitmapFileMaterial;
        import org.papervision3d.materials.BitmapMaterial;
        import org.papervision3d.objects.primitives.Sphere;
        import org.papervision3d.view.BasicView;
        [SWF (width="800", height="600", backgroundColor="0x000000",frameRate="30")]
        public class EarthBitmap extends BasicView
            private var sphere:Sphere;
            public function EarthBitmap()
                super(800 , 600);
                var earthmaterial:BitmapFileMaterial = new BitmapFileMaterial("../assets/Earth.jpg");
                sphere = new Sphere(earthmaterial,100,20,18);
                camera.fov = 25;
                scene.addChild(sphere);
                addEventListener(Event.ENTER_FRAME,rotateSphere);
            public function rotateSphere(evt:Event):void
                sphere.yaw(0.2);
                singleRender();

    Turn the click handler into a full on separate function. Then store all the views in an array and use Math.rand() to randomly choose one.
    Something like this:
    <fx:Script>
         <![CDATA[
              var questionsArray:Array = {question2,question3,question5,questionRed,questionGeography};
              function buttonClickHandler(event:MouseEvent){
                   var randomProblem:int = Math.floor(Math.random()*(questionsArray.length));     //generates a random integer between 0 and the total number of questions in the array (arrays are 0-based)
                   navigator.pushView(questionsArray[randomProblem]);
         ]]>
    </fx:Script>
    <s:Button id="randomProblemButton" label="Next Problem" click="buttonClickHandler(event)" />
    Haven't tested that, but something along that line should work

  • Need help for writing extract program

    hi
    i need help for writing extract program to retriew data from legacy system.
    i already developed bdc programs for me31k and me21.
    my requirement is to write extract program s for those t.codes.
    to retriew data from legacy system and stored in flat file.

    i need help with a java program. it is a program that allows the user to enter a student's GPA, number of extracurricular activities, and number of service activities. The user can not enter a gpa above 4.0 or below 0. The user can not enter a negative number for the number of both activities. If the student meets the following criteria: 1) GPA of 3.8 or above and at least one extracurricular activity and one service activity, 2) GPA below 3.8 but at least 3.4 and a total of at least three extracurricular and service activities, 3) GPA below 3.4 but at least 3.0 and at least two extracurricular activities and three service activities, the message "Scholarship candidate" should display. If the student does not meet the criteria above, then the message"not a candidate" should display. Can you help me, please?
    You haven't posted ANY 'java program' for us to help with.
    The forum is NOT a coding service. It is to help you with YOUR code.
    Post the code you have written and SHOW us (don't just tell us) how you compile it and execute it and the results you get. Then we can help you with any problems you are are having.
    If you need help understanding just what the program should be doing you need to ask your instructor to clarify the assignment.

  • Need Help for Blackberry8700g

    I need help for Blackberry8700g, It is the error message Java.lang.outofmemory Error. I can not make even phone calls. After reset it is same message pop up and does not off the power jum error523 

    You are in line to wipe and reload the OS on the BlackBerry.
    Follow the directions here and you will be fine.
    http://www.blackberryfaq.com/index.php/How_do_I_wipe_the_BlackBerry_using_Jl_Cmder%3F
    1. If any post helps you please click the below the post(s) that helped you.
    2. Please resolve your thread by marking the post "Solution?" which solved it for you!
    3. Install free BlackBerry Protect today for backups of contacts and data.
    4. Guide to Unlocking your BlackBerry & Unlock Codes
    Join our BBM Channels (Beta)
    BlackBerry Support Forums Channel
    PIN: C0001B7B4   Display/Scan Bar Code
    Knowledge Base Updates
    PIN: C0005A9AA   Display/Scan Bar Code

  • Need help for creat apple id in iphone 5s

    need help for creat apple id in iphone 5s

    See this support document for instructions. http://support.apple.com/kb/HT2731

  • Hi , i need help for resetting my airport express as a repeater since this one is already register to old wifi. thanks

    hi everyone. i need help for resettting my airport express as a repeater. i bought is airport express 2nd hand. so now this one already registered to old wireless.
    could anyone have any advice. thank you.
    now the airport express is blinking yellow color.
    my main base is using time capsule. this is a new one so when i first turn it on and set it up in airport utility its very easy.
    now setting the repeater (airport express) is ............ ???
    thanks everyone.

    Do a factory reset, then it'd be like it's new from the Apple Store.
    http://support.apple.com/kb/ht3728

  • I need help for actionscript 3, sending php info to my email, website created in Flash cs5 pro

    Hi,  My name is David and I followed a course creating my own website from Lynda.com by Paul Trani. After that I created my first own webste. After I finished it, everything was working well in flash and firefox. I have only one problem and question concerning the feed back form for sending info from my website to my emailaddres. I created my website “LisbonDreamWalking”in Flash CS5 pro. I herein have a contact page, where people can send an email for a walk in Lisbon, date,the number of people etc. Now I want through my ISP / host funpic.org, that the input, info text fields to be sended to my emailaddress [email protected]. My mail URL adress  iss: http://lisbondreamwalk.li.funpic.org  This is a free host, so they don't work with forms like in the course, and I need some additional info for the php. Here is my HTML (Flash actionscript 3.0) for the sending I only have the red text to fill in (php), I was told by the adobe course.I really hope someone can help me?! Thanks in advance!
    Instructions: 1. Add your custom code on a new line after the line that says "// Start your custom code" below. The code will execute when the symbol instance is clicked. */  send_btn.addEventListener(MouseEvent.CLICK, fl_MouseClickHandler_13);  function fl_MouseClickHandler_13(event:MouseEvent):void {          if (thename.text == "" || theemail.text == "" || thetime.text == "" || thepersons.text == "" || themessage.text == "")      {           thankyou.text = "please fill out all fields";      }      else      {           // create a variable container           var allVars : URLVariables = new URLVariables();           allVars.name = thename.text;           allVars.email = theemail.text;           allVars.time = thetime.text;           allVars.persons = thepersons.text;           allVars.message = themessage.text;           //Send info to a URL           var mailAddress:URLRequest = new URLRequest("http.www.namewebsite.com/gdform.php");           mailAddress.data = allVars;           mailAddress.method = URLRequestMethod.POST;           sendToURL(mailAddress);            thankyou.text = "Thank YOU!";           thename.text = "";           theemail.text = "";           thetime.text = "";           thepersons.text = "";           themessage.text = "";      } }
    H

    Thank you Kglad, I am going to see if I can make it work. I will let you know!
    Date: Thu, 13 Oct 2011 08:55:05 -0600
    From: [email protected]
    To: [email protected]
    Subject: I need help for actionscript 3, sending php info to my email, website created in Flash cs5 pro
        Re: I need help for actionscript 3, sending php info to my email, website created in Flash cs5 pro
        created by kglad in Action Script 3 - View the full discussion
    you missed part of the tutorial (or the tutorial is incomplete):  send_btn.addEventListener(MouseEvent.CLICK, fl_MouseClickHandler_13); function fl_MouseClickHandler_13(event:MouseEvent):void{     if (thename.text == "" || theemail.text == "" || thetime.text == "" || thepersons.text == "" || themessage.text == "") { thankyou.text = "please fill out all fields"; } else { // create a variable container var allVars : URLVariables = new URLVariables(); allVars.name = thename.text; allVars.email = theemail.text; allVars.time = thetime.text; allVars.persons = thepersons.text; allVars.message = themessage.text; //Send info to a URLvar mailAddress:URLRequest = new URLRequest("http.www.namewebsite.com/gdform.php"); mailAddress.data = allVars; mailAddress.method = URLRequestMethod.POST; sendToURL(mailAddress);
    }}  var urlLoader:URLLoader=new URLLoader(); function sendToURL(mailAddress):void{urlLoader.addEventListener(Event.COMPLETE,completeF);urlLoade r.load(mailAddress);} function completeF(e:Event):void{ thankyou.text = "Thank YOU!"; thename.text = ""; theemail.text = ""; thetime.text = ""; thepersons.text = ""; themessage.text = "";}
         Replies to this message go to everyone subscribed to this thread, not directly to the person who posted the message. To post a reply, either reply to this email or visit the message page: http://forums.adobe.com/message/3969414#3969414
         To unsubscribe from this thread, please visit the message page at http://forums.adobe.com/message/3969414#3969414. In the Actions box on the right, click the Stop Email Notifications link.
         Start a new discussion in Action Script 3 by email or at Adobe Forums
      For more information about maintaining your forum email notifications please go to http://forums.adobe.com/message/2936746#2936746.

Maybe you are looking for