Need HELP for MIDP application.

i was having problems in row 45-70 and from row 88-105 which im not so sure weither i write it correctly or not.
i wanted to do an application using MIDP where user can view question and chose the answer using List.
The question can be get from database and the answer chose are needed to be written in text file.
======================================================import javax.microedition.midlet.*;
import javax.microedition.lcdui.*;
public class NotSoSimpleFace extends MIDlet implements CommandListener
  private Display display;
  private Command exit;
  private Command next;
  private Command finish;
  private List list;
  private int QNo=1;
  public NotSoSimpleFace()
    display = Display.getDisplay(this);
  public void startApp()
      Question(QNo);
  public void pauseApp()
  public void destroyApp(boolean unconditional)
     notifyDestroyed();
  public void commandAction(Command command, Displayable Displayable)
    if (command == next)
     boolean choice[] = new boolean[list.size()];
     list.getSelectedFlags(choice);
     for (int x = 0; x < 4; x++)
             if (choice[x])
               System.out.println(list.getString(x));
            //Write to Text File in Append Mode
            //..."//root1/answer.txt;append=true", Connector.WRITE
             OutputConnection connection = (OutputConnection)                    
             Connector.open("file:///root1/answer.txt; append=true" Connector.WRITE );
             OutputStream out = connection.openOutputStream();
             PrintStream output = new PrintStream( out );
             output.println( "Answer 1 is:" + list.append(x));
             output.println( "Answer 2 is:" + list.append(x));
             output.println( "Answer 3 is:" + list.append(x));
             output.println( "Answer 4 is:" + list.append(x));
             out.close();
             connection.close();
               Alert alert = new Alert("Completed", "Data Written", null, null);
             alert.setTimeout(Alert.FOREVER);
             alert.setType(AlertType.ERROR);
             display.setCurrent(alert);
     QNo+=1;
     if (QNo <= 4) {
          Question(QNo);
     } else {
           destroyApp(true);
    else if (command == exit)
      destroyApp(true);
  private void Question(int no)
            String url = "jdbc:odbc:MyODBC";
         Class.forName("sun.jdbc.odbc.JdbcOdbcDriver");
         Connection c = DriverManager.getConnection(url,"","");
         Statement s = c.createStatement();
         ResultSet rs = s.executeQuery ("select Question from Question");
         while (rs.next())
          FileOutputStream fout =  new FileOutputStream("sample.txt");
         PrintStream myOutput = new PrintStream(fout);
    list = new List( myOutput.print(rs.getString(1) + "\t") + no, List.MULTIPLE);
    list.append("A", null);
    list.append("B", null);
    list.append("C", null); 
    list.append("D", null); 
    exit = new Command("Exit", Command.EXIT, 1);
    if (no == 4) {
      next = new Command("Finish", Command.EXIT, 2);
    } else {
      next = new Command("Next", Command.EXIT, 2);
    list.addCommand(exit);
    list.addCommand(next);
    list.setCommandListener(this);  
    display.setCurrent(list);
}

Ok, I haven't really worked much with files in J2ME and I haven't worked with MIDP 2.0 at all, but I'm fairly certain that there is no JDBC available in CLDC. If you're programming for a mobile phone then you can't use SQL. It's only available for CDC
You're on the right track with the Connector; explore that further.
But not every phone has a filesystem; keep that in mind. Some only expose an RMS for data storage to MIDlets.
Message was edited by:
nogoodatcoding

Similar Messages

  • Need help for printer application status

    Hi,
    I am using jdeveloper11.1.1.2.0.Actually standalone java application,I want to know status of the printer,If there is no paper inside printer then message should be display no paper in the printer,
    if i did printout but after 2 second i want to cancel the print then message should be also display ...
    my code is below..
    public void invokePrintJob(ActionEvent actionEvent) {
    // Add event code here...
    PrintService[] printers = PrintServiceLookup.lookupPrintServices(null, null);
    Boolean printerFound = false;
    for (int i = 0; i < printers.length && !printerFound; i++) {
    if (printers.getName().equalsIgnoreCase(getSelectedPrinter())) {
    printerFound = true;
    PrintService printer = printers[i];
    UploadedFile file = getTheFile();
    String fileName = getTheFile().getFilename();
    // String file = getTheFile();
    //PrintJobAdapter pr = new PrintJobAdapter();
    InputStream input;
    try {
    input = new BufferedInputStream((file.getInputStream()));
    Doc doc = new SimpleDoc(input, DocFlavor.INPUT_STREAM.PNG, null);
    PrintRequestAttributeSet attrs = new HashPrintRequestAttributeSet();
    attrs.add(new Copies(2));
    attrs.add(OrientationRequested.LANDSCAPE);
    JobName name = new JobName(fileName ,null);
    attrs.add(name);
    DocPrintJob job = printer.createPrintJob();
    PrintJobWatcher pjDone = new PrintJobWatcher(job);
    job.print(doc, attrs);
    pjDone.waitForDone();
    System.out.println("--------jobRunning-end----------");
    input.close();
    } catch (PrintException e) {
    System.out.println(e.getMessage());
    addFacesErrorMessage(e.getMessage());
    } catch (FileNotFoundException e) {
    System.out.println(e.getMessage());
    addFacesErrorMessage(e.getMessage());
    }catch (IOException ioe) {
    // TODO: Add catch code
    ioe.printStackTrace();
    public static class PrintJobWatcher {
    // true iff it is safe to close the print job's input stream
    boolean done = false;
    PrintJobWatcher(DocPrintJob job) {
    // Add a listener to the print job
    job.addPrintJobListener(new PrintJobAdapter() {
    public void printJobCanceled(PrintJobEvent pje) {
    System.out.println("-------printJobCanceled--------");
    allDone();
    public void printJobCompleted(PrintJobEvent pje) {
    System.out.println("------printJobCompleted---------");
    allDone();
    public void printJobFailed(PrintJobEvent pje) {
    System.out.println("----------printJobFailed-------");
    allDone();
    public void printJobNoMoreEvents(PrintJobEvent pje) {
    System.out.println("--------printJobNoMoreEvents---------");
    allDone();
    @Override
    public void printJobRequiresAttention(PrintJobEvent pje) {
    System.out.println("-----------printJobRequiresAttention----------");
    allDone();
    @Override
    public void printDataTransferCompleted(PrintJobEvent pje) {
    System.out.println("-------printDataTransferCompleted---------");
    allDone();
    void allDone() {
    // System.out.println("---------------");
    synchronized (PrintJobWatcher.this) {
    done = true;
    PrintJobWatcher.this.notify();
    public synchronized void waitForDone() {
    try {
    while (!done) {
    wait(1000);
    } catch (InterruptedException e) {
    e.printStackTrace();
    Please help me..

    Help with what? What's the actual problem?
    As far the code looks horrible. This kind of logic belongs in a fitler rather than a backing bean. You use empty strings instead of nulls. You stores passwords plain and unhashed in DB. You compares the password in Java instead of in DB. You stores password in a cookie. Your query is unsafe for SQL injections. You're reloading the driver class everytime when you acquire the connection. You're leaking DB connections. The application will crash sooner or later when the DB run out of connections.
    Is that all what you need to know?

  • Hello i need help for adobe creative cloud...when i launch application adobe  cc 2014  for photoshop or illustrator.....the apps launch and i can see the workspace and menu bar  for a while and  suddenly this application close automatic

    hello i need help for adobe creative cloud...when i launch application adobe  cc 2014  for photoshop or illustrator.....the apps launch and i can see the workspace and menu bar  for a while and  suddenly this application close automatic

    Sign in, activation, or connection errors | CS5.5 and later
    Mylenium

  • I have flash professional cc and I need air for desktop application with .exe or .air that should contain all swf's and captive air runtime in one Installer only . I don't want to install separate adobe air runtime .

    I need Air for desktop application either in .exe or in .air with embedded captive runtime just like .apk . I don't want to install adobe air separate . everything should come in installer
    I have adobe flash professional cc development tool , let me know whether I have to go with other development tool???
    your reply will  increase my confidential level
    please anyone can help me to solve this problem
    Thanks&regards
    Niranjan

    Adobe Flash Professional CC manual
    1) Create new project
    2) Configure your Project properties
    3) Embed runtime, so you users can use Adobe AIR without pre-installed Adobe AIR runtime
    4) After publishing you will receive %APP_NAME%.app folder that contain your project files

  • Need help for Format HD

    Hi I need Help for Formating HD so Wat Key need hold on start up for format HD I apprciated you Help

    Jesus:
    Formatting, Partitioning Erasing a Hard Disk Drive
    Warning! This procedure will destroy all data on your Hard Disk Drive. Be sure you have an up-to-date, tested backup of at least your Users folder and any third party applications you do not want to re-install before attempting this procedure.
    • With computer shut down insert install disk in optical drive.
    • Hit Power button and immediately after chime hold down the "C" key.
    • Select language
    • Go to the Utilities menu (Tiger) Installer menu (Panther & earlier) and launch Disk Utility.
    • Select your HDD (manufacturer ID) in left side bar.
    • Select Partition tab in main panel. (You are about to create a single partition volume.)
    • _Where available_ +Click on Options button+
    +• Select Apple Partition Map (PPC Macs) or GUID Partition Table (Intel Macs)+
    +• Click OK+
    • Select number of partitions in pull-down menu above Volume diagram.
    (Note 1: One partition is normally preferable for an internal HDD.)
    • Type in name in Name field (usually Macintosh HD)
    • Select Volume Format as Mac OS Extended (Journaled)
    • Click Partition button at bottom of panel.
    • Select Erase tab
    • Select the sub-volume (indented) under Manufacturer ID (usually Macintosh HD).
    • Check to be sure your Volume Name and Volume Format are correct.
    • Click Erase button
    • Quit Disk Utility.
    cornelius

  • I have problem with buying in games , I got the massage that the purchased can not be completed , please contact iTunes support.. I need help for my case please

    I have problem with buying in games , I got the massage that the purchased can not be completed , please contact iTunes support.. I need help for my case please

    http://www.apple.com/support/itunes/contact/

  • Need help for my requirement...

    Need help for my requirement...
    Hello Experts,
    I have report where users can input the company, housebank, account ID and posting date.
    Now in one column of my report named 'Cash in Bank', I need to get all postings from cash
    accounts with GL code ending in '0'. Now, I know that I can get the amounts in BSIS/BSAS
    but how do I link it with the proper bank and account?
    For example:
                       Cash in Bank
    Bank A
      Account ID 1     1,000,000
      Account ID 2     25,000,000
    Hope you can help me guys. Thank you and take care!

    hi Viraylab,
    each house bank you can find in table T012, in T012K you'll find the bank accounts to the housebank, the G/L account will be in T012K-HKONT.
    hope this helps
    ec

  • Need help for flash builder

    i need help for flash builder 4 and papervison 3d. I need to create a slider with it ranges of value from 10 to 50 to adjust the camera values for the camera.fov and also need to create it for the yaw of the object from 0 to 360. I try to look for any slider event and classes in this program but cant find any, btw, i need to use the AS only project file.
    here is my codes:
    can you please tell me how i should modify the codes?
    package
        import flash.display.BitmapData;
        import flash.display.Sprite;
        import flash.events.Event;
        import org.papervision3d.materials.BitmapFileMaterial;
        import org.papervision3d.materials.BitmapMaterial;
        import org.papervision3d.objects.primitives.Sphere;
        import org.papervision3d.view.BasicView;
        [SWF (width="800", height="600", backgroundColor="0x000000",frameRate="30")]
        public class EarthBitmap extends BasicView
            private var sphere:Sphere;
            public function EarthBitmap()
                super(800 , 600);
                var earthmaterial:BitmapFileMaterial = new BitmapFileMaterial("../assets/Earth.jpg");
                sphere = new Sphere(earthmaterial,100,20,18);
                camera.fov = 25;
                scene.addChild(sphere);
                addEventListener(Event.ENTER_FRAME,rotateSphere);
            public function rotateSphere(evt:Event):void
                sphere.yaw(0.2);
                singleRender();

    Turn the click handler into a full on separate function. Then store all the views in an array and use Math.rand() to randomly choose one.
    Something like this:
    <fx:Script>
         <![CDATA[
              var questionsArray:Array = {question2,question3,question5,questionRed,questionGeography};
              function buttonClickHandler(event:MouseEvent){
                   var randomProblem:int = Math.floor(Math.random()*(questionsArray.length));     //generates a random integer between 0 and the total number of questions in the array (arrays are 0-based)
                   navigator.pushView(questionsArray[randomProblem]);
         ]]>
    </fx:Script>
    <s:Button id="randomProblemButton" label="Next Problem" click="buttonClickHandler(event)" />
    Haven't tested that, but something along that line should work

  • Need help for importing oracle 10G dump into 9i database

    hi, Someone help me to import oracle 10G dump into 9i database. I'm studying oracle . Im using oracle 10G developer suite(downloaded from oracle) and oracle 9i database. I saw some threads tat we can't import the higher version dumps into lower version database. But i'm badly need help for importing the dump...
    or
    someone please tell me the site to download oracle 9i Developer suite as i can't find it in oracle site...

    I didnt testet it to import a dump out of a 10g instance into a 9i instance if this export has been done using a 10g environment.
    But it is possible to perform an export with a 9i environment against a 10g instance.
    I am just testing this with a 9.2.0.8 environment against a 10.2.0.4.0 instance and is working so far.
    The system raises an EXP-00008 / ORA-37002 error after exporting the data segments (exporting post-schema procedural objects and actions).
    I am not sure if it is possible to perform an import to a 9i instance with this dump but maybe worth to give it a try.
    It should potentially be possible to export at least 9i compatible objects/segments with this approach.
    However, I have my doubts if this stunt is supported by oracle ...
    Message was edited by:
    user434854

  • Need Help for Nokia 6500 slide

    Hi all I'm A new Guy here ,
    But I do really need help for hard reset my phone
    I already try *#7073# But It doesn't work ,
    If Anybody know to make a hard reset please help

    rwss wrote:
    I'v got te same problem with my 6500 Slide, is there a button combination that we have to press
    to hard reset the 6500 Slide?!
    How does the 6500 slide hard reset?
    That's simple.
    All you have to do is:
    From MENU goto SETTINGS, When there scroll down and select 'Restore Factory Setting'.
    There are two options in there:
    "Restore Settings only"
    and
    "Restore all"
    Select "Restore All"
    When done the phone will delete every thing on the Phone memory(C:\)(contacts,picture,messages etc)
    and also restore phone to its original settings and will restart.
    This proceedure is mostly common on S40 phone.
    Hope this explain and solve the problem.

  • Need help for publishing web intelligence document (universe) into InfoView

    Post Author: mirage
    CA Forum: Publishing
    Hello all,
    I need help for publishing web intelligence document (universe) into InfoView.
    can't find this information in Business Objects Designer's Guide and in Business Objects Administrator Guide.
    Can somebody give short instructions how can I do it?
    Regards, Slava

    If the change between the 2 types of data has to happen dynamically during run time them
    1. Use 2 dataproviders
         a. Current
         b. Historic
    2. Merge the 2 dimensions
    3. Use Webi variable to switch between the measure of the current and historic universe
    Ex  if [year] < 2010 then historic.[expense] else current.[expense]
    Hope this helps,
    Divya

  • Need help for access list problem

    Cisco 2901 ISR
    I need help for my configuration.... although it is working fine but it is not secured cause everybody can access the internet
    I want to deny this IP range and permit only TMG server to have internet connection. My DHCP server is the 4500 switch.
    Anybody can help?
             DENY       10.25.0.1 – 10.25.0.255
                              10.25.1.1 – 10.25.1.255
    Permit only 1 host for Internet
                    10.25.7.136  255.255.255.192 ------ TMG Server
    Using access-list.
    ( Current configuration  )
    object-group network IP
    description Block_IP
    range 10.25.0.2 10.25.0.255
    range 10.25.1.2 10.25.1.255
    interface GigabitEthernet0/0
    ip address 192.168.2.3 255.255.255.0
    ip nat inside
    ip virtual-reassembly in max-fragments 64 max-reassemblies 256
    duplex auto
    speed auto
    interface GigabitEthernet0/1
    description ### ADSL WAN Interface ###
    no ip address
    pppoe enable group global
    pppoe-client dial-pool-number 1
    interface ATM0/0/0
    no ip address
    no atm ilmi-keepalive
    interface Dialer1
    description ### ADSL WAN Dialer ###
    ip address negotiated
    ip mtu 1492
    ip nat outside
    no ip virtual-reassembly in
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication pap callin
    ppp pap sent-username xxxxxxx password 7 xxxxxxxxx
    ip nat inside source list 101 interface Dialer1 overload
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip route 10.25.0.0 255.255.0.0 192.168.2.1
    access-list 101 permit ip 10.25.0.0 0.0.255.255 any
    access-list 105 deny   ip object-group IP any
    From the 4500 Catalyst switch
    ( Current Configuration )
    interface GigabitEthernet0/48
    no switchport
    ip address 192.168.2.1 255.255.255.0 interface GigabitEthernet2/42
    ip route 0.0.0.0 0.0.0.0 192.168.2.3

    Hello,
    Host will can't get internet connection
    I remove this configuration......         access-list 101 permit ip 10.25.0.0 0.0.255.255 any
    and change the configuration ....      ip access-list extended 101
                                                                5 permit ip host 10.25.7.136 any
    In this case I will allow only host 10.25.7.136 but it isn't work.
    No internet connection from the TMG Server.

  • Need help for cenvat reversal

    Hi Friends,
    Need help for cenvat reversal.
    Reversed MIRO by MR8M & MIGO by 102 movement but not able to post & cancel cenvat by J1IEX.
    In table J_1IEXCHDR status = "P" and J1I5 does not update for document of 102 movement because reversal document of MIGO, i.e. material document with 102 movement type does not have excise tab. MBSM-Cancelled Material Documents, does not show any of the material documents.
    Want to reverse the cenvat credit, please help.
    --Anil Bhamere

    Hi,
    If I select Cancellation in MIGO then there is only Material Document option.
    In MIGO Purchase Order option shows for Goods Receipt, Goods Issue and Subsequet Adj.
    In this case I have been selected Goods Receipt option followed by purchase order number by which original goods receipt MIGO was created, selected 102 movement type and from line item respective MIGO document. The reversal document created successfully where as original MIGO document does not show in cancelled document list. When post option selected from J1IEX and entered vendor excise number then message appeared as No Part I exists for availing credit in excise invoice xxxxx.
    If Cancel option selected from J1IEX and entered vendor excise number then message appeared as Excise invoice xxxx has already been posted for vendor xxxxx.
    Please help.
    Regards,
    Anil Bhamere

  • Need help for finding objects impacted by size change for an infoobject

    hi all,
    need help for finding objects impacted by size change
    for xxx infoobject, due to some requirements, the size to be changed from
    char(4) to char(10), in the source database tables as well as adjustment
    to be done in BI side.
    this infoobject xxx is nav attribute of YYY as well as for WWW
    infoobjects. and xxx is loaded from infopkg for www infoobject load.
    now that i have to prepare an impact analysis doc for BI side.
    pls help me with what all could be impacted and what to be done as a
    solution to implement the size change.
    FYI:
    where used list for xxx infoobject - relveals these object types :
    infocubes,
    infosources,
    tranfer rules,
    DSO.
    attribute of characteristic,
    nav attribute,
    ref infoobject,
    in queries,
    in variables

    Hi Swetha,
    You will have to manually make the table adjustments in all the systems using SE14 trans since the changes done using SE14 cannot be collected in any TR.
    How to adjust tables :
    Enter the table name in SE14. For ex for any Z master data(Say ZABCD), master data table name would be /BIC/PZABCD, text table would be /BIC/TZABCD. Similarly any DSO(say ZXYZ) table name would be /BIC/AZXYZ00 etc.
    Just enter the table name in SE14 trans --> Edit --> Select the radio button "Save Data" --> Click on Activate & adjust database table.
    NOTE : Be very careful in using SE14 trans since there is possibility that the backend table could be deleted.
    How to collect the changes in TR:
    You can collect only the changes made to the IO --> When you activate, it will ask you for the TR --> Enter the correct package name & create a new TR. If it doesn't prompt you for TR, just goto Extras --> Write transport request from the IO properties Menu screen. Once these IO changes are moved successfully, then the above proceduce can be followed using SE14 trans.
    Hope it helps!
    Regards,
    Pavan

  • Need help for writing extract program

    hi
    i need help for writing extract program to retriew data from legacy system.
    i already developed bdc programs for me31k and me21.
    my requirement is to write extract program s for those t.codes.
    to retriew data from legacy system and stored in flat file.

    i need help with a java program. it is a program that allows the user to enter a student's GPA, number of extracurricular activities, and number of service activities. The user can not enter a gpa above 4.0 or below 0. The user can not enter a negative number for the number of both activities. If the student meets the following criteria: 1) GPA of 3.8 or above and at least one extracurricular activity and one service activity, 2) GPA below 3.8 but at least 3.4 and a total of at least three extracurricular and service activities, 3) GPA below 3.4 but at least 3.0 and at least two extracurricular activities and three service activities, the message "Scholarship candidate" should display. If the student does not meet the criteria above, then the message"not a candidate" should display. Can you help me, please?
    You haven't posted ANY 'java program' for us to help with.
    The forum is NOT a coding service. It is to help you with YOUR code.
    Post the code you have written and SHOW us (don't just tell us) how you compile it and execute it and the results you get. Then we can help you with any problems you are are having.
    If you need help understanding just what the program should be doing you need to ask your instructor to clarify the assignment.

Maybe you are looking for

  • CRIO-9104 running .vi across subnets

    I have a .vi that I am running from my computer with Labview version 8.2 and a cRIO-9104 that runs another .vi connected across an ethernet switch.  My problem is this: when I am connected to the same switch and am assigned the same IP scheme as my c

  • Reg: Workitem forwarding issue in SC workflow

    Hi,      I have a problem in Shopping cart workflow. When I try to forward the work item, the system is allowing me to forward it to only one person.      I have two options. Please help me to achieve any of the two options. Option1 : To forward it t

  • Create pdf from web page - auto scaled page length

    I'd like to capture LONG web pages to pdf without acrobat breaking the content into several letter size pages.  I used to be able to do this in acrobat 8 and the page length would automatically scale to fit the contents.  This was accomplished by lea

  • Can I retrieve photos that disappeared during sync?

    My recent photos were lost during a sync. When I attempted to sync a message popped up telling me I needed to either 1) add my iphone as a new device or 2) revert to most recent sync from a couple months back. The reason given had something to do wit

  • Displaying unicode text

    I have to display unicode text present in Indian language on Jlabl or Jbutton. Thanks