Need help for type Comparable

Hey guys this is my first post thanks for helping!
Ok these are the codes that I wrote to store Int into the array
then compare each input with the element of the array and put them in accending order. NOW, I want the very same code to Compare type Integer, Double, and String. But I'm stuck, I'm having trouble changing to type Comparable and the using the compareTo method provide by Java. Here is the privimative type
import java.io.*;
import java.util.*;
public class SortedVectorDriver {
     public static void main(String[] args) throws Exception {
     SortedVectors a = new SortedVectors (5);
     a.getInput();
import java.io.*;
import java.util.*;
public class SortedVectors{
     private int [] Num;//=new int [size] ;;
     private int size,smallest,largest,choice,Number,tempSpot,top;
     final static int increment = 4;
     final static int orSize = 5;     
     private String s;
     private boolean goodData;     
     public SortedVectors (int size) {
          this.size = size;
          Num=new int [this.size] ;
          this.top=0;
          //this.increment = 4;     
     public int getChoice () {
          return choice;          
     public int getNumber () {
          return Number;
     private void callOneTwo () {
          if ( choice == 1 )
               insert (getNumber());     
          else if ( choice == 2)
               delete (getNumber());
     private void callOther () {
          if ( choice == 3)
               smallest ();     
          else if ( choice == 4)
               largest();
          else if ( choice == 5)
               clear ();
     private void readChoice () throws IOException {
          int temp=0;
          goodData = false;
          BufferedReader br = new BufferedReader (new InputStreamReader (System.in));
          System.out.print ("Checking Choice : ");     
          s = br.readLine ();
          while ( (!goodData) ) {
               goodData = true;     
               try {     
                    this.choice = Integer.parseInt(s);
               catch (NumberFormatException e) {
                    goodData = false;
                    System.out.print ("PLEASE RE-ENTER CHOICE : ");
                    s = br.readLine();
                    //choice = Integer.parseInt(s);
          System.out.println("Return goodData");
          ///return temp;
     private void readNumber () throws IOException {
          goodData = false;
          BufferedReader br = new BufferedReader (new InputStreamReader (System.in));
          System.out.print ("Checking Number : ");     
          s = br.readLine ();
          while ( (!goodData) ) {
               goodData = true;     
               try {     
                    this.Number = Integer.parseInt(s);
               catch (NumberFormatException a) {
                    goodData = false;
                    System.out.print ("PLEASE RE-ENTER NUMBER : ");
                    s = br.readLine();
          System.out.println("Return goodData");
          //return temps;
     public void getInput() throws IOException{
          this.showMenu();
          System.out.print ("PLEASE ENTER CHOICEa : ");
     //     BufferedReader br = new BufferedReader (new InputStreamReader (System.in));
          readChoice();
               while (choice != 6 ){
                    if (choice==3 ||choice==4 ||choice==5) {
               ///          if (this.choice == 6)
                    //          return;
                         this.callOther();     
                         this.showMenu();
                         this.goodData = false;     
                         System.out.print ("PLEASE ENTER CHOICEc : ");
                         readChoice();
                    else if (choice==1 ||choice==2 ) {
                         System.out.print ("Please enter the NUMBER you want to process: ");
                         readNumber();
                         this.callOneTwo();
                         this.print();
                         this.showMenu();
                         this.goodData = false;
                         System.out.print ("PLEASE ENTER CHOICEd : ");
                         readChoice();
          System.out.println ("Bye! Have a nice day");
     public void insert (int Number) {
//     public void insert ( ) {     
          if (top == 0) {
               this.Num[0] = Number;
               top++;     
               return;
          if (Num[0] >= Number && Num[1]==0) {
               int temp = Num[0];
               Num[0] = Number;
               Num[1] = temp;
               top++;
               return;
          if (Num[0] < Number && Num[1]==0){
               Num[1]=Number;
               top++;
               return;
          if (top >=2) {     
               tempSpot = this.apPos(Number);
               System.out.println("Inside top >= 2");
               if (top >= this.Num.length)
                    this.Num = this.copyArray ( this.Num, increment);
               for (int ii=top; ii > tempSpot; ii--)
                    this.Num[ii] = this.Num[ii-1];
               this.Num[tempSpot] = Number;
               top +=1;
               return ;
          else
               System.out.println("Out of insert method error");
               return ;
     private int apPos (int Number) {//find correct box for new number
          int spot = 0;
          if (this.top >= this.Num.length)
               this.Num = this.copyArray ( this.Num, increment);
          for (int i=0; i<Num.length; i++){
               if (this.top == 0 )
                    return (spot =0 );
               else if ( Number <= Num[0])               
                    return spot =0;
               else if ( Num[i] <= Number && Num[i+1] >= Number )          
                    return spot = i+1;
               else if ( Num[i] <= Number && Num[i+1] == 0)
                    return (spot = this.top);               
               else if ( Num[i] > Number && Num[i+1] == 0)                         
                    return spot = i;
          return spot;
     private void print() {
          System.out.println ("&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&");
          System.out.println("Inside of print");
          for (int i=0; i<(this.Num.length);i++)
               System.out.println ("Element "+i+ "= " + this.Num );
          System.out.println ("&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&");
     public void clear () {
          int tempNum [] = new int [orSize];
          //for (int i=0; i<Num.length;i++)
          //     Num[i]=0;
          Num = tempNum ;
          this.top =0;
          print();
     public int smallest ( ) {
          System.out.println ("@@@@@@@@@@@@@@@@@@@@@@@");
          int smallest=this.Num[0];//assume the first element in the array is the smallest
          if (this.Num[1] ==0)
               return smallest;
          System.out.println ("Inside of smallest");
          for (int i=1; i<this.top/*(this.Num).length*/; i++){
               if (this.Num[i] < smallest)
               smallest = this.Num[i];
               else if (this.Num[i] > smallest)
               smallest = smallest;
          this.smallest = smallest;
          System.out.println ("SMALLEST = "+this.smallest);
          System.out.println ("@@@@@@@@@@@@@@@@@@@@@@@");
          return ( smallest);
     public int largest ( ) {
          System.out.println ("~~~~~~~~~~~~~~~~~~~~~~~~~~");          
          System.out.println ("Inside of largest");     
          int largest=Num[0];//assume the first element in the array is the largest          
          if (this.Num[1] ==0)
               return largest;     
          for (int i=1; i<this.top; i++){
               if (Num[i] > largest)
               largest = Num[i];
               else if (Num[i] < largest)
               largest = largest;     
          this.largest= largest;
          System.out.println ("LARGEST = "+this.largest);     
          System.out.println ("~~~~~~~~~~~~~~~~~~~~~~~~~~");
          return largest;
     public boolean full (){
          if (this.top >= this.Num[this.Num.length-1]){
               if (this.top == this.Num[this.Num.length-1]){
                    System.out.println("Array is full");                    
                    return true;
               else
               System.out.println("Array is not full");
               return false;
          else
               System.out.println("Array is NOT full");
          return false;
     public boolean empty (){
          System.out.println("Top is = "+this.top);
          if ((this.Num[0]!=0)&&(this.Num[this.Num.length-1] ==0)){
               System.out.println ("The array is not full");
               return true;
          else if ((this.Num[0]!=0)&&(this.Num[this.Num.length-1] !=0)){
               System.out.println ("The array is full");
               return false;
          else if ((this.Num[0]==0)&&(this.Num[this.Num.length-1] ==0)){
               System.out.println ("The array is empty");
               return true;
          else if ((top == (this.Num.length - 1))&&(this.Num[0]!=0)){
               System.out.println ("The array is full");
               return false;
          else return false;
     public int find (int NumberTobeSearch) {
          int left = 0;
          int right = this.size-1;
          while (left != right-1) {
               int middle = (right + left)/2;
               if (this.Num[middle] > NumberTobeSearch){
                    left = left;
                    right = middle;
                    if (this.Num[left] == NumberTobeSearch)
                         return left = this.findCopy(Num,NumberTobeSearch,left);
                    else if ((this.Num[left] != NumberTobeSearch) && (right - left) == 1 )
                         return -1;
               else if (this.Num[middle] < NumberTobeSearch){     
                    left = middle;
                    right = right;
                    if (this.Num[right] == NumberTobeSearch)
                         return right = this.findCopy(Num,NumberTobeSearch,right);
                    else if (((right - left)== 1) && (this.Num[left] !=NumberTobeSearch )){
                         System.out.println("No Number found");
                         return -1;     
               else /*if (this.Num[middle] == NumberTobeSearch)*/{
                    System.out.println("Inside third if");     
                    left = middle;
                    right = middle+1;
                    return left = this.findCopy(Num,NumberTobeSearch,left);
          System.out.println ("THE LAST INDEX IS BEFORE EXIT " + left);
          return left;     
     public void delete (int NumberTobeDelete) {
          int tempIndex = this.find (NumberTobeDelete);     
          if ( tempIndex == -1){
               System.out.println("NO NUMBER FOUND, TRY DELETING ANOTHER");
               return;
          else if (this.top >= this.Num.length){
               System.out.println("I'm allocating more space for U");
               this.Num = this.copyArray ( this.Num, increment);
          int i = 0;
          for (i=tempIndex; i<this.top; i++)
                    this.Num[i] = this.Num[i+1];               
               top--;//keeping track of top          
     private int findCopy (int [] Num, int Number, int tempIndex){
          for (int i=0; i<tempIndex;i++){
               if (Num[i] == Number)
                    return i;
          return tempIndex;     
     private int [] copyArray (int [] Num, int howMany){
     System.out.println("----------------------------");
     System.out.println("Inside CopyArray");
     int Bigger [] = new int [Num.length+howMany];
     for (int i=0; i<Num.length; i++)
          Bigger[i] = Num[i];
     Num = Bigger;
     System.out.println("----------------------------");
          return Num;     
     private void showMenu () {
          System.out.println ("********************************");     
          System.out.println ("Please choose the following operation ");
          System.out.println ("Enter 1 for INSERT");
          System.out.println ("Enter 2 for DELETE");
          System.out.println ("Enter 3 for the SMALLEST ");
          System.out.println ("Enter 4 for the LARGEST");
          System.out.println ("Enter 5 to CLEAR ");
          System.out.println ("Enter 6 to EXIT ");     
          System.out.println ("*******************************");          
///end of program thank for helping guys

To sort a List (which includes Vector) of mutually Comparable objects, you can use Collections.sort(List). If that's not what you're trying to do, please post the relevant sections of the code (i.e. not the IO etc) using &#91;code] tags and explain the problem - compiler errors, runtime errors, conceptual problems.

Similar Messages

  • Need help for Format HD

    Hi I need Help for Formating HD so Wat Key need hold on start up for format HD I apprciated you Help

    Jesus:
    Formatting, Partitioning Erasing a Hard Disk Drive
    Warning! This procedure will destroy all data on your Hard Disk Drive. Be sure you have an up-to-date, tested backup of at least your Users folder and any third party applications you do not want to re-install before attempting this procedure.
    • With computer shut down insert install disk in optical drive.
    • Hit Power button and immediately after chime hold down the "C" key.
    • Select language
    • Go to the Utilities menu (Tiger) Installer menu (Panther & earlier) and launch Disk Utility.
    • Select your HDD (manufacturer ID) in left side bar.
    • Select Partition tab in main panel. (You are about to create a single partition volume.)
    • _Where available_ +Click on Options button+
    +• Select Apple Partition Map (PPC Macs) or GUID Partition Table (Intel Macs)+
    +• Click OK+
    • Select number of partitions in pull-down menu above Volume diagram.
    (Note 1: One partition is normally preferable for an internal HDD.)
    • Type in name in Name field (usually Macintosh HD)
    • Select Volume Format as Mac OS Extended (Journaled)
    • Click Partition button at bottom of panel.
    • Select Erase tab
    • Select the sub-volume (indented) under Manufacturer ID (usually Macintosh HD).
    • Check to be sure your Volume Name and Volume Format are correct.
    • Click Erase button
    • Quit Disk Utility.
    cornelius

  • Need help for publishing web intelligence document (universe) into InfoView

    Post Author: mirage
    CA Forum: Publishing
    Hello all,
    I need help for publishing web intelligence document (universe) into InfoView.
    can't find this information in Business Objects Designer's Guide and in Business Objects Administrator Guide.
    Can somebody give short instructions how can I do it?
    Regards, Slava

    If the change between the 2 types of data has to happen dynamically during run time them
    1. Use 2 dataproviders
         a. Current
         b. Historic
    2. Merge the 2 dimensions
    3. Use Webi variable to switch between the measure of the current and historic universe
    Ex  if [year] < 2010 then historic.[expense] else current.[expense]
    Hope this helps,
    Divya

  • Need help for cenvat reversal

    Hi Friends,
    Need help for cenvat reversal.
    Reversed MIRO by MR8M & MIGO by 102 movement but not able to post & cancel cenvat by J1IEX.
    In table J_1IEXCHDR status = "P" and J1I5 does not update for document of 102 movement because reversal document of MIGO, i.e. material document with 102 movement type does not have excise tab. MBSM-Cancelled Material Documents, does not show any of the material documents.
    Want to reverse the cenvat credit, please help.
    --Anil Bhamere

    Hi,
    If I select Cancellation in MIGO then there is only Material Document option.
    In MIGO Purchase Order option shows for Goods Receipt, Goods Issue and Subsequet Adj.
    In this case I have been selected Goods Receipt option followed by purchase order number by which original goods receipt MIGO was created, selected 102 movement type and from line item respective MIGO document. The reversal document created successfully where as original MIGO document does not show in cancelled document list. When post option selected from J1IEX and entered vendor excise number then message appeared as No Part I exists for availing credit in excise invoice xxxxx.
    If Cancel option selected from J1IEX and entered vendor excise number then message appeared as Excise invoice xxxx has already been posted for vendor xxxxx.
    Please help.
    Regards,
    Anil Bhamere

  • Need help for finding objects impacted by size change for an infoobject

    hi all,
    need help for finding objects impacted by size change
    for xxx infoobject, due to some requirements, the size to be changed from
    char(4) to char(10), in the source database tables as well as adjustment
    to be done in BI side.
    this infoobject xxx is nav attribute of YYY as well as for WWW
    infoobjects. and xxx is loaded from infopkg for www infoobject load.
    now that i have to prepare an impact analysis doc for BI side.
    pls help me with what all could be impacted and what to be done as a
    solution to implement the size change.
    FYI:
    where used list for xxx infoobject - relveals these object types :
    infocubes,
    infosources,
    tranfer rules,
    DSO.
    attribute of characteristic,
    nav attribute,
    ref infoobject,
    in queries,
    in variables

    Hi Swetha,
    You will have to manually make the table adjustments in all the systems using SE14 trans since the changes done using SE14 cannot be collected in any TR.
    How to adjust tables :
    Enter the table name in SE14. For ex for any Z master data(Say ZABCD), master data table name would be /BIC/PZABCD, text table would be /BIC/TZABCD. Similarly any DSO(say ZXYZ) table name would be /BIC/AZXYZ00 etc.
    Just enter the table name in SE14 trans --> Edit --> Select the radio button "Save Data" --> Click on Activate & adjust database table.
    NOTE : Be very careful in using SE14 trans since there is possibility that the backend table could be deleted.
    How to collect the changes in TR:
    You can collect only the changes made to the IO --> When you activate, it will ask you for the TR --> Enter the correct package name & create a new TR. If it doesn't prompt you for TR, just goto Extras --> Write transport request from the IO properties Menu screen. Once these IO changes are moved successfully, then the above proceduce can be followed using SE14 trans.
    Hope it helps!
    Regards,
    Pavan

  • Need help for interface to process employee expenses

    need help for interface to process employee expenses
    i have used the interface tables as
    AP_INVOICES_INTERFACE
    AP_INVOICE_LINES_INTERFACE
    are they the right one
    is there a concurrent program or any API for doing interface

    hi,
    i think what ever table are using for interfacing expenses correct.
    but you have to enter invoice type as expense report.
    Regards,
    Srikanth

  • Urgently  need help for parsing IP header

    Hi, could anyone tell which class I should use to parsing the IP header of a packet?
    Thanks many many times!

    > Hi, could anyone tell which class I should use to
    parsing the IP header of a packet?
    DatagramPacket?
    > Urgently need help for parsing IP header
    Don't flag your question as urgent, even if it is for you.
    * We all answer questions here voluntarily, in our leisure time. We do that because doing so is fun for us, because we enjoy helping people and having interesting discussions. Guess what, it is much less fun if it gets stressful. So the last thing you want to do to get us to answer your question is to pass your stress over to us.
    * People who are stressed and want a fast answer often don't even find the time to do the necessary research or to formulate their question in an easy to comprehend way. That's even less fun to work with. So you really don't want us to feel your stress. Instead you want to take your time to write a well formulated post that is fun to answer. The less likely it is for us to know that your question is urgent, the more likely you are to get a fast answer!
    * The simple notion that you want your post to be answered faster than those of the other members might feel rather unfair to some of us. Doubly so because often "urgent" questions actually are homework questions. Yours might be different, but someone who had bad experiences with this type of question might not read far enough to notice.

  • I have problem with buying in games , I got the massage that the purchased can not be completed , please contact iTunes support.. I need help for my case please

    I have problem with buying in games , I got the massage that the purchased can not be completed , please contact iTunes support.. I need help for my case please

    http://www.apple.com/support/itunes/contact/

  • Need help for my requirement...

    Need help for my requirement...
    Hello Experts,
    I have report where users can input the company, housebank, account ID and posting date.
    Now in one column of my report named 'Cash in Bank', I need to get all postings from cash
    accounts with GL code ending in '0'. Now, I know that I can get the amounts in BSIS/BSAS
    but how do I link it with the proper bank and account?
    For example:
                       Cash in Bank
    Bank A
      Account ID 1     1,000,000
      Account ID 2     25,000,000
    Hope you can help me guys. Thank you and take care!

    hi Viraylab,
    each house bank you can find in table T012, in T012K you'll find the bank accounts to the housebank, the G/L account will be in T012K-HKONT.
    hope this helps
    ec

  • Need help for flash builder

    i need help for flash builder 4 and papervison 3d. I need to create a slider with it ranges of value from 10 to 50 to adjust the camera values for the camera.fov and also need to create it for the yaw of the object from 0 to 360. I try to look for any slider event and classes in this program but cant find any, btw, i need to use the AS only project file.
    here is my codes:
    can you please tell me how i should modify the codes?
    package
        import flash.display.BitmapData;
        import flash.display.Sprite;
        import flash.events.Event;
        import org.papervision3d.materials.BitmapFileMaterial;
        import org.papervision3d.materials.BitmapMaterial;
        import org.papervision3d.objects.primitives.Sphere;
        import org.papervision3d.view.BasicView;
        [SWF (width="800", height="600", backgroundColor="0x000000",frameRate="30")]
        public class EarthBitmap extends BasicView
            private var sphere:Sphere;
            public function EarthBitmap()
                super(800 , 600);
                var earthmaterial:BitmapFileMaterial = new BitmapFileMaterial("../assets/Earth.jpg");
                sphere = new Sphere(earthmaterial,100,20,18);
                camera.fov = 25;
                scene.addChild(sphere);
                addEventListener(Event.ENTER_FRAME,rotateSphere);
            public function rotateSphere(evt:Event):void
                sphere.yaw(0.2);
                singleRender();

    Turn the click handler into a full on separate function. Then store all the views in an array and use Math.rand() to randomly choose one.
    Something like this:
    <fx:Script>
         <![CDATA[
              var questionsArray:Array = {question2,question3,question5,questionRed,questionGeography};
              function buttonClickHandler(event:MouseEvent){
                   var randomProblem:int = Math.floor(Math.random()*(questionsArray.length));     //generates a random integer between 0 and the total number of questions in the array (arrays are 0-based)
                   navigator.pushView(questionsArray[randomProblem]);
         ]]>
    </fx:Script>
    <s:Button id="randomProblemButton" label="Next Problem" click="buttonClickHandler(event)" />
    Haven't tested that, but something along that line should work

  • Need help for importing oracle 10G dump into 9i database

    hi, Someone help me to import oracle 10G dump into 9i database. I'm studying oracle . Im using oracle 10G developer suite(downloaded from oracle) and oracle 9i database. I saw some threads tat we can't import the higher version dumps into lower version database. But i'm badly need help for importing the dump...
    or
    someone please tell me the site to download oracle 9i Developer suite as i can't find it in oracle site...

    I didnt testet it to import a dump out of a 10g instance into a 9i instance if this export has been done using a 10g environment.
    But it is possible to perform an export with a 9i environment against a 10g instance.
    I am just testing this with a 9.2.0.8 environment against a 10.2.0.4.0 instance and is working so far.
    The system raises an EXP-00008 / ORA-37002 error after exporting the data segments (exporting post-schema procedural objects and actions).
    I am not sure if it is possible to perform an import to a 9i instance with this dump but maybe worth to give it a try.
    It should potentially be possible to export at least 9i compatible objects/segments with this approach.
    However, I have my doubts if this stunt is supported by oracle ...
    Message was edited by:
    user434854

  • Need Help for Nokia 6500 slide

    Hi all I'm A new Guy here ,
    But I do really need help for hard reset my phone
    I already try *#7073# But It doesn't work ,
    If Anybody know to make a hard reset please help

    rwss wrote:
    I'v got te same problem with my 6500 Slide, is there a button combination that we have to press
    to hard reset the 6500 Slide?!
    How does the 6500 slide hard reset?
    That's simple.
    All you have to do is:
    From MENU goto SETTINGS, When there scroll down and select 'Restore Factory Setting'.
    There are two options in there:
    "Restore Settings only"
    and
    "Restore all"
    Select "Restore All"
    When done the phone will delete every thing on the Phone memory(C:\)(contacts,picture,messages etc)
    and also restore phone to its original settings and will restart.
    This proceedure is mostly common on S40 phone.
    Hope this explain and solve the problem.

  • Need help for access list problem

    Cisco 2901 ISR
    I need help for my configuration.... although it is working fine but it is not secured cause everybody can access the internet
    I want to deny this IP range and permit only TMG server to have internet connection. My DHCP server is the 4500 switch.
    Anybody can help?
             DENY       10.25.0.1 – 10.25.0.255
                              10.25.1.1 – 10.25.1.255
    Permit only 1 host for Internet
                    10.25.7.136  255.255.255.192 ------ TMG Server
    Using access-list.
    ( Current configuration  )
    object-group network IP
    description Block_IP
    range 10.25.0.2 10.25.0.255
    range 10.25.1.2 10.25.1.255
    interface GigabitEthernet0/0
    ip address 192.168.2.3 255.255.255.0
    ip nat inside
    ip virtual-reassembly in max-fragments 64 max-reassemblies 256
    duplex auto
    speed auto
    interface GigabitEthernet0/1
    description ### ADSL WAN Interface ###
    no ip address
    pppoe enable group global
    pppoe-client dial-pool-number 1
    interface ATM0/0/0
    no ip address
    no atm ilmi-keepalive
    interface Dialer1
    description ### ADSL WAN Dialer ###
    ip address negotiated
    ip mtu 1492
    ip nat outside
    no ip virtual-reassembly in
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication pap callin
    ppp pap sent-username xxxxxxx password 7 xxxxxxxxx
    ip nat inside source list 101 interface Dialer1 overload
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip route 10.25.0.0 255.255.0.0 192.168.2.1
    access-list 101 permit ip 10.25.0.0 0.0.255.255 any
    access-list 105 deny   ip object-group IP any
    From the 4500 Catalyst switch
    ( Current Configuration )
    interface GigabitEthernet0/48
    no switchport
    ip address 192.168.2.1 255.255.255.0 interface GigabitEthernet2/42
    ip route 0.0.0.0 0.0.0.0 192.168.2.3

    Hello,
    Host will can't get internet connection
    I remove this configuration......         access-list 101 permit ip 10.25.0.0 0.0.255.255 any
    and change the configuration ....      ip access-list extended 101
                                                                5 permit ip host 10.25.7.136 any
    In this case I will allow only host 10.25.7.136 but it isn't work.
    No internet connection from the TMG Server.

  • Need help for writing extract program

    hi
    i need help for writing extract program to retriew data from legacy system.
    i already developed bdc programs for me31k and me21.
    my requirement is to write extract program s for those t.codes.
    to retriew data from legacy system and stored in flat file.

    i need help with a java program. it is a program that allows the user to enter a student's GPA, number of extracurricular activities, and number of service activities. The user can not enter a gpa above 4.0 or below 0. The user can not enter a negative number for the number of both activities. If the student meets the following criteria: 1) GPA of 3.8 or above and at least one extracurricular activity and one service activity, 2) GPA below 3.8 but at least 3.4 and a total of at least three extracurricular and service activities, 3) GPA below 3.4 but at least 3.0 and at least two extracurricular activities and three service activities, the message "Scholarship candidate" should display. If the student does not meet the criteria above, then the message"not a candidate" should display. Can you help me, please?
    You haven't posted ANY 'java program' for us to help with.
    The forum is NOT a coding service. It is to help you with YOUR code.
    Post the code you have written and SHOW us (don't just tell us) how you compile it and execute it and the results you get. Then we can help you with any problems you are are having.
    If you need help understanding just what the program should be doing you need to ask your instructor to clarify the assignment.

  • Need help for user exit mereq001

    Hi,
    I need help for user exit mereq001. I think I messed up with include table CI_EBANDB and CI_EBANMEM. And When I tried to check the syntax . It gives me error like : <b>Class IF_PURCHASE_REQUISITION. Inconsistency in the dictionary for the structure mereq_item_s_cust_data.</b> Anyone had experience for this exit? I just need to extract costcenter information of the each item from the requisition and block the requisiton if the costcenter are differents from each other before the requisition is saved. Any one has idea about it?
    Thanks.

    biao,
    Have you checked this struture consistency from SE11. Also check the activation log.
    If there are any errors and you are not able to rectify the same use RSDDCHECK program, give your table name and run the report.
    This will list down the error structures releated this table and also prompts for you to activate it.
    Regds
    Manohar

Maybe you are looking for

  • Latest version of Adobe Reader won't let me annotate

    I have been using the Adobe Reader 11 app to open PDFs and annotate them. The revised pdf is then uploaded to Dropbox and the reps in the field can download and continue annotating the same file. The field reps use iPads and/or iPhones but since the

  • Vendor Master Activity

    I want to clean up our Vendor Master File. I need to get a list of all Vendors with no activity over the last 3 years. It's seems this would be a standard report but I do not see one that meets this needs. How do I get  a list of Vendors that can be

  • HTML thumbnails page will take me to a Simple Viewer do I have to create 12 Simple Viewer galleries?

    I have created an HTML thumbnail page with 12 thumbnails. When I click on a thumbnail I would like it to take me to SV. Do I have to create 12 different SV galleries for each thumbnail?  EX: I have a project of an identity so I click on a thumbnail a

  • Partitioning on tables

    HI. I can do new partiton table when creating new table. CREATE TABLE zsat_dokumenti_saldakonti_bri1 PARTITION by list(id_organizacijske_enote_de)(PARTITION de_kc VALUES('20') TABLESPACE users, PARTITION de_mo VALUES('01') TABLESPACE users) AS SELECT

  • Worspace issue

    Hi I created a new user in Shared services for WebAnalysis Reports and i provided provisions to tht user till now its fine Now when i login to workspace with Admin ID and check for tht user I'm unable to see tht user under users folder... but tht use