Need help on Self Hosting Using channel Factory

Hello,
     Need Help.
     I am trying to self host WCF service using cutom Channel Factory class. but I am getting exception.
 The scenario is something like below this  : -
I want to create the endpoint connection to WCF service. I want to achieve this  using custom channel factory(not using default channel factory API provided in .Net Framework).
I have written one class and it is derived from channel factory and we are reading the service endpoints, behaviors, bindings from external configuration file added in the project.
I am able to connect to server side service hosted on different machine using following sample code successfully.
In the case of “self-hosting”  I am receiving following error : --
     "There was an error reading from the pipe: The pipe has been ended. (109, 0x6d)."
Below is the code which I have written for self hosting WCF service using custom channel factory.
// Method where I am calling CustomChannel Factory constructor
internal void ProxyCall(string msgEndpointConfigurationName, string url)
            string appConfigDirName, extConfigFilePath;
            FileInfo configFileInfo = new FileInfo(appConfigName);
            appConfigDirName = configFileInfo.DirectoryName;
            extConfigFilePath = appConfigDirName + "\\" + extConfigFileName;
            this.messageEndpointConfigurationName = msgEndpointConfigurationName;
            if (string.IsNullOrEmpty(url))
                this.messageFactory = new CustomChannelFactory<IServerOperationsMessage>(extConfigFilePath, this.messageEndpointConfigurationName);
            else
               //EndpointAddress e = new EndpointAddress(url + ClientToServerOperations.ServiceAddress);
               //this.messageFactory = new ChannelFactory<IServerOperationsMessage>(this.messageEndpointConfigurationName, e);
               this.messageFactory = new CustomSelfHostingChannelFactory<IServerOperationsMessage>(extConfigFilePath, this.messageEndpointConfigurationName, url + ClientToServerOperations.ServiceAddress);
               //this.messageFactory = new CustomSelfHostingChannelFactory<IServerOperationsMessage>(extConfigFilePath, this.messageEndpointConfigurationName, e);
   ClientMessageFormatterBehavior formatterBehavior = new ClientMessageFormatterBehavior();
   foreach (OperationDescription operation in this.messageFactory.Endpoint.Contract.Operations)
    if (!operation.Behaviors.Contains(typeof(ClientMessageFormatterBehavior)))
     operation.Behaviors.Add(formatterBehavior);
   this.messageFactory.Endpoint.Behaviors.Add(new MessageStatisticsBehavior());
   this.messageFactory.Open();
// Custom Channel Factory Class
internal class CustomSelfHostingChannelFactory<T> : ChannelFactory<T>
        /// Custom client channel. Allows to specify a different configuration file
        /// <typeparam name="T"></typeparam>
        private string configurationPath, selectedMsgEndPoint, uriAddress;
        public PPCCustomSelfHostingChannelFactory(string configurationPath, string selectedEndPoint, string uriAddress)
            : base(typeof(T))
            this.configurationPath = configurationPath;
            this.selectedMsgEndPoint = selectedEndPoint;
            this.uriAddress = uriAddress;
            EndpointAddress e = new EndpointAddress(this.uriAddress);
            base.InitializeEndpoint(selectedEndPoint,e);
        //As you can see, a call to the method InitialiazeEndpoint of the base class is required.
        //That method will automatically call to our CreateDescription method to configure the service endpoint.
        ///Loads the serviceEndpoint description from the specified configuration file
        protected override ServiceEndpoint CreateDescription()
            ServiceEndpoint serviceEndpoint = base.CreateDescription();
            return serviceEndpoint;
        private EndpointIdentity GetIdentity(IdentityElement element)
            EndpointIdentity identity = null;
            PropertyInformationCollection properties = element.ElementInformation.Properties;
            if (properties["userPrincipalName"].ValueOrigin != PropertyValueOrigin.Default)
                return EndpointIdentity.CreateUpnIdentity(element.UserPrincipalName.Value);
            if (properties["servicePrincipalName"].ValueOrigin != PropertyValueOrigin.Default)
                return EndpointIdentity.CreateSpnIdentity(element.ServicePrincipalName.Value);
            if (properties["dns"].ValueOrigin != PropertyValueOrigin.Default)
                return EndpointIdentity.CreateDnsIdentity(element.Dns.Value);
            if (properties["rsa"].ValueOrigin != PropertyValueOrigin.Default)
                return EndpointIdentity.CreateRsaIdentity(element.Rsa.Value);
            return identity;
        private Binding GetBinding(IBindingConfigurationElement configurationElement)
            if (configurationElement is CustomBindingElement) return new CustomBinding();
            else if (configurationElement is BasicHttpBindingElement) return new BasicHttpBinding();
            else if (configurationElement is NetMsmqBindingElement) return new NetMsmqBinding();
            else if (configurationElement is NetNamedPipeBindingElement) return new NetNamedPipeBinding();
            else if (configurationElement is NetPeerTcpBindingElement) return new NetPeerTcpBinding();
            else if (configurationElement is NetTcpBindingElement) return new NetTcpBinding();
            else if (configurationElement is WSDualHttpBindingElement) return new WSDualHttpBinding();
            else if (configurationElement is WSHttpBindingElement) return new WSHttpBinding();
            else if (configurationElement is WSFederationHttpBindingElement) return new WSFederationHttpBinding();
            return null;
        private Binding CreateBinding(string bindingName, ServiceModelSectionGroup group)
            BindingCollectionElement bindingElementCollection = group.Bindings[bindingName];
            if (bindingElementCollection.ConfiguredBindings.Count > 0)
                IBindingConfigurationElement be = bindingElementCollection.ConfiguredBindings[0];
                Binding binding = GetBinding(be);
                if (be != null)
                    be.ApplyConfiguration(binding);
                return binding;
            return null;
        private void AddBehaviors(string behaviorConfiguration, ServiceEndpoint serviceEndpoint, ServiceModelSectionGroup group)
            EndpointBehaviorElement behaviorElement = group.Behaviors.EndpointBehaviors[behaviorConfiguration];
            for (int i = 0; i < behaviorElement.Count; i++)
                BehaviorExtensionElement behaviorExtension = behaviorElement[i];
                object extension = behaviorExtension.GetType().InvokeMember("CreateBehavior", BindingFlags.InvokeMethod | BindingFlags.NonPublic | BindingFlags.Instance, null,
behaviorExtension, null);
                if (extension != null)
                    serviceEndpoint.Behaviors.Add((IEndpointBehavior)extension);
Thanks in advance !! :-)

Hi,
There was an error reading from the pipe: Unrecognized error 109 (0x6d).
One reason was inconsistent binding between client and server <netNamedPipeBinding> <security mode="None"></security>... (no
communication)
The other intermittent issue was time-out related.
For more information, you could refer to:
http://stackoverflow.com/questions/15836199/wcf-namedpipe-communicationexception-the-pipe-has-been-ended-109-0x6d
http://stackoverflow.com/questions/22334514/wcf-named-pipe-error-the-pipe-has-been-ended-109-0x6d
Regards

Similar Messages

  • I need help I tried to use cloud backup on my iPhone 5.0.1 and after all my camera roll pictures are blurry and videos canot be played messege says URL not on this server ! Please help!! iPhone 4S, iOS 5.0.1

    I need help I tried to use cloud backup on my iPhone 5.0.1 and after all my camera roll pictures are blurry and videos canot be played messege says URL not on this server ! Please help!!
    iPhone 4S, iOS 5.0.1

    Try updating to iOS 6.1.3.

  • I need help from chile and use a language translator to write and not turn my iphone4

    I need help from chile and use a language translator to write and not turn my iphone4

    http://support.apple.com/kb/TS3281       
    Not turn on

  • Need help in english to use my iphone4 with orange.fr in france

    I am travelling in France with my factory unlocked iphone4. England and Thailand services have been fine but Orange France is a nightmare. They say I can't get 3G on my iphone4 and there is no english speaking support to help me out. My network settings are turned off but my 20 euro credit has either dissappeared or never was there in the first place. Where can I get English support for this company?

    Hello
    The whole story is a little bit confusing for me. So lets see what you wrote:
    >... thinking that it would fix it but it ended up erasing the whole of my computer even windows 7.
    Thinking is wrong. What you need is exact info about recovery installation and this can be found in users manuals document. Recovery disc is not like Microsoft installation disc and cannot be used for repair. Recovery disc contains recovery image and can be used for clean OS installation (recovery image installation) only.
    > So now I have a computer I can't use
    Why you cannot use it? Recovery image installation installs OS again. Which OS is installed after running recovery image installation?
    > I have also bought the product recovery disks from toshiba's backup media site
    But why if you already have recovery disc that you have used at the beginning of the whole story?
    What you need to do is to use this original disc for OS installation.
    -start your notebook and press F12 several times to enter BOOT menu
    -when the menu is shown put recovery disc into ODD
    -select CD/DVD drive in the menu and press ENTER
    -follow the menu on the screen
    After recovery image installation you will have factory settings again and everything should be OK.
    More questions?

  • Need Help Understanding How To Use iMessage Between Two iPhones

    I have an iPhone 4 and my wife an iPhone 3GS.  We both have iOS 5, but I have discovered something about iMessage I need to make sure I understand correctly.  As I understand it iMessage can send text even if our voice carrier service is unavailable.  I tend to loose signal inside the building I work in.  I usually can get texts in and out, but sometimes not.  But in testing the two phones sending iMessages, I've noticed is that if I have one of the phones with iMessage turned on and the other with iMessage turned off, the two phones will not be able to exchange text.  Is that how it's supposed to work?  Even though one of these phones can receive an iMessage doesn't mean the other one send one back.  Can't the system detect when one phone is connected and another one not, and the one that is not gets sent SMS messages instead?  I don't want to try to send my wife an iMessage because I can't get a voice signal in my building, but her have iMessages turned off and not able to get any messages from me, iMessage or SMS.  I guess I need help better understanding how this actually works between the two phones so I can always get texts back and forth between my wife and I.  My other misgiving is that this iMessage thing consumes my data limit.  My wife gets unlimited because she had her phone before the limits were imposed, but I got on board after, so I am hesitant to use iMessage all the time because of it.  I have no intention to send picture mail through iMessage, but the thing is if I wanted to switch to SMS to send picture mail to save data, but my wife's phone is set to iMessage, she won't get it.  If this is how this thing is supposed to work, I'm not really impressed.  Some insight would be appreciated

    I think you are making this way too complicated. Why are you turning iMessage off? If you are at your office connect to the WiFi there and send your wife messages that way (unless your office is blocking the port iMessage uses). When possible the two phones will use iMessage but will revert to SMS is iMessage is not available if that option is set that way.
    I would not worry about using up your data plan if you have the 2GB, text iMessages are going to be very small and MMS (picture) ones are not very large either. Unless you are sending hundreds of picture iMessages a day you will have a hard time using up your data.
    If you are near an Apple Store you should explore signing up for an intro iPhone course and have them run through iMessage options.

  • Need help on how to use conference facility within adobe connect

    I need some help on how to use conference facility within adobe connect?

    I'd recommend you start here: Getting Started with Adobe Connect - Adobe Connect User Community

  • Need help please. When using Safari while banking online I cannot get rid of Pop ups although I have ticket no Pop ups. Any ideas ?

    Need your help please. When using Safari while banking online- I cannot get rid of the Pop ups although I have ticked the correct place. Any ideas ?
    A few months ago I downloaded a program someone suggested.

    Get Adblock or GlimmerBlocker.

  • Need help about ref cursor using like table

    Hi Guys...
    I am devloping package function And i need help about cursor
    One of my function return sys_refcursor. And the return cursor need to be
    join another table in database . I don't have to fetch all rows in cursor
    All i need to join ref cursor and another table in sql clause
    like below
    select a.aa , b.cc form ( ref_cursor ) A, table B
    where A.dd = B.dd
    I appeciate it in advance

    My understanding is that you have a function that returns a refcursor and is called by a java app.
    Because this is a commonly used bit of code, you also want to reuse this cursor in other bits of sql and so you want to include it like table in a bit of sql and join that refcursor to other tables.
    It's not as easy as you might hope but you can probably achieve this with pipelined functions.
    Is it a direction that code should be going down? yes, eventually. I like the idea of pulling commonly used bits of code into a SQL statement especially into the WITH section, provided it could be used efficiently by the CBO.
    Is it worth the effort given what you have to do currently to implement it? possibly not.
    what else could you do? construct the sql statement independently of the thing that used it and reuse that sql statement rather than the refcursor it returns?
    Message was edited by:
    dombrooks

  • I am Stuck! Need Help With Multicast Streaming Using VLC Player

    I have a Multicast network topology shown below
    and my configs
    HUB ROUTER
    no ip domain lookup
    ip domain name primestarhotel.com
    ip multicast-routing
    interface Loopback0
    ip address 5.5.5.5 255.255.255.255
    ip pim sparse-dense-mode
    interface FastEthernet0/0
    ip address 200.0.0.2 255.255.255.240
    ip pim sparse-dense-mode
    ip virtual-reassembly
    speed 100
    full-duplex
    interface FastEthernet0/1.65
    description "Server Vlan"
    encapsulation dot1Q 65
    ip address 10.1.65.1 255.255.255.0
    ip pim sparse-dense-mode
    ip virtual-reassembly
    router ospf 200
    log-adjacency-changes
    network 5.5.5.5 0.0.0.0 area 0
    network 10.1.65.0 0.0.0.255 area 0
    network 200.0.0.0 0.0.0.15 area 0
    ip route 200.1.1.0 255.255.255.252 200.0.0.1
    ip route 200.2.2.0 255.255.255.252 200.0.0.1
    no ip http server
    no ip http secure-server
    ip pim send-rp-announce Loopback0 scope 6
    ip pim send-rp-discovery Loopback0 scope 6
    ISP ROUTER
    interface FastEthernet1/0
    interface FastEthernet1/1
    no switchport
    ip address 200.0.0.1 255.255.255.240
    ip pim sparse-dense-mode
    duplex full
    speed 100
    interface FastEthernet1/2
    no switchport
    ip address 200.1.1.1 255.255.255.252
    ip pim sparse-dense-mode
    duplex full
    speed 100
    interface FastEthernet1/3
    no switchport
    ip address 200.2.2.1 255.255.255.252
    ip pim sparse-dense-mode
    duplex full
    speed 100
    router ospf 200
    log-adjacency-changes
    network 200.0.0.0 0.0.0.15 area 0
    network 200.1.1.0 0.0.0.3 area 0
    network 200.2.2.0 0.0.0.3 area 0
    SPOKE 1 Router
    interface FastEthernet0/0
    ip address 200.1.1.2 255.255.255.252
    ip pim sparse-dense-mode
    speed 100
    full-duplex
    interface FastEthernet0/1
    no ip address
    ip pim sparse-dense-mode
    ip virtual-reassembly
    speed 100
    full-duplex
    interface FastEthernet0/1.12
    description "Workstation pc"
    encapsulation dot1Q 12
    ip address 10.1.12.1 255.255.255.0
    ip pim sparse-dense-mode
    router ospf 200
    log-adjacency-changes
    network 10.1.12.0 0.0.0.255 area 0
    network 200.1.1.0 0.0.0.3 area 0
    ip route 0.0.0.0 0.0.0.0 200.1.1.1
    SPOKE 2
    interface FastEthernet0/0
    ip address 200.2.2.2 255.255.255.252
    ip pim sparse-dense-mode
    speed 100
    full-duplex
    interface FastEthernet0/1
    ip address 10.2.22.1 255.255.255.0
    ip pim sparse-dense-mode
    speed 100
    full-duplex
    router ospf 200
    log-adjacency-changes
    network 10.2.22.0 0.0.0.255 area 0
    network 200.2.2.0 0.0.0.3 area 0
    ip route 0.0.0.0 0.0.0.0 200.2.2.1
    ip route 200.2.2.0 255.255.255.252 200.0.0.1
    I have implemented multicast on the network in a hub and spoke topology. i have set up ospf routing protocol and broadcast all network and can successfully ping.
    I am currently using VLC player as my media streaming server and client. i have set up rtp streaming from the HUb router using multicast ip 224.2.2.2 and unable to broadcast the multicast traffic across the spokes 1 and 2 PC's
    I have never used vlc player  never set up multicast network before and i am struggling with this and need help.
    these are my router configs below
    http://dl.dropbox.com/u/20145606/ip%20video%20config.txt
    Message was edited by: Louis Ojuwu

    I have edited the message and the configs and topology are visible above now. instead of the links i provided

  • Need Help With Military DTD Using FrameMaker 8

    Fellow Forum Members,
    I hope someone out there with experience in using Department of Defense DTDs with FrameMaker can contribute to this thread.
    Attached is the MIL STD 400051-2 DTD that needs to play with FrameMaker. Does anyone out there know where I could find FrameMaker templates already setup that comply and play with the MIL STD 400051-2 DTD standard? If the Department of Defense is freely distributing the MIL STD 400051-2 DTD, shouldn't somebody in the Department of Defense also be providing MIL STD 400051-2 FrameMaker Templates for free that are already setup?  I would greatly appreciate if anyone out there could provide an online source where I could download MIL STD 400051-2 FrameMaker templates.
    Lastly, can anyone out there clarify what the purpose of the entities are inside the "Charant" and "Boilerplate" folders?  The Department of Defense does not provide a readme file that define what the "Charant" and "Boilerplate" folders are about.
    Any info will be greatly appreciated. Thanks.

    I'll answer the specifics that I know about your questions, but please look at the post from Srini for additional info:
    1) Do i need to do full export using SYS/SYSTEM user.
    exp80 system/manager file=c:full.dmp log=c:\full.txt full=y consistent=yA full export will move as much information (metadata/data) as possible. In order to do a full export/import, you need to do this from a
    privileged account. A privileged account is one with EXP_FULL_DATABASE for export and IMP_FULL_DATABASE for import.
    2) Will there be any data corruption while export.The data in the objects that you are exporting is being read, nothing is written to user data. I'm not sure what this is available in 8.0.6,
    but if you need a consistent export, look to see if consistent=y is available in 8.0.6. All this means is that the dump file created will have
    consistent data in it.
    3) Is export/import the only method of migration/upgradation.If you are changing hardware, the only supported way from 8.0 to 10.2.0.4, that I know of, is using exp/imp.
    Hope this helps.
    Dean

  • Need help with database migration using export/import

    Hi,
    I am planning to do a database migration from 8.0.6 to 10.2.0.4. I am using export/import. Please answer some of my queries:
    1) Do i need to do full export using SYS/SYSTEM user.
    exp80 system/manager file=c:full.dmp log=c:\full.txt full=y consistent=y
    2) Will there be any data corruption while export.
    3) Is export/import the only method of migration/upgradation.
    Please help
    Thanks.

    I'll answer the specifics that I know about your questions, but please look at the post from Srini for additional info:
    1) Do i need to do full export using SYS/SYSTEM user.
    exp80 system/manager file=c:full.dmp log=c:\full.txt full=y consistent=yA full export will move as much information (metadata/data) as possible. In order to do a full export/import, you need to do this from a
    privileged account. A privileged account is one with EXP_FULL_DATABASE for export and IMP_FULL_DATABASE for import.
    2) Will there be any data corruption while export.The data in the objects that you are exporting is being read, nothing is written to user data. I'm not sure what this is available in 8.0.6,
    but if you need a consistent export, look to see if consistent=y is available in 8.0.6. All this means is that the dump file created will have
    consistent data in it.
    3) Is export/import the only method of migration/upgradation.If you are changing hardware, the only supported way from 8.0 to 10.2.0.4, that I know of, is using exp/imp.
    Hope this helps.
    Dean

  • Need Help with Virtual Host

    a quick Explaination of what I'm trying to do.
    We have a DNS name, "our_intranet.com". This DNS points to a load balancer which routes the call to "our_weblogic_server:7015". When a request with this DNS comes in, we really want to go to our_weblogic_server:7015/portal/site/our_intranet. Can this be acheived using a Virtual Host? And if so, could give an example of creating a virtual host?
    Thanks,
    Tom.

    Thank you James for your reply,
    I do appreciate you taking a moment to respond and include some suggestions. At this point I feel 90% certain that the answer lies within WebLogic configuration somewhere.
    Discoverer is a J2EE application as I understand it and based on that belief it is probably using the standard J2EE servlet API calls such as ServletRequest. getScheme() (the protocol portion of the URL such as http, https, ftp), ServletRequest.getHostname(), and ServletRequest.getPort(). Those API calls return values derived by the server either from the connection itself or from server configuration.
    The URL's being returned by the web application are not static either. Although the protocol and the port never change (always http://...:80/) the server hostname does. If I add an entry to my host file for fred.somewhere.com and then hit the server using that server name then the URL's returned by the web application are http://fred.somewhere.com:80/, and if I use barney.somewhere.com I get a similar result. Now, the web application could be reading the "Host" HTTP header out of the request itself to derive that information but why go through all that trouble when the Servlet API gives you a standard way to do it.
    For this reason I believe Discoverer (the web app causing our grief) is getting this information from WebLogic even though I cannot verify that with absolute certainty. I wish someone from the Disco area could verify that. I have had a support request open with Oracle for over a week but so far they haven't been able to tell me where they get that information from (which I'm sure is just because I'm not speaking with a developer). I may actually in fact pass on this question to the Discoverer forums you suggested. If someone can at least tell me if Discoverer is getting this information from the application server then I can at least pass that along as confirmation to WebLogic folks.
    I have set up an Apache web server as a reverse proxy server for http and https in front of this particular server as an experiment and get similar results with the server name. Whether I hit Apache via http or https I always get back http://servername:80/ from the back-end WLS. The fact is WebLogic isn't even running on port 80 which makes it even more interesting why the URL's we get back should point at 80 instead of the port WLS is listenning on. Since there is no port or protocol information contained within the HTTP request sent by client browsers (only the Host header which just has the hostname) that may have something to do with why the server doesn't know how to provide correct values, but that doesn't explain why it would choose to tell the web application port 80 instead of the port it is actually listening on.
    As far as tracking down how to configure this beast it might be complicated by the fact that I don't think this is just WebLogic Server. This is Fusion Middleware. I didn't think that included Apache HTTP Server, but actually I can see there is a directory for Apache on the server identified as ohs (stands for Oracle HTTP Server). Some of the help in Enterprise Manager (or maybe it was in the WebLogic administration web console) actually talks about Oracle HTTP Server which they say is based on Apache HTTP Server and in fact the configuration files are consistent with Apache. That doesn't mean I don't believe WebLogic folks like yourself that say Apache is not a part of WebLogic server (which seems like a pure Java application) but maybe it is a part of Oracle Fusion Middleware. They might just have it there for other stuff working together with WLS (such as Oracle Web Cache) or for load balancing as you mentioned. If it is there then it might either complicate things, or might provide a possible solution. If it really is running there in front of WLS and we can use some Apache configuration values to override URL information that the server passes on to the web applications maybe it could help. I did see some processes running on the same server with a name something like HTTPD.worker. My Apps DBA's (who are also learning as they go with WLS) said they did zero Apache configuration as part of the install however and I know zero about how (or if) Apache is working together with WLS.
    I tried going down the path of setting up a custom Network Channel and Virtual Host because a) it seemed like a logical place to look and b) I had seen some references to them on the web but as I tried to step through the configuration I admit I never saw any settings that related to protocol overrides. I have seen host and port overrides somewhere along the way but never a protocol override.
    I'm confused that this seems so complicated. I mean, aren't there a lot of people out there running their servers behind a hardware load balancer with SSL termination at the load balancer (it handles the https decryption and then forwards the requests unencrypted to the back-end servers)?
    Your link to the "Corecoreserverserverprotocolshttptitle.html" looks like just the right place (almost). If it only had Frontend Port and Frontend Protocol as well as Frontend Host (and instead of Frontend HTTP Port and Frontend HTTPS Port). So frustrating to be so close but miss. I do appreciate the pointer though.
    Funny that you should bring up the post on WebLogic Wonders because that is actually the example I tried to follow when I attempted to set up a network channel and virtual host. I aborted before the deploy because the deploy wasn't working quite how I expected and I had little confidence it was going to help me at that point (because I hadn't been presented with any setting that allowed me to override the protocol (http/https) value for a front-end system. I'm still not quite sure how the Network Channel works together with the server/domain/virtual host so perhaps I need to do a little more reading.
    If anyone understands exactly what I am trying to achieve though and can give me some direction it would be much appreciated. It seems straight forward to me:
    We have an F5 hardware load-balancer that runs here:
    https://external-servername:443/....
    It uses hardware SSL accelleration to decrypt the incoming request and if it sees /discoverer/ in the URL it then forwards the request unencrypted to a back-end WLS here:
    http://internal-servername:8888/...
    We would be happy if any connection that server recieved it always overrides the scheme (https instead of http), server (external instead of internal...it actually does this properly already), and port (443 instead of 80). In a perfect world it might behave differently if we connect internally directly to the server (in other words if we don't access it through the load balancer then it provides URL information to continue accessing it directly) but that is just icing on the cake which probably would require virtual host configuration to differentiate the two. We'd be ecstatic if we could simply override those values all the time for the entire server to some constant values that we set.
    Thanks,
    Eric R.

  • Need help on self referencing a ssrs report

    Hi All,
    I have a graph on one of my report which shows data on level 1 by default and go on showing level 2 and level 3 data on successive clicks. This has been achieved by self referencing a ssrs report and passing respective parameters. Now to identify which level
    data needs to be shown on graph, I have used one more parameter which default value is 1 and go on increasing to 2 then 3 on successive click and this parameter value is used in group expression of graph. This works just fine.
    But the real problem has occurred when you go and select report parameters which are corresponding to level 1, level 2 and level 2 values and click on apply in between. For e.g. Assume level 1=Region, level 2=SubRegion and level 3=Country. When you run this
    report it shows region wise data on graph and value of fourth parameter is 1, now when you click on graph it takes you to level 2 i.e. it shows sub region wise data on graph and value of fourth parameter is 2 but when you go and select all region, sub region
    and countries from report parameters and click on apply button then it should show data on graph region wise but since the time you were selecting parameter data was sub region wise and value of fourth parameter was 2 it shows data for all sub regions which
    is weird and not acceptable at all. 
    I am hoping SSRS should provide a way to pass parameters just like we pass in action on any control within ssrs report to solve this issue. Please help me out to solve this issue or let me know if need more infor.

    Hi,
    There was an error reading from the pipe: Unrecognized error 109 (0x6d).
    One reason was inconsistent binding between client and server <netNamedPipeBinding> <security mode="None"></security>... (no
    communication)
    The other intermittent issue was time-out related.
    For more information, you could refer to:
    http://stackoverflow.com/questions/15836199/wcf-namedpipe-communicationexception-the-pipe-has-been-ended-109-0x6d
    http://stackoverflow.com/questions/22334514/wcf-named-pipe-error-the-pipe-has-been-ended-109-0x6d
    Regards

  • Need Help Connect to MySQL using dg4odbc

    I am looking for some help getting a dblink working from my Oracle 11.1.0.6 Dtabase to a MySQL 5.0.77 Database (Holds Bugzilla).
    This is the error I get when I try select * from "bugs"@bugz;
    ORA-28500: connection from ORACLE to a non-Oracle system returned this message:
    [MySQL][ODBC 5.1 Driver][mysqld-5.0.77]You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '"bug_id" FROM "bugs" A1' at line 1
    ORA-02063: preceding 2 lines from BUGZ
    On Server hosting Oracle DB:
    lsb_release -id
    Distributor ID: RedHatEnterpriseServer
    Description: Red Hat Enterprise Linux Server release 5.7 (Tikanga)
    rpm -qa|grep mysql
    mysql-connector-odbc-5.1.8-1.rhel5
    mysql-5.0.77-4.el5_6.6
    tnsping BUGZ
    TNS Ping Utility for Linux: Version 11.1.0.6.0 - Production on 08-DEC-2011 07:53:52
    Copyright (c) 1997, 2007, Oracle. All rights reserved.
    Used parameter files:
    Used TNSNAMES adapter to resolve the alias
    Attempting to contact (DESCRIPTION = (ADDRESS_LIST = (ADDRESS = (PROTOCOL = TCP)(HOST = localhost)(PORT = 1521))) (CONNECT_DATA = (SID = BUGZ)) (HS = OK))
    OK (0 msec)
    tnsnames.ora
    BUGZ =
      (DESCRIPTION =
        (ADDRESS_LIST =
          (ADDRESS = (PROTOCOL = TCP)(HOST = localhost)(PORT = 1521))
        (CONNECT_DATA =
          (SID = BUGZ)
        (HS = OK)
      )listener.ora
    SID_LIST_LISTENER =
      (SID_LIST =
         (SID_DESC =
            (ORACLE_HOME = /u00/app/oracle/product/11.1.0/db_1)
            (SID_NAME = BUGZ)
            (PROGRAM = dg4odbc)
            (ENVS ="LD_LIBRARY_PATH=/u00/app/oracle/product/11.1.0/db_1/lib:/usr/lib64:/usr/lib")
    .../u00/app/oracle/product/11.1.0/db_1/hs/admin/initbugz.ora
    # This is a sample agent init file that contains the HS parameters that are
    # needed for the Database Gateway for ODBC
    # HS init parameters
    HS_FDS_CONNECT_INFO=bugz
    HS_FDS_TRACE_LEVEL=off
    HS_FDS_SHAREABLE_NAME=/usr/lib64/libmyodbc5.so
    HS_LANGUAGE=AMERICAN_AMERICA.WE8ISO8859P15
    # ODBC specific environment variables
    set ODBCINI=/u00/home/oracle/.odbc.ini
    # Environment variables required for the non-Oracle system
    set HOME=/u00/home/oracle
    ~/u00/home/oracle/.odbc.ini
    [ODBC Data Sources]
    [bugz]
    Driver      = /usr/lib64/libmyodbc5.so
    DATABASE    = bugzilla
    DESCRIPTION = MySQL ODBC 5.x Connector
    PORT        = 3306
    SERVER      = bugzilla
    UID         = bugquery
    PWD         = password
    CHARSET     = latin1
    TRACEFILE   = /tmp/myodbc-bugzdsn.trc
    TRACE       = OFFODBC Test
    isql -v bugz
    +---------------------------------------+
    | Connected!                            |
    |                                       |
    | sql-statement                         |
    | help [tablename]                      |
    | quit                                  |
    |                                       |
    +---------------------------------------+
    SQL> help bugs
    [Bunch of stuff omitted]
    SQLRowCount returns 31
    31 rows fetched
    SQL>

    I did the delete and reconnected and the rows where created again.
    I am testing with two SQL statements right now from TOAD and from SQLPlus.
    A. select bugs."bug_id" as Ticket, bugs."short_desc", bugs."bug_status" AS Status, bugs."assigned_to", dump(bugs."short_desc") from "bugs"@BUGZ bugs where "bug_id" = 2;
    B. select bugs."bug_id" as Ticket, bugs."short_desc", bugs."bug_status" AS Status, bugs."assigned_to" from "bugs"@BUGZ bugs
    When I issue "A" I get good looking results. When I issue "B" I get an error.
    SQL> select bugs."bug_id" as Ticket, bugs."short_desc", bugs."bug_status" AS Status, bugs."assigned_to", dump(bugs."short_desc") from "bugs"@BUGZ bugs where "bug_id" = 2;
        TICKET
    short_desc
    STATUS                                                           assigned_to
    DUMP(BUGS."SHORT_DESC")
             2
    COMA computer has updates set to auto install  please disable and allow me to ch
    oose
    CLOSED                                                                     8
    Typ=1 Len=168: 0,67,0,79,0,77,0,65,0,32,0,99,0,111,0,109,0,112,0,117,0,116,0,101
        TICKET
    short_desc
    STATUS                                                           assigned_to
    DUMP(BUGS."SHORT_DESC")
    ,0,114,0,32,0,104,0,97,0,115,0,32,0,117,0,112,0,100,0,97,0,116,0,101,0,115,0,32,
    0,115,0,101,0,116,0,32,0,116,0,111,0,32,0,97,0,117,0,116,0,111,0,32,0,105,0,110,
    0,115,0,116,0,97,0,108,0,108,0,32,0,32,0,112,0,108,0,101,0,97,0,115,0,101,0,32,0
    ,100,0,105,0,115,0,97,0,98,0,108,0,101,0,32,0,97,0,110,0,100,0,32,0,97,0,108,0,1
    08,0,111,0,119,0,32,0,109,0,101,0,32,0,116,0,111,0,32,0,99,0,104,0,111,0,111,0,1
        TICKET
    short_desc
    STATUS                                                           assigned_to
    DUMP(BUGS."SHORT_DESC")
    15,0,101
    SQL> select bugs."bug_id" as Ticket, bugs."short_desc", bugs."bug_status" AS Status, bugs."assigned_to" from "bugs"@BUGZ bugs;
    ERROR:
    ORA-28528: Heterogeneous Services datatype conversion error
    ORA-02063: preceding line from BUGZ
    no rows selectedThe bugs table looks like this:
    CREATE TABLE `bugs` (
      `bug_id` mediumint(9) NOT NULL auto_increment,
      `assigned_to` mediumint(9) NOT NULL,
      `bug_file_loc` mediumtext,
      `bug_severity` varchar(64) NOT NULL,
      `bug_status` varchar(64) NOT NULL,
      `creation_ts` datetime default NULL,
      `delta_ts` datetime NOT NULL,
      `short_desc` varchar(255) NOT NULL,
      `op_sys` varchar(64) NOT NULL,
      `priority` varchar(64) NOT NULL,
      `product_id` smallint(6) NOT NULL,
      `rep_platform` varchar(64) NOT NULL,
      `reporter` mediumint(9) NOT NULL,
      `version` varchar(64) NOT NULL,
      `component_id` smallint(6) NOT NULL,
      `resolution` varchar(64) NOT NULL default '',
      `target_milestone` varchar(20) NOT NULL default '---',
      `qa_contact` mediumint(9) default NULL,
      `status_whiteboard` mediumtext NOT NULL,
      `votes` mediumint(9) NOT NULL default '0',
      `lastdiffed` datetime default NULL,
      `everconfirmed` tinyint(4) NOT NULL,
      `reporter_accessible` tinyint(4) NOT NULL default '1',
      `cclist_accessible` tinyint(4) NOT NULL default '1',
      `estimated_time` decimal(7,2) NOT NULL default '0.00',
      `remaining_time` decimal(7,2) NOT NULL default '0.00',
      `deadline` datetime default NULL,
      `alias` varchar(20) default NULL,
      `cf_type` varchar(64) NOT NULL default '---',
      `cf_notes` mediumtext,
      `keywords` mediumtext NOT NULL,
      PRIMARY KEY  (`bug_id`),
      UNIQUE KEY `bugs_alias_idx` (`alias`),
      KEY `bugs_assigned_to_idx` (`assigned_to`),
      KEY `bugs_creation_ts_idx` (`creation_ts`),
      KEY `bugs_delta_ts_idx` (`delta_ts`),
      KEY `bugs_bug_severity_idx` (`bug_severity`),
      KEY `bugs_bug_status_idx` (`bug_status`),
      KEY `bugs_op_sys_idx` (`op_sys`),
      KEY `bugs_priority_idx` (`priority`),
      KEY `bugs_product_id_idx` (`product_id`),
      KEY `bugs_reporter_idx` (`reporter`),
      KEY `bugs_version_idx` (`version`),
      KEY `bugs_component_id_idx` (`component_id`),
      KEY `bugs_resolution_idx` (`resolution`),
      KEY `bugs_target_milestone_idx` (`target_milestone`),
      KEY `bugs_qa_contact_idx` (`qa_contact`),
      KEY `bugs_votes_idx` (`votes`),
      CONSTRAINT `fk_bugs_assigned_to_profiles_userid` FOREIGN KEY (`assigned_to`) REFERENCES `profiles` (`userid`) ON UPDATE CASCADE,
      CONSTRAINT `fk_bugs_component_id_components_id` FOREIGN KEY (`component_id`) REFERENCES `components` (`id`) ON UPDATE CASCADE,
      CONSTRAINT `fk_bugs_product_id_products_id` FOREIGN KEY (`product_id`) REFERENCES `products` (`id`) ON UPDATE CASCADE,
      CONSTRAINT `fk_bugs_qa_contact_profiles_userid` FOREIGN KEY (`qa_contact`) REFERENCES `profiles` (`userid`) ON UPDATE CASCADE,
      CONSTRAINT `fk_bugs_reporter_profiles_userid` FOREIGN KEY (`reporter`) REFERENCES `profiles` (`userid`) ON UPDATE CASCADE
    ) ENGINE=InnoDB AUTO_INCREMENT=4570 DEFAULT CHARSET=utf8;Edited by: Sky13 on Dec 22, 2011 1:36 PM

  • Need help on HTTP AAE Sender channel PI 7.4

    Hi Experts ,
    My scenario is sender system will be sending .xml file using HTTP request to Middle ware (SAP PI )  . Receiver is ECC System  where IDOC is generated  . Its Async Scenario .
    I have used HTTP AAE sender channel . Now need to some help on wheater to Select POST or GET Option to complete above requirement .
    Please suggest few points which option to select
    Regads,
    Khan

    Hi Aziz,
    Please refer the below blog for details and you can use the post method.
    HTTP Test Tool for SAP PI 7.3
    PI 7.30 HTTP Java Adapter Test Tools

Maybe you are looking for

  • Problem with CALL TRANSACTION  SKIP FIRST SCREEN

    Hi Experts, I am having a functionality where in if i click the hotspot i go the specified transaction..I am able to do that using -- CALL TRANSACTION 'CAA3' AND SKIP FIRST SCREEN Now if i press the back button on the standard transaction i am coming

  • Outlook 2002 and iTunes 10

    I'm using Outlook 2002 SP3 with Windows 7 and iTunes 10.1.1.4 with an iPhone 4 running IOS 4.2.1 I have been successfully synching my iPhones with iTunes and Outlook 2002 for years but since installing the most recent version of iTunes I am unable to

  • SFTP- permission issue

    Hi SuperSAs, I have one issue with SFTP, one of our user complaint me that whenever he create a directory by using his SFTP id the permission set to 750. He requested me to set his permission to 770. i checked his profile and found that umask is alre

  • Cannot find symbol symbol : class Item location: package platypos.services.

    Well, I am having a few problems getting this java file to compile. /home/brandon/Desktop/platypos/services/order/Seat.java package platypos.services.order; import platypos.services.order.Item; import java.util.Vector; public class Seat     private i

  • Iphoto '08 has circle with left slash over its icon

    I tried to import or copy (tried both) an image to iphoto to my library, then all of a sudden the fan became extremely loud and the bottom of the laptop heated up quickly. I had to force quit and let the laptop cool off. Today, iphoto has the circle