Need help with a Webdynpro scenario

Hi,
I have the following scenario.
I have a webdynpro application (form) which allows the user to change some data. When the page loads, the data already available is displayed in the corresponding UI elements in the form. This is done using a BAPI call. Then after the user modifies the values and clicks modify, the corresponding values should be updated using a different BAPI call.
Here, for displaying the values at first, I have mapped the view context to the controller context and in turn to the corresponding model. But to update using a different Model class, how can we map the updated values dynamically, say on submit? Can the view context attributes, mapped to multiple controller context attributes? Or is there any other way to acheive this.
I have another question. I have a dropdown UI element in the same application. It is populated with data coming from a BAPI call. But how can we set the selected value to the one which the user has already stored previously? Remember, the user is modifying the values.
thanks in advance!
KK

Hi KK,
You can achieve the same by copying the UI attributes to a new node in the controller using copy corresponding( i am assuming your node structure and name remains same). You can then pass this node to the 2nd BAPI.
and when you get the next display the 1st BAPI will get you updated data.
For the UI dropdown also, you can persist the data in a value node and then check if the dropdown model node for this element and set it default. OR there needs to be some sorting in the BackEnd.
Kind Regards
Asif

Similar Messages

  • Need help with CATS WebDynpro

    <h4>System Landscape</h4>
    ERP 6.0 - HR
    ERP 6.0 - Financials
    EP 7.0 SP13 u2013 MSS 1.0, ESS 1.0
    Scenario: We are trying to implement the CATS functionality in the portal so that contractors can enter their time and managers can approve time from within the portal. We currently have our employees in the HR system and Contractors in the Financial system. I have changed the JCo References within the DCu2019s for esscat & msscat~approval from SAP_R3_Human Resources to SAP_R3_Financials.
    Issues: Approving time is working correctly. What is not working is the Time Entry Portion. If a contractor logs into the portal to enter time he can not see his work items. When I remove my IT0105 Subtype 0001 from my HR system I get the User does not exist in this period error. I looked in the DC and notice that it uses the DC pcuigp~xssutils FCEmployeeServices. This DC checks the HR system for the useru2019s information. Since contractors donu2019t exist in our HR system we receive the error. Is there a way to override the calls to this DC and point them to the Financials systems? We donu2019t want to change the DC to only point to the Financials systems and this DC is used for ESS as well.
    Any help would be greatly appreciated.

    Yeh I got that. I was just thinking of past clients. It always worked pretty well if they "rolled on" contractors like employees but in their own emp. group. Then they had a pretty good way of tracking them.....as well as things like you discuss with time especially around PS. In fact, at one client, I had to build a CSS (Contractor/Consultant Self-Service) along with their ESS solutions. hahahaha
    Anyways...yeh, yours will be tricky. The FI and HR tie ins to CATS are cake (hey, that's what it's for CROSS APPLICAITON....haha) but the trick is saying "some of these people are employees and need to feed over to HR, but some aren't". Have you looked at any of the CATS user-exist or BADIs to see if you could put in your own "filter" to not check contractors? Maybe have contractors in some Z table and check it before the calls are made to the HCM system? Just a quick thought. In any event, I think I see some "fun" custom development in your future. *grin*

  • Need help with the following scenario

    Hi guys,
    I have to implement a solution which requires me to duplicated all the rows from a table to another in reverse order. For eg. I have table1 containing the following rows:
    200, 350, 700, 90
    All these numbers are sorted according to their ROW_ID_BLOCK_NUMBER. When these rows are replicated over to another table, say table2, it should be inserted in the following order:
    90, 700, 350, 200
    I do not have another column column that stores the running identity number for each row and I don't intend to implement that right now. I was wondering if that can be implemented using the DBMS_ROWID package and if so, how? Any help is greatly appreciated here. Thanks in advance.

    In 10g, assuming you've built a table with row dependencies enabled
    SCOTT @ jcave102 Local> create table a (
      2  col1 number
      3  )
      4  rowdependencies;
    Table created.
    Elapsed: 00:00:00.04the ORA_ROWSCN pseudocolumn will tell you the SCN (system change number) of the transaction that inserted the rows
    SCOTT @ jcave102 Local> insert into a values( 1 );
    1 row created.
    Elapsed: 00:00:00.07
    SCOTT @ jcave102 Local> insert into a values( 2 );
    1 row created.
    Elapsed: 00:00:00.01
    SCOTT @ jcave102 Local> commit;
    Commit complete.
    Elapsed: 00:00:00.00
    SCOTT @ jcave102 Local> insert into a values( 3 );
    1 row created.
    Elapsed: 00:00:00.04
    SCOTT @ jcave102 Local> commit;
    Commit complete.
    Elapsed: 00:00:00.01
    SCOTT @ jcave102 Local> select ora_rowscn, col1 from a;
    ORA_ROWSCN       COL1
       6270940          1
       6270940          2
       6270944          3
    Elapsed: 00:00:00.09Sorting on that, assuming you insert the rows in the right logical order, should work (the documentation only guarantees that the SCN of the row is greater than or equal to the SCN when a row was modified, so it's not guaranteed, but I don't know of a mechanism that would cause the ORA_ROWSCN to change without DML affecting the row in this example so it's relatively safe, at least with your current Oracle version). If ROWDEPENDENCIES is not set, the default is that the SCN is tracked at the block rather than the row level.
    Justin

  • Need help with simple BPM scenario

    2 places.
    1. SXMB_MONI
    2. CC Monitor

    Hi...
      Check the receiver communciation channel is correctly configured. Check in the SMQ2 and refresh it and also refresh the cahce.
    Regards,
    Leela

  • Need help with saving data and keeping table history for one BP

    Hi all
    I need help with this one ,
    Scenario:
    When adding a new vendor on the system the vendor is suppose to have a tax clearance certificate and it has an expiry date, so after the certificate has expired a new one is submitted by the vendor.
    So i need to know how to have SBO fullfil this requirement ?
    Hope it's clear .
    Thanks
    Bongani

    Hi
    I don't have a problem with the query that I know I've got to write , the problem is saving the tax clearance certificate and along side it , its the expiry date.
    I'm using South African localization.
    Thanks

  • Project Server 2013: I am using Project Server Permission Mode and need help with permission assignments?

    Hi 
    Project Server 2013: I am using Project Server Permission Mode and need help with permission assignments?
    How can I change Permissions for the individual users to see specific projects or all projects in project center and to see specific quick launch items?
    For Example: if i have 4 users, A, B, C and D. what i want is:
    User A can see everything and act as a project manager or Admin.
    User B can view all projects in project centre but can change the schedule or resource assignment etc.
    User C can only act as approver of projects and can view all projects in project centre.
    User D can only view specific projects for which permissions are given.
    can i have some expert help in sorting and understanding permission modes... as i was playing with project server mode permissions and can't figure out how to apply the above scenario to set of my user.
    Thanks in Advance
    Cheers
    AJ
    Ajay Kumar

    Hi Ajay,
    Please refer to this link for detailed explanations about PS2013 security model. 
    http://technet.microsoft.com/en-us/library/cc197638(v=office.15).aspx
    Actually, it will take a couple of days to explain in detail the security model that is a fundamental and tricky aspect of every PS implementation. But basically, you NEVER set permissions for a single user. You have groups in which your insert users. Groups
    define "what users can do". Then you associate groups to a corresponding category. Categories define "what user can see". Thus the association of a group with a category will set "what the user can do on the objects he can see". Then, for more advanced security
    level, you can use the RBS that will consist in "branches" in which you'll insert users. Based on those branches, you'll customize categories to fine-tune what user can see (for projects and resources) depending on the RBS branch and level.
    I'd advice you to start "playing" in a test environment with the default categories/groups that might probably cover your need.
    Concerning your 4 users:
    user A : add him to the "administrator" group. Be careful that you're mentionning either project manager or administrator, which are 2 groups/categories with totally different permissions level.
    user B : basically can see everything and change everything? it could be in the project manager group, assuming that there are no project visibility restrictions on the category via the RBS.
    user C : waht do you mean by "approver"? Workflow approvals? Then it will be the portfolio manager group. Task update or timesheet approval? Then it is another long topic: please refer in the documentation to the "status manager" and "timesheet manager"
    concepts. There are not related to the security model. In a few words, the status manager is the owner of the project plan, is defined for each task and approves tasks updates. The timesheet manager is an attribute defined for each resource in its parameters
    and approves resource timesheet.
    user D : you have to define which permission level must be given to this user. Basically it could be a team member that will see only projects he's in the project team. Note that team member cannot interact with the project plan in another way than submitting
    timesheets and/or tasks updates which must be approved.
    Once more, those are large and complex subjects that require a deep dive into your business model and tons of tests in a test environment.
    Hope this helps.
    Guillaume Rouyre - MBA, MCP, MCTS

  • ISM with NAT44 - Need help with configuration

    Hello everyone,
    I'm trying to set up NAT44 in the following scenario below and I'm having a hard time figuring out how to redirect the traffic. As you can see the big problem is that I have one single interface that connects to the internal network (10.0.0.0/8) and also to the tunnel destinations all in the same VRF. Can you guys give me a hand? The trafiic comes from network network 10.0.0.0/8 enters interface bundle-ether 2 (Now it needs to be translated), once it is translated, now it needs to reach the destination known via GRE tunnel.
    Configurations
    vrf NAT_IN
    address-family ipv4 unicast
    vrf BLUE
    address-family ipv4 unicast
    hw-module service cgn location 0/3/CPU0
    interface Bundle-Ether2
    description UPLINK TO METRO ETHERNET
    interface Bundle-Ether2.2 l2transport
    encapsulation dot1q 2
    rewrite ingress tag pop 1 symmetric
    interface GigabitEthernet200/0/0/43
    description LINK TO METRO ETHERNET
    bundle id 2 mode active
    interface GigabitEthernet300/0/0/43
    description LINK TO METRO ETHERNET
    bundle id 2 mode active
    interface BVI2
    description METRO
    vrf BLUE
    ipv4 address 100.0.0.10/24
    interface tunnel-ip 101
    description GRE_TUNNEL
    vrf BLUE
    ipv4 address 1.1.1.1/32
    tunnel mode gre ipv4
    tunnel source interface bvi 2
    tunnel destination 200.0.0.1
    interface BVI 100
    vrf BLUE
    ipv4 address [GATEWAY_100] [MASK_100]
    interface BVI 200
    vrf BLUE
    ipv4 address [GATEWAY_200] [MASK_200]
    interface BVI 300
    vrf BLUE
    ipv4 address [GATEWAY_300] [MASK_300]
    interface ServiceApp1
    vrf NAT_IN
    ipv4 address 10.0.2.1 255.255.255.252
    service cgn CGN service-type nat44
    interface ServiceApp2
    vrf BLUE
    ipv4 address 10.0.2.2 255.255.255.252
    service cgn CGN service-type nat44
    interface ServiceInfra1
    ipv4 address 10.0.3.1 255.255.255.0
    service-location 0/3/CPU0
    router static
    address-family ipv4 unicast
    vrf NAT_IN
    address-family ipv4 unicast
    0.0.0.0/0 ServiceApp1
    10.0.0.0/8 vrf BLUE bvI 2 <NEXT HOP>
    vrf BLUE
    address-family ipv4 unicast
    172.16.0.0/24 ServiceApp2
    router ospf METRO
    vrf BLUE
    router-id [ROUTER_ID]
    redistribute bgp 65500 metric 100
    area 0
    interface bvi 2
    router ospf BLUE
    vrf BLUE
    router-id [ROUTER ID]
    redistribute bgp 65500 metric 100
    area 10
    interface BVI100
    interface BVI200
    interface BVI200
    router bgp 65500
    address-family ipv4 unicast
    address-family vpnv4 unicast
    vrf BLUE
    rd 65500:2
    address-family ipv4 unicast
    redistribute static
    redistribute ospf BLUE
    neighbor 1.1.1.2
    remote-as 64512
    ebgp-multihop 5
    address-family ipv4 unicast
    route-policy PASS in
    route-policy PASS out
    service cgn CGN
    service-location preferred-active 0/3/CPU0
    service-type nat44 nat44
    portlimit 20000
    inside-vrf NAT_IN
    map outside-vrf BLUE address-pool 172.16.0.0/24
    Thanks in advance,
    Renato

    Hi Somnath,
    Let's see if you can help with this new scenario. I want to extend this NAT configuration to a new site (BO1), but instead of using this entire setup with ASR9K, etc, I just want to use ASR9000v module and have this AS9K + ISM as the host. The first problem I see in this scenario is that I have the same 10.0.0.0/8 network in both sites, network which will access the same resources as the devices in the 10.0.0.0/8 in the main site.
    1) Do you think if I create a new inside VRF [NAT_IN1] would address this issue?
    2) Can I use the same outside VRF?
    Here is the configurations.
    !! IOS XR Configuration 4.3.1
    vrf NAT_IN
    address-family ipv4 unicast
      import route-target
       65500:2
       65500:3
      export route-target
       65500:3
    vrf RED
    address-family ipv4 unicast
      import route-target
       65500:1
      export route-target
       65500:1
    vrf NAT_OUT
    address-family ipv4 unicast
      import route-target
       65500:4
      export route-target
       65500:4
    vrf SATELLITE
    vrf BLUE
    address-family ipv4 unicast
      import route-target
       65500:2
      export route-target
       65500:2
    hw-module service cgn location 0/3/CPU0
    ipv4 access-list ABF
    5 permit ospf any any
    10 permit ipv4 any 10.200.0.0 0.0.255.255 nexthop1 vrf NAT_IN ipv4 10.0.2.2
    20 permit icmp any any
    interface Bundle-Ether3
    description Uplink (BE3 - VRF NAT_IN) - VLAN 20
    vrf NAT_IN
    ipv4 address 1.1.1.1 255.255.255.0
    ipv4 access-group ABF ingress
    interface Bundle-Ether22
    description LOOPBACK CABLE NAT_OUT
    vrf NAT_OUT
    ipv4 address 10.0.1.1 255.255.255.0
    interface Bundle-Ether23
    description LOOPBACK CABLE BLUE
    vrf BLUE
    ipv4 address 10.0.1.2 255.255.255.0
    interface 6
    description Uplink  (BE6 - Global) - VLAN 20,51,80-82
    interface 6.2
    ipv4 address 1.1.1.2 255.255.255.0
    encapsulation dot1q 2
    interface 6.51 l2transport
    description EFP - BE6 - VLAN 51
    encapsulation dot1q 51
    rewrite ingress tag pop 1 symmetric
    interface 6.80 l2transport
    description EFP - BE6 - VLAN 80
    encapsulation dot1q 80
    rewrite ingress tag pop 1 symmetric
    interface 6.81 l2transport
    description EFP - BE6 - VLAN 81
    encapsulation dot1q 81
    rewrite ingress tag pop 1 symmetric
    interface 6.82 l2transport
    description EFP - BE6 - VLAN 82
    encapsulation dot1q 82
    rewrite ingress tag pop 1 symmetric
    interface Bundle-Ether100
    description Bundle to Satellite 100
    vrf SATELLITE
    ipv4 point-to-point
    ipv4 unnumbered Loopback0
    nv
      satellite-fabric-link satellite 100
       remote-ports GigabitEthernet 0/0/0-43
    interface Bundle-Ether200
    description Bundle to Satellite 200
    vrf SATELLITE
    ipv4 point-to-point
    ipv4 unnumbered Loopback0
    nv
      satellite-fabric-link satellite 200
       remote-ports GigabitEthernet 0/0/0-43
    interface Bundle-Ether300
    description Bundle to Satellite 300
    vrf SATELLITE
    ipv4 point-to-point
    ipv4 unnumbered Loopback0
    nv
      satellite-fabric-link satellite 300
       remote-ports GigabitEthernet 0/0/0-35
    interface Loopback0
    description MGMT SATELLITE
    vrf SATELLITE
    ipv4 address 10.0.0.254 255.255.255.0
    interface tunnel-ip31101
    description BLUE-TUNNEL01
    vrf BLUE
    ipv4 address 10.200.253.90 255.255.255.252
    tunnel mode gre ipv4
    tunnel source 6.2
    tunnel destination 13.13.13.13
    interface tunnel-ip31102
    description BLUE-TUNNEL02
    vrf BLUE
    ipv4 address 10.200.253.94 255.255.255.252
    tunnel mode gre ipv4
    tunnel source 6.2
    tunnel destination 14.14.14.14
    interface tunnel-ip31103
    description RED-TUNNEL03
    vrf RED
    ipv4 address 10.200.253.90 255.255.255.252
    tunnel mode gre ipv4
    tunnel source 6.2
    tunnel destination 13.13.13.13
    interface tunnel-ip31104
    description RED-TUNNEL04
    vrf RED
    ipv4 address 10.200.253.94 255.255.255.252
    tunnel mode gre ipv4
    tunnel source 6.2
    tunnel destination 14.14.14.14
    interface TenGigE0/0/0/0
    description LINK TO SATELLITE 100
    bundle id 100 mode on
    interface TenGigE0/0/0/1
    description LINK TO SATELLITE 100
    bundle id 100 mode on
    interface TenGigE0/0/0/2
    description LINK TO SATELLITE 200
    bundle id 200 mode on
    interface TenGigE0/0/0/3
    description LINK TO SATELLITE 200
    bundle id 200 mode on
    interface TenGigE0/0/0/4
    description LINK TO SATELLITE 300
    vrf SATELLITE
    ipv4 point-to-point
    ipv4 unnumbered Loopback0
    nv
      satellite-fabric-link satellite 300
       remote-ports GigabitEthernet 0/0/36-43
    interface TenGigE0/0/0/5
    description LINK TO SATELLITE 300
    bundle id 300 mode on
    interface TenGigE0/0/0/16
    description UPLINK  (BE6 - GLOBAL) - VLAN 20,51,80-82
    bundle id 6 mode active
    interface TenGigE0/1/0/16
    description UPLINK  (BE6 - GLOBAL) - VLAN 20,51,80-82
    bundle id 6 mode active
    interface TenGigE0/0/0/17
    description UPLINK  (BE3 - VRF NAT_IN) - VLAN 20
    bundle id 3 mode active
    interface TenGigE0/1/0/17
    description UPLINK  (BE3 - VRF NAT_IN) - VLAN 20
    bundle id 3 mode active
    interface TenGigE0/0/0/22
    description LOOPBACK CABLE TE0/1/0/22
    bundle id 22 mode on
    interface TenGigE0/0/0/23
    description LOOPBACK CABLE TE0/1/0/23
    bundle id 22 mode on
    interface TenGigE0/1/0/0
    description LINK TO SATELLITE 100
    bundle id 100 mode on
    interface TenGigE0/1/0/1
    description LINK TO SATELLITE 100
    bundle id 100 mode on
    interface TenGigE0/1/0/2
    description LINK TO SATELLITE 200
    bundle id 200 mode on
    interface TenGigE0/1/0/3
    description LINK TO SATELLITE 200
    bundle id 200 mode on
    interface TenGigE0/1/0/4
    description LINK TO SATELLITE 300
    bundle id 300 mode on
    interface TenGigE0/1/0/5
    description LINK TO SATELLITE 300
    bundle id 300 mode on
    interface TenGigE0/1/0/22
    description LOOPBACK CABLE TE0/0/0/22
    bundle id 23 mode on
    interface TenGigE0/1/0/23
    description LOOPBACK CABLE TE0/0/0/23
    bundle id 23 mode on
    interface BVI30
    vrf RED
    ipv4 address 10.200.25.193 255.255.255.192
    interface BVI31
    vrf BLUE
    ipv4 address 10.200.1.1 255.255.255.248
    interface BVI32
    vrf BLUE
    ipv4 address 10.200.25.129 255.255.255.224
    interface BVI33
    vrf BLUE
    ipv4 address 10.200.25.1 255.255.255.128
    interface BVI36
    vrf BLUE
    ipv4 address 10.200.237.145 255.255.255.240
    interface BVI51
    vrf RED
    ipv4 address 192.168.7.12 255.255.255.0
    interface BVI80
    vrf RED
    ipv4 address 10.200.26.169 255.255.255.224
    interface BVI81
    vrf BLUE
    ipv4 address 10.200.25.164 255.255.255.240
    interface BVI82
    vrf BLUE
    ipv4 address 10.200.25.180 255.255.255.240
    interface ServiceApp1
    description NAT_IN
    vrf NAT_IN
    ipv4 address 10.0.2.1 255.255.255.252
    service cgn CGN service-type nat44
    interface ServiceApp2
    description NAT_OUT
    vrf NAT_OUT
    ipv4 address 10.0.2.5 255.255.255.252
    service cgn CGN service-type nat44
    interface ServiceInfra1
    description ISM
    ipv4 address 10.0.3.1 255.255.255.0
    service-location 0/3/CPU0
    prefix-set PS_ROUTES
      10.200.0.8,
      10.200.5.40/29,
      10.200.1.0/29,
      10.200.5.32/29,
      10.200.0.144/28,
      10.200.106.0/28,
      10.200.106.16/28
    end-set
    prefix-set PS_BGP_BLUE_OUT
      10.200.24.192/26,
      10.200.5.40/29,
      10.200.240.0/25,
      10.200.1.0/29,
      10.200.25.128/27,
      10.200.25.0/25,
      10.200.5.32/29,
      10.200.26.0/25,
      10.200.0.144/28,
      10.200.27.128/27,
      10.200.27.0/25,
      10.200.106.0/28,
      10.200.106.128/25,
      10.200.106.16/28,
      10.200.107.128/25
    end-set
    route-policy RP_DENY_ALL
      drop
    end-policy
    route-policy RP_PASS_ALL
      pass
    end-policy
    route-policy RP_BGP_BLUE_OUT
      if destination in PS_BGP_BLUE_OUT then
        pass
      endif
    end-policy
    route-policy RP_PASS_ROUTES
      if destination in PS_ROUTES then
        pass
      endif
    end-policy
    router static
    address-family ipv4 unicast
      0.0.0.0/0 1.1.1.20
    vrf NAT_IN
      address-family ipv4 unicast
       0.0.0.0/0 ServiceApp1
    vrf RED
    vrf NAT_OUT
      address-family ipv4 unicast
       0.0.0.0/0 10.0.1.2
       10.200.24.192/26 ServiceApp2
    vrf BLUE
      address-family ipv4 unicast
       10.200.24.192/26 10.0.1.1
    router ospf
    log adjacency changes
    vrf NAT_IN
      router-id 1.1.1.1
      disable-dn-bit-check
      redistribute bgp 65500 metric 5 metric-type 2 route-policy RP_PASS_ROUTES
      area 7
       interface Bundle-Ether3
    router ospf RED
    log adjacency changes
    vrf RED
      router-id 10.200.26.169
      disable-dn-bit-check
      redistribute bgp 65500 metric 10 metric-type 2
      area 11
       interface BVI30
       interface BVI80
    router ospf BLUE
    log adjacency changes
    vrf BLUE
      router-id 10.200.25.164
      disable-dn-bit-check
      redistribute static
      redistribute bgp 65500 metric 10 metric-type 2
      area 0
       interface BVI81
       interface BVI82
      area 2
       interface BVI31
       interface BVI32
       interface BVI33
       interface BVI36
    router bgp 65500
    address-family ipv4 unicast
    address-family vpnv4 unicast
    vrf NAT_IN
      rd 65500:3
      bgp router-id 1.1.1.1
      address-family ipv4 unicast
       route-target download
    vrf RED
      rd 65500:1
      bgp router-id 10.200.253.90
      address-family ipv4 unicast
       network 10.200.25.192/26
       network 10.200.26.128/27
       network 10.200.26.192/27
       network 10.200.27.192/26
       network 10.200.104.128/27
       network 10.200.104.160/27
      neighbor 10.200.253.89
       remote-as 64512
       ebgp-multihop 5
       update-source tunnel-ip31103
       address-family ipv4 unicast
        route-policy RP_PASS_ALL in
        route-policy RP_PASS_ALL out
        soft-reconfiguration inbound
      neighbor 10.200.253.93
       remote-as 64512
       ebgp-multihop 5
       update-source tunnel-ip31104
       address-family ipv4 unicast
        route-policy RP_PASS_ALL in
        route-policy RP_PASS_ALL out
        soft-reconfiguration inbound
    vrf BLUE
      rd 65500:2
      bgp router-id 10.200.253.90
      address-family ipv4 unicast
       network 10.200.0.144/28
       network 10.200.1.0/29
       network 10.200.5.32/29
       network 10.200.5.40/29
       network 10.200.24.192/26
       network 10.200.25.0/25
       network 10.200.25.128/27
       network 10.200.26.0/25
       network 10.200.27.0/25
       network 10.200.27.128/27
       network 10.200.106.0/28
       network 10.200.106.16/28
       network 10.200.106.128/25
       network 10.200.107.128/25
       network 10.200.240.0/25
      neighbor 10.200.253.89
       remote-as 64512
       ebgp-multihop 5
       update-source tunnel-ip31101
       address-family ipv4 unicast
        route-policy RP_PASS_ALL in
        route-policy RP_BGP_BLUE_OUT out
        soft-reconfiguration inbound
      neighbor 10.200.253.93
       remote-as 64512
       ebgp-multihop 5
       update-source tunnel-ip31102
       address-family ipv4 unicast
        route-policy RP_PASS_ALL in
        route-policy RP_BGP_BLUE_OUT out
        soft-reconfiguration inbound
    l2vpn
    load-balancing flow src-dst-ip
    bridge group VLAN30
      bridge-domain VLAN30
       routed interface BVI30
    bridge group VLAN31
      bridge-domain VLAN31
       routed interface BVI31
    bridge group VLAN32
      bridge-domain VLAN32
       routed interface BVI32
    bridge group VLAN33
      bridge-domain VLAN33
       routed interface BVI33
    bridge group VLAN36
      bridge-domain VLAN36
       routed interface BVI36
    bridge group VLAN51
      bridge-domain VLAN51
       routed interface BVI51
    bridge group VLAN80
      bridge-domain VLAN80
       interface 6.80
       routed interface BVI80
    bridge group VLAN81
      bridge-domain VLAN81
       interface 6.81
       routed interface BVI81
    bridge group VLAN82
      bridge-domain VLAN82
       interface 6.82
       routed interface BVI82
    nv
    satellite 100
      type asr9000v
      ipv4 address 10.0.0.1
    satellite 200
      type asr9000v
      ipv4 address 10.0.0.2
    satellite 300
      type asr9000v
      ipv4 address 10.0.0.3
    service cgn CGN
    service-location preferred-active 0/3/CPU0
    service-type nat44 nat44
      portlimit 20000
      inside-vrf NAT_IN
       map outside-vrf NAT_OUT address-pool 10.200.24.192/26
    Thanks in advance,
    Renato

  • Need help with a currently "in-use" form we want to switch to Adobes hosting service

    Hi, I am in desperate need of help with some issues concerning several forms which we currently use a paid third party (not Adobe) to host and "re-distribute through email"...Somehow I got charged $14.95 for YOUR service, (signed up for a trial, but never used it)..and now I am paying for a year of use of the similar service which Adobe is in control of.  I might want to port my form distribution through Adobe in the hopes of reducing the errors, problems and hassles my customers are experiencing when some of them push our  "submit button". (and I guess I am familiar with these somewhat from reading what IS available in here, and I also know that, Adobe is working to alleviate some of these " submit"  issues, so let's don't start by going backwards, here) I need solutions now for my issues or I can leave it as is, If Adobe's solution will be no better for my end users...
    We used FormsCentral to code these forms and it works for the most part (if the end-user can co-operate, and thats iffy, sometimes), but I need help with how to make it go through your servers (and not the third party folks we use now), Not being cruel or racist here, but your over the phone "support techs" are about horrible & I cannot understand them or work with any of them, so I would definitely need someone who speaks English and can understand the nuances of programming these forms, to please contact me back. (Sorry, but both those attributes will be required to be able to help me, so, no "newbie-interns" or first week trainees are gonna cut it).... If you have anyone who fits the bill on those items and would be willing to help us, please contact me back at your earliest convenience. If we have to communicate here, I will do that & I can submit whatever we need to & to whoever we need to.
    I need to get this right and working for the majority of my users and on any platform and OS.
    You may certainly call me to talk about this, and I have given my number numerous times to your (expletive deleted) time wasting - recording message thingy. So, If it's not available look it up under [email protected]
    (and you will probably get right to me, unlike my and I'm sure most other folks',  "Adobe phone-in experiences")
    Thank You,
    Michael Corman
    VinylCouture
    Phenix City, Alabama  36869

    Well, thanks for writing back...just so you know...I started using Adobe products in 1987, ...yeah...back then...like Illustrator 1 & 9" B&W Macs ...John Warnock's Helvetica's....stuff like that...8.5 x 11 LaserWriters...all that good stuff...I still have some of it working on a mac...much of it was stuff I bought. some stuff I did not...I'm not a big fan of this "cloud" thing Adobe has foisted upon the creatives of the world...which I'm sure you can tell...but the functionality and usefulness of your software can not be disputed, so feel free to do whatever we will continue to pay for, ...I am very impressed with CC PS on the 64 bit PC and perhaps I will end up paying you the stipend that you demand for the other services.
    So  I guess that brings us to our problem.. a few years back and at the height of the recession and near bankruptcy myself,  I was damn lucky and hit on something and began a small arts and crafts supply service to sell my products online to a very "niche market" ...I had a unique product and still sell that product (plus others) online...My website is www.vinylcouture.com...Strange? Yes...but there is a market it seems, for everything now, and this is the market I service...Catagorically, these are 99%+ women that use these "adhesive, sticky backed vinyl products"  to make different "craft items" that are just way too various and numerous to go into... generally older women, women who are computer illiterate for the most part...and all this is irrelevant to my problem, but I want you to have every bit of background on this and especially the demographic we are dealing with, so we can get right to the meat of the problem.
    OK...So about two years ago, I decided to offer a "plain sheet" product of a plain colored "stick back" vinyl... it is available in multiple quantities of packs ( like 5 pieces, 10 pieces, 15 pieces, in a packi  & so on)...and if you are still on my site.. go to any  "GO RIGHT TO OUR ORDER PAGE"  button, scroll down a little...and then to the "PLAIN VINYL" section...you will see the Weebly website order process.) You can back out from here, I think,..but, anyway this product is available in 63 colors + or - a few. So then the problem is,  how do they select their individual colors within that (whatever) pack?... .
    So my initial idea was to enable a "selection form" for these "colors" that would be transmitted to me via email as 'part" of the "order process".. We tried getting our customers to submit a  " a list" ( something my competitiors still do, lol, poor bastards)......but that..is just unbelievable..I can't even begin to tell you what a freakin' nightmare that was...these people cannot even count to 10, much less any higher... figuring out what colors to list and send me... well, lets just say, it wasn't working......I had to figure out a better way...Something had to be done.
    So after thinking this all out,  and yeah...due to my total ignorance, i figured that we could make a form with Live Cycle Designer (Now Forms Central)...(back then something that was bundled with Adobe Acrobat Pro), I believe, and thats what this thing was authored in... and it would be all good...LOL!
    Well not so simple...as you well know, Adobe Acrobat would NOT LET YOU EMAIL anything from itself.....it just wouldn't work (and I know why, and all that hooey), but not being one to take NO for answer,.I started looking for a way to make my little gizmo work.. So I found this company that said they can "hijack" (re-direct actually) the request to email, bypass the wah-wah, and re-transmit it to the proper parties.....for less than $100 a year,  I think...its called http://pdf-fillableforms.com/.
    A nice gentleman named Joseph Silva helped us program the thing to go to his servers and back out. Please dont hassle them...I need them...for now..it basically does work...try it...you should get back a copy of the form that you filled out...good luck however,  if you're on MAC OSX or similar...
    I have included a copy of both of our forms (and feel free to fill it out and play with it)...just put test somewhere on it...(and you must include YOUR email or it will balk)..they are supposed to be mostly identical, except one seems to be twice as large....generating a 1.7 meg file upon submission, while the other one only generates a 600K file or so...thats another issue for another day or maybe you can advise on that also...
    OK so far so good......In our shop, once Grandma buys a 10 pack (or whatever), Only then she gets to the link on her receipt page ro the relevant "selection form" ,(this prevents "Filling and Sending"  with "no order" and "no payment", another early problem we had)... which they can click on and it will usually download and open up on their device if all goes well...Then our little form is supposed to be fillable and is supposed to ADD UP all the quantities, so grandma knows how many she is buying and so forth right on the fly,  and even while she changes her mind..., and IT'S LARGE so grandma can see it, and then it TOTALS it all up for them, ( cause remember, they can NOT add)..,  except there is a programming bug (mouse-click should be a mouse-up probably or something..) which makes you click in the blank spaces to get to a correct TOTAL...about 70-80% of our customers can enable all these features and usually the process completes without problems for them especially on PC's running Windows OS and Acrobat Reader X or XI...at least for most... Unfortunately it is still not the "seamless process" I would like or had envisioned for the other folks out there that do have trouble using our form....  Many folks report to us the following issues that we know of.  First of all it takes too much time to load up...We know its HUGE...is there anyway that you can see, to streamline this thing? I would love for it to be more compact...this really helps on the phones and pads as I'm sure you well know.
    Some just tell us,"it WON'T work"....I believe this is because they are totally out of it and dont even have Adobe Reader on their machine, & don't know how to get it ( yes, we provide the links).....or it's some ancient version....no one can stop this one...
    It almost always generates some kind ( at least one time)  of "error message" which we do warn them about..., telling one,  basically that "Acrobat doesnt even like this happening at all, and it could be detrimental to ones computer files", blah-blah...(this freaks grandma out really bad)...& usually they end up not even trying to send it...  and then I get calls that even you wouldn't believe...& If they DO nut up and push the Red "Submit Form" button, it will usually send the thing to us (and also back to them at the "required email address" they furnished on the form, thats what the folks at the "fillable forms place" do) so, if it's performing it's functions, why it is having to complain?. What are we doing wrong?....and how can I fix it?...Will re-compiling it or saving it as a newer version of "FormsCentral" correct any of these problems ?
    Ok, so that should keep you busy for a minute and we can start out with those problems...but the next thing is, how can I take advantage of YOUR re-direct & hosting services?, And will it get rid of the error messages, and the slowness, and the iOS incompatibilities ? (amazingly,  the last iOS Reader version worked almost OK.. but the newest version doesnt seem to work with my form on my iphone4)  If it will enable any version of the iOS to send my form correctly and more transparently, then it might be worth the money...$14.95 a MONTH you say. hmmmmm...Better be good.
    Another problem is, that I really don't need 5000 forms a month submitted. I think its like 70-100 or less....Got any plans for that?  Maybe I'm just not BIG ENOUGH to use Adobe's services, however in this case, I really don't care whose I do use as long as the product works most correctly for my customers as well as us. Like I said, If I'm doing the best I can, I won't change anything, and still use the other third party, If Adobe has a better solution, then i'm all for that as well. In the meantime, Thanks for any help you can provide on this...
    Michael Corman
    VinylCouture.com
    (706) 326-7911

  • Need help with JTextArea and Scrolling

    import java.awt.*;
    import java.awt.event.*;
    import java.text.DecimalFormat;
    import javax.swing.*;
    public class MORT_RETRY extends JFrame implements ActionListener
    private JPanel keypad;
    private JPanel buttons;
    private JTextField lcdLoanAmt;
    private JTextField lcdInterestRate;
    private JTextField lcdTerm;
    private JTextField lcdMonthlyPmt;
    private JTextArea displayArea;
    private JButton CalculateBtn;
    private JButton ClrBtn;
    private JButton CloseBtn;
    private JButton Amortize;
    private JScrollPane scroll;
    private DecimalFormat calcPattern = new DecimalFormat("$###,###.00");
    private String[] rateTerm = {"", "7years @ 5.35%", "15years @ 5.5%", "30years @ 5.75%"};
    private JComboBox rateTermList;
    double interest[] = {5.35, 5.5, 5.75};
    int term[] = {7, 15, 30};
    double balance, interestAmt, monthlyInterest, monthlyPayment, monPmtInt, monPmtPrin;
    int termInMonths, month, termLoop, monthLoop;
    public MORT_RETRY()
    Container pane = getContentPane();
    lcdLoanAmt = new JTextField();
    lcdMonthlyPmt = new JTextField();
    displayArea = new JTextArea();//DEFINE COMBOBOX AND SCROLL
    rateTermList = new JComboBox(rateTerm);
    scroll = new JScrollPane(displayArea);
    scroll.setSize(600,170);
    scroll.setLocation(150,270);//DEFINE BUTTONS
    CalculateBtn = new JButton("Calculate");
    ClrBtn = new JButton("Clear Fields");
    CloseBtn = new JButton("Close");
    Amortize = new JButton("Amortize");//DEFINE PANEL(S)
    keypad = new JPanel();
    buttons = new JPanel();//DEFINE KEYPAD PANEL LAYOUT
    keypad.setLayout(new GridLayout( 4, 2, 5, 5));//SET CONTROLS ON KEYPAD PANEL
    keypad.add(new JLabel("Loan Amount$ : "));
    keypad.add(lcdLoanAmt);
    keypad.add(new JLabel("Term of loan and Interest Rate: "));
    keypad.add(rateTermList);
    keypad.add(new JLabel("Monthly Payment : "));
    keypad.add(lcdMonthlyPmt);
    lcdMonthlyPmt.setEditable(false);
    keypad.add(new JLabel("Amortize Table:"));
    keypad.add(displayArea);
    displayArea.setEditable(false);//DEFINE BUTTONS PANEL LAYOUT
    buttons.setLayout(new GridLayout( 1, 3, 5, 5));//SET CONTROLS ON BUTTONS PANEL
    buttons.add(CalculateBtn);
    buttons.add(Amortize);
    buttons.add(ClrBtn);
    buttons.add(CloseBtn);//ADD ACTION LISTENER
    CalculateBtn.addActionListener(this);
    ClrBtn.addActionListener(this);
    CloseBtn.addActionListener(this);
    Amortize.addActionListener(this);
    rateTermList.addActionListener(this);//ADD PANELS
    pane.add(keypad, BorderLayout.NORTH);
    pane.add(buttons, BorderLayout.SOUTH);
    pane.add(scroll, BorderLayout.CENTER);
    addWindowListener( new WindowAdapter()
    public void windowClosing(WindowEvent e)
    System.exit(0);
    public void actionPerformed(ActionEvent e)
    String arg = lcdLoanAmt.getText();
    int combined = Integer.parseInt(arg);
    if (e.getSource() == CalculateBtn)
    try
    JOptionPane.showMessageDialog(null, "Got try here", "Error", JOptionPane.ERROR_MESSAGE);
    catch(NumberFormatException ev)
    JOptionPane.showMessageDialog(null, "Got here", "Error", JOptionPane.ERROR_MESSAGE);
    if ((e.getSource() == CalculateBtn) && (arg != null))
    try{
    if ((e.getSource() == CalculateBtn) && (rateTermList.getSelectedIndex() == 1))
    monthlyInterest = interest[0] / (12 * 100);
    termInMonths = term[0] * 12;
    monthlyPayment = combined * (monthlyInterest / (1 - (Math.pow (1 + monthlyInterest,  -termInMonths))));
    lcdMonthlyPmt.setText(calcPattern.format(monthlyPayment));
    if ((e.getSource() == CalculateBtn) && (rateTermList.getSelectedIndex() == 2))
    monthlyInterest = interest[1] / (12 * 100);
    termInMonths = term[1] * 12;
    monthlyPayment = combined * (monthlyInterest / (1 - (Math.pow (1 + monthlyInterest,  -termInMonths))));
    lcdMonthlyPmt.setText(calcPattern.format(monthlyPayment));
    if ((e.getSource() == CalculateBtn) && (rateTermList.getSelectedIndex() == 3))
    monthlyInterest = interest[2] / (12 * 100);
    termInMonths = term[2] * 12;
    monthlyPayment = combined * (monthlyInterest / (1 - (Math.pow (1 + monthlyInterest,  -termInMonths))));
    lcdMonthlyPmt.setText(calcPattern.format(monthlyPayment));
    catch(NumberFormatException ev)
    JOptionPane.showMessageDialog(null, "Invalid Entry!\nPlease Try Again", "Error", JOptionPane.ERROR_MESSAGE);
    }                    //IF STATEMENTS FOR AMORTIZATION
    if ((e.getSource() == Amortize) && (rateTermList.getSelectedIndex() == 1))
    loopy(7, 5.35);
    if ((e.getSource() == Amortize) && (rateTermList.getSelectedIndex() == 2))
    loopy(15, 5.5);
    if ((e.getSource() == Amortize) && (rateTermList.getSelectedIndex() == 3))
    loopy(30, 5.75);
    if (e.getSource() == ClrBtn)
    rateTermList.setSelectedIndex(0);
    lcdLoanAmt.setText(null);
    lcdMonthlyPmt.setText(null);
    displayArea.setText(null);
    if (e.getSource() == CloseBtn)
    System.exit(0);
    private void loopy(int lTerm,double lInterest)
    double total, monthly, monthlyrate, monthint, monthprin, balance, lastint, paid;
    int amount, months, termloop, monthloop;
    String lcd2 = lcdLoanAmt.getText();
    amount = Integer.parseInt(lcd2);
    termloop = 1;
    paid = 0.00;
    monthlyrate = lInterest / (12 * 100);
    months = lTerm * 12;
    monthly = amount *(monthlyrate/(1-Math.pow(1+monthlyrate,-months)));
    total = months * monthly;
    balance = amount;
    while (termloop <= lTerm)
    displayArea.setCaretPosition(0);
    displayArea.append("\n");
    displayArea.append("Year " + termloop + " of " + lTerm + ": payments\n");
    displayArea.append("\n");
    displayArea.append("Month\tMonthly\tPrinciple\tInterest\tBalance\n");
    monthloop = 1;
    while (monthloop <= 12)
    monthint = balance * monthlyrate;
    monthprin = monthly - monthint;
    balance -= monthprin;
    paid += monthly;
    displayArea.setCaretPosition(0);
    displayArea.append(monthloop + "\t" + calcPattern.format(monthly) + "\t" + calcPattern.format(monthprin) + "\t");
    displayArea.append(calcPattern.format(monthint) + "\t" + calcPattern.format(balance) + "\n");
    monthloop ++;
    termloop ++;
    public static void main(String args[])
    MORT_RETRY f = new MORT_RETRY();
    f.setTitle("MORTGAGE PAYMENT CALCULATOR");
    f.setBounds(600, 600, 500, 500);
    f.setLocationRelativeTo(null);
    f.setVisible(true);
    }need help with displaying the textarea correctly and the scroll bar please.
    Message was edited by:
    new2this2020

    What's the problem you're having ???
    PS.

  • Need help with trim and null function

    Hi all,
    I need help with a query. I use the trim function to get the first three characters of a string. How do I write my query so if a null value occurs in combination with my trim to say 'Null' in my results?
    Thanks

    Hi,
    Thanks for the reply. What am I doing wrong?
    SELECT trim(SUBSTR(AL1.user_data_text,1,3)),NVL
    (AL1.user_data_text,'XX')
    FROM Table
    I want the XX to appear in the same column as the
    trim.The main thing you're doing wrong is not formatting your code. The solution may become obvious if you do.
    What you're saying is:
    SELECT  trim ( SUBSTR (AL1.user_data_text, 1, 3))
    ,       NVL ( AL1.user_data_text, 'XX' )
    FROM    Tablewhich makes it clear that you're SELECTing two columns, when you only want to have one.
    If you want that column to be exactly like the first column you're currently SELECTing, except that when that column is NULL you want it to be 'XX', then you have to apply NVL to that column, like this:
    SELECT  NVL ( trim ( SUBSTR (AL1.user_data_text, 1, 3))
                , 'XX'
    FROM    Table

  • I need help with resetting my ichat. When i try to login now it wont let me... it says "AOL Instant Messenger password" and then "iChat can't log in to ... because your login ID or password is incorrect. How do I reset this if I cant log in?

    I need help with resetting my ichat. When i try to login now it wont let me... it says "AOL Instant Messenger password" and then "iChat can't log in to ... because your login ID or password is incorrect. How do I reset this if I cant log in? When I try to press online the same thing pops up and I have no way of logging in or asking for help.

    Hi,
    iChat (it would help to know which version) can accept Apple IDs as valid AIM Screen Names.
    However if you have iChat 5 or earlier you cannot use ones ending in @me.com or @icloud.com issued by iCloud. (they can be used in iChat 6 or Messages as these versions make a double login to AIM and Apple to allow the use of the password).
    In addition if you are using an Apple ID for an AIM Screen Name the password still needs to keep to the 16 character limit that AIM has.
    AN @mac.com name can be used on any version of iChat  (Until the 30th June 2014)
    As it does not need a double check with Apple you can use it to log in to the AIM Web pages
    Login here with an AIM Name registered at AIM or and @mac.com name and see if you get any suspended account messages.
    Sometimes account can be suspended. Usually because something has triggered the "Unusual Activity" item.
    About a year ago many @mac.com users that travelled out of their own country found themselves suspended when they got home.
    If the Name checks out of if an Apple ID the password in known to be 16 characters or Less then do this:-
    In Lion upwards open a Finder Window and use the Go Menu whilst holding down the ALT key.
    Select the Library that appears in the menu list.
    Navigate to Preferences.
    (If you have version earlier than Lion the just navigate to ~/Library/Preferences (that's the Library in you Home - Little House icon - folder)
    Fnd com.apple.ichat.aim.plist (even if you are using Messages)
    Drag the file to the Trash and Restart the app.
    7:39 pm      Thursday; May 29, 2014
    ​  iMac 2.5Ghz i5 2011 (Mavericks 10.9)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

  • Need help with Airport Express and so on.

    Ok so my main problem before getting into what I need help with here is that our MacBooks and now my iPhone 6 plus isn't staying online. Keep getting booted off and then I either have to select the network again or it will eventually go back on. If anyone has a solution or so please feel free to answer that as well. I'm running on Roadrunner with a Netgear 600 wireless router and a motorola modem. Both of which I'll leave the link to below for a better look.
    My Main Question: So I'm looking at a new wireless router mainly and possibly a new modem. I know Apple products are trustworthy but how good is the Airport Express and other Airport products. Also what is the Maximum speed and Maximum data speed for the cheapest express station and if anyone knows the speeds of the other devices it would be greatly appreciated.

    DSL Router to Netgear 5-port Switch and I used the switch to connect to Airport Extreme, TV, Blue-Ray DVD player and DirecTV Receiver.
    The AirPort Extreme base station (AEBS) is a router so it will do what you need.
    You need to reconfigure your setup. Connect the WAN port of the AEBS to the DSL router. Then connect the Netgear switch to one of the LAN ports on the AEBS. The AEBS will properly share the connection.

  • I need help with shooting in my flash game for University

    Hi there
    Ive tried to make my tank in my game shoot, all the code that is there works but when i push space to shoot which is my shooting key it does not shoot I really need help with this and I would appriciate anyone that could help
    listed below should be the correct code
    //checking if the space bar is pressed and shooting is allowed
    if(evt.keyCode == 32 && shootAllow){
        //making it so the user can't shoot for a bit
        shootAllow = false;
        //declaring a variable to be a new Bullet
        var newBullet:Bullet = new Bullet();
        //changing the bullet's coordinates
        newBullet.y = tank_mc.y + tank_mc.width/2 - newBullet.width/2;
        newBullet.x = tank_mc.x;
        //then we add the bullet to stage
        addChild(newBullet);
    listed below is my entire code
    import flash.display.MovieClip;
        //declare varibles to create mines
    //how much time before allowed to shoot again
    var cTime:int = 0;
    //the time it has to reach in order to be allowed to shoot (in frames)
    var cLimit:int = 12;
    //whether or not the user is allowed to shoot
    var shootAllow:Boolean = true;
    var minesInGame:uint;
    var mineMaker:Timer;
    var cursor:MovieClip;
    var index:int=0;
    var tankMine_mc:MovieClip;
    var antiTankmine_mc:MovieClip;
    var maxHP:int = 100;
    var currentHP:int = maxHP;
    var percentHP:Number = currentHP / maxHP;
    function initialiseMine():void
        minesInGame = 15;
        //create a timer fires every second
        mineMaker = new Timer(6000, minesInGame);
        //tell timer to listen for Timer event
        mineMaker.addEventListener(TimerEvent.TIMER, createMine);
        //start the timer
        mineMaker.start();
    function createMine(event:TimerEvent):void
    //var tankMine_mc:MovieClip;
    //create a new instance of tankMine
    tankMine_mc = new Mine();
    //set the x and y axis
    tankMine_mc.y = 513;
    tankMine_mc.x = 1080;
    // adds mines to stage
    addChild(tankMine_mc);
    tankMine_mc.addEventListener(Event.ENTER_FRAME, moveHorizontal);
    function moveHorizontal(evt:Event):void{
        evt.target.x -= Math.random()*5;
        if (evt.target.x >= stage.stageWidth)
            evt.target.removeEventListener(Event.ENTER_FRAME, moveHorizontal);
            removeChild(DisplayObject(evt.target));
    initialiseMine();
        //declare varibles to create mines
    var atmInGame:uint;
    var atmMaker:Timer;
    function initialiseAtm():void
        atmInGame = 15;
        //create a timer fires every second
        atmMaker = new Timer(8000, minesInGame);
        //tell timer to listen for Timer event
        atmMaker.addEventListener(TimerEvent.TIMER, createAtm);
        //start the timer
        atmMaker.start();
    function createAtm(event:TimerEvent):void
    //var antiTankmine_mc
    //create a new instance of tankMine
    antiTankmine_mc = new Atm();
    //set the x and y axis
    antiTankmine_mc.y = 473;
    antiTankmine_mc.x = 1080;
    // adds mines to stage
    addChild(antiTankmine_mc);
    antiTankmine_mc.addEventListener(Event.ENTER_FRAME, moveHorizontal);
    function moveHorizontal_2(evt:Event):void{
        evt.target.x -= Math.random()*10;
        if (evt.target.x >= stage.stageWidth)
            evt.target.removeEventListener(Event.ENTER_FRAME, moveHorizontal);
            removeChild(DisplayObject(evt.target));
    initialiseAtm();
    function moveForward():void{
        bg_mc.x -=10;
    function moveBackward():void{
        bg_mc.x +=10;
    var tank_mc:Tank;
    // create a new Tank and put it into the variable
    // tank_mc
    tank_mc= new Tank;
    // set the location ( x and y) of tank_mc
    tank_mc.x=0;
    tank_mc.y=375;
    // show the tank_mc on the stage.
    addChild(tank_mc);
    stage.addEventListener(KeyboardEvent.KEY_DOWN, onMovementKeys);
    //creates the movement
    function onMovementKeys(evt:KeyboardEvent):void
        //makes the tank move by 10 pixels right
        if (evt.keyCode==Keyboard.D)
        tank_mc.x+=5;
    //makes the tank move by 10 pixels left
    if (evt.keyCode==Keyboard.A)
    tank_mc.x-=5
    //checking if the space bar is pressed and shooting is allowed
    if(evt.keyCode == 32 && shootAllow){
        //making it so the user can't shoot for a bit
        shootAllow = false;
        //declaring a variable to be a new Bullet
        var newBullet:Bullet = new Bullet();
        //changing the bullet's coordinates
        newBullet.y = tank_mc.y + tank_mc.width/2 - newBullet.width/2;
        newBullet.x = tank_mc.x;
        //then we add the bullet to stage
        addChild(newBullet);
    if (tank_mc.hitTestObject(antiTankmine_mc))
            //tank_mc.gotoAndPlay("hit");
            currentHP -= 10;
            // remove anti tank mine
            removeChild(antiTankmine_mc);
    if (tank_mc.hitTestObject(tankMine_mc))
            //tank_mc.gotoAndPlay("hit");
            currentHP -= 10;
            // remove anti tank mine
            removeChild(tankMine_mc);
        //var maxHP:int = 100;
    //var currentHP:int = maxHP;
    //var percentHP:Number = currentHP / maxHP;
        //Incrementing the cTime
    //checking if cTime has reached the limit yet
    if(cTime < cLimit){
        cTime ++;
    } else {
        //if it has, then allow the user to shoot
        shootAllow = true;
        //and reset cTime
        cTime = 0;
    function updateHealthBar():void
        percentHP = currentHP / maxHP;
        healthBar.barColor.scaleX = percentHP;
        if(currentHP <= 0)
            currentHP = 0;
            trace("Game Over");
        updateHealthBar();

    USe the trace function to analyze what happens and what fails to happen in the code you showed.  trace the conditional values to see if they are set up to allow a shot when you press the key

  • Need help with conditional query

    guys this is just an extension of this post that Frank was helping me with. im reposting because my requirements have changes slightly and im having a hell of a time trying to modify the query.
    here is the previous post.
    need help with query that can look data back please help.
    CREATE TABLE "FGL"
        "FGL_GRNT_CODE" VARCHAR2(60),
        "FGL_FUND_CODE" VARCHAR2(60),
        "FGL_ACCT_CODE" VARCHAR2(60),
        "FGL_ORGN_CODE" VARCHAR2(60),
        "FGL_PROG_CODE" VARCHAR2(60),
        "FGL_GRNT_YEAR" VARCHAR2(60),
        "FGL_PERIOD"    VARCHAR2(60),
        "FGL_BUDGET"    VARCHAR2(60)
      )data
    Insert into FGL (FGL_GRNT_CODE,FGL_FUND_CODE,FGL_ACCT_CODE,FGL_ORGN_CODE,FGL_PROG_CODE,FGL_GRNT_YEAR,FGL_PERIOD,FGL_BUDGET) values ('240055','240055','7600','4730','02','11','00','400');
    Insert into FGL (FGL_GRNT_CODE,FGL_FUND_CODE,FGL_ACCT_CODE,FGL_ORGN_CODE,FGL_PROG_CODE,FGL_GRNT_YEAR,FGL_PERIOD,FGL_BUDGET) values ('240055','240055','7240','4730','02','10','1','100');
    Insert into FGL (FGL_GRNT_CODE,FGL_FUND_CODE,FGL_ACCT_CODE,FGL_ORGN_CODE,FGL_PROG_CODE,FGL_GRNT_YEAR,FGL_PERIOD,FGL_BUDGET) values ('240055','240055','7240','4730','02','10','1','0');
    Insert into FGL (FGL_GRNT_CODE,FGL_FUND_CODE,FGL_ACCT_CODE,FGL_ORGN_CODE,FGL_PROG_CODE,FGL_GRNT_YEAR,FGL_PERIOD,FGL_BUDGET) values ('240055','240055','7600','4730','02','11','1','400');
    Insert into FGL (FGL_GRNT_CODE,FGL_FUND_CODE,FGL_ACCT_CODE,FGL_ORGN_CODE,FGL_PROG_CODE,FGL_GRNT_YEAR,FGL_PERIOD,FGL_BUDGET) values ('360055','360055','7200','4730','02','10','1','400');
    Insert into FGL (FGL_GRNT_CODE,FGL_FUND_CODE,FGL_ACCT_CODE,FGL_ORGN_CODE,FGL_PROG_CODE,FGL_GRNT_YEAR,FGL_PERIOD,FGL_BUDGET) values ('360055','360055','7600','4730','02','10','1','400');
    Insert into FGL (FGL_GRNT_CODE,FGL_FUND_CODE,FGL_ACCT_CODE,FGL_ORGN_CODE,FGL_PROG_CODE,FGL_GRNT_YEAR,FGL_PERIOD,FGL_BUDGET) values ('240055','240055','7240','4730','02','10','14','200');
    Insert into FGL (FGL_GRNT_CODE,FGL_FUND_CODE,FGL_ACCT_CODE,FGL_ORGN_CODE,FGL_PROG_CODE,FGL_GRNT_YEAR,FGL_PERIOD,FGL_BUDGET) values ('240055','240055','7600','4730','02','10','14','100');
    Insert into FGL (FGL_GRNT_CODE,FGL_FUND_CODE,FGL_ACCT_CODE,FGL_ORGN_CODE,FGL_PROG_CODE,FGL_GRNT_YEAR,FGL_PERIOD,FGL_BUDGET) values ('240055','240055','7240','4730','02','10','14','200');
    Insert into FGL (FGL_GRNT_CODE,FGL_FUND_CODE,FGL_ACCT_CODE,FGL_ORGN_CODE,FGL_PROG_CODE,FGL_GRNT_YEAR,FGL_PERIOD,FGL_BUDGET) values ('240055','240055','7240','4730','02','10','2','100');
    Insert into FGL (FGL_GRNT_CODE,FGL_FUND_CODE,FGL_ACCT_CODE,FGL_ORGN_CODE,FGL_PROG_CODE,FGL_GRNT_YEAR,FGL_PERIOD,FGL_BUDGET) values ('240055','240055','7240','4730','02','11','2','600');
    I need to find the greatest grant year for the grant by a period parameter.
    once i find the greatest year i need to check the value of period 14 for that grant for the previous year and add it to the budget amount for that grant. however if their is an entry in the greatest year for period 00 then i need to ignore the period 14 of previous year and do this calculation current period +(current period - greatest year 00)
    hope that makes sense so in other words with the new data above. if i was querying period two of grant year 11. i would end up with $800
    because the greatest year is 11 it contains a period 0 with amount of $400 so my total should be
    period 2 amount $ 600
    period 0 amount $ 400 - period 2 amount of $600 = 200
    600+200 = $800
    if i query period 1 of grant 360055 i would just end up with 800 of grnt year 10.
    i have tried to modify that query you supplied to me with no luck. I have tried for several day but im embarrased to say i just can get it to do what im trying to do .
    can you please help me out.
    here is the query supplied by frank kulash who gracefully put this together for me.
    WITH     got_greatest_year     AS
         SELECT     fgl.*     -- or whatever columns are needed
         ,     MAX ( CASE
                     WHEN  fgl_period = :given_period
                     THEN  fgl_grnt_year
                    END
                  ) OVER ()     AS greatest_year
         FROM     fgl
    SELECT     SUM (fgl_budget)     AS total_budget     -- or SELECT *
    FROM     got_greatest_year
    WHERE     (     fgl_grnt_year     = greatest_year
         AND     fgl_period     = :given_period
    OR     (     fgl_grnt_year     = greatest_year - 1
         AND     fgl_period     = 14
    ;Miguel

    Hi, Miguel,
    Are you waying that, when the greatest year that has :given_period also has period='00' (or '0', or whatever you want to use), then you want to double the budget from the given_period (as well as subtract the budget from the '00', and not count the pevious year's '14')? If so, add another condition to the CASE statement which decides what you're SUMming:
    WITH     got_greatest_year     AS
         SELECT       TO_NUMBER (fgl_grnt_year)     AS grnt_year
         ,       fgl_period
         ,       TO_NUMBER (fgl_budget)     AS budget
         ,       MAX ( CASE
                       WHEN  fgl_period = :given_period
                       THEN  TO_NUMBER (fgl_grnt_year)
                      END
                    ) OVER ()     AS greatest_year
         FROM       fgl
    ,     got_cnt_00     AS
         SELECT     grnt_year
         ,     fgl_period
         ,     budget
         ,     greatest_year
         ,     COUNT ( CASE
                       WHEN  grnt_year     = greatest_year
                       AND       fgl_period     = '00'
                       THEN  1
                         END
                    ) OVER ()          AS cnt_00
         FROM    got_greatest_year
    SELECT       SUM ( CASE
                        WHEN  grnt_year     = greatest_year                    -- New
                  AND       fgl_period     = :given_period                    -- New
                  AND       cnt_00     > 0            THEN  budget * 2     -- New
                        WHEN  grnt_year     = greatest_year
                  AND       fgl_period     = :given_period       THEN  budget
                        WHEN  grnt_year     = greatest_year
                  AND       fgl_period     = '00'            THEN -budget
                        WHEN  grnt_year     = greatest_year - 1
                  AND       fgl_period     = '14'     
                  AND       cnt_00     = 0            THEN  budget
                    END
               )          AS total_budget
    FROM       got_cnt_00
    ;You'll notice this is the same as the previous query I posted, except for 3 lines maked "New".

  • Need Help With File Matching Records

    I need help with my file matching program.
    Here is how it suppose to work: FileMatch class should contain methods to read oldmast.txt and trans.txt. When a match occurs (i.e., records with the same account number appear in both the master file and the transaction file), add the dollar amount in the transaction record to the current balance in the master record, and write the "newmast.txt" record. (Assume that purchases are indicated by positive amounts in the transaction file and payments by negative amounts.)
    When there is a master record for a particular account, but no corresponding transaction record, merely write the master record to "newmast.txt". When there is a transaction record, but no corresponding master record, print to a log file the message "Unmatched transaction record for account number ..." (fill in the account number from the transaction record). The log file should be a text file named "log.txt".
    Here is my following program code:
    // Exercise 14.8: CreateTextFile.java
    // creates a text file
    import java.io.FileNotFoundException;
    import java.lang.SecurityException;
    import java.util.Formatter;
    import java.util.FormatterClosedException;
    import java.util.NoSuchElementException;
    import java.util.Scanner;
    import org.egan.AccountRecord;
    import org.egan.TransactionRecord;
    public class CreateTextFile
      private Formatter output1;  // object used to output text to file
      private Formatter output2;  // object used to output text to file
      // enable user to open file
      public void openTransFile()
        try
          output1 = new Formatter("trans.txt");
        catch (SecurityException securityException)
          System.err.println("You do not have write access to this file.");
          System.exit(1);
        } // end catch
        catch (FileNotFoundException filesNotFoundException)
          System.err.println("Error creating file.");
          System.exit(1);
      } // end method openTransFile
      // enable user to open file
      public void openOldMastFile()
        try
          output2 = new Formatter("oldmast.txt");
        catch (SecurityException securityException)
          System.err.println("You do not have write access to this file.");
          System.exit(1);
        } // end catch
        catch (FileNotFoundException filesNotFoundException)
          System.err.println("Error creating file.");
          System.exit(1);
      } // end method openOldMastFile
      // add transaction records to file
      public void addTransactionRecords()
        // object to be written to file
        TransactionRecord record1 = new TransactionRecord();
        Scanner input1 = new Scanner(System.in);
        System.out.printf("%s\n%s\n%s\n%s\n\n",
          "To terminate input, type the end-of-file indicator",   
          "when you are prompted to enter input.",
          "On UNIX/Linux/Mac OS X type <ctrl> d then press Enter",
          "On Windows type <ctrl> z then press Enter");
        System.out.printf("%s\n%s",
           "Enter account number (> 0) and amount.","? ");
        while (input1.hasNext())  // loop until end-of-file indicator
          try // output values to file
            // retrieve data to be output
            record1.setAccount(input1.nextInt());    // read account number
            record1.setAmount(input1.nextDouble());  // read amount
            if (record1.getAccount() > 0)
              // write new record
              output1.format("%d %.2f\n", record1.getAccount(), record1.getAmount());
            } // end if
            else
              System.out.println("Account number must be greater than 0.");
            } // end else
          } // end try
          catch (FormatterClosedException formatterClosedException)
            System.err.println("Error writing to file.");
            return;
          } // end catch
          catch (NoSuchElementException elementException)
            System.err.println("Invalid input. Please try again.");
            input1.nextLine(); // discard input so user can try again
          } // end catch
          System.out.printf("%s %s\n%s", "Enter account number (> 0) ",
            "and amount.","? ");
        } // end while
      } // end method addTransactionRecords
      // add account records to file
      public void addAccountRecords()
        // object to be written to file
        AccountRecord record2 = new AccountRecord();
        Scanner input2 = new Scanner(System.in);
        System.out.printf("%s\n%s\n%s\n%s\n\n",
          "To terminate input, type the end-of-file indicator",   
          "when you are prompted to enter input.",
          "On UNIX/Linux/Mac OS X type <ctrl> d then press Enter",
          "On Windows type <ctrl> z then press Enter");
        System.out.printf("%s\n%s",
           "Enter account number (> 0), first name, last name and balance.","? ");
        while (input2.hasNext())  // loop until end-of-file indicator
          try // output values to file
            // retrieve data to be output
            record2.setAccount(input2.nextInt());    // read account number
            record2.setFirstName(input2.next());      // read first name
            record2.setLastName(input2.next());       // read last name
            record2.setBalance(input2.nextDouble());  // read balance
            if (record2.getAccount() > 0)
              // write new record
              output2.format("%d %s %s %.2f\n", record2.getAccount(), record2.getFirstName(),
                record2.getLastName(), record2.getBalance());
            } // end if
            else
              System.out.println("Account number must be greater than 0.");
            } // end else
          } // end try
          catch (FormatterClosedException formatterClosedException)
            System.err.println("Error writing to file.");
            return;
          } // end catch
          catch (NoSuchElementException elementException)
            System.err.println("Invalid input. Please try again.");
            input2.nextLine(); // discard input so user can try again
          } // end catch
          System.out.printf("%s %s\n%s", "Enter account number (> 0),",
            "first name, last name and balance.","? ");
        } // end while
      } // end method addAccountRecords
      // close file
      public void closeTransFile()
        if (output1 != null)
          output1.close();
      } // end method closeTransFile
      // close file
      public void closeOldMastFile()
        if (output2 != null)
          output2.close();
      } // end method closeOldMastFile
    } // end class CreateTextFile--------------------------------------------------------------------------------------------------
    // Exercise 14.8: CreateTextFileTest.java
    // Testing class CreateTextFile
    public class CreateTextFileTest
       // main method begins program execution
       public static void main( String args[] )
         CreateTextFile application = new CreateTextFile();
         application.openTransFile();
         application.addTransactionRecords();
         application.closeTransFile();
         application.openOldMastFile();
         application.addAccountRecords();
         application.closeOldMastFile();
       } // end main
    } // end class CreateTextFileTest-------------------------------------------------------------------------------------------------
    // Exercise 14.8: TransactionRecord.java
    // A class that represents on record of information
    package org.egan; // packaged for reuse
    public class TransactionRecord
      private int account;
      private double amount;
      // no-argument constructor calls other constructor with default values
      public TransactionRecord()
        this(0,0.0); // call two-argument constructor
      } // end no-argument AccountRecord constructor
      // initialize a record
      public TransactionRecord(int acct, double amt)
        setAccount(acct);
        setAmount(amt);
      } // end two-argument TransactionRecord constructor
      // set account number
      public void setAccount(int acct)
        account = acct;
      } // end method setAccount
      // get account number
      public int getAccount()
        return account;
      } // end method getAccount
      // set amount
      public void setAmount(double amt)
        amount = amt;
      } // end method setAmount
      // get amount
      public double getAmount()
        return amount;
      } // end method getAmount
    } // end class TransactionRecord -------------------------------------------------------------------------------------------------
    // Exercise 14.8: AccountRecord.java
    // A class that represents on record of information
    package org.egan; // packaged for reuse
    import org.egan.TransactionRecord;
    public class AccountRecord
      private int account;
      private String firstName;
      private String lastName;
      private double balance;
      // no-argument constructor calls other constructor with default values
      public AccountRecord()
        this(0,"","",0.0); // call four-argument constructor
      } // end no-argument AccountRecord constructor
      // initialize a record
      public AccountRecord(int acct, String first, String last, double bal)
        setAccount(acct);
        setFirstName(first);
        setLastName(last);
        setBalance(bal);
      } // end four-argument AccountRecord constructor
      // set account number
      public void setAccount(int acct)
        account = acct;
      } // end method setAccount
      // get account number
      public int getAccount()
        return account;
      } // end method getAccount
      // set first name
      public void setFirstName(String first)
        firstName = first;
      } // end method setFirstName
      // get first name
      public String getFirstName()
        return firstName;
      } // end method getFirstName
      // set last name
      public void setLastName(String last)
        lastName = last;
      } // end method setLastName
      // get last name
      public String getLastName()
        return lastName;
      } // end method getLastName
      // set balance
      public void setBalance(double bal)
        balance = bal;
      } // end method setBalance
      // get balance
      public double getBalance()
        return balance;
      } // end method getBalance
      // combine balance and amount
      public void combine(TransactionRecord record)
        balance = (getBalance() + record.getAmount()); 
      } // end method combine
    } // end class AccountRecord -------------------------------------------------------------------------------------------------
    // Exercise 14.8: FileMatch.java
    import java.io.File;
    import java.io.FileNotFoundException;
    import java.lang.IllegalStateException;
    import java.util.NoSuchElementException;
    import java.util.Scanner;
    import java.util.Formatter;
    import java.util.FormatterClosedException;
    import org.egan.AccountRecord;
    import org.egan.TransactionRecord;
    public class FileMatch
      private Scanner inTransaction;
      private Scanner inOldMaster;
      private Formatter outNewMaster;
      private Formatter theLog;
      // enable user to open file
      public void openTransFile()
        try
          inTransaction = new Scanner(new File("trans.txt"));
        } // end try
        catch (FileNotFoundException fileNotFoundException)
          System.err.println("Error opening file.");
          System.exit(1);
        } // end catch
      } // end method openTransFile
      // enable user to open file
      public void openOldMastFile()
        try
          inOldMaster = new Scanner(new File("oldmast.txt"));
        } // end try
        catch (FileNotFoundException fileNotFoundException)
          System.err.println("Error opening file.");
          System.exit(1);
        } // end catch
      } // end method openOldMastFile
      // enable user to open file
      public void openNewMastFile()
        try
          outNewMaster = new Formatter("newmast.txt");
        catch (SecurityException securityException)
          System.err.println("You do not have write access to this file.");
          System.exit(1);
        } // end catch
        catch (FileNotFoundException filesNotFoundException)
          System.err.println("Error creating file.");
          System.exit(1);
      } // end method openNewMastFile
      // enable user to open file
      public void openLogFile()
        try
          theLog = new Formatter("log.txt");
        catch (SecurityException securityException)
          System.err.println("You do not have write access to this file.");
          System.exit(1);
        } // end catch
        catch (FileNotFoundException filesNotFoundException)
          System.err.println("Error creating file.");
          System.exit(1);
      } // end method openLogFile
      // update records
      public void updateRecords()
        TransactionRecord transaction = new TransactionRecord();
        AccountRecord account = new AccountRecord();
        try // read records from file using Scanner object
          System.out.println("Start file matching.");
          while (inTransaction.hasNext() && inOldMaster.hasNext())
            transaction.setAccount(inTransaction.nextInt());     // read account number
            transaction.setAmount(inTransaction.nextDouble());   // read amount
            account.setAccount(inOldMaster.nextInt());     // read account number
            account.setFirstName(inOldMaster.next());      // read first name 
            account.setLastName(inOldMaster.next());       // read last name
            account.setBalance(inOldMaster.nextDouble());  // read balance
            if (transaction.getAccount() == account.getAccount())
              while (inTransaction.hasNext() && transaction.getAccount() == account.getAccount())
                account.combine(transaction);
                outNewMaster.format("%d %s %s %.2f\n",
                account.getAccount(), account.getFirstName(), account.getLastName(),
                account.getBalance());
                transaction.setAccount(inTransaction.nextInt());     // read account number
                transaction.setAmount(inTransaction.nextDouble());   // read amount
            else if (transaction.getAccount() != account.getAccount())
              outNewMaster.format("%d %s %s %.2f\n",
              account.getAccount(), account.getFirstName(), account.getLastName(),
              account.getBalance());         
              theLog.format("%s%d","Unmatched transaction record for account number ",transaction.getAccount());
          } // end while
          System.out.println("Finish file matching.");
        } // end try
        catch (NoSuchElementException elementException)
          System.err.println("File improperly formed.");
          inTransaction.close();
          inOldMaster.close();
          System.exit(1);
        } // end catch
        catch (IllegalStateException stateException)
          System.err.println("Error reading from file.");
          System.exit(1);
        } // end catch   
      } // end method updateRecords
      // close file and terminate application
      public void closeTransFile()
        if (inTransaction != null)
          inTransaction.close();
      } // end method closeTransFile
      // close file and terminate application
      public void closeOldMastFile()
        if (inOldMaster != null)
          inOldMaster.close();
      } // end method closeOldMastFile
      // close file
      public void closeNewMastFile()
        if (outNewMaster != null)
          outNewMaster.close();
      } // end method closeNewMastFile
      // close file
      public void closeLogFile()
        if (theLog != null)
          theLog.close();
      } // end method closeLogFile
    } // end class FileMatch-------------------------------------------------------------------------------------------------
    // Exercise 14.8: FileMatchTest.java
    // Testing class FileMatch
    public class FileMatchTest
       // main method begins program execution
       public static void main( String args[] )
         FileMatch application = new FileMatch();
         application.openTransFile();
         application.openOldMastFile();
         application.openNewMastFile();
         application.openLogFile();
         application.updateRecords();
         application.closeLogFile();
         application.closeNewMastFile();
         application.closeOldMastFile();
         application.closeTransFile();
       } // end main
    } // end class FileMatchTest-------------------------------------------------------------------------------------------------
    Sample data for master file:
    Master file                         
    Account Number            Name                     Balance
    100                            Alan Jones                   348.17
    300                            Mary Smith                    27.19
    500                            Sam Sharp                   0.00
    700                            Suzy Green                   -14.22Sample data for transaction file:
    Transaction file                    Transaction
    Account Number                  Amount
    100                                         27.14
    300                                         62.11
    300                                         83.89
    400                                         100.56
    700                                         80.78
    700                                         1.53
    900                                         82.17  -------------------------------------------------------------------------------------------------
    My FileMatch class program above has bugs in it.
    The correct results for the newmast.txt:
    100  Alan  Jones  375.31
    300  Mary  Smith  173.19
    500  Sam  Sharp  0.00
    700  Suzy Green  68.09The correct results for the log.txt:
    Unmatched transaction record for account number 400Unmatched transaction record for account number 900------------------------------------------------------------------------------------------------
    My results for the newmast.txt:
    100 Alan Jones 375.31
    300 Mary Smith 111.08
    500 Sam Sharp 0.00
    700 Suzy Green -12.69My results for the log.txt
    Unmatched transaction record for account number 700-------------------------------------------------------------------------------------------------
    I am not sure what is wrong with my code above to make my results different from the correct results.
    Much help is appreciated. Please help.

    From the output, it looks like one problem is just formatting -- apparently you're including a newline in log entries and not using tabs for the newmast output file.
    As to why the numbers are off -- just from glancing over it, it appears that the problem is when you add multiple transaction values. Since account.combine() is so simple, I suspect that you're either adding creating transaction objects incorrectly or not creating them when you should be.
    Create test input data that isolates a single case of this (e.g., just the Mary Smith case), and then running your program in a debugger or adding debugging code to the add/combine method, so you can see what's happening in detail.
    Also I'd recommend reconsidering your design. It's a red flag if a class has a name with "Create" in it. Classes represent bundles of independant state and transformations on that state, not things to do.

Maybe you are looking for

  • How to enable DFF for each line level on a Table Region - very very urgent

    Hi, I have a Master- Detail Page, Detail is Table region. I need to enable DFF (Context Based) for each line. If any one has done similar requirement please share how to do this. Its very very urgent. It is a standard page. Thanks, Edited by: user899

  • Change source field in Employee Self Service - Personal Information

    Dear Expert, I want to change source field in ESS - Personal Information. Currently, value of field Full Name in Personal Data - Personal Information is taken from column CNAME in table PA0002. I want to change it so that value for field Full Name is

  • Airtunes "skips" during "multiple speakers" mode...

    The problem is when I play in the new "multiple speakers" mode my local PC skips, and remote signal plays fine. If I select local by itself, my PC plays fine, or if I select remote by itself, it also plays fine. No other issues with Itunes, ever! Jus

  • Blob to base64 encoded XML

    Hi, We have a table with two columns (Name varchar2, Picture Blob). How do we get XML output containing rows from table, with Picture (blob column) being base64 encoded. Note: I have tried using utl_encode.base64_encode, but getting error due to larg

  • How Use /Fastdetect /3GB switch for Utlizing 2G RAM

    DB : 10.2.0 OS : Microsoft Server 2003 Processor : 2xDual Core Intel Xeon Physical Memory : 4G (But showing 3.5G) i want to configure my databse for utlizing 3g RAM ( using 3gb switch in boot.ini file 1G for OS Kernal and 2G for user related applicat