Need Some Help in creating chart description is long thanks for ur time.

Hi, I was asked to create a chart for an existing report which is Average number of days open versus Profit Center.
I need to calculate Average number of days open as a sum of {command.Days_Opened}/Record Count.
Record Count = number of records with days open <> 0 in a group
I created a running total name Evalution and put it in details with formulae
whileprintingrecords;
Numbervar i;
if (command.days_open) <> 0 then
  i := i+1;
else
i
In group headder i put @reset with the following syntax: whileprintingrecords; Numbervar i := 0;
in Group footer again Display with formulae whileprintingrecords; Numbervar i;
so i finally got avg. number of days open as Sum of {command.Days_Open}/@dispaly
tested the formule and is working well.
But the problem is this formulae doesnt work in chart. How can i resolve this problem

Sandeep,
Your question was posted in the "General" forum, however, it appears that you have a specific question centering around an application.  I would suggest that you close this entry and re-post your question in the applicable forum (for example, Crystal or Web Intelligence, etc, etc).
Thanks,
John

Similar Messages

  • Need some help in creating Search Help for standard screen/field

    I need some help in adding a search-help to a standard screen-field.
    Transaction Code - PP01,
    Plan Version - Current Plan (PLVAR = '01'),
    Object Type - Position ( OTYPE = 'S'),
    Click on Infotype Name - Object ( Infotype 1000) and Create.
    I need to add search help to fields Object Abbr (P1000-SHORT) / Object Name (P1000-STEXT).
    I want to create one custom table with fields, Position Abb, Position Name, Job. Position Abb should be Primary Key. And when object type is Position (S), I should be able to press F4 for Object Abb/Object Name fields and should return Position Abbr and Position Name.
    I specify again, I have to add a new search help to standard screen/field and not to enhance it.
    This is HR specific transaction. If someone has done similar thing with some other transation, please let me know.
    There is no existing search help for these fields. If sm1 ever tried or has an idea how to add new search help to a standard screen/field.
    It's urgent.
    Thanks in advace. Suitable answers will be rewarded

    Hi Pradeep,
    Please have a look into the below site which might be useful
    Enhancing a Standard Search Help
    https://www.sdn.sap.com/irj/sdn/go/portal/prtroot/docs/library/uuid/daeda0d7-0701-0010-8caa-
    edc983384237
    http://help.sap.com/saphelp_nw04/helpdata/en/cf/21ee93446011d189700000e8322d00/frameset.htm
    A search help exit is a function module for making the input help process described by the search help more flexible than possible with the standard version.
    This function module must have the same interface as function module F4IF_SHLP_EXIT_EXAMPLE. The search help exit may also have further optional parameters (in particular any EXPORTING parameters).
    A search help exit is called at certain timepoints in the input help process.
    Note: The source text and long documentation of the above-specified function module (including the long documentation about the parameters) contain information about using search help exits.
    Function modules are provided in the function library for operations that are frequently executed in search help exits. The names of these function modules begin with the prefix F4UT_. These function modules can either be used directly as search help exits or used within other search help exits. You can find precise instructions for use in the long documentation for the corresponding function module.
    During the input help process, a number of timepoints are defined that each define the beginning of an important operation of the input help process.
    If the input help process is defined with a search help having a search help exit, this search help exit is called at each of these timepoints. If required, the search help exit can also influence the process and even determine that the process should be continued at a different timepoint.
    timepoints
    The following timepoints are defined:
    1. SELONE
    Call before selecting an elementary search help. The possible elementary search helps are already in SHLP_TAB. This timepoint can be used in a search help exit of a collective search help to restrict the selection possibilities for the elementary search helps.
    Entries that are deleted from SHLP_TAB in this step are not offered in the elementary search help selection. If there is only one entry remaining in SHLP_TAB, the dialog box for selecting elementary search helps is skipped. You may not change the next timepoint.
    The timepoint is not accessed again if another elementary search help is to be selected during the dialog.
    2. PRESEL1
    After selecting an elementary search help. Table INTERFACE has not yet been copied to table SELOPT at this timepoint in the definition of the search help (type SHLP_DESCR_T). This means that you can still influence the attachment of the search help to the screen here. (Table INTERFACE contains the information about how the search help parameters are related to the screen fields).
    3. PRESEL
    Before sending the dialog box for restricting values. This timepoint is suitable for predefining the value restriction or for completely suppressing or copying the dialog.
    4. SELECT
    Before selecting the values. If you do not want the default selection, you should copy this timepoint with a search help exit. DISP should be set as the next timepoint.
    5. DISP
    Before displaying the hit list. This timepoint is suitable for restricting the values to be displayed, e.g. depending on authorizations.
    6. RETURN (usually as return value for the next timepoint)
    The RETURN timepoint should be returned as the next step if a single hit was selected in a search help exit.
    It can make sense to change the F4 flow at this timepoint if control of the process sequence of the Transaction should depend on the selected value (typical example: setting SET/GET parameters). However, you should note that the process will then depend on whether a value was entered manually or with an input help.
    7. RETTOP
    You only go to this timepoint if the input help is controlled by a collective search help. It directly follows the timepoint RETURN. The search help exit of the collective search help, however, is called at timepoint RETTOP.
    8. EXIT (only for return as next timepoint)
    The EXIT timepoint should be returned as the next step if the user had the opportunity to terminate the dialog within the search help exit.
    9. CREATE
    The CREATE timepoint is only accessed if the user selects the function "Create new values". This function is only available if field CUSTTAB of the control string CALLCONTROL was given a value not equal to SPACE earlier on.
    The name of the (customizing) table to be maintained is normally entered there. The next step returned after CREATE should be SELECT so that the newly entered value can be selected and then displayed.
    10. APP1, APP2, APP3
    If further pushbuttons are introduced in the hit list with function module F4UT_LIST_EXIT, these timepoints are introduced. They are accessed when the user presses the corresponding pushbutton.
    Note: If the F4 help is controlled by a collective search help, the search help exit of the collective search help is called at timepoints SELONE and RETTOP. (RETTOP only if the user selects a value.) At all other timepoints the search help exit of the selected elementary search help is called.
    If the F4 help is controlled by an elementary search help, timepoint RETTOP is not executed. The search help exit of the elementary search help is called at timepoint SELONE (at the
    F4IF_SHLP_EXIT_EXAMPLE
    This module has been created as an example for the interface and design of Search help exits in Search help.
    All the interface parameters defined here are mandatory for a function module to be used as a search help exit, because the calling program does not know which parameters are actually used internally.
    A search help exit is called repeatedly in connection with several
    events during the F4 process. The relevant step of the process is passed on in the CALLCONTROL step. If the module is intended to perform only a few modifications before the step, CALLCONTROL-STEP should remain unchanged.
    However, if the step is performed completely by the module, the following step must be returned in CALLCONTROL-STEP.
    The module must react with an immediate EXIT to all steps that it does not know or does not want to handle.
    Hope this info will help you.
    ***Reward points if found useful
    Regards,
    Naresh

  • I need some help to create more space on my hard drive-what can I delete?  I have my external G-DRIVE connected as a back up, so i think I'm duplicating a lot of back up files, mostly photos through Lightroom on my Mac HD. Only 9GB left out of 297GB...

    Have never had to retrieve backed up files so I think I'm just chicken to delete files on my Mac.  Is everything on my back up if I need it?  Even photos that have been processed in Lightroom?  Could I delete all older photo folders from my Mac and still get them from external drive if I needed them down the road?  I have run a GrandPerspective scan and it appears most of my disk space is used for photo files and back-ups...probably have 30,000-40,000 photos.  Thanks!

    Look at getting Onyx, as you have alot of photo's, and so do I. Onyx will help clear somethings from you Mac, all you have to do is run Automation, and or Cleaning. Is that 30,000-40,000 Photo's Duplicates? if so, you might want to delete as many as the those duplicates as possible. i see you use Lightroom, are you useing that to import your images or are you useing something else like Iphoto, or just importing them to your mac. if you are using something else to import your photo's and then reimporting them, this might create duplicates of images. also sometimes when you delete images you dont want, they might not be acctually deleted. so clear you Trash, and run onyx to help clear these things up.
    I know there are a few different programs out there that will help clrear out duplicates of items, and help you reduce space.
    Duplicate-Annihilator Looks for images in Iphoto that are the same, and allows you to change them or delete them.
    http://www.macupdate.com/app/mac/18748/duplicate-annihilator
    TidyUp ($$) Will look for Music, Pictures Documents, or any duplicates.
    http://www.hyperbolicsoftware.com/TidyUp.html
    Hope This Helps you.

  • I need some help on creating a query

    This is my first crack at writing query's.  
    I am trying to create a query for a list on clients with a file name on the system. I found a lot of samples on the web, however i keep getting errors on all of them. 
    Here is on sample:
    select SMS_G_System_COMPUTER_SYSTEM.Name, 
    SMS_G_System_SoftwareFile.FilePath, SMS_G_System_SoftwareFile.CreationDate, 
    SMS_G_System_SoftwareFile.FileDescription, V_R_System.ResourceType, 
    V_R_System.ResourceId from V_R_System inner join SMS_G_System_COMPUTER_SYSTEM on 
    SMS_G_System_COMPUTER_SYSTEM.ResourceID = V_R_System.ResourceId inner join SMS_G_System_SoftwareFile on 
    SMS_G_System_SoftwareFile.ResourceID = V_R_System.ResourceId where SMS_G_System_SoftwareFile.FileName = "test1234.exe" 
    First i was getting an error:
    Invalid object name 'SMS_R_System' and i had to change to V_R_System instead of SMS_R_System. "Is it because
    SQL and WQL difference?????"
    Now i am getting Invalid object name 'SMS_G_System_COMPUTER_SYSTEM' "Here is where i am stuck"
    If possible i would like to explanation as well "maybe some good links", please keep in mind just getting started with query's.
    Thanks for the help.
    I am writing/testing query in sql management studio.
    If there is a better way or a tool please let me know.

    The application i am looking for does not show up in ADD/REM.
    I was asking what is the difference between V_R_System instead of SMS_R_System?
    And what should i use instead of SMS_G_System_COMPUTER_SYSTEM?
    Maybe you can share some links so i can read a little more?
    Thank you.

  • I need some help to create service product in crm 2007

    Hello everybody
    I 'm new to crm 2007.
    Now I met a problem.
    Can somebody give me some advice. Thanks.
    I want to write a programm to create service product.
    But I don't know  function modul  which I can use.

    Hi ,Garcia   
    Thanks for your reply.
    I have tried that method,but met a error in sap function modul.
    My crm's version is 2007.
    Is there any othor method or fm?

  • Need some help in creating client proxy to call webservice

    Hi experts,
    I am new to ABAP so couldnt understand the SAP ABAP jargons.
    On of my colleague has written one search help exit function and i need to use that and have to write client proxy to establish connection to webservice.
    I never worked on proxy or webservice so, struggling to understand the concept and steps.
    I am following second part i.e Release 640 part of /people/thomas.jung3/blog/2004/11/17/bsp-a-developers-journal-part-xiv--consuming-webservices-with-abap weblog.
    I couldnt find "To get the process started, we turn to our old friend SE80. <b>From the Enterprise Services Tab, we are going to select Client Proxy and then hit create"</b>
    when i go to transaction se80 ObjectNavigator, i could see two dropdown lists after some tabs.
    in first list, I have selected, "Application Hierarchy", and in second I am selecting "Package".
    Not sure whether its correct or not.
    Once i do this i could see long list of <b>Object name and its description.</b>
    Now, what should i do ? where should i go for "Enterprise Services Tab" to create my proxy.
    Any help would be appreciated.
    Please send me PDF, having detailed steps to create client proxy.
    Thanks,
    Pranav

    Right click on the package and select Proxy object. In the Wizard select Service Consumer.
    then give the url of the WSDL file you want to access or path if u have a local file.
    then give the package for client proxy.
    then complete the wizard. the  client proxy will be create in that package.
    Next step will be creating a Logical Port using the transaction "lpconfig". Give the proxy name of the service interface created under client proxy. and set the configuration as follows.
    1. Make as a default port.
    2. in the URL, give the url of the webservice (.asmx)
    3. select "State Enabled" and "Message ID"
    and after creating a logical port,  set the proxy settings as in your webbrowser.
    (Http proxy server and port).
    then simply execute your webservice from SE80.

  • Hi friends need some help while creating background job

    I need to run a batch report in background in SM36 when any cancellation of sales order is done in VL09.
    i.e when a cancellation of sales order is done i have to run a batch report which will call an IDOC outbound generation function module that will create the IDOC.....
    Please tell me how to do this.....

    Hi,
    To submit backgroud jobs.
    Call Function 'Job_Open'.
    SUBMIT <report name>
    WITH <input variants>
    USER sy-uname
    VIA JOB <job name>
    AND RETURN.
    If sysubrc eq 0.
    Call Function 'Job_Close'.
    Reward if helpfull.

  • I forgot my restriction password in my iphone 4s i need some help to get my restriction password back thanks

    Hi i just need help to get my app store back i forgot my restriction password and i cant put the appstore back to the menu so ireally  cant update all my apps thanks

    Restore the device as new, there is no way to recover or reset the restrictions passcode.

  • Remote App on iPad connects but drops after about  20 mins. Need to turn  off wait about 1 minute then turn on wifi on iMac before it can reconnect. Need some help please.

    Remote App on iPad connects but drops after about  20 mins. Need to turn  off wait about 1 minute, then turn on wifi on iMac before it can reconnect. Need some help please.
    Already gone through troubleshooting guide a zillion times. Thanks.

    This worked for me... A little time consuming but once you get rolling it goes GREAT... Thanks....
    I got my artwork and saved it to my Desktop
    Opened up Microsoft Paint and clicked on "File" and "Open" and found it to get it on the screen to resize it
    Clicked "resize" and a box for changing it opened up
    Checked the box "Pixels" and "Unchecked maintain aspect ratio"
    Set Horizontal for 640 and Vertical for 480
    Clicked on "OK" and went back to "File" and did a "Save As" and chose JPEG Picture
    It came up "File Already Existed" and clicked "OK" (really did not care about the original artwork I found because wrong size)
    Went to iTunes and on the movie right clicked on "Get Info", clicked on "Details", then "Artwork"
    Go to the little box on the top left that shows your old artwork and click on it to get the little blue border to appear around it and hit "Delete" to make it gone
    Click on "Add Artwork" and find it where you put the one from above on your Desktop and hit "Open" and OK and your new artwork is now there and all good.
    Sounds like a lot of steps to follow but after around 5 or so you will fly through it. This worked perfect on my iPhone 6 Plus and I have artwork on my Home Videos now.

  • Need some help with downloading PDF's from the net.

    need some help with downloading PDF's from the net.  Each time I try to click on a link from a website, if it takes me to a new screen to view a pdf, it just comes up as a blank black screen?  any suggestions?

    Back up all data.
    Triple-click the line of text below to select it, the copy the selected text to the Clipboard (command-C):
    /Library/Internet Plug-ins
    In the Finder, select
    Go ▹ Go to Folder
    from the menu bar, or press the key combination shift-command-G. Paste into the text box that opens (command-V), then press return.
    From the folder that opens, remove any items that have the letters “PDF” in the name. You may be prompted for your login password. Then quit and relaunch Safari, and test.
    The "Silverlight" web plugin distributed by Microsoft can also interfere with PDF display in Safari, so you may need to remove it as well, if it's present.
    If you still have the issue, repeat with this line:
    ~/Library/Internet Plug-ins
    If you don’t like the results of this procedure, restore the items from the backup you made before you started. Relaunch Safari again.

  • Ok i have indesign CS6 and all files are stored on a 10.7.5 MAC server.  This just started happening.  When I open a file indesigns is creating a textfile in the same folder?  I need some help on this.

    Ok i have indesign CS6 and all files are stored on a 10.7.5 MAC server.  This just started happening.  When I open a file indesigns is creating a textfile in the same folder?  I need some help on this.

    Ask in the ID forum and be much more specific about your configuration. there could be any number of reasons why manifests, temp files or restore files are created.
    Mylenium

  • I need some help , for create some paper on air

    Hi everyone
    I need some help , i work in a static sequence from Tehran street (1 frame), i paint damages on this frame in Photoshop because i need war atmosphere, then i add some smoke and cloud with particular .
    but i think this sequence is not realistic yet
    now i want add some moving paper in air and on street
    do u have any solution for how can i make this paper and moving those
    Thanks a lot
    and pardon me for bad English
    Ali Molavi

    The best tool to add this kind of particle is After Effects.
    If you have the Creative Cloud then I recommend you download that.
    Slightly annoying voice over, but here is a youtube tutorial you can follow top make floating particals. You can adjust it to make it look exactly as you want.
    http://www.youtube.com/watch?v=dq2op6yqvFk&noredirect=1

  • Need some help with a remove function

    Design and code a program that will maintain a list of product names. Use a String type to represent the product name and an array of strings to implement the list. Your program must implement the following methods:
    Add a product to the list
    Remove a product from the list
    Display then entire list
    Find out if a particular product is on the list.
    You need to create a command command loop with a menu() function. The program must continue asking for input until the user stops.
    This is the assignment and this is what I have so far. I need some help writing the remove function.
    Thanks
    * Title: SimpleSearchableList.java
    * Description: this example will show a reasonably efficient and
    * simple algorithm for rearranging the value in an array
    * in ascending order.
    public class SimpleSearchableList {
         private static String[] List = new String[25]; //These variables (field variables)
         private static int Size; //are common to the entire class, but unavailable
         //except to the methods of the class...
         public static void main(String[] args)
              String Cmd;
              for(;;) {
                   Menu();
                   System.out.print("Command: ");
                   Cmd = SimpleIO.inputString();
                   if(Cmd.equals("Quit"))
                        break;
                   else if(Cmd.equals("Fill"))
                        FillList();
                   else if(Cmd.equals("Search"))
                        SearchList();
                   else if(Cmd.equals("Show"))
                        ShowList();
                   else if(Cmd.equals("Remove"))
                        Remove();
         //Tells you what you can do...
         public static void Menu()
              System.out.println("Choices..................................");
              System.out.println("\tFill to Enter Product");
              System.out.println("\tShow to Show Products");
              System.out.println("\tSearch to Search for Product");
              System.out.println("\tRemove a Product");
              System.out.println("\tQuit");
              System.out.println(".........................................");
         //This method will allow the user to fill an array with values...
         public static void FillList()
              int Count;
              System.out.println("Type Stop to Stop");
              for(Count = 0 ; Count < List.length ; Count++)
                   System.out.print("Enter Product: ");
                   List[Count] = SimpleIO.inputString();
                   if(List[Count].equals("Stop"))
                        break;
              Size = Count;
         //This method will rearrange the values in the array so that
         // go from smallest to largest (ascending) order...
         public static void SearchList()
              String KeyValue;
              boolean NotFoundFlag;
              int Z;
              System.out.println("Enter Product Names Below, Stop To Quit");
              while(true)
                   System.out.print("Enter: ");
                   KeyValue = SimpleIO.inputString();
                   if(KeyValue.equals("Stop")) //Note the use of a method for testing
                        break; // for equality...
                   NotFoundFlag = true; //We'll assume the negative
                   for(Z = 0 ; Z < Size ; Z++)
                        if(List[Z].equals(KeyValue)) {
                             NotFoundFlag = false; //If we fine the name, we'll reset the flag
              System.out.println(List[Z] + " was found");
                   if(NotFoundFlag)
                        System.out.println(KeyValue + " was not found");     
         //This method will display the contents of the array...
         public static void ShowList()
              int Z;
              for(Z = 0 ; Z < Size ; Z++)
                   System.out.println("Product " + (Z+1) + " = " + List[Z]);
         public static void Remove()
    }

    I need help removing a product from the arrayYes. So what's your problem?
    "Doctor, I need help."
    "What's wrong?"
    "I need help!"
    Great.
    By the way, you can't remove anything from an array. You'll have to copy the remaining stuff into a new one, or maybe maintain a list of "empty" slots. Or null the slots and handle that. The first way will be the easiest though.

  • Need some help with GUI development

    Hi ppl.. I am new to labview and I am currently involved in a testing equipment development. I need some help. firstly I need to know if multi-screen GUI (with icons and stuff)is possible in Labview. Secondly I need to interface the measurements to a database. Would it be possible to create just small executable to perform the measurement part alone and do the rest of database operation using VB. (or would it be advisable to do the whole lot in labview)
    the final sft should look something like this
    screen1 :setup screen... interface with database
    screen2 :actual test and test results
    screen3 :log file creation
    measurement is via daq board and i also need to send some control signals and set up TCP/IP for data transfer.

    Hello.
    I am not completely sure what you mean by "multi-screen", but I am pretty sure that doing the user interface using a tab control will work for you. I have attached an example VI which is a state machine (which in LabVIEW you do with a case structure inside a while loop). Notice how the configuration controls are in the first page of the tab control, associated with state 0 of the state machine, but in the block diagram, they are actually used in state 1 of the state machine. Instead of writing a very long description, I will let you take a look at the code (which I saved in LV 7.0 version). Let me know if you have questions or comments
    Attachments:
    MultiScreenStateMachineExample.vi ‏50 KB

  • Need some Help configuring sip

    Hi all ! ,
    Im kind off new to sip calling and cisco telephony , but here goes ,: i have a 2821 router with CME installed
    IOS : C2800NM-IPVOICEK9-M
    Sofware version : 15.1(4)M4 / CME 8.6
    Attached to GE0/0 is a CISCO 3750 switch
    GEO - consisfts of 3 VLANS  , the native
    172.22.1.X
    172.22.100.X VOICE
    172.22.101.X DATA
    my tftpserver = 172.22.1.150
    i need some help configuring a sip trunk , i have 10 testing phonenumbers from vodafone , but i do not know where to start to get this working
    i have tried
    http://www.cisco.com/en/US/products/sw/voicesw/ps4625/products_configuration_example09186a00808f9666.shtml
    but im getting stuck with what to fill in where .. is there anyone form NL whom has the same setup ? or similar ? or can give me some guidance on how to make the test calls

    ok.. here goes
    Building configuration...
    Current configuration : 9721 bytes
    ! Last configuration change at 15:26:14 CET Thu Jan 2 2014
    ! NVRAM config last updated at 15:26:14 CET Thu Jan 2 2014
    ! NVRAM config last updated at 15:26:14 CET Thu Jan 2 2014
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname Router
    boot-start-marker
    boot-end-marker
    no aaa new-model
    clock timezone CET 1 0
    network-clock-participate wic 0
    network-clock-participate wic 1
    network-clock-select 1 E1 0/0/0
    network-clock-select 2 E1 0/0/1
    dot11 syslog
    ip source-route
    ip cef
    ip dhcp pool VOICE
    network 172.22.100.0 255.255.255.0
    option 150 ip 172.22.1.150
    default-router 172.22.100.1
    ip dhcp pool DATA
    network 172.22.101.0 255.255.255.0
    default-router 172.22.101.1
    no ip domain lookup
    no ipv6 cef
    multilink bundle-name authenticated
    isdn switch-type primary-net5
    voice service voip
    ip address trusted list
      ipv4 172.22.1.50
      ipv4 172.22.1.51
      ipv4 172.22.100.1
      ipv4 172.22.101.1
      ipv4 62.140.159.225
    callmonitor
    allow-connections h323 to h323
    allow-connections h323 to sip
    allow-connections sip to h323
    allow-connections sip to sip
    no supplementary-service sip moved-temporarily
    no supplementary-service sip refer
    sip
      registrar server expires max 3600 min 3600
    voice class codec 1
    codec preference 1 g711ulaw
    codec preference 2 g711alaw
    codec preference 3 g729r8
    codec preference 4 g729br8
    voice register global
    voice translation-rule 1
    rule 1 /5123781291/ /601/
    rule 2 /5123781290/ /600/
    voice translation-rule 2
    rule 1 /^112$/ /112/
    voice translation-rule 3
    rule 1 /^.*/ /0262610290/
    voice translation-rule 4
    rule 2 /600/ /5123788000/
    rule 3 /601/ /5123788001/
    rule 4 /^2(..)$/ /51237812\1/
    voice translation-profile CUE_Voicemail/AutoAttendant
    translate called 1
    voice translation-profile PSTN_CallForwarding
    translate redirect-target 4
    translate redirect-called 4
    voice translation-profile PSTN_Outgoing
    translate calling 3
    translate called 2
    translate redirect-target 4
    translate redirect-called 4
    voice-card 0
    crypto pki token default removal timeout 0
    controller E1 0/0/0
    framing NO-CRC4
    pri-group timeslots 1-31
    controller E1 0/0/1
    framing NO-CRC4
    pri-group timeslots 1-31
    ip ftp username cisco
    ip ftp password cisco123
    ip tftp source-interface GigabitEthernet0/0.1
    interface GigabitEthernet0/0
    no ip address
    duplex auto
    speed auto
    no keepalive
    interface GigabitEthernet0/0.1
    encapsulation dot1Q 1 native
    ip address 172.22.1.51 255.255.255.0
    interface GigabitEthernet0/0.20
    encapsulation dot1Q 20
    ip address 172.22.101.1 255.255.255.0
    interface GigabitEthernet0/0.100
    encapsulation dot1Q 100
    ip address 172.22.100.1 255.255.255.0
    interface GigabitEthernet0/1
    no ip address
    shutdown
    duplex full
    speed 100
    interface Serial0/0/0:15
    no ip address
    encapsulation hdlc
    isdn switch-type primary-net5
    isdn incoming-voice voice
    no cdp enable
    interface Serial0/0/1:15
    no ip address
    encapsulation hdlc
    isdn switch-type primary-net5
    isdn incoming-voice voice
    no cdp enable
    interface BRI0/1/0
    no ip address
    isdn switch-type basic-net3
    isdn point-to-point-setup
    interface BRI0/1/1
    no ip address
    isdn switch-type basic-net3
    isdn point-to-point-setup
    ip forward-protocol nd
    ip http server
    ip http authentication local
    no ip http secure-server
    ip http max-connections 16
    ip http path flash:gui
    ip route 0.0.0.0 0.0.0.0 172.22.1.50
    tftp-server flash:7941/apps41.8-4-1-23.sbn alias apps41.8-4-1-23.sbn
    tftp-server flash:7941/cnu41.8-4-1-23.sbn alias cnu41.8-4-1-23.sbn
    tftp-server flash:7941/dsp41.8-4-1-23.sbn alias dsp41.8-4-1-23.sbn
    tftp-server flash:7941/jar41sccp.8-4-1-23.sbn alias jar41sccp.8-4-1-23.sbn
    tftp-server flash:7941/cvm41sccp.8-4-1-23.sbn alias cvm41sccp.8-4-1-23.sbn
    tftp-server flash:7941/SCCP41.8-4-2S.loads alias SCCP41.8-4-2S.loads
    tftp-server flash:7941/term41.default.loads alias term41.default.loads
    tftp-server debug
    control-plane
    voice-port 0/0/0:15
    voice-port 0/1/0
    voice-port 0/1/1
    voice-port 0/0/1:15
    voice-port 2/0/0
    voice-port 2/0/1
    voice-port 2/0/2
    voice-port 2/0/3
    voice-port 2/0/4
    voice-port 2/0/5
    voice-port 2/0/6
    voice-port 2/0/7
    voice-port 2/0/8
    voice-port 2/0/9
    voice-port 2/0/10
    voice-port 2/0/11
    voice-port 2/0/12
    voice-port 2/0/13
    voice-port 2/0/14
    voice-port 2/0/15
    voice-port 2/0/16
    voice-port 2/0/17
    voice-port 2/0/18
    voice-port 2/0/19
    voice-port 2/0/20
    voice-port 2/0/21
    voice-port 2/0/22
    voice-port 2/0/23
    mgcp profile default
    dial-peer voice 1 voip
    description **Incomming Call from SIP Trunk**
    translation-profile incoming CUE_Voicemail/AutoAttendant
    session protocol sipv2
    session target ipv4:172.22.1.50
    incoming called-number .%
    voice-class codec 1
    voice-class sip dtmf-relay force rtp-nte
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 2 voip
    description **Outgoing Call to SIP Trunk**
    translation-profile outgoing PSTN_Outgoing
    destination-pattern 9........
    session protocol sipv2
    session target ipv4:172.22.1.50
    voice-class codec 1
    voice-class sip dtmf-relay force rtp-nte
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 3 voip
    description **Outgoing Call to SIP Trunk **
    translation-profile outgoing PSTN_Outgoing
    destination-pattern 9[2-9]..[2-9]......
    session protocol sipv2
    session target ipv4:172.22.1.50
    voice-class codec 1
    voice-class sip dtmf-relay force rtp-nte
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 4 voip
    description **Outgoing Call to SIP Trunk**
    translation-profile outgoing PSTN_Outgoing
    destination-pattern 9[0-1][2-9]..[2-9]......
    session protocol sipv2
    session target ipv4:172.22.1.50
    voice-class codec 1
    voice-class sip dtmf-relay force rtp-nte
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 5 voip
    description **911 Outgoing Call to SIP trunk**
    translation-profile outgoing PSTN_Outgoing
    destination-pattern 911
    session protocol sipv2
    session target ipv4:172.22.1.50
    voice-class codec 1
    voice-class sip dtmf-relay force rtp-nte
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 6 voip
    description **Emergency Outgoing Call to SIP Trunk**
    translation-profile outgoing PSTN_Outgoing
    destination-pattern 9911
    session protocol sipv2
    session target ipv4:172.22.1.50
    voice-class codec 1
    voice-class sip dtmf-relay force rtp-nte
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 7 voip
    description **911/411 Outgoing Call to SIP Trunk**
    translation-profile outgoing PSTN_Outgoing
    destination-pattern 9[2-9]11
    session protocol sipv2
    session target ipv4:172.22.1.50
    voice-class codec 1
    voice-class sip dtmf-relay force rtp-nte
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 8 voip
    description **International Outgoing Call to SIP Trunk**
    translation-profile outgoing PSTN_Outgoing
    destination-pattern 9011T
    session protocol sipv2
    session target ipv4:172.22.1.50
    voice-class codec 1
    voice-class sip dtmf-relay force rtp-nte
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 9 voip
    description **Star Code to SIP Trunk**
    destination-pattern *..
    session protocol sipv2
    session target ipv4:172.22.1.50
    voice-class codec 1
    voice-class sip dtmf-relay force rtp-nte
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 10 voip
    description **CUE Voicemail**
    translation-profile outgoing PSTN_CallForwarding
    destination-pattern 600
    b2bua
    session protocol sipv2
    session target ipv4:172.22.1.155
    dtmf-relay sip-notify
    codec g711ulaw
    no vad
    dial-peer voice 11 voip
    description **CUE Auto Attendant**
    translation-profile outgoing PSTN_CallForwarding
    destination-pattern 601
    b2bua
    session protocol sipv2
    session target ipv4:172.22.1.155
    dtmf-relay sip-notify
    codec g711ulaw
    no vad
    sip-ua
    authentication username 0262610290 password 7 15020A1F173D24362C realm 62.140.1
    59.225
    authentication username 0262610290 password 7 021605481811003348
    no remote-party-id
    retry invite 2
    retry register 10
    timers connect 100
    registrar ipv4:62.140.159.225 expires 3600
    sip-server ipv4:62.140.159.224
    host-registrar
    telephony-service
    max-ephones 58
    max-dn 192
    ip source-address 172.22.100.1 port 2000
    calling-number initiator
    system message testing
    cnf-file location TFTP tftp://172.22.1.150/
    load 7960-7940 P00307020200.loads
    load 7941 SCCP41.8-4-2S.loads
    load 7941GE SCCP41.8-4-2S
    time-format 24
    dialplan-pattern 1 26261029.. extension-length 3 extension-pattern 9..
    voicemail 600
    max-conferences 12 gain -6
    call-forward pattern 9.T
    moh music-on-hold.au
    web admin system name admin password password
    dn-webedit
    time-webedit
    transfer-system full-consult
    secondary-dialtone 9
    directory entry 1 101 name 101
    create cnf-files version-stamp 7960 Jan 02 2014 08:40:49
    ephone-dn  1
    number 290 secondary 0262610290
    name Phone 1
    hold-alert 30 originator
    ephone-dn  2
    number 291 secondary 0262610291
    name phone 2
    hold-alert 30 originator
    ephone-dn  3
    number 292 secondary 0262610292
    name Phone 3
    hold-alert 30 originator
    ephone-dn  4
    number 293 secondary 0262610293
    name Phone 4
    hold-alert 30 originator
    ephone-dn  5
    number 294 secondary 0262610294
    label Phone 5
    hold-alert 30 originator
    ephone  1
    mac-address 0019.E88F.3BDD
    button  1:1
    ephone  2
    mac-address 001E.4A92.0A27
    type 7961
    button  1:2
    ephone  3
    mac-address 0012.43F5.03AF
    button  1:3
    ephone  4
    mac-address 000F.F7AC.502A
    button  1:4
    ephone  5
    mac-address 0019.E851.090A
    button  1:5
    line con 0
    line aux 0
    line vty 0 4
    login
    transport input all
    scheduler allocate 20000 1000
    ntp master
    end

Maybe you are looking for