Needed help for  query

Hi All,
Here is requirement
User X has View only and Account manager Role then we don't need to report any changes for him. And if User Y has View Only role then we need to report his activity.
select u.loginname, p.firstname,p.lastname,g.name
from sc_user u, bqperson p, sc_acl_group_mem gm,
sc_acl_group g,sc_acl_group gnm
where u.bqperson = p.tril_gid and u.tril_groups = gm.collectiongid AND gm.objectgid =
g.tril_gid AND
(g.NAME LIKE 'VIEW ONLY' OR g.NAME LIKE 'SME%')
ORDER BY loginname
Here is out put
LOGINNAME FIRSTNAME LASTNAME NAME
b684276 xxx xxx VIEW ONLY
default Guest User VIEW ONLY
n105371 Adil Khan SME EXGRATIA ADMINISTRATOR
n105371 Adil Khan SME SERVICE CENTRE SUPERVISOR
n105371 Adil Khan SME PROMOTIONS ADMINISTRATOR
n105557 Emmanuel Kajjor SME EXGRATIA ADMINISTRATOR
n105557 Emmanuel Kajjor SME SERVICE CENTRE SUPERVISOR
n105740 Priya Ghag SME EXGRATIA ADMINISTRATOR
n105740 Priya Ghag SME SERVICE CENTRE SUPERVISOR
n106311 Megha Nalawade SME EXGRATIA ADMINISTRATOR
n106311 Megha Nalawade SME SERVICE CENTRE SUPERVISOR
n106311 Megha Nalawade SME PROMOTIONS ADMINISTRATOR
n107864 Ragini Sule SME EXGRATIA ADMINISTRATOR
n107864 Ragini Sule SME SERVICE CENTRE SUPERVISOR
n107864 Ragini Sule SME PROMOTIONS ADMINISTRATOR
n110022 Harikrishna Kurup SME EXGRATIA ADMINISTRATOR
n110022 Harikrishna Kurup SME SERVICE CENTRE SUPERVISOR
n110022 Harikrishna Kurup SME PROMOTIONS ADMINISTRATOR
n110450 Rachana Vasandani SME EXGRATIA ADMINISTRATOR
n110450 Rachana Vasandani SME SERVICE CENTRE SUPERVISOR
n110932 Jigna Trivedi SME EXGRATIA ADMINISTRATOR
n110932 Jigna Trivedi SME PROMOTIONS ADMINISTRATOR
n110932 Jigna Trivedi SME SERVICE CENTRE SUPERVISOR
Please advice
Thanks in advance
Sachin

Hi Sudeep,
Account manager is Simply a role like View Only and 'SME %'
Some user can have Roles Like 'View only' ,'Account manager' ,'SME%' They are all differnt Role
Some user Can have only 'View only' Role
Some user can have 'SMe%' Role
Some user can have 'SMe%' , 'Account manager' Role
etc probabilites
I want to retrieve the record for thiose user who have 'View only' Role or 'SMe%' Role
Some times it might happened user can have 'View only' ,'Account manager' ,'SME%' .This should come in list
if USer has any role with 'Account Manager' its result should not appear in Query other wise it should appear

Similar Messages

  • Need help for query... exam incoming...

    ARTIST(CodA,NameA)
    WORK(CodW,Title,AuthorCode,ExpositionCode)
    Question:
    For each ExpositionCode, find the artists with the greater number of exposed works
    Pls... help!!
    Fabio

    It's running, i have only to remove title
    italics with howmuch as
    italics(select ExpositionCode,AuthorCode,count(*) n from work
    italicsgroup by ExpositionCode,AuthorCode)
    italicsselect ExpositionCode,AuthorCode,n from howmuch h1,ARTIST a
    italicswhere h1.n=(select max(n) from howmuch h2 where h2.ExpositionCode=h1.ExpositionCode)
    italicsand a.CodA=h1.AuthorCode
    I have only a little problem... i can't use "with" clause in the exam, can u write a running query without that?

  • Need help for query

    I have Table1
    ID -- Key -- Name -- City
    1--R1--abc--xyz
    2--R1--abc--xyz
    3--R1--pqr--xyz
    4--R1--abc--xyz
    5--R1--abc--stp
    6--R2--abc1--xyz1
    7--R2--abc1--xyz1
    8--R2--pqr1--xyz1
    9--R2--abc1--xyz1
    10--R2--abc1--stp1
    I want to get result - Max(ID) where Key + Name + City is same for all rows. there should be one max per key
    and result like -
    Key-- MaxID
    R1--4
    R2--9
    Edited by: 871447 on Oct 19, 2011 1:54 PM
    Edited by: 871447 on Oct 19, 2011 1:56 PM

    Maybe (NOT TESTED!)
    select key,max_id
      from (select key,name,city,max(id) max_id,count(*) cnt
              from table1
             group by key,name,city
    where cnt > 1Regards
    Etbin

  • Need Help to query Lync Database for User Information

    Need Help to Query the lync database to retrieve below user information.
    1. SIP Address of the registered user
            2. Phone Number configured to the particular account.
            3. IP Address
           4. Last Logged in time.
    I am trying to pull the above information from rtc database for all the registered users. Please let me know if this is possible and it would be great if you can throw some light on what tables to look for the data. Thank You.

    Hi,
    For SIP address and Phone number you can check RTC database.
    IP Address:
    You can refer to the link below to query IP address: 
    http://h30499.www3.hp.com/t5/Business-Service-Management-BAC/Monitoring-Lync-with-the-User-Registrations-Viewer-Free-NMC-tool/ba-p/5961497#.UtOU43mIrwo
    Note: Microsoft is providing this information as a convenience to you. The sites are not controlled by Microsoft. Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there.
    Please make sure that you completely understand the risk before retrieving any suggestions from the above link.
    Last Logged in time:
    You can refer to the link below:
    http://blogs.technet.com/b/dodeitte/archive/2011/05/11/how-to-get-the-last-time-a-user-registered-with-a-front-end.aspx
    Best Regards,
    Eason Huang
    Eason Huang
    TechNet Community Support

  • Need help for Transfer PO

    need help for Transfer PO.
    i need help for to transfer PO from one season to onther season. pleas ehelp me how to proceed and how 2 approach the process.
    if any code is there please provide  me

    follow the link
    it may help you
    MM SCENARIO
    https://www.sdn.sap.com/irj/sdn/advancedsearch?cat=sdn_all&query=abapcodetotransferpurchaseorder&adv=true&sdn_author_name=&sdn_allusernamesofthread=&sdn_category=&sdn_forum=&sdn_updated_on_comparator=GE&sdn_updated_on=&sortby=cm_rnd_rankvalue
    reward if helpful
    Edited by: sharad narayan on Apr 8, 2008 3:16 PM

  • Need tcode for Query analyzer

    hi i want to test query in query analyzer befor using in programe.
    i need tcode for query analyzer.
    thanks in advanced.

    hi,,
    SE30 - gives you a run time analysis and points out the issues more at design time.
    ST05 - Is the most useful if you want to track time taken for execution of each of the sections.
    SM50 - Will give you a work process overview, not sure at a program level how can it help you.
    Some times you will have to use a combination of SE30 and ST05.
    I would like to use St05 personally.
    rgds
    anver
    if hlped mark points

  • I have problem with buying in games , I got the massage that the purchased can not be completed , please contact iTunes support.. I need help for my case please

    I have problem with buying in games , I got the massage that the purchased can not be completed , please contact iTunes support.. I need help for my case please

    http://www.apple.com/support/itunes/contact/

  • Need help for Format HD

    Hi I need Help for Formating HD so Wat Key need hold on start up for format HD I apprciated you Help

    Jesus:
    Formatting, Partitioning Erasing a Hard Disk Drive
    Warning! This procedure will destroy all data on your Hard Disk Drive. Be sure you have an up-to-date, tested backup of at least your Users folder and any third party applications you do not want to re-install before attempting this procedure.
    • With computer shut down insert install disk in optical drive.
    • Hit Power button and immediately after chime hold down the "C" key.
    • Select language
    • Go to the Utilities menu (Tiger) Installer menu (Panther & earlier) and launch Disk Utility.
    • Select your HDD (manufacturer ID) in left side bar.
    • Select Partition tab in main panel. (You are about to create a single partition volume.)
    • _Where available_ +Click on Options button+
    +• Select Apple Partition Map (PPC Macs) or GUID Partition Table (Intel Macs)+
    +• Click OK+
    • Select number of partitions in pull-down menu above Volume diagram.
    (Note 1: One partition is normally preferable for an internal HDD.)
    • Type in name in Name field (usually Macintosh HD)
    • Select Volume Format as Mac OS Extended (Journaled)
    • Click Partition button at bottom of panel.
    • Select Erase tab
    • Select the sub-volume (indented) under Manufacturer ID (usually Macintosh HD).
    • Check to be sure your Volume Name and Volume Format are correct.
    • Click Erase button
    • Quit Disk Utility.
    cornelius

  • Need help for my requirement...

    Need help for my requirement...
    Hello Experts,
    I have report where users can input the company, housebank, account ID and posting date.
    Now in one column of my report named 'Cash in Bank', I need to get all postings from cash
    accounts with GL code ending in '0'. Now, I know that I can get the amounts in BSIS/BSAS
    but how do I link it with the proper bank and account?
    For example:
                       Cash in Bank
    Bank A
      Account ID 1     1,000,000
      Account ID 2     25,000,000
    Hope you can help me guys. Thank you and take care!

    hi Viraylab,
    each house bank you can find in table T012, in T012K you'll find the bank accounts to the housebank, the G/L account will be in T012K-HKONT.
    hope this helps
    ec

  • Need help for flash builder

    i need help for flash builder 4 and papervison 3d. I need to create a slider with it ranges of value from 10 to 50 to adjust the camera values for the camera.fov and also need to create it for the yaw of the object from 0 to 360. I try to look for any slider event and classes in this program but cant find any, btw, i need to use the AS only project file.
    here is my codes:
    can you please tell me how i should modify the codes?
    package
        import flash.display.BitmapData;
        import flash.display.Sprite;
        import flash.events.Event;
        import org.papervision3d.materials.BitmapFileMaterial;
        import org.papervision3d.materials.BitmapMaterial;
        import org.papervision3d.objects.primitives.Sphere;
        import org.papervision3d.view.BasicView;
        [SWF (width="800", height="600", backgroundColor="0x000000",frameRate="30")]
        public class EarthBitmap extends BasicView
            private var sphere:Sphere;
            public function EarthBitmap()
                super(800 , 600);
                var earthmaterial:BitmapFileMaterial = new BitmapFileMaterial("../assets/Earth.jpg");
                sphere = new Sphere(earthmaterial,100,20,18);
                camera.fov = 25;
                scene.addChild(sphere);
                addEventListener(Event.ENTER_FRAME,rotateSphere);
            public function rotateSphere(evt:Event):void
                sphere.yaw(0.2);
                singleRender();

    Turn the click handler into a full on separate function. Then store all the views in an array and use Math.rand() to randomly choose one.
    Something like this:
    <fx:Script>
         <![CDATA[
              var questionsArray:Array = {question2,question3,question5,questionRed,questionGeography};
              function buttonClickHandler(event:MouseEvent){
                   var randomProblem:int = Math.floor(Math.random()*(questionsArray.length));     //generates a random integer between 0 and the total number of questions in the array (arrays are 0-based)
                   navigator.pushView(questionsArray[randomProblem]);
         ]]>
    </fx:Script>
    <s:Button id="randomProblemButton" label="Next Problem" click="buttonClickHandler(event)" />
    Haven't tested that, but something along that line should work

  • Need help for importing oracle 10G dump into 9i database

    hi, Someone help me to import oracle 10G dump into 9i database. I'm studying oracle . Im using oracle 10G developer suite(downloaded from oracle) and oracle 9i database. I saw some threads tat we can't import the higher version dumps into lower version database. But i'm badly need help for importing the dump...
    or
    someone please tell me the site to download oracle 9i Developer suite as i can't find it in oracle site...

    I didnt testet it to import a dump out of a 10g instance into a 9i instance if this export has been done using a 10g environment.
    But it is possible to perform an export with a 9i environment against a 10g instance.
    I am just testing this with a 9.2.0.8 environment against a 10.2.0.4.0 instance and is working so far.
    The system raises an EXP-00008 / ORA-37002 error after exporting the data segments (exporting post-schema procedural objects and actions).
    I am not sure if it is possible to perform an import to a 9i instance with this dump but maybe worth to give it a try.
    It should potentially be possible to export at least 9i compatible objects/segments with this approach.
    However, I have my doubts if this stunt is supported by oracle ...
    Message was edited by:
    user434854

  • Need Help for Nokia 6500 slide

    Hi all I'm A new Guy here ,
    But I do really need help for hard reset my phone
    I already try *#7073# But It doesn't work ,
    If Anybody know to make a hard reset please help

    rwss wrote:
    I'v got te same problem with my 6500 Slide, is there a button combination that we have to press
    to hard reset the 6500 Slide?!
    How does the 6500 slide hard reset?
    That's simple.
    All you have to do is:
    From MENU goto SETTINGS, When there scroll down and select 'Restore Factory Setting'.
    There are two options in there:
    "Restore Settings only"
    and
    "Restore all"
    Select "Restore All"
    When done the phone will delete every thing on the Phone memory(C:\)(contacts,picture,messages etc)
    and also restore phone to its original settings and will restart.
    This proceedure is mostly common on S40 phone.
    Hope this explain and solve the problem.

  • Need help for publishing web intelligence document (universe) into InfoView

    Post Author: mirage
    CA Forum: Publishing
    Hello all,
    I need help for publishing web intelligence document (universe) into InfoView.
    can't find this information in Business Objects Designer's Guide and in Business Objects Administrator Guide.
    Can somebody give short instructions how can I do it?
    Regards, Slava

    If the change between the 2 types of data has to happen dynamically during run time them
    1. Use 2 dataproviders
         a. Current
         b. Historic
    2. Merge the 2 dimensions
    3. Use Webi variable to switch between the measure of the current and historic universe
    Ex  if [year] < 2010 then historic.[expense] else current.[expense]
    Hope this helps,
    Divya

  • Need help for access list problem

    Cisco 2901 ISR
    I need help for my configuration.... although it is working fine but it is not secured cause everybody can access the internet
    I want to deny this IP range and permit only TMG server to have internet connection. My DHCP server is the 4500 switch.
    Anybody can help?
             DENY       10.25.0.1 – 10.25.0.255
                              10.25.1.1 – 10.25.1.255
    Permit only 1 host for Internet
                    10.25.7.136  255.255.255.192 ------ TMG Server
    Using access-list.
    ( Current configuration  )
    object-group network IP
    description Block_IP
    range 10.25.0.2 10.25.0.255
    range 10.25.1.2 10.25.1.255
    interface GigabitEthernet0/0
    ip address 192.168.2.3 255.255.255.0
    ip nat inside
    ip virtual-reassembly in max-fragments 64 max-reassemblies 256
    duplex auto
    speed auto
    interface GigabitEthernet0/1
    description ### ADSL WAN Interface ###
    no ip address
    pppoe enable group global
    pppoe-client dial-pool-number 1
    interface ATM0/0/0
    no ip address
    no atm ilmi-keepalive
    interface Dialer1
    description ### ADSL WAN Dialer ###
    ip address negotiated
    ip mtu 1492
    ip nat outside
    no ip virtual-reassembly in
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication pap callin
    ppp pap sent-username xxxxxxx password 7 xxxxxxxxx
    ip nat inside source list 101 interface Dialer1 overload
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip route 10.25.0.0 255.255.0.0 192.168.2.1
    access-list 101 permit ip 10.25.0.0 0.0.255.255 any
    access-list 105 deny   ip object-group IP any
    From the 4500 Catalyst switch
    ( Current Configuration )
    interface GigabitEthernet0/48
    no switchport
    ip address 192.168.2.1 255.255.255.0 interface GigabitEthernet2/42
    ip route 0.0.0.0 0.0.0.0 192.168.2.3

    Hello,
    Host will can't get internet connection
    I remove this configuration......         access-list 101 permit ip 10.25.0.0 0.0.255.255 any
    and change the configuration ....      ip access-list extended 101
                                                                5 permit ip host 10.25.7.136 any
    In this case I will allow only host 10.25.7.136 but it isn't work.
    No internet connection from the TMG Server.

  • Need help for cenvat reversal

    Hi Friends,
    Need help for cenvat reversal.
    Reversed MIRO by MR8M & MIGO by 102 movement but not able to post & cancel cenvat by J1IEX.
    In table J_1IEXCHDR status = "P" and J1I5 does not update for document of 102 movement because reversal document of MIGO, i.e. material document with 102 movement type does not have excise tab. MBSM-Cancelled Material Documents, does not show any of the material documents.
    Want to reverse the cenvat credit, please help.
    --Anil Bhamere

    Hi,
    If I select Cancellation in MIGO then there is only Material Document option.
    In MIGO Purchase Order option shows for Goods Receipt, Goods Issue and Subsequet Adj.
    In this case I have been selected Goods Receipt option followed by purchase order number by which original goods receipt MIGO was created, selected 102 movement type and from line item respective MIGO document. The reversal document created successfully where as original MIGO document does not show in cancelled document list. When post option selected from J1IEX and entered vendor excise number then message appeared as No Part I exists for availing credit in excise invoice xxxxx.
    If Cancel option selected from J1IEX and entered vendor excise number then message appeared as Excise invoice xxxx has already been posted for vendor xxxxx.
    Please help.
    Regards,
    Anil Bhamere

Maybe you are looking for

  • Text in purchased book disappeared after update

    I just updated my iPad to 5.1.1 and iBooks to 2.1.1.  After updating and synching to my iMac, I opened a book that I had purchased one month ago and had been reading.  All the text had disappeared.  I had nothing but blank pages except for the title

  • Where is the file which stores the users and groups policies?

    Hi, as mentioned in the title..i would like to know which file stores the policies of the users and groups which i've defined. And where is this file stored? Thanks.

  • Issue while running Report /SAPAPO/SDORDER_DEL

    Hello All, We are using the first tab "Delete on database" in the Report /SAPAPO/SDORDER_DEL. We have created a variant with a combination of selections like "Locations" and "Last before change date" and also we checked the addtional functions "Compa

  • File Upload Example in ADF Development Guide

    I tried to upload a file using ADF as described in Development Guide. I have taken a <af:inputFile> component as described. <af:inputFile label="#{res['srfileupload.uploadlabel']}" valueChangeListener="#{backing_SRFileUpload.fileUploaded}" binding="#

  • Adobe Reader 9.3 install Fails - Why?

    I run Windows 7 - 64 bit on a Dell laptop.  When I try to load AR v. 9.3, I just get a message informing me it can't be installed.  No reasons.  No options.  Nothing but an "OK" button to exit the pop-up.  Real user friendly!  What gives?