Netcfg breaks wireless dhcp?

I'm using the brcmsmac module in 3.0 and have been able to connect to the wireless network fine using wpa_supplicant. I've been using a manual method to connect so I thought I would move to netcfg. I installed netcfg through pacman and am using the following config file in /etc/network.d/wireless
CONNECTION='wireless'
DESCRIPTION='A simple WPA encrypted wireless connection'
INTERFACE='wlan0'
SECURITY='wpa'
ESSID='biteynet'
KEY='myawesomepassword''
IP='dhcp'
# Uncomment this if your ssid is hidden
#HIDDEN=yes
I also updated /etc/rc.conf to remove network and add netcfg to my daemons and add the line
NETWORKS=(wireless)
The wireless connects fine initially when I run netcfg wireless, but am having problems maintaining an IP address. I receive the ip address according to dhcpcd but lose it immediately. Even running dhcpcd manually does not solve the problem. I've tried running dhcpcd --nohook mtu but that didn't help either
Aug 12 20:17:24 localhost dhcpcd[810]: version 5.2.12 starting
Aug 12 20:17:24 localhost dhcpcd[810]: wlan0: rebinding lease of 192.168.1.104
Aug 12 20:17:24 localhost dhcpcd[810]: wlan0: acknowledged 192.168.1.104 from 192.168.1.1
Aug 12 20:17:24 localhost dhcpcd[810]: wlan0: checking for 192.168.1.104
Aug 12 20:17:29 localhost dhcpcd[810]: wlan0: leased 192.168.1.104 for 86400 seconds
Aug 12 20:17:29 localhost dhcpcd[810]: forked to background, child pid 833
Aug 12 20:17:42 localhost dhcpcd[833]: wlan0: carrier lost
Aug 12 20:17:42 localhost kernel: [ 59.064218] cfg80211: Calling CRDA for country: US
Aug 12 20:17:43 localhost dhcpcd[833]: wlan0: carrier acquired
Aug 12 20:17:43 localhost dhcpcd[833]: wlan0: rebinding lease of 192.168.1.104
Aug 12 20:17:53 localhost dhcpcd[833]: wlan0: broadcasting for a lease
Aug 12 20:17:53 localhost dhcpcd[833]: wlan0: carrier lost
Aug 12 20:17:53 localhost kernel: [ 70.164055] cfg80211: Calling CRDA to update world regulatory domain
Aug 12 20:17:54 localhost dhcpcd[833]: wlan0: carrier acquired
Aug 12 20:17:54 localhost dhcpcd[833]: wlan0: rebinding lease of 192.168.1.104
Aug 12 20:18:04 localhost dhcpcd[833]: wlan0: broadcasting for a lease
Aug 12 20:18:04 localhost dhcpcd[833]: wlan0: carrier lost
Aug 12 20:18:04 localhost kernel: [ 81.303433] cfg80211: Calling CRDA to update world regulatory domain
Removing netcfg from my daemons and using wpa_supplicant continue to work fine.
Any help would be appreciated.
Last edited by multiphrenic (2011-08-13 01:30:26)

There are some bugs wrt netcfg
https://bugs.archlinux.org/task/25473
https://bugs.archlinux.org/task/25476

Similar Messages

  • Netcfg laptop wireless - "DHCP ip lease attempt failed"??

    hey folks. just loaded arch onto a toshiba laptop. in the process of configuring wireless, i followed the netcfg config instructions in the wiki. It worked fine the first time, but when I rebooted every subsequent time i tried to connect I get the "DHCP IP lease attempt failed" error. IN my logs i get absolutely nothing helpful - just "wlan0: rebinding lease of 172.16.0.138" and "wlan0: timed out". Of course, when I had Windows XP on the laptop it had zero problems connecting to the network, and it makes no damn sense why I was able to connect intially but each time after that it times out. My router has no problems.
    I did a forum search and someone suggested that this was because of a "bug" and to delete the file "/var/lib/dhcpcd/dhcpcd-wlan0.lease" file. I did this, and was able to connect successfully. But this is not a solution; am I really supposed to delete the lease EVERY time I reconnect/reboot the machine? Doesn't make any sense at all.
    Can ANYONE please help on this? I can post whatever config file/log info you need. This seems like it should be a simple setup, but I've come to realize nothing's ever simple in the linux world.... btw my network uses WPA2. There wasn't anything in the wiki about WPA2 (must be really really old, huh?); could this be part of the problem?

    Alternatively, try adding
    PRE_UP=' [ -e /var/lib/dhcpcd/dhcpcd-wlan0.lease ] && rm /var/lib/dhcpcd/dhcpcd-wlan0.lease '
    to the profile with the problem.
    Edit: I misspelled "dhcpcd" in the code above.
    Last edited by alexandrite (2010-08-15 14:54:33)

  • Change default wireless dhcp

    I want to deploy an Airport in an existing network address space of 10.90.8.0. The default wireless dhcp address space is 10.0.1..0. Can I change that default or must I reassign all ip address to conform with the Airport default?

    If you configure the AirPort Express in Bridge Mode, it will pick up an IP address from your "main" router.
    If you have the AirPort Express configured to provide DHCP services and hand out IP addresses, then those addresses will be limited to the 10.0.x.x range. The Express can also provide addresses in the 192.168.x.x range and 172.16.x.x range as well.

  • Order of profiles for netcfg-auto-wireless

    Hi fellow Archers,
    I'm running Arch Linux with netcfg 2.5.4 on my laptop, and have several wireless network profiles set up. Amongst other things, I have three profiles for my University WLAN. The reason for this is that the University offers three different wireless networks, one for Staff, one for Students and one unencrypted with a password-protected HTTP proxy. I have access to all three, but I want netcfg to attempt to connect to the networks in that order.
    I have tried to name the profiles as such:
    UniversityAStaff
    UniversityBStudent
    UniversityCOpen
    But that doesn't seem to make any difference; it still connects to the Student network by default.
    Is there any way of setting the priority of the wireless networks that netcfg-auto-wireless tries to connect to?
    Jon

    if you make your profiles like in /etc/network.d/examples/wireless-wpa-configsection you can put a priority falue in the wpa_supplicant section this should do the trick
    edit because of typo
    Last edited by parintachin (2010-03-08 14:48:44)

  • [SOLVED] Netcfg and Wireless connections stopped working

    I've been using Netcfg for a while now on my laptop and I've had no problems connecting to the internet until last week. Since the last pacman update I did (around Wednesday I believe) my laptop has not been able to connect to the internet again. It doesn't recognize my wireless interface even though it did before, and netcfg gives me a strange output when I try to connect to my network and tells me the network is not available. I've gone through the steps in the wiki about installing wireless drivers and I've redone that but it still does not work.
    Here is what Netcfg gives me when I try to connect:
    :: LosPin up [BUSY]
    nl80211: 'nl80211' generic netlink not found
    ioctl[SIOCSIWMODE]: Operation not supported
    ioctl[SIOCGIWRANGE]: Operation not supported
    ioctl[SIOCGIWMODE]: Operation not supported
    ioctl[SIOCSIWAP]: Operation not supported
    ioctl[SIOCSIWENCODEEXT]: Operation not supported
    ioctl[SIOCSIWENCODE]: Operation not supported
    ioctl[SIOCSIWENCODEEXT]: Operation not supported
    ioctl[SIOCSIWENCODE]: Operation not supported
    ioctl[SIOCSIWENCODEEXT]: Operation not supported
    ioctl[SIOCSIWENCODE]: Operation not supported
    ioctl[SIOCSIWENCODEEXT]: Operation not supported
    ioctl[SIOCSIWENCODE]: Operation not supported
    > Wireless network "LosPin" not present.
    [FAIL]
    I know the network is present because when I boot into Windows on this same laptop it connects without any issues. I think it is a driver issue but re-installing the driver has not helped so I'm wondering if anyone can help me out.
    This is my netcfg profile if needed:
    CONNECTION="wireless"
    ESSID="LosPin"
    INTERFACE="eth0"
    SCAN="yes"
    TIMEOUT="10"
    SECURITY="wpa"
    KEY=
    WPA_Driver='wext'
    IP='static'
    ADDR='10.0.0.80'
    GATEWAY='10.0.0.1'
    DNS='10.0.0.1'
    The reason that the interface is set to eth0 is because it is the only interface for which netcfg tries to connect to the network. If I use wlan0 as the interface it tells me it doesn't exist, and before I had the problem, the interface I used was eth1, which now netcfg says does not exist either.
    Any help is greatly appreciated.
    Last edited by Hoest (2011-11-17 23:32:29)

    I've checked and it's definitely not an rfkill issue. I've tried to connect to the network with two different netcfg profiles, one using wpa_supplicant and the other with configsection. Both give me the same "WPA Authentication/Association Failed" error. There was one try with the wpa_supplicant profile that gave the a "network not found" error but afterwards it went back to the original error. Here are my profiles if needed.
    configsection profile:
    CONNECTION='wireless'
    INTERFACE='eth0'
    SECURITY='wpa-configsection'
    ESSID='LosPin'
    IP='dhcp'
    TIMEOUT='130'
    CONFIGSECTION='
    ssid="LosPin"
    key_mgmt=WPA-PSK
    psk="..."'
    wpa_supplicant profile:
    CONNECTION="wireless"
    INTERFACE="eth0"
    TIMEOUT="60"
    WPA_Driver='wext'
    IP='dhcp'
    SECURITY='wpa-config'
    WPA_CONF='/etc/wpa_supplicant.conf'
    And this is my wpa_supplicant.conf:
    ctrl_interface=DIR=/run/wpa_supplicant GROUP=wheel
    network={
    ssid="LosPin"
    proto=RSN
    key_mgmt=WPA-PSK
    pairwise=CCMP TKIP
    group=CCMP TKIP
    #psk="..."
    psk=84e710904340353a5217eb63ced7e8f4beb38bf6317bf4648e8b4557c7f3442d
    Again, thank you all for all your help.

  • [solved] Problems with wireless / dhcp

    I've been happily using Arch for the past two years but only recently I hit a problem I can't seem to solve on my own.
    I have a wireless network at home, with WPA encryption and suddenly one day (probably after an update) I cannot get the IP address from my router over DHCP any more. The other PC at home (with Windows) works as it used to.
    Details:
    [fijam@hp510 ~]$ cat /etc/network.d/wlan
    CONNECTION="wireless"
    INTERFACE=eth1
    SECURITY="wpa"
    ESSID="wlan"
    KEY="xxxxxxxxxxxx"
    IP="dhcp"
    TIMEOUT="30"
    DHCP_OPTIONS="-d"
    [fijam@hp510 ~]$ cat /etc/dhcpcd.conf
    # Inform the DHCP server of our hostname for DDNS.
    hostname
    # A list of options to request from the DHCP server.
    option domain_name_servers, domain_name, domain_search, host_name
    # Most distributions have NTP support.
    #option ntp_servers
    # Respect the network MTU.
    option interface_mtu
    # A ServerID is required by RFC2131.
    # Some broken DHCP servers do not send one and dhcpcd can work without it.
    # Some broken DHCP servers NAK incorrectly and do not include a ServerID
    # either so the default is to require a ServerID.
    #require dhcp_server_identifier
    # A hook script is provided to lookup the hostname if not set by the DHCP
    # server, but it should not be run by default.
    nohook lookup-hostname
    noipv4ll
    [fijam@hp510 ~]$ sudo netcfg -c wlan
    :: wlan up [BUSY]
    dhcpcd: version 5.0.6 starting
    dhcpcd: eth1: executing `/usr/lib/dhcpcd/dhcpcd-run-hooks', reason PREINIT
    dhcpcd: eth1: executing `/usr/lib/dhcpcd/dhcpcd-run-hooks', reason CARRIER
    dhcpcd: eth1: rebinding lease of 192.168.1.12
    dhcpcd: eth1: sending DHCP_REQUEST (xid 0x55befbc9), next in 3.13 seconds
    dhcpcd: eth1: sending DHCP_REQUEST (xid 0x55befbc9), next in 7.96 seconds
    dhcpcd: timed out
    - DHCP IP lease attempt failed. [FAIL]
    [fijam@hp510 ~]$ iwconfig
    lo no wireless extensions.
    eth0 no wireless extensions.
    eth1 IEEE 802.11g ESSID:"wlan"
    Mode:Managed Frequency:2.417 GHz Access Point: 00:1E:37:EF:67:60
    Bit Rate:54 Mb/s Tx-Power=20 dBm Sensitivity=8/0
    Retry limit:7 RTS thr:off Fragment thr:off
    Power Management:off
    Link Quality=68/100 Signal level=-59 dBm Noise level=-89 dBm
    Rx invalid nwid:0 Rx invalid crypt:41 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:218 Missed beacon:0
    Help would be appreciated, I am really out of ideas here.
    Last edited by fijam (2009-08-06 15:35:32)

    EDIT: Actaully, dhcpcd still would not work while dhclient obtained IP without problems. I fixed the problem by adding -r <ip> to DHCP_OPTIONS in network.d file but I am still not sure why is it necessary.
    EDIT2: Today -- not working again. I increased DHCP_TIMEOUT to 60 and it eventually gets the IP. I am surprised since the link quality is 77 and it had not been necessary before.
    Last edited by fijam (2009-08-05 09:11:04)

  • HS-1200 breaks Wireless Internet access

    FYI, I just installed and started using the HS-1200 yesterday and they are awesome. An unfortunate side effect is that it breaks the wireless internet in my house. Wireless routers and the headset both operate at 2.4GHZ and they don't play well together. I thought it may have been my Belkin N1 Vision router so I went out and bought a Linksys WRT310N and it does the same thing. The remote computer have trouble connecting and when they do they get around 1mbps. Turn off the headset and poof, back to 36-54mbps. I have open tickets now with all 3 parties involved so hopefully there is a fix, otherwise the $106 headphones have to go in the closet and that would really p_ss me off.
    I can't believe that this problem didn't present itself anywhere in their testing and QA process.

    Im having the same issue also SabreHawke. I use my HS-1200, with my desktop replacement laptop, and off and on, the wifi light indicator turns off then on. Never had this issue before. Been using wireless channel 2 for about 3 years now, w/ great connection. Not sure what channel the headset uses. I cant use the default channels, i think 6, 9, 11, cause once someone turns on the microwave it disconnects. Guess i'll try some others, but channel 2 has been the best. Other than this i love the headset, :-).
    Edit: Did speakeasy speed test.
    Normal (w/ headset off): Download ~10mbps w/ speedboost up to 16. Upload ~2mbps.
    Headset On: Download ~1.5mbps. Upload ~1.0mbps.
    Message Edited by kama64 on 08-05-2008 07:00 PM

  • Macbook pro "breaks" wireless network

    greetings,
    whenever i'm home, i use my macbook pro to connect to our wireless network, a network that is usually only used by PCs (one running Network Magic).
    However, whenever i connect, it works great but sporadically it will "break" the network, causing the router to be reset. when it's down, it doesn't work for any computer. but this only happens when my computer is connected. also, this is the second router, so it shouldn't be that.
    is this caused by my wireless card or os?
    Message was edited by: mfeury

    I've been experiencing a very similar issue.
    I have a MBP from Nov 2007. I have a Billion 7402GL wireless/modem-router.
    I have a 3 year old Acer Aspire 5672 that I am using as nothing more than a Windows Media Center gateway. In other words the Acer's wireless connects to my main desktop in the next room, where all my TV shows are stored and shared out to it. It is then connected to the AV inputs on my TV.
    For the last month or so, if I am streaming something through to the Acer, if I then power up my MBP (where the WLAN is set to immediately connect) it appears that the MBP immediately consumes up all the signal/bandwidth to the wireless router, because the playback on the Acer either stutters, or freezes, which then crashes MCE.
    However once I disable WLAN on the MBP, the issue goes away.
    The strange thing is I have not altered the modem's firmware, nor any drivers on the Acer. I'd be willing to blame it on a Windows Update for Vista, but that wouldn't explain why I only suffer issues when the MBP's WLAN is operational.

  • Wireless DHCP

    I've just taken over the managment of a new wireless solution. They currently have only one WLAN and want to implement a second for guests only, so they only have access to the internet and no internal devices.
    The controller is a AIR-WLC52 running 4.2.61.8.
    All the DHCP info points to a router onsite, but when i check the DHCP bindings from that router they are not the DHCP pool that the WLC is handing out..
    The config on the WLC:
    interface address ap-manager 192.168.144.250 255.255.255.0 192.168.144.254
    interface address management 192.168.144.249 255.255.255.0 192.168.144.254
    interface address virtual 1.1.1.1
    interface dhcp ap-manager primary 192.168.144.254 
    interface dhcp management primary 192.168.144.254 
    wlan create 1 ReduserReduser
    wlan create 2 RedGuest RedGuest
    wlan custom-web global enable 2
    wlan qos 1 platinum
    wlan session-timeout 1 disable
    wlan session-timeout 2 disable
    wlan wmm allow 1
    wlan wmm allow 2
    wlan security wpa disable 1
    wlan security wpa disable 2
    wlan radius_server acct disable 1
    wlan radius_server acct disable 2
    wlan security static-wep-key enable 1
    wlan security static-wep-key enable 2
    --More-- or (q)uit
    wlan security static-wep-key authentication shared-key 1
    wlan security static-wep-key authentication shared-key 2
    wlan security static-wep-key encryption 1 40 <mode unknown> <passwd hidden> 1
    wlan security static-wep-key encryption 2 40 <mode unknown> <passwd hidden> 1
    wlan security wpa akm  802.1x disable 1
    wlan security wpa akm  psk enable 1
    wlan dhcp_server 2 192.168.144.254 required required
    The config on the Router:
    interface GigabitEthernet0/0
    description *** Outside Management ***
    ip address 194.105.164.249 255.255.255.248
    ip access-group FIREWALL_IN in
    ip nat outside
    ip virtual-reassembly
    duplex auto
    speed auto
    crypto map IPSec_vpn
    interface GigabitEthernet0/1
    description *** Physical Connection to 3560-SW1 ***
    no ip address
    duplex auto
    speed auto
    interface GigabitEthernet0/1.2
    description *** DATA ***
    encapsulation dot1Q 2 native
    ip address 192.168.144.254 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    interface GigabitEthernet0/1.100
    description *** VOICE ***
    encapsulation dot1Q 100
    ip address 192.168.244.254 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    h323-gateway voip bind srcaddr 192.168.244.254
    ip dhcp pool VOICE
       network 192.168.244.0 255.255.255.0
       default-router 192.168.244.254
       option 150 ip 192.168.244.254
    ip dhcp pool 88B6
       host 192.168.144.3 255.255.255.0
       client-identifier 0100.1ef7.2788.b6
       default-router 192.168.144.254
       option 150 ip 192.168.244.254
    ip dhcp pool WLAN
    network 192.168.250.0 255.255.255.0
    default-router 192.168.144.249
    The bindings on the router only show bindings for the voice equipmen 192.168.244 and one for host 192.168.144.3:
    IP address          Client-ID/              Lease expiration        Type
                        Hardware address/
                        User name
    192.168.144.3       0100.1ef7.2788.b6       Infinite                Manual
    192.168.244.1       0100.1ef7.278f.0c       May 13 2011 04:27 AM    Automatic
    192.168.244.2       0100.1ebe.921c.f6       May 13 2011 03:31 AM    Automatic
    192.168.244.3       0100.1ef7.2788.bd       May 13 2011 03:31 AM    Automatic
    192.168.244.4       0100.1ef7.278f.80       May 13 2011 03:31 AM    Automatic
    192.168.244.5       0100.1ebe.921e.19       May 13 2011 03:41 AM    Automatic
    192.168.244.6       0100.1ebe.921f.b0       May 13 2011 03:31 AM    Automatic
    192.168.244.7       0100.1ef7.2788.b6       May 13 2011 03:31 AM    Automatic
    192.168.244.8       0100.1ef7.278f.54       May 13 2011 03:32 AM    Automatic
    192.168.244.9       0100.1ebe.921d.e6       May 13 2011 11:02 AM    Automatic
    There are an average of 50 clients using the wireless right now obtaining 192.168.144.x address'. So I guess it will be on another server on site?
    How does the controller know how to get to this unknown DHCP server?
    How can I get my new Guest WLAN to point correctly to the router at 192.168.144.254?
    When running a dhcp debug I can see DHCP messages failing:
    May 12 14:08:24.589: DHCPD: no subnet configured for 192.168.144.63.
    May 12 14:08:24.589: DHCPD: Seeing if there is an internally specified pool class:
    May 12 14:08:24.589:   DHCPD: htype 1 chaddr 40a6.d9c7.437a
    May 12 14:08:24.593:   DHCPD: remote id 020a0000c0a890fe01000002
    May 12 14:08:24.593:   DHCPD: circuit id 00000000
    May 12 14:08:24.593: DHCPD: there is no pool for 192.168.144.254.
    May 12 14:08:26.633: DHCPD: Seeing if there is an internally specified pool class:
    May 12 14:08:26.633:   DHCPD: htype 1 chaddr 0017.427a.c75f
    May 12 14:08:26.637:   DHCPD: remote id 020a0000c0a890fe01000002
    May 12 14:08:26.637:   DHCPD: circuit id 00000000
    May 12 14:08:26.637: DHCPD: there is no pool for 192.168.144.254.
    May 12 14:08:36.529: DHCPD: no subnet configured for 192.168.144.63.
    May 12 14:08:36.529: DHCPD: Seeing if there is an internally specified pool class:
    May 12 14:08:36.529:   DHCPD: htype 1 chaddr 40a6.d9c7.437a
    May 12 14:08:36.529:   DHCPD: remote id 020a0000c0a890fe01000002
    May 12 14:08:36.529:   DHCPD: circuit id 00000000
    May 12 14:08:36.529: DHCPD: there is no pool for 192.168.144.254
    Thought it maybe better to assign pools on the WLC itself, but can not see how to do that. Am I unable to on the software version that I am running?
    Any help would be greatly appreciated

    Your hardware (WLC500) cannot do dhcp server.
    The easiest is that you configure a pool on the dhcp server for the wireless clients.
    Either you create a pool for subnet 144 like it seems to request. Or you create a new dynamic interface on the WLC in another subnet and assign the WLAN to that interface (that's how you normally do).
    From there you create that subnet as a pool on the router.

  • Wireless: DHCP IP lease attempt failed

    Hi,
    did an upgrade today and now I get the above error message, when trying to connect to my router with netcfg2. The exact error message is like following:
    [root@tux matthias]#
    [root@tux matthias]# netcfg2 home
    dhcpcd: wlan0: ignoring DHCP message; no Server ID
    dhcpcd: wlan0: ignoring DHCP message; no Server ID
    dhcpcd: wlan0: ignoring DHCP message; no Server ID
    dhcpcd: timed out
    :: home up - DHCP IP lease attempt failed [FAIL]
    My /etc/network.d/home looks like that:
    CONNECTION="wireless"
    INTERFACE=wlan0
    QUIRKS=(prescan preessid)
    SCAN="yes"
    SECURITY="wpa"
    ESSID="wirelessbox"
    KEY="..."
    IP="dhcp"
    TIMEOUT=30
    I did nothing except updating. Everything worked fine before that.
    Any hints?
    EDIT: I added the QUIRKS line after getting the error message, because a guy on IRC suggested that. This didn't help either.
    Last edited by mamr (2009-05-11 12:46:11)

    rsmarples wrote:
    dhave wrote:
    rsmarples wrote:You can't "turn the message off" as such. You you see the ignoring message then the DHCP packet really is ignored. So if you see that message AND dhcpcd still works with a proper IP (ie not ipv4ll) then you have 2 DHCP servers running on your network and one of them is fautly.
    Thanks for the explanation. Is this a problem to have a broken DHCP server running for no purpose? Is this hurting my gas mileage or anything?
    Well, you're probably better off finding the faulty router and disabling it.
    dhcpcd presently selects and uses the first DHCP working reply it gets and if the server is "fixed" to send ServerID then you could get conflicting lease information.
    I see I have a lot to learn. The reason it's finding two routers is that I have a modem-router and then, in another part of the house, an access point that I've configured as a repeater (actually, since it has a separate ssid, maybe it's not considered a repeater; I don't know).
    When I move my laptop from my office into the living room, I often switch from connecting through the "repeater" and connect directly to the modem-router. It's at this point that I get the messages about "no server ID". So, in fact, dhcpcd is doing what it's supposed to be doing, I guess.
    I need to do some reading and try to figure out if my setup could be cleaned up so as to avoid lease conflicts or whatever. When I fool with network stuff, I'm always working beyond my level of understanding. I usually just fiddle until I get things to work, which means I probably could do a lot to streamline and improve performance.

  • X1000 stops giving out Wireless DHCP IP addresses

    I have 2 X1000 switches, the prmary switch, IP, 192.168.1.1 connects to my ADSL line upstairs and handles all DHCP..
    My second router is downstairs and has been configured as 192.168.1.2, there is a LAN cable running from a LAN port of the primary router to the secondary router. Any device that I connect to the second router via the LAN ports works perfectly. However, when I connect a wireless device, the first time it works,If I then disconnect from the second router and reconnect I connect to the wireless network, but I cannot get an IP.
    I've gone through posts here and reset to defaults and reconfigured according to the posts, the problem persists.
    Router 1 - Works perfect, no problems
    Router 2 - IP 192.168.1.2
    Router 2 is configured as Ethernet
    different SSID to router 1
    different channelto Router 1
    I've turned off internet filtering and the firewalls to see if that would make a difference, no change.
    It's really strange as DHCP works perfect via an ethernet connection to Router 2, but wifi only works once, thereafter you connect to the wifi fine, but the wifi device never gets an IP Address. I've checked for new fw and there is only version 1 available and I have already gone back to factory defaults and re-setup the router.

    murattug wrote:
    Same problem here
    we have 5 older model linksys adsl modem (all of them works as wireless acces point) works well
    yesterday we bought 2 x1000 and I tried to configure as wireless router. our network has only one dhcp server and network gateway and its ip is 192.168.1.234
    I configured x1000 as router,  its ip as 192.168.1.16, dhcp relay mode,  relay server address: 192.168.1.234
    then I tried to connect using my smartphone, but it never gets an ip number.
    after first unsucsessful connection try, I downloaded firmware and flashed the x1000 
    but no change 
    thanks
    Be sure to avoid IP address conflict. If you are to configure the X1000 with an IP address of 192.168.1.x, plug the cable from the modem to any of the LAN ports of the X1000. If you are to configure the X1000 with an IP address of 192.168.x.x, plug the cable from the modem to the Internet port of the X1000.

  • WRT54G v7 Wireless DHCP

    Hi,
    I just bought a WRT54G, labels says V7. After days trying to configure it, I'm at a loss.
    I have a LAN, with DHCP off a Linux machine (also acts as gateway to Internet and firewall). There are several machines connected to it. I wanted to use the WRT as an access point basically, just link wirelessly with a password and access the net (as well as the other computers on the LAN).
    I linked the LAN (2) to the gateway (via switch), and inserted my computer into LAN (3). I figured I get dynamic IP via LAN, while wireless clients do the same (no wire). Great.
    I did just that, disabled DHCP, got me a SSID, all was well. Then I wanted to secure the Wi so I did a WEP settings with a passphrase, generated, all well. Except now wireless clients never get an IP. They connect (Passphrase OK), but no DHCP response, not from the router (I tried temporary DHCP from the WRT), not from the gateway. Disable security, all is well.
    LAN clients work OK, they get IP from the gateway just fine, if I disconnect the GW and enable local DHCP, I get IP from the WRT. Enable security, no DHCP. It __DOES__ work if I assign fixed IPs to wireless clients, but I like DHCP.
    A dump of network traffic shows that if the encryption is enabled the blasted client connects, does a DHCP broadcast, but receives nothing. Apparently the router blocks the broadcast.
    I already went through secure funa and fuzzy setup, the manuals, the setup guides, checking the password, trying different cards, etc.
    I upgraded to 7.0.0.4, no difference. Didn't do a hard boot after the 7.0.0.4, I'll try that too but I guess the question(s) is:
    * Is this by design? Couldn't find anything in the manual.
    * Is anything like this known?
    * Do you have PCs that connect over a WEP-secure wireless and get an IP from a non-WRT? (what I'm trying to do)
    Hints?

    gv:
    "Check to see if the WEP encrypted wireless connection does in fact work or not: set a static IP address in the wireless client and let it connect to your access point. Now try to ping the router at 192.168.1.1 or other computers in the LAN to see if it is actually working. If not, it is the WEP configuration which is the problem."
    I did, results are:
    * static IP works as wireless and wired client, logs on via open/WEP/wpa, everything works (including pinging router, other wireless clients and LAN clients. aka- as it should.
    * DHCP works via LAN or Internet ports, via wireless over open/WPA but does NOT work over wireless/WEP.
    "For WEP you must select the key which is used for transfer. This selection must match on the client and on the access point. If you use the first key on the access point you must use the first key in the client as well."
    Done, it logs on via wireless/wep, I get different errors for unable to connect to network and connected, but no DHCP found.
    "Please verify that this is actually the case. Also: don't use the passphrase to setup the keys in the client but copy the actual keys in hex."
    My Windows doesn't have such inputs (as far as I've seen). But using a bad password gives me a login error, the correct key does not. I assume it's not the key. Aslo, I assume that with a bad pass fixed IP shouldn't work.
    "Are you using Windows Zero Configuration for your wireless configuration or a different software?"
    None. Pure Win32 over a wireless card. Actually, I have several Windows machines with different cards, various configs, and all working with WPA and open, so compatible. If only my machine didn't work I wouldn't be asking for known bugs
    I actually sniffed the traffic and DHCP discover uses broadcasts. With WEP those broadcasts get no answer, but on LAN or wireless/WPA they do and get a DHCP response. Same behavior with internal DHCP server or the LAN DHCP server.
    I can't find a way to attach any files to the forum, but if you have any questions about the layout I'll be happy to host an image for you.Message Edited by Ndi on 02-02-200702:46 PM

  • 10.4.8 breaks wireless

    Just got a macbook, with OSX 10.4.6. Wireless worked fine both at home and work. Upgraded to 10.4.8 the next day to find that wireless dies almost exactly at 30 minutes (which coincidentally is the same 3600 seconds that is the idle timeout on the wlan). This happens both at work and home.
    It dies such that the wireless "radar" icon in the menu just goes gray - I have to click it and select my wlan for it to reconnect.
    Both work and home use WPA-PSK, but I also tried WPA2-PSK. At work we use an Extreme Altitude and at home I have a Zyxel 660HW. It works perfectly with a third wireless router, however (Linksys).
    I reinstalled OSX 10.4.6 from scratch and confirmed it works perfectly. Upgraded again to 10.4.8 and confirmed it does indeed break. Always at about 3550 seconds or so.
    When this happens dmesg shows:
    athchanset: unable to restart recv logic
    and in system.log:
    Oct 24 22:55:56 Bat configd[36]: posting notification com.apple.system.config.network_change
    Those are the only errors that are always present when this happens.
    Any help/tips appreciated.
    MacBook   Mac OS X (10.4.8)  

    i have the exact same issue, with a NON-intel 15" powerbook. it drops connection for no reason where i used to always have perfect signal, and without changing anything or even doing anything it picks up signal again to 5 bars. i played with the channels on the wireless access point, etc but no changes. none of these problems existed before the 10.4.8 update!

  • Macbook Air (Mid 2011) Wired/Wireless DHCP issues

    All,
    I have been attempting to fix a nagging problem with my brand new MBA 'Ultimate' - while at home it connects fine wirelessly and I do not experience any issues (note this is the first SSID it has ever connected to) I have not been able to connect to my office's wireless - I do not pull a DHCP address or connect. In an attempt to rule out the wireless issues everyone has, I purchased the 10/100 Apple RJ-45 (ethernet) adapter and have attempted this morning to connect via a known working patch cable.
    The wired connection fails to pull a DHCP address as well!
    I have followed wifiguru's posts and attempted to disable the firewall, reset the SMC, reset the PRAM, delete the offending plists, changed the network order, etc.
    I do not believe my issue lies on my computer network as multiple other iOS and OSX devices can connect (that are Lion as well)
    Admittedly, I have not attempted to go to another third party wireless location (Starbucks, McD's, etc) but for the wired connection to fail as well and my home wireless (802.11n) connection to work leads me to think I am missing something. I do not believe I should have to reboot my work's wireless router to accept me as a client as well - especially since the wired does not connect.
    Any thoughts?
    Cliffs:
    - mid-2011 MBA Ultimate
    - wireless works at home network (802.11n) - gets DHCP address
    - wireless doesn't work at work (802.11b/g) - no DHCP address
    - wired doesn't work at work (apple adapter) - no DHCP address
    - firewall off/on doesn't matter
    - deleted problematic plists, no change
    I also feel I should add, I'm not computer illiterate by any stretch of the imagination and have used OSX products in the past.

    Really?
    No input at all?

  • Sony VAIO Duo 13 Rolled Back from Windows 10 to Windows 8.1 (Breaks Wireless Card)

    I have the subject machine (model SVD1322BPXR) and the upgrade to Win 10 was fine except for the fact that it broke the Network Wireless Card - a Broadcom 802.11abgn Wireless SDIO Adapter.  While it would make WiFi connections, the WiFi continually cycled between connected and "Limited Connectivity" approximately every 30 seconds and it didn't matter which WAP I connected to. Oddly enough, the Win 10 upgrade didn't break my Mobile Broadband Module and so it seamlessly switched to using my cellular service (T-Mobile) when the WiFi was Limited - nice except for the fact that I don't have unlimited data on that plan and I didn't notice the problem right away. I tired uninstalling/reinstalling the network adapter, switching to earlier version drivers, and disabling Defender/Firewall but it didn't repair the problem and so I'm back to Win 8.1; even that process broke as I had to refresh & reinstall hundreds of 8.1 updates.   Since the 'Get Windows 10 app' said everything was good to go, I went through the upgrade process even though the Sony advised against it.  I must learn to remember - never believe Microsoft and I'm rather unimpressed with the reduced touch funtionality that Windows 10 brings.    Anybody else using a similar model and get it to work on Win 10?   

     
    Hi markbyrn, 
    Welcome to Sony Community! 
    'Get Windows 10 app' of Microsoft probably just checking the basic system requirements https://www.microsoft.com/en-us/windows/Windows-10-specifications#sysreqs, regardless of the drivers and other software needed. 
    What we recommend is to wait for the updated drivers and software first. Please bookmark this page since Sony will update this once the drivers are uploaded: http://esupport.sony.com/US/p/os10upgrade.pl
    Best regards,
    Vincent 
    If my post answers your question, please mark it as "Accept as Solution"
     

Maybe you are looking for

  • Remote not working

    I thought I would throw this question out there before I did anything drastic: Yesterday my AppleTV remote stopped working. No indication that it was a battery problem. Our iPhone remote apps still work. I bought a new battery. Still nothing. Like I

  • TREE NODE IN F4 SEARCH HELP

    Hi All, Can anyone help me to implement Tree node in F4 Search help? Thanks E Karthikeyan

  • Video and IPIPGW

    I am trying to use the IPIPGW to connect two H.323 endpoints located in different local zones. I can establish a connection using the registered E.164 addresses and the audio works through the IPIPGW, but not the video. The two endpoints can call eac

  • 16GB Retina MacBook Pro in-Store?

    Does anyone know if apple retail stores carry the base model retina MacBook pro with ram upgraded to 16GB? Thanks

  • My kind of case/sleeve for my iPad 2

    I just want to share this with you...  I bought the following nifty leather sleeve for my iPad 2 for € 50. For once something that is not made in China or Japan or Malaysia or Korea or USA - no, it's made in Turkey. http://www.trexta.com/Default.aspx