PKCS12 question

I have one PKCS12 store .
When I use this store with Server(server authendication) it works fine.
When I use the same PKCS12 store on the client side it doesnt work.
The client is not returning the certificate to server, and the server throws
javax.net.ssl.SSLHandshakeException: null cert chain IOException occurred when processing request.
Any idea why this is happening??
I have another PKCS12 store which works fine with both server and client.
What is the problem with my 1st PKCS12 store??
Below is my server and client code and ssl trace
---------Client----------
KeyManagerFactory kmf = KeyManagerFactory.getInstance("SunX509");
KeyStore keystore = KeyStore.getInstance("PKCS12");
keystore.load(new FileInputStream(KEYSTORE), KEYSTOREPW);
kmf.init(keystore, KEYPW);
TrustManagerFactory tmf = TrustManagerFactory.getInstance("SunX509");
KeyStore truststore = KeyStore.getInstance("jks");
truststore.load(new FileInputStream(TRUSTSTORE), TRUSTSTOREPW);
tmf.init(truststore);
SSLContext sslc = SSLContext.getInstance("SSLv3");
sslc.init(kmf.getKeyManagers(), tmf.getTrustManagers(), null);
SSLSocketFactory factory = sslc.getSocketFactory();
SSLSocket socket = (SSLSocket)factory.createSocket("babu", 443);
-----Server---------
Security.addProvider(new com.sun.net.ssl.internal.ssl.Provider());
          System.setProperty("javax.net.debug", "all");
          KeyManagerFactory kmf = KeyManagerFactory.getInstance("SunX509");
     KeyStore keystore = KeyStore.getInstance("PKCS12");
     keystore.load(new FileInputStream(KEYSTORE), KEYSTOREPW);
     kmf.init(keystore, KEYPW);
     TrustManagerFactory tmf = TrustManagerFactory.getInstance("SunX509");
     KeyStore truststore = KeyStore.getInstance("jks");
     truststore.load(new FileInputStream(TRUSTSTORE), TRUSTSTOREPW);
     tmf.init(truststore);
     SSLContext sslc = SSLContext.getInstance("SSLv3");
     sslc.init(kmf.getKeyManagers(), tmf.getTrustManagers(), null);
     ServerSocketFactory ssf = sslc.getServerSocketFactory();
     SSLServerSocket serverSocket =(SSLServerSocket) ssf.createServerSocket(serverPort);
     serverSocket.setNeedClientAuth(requireClientAuthentication);
-------------SSL Server trace--------
SecureServer version 1.0
found key for : 1b171437ea2e3946aa536179d508b6eb_f9948e6e-6fdb-4f6e-b09e-613f60f00e41
chain [0] = [
Version: V3
Subject: CN=babu babu, [email protected], DNQ=12141726907, L=dubai, C=AE
Signature Algorithm: SHA1withRSA, OID = 1.2.840.113549.1.1.5
Key: Sun RSA public key, 512 bits
modulus: 9683790188147953162795730790793527257397758989267819282372960853921863644980017792669595318858981940986671279705015616513809624780681913479305781592431811
public exponent: 65537
Validity: [From: Wed Nov 01 12:09:39 GST 2006,
               To: Fri Dec 01 12:09:38 GST 2006]
Issuer: CN=Comtrust Demo CA, OU=Comtrust eBusiness Services, O=Etisalat, C=AE
SerialNumber: [    0118]
Certificate Extensions: 4
[1]: ObjectId: 2.5.29.35 Criticality=false
AuthorityKeyIdentifier [
KeyIdentifier [
0000: 7B 36 C0 C7 73 46 9E FB 0B C4 9E 93 48 B3 CA A5 .6..sF......H...
0010: 07 1A FD B5 ....
[2]: ObjectId: 2.5.29.17 Criticality=false
SubjectAlternativeName [
[RFC822Name: [email protected]]]
[3]: ObjectId: 2.5.29.15 Criticality=false
KeyUsage [
DigitalSignature
Key_Encipherment
[4]: ObjectId: 2.5.29.19 Criticality=false
BasicConstraints:[
CA:false
PathLen: undefined
Unparseable certificate extensions: 1
[1]: ObjectId: 2.5.29.31 Criticality=false
0000: 30 66 30 64 A0 62 A0 60 86 5E 6C 64 61 70 3A 2F 0f0d.b.`.^ldap:/
0010: 2F 6C 64 61 70 2E 63 6F 6D 74 72 75 73 74 2E 63 /ldap.comtrust.c
0020: 6F 2E 61 65 2F 43 4E 3D 43 6F 6D 74 72 75 73 74 o.ae/CN=Comtrust
0030: 20 44 65 6D 6F 20 43 41 2C 20 4F 55 3D 43 6F 6D Demo CA, OU=Com
0040: 74 72 75 73 74 20 65 42 75 73 69 6E 65 73 73 20 trust eBusiness
0050: 53 65 72 76 69 63 65 73 2C 4F 3D 45 74 69 73 61 Services,O=Etisa
0060: 6C 61 74 2C 43 3D 41 45 lat,C=AE
Algorithm: [SHA1withRSA]
Signature:
0000: 41 AC BF FB 89 E2 5D C3 41 40 95 74 41 9B D4 4D A.....][email protected]
0010: 02 2D AE 92 85 CD 8B 55 5E 8A E9 CA 1F 20 36 2A .-.....U^.... 6*
0020: 36 89 8F 84 22 AB 4F 8B B3 8B 7A DD 88 B3 98 B1 6...".O...z.....
0030: EE D0 82 06 D2 75 2F DD 36 2E 30 C6 6D 92 0A 7D .....u/.6.0.m...
0040: 61 F1 90 71 00 FA 09 86 2E B7 76 00 EE 4B 85 90 a..q......v..K..
0050: CD A0 0A 20 F2 C7 0C 49 E4 A0 71 83 FB 9A 4A EF ... ...I..q...J.
0060: ED 4A E9 36 C5 00 59 A8 EF 28 66 1E CC 81 FC FA .J.6..Y..(f.....
0070: 75 B0 B5 B8 0E 5F BE 4E C6 D0 B3 BA 4E 4C 2C B9 u...._.N....NL,.
adding as trusted cert:
Subject: CN=babu babu, [email protected], DNQ=12141726907, L=dubai, C=AE
Issuer: CN=Comtrust Demo CA, OU=Comtrust eBusiness Services, O=Etisalat, C=AE
Algorithm: RSA; Serial number: 0x118
Valid from Wed Nov 01 12:09:39 GST 2006 until Fri Dec 01 12:09:38 GST 2006
trigger seeding of SecureRandom
done seeding SecureRandom
SecureServer is listening on port 443.
matching alias: 1b171437ea2e3946aa536179d508b6eb_f9948e6e-6fdb-4f6e-b09e-613f60f00e41
Accepted connection to 192.168.254.1 (192.168.254.1) on port 2879.
----------1-1-1-----
[Raw read]: length = 5
0000: 80 62 01 03 01 .b...
[Raw read]: length = 95
0000: 00 39 00 00 00 20 00 00 04 01 00 80 00 00 05 00 .9... ..........
0010: 00 2F 00 00 33 00 00 32 00 00 0A 07 00 C0 00 00 ./..3..2........
0020: 16 00 00 13 00 00 09 06 00 40 00 00 15 00 00 12 .........@......
0030: 00 00 03 02 00 80 00 00 08 00 00 14 00 00 11 45 ...............E
0040: 49 02 A0 AA 35 C2 92 48 CA FD 03 76 64 95 65 D6 I...5..H...vd.e.
0050: 97 8F 8C 88 86 FD 03 19 0E 10 B8 7E 68 8F 30 ............h.0
[read] MD5 and SHA1 hashes: len = 3
0000: 01 03 01 ...
[read] MD5 and SHA1 hashes: len = 95
0000: 00 39 00 00 00 20 00 00 04 01 00 80 00 00 05 00 .9... ..........
0010: 00 2F 00 00 33 00 00 32 00 00 0A 07 00 C0 00 00 ./..3..2........
0020: 16 00 00 13 00 00 09 06 00 40 00 00 15 00 00 12 .........@......
0030: 00 00 03 02 00 80 00 00 08 00 00 14 00 00 11 45 ...............E
0040: 49 02 A0 AA 35 C2 92 48 CA FD 03 76 64 95 65 D6 I...5..H...vd.e.
0050: 97 8F 8C 88 86 FD 03 19 0E 10 B8 7E 68 8F 30 ............h.0
Thread-0, READ: SSL v2, contentType = Handshake, translated length = 73
*** ClientHello, TLSv1
RandomCookie: GMT: 1162412448 bytes = { 170, 53, 194, 146, 72, 202, 253, 3, 118, 100, 149, 101, 214, 151, 143, 140, 136, 134, 253, 3, 25, 14, 16, 184, 126, 104, 143, 48 }
Session ID: {}
Cipher Suites: [SSL_RSA_WITH_RC4_128_MD5, SSL_RSA_WITH_RC4_128_SHA, TLS_RSA_WITH_AES_128_CBC_SHA, TLS_DHE_RSA_WITH_AES_128_CBC_SHA, TLS_DHE_DSS_WITH_AES_128_CBC_SHA, SSL_RSA_WITH_3DES_EDE_CBC_SHA, SSL_DHE_RSA_WITH_3DES_EDE_CBC_SHA, SSL_DHE_DSS_WITH_3DES_EDE_CBC_SHA, SSL_RSA_WITH_DES_CBC_SHA, SSL_DHE_RSA_WITH_DES_CBC_SHA, SSL_DHE_DSS_WITH_DES_CBC_SHA, SSL_RSA_EXPORT_WITH_RC4_40_MD5, SSL_RSA_EXPORT_WITH_DES40_CBC_SHA, SSL_DHE_RSA_EXPORT_WITH_DES40_CBC_SHA, SSL_DHE_DSS_EXPORT_WITH_DES40_CBC_SHA]
Compression Methods: { 0 }
%% Created: [Session-1, SSL_RSA_WITH_RC4_128_MD5]
*** ServerHello, TLSv1
RandomCookie: GMT: 1162412463 bytes = { 44, 156, 132, 21, 120, 87, 69, 229, 176, 58, 159, 137, 35, 145, 220, 129, 236, 8, 45, 127, 240, 221, 7, 210, 241, 52, 150, 138 }
Session ID: {69, 73, 2, 175, 117, 130, 69, 187, 79, 198, 111, 18, 143, 44, 89, 188, 221, 232, 110, 109, 149, 122, 194, 49, 150, 66, 164, 65, 72, 177, 218, 89}
Cipher Suite: SSL_RSA_WITH_RC4_128_MD5
Compression Method: 0
Cipher suite: SSL_RSA_WITH_RC4_128_MD5
*** Certificate chain
chain [0] = [
Version: V3
Subject: CN=babu babu, [email protected], DNQ=12141726907, L=dubai, C=AE
Signature Algorithm: SHA1withRSA, OID = 1.2.840.113549.1.1.5
Key: Sun RSA public key, 512 bits
modulus: 9683790188147953162795730790793527257397758989267819282372960853921863644980017792669595318858981940986671279705015616513809624780681913479305781592431811
public exponent: 65537
Validity: [From: Wed Nov 01 12:09:39 GST 2006,
               To: Fri Dec 01 12:09:38 GST 2006]
Issuer: CN=Comtrust Demo CA, OU=Comtrust eBusiness Services, O=Etisalat, C=AE
SerialNumber: [    0118]
Certificate Extensions: 4
[1]: ObjectId: 2.5.29.35 Criticality=false
AuthorityKeyIdentifier [
KeyIdentifier [
0000: 7B 36 C0 C7 73 46 9E FB 0B C4 9E 93 48 B3 CA A5 .6..sF......H...
0010: 07 1A FD B5 ....
[2]: ObjectId: 2.5.29.17 Criticality=false
SubjectAlternativeName [
[RFC822Name: [email protected]]]
[3]: ObjectId: 2.5.29.15 Criticality=false
KeyUsage [
DigitalSignature
Key_Encipherment
[4]: ObjectId: 2.5.29.19 Criticality=false
BasicConstraints:[
CA:false
PathLen: undefined
Unparseable certificate extensions: 1
[1]: ObjectId: 2.5.29.31 Criticality=false
0000: 30 66 30 64 A0 62 A0 60 86 5E 6C 64 61 70 3A 2F 0f0d.b.`.^ldap:/
0010: 2F 6C 64 61 70 2E 63 6F 6D 74 72 75 73 74 2E 63 /ldap.comtrust.c
0020: 6F 2E 61 65 2F 43 4E 3D 43 6F 6D 74 72 75 73 74 o.ae/CN=Comtrust
0030: 20 44 65 6D 6F 20 43 41 2C 20 4F 55 3D 43 6F 6D Demo CA, OU=Com
0040: 74 72 75 73 74 20 65 42 75 73 69 6E 65 73 73 20 trust eBusiness
0050: 53 65 72 76 69 63 65 73 2C 4F 3D 45 74 69 73 61 Services,O=Etisa
0060: 6C 61 74 2C 43 3D 41 45 lat,C=AE
Algorithm: [SHA1withRSA]
Signature:
0000: 41 AC BF FB 89 E2 5D C3 41 40 95 74 41 9B D4 4D A.....][email protected]
0010: 02 2D AE 92 85 CD 8B 55 5E 8A E9 CA 1F 20 36 2A .-.....U^.... 6*
0020: 36 89 8F 84 22 AB 4F 8B B3 8B 7A DD 88 B3 98 B1 6...".O...z.....
0030: EE D0 82 06 D2 75 2F DD 36 2E 30 C6 6D 92 0A 7D .....u/.6.0.m...
0040: 61 F1 90 71 00 FA 09 86 2E B7 76 00 EE 4B 85 90 a..q......v..K..
0050: CD A0 0A 20 F2 C7 0C 49 E4 A0 71 83 FB 9A 4A EF ... ...I..q...J.
0060: ED 4A E9 36 C5 00 59 A8 EF 28 66 1E CC 81 FC FA .J.6..Y..(f.....
0070: 75 B0 B5 B8 0E 5F BE 4E C6 D0 B3 BA 4E 4C 2C B9 u...._.N....NL,.
*** CertificateRequest
Cert Types: RSA, DSS,
Cert Authorities:
<CN=babu babu, [email protected], DNQ=12141726907, L=dubai, C=AE>
*** ServerHelloDone
[write] MD5 and SHA1 hashes: len = 938
0000: 02 00 00 46 03 01 45 49 02 AF 2C 9C 84 15 78 57 ...F..EI..,...xW
0010: 45 E5 B0 3A 9F 89 23 91 DC 81 EC 08 2D 7F F0 DD E..:..#.....-...
0020: 07 D2 F1 34 96 8A 20 45 49 02 AF 75 82 45 BB 4F ...4.. EI..u.E.O
0030: C6 6F 12 8F 2C 59 BC DD E8 6E 6D 95 7A C2 31 96 .o..,Y...nm.z.1.
0040: 42 A4 41 48 B1 DA 59 00 04 00 0B 00 02 DD 00 02 B.AH..Y.........
0050: DA 00 02 D7 30 82 02 D3 30 82 02 3C A0 03 02 01 ....0...0..<....
0060: 02 02 02 01 18 30 0D 06 09 2A 86 48 86 F7 0D 01 .....0...*.H....
0070: 01 05 05 00 30 61 31 0B 30 09 06 03 55 04 06 13 ....0a1.0...U...
0080: 02 41 45 31 11 30 0F 06 03 55 04 0A 13 08 45 74 .AE1.0...U....Et
0090: 69 73 61 6C 61 74 31 24 30 22 06 03 55 04 0B 13 isalat1$0"..U...
00A0: 1B 43 6F 6D 74 72 75 73 74 20 65 42 75 73 69 6E .Comtrust eBusin
00B0: 65 73 73 20 53 65 72 76 69 63 65 73 31 19 30 17 ess Services1.0.
00C0: 06 03 55 04 03 13 10 43 6F 6D 74 72 75 73 74 20 ..U....Comtrust
00D0: 44 65 6D 6F 20 43 41 30 1E 17 0D 30 36 31 31 30 Demo CA0...06110
00E0: 31 30 38 30 39 33 39 5A 17 0D 30 36 31 32 30 31 1080939Z..061201
00F0: 30 38 30 39 33 38 5A 30 6E 31 0B 30 09 06 03 55 080938Z0n1.0...U
0100: 04 06 13 02 41 45 31 0E 30 0C 06 03 55 04 07 13 ....AE1.0...U...
0110: 05 64 75 62 61 69 31 14 30 12 06 03 55 04 2E 13 .dubai1.0...U...
0120: 0B 31 32 31 34 31 37 32 36 39 30 37 31 25 30 23 .121417269071%0#
0130: 06 09 2A 86 48 86 F7 0D 01 09 01 16 16 62 61 62 ..*.H........bab
0140: 75 65 40 65 6D 69 72 61 74 65 73 62 61 6E 6B 2E ue@nbdbank.
0150: 63 6F 6D 31 12 30 10 06 03 55 04 03 13 09 62 61 com1.0...U....ba
0160: 62 75 20 62 61 62 75 30 5C 30 0D 06 09 2A 86 48 bu babu0\0...*.H
0170: 86 F7 0D 01 01 01 05 00 03 4B 00 30 48 02 41 00 .........K.0H.A.
0180: B8 E5 61 65 47 4F AE 19 55 98 CE 56 A9 4F 73 33 ..aeGO..U..V.Os3
0190: 5E 73 FD 26 1B AD 63 C8 C9 91 53 7E 7E CB 15 18 ^s.&..c...S.....
01A0: EB 78 00 8A 23 DD 03 68 2E 1F AE 3D 5F 53 3D 64 .x..#..h...=_S=d
01B0: 76 2C 87 F5 12 07 F3 17 C6 7D 04 F1 21 DF 9C C3 v,..........!...
01C0: 02 03 01 00 01 A3 81 D0 30 81 CD 30 1F 06 03 55 ........0..0...U
01D0: 1D 23 04 18 30 16 80 14 7B 36 C0 C7 73 46 9E FB .#..0....6..sF..
01E0: 0B C4 9E 93 48 B3 CA A5 07 1A FD B5 30 09 06 03 ....H.......0...
01F0: 55 1D 13 04 02 30 00 30 0B 06 03 55 1D 0F 04 04 U....0.0...U....
0200: 03 02 05 A0 30 21 06 03 55 1D 11 04 1A 30 18 81 ....0!..U....0..
0210: 16 62 61 62 75 65 40 65 6D 69 72 61 74 65 73 62 .babue@nbdb
0220: 61 6E 6B 2E 63 6F 6D 30 6F 06 03 55 1D 1F 04 68 ank.com0o..U...h
0230: 30 66 30 64 A0 62 A0 60 86 5E 6C 64 61 70 3A 2F 0f0d.b.`.^ldap:/
0240: 2F 6C 64 61 70 2E 63 6F 6D 74 72 75 73 74 2E 63 /ldap.comtrust.c
0250: 6F 2E 61 65 2F 43 4E 3D 43 6F 6D 74 72 75 73 74 o.ae/CN=Comtrust
0260: 20 44 65 6D 6F 20 43 41 2C 20 4F 55 3D 43 6F 6D Demo CA, OU=Com
0270: 74 72 75 73 74 20 65 42 75 73 69 6E 65 73 73 20 trust eBusiness
0280: 53 65 72 76 69 63 65 73 2C 4F 3D 45 74 69 73 61 Services,O=Etisa
0290: 6C 61 74 2C 43 3D 41 45 30 0D 06 09 2A 86 48 86 lat,C=AE0...*.H.
02A0: F7 0D 01 01 05 05 00 03 81 81 00 41 AC BF FB 89 ...........A....
02B0: E2 5D C3 41 40 95 74 41 9B D4 4D 02 2D AE 92 85 .][email protected]...
02C0: CD 8B 55 5E 8A E9 CA 1F 20 36 2A 36 89 8F 84 22 ..U^.... 6*6..."
02D0: AB 4F 8B B3 8B 7A DD 88 B3 98 B1 EE D0 82 06 D2 .O...z..........
02E0: 75 2F DD 36 2E 30 C6 6D 92 0A 7D 61 F1 90 71 00 u/.6.0.m...a..q.
02F0: FA 09 86 2E B7 76 00 EE 4B 85 90 CD A0 0A 20 F2 .....v..K..... .
0300: C7 0C 49 E4 A0 71 83 FB 9A 4A EF ED 4A E9 36 C5 ..I..q...J..J.6.
0310: 00 59 A8 EF 28 66 1E CC 81 FC FA 75 B0 B5 B8 0E .Y..(f.....u....
0320: 5F BE 4E C6 D0 B3 BA 4E 4C 2C B9 0D 00 00 77 02 _.N....NL,....w.
0330: 01 02 00 72 00 70 30 6E 31 0B 30 09 06 03 55 04 ...r.p0n1.0...U.
0340: 06 13 02 41 45 31 0E 30 0C 06 03 55 04 07 13 05 ...AE1.0...U....
0350: 64 75 62 61 69 31 14 30 12 06 03 55 04 2E 13 0B dubai1.0...U....
0360: 31 32 31 34 31 37 32 36 39 30 37 31 25 30 23 06 121417269071%0#.
0370: 09 2A 86 48 86 F7 0D 01 09 01 16 16 62 61 62 75 .*.H........babu
0380: 65 40 65 6D 69 72 61 74 65 73 62 61 6E 6B 2E 63 [email protected]
0390: 6F 6D 31 12 30 10 06 03 55 04 03 13 09 62 61 62 om1.0...U....bab
03A0: 75 20 62 61 62 75 0E 00 00 00 u babu....
Thread-0, WRITE: TLSv1 Handshake, length = 938
[Raw write]: length = 943
0000: 16 03 01 03 AA 02 00 00 46 03 01 45 49 02 AF 2C ........F..EI..,
0010: 9C 84 15 78 57 45 E5 B0 3A 9F 89 23 91 DC 81 EC ...xWE..:..#....
0020: 08 2D 7F F0 DD 07 D2 F1 34 96 8A 20 45 49 02 AF .-......4.. EI..
0030: 75 82 45 BB 4F C6 6F 12 8F 2C 59 BC DD E8 6E 6D u.E.O.o..,Y...nm
0040: 95 7A C2 31 96 42 A4 41 48 B1 DA 59 00 04 00 0B .z.1.B.AH..Y....
0050: 00 02 DD 00 02 DA 00 02 D7 30 82 02 D3 30 82 02 .........0...0..
0060: 3C A0 03 02 01 02 02 02 01 18 30 0D 06 09 2A 86 <.........0...*.
0070: 48 86 F7 0D 01 01 05 05 00 30 61 31 0B 30 09 06 H........0a1.0..
0080: 03 55 04 06 13 02 41 45 31 11 30 0F 06 03 55 04 .U....AE1.0...U.
0090: 0A 13 08 45 74 69 73 61 6C 61 74 31 24 30 22 06 ...Etisalat1$0".
00A0: 03 55 04 0B 13 1B 43 6F 6D 74 72 75 73 74 20 65 .U....Comtrust e
00B0: 42 75 73 69 6E 65 73 73 20 53 65 72 76 69 63 65 Business Service
00C0: 73 31 19 30 17 06 03 55 04 03 13 10 43 6F 6D 74 s1.0...U....Comt
00D0: 72 75 73 74 20 44 65 6D 6F 20 43 41 30 1E 17 0D rust Demo CA0...
00E0: 30 36 31 31 30 31 30 38 30 39 33 39 5A 17 0D 30 061101080939Z..0
00F0: 36 31 32 30 31 30 38 30 39 33 38 5A 30 6E 31 0B 61201080938Z0n1.
0100: 30 09 06 03 55 04 06 13 02 41 45 31 0E 30 0C 06 0...U....AE1.0..
0110: 03 55 04 07 13 05 64 75 62 61 69 31 14 30 12 06 .U....dubai1.0..
0120: 03 55 04 2E 13 0B 31 32 31 34 31 37 32 36 39 30 .U....1214172690
0130: 37 31 25 30 23 06 09 2A 86 48 86 F7 0D 01 09 01 71%0#..*.H......
0140: 16 16 62 61 62 75 65 40 65 6D 69 72 61 74 65 73 ..babue@nbd
0150: 62 61 6E 6B 2E 63 6F 6D 31 12 30 10 06 03 55 04 bank.com1.0...U.
0160: 03 13 09 62 61 62 75 20 62 61 62 75 30 5C 30 0D ...babu babu0\0.
0170: 06 09 2A 86 48 86 F7 0D 01 01 01 05 00 03 4B 00 ..*.H.........K.
0180: 30 48 02 41 00 B8 E5 61 65 47 4F AE 19 55 98 CE 0H.A...aeGO..U..
0190: 56 A9 4F 73 33 5E 73 FD 26 1B AD 63 C8 C9 91 53 V.Os3^s.&..c...S
01A0: 7E 7E CB 15 18 EB 78 00 8A 23 DD 03 68 2E 1F AE ......x..#..h...
01B0: 3D 5F 53 3D 64 76 2C 87 F5 12 07 F3 17 C6 7D 04 =_S=dv,.........
01C0: F1 21 DF 9C C3 02 03 01 00 01 A3 81 D0 30 81 CD .!...........0..
01D0: 30 1F 06 03 55 1D 23 04 18 30 16 80 14 7B 36 C0 0...U.#..0....6.
01E0: C7 73 46 9E FB 0B C4 9E 93 48 B3 CA A5 07 1A FD .sF......H......
01F0: B5 30 09 06 03 55 1D 13 04 02 30 00 30 0B 06 03 .0...U....0.0...
0200: 55 1D 0F 04 04 03 02 05 A0 30 21 06 03 55 1D 11 U........0!..U..
0210: 04 1A 30 18 81 16 62 61 62 75 65 40 65 6D 69 72 ..0...babue@emir
0220: 61 74 65 73 62 61 6E 6B 2E 63 6F 6D 30 6F 06 03 atesbank.com0o..
0230: 55 1D 1F 04 68 30 66 30 64 A0 62 A0 60 86 5E 6C U...h0f0d.b.`.^l
0240: 64 61 70 3A 2F 2F 6C 64 61 70 2E 63 6F 6D 74 72 dap://ldap.comtr
0250: 75 73 74 2E 63 6F 2E 61 65 2F 43 4E 3D 43 6F 6D ust.co.ae/CN=Com
0260: 74 72 75 73 74 20 44 65 6D 6F 20 43 41 2C 20 4F trust Demo CA, O
0270: 55 3D 43 6F 6D 74 72 75 73 74 20 65 42 75 73 69 U=Comtrust eBusi
0280: 6E 65 73 73 20 53 65 72 76 69 63 65 73 2C 4F 3D ness Services,O=
0290: 45 74 69 73 61 6C 61 74 2C 43 3D 41 45 30 0D 06 Etisalat,C=AE0..
02A0: 09 2A 86 48 86 F7 0D 01 01 05 05 00 03 81 81 00 .*.H............
02B0: 41 AC BF FB 89 E2 5D C3 41 40 95 74 41 9B D4 4D A.....][email protected]
02C0: 02 2D AE 92 85 CD 8B 55 5E 8A E9 CA 1F 20 36 2A .-.....U^.... 6*
02D0: 36 89 8F 84 22 AB 4F 8B B3 8B 7A DD 88 B3 98 B1 6...".O...z.....
02E0: EE D0 82 06 D2 75 2F DD 36 2E 30 C6 6D 92 0A 7D .....u/.6.0.m...
02F0: 61 F1 90 71 00 FA 09 86 2E B7 76 00 EE 4B 85 90 a..q......v..K..
0300: CD A0 0A 20 F2 C7 0C 49 E4 A0 71 83 FB 9A 4A EF ... ...I..q...J.
0310: ED 4A E9 36 C5 00 59 A8 EF 28 66 1E CC 81 FC FA .J.6..Y..(f.....
0320: 75 B0 B5 B8 0E 5F BE 4E C6 D0 B3 BA 4E 4C 2C B9 u...._.N....NL,.
0330: 0D 00 00 77 02 01 02 00 72 00 70 30 6E 31 0B 30 ...w....r.p0n1.0
0340: 09 06 03 55 04 06 13 02 41 45 31 0E 30 0C 06 03 ...U....AE1.0...
0350: 55 04 07 13 05 64 75 62 61 69 31 14 30 12 06 03 U....dubai1.0...
0360: 55 04 2E 13 0B 31 32 31 34 31 37 32 36 39 30 37 U....12141726907
0370: 31 25 30 23 06 09 2A 86 48 86 F7 0D 01 09 01 16 1%0#..*.H.......
0380: 16 62 61 62 75 65 40 65 6D 69 72 61 74 65 73 62 .babue@nbdb
0390: 61 6E 6B 2E 63 6F 6D 31 12 30 10 06 03 55 04 03 ank.com1.0...U..
03A0: 13 09 62 61 62 75 20 62 61 62 75 0E 00 00 00 ..babu babu....
[Raw read]: length = 5
0000: 16 03 01 00 4D ....M
[Raw read]: length = 77
0000: 0B 00 00 03 00 00 00 10 00 00 42 00 40 25 49 2D ..........B.@%I-
0010: 10 ED DE 8A 27 28 E1 F9 CD 1B 1C 51 E1 A0 C7 2E ....'(.....Q....
0020: CA 7C A0 1F 19 E2 88 C4 41 49 33 7A CD 1C EA D8 ........AI3z....
0030: 6A C9 EC 32 88 81 73 D1 42 A4 7D BE 17 32 E3 5B j..2..s.B....2.[
0040: EA A5 2C 5D EC 0D 8A 76 CB F6 1D 82 0B ..,]...v.....
Thread-0, READ: TLSv1 Handshake, length = 77
*** Certificate chain
Thread-0, SEND TLSv1 ALERT: fatal, description = bad_certificate
Thread-0, WRITE: TLSv1 Alert, length = 2
[Raw write]: length = 7
0000: 15 03 01 00 02 02 2A ......*
Thread-0, called closeSocket()
Thread-0, handling exception: javax.net.ssl.SSLHandshakeException: null cert chain
IOException occurred when processing request.
Thread-0, called close()
Thread-0, called closeInternal(true)
Accepted connection to 192.168.254.1 (192.168.254.1) on port 2990.
----------1-1-1-----
[Raw read]: length = 5
0000: 80 62 01 03 01 .b...
[Raw read]: length = 95
0000: 00 39 00 00 00 20 00 00 04 01 00 80 00 00 05 00 .9... ..........
0010: 00 2F 00 00 33 00 00 32 00 00 0A 07 00 C0 00 00 ./..3..2........
0020: 16 00 00 13 00 00 09 06 00 40 00 00 15 00 00 12 .........@......
0030: 00 00 03 02 00 80 00 00 08 00 00 14 00 00 11 45 ...............E
0040: 49 06 56 DE 63 83 34 50 9F A8 B4 E3 30 2F C0 79 I.V.c.4P....0/.y
0050: 42 45 1A 6A A3 A4 20 2D 89 10 A0 25 AE 48 66 BE.j.. -...%.Hf
[read] MD5 and SHA1 hashes: len = 3
0000: 01 03 01 ...
[read] MD5 and SHA1 hashes: len = 95
0000: 00 39 00 00 00 20 00 00 04 01 00 80 00 00 05 00 .9... ..........
0010: 00 2F 00 00 33 00 00 32 00 00 0A 07 00 C0 00 00 ./..3..2........
0020: 16 00 00 13 00 00 09 06 00 40 00 00 15 00 00 12 .........@......
0030: 00 00 03 02 00 80 00 00 08 00 00 14 00 00 11 45 ...............E
0040: 49 06 56 DE 63 83 34 50 9F A8 B4 E3 30 2F C0 79 I.V.c.4P....0/.y
0050: 42 45 1A 6A A3 A4 20 2D 89 10 A0 25 AE 48 66 BE.j.. -...%.Hf
Thread-1, READ: SSL v2, contentType = Handshake, translated length = 73
*** ClientHello, TLSv1
RandomCookie: GMT: 1162413654 bytes = { 222, 99, 131, 52, 80, 159, 168, 180, 227, 48, 47, 192, 121, 66, 69, 26, 106, 163, 164, 32, 45, 137, 16, 160, 37, 174, 72, 102 }
Session ID: {}
Cipher Suites: [SSL_RSA_WITH_RC4_128_MD5, SSL_RSA_WITH_RC4_128_SHA, TLS_RSA_WITH_AES_128_CBC_SHA, TLS_DHE_RSA_WITH_AES_128_CBC_SHA, TLS_DHE_DSS_WITH_AES_128_CBC_SHA, SSL_RSA_WITH_3DES_EDE_CBC_SHA, SSL_DHE_RSA_WITH_3DES_EDE_CBC_SHA, SSL_DHE_DSS_WITH_3DES_EDE_CBC_SHA, SSL_RSA_WITH_DES_CBC_SHA, SSL_DHE_RSA_WITH_DES_CBC_SHA, SSL_DHE_DSS_WITH_DES_CBC_SHA, SSL_RSA_EXPORT_WITH_RC4_40_MD5, SSL_RSA_EXPORT_WITH_DES40_CBC_SHA, SSL_DHE_RSA_EXPORT_WITH_DES40_CBC_SHA, SSL_DHE_DSS_EXPORT_WITH_DES40_CBC_SHA]
Compression Methods: { 0 }
%% Created: [Session-2, SSL_RSA_WITH_RC4_128_MD5]
*** ServerHello, TLSv1
RandomCookie: GMT: 1162413669 bytes = { 30, 208, 109, 78, 140, 101, 21, 219, 26, 140, 158, 150, 32, 100, 190, 23, 140, 102, 8, 144, 137, 86, 160, 236, 214, 245, 33, 94 }
Session ID: {69, 73, 6, 101, 151, 179, 48, 160, 233, 21, 49, 37, 62, 184, 27, 54, 134, 50, 218, 49, 149, 61, 139, 27, 93, 80, 81, 120, 238, 184, 24, 110}
Cipher Suite: SSL_RSA_WITH_RC4_128_MD5
Compression Method: 0
Cipher suite: SSL_RSA_WITH_RC4_128_MD5
*** Certificate chain
chain [0] = [
Version: V3
Subject: CN=babu babu, [email protected], DNQ=12141726907, L=dubai, C=AE
Signature Algorithm: SHA1withRSA, OID = 1.2.840.113549.1.1.5
Key: Sun RSA public key, 512 bits
modulus: 9683790188147953162795730790793527257397758989267819282372960853921863644980017792669595318858981940986671279705015616513809624780681913479305781592431811
public exponent: 65537
Validity: [From: Wed Nov 01 12:09:39 GST 2006,
               To: Fri Dec 01 12:09:38 GST 2006]
Issuer: CN=Comtrust Demo CA, OU=Comtrust eBusiness Services, O=Etisalat, C=AE
SerialNumber: [    0118]
Certificate Extensions: 4
[1]: ObjectId: 2.5.29.35 Criticality=false
AuthorityKeyIdentifier [
KeyIdentifier [
0000: 7B 36 C0 C7 73 46 9E FB 0B C4 9E 93 48 B3 CA A5 .6..sF......H...
0010: 07 1A FD B5 ....
[2]: ObjectId: 2.5.29.17 Criticality=false
SubjectAlternativeName [
[RFC822Name: [email protected]]]
[3]: ObjectId: 2.5.29.15 Criticality=false
KeyUsage [
DigitalSignature
Key_Encipherment
[4]: ObjectId: 2.5.29.19 Criticality=false
BasicConstraints:[
CA:false
PathLen: undefined
Unparseable certificate extensions: 1
[1]: ObjectId: 2.5.29.31 Criticality=false
0000: 30 66 30 64 A0 62 A0 60 86 5E 6C 64 61 70 3A 2F 0f0d.b.`.^ldap:/
0010: 2F 6C 64 61 70 2E 63 6F 6D 74 72 75 73 74 2E 63 /ldap.comtrust.c
0020: 6F 2E 61 65 2F 43 4E 3D 43 6F 6D 74 72 75 73 74 o.ae/CN=Comtrust
0030: 20 44 65 6D 6F 20 43 41 2C 20 4F 55 3D 43 6F 6D Demo CA, OU=Com
0040: 74 72 75 73 74 20 65 42 75 73 69 6E 65 73 73 20 trust eBusiness
0050: 53 65 72 76 69 63 65 73 2C 4F 3D 45 74 69 73 61 Services,O=Etisa
0060: 6C 61 74 2C 43 3D 41 45 lat,C=AE
Algorithm: [SHA1withRSA]
Signature:
0000: 41 AC BF FB 89 E2 5D C3 41 40 95 74 41 9B D4 4D A.....][email protected]
0010: 02 2D AE 92 85 CD 8B 55 5E 8A E9 CA 1F 20 36 2A .-.....U^.... 6*
0020: 36 89 8F 84 22 AB 4F 8B B3 8B 7A DD 88 B3 98 B1 6...".O...z.....
0030: EE D0 82 06 D2 75 2F DD 36 2E 30 C6 6D 92 0A 7D .....u/.6.0.m...
0040: 61 F1 90 71 00 FA 09 86 2E B7 76 00 EE 4B 85 90 a..q......v..K..
0050: CD A0 0A 20 F2 C7 0C 49 E4 A0 71 83 FB 9A 4A EF ... ...I..q...J.
0060: ED 4A E9 36 C5 00 59 A8 EF 28 66 1E CC 81 FC FA .J.6..Y..(f.....
0070: 75 B0 B5 B8 0E 5F BE 4E C6 D0 B3 BA 4E 4C 2C B9 u...._.N....NL,.
*** CertificateRequest
Cert Types: RSA, DSS,
Cert Authorities:
<CN=babu babu, [email protected], DNQ=12141726907, L=dubai, C=AE>
*** ServerHelloDone
[write] MD5 and SHA1 hashes: len = 938
0000: 02 00 00 46 03 01 45 49 06 65 1E D0 6D 4E 8C 65 ...F..EI.e..mN.e
0010: 15 DB 1A 8C 9E 96 20 64 BE 17 8C 66 08 90 89 56 ...... d...f...V
0020: A0 EC D6 F5 21 5E 20 45 49 06 65 97 B3 30 A0 E9 ....!^ EI.e..0..
0030: 15 31 25 3E B8 1B 36 86 32 DA 31 95 3D 8B 1B 5D .1%>..6.2.1.=..]
0040: 50 51 78 EE B8 18 6E 00 04 00 0B 00 02 DD 00 02 PQx...n.........
0050: DA 00 02 D7 30 82 02 D3 30 82 02 3C A0 03 02 01 ....0...0..<....
0060: 02 02 02 01 18 30 0D 06 09 2A 86 48 86 F7 0D 01 .....0...*.H....
0070: 01 05 05 00 30 61 31 0B 30 09 06 03 55 04 06 13 ....0a1.0...U...
0080: 02 41 45 31 11 30 0F 06 03 55 04 0A 13 08 45 74 .AE1.0...U....Et
0090: 69 73 61 6C 61 74 31 24 30 22 06 03 55 04 0B 13 isalat1$0"..U...
00A0: 1B 43 6F 6D 74 72 75 73 74 20 65 42 75 73 69 6E .Comtrust eBusin
00B0: 65 73 73 20 53 65 72 76 69 63 65 73 31 19 30 17 ess Services1.0.
00C0: 06 03 55 04 03 13 10 43 6F 6D 74 72 75 73 74 20 ..U....Comtrust
00D0: 44 65 6D 6F 20 43 41 30 1E 17 0D 30 36 31 31 30 Demo CA0...06110
00E0: 31 30 38 30 39 33 39 5A 17 0D 30 36 31 32 30 31 1080939Z..061201
00F0: 30 38 30 39 33 38 5A 30 6E 31 0B 30 09 06 03 55 080938Z0n1.0...U
0100: 04 06 13 02 41 45 31 0E 30 0C 06 03 55 04 07 13 ....AE1.0...U...
0110: 05 64 75 62 61 69 31 14 30 12 06 03 55 04 2E 13 .dubai1.0...U...
0120: 0B 31 32 31 34 31 37 32 36 39 30 37 31 25 30 23 .121417269071%0#
0130: 06 09 2A 86 48 86 F7 0D 01 09 01 16 16 62 61 62 ..*.H........bab
0140: 75 65 40 65 6D 69 72 61 74 65 73 62 61 6E 6B 2E ue@nbdbank.
0150: 63 6F 6D 31 12 30 10 06 03 55 04 03 13 09 62 61 com1.0...U....ba
0160: 62 75 20 62 61 62 75 30 5C 30 0D 06 09 2A 86 48 bu babu0\0...*.H
0170: 86 F7 0D 01 01 01 05 00 03 4B 00 30 48 02 41 00 .........K.0H.A.
0180: B8 E5 61 65 47 4F AE 19 55 98 CE 56 A9 4F 73 33 ..aeGO..U..V.Os3
0190: 5E 73 FD 26 1B AD 63 C8 C9 91 53 7E 7E CB 15 18 ^s.&..c...S.....
01A0: EB 78 00 8A 23 DD 03 68 2E 1F AE 3D 5F 53 3D 64 .x..#..h...=_S=d
01B0: 76 2C 87 F5 12 07 F3 17 C6 7D 04 F1 21 DF 9C C3 v,..........!...
01C0: 02 03 01 00 01 A3 81 D0 30 81 CD 30 1F 06 03 55 ........0..0...U
01D0: 1D 23 04 18 30 16 80 14 7B 36 C0 C7 73 46 9E FB .#..0....6..sF..
01E0: 0B C4 9E 93 48 B3 CA A5 07 1A FD B5 30 09 06 03 ....H.......0...
01F0: 55 1D 13 04 02 30 00 30 0B 06 03 55 1D 0F 04 04 U....0.0...U....
0200: 03 02 05 A0 30 21 06 03 55 1D 11 04 1A 30 18 81 ....0!..U....0..
0210: 16 62 61 62 75 65 40 65 6D 69 72 61 74 65 73 62 .babue@nbdb
0220: 61 6E 6B 2E 63 6F 6D 30 6F 06 03 55 1D 1F 04 68 ank.com0o..U...h
0230: 30 66 30 64 A0 62 A0 60 86 5E 6C 64 61 70 3A 2F 0f0d.b.`.^ldap:/
0240: 2F 6C 64 61 70 2E 63 6F 6D 74 72 75 73 74 2E 63 /ldap.comtrust.c
0250: 6F 2E 61 65 2F 43 4E 3D 43 6F 6D 74 72 75 73 74 o.ae/CN=Comtrust
0260: 20 44 65 6D 6F 20 43 41 2C 20 4F 55 3D 43 6F 6D Demo CA, OU=Com
0270: 74 72 75 73 74 20 65 42 75 73 69 6E 65 73 73 20 trust eBusiness
0280: 53 65 72 76 69 63 65 73 2C 4F 3D 45 74 69 73 61 Services,O=Etisa
0290: 6C 61 74 2C 43 3D 41 45 30 0D 06 09 2A 86 48 86 lat,C=AE0...*.H.
02A0: F7 0D 01 01 05 05 00 03 81 81 00 41 AC BF FB 89 ...........A....
02B0: E2 5D C3 41 40 95 74 41 9B D4 4D 02 2D AE 92 85 .][email protected]...
02C0: CD 8B 55 5E 8A E9 CA 1F 20 36 2A 36 89 8F 84 22 ..U^.... 6*6..."
02D0: AB 4F 8B B3 8B 7A DD 88 B3 98 B1 EE D0 82 06 D2 .O...z..........
02E0: 75 2F DD 36 2E 30 C6 6D 92 0A 7D 61 F1 90 71 00 u/.6.0.m...a..q.
02F0: FA 09 86 2E B7 76 00 EE 4B 85 90 CD A0 0A 20 F2 .....v..K..... .
0300: C7 0C 49 E4 A0 71 83 FB 9A 4A EF ED 4A E9 36 C5 ..I..q...J..J.6.
0310: 00 59 A8 EF 28 66 1E CC 81 FC FA 75 B0 B5 B8 0E .Y..(f.....u....
0320: 5F BE 4E C6 D0 B3 BA 4E 4C 2C B9 0D 00 00 77 02 _.N....NL,....w.
0330: 01 02 00 72 00 70 30 6E 31 0B 30 09 06 03 55 04 ...r.p0n1.0...U.
0340: 06 13 02 41 45 31 0E 30 0C 06 03 55 04 07 13 05 ...AE1.0...U....
0350: 64 75 62 61 69 31 14 30 12 06 03 55 04 2E 13 0B dubai1.0...U....
0360: 31 32 31 34 31 37 32 36 39 30 37 31 25 30 23 06 121417269071%0#.
0370: 09 2A 86 48 86 F7 0D 01 09 01 16 16 62 61 62 75 .*.H........babu
0380: 65 40 65 6D 69 72 61 74 65 73 62 61 6E 6B 2E 63 [email protected]
0390: 6F 6D 31 12 30 10 06 03 55 04 03 13 09 62 61 62 om1.0...U....bab
03A0: 75 20 62 61 62 75 0E 00 00 00 u babu....
Thread-1, WRITE: TLSv1 Handshake, length = 938
[Raw write]: length = 943
0000: 16 03 01 03 AA 02 00 00 46 03 01 45 49 06 65 1E ........F..EI.e.
0010: D0 6D 4E 8C 65 15 DB 1A 8C 9E 96 20 64 BE 17 8C .mN.e...... d...
0020: 66 08 90 89 56 A0 EC D6 F5 21 5E 20 45 49 06 65 f...V....!^ EI.e
0030: 97 B3 30 A0 E9 15 31 25 3E B8 1B 36 86 32 DA 31 ..0...1%>..6.2.1
0040: 95 3D 8B 1B 5D 50 51 78

Few questions for you, before I go off in a completely
different direction than you're after...
Are you using a third party Crypto Provider?
Do you need to be able to read these files into Java
often, or is this a one-time-only type conversion?Hi,
I got these files from a third party as part of a small project. They used openssl to generate the private keys, and the corresponding certificates. They dont have a file such as keyfile or anything similar so that I could generate a keystore. But I know the passwords which was used to generate the key.
The private keys are in pem (they've used pkcs12) and stored as:
-----BEGIN RSA PRIVATE KEY-----
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
-----END RSA PRIVATE KEY-----
I don't know how to read the private keys. I've managed to read the certificates by doing:
FileInputStream in = new FileInputStream(filename);
CertificateFactory cf = CertificateFactory.getInstance("X509");
cert = (X509Certificate) cf.generateCertificate(in);
in.close();
I am using Bouncy Castle Crypto, and yes I will need to read these files often.
Thanks

Similar Messages

  • PKCS12 certificate payloads in OS X Server 10.9 Profile Manager

    Hi all,
    I'm unable to successfully push .p12 packaged certificate identities to devices managed by OS X Server 10.9 Profile Manager. The problem is that while the file is pushed to the device, it doesn't get unpacked and hence is unable to be used.
    I've identified the problem as Profile Manager setting the payload type incorrectly to "com.apple.security.pkcs1" in the profile rather than "com.apple.security.pkcs12". If I strip the profile signing data and edit it, the profile works perfectly when manually installed.
    So the questions I have:
    1) What's the best way of getting Apple's attention for someone to fix this bug, or is this possibly a browser JavaScript issue incorrectly identifying the payload type (using latest Safari though)?
    2) Does anyone know of a workaround to allow this to still be automatically pushed out without having to manually edit and install on each device?
    (SCEP is out at the moment due to another issue base64 decoding the SCEP request from Mac OS X devices that I'm taking up with the SCEP server vendor - but iOS works fine)
    Thanks!
    Al

    I'm new to OS X Server and Radius, and have just spent way too many hours trying to figure out what I was doing wrong. I could connect to our enterprise wifi perfectly fine when selecting the certificate from the keychain, but I just couldn't get it to work when I uploaded the .p12 file and used it as the WiFi identity. I tried so many combinations of passphrase, no passphrase, pem format, pkcs12 format, resetting Radius server, resetting whole PKI... But I'd always see Certificate: ?Error_-25257? in the Settings window while I was trying to install the profile, and I couldn't see anything useful in the Radius logs when I tried to connect.
    But it turns out, all I needed to do was:
       sed -i '' -e '1s/pkcs1/pkcs12/;t' -e '1,/pkcs1/s//pkcs12/' wifi_profile.mobileconfig
    (changes the first instance of pkcs1 to pkcs12 - don't change both! I was wondering why it was asking me for a password for our public certificate.)
    Will try to update and see if that fixes the problem.

  • Question about SSLM configure

    I have a question about our SSLM configure, please see the following example:
    service aa-SSL
    virtual ipaddr 172.25.17.15 protocol tcp port 443 secondary
    server ipaddr 172.24.92.6 protocol tcp port 80
    certificate rsa general-purpose trustpoint www.app.aa.com
    no nat server
    inservice
    crypto pki trustpoint www.app.aa.com
    revocation-check none
    rsakeypair www.app.aa.com
    crypto ca import www.app.aa.com pkcs12 tftp:xxx
    ======================================
    Once we finish the configuration, we could find the corresponding cer in SSLM, like:
    crypto pki certificate chain www.app.aa.com
    My first question is how to remove this cert if we want to decommission aa-ssl environment? Is it only with “no crypto pki certificate chain www.app.aa.com”
    If we have another environment like www.pre.app.aa.com shared the same VIP with www.app.aa.com. My second question is could I create only one ssl entry with wildcard like the following configuration:
    service aa-SSL
    virtual ipaddr 172.25.17.15 protocol tcp port 443 secondary
    server ipaddr 172.24.92.6 protocol tcp port 80
    certificate rsa general-purpose trustpoint *.app.aa.com
    no nat server
    inservice
    Please advice! I would appreciate it!

    You can remove the certificate but you need to be in certificate chain configuration mode to delete certificates. An example configuration is provided here
    http://www.cisco.com/en/US/docs/ios/security/command/reference/sec_c5.html#wp1043434

  • Questions on Print Quote report

    Hi,
    I'm fairly new to Oracle Quoting and trying to get familiar with it. I have a few questions and would appreciate if anyone answers them
    1) We have a requirement to customize the Print Quote report. I searched these forums and found that this report can be defined either as a XML Publisher report or an Oracle Reports report depending on a profile option. Can you please let me know what the name of the profile option is?
    2) When I select the 'Print Quote' option from the Actions drop down in the quoting page and click Submit I get the report printed and see the following URL in my browser.
    http://<host>:<port>/dev60cgi/rwcgi60?PROJ03_APPS+report=/proj3/app/appltop/aso/11.5.0/reports/US/ASOPQTEL.rdf+DESTYPE=CACHE+P_TCK_ID=23731428+P_EXECUTABLE=N+P_SHOW_CHARGES=N+P_SHOW_CATG_TOT=N+P_SHOW_PRICE_ADJ=Y+P_SESSION_ID=c-RAuP8LOvdnv30grRzKqUQs:S+P_SHOW_HDR_ATTACH=N+P_SHOW_LINE_ATTACH=N+P_SHOW_HDR_SALESUPP=N+P_SHOW_LN_SALESUPP=N+TOLERANCE=0+DESFORMAT=RTF+DESNAME=Quote.rtf
    Does it mean that the profile in our case is set to call the rdf since it has reference to ASOPQTEL.rdf in the above url?
    3) When you click on submit button do we have something like this in the jsp code: On click call ASOPQTEL.rdf. Is the report called using a concurrent program? I want to know how the report is getting invoked?
    4) If we want to customize the jsp pages can you please let me know the steps involved in making the customizations and testing them.
    Thanks and Appreciate your patience
    -PC

    1) We have a requirement to customize the Print Quote report. I searched these forums and found that this report can be defined either as a XML Publisher report or an Oracle Reports report depending on a profile option. Can you please let me know what the name of the profile option is?
    I think I posted it in one of the threads2) When I select the 'Print Quote' option from the Actions drop down in the quoting page and click Submit I get the report printed and see the following URL in my browser.
    http://<host>:<port>/dev60cgi/rwcgi60?PROJ03_APPS+report=/proj3/app/appltop/aso/11.5.0/reports/US/ASOPQTEL.rdf+DESTYPE=CACHE+P_TCK_ID=23731428+P_EXECUTABLE=N+P_SHOW_CHARGES=N+P_SHOW_CATG_TOT=N+P_SHOW_PRICE_ADJ=Y+P_SESSION_ID=c-RAuP8LOvdnv30grRzKqUQs:S+P_SHOW_HDR_ATTACH=N+P_SHOW_LINE_ATTACH=N+P_SHOW_HDR_SALESUPP=N+P_SHOW_LN_SALESUPP=N+TOLERANCE=0+DESFORMAT=RTF+DESNAME=Quote.rtf
    Does it mean that the profile in our case is set to call the rdf since it has reference to ASOPQTEL.rdf in the above url?
    Yes, your understanding is correct.3) When you click on submit button do we have something like this in the jsp code: On click call ASOPQTEL.rdf. Is the report called using a concurrent program? I want to know how the report is getting invoked?
    No, there is no conc program getting called, you can directly call a report in a browser window, Oracle reports server will execute the report and send the HTTP response to the browser.4) If we want to customize the jsp pages can you please let me know the steps involved in making the customizations and testing them.
    This is detailed in many threads.Thanks
    Tapash

  • Satellite P300D-10v - Question about warranty

    HI EVERYBODY
    I have these overheating problems with my laptop Satellite P300D-10v.
    I did everything I could do to fix it without any success..
    I get the latest update of the bios from Toshiba. I cleaned my lap with compressed air first and then disassembled it all and cleaned it better.(it was really clean insight though...)
    BUT unfortunately the problem still exists...
    So i made a research on the internet and I found out that most of Toshiba owners have the same exactly problem with their laptop.
    Well i guess this is a Toshiba bug for many years now.
    Its a really nice lap, cool sound (the best in laptop ever) BUT......
    So I wanted to make a question. As i am still under warranty, can i return this laptop and get my money back or change it with a different one????
    If any body knows PLS let me know.
    chears
    Thanks in advance

    Hi
    I have already found you other threads.
    Regarding the warranty question;
    If there is something wrong with the hardware then the ASP in your country should be able to help you.
    The warranty should cover every reparation or replacement.
    But I read that you have disasembled the laptop at your own hand... hmmm if you have disasembled the notebook then your warrany is not valid anymore :(
    I think this should be clear for you that you can lose the warrany if you disasemble the laptop!
    By the way: you have to speak with the notebook dealer where you have purchased this notebook if you want to return the notebook
    The Toshiba ASP can repair and fix the notebook but you will not get money from ASP.
    Greets

  • Question regarding NULL and forms

    Hi all, i have a survey that im working on that will be sent via email.
    I'm having an issue though. if i have a multiple choice question, and the user only selects one of the choices, all the unselected choices return as NULL. is there a way i can filter out anytihng that says "NULL" so it only shows the selected options?
    thanks.
    here is the page that retrieves all the data. thanks
    <body>
    <p>1) Is this your first visit to xxxxxxx? <b><%=request.getParameter("stepone") %></b>
    </p>
    <p> </p>
    <p>2) How did You Learn About xxxxxxx?</p>
    <p><b><%=request.getParameter("steptwoOne") %></b>
      <br>
        <b><%=request.getParameter("steptwoTwo") %></b>
      <br>
        <b><%=request.getParameter("steptwoThree") %></b>
      <br>
        <b><%=request.getParameter("steptwoFour") %></b>
      <br>
        <b><%=request.getParameter("steptwoOther") %></b>
    </p>
    <p> </p>
    <p>3) What was your main reason for visiting xxxxx?</p>
    <p><b><%=request.getParameter("stepthreeOne") %></b>
        <br>
          <b><%=request.getParameter("stepthreeTwo") %></b>
        <br>
          <b><%=request.getParameter("stepthreeThree") %></b>
        <br>
          <b><%=request.getParameter("stepthreeFour") %></b>
        <br>
          <b><%=request.getParameter("stepthreeOther") %></b>
    </p>
    <p>4) did you find the information you were looking for on this site?</p>
    <p><b><%=request.getParameter("stepfour") %>
    <br>
    <b><%=request.getParameter("stepfourOther") %></b>
    </b></p>
    <p>5) Do you plan on using this website in the future?</p>
    <p><b><%=request.getParameter("stepfive") %></b></p>
    <p>6) What is your gender</p>
    <p><b><%=request.getParameter("stepsix") %></b></p>
    <p>7) What is your age group</p>
    <p><b><%=request.getParameter("stepseven") %></b></p>
    8) Would you like to take a moment and tell us how we can improve your experience on xxxxxxxxxx?
    <p><b><%=request.getParameter("stepeightFeedback") %></b></p>

    i was messing around and came up with this. it doesnt remove the null, but if it is null it adds ABC beside it. so i think i might be getting close. i just need to figure out how to replace the null.
    code]
    <b><%=request.getParameter("steptwoFour") %></b>
         <% if (request.getParameter("steptwoFour") == null ) {
         %>
         <% out.print("abc"); %>
         <% }
         %>

  • Anyone know how to remove Overdrive books from my iphone that have been transferred from my computer? They do not show up on itunes. I see a lot of answers to this question but they all are based on being able to see the books in iTunes.

    How do I remove Overdrive books from the library that were downloaded onto my computer then transferred to my iphone? The problem is that they do not show up in iTunes.
    I see this question asked a lot when I google, but they always give answers that assumes you can find the books in iTunes either under the books tab, or the audio books tab or in the music. They do not show up anywhere for me. They do not remove from the app like the ones I downloaded directly onto my iphone.the related archived article does not answer it either.  I even asked a guy working at an apple store and he could not help either.   Anybody...?
    Thanks!

    there is an app called daisydisk on mac app store which will help you see exactly where the memory is focused and consumed try using that app and see which folders are using more memory

  • Basic question

    Hello, i have a basic question. if i have defined 2 fields in a cube or a dso:
    Name Quantity
    and from the external flat file i get some characters for my quantity field. would my load fail?  for standard dso and for write optimized?
    NOTE: quantity field is a keyfigure defined as numeric.
    and the load coming in has "VIKPATEL" for Quantity field and not numbers.
    thanks

    Hi Vik,
    Yes, the load will fail.
    May be you coud first load this data into BW (into PSA) and set both fields as characters fields. Then you can create DSO, do transformation from this PSA to the DSO, and put your logic as to what do you want to do with those Quantity that is not number (e.g. convert to 0, or 'Not assgined', etc).
    You can use transfer rule, or a clean up ABAP code in the start routine.
    Hope this helps.

  • Mid 2010 15" i5 Battery Calibration Questions

    Hi, I have a mid 2010 15" MacBook Pro 2.4GHz i5.
    Question 1: I didn't calibrate my battery when I first got my MacBook Pro (it didn't say in the manual that I had to). I've had it for about a month and am doing a calibration today, is that okay? I hope I haven't damaged my battery? The calibration is only to help the battery meter provide an accurate reading of how much life it has remaining, right?
    Question 2: After reading Apple's calibration guide, I decided to set the MacBook Pro to never go to sleep (in Energy Saver System Preference) and leave it on overnight so it would run out of power and go to sleep, then I'd leave it in that state for at least 5 hours before charging it. When I woke up, the light on the front wasn't illuminated. It usually pulsates when in Sleep. Expectedly, it wouldn't wake when pressing buttons on the keyboard. So, what's happened? Is this Safe Sleep? I didn't see any "Your Mac is on reserve battery and will shut down" dialogues or anything similar, as I was asleep! I've left it in this state while I'm at work and will charge it this afternoon. Was my described method okay for calibration or should I have done something different?
    Question 3: Does it matter how quickly you drain your battery when doing a calibration? i.e is it okay to drain it quickly (by running HD video, Photo Booth with effects etc) or slowly (by leaving it idle or running light apps)?
    Thanks.
    Message was edited by: Fresh J

    Fresh J:
    A1. You're fine calibrating the battery now. You might have gotten more accurate readings during the first month if you'd done it sooner, but no harm has been done.
    A2. Your machine has NOT shut down; it has done exactly what it was supposed to do. When the power became critically low, it first wrote the contents of RAM to the hard drive, then went to sleep. When the battery was completely drained some time later, the MBP went into hibernation and the slepp light stopped pulsing and turned off. In that state the machine was using no power at all, but the contents of your RAM were still saved. Once the AC adapter was connected, a press of the power button would cause those contents to be reloaded, and the machine would pick up again exactly where you left off. It is not necessary to wait for the battery to be fully charged before using the machine on AC power, but do leave the AC adapter connected for at least two hours after the battery is fully charged. Nothing that you say you've done was wrong, and nothing that you say has happened was wrong.
    A3. No, it does not matter.

  • Jabber/WebEx Connect SSO Questions

    I've got a few questions around exactly what needs to be done to get SAML working for our Connect accounts to successfully authenticate from Jabber for Windows, Mac, iPhone, and Android.
    We have both a Meeting Center and Connect account under WebEx using Loose Coupled Integration. Just this past week I enabled SAML for our Meeting Center accounts which went off without a hitch with the exception of Meeting Center integration with Jabber, which is now broken with a message about SSO enabled Meeting Sites not being supported (I think this would maybe be fixed if we had Tight Coupled Integration with our two account?).
    Anyway, my questions are...
    For Windows, I understand all clients will need to be reinstalled with the MSI argument for the SSO_ORG_DOMAIN switch I've read about, is that correct? Are there any other switches needed for the reinstall? 
    How will this work with the Mac and mobile clients? There's obviously no command line options to specify for the installations here, will they just know to kick over to my IdP for authentication once they see an email address that falls under an org with SSO enabled? If so, why does the Windows client need to be completely reinstalled and not just know to find the IdP from the Cloud Connect service like Meeting Center does with the Productivity Tools?
    We're just doing this for our Connect Web IM accounts, not attempting any sort of SSO with the phone accounts/UC integration yet.
    Any ideas on getting the Meeting Center integration into Jabber working again?

    I'd suggest posting your question over on the Jabber Pilot forum, as this forum is specific to Jabber Guest questions:
    https://supportforums.cisco.com/community/4551/jabber-pilot-support
    -jim

  • My iPad wont let me download apps bc security questions, but when I try to make them it freezes

    Every time I try to download an app it tells me I need to update my security questions, but once I click to make the questions the box goes white. So I'm not sure how to fix it

    The new questions show on your account on http://appleid.apple.com ? If they do then try logging out and back into your account on your phone (assuming that is where you are trying to purchase from) and see if the new questions then show on it.

  • ASA VPN QUESTION

    Hi All
    The question is pretty simple. I can successfully connect  to my ASA 5505  firewall via cisco vpn client 64 bit , i can ping any ip  address on the LAN behind ASA but none of the LAN computers can see or  ping the IP Address which is assigned to my vpn client from the ASA VPN  Pool.
    The LAN behind ASA is 192.168.0.0 and the VPN Pool for the cisco vpn client is 192.168.30.0
    I would appreciate some help pls
    Here is the config:
    ASA Version 7.2(4)
    hostname ciscoasa
    domain-name default.domain.invalid
    enable password J7NxNd4NtVydfOsB encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    name 192.168.0.11 EXCHANGE
    name x.x.x.x WAN
    name 192.168.30.0 VPN_POOL2
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.0.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address WAN 255.255.255.252
    interface Ethernet0/0
    switchport access vlan 2
    <--- More --->
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    boot system disk0:/asa724-k8.bin
    ftp mode passive
    clock timezone EEST 2
    clock summer-time EEDT recurring last Sun Mar 3:00 last Sun Oct 4:00
    dns server-group DefaultDNS
    domain-name default.domain.invalid
    object-group protocol TCPUDP
    protocol-object udp
    protocol-object tcp
    access-list nk-acl extended permit tcp any interface outside eq smtp
    access-list nk-acl extended permit tcp any interface outside eq https
    access-list customerVPN_splitTunnelAcl standard permit 192.168.0.0 255.255.255.0
    access-list inside_nat0_outbound extended permit ip 192.168.0.0 255.255.255.0 VPN_POOL2 255.255.255.0
    access-list inside_access_in extended permit ip any any
    access-list VPN_NAT extended permit ip VPN_POOL2 255.255.255.0 192.168.0.0 255.255.255.0
    pager lines 24
    logging enable
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    ip local pool VPN_POOL2 192.168.30.10-192.168.30.90 mask 255.255.255.0
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-524.bin
    no asdm history enable
    arp timeout 14400
    global (inside) 10 interface
    global (outside) 1 interface
    nat (inside) 0 access-list inside_nat0_outbound
    nat (inside) 1 0.0.0.0 0.0.0.0
    nat (outside) 10 access-list VPN_NAT outside
    static (inside,outside) tcp interface smtp EXCHANGE smtp netmask 255.255.255.255
    static (inside,outside) tcp interface https EXCHANGE https netmask 255.255.255.255
    access-group inside_access_in in interface inside
    access-group nk-acl in interface outside
    route outside 0.0.0.0 0.0.0.0 x.x.x.x 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    aaa authentication enable console LOCAL
    aaa authentication http console LOCAL
    aaa authentication serial console LOCAL
    aaa authentication ssh console LOCAL
    aaa authentication telnet console LOCAL
    aaa authorization command LOCAL
    http server enable
    http 192.168.0.0 255.255.255.0 inside
    snmp-server host inside 192.168.0.16 community public
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto dynamic-map outside_dyn_map 20 set pfs group1
    crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
    crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
    crypto map outside_map interface outside
    crypto isakmp enable outside
    crypto isakmp policy 10
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    crypto isakmp nat-traversal  20
    telnet 192.168.0.0 255.255.255.0 inside
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    dhcp-client client-id interface outside
    dhcpd dns 217.27.32.196
    dhcpd address 192.168.0.100-192.168.0.200 inside
    dhcpd dns 192.168.0.10 interface inside
    dhcpd enable inside
    group-policy DfltGrpPolicy attributes
    banner none
    wins-server none
    dns-server none
    dhcp-network-scope none
    vpn-access-hours none
    vpn-simultaneous-logins 3
    vpn-idle-timeout 30
    vpn-session-timeout none
    vpn-filter none
    vpn-tunnel-protocol IPSec l2tp-ipsec
    password-storage disable
    ip-comp disable
    re-xauth disable
    group-lock none
    pfs disable
    ipsec-udp disable
    ipsec-udp-port 10000
    split-tunnel-policy tunnelall
    split-tunnel-network-list none
    default-domain none
    split-dns none
    intercept-dhcp 255.255.255.255 disable
    secure-unit-authentication disable
    user-authentication disable
    user-authentication-idle-timeout 30
    ip-phone-bypass disable
    leap-bypass disable
    nem disable
    backup-servers keep-client-config
    msie-proxy server none
    msie-proxy method no-modify
    msie-proxy except-list none
    msie-proxy local-bypass disable
    nac disable
    nac-sq-period 300
    nac-reval-period 36000
    nac-default-acl none
    address-pools none
    smartcard-removal-disconnect enable
    client-firewall none
    client-access-rule none
    webvpn
      functions url-entry
      html-content-filter none
      homepage none
      keep-alive-ignore 4
      http-comp gzip
      filter none
      url-list none
      customization value DfltCustomization
      port-forward none
      port-forward-name value Application Access
      sso-server none
      svc none
      svc keep-installer installed
      svc keepalive none
      svc rekey time none
      svc rekey method none
      svc dpd-interval client none
      svc dpd-interval gateway none
      svc compression deflate
    group-policy customerVPN internal
    group-policy customerVPN attributes
    dns-server value 192.168.0.10
    vpn-tunnel-protocol IPSec
    password-storage enable
    split-tunnel-policy tunnelspecified
    split-tunnel-network-list value customerVPN_splitTunnelAcl
    default-domain value customer.local
    username xxx password 8SYsAcRU4s6DpQP1 encrypted privilege 0
    username xxx attributes
    vpn-group-policy TUNNEL1
    username xxx password C6M4Xy7t0VOLU3bS encrypted privilege 0
    username xxx attributes
    vpn-group-policy PAPAGROUP
    username xxx password RU2zcsRqQAwCkglQ encrypted privilege 0
    username xxx attributes
    vpn-group-policy customerVPN
    username xxx password zfP8z5lE6WK/sSjY encrypted privilege 15
    tunnel-group customerVPN type ipsec-ra
    tunnel-group customerVPN general-attributes
    address-pool VPN_POOL2
    default-group-policy customerVPN
    tunnel-group customerVPN ipsec-attributes
    pre-shared-key *
    tunnel-group-map default-group DefaultL2LGroup
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
    service-policy global_policy global
    prompt hostname context
    Cryptochecksum:a4dfbb82008f78756fe4c7d029871ec1
    : end
    ciscoasa#                           

    Well lots of new features have been hinted at for ASA 9.2 but I've not seen anything as far as an Engineering Commit or Customer Commit for that feature.
    Site-site VPN in multiple context mode was added in 9.0(1) and I have customers have been asking for the remote access features as well.
    I will remember to ask about that at Cisco Live next month.

  • New to Apple, questions about using Windows, and other things

    Hello all,
    Today is my first day as an Apple owner. It's funny because I'm also a MCSE, MCSA, and MCP.
    I purchased a 24" iMac, 2.8GHz, 4GB RAM, and 1TB Hard Drive.
    I want to use Windows on my Mac so that I don't have to keep switching over to my PC. My main reason for using Windows is so that I can continue to enjoy my PC Games... mostly racing and D&D games.
    So my question is... how does Windows run on bootcamp? Can I still use all of my USB controllers (like my steering wheels, joysticks, etc?)
    I really havent even turned on my iMac... been too amazed at just looking at it for the first day (and also rearranging my home office).
    I really just want to know from those of you who have PCs AND Macs, if you still find yourself having to go back to your PC because of incompatibilities or performance issues on the iMac?

    Using BootCamp, your Windows experience is no different than if running it on a similarly configured PC. If you went with a VM running under Mac OS X (like VMWare or Parallels), there are a number of differences. However, using BootCamp you have a Mac-branded PC.
    I'd point out that people have been dual-booting operating systems in this fashion for decades. Windows has no obvious in-built support for doing so, but other operating systems (like Linux, FreeBSD, etc.) have always very clearly and explicitly supported dual-booting (on Macs and regular PCs) from the get go.

  • New Member / Video Card Choice Question

    New CS4 Production Premium User Here.
    I am building a computer system specifically for Video Editing and production for use with Premier CS4 & Sony Vegas.. Have been doing my usual amount of Over Research here and other places but have a series of issues I am having a little trouble coming to grips with.
    I have been into computer editing game for a long time but strictly in the Audio Recording /Mixing area /..
    Video is a new interest which has me hooked / Im also a Gear Junkie so I have to watch it. 
    I will probably be back with a couple more topics but to keep this thread simple /
    My first post question is the topic of Video cards: Adobes Hardware compatibility list seems a little out dated. ?
    The system does not have to be an ultimate gaming rig as I am not into that / just SD & HD Video editing & 3d effects.. I need a card which will do what is needed / works well with Premier CS4 / Is not too loud fan wise / can run 24/5 and not overheat.
    I also will need the ability to monitor on a HD TV with a good sound monitoring system / Midas / Bryston / Dynaudio etc;
    I was considering either of the following / from lowest price to highest.
    ASUS GeForce 9600GT Silent 650MHZ 512MB 1.8GHZ DDR3 PCI-E Dual DVI-I HDCP HDTV Out
    ASUS GeForce 9800GT Matrix 612MHZ 512MB 1.8GHZ DDR3 PCI-E Dual DVI-I HDCP HDTV Out
    ASUS GeForce 9800GTX+ Dk 740MHZ 512MB 2.3GHZ DDR3 PCI-E Dual DVI-I HDCP HDTV Out
    Questions:
    Is a 512mb card sufficient?
    Will all of the above do what is needed for my purpose?
    What about noise of heat issues.
    My system could be running close to 24/5 at times.
    Have not made a final decision on all components but will probably basically start of like this.
    Vista 64 Bit/OS
    Core I7 940
    Asus Rampage 2 Extreme or a plain P6T
    Antec 1200 Case / For now I will leave out the hard drives and other things on my list.
    My builder suggests to stick with ASUS Video Cards because he has the fastest warranty replacement service on his end for ASUS products / plus I am a total ASUS Motherboard guy with years satisfied experiences.. (in Audio setups).
    Any feedback or comments on the above will be appreciated.
    Thanks / Orion

    Thanks Members for the Feedback:
    I am trying to stick just to the Video Card Issues so the topic does not get all over the map / Raid issues have already been researched & I might have a question about that later in another thread.
    Witha the video card issue I am just trying to see if I can get a reply which the majority of users agree upon / not an easy task & that is were my confused state of topic started.
    b Keith
    It seems what you have said about QUADRO cards is the most agreed upon overall from my last three months of research at various locations / The cost is extreme for these cards & I was just trying to determime if I realy needed to go that far : >$2,000.00 and up.
    just for the Graphics card..
    Perhaps I should start of with one of the cards I first mentioned which are dirt cheep compared to the Quadro series and replace it when I have arrived at the point where my shills are beyond my hardware limitations.
    b Charles & Jim.
    Thanks for the reference to the . >ASUS GeForce 9800GTX+ Dk 740MHZ 512MB 2.3GHZ DDR3< I was thinking this might be the best to start with / except for the reported could be problems of / Noise / card size and Heat issues if running 24/5?
    Other issues you have stated also seem to be agreed upon from mny sources as well / which is why I am considering perhaps not going Raid "o" from the start / perhaps Raid 5.. / or No Raid until I see If realy need it for my own personal use level.
    b conclusion to this point in the game:
    Looks like If I do a top notch system following all the higher end recomendations it will cost me over $10,000.00 (if I include a capture card / raid card (Areca 1220 or 1240(don't want to get into that topic just yet)& all the extras... This is about double the investment I had planned as this is basically a serious hobby not a business venture. Plus we have not included another $6,000.00 for a half decent peosumer HD camera with a few extras. I was trying to keep the entire setup to 8 to 10 grand total.. Not including the software / so this looks like wishfull thinking at best / Ho Ho.
    b remember / unfortunately my pricing reflects Canadian $$ which includes a 25% hike in pricing because our government wants the loonie (Good Name) low valued so businesses can export our products at built in 25% Sale Pricing.
    Perhaps,we wont get into that topic/please, but I just couldn't resist / when I start thinking about government issues (anywhere in this world) I tend to go off the deep end as part of why I am going into this video thing is to document the destruction of our environment & the entire democratic process, which is a total farce in my neck of the woods. Nuff Said..
    Again Thanks for the input and I will keep watching and perhaps cover another topic later / my goal is to place an order for a build within the next 10 days of so.
    B Orion

  • External preview display via. Mini-DVI to video adapter QUESTION

    Hello, I have been browsing this forum for a while, and this is my first question.
    I have a Macbook Core2duo running Final Cut Pro. I purchased a Mini-DVI to S-video/composite video adapter.
    I cannot get my work to preview on this external monitor. I would like to view the canvas on the monitor while working. I had this setup at school on a G5, but I cannot get it to work on my macbook. The only way apple suggests doing this is by setting up a camera via. firewire and then run from the camera to the NTSC video display (television). I would just like to do it via. mini-dvi to my television for previewing.
    Any help is greatly appreciated. Thank you,
    Morgan Bressler

    From what I've been told, using the computer's video output isn't outputting a true NTSC picture. I was told when talking about how the Macbook Pros dropped the S-vdieo port that I shouldn't use that anyways, but rather to go the firewire route. THat was actually converts the video source to true NTSC instead of taking a computer output to a TV. While I have no doubt that it works, I'm willing to bet that you'll see a noticeable difference between the G5 S-video and your MB using firewire. Most consumer camcorders from the past several years do digital (firewire) to analogue (NTSC) conversion, so you probably don't even need a new box.
    -Brian

Maybe you are looking for

  • HT1947 Lost Apple TV remote, how can I use app if the home sharing is not already enabled?

    I lost my Apple TV remote so I can't change the settings on the tv.  Is there a way to use the remote app on my ipad without having the actual hardware remote to program the tv?

  • Familiar with GRAYSCALE ?

    can i convert a color image to grayscale. PLEASE! is it using colorTramsform? or the matrix one? well any ideas are welcome thanks

  • Speak only the highlighted text in TextEdit

    I would like a script that speaks only the highlighted text in TextEdit. I found this script at MacScripter, written by kai. Can it be tweaked. Thanks, Tom set text_buffer to 5 (* avoid attempts to speak just a few new characters: modify as required

  • Af:selectInputDate and Range Control

    I have two af:selectInputDate boxes in my page : one each for the start and end dates corresponding to a functionality. Once the user selects the start date(the first af:selectInputDate), i want the second af:selectInputDate to have that value as the

  • DAQPAD 6020e misses digital triggers during analog input (AI)

    I am using a 6020E BNC DAQPAD to acquire two seperate 12kHz analog signals from a sonar through ACH0 and ACH1. The sonar generates a digital start trigger at the start of each ping to notify the DAQ that new data is to follow and i am using this to t