Port Channel and VLAN trunking

When configuring trunking of VLANS accross a Port Channel, do we need to configure vlan pruning on both the port-Channel port and the physical ports ???
E.g. do I need to apply the "switchport trunk allowed vlan add " command under each physical port and the port channel port ? Or only under the port channel port ?
Thanks

In short, yes. Configure the port channel interface exactly as you do the physical interfaces and both ends should be an exact match. otherwise you will have problems getting the channel to come up or stay up.
-Mark

Similar Messages

  • How to configure a port channel with VLAN trunking (and make it work..)

    We're trying to configure a port channel group with trunked ports to connect a NetApp HA pair. We want to create two data LIFs and connect them to the switch stack.  We are trying to create 2 data lifs, one for cifs and one for nfs that are on different vlans.
    We want the same ports to be able to allow multiple vlans to communicate. (trunked)
    These data lifs should be able to fail over to different nodes in the HA pair and still be able to communicate on the network.
    What this means is that we have to connect 4 ports each for each node in the NetApp HA Pair to the switches and create a port channel of some type that allows for trunked vlans. When we configure the ports, the configuration is as follows (below):
    We are only able to configure an IP on one of the vlans.
    When we configure an IP from another vlan for the data lif, it does not respond to a ping.
    Does anyone have any idea what I'm doing wrong on the Cisco switch?
    interface GigabitEthernet4/0/12
    description Netapp2-e0a
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 10,20,511,519
    channel-protocol lacp
    channel-group 20 mode active
    end
    interface GigabitEthernet4/0/13
    description Netapp2-e0c
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 10,20,511,519
    channel-protocol lacp
    channel-group 20 mode active
    end
    interface GigabitEthernet6/0/12
    description Netapp2-e0b
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 10,20,511,519
    channel-protocol lacp
    channel-group 20 mode active
    end
    interface GigabitEthernet6/0/13
    description Netapp2-e0d
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 10,20,511,519
    channel-protocol lacp
    channel-group 20 mode active
    end
    interface Port-channel20
    description Netapp2-NFS
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 10,20,511,519
    spanning-tree portfast
    spanning-tree bpduguard enable
    end

    Our problem was fixed by the storage people.  They changed the server end to trunk, and the encapsulation / etherchannel.
    I like all the suggestions, and they probably helped out with the configuration getting this to work.
    Thanks!
    interface Port-channel20
    description Netapp2-NFS
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 10,20,511,519
    switchport mode trunk
    interface GigabitEthernet4/0/12
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 10,20,511,519
    switchport mode trunk
    channel-protocol lacp
    channel-group 20 mode active
    interface GigabitEthernet4/0/13
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 10,20,511,519
    switchport mode trunk
    channel-protocol lacp
    channel-group 20 mode active
    interface GigabitEthernet6/0/12
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 10,20,511,519
    switchport mode trunk
    channel-protocol lacp
    channel-group 20 mode active
    interface GigabitEthernet6/0/13
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 10,20,511,519
    switchport mode trunk
    channel-protocol lacp
    channel-group 20 mode active

  • SGE2010 port-channel and trunking config question

    I have port-channels configured and working for the native VLAN on multiple SGE2010s. I now want to add multiple VLANs and enable trunking for the port-channel. I am not clear on the appropriate way to enable trunking as it can be enabled on the port and on the port-channel. The ports and port-channel are currently in access mode. If anyone can provide the correct configuration, I would appreciate the guidance. I also need to get the port-channels and trunking working with 3Com 4500 & 4200s. If you know of any configuration issues, again any guidance would be appreciated

    Hi Jacqueline,
    Sorry Juans answer needs some correction, but I am grateful for Juans participation.
    The SGE2010 does not support a CLI.
    There is a unsupported CLI,  that someone plastered somehwere on this community, but i must admit i still like to use the GUI.
    The software on the SGE2XXX was recently updated so you can find that on the cisco.com website.
    I have created a link below  to a recording i just made,  regarding Link aggregation on the SGE2XXXX, i thnk if you see the 11 minute recording a couple of times, maybe pause it, play with your switch, it  will start to make sense.
    you can't breat the switch by configuring it
    click here to see a recording of me creating a Link aggregation between two switches
    regards Dave

  • Difference between Port Channel and VPc

    Hi Friends,
    Could you please provide the difference between Port Channel and VPC.
    Regards,
    Zaheer

    Read :)
    http://www.cisco.com/c/en/us/products/collateral/switches/nexus-3000-series-switches/white_paper_c11-685753.html
    Virtual PortChannel Technology
    Virtual PortChannels (vPCs) allow links that are physically connected to two different Cisco® switches to appear to a third downstream device to be coming from a single device and as part of a single PortChannel. The third device can be a switch, a server, or any other networking device that supports IEEE 802.3ad PortChannels.
    Cisco NX-OS Software vPCs and Cisco Catalyst® Virtual Switching Systems (VSS) are similar technologies. For Cisco EtherChannel technology, the term “multichassis EtherChannel” (MCEC) refers to either technology interchangeably.
    vPC allows the creation of Layer 2 PortChannels that span two switches. At the time of this writing, vPC is implemented on the Cisco Nexus® 7000 and 5000 Series platforms (with or without Cisco Nexus 2000 Series Fabric Extenders).

  • EtherChannel and Vlan trunk

    I am trying to have 3 group of 4 GigE ports on the 3560G as a etherchannel and connect to 4 dells.
    On gi0/7 - 10 the trunk config seems to work but I am not able to route between the switches. Here is the config ...
    Can anyone take a look tell me what's missing? Much appreciated!
    Building configuration...
    Current configuration : 3422 bytes
    ! Last configuration change at 00:35:24 UTC Sat Jul 9 2005
    version 12.2
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    hostname cisco_switch_b
    enable secret xxxx
    enable password xxx
    ip subnet-zero
    ip routing
    spanning-tree mode pvst
    no spanning-tree optimize bpdu transmission
    spanning-tree extend system-id
    interface Port-channel1
    switchport access vlan 5
    switchport trunk encapsulation dot1q
    switchport mode trunk
    interface GigabitEthernet0/1
    description To Internet Router
    no switchport
    ip address 10.1.1.2 255.255.255.0
    ip helper-address 10.1.1.8
    interface GigabitEthernet0/2
    interface GigabitEthernet0/3
    interface GigabitEthernet0/4
    interface GigabitEthernet0/5
    interface GigabitEthernet0/6
    interface GigabitEthernet0/7
    description To Dell_switch_1
    switchport access vlan 5
    switchport trunk encapsulation dot1q
    switchport mode trunk
    channel-group 1 mode on
    spanning-tree portfast
    interface GigabitEthernet0/8
    switchport access vlan 5
    switchport trunk encapsulation dot1q
    switchport mode trunk
    channel-group 1 mode on
    spanning-tree portfast
    interface GigabitEthernet0/9
    switchport access vlan 5
    switchport trunk encapsulation dot1q
    switchport mode trunk
    channel-group 1 mode on
    spanning-tree portfast
    interface GigabitEthernet0/10
    switchport access vlan 5
    switchport trunk encapsulation dot1q
    switchport mode trunk
    channel-group 1 mode on
    spanning-tree portfast
    interface GigabitEthernet0/11
    description To Dell_switch_2
    switchport access vlan 6
    spanning-tree portfast
    interface GigabitEthernet0/12
    switchport access vlan 6
    spanning-tree portfast
    interface GigabitEthernet0/13
    switchport access vlan 6
    spanning-tree portfast
    interface GigabitEthernet0/14
    switchport access vlan 6
    spanning-tree portfast
    interface GigabitEthernet0/15
    description To Dell_switch_3
    switchport access vlan 7
    switchport mode access
    spanning-tree portfast
    interface GigabitEthernet0/16
    switchport access vlan 7
    switchport mode access
    spanning-tree portfast
    interface GigabitEthernet0/17
    switchport access vlan 7
    switchport mode access
    spanning-tree portfast
    interface GigabitEthernet0/18
    switchport access vlan 7
    switchport mode access
    spanning-tree portfast
    interface GigabitEthernet0/19
    interface GigabitEthernet0/20
    interface GigabitEthernet0/21
    interface GigabitEthernet0/22
    interface GigabitEthernet0/23
    interface GigabitEthernet0/24
    interface GigabitEthernet0/25
    interface GigabitEthernet0/26
    interface GigabitEthernet0/27
    interface GigabitEthernet0/28
    interface Vlan1
    no ip address
    shutdown
    interface Vlan5
    ip address 10.1.5.1 255.255.255.0
    interface Vlan6
    ip address 10.1.6.1 x.x.255.0
    ip helper-address 10.1.5.7
    interface Vlan7
    ip address 10.1.7.1 x.x.x.0
    ip helper-address 10.1.5.7
    ip default-gateway 10.1.1.1
    ip classless
    ip http server
    access-list 100 permit ip host 0.0.0.0 host 255.255.255.255
    access-list 100 permit udp host 10.1.5.1 host 10.1.5.7 eq bootps
    access-list 100 permit udp host 10.1.5.1 host 10.1.5.7 eq bootpc
    access-list 100 permit udp host 10.1.5.7 host 10.1.5.1 eq bootps
    access-list 100 permit udp host 10.1.5.7 host 10.1.5.1 eq bootpc
    access-list 100 permit ip host 0.0.0.0 host 255.255.255.0
    control-plane
    line con 0
    exec-timeout 0 0
    line vty 0 4
    password xxx
    no login
    line vty 5 15
    password xxx
    no login
    ntp server 10.1.5.7
    end

    Here is an example to configure EtherChannel:
    Cisco Catalyst 3560 Switch Configuration
    Set MDIX automatic – To enable cisco catalyst to accept cross cable and straight cable connection
    # config t
    # int range g0/1 – 28
    # switchport mode access - Configure Cisco catalyst to normal switch port
    # speed auto
    # duplex auto
    # mdix auto
    # end
    # show controllers Ethernet-controller
    # copy running-config startup-config
    Configure Etherchannels – support redundancy and network load balancing
    # config t
    # int range g0/23 – 24
    # switchport mode access
    # switchport mode vlan 1
    # channel-group 5 mode active
    # exit
    Configure Etherchannels load balancing
    # config t
    # port-channel load-balance src-dst-mac
    # exit
    Configure IP Address:
    # config t
    # int vlan 1
    # ip address 10.xx.xx.xx 255.255.252.0
    # ip default-gateway 10.xx.xx.1
    # config t
    # int range g0/19-20
    # channel-group 2 mode active
    # config t
    # int range g0/17-18
    # channel-group 3 mode active
    # channel-group mode 3 desirable
    # int port-channel 3
    # switchport mode access
    # config t
    # int range g0/15-16
    # channel-group 4 mode active
    # show etherchannel summary – to check Etherchannel port status
    Regards,
    Junhan
    IT Specialist

  • Dynamic port channel and load distribution across the interfaces on th trunk.

    WS-C3750G-48TS
    NOS-12.2(25)SEE2
    I have a dynamic port channenl setup on Cisco+NetApp environemt where i have 6 interfaces(1Gbps) on that trunk for load balancing and reduntancy reason.
    But i see the interfaces are not balanced on receives or inbound. I mean most of them are going to only 2 interfaces and other four are almost doing nothing.
    I am assuming netapp ports serves the way how Cisco instructs. How i can remediate this situation? What am i missing here?

    I have alerady mentioned "lacp" in my my last post. Also my understanding  LB is set at switch side , not at filer side. Becase i dont have config at filer side. Also loooking the link there also  dont see a config which says use a particular LB.But the article clearly says to use "ip load balace", no clue though where it is set.  hence my question what is the default LB used/set at switch side. http://now.netapp.com/NOW/knowledge/docs/ontap/rel727/html/ontap/nag/7vifs3.htm https://communities.netapp.com/community/netapp-blogs/sanbytes/blog/2011/12/13/what-value-does-the-leading-fc-switch-vendor-bring-to-ethernet-guest-post-by-brocade http://blog.ioshints.info/2011/04/brocade-vcs-fabric-has-almost-perfect.html may be a good reads i guess.

  • Ubr7200 (7246) and VLAN Trunks

    Has anyone successfully setup a VLAN subinterface on a ubr7200? All of the documents I have seen on TAC state I should use the encapsulation command but it is not available. I want to do something like:
    interface gig 2/0.500
    encapsulation dot1q 500
    ip address x.x.x.x y.y.y.y
    uBR7246VXR (NPE300) 13.3(17a)BC
    1 FastEthernet/IEEE 802.3 interface(s)
    1 Gigabit Ethernet/IEEE 802.3 interface(s)
    1 ATM network interface(s)
    1 Cable Modem network interface(s)

    I thought I had tried an IP+ feature this weekend out of desperation. I downloaded it but I guess I didn't copy it to flash. Is there a decent chart that shows the differences? I kind of got burned on something similiar when I ordered a 3750. I was assured the base install was sufficient for my needs. A few weeks later and before the 3750 came in (I had the delivery pushed for budget reasons), I was discussing adding some additional equipment, the VAR sales rep suddenly realized I needed the enterprise version. My CFO was not happy about the unexpected expenditure. At least this router isn't in my cost center and instead belongs to an engineering department.

  • SG-300 52p POE and the case of Native vlan forgotten on a Port-channel

    Hi
    We have recently changed our access switched to Cisco Small Business SG-300 52p on which is working firmware
    SW version    1.3.5.58
    We found out a very annoying problem on Port-channel and default vlan topic.
    Our switch have a default vlan diffrent to the vlan 1 that depends on the floor they are, and this native vlan is at first defined on the portchannel of our central switch, a Cisco 3750
    Example of a central switch port-channel with a define native vlan:
    interface Port-channel2
    description TO 1F
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 6
    switchport trunk allowed vlan 4-6,11,13
    switchport mode trunk
    on the SG300 side the configuration is this:
    interface Port-channel2
    description 1F
    switchport trunk allowed vlan add 4-5,11,13
    !next command is internal.
    macro auto smartport dynamic_type switch
    As you can see there is no "switchport trunk native vlan 6" simply because the SG300 once i write it on the command line, it accepts the command but the command sentence is not written on the conf (why?!)
    the result is that everytime the SG300 is restarted on the port-channel i got two AUTO CREATED commands on the configuration "
    switchport trunk native vlan 1
    switchport default-vlan tagged
    that let not work the network on that floor until i manually write on the SG300
    no switchport default-vlan tagged
    switchport trunk native vlan 6
    These command, as said, works once i write them but are not viewed on a "sh run" and so saved on the conf so every time SG 300 is restarted i need to re-write them.
    Is this a bug?
    have i made some mistake?
    Please let me know
    regards
    Pietro

    Figure out!
    the problem was on macro i have to write this:
    macro auto processing type switch disabled
    and then everything starts going as it should be
    Regards
    Pietro

  • Catalyst 3750G and WLC 440x - Port Channel - Configuration - Best Pactice

    What is the best practice to use when configuring port channel between Catalystr 3750G switch stack and WLC 4402 / 4404 Wireless Lan Controllers:
    a) Negotiate to LACP
    b) Negotiate to PAgP
    or
    c) Hard-code to Port Channel without any negotiation.
    Any pointers to any useful links - much appreciated and configuration example as well.

    Answer is 'C'... channel-mode on
    Configuring Neighbor Devices to Support LAG
    The controller's neighbor devices must also be properly configured to support LAG.
    •Each neighbor port to which the controller is connected should be configured as follows:
    interface GigabitEthernet
    switchport
    channel-group mode on
    no shutdown
    •The port channel on the neighbor switch should be configured as follows:
    interface port-channel
    switchport
    switchport trunk encapsulation dot1q
    switchport trunk native vlan
    switchport trunk allowed vlan
    switchport mode trunk
    no shutdown
    Here is a link that explains it. Hope this answers your question:
    http://www.cisco.com/en/US/docs/wireless/controller/4.2/configuration/guide/c42mint.html#wp1116136
    Here is a Best Practice doc:
    http://www.cisco.com/en/US/tech/tk722/tk809/technologies_tech_note09186a0080810880.shtml

  • MDS Code Level for UCS FC Port Channel/Trunking

    What is the required MDS code level needed to support FC Port-Channeling/Trunking on a 9222i, 9148, or 9509/9513 w/ Gen2 line cards to UCS 1.4(3)?
    I know the fport-channel-trunk feature is needed and was released in MDS 4.2 code but I have seen documents that this level of code wont support these features when used to connect to Cisco UCS. 
    Can someone confirm?  Is NXOS 5.0(4) or higher required?

    Doug,
    I wrote the doc almost a year ago and it doesn't have the latest interop matrix support information. The current MDS NX-OS support is located in this doc: http://www.cisco.com/en/US/docs/switches/datacenter/mds9000/interoperability/matrix/intmatrx.html
    While, I wish this was also duplicated in UCS docs, they are more or less taking the stance that 3rd party (Cisco MDS is this case) interop is maintained by the 3rd party. EMC, Netapp, or even Cisco.
    It would be a nightmare updating UCS docs with 3rd party qualifications and support.
    The short answer to your question is:
    UCS 1.4(1), 1.4(2), 1.4(3) Is supported by MDS9000: 3.3(4a), 3.3(5), 4.2(1a), 4.2(1b), 4.2(3a), 4.2(5), 5.0(1a), 5.0(4), 5.0(4c)
    NPV was introduced in MDS 3.3. f port-channel/trunk was introduced in MDS 4.2.
    As Ram mentioned above, 4.2(5) is what I would recommend if I wanted to implement f port-channel and/or f port-trunk. I have also had recent experience with 4.2(5) and it worked great with a large UCS f port-channel/trunk implementation
    The specific switch limitations I mentioned in my doc still exist. Only certain models of MDS will support f port-trunk. Almost all models will support f port-channel.
    Dave

  • Fabric Interconnect To MDS 9148 FC Port Channel/Trunks

    Is it possible to create both a Port Channel and Trunk on a Cisco MDS 9148? Yes correct?
    Or can I only trunk between the 2 MDS switches and not the MDS to Fabric Interconnect?
    These FC links would be connected to a 2248XP Fabric Interconnect carrying multiple VSANs from the MDS to the Fabric Interconnect.
    Thanks

    Hello,
    Yes, you can have trunk links grouped into port channel ( F port-channel trunking ) between FI and MDS.
    http://www.cisco.com/en/US/docs/unified_computing/ucs/sw/gui/config/guide/2.0/b_UCSM_GUI_Configuration_Guide_2_0_chapter_0101.html
    Padma

  • Configure port channel between IO Module and FI

                       Hi,
    I have the current setup
    UCS chassis (4 uplinks) --> FI --> (Port channel) --> N5K --> (port channel) --> VSS 6500
    I configure port channel between IO Module and the FI by changing to policy to "Port Channel" and set the link to 4
    FI has created a portchannel under "Internal" containing all the FI interfaces that are connected to the IO module.
    I have installed ESXI on a blade but i was unable to reach it, even the esx was unable to ping the gateway.
    VLAN tagging is enabled from the ESX server.
    I have issued the command "show mac address-table | inc <mac address of the vnic assigned from thre service profile> on both the N5K and thr 6500 and the mac is there.
    I have allowed all the vlans on the vNIC from the service profile.
    am I missing anything?
    thanks

    Hello,
    Can you please check whether your ESXi vmkernel interface ip address learned on right VLAN on FI / upstream switch or not.
    connect nxos
    show mac-address-table | inc 
    Padma

  • FC Port Channel & Trunking

    Hi, Cisco Experts:
    Can I have a definitive answer to the following?
    q1.
    EMC mentioned that they do not support FC Port Channel & Trunking with regard to our UCS Fabric Interconnects/MDS/VNX5300?
    Is that any truth in that?
    We are trying a Cisco UCS solutions with MDS and EMC VNX in the mix-SAN Boot basically, ESXi 5.1 and all others.
    q2.
    From MDS all the ways up to EMC VNX, is there such concept too-FC Port Channel & Trunking, assuming we are doing FC Port Channel & Trunking from FInterconnect to MDS?
    Please let me know.
    Appreciate it.
    SiM

    Hi Sim,
    We support FC port channel and trunking between UCS FI and MDS.
    Is EMC saying about the port channel between the MDS and VNX? Is there any document EMC pointed out?
    With respect to booting from SAN, yes, you can boot from SAN with MDS and EMC VNX as long as the OS is supported in the UCS system. You can refer to
    http://www.cisco.com/en/US/products/ps10477/prod_technical_reference_list.html for the supported OS versions.
    Hope this answers your question.
    -Ganesh

  • N7K Port Channel Layer 3 VLAN Question

    I have 2 N7K switches and would like to connect them via port channel and put the channel in VLAN 101. I have the following config, does it make sense? Thanks in advance!
    interface eth 3/1
    switchport
    channel-group 101 mode active
    interface eth 3/2
    switchport
    channel-group 101 mode active
    interface port-channel 101
    switchport
    switchport mode access
    switchport access vlan 10
    spanning-tree network type edge
    interface vlan 10
    ip address 10.1.1.1/24

    Could be something like this in the both sides (if the port numbers match):
    conf t
    feature lacp
    feature interface-vlan
    interface eth 3/1
    switchport
    channel-group 101 mode active
    interface eth 3/2
    switchport
    channel-group 101 mode active
    interface port-channel 101
    switchport
    switchport mode access
    switchport access vlan 101
    spanning-tree port type network
    interface vlan 101
    ip address 10.1.1.1/24
    no shut
    end
    vlan 101
    end
    *(This ip address will be available in only one box, you can use a FHRP as well, to increase the level of reachability)

  • F-port-channel-trunk disruptive or not?

    Hi,
    We have a N5K with NPIV configured and and MDS9148 we're gonna setup a port channel and have come to the conclusion that we need the F-port-channel-trunk feature enabled on the MDS side.
    Question: Is enabling the F-port-channel-trunk feature on the MDS disruptive or non-disruptive?
    --M

    It's too late; I would say it is disruptive; however, the disruption is so short, that you didn't notice it. Similar without non F-port trunking channeling: using a link: the lost sessions are simply redistributed over the remaining links; new flogi is necessary.

Maybe you are looking for