PPP problems

Hello everyone !
I use pppd to establish a connection to the internet.
I open a /dev/ptmx and /dev/ptsX pair. I start pppd with STDIN and STDOUT set to the /dev/ptsX device.
The /dev/ptmx device is connected to a software that emulates an AT-command modem using a special USB modem.
The problem is:
* LCP, CHAP/PAP and IPCP packets work correctly.
* Incoming TCP/IP packets are sent to the kernel
(kdebug option of pppd shows that the TCP/IP packets arrive at the kernel)
* PPP does NOT send any outgoing TCP/IP packet
Q: Why does PPP not send any outgoing TCP/IP packets ?
I even tried the "notty" option of pppd.
Any ideas ?
Thanks.
Martin

I found out that the first PPP connection (over the network device sppp0) works.
Following connections over sppp0 work, too while connections over sppp1 etc. do NOT work.
I think this is a routing problem; the "default route" is bound to sppp0 and cannot be changed to sppp1.
I'm not 100% sure and I do not know how to handle this.
Another problem is that a non-blocking read() from /dev/ptmx sometimes returns 0 instead of errno=EWOULDBLOCK. Unfortunately I use read()==0 as hang-up detection.
Any ideas ?
Thanks.
Martin.

Similar Messages

  • Solaris 10 ppp problems

    Hi!
    I've big problems connecting to my isp using pppd included in Solaris 10 x86. I have Ericsson HiS modem, IDSL technology, connected to /dev/cua0 max speed set to 115200 kbps, it doesn't require chat script. I'd like to notice that there are no problems connecting my ISP on Linux with the same options used. I think the problem is a buggy PAP authentication negotiation with peer (diffs between linux and solaris in pppd debug log). Is there problem with configuration or (buggy?) old 2.4.0b1 version of ppp?? Any suggestions appreciated.

    I need help especially from polish users, who experienced problems, or not, with HiS Ericsson iDSL modem (115,2 kbps) and Sun's ppp. Why can't I connect the same way as in for ex. FreeBSD or linux systems? Do I need a special configuration of serial port or modem? This is a fragment from typical pppd debug log:
    serial speed set to 115200bps
    Using interface sppp0
    Connect: sppp0 <--> /dev/cua0
    sent [LCP ConfReq id=0xe <asyncmap 0x0> <magic 0x7d40a344> <pcomp> <accomp>]
    rcvd [LCP ConfReq id=ox1 <mru 1656> <asyncmap 0x0> <auth pap> <magic 0x6a789b2f> <linkdisc 256>]
    LCP: rejecting unknown option 23 #this message repeats several times
    LCP: Rcvd Code-Reject for unknown code 192 id 33
    Authenticating to peer with PAP
    sent [PAP AuthReq id=0x1 user="user" password=<hidden>]
    rcvd  [PAP AuthAck id=0x1 " "]
    sent {IPCP ConfReq id=0x49 <addr 0.0.0.0> <compress VJ 0f 01>]
    sent [CCP ConfReq id=0x2b <deflate 15> <deflate (old#) 15> <bsd v1 15>]
    rcvd [proto=0xc02b] 01 08 00 0a 01 06 25 fe 28 0c
    Unsupported protocol 0xc02b received #this message appears several times
    ...

  • Autoselect ppp problems

    Hi,
    After upgrading old C2500 analog dial-in router with ext. modem pool and with IOS v.11.2.17 to new C3845 router with int. NM-8AM-V2 and IOS v. 12.4.10 i have folloing problems:
    1. ppp session does not starts automatically with
    'autoselect ppp' command in configuration
    2. ppp session starts only when both 'autoselect ppp' and 'autoselect during-login' are configured, but remote users need access both EXEC-mode and PPP-mode w/o 'autoselect during-login' command and Username prompt.
    Any ideas?
    Router C2500 with old v.11.2.17 IOS configuration:
    modemcap entry zyxel:FD=&f*m1s0=1s7=120s10=250:SPD=s20=3:DTE=19200
    interface Group-Async1
    ip unnumbered Ethernet0
    ip access-group 105 out
    encapsulation ppp
    async default routing
    async mode interactive
    ntp disable
    peer default ip address pool ppp_DialIn
    no cdp enable
    ppp authentication chap
    group-range 1 8
    line 1 8
    session-timeout 10
    no exec-banner
    autoselect ppp
    login authentication via_tacacs
    modem InOut
    modem autoconfigure type zyxel
    terminal-type download
    no editing
    transport input all
    escape-character NONE
    telnet transparent
    stopbits 1
    rxspeed 19200
    txspeed 19200
    flowcontrol hardware

    Removing "autoselect during-login" and adding "autoselect timeout 5". Doing this will allow AAA authentication not to be taken immediately after the connection is made.

  • Multilink PPP problem

    Hi Guys,
    i got a situation here and hope someone will be able to help me out. Recently i configured a PPP multilink and am facing some issues after that.
    Issue 1:
    There seems to be lot of input error on multilink interface (150 errors in 40 mins)
    Issue 2:
    when any of the multilink member interface goes down (all other links are active), am getting packrt drops and request timed out when i ping my other end multi link interface atleast for some 30 sec , after which my response is ok.
    About my network
    I have connectivity between site A and Site B which consists of five 64 kbps Leased lines bundled together with Multilink PPP
    My configuration is shown below
    End A
    interface multilink 1
    ip address x.x.x.x x.x.x.x
    ppp multilink fragment-delay 20
    ppp multilink interleave
    ppp multilink
    multilink-group 1
    int Ser 2/0
    bandwidth 64
    no ip address
    no ip redirects
    no ip proxy-arp
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    no fair-queue
    ppp multilink
    multilink-group 1
    int Ser 2/1
    bandwidth 64
    no ip address
    no ip redirects
    no ip proxy-arp
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    no fair-queue
    ppp multilink
    multilink-group 1
    int Ser 2/2
    bandwidth 64
    no ip address
    no ip redirects
    no ip proxy-arp
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    no fair-queue
    ppp multilink
    multilink-group 1
    int Ser 2/3
    bandwidth 64
    no ip address
    no ip redirects
    no ip proxy-arp
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    no fair-queue
    ppp multilink
    multilink-group 1
    int Ser 2/4
    bandwidth 64
    no ip address
    no ip redirects
    no ip proxy-arp
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    no fair-queue
    ppp multilink
    multilink-group 1
    End B
    interface multilink 1
    ip address ip address x.x.x.x x.x.x.x
    ppp multilink fragment-delay 20
    ppp multilink interleave
    ppp multilink
    multilink-group 1
    interface S 2/0:1
    bandwidth 64
    no ip address
    no ip redirects
    no ip proxy-arp
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    no fair-queue
    ppp multilink
    multilink-group 1
    interface S 2/0:11
    bandwidth 64
    no ip address
    no ip redirects
    no ip proxy-arp
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    no fair-queue
    ppp multilink
    multilink-group 1
    interface S 2/0:25
    bandwidth 64
    no ip address
    no ip redirects
    no ip proxy-arp
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    no fair-queue
    ppp multilink
    multilink-group 1
    interface S 2/0:4
    bandwidth 64
    no ip address
    no ip redirects
    no ip proxy-arp
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    no fair-queue
    ppp multilink
    multilink-group 1
    interface S 2/0:6
    bandwidth 64
    no ip address
    no ip redirects
    no ip proxy-arp
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    no fair-queue
    ppp multilink
    multilink-group 1

    pls find the output of show command
    END A #sh int multilink 5
    Multilink5 is up, line protocol is up
    Hardware is multilink group interface
    Description: ***Multilink to End B ***
    Internet address is 192.26.0.162/30
    MTU 1500 bytes, BW 320 Kbit, DLY 100000 usec,
    reliability 255/255, txload 2/255, rxload 1/255
    Encapsulation PPP, loopback not set
    Keepalive set (10 sec)
    DTR is pulsed for 2 seconds on reset
    LCP Open, multilink Open
    Open: IPCP, CDPCP
    Last input 00:00:00, output never, output hang never
    Last clearing of "show interface" counters 19:55:13
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: fifo
    Output queue: 0/40 (size/max)
    5 minute input rate 2000 bits/sec, 4 packets/sec
    5 minute output rate 3000 bits/sec, 4 packets/sec
    309478 packets input, 58763590 bytes, 0 no buffer
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    1492 input errors, 0 CRC, 1492 frame, 0 overrun, 0 ignored, 0 abort
    290606 packets output, 32728691 bytes, 0 underruns
    0 output errors, 0 collisions, 0 interface resets
    0 output buffer failures, 0 output buffers swapped out
    0 carrier transitions
    END A #sh ppp multilink
    Multilink5, bundle name is End B
    Bundle up for 22:06:31
    493 lost fragments, 162050 reordered, 0 unassigned
    999 discarded, 0 lost received, 3/255 load
    0xAE5E6 received sequence, 0x69F6B sent sequence
    Member links: 5 active, 0 inactive (max not set, min not set)
    Se2/0, since 20:07:34, last rcvd seq 0AE5E1, 160 weight, 152 frag size
    Se2/2, since 20:04:45, last rcvd seq 0AE5E2, 160 weight, 152 frag size
    Se2/3, since 20:04:07, last rcvd seq 0AE5E3, 160 weight, 152 frag size
    Se2/5, since 20:03:24, last rcvd seq 0AE5E4, 160 weight, 152 frag size
    Se2/1, since 19:57:12, last rcvd seq 0AE5E5, 160 weight, 152 frag size
    Am getting 1400 input errors in last 19 hours on multilink interface, also less than 100 input errors on member serial interfacs.Also am not loosing any link member.

  • Can't connect to Internet since 12/20/09??​?? PPP problem

    I haven't been able to connect to internet here in Plymouth, MA since 12/19? Called numerous time to support and they say it is outage problems in area. My DSL light is steady on modem but when trying to connect the Internet light goes steady red!  Anyone else having this problem in South East MA area? Does it normally take over a week to correct?

    Outages almost never last a week. Verizon can't afford to leave customers without service for that long. I would suggest contacting Tech Support again. If the agent tells you that it's just an outage, ask to speak to their supervisor.
    If a forum member gives an answer you like, give them the Kudos they deserve. If a member gives you the answer to your question, mark the answer as Accepted Solution so others can see the solution to the problem.
    "All knowledge is worth having."

  • PPP Mulilink problem

    Need Help!
    Got problem with ppp multilink. Set up it, but the interface show down, like that in both side:
    Serial4:0                  unassigned      YES manual down                  down
    Serial5:0                  unassigned      YES manual down                  down
    check lthe phisical line, phisical line is ok.
    here are configs of both sides
    R1:
    controller E1 0/0/0
     framing NO-CRC4
     clock source internal
     channel-group 0 timeslots 1-31
    controller E1 0/0/1
     framing NO-CRC4
     clock source internal
     channel-group 0 timeslots 1-31
    interface Multilink3
     ip address 192.10.10.1 255.255.255.252
     ppp multilink
     ppp multilink interleave
     ppp multilink group 3
    interface Serial0/0/0:0
     no ip address
      encapsulation ppp
     ppp multilink
     ppp multilink group 3
    interface Serial0/0/1:0
     no ip address
     encapsulation ppp
     ppp multilink
     ppp multilink group 3
    R2:
    controller E1 4
     framing NO-CRC4
     clock source line secondary 4
     channel-group 0 timeslots 1-31
    controller E1 5
     framing NO-CRC4
     clock source line secondary 5
     channel-group 0 timeslots 1-31
    interface Multilink3
     ip address 172.28.235.37 255.255.255.252
     shutdown
     ppp multilink
     ppp multilink interleave
     ppp multilink group 3
    interface Serial4:0
     no ip address
     encapsulation ppp
     ppp multilink
     ppp multilink group 3
    interface Serial5:0
     no ip address
     encapsulation ppp
     ppp multilink
     ppp multilink group 3
    What to do?

    I would assume the multilink interface on R2 been shut down is the issue
    interface Multilink3
     ip address 172.28.235.37 255.255.255.252
     shutdown <------------------- do a no shut on this interface
     ppp multilink
     ppp multilink interleave
     ppp multilink group 3

  • Ppp multilink problem

    Hi
    I am having a problem configuring ip rtp with interleaving on two 1721's prioritizing voice traffic between two ip voice devices over a 128k point to point link. This is my config...
    interface Multilink1
    ip address 192.168.24.2 255.255.255.0
    no cdp enable
    ppp multilink
    ppp multilink fragment delay 20
    ppp multilink interleave
    ppp multilink group 1
    ip rtp header-compression iphc-format
    ip tcp header-compression iphc-format
    ip rtp priority 8100 100 40
    interface Serial0
    bandwidth 128
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    encapsulation ppp
    ppp multilink
    no cdp enable
    Everytime I add the 'ppp multilink' to the serial, I get the virtual-access interface bouncing up and down with no traffic flowing.
    any ideas?

    Cannnnnnnnt see much wrong, try adding "ppp multilink group 1" to int S0 config.

  • Nov 19 11:12:17 EET: ppp8272 PPP: Sent PAP LOGIN Request PPPOE problem

    a session stays in LCP and the debug is :
    Nov 19 11:43:20 EET: PPPoE 0: I PADI R:0015.0c44.e6c4 L:ffff.ffff.ffff 1470 Gi1/1/0.1470
    Nov 19 11:43:20 EET: Service tag: NULL Tag
    Nov 19 11:43:20 EET: PPPoE 0: O PADO, R:001b.53c3.1d24 L:0015.0c44.e6c4 1470 Gi1/1/0.1470
    Nov 19 11:43:20 EET: Service tag: NULL Tag
    Nov 19 11:43:20 EET: PPPoE 0: I PADR R:0015.0c44.e6c4 L:001b.53c3.1d24 1470 Gi1/1/0.1470
    Nov 19 11:43:20 EET: Service tag: NULL Tag
    Nov 19 11:43:20 EET: PPPoE : encap string prepared
    Nov 19 11:43:20 EET: [12789]PPPoE 59193: Access IE handle allocated
    Nov 19 11:43:20 EET: [12789]PPPoE 59193: AAA get retrieved attrs
    Nov 19 11:43:20 EET: [12789]PPPoE 59193: AAA get nas port details
    Nov 19 11:43:20 EET: [12789]PPPoE 59193: AAA get dynamic attrs
    Nov 19 11:43:20 EET: [12789]PPPoE 59193: AAA get dynamic attrs
    Nov 19 11:43:20 EET: [12789]PPPoE 59193: AAA unique ID allocated
    Nov 19 11:43:20 EET: [12789]PPPoE 59193: AAA method list set
    Nov 19 11:43:20 EET: [12789]PPPoE 59193: Service request sent to SSS
    Nov 19 11:43:20 EET: [12789]PPPoE 59193: Created, Service: None R:001b.53c3.1d24 L:0015.0c44.e6c4 1470 Gi1/1/0.1470
    Nov 19 11:43:20 EET: [12789]PPPoE 59193: State NAS_PORT_POLICY_INQUIRY Event SSS MORE KEYS
    Nov 19 11:43:20 EET: [12789]PPPoE 59193: data path set to PPP
    Nov 19 11:43:20 EET: [12789]PPPoE 59193: Segement (SSS class): PROVISION
    Nov 19 11:43:20 EET: [12789]PPPoE 59193: State PROVISION_PPP Event SSM PROVISIONED
    Nov 19 11:43:20 EET: [12789]PPPoE 59193: O PADS R:0015.0c44.e6c4 L:001b.53c3.1d24 Gi1/1/0.1470
    Nov 19 11:43:21 EET: PPPoE 0: I PADR R:0015.0c44.e6c4 L:001b.53c3.1d24 1470 Gi1/1/0.1470
    Nov 19 11:43:21 EET: Service tag: NULL Tag
    Nov 19 11:43:21 EET: [12789]PPPoE 59193: O PADS R:0015.0c44.e6c4 L:001b.53c3.1d24 1470 Gi1/1/0.1470
    Nov 19 11:43:22 EET: PPPoE 0: I PADR R:0015.0c44.e6c4 L:001b.53c3.1d24 1470 Gi1/1/0.1470
    Nov 19 11:43:22 EET: Service tag: NULL Tag
    Nov 19 11:43:22 EET: [12789]PPPoE 59193: O PADS R:0015.0c44.e6c4 L:001b.53c3.1d24 1470 Gi1/1/0.1470
    Nov 19 11:43:25 EET: [1564]PPPoE 59133: AAA get dynamic attrs
    Nov 19 11:43:25 EET: [1564]PPPoE 59133: AAA get dynamic attrs
    Nov 19 11:43:25 EET: PPPoE 59133: I PADT R:0015.0c7f.3617 L:001b.53c3.1d24 1470 Gi1/1/0.1470
    Nov 19 11:43:25 EET: [1564]PPPoE 59133: Destroying R:0015.0c7f.3617 L:001b.53c3.1d24 1470 Gi1/1/0.1470
    Nov 19 11:43:25 EET: PPPoE: Returning Vaccess Virtual-Access1.5542
    Nov 19 11:43:25 EET: [1564]PPPoE 59133: AAA get dynamic attrs
    Nov 19 11:43:25 EET: [1564]PPPoE 59133: AAA get dynamic attrs
    Nov 19 11:43:25 EET: [1564]PPPoE 59133: AAA account stopped
    Nov 19 11:43:25 EET: [1564]PPPoE 59133: Segement (SSS class): UNPROVISION
    Nov 19 11:43:26 EET: PPPoE 59133: I PADT R:0015.0c7f.3617 L:001b.53c3.1d24 1470 Gi1/1/0.1470
    Nov 19 11:43:29 EET: [12789]PPPoE 59193: AAA get dynamic attrs
    Nov 19 11:43:29 EET: [12789]PPPoE 59193: AAA get dynamic attrs
    Nov 19 11:43:29 EET: [12789]PPPoE 59193: AAA get dynamic attrs
    Nov 19 11:43:29 EET: [12789]PPPoE 59193: AAA get dynamic attrs
    Nov 19 11:43:29 EET: [12789]PPPoE 59193: O PADT R:0015.0c44.e6c4 L:001b.53c3.1d24 Gi1/1/0.1470
    Nov 19 11:43:29 EET: [12789]PPPoE 59193: Destroying R:0015.0c44.e6c4 L:001b.53c3.1d24 1470 Gi1/1/0.1470
    Nov 19 11:43:29 EET: [12789]PPPoE 59193: AAA get dynamic attrs
    Nov 19 11:43:29 EET: [12789]PPPoE 59193: AAA get dynamic attrs
    Nov 19 11:43:29 EET: [12789]PPPoE 59193: AAA get dynamic attrs
    Nov 19 11:43:29 EET: [12789]PPPoE 59193: AAA get dynamic attrs
    Nov 19 11:43:29 EET: [12789]PPPoE 59193: AAA account stopped
    Nov 19 11:43:29 EET: [12789]PPPoE 59193: Segement (SSS class): UNPROVISION
    Nov 19 11:43:29 EET: PPPoE 59193: I PADT R:0015.0c44.e6c4 L:001b.53c3.1d24 1470 Gi1/1/0.1470
    sh pppoe session | in e6c4
    9040 61583 0015.0c44.e6c4 Gi1/1/0.1470 1 N/A LCP
    Does anyone understands why the session stays to LCP and it is terminated?

    I have already tried a debug ppp negotiation and a debug radius authentication, but i do not seem to get the user's username....And after all the ppp stops in LCP. I run a certain pppoe debug and i watched the user changing from PADI to PADO all the time. Is there a chance to have a problem in the dlsam?

  • RV220W - VPN PPP & RDP problem

    Hello!
    This is my first post here, so welcome!
    I have purchased RV220W router and implemented into the existing netowork. Everything seems to work fine except logging into rdp desktops of wxp's on the local network in the office.
    I'm not using router's VPN capabilities. I have made a connection through one of the WXP's VPN locally in the office. I login with password as PPP connection. Everything works fine, but I can only connect through RDP to the machine that is making the connection by "VPN IP". I cannot login to any IP that is local in the office. I can not ping either.
    We are using also Macs and the same problem is when connecting with ScreenSharing and pinging.
    It is definitely something to be set on the router.
    If you have any idea, I would apprecite your help!

    Hi again!
    After reading similar post I found a "solution".
    I have manually put actual RV220W IP as router ip (except of the ip of the XP that is making the vpn connection) on the computer I'm connected to VPN and now it's working fine.
    Anyway, thanks for approving this thread.
    Cheers,
    Adam

  • Ppp radius problem

    Hi guys my problem is about Radius.It can not assign ip to remote host.This host request ppp and it terminated by on our Cisco router(LAC-LNS).And Cisco router uses AAA for authentication and ip assignment.Authentication part is okey.The host can connect radius and passes username password phase.But when the ppp protocol pass next ipcp level, host request;confreq is above,
    Primary DNS server IP address: 0.0.0.0
    Secondary DNS server IP address: 0.0.0.0
    Primary WINS server IP address: 0.0.0.0
    Secondary WINS server IP address: 0.0.0.0
    IP address: 0.0.0.0
    But the Router returns reject;confrej
    Primary DNS server IP address: 0.0.0.0
    Secondary DNS server IP address: 0.0.0.0
    Primary WINS server IP address: 0.0.0.0
    Secondary WINS server IP address: 0.0.0.0
    IP address: 0.0.0.0
    After this negotiation ppp ipcp part is terminated and the host never get ip address.
    My question, Although the ppp authentication seems okey, why the remote host does not get ip address.Shoul I focus radius config. or Router config. ?
    Thanks.

    Hi Marco,
    interface Virtual-Template1
    ip unnumbered GigabitEthernet0/0.12
    no ip mroute-cache
    no peer default ip address
    ppp authentication pap
    ppp ipcp predictive
    I will paste here also debug files.
    Best regards

  • I have asr 1000 with asr1000rp2-adventerprisek have problem when I gave PPP Multilink to the interface Dialer

    Hello,
    please Urgent Help
    I have ASR 1000 with asr1000rp2-adventerprisek  Version, when I give PPP Multilink to the dialer interface it show following error :
    FMFP-3-OBJ_DWNLD_TO_CPP_FAILED: F0: fman_fp_image:
    MLP bundle , link download to CPP failed
    please urgent help

    this error comes with the command PPP multilink, it is a lot of letters and numbers and then this last line comes this message 
    FMFP-3-OBJ_DWNLD_TO_CPP_FAILED: F0: fman_fp_image:
    MLP bundle 181, link 178 download to CPP failed
    the configuration still not installed but I configured just the following lines
    interface Virtual-Template
    ip unnumbered Loopback2
    ip mtu 1440
    ip load-sharing per-packet
    ip tcp adjust-mss 1400
    no logging event link-status
    peer default ip address pool
    ipv6 unnumbered Loopback2
    ipv6 enable
    no ipv6 nd suppress-ra
    ppp authentication pap chap callin
    ppp multilink
    ppp multilink fragment delay 100
    ppp multilink mrru local 1546
    that were the lines used to configure this Dialer, the image must be asr1000rp2-adventerprisek and not Ipbase but I dont tried to use IPbase.
    what do think ?

  • Problems setting up PPP using GSM modem

    I am trying to setup a PC with Solaris 10 installed to use a 3G USB modem to connect to the internet.
    bash-3.00# cat /etc/release
    Solaris 10 10/09 s10x_u8wos_08a X86
    bash-3.00# uname -a
    SunOS gateway 5.10 Generic_141445-09 i86pc i386 i86pc
    I have the modem working in so far as I can tip to it and get a response back:-
    bash-3.00# tip -460800 /dev/cua/0
    connected
    at
    OK
    ati
    Manufacturer: huawei
    Model: E17X
    Revision: 11.311.05.02.67
    IMEI: 358108024400748
    GCAP: CGSM,+FCLASS,+DS
    OK
    ~
    [EOT]
    when I run the following command: pppd debug call mtn
    I get the following in the pppd log:-
    Aug 7 19:44:00 gateway pppd[463]: [ID 860527 daemon.notice] pppd 2.4.0b1 (Sun Microsystems, Inc.) started by root, uid 0
    Aug 7 19:44:00 gateway pppd[463]: [ID 702911 daemon.debug] serial speed set to 460800 bps
    Aug 7 19:44:01 gateway pppd[463]: [ID 702911 daemon.debug] connect option: '/usr/bin/chat -Vv -f /etc/ppp/mtn-connect' started (pid 464)
    Aug 7 19:44:02 gateway chat[465]: [ID 702911 local2.info] timeout set to 5 seconds
    Aug 7 19:44:02 gateway chat[465]: [ID 702911 local2.info] abort on (\nBUSY\r)
    Aug 7 19:44:02 gateway chat[465]: [ID 702911 local2.info] abort on (\nERROR\r)
    Aug 7 19:44:02 gateway chat[465]: [ID 702911 local2.info] abort on (\nNO ANSWER\r)
    Aug 7 19:44:02 gateway chat[465]: [ID 702911 local2.info] abort on (\nNO CARRIER\r)
    Aug 7 19:44:02 gateway chat[465]: [ID 702911 local2.info] abort on (\nNO DIALTONE\r)
    Aug 7 19:44:02 gateway chat[465]: [ID 702911 local2.info] abort on (\nRINGING\r\n\r\nRINGING\r)
    Aug 7 19:44:02 gateway chat[465]: [ID 702911 local2.info] report (CONNECT)
    Aug 7 19:44:02 gateway chat[465]: [ID 702911 local2.info] expect (OK)
    Aug 7 19:44:07 gateway chat[465]: [ID 702911 local2.info] alarm
    Aug 7 19:44:07 gateway chat[465]: [ID 702911 local2.info] Failed
    Aug 7 19:44:07 gateway pppd[463]: [ID 702911 daemon.error] Connect script failed
    Aug 7 19:44:08 gateway pppd[463]: [ID 834084 daemon.info] Exit.
    the peer file is as follows:-
    bash-3.00# more /etc/ppp/peers/mtn
    # MTN PPP initialisation/termination script
    # Do not ask the remote to authenticate.
    noauth
    # Modem chat scripts
    connect "/usr/bin/chat -Vv -f /etc/ppp/mtn-connect"
    disconnect "/usr/bin/chat -Vv -f /etc/ppp/mtn-disconnect"
    # Serial device to which the modem is connected.
    /dev/cua/0
    # Speed of the serial line.
    460800
    # Use this connection as the default route.
    defaultroute
    # ISP supplies us with a local IP address during IPCP negotiation
    noipdefault
    # Try to get the name server addresses from the ISP.
    usepeerdns
    # Username for authentication
    user "username"
    # Password for authentication
    password "password"
    # Always try to reconnect, when connection fails or is lost
    # persist
    # Never give up after failed connect attempts
    # maxfail 0
    # Debugging
    debug
    and the connect script is as follows:-
    # MTN PPP CONNECT script
    TIMEOUT 5
    ECHO ON
    ABORT '\nBUSY\r'
    ABORT '\nERROR\r'
    ABORT '\nNO ANSWER\r'
    ABORT '\nNO CARRIER\r'
    ABORT '\nNO DIALTONE\r'
    ABORT '\nRINGING\r\n\r\nRINGING\r'
    REPORT CONNECT
    OK 'ATZ'
    OK 'AT+cgdcont=1,"IP","apn1.mtn.net"'
    OK 'AT+cgdcont=2,"IP","apn2.mtn.net"'
    OK 'ATD*99***1#'
    I am sure I have missed something really obvious but I can't see where.

    Don't use the setup CD.  Connect manually via wired computer to 192.168.1.1 username blank, password 'admin'.  Now configure the router manually like everyone else.

  • Strange problem with ppp

    installed the base system + kde + xfce + rp-pppoe, but now, if use the kde a strange error happend:
    Nov 9 23:32:03 Geo-Front kernel: unregister_netdevice: waiting for ppp0 to become free. Usage count = 1
    the log is big if yours want, a paste, but now, that message show, and kde don`t work, inly can "killall kdm", then "adsl-stop", and "kdm", and, if try login to kde with internet coneccion running, don`t start, only can login in xfce, and y try run a kprogram, dont work too 

    the full log:
    http://www.foro.powers.cl/viewtopic.php … 46#1247046

  • Problem with ASA 5505

    Good morning,
    I'm having the following problem. I configured a ASA 5505 with VPN and a VPN Remote Access Site-to-site. Everything is working, but when I reload the ASA does not work anymore VPNs, Remote Access error 412 and the Site-to-site does not connect more to solve, I have to reset and reconfigure the ASA. This is happening dopo updating the ASA, I have version 842-k8 and asdm645-106.
    Does anyone have any idea what can be?
    Thank you.
    Running-config:
    : Saved
    : Written by master at 10:34:14.839 BRDT Mon Oct 10 2011
    ASA Version 8.4(2)
    hostname ciscoasa
    domain-name default.domain.invalid
    enable password 2KFQnbNIdI.2KYOU encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
    nameif inside
    security-level 0
    ip address 172.16.0.140 255.255.252.0
    interface Vlan2
    nameif outside
    security-level 0
    pppoe client vpdn group gvt
    ip address pppoe setroute
    boot system disk0:/asa842-k8.bin
    ftp mode passive
    clock timezone BRST -3
    clock summer-time BRDT recurring 2 Sun Oct 0:00 3 Sun Feb 0:00
    dns server-group DefaultDNS
    domain-name default.domain.invalid
    same-security-traffic permit inter-interface
    same-security-traffic permit intra-interface
    object network NETWORK_OBJ_172.16.0.0_22
    subnet 172.16.0.0 255.255.252.0
    object network NETWORK_OBJ_172.16.0.128_26
    subnet 172.16.0.128 255.255.255.192
    object network NETWORK_OBJ_20.0.0.0_24
    subnet 20.0.0.0 255.255.255.0
    object network NETWORK_OBJ_172.16.11.0_24
    subnet 172.16.11.0 255.255.255.0
    object-group network obj_any
    access-list 1 standard permit 172.16.0.0 255.255.252.0
    access-list 1 standard permit 20.0.0.0 255.255.255.0
    access-list outside_cryptomap extended permit ip 172.16.0.0 255.255.252.0 20.0.0.0 255.255.255.0
    access-list outside_cryptomap_1 extended permit ip 172.16.0.0 255.255.252.0 172.16.11.0 255.255.255.0
    pager lines 24
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    ip local pool pool 172.16.0.150-172.16.0.160 mask 255.255.252.0
    no failover
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-645-106.bin
    no asdm history enable
    arp timeout 14400
    nat (inside,outside) source static NETWORK_OBJ_172.16.0.0_22 NETWORK_OBJ_172.16.0.0_22 destination static NETWORK_OBJ_172.16.0.128_26 NETWORK_OBJ_172.16.0.128_26 no-proxy-arp route-lookup
    nat (inside,outside) source static NETWORK_OBJ_172.16.0.0_22 NETWORK_OBJ_172.16.0.0_22 destination static NETWORK_OBJ_20.0.0.0_24 NETWORK_OBJ_20.0.0.0_24 no-proxy-arp route-lookup
    nat (inside,outside) source static NETWORK_OBJ_172.16.0.0_22 NETWORK_OBJ_172.16.0.0_22 destination static NETWORK_OBJ_172.16.11.0_24 NETWORK_OBJ_172.16.11.0_24 no-proxy-arp route-lookup
    nat (inside,outside) after-auto source dynamic any interface
    route outside 172.16.11.0 255.255.255.0 187.16.33.131 10
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    user-identity default-domain LOCAL
    http server enable
    http 172.16.0.0 255.255.252.0 inside
    no snmp-server location
    no snmp-server contact
    crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec ikev2 ipsec-proposal DES
    protocol esp encryption des
    protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal 3DES
    protocol esp encryption 3des
    protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal AES
    protocol esp encryption aes
    protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal AES192
    protocol esp encryption aes-192
    protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal AES256
    protocol esp encryption aes-256
    protocol esp integrity sha-1 md5
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
    crypto map outside_map 1 match address outside_cryptomap
    crypto map outside_map 1 set peer 189.11.56.237
    crypto map outside_map 1 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
    crypto map outside_map 1 set ikev2 ipsec-proposal AES256 AES192 AES 3DES DES
    crypto map outside_map 2 match address outside_cryptomap_1
    crypto map outside_map 2 set peer 187.16.33.131
    crypto map outside_map 2 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
    crypto map outside_map 2 set ikev2 ipsec-proposal DES 3DES AES AES192 AES256
    crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map outside_map interface outside
    crypto ikev2 policy 1
    encryption aes-256
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 10
    encryption aes-192
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 20
    encryption aes
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 30
    encryption 3des
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 40
    encryption des
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 enable outside
    crypto ikev1 enable outside
    crypto ikev1 ipsec-over-tcp port 10000
    crypto ikev1 policy 10
    authentication crack
    encryption aes-256
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 20
    authentication rsa-sig
    encryption aes-256
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 30
    authentication pre-share
    encryption aes-256
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 40
    authentication crack
    encryption aes-192
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 50
    authentication rsa-sig
    encryption aes-192
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 60
    authentication pre-share
    encryption aes-192
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 70
    authentication crack
    encryption aes
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 80
    authentication rsa-sig
    encryption aes
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 90
    authentication pre-share
    encryption aes
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 100
    authentication crack
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 110
    authentication rsa-sig
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 120
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 130
    authentication crack
    encryption des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 140
    authentication rsa-sig
    encryption des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 150
    authentication pre-share
    encryption des
    hash sha
    group 2
    lifetime 86400
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    vpdn group gvt request dialout pppoe
    vpdn group gvt localname *******@turbonetpro
    vpdn group gvt ppp authentication pap
    vpdn username *******@turbonetpro password *****
    dhcpd auto_config outside
    dhcpd address 172.16.0.144-172.16.1.143 inside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    group-policy crv internal
    group-policy crv attributes
    dns-server value 172.16.0.253 8.8.8.8
    vpn-tunnel-protocol ikev1
    split-tunnel-policy tunnelspecified
    split-tunnel-network-list value 1
    default-domain value crvnatural.com.br
    group-policy GroupPolicy_189.11.56.237 internal
    group-policy GroupPolicy_189.11.56.237 attributes
    vpn-filter value 1
    vpn-tunnel-protocol ikev1 ikev2
    group-policy GroupPolicy_187.16.33.131 internal
    group-policy GroupPolicy_187.16.33.131 attributes
    vpn-filter value 1
    vpn-tunnel-protocol ikev1 ikev2
    username master password kWH7f2vqtjMEg2Yp encrypted
    tunnel-group crv type remote-access
    tunnel-group crv general-attributes
    default-group-policy crv
    dhcp-server 172.16.0.253
    tunnel-group crv ipsec-attributes
    ikev1 pre-shared-key *****
    tunnel-group 189.11.**.*** type ipsec-l2l
    tunnel-group 189.11.**.*** general-attributes
    default-group-policy GroupPolicy_189.11.**.***
    tunnel-group 189.11.**.*** ipsec-attributes
    ikev1 pre-shared-key *****
    ikev2 remote-authentication pre-shared-key ****
    ikev2 local-authentication pre-shared-key *****
    tunnel-group 187.16.33.*** type ipsec-l2l
    tunnel-group 187.16.33.*** general-attributes
    default-group-policy GroupPolicy_187.16.33.***
    tunnel-group 187.16.33.*** ipsec-attributes
    ikev1 pre-shared-key ******
    ikev2 remote-authentication pre-shared-key *****
    ikev2 local-authentication pre-shared-key *****
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny 
      inspect sunrpc
      inspect xdmcp
      inspect sip 
      inspect netbios
      inspect tftp
      inspect ip-options
    service-policy global_policy global
    prompt hostname context
    call-home
    profile CiscoTAC-1
      no active
      destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
      destination address email [email protected]
      destination transport-method http
      subscribe-to-alert-group diagnostic
      subscribe-to-alert-group environment
      subscribe-to-alert-group inventory periodic monthly
      subscribe-to-alert-group configuration periodic monthly
      subscribe-to-alert-group telemetry periodic daily
    Cryptochecksum:50ed6f55182534a2429d065a26e9b45c
    : end

    David,
    In order to understand why LDAP is not working run a "debug ldap 255" and then try to login or run a AAA test.
    Attach the output to find out the issue.
    Please check this out as well, to make sure that you have the correct settings:
    ASA 8.0: Configure LDAP Authentication for WebVPN Users
    HTH.
    Portu.

  • Long boot due to ata recognition problems [SOLVED]

    As the message says my boot is taking about 10 minutes, of which 95% of the time is spent trying to recognize ata4 device.
    I'm using the x86_64 version of arch, which works just fine on my laptop, and on my desktop - when it boots that is.
    Another thing that puzzles me is how am I getting those errors, considering I don't really have 4 ata drives, yet only two - hard disk and dvd rom.
    Anyway, this is my dmesg output :
    Linux version 2.6.24-ARCH (root@artin) (gcc version 4.3.0 (GCC) ) #1 SMP PREEMPT Sun Mar 30 10:50:22 CEST 2008
    Command line: root=/dev/sda1 ro vga=791
    BIOS-provided physical RAM map:
    BIOS-e820: 0000000000000000 - 000000000009f000 (usable)
    BIOS-e820: 000000000009f000 - 00000000000a0000 (reserved)
    BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
    BIOS-e820: 0000000000100000 - 000000007fee0000 (usable)
    BIOS-e820: 000000007fee0000 - 000000007fee3000 (ACPI NVS)
    BIOS-e820: 000000007fee3000 - 000000007fef0000 (ACPI data)
    BIOS-e820: 000000007fef0000 - 000000007ff00000 (reserved)
    BIOS-e820: 00000000e0000000 - 00000000f0000000 (reserved)
    BIOS-e820: 00000000fec00000 - 0000000100000000 (reserved)
    Entering add_active_range(0, 0, 159) 0 entries of 256 used
    Entering add_active_range(0, 256, 524000) 1 entries of 256 used
    end_pfn_map = 1048576
    DMI 2.4 present.
    ACPI: RSDP 000F9210, 0014 (r0 IntelR)
    ACPI: RSDT 7FEE3040, 003C (r1 IntelR AWRDACPI 42302E31 AWRD 0)
    ACPI: FACP 7FEE30C0, 0074 (r1 IntelR AWRDACPI 42302E31 AWRD 0)
    ACPI: DSDT 7FEE3180, 4BB6 (r1 INTELR AWRDACPI 1000 MSFT 100000E)
    ACPI: FACS 7FEE0000, 0040
    ACPI: HPET 7FEE7E80, 0038 (r1 IntelR AWRDACPI 42302E31 AWRD 98)
    ACPI: MCFG 7FEE7F00, 003C (r1 IntelR AWRDACPI 42302E31 AWRD 0)
    ACPI: APIC 7FEE7D80, 0084 (r1 IntelR AWRDACPI 42302E31 AWRD 0)
    ACPI: SSDT 7FEE7F80, 015C (r1 PmRef Cpu0Ist 3000 INTL 20060912)
    ACPI: SSDT 7FEE8410, 02F1 (r1 PmRef CpuPm 3000 INTL 20040311)
    Entering add_active_range(0, 0, 159) 0 entries of 256 used
    Entering add_active_range(0, 256, 524000) 1 entries of 256 used
    Zone PFN ranges:
    DMA 0 -> 4096
    DMA32 4096 -> 1048576
    Normal 1048576 -> 1048576
    Movable zone start PFN for each node
    early_node_map[2] active PFN ranges
    0: 0 -> 159
    0: 256 -> 524000
    On node 0 totalpages: 523903
    DMA zone: 56 pages used for memmap
    DMA zone: 1354 pages reserved
    DMA zone: 2589 pages, LIFO batch:0
    DMA32 zone: 7108 pages used for memmap
    DMA32 zone: 512796 pages, LIFO batch:31
    Normal zone: 0 pages used for memmap
    Movable zone: 0 pages used for memmap
    ACPI: PM-Timer IO Port: 0x408
    ACPI: Local APIC address 0xfee00000
    ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
    Processor #0 (Bootup-CPU)
    ACPI: LAPIC (acpi_id[0x01] lapic_id[0x01] enabled)
    Processor #1
    ACPI: LAPIC (acpi_id[0x02] lapic_id[0x02] disabled)
    ACPI: LAPIC (acpi_id[0x03] lapic_id[0x03] disabled)
    ACPI: LAPIC_NMI (acpi_id[0x00] high edge lint[0x1])
    ACPI: LAPIC_NMI (acpi_id[0x01] high edge lint[0x1])
    ACPI: LAPIC_NMI (acpi_id[0x02] high edge lint[0x1])
    ACPI: LAPIC_NMI (acpi_id[0x03] high edge lint[0x1])
    ACPI: IOAPIC (id[0x04] address[0xfec00000] gsi_base[0])
    IOAPIC[0]: apic_id 4, address 0xfec00000, GSI 0-23
    ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
    ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 high level)
    ACPI: IRQ0 used by override.
    ACPI: IRQ2 used by override.
    ACPI: IRQ9 used by override.
    Setting APIC routing to flat
    ACPI: HPET id: 0x10b9a201 base: 0xfed00000
    Using ACPI (MADT) for SMP configuration information
    swsusp: Registered nosave memory region: 000000000009f000 - 00000000000a0000
    swsusp: Registered nosave memory region: 00000000000a0000 - 00000000000f0000
    swsusp: Registered nosave memory region: 00000000000f0000 - 0000000000100000
    Allocating PCI resources starting at 80000000 (gap: 7ff00000:60100000)
    SMP: Allowing 4 CPUs, 2 hotplug CPUs
    PERCPU: Allocating 33200 bytes of per cpu data
    Built 1 zonelists in Zone order, mobility grouping on. Total pages: 515385
    Kernel command line: root=/dev/sda1 ro vga=791
    Initializing CPU#0
    PID hash table entries: 4096 (order: 12, 32768 bytes)
    hpet clockevent registered
    TSC calibrated against HPET
    time.c: Detected 2395.908 MHz processor.
    Console: colour dummy device 80x25
    console [tty0] enabled
    Dentry cache hash table entries: 262144 (order: 9, 2097152 bytes)
    Inode-cache hash table entries: 131072 (order: 8, 1048576 bytes)
    Checking aperture...
    Calgary: detecting Calgary via BIOS EBDA area
    Calgary: Unable to locate Rio Grande table in EBDA - bailing!
    Memory: 2057296k/2096000k available (2958k kernel code, 38092k reserved, 1092k data, 248k init)
    SLUB: Genslabs=11, HWalign=64, Order=0-1, MinObjects=4, CPUs=4, Nodes=1
    Calibrating delay using timer specific routine.. 4796.31 BogoMIPS (lpj=7990897)
    Security Framework initialized
    Capability LSM initialized
    Mount-cache hash table entries: 256
    CPU: L1 I cache: 32K, L1 D cache: 32K
    CPU: L2 cache: 4096K
    using mwait in idle threads.
    CPU: Physical Processor ID: 0
    CPU: Processor Core ID: 0
    CPU0: Thermal monitoring enabled (TM1)
    SMP alternatives: switching to UP code
    Early unpacking initramfs... done
    ACPI: Core revision 20070126
    ACPI: Looking for DSDT in initramfs... error, file /DSDT.aml not found.
    Using local APIC timer interrupts.
    APIC timer calibration result 16638250
    Detected 16.638 MHz APIC timer.
    SMP alternatives: switching to SMP code
    Booting processor 1/2 APIC 0x1
    Initializing CPU#1
    Calibrating delay using timer specific routine.. 4793.45 BogoMIPS (lpj=7986329)
    CPU: L1 I cache: 32K, L1 D cache: 32K
    CPU: L2 cache: 4096K
    CPU: Physical Processor ID: 0
    CPU: Processor Core ID: 1
    CPU1: Thermal monitoring enabled (TM2)
    Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz stepping 06
    checking TSC synchronization [CPU#0 -> CPU#1]: passed.
    Brought up 2 CPUs
    net_namespace: 120 bytes
    NET: Registered protocol family 16
    ACPI: bus type pci registered
    PCI: Using MMCONFIG at e0000000 - efffffff
    ACPI: EC: Look up EC in DSDT
    ACPI: Interpreter enabled
    ACPI: (supports S0 S1 S4 S5)
    ACPI: Using IOAPIC for interrupt routing
    ACPI: PCI Root Bridge [PCI0] (0000:00)
    PCI quirk: region 0400-047f claimed by ICH6 ACPI/GPIO/TCO
    PCI quirk: region 0480-04bf claimed by ICH6 GPIO
    PCI: Transparent bridge - 0000:00:1e.0
    ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
    ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.PEX0._PRT]
    ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.HUB0._PRT]
    ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 7 9 *10 11 14 15)
    ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 7 9 *10 11 14 15)
    ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 5 7 9 10 *11 14 15)
    ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 7 9 10 *11 14 15)
    ACPI: PCI Interrupt Link [LNKE] (IRQs 3 4 5 7 9 10 11 14 15) *0, disabled.
    ACPI: PCI Interrupt Link [LNKF] (IRQs 3 4 *5 7 9 10 11 14 15)
    ACPI: PCI Interrupt Link [LNK0] (IRQs 3 4 5 7 *9 10 11 14 15)
    ACPI: PCI Interrupt Link [LNK1] (IRQs 3 4 5 7 9 10 11 14 15) *0, disabled.
    Linux Plug and Play Support v0.97 (c) Adam Belay
    pnp: PnP ACPI init
    ACPI: bus type pnp registered
    pnp: PnP ACPI: found 16 devices
    ACPI: ACPI bus type pnp unregistered
    SCSI subsystem initialized
    PCI: Using ACPI for IRQ routing
    PCI: If a device doesn't work, try "pci=routeirq". If it helps, post a report
    NetLabel: Initializing
    NetLabel: domain hash size = 128
    NetLabel: protocols = UNLABELED CIPSOv4
    NetLabel: unlabeled traffic allowed by default
    PCI-GART: No AMD northbridge found.
    ACPI: RTC can wake from S4
    Time: tsc clocksource has been installed.
    system 00:01: ioport range 0x4d0-0x4d1 has been reserved
    system 00:01: ioport range 0xa00-0xa7f has been reserved
    system 00:01: ioport range 0x880-0x88f has been reserved
    system 00:0c: ioport range 0x400-0x4bf could not be reserved
    system 00:0e: iomem range 0xe0000000-0xefffffff could not be reserved
    system 00:0f: iomem range 0xf0000-0xfffff could not be reserved
    system 00:0f: iomem range 0xfed00000-0xfed000ff has been reserved
    system 00:0f: iomem range 0x7fee0000-0x7fefffff could not be reserved
    system 00:0f: iomem range 0x0-0x9ffff could not be reserved
    system 00:0f: iomem range 0x100000-0x7fedffff could not be reserved
    system 00:0f: iomem range 0xfec00000-0xfec00fff has been reserved
    system 00:0f: iomem range 0xfed14000-0xfed1dfff has been reserved
    system 00:0f: iomem range 0xfed20000-0xfed9ffff has been reserved
    system 00:0f: iomem range 0xfee00000-0xfee00fff could not be reserved
    system 00:0f: iomem range 0xffb00000-0xffb7ffff has been reserved
    system 00:0f: iomem range 0xfff00000-0xffffffff has been reserved
    system 00:0f: iomem range 0xe0000-0xeffff has been reserved
    PCI: Bridge: 0000:00:01.0
    IO window: d000-dfff
    MEM window: fa000000-fcffffff
    PREFETCH window: d0000000-dfffffff
    PCI: Bridge: 0000:00:1c.0
    IO window: b000-bfff
    MEM window: fdb00000-fdbfffff
    PREFETCH window: fdc00000-fdcfffff
    PCI: Bridge: 0000:00:1e.0
    IO window: c000-cfff
    MEM window: fde00000-fdefffff
    PREFETCH window: fdd00000-fddfffff
    ACPI: PCI Interrupt 0000:00:01.0[A] -> GSI 16 (level, low) -> IRQ 16
    PCI: Setting latency timer of device 0000:00:01.0 to 64
    ACPI: PCI Interrupt 0000:00:1c.0[A] -> GSI 16 (level, low) -> IRQ 16
    PCI: Setting latency timer of device 0000:00:1c.0 to 64
    PCI: Setting latency timer of device 0000:00:1e.0 to 64
    NET: Registered protocol family 2
    IP route cache hash table entries: 65536 (order: 7, 524288 bytes)
    TCP established hash table entries: 262144 (order: 10, 4194304 bytes)
    TCP bind hash table entries: 65536 (order: 8, 1048576 bytes)
    TCP: Hash tables configured (established 262144 bind 65536)
    TCP reno registered
    checking if image is initramfs... it is
    Freeing initrd memory: 690k freed
    VFS: Disk quotas dquot_6.5.1
    Dquot-cache hash table entries: 512 (order 0, 4096 bytes)
    Installing knfsd (copyright (C) 1996 [email protected]).
    Block layer SCSI generic (bsg) driver version 0.4 loaded (major 254)
    io scheduler noop registered
    io scheduler anticipatory registered
    io scheduler deadline registered
    io scheduler cfq registered (default)
    Boot video device is 0000:01:00.0
    PCI: Setting latency timer of device 0000:00:01.0 to 64
    assign_interrupt_mode Found MSI capability
    Allocate Port Service[0000:00:01.0:pcie00]
    Allocate Port Service[0000:00:01.0:pcie03]
    PCI: Setting latency timer of device 0000:00:1c.0 to 64
    assign_interrupt_mode Found MSI capability
    Allocate Port Service[0000:00:1c.0:pcie00]
    Allocate Port Service[0000:00:1c.0:pcie02]
    Allocate Port Service[0000:00:1c.0:pcie03]
    vesafb: framebuffer at 0xd0000000, mapped to 0xffffc20010100000, using 3072k, total 262144k
    vesafb: mode is 1024x768x16, linelength=2048, pages=1
    vesafb: scrolling: redraw
    vesafb: Truecolor: size=0:5:6:5, shift=0:11:5:0
    Console: switching to colour frame buffer device 128x48
    fb0: VESA VGA frame buffer device
    Linux agpgart interface v0.102
    Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing disabled
    serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
    serial8250: ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
    00:08: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
    00:09: ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
    RAMDISK driver initialized: 16 RAM disks of 16384K size 1024 blocksize
    loop: module loaded
    input: Macintosh mouse button emulation as /devices/virtual/input/input0
    PNP: PS/2 Controller [PNP0303:PS2K] at 0x60,0x64 irq 1
    PNP: PS/2 appears to have AUX port disabled, if this is incorrect please boot with i8042.nopnp
    serio: i8042 KBD port at 0x60,0x64 irq 1
    mice: PS/2 mouse device common for all mice
    input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input1
    cpuidle: using governor ladder
    cpuidle: using governor menu
    TCP cubic registered
    NET: Registered protocol family 1
    NET: Registered protocol family 17
    RPC: Registered udp transport module.
    RPC: Registered tcp transport module.
    Freeing unused kernel memory: 248k freed
    libata version 3.00 loaded.
    PCI: Enabling device 0000:02:00.1 (0000 -> 0001)
    ACPI: PCI Interrupt 0000:02:00.1[b] -> GSI 17 (level, low) -> IRQ 17
    Switched to high resolution mode on CPU 1
    PCI: Setting latency timer of device 0000:02:00.1 to 64
    scsi0 : pata_jmicron
    Switched to high resolution mode on CPU 0
    scsi1 : pata_jmicron
    ata1: PATA max UDMA/100 cmd 0xbf00 ctl 0xbe00 bmdma 0xbb00 irq 17
    ata2: PATA max UDMA/100 cmd 0xbd00 ctl 0xbc00 bmdma 0xbb08 irq 17
    ata1.00: ATA-7: ST3200826A, 3.06, max UDMA/100
    ata1.00: 390721968 sectors, multi 0: LBA48
    ata1.01: ATAPI: HL-DT-ST DVDRAM GSA-4120B, A101, max UDMA/33
    ata1.00: configured for UDMA/100
    ata1.01: configured for UDMA/33
    scsi 0:0:0:0: Direct-Access ATA ST3200826A 3.06 PQ: 0 ANSI: 5
    scsi 0:0:1:0: CD-ROM HL-DT-ST DVDRAM GSA-4120B A101 PQ: 0 ANSI: 5
    ahci 0000:02:00.0: version 3.0
    ACPI: PCI Interrupt 0000:02:00.0[A] -> GSI 16 (level, low) -> IRQ 16
    ahci 0000:02:00.0: AHCI 0001.0000 32 slots 2 ports 3 Gbps 0x3 impl SATA mode
    ahci 0000:02:00.0: flags: 64bit ncq pm led clo pmp pio slum part
    PCI: Setting latency timer of device 0000:02:00.0 to 64
    scsi2 : ahci
    scsi3 : ahci
    ata3: SATA max UDMA/133 abar m8192@0xfdbfe000 port 0xfdbfe100 irq 16
    ata4: SATA max UDMA/133 abar m8192@0xfdbfe000 port 0xfdbfe180 irq 16
    ata3: SATA link down (SStatus 0 SControl 300)
    ata4: classification failed
    ata4: reset failed (errno=-22), retrying in 8 secs
    ata4: classification failed
    ata4: reset failed (errno=-22), retrying in 10 secs
    ata4: classification failed
    ata4: reset failed (errno=-22), retrying in 35 secs
    ata4: limiting SATA link speed to 1.5 Gbps
    ata4: classfication failed, assuming ATA
    ata4: SATA link up 3.0 Gbps (SStatus 123 SControl 310)
    ata4.00: qc timeout (cmd 0xec)
    ata4.00: failed to IDENTIFY (I/O error, err_mask=0x4)
    ata4: failed to recover some devices, retrying in 5 secs
    ata4: classification failed
    ata4: reset failed (errno=-22), retrying in 10 secs
    ata4: classification failed
    ata4: reset failed (errno=-22), retrying in 10 secs
    ata4: classification failed
    ata4: reset failed (errno=-22), retrying in 35 secs
    ata4: classfication failed, assuming ATA
    ata4: SATA link up 3.0 Gbps (SStatus 123 SControl 310)
    ata4.00: qc timeout (cmd 0xec)
    ata4.00: failed to IDENTIFY (I/O error, err_mask=0x4)
    ata4: failed to recover some devices, retrying in 5 secs
    ata4: classification failed
    ata4: reset failed (errno=-22), retrying in 10 secs
    ata4: classification failed
    ata4: reset failed (errno=-22), retrying in 10 secs
    ata4: classification failed
    ata4: reset failed (errno=-22), retrying in 35 secs
    ata4: classfication failed, assuming ATA
    ata4: SATA link up 3.0 Gbps (SStatus 123 SControl 310)
    ata4.00: qc timeout (cmd 0xec)
    ata4.00: failed to IDENTIFY (I/O error, err_mask=0x4)
    ata4: failed to recover some devices, retrying in 5 secs
    ata4: classification failed
    ata4: reset failed (errno=-22), retrying in 10 secs
    ata4: classification failed
    ata4: reset failed (errno=-22), retrying in 10 secs
    ata4: classification failed
    ata4: reset failed (errno=-22), retrying in 35 secs
    ata4: classfication failed, assuming ATA
    ata4: SATA link up 3.0 Gbps (SStatus 123 SControl 310)
    ata_piix 0000:00:1f.2: version 2.12
    ata_piix 0000:00:1f.2: MAP [ P0 P2 P1 P3 ]
    ACPI: PCI Interrupt 0000:00:1f.2[b] -> GSI 19 (level, low) -> IRQ 19
    PCI: Setting latency timer of device 0000:00:1f.2 to 64
    scsi4 : ata_piix
    scsi5 : ata_piix
    ata5: SATA max UDMA/133 cmd 0xfa00 ctl 0xf900 bmdma 0xf600 irq 19
    ata6: SATA max UDMA/133 cmd 0xf800 ctl 0xf700 bmdma 0xf608 irq 19
    ata_piix 0000:00:1f.5: MAP [ P0 -- P1 -- ]
    ACPI: PCI Interrupt 0000:00:1f.5[b] -> GSI 19 (level, low) -> IRQ 19
    PCI: Setting latency timer of device 0000:00:1f.5 to 64
    scsi6 : ata_piix
    scsi7 : ata_piix
    ata7: SATA max UDMA/133 cmd 0xf300 ctl 0xf200 bmdma 0xef00 irq 19
    ata8: SATA max UDMA/133 cmd 0xf100 ctl 0xf000 bmdma 0xef08 irq 19
    usbcore: registered new interface driver usbfs
    usbcore: registered new interface driver hub
    usbcore: registered new device driver usb
    USB Universal Host Controller Interface driver v3.0
    ACPI: PCI Interrupt 0000:00:1a.0[A] -> GSI 16 (level, low) -> IRQ 16
    PCI: Setting latency timer of device 0000:00:1a.0 to 64
    uhci_hcd 0000:00:1a.0: UHCI Host Controller
    uhci_hcd 0000:00:1a.0: new USB bus registered, assigned bus number 1
    uhci_hcd 0000:00:1a.0: irq 16, io base 0x0000ff00
    usb usb1: configuration #1 chosen from 1 choice
    hub 1-0:1.0: USB hub found
    hub 1-0:1.0: 2 ports detected
    ACPI: PCI Interrupt 0000:00:1a.1[b] -> GSI 21 (level, low) -> IRQ 21
    PCI: Setting latency timer of device 0000:00:1a.1 to 64
    uhci_hcd 0000:00:1a.1: UHCI Host Controller
    uhci_hcd 0000:00:1a.1: new USB bus registered, assigned bus number 2
    uhci_hcd 0000:00:1a.1: irq 21, io base 0x0000fe00
    usb usb2: configuration #1 chosen from 1 choice
    hub 2-0:1.0: USB hub found
    hub 2-0:1.0: 2 ports detected
    ACPI: PCI Interrupt 0000:00:1d.0[A] -> GSI 23 (level, low) -> IRQ 23
    PCI: Setting latency timer of device 0000:00:1d.0 to 64
    uhci_hcd 0000:00:1d.0: UHCI Host Controller
    uhci_hcd 0000:00:1d.0: new USB bus registered, assigned bus number 3
    uhci_hcd 0000:00:1d.0: irq 23, io base 0x0000fd00
    usb usb3: configuration #1 chosen from 1 choice
    hub 3-0:1.0: USB hub found
    hub 3-0:1.0: 2 ports detected
    ACPI: PCI Interrupt 0000:00:1d.1[b] -> GSI 19 (level, low) -> IRQ 19
    PCI: Setting latency timer of device 0000:00:1d.1 to 64
    uhci_hcd 0000:00:1d.1: UHCI Host Controller
    uhci_hcd 0000:00:1d.1: new USB bus registered, assigned bus number 4
    uhci_hcd 0000:00:1d.1: irq 19, io base 0x0000fc00
    usb usb4: configuration #1 chosen from 1 choice
    hub 4-0:1.0: USB hub found
    hub 4-0:1.0: 2 ports detected
    ACPI: PCI Interrupt 0000:00:1d.2[C] -> GSI 18 (level, low) -> IRQ 18
    PCI: Setting latency timer of device 0000:00:1d.2 to 64
    uhci_hcd 0000:00:1d.2: UHCI Host Controller
    uhci_hcd 0000:00:1d.2: new USB bus registered, assigned bus number 5
    uhci_hcd 0000:00:1d.2: irq 18, io base 0x0000fb00
    usb usb5: configuration #1 chosen from 1 choice
    hub 5-0:1.0: USB hub found
    hub 5-0:1.0: 2 ports detected
    ACPI: PCI Interrupt 0000:00:1a.7[C] -> GSI 18 (level, low) -> IRQ 18
    PCI: Setting latency timer of device 0000:00:1a.7 to 64
    ehci_hcd 0000:00:1a.7: EHCI Host Controller
    ehci_hcd 0000:00:1a.7: new USB bus registered, assigned bus number 6
    PCI: cache line size of 32 is not supported by device 0000:00:1a.7
    ehci_hcd 0000:00:1a.7: irq 18, io mem 0xfdfff000
    usb 4-1: new low speed USB device using uhci_hcd and address 2
    ehci_hcd 0000:00:1a.7: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
    usb usb6: configuration #1 chosen from 1 choice
    hub 6-0:1.0: USB hub found
    hub 6-0:1.0: 4 ports detected
    ACPI: PCI Interrupt 0000:00:1d.7[A] -> GSI 23 (level, low) -> IRQ 23
    PCI: Setting latency timer of device 0000:00:1d.7 to 64
    ehci_hcd 0000:00:1d.7: EHCI Host Controller
    ehci_hcd 0000:00:1d.7: new USB bus registered, assigned bus number 7
    PCI: cache line size of 32 is not supported by device 0000:00:1d.7
    ehci_hcd 0000:00:1d.7: irq 23, io mem 0xfdffe000
    usb 4-1: string descriptor 0 read error: -71
    ehci_hcd 0000:00:1d.7: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
    usb usb7: configuration #1 chosen from 1 choice
    hub 7-0:1.0: USB hub found
    hub 7-0:1.0: 6 ports detected
    usb 4-1: string descriptor 0 read error: -71
    usb 4-1: configuration #1 chosen from 1 choice
    usb 4-1: can't set config #1, error -71
    usb 4-1: USB disconnect, address 2
    Driver 'sd' needs updating - please use bus_type methods
    sd 0:0:0:0: [sda] 390721968 512-byte hardware sectors (200050 MB)
    sd 0:0:0:0: [sda] Write Protect is off
    sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
    sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
    Driver 'sr' needs updating - please use bus_type methods
    sd 0:0:0:0: [sda] 390721968 512-byte hardware sectors (200050 MB)
    sd 0:0:0:0: [sda] Write Protect is off
    sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
    sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
    sda: sda1 sda2 sda3
    sd 0:0:0:0: [sda] Attached SCSI disk
    sr0: scsi3-mmc drive: 40x/40x writer dvd-ram cd/rw xa/form2 cdda tray
    Uniform CD-ROM driver Revision: 3.20
    sr 0:0:1:0: Attached scsi CD-ROM sr0
    kjournald starting. Commit interval 5 seconds
    EXT3-fs: mounted filesystem with ordered data mode.
    usb 4-1: new low speed USB device using uhci_hcd and address 3
    usb 4-1: configuration #1 chosen from 1 choice
    rtc_cmos 00:04: rtc core: registered rtc_cmos as rtc0
    rtc0: alarms up to one month
    r8169 Gigabit Ethernet driver 2.2LK loaded
    ACPI: PCI Interrupt 0000:03:06.0[A] -> GSI 21 (level, low) -> IRQ 21
    eth0: RTL8169sc/8110sc at 0xffffc20000024000, 00:16:17:b2:2b:11, XID 18000000 IRQ 21
    ACPI: PCI Interrupt 0000:00:1b.0[A] -> GSI 22 (level, low) -> IRQ 22
    PCI: Setting latency timer of device 0000:00:1b.0 to 64
    hda_codec: Unknown model for ALC883, trying auto-probe from BIOS...
    input: Power Button (FF) as /devices/virtual/input/input2
    ACPI: Power Button (FF) [PWRF]
    input: Power Button (CM) as /devices/virtual/input/input3
    ACPI: Power Button (CM) [PWRB]
    ACPI: Fan [FAN] (on)
    ACPI: SSDT 7FEE8380, 0087 (r1 PmRef Cpu1Ist 3000 INTL 20060912)
    ACPI Exception (processor_core-0816): AE_NOT_FOUND, Processor Device is not present [20070126]
    ACPI Exception (processor_core-0816): AE_NOT_FOUND, Processor Device is not present [20070126]
    ACPI: Thermal Zone [THRM] (43 C)
    sd 0:0:0:0: Attached scsi generic sg0 type 0
    sr 0:0:1:0: Attached scsi generic sg1 type 5
    ACPI: PCI Interrupt 0000:00:1f.3[b] -> GSI 19 (level, low) -> IRQ 19
    nvidia: module license 'NVIDIA' taints kernel.
    PPP generic driver version 2.4.2
    usbcore: registered new interface driver hiddev
    input: Logitech USB-PS/2 Optical Mouse as /devices/pci0000:00/0000:00:1d.1/usb4/4-1/4-1:1.0/input/input4
    lp: driver loaded but no devices found
    input,hidraw0: USB HID v1.10 Mouse [Logitech USB-PS/2 Optical Mouse] on usb-0000:00:1d.1-1
    usbcore: registered new interface driver usbhid
    drivers/hid/usbhid/hid-core.c: v2.6:USB HID core driver
    ppdev: user-space parallel port driver
    ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 16 (level, low) -> IRQ 16
    PCI: Setting latency timer of device 0000:01:00.0 to 64
    NVRM: loading NVIDIA UNIX x86_64 Kernel Module 169.12 Thu Feb 14 17:51:09 PST 2008
    parport_pc 00:0a: reported by Plug and Play ACPI
    parport0: PC-style at 0x378, irq 7 [PCSPP,TRISTATE]
    lp0: using parport0 (interrupt-driven).
    EXT3 FS on sda1, internal journal
    kjournald starting. Commit interval 5 seconds
    EXT3 FS on sda2, internal journal
    EXT3-fs: mounted filesystem with ordered data mode.
    Adding 29294516k swap on /dev/sda3. Priority:-1 extents:1 across:29294516k
    r8169: eth0: link up
    NET: Registered protocol family 10
    lo: Disabled Privacy Extensions
    eth0: no IPv6 routers present
    That's the entire code, the part on which it holds on is :
    ata4: classification failed
    ata4: reset failed (errno=-22), retrying in 8 secs
    ata4: classification failed
    ata4: reset failed (errno=-22), retrying in 10 secs
    ata4: classification failed
    ata4: reset failed (errno=-22), retrying in 35 secs
    ata4: limiting SATA link speed to 1.5 Gbps
    ata4: classfication failed, assuming ATA
    ata4: SATA link up 3.0 Gbps (SStatus 123 SControl 310)
    ata4.00: qc timeout (cmd 0xec)
    ata4.00: failed to IDENTIFY (I/O error, err_mask=0x4)
    ata4: failed to recover some devices, retrying in 5 secs
    ata4: classification failed
    ata4: reset failed (errno=-22), retrying in 10 secs
    ata4: classification failed
    ata4: reset failed (errno=-22), retrying in 10 secs
    ata4: classification failed
    ata4: reset failed (errno=-22), retrying in 35 secs
    ata4: classfication failed, assuming ATA
    ata4: SATA link up 3.0 Gbps (SStatus 123 SControl 310)
    ata4.00: qc timeout (cmd 0xec)
    ata4.00: failed to IDENTIFY (I/O error, err_mask=0x4)
    ata4: failed to recover some devices, retrying in 5 secs
    ata4: classification failed
    ata4: reset failed (errno=-22), retrying in 10 secs
    ata4: classification failed
    ata4: reset failed (errno=-22), retrying in 10 secs
    ata4: classification failed
    ata4: reset failed (errno=-22), retrying in 35 secs
    ata4: classfication failed, assuming ATA
    ata4: SATA link up 3.0 Gbps (SStatus 123 SControl 310)
    ata4.00: qc timeout (cmd 0xec)
    ata4.00: failed to IDENTIFY (I/O error, err_mask=0x4)
    ata4: failed to recover some devices, retrying in 5 secs
    ata4: classification failed
    ata4: reset failed (errno=-22), retrying in 10 secs
    ata4: classification failed
    ata4: reset failed (errno=-22), retrying in 10 secs
    ata4: classification failed
    ata4: reset failed (errno=-22), retrying in 35 secs
    ata4: classfication failed, assuming ATA
    ata4: SATA link up 3.0 Gbps (SStatus 123 SControl 310)
    ata_piix 0000:00:1f.2: version 2.12
    ata_piix 0000:00:1f.2: MAP [ P0 P2 P1 P3 ]
    Also I might add that on my first boot it didn't go this slow - I can't remember if I got the error or not though since I didn't pay attention.
    I don't think it's necessarily a hardware issue, even though this PC had it's issues with linux - had to flash my bios just so grub would detect hard drives, this doesn't seem like one of those.
    At least, I think it isn't since Mandriva booted just fine, and I don't think it's using a different kernel or some such, is it? Altough it was 32bit, but still, I find this quite odd.
    Now if this really is an error, not just buggy software, is there a way to ignore the error - I mean it boots up eventually anyway, just takes a hell of a lot of time.
    Last edited by gajo (2008-06-20 10:12:52)

    I'm going to bring up this issue again, still haven't fixed it and it remains unsolved with the newest kernel.
    The following links seem to have the same issue:
    http://www.ubuntu-forum.net/showthread.php?t=765486
    http://www.slackwarehelp.org/post-6750. … 194ecb9f80
    http://www.archlinux.it/forum/viewtopic.php?pid=11632
    http://www.linuxquestions.org/questions … 26-644368/
    Some of those threads link to this one as well, pretty much all seem to be unresolved or lack any given solution.
    One thing I noticed though, it seems that in nearly all cases the users report to have an MSI motherboard, coincidence? Hope so.
    Any clues on how one might fix this? Facts are, the kernel boots eventually, always, and it works like there is no problem; the issue is that it takes it's time, about 5-10 times the amount it would be normally (or before 2.6.x). Note that in the old kernel the delay was only about 5 seconds or less, with just one error message.
    Also, it seems to boot just fine in Windows, bit sad that Windows seems more stable/reliable eh?
    So where to next? I really want to fix this. It seems Google can't spit out the solution, should I report a bug to the kernel devs and pray that they look it up? Or perhaps it might be feasible to just change the source code of the kernel so it doesn't try 4 times for 10, 10, 30 seconds yet only once for 1 second? Surely it would be a matter of a simple for loop, just a matter of finding it!
    Please, even if you ain't got a solution to the particular issue, at least give me(and the people who google for the problem since this thread seems to be topping the results) an advice on what approach to take next, I'm fairly sure that everything can be fixed with common sense and a bit of C knowledge, only thing that's needed is a bit of experience.

Maybe you are looking for