Problems with AJAX, can't seem to get it to work

Hello! I've just downloaded DWR and I've been going through the samples of it. I attempted to make some test pages but the javascript says that the class I'm using is undefined.
I'm using Firefox and in the Javascript console it says
"Error: <the classname that i used> is undefined"This is what the web.xml file looks like
<?xml version="1.0" encoding="ISO-8859-1"?>
<!DOCTYPE web-app PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN" "http://java.sun.com/dtd/web-app_2_3.dtd">
<web-app>
  <display-name>DWR (Direct Web Remoting)</display-name>
  <description>A demo of how to call Java on the server directly from Javascript on the client</description>
  <servlet>
    <servlet-name>dwr-invoker</servlet-name>
    <display-name>DWR Servlet</display-name>
    <description>Direct Web Remoter Servlet</description>
    <servlet-class>uk.ltd.getahead.dwr.DWRServlet</servlet-class>
    <init-param>
      <param-name>debug</param-name>
      <param-value>true</param-value>
    </init-param>
    <init-param>
      <param-name>scriptCompressed</param-name>
      <param-value>false</param-value>
    </init-param>
    <load-on-startup>1</load-on-startup>
  </servlet>
  <servlet-mapping>
    <servlet-name>dwr-invoker</servlet-name>
    <url-pattern>/dwr/*</url-pattern>
  </servlet-mapping>
</web-app>I actually just copied this cause seeing that it worked in the samples.
And here's the dwr.xml
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE dwr PUBLIC "-//GetAhead Limited//DTD Direct Web Remoting 1.0//EN" "http://www.getahead.ltd.uk/dwr/dwr10.dtd">
<dwr>
   <allow>
    <create creator="new" javascript="CorrUpdate"> // This is the part where the class that dwr in the javascript will be using
      <param name="class" value="com.ats.ocfg.CorrUpdate"/>
    </create>
  </allow>
</dwr>Just for testing, I put one class in it, CorrUpdate. All the classes are in their proper places.
Lastly here's a simple Jsp page
<%@ page contentType="text/html; charset=utf-8" language="java" import="java.sql.*" errorPage="" %>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<title>Untitled Document</title>
<script type="text/javascript" src="./dwr/engine.js"></script>
<script type="text/javascript" src="./dwr/util.js"></script>
<script language="javascript" type="text/javascript">
     function update() {
          CorrUpdate.getCorrModels(createList, $("corrType")); // This is that class. The error is on this line saying that it can't find "CorrUpdate". I don't know why this is, since I've defined it in the dwr.xml file
     function createList(data) {
          DWRUtil.removeAllOptions("corrModel");
          DWRUtil.addOptions("corrModel", data);
     function init()
          DWRUtil.useLoadingMessage();
          update();
</script>
</head>
<body>
Corr type:
  <select name="corrType" style="width:100" onchange="update();">
       <option value="A">A</option>
     <option value="B">B</option>
  </select>
<br />
Corr Model:
     <select name="corrModel"  style="width:200">
     </select>
</body>
</html>What the page is supposed to do is to change the second listbox based on what is selected on the first.
Any AJAX gurus in here?

In your jsp you need to give one more entry saying <script type='text/javascript' src='xxx/xxx/corrUpdate.js'></script> . Path of the js can be obtained from http://localhost:9080/xxx/dwr .

Similar Messages

  • Having a problem in iBooks. When I highlight a section I would like to copy the highlighted parts sometimes to post in my notes. Can't seem to get it to work. Any ideas?

    Having a problem in iBooks. When I highlight a section I would like to copy the highlighted parts sometimes to post in my notes. Can't seem to get it to work. Any ideas?

    Just noticed the same problem. I was able to do it before updating. Hope there's a simple answer. That is a big reason why I got the iPad and iBooks.

  • I just purchased a Brother MFC-9340CDW all in one printer.  It shows up on a list of compatable airprint devices but I can't seem to get it to work.  Any suggestions?

    I just purchased a Brother MFC-9340CDW all in one printer.  It shows up on a list of compatable airprint devices but I can't seem to get it to work.  Any suggestions?

    Hi,
    It won't work with airplay, here is how I got it to work with OSX 10.9.4 fully patched;
    you will need to use the serial cable to start the process:
    In-brief Version:
    0) Go grab the firmware update tool, the driver, and the scanner software
    1) Turn off the firewall and antivirus (if you use it ??)
    2) Update the firmware using the serial line
    3) Reserve a static IP outside the DHCP range (using the MAC address of the printer) on your WAP server
    4) Configure the printer to use a static IP through the front panel
    5) Configure the printer WIFI with your SSID and net key through the front panel
    6) Install the CUPS driver on your computer through the printer settings by specifying the static IP
    7) Install the Scanner driver then go into the Control Center and add you computer and printer configuration
    I generally use this kind of set up so that the printer comes back at the same place after a power failure in
    the event that it has a crappy driver.
    For those of you who need a little more help:
    0) Turn off anti-virus and firewall software (it did seem to matter)
    1) Go to the Brother Center and download 1) The firmware update tool, 2) the driver, 3) the scanner software
    2) Go to the front panel on the printer: tools -> all settings -> network -> tcp/ip -> WLAN ; find the MAC address and write it down
    3) Plug the printer in using the serial cable, it will auto detect and you will be able to talk to it.
    4) Install the firmware update tool by double clicking on the dmg you downloaded
    5) Update the firmware and the subfirmware (NOTE: this is a bit finicky -- you may have to unplug and replug it in a couple of times before it starts to talk with the device, after it starts the update process it frequently gives up in the middle, DO NOT unplug the device at this point, just select "retry" from the dialog and it will continue -- it will take about 15 mins or so.
    6) Once the firmware is installed, go to your WAP server and look at the DHCP IP range; typically something like 10.0.1.2 to 10.0.1.200
    7) If there is a capability to reserve an IP on your WAP server pick an IP outside the range in 6 (e.g. 10.0.1.201) and use the MAC address (from step 2) for the reservation... its fine if you don't reserve it -- this is an extra precaution -- just make sure you pick an IP outside the DHCP range
    8) Go to the front panel on the printer: tools -> all settings -> network -> tcp/ip -> WLAN ; then set the IP address:
         boot method: static
         IP address: the address you chose in 7)
         mask: 255.255.255.0
         gateway: the IP of your router -- typically 10.0.1.1
    8) Go to the front panel on the printer: tools -> wireless -> setup wizard -> let it find your network, select it, and enter your key.
    9) Reboot the printer and check it connects to your wireless network
    10) Go to the front panel on the printer, tools -> all settings -> print reports -> network configuration ; print the report and check the IP and MAC
    are what you think they should be.
    11) Go to your computer, bring up a terminal (applications->utilities->terminal)
    12) Ping your printer to make sure its up and accessible -- type: "ping 10.0.1.201" (or whatever IP you used in step 7) and check you get a response -- not a timeout -- if it works disconnect the serial line and delete the (serial line) printer from the list of printers  -- you won't need it anymore -- if not you screwed up somewhere along the line
    13) Now the printer is on the wireless network, install the driver by double clicking the dmg. Then go to system preferences->printers & scanners
         click +
         in the add menu click IP
         enter your IP (from step 7)
         make sure the Protocol is IPP
         Name the printer and set its location
         Go to Use field, in the pull down menu select "Select Software"
         Go through the list and find the Brother MFC-9340CDW CUPS driver -- if its not there you screwed up installing it so go do it again.
    14) Go back to the printer page -- select the printer, select Open Print Queue, then select Settings -- check the Driver Version is 4.1.0 -- if
    it says 2 you are using the airplay version which seems to be buggered -- so you need to try again.
    15) Go open a word document and print it -- smile you are nearly there
    16) Install the scanner software by double clicking the dmg
    17) Open the Control Center, under the Model: select Other
         Click +
         Select your printer
         Enter your computer name in the display name and click ok
    18) Go into adobe Acrobat File->Create->PDF from Scanner (or whatever software you are scanning with)
    19) Select "Brother TWAIN" from the scanner list -- if its not there you screwed up the scanner software installation -- go do it again
    20) Put a document in the top of the printer and press scan -- wammo !
    21) Turn back on your firewall (and antivirus if you have it -- why I can't imagine but what the ****)
    22) Go ping the printer and make sure its still reachable (see step 12) -- if not you need to figure out what your antivirus is screwing up because the firewall is no problem
    23) try printing and scanning again...
    24) rejoice... your done.

  • Chat - with google/yahoo webmail - when i opened in the firefox earlier version, it automatically loads the webchat on the side bar(gmail) or there is a smiley face next to username (yahoo) but with Firefox4 - i dont seem to get the chat working.

    chat - with google/yahoo webmail - when i opened in the firefox earlier version, it automatically loads the webchat on the side bar(gmail) or there is a smiley face next to username (yahoo) but with Firefox4 - i dont seem to get the chat working.

    uninstalled firefox ....deleted all files still remaining under mozilla firefox directory in program files ... to avoid having to reprogram all my settings, reisntall all addons as well .. I did not remove anything from mozilla firefox that is stored in either appdata or under the windows users directory (if any)
    ... the as suggested reinstalled the latest version of the firefox browser using the link you provided in the email ..; tested and several issues still remain present and unresolved ....
    so please this is urgent or I will have to jump browsers and start using chrome .. because we work 14 hours a day 6 (sometimes 7) days a week, to get ready for the launch of our newest venture and we cannot lose that much days on browser related issues ... so please instead of putting me through week long step process .. of do this .. do that .. can you please actually look into the issue from your end .. I use firefox for so many, many years thta I deserve this kind of support .. thnx Robert

  • HT204291 I can't seem to get AirPlay to work on my iPads, works fine on my iPhones on the same network, any suggestions?

    I can't seem to get AirPlay to work on my iPad's, it works fine on my iPhone 5's on the same network, any suggestions?

    http://whirlpool.net.au/wiki/three_email
    Have you tried contacting your ISP for support? Can you confirm that the email is suppose to be over Port 110 and not 143, or 995/993?

  • I am attempting to transfer my contacts from my Android phone to a new Lenovo Yoga 2 computer via the intouch app and I can't seem to get it to work.

    I am attempting to transfer my contacts from my Android phone to a new Lenovo Yoga 2 computer via the intouch app and I can't seem to get it to work.

    Maybe I'm not understanding but it appears that your question refers to a transfer from a non-Apple phone to a non-Apple computer. If that is correct, this forum is likely not the best place to get an informed answer.

  • Hello please can you tell me how to set up AirPlay as I can't seem to get it to work!

    HI I've recently brought a Apple TV tired to set it up yesterday to watch cartonn hd but can't seem to get it to play on my TV am I doing something wrong?
    aany help gratefully received  

    Hello Pepsimax1972,
    Thank you for using Apple Support Communities. 
    I see you are having difficulties in getting your Apple TV to play on your TV. The following article provides some basic troubleshooting steps to help you sort out what might be going on. 
    Apple TV: Basic troubleshooting - Apple Support
    Regards,
    Jeff D. 

  • I have the new iphone 5s and I am trying to sync my music from itunes on my desktop, but can't seem to get it to work....

    I have the iphone 5s and I am trying to sync my music from itunes on my desktop, but can't seem to do it, any suggestions??

    Make sure you have selected to sync your entire library, or have checked the songs you want to sync.  This might help: http://support.apple.com/kb/ht1351

  • New iMac...trying to set up sound recording form the internet but my microphone isn't working for facetime.  I have soundflower installed...recording into Adobe Audition. Can't seem to get them all working...any help?

    I'm just setting up my iMac, and am not very familiar as I'm just coming over from Windows.  Working on setting up my recordeing software (will most likely be Audition) and I need to be able to record from the internet as well as from a microphone.
    I've installed soundflower but now the micropohone is not working in facetime.  What is the proper way to set all this up? 
    Thank you!
    Frank

    O.K. fgonoz98
    I would do 1 thing at a time:"now the micropohone is not working in facetime"
    Here is what you can check to get your mike working in facetime:
    1. Hold down option while you click on the speaker next to time a. date,
    under input Device see if your mic is marked. If not: ✔️
    2. Click the apple top left/System Prefs./click on the Sound speaker:
    under Input highlight microphone.
    3. When you have factime on go to video above scroll and see if your mic is marked ✔️
    If that does not get it to work there is more you can check:
    (Utilities/Audio, midi setup)
    For any other audio device you do this for input and output.
    If you get stock post back

  • A problem with Smart Folders, I can't seem to get it to work.

    Hi, I'm trying to make a smart folder that will include all folders which contain a certain word in the comment section, but it's not working. For example in the Comment section (in Get Info) of folders that contain films by Martin Scorsese I've typed "Directed by Martin Scorsese". Then, I made a Smart folder and as search criteria I've added "Comment contains Martin Scorsese", but nothing appears in the folder. I was hoping that the smart folder will show all the folders which contain Martin Scorsese in the Comment section but it's not working. However, when I type "Martin Scorsese" in the Spotlight those folders appear? What am I doing wrong? Please help

    After a bit of work I have found the solution to searching for a comment.
    1. Open a finder window and do a search for a comment.
    2. Save the finder window.
    3. The saved window will function correctly. You may not set up a search window using the criteria functions and get a result. It must be done in this sequence
    If you want to find a folder only with a comment
    1. Open a finder window  and in the search window type "folder comment:xxxx" where xxxx is the comment.
    2. Save the finder window.
    3. The saved window will function correctly. You may not set up a search window using the criteria and get a result. It must be done in this sequence

  • I can't seem to get  my iCloud working between my iPhone and iPad

    My wife and I recently purchased (in This order) an iPad, then 2 iPhones, then a second iPad. My iCloud on my devices is working fine. We are having trouble getting my wife's to work. I checked again, and was sure I had done what I was supposed to do to set hers up. She had her iPhone for a week or so before we got her iPad. We may have registered the phone with one Apple ID, and the pad with another. How can we get the two in sync?

    Hi
    So the problem we are working on is just your wife's iPhone nad iPad right?
    It sounds like you have a pretty good handle on the detailed screens.
    I think the key is to log out of your devices and then sign back in with only ONE ID on each device.
    Let's start with
    1. Settings
    2. Itunes and Apps stores
    3.  Tap on the Apple ID (willlook like your wife's id).
    4.  Tap sign out
    5.  Enter your preferred Apple id and password
    6.  Tap sign in
    7.  Check Settings> iCloud... should be the correct iCloud Id now (and greyed out)
    Do this on each device.....

  • Can't seem to get VPN to work ... how difficult can it be?

    Okay. I'm a Mac IT professional, but have never had the need to do VPN for a client until now. The client has a Mac Pro server running 10.5.6 Server Unlimited. The router is a brand-new Apple Airport Extreme base station doing DHCP and NAT from 10.0.0.2 to 10.0.0.200. The server is set to 10.0.0.250 and the base station is forwarding all inbound traffic to the server at 10.0.0.250 (DMZ). Access from the outside for AFP, ScreenSharing, Server Admin, Workgroup Manager, etc -- all working.
    The server has a domain name of "server.client.com" and the server is running Open Directory, Kerberos is running, and all DNS info seems correct.
    When I turned on VPN, I enabled L2TP over IPsec and entered 10.0.0.201 as the beginning address and 10.0.0.210 as the ending address since they are out of the DHCP scope of the Airport Base Station. I also tried 10.0.1.201 to 10.0.1.210. I have PPP Authentication set to MS-CHAPv2 and on my client computer (MacBook Pro running 10.5.6) I configured the client authentication to "password". I've confirmed that I'm entering the correct password, and I've also tried Kerberos authentication. I will point out, however, that when I open Kerberos Utility on my client workstation, it is unable to get a Kerberos ticket from the server. Not sure why. I know I've typed the "shared secret" correctly on both computers because I'm just using a simple word for now while configuring and testing the service.
    I've tried turning off the firewall just to be sure that it's not blocking my connection.
    When I look at the Overview tab for VPN, it shows that L2TP is running. When I look at the log for VPN service on the server, it doesn't show anything.
    Apple's tech specs on the base station in question list compatibility for VPN with the following info "NAT, DHCP, PPPoE, VPN Passthrough (IPSec, PPTP, and L2TP), DNS Proxy, SNMP, IPv6 (6to4 and manual tunnels)"
    Does the server need to be running DHCP in order for VPN to work? And if so, can I continue to have the Airport Base Station do DHCP if the server is doing it? If the server needs to run DHCP, I'd prefer to have it run DHCP just for the VPN clients and not the rest of the network.
    Am I missing something?

    Does your server have only one interface?
    I've never seen the VPN software work in this configuration. Usually you have one public interface (where VPN clients connect to) and a separate internal interface (where the secured systems are).
    I don't know if it's possible to run in this way given that all incoming VPN connections will appear to come from a LAN address (thanks to the NAT router), and you wouldn't normally have a LAN client connect via VPN to the server to talk to devices on the same LAN.
    Apple's tech specs on the base station in question list compatibility for VPN with the following info "NAT, DHCP, PPPoE, VPN Passthrough (IPSec, PPTP, and L2TP), DNS Proxy, SNMP, IPv6 (6to4 and manual tunnels)"
    That doesn't matter - it relates to OUTgoing connections from clients on the LAN to remote VPN servers, not incoming connections.
    The other place to look is in the router - make sure the relevant ports are being forwarded to the server. If all ports are (as you say) then this might not be an issue (although I seriously question the sanity of running your network this way).
    You should also run a tcpdump on the server looking for traffic from the client. That will tell you whether the connection is even getting to the server.

  • Snap to beat markers:  I'm using iMovie 11.  Trying to prepare short movie of holiday using 2 or 3 songs and snap to beat feature.  It worked great for first segment/song but I can't seem to get it to work for the second song.  Help please.

    I'm using iMovie to prepare a short holiday video.  Snap to beat markers worked great for the first song but doesn't seem to work when I try to extend my project with a second song and more video and stills.  I dragged in the song and marked the beats but when I bring in stils and video clips they just ignore the beat markers.  Can anyone help please.  Thanks.

    I am having the same issue. The first song and beat markers work great. I add a second song and set beat markers. When I add photos, the appear at random spots with random lengths. I haven't seen a pattern yet. Spent 30 minutes on this topic at my last 1:1 session in the store. No luck figuring it out.
    One work-around might be to create one song per project (so beat markers work), then combine the two (or more) projects. But I'm not sure if that's possible or how to do it.
    Thanks for any help on this.

  • Can't seem to get sort-object working in powershell widget

    I'm experiencing a bit of exasperation with the powershell widget in SCOM 2012 - go easy on me though, this is my first time posting and I'm a bit of a newbie with powershell.
    Because of the issues with the logical disk space performance widget and multiple disks (if you have 3 disks attached you get 9 results back) I've been trying to adapt a script somebody else wrote (http://blogs.technet.com/b/lukaszr/archive/2014/06/18/how-to-get-nice-logical-disk-state-view-using-powershell-grid-widget.aspx)
    as I want something slightly different.
    My objective is to list the 10 servers with lowest free GB space. The script I've been trying to adapt just lists all disks on all servers.
    Here is my modified version of the script
    $disklist = @()
    $disks = Get-SCOMClass -Name "Microsoft.Windows.Server.LogicalDisk" | Get-SCOMClassInstance
    foreach ($disk in $disks)
    $query = GET-WMIOBJECT –query "SELECT * from win32_logicaldisk where DeviceID = '$disk'" -ComputerName $disk.Path | Select-Object Size, FreeSpace
    $size = $query.Size
    $free = $query.FreeSpace
    $percent = $free / $size
    $pervalue = "{0:P0}" -f $percent
    $sizeGB = "{0:N1}" -f ($size / 1024 / 1024 / 1024)
    $freeGB = "{0:N1}" -f ($free / 1024 / 1024 / 1024)
    $diskobject = $ScriptContext.CreateFromObject($disk, "Id=Id", $null)
    $diskobject["Server"] = $disk.Path
    $diskobject["Drive"] = $disk.Displayname
    $diskobject["FreeG"] = $freeGB
    $diskobject["FreeP"] = $pervalue
    $diskobject["FreeTotal"] = ($freeGB + " / " + $sizeGB)
    $disklist += $diskobject
    $GBdisklist = $disklist | Sort-Object -Property {[float]($_.FreeG)} | select -first 10
    foreach($thing in $GBdisklist) {
    $ScriptContext.ReturnCollection.Add($thing)
    My thinking was to put all the info into one big collection, then sort that by free disk space and select the top 10, then pipe those back into the scriptcontext collection for displaying. It's slightly unwieldy, granted, but works fine in standard powershell
    (after changing the scriptcontext bits), just not the widget!
    It all seems to work, and brings back data, except the data that comes back has clearly not been sorted before having the top 10 selected. It's as if the sort command is completely ignored. I've tried quite a few variations on the script sort/sort-object
    with or without -property in desperation as I seem to be so close, but yet so far.
    Any help would be appreciated!
    Pete.
    Incidentally, this is the script that works perfectly in standard powershell:
    $disklist = @()
    $disks = Get-SCOMClass -Name "Microsoft.Windows.Server.LogicalDisk" | Get-SCOMClassInstance
    foreach ($disk in $disks)
    $query = GET-WMIOBJECT –query "SELECT * from win32_logicaldisk where DeviceID = '$disk'" -ComputerName $disk.Path | Select-Object Size, FreeSpace
    $size = $query.Size
    $free = $query.FreeSpace
    $percent = $free / $size
    $pervalue = "{0:P0}" -f $percent
    $sizeGB = "{0:N1}" -f ($size / 1024 / 1024 / 1024)
    $freeGB = "{0:N1}" -f ($free / 1024 / 1024 / 1024)
    $diskobject = New-Object System.Object
    $diskobject | Add-Member -MemberType NoteProperty -Name "Id" -Value $disk.ID
    $diskobject | Add-Member -MemberType NoteProperty -Name "Server" -Value $disk.Path
    $diskobject | Add-Member -MemberType NoteProperty -Name "Drive" -Value $disk.Displayname
    $diskobject | Add-Member -MemberType NoteProperty -Name "FreeP" -Value "$pervalue"
    $diskobject | Add-Member -MemberType NoteProperty -Name "FreeG" -Value $freeGB
    $diskobject | Add-Member -MemberType NoteProperty -Name "FreeTotal" -Value ($freeGB + " / " + $sizeGB)
    $disklist += $diskobject
    $GBdisklist = $disklist | Sort-Object -Property {[float]($_.FreeG)} | select -first 10
    $GBdisklist | ft

    After hacking the code around massively I've managed to solve the issue with it and made it a lot neater in the process. Still unsure what the issue was, but I think it helps to sort the output of the diskinfo first before starting with any of the info processing
    / scriptcontext adding
    $disklist = @()
    $rawdisks = Get-SCOMClass -Name "Microsoft.Windows.Server.LogicalDisk" | Get-SCOMClassInstance
    foreach ($disk in $rawdisks)
    $diskdetails = GET-WMIOBJECT –query "SELECT * from win32_logicaldisk where DeviceID = '$disk'" -ComputerName $disk.Path | Select-Object PSComputerName, DeviceID, FreeSpace, Size
    $disklist += $diskdetails
    $top10disks = $disklist | Sort-Object -Property FreeSpace | select -first 10
    foreach ($object in $top10disks) {
    $size = $object.Size
    $free = $object.FreeSpace
    $percent = $free / $size
    $pervalue = "{0:P0}" -f $percent
    $sizeGB = "{0:N1}" -f ($size / 1024 / 1024 / 1024)
    $freeGB = "{0:N1}" -f ($free / 1024 / 1024 / 1024)
    $dataObject = $ScriptContext.CreateInstance("xsd://foo!bar/baz")
    $dataObject["Id"] = (($object.PSComputerName).ToString() + ($object.DeviceID).ToString())
    $dataObject["Server"] = ($object.PSComputerName).ToString()
    $dataObject["Drive"] = $object.DeviceID
    #$dataObject["Free GB"] = ($freeGB).ToString("0000.00")
    $dataObject["Free GB"] = ($freeGB).ToString()
    $dataObject["FreeTotal"] = (($freeGB).ToString() + " / " + ($sizeGB).ToString())
    $ScriptContext.ReturnCollection.Add($dataObject)

  • Can't seem to get split tunneling working.

    Hi,
    I am using the Cisco VPN client (Thick Client) and I can connect and communicate with the remote network but I lose internet access. It seems my split tunneling is setup properly. Can someone please assist?
    Here is my config:
    ASA Version 8.2(2)19
    hostname ***-DC-SR1-5510-1
    domain-name cisco.com
    enable password ds4hdW4uvMnfKnfo encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    name 10.245.2.0 ***LAN description 10.245.2.x
    interface Ethernet0/0
    nameif outside
    security-level 0
    ip address dhcp setroute
    interface Ethernet0/1
    shutdown
    nameif Outside2
    security-level 100
    no ip address
    interface Ethernet0/2
    nameif inside
    security-level 100
    ip address 10.245.253.1 255.255.255.0
    interface Ethernet0/3
    shutdown
    nameif Inside2
    security-level 100
    no ip address
    interface Management0/0
    nameif management
    security-level 100
    ip address 10.245.1.2 255.255.255.0
    management-only
    boot system disk0:/asa822-19-k8.bin
    ftp mode passive
    dns server-group DefaultDNS
    domain-name cisco.com
    same-security-traffic permit inter-interface
    access-list outside_access_in extended permit icmp ***LAN 255.255.255.0 any echo-reply
    access-list outside_access_in extended permit esp ***LAN 255.255.255.0 host ***
    access-list outside_access_in extended permit udp ***LAN 255.255.255.0 eq isakmp host ***
    access-list outside_access_in extended permit udp ***LAN 255.255.255.0 eq 4500 host ***
    access-list outside_access_in extended permit udp ***LAN 255.255.255.0 eq 1701 host ***
    access-list ***VPN_splitTunnelAcl standard permit ***LAN 255.255.255.0
    access-list inside_nat0_outbound extended permit ip any 10.245.50.0 255.255.255.0
    pager lines 24
    logging enable
    logging asdm informational
    mtu outside 1500
    mtu Outside2 1500
    mtu inside 1500
    mtu Inside2 1500
    mtu management 1500
    ip local pool ***VPNPOOL 10.245.50.50-10.245.50.254 mask 255.255.255.0
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-632.bin
    no asdm history enable
    arp timeout 14400
    global (outside) 101 interface
    nat (inside) 0 access-list inside_nat0_outbound
    nat (inside) 101 0.0.0.0 0.0.0.0
    access-group outside_access_in in interface outside
    route inside 10.245.0.0 255.255.0.0 10.245.253.2 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    dynamic-access-policy-record DfltAccessPolicy
    aaa authentication ssh console LOCAL
    http server enable
    http 192.168.1.0 255.255.255.0 management
    http ***LAN 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
    crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map outside_map interface outside
    crypto ca trustpoint ASDM_TrustPoint0
    enrollment terminal
    subject-name CN=***-DC-SR1-5510-1
    crl configure
    crypto isakmp enable outside
    crypto isakmp policy 1
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    telnet timeout 5
    ssh 10.245.0.0 255.255.0.0 inside
    ssh timeout 30
    console timeout 30
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    group-policy ***VPN internal
    group-policy ***VPN attributes
    banner value Welcome to *** Financial VPN!
    vpn-tunnel-protocol IPSec
    split-tunnel-policy tunnelspecified
    split-tunnel-network-list value ***VPN_splitTunnelAcl
    default-domain value ***financial.local
    username *** password QeDXBFUts7/E3/zS encrypted privilege 15
    username *** password 7hgN6nCxTAeewqbW encrypted
    username *** attributes
    vpn-group-policy DfltGrpPolicy
    vpn-tunnel-protocol IPSec l2tp-ipsec
    service-type remote-access
    tunnel-group ***VPN type remote-access
    tunnel-group ***VPN general-attributes
    address-pool ***VPNPOOL
    default-group-policy ***VPN
    tunnel-group ***VPN ipsec-attributes
    pre-shared-key *****
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
      inspect ip-options
      inspect pptp
    service-policy global_policy global
    prompt hostname context
    call-home
    profile CiscoTAC-1
      no active
      destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
      destination address email [email protected]
      destination transport-method http
      subscribe-to-alert-group diagnostic
      subscribe-to-alert-group environment
      subscribe-to-alert-group inventory periodic monthly
      subscribe-to-alert-group configuration periodic monthly
      subscribe-to-alert-group telemetry periodic daily
    Cryptochecksum:335b4cd70796a4c47fe59046c8132d19
    : end

    Seems like you are using ASA internal local database for authentication.
    The group-policy that has been assigned to that user uses the DfltGrpPolicy instead of the one you configured: ***VPN
    username *** attributes
         vpn-group-policy DfltGrpPolicy
    Please kindly change it to the one you configured:
    username *** attributes
         vpn-group-policy ***VPN
    Hope that resolves the issue.

Maybe you are looking for

  • Embedded font issues -- Flex not measuring properly

    I started this out in one thread ( http://forums.adobe.com/thread/470702 ) and it has progressed into a new, bigger issue. I embedded fonts using the code below.  Flex is not measuring them properly or the font I'm using is vertically challenged.  I

  • Ipod doesn't charge except with usb

    My 30 gig video only charges through the usb cable via computer. It doesn't charge with older firewire adapter, and I just bought an ez-trip car charger/fm modulator and it doesn't charge either. Any ideas?

  • Viewing Nikon D300 images in finder

    Hi, Is there anyone out there using Nikon D300 with Mac Book Pro under OSX 10.5.1? Can you see the thumbnails? Can you see the NEF, TIFF, or PSD files in Finder? How do you view your photos? In Finder, if you click on one single pictures, does it clo

  • Error loading lynx (solved, thank you)

    Hello. I've got a clean base arch installation. 1st: I've installed Lynx web browser using pacman. When I type pacman -Qs lynx the result is: local/lynx 2.8.5-3 When I type lynx it says: error while loading shared libraries - libssl.so.0.9.8 I've the

  • Pricing: header condition with condition value formula

    Hi, can anyone helps us on the following topic: - is it possible to enter a conditon value formula for a header condition? We have created a formula, but it is only executed when we enter the condition on item level. Our condition settings are: Cond.