SelectBooleanCheckbox not working for mult rows, Attn: Shay, Simon, Frank

I converted some input texts my detail table to selectBooleanCheckBox. Input texts have "y" or "n". However, my selectCheckBox showed no checkboxes for either "y" or "n". Anything special about this?

Here is a snippet of my code. Actually, it works as long as I have a single row. It starts failing on multiple rows.
Let us say, I have two fields "Create" and "Read" (values "y" or "n" in the database table).
When I have one row, I have the checkboxes checked fine (A "y" is shown as a checked field). If, however, I have two rows, the selection for the first row shown on the page seems to be propagating to all rows. It is almost like it dioes not understand there are two rows. However, all the inputtexts corresponding to the rows have correct values. I made sure I selected the correct field from Data Controls and drooped them in the details column area. If I replace the selectBooleanCheckBox with "inputText", the values are shown fine on the page even if there are multiple rows.
<af:table value="#{bindings.SecPagePermissionView1.collectionModel}"
<af:panelHorizontal binding="# {backing_PagePermissions.panelHorizontal1}"
id="panelHorizontal1">
<af:selectBooleanCheckbox value="#{bindings.SecPagePermissionView1Cr.inputValue}"
label="#{bindings.SecPagePermissionView1Cr.label}"
binding="#{backing_PagePermissions.selectBooleanCheckbox3}"
id="selectBooleanCheckbox3"/>
<af:selectBooleanCheckbox value="#{bindings.SecPagePermissionView1Read.inputValue}"
label="#{bindings.SecPagePermissionView1Read.label}"
binding="#{backing_PagePermissions.selectBooleanCheckbox4}"
id="selectBooleanCheckbox4"/>
</af:panelHorizontal>
<af:panelHorizontal binding="#{backing_PagePermissions.panelHorizontal3}"
id="panelHorizontal3">
</af:panelHorizontal>
</af:column>
</af:table>

Similar Messages

  • EditCellAt() with mouseclick is not working for first row of the jtable

    Hi All,
    I have extended JTable.changeSelection() & editCellAt() methods to force the text to select when focus is brought to the cell.
    I have a page which has both editable and non-editable columns. when I do a mouse click on FIRST ROW of the editable cell and type the value, The value is not displayed in the cell. when I click on any other editable field in the page, The typed value is displayed in the cell. In the first row of the cell, only the first attempt is not working. When I remove the editCellAt() call in changeSelection(), it works as expected.
    But, If I reach the FIRST ROW editable cell using TAB key instead of Mouse click and type the value, its working fine.
    Kindly suggest me what could be the problem in my code. I think something wrong in editcellat() or mouseclicked/released or focusgained in our versions of JTable or jtextfield.
    Kindly let me know if you need any more functions of my version of implementation.
    Thanks In advance.
    My JTable Version of editCellAt:
         public boolean editCellAt(int row, int column, EventObject e) {
              try {
                   if (getCellEditor() != null && !getCellEditor().stopCellEditing()) {
                        return false;
                   if (!isCellEditable(row, column)) {
                        return false;
                   if (isShowStarRow() /*&& !starRowAdded*/) {
                        VSDataControl ds = getDataSource();
                        if (ds != null) {
                             VSResultSet rs = ds.getResultSet();
                             if (rs != null) {
                                  if (row == rs.getRowCount()) { // This is the star row
                                       // Go to the last record
                                       if (row > 0) {
                                            try {
                                                 rs.getRowAt(row + 1, true);
                                                 rs.last();
                                            } catch (Exception ex) {
                                                 return false;
                                       if (ds.insert() == null) {
                                            return false;
                                       currentRow = row + 1;
                                       starRowAdded = true;
                   TableCellEditor editor = getCellEditor(row, column);
                   if (editor != null && editor.isCellEditable(e)) {
                        editorComp = prepareEditor(editor, row, column);
                        if ( editorComp instanceof VSGridChoice && lastKeyEvent != null ) {
                             VSGridChoice choice = (VSGridChoice) editorComp;
                             choice.handleMissingCharEvent( lastKeyEvent );
                        if (editorComp instanceof VSChoiceBase && lastKeyEvent != null ) {
                             VSChoiceBase hack = (VSChoiceBase)editorComp;
                             hack.addMissingChar(lastKeyEvent);
                        lastKeyEvent = null;
                        if (editorComp == null) {
                             removeEditor();
                             return false;
                        editorComp.setBounds(getCellRect(row, column, false));
                        add(editorComp);
                        editorComp.validate();
                        editorComp.requestFocus();
                        setCellEditor(editor);
                        setEditingRow(row);
                        setEditingColumn(column);
                        editor.addCellEditorListener(this);
                        return true;
                   return false;
              } catch (Exception ex) {
                   showValidationError(e, ex);
                   return false;
         public void changeSelection(int rowIndex, int columnIndex, boolean toggle, boolean extend)
              super.changeSelection(rowIndex, columnIndex, toggle, extend);
                    editCellAt(rowIndex, columnIndex);
                           if (getEditorComponent() != null)
                   if (getEditorComponent() instanceof CustomJTextField)
                        ((CustomJTextField)getEditorComponent()).selectAll();
          }

    i will suggest you to override your requetFocus()
    like.
    public void requestFocus()
            super.requestFocus(); // may be panel or container.
            textPane.setSelectionStart(0); // textpane is the editor for the cell.
            textPane.setSelectionEnd(textPane.getText().length());
        } Gud luck.

  • Ipsec sequence numbers not working for multi VPN's

    one site to one site VPN works no problem, but when I add the second peer in the hub router it does not connect. There is no routing in place all routers are connected to the same switch and with no crypto map they can both ping 192.168.2.1. With crypto map only 192.168.2.2 can ping 192.168.2.1. I am at a loss as to what I am doing wrong this seems simple I just add the entry to Test with a different number, but it will not work.
    Please ask any other question you can think of. I followed the same commands on both spoke routers so it seem like it would be in the hub router, but it has me beat as to why.
    Thanks for the help.
    Hub router:
    r1#sh crypto map
    Crypto Map Test 1 ipsec-isakmp
            Peer = 192.168.2.2
            Extended IP access list 110
                access-list 110 permit ip any any
            Current peer: 192.168.2.2
            Security association lifetime: 4608000 kilobytes/86400 seconds
            PFS (Y/N): N
            Transform sets={
                    Test,
            Interfaces using crypto map Test:
                    FastEthernet0/0
    Crypto Map Test 2 ipsec-isakmp
            Peer = 192.168.2.3
            Extended IP access list 110
                access-list 110 permit ip any any
            Current peer: 192.168.2.3
            Security association lifetime: 4608000 kilobytes/86400 seconds
            PFS (Y/N): N
            Transform sets={
                    Test,
            Interfaces using crypto map Test:
                    FastEthernet0/0
    r2#sh crypto map
    Crypto Map Test 1 ipsec-isakmp
            Peer = 192.168.2.1
            Extended IP access list 110
                access-list 110 permit ip any any
            Current peer: 192.168.2.1
            Security association lifetime: 4608000 kilobytes/86400 seconds
            PFS (Y/N): N
            Transform sets={
                    Test,
            Interfaces using crypto map Test:
                    FastEthernet0/0
    r3#sh crypto map
    Crypto Map Test 1 ipsec-isakmp
            Peer = 192.168.2.1
            Extended IP access list 110
                access-list 110 permit ip any any
            Current peer: 192.168.2.1
            Security association lifetime: 4608000 kilobytes/86400 seconds
            PFS (Y/N): N
            Transform sets={
                    Test,
            Interfaces using crypto map Test:
                    FastEthernet0/0

    Ok I cannot ping anything now. Can you see any other obvious problems? Seems like I should be close and must be missing something simple.
    Thanks for the help by the way.
    hostname r1
    crypto isakmp policy 9
    authentication pre-share
    crypto isakmp key Test1234 address 192.168.2.2
    crypto isakmp key Test1234 address 192.168.2.3
    crypto ipsec security-association lifetime seconds 86400
    crypto ipsec transform-set Test esp-3des esp-sha-hmac
    crypto map Test 1 ipsec-isakmp
    set peer 192.168.2.2
    set security-association lifetime seconds 86400
    set transform-set Test
    match address 110
    crypto map Test 2 ipsec-isakmp
    set peer 192.168.2.3
    set security-association lifetime seconds 86400
    set transform-set Test
    match address 111
    spanning-tree mode pvst
    interface FastEthernet0/0
    ip address 192.168.2.1 255.255.255.0
    duplex auto
    speed auto
    crypto map Test
    interface FastEthernet0/1
    no ip address
    duplex auto
    speed auto
    shutdown
    interface Vlan1
    no ip address
    shutdown
    ip classless
    access-list 111 permit ip host 192.168.2.1 host 192.168.2.3
    access-list 110 permit ip host 192.168.2.1 host 192.168.2.2
    line con 0
    line vty 0 4
    login
    end
    hostname r2
    crypto isakmp policy 9
    authentication pre-share
    crypto isakmp key Test1234 address 192.168.2.1
    crypto ipsec security-association lifetime seconds 86400
    crypto ipsec transform-set Test esp-3des esp-sha-hmac
    crypto map Test 1 ipsec-isakmp
    set peer 192.168.2.1
    set security-association lifetime seconds 86400
    set transform-set Test
    match address 110
    spanning-tree mode pvst
    interface FastEthernet0/0
    ip address 192.168.2.2 255.255.255.0
    duplex auto
    speed auto
    crypto map Test
    interface FastEthernet0/1
    no ip address
    duplex auto
    speed auto
    shutdown
    interface Vlan1
    no ip address
    shutdown
    ip classless
    access-list 110 permit ip host 192.168.2.2 host 192.168.2.1
    line con 0
    line vty 0 4
    login
    end
    hostname r2
    crypto isakmp policy 9
    authentication pre-share
    crypto isakmp key Test1234 address 192.168.2.1
    crypto ipsec security-association lifetime seconds 86400
    crypto ipsec transform-set Test esp-3des esp-sha-hmac
    crypto map Test 1 ipsec-isakmp
    set peer 192.168.2.1
    set security-association lifetime seconds 86400
    set transform-set Test
    match address 110
    spanning-tree mode pvst
    interface FastEthernet0/0
    ip address 192.168.2.2 255.255.255.0
    duplex auto
    speed auto
    crypto map Test
    interface FastEthernet0/1
    no ip address
    duplex auto
    speed auto
    shutdown
    interface Vlan1
    no ip address
    shutdown
    ip classless
    access-list 110 permit ip host 192.168.2.2 host 192.168.2.1
    line con 0
    line vty 0 4
    login
    end

  • "Include Header Row in Subsequent Pages" is not working for table

    Hi,
    I'm using version 8.1.2.3337.1.509884.
    The pagnation feature "Include Header Row in Subsequent Pages" is not working for any table in my design. ( the check-box can not be checked no matter how many times I clicking it)
    I put such table already in a flow bodypage.
    Any similar issue reported?
    Any suggestions?
    Thanks.
    -Vicky

    Hi Raghu,
    Appologies that I uploaded a wrong version of xdp file yesterday.
    Here is the correct one.
    https://acrobat.com/#d=jr0XffvBZWXd0cVhL0OQ3A
    I totally understand that I have to check the checkbox "Include Header Row in Subsequent Pages".
    My problem is that, although I can see that checkbox, and it's not grey-out, I can not tick it. See below screenshot, with the red-cycle mark.
    You can try with above file.
    Just wondering why such weird behavior happened.
    -Vicky

  • My laptops QWERTY row of keys does not work for long periods at random intervals and only after pushing all the buttons on the row does it eventually turn back on and then will still cut out every now and again, anyone know how to solve this?

    My laptops QWERTY row of keys does not work for long periods at random intervals and only after pushing all the buttons on the row does it eventually turn back on and then will still cut out every now and again, anyone know how to solve this? If not is there any way to actually get a genuis appointment lol to get one of them to have a look at the hardware on the keyboard?

    Apple Support (formerly ExpressLane):
    https://getsupport.apple.com/GetproductgroupList.do
    https://getsupport.apple.com/GetSASO?SG=SG001&locale=en_US

  • Select All in a table does not work for Drag and Drop

    Hi. I am using Jdeveloper 11.1.1.2 but have also reproduced in 11.1.1.3.
    I am trying to implement drag and drop rows from one table to another. Everything works fine except when I do a Select All (ctrl-A) in a table, the table visually looks like all rows are selected, but when I try to click on one of the selected rows to drag to the other table, only the row I click on is dragged.
    I tried setting Range Size -1, fetch mode to FETCH_ALL, content delivery to "immediate" but nothing works.
    I even have reproduced not using a view object but just a List of beans with only 5 or 10 beans showing in the table.
    Does anyone know how to get Select All to work for a Drag Source?
    Thanks.
    -Ed

    Frank-
    OK, thanks for looking into that. I also submitted this service request, which includes a simple sample app to demonstrate the problem:
    SR #3-2387481211: ADF Drag and Drop does not work for rows in table using Select All
    Thanks again for the reply.
    -Ed

  • Form Designed in LiveCycle will not work for End User

    Please Help!
    I am a newbie to Adobe LiveCycle but recognized the utility in the program, so decided to give it a while to try and streamline some of my employer's forms.  After spending too much time learning how to design a form (much to the dislike of my boss), I am finally going to have to ask for some help.  So here's the deal:
    I've designed a dynamic pdf in LiveCycle with two master pages and two repeating flowed subforms.  The first repeating subform is basically an expanding table intended to be used as a photographer's log where they can log each photo taken with the camera.  The expanding table has some code with a button at the top for the end user to enter the number of photos on the photo roll, click submit, and table expands to however many instances of rows are needed for each photo that was taken.  The second subform is basically an image field and text fields used as photo captions/photo compilation pages.  When the end user clicks submit on the first subform to expand the table, I also have javascript in that click event to also create same amouint of instances of the second subform (the photo compilation page(s)).  Each text field for the photo caption on the second subform is populated by the data entered into the photo log table cells.  I was able to find a script to correctly populate those fields for each instance of the table.  Wish I had the form here, but it's at work at the moment.
    My problem is this: I've scratched and clawed to get all of the forms expanding correctly and the scripts populating each instance of the fields correctly and everything works great in LiveCycle preview.  I then saved the form as PDF for use by my field crew personnel (whom all use, at the very least, Adobe Pro 9, but most Pro X).  I sent the new form to them and they move it to their desktop, open it with Adobe Pro, and populate all of the fields and everything works swimmingly.  However, once they save it, it gets all jumbled and they can't even print it.  We even thought we found a workaround by entering all data and printing to PDF, but even that has turned out to not work.  I checked to make sure that I designed and saved the form in LiveCycle for use with the Adobe Pro versions, but still not working for my end users.
    Anyone have any thoughts on my long explanation??  Please HELLLLPPPP!

    The error(s) occur when trying to save the document.  I want each user to tell the first page how many rows they will need in the photo log table, so they would enter however many photos were taken in the box: "Number of Photos on Roll:"  ---> Then click the "Submit" cmd button.  That should expand the table.  Once it expands, it should also add the same amount of instances of the photo compilation page (2nd Page) as there are rows in 1st page table.  Then the user will populate each cell of the table on page 1 with data.  The data entered into the page 1 table cells will populate the text fields (photo caption) in Page 2 once the user clicks on the "Populate Captions!" cmd button in the lower left corner of the table on Page 1. 
    The problem is in the distributing of the form to the user so they can save the form after populating the data.  I did a test run this morning and for some reason it did do the "print to PDF" correctly for 5 photos on the roll (though this has not been happening every time and especially for a large number of pages, ie. 80 photos).  However, after entering the data for 5 rows on page 1 and then populating the 5 photo compilation pages, I saved a copy as "Save As PDF" and closed the document.  Then re-opened the copy in Acrobat Pro X.  The new copy:
    -had 5 additional rows added to Page 1
    -Duplicates of some of the fields
    -Only retained the 1st instance of the Second Page (Photo w/ Caption) and not all fields were populated
    Again, this all works fine in the LiveCycle Preview but not anywhere else.  I do not have this set up to be linked to an external data source (YET) but there is javascript in the cmd buttons.  I also do not want to distribute this form to end users and then collect the data back from them.  I want them to be able to save a copy of my LiveCycle designed form, open in Adobe Pro, populate the data and save as many copies as needed for form production.

  • After Upgradation BPF is not working for some users

    Hi All,
    We have recently upgraded from BPC 5.1 to 7MS SP7.  we are having multi server setup with one application / reporting server (windows 2003 and one sql server 2008 (windows 2003 64 bit).
    Intially before upgradation we don't have any issues with BPF and it worked fine for all users. But post upgradation tasks within the BPF  does not work for other users except for the first two people who first  used it. Other users have the same rights as the ones who can access the tasks.
    when they  click on the link it gets them to eExcel and the right application but doesnt open the package or report assigned to the task. It doesn't give us any errors, on the status bar we get a message finalising but does  not getting any thing.
    Any inputs ??

    Hi,
    Are you sure that those users have installed BPC 7 SP7 clients on their machine? Meaning that you uninstalled 5.1 clients and installed the new client from http://servername/Osoft?
    If yes, you should maybe run a client diagnostic on the machines and also check the Management Console for any error messages.
    Hope this will drive you to a potential solution.
    Best Regards,
    Patrick

  • Discoverer Reports does not work in Multi-org Environment after R12 Upgrade

    Discoverer Reports does not work in Multi-org Environment after R12 Upgrade. Created a simple report using the below query:
    SELECT po_header_id, segment1, type_lookup_code
    FROM po_headers
    WHERE segment1 = '5000002'
    Query works perfectly fine; when i set the ORG_CONTEXT in the database using the command:
    EXEC mo_global.set_policy_context('S',129)
    But the report doesn't fetch any data when ran from an Org based responsibility. We've ensured that the MO: Operting Unit is set accurately and general Oracle reports (PLSQL Program OR XML Publisher) are working perfectly fine.
    ===========
    I followed the steps provided in Metalink Note: 732826.1 - It works for some responsibilities where the MO: Security Profile is not set; but fails for those responsibilities where the MO: Security Profile is set.
    I am looking for specific solution that works irrespective of either the MO: Operating Unit profile is set of not.
    Please suggest. Appreciate your response.
    Thanks,
    Kesava Chunduri

    Hi Hussein,
    Thanks for the quick response.
    Yes, I've gone thru both the notes specified below:
    Discoverer Workbooks Based On Organization Enabled Views Are Not Populated [ID 1293438.1]
    - Tried this option; but this option is messing up a couple of Oracle Standard Functionalities.
    - For ex: If i set this profile option; we are not able to create any receipts using Custom Responsibilities.
    I am able to create the receipt, when i remove this profile option.
    No Data Shows for Reports in Discoverer 10g with Applications Release 12 [ID 1054380.1]
    - I see that the products i am running these reports from AR/GL - already exists in these tables.
    Anything other options??
    Thanks,
    Kesava

  • Auto_lexer (stemming) not working for other languages(other than english)

    Hi All,
    We are planning to use AUTO_LEXER instead of MULTI_LEXER and observed that stemming is not working for German where as it is working for English when I use AUTO_LEXER. I even used query templates but of no use.
    But when i use MULTI_LEXER, creating sub lexers for German and Enlgish, Stemming is working for German also after changing the session language and setting stemmer of wod list to German (Which is expected).
    Following is the code for AUTO_LEXER creation:
    CREATE TABLE test_auto_lexer(pkey NUMBER(5,0),
    lang_index VARCHAR2(3),
    content_text CLOB,
    CONSTRAINT test_auto_lexer_pk primary key (pkey))
    INSERT INTO test_auto_lexer(pkey,lang_index,content_text)
    VALUES (1,'eng','I drive a bike')
    INSERT INTO test_auto_lexer(pkey,lang_index,content_text)
    VALUES (2,'eng','I drove a bike')
    INSERT INTO test_auto_lexer(pkey,lang_index,content_text)
    VALUES (3,'eng','I have driven a bike')
    INSERT INTO test_auto_lexer(pkey,lang_index,content_text)
    VALUES (4,'eng','Just check for other things')
    INSERT INTO test_auto_lexer(pkey,lang_index,content_text)
    VALUES (5,'eng','always drive a car')
    INSERT INTO test_auto_lexer(pkey,lang_index,content_text)
    VALUES (6,'eng','it is nothing')
    INSERT INTO test_auto_lexer(pkey,lang_index,content_text)
    VALUES (7,'ger','Ich fahre ein Fahrrad')
    INSERT INTO test_auto_lexer(pkey,lang_index,content_text)
    VALUES (8,'ger','Ich fuhr ein Fahrrad')
    INSERT INTO test_auto_lexer(pkey,lang_index,content_text)
    VALUES (9,'ger','Ich habe ein Fahrrad gefahren')
    INSERT INTO test_auto_lexer(pkey,lang_index,content_text)
    VALUES (10,'ger','Aktivieren Sie einfach für andere Dinge')
    INSERT INTO test_auto_lexer(pkey,lang_index,content_text)
    VALUES (11,'ger','immer Auto fahren')
    INSERT INTO test_auto_lexer(pkey,lang_index,content_text)
    VALUES (12,'ger','es ist nichts')
    INSERT INTO test_auto_lexer(pkey,lang_index,content_text)
    VALUES (13,'ger','sprechen')
    INSERT INTO test_auto_lexer(pkey,lang_index,content_text)
    VALUES (14,'ger','sprach')
    INSERT INTO test_auto_lexer(pkey,lang_index,content_text)
    VALUES (15,'ger','gesprochen')
    INSERT INTO test_auto_lexer(pkey,lang_index,content_text)
    VALUES (16,'ger','tale')
    INSERT INTO test_auto_lexer(pkey,lang_index,content_text)
    VALUES (17,'ger','Indlæg')
    INSERT INTO test_auto_lexer(pkey,lang_index,content_text)
    VALUES (18,'ger','tales')
    BEGIN
    ctx_ddl.create_preference('auto_lexer1', 'auto_lexer');
    END;
    BEGIN
    ctx_ddl.set_attribute('auto_lexer1','index_stems','yes');
    END;
    BEGIN
    ctx_ddl.set_attribute('auto_lexer1','language','danish english german');
    END;
    BEGIN
    ctx_ddl.set_attribute('auto_lexer1','alternate_spelling','german');
    END;
    CREATE INDEX test_auto_lexer_ix1
    ON test_auto_lexer(content_text)
    INDEXTYPE IS ctxsys.context
    PARAMETERS ('datastore ctxsys.direct_datastore filter ctxsys.null_filter lexer auto_lexer1')
    select to_char(content_Text) from test_auto_lexer where contains(content_text,
    '<query>
    <textquery lang="ger" grammar="context">
    $fahren
    </textquery>
    <score datatype="integer"/>
    </query>') > 0
    this doesnt work even after changing the session language. My default Sesson language is AMERICAN.
    Could any one help me with this, in case I am missing something here. I would be really thankful.
    Edited by: Nagendra Prasad on Jan 23, 2010 12:05 AM

    In the future, please begin a new thread for a new question and provide a link to a related question.
    According to the online documentation, Oracle only supports stemming for English, Dutch, French, German, Italian, Spanish, and Japanese. Oracle does not support Russian stemming, although you may have gotten some accidental results, due to identifying it as a different language and applying stemming rules for that language. The following manual sections show the languages available for the index_stems attribute of the basic_lexer and stemmer attribute of the basic_wordlist:
    Basic_lexer attributes:
    http://docs.oracle.com/cd/E11882_01/text.112/e24436/cdatadic.htm#CIHHBAAD
    Basic_wordlist attributes:
    http://docs.oracle.com/cd/E11882_01/text.112/e24436/cdatadic.htm#g1019326
    Also, please see the following note:
    Features not available in 11.2.0.3:
    http://docs.oracle.com/cd/E11882_01/readmes.112/e22488/toc.htm#BABDGGDB
    "Certain Oracle Text functionality based on third-party technologies, including AUTO_LEXER and CTX_ENTITY, have been disabled in this release (reference Bug 12618046). For BASIC_LEXER, the usage of the INDEX_STEMS attribute values that depend on third-party technologies, is also affected. If this impacts an existing application, contact Oracle Support Services for guidance."
    Also, the auto_lexer has been replaced by the world_lexer, which only has one attribute:
    http://docs.oracle.com/cd/E11882_01/text.112/e24436/cdatadic.htm#BHCJEGFJ
    I don't work for Oracle, so I don't know why they do things the way they do.
    So, you need to stick with the basic_wordlist for stemming, not the lexers. However, you may get better performance by combining the multi_lexer with the basic_wordlist, as the multi_lexer eliminates time spent on automatic language detection. But, you need to remember not to use the index_stems with your lexer, since it will conflict with the wordlist. I am not experiencing any time problems as you have. Please see the demo below. I have provided the whole script below that, so that you can reproduce it on your system. If you still have problems, then it may be due to differences in versions.
    -- demo:
    SCOTT@orcl_11gR2> select * from v$version
      2  /
    BANNER
    Oracle Database 11g Enterprise Edition Release 11.2.0.1.0 - 64bit Production
    PL/SQL Release 11.2.0.1.0 - Production
    CORE     11.2.0.1.0     Production
    TNS for 64-bit Windows: Version 11.2.0.1.0 - Production
    NLSRTL Version 11.2.0.1.0 - Production
    5 rows selected.
    SCOTT@orcl_11gR2> select value from v$nls_parameters
      2  where  parameter = 'NLS_CHARACTERSET'
      3  /
    VALUE
    AL32UTF8
    1 row selected.
    SCOTT@orcl_11gR2> DROP TABLE news
      2  /
    Table dropped.
    SCOTT@orcl_11gR2> EXEC CTX_DDL.DROP_PREFERENCE ('my_wordlist')
    PL/SQL procedure successfully completed.
    SCOTT@orcl_11gR2> EXEC CTX_DDL.DROP_PREFERENCE ('global_lexer')
    PL/SQL procedure successfully completed.
    SCOTT@orcl_11gR2> EXEC CTX_DDL.DROP_PREFERENCE ('english_LEXER')
    PL/SQL procedure successfully completed.
    SCOTT@orcl_11gR2> EXEC CTX_DDL.DROP_PREFERENCE ('german_LEXER')
    PL/SQL procedure successfully completed.
    SCOTT@orcl_11gR2> CREATE TABLE news
      2    (pkey            NUMBER,
      3       lang            VARCHAR2 (2),
      4       short_content  CLOB)
      5  /
    Table created.
    SCOTT@orcl_11gR2> INSERT ALL
      2  INTO news (pkey, lang, short_content)
      3    VALUES  (1, 'en', 'I drive a bike.')
      4  INTO news (pkey, lang, short_content)
      5    VALUES  (2, 'en', 'I drove a bike.')
      6  INTO news (pkey, lang, short_content)
      7    VALUES  (3, 'en', 'I have driven a bike.')
      8  INTO news (pkey, lang, short_content)
      9    VALUES  (4, 'en', 'I always drive a car')
    10  INTO news (pkey, lang, short_content)
    11    VALUES  (5, 'en', 'This is nothing')
    12  INTO news (pkey, lang, short_content)
    13    VALUES  (6, 'de', 'Ich fahre ein Fahrrad.')
    14  INTO news (pkey, lang, short_content)
    15    VALUES  (7, 'de', 'Ich fuhr ein Fahrrad.')
    16  INTO news (pkey, lang, short_content)
    17    VALUES  (8, 'de', 'Ich habe ein Fahrrad gefahren.')
    18  INTO news (pkey, lang, short_content)
    19    VALUES  (9, 'de', 'Ich habe immer ein Auto fahren.')
    20  INTO news (pkey, lang, short_content)
    21    VALUES  (10, 'de', 'Es ist nichts.')
    22  SELECT * FROM DUAL
    23  /
    10 rows created.
    SCOTT@orcl_11gR2> BEGIN
      2    -- word list:
      3    ctx_ddl.create_preference ('my_wordlist',   'basic_wordlist');
      4    ctx_ddl.set_attribute      ('my_wordlist',   'stemmer',           'auto');
      5    -- english lexer:
      6    ctx_ddl.create_preference ('english_lexer', 'basic_lexer');
      7    -- german lexer:
      8    ctx_ddl.create_preference ('german_lexer',  'basic_lexer');
      9    ctx_ddl.set_attribute      ('german_lexer',  'composite',       'german');
    10    ctx_ddl.set_attribute      ('german_lexer',  'alternate_spelling', 'german');
    11    ctx_ddl.set_attribute      ('german_lexer',  'mixed_case',       'no');
    12    ctx_ddl.set_attribute      ('german_lexer',  'base_letter',       'yes');
    13    -- multi_lexer:
    14    ctx_ddl.create_preference ('global_lexer',  'multi_lexer');
    15    ctx_ddl.add_sub_lexer      ('global_lexer',  'default',            'english_lexer');
    16    ctx_ddl.add_sub_lexer      ('global_lexer',  'german',            'german_lexer');
    17  END;
    18  /
    PL/SQL procedure successfully completed.
    SCOTT@orcl_11gR2> create index search_news
      2  on news (short_content)
      3  indextype is ctxsys.context
      4  parameters
      5    ('lexer            global_lexer
      6        language column  lang
      7        wordlist       my_wordlist')
      8  /
    Index created.
    SCOTT@orcl_11gR2> EXEC DBMS_STATS.GATHER_TABLE_STATS (USER, 'NEWS')
    PL/SQL procedure successfully completed.
    SCOTT@orcl_11gR2> COLUMN short_content FORMAT A30
    SCOTT@orcl_11gR2> ALTER SESSION SET NLS_LANGUAGE = 'AMERICAN'
      2  /
    Session altered.
    SCOTT@orcl_11gR2> set timing on
    SCOTT@orcl_11gR2> select * from news
      2  where  contains (short_content, '$drive') > 0
      3  /
          PKEY LA SHORT_CONTENT
             1 en I drive a bike.
             2 en I drove a bike.
             3 en I have driven a bike.
             4 en I always drive a car
    4 rows selected.
    Elapsed: 00:00:00.05
    SCOTT@orcl_11gR2> select * from news
      2  where  contains (short_content, '$drove') > 0
      3  /
          PKEY LA SHORT_CONTENT
             1 en I drive a bike.
             2 en I drove a bike.
             3 en I have driven a bike.
             4 en I always drive a car
    4 rows selected.
    Elapsed: 00:00:00.05
    SCOTT@orcl_11gR2> ALTER SESSION SET NLS_LANGUAGE = 'GERMAN'
      2  /
    Session altered.
    Elapsed: 00:00:00.01
    SCOTT@orcl_11gR2> select * from news
      2  where  contains (short_content, '$fahr') > 0
      3  /
          PKEY LA SHORT_CONTENT
             6 de Ich fahre ein Fahrrad.
             7 de Ich fuhr ein Fahrrad.
             8 de Ich habe ein Fahrrad gefahren.
             9 de Ich habe immer ein Auto fahren
    4 rows selected.
    Elapsed: 00:00:00.07
    SCOTT@orcl_11gR2> select * from news
      2  where  contains (short_content, '$fuhr') > 0
      3  /
          PKEY LA SHORT_CONTENT
             6 de Ich fahre ein Fahrrad.
             7 de Ich fuhr ein Fahrrad.
             8 de Ich habe ein Fahrrad gefahren.
             9 de Ich habe immer ein Auto fahren
    4 rows selected.
    Elapsed: 00:00:00.16-- script for you to reproduce the demo on your system:
    select * from v$version
    select value from v$nls_parameters
    where  parameter = 'NLS_CHARACTERSET'
    DROP TABLE news
    EXEC CTX_DDL.DROP_PREFERENCE ('my_wordlist')
    EXEC CTX_DDL.DROP_PREFERENCE ('global_lexer')
    EXEC CTX_DDL.DROP_PREFERENCE ('english_LEXER')
    EXEC CTX_DDL.DROP_PREFERENCE ('german_LEXER')
    CREATE TABLE news
      (pkey           NUMBER,
       lang           VARCHAR2 (2),
       short_content  CLOB)
    INSERT ALL
    INTO news (pkey, lang, short_content)
      VALUES  (1, 'en', 'I drive a bike.')
    INTO news (pkey, lang, short_content)
      VALUES  (2, 'en', 'I drove a bike.')
    INTO news (pkey, lang, short_content)
      VALUES  (3, 'en', 'I have driven a bike.')
    INTO news (pkey, lang, short_content)
      VALUES  (4, 'en', 'I always drive a car')
    INTO news (pkey, lang, short_content)
      VALUES  (5, 'en', 'This is nothing')
    INTO news (pkey, lang, short_content)
      VALUES  (6, 'de', 'Ich fahre ein Fahrrad.')
    INTO news (pkey, lang, short_content)
      VALUES  (7, 'de', 'Ich fuhr ein Fahrrad.')
    INTO news (pkey, lang, short_content)
      VALUES  (8, 'de', 'Ich habe ein Fahrrad gefahren.')
    INTO news (pkey, lang, short_content)
      VALUES  (9, 'de', 'Ich habe immer ein Auto fahren.')
    INTO news (pkey, lang, short_content)
      VALUES  (10, 'de', 'Es ist nichts.')
    SELECT * FROM DUAL
    BEGIN
      -- word list:
      ctx_ddl.create_preference ('my_wordlist',   'basic_wordlist');
      ctx_ddl.set_attribute     ('my_wordlist',   'stemmer',            'auto');
      -- english lexer:
      ctx_ddl.create_preference ('english_lexer', 'basic_lexer');
      -- german lexer:
      ctx_ddl.create_preference ('german_lexer',  'basic_lexer');
      ctx_ddl.set_attribute     ('german_lexer',  'composite',          'german');
      ctx_ddl.set_attribute     ('german_lexer',  'alternate_spelling', 'german');
      ctx_ddl.set_attribute     ('german_lexer',  'mixed_case',          'no');
      ctx_ddl.set_attribute     ('german_lexer',  'base_letter',         'yes');
      -- multi_lexer:
      ctx_ddl.create_preference ('global_lexer',  'multi_lexer');
      ctx_ddl.add_sub_lexer     ('global_lexer',  'default',             'english_lexer');
      ctx_ddl.add_sub_lexer     ('global_lexer',  'german',              'german_lexer');
    END;
    create index search_news
    on news (short_content)
    indextype is ctxsys.context
    parameters
      ('lexer            global_lexer
        language column  lang
        wordlist         my_wordlist')
    EXEC DBMS_STATS.GATHER_TABLE_STATS (USER, 'NEWS')
    COLUMN short_content FORMAT A30
    ALTER SESSION SET NLS_LANGUAGE = 'AMERICAN'
    set timing on
    select * from news
    where  contains (short_content, '$drive') > 0
    select * from news
    where  contains (short_content, '$drove') > 0
    ALTER SESSION SET NLS_LANGUAGE = 'GERMAN'
    select * from news
    where  contains (short_content, '$fahr') > 0
    select * from news
    where  contains (short_content, '$fuhr') > 0
    /

  • Incoming Email not working for one web app, but IS working for others in same farm.

    I have enabled incoming email in a large multi-web application farm running SharePoint 2013 SP1 and the Feb 2015/March 2015 CUs that were pushed down in Windows Updates.  It works just fine for two web applications, but it will not work for one particular
    web application. I see the email land in the /drop folder. If I remove the email address from the library in http://nonworkingapp web
    application and use it on a library in a http://working web application, then the email is processed successfully. Conversely,
    if I take an address from a library in http://working and move it to a library inhttp://nonworkingapp it
    does not work. I've tried multiple site collections on http://nonworkingapp. This rules out any SMTP issues, etc. and means
    the issue is bound to this web application. Permissions are the same between the "non-working" and "working" locations: domain users are members on the site, and the library inherits permissions from the site.  The App Pool and Timer
    Service accounts have rights to the folder and to the library.
    The error in the ULS log is the typical error processing message, but it gives no additional information even though I have enabled Verbose logging.
    The Incoming E-Mail service has completed a batch. The elapsed time was 00:00: 00.0156294. The service processed 2 message(s) in total. Errors occurred processing 2 message(s): Message ID: Message
    ID:
    Typically, you see "alias not found" or some permissions or quota issue here, but this issue is NOT the same as those. In this case NO additional information is provided in ULS.
    Edit: running stsadm.exe -o refreshdms -url http://one/failing/site fixed some similar issues where "Unknown alias" was
    reported even though the list did have an alias (see here:http://blogs.technet.com/b/vinitt/archive/2009/07/15/e-mail-enabled-list-alias-information-is-not-synchronized-between-configuration-database-and-content-database.aspx).
    This did not fix the issue for the case mentioned above.
    What could possibly be the issue preventing incoming email from working on this one web application?

    Thanks for your reply.  Incoming E-Mail was running on all 3 WFE, however I do not think this was the cause.  As noted, _other_ emails send to http://workingapp are working just fine.  I can send two emails - one to a library on http://workingapp
    and another on http://notworkingapp.  The email to http://notworkingapp will sit in the drop folder, while the one to http://workingapp will be processed correctly.  In addition, the ULS log on WFE1 indicates an attempt to process the file fails.
     So clearly, the timer job on WFE1 is running and attempting to process the file.  For kicks, I disabled the service on WFE2 and WFE3, but with no change in the behavior.
    WRT to #1, I have done this already (as noted in the original post).  I can remove an alias from http://workingapp and place it on http://nonworkingapp and it is not processed.  If I return it to http://workingapp it is processed.  In other
    words, I go into Library Settings -> Incoming Email for a working library, and copy the alias, then disable incoming email for that library.  I then go to Library Settings -> Incoming Email for a non-working library, enable incoming email, and paste
    the alias.  Once done, emails sent to the alias are not processed.  I then do the reverse, and it works again.
    On #2, I have already tried multiple libraries on http://nonworkingapp (also as noted in the original post).
    In my environment, incoming email does not work for any library on http://nonworkingapp, but does work for any library on http://workingapp.  Troubleshooting listed above has ruled out any problem with basic mail server configuration or library settings
    - the problem is bound to http://nonworkingapp
    I'm not sure what you mean by "steps to reproduce the issue".  If I knew that, I would probably be able to solve the issue.  The best I could come up with to describe the situation would be:
    Set up SP 2010 in a three-node configuration with multiple web apps
    Enable incoming email and confirm it works
    Migrate to a SP2013 SP1 farm in a three node configuration.
    Enable a new email alias for a library
    Observe that it doesn't work for one web application.
    Obviously, it's pretty unlikely that attempting that in a lab would actually have the same result.

  • Clob is not working for bulk data files in PL/SQL XML program

    Hi Odie,
    we took your help to fix the our issue before
    "https://forums.oracle.com/forums/thread.jspa?threadID=2238458&tstart=105"
    working fine for : program is working for smaller size data.
    Issue : now we have problem with the largr size data .
    getting the below error:
    Arguments
    P_dir_name='/tmp'
    P_file_name='CCBGO.COLO_CNG.RESPONSES.20120802.00054131826'
    Environment will now switch to UTF-8 code-set.
    Parts of this log file may not display correctly
    as a result. This is an expected behavior.
    XML_REPORTS_XENVIRONMENT is :
    /apps/applmgr/product/OFDEV/ofdevora/806/guicommon6/tk60/admin/Tk2Motif_UTF8.rgb
    XENVIRONMENT is set to /apps/applmgr/product/OFDEV/ofdevora/806/guicommon6/tk60/admin/Tk2Motif_UTF8.rgb
    Current NLS_LANG and NLS_NUMERIC_CHARACTERS Environment Variables are :
    American_America.UTF8
    stat_low = 8B
    stat_high = 0
    emsg:was terminated by signal 11
    Appreciated for your earlier support.
    Kindly suggest .
    Many Thanks,
    Ramesh.

    Thanks ALex,
    your are true it is concurrent program error ,
    but it is working for small amount of data and generating the output and it is not working for larger data.
    i have placed the code which i have used kindly suggest where i am going wrong.
    i am calling the .rdf through the concurrent program, i've used the below query in RDF
    select
    BATCHHEADER
    ,BATCHTRAILER
    ,RqUID
    ,Severity
    ,PmtRefId
    ,StatusDesc
    ,ErrorDesc
    ,AsOfDate
    ,AsOfTime
    ,RqUID1
    ,SPRefId
    from table(CL_CXFRFXFH_PKG.rcacknowledgments(:P_dir_name,:P_file_name));
    kindly find the below code for the package CL_CXFRFXFH_PKG.
    ==========================
    CREATE OR REPLACE package body APPS.CL_CXFRFXFH_PKG is
    function rcacknowledgments (p_directory in varchar2, p_filename in varchar2)
    return TRecordTable pipelined
    is
    nb_rec number := 1;
    tmp_xml clob;
    tmp_file clob;
    rec TRecord;
    begin
    dbms_lob.createtemporary(tmp_file, true);
    tmp_file := dbms_xslprocessor.read2clob(p_directory, p_filename);
    rec.BATCHHEADER := regexp_replace(tmp_file, '.*<BATCHHEADER>(.*)</BATCHHEADER>.*', '\1', 1, 1, 'n');
    rec.BATCHTRAILER := regexp_replace(tmp_file, '.*<BATCHTRAILER>(.*)</BATCHTRAILER>.*', '\1', 1, 1, 'n');
    loop
    tmp_xml := regexp_substr(tmp_file, '<\?xml[^?]+\?>\s*<([^>]+)>.*?</\1>', 1, nb_rec, 'n');
    exit when length(tmp_xml) = 0;
    --dbms_output.put_line(tmp_rec);
    nb_rec := nb_rec + 1;
    select RqUID, Severity, PmtRefId, StatusDesc, ErrorDesc, AsOfDate, AsOfTime, RqUID1, SPRefId
    into rec.RqUID
    , rec.Severity
    , rec.PmtRefId
    , rec.StatusDesc
    , rec.ErrorDesc
    , rec.AsOfDate
    , rec.AsOfTime
    , rec.RqUID1
    , rec.SPRefId
    from xmltable(
    '/CMA/BankSvcRq' passing xmltype(tmp_xml)
    columns RqUID varchar2(3000) path 'RqUID'
    , Severity varchar2(3000) path 'XferAddRs/Status/Severity'
    , PmtRefId varchar2(3000) path 'XferAddRs/Status/PmtRefId'
    , StatusDesc varchar2(3000) path 'XferAddRs/Status/StatusDesc'
    , ErrorDesc varchar2(3000) path 'XferAddRs/Status/ErrorDesc'
    , AsOfDate varchar2(3000) path 'XferAddRs/Status/AsOfDate'
    , AsOfTime varchar2(3000) path 'XferAddRs/Status/AsOfTime'
    , RqUID1 varchar2(3000) path 'XferAddRs/RqUID'
    , SPRefId varchar2(3000) path 'XferAddRs/SPRefId'
    pipe row ( rec );
    end loop;
    dbms_lob.freetemporary(tmp_file);
    return;
    end;
    end;
    ============================================
    Many Thanks,
    Ramesh.

  • Bookmarks not working in multi-document PDF application

    Why are bookmarks not working in multi-document PDF application when uploaded to the web? We created a multi-document PDF application. All bookmarks and links work on our systems. All work on the customer's system. They do not work when uploaded to the customers website. Their IT department says its an issue of relative vs. absolute addressing. We've created applications like this for years without running into this issue. Can't find anything about it in Acrobat Help. Can anyone help or lead me to help? Thx much, Sandy

    Have you tried opening the file in your browser to see if the bookmarks are working?  To open the file in your browser you need to do this:
    1) Launch your favorite browser;
    2) File >> Open >> Select your pdf file
    See this picture to see what I am talking about.  You might need to click on it to magnify it:
    Good luck.

  • What's This Help not working for one entry in each header file

    I have a large RoboHelp project that I have imported into Version 8 from a previous version. Prior to the import into Version 8, all of the What's This Help in the project was working perfectly; now, post-import, I have a problem.
    Firstly, some background information.
    My project contains a large number of individual header (.H) files, one for each dialog within the software. These header files, which have been generated and provided by our developers, contain one entry for each field on the dialog to which the header file relates. The header files are all contained within a \HTML Topics\Fields\ folder (going from the root of my Help project).
    Each header file has a corresponding text (.TXT) file. These text files contain entries that correspond to the entries in the relevant header file. The text files are also contained within the \HTML Topics\Fields\ folder.
    Below is an example of the contents of a header file:
    #define IDH_HIERARCHY_APPEARANCE_HIEARCHY_LIST          16811
    #define IDH_HIERARCHY_APPEARANCE_ADD_APPEARANCE         16812    
    #define IDH_HIERARCHY_APPEARANCE_REMOVE_APPEARANCE      16813
    Below is the contents of the corresponding text file:
    .topic IDH_HIERARCHY_APPEARANCE_ADD_APPEARANCE
    Click this button to add a new row of hierarchical appearance settings to the grid.
    .topic IDH_HIERARCHY_APPEARANCE_HIEARCHY_LIST
    Use this grid to define hierarchy appearance settings. Each row in the grid represents a level of the hierarchy. For example, the appearance settings you define for the first row apply to the top level of hierarchy, the settings you define for the second row apply to the second level, and so on.
    .topic IDH_HIERARCHY_APPEARANCE_REMOVE_APPEARANCE
    Click this button to delete the selected row of hierarchical appearance settings from the grid.
    The What's This Help that was part of the original project still works perfectly. However, after upgrading the project to RoboHelp Version 8, I have had to update the project to reflect changes to the software. As part of this work, I have imported some new header files and updated some existing ones - and edited the corresponding text files accordingly.
    The What's This Help that is covered by the header files that I have imported since the upgrade to RoboHelp Version 8 does not work correctly; in each case, the What's This Help does not work for whichever field appears at the top of the appropriate text file. The position of the entry in the corresponding header file does not make a difference.
    If I manually edit a text file to move a different entry to the top then recompile the Help project, the What's This Help does not work for the field that now appears at the top of the text file - and the What's This Help for the field that used to appear at the top of the text file now works.
    I've tried everything I can think of to fix this, but nothing has worked. It seems as if there is a problem in the way RoboHelp is compiling the header and text files.
    If I use Microsoft HTML Help Workshop to decompile the CHM file, then view the contents of the resulting, decompiled text files, the affected files appear as follows:
    .topic IDH_HIERARCHY_APPEARANCE_ADD_APPEARANCE
    Click this button to add a new row of hierarchical appearance settings to the grid.
    .topic 16811
    Use this grid to define hierarchy appearance settings. Each row in the grid represents a level of the hierarchy. For example, the appearance settings you define for the first row apply to the top level of hierarchy, the settings you define for the second row apply
    to the second level, and so on.
    .topic 16813
    Click this button to delete the selected row of hierarchical appearance settings from the grid.
    Note how the entry at the top - which relates to the What's This Help that doesn't work - appears differently to the other entries which do work. The name of the ID appears after ".topic" rather than the appropriate ID number.
    Any help that anyone can provide me with would be very much appreciated.
    Thank you,
    Mark

    Its working now. We just kept trying to reinstall the tools and restarting indesign. On the 4th time the buttons started working. I can't explain why it finally worked, just that it is working now.

  • Drill down is not working for Pivot tables,but working for chart

    I have two reports and trying to navigate betwen summary report to detail report. But details report is displaying all the records .The filter condition is not working and displaying all the filters .I have Case statement in my filter.But the summary report column where the filter condition is applied is aggregated in the RPD level. Does this might be the reason ?. Is it passing different type of data type to details report ?. The filter condition is not working for Pivot table .But Chart is working fine and displaying the only selected records based on the filter condition.
    Please help me with the below issue.

    Hi sil174sss,
    Per my understanding you are experiencing the issue with the excel report which have add the drill down action, after export to excel only the expanded nodes included and the collapsed nodes is not shown, right?
    Generally, if we expand the nodes before export to excel then the excel will display the expanded details row and keep collapsed the details row which haven't expand, but we have the toggle "+","-" on the left of the Excel to help
    control the expand and collapse, when you click the "+" you can expand the collapsed notes to see the details rows.
    I have tested on my local environment with different version of SSRS and can always see the "+","-" as below:
    On the Top left corner you can find the "1","2", this help to control the "Collapse All" and "Expand All".
    If you can't see the "+","-" in the excel, the issue can be caused by the Excel version you are currently using, and also excel have limit support of this, please provide us the Excel version information and the SSRS version. You
    can reference to this similar thread:
    lost collapsing columns when export to excel
    Please try to export other drill down report to excel and check if they work fine, if they did, the issue can be caused by the drill down action you have added in this report is not correctly, if possible, please try to redesign the report.
    Article below about how to add  Expand/Collapse Action to an Item for your reference:
    http://msdn.microsoft.com/en-us/library/dd220405.aspx
    If your problem still exists, please feel free to ask
    Regards
    Vicky Liu

Maybe you are looking for

  • Importing MP4 format into Imovie

    I have just purchase a New HD video camera which seems to record in MP4 format, which shows an error message when I try to import into Imovie (an error occurred during import) my previous camera recorded in avi format, which did not create a problem.

  • How to restrict to process a File until another File gets processed

    Hi Gurus, we have a sceario in our system where PI system picks unicode Text files which has product and Forecast data information which is also a Flat File (unicode Text) and updates in SNP System. For updating forecast information we need to have p

  • Web Services with complext objects as method parameters

    Can anyone point me to an example of web services that accept complex objects as parameters, using annotations? Appreciate it.

  • E72 waiting on gps....

    Hi, i'm from belgium and i have a problem with my gps on my nokia e72 ovi map sis free but it takes ages to find a suitable satelite for my gps... after 1hour it still says waiting on gps... does anyone have a clue what i did wrong or what went wrong

  • Join MARA with MCSHIERB

    Hi, I need to join the dictionary tables MARA and MCSHIERB to create lists of materiales for output in .txt files. My problem is finding a referencebetween the tables. I need to select MARA-MTART MCSHIERB-NAME               where MARA-MTART = 'ZPAC'.