Setting up haskell

I am a new Arch user, and I'm trying to setup a haskell dev environment, but I'm running into a few problems.  In most other distributions I would install the latest haskell platform, but I can't seem to find it.  I see ghc as well as a few other haskell packages, but not the platform meta-package.  According to the wiki, this should be in [extra] but I can't find it there.  Perhaps the wiki is out-of-date?  The only thing I see is an orphaned package in the AUR that people are having difficulty installing.  Surely this can't be what I'm after, can it?
I tried to educate myself by reading from the Arch Haskell resources, but they are not very newbie friendly.  I added the [haskell] repo, but still can't find a haskell-platform package (2012.2.0.0, or any version for that matter) anywhere.  Are there instructions anywhere for setting up the haskell platform on Arch?
Last edited by Xitup (2012-08-26 00:46:40)

I tried installing other packages that compromise the haskell-platform but I'm running into problems.
pacman -S haskell-cgi
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: haddock: requires haskell-xhtml=3000.2.1-1
:: xmonad: requires haskell-mtl=2.1.1-1
I'm confused by your suggestion bernarcher.  It is precisely because I don't know the information that I went to the wiki in the first place.  I would gladly update it if I knew any of the answers myself.  Is it just a clever way of you telling me to figure it out for myself?  Certainly once I am more comfortable (and knowledgeable) I will do my best to contribute, but for now it would just be the blind leading the blind.  I was hoping to appeal to the people who already know what's going on to enlighten me.

Similar Messages

  • Why C# is not statically typed but F# and Haskell are?

    There was a talk given by Brian Hurt about advantages and disadvantages of static typing.
    Brian said that by static typing he don't mean C#, but F# and Haskell.
    Is it because of dynamic keyword added
    to C#-4.0? But this feature is relatively rarely useful. By the way, there are ⊥ and unsafeCoerse in
    Haskell which obviously are not the same, but something that could blown your head off in runtime similarly like exception thrown as a result of dynamic.
    Finally, why F# and Haskell could be named a statically typed languages and C# couldn't?

    I'm addressing the overlap between Haskell and F#'s type systems. The part they share is known sometimes as System F. F# by necessity provides bits and pieces of C#'s type system, but this isn't what the speaker was talking about.
    Both C# and Haskell/F# are statically typed, but they're two different flavors.
    Subtyping
    Specifically, C# is a statically typed language with subtyping. This means that if you look at the typing rules for C# there's one like
    Env |- x : T, T' <: T
    Env |- x : T'
    Which means that any well typed term has more than one potential type. This in not the case in (vanilla) Haskell or F#. Every type has a single most general type, a principal type. This has a few benefits like total type inference.
    Expressions Everywhere
    Besides this, Haskell and F# have a greater emphasis on expressions, expressions have types, but statements don't. This means that in C#, the compiler is checking less of your code, because less of your code has types. In Haskell, everything has a real, checkable
    type.
    In substantive terms, every single node on a Haskell AST has a type or kind (or sort). The same cannot be said of a C# one.
    Sum Types
    Beyond this, Haskell and F# have what are known as sum types.
    data Bool = True | False
    This is how a boolean is defined in Haskell. This provides a few different guarantees than in C#. For example, when there are a discrete number of things in C#, like say, an AST. We can model this with an inheritance hierarchy, but these are open. Anyone can
    come along and add something to it. We can use an Enum,
    but then there's no sane way to attach data to each tag uniformly. This is what's called a tagged union, and it's up to you to implement/use it correctly, the compiler ain't gonna help.
    This makes it very hard to ensure that we've covered all possible nodes of an AST. For example, say you have a function
    doStuff :: AST -> AST
    doStuff (SomeExpr ..) = ...
    doStuff (SomeStatement ..) = ...
    --// doStuff (SomeIf ...) = Oh noes, we forgot a node
    The compiler can warn you because it can prove exactly how many nodes there are, ever. In C#, the equivalent would have to be done with downcasting, and then, since the set of nodes in our hierarchy is open, there's no way to issue compile time warnings.
    A company, Jane Street, raves about how useful this feature is in their large OCaml code base. Watch a few of their talks,
    they talk quite a bit about how using OCaml impacts them in the Real World.
    Soapbox
    Now I've outlined quite a few differences over System F over many mainstream type systems, but they're all still static type systems. It does bother me when people call Java/C#/C++ "not statically typed" they are. And they certainly give you
    more compile time guarantees than say, Python. So it's a bit unfair to dismiss them out right.

  • /usr/share/haskell/ and ghc-pkg list --user

    Here goes :  was bored and thought of Space Invaders , hadn't played that in a while so offs I go to find , (AUR) , found it and thought alright , coupla games and call it a night. Well I'm strictly Newbie and sure enough haskell , ghc, haskell-hgl ? , flashed up and I naively thought upgrade ? , why not - Space Invaders right ?
    Well this showed ;
    All cabalized and yaourt-installed packages need to be reinstalled now.
    ==> See /usr/share/haskell/ and ghc-pkg list --user for a tentative list of affected packages.
    I thought , ok , I can deal with this . So off to find above mentioned found it but couldn't run it ? , . O K looked for aforementioned pkg list - no go . tried to downgrade and got this ;
    yaourt -Su --downgrade haskell-cabel
    ==> Downgrading packages
    No package to downgrade
      So offs I go to var /packman/pkg , thats were I found ghc-6.10.4-1-x86_64.pkg.tar.gz and haskell-x11-1.4.5-2-x86_64.pkg.tar.gz  and looked for older ones , no go . Found older ones but i couldn't fix it , not much on Google and found 1 post here  , but didn't make a lot of since to me .   Affected pkg.'s, ( so far ) , claws won't open and no icon for pidgin when running , no mail at all .   
    Excuse the infrequent postings , hey I 'm running Arch and most always can find an answer by searching but must admit I's hit a wall and dread the thought of losing Claws and the E-Mail that is in it . This is probably a simple fix so I Thank You all in advance .
    sudo pacman -U ghc-6.10.4-1-x86_64.pkg.tar.gz-ghc-6.8.2-2x86_64.pkg.tar.gz
    Password:
    loading package data...
    error: 'ghc-6.10.4-1-x86_64.pkg.tar.gz-ghc-6.8.2-2x86_64.pkg.tar.gz': cannot open package file
    wesley ~ $ sudo pacman -U ghc-6.10.4-1-x86_64.pkg.tar.gz -ghc-6.8.2-2x86_64.pkg.tar.gz
    pacman: invalid option -- '-'
    wesley ~ $ sudo pacman -U ghc-6.10.4-1-x86_64.pkg.tar.gz - ghc-6.8.2-2x86_64.pkg.tar.gz
    loading package data...
    error: 'ghc-6.10.4-1-x86_64.pkg.tar.gz': cannot open package file
    wesley ~ $ sudo pacman -U ghc-6.10.4-1-x86_64.pkg.-ghc-6.8.2-2x86_64.pkg.tar.gz
    loading package data...
    error: 'ghc-6.10.4-1-x86_64.pkg.-ghc-6.8.2-2x86_64.pkg.tar.gz': cannot open package file
    wesley ~ $ pacman -U ghc-6.10.4-1-x86_64.pkg.-ghc-6.8.2-2x86_64.pkg.tar.gzWed Sep 16 15:05:42 CDT 2009
    error: you cannot perform this operation unless you are root.
    wesley ~ $
    Thanks
    Did a little more research and not to sure if it had anything to do with the "game and/or Haskell " , don't know .But reread the Wiki Downgrade and came up with this . 
    http://wiki.archlinux.org/index.php/Downgrade_packages
    The package ,libldap-2.3.43-3-x86_64.pkg.tar.gz ,  is sitting on desktop and the one I've installed is  2.4.18-1 so now acording to the wiki would  ; pacman -U pkgname-olderpkgver.pkg.tar.gz.  , be
    wrote as such -
       pacman -U libldap-2.418-1-libldap-2.3.43-3-x86_64.pkg.tar.gz
        or does the package have to be some where else ?  Still learning here and downgrading seems like a good deal ! Also would it resurrect Claws without loss of E-Mail ?
    There was this filed/reported , on Google : http://tinyurl.com/qwjbtq
    which led me to here :
    http://bugs.archlinux.org/task/16217
    and
    Found package here :
    http://www.schlunix.org/archlinux/current/os/x86_64/
    Last edited by wesley_of_course (2009-09-16 23:23:30)

    Mr.Elendig wrote:1. you are not typing the package name correctly, please use tab completion
    2. just reinstall any cabalized haskell packages that you might have installed.
    Thank You Mr.Elendig for your response ! 
    wesley ~ $ yaourt -Q claws-mail
    Error: PACMANBIN: /usr/bin/pacman-color is incorrect
    /usr/bin/pacman-color no recognized in config file
    ==> List all installed packages
    testing/claws-mail 3.7.2-3
    wesley ~ $ ghc-pkg list --user
    /home/wesley/.ghc/x86_64-linux-6.10.4/package.conf:
    wesley ~ $ gedit usr/share/haskell/
    /usr/lib/gedit-2/plugins/auto_completion.py:51: Warning: gsignal.c:2387: instance `0x1d86000' has no handler with id `1745'
    view.disconnect(handler_id)
    wesley ~ $ ghc-pkg list --user wesley
    /home/wesley/.ghc/x86_64-linux-6.10.4/package.conf:
    wesley ~ $ yaourt -Q libldap
    Error: PACMANBIN: /usr/bin/pacman-color is incorrect
    /usr/bin/pacman-color no recognized in config file
    ==> List all installed packages
    core/libldap 2.4.18-1
    Claws is updated , but can't find the list , ( ghc-pkg list --user ) , I think Haskell probably needs to be configured and don't have a clue .
                     Shaman icon , when running ,  isn't visible  nor Pidgin ! Use System Monitor to kill it but Pidgin shuts down when window is closed , whats in common with the two and not others , is it still related to the
    Haskell install ? Now the spam icon in Claws is greyed out too .
                      Thanks again for helping out . edit ; forgot to mention running
    locate ghc-pkg list wesley
    and it came back with a slew of apps., !? can't believe they all need re-installed , maybe base packages for them will reinstall what it wants to set it straight ????
    Last edited by wesley_of_course (2009-09-28 02:47:07)

  • GHC , haskell-x11, xmonad etc issues.

    Hi,
    I upgraded ghc yesterday (or the day before, not sure) and when rebuilding xmonad I have some issues.
    When upgrading ghc I had this message:
    Proceed with installation? [Y/n] y
    checking package integrity...
    (1/1) checking for file conflicts [##############################################] 100%
    ==> Unregistering cabalized packages...
    ==> Done.
    (1/1) upgrading ghc [##############################################] 100%
    ==> All cabalized and yaourt-installed packages need to be reinstalled now.
    ==> See /usr/share/haskell/ and ghc-pkg list --user for a tentative list of affected packages.
    I assume reinstalling them using pacman/yaourt is sufficient. When installing haskell-x11 for instance I have these messages:
    Targets (1): haskell-x11-1.4.5-1
    Total Download Size: 0.00 MB
    Total Installed Size: 3.96 MB
    Proceed with installation? [Y/n] y
    checking package integrity...
    (1/1) checking for file conflicts [##############################################] 100%
    ghc-pkg: cannot find package X11-1.4.5
    error: scriptlet failed to execute correctly
    (1/1) upgrading haskell-x11 [##############################################] 100%
    Reading package info from stdin ... done.
    X11-1.4.5: dependency base-3.0.3.0 doesn't exist (use --force to override)
    error: scriptlet failed to execute correctly
    If you like this package, please install aurvote
    and vote for its inclusion/keeping in [community]
    As a consequence haskell-x11 is not available when recompiling xmonad. I have similar messages for xmonad:
    Targets (1): xmonad-0.8.1-1
    Total Download Size: 0.00 MB
    Total Installed Size: 2.93 MB
    Proceed with installation? [Y/n] y
    checking package integrity...
    (1/1) checking for file conflicts [##############################################] 100%
    ghc-pkg: cannot find package xmonad-0.8.1
    error: scriptlet failed to execute correctly
    (1/1) upgrading xmonad [##############################################] 100%
    Reading package info from stdin ... done.
    xmonad-0.8.1: dependency X11-1.4.5 doesn't exist (use --force to override)
    xmonad-0.8.1: dependency base-3.0.3.0 doesn't exist (use --force to override)
    xmonad-0.8.1: dependency containers-0.2.0.0 doesn't exist (use --force to override)
    xmonad-0.8.1: dependency directory-1.0.0.2 doesn't exist (use --force to override)
    xmonad-0.8.1: dependency process-1.0.1.0 doesn't exist (use --force to override)
    xmonad-0.8.1: dependency unix-2.3.1.0 doesn't exist (use --force to override)
    error: scriptlet failed to execute correctly
    If you like this package, please install aurvote
    and vote for its inclusion/keeping in [community]
    When I downgrade to ghc in extra and reinstall these packages they work fine, and don't have the above dependency error messages. The only error message I keep having is:
    error: scriptlet failed to execute correctly
    But this might have been there before. I have no experience in actually using ghc, so maybe I'm missing something?

    It's the right idea, but technically not feasible currently. [community] is maintained by a different set of people than [core], [extra] and [testing] (not only that, they are technically implemented differently at the moment, but devs are working on that about now). So only packages from [core] and [extra] can go through [testing] at present. Hence there is always only one version of a package in [community], and naturally it needs to be in sync with [core/extra], not [testing]. So currently it's assumed that people that use testing are technically skilled enough to know (and know how) to rebuild some community packages that need it.

  • Building Xmonad 0.4.1 with GHC 6.8.1 and haskell-X11 1.3.0 fails

    I've tried to build Xmonad 0.4.1, but it fails with the following output:
    XMonad.hs:42:17:
    Could not find module `Data.Set':
    it is a member of package containers-0.1.0.0, which is hidden
    After a bit of research I discovered that it has something to do with Cabal, but I can't understand how to fix it? Anyone else encountered this and anyone with a possible solution?

    ashren: using your suggestion, I made a patch and modified the AUR PKGBUILD:
    PKGBUILD:
    pkgname=xmonad
    pkgver=0.4.1
    pkgrel=2
    pkgdesc="A lightweight X11 tiled window manager written in Haskell"
    arch=(i686 x86_64)
    url="http://xmonad.org/"
    license=('custom:BSD3')
    depends=('gmp' 'libxext' 'dmenu')
    makedepends=('ghc' 'haskell-x11>=1.3.0')
    source=(http://hackage.haskell.org/packages/archive/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz xmonad-0.4.1-containers-fix.diff)
    build() {
    cd $startdir/src/$pkgname-$pkgver
    patch -p1 < ../xmonad-0.4.1-containers-fix.diff
    runhaskell Setup.lhs configure --ghc --prefix=/usr || return 1
    # configuration handling stuff
    if [ -f ../../Config.hs ]; then
    msg "Custom configuration detected"
    msg2 "copying config.h to build directory"
    cp ../../Config.hs Config.hs
    fi
    # Maybe move this to function ?
    msg "Do you want to change configuration before compilation ? [y/N] "
    read answerpkgname=xmonad
    pkgver=0.4.1
    pkgrel=2
    pkgdesc="A lightweight X11 tiled window manager written in Haskell"
    arch=(i686 x86_64)
    url="http://xmonad.org/"
    license=('custom:BSD3')
    depends=('gmp' 'libxext' 'dmenu')
    makedepends=('ghc' 'haskell-x11>=1.3.0')
    source=(http://hackage.haskell.org/packages/archive/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz xmonad-0.4.1-containers-fix.diff)
    build() {
    cd $startdir/src/$pkgname-$pkgver
    patch -p1 < ../xmonad-0.4.1-containers-fix.diff
    runhaskell Setup.lhs configure --ghc --prefix=/usr || return 1
    # configuration handling stuff
    if [ -f ../../Config.hs ]; then
    msg "Custom configuration detected"
    msg2 "copying config.h to build directory"
    cp ../../Config.hs Config.hs
    fi
    # Maybe move this to function ?
    msg "Do you want to change configuration before compilation ? [y/N] "
    read answer
    answer=$(echo $answer | tr [:upper:] [:lower:])
    if [ $answer = "y" -o $answer = "yes" ]; then
    # maybe user prefer something other than vim ?
    if [ x"$EDITOR" != x"" ]; then
    $EDITOR Config.hs
    else
    vi Config.hs
    fi
    # save modified config for future builds
    cp -f Config.hs ../../Config.hs
    fi
    runhaskell Setup.lhs build || return 1
    runhaskell Setup.lhs copy --destdir=$startdir/pkg
    runhaskell util/GenerateManpage.hs
    install -D -m644 LICENSE $startdir/pkg/usr/share/licenses/$pkgname/BSD3
    install -D -m644 man/xmonad.1 $startdir/pkg/usr/man/man1/xmonad.1
    answer=$(echo $answer | tr [:upper:] [:lower:])
    if [ $answer = "y" -o $answer = "yes" ]; then
    # maybe user prefer something other than vim ?
    if [ x"$EDITOR" != x"" ]; then
    $EDITOR Config.hs
    else
    vi Config.hs
    fi
    # save modified config for future builds
    cp -f Config.hs ../../Config.hs
    fi
    runhaskell Setup.lhs build || return 1
    runhaskell Setup.lhs copy --destdir=$startdir/pkg
    runhaskell util/GenerateManpage.hs
    install -D -m644 LICENSE $startdir/pkg/usr/share/licenses/$pkgname/BSD3
    install -D -m644 man/xmonad.1 $startdir/pkg/usr/man/man1/xmonad.1
    And you also need this file: xmonad-0.4.1--containers-fix.diff
    Only in xmonad-0.4.1-new: dist
    Common subdirectories: xmonad-0.4.1/man and xmonad-0.4.1-new/man
    Common subdirectories: xmonad-0.4.1/tests and xmonad-0.4.1-new/tests
    Common subdirectories: xmonad-0.4.1/util and xmonad-0.4.1-new/util
    diff -up xmonad-0.4.1/xmonad.cabal xmonad-0.4.1-new/xmonad.cabal
    --- xmonad-0.4.1/xmonad.cabal 2007-11-02 17:31:08.000000000 -0500
    +++ xmonad-0.4.1-new/xmonad.cabal 2007-11-15 13:00:28.041790818 -0600
    @@ -17,7 +17,7 @@ license: BSD3
    license-file: LICENSE
    author: Spencer Janssen
    maintainer: [email protected]
    -build-depends: base>=2.0, mtl>=1.0, unix>=1.0, X11==1.3.0
    +build-depends: base>=2.0, mtl>=1.0, unix>=1.0, X11==1.3.0, containers
    extra-source-files: README TODO tests/loc.hs tests/Properties.hs man/xmonad.1.in
    Config.hs-boot util/GenerateManpage.hs man/xmonad.1 man/xmonad.html

  • Stumpwm and stability in an office setting

    I have used awesome (the window manager) for a fairly long time, and while it is quite good constantly changing my config file is not very pleasant. I use emacs a lot and I am fairly competent with lisp so I thought of using stumpwm. I have also considered using Xmonad although the prospect of working haskel is kind of pushing me away from that (being that I have no experience with Haskel).
    From what I hear stumpwm used to be fairly unstable, lots of crashing etc. Has this improved? Is it stable enough to use as a main window manager in an office setting? If not I guess I will go with Xmonad as from what I hear it is much more stable.
    Thanks for any help provided,
    Kruppe

    Hm...
    I think it's not a good idea to use Stumpwm in an office setting. It's really cool, but far from stable.
    If you really want to use it, I'd recommend using clisp-new-clx (AUR). SBCL crashes more often, at least on my PC. (That's why I made the PKGBUILD )
    Avoid using the mode-line ! Afaik it's responsible for most crashes.
    P.S.: Do I have to mention that you should use the stable release ? Git-version can be a pain in the......
    Last edited by Theomachos (2009-08-20 20:49:35)

  • Xorg 1.10.1 no longer affected by manual DPI setting

    I use my 23 inch 1920x1080 monitor as TV also. As this means I sit rather far from it, I manually set DPI quite low to enlarge windows and fonts by default. However after the last upgrade, which brought Xorg 1.10 and Gnome 3, Xorg seems to no longer be affected by my setting DPI in xorg.conf. The logs show that the value is read, and xdpyinfo shows the DPI I have set manually, but this setting no longer seems to affect any windows or fonts.
    The DPI is set via the nvidia driver. Relevant parts of xorg.conf and the full Xorg.0.log are attached.
    Does anyone know what could have caused this?
    xorg.conf:
    Section "Monitor"
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "Unknown"
    HorizSync 28.0 - 33.0
    VertRefresh 43.0 - 72.0
    Option "DPMS"
    Option "DPI" "60x60"
    EndSection
    Xorg.0.log:
    [ 45267.074]
    X.Org X Server 1.10.1
    Release Date: 2011-04-15
    [ 45267.074] X Protocol Version 11, Revision 0
    [ 45267.074] Build Operating System: Linux 2.6.38-ARCH x86_64
    [ 45267.074] Current Operating System: Linux norstaurar 2.6.38-ARCH #1 SMP PREEMPT Fri May 13 09:24:47 CEST 2011 x86_64
    [ 45267.074] Kernel command line: root=/dev/disk/by-uuid/41bd750d-271b-4392-898a-51e284889d43 ro
    [ 45267.074] Build Date: 16 April 2011 12:02:01PM
    [ 45267.074]
    [ 45267.074] Current version of pixman: 0.20.2
    [ 45267.074] Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
    [ 45267.074] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [ 45267.074] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Jun 3 10:40:17 2011
    [ 45267.074] (==) Using config file: "/etc/X11/xorg.conf"
    [ 45267.074] (==) Using config directory: "/etc/X11/xorg.conf.d"
    [ 45267.075] (==) ServerLayout "Layout0"
    [ 45267.075] (**) |-->Screen "Screen0" (0)
    [ 45267.075] (**) | |-->Monitor "Monitor0"
    [ 45267.075] (**) | |-->Device "Device0"
    [ 45267.075] (**) |-->Input Device "Keyboard0"
    [ 45267.075] (**) |-->Input Device "Mouse0"
    [ 45267.075] (==) Automatically adding devices
    [ 45267.075] (==) Automatically enabling devices
    [ 45267.075] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
    [ 45267.075] Entry deleted from font path.
    [ 45267.075] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
    [ 45267.075] Entry deleted from font path.
    [ 45267.075] (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
    [ 45267.075] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
    [ 45267.075] Entry deleted from font path.
    [ 45267.075] (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
    [ 45267.075] (==) FontPath set to:
    /usr/share/fonts/misc/,
    /usr/share/fonts/TTF/,
    /usr/share/fonts/Type1/
    [ 45267.075] (==) ModulePath set to "/usr/lib/xorg/modules"
    [ 45267.075] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
    [ 45267.075] (WW) Disabling Keyboard0
    [ 45267.075] (WW) Disabling Mouse0
    [ 45267.075] (II) Loader magic: 0x7d6fa0
    [ 45267.075] (II) Module ABI versions:
    [ 45267.075] X.Org ANSI C Emulation: 0.4
    [ 45267.075] X.Org Video Driver: 10.0
    [ 45267.075] X.Org XInput driver : 12.2
    [ 45267.075] X.Org Server Extension : 5.0
    [ 45267.076] (--) PCI:*(0:2:0:0) 10de:0848:1043:82f2 rev 162, Mem @ 0xfd000000/16777216, 0xf0000000/134217728, 0xfa000000/33554432, I/O @ 0x0000ec00/128, BIOS @ 0x????????/131072
    [ 45267.076] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
    [ 45267.076] (II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
    [ 45267.076] (II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
    [ 45267.076] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
    [ 45267.076] (II) "record" will be loaded by default.
    [ 45267.076] (II) "dri" will be loaded by default.
    [ 45267.076] (II) "dri2" will be loaded by default.
    [ 45267.076] (II) LoadModule: "dbe"
    [ 45267.077] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
    [ 45267.077] (II) Module dbe: vendor="X.Org Foundation"
    [ 45267.077] compiled for 1.10.1, module version = 1.0.0
    [ 45267.077] Module class: X.Org Server Extension
    [ 45267.077] ABI class: X.Org Server Extension, version 5.0
    [ 45267.077] (II) Loading extension DOUBLE-BUFFER
    [ 45267.077] (II) LoadModule: "extmod"
    [ 45267.077] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
    [ 45267.077] (II) Module extmod: vendor="X.Org Foundation"
    [ 45267.077] compiled for 1.10.1, module version = 1.0.0
    [ 45267.077] Module class: X.Org Server Extension
    [ 45267.077] ABI class: X.Org Server Extension, version 5.0
    [ 45267.077] (II) Loading extension MIT-SCREEN-SAVER
    [ 45267.077] (II) Loading extension XFree86-VidModeExtension
    [ 45267.077] (II) Loading extension XFree86-DGA
    [ 45267.077] (II) Loading extension DPMS
    [ 45267.077] (II) Loading extension XVideo
    [ 45267.077] (II) Loading extension XVideo-MotionCompensation
    [ 45267.077] (II) Loading extension X-Resource
    [ 45267.077] (II) LoadModule: "glx"
    [ 45267.077] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
    [ 45267.092] (II) Module glx: vendor="NVIDIA Corporation"
    [ 45267.092] compiled for 4.0.2, module version = 1.0.0
    [ 45267.092] Module class: X.Org Server Extension
    [ 45267.092] (II) NVIDIA GLX Module 270.41.19 Mon May 16 23:48:30 PDT 2011
    [ 45267.092] (II) Loading extension GLX
    [ 45267.092] (II) LoadModule: "record"
    [ 45267.092] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
    [ 45267.092] (II) Module record: vendor="X.Org Foundation"
    [ 45267.092] compiled for 1.10.1, module version = 1.13.0
    [ 45267.092] Module class: X.Org Server Extension
    [ 45267.092] ABI class: X.Org Server Extension, version 5.0
    [ 45267.092] (II) Loading extension RECORD
    [ 45267.092] (II) LoadModule: "dri"
    [ 45267.092] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
    [ 45267.092] (II) Module dri: vendor="X.Org Foundation"
    [ 45267.092] compiled for 1.10.1, module version = 1.0.0
    [ 45267.092] ABI class: X.Org Server Extension, version 5.0
    [ 45267.092] (II) Loading extension XFree86-DRI
    [ 45267.092] (II) LoadModule: "dri2"
    [ 45267.092] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
    [ 45267.092] (II) Module dri2: vendor="X.Org Foundation"
    [ 45267.092] compiled for 1.10.1, module version = 1.2.0
    [ 45267.092] ABI class: X.Org Server Extension, version 5.0
    [ 45267.093] (II) Loading extension DRI2
    [ 45267.093] (II) LoadModule: "nvidia"
    [ 45267.093] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
    [ 45267.093] (II) Module nvidia: vendor="NVIDIA Corporation"
    [ 45267.093] compiled for 4.0.2, module version = 1.0.0
    [ 45267.093] Module class: X.Org Video Driver
    [ 45267.094] (II) NVIDIA dlloader X Driver 270.41.19 Mon May 16 23:33:35 PDT 2011
    [ 45267.094] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
    [ 45267.094] (++) using VT number 8
    [ 45267.096] (II) Loading sub module "fb"
    [ 45267.096] (II) LoadModule: "fb"
    [ 45267.096] (II) Loading /usr/lib/xorg/modules/libfb.so
    [ 45267.097] (II) Module fb: vendor="X.Org Foundation"
    [ 45267.097] compiled for 1.10.1, module version = 1.0.0
    [ 45267.097] ABI class: X.Org ANSI C Emulation, version 0.4
    [ 45267.097] (II) Loading sub module "wfb"
    [ 45267.097] (II) LoadModule: "wfb"
    [ 45267.097] (II) Loading /usr/lib/xorg/modules/libwfb.so
    [ 45267.097] (II) Module wfb: vendor="X.Org Foundation"
    [ 45267.097] compiled for 1.10.1, module version = 1.0.0
    [ 45267.097] ABI class: X.Org ANSI C Emulation, version 0.4
    [ 45267.097] (II) Loading sub module "ramdac"
    [ 45267.097] (II) LoadModule: "ramdac"
    [ 45267.097] (II) Module "ramdac" already built-in
    [ 45267.097] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
    [ 45267.097] (II) Loading /usr/lib/xorg/modules/libwfb.so
    [ 45267.097] (II) Loading /usr/lib/xorg/modules/libfb.so
    [ 45267.097] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
    [ 45267.097] (==) NVIDIA(0): RGB weight 888
    [ 45267.097] (==) NVIDIA(0): Default visual is TrueColor
    [ 45267.097] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
    [ 45267.097] (**) NVIDIA(0): Option "DPI" "60x60"
    [ 45267.369] (II) NVIDIA(GPU-0): Display (Samsung SyncMaster (DFP-0)) does not support NVIDIA
    [ 45267.369] (II) NVIDIA(GPU-0): 3D Vision stereo.
    [ 45267.370] (II) NVIDIA(0): NVIDIA GPU GeForce 8300 (C77) at PCI:2:0:0 (GPU-0)
    [ 45267.370] (--) NVIDIA(0): Memory: 524288 kBytes
    [ 45267.370] (--) NVIDIA(0): VideoBIOS: 62.77.2f.00.00
    [ 45267.370] (--) NVIDIA(0): Interlaced video modes are supported on this GPU
    [ 45267.370] (--) NVIDIA(0): Connected display device(s) on GeForce 8300 at PCI:2:0:0
    [ 45267.370] (--) NVIDIA(0): Samsung SyncMaster (DFP-0)
    [ 45267.370] (--) NVIDIA(0): Samsung SyncMaster (DFP-0): 165.0 MHz maximum pixel clock
    [ 45267.370] (--) NVIDIA(0): Samsung SyncMaster (DFP-0): Internal Single Link TMDS
    [ 45267.372] (WW) NVIDIA(0): The EDID for Samsung SyncMaster (DFP-0) contradicts itself:
    [ 45267.372] (WW) NVIDIA(0): mode "720x480" is specified in the EDID; however, the
    [ 45267.372] (WW) NVIDIA(0): EDID's valid HorizSync range (27.000-81.000 kHz) would
    [ 45267.372] (WW) NVIDIA(0): exclude this mode's HorizSync (15.7 kHz); ignoring
    [ 45267.372] (WW) NVIDIA(0): HorizSync check for mode "720x480".
    [ 45267.372] (WW) NVIDIA(0): The EDID for Samsung SyncMaster (DFP-0) contradicts itself:
    [ 45267.372] (WW) NVIDIA(0): mode "720x576" is specified in the EDID; however, the
    [ 45267.372] (WW) NVIDIA(0): EDID's valid HorizSync range (27.000-81.000 kHz) would
    [ 45267.372] (WW) NVIDIA(0): exclude this mode's HorizSync (15.6 kHz); ignoring
    [ 45267.372] (WW) NVIDIA(0): HorizSync check for mode "720x576".
    [ 45267.375] (WW) NVIDIA(0): The EDID for Samsung SyncMaster (DFP-0) contradicts itself:
    [ 45267.375] (WW) NVIDIA(0): mode "720x480" is specified in the EDID; however, the
    [ 45267.375] (WW) NVIDIA(0): EDID's valid HorizSync range (27.000-81.000 kHz) would
    [ 45267.375] (WW) NVIDIA(0): exclude this mode's HorizSync (15.7 kHz); ignoring
    [ 45267.375] (WW) NVIDIA(0): HorizSync check for mode "720x480".
    [ 45267.376] (WW) NVIDIA(0): The EDID for Samsung SyncMaster (DFP-0) contradicts itself:
    [ 45267.376] (WW) NVIDIA(0): mode "720x576" is specified in the EDID; however, the
    [ 45267.376] (WW) NVIDIA(0): EDID's valid HorizSync range (27.000-81.000 kHz) would
    [ 45267.376] (WW) NVIDIA(0): exclude this mode's HorizSync (15.6 kHz); ignoring
    [ 45267.376] (WW) NVIDIA(0): HorizSync check for mode "720x576".
    [ 45267.402] (II) NVIDIA(0): Assigned Display Device: DFP-0
    [ 45267.402] (==) NVIDIA(0):
    [ 45267.402] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
    [ 45267.402] (==) NVIDIA(0): will be used as the requested mode.
    [ 45267.402] (==) NVIDIA(0):
    [ 45267.402] (II) NVIDIA(0): Validated modes:
    [ 45267.402] (II) NVIDIA(0): "nvidia-auto-select"
    [ 45267.402] (II) NVIDIA(0): Virtual screen size determined to be 1920 x 1080
    [ 45267.426] (**) NVIDIA(0): DPI set to (60, 60); computed from "DPI" X config option
    [ 45267.426] (--) Depth 24 pixmap format is 32 bpp
    [ 45267.426] (II) NVIDIA: Using 768.00 MB of virtual memory for indirect memory access.
    [ 45267.430] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
    [ 45267.430] (II) NVIDIA(0): may not be running or the "AcpidSocketPath" X
    [ 45267.430] (II) NVIDIA(0): configuration option may not be set correctly. When the
    [ 45267.430] (II) NVIDIA(0): ACPI event daemon is available, the NVIDIA X driver will
    [ 45267.430] (II) NVIDIA(0): try to use it to receive ACPI event notifications. For
    [ 45267.430] (II) NVIDIA(0): details, please see the "ConnectToAcpid" and
    [ 45267.430] (II) NVIDIA(0): "AcpidSocketPath" X configuration options in Appendix B: X
    [ 45267.430] (II) NVIDIA(0): Config Options in the README.
    [ 45267.431] (II) NVIDIA(0): Setting mode "nvidia-auto-select"
    [ 45267.472] (II) Loading extension NV-GLX
    [ 45267.508] (==) NVIDIA(0): Disabling shared memory pixmaps
    [ 45267.508] (==) NVIDIA(0): Backing store disabled
    [ 45267.508] (==) NVIDIA(0): Silken mouse enabled
    [ 45267.509] (**) NVIDIA(0): DPMS enabled
    [ 45267.509] (II) Loading extension NV-CONTROL
    [ 45267.510] (II) Loading extension XINERAMA
    [ 45267.510] (II) Loading sub module "dri2"
    [ 45267.510] (II) LoadModule: "dri2"
    [ 45267.510] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
    [ 45267.510] (II) Module dri2: vendor="X.Org Foundation"
    [ 45267.510] compiled for 1.10.1, module version = 1.2.0
    [ 45267.510] ABI class: X.Org Server Extension, version 5.0
    [ 45267.510] (II) NVIDIA(0): [DRI2] Setup complete
    [ 45267.510] (==) RandR enabled
    [ 45267.510] (II) Initializing built-in extension Generic Event Extension
    [ 45267.510] (II) Initializing built-in extension SHAPE
    [ 45267.510] (II) Initializing built-in extension MIT-SHM
    [ 45267.510] (II) Initializing built-in extension XInputExtension
    [ 45267.510] (II) Initializing built-in extension XTEST
    [ 45267.510] (II) Initializing built-in extension BIG-REQUESTS
    [ 45267.510] (II) Initializing built-in extension SYNC
    [ 45267.510] (II) Initializing built-in extension XKEYBOARD
    [ 45267.510] (II) Initializing built-in extension XC-MISC
    [ 45267.510] (II) Initializing built-in extension SECURITY
    [ 45267.510] (II) Initializing built-in extension XINERAMA
    [ 45267.510] (II) Initializing built-in extension XFIXES
    [ 45267.510] (II) Initializing built-in extension RENDER
    [ 45267.510] (II) Initializing built-in extension RANDR
    [ 45267.510] (II) Initializing built-in extension COMPOSITE
    [ 45267.510] (II) Initializing built-in extension DAMAGE
    [ 45267.512] (II) Initializing extension GLX
    [ 45267.586] (II) config/udev: Adding input device Power Button (/dev/input/event3)
    [ 45267.586] (**) Power Button: Applying InputClass "evdev keyboard catchall"
    [ 45267.586] (II) LoadModule: "evdev"
    [ 45267.586] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
    [ 45267.586] (II) Module evdev: vendor="X.Org Foundation"
    [ 45267.586] compiled for 1.10.0, module version = 2.6.0
    [ 45267.586] Module class: X.Org XInput Driver
    [ 45267.586] ABI class: X.Org XInput driver, version 12.2
    [ 45267.586] (II) Using input driver 'evdev' for 'Power Button'
    [ 45267.586] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
    [ 45267.586] (**) Power Button: always reports core events
    [ 45267.586] (**) Power Button: Device: "/dev/input/event3"
    [ 45267.605] (--) Power Button: Found keys
    [ 45267.605] (II) Power Button: Configuring as keyboard
    [ 45267.605] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input3/event3"
    [ 45267.605] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
    [ 45267.605] (**) Option "xkb_rules" "evdev"
    [ 45267.605] (**) Option "xkb_model" "evdev"
    [ 45267.605] (**) Option "xkb_layout" "se"
    [ 45267.636] (II) config/udev: Adding input device Video Bus (/dev/input/event1)
    [ 45267.636] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
    [ 45267.636] (II) Using input driver 'evdev' for 'Video Bus'
    [ 45267.636] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
    [ 45267.636] (**) Video Bus: always reports core events
    [ 45267.636] (**) Video Bus: Device: "/dev/input/event1"
    [ 45267.648] (--) Video Bus: Found keys
    [ 45267.648] (II) Video Bus: Configuring as keyboard
    [ 45267.648] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0A03:00/device:12/LNXVIDEO:00/input/input1/event1"
    [ 45267.648] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD)
    [ 45267.648] (**) Option "xkb_rules" "evdev"
    [ 45267.648] (**) Option "xkb_model" "evdev"
    [ 45267.648] (**) Option "xkb_layout" "se"
    [ 45267.650] (II) config/udev: Adding input device Power Button (/dev/input/event2)
    [ 45267.650] (**) Power Button: Applying InputClass "evdev keyboard catchall"
    [ 45267.650] (II) Using input driver 'evdev' for 'Power Button'
    [ 45267.650] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
    [ 45267.650] (**) Power Button: always reports core events
    [ 45267.650] (**) Power Button: Device: "/dev/input/event2"
    [ 45267.662] (--) Power Button: Found keys
    [ 45267.662] (II) Power Button: Configuring as keyboard
    [ 45267.662] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input2/event2"
    [ 45267.662] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
    [ 45267.662] (**) Option "xkb_rules" "evdev"
    [ 45267.662] (**) Option "xkb_model" "evdev"
    [ 45267.662] (**) Option "xkb_layout" "se"
    [ 45267.666] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/event5)
    [ 45267.666] (**) Logitech USB Receiver: Applying InputClass "evdev keyboard catchall"
    [ 45267.666] (II) Using input driver 'evdev' for 'Logitech USB Receiver'
    [ 45267.666] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
    [ 45267.666] (**) Logitech USB Receiver: always reports core events
    [ 45267.666] (**) Logitech USB Receiver: Device: "/dev/input/event5"
    [ 45267.675] (--) Logitech USB Receiver: Found keys
    [ 45267.675] (II) Logitech USB Receiver: Configuring as keyboard
    [ 45267.675] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:04.0/usb4/4-3/4-3:1.0/input/input5/event5"
    [ 45267.675] (II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: KEYBOARD)
    [ 45267.675] (**) Option "xkb_rules" "evdev"
    [ 45267.675] (**) Option "xkb_model" "evdev"
    [ 45267.675] (**) Option "xkb_layout" "se"
    [ 45267.676] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/event6)
    [ 45267.676] (**) Logitech USB Receiver: Applying InputClass "evdev pointer catchall"
    [ 45267.676] (**) Logitech USB Receiver: Applying InputClass "evdev keyboard catchall"
    [ 45267.676] (II) Using input driver 'evdev' for 'Logitech USB Receiver'
    [ 45267.676] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
    [ 45267.676] (**) Logitech USB Receiver: always reports core events
    [ 45267.676] (**) Logitech USB Receiver: Device: "/dev/input/event6"
    [ 45267.685] (--) Logitech USB Receiver: Found 12 mouse buttons
    [ 45267.685] (--) Logitech USB Receiver: Found scroll wheel(s)
    [ 45267.685] (--) Logitech USB Receiver: Found relative axes
    [ 45267.685] (--) Logitech USB Receiver: Found x and y relative axes
    [ 45267.685] (--) Logitech USB Receiver: Found absolute axes
    [ 45267.685] (--) Logitech USB Receiver: Found keys
    [ 45267.685] (II) Logitech USB Receiver: Configuring as mouse
    [ 45267.685] (II) Logitech USB Receiver: Configuring as keyboard
    [ 45267.685] (II) Logitech USB Receiver: Adding scrollwheel support
    [ 45267.685] (**) Logitech USB Receiver: YAxisMapping: buttons 4 and 5
    [ 45267.685] (**) Logitech USB Receiver: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
    [ 45267.685] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:04.0/usb4/4-3/4-3:1.1/input/input6/event6"
    [ 45267.685] (II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: KEYBOARD)
    [ 45267.685] (**) Option "xkb_rules" "evdev"
    [ 45267.685] (**) Option "xkb_model" "evdev"
    [ 45267.685] (**) Option "xkb_layout" "se"
    [ 45267.685] (II) Logitech USB Receiver: initialized for relative axes.
    [ 45267.685] (WW) Logitech USB Receiver: ignoring absolute axes.
    [ 45267.686] (**) Logitech USB Receiver: (accel) keeping acceleration scheme 1
    [ 45267.686] (**) Logitech USB Receiver: (accel) acceleration profile 0
    [ 45267.686] (**) Logitech USB Receiver: (accel) acceleration factor: 2.000
    [ 45267.686] (**) Logitech USB Receiver: (accel) acceleration threshold: 4
    [ 45267.686] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/mouse0)
    [ 45267.686] (II) No input driver/identifier specified (ignoring)
    [ 45267.687] (II) config/udev: Adding input device HDA Digital PCBeep (/dev/input/event4)
    [ 45267.687] (II) No input driver/identifier specified (ignoring)
    [ 45267.692] (II) config/udev: Adding input device PC Speaker (/dev/input/event0)
    [ 45267.692] (II) No input driver/identifier specified (ignoring)

    I seem to have been unclear in my original post. Setting it in Gnome 3 would all be fine and dandy, however although Gnome 3 was installed (upgraded from 2.x), I use fvwm. Gtk etc is still used but I don't see why upgrading a DE I don't use would impair another WM from using the X11 DPI settings. Also changing that setting in Gnome 3 does not affect neither the login screen (GDM) nor anything in fvwm.

  • Cannot send email from Iphone. A setting is off.

    What are the correct settings to send email from my aol account that's included in my I Cloud acct. any suggestions???? Thanks Sue

    Read this
    How do I set up AOL Mail on my iPhone or iPod Touch? - AOL Help

  • HOW TO SET UP PARTNER APPLICATION TO USE SSO OUTSIDE OF PORTAL

    If anyone knows how Portal switches context to run as the db user mapped to the lightweight schema and how it knows the db schema password please let me know.
    Should you have any queries please do not hesitate to contact me on 07775 896738.
    From document Oracle Portal Security Overview on PortalStudio.oracle.com:
    In Single Sign On mode (EnableSSO=Yes in the DAD), mod_plsql determines the name of the light-weight user and mapped database schema by calling
    WPG_SESSION_PRIVATE.GET_LW_USER and WPG_SESSION_PRIVATE.GET_DB_USER respectively.
    ** These calls are done using the Portal Schema (PORTAL30) and Portal schema password **
    mod_plsql then executes the procedure in the requested URL by using the N-Tier Authentication feature to connect to the database as the user returned from
    WPG_SESSION_PRIVATE.GET_DB_USER. ..... Note that N-Tier Authentication requires all schemas to be used for Portal user mappings to be granted 'connect
    through' privleges to the Portal schema (PORTAL30).
    The WWCTX packages are also used.
    So this is how it works with standard Portal
    - the document states that the WPG_SESSION_PRIVATE package is only accessible to the Portal schema
    - but I checked and it is also available to PORTAL30_SSO
    SQL> desc WPG_SESSION_PRIVATE
    PROCEDURE CREATE_SESSION
    Argument Name Type In/Out Default?
    P_COOKIE_NAME VARCHAR2 IN
    FUNCTION GET_DB_USER RETURNS VARCHAR2
    FUNCTION GET_LW_USER RETURNS VARCHAR2
    PROCEDURE GET_SESSION_INFO
    Argument Name Type In/Out Default?
    NUM_PARAMS NUMBER OUT
    PARAM_NAMES TABLE OF VARCHAR2(32000) OUT
    PARAM_VALUES TABLE OF VARCHAR2(32000) OUT
    PROCEDURE RESET_SESSION
    Argument Name Type In/Out Default?
    P_COOKIE_NAME VARCHAR2 IN
    In my case only the Login Server (PORTAL30_SSO) is going to be used/installed
    - the SAMPLE_SSO_PAPP application will only work if the DAD used to access is it set to use Basic authentication, i.e. the actual integration with the Login Server
    is done in the sample application code calls, stored in the database
    - when a DAD has enableSSO=yes it automatically accesses Portal (PORTAL30) packages to implement N-Tier authentication
    I'm currently testing:
    1. Configuring the SAMPLE_SSO_PAPP sample as documented with a DAD with Basic authentication
    2. Amending the ssoapp procedure to set context to another (db) user on successful authentication:
    wwctx_api.set_context (
    p_user_name => 'SCOTT',
    p_password => 'TIGER' );
    3. If this works then set_context with get_lw_user instead
    I have now amended the ssoapp procedure as follows to print out
    1. The userid entered when the login box is presented
    2. The Database user which the Portal Lightweight user is mapped to
    3. The Lightweight user Portal has used for authentication
    Amendments to papp.pkb:
    (ssoapp procedure, declare db_user_info and lw_user_info as VARCHAR2 in declare section)
    htp.p('Congratulations! It is working!<br>');
    db_user_info := wwctx_api.get_db_user;
    lw_user_info := wwctx_api.get_user;
    htp.p('User Information:' || l_user_info || '<br>');
    htp.p('DB User Information:' || db_user_info || '<br>');
    htp.p('LW User Information:' || lw_user_info || '<br>');
    The following shows the interesting results from my testing:
    - if the user owning the sample_sso_papp package is PORTAL30_SSO then the call to wwctx_api.get_db_user succeeds
    - if the user owning the sample_sso_papp package is a non-portal schema e.g. SSOAPP below the call to wwctx_api.get_db_user generates a User Defined exception
    Steps to test:
    Created new schema SSOAPP on the database
    - edited it in Portal and checked the use this schema for Portal users checkbox
    - created new Lightweight user SSO_LW in Portal, mapped it to SSOAPP schema
    - created new Lightweight user SSO_SCOTT in Portal, mapped to SCOTT schema
    - loadjava -user ssoapp/ssoapp@portal30 SSOHash.class
    - sqlplus portal30/portal30@portal30
    @provsyns ssoapp
    - sqlplus ssoapp/ssoapp@portal30
    @loadsdk.sql
    @loadpapp.sql
    Created DAD with basic authentication SAMPLE_SSO_PAPP
    - username: ssoapp
    - default home page: sample_sso_papp.ssoapp
    Registered the Sample SSO Partner Application with the Login Server and ran regapp.sql
    Commented out the calls to get_db_user in papp.pkb to avoid exception
    - called http://<server>/pls/sample_sso_papp
    - logged on as SSO_LW/sso_lw
    - got output:
    Congratulations! It is working!
    User Information: SSO_LW
    LW User Information: PUBLIC
    So the Portal lightweight user is not returned as SSO_LW
    if anyone knows why the Lightweight User in my test is returned as PUBLIC not SSO_LW
    Best Regards
    MIchael

    http://support.mozilla.com/en-US/kb/Changing+the+e-mail+program+used+by+Firefox

  • Battery , time , signal strength bar is not getting displayed in home screen , these will be displayed only when i click on any app. Can u let me know the setting change ?

    Battery , time , signal strength bar is not getting displayed in home screen , these will be displayed only when i click on any app. Can u let me know the setting change ?

    Did you check the Zoom setting?
    Have you tried a reset (reboot)? Hold HOME and SLEEP until an Apple logo appears.
    If it isn't Zoom and a reboot doesn't help try Settings/General/Reset - Reset all settings

  • "cacheHostInfo is null" and Add-SPDistributedCacheServiceInstance : Object reference not set to an instance of an object.

    I am working on a standalone install Sharepoint 2013 (no Active Directory). I found newsfeed feature is not available and checked Distributed Cache service is stopped. When start it “cacheHostInfo is null” is returned.
    I checked the Windows service “AppFabric caching service” is stopped because the default identity “Network Service” not work. Then I change the AppFabric service identity to use “.\administrator” (which is also the sp farm administrator) and the service can
    be started.
    However the “cacheHostInfo is null” when try to start Distributed Cache service in central admin.
    I searched on web and found this blog: http://rakatechblog.wordpress.com/2013/02/04/sharepoint-2013-spdistributedcacheserviceinstance-cachehostinfo-is-null/
    I tried to run the script but it return error:
    Add-SPDistributedCacheServiceInstance : Object reference not set to an
    instance of an object.
    At C:\root\ps\test.ps1:8 char:13
    + $whatever = Add-SPDistributedCacheServiceInstance
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : InvalidData: (Microsoft.Share…ServiceInstance:
    SPCmdletAddDist…ServiceInstance) [Add-SPDistributedCacheServiceInstance]
    , NullReferenceException
    + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletAddDistr
    ibutedCacheServiceInstance
    I am not sure what went wrong. Please give me some idea? Thank you for any comment!

    Can you deploy Active Directory as installing without is not a supported installation scenario - http://support.microsoft.com/kb/2764086.
    Trevor Seward
    Follow or contact me at...
    &nbsp&nbsp
    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

  • HT5361 Tools Options Mail format Plain text options Set you characters to 130 Click ok

    How do I goto out look to change mail format

    smercurio_fc wrote:
    Then it sounds to me like this other application is not decoding the attachment correctly, especially if you looked at the attachment yourself after you received it and verified it's correct.
    No, no, smercurio. This is charcter encoding here. In older versions of LabVIEW you could specify what character encoding to use when sending an email through the SMTP VIs. But that gave problems since people in certain locales used certain characters that where not transfered right when the wrong encoding was specified, and that encoding stuff is not understood by most people at all, so the wrong selected encoding was rather the rule than the exception. In newer versions of LabVIEW do the SMTP VIs handle the encoding automatically based on the currently used locale on the system.
    This change is documented in the Upgrade Notes of LabVIEW and probably happened around LabVIEW 7.1 or 8.0.
    A decent mail client will recognize the encoding and convert it back to whatever is necessary before presenting it to the user. The OPs posters server application obviously isn't a smart mail client but probably just some crude text file parser that has no notion of proper mail character encoding and how to deal with it.
    I would suppose that there is a chance to dig into the SMTP VIs itself and try to manipulate or disable that encoding altogether in there but that may open a whole can of worms somewhere else. The proper way would be to process the incoming mail by a character encoding aware mail client before passing it to the text parser. On Unix setting up something like this would be fairly trivial.
    Rolf Kalbermatter
    Message Edited by rolfk on 01-23-2008 10:21 AM
    Rolf Kalbermatter
    CIT Engineering Netherlands
    a division of Test & Measurement Solutions

  • Setting up Chat Room with Jabber

    I am trying to create a chat room for multiple users all using a Jabber (gmail) account within ichat.  Is there a special naming protocol to creating a chat room or do you need to create an address somewhere before joining this chat room?
    I have no problem doing it with my .me account but for work everyone is on gmail so we ideally be able to use the Jabber accounts for group chats. 
    I did mange to "create" one called [email protected] (our domain) but when I tried to join I get the grey spinning wheel and don't get any further.
    Clearly I'm missing something so any help would be appreciated!
    Thanks,
    Sarah

    Hi,
    GoogleTalk is supposed to allow group chats.
    These tend to be called "Conferences" on most Jabber servers.
    Most Jabber servers have a section of additional itme your can "register" for and Login to.
    However to do this takes a third party app like Psi.
    This can then do "Service Discovery" on the server in question and show what features you can sign up for.
    These can include "Transports" that allow you to add Buddies from different services and Conference calls.
    Having said that if you do Service Discovery on GoogleTalk you find nothing
    Many apps also presume the server name is the last part of your user ID and for Google with it's @gmail.com and @googlemail.com this does not work properly in some of these apps.
    This page has Instructions for how to set up a Transport to MSN using Psi and you can see the Service Discovery panel.
    Essentially a room has to be given a Name and this is coupled with the Jabber server name it is on so that it looks something like this:-
    [email protected]
    The room "ralph" is on the conference server at the jabber.org.uk server.
    Substituting [email protected] does not seem to work as a room name.
    It may pay to start from a  Web Browser login and see if a room name becomes apparent that way.
    Edit
    The last two "links" I have tried to remove the Links but they keep get added back
    9:53 PM      Friday; April 26, 2013
      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.3)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad
    "Limit the Logs to the Bits above Binary Images."  No, Seriously
    Message was edited by: Ralph Johns (UK)
    Message was edited by: Ralph Johns (UK)
    Message was edited by: Ralph Johns (UK)

  • Setting up site to site vpn with cisco asa 5505

    I have a cisco asa 5505 that needs to be set up for site to site vpn to a cisco asa 5500. The 5505 is the remote office and the 5500 is the main office.
    IP of remote office router is 71.37.178.142
    IP of the main office firewall is 209.117.141.82
    Can someone tell me if my config is correct, this is the first time I am setting this up and it can not be tested until I set it up at the remote office. I would rather know its correct before I go.
    ciscoasa# show run
    : Saved
    ASA Version 7.2(4)
    hostname ciscoasa
    domain-name default.domain.invalid
    enable password TMACBloMlcBsq1kp encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.1.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address dhcp setroute
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    ftp mode passive
    dns server-group DefaultDNS
    domain-name default.domain.invalid
    access-list outside_1_cryptomap extended permit ip host 71.37.178.142 host 209.117.141.82
    access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 host 209.117.141.82
    access-list inside_nat0_outbound extended permit ip host 71.37.178.142 host 209.117.141.82
    pager lines 24
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-524.bin
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list inside_nat0_outbound
    nat (inside) 1 0.0.0.0 0.0.0.0
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    http server enable
    http 192.168.1.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto map outside_map 1 match address outside_1_cryptomap
    crypto map outside_map 1 set pfs group5
    crypto map outside_map 1 set peer 209.117.141.82
    crypto map outside_map 1 set transform-set ESP-AES-256-SHA
    crypto map outside_map interface outside
    crypto isakmp enable outside
    crypto isakmp policy 10
    authentication pre-share
    encryption aes-256
    hash sha
    group 5
    lifetime 86400
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    vpdn username [email protected] password ********* store-local
    dhcpd auto_config outside
    dhcpd address 192.168.1.2-192.168.1.129 inside
    dhcpd enable inside
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
    service-policy global_policy global
    prompt hostname context
    Cryptochecksum:7e338fb2bf32a9ceb89560b314a5ef6c
    : end
    ciscoasa#
    Thanks!

    Hi Mandy,
    By using following access list define Peer IP as source and destination
    access-list outside_1_cryptomap extended permit ip host 71.37.178.142 host 209.117.141.82
    you are not defining the interesting traffic / subnets from both ends.
    Make some number ACL 101 as you do not have to write the extended keyword then if you like as follows, or else NAME aCL will also work:
    access-list outside_1_cryptomap extended ip 192.168.200.0 0.0.0.255 192.168.100.0 0.0.0.255
    access-list outside_1_cryptomap extended ip 192.168.200.0 0.0.0.255 192.168.100.0 0.0.0.255
    access-list 101 remark CCP_ACL Category=4 access-list 101 remark IPSEC Rule
    !.1..source subnet(called local encryption domain) at your end  192.168.200.0
    !..2.and destination subnet(called remote encryption domain)at other end 192.168.100.0 !.3..I mean you have to define what subnets you need to communicate between which are behind these firewalls
    !..4...Local Subnets behind IP of the main office firewall is 209.117.141.82 say
    !...at your end  192.168.200.0
    !..5.Remote Subnets behind IP of remote office router is 71.37.178.142 say
    !...at other end 192.168.100.0
    Please use Baisc Steps as follows:
    A. Configuration in your MAIN office  having IP = 209.117.141.82  (follow step 1 to 6)
    Step 1.
    Define Crypto ACL/ mirror ACL for other end (change source to destination and destination to source in other side router or VPN device and thats why they are called mirror ACL/ or also called Proxy ID or also called Proxy ACL, your interesting traffic , that you want to encrypt / trave/enter in the tunnel)
    access-list outside_1_cryptomap extended ip 192.168.200.0 0.0.0.255 192.168.100.0 0.0.0.255
    Step 2.
    Config ISAKMP Policy with minimum 4 parameters are to be config for
    crypto isakmp policy 10
    authentication pre-share  ---> Ist parameter of setting Authentication type ISAKMP Policy is OK
    encryption aes-256   --->2nd parameter of ISAKMP Policy is OK
    hash sha   --->  3rd parameter of ISAKMP Policy is OK
    group 5  --->  4th parameter of ISAKMP Policy is OK
    lifetime 86400  ------ >  this 5th parameter is optional , and will negotiate for the less value at either end or by default is will be taken 86400
    Step 3.
    Define Preshared key or PKI which you will use with other side Peer address 71.37.178.142, either key type 0 is Plain text anyone can see it over internet, or use key type 6 for encrypted key , say your password is CISCO123
    Here in your case in step 2 Authentication is using PSK, looks you have not defines Password
    Use following command:
    crypto isakmp key 0 CISCO123 address 71.37.178.142
    or , but not both
    crypto isakmp key 6 CISCO123 address71.37.178.142
    step 4.
    Define Transform set , which will be used for phase 2 tunnel parameters, if you use ESP it can have to sets one cor encryption and other for Authentication.
    Here is yours one:
    crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    this is correct but give name somthing easier to remember /distinguish it is a transform set , like TSET1 instead of ESP-AES-256-SHA ,try following (here you are using ESP so for encryption we use first set as esp-des and for authentication we use second set esp-sha-hmac)
    crypto ipsec transform-set TSET1 esp-des esp-sha-hmac
    or
    crypto ipsec transform-set TSET1 esp-aes-256 esp-sha-hmac
    Suppose you are using only AH then as AH does not support encryption or confidentiality hence it always use onle one set not 2 sets like ESP(remember the difference) say for example only one set for auth etc but no set for encryption hence AH have no such sets like ah-des or ah-3des or ah-aes, it has only second set for authentication like
    ah-sha-hmac or  ah-md5-hmac
    crypto ipsec transform-set TSET1 ah-sha-hmac
    or
    crypto ipsec transform-set TSET1 ah-md5-hmac
    Step 5.
    Now configure Crypto MAP as follows and only one CMPA can be applied to OUTSIDE Interface as VPN tunnel is alsways applied for traffic from inside subnets to outside subnets and only once Cryptomap can be applied to OUTSIDE Interface and hence for several VPN peers from different vendors we use seq no 10, 2 30 for different tunnels in one single CMAP:
    crypto map ipsec-isakmp
    1. Define peer -- called WHO to set tunnel with
    2. Define or call WHICH - Transform Set
    3. Define WHAT to call interesting traffic define in your ACL or Proxy ID or Proxy ACL in step 1 using match address
    Like in your case it is but ipsec-isakmp keyword missing in the ;ast
    crypto map outside_map 10 ipsec-isakmp
    1. set peer 209.117.141.82  -----> is correct as this is your other side peer called WHO in my step
    2. set transform-set TSET1  -----> is correct as this is WHICH, and only one transform set can be called
    !..In you case it is correct
    !...set transform-set ESP-AES-256-SHA (also correct)
    3.  match address outside_1_cryptomap  ---->Name of the extended ACL define as WHAT to pass through this tunnel
    4. set pfs group5 (this is optional but if config at one end same has to be config at other side peer as well)
    Step 6.
    Now apply this one crypto MAP to your OUTSIDE interface always
    interface outside
    crypto map outside_map
    Configure the same but just change ACL on other end in step one  by reversing source and destination
    and also set the peer IP of this router in other end.
    So other side config should look as follows:
    B.  Configuration in oyur Remote PEER IP having IP = 71.37.178.142 (follow step 7 to 12)
    Step 7.
    Define Crypto ACL/ mirror ACL for other end (change source to destination and destination to source in other side router or VPN device and thats why they are called mirror ACL/ or also called Proxy ID or also called Proxy ACL, your interesting traffic , that you want to encrypt / trave/enter in the tunnel)
    access-list outside_1_cryptomap extended ip 192.168.100.0 0.0.0.255 192.168.200.0 0.0.0.255
    Step 8.
    Config ISAKMP Policy with minimum 4 parameters are to be config for
    crypto isakmp policy 10
    authentication pre-share  ---> Ist parameter of setting Authentication type ISAKMP Policy is OK
    encryption aes-256   --->2nd parameter of ISAKMP Policy is OK
    hash sha   --->  3rd parameter of ISAKMP Policy is OK
    group 5  --->  4th parameter of ISAKMP Policy is OK
    lifetime 86400  ------ >  this 5th parameter is optional , and will negotiate for the less value at either end or by default is will be taken 86400
    Step 9.
    Define Preshared key or PKI which you will use with other side Peer address key type 0 is Plain text anyone can see it over internet, or use key type 6 for encrypted key , say your password is CISCO123
    Here in your case in step 8 Authentication is using PSK, looks you have not defines Password
    Use following command:
    crypto isakmp key 0 CISCO123 address 209.117.141.82
    or , but not both
    crypto isakmp key 6 CISCO123 address 209.117.141.82
    step 10.
    Define Transform set , which will be used for phase 2 tunnel parameters, if you use ESP it can have to sets one cor encryption and other for Authentication.
    Here is yours one:
    crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    this is correct but give name somthing easier to remember /distinguish it is a transform set , like TSET1 instead of ESP-AES-256-SHA ,try following (here you are using ESP so for encryption we use first set as esp-des and for authentication we use second set esp-sha-hmac)
    crypto ipsec transform-set TSET1 esp-des esp-sha-hmac
    or
    crypto ipsec transform-set TSET1 esp-aes-256 esp-sha-hmac
    Suppose you are using only AH then as AH does not support encryption or confidentiality hence it always use onle one set not 2 sets like ESP(remember the difference) say for example only one set for auth etc but no set for encryption hence AH have no such sets like ah-des or ah-3des or ah-aes, it has only second set for authentication like
    ah-sha-hmac or  ah-md5-hmac
    crypto ipsec transform-set TSET1 ah-sha-hmac
    or
    crypto ipsec transform-set TSET1 ah-md5-hmac
    Step 11.
    Now configure Crypto MAP as follows and only one CMPA can be applied to OUTSIDE Interface as VPN tunnel is alsways applied for traffic from inside subnets to outside subnets and only once Cryptomap can be applied to OUTSIDE Interface and hence for several VPN peers from different vendors we use seq no 10, 2 30 for different tunnels in one single CMAP:
    crypto map    ipsec-isakmp
    1. Define peer -- called WHO to set tunnel with
    2. Define or call WHICH - Transform Set, only one is permissible
    3. Define WHAT to call interesting traffic define in your ACL or Proxy ID or Proxy ACL in step 1 using match address
    Like in your case it is but ipsec-isakmp keyword missing in the ;ast
    crypto map outside_map 10 ipsec-isakmp
    1. set peer 209.117.141.82  -----> is correct as this is your other side peer called WHO in my step
    2. set transform-set TSET1  -----> is correct as this is WHICH, and only one transform set can be called
    !..In you case it is correct
    !...set transform-set ESP-AES-256-SHA (also correct)
    3.  match address outside_1_cryptomap  ---->Name of the extended ACL define as WHAT to pass through this tunnel
    4. set pfs group5 (this is optional but if config at one end same has to be config at other side peer as well)
    Step 12.
    Now apply this one crypto MAP to your OUTSIDE interface always
    interface outside
    crypto map outside_map
    Now initite a ping
    Here is for your summary:
    IPSec: Site to Site - Routers
    Configuration Steps
    Phase 1
    Step 1: Configure Mirrored ACL/Crypto ACL       for Interesting Traffic
    Step 2: Configure ISAKMP Policy
    Step 3: Configure ISAKMP Key
    Phase 2
    Step 4: Configure Transform Set
    Step 5: Configure Crypto Map
    Step 6: Apply Crypto Map to an Interface
    To debug for Phase 1 and Phase 2. Store it in buffer without displaying logs on terminal.
    Router#debug crpyto isakmp
    Router#debug crpyto ipsec
    Router(config)# logging buffer 7
    Router(config)# logging buffer 99999
    Router(config)# logging console 6
    Router# clear logging
    Configuration
    In R1:
    (config)# access-list 101 permit ipo host 10.1.1.1 host      10.1.2.1
    (config)# crypto isakmp policy 10
    (config-policy)# encryption 3des
    (config-policy)# authentication pre-share
    (config-policy)# group 2
    (config-policy)# hash sha1
    (config)# crypto isakmp key 0 cisco address 2.2.2.1
    (config)# crypto ipsec transform-set TSET esp-3des      sha-aes-hmac
    (config)# crypto map CMAP 10 ipsec-isakmp
    (config-crypto-map)# set peer 2.2.2.1
    (config-crypto-map)# match address 101
    (config-crypto-map)# set transform-set TSET
    (config)# int f0/0
    (config-if)# crypto map CMAP
    Similarly in R2
    Verification Commands
    #show crypto isakmp SA
    #show crypto ipsec SA
    Change to Transport Mode, add the following command in Step 4:
    (config-tranform-set)# mode transport
    Even after  doing this change, the ipsec negotiation will still be done through  tunnel mode if pinged from Loopback to Loopback. To overcome this we  make changes to ACL.
    Change to Aggressive Mode, replace the Step 3 command with these commands in R1:
    (config)# crypto isakmp peer address 2.2.2.1
    (config-peer)# set aggressive-mode password cisco
    (config-peer)# set aggressive-mode clien-endpoint       ipv4-address 2.2.2.1
    Similarly on R2.
    The below process is for the negotiation using RSA-SIG (PKI) as authentication type
    Debug Process:
    After  we debug, we can see the negotiation between the two peers. The first  packet of the interesting traffic triggers the ISAKMP (Phase1)  negotiation. Important messages are marked in BOLD and explanation in  RED
    R2(config)#do ping 10.1.1.1 so lo0 // Interesting Traffic
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
    Packet sent with a source address of 2.2.2.2
    Mar  2 16:18:42.939: ISAKMP:(0): SA request profile is (NULL) //  Router tried to find any IPSec SA matching the outgoing connection but  no valid SA has been found in Security Association Database (SADB)
    Mar  2 16:18:42.939: ISAKMP: Created a peer struct for 20.1.1.10, peer port 500
    Mar  2 16:18:42.939: ISAKMP: New peer created peer = 0x46519678 peer_handle = 0x8000000D
    Mar  2 16:18:42.939: ISAKMP: Locking peer struct 0x46519678, refcount 1 for isakmp_initiator
    Mar  2 16:18:42.939: ISAKMP: local port 500, remote port 500
    Mar  2 16:18:42.939: ISAKMP: set new node 0 to QM_IDLE    
    Mar  2 16:18:42.939: ISAKMP:(0):insert sa successfully sa = 4542B818
    Mar  2 16:18:42.939: ISAKMP:(0):Can not start Aggressive mode, trying Main mode. // Not an error. By default it is configured for Main Mode
    Mar  2 16:18:42.939: ISAKMP:(0):No pre-shared key with 20.1.1.10! // Since we are using RSA Signature, this message. If we use pre-share, this is where it would indicate so!
    Mar  2 16:18:42.939: ISAKMP:(0): constructed NAT-T vendor-rfc3947 ID
    Mar  2 16:18:42.939: ISAKMP:(0): constructed NAT-T vendor-07 ID
    Mar  2 16:18:42.939: ISAKMP:(0): constructed NAT-T vendor-03 ID
    Mar  2 16:18:42.939: ISAKMP:(0): constructed NAT-T vendor-02 ID
    Mar  2 16:18:42.939: ISAKMP:(0):Input = IKE_MESG_FROM_IPSEC, IKE_SA_REQ_MM
    Mar  2 16:18:42.939: ISAKMP:(0):Old State = IKE_READY  New State = IKE_I_MM1
    Mar  2 16:18:42.943: ISAKMP:(0): beginning Main Mode exchange
    Mar  2 16:18:42.943: ISAKMP:(0): sending packet to 20.1.1.10 my_port 500 peer_port 500 (I) MM_NO_STATE // Sending ISAKMP Policy to peer
    Mar  2 16:18:42.943: ISAKMP:(0):Sending an IKE IPv4 Packet.
    Mar  2 16:18:42.943: ISAKMP (0): received packet from 20.1.1.10 dport 500 sport 500 Global (I) MM_NO_STATE // Sending ISAKMP Policy to peer
    Mar  2 16:18:42.947: ISAKMP:(0):Input = IKE_MESG_FROM_PEER, IKE_MM_EXCH
    Mar  2 16:18:42.947: ISAKMP:(0):Old State = IKE_I_MM1  New State = IKE_I_MM2
    Mar  2 16:18:42.947: ISAKMP:(0): processing SA payload. message ID = 0
    Mar  2 16:18:42.947: ISAKMP:(0): processing vendor id payload
    Mar  2 16:18:42.947: ISAKMP:(0): vendor ID seems Unity/DPD but major 123 mismatch // Do not worry about this! Not an ERROR!
    Mar  2 16:18:42.947: ISAKMP:(0): vendor ID is NAT-T v2
    Mar  2 16:18:42.947:.!!!!
    Success rate is 80 percent (4/5), round-trip min/avg/max = 1/2/4 ms
    R2(config)# ISAKMP:(0): processing vendor id payload
    Mar  2 16:18:42.947: ISAKMP:(0): processing IKE frag vendor id payload
    Mar  2 16:18:42.947: ISAKMP:(0):Support for IKE Fragmentation not enabled
    Mar  2 16:18:42.947: ISAKMP : Scanning profiles for xauth ...
    Mar  2 16:18:42.947: ISAKMP:(0):Checking ISAKMP transform 1 against priority 10 policy
    Mar  2 16:18:42.947: ISAKMP:      encryption 3DES-CBC
    Mar  2 16:18:42.947: ISAKMP:      hash SHA
    Mar  2 16:18:42.947: ISAKMP:      default group 2
    Mar  2 16:18:42.947: ISAKMP:      auth RSA sig
    Mar  2 16:18:42.947: ISAKMP:      life type in seconds
    Mar  2 16:18:42.947: ISAKMP:      life duration (VPI) of  0x0 0x1 0x51 0x80
    Mar  2 16:18:42.947: ISAKMP:(0):atts are acceptable. Next payload is 0
    Mar  2 16:18:42.947: ISAKMP:(0):Acceptable atts:actual life: 0
    Mar  2 16:18:42.947: ISAKMP:(0):Acceptable atts:life: 0
    Mar  2 16:18:42.947: ISAKMP:(0):Fill atts in sa vpi_length:4
    Mar  2 16:18:42.947: ISAKMP:(0):Fill atts in sa life_in_seconds:86400
    Mar  2 16:18:42.947: ISAKMP:(0):Returning Actual lifetime: 86400
    Mar  2 16:18:42.947: ISAKMP:(0)::Started lifetime timer: 86400.
    Mar  2 16:18:42.947: ISAKMP:(0): processing vendor id payload
    Mar  2 16:18:42.947: ISAKMP:(0): vendor ID seems Unity/DPD but major 123 mismatch
    Mar  2 16:18:42.947: ISAKMP:(0): vendor ID is NAT-T v2
    Mar  2 16:18:42.947: ISAKMP:(0): processing vendor id payload
    Mar  2 16:18:42.951: ISAKMP:(0): processing IKE frag vendor id payload
    Mar  2 16:18:42.951: ISAKMP:(0):Support for IKE Fragmentation not enabled
    Mar  2 16:18:42.951: ISAKMP:(0):Input = IKE_MESG_INTERNAL, IKE_PROCESS_MAIN_MODE
    Mar  2 16:18:42.951: ISAKMP:(0):Old State = IKE_I_MM2  New State = IKE_I_MM2
    Mar  2 16:18:42.951: ISAKMP (0): constructing CERT_REQ for issuer cn=ca_server OU=cisco C=India S=Karnataka L=Bangalore
    Mar  2 16:18:42.951: ISAKMP:(0): sending packet to 20.1.1.10 my_port 500 peer_port 500 (I) MM_SA_SETUP // Sending Key Exchange Information to peer
    Mar  2 16:18:42.951: ISAKMP:(0):Sending an IKE IPv4 Packet.
    Mar  2 16:18:42.951: ISAKMP:(0):Input = IKE_MESG_INTERNAL, IKE_PROCESS_COMPLETE
    Mar  2 16:18:42.951: ISAKMP:(0):Old State = IKE_I_MM2  New State = IKE_I_MM3
    Mar  2 16:18:42.955: ISAKMP (0): received packet from 20.1.1.10 dport 500 sport 500 Global (I) MM_SA_SETUP // Receive key exchange information from peer
    Mar  2 16:18:42.955: ISAKMP:(0):Input = IKE_MESG_FROM_PEER, IKE_MM_EXCH
    Mar  2 16:18:42.955: ISAKMP:(0):Old State = IKE_I_MM3  New State = IKE_I_MM4
    Mar  2 16:18:42.959: ISAKMP:(0): processing KE payload. message ID = 0
    Mar  2 16:18:43.003: ISAKMP:(0): processing NONCE payload. message ID = 0
    Mar  2 16:18:43.007: ISAKMP:(1008): processing CERT_REQ payload. message ID = 0
    Mar  2 16:18:43.007: ISAKMP:(1008): peer wants a CT_X509_SIGNATURE cert
    Mar  2 16:18:43.007: ISAKMP:(1008): peer wants cert issued by cn=ca_server OU=cisco C=India S=Karnataka L=Bangalore
    Mar  2 16:18:43.007:  Choosing trustpoint CA_Server as issuer
    Mar  2 16:18:43.007: ISAKMP:(1008): processing vendor id payload
    Mar  2 16:18:43.007: ISAKMP:(1008): vendor ID is Unity
    Mar  2 16:18:43.007: ISAKMP:(1008): processing vendor id payload
    Mar  2 16:18:43.007: ISAKMP:(1008): vendor ID seems Unity/DPD but major 180 mismatch
    Mar  2 16:18:43.007: ISAKMP:(1008): vendor ID is XAUTH
    Mar  2 16:18:43.007: ISAKMP:(1008): processing vendor id payload
    Mar  2 16:18:43.007: ISAKMP:(1008): speaking to another IOS box!
    Mar  2 16:18:43.007: ISAKMP:(1008): processing vendor id payload
    Mar  2 16:18:43.007: ISAKMP:(1008):vendor ID seems Unity/DPD but hash mismatch
    Mar  2 16:18:43.007: ISAKMP:received payload type 20
    Mar  2 16:18:43.007: ISAKMP (1008): His hash no match - this node outside NAT
    Mar  2 16:18:43.007: ISAKMP:received payload type 20
    Mar  2 16:18:43.007: ISAKMP (1008): No NAT Found for self or peer
    Mar  2 16:18:43.007: ISAKMP:(1008):Input = IKE_MESG_INTERNAL, IKE_PROCESS_MAIN_MODE
    Mar  2 16:18:43.007: ISAKMP:(1008):Old State = IKE_I_MM4  New State = IKE_I_MM4
    Mar  2 16:18:43.011: ISAKMP:(1008):Send initial contact
    Mar  2 16:18:43.011: ISAKMP:(1008):My ID configured as IPv4 Addr, but Addr not in Cert!
    Mar  2 16:18:43.011: ISAKMP:(1008):Using FQDN as My ID
    Mar  2 16:18:43.011: ISAKMP:(1008):SA is doing RSA signature authentication using id type ID_FQDN
    Mar  2 16:18:43.011: ISAKMP (1008): ID payload
              next-payload : 6
              type         : 2
              FQDN name    : R2
              protocol     : 17
              port         : 500
              length       : 10
    Mar  2 16:18:43.011: ISAKMP:(1008):Total payload length: 10
    Mar  2 16:18:43.019: ISAKMP (1008): constructing CERT payload for hostname=R2+serialNumber=FHK1502F2H8
    Mar  2 16:18:43.019: ISAKMP:(1008): using the CA_Server trustpoint's keypair to sign
    Mar  2 16:18:43.035: ISAKMP:(1008): sending packet to 20.1.1.10 my_port 500 peer_port 500 (I) MM_KEY_EXCH
    Mar  2 16:18:43.035: ISAKMP:(1008):Sending an IKE IPv4 Packet.
    Mar  2 16:18:43.035: ISAKMP:(1008):Input = IKE_MESG_INTERNAL, IKE_PROCESS_COMPLETE
    Mar  2 16:18:43.035: ISAKMP:(1008):Old State = IKE_I_MM4  New State = IKE_I_MM5
    Mar  2 16:18:43.047: ISAKMP (1008): received packet from 20.1.1.10 dport 500 sport 500 Global (I) MM_KEY_EXCH
    // "MM_KEY_EXCH" indicates that the peers have exchanged DH Public keys and generated a shared secret!
    Mar  2 16:18:43.047: ISAKMP:(1008): processing ID payload. message ID = 0
    Mar  2 16:18:43.047: ISAKMP (1008): ID payload
              next-payload : 6
              type         : 2
              FQDN name    : ASA1
              protocol     : 0
              port         : 0
              length       : 12
    Mar  2 16:18:43.047: ISAKMP:(0):: peer matches *none* of the profiles // Normal Message! Not an error!
    Mar  2 16:18:43.047: ISAKMP:(1008): processing CERT payload. message ID = 0
    Mar  2 16:18:43.047: ISAKMP:(1008): processing a CT_X509_SIGNATURE cert
    Mar  2 16:18:43.051: ISAKMP:(1008): peer's pubkey isn't cached
    Mar  2 16:18:43.059: ISAKMP:(1008): Unable to get DN from certificate!
    Mar  2 16:18:43.059: ISAKMP:(1008): Cert presented by peer contains no OU field.
    Mar  2 16:18:43.059: ISAKMP:(0):: peer matches *none* of the profiles
    Mar  2 16:18:43.063: ISAKMP:(1008): processing SIG payload. message ID = 0
    Mar  2 16:18:43.067: ISAKMP:received payload type 17
    Mar  2 16:18:43.067: ISAKMP:(1008): processing vendor id payload
    Mar  2 16:18:43.067: ISAKMP:(1008): vendor ID is DPD
    Mar  2 16:18:43.067: ISAKMP:(1008):SA authentication status:
              authenticated
    Mar  2 16:18:43.067: ISAKMP:(1008):SA has been authenticated with 20.1.1.10
    Mar  2 16:18:43.067: ISAKMP: Trying to insert a peer 40.1.1.1/20.1.1.10/500/,  and inserted successfully 46519678. // SA inserted into SADB
    Mar  2 16:18:43.067: ISAKMP:(1008):Input = IKE_MESG_FROM_PEER, IKE_MM_EXCH
    Mar  2 16:18:43.067: ISAKMP:(1008):Old State = IKE_I_MM5  New State = IKE_I_MM6
    Mar  2 16:18:43.067: ISAKMP:(1008):Input = IKE_MESG_INTERNAL, IKE_PROCESS_MAIN_MODE
    Mar  2 16:18:43.067: ISAKMP:(1008):Old State = IKE_I_MM6  New State = IKE_I_MM6
    Mar  2 16:18:43.071: ISAKMP:(1008):Input = IKE_MESG_INTERNAL, IKE_PROCESS_COMPLETE
    Mar  2 16:18:43.071: ISAKMP:(1008):Old State = IKE_I_MM6  New State = IKE_P1_COMPLETE
    Mar  2 16:18:43.071: ISAKMP:(1008):beginning Quick Mode exchange, M-ID of -1523793378
    Mar  2 16:18:43.071: ISAKMP:(1008):QM Initiator gets spi
    Mar  2 16:18:43.075: ISAKMP:(1008): sending packet to 20.1.1.10 my_port 500 peer_port 500 (I) QM_IDLE    
    Mar  2 16:18:43.075: ISAKMP:(1008):Sending an IKE IPv4 Packet.
    Mar  2 16:18:43.075: ISAKMP:(1008):Node -1523793378, Input = IKE_MESG_INTERNAL, IKE_INIT_QM
    Mar  2 16:18:43.075: ISAKMP:(1008):Old State = IKE_QM_READY  New State = IKE_QM_I_QM1
    Mar  2 16:18:43.075: ISAKMP:(1008):Input = IKE_MESG_INTERNAL, IKE_PHASE1_COMPLETE
    Mar  2 16:18:43.075: ISAKMP:(1008):Old State = IKE_P1_COMPLETE  New State = IKE_P1_COMPLETE
    Mar  2 16:18:43.079: ISAKMP (1008): received packet from 20.1.1.10 dport 500 sport 500 Global (I) QM_IDLE // IPSec Policies
    Mar  2 16:18:43.079: ISAKMP:(1008): processing HASH payload. message ID = -1523793378
    Mar  2 16:18:43.079: ISAKMP:(1008): processing SA payload. message ID = -1523793378
    Mar  2 16:18:43.079: ISAKMP:(1008):Checking IPSec proposal 1
    Mar  2 16:18:43.079: ISAKMP: transform 1, ESP_3DES
    Mar  2 16:18:43.079: ISAKMP:   attributes in transform:
    Mar  2 16:18:43.079: ISAKMP:      SA life type in seconds
    Mar  2 16:18:43.079: ISAKMP:      SA life duration (basic) of 3600
    Mar  2 16:18:43.079: ISAKMP:      SA life type in kilobytes
    Mar  2 16:18:43.079: ISAKMP:      SA life duration (VPI) of  0x0 0x46 0x50 0x0
    Mar  2 16:18:43.079: ISAKMP:      encaps is 1 (Tunnel)
    Mar  2 16:18:43.079: ISAKMP:      authenticator is HMAC-SHA
    Mar  2 16:18:43.079: ISAKMP:(1008):atts are acceptable. // IPSec attributes are acceptable!
    Mar  2 16:18:43.079: ISAKMP:(1008): processing NONCE payload. message ID = -1523793378
    Mar  2 16:18:43.079: ISAKMP:(1008): processing ID payload. message ID = -1523793378
    Mar  2 16:18:43.079: ISAKMP:(1008): processing ID payload. message ID = -1523793378
    Mar  2 16:18:43.083: ISAKMP:(1008): Creating IPSec SAs
    Mar  2 16:18:43.083:         inbound SA from 20.1.1.10 to 40.1.1.1 (f/i)  0/ 0
              (proxy 1.1.1.1 to 2.2.2.2)
    Mar  2 16:18:43.083:         has spi 0xA9A66D46 and conn_id 0
    Mar  2 16:18:43.083:         lifetime of 3600 seconds
    Mar  2 16:18:43.083:         lifetime of 4608000 kilobytes
    Mar  2 16:18:43.083:         outbound SA from 40.1.1.1 to 20.1.1.10 (f/i) 0/0
              (proxy 2.2.2.2 to 1.1.1.1)
    Mar  2 16:18:43.083:         has spi  0x2B367FB4 and conn_id 0
    Mar  2 16:18:43.083:         lifetime of 3600 seconds
    Mar  2 16:18:43.083:         lifetime of 4608000 kilobytes
    Mar  2 16:18:43.083: ISAKMP:(1008): sending packet to 20.1.1.10 my_port 500 peer_port 500 (I) QM_IDLE    
    Mar  2 16:18:43.083: ISAKMP:(1008):Sending an IKE IPv4 Packet.
    Mar  2 16:18:43.083: ISAKMP:(1008):deleting node -1523793378 error FALSE reason "No Error"
    Mar  2 16:18:43.083: ISAKMP:(1008):Node -1523793378, Input = IKE_MESG_FROM_PEER, IKE_QM_EXCH
    Mar  2 16:18:43.083: ISAKMP:(1008):Old State = IKE_QM_I_QM1  New State = IKE_QM_PHASE2_COMPLETE // At this point tunnels are up and ready to pass traffic!
    Verification Commands
    #show crypto isakmp SA
    #show crypto ipsec SA
    Kindly rate if you find the explanation useful !!
    Best Regards
    Sachin Garg

  • Memory Problem with SEt and GET parameter

    hi,
    I m doing exits. I have one exit for importing and another one for changing parameter.
    SET PARAMETER exit code is ....
    *data:v_nba like eban-bsart,
           v_nbc like eban-bsart,
           v_nbo like eban-bsart.
           v_nbc = 'CAPX'.
           v_nbo = 'OPEX'.
           v_nba = 'OVH'.
    if im_data_new-werks is initial.
      if im_data_new-knttp is initial.
        if im_data_new-bsart = 'NBC' or im_data_new-bsart = 'SERC' or im_data_new-bsart = 'SERI'
           or im_data_new-bsart = 'SER' or im_data_new-bsart = 'SERM' or im_data_new-bsart = 'NBI'.
          set parameter id 'ZC1' field v_nbc.
        elseif im_data_new-bsart = 'NBO' or im_data_new-bsart = 'NBM' or im_data_new-bsart = 'SERO'.
          set parameter id 'ZC2' field v_nbo.
        elseif im_data_new-bsart = 'NBA' or im_data_new-bsart = 'SERA'.
          set parameter id 'ZC3' field  v_nba.
        endif.
      endif.
    endif. *
    and GET PARAMETER CODE IS....
      get parameter id 'ZC1' field c_fmderive-fund.
      get parameter id 'ZC2' field c_fmderive-fund.
      get parameter id 'ZC3' field c_fmderive-fund.
    FREE MEMORY ID 'ZC1'.
      FREE MEMORY ID 'ZC2'.
       FREE MEMORY ID 'ZC3'.
    In this code i m facing memory problem.
    It is not refreshing the memory every time.
    So plz give me proper solution.
    Its urgent.
    Thanks
    Ranveer

    Hi,
       I suppose you are trying to store some particular value in memory in one program and then retieve it in another.
    If so try using EXPORT data TO MEMORY ID 'ZC1'. and IMPORT data FROM MEMORY ID 'ZC1'.
    To use SET PARAMETER/GET PARAMETER the specified parameter name should be in table TPARA. Which I don't think is there in your case.
    Sample Code :
    Data declarations for the function codes to be transferred
    DATA : v_first  TYPE syucomm,
           v_second TYPE syucomm.
    CONSTANTS : c_memid TYPE char10 VALUE 'ZCCBPR1'.
    Move the function codes to the program varaibles
      v_first  = gv_bdt_fcode.
      v_second = sy-ucomm.
    Export the function codes to Memory ID
    EXPORT v_first
           v_second TO MEMORY ID c_memid.        "ZCCBPR1  --- Here you are sending the values to memory
    Then retrieve it.
    Retrieve the function codes from the Memory ID
      IMPORT v_first  TO v_fcode_1
             v_second TO v_fcode_2
      FROM MEMORY ID c_memid.                                   "ZCCBPR1
      FREE MEMORY ID c_memid.                                   "ZCCBPR1
    After reading the values from memory ID free them your problem should be solved.
    Thanks
    Barada
    Edited by: Baradakanta Swain on May 27, 2008 10:20 AM

Maybe you are looking for