SIU error in 10.6.6

Hello,
I'm using SIU to create a Net Restore image however I'm getting a error message when it starts to create the system.dmg (No Space left on Disk).  I have checked the amount of space on the drive (over 100GB) free.  The image I'm trying to create a 16GB image. I bolded the part where it fails.
Here is the Debug log it is quiet long.
Starting image creation.
Workflow Started (2011-06-21 13:06:41 -0400)
Mac OS X Server 10.6.7 (10J869), System Image Utility 10.6.7 (448)
Starting action: Define Image Source (1.2)
Finished running action: Define Image Source
Starting action: Create Image (1.5.4)
Starting image creation process...
Create NetInstall Image
Initiating NetInstall from Restore Media.
progressPrefix="_progress"
++ progressPrefix=_progress
scriptsDebugKey="DEBUG"
++ scriptsDebugKey=DEBUG
imageIsUDIFKey="1"
++ imageIsUDIFKey=1
mountPoint="/tmp/mnt.bcFq7u"
++ mountPoint=/tmp/mnt.bcFq7u
ownershipInfoKey="501:20"
++ ownershipInfoKey=501:20
mkextPathKey="/System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mk ext"
++ mkextPathKey=/System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mk ext
sourceVol="/Volumes/Macintosh HD"
++ sourceVol='/Volumes/Macintosh HD'
skipFileChecksumKey="0"
++ skipFileChecksumKey=0
dmgTarget="NetInstall"
++ dmgTarget=NetInstall
destPath="/Library/NetBoot/NetBootSP0/Dev_Image"
++ destPath=/Library/NetBoot/NetBootSP0/Dev_Image
asrSource="ASRInstall.pkg"
++ asrSource=ASRInstall.pkg
blockCopyDeviceKey="0"
++ blockCopyDeviceKey=0
. "$1/createCommon.sh"
+ . /tmp/niutemp.ZbrIcFvw/createCommon.sh
# createCommon.sh
# Common functionality for the Image creation process.
# sourced in by the various SIU scripts
# Copyright 2007 Apple Inc. All rights reserved.
# Using dscl, create a user account
AddLocalUser()
    # $1 long name
    # $2 short name
    # $3 isAdminUser key
    # $4 password hash
    # $5 user picture path
    # $6 Language string
    local    databasePath="/Local/Target/Users/${2}"
    # Find a free UID between 501 and 599
    for ((i=501; i<600; i++)); do
        output=`/usr/bin/dscl -f "${mountPoint}/var/db/dslocal/nodes/Default" localonly -search /Local/Target/Users UniqueID $i`
        # If there is already an account dscl returns it, so we're looking for an empty return value.
        if [ "$output" == "" ]; then
            break
        fi
    done
    # Create the user record
    /usr/bin/dscl -f "${mountPoint}/var/db/dslocal/nodes/Default" localonly -create $databasePath || exit 1
    # Add long name
    /usr/bin/dscl -f "${mountPoint}/var/db/dslocal/nodes/Default" localonly -append $databasePath RealName "${1}" || exit 1
    # Add PrimaryGroupID
    if [ "${3}" == 1 ]; then
        /usr/bin/dscl -f "${mountPoint}/var/db/dslocal/nodes/Default" localonly -append $databasePath PrimaryGroupID 80 || exit 1
    else
        /usr/bin/dscl -f "${mountPoint}/var/db/dslocal/nodes/Default" localonly -append $databasePath PrimaryGroupID 20 || exit 1
    fi
    # Add UniqueID
    /usr/bin/dscl -f "${mountPoint}/var/db/dslocal/nodes/Default" localonly -append $databasePath UniqueID ${i} || exit 1
    # Add Home Directory entry
    /usr/bin/dscl -f "${mountPoint}/var/db/dslocal/nodes/Default" localonly -append $databasePath dsAttrTypeNative:home /Users/${2} || exit 1
    /usr/bin/dscl -f "${mountPoint}/var/db/dslocal/nodes/Default" localonly -append $databasePath authentication_authority ";ShadowHash;" || exit 1
    /usr/bin/dscl -f "${mountPoint}/var/db/dslocal/nodes/Default" localonly -append $databasePath picture "${5}" || exit 1
    /usr/bin/dscl -f "${mountPoint}/var/db/dslocal/nodes/Default" localonly -append $databasePath passwd "*" || exit 1
    # Add shell
    /usr/bin/dscl -f "${mountPoint}/var/db/dslocal/nodes/Default" localonly -append $databasePath UserShell "/bin/bash" || exit 1
    # lookup generated uid
    genUID=`/usr/bin/dscl -f "${mountPoint}/var/db/dslocal/nodes/Default" localonly -read /Local/Target/Users/${2} GeneratedUID` || exit 1
    genUID=${genUID:14:36}
    # make sure the shadow/hash directory exists
    if [ ! -e "${mountPoint}/var/db/shadow/hash" ] ; then
        /bin/mkdir -p "${mountPoint}/var/db/shadow/hash" || exit 1
        /bin/chmod -R 700 "${mountPoint}/var/db/shadow" || exit 1
    fi
    # to copy our password hash in there...
    echo "${4}" > "${mountPoint}/var/db/shadow/hash/$genUID"
    /bin/chmod 600 "${mountPoint}/var/db/shadow/hash/$genUID" || exit 1
    # Create Home directory
    if [ -e "/System/Library/User Template/${6}.lproj/" ]; then
        /usr/bin/ditto "/System/Library/User Template/${6}.lproj/" "${mountPoint}/Users/${2}" || exit 1
    else
        /usr/bin/ditto "/System/Library/User Template/English.lproj/" "${mountPoint}/Users/${2}" || exit 1
    fi
    /usr/sbin/chown -R $i:$i "${mountPoint}/Users/${2}" || exit 1
# If they exist, apply any Append.bom changes
ApplyAppendBom()
    local tempDir="$1"
    local srcVol="$2"
    local opt=""
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
        opt="-v"
    fi
    if [ -e  "$tempDir/Append.bom" ]; then   
        if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
            echo "Applying Append.bom additions from System Image Utility"
        fi
        /usr/bin/ditto $opt -bom "$tempDir/Append.bom" "$srcVol" "${mountPoint}" || exit 1
    fi
    if [ -e  "$srcVol/Library/Application Support/Apple/System Image Utility/Append.bom" ]; then
        if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
            echo "Applying Append.bom additions from $srcVol"
        fi
        /usr/bin/ditto $opt -bom "$srcVol/Library/Application Support/Apple/System Image Utility/Append.bom" "$srcVol" "${mountPoint}" || exit 1
    fi
# Copies a list of packages (full paths contained in the file at $1) from source to .../System/Installation/Packages/
CopyPackagesFromFile()
    local theFile="$1"
    local opt=""
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
        opt="-v"
    fi
    while read FILE
    do
        if [ -e "${FILE}" ]; then
            local leafName=`basename "${FILE}"`
            if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
                echo "Copying ${FILE}."
            fi
            /usr/bin/ditto $opt "${FILE}" "${mountPoint}/System/Installation/Packages/${leafName}" || exit 1
        fi
    done < "${theFile}"
# Copies a list of packages (full path, destination pairs contained in the file at $1) from source to .../System/Installation/Packages/
CopyPackagesWithDestinationsFromFile()
    local theFile="$1"
    local opt=""
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
        opt="-v"
    fi
    while read FILE
    do
        if [ -e "${FILE}" ]; then
            local leafName=`basename "${FILE}"`
            if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
                echo "Copying ${FILE}."
            fi
            read SUB_PATH
            /usr/bin/ditto $opt "${FILE}" "${mountPoint}/System/Installation/Packages/${SUB_PATH}${leafName}" || exit 1
        fi
    done < "${theFile}"
# Create the dyld shared cache files
CreateDyldCaches()
    local opt=""
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
        echo "Creating dyld shared cache files"
        # This spews too much for verbose mode... only enable for debug
        if [ "${scriptsDebugKey}" == "DEBUG" ]; then
            opt="-debug"
        fi
    fi
    /usr/bin/update_dyld_shared_cache -root "${mountPoint}" -universal_boot -force $opt
# Validate or create the destination directory and mount point
CreateOrValidateDestination()
    local destDir="$1"
    if [ ! -d "$destDir" ]; then
        if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
            echo "Creating working path at $destDir"
        fi
        /bin/mkdir -p "$destDir" || exit 1
    fi
    # Create mount point
    if [ ! -d "${mountPoint}" ]; then
        if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
            echo "Creating mountpoint for in $destDir"
        fi
        /bin/mkdir -p "${mountPoint}" || exit 1
    fi
# If any exist, apply any user accounts
CreateUserAccounts()
    local count="${#userFullName[*]}"
    if [ $count -gt 0 ]; then
        if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
            echo "Adding $count user account(s) to the image"
        fi
        for ((index=0; index<$count; index++)); do
            if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
                echo "Adding user ${userFullName[$index]}"
            fi
            #lay down user here
            AddLocalUser "${userFullName[$index]}" "${userUnixName[$index]}" "${userIsAdmin[$index]}" "${userPassHash[$index]}" "${userImagePath[$index]}" "${userLanguage[$index]}"
        done
        # "touch"
        /usr/bin/touch "${mountPoint}/private/var/db/.AppleSetupDone"
        /usr/bin/touch "${mountPoint}/Library/Receipts/.SetupRegComplete"
    fi
# retry the hdiutil detach until we either time out or it succeeds
retry_hdiutil_detach()
    local mount_point="${1}"
    local tries=0
    local forceAt=0
    local limit=24
    local opt=""
    forceAt=$(($limit - 1))
    while [ $tries -lt $limit ]; do
        tries=$(( tries + 1 ))
        /bin/sleep 5
        echo "Attempting to detach the disk image again..."
        /usr/bin/hdiutil detach "${mount_point}" $opt
        if [ $? -ne 0 ]; then
            # Dump a list of any still open files on the mountPoint
            if [ "${scriptsDebugKey}" == "DEBUG" ]; then
                /usr/sbin/lsof +fg "${mount_point}"
            fi
            if [ $tries -eq $forceAt ]; then
                echo "Failed to detach disk image at '${mount_point}' normally, adding -force."
                opt="-force"
            fi
            if [ $tries -eq $limit ]; then
                echo "Failed to detach disk image at '${mount_point}'."
                exit 1
            fi
        else
            tries=$limit
        fi
    done
# Create the dyld shared cache files
DetachAndRemoveMount()
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
        echo "Detaching disk image"
        # Dump a list of any still open files on the mountPoint
        if [ "${scriptsDebugKey}" == "DEBUG" ]; then
            /usr/sbin/lsof +fg "${mountPoint}"
        fi
    fi
    # Finally detach the image and dispose the mountPoint directory
    /usr/bin/hdiutil detach "${mountPoint}" || retry_hdiutil_detach "${mountPoint}" || exit 1
    /bin/rmdir "${mountPoint}" || exit 1
# If the pieces exist, enable remote access for the shell image
EnableRemoteAccess()
    local srcVol="$1"
    local opt=""
    if [ -e "${srcVol}/usr/lib/pam/pam_serialnumber.so.2" ]; then
        if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
            echo "Enabling shell image remote access support"
            if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
                opt="-v"
            fi
        fi
        # install some things (again which aren't part of BaseSystem) needed for remote ASR installs
        /usr/bin/ditto $opt "${srcVol}/usr/lib/pam/pam_serialnumber.so.2" "${mountPoint}/usr/lib/pam/pam_serialnumber.so.2" || exit 1
        if [ -e "${srcVol}/usr/sbin/installer" ]; then
            /usr/bin/ditto $opt "${srcVol}/usr/sbin/installer" "${mountPoint}/usr/sbin/installer" || exit 1
        fi
        # copy the sshd config and add our keys to the end of it
        if [ -e "${srcVol}/etc/sshd_config" ]; then
            /bin/cat "${srcVol}/etc/sshd_config" - > "${mountPoint}/etc/sshd_config" << END
HostKey /private/var/tmp/ssh_host_key
HostKey /private/var/tmp/ssh_host_rsa_key
HostKey /private/var/tmp/ssh_host_dsa_key
END
        fi
    fi
# If it exists, install the sharing names and/or directory binding support to the install image
HandleNetBootClientHelper()
    local tempDir="$1"
    local opt=""
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
        opt="-v"
    fi
    if [ -e  "$tempDir/bindingNames.plist" ]; then   
        if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
            echo "Installing Directory Service binding information"
        fi
        /usr/bin/ditto $opt "$tempDir/bindingNames.plist" "${mountPoint}/etc/bindingNames.plist" || exit 1
        /usr/sbin/chown root:wheel "${mountPoint}/etc/bindingNames.plist"
        /bin/chmod 644 "${mountPoint}/etc/bindingNames.plist"
    fi
    if [ -e  "$tempDir/sharingNames.plist" ]; then   
        if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
            echo "Installing Sharing Names support"
        fi
        /usr/bin/ditto $opt "$tempDir/sharingNames.plist" "${mountPoint}/etc/sharingNames.plist" || exit 1
        /usr/sbin/chown root:wheel "${mountPoint}/etc/sharingNames.plist"
        /bin/chmod 644 "${mountPoint}/etc/sharingNames.plist"
    fi
    if [ -e  "$tempDir/NetBootClientHelper" ]; then   
        /usr/bin/ditto $opt "$tempDir/NetBootClientHelper" "${mountPoint}/usr/sbin/NetBootClientHelper" || exit 1
        /usr/sbin/chown root:wheel "${mountPoint}/usr/sbin/NetBootClientHelper"
        /bin/chmod 555 "${mountPoint}/usr/sbin/NetBootClientHelper"
        /usr/bin/ditto $opt "$tempDir/com.apple.NetBootClientHelper.plist" "${mountPoint}/System/Library/LaunchDaemons/com.apple.NetBootClientHelper.plist " || exit 1
        /usr/sbin/chown root:wheel "${mountPoint}/System/Library/LaunchDaemons/com.apple.NetBootClientHelper.plist "
        /bin/chmod 644 "${mountPoint}/System/Library/LaunchDaemons/com.apple.NetBootClientHelper.plist "
        # finally, make sure it isn't disabled...
        /usr/libexec/PlistBuddy -c "Delete :com.apple.NetBootClientHelper" "${mountPoint}/var/db/launchd.db/com.apple.launchd/overrides.plist" > /dev/null 2>&1
    fi
# Create an installer package in /System/Installation/Packages/ wrapping the supplied script
InstallerPackageFromScript()
    local tempDir="$1"
    local scriptPath="$2"
    local scriptName=`basename "${scriptPath}"`
    local opt=""
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
        echo "Create installer for script $scriptName"
        if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
            opt="-v"
        fi
    fi
    # shouldn't exist on entry...
    if [ -e "${tempDir}/emptyDir" ]; then
        /bin/rm -rf "${tempDir}/emptyDir"
    fi
    # make some directories to work in
    /bin/mkdir $opt -p "${tempDir}/$scriptName.pkg/Contents/Resources"
    /bin/mkdir $opt "${tempDir}/emptyDir" || exit 1
    cd "${tempDir}/emptyDir"
    # Create Archive.pax.gz
    /bin/pax -w -x cpio -f "$tempDir/$scriptName.pkg/Contents/Archive.pax" .
    /usr/bin/gzip "$tempDir/$scriptName.pkg/Contents/Archive.pax"
    # Create the Archive.bom file
    /usr/bin/mkbom "$tempDir/emptyDir/" "$tempDir/$scriptName.pkg/Contents/Archive.bom"
    # Create the Info.plist
    /bin/cat > "$tempDir/$scriptName.pkg/Contents/Info.plist" << END
    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
        <key>CFBundleIdentifier</key>
        <string>com.apple.server.SystemImageUtility.$scriptName</string>
        <key>CFBundleShortVersionString</key>
        <string>1</string>
        <key>IFMajorVersion</key>
        <integer>1</integer>
        <key>IFMinorVersion</key>
        <integer>0</integer>
        <key>IFPkgFlagDefaultLocation</key>
        <string>/tmp</string>
        <key>IFPkgFlagInstallFat</key>
        <false/>
        <key>IFPkgFlagIsRequired</key>
        <false/>
        <key>IFPkgFormatVersion</key>
        <real>0.10000000149011612</real>
    </dict>
    </plist>
END
    echo "pkmkrpkg1" > "$tempDir/$scriptName.pkg/Contents/PkgInfo"
    echo "major: 1\nminor: 0" > "$tempDir/$scriptName.pkg/Contents/Resources/package_version"
    # Copy the script
    /bin/cp "$scriptPath" "$tempDir/$scriptName.pkg/Contents/Resources/postflight"
    # copy the package to the Packages directory
    /usr/bin/ditto $opt "$tempDir/$scriptName.pkg" "${mountPoint}/System/Installation/Packages/$scriptName.pkg" || exit 1
    # clean up
    /bin/rm -r "$tempDir/emptyDir"
    /bin/rm -r "$tempDir/$scriptName.pkg"
# If it exists, install the PowerManagement.plist onto the install image
InstallPowerManagementPlist()
    local tempDir="$1"
    local opt=""
    if [ -e "$tempDir/com.apple.PowerManagement.plist" ]; then
        if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
            echo "Installing PowerManagement plist to install image"
            if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
                opt="-v"
            fi
        fi
        /usr/bin/ditto $opt "$tempDir/com.apple.PowerManagement.plist" "${mountPoint}/Library/Preferences/SystemConfiguration/com.apple.PowerManagemen t.plist" || exit 1
        /usr/sbin/chown root:wheel "${mountPoint}/Library/Preferences/SystemConfiguration/com.apple.PowerManagemen t.plist"
        /bin/chmod 644 "${mountPoint}/Library/Preferences/SystemConfiguration/com.apple.PowerManagemen t.plist"
    fi
# If it exists, install the InstallerStatusNotifications.bundle and progress emitter onto the install image
InstallProgressPieces()
    local tempDir="$1"
    local opt=""
    if [ -e "$tempDir/InstallerStatusNotifications.bundle" ]; then
        if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
            echo "Installing progress announcer to install image"
            if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
                opt="-v"
            fi
        fi
        /usr/bin/ditto $opt "$tempDir/InstallerStatusNotifications.bundle" "${mountPoint}/System/Library/CoreServices/InstallerStatusNotifications.bundle" || exit 1
        /usr/sbin/chown -R root:wheel "${mountPoint}/System/Library/CoreServices/InstallerStatusNotifications.bundle"
        /bin/chmod 755 "${mountPoint}/System/Library/CoreServices/InstallerStatusNotifications.bundle"
    fi
    if [ -e "$tempDir/com.apple.ProgressEmitter.plist" ]; then
        if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
            echo "Installing status emitter to image"
        fi
        /usr/bin/ditto $opt "$tempDir/progress_emitter" "${mountPoint}/usr/sbin/progress_emitter" || exit 1
        /usr/sbin/chown root:wheel "${mountPoint}/usr/sbin/progress_emitter"
        /bin/chmod 555 "${mountPoint}/usr/sbin/progress_emitter"
        /usr/bin/ditto $opt "$tempDir/com.apple.ProgressEmitter.plist" "${mountPoint}/System/Library/LaunchDaemons/com.apple.ProgressEmitter.plist" || exit 1
        /usr/sbin/chown root:wheel "${mountPoint}/System/Library/LaunchDaemons/com.apple.ProgressEmitter.plist"
        /bin/chmod 644 "${mountPoint}/System/Library/LaunchDaemons/com.apple.ProgressEmitter.plist"
    fi
# Converts a list of scripts (full paths contained in the file at $1) into packages in .../System/Installation/Packages/
InstallScriptsFromFile()
    local tempDir="$1"
    local theFile="$2"
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
        echo "Converting scripts into install packages"
    fi
    while read FILE
    do
        if [ -e "${FILE}" ]; then
            # make an installer package out of the script
            InstallerPackageFromScript "$tempDir" "${FILE}"
        fi
    done < "${theFile}"
# Prepare the source by deleting stuff we don't want to copy if sourcing a volume
PostFlightDestination()
    local tempDir="$1"
    local destDir="$2"
    local opt=""
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
        echo "Performing post install cleanup"
        if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ] ; then
            opt="-v"
        fi
    fi
    # delete the DS indices to force reindexing...
    if [ -e "${mountPoint}/var/db/dslocal/indices/Default/index" ]; then
        /bin/rm $opt "${mountPoint}/var/db/dslocal/indices/Default/index"
    fi
    # detach the disk and remove the mount folder
    DetachAndRemoveMount || exit 1
    # copy the NBImageInfo.plist file
    /usr/bin/ditto $opt "$tempDir/NBImageInfo.plist" "$destDir/NBImageInfo.plist" || exit 1
    echo "Correcting permissions. ${ownershipInfoKey} $destDir"
    /usr/sbin/chown -R "${ownershipInfoKey}" "$destDir"
    # rename the folder to .nbi
    if [ ! -e "$destDir.nbi" ]; then
        /bin/mv $opt "$destDir" "$destDir.nbi" || exit 1
    else
        local parentDir=`dirname "${destDir}"`
        local targetName=`basename "${destDir}"`
        for ((i=2; i<1000; i++)); do
            if [ ! -e "${parentDir}/${targetName}_$i.nbi" ]; then
                /bin/mv $opt "$destDir" "${parentDir}/${targetName}_$i.nbi" || exit 1
                break
            fi
        done
    fi
# Prepare the source by deleting stuff we don't want to copy if sourcing a volume
PreCleanSource()
    local srcVol="$1"
    local opt=""
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
        if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ] ; then
            opt="-v"
        fi
    fi
    if [ -e "$srcVol/private/var/vm/swapfile*" ]; then
        if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
            echo "Removing swapfiles on $1"
        fi
        /bin/rm $opt "$srcVol/private/var/vm/swapfile*"
    fi
    if [ -d "$srcVol/private/tmp" ]; then
        if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
            echo "Cleaning out /private/tmp on $1"
        fi
        /bin/rm -r $opt "$srcVol/private/tmp/*"
    fi
    if [ -d "$srcVol/private/var/tmp" ]; then
        if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
            echo "Cleaning out /private/var/tmp on $1"
        fi
        /bin/rm -r $opt "$srcVol/private/var/tmp/*"
    fi
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
        echo "Cleaning out devices and volumes on $1"
    fi
    if [ -d "$srcVol/Volumes" ]; then
        /bin/rm -r $opt "$srcVol/Volumes/*"
    fi
    if [ -d "$srcVol/dev" ]; then
        /bin/rm $opt "$srcVol/dev/*"
    fi
    if [ -d "$srcVol/private/var/run" ]; then
        /bin/rm -r $opt "$srcVol/private/var/run/*"
    fi
# Copy kernel and build the kext cache on the boot image
PrepareKernelAndKextCache()
    local destDir="$1"
    local opt=""
    local arch_x86_64=`/usr/bin/file -b "${mountPoint}/mach_kernel" | /usr/bin/sed -ne 's/.*\(x86_64\)):.*/\1/p'`
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
        echo "Preparing the kernel and kext cache for the boot image"
        if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
            opt="-v"
        fi
    fi
    # Insure the kext cache on our source volume (the boot shell) is up to date
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
        echo "Updating kext cache on source volume"
    fi
    /usr/sbin/kextcache -update-volume "${mountPoint}" || exit 1
    # Copy the i386 and, if it exists, the x86_64 architecture
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
        echo "Preparing Intel architecture"
    fi
    # Prepare the kernel
    /bin/mkdir $opt "$destDir/i386" || exit 1
    /usr/bin/lipo -extract i386 "${mountPoint}/mach_kernel" -output "$destDir/i386/mach.macosx" || exit 1
    # Build kext cache
    /usr/sbin/kextcache -a i386 -s -l -n -z -mkext2 "$destDir/i386/mach.macosx.mkext" "${mountPoint}/System/Library/Extensions" || exit 1
    # If the x86_64 architecture exists, copy it
    if [ "${arch_x86_64}" = "x86_64" ]; then
        if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
            echo "Preparing x86_64 architecture"
        fi
        # Prepare the kernel
        /bin/mkdir $opt "$destDir/i386/x86_64" || exit 1
        /usr/bin/lipo -extract x86_64 "${mountPoint}/mach_kernel" -output "$destDir/i386/x86_64/mach.macosx" || exit 1
        # Build kext cache
        /usr/sbin/kextcache -a x86_64 -s -l -n -z -mkext2 "$destDir/i386/x86_64/mach.macosx.mkext" "${mountPoint}/System/Library/Extensions" || exit 1
    fi
# Create the i386 and x86_64 boot loaders on the boot image
PrepareBootLoader()
    local srcVol="$1"
    local destDir="$2"
    local opt=""
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
        echo "Preparing boot loader"
        if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
            opt="-v"
        fi
    fi
    # Copy the i386 and, by default, the x86_64 architecture
    if [ -e "${mountPoint}/usr/standalone/i386/boot.efi" ]; then
        /usr/bin/ditto $opt "${mountPoint}/usr/standalone/i386/boot.efi" "$destDir/i386/booter" || exit 1
    else
        /usr/bin/ditto $opt "$srcVol/usr/standalone/i386/boot.efi" "$destDir/i386/booter" || exit 1
    fi
# If it exists, install the partitioning application and data onto the install image
ProcessAutoPartition()
    local tempDir="$1"
    local opt=""
    if [ -e "$tempDir/PartitionInfo.plist" ]; then
        if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
            echo "Installing Partitioning application and data to install image"
            if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
                opt="-v"
            fi
        fi
        /usr/bin/ditto $opt "$tempDir/PartitionInfo.plist" "${mountPoint}/System/Installation/PartitionInfo.plist" || exit 1
        /usr/bin/ditto $opt "$tempDir/AutoPartition.app" "${mountPoint}/System/Installation/AutoPartition.app" || exit 1
        # Tell the installer to run the Partitioning application
        /bin/echo "#!/bin/sh
        /System/Installation/AutoPartition.app/Contents/MacOS/AutoPartition" > "${mountPoint}/private/etc/rc.cdrom.postWS"
        # Due to the way rc.install sources the script, it needs to be executable
        /usr/sbin/chown root:wheel "${mountPoint}/private/etc/rc.cdrom.postWS"
        /bin/chmod 755 "${mountPoint}/private/etc/rc.cdrom.postWS"
    fi
# If it exists, install the InstallPreferences.plist onto the install image
ProcessInstallPreferences()
    local tempDir="$1"
    local opt=""
    if [ -e "$tempDir/InstallPreferences.plist" ]; then
        if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
            echo "Installing InstallPreferences.plist to install image"
            if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
                opt="-v"
            fi
        fi
        /usr/bin/ditto $opt "$tempDir/InstallPreferences.plist" "${mountPoint}/System/Installation/Packages/InstallPreferences.plist" || exit 1
        /usr/sbin/chown root:wheel "${mountPoint}/System/Installation/Packages/InstallPreferences.plist"
        /bin/chmod 644 "${mountPoint}/System/Installation/Packages/InstallPreferences.plist"
    fi
# If it exists, install the minstallconfig.xml onto the install image
ProcessMinInstall()
    local tempDir="$1"
    local opt=""
    if [ -e "$tempDir/minstallconfig.xml" ]; then
        if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
            echo "Installing minstallconfig.xml to install image"
            if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
                opt="-v"
            fi
        fi
        /usr/bin/ditto $opt "$tempDir/minstallconfig.xml" "${mountPoint}/etc/minstallconfig.xml" || exit 1
        /usr/sbin/chown root:wheel "${mountPoint}/etc/minstallconfig.xml"
        /bin/chmod 644 "${mountPoint}/etc/minstallconfig.xml"
    fi
# untar the OSInstall.mpkg so it can be modified
untarOSInstallMpkg()
    local tempDir="$1"
    local opt=""
    # we might have already done this, so check for it first
    if [ ! -d "${tempDir}/OSInstall_pkg" ]; then
        if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
            echo "uncompressing OSInstall.mpkg"
            if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
                opt="-v"
            fi
        fi
        /bin/mkdir "${tempDir}/OSInstall_pkg"
        cd "${tempDir}/OSInstall_pkg"
        /usr/bin/xar $opt -xf "${mountPoint}/System/Installation/Packages/OSInstall.mpkg"
        # make Distribution writeable
        /bin/chmod 777 "${tempDir}/OSInstall_pkg"
        /bin/chmod 666 "${tempDir}/OSInstall_pkg/Distribution"
    fi
handler ()
    echo "Terminated. Cleaning up. Unmounting $destPath"
    # detach the disk and remove the mount folder
    DetachAndRemoveMount
    # Remove the items we created
    /bin/rm -r "$destPath/i386"
    /bin/rm "$destPath/$dmgTarget.dmg"
    /bin/rm "$destPath/System.dmg"
    # Finally, remove the directory IF empty
    /bin/rmdir "$destPath"
    exit 1
InstallNetBootClientHelper()
    local tempDir="$1"
    local destDir="${mountPoint}/System/Installation/Packages/SIUExtras"
    local opt=""
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
        opt="-v"
    fi
    if [ -e  "${tempDir}/bindingNames.plist" ]; then   
        if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
            echo "Installing Directory Service binding information"
        fi
        /usr/bin/ditto $opt "${tempDir}/bindingNames.plist" "${destDir}/bindingNames.plist" || exit 1
        /usr/sbin/chown root:wheel "${destDir}/bindingNames.plist"
        /bin/chmod 644 "${destDir}/bindingNames.plist"
    fi
    if [ -e  "${tempDir}/sharingNames.plist" ]; then   
        if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
            echo "Installing Sharing Names support"
        fi
        /usr/bin/ditto $opt "${tempDir}/sharingNames.plist" "${destDir}/sharingNames.plist" || exit 1
        /usr/sbin/chown root:wheel "${destDir}/sharingNames.plist"
        /bin/chmod 644 "${destDir}/sharingNames.plist"
    fi
    # This is required, make sure it's here
    /usr/bin/ditto $opt "${tempDir}/NetBootClientHelper" "${destDir}/NetBootClientHelper" || exit 1
    /usr/sbin/chown root:wheel "${destDir}/NetBootClientHelper"
    /bin/chmod 555 "${destDir}/NetBootClientHelper"
    /usr/bin/ditto $opt "${tempDir}/com.apple.NetBootClientHelper.plist" "${destDir}/com.apple.NetBootClientHelper.plist" || exit 1
    /usr/sbin/chown root:wheel "${destDir}/com.apple.NetBootClientHelper.plist"
    /bin/chmod 644 "${destDir}/com.apple.NetBootClientHelper.plist"
    /usr/bin/ditto $opt "${tempDir}/installClientHelper.sh" "${mountPoint}/var/tmp/niu/postinstall/installClientHelper.sh" || exit 1
    /usr/sbin/chown root:wheel "${mountPoint}/var/tmp/niu/postinstall/installClientHelper.sh"
    /bin/chmod 555 "${mountPoint}/var/tmp/niu/postinstall/installClientHelper.sh"
trap "handler" TERM INT
+ trap handler TERM INT
# Set up for script debugging
debug_opt=""
+ debug_opt=
if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ] ; then
    debug_opt="-v"
fi
+ '[' DEBUG == VERBOSE -o DEBUG == DEBUG ']'
+ debug_opt=-v
# See if the source volume was overridden (NetRestore from install media workflow)
isRestoreFromInstallMedia="NO"
+ isRestoreFromInstallMedia=NO
if [ ! -z "${3:-}" ]; then
    sourceVol="${3}"
    isRestoreFromInstallMedia="YES"
fi
+ '[' '!' -z '' ']'
# Prepare the destination
CreateOrValidateDestination "$destPath"
+ CreateOrValidateDestination /Library/NetBoot/NetBootSP0/Dev_Image
+ local destDir=/Library/NetBoot/NetBootSP0/Dev_Image
+ '[' '!' -d /Library/NetBoot/NetBootSP0/Dev_Image ']'
+ '[' DEBUG == VERBOSE -o DEBUG == DEBUG ']'
+ echo 'Creating working path at /Library/NetBoot/NetBootSP0/Dev_Image'
Creating working path at /Library/NetBoot/NetBootSP0/Dev_Image
+ /bin/mkdir -p /Library/NetBoot/NetBootSP0/Dev_Image
+ '[' '!' -d /tmp/mnt.bcFq7u ']'
# If the sourceVol is the boot drive we have an asr:// type source
if [ "$sourceVol" == "/" ]; then
    # Create an empty image to skip the ASR volume creation
    /usr/bin/touch "${destPath}/System.dmg"
fi
+ '[' '/Volumes/Macintosh HD' == / ']'
# Look for an existing System.dmg
if [ ! -e "$destPath/System.dmg" ]; then
    # update progress information
    echo "${progressPrefix}_imagingSource_"
    # Create an image of the source volume
#    /usr/bin/hdiutil create "$destPath/System" -srcfolder "$sourceVol" -format UDBZ -uid 0 -gid 80 -mode 1775 -ov -puppetstrings || exit 1
    if [ "${blockCopyDeviceKey}" == 1 ] ; then
        theDevice=`/usr/sbin/diskutil info "$sourceVol" | grep "Device Identifier:" | awk '{print $3}'`
        /usr/sbin/diskutil umount "${theDevice}"
        if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ] ; then
            echo "Creating block-level image of $theDevice"
        fi
        /usr/bin/hdiutil create "$destPath/System" -srcdevice "${theDevice}" -uid 0 -gid 80 -mode 1775 -ov -puppetstrings || exit 1
        /usr/sbin/diskutil mount "${theDevice}"
    else
        if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ] ; then
            echo "Creating image of $sourceVol"
        fi
        /usr/bin/hdiutil create "$destPath/System" -srcfolder "${sourceVol}" -fsargs "-c a=16384,c=8192,e=1280" -uid 0 -gid 80 -mode 1775 -ov -puppetstrings || exit 1
    fi
    # update progress information
    echo "${progressPrefix}_preparingASR_"
    # "Scan the image for restore"
    asr_opt="--filechecksum"
    if [ "${skipFileChecksumKey}" == 1 ] ; then
        asr_opt=""
        if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ] ; then
            echo "Preparing image for restore without file checksums"
        fi
    else
        if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ] ; then
            echo "Preparing image for restore"
        fi
    fi
    /usr/sbin/asr imagescan --source "$destPath/System.dmg" $asr_opt || exit 1
fi
+ '[' '!' -e /Library/NetBoot/NetBootSP0/Dev_Image/System.dmg ']'
+ echo _progress_imagingSource_
+ '[' 0 == 1 ']'
+ '[' DEBUG == VERBOSE -o DEBUG == DEBUG ']'
+ echo 'Creating image of /Volumes/Macintosh HD'
Creating image of /Volumes/Macintosh HD
+ /usr/bin/hdiutil create /Library/NetBoot/NetBootSP0/Dev_Image/System -srcfolder '/Volumes/Macintosh HD' -fsargs '-c a=16384,c=8192,e=1280' -uid 0 -gid 80 -mode 1775 -ov -puppetstrings
PERCENT:0.000000
PERCENT:0.330451
PERCENT:0.332470
PERCENT:0.344677
PERCENT:0.377071
PERCENT:0.422909
PERCENT:0.459435
PERCENT:0.489441
PERCENT:0.518527
PERCENT:0.565020
PERCENT:0.623910
PERCENT:0.685802
PERCENT:0.744207
PERCENT:0.794040
PERCENT:0.841389
PERCENT:0.921185
PERCENT:0.985307
PERCENT:1.046925
PERCENT:1.105213
PERCENT:1.175296
PERCENT:1.230995
PERCENT:1.293341
PERCENT:1.352126
PERCENT:1.406514
PERCENT:1.473987
PERCENT:1.522076
PERCENT:1.585543
PERCENT:1.643091
PERCENT:1.717444
PERCENT:1.794418
PERCENT:1.862271
PERCENT:1.936603
PERCENT:1.994204
PERCENT:2.052249
PERCENT:2.111711
PERCENT:2.173170
PERCENT:2.214875
PERCENT:2.261125
PERCENT:2.305547
PERCENT:2.349017
PERCENT:2.390067
PERCENT:2.426858
PERCENT:2.464494
PERCENT:2.501401
PERCENT:2.544618
PERCENT:2.585044
PERCENT:2.616508
PERCENT:2.653373
PERCENT:2.684488
PERCENT:2.714250
PERCENT:2.744013
PERCENT:2.775128
PERCENT:2.805567
PERCENT:2.842241
PERCENT:2.896164
PERCENT:2.947551
PERCENT:3.077877
PERCENT:3.189032
PERCENT:3.255416
PERCENT:3.318238
PERCENT:3.385203
PERCENT:3.447032
PERCENT:3.501008
PERCENT:3.556358
PERCENT:3.596298
PERCENT:3.640265
PERCENT:3.701312
PERCENT:3.740216
PERCENT:3.751684
PERCENT:3.756873
PERCENT:3.759463
PERCENT:3.771110
PERCENT:3.832558
PERCENT:3.878956
PERCENT:3.921570
PERCENT:3.966489
PERCENT:4.017378
PERCENT:4.063142
PERCENT:4.108230
PERCENT:4.145591
PERCENT:4.192771
PERCENT:4.235164
PERCENT:4.266099
PERCENT:4.307170
PERCENT:4.339046
PERCENT:4.361928
PERCENT:4.408115
PERCENT:4.481009
PERCENT:4.546252
PERCENT:4.608429
PERCENT:4.672034
PERCENT:4.743332
PERCENT:4.808416
PERCENT:4.873353
PERCENT:4.936820
PERCENT:4.938119
PERCENT:4.964922
PERCENT:5.001111
PERCENT:5.047287
PERCENT:5.097353
PERCENT:5.156835
PERCENT:5.215133
PERCENT:5.275134
PERCENT:5.325294
PERCENT:5.386827
PERCENT:5.434113
PERCENT:5.478503
PERCENT:5.503984
PERCENT:5.529995
PERCENT:5.571034
PERCENT:5.621808
PERCENT:5.664380
PERCENT:5.703200
PERCENT:5.741238
PERCENT:5.787234
PERCENT:5.833463
PERCENT:5.900407
PERCENT:5.969592
PERCENT:6.021909
PERCENT:6.068772
PERCENT:6.125062
PERCENT:6.181723
PERCENT:6.232296
PERCENT:6.298521
PERCENT:6.352899
PERCENT:6.395819
PERCENT:6.423500
PERCENT:6.466389
PERCENT:6.512131
PERCENT:6.545339
PERCENT:6.606682
PERCENT:6.679429
PERCENT:6.731269
PERCENT:6.774930
PERCENT:6.810389
PERCENT:6.839253
PERCENT:6.869015
PERCENT:6.899454
PERCENT:6.931246
PERCENT:6.961008
PERCENT:6.992123
PERCENT:7.021167
PERCENT:7.055696
PERCENT:7.085416
PERCENT:7.120241
PERCENT:7.170761
PERCENT:7.212403
PERCENT:7.268651
PERCENT:7.318632
PERCENT:7.369744
PERCENT:7.417505
PERCENT:7.458164
PERCENT:7.470160
PERCENT:7.475867
PERCENT:7.481638
PERCENT:7.491499
PERCENT:7.500853
PERCENT:7.531027
PERCENT:7.565736
PERCENT:7.605169
PERCENT:7.634698
PERCENT:7.643978
PERCENT:7.658616
PERCENT:7.672662
PERCENT:7.730052
PERCENT:7.760406
PERCENT:7.793488
PERCENT:7.824518
PERCENT:7.858973
PERCENT:7.892022
PERCENT:7.927841
PERCENT:7.968045
PERCENT:8.000407
PERCENT:8.045262
PERCENT:8.094852
PERCENT:8.149515
PERCENT:8.210488
PERCENT:8.273025
PERCENT:8.323418
PERCENT:8.375428
PERCENT:8.427924
PERCENT:8.490250
PERCENT:8.565670
PERCENT:8.627298
PERCENT:8.680439
PERCENT:8.725358
PERCENT:8.787376
PERCENT:8.862871
PERCENT:8.912630
PERCENT:8.966120
PERCENT:9.012793
PERCENT:9.057658
PERCENT:9.096415
PERCENT:9.129918
PERCENT:9.178705
PERCENT:9.227861
PERCENT:9.266333
PERCENT:9.308345
PERCENT:9.361263
PERCENT:9.424857
PERCENT:9.499887
PERCENT:9.545059
PERCENT:9.599288
PERCENT:9.646638
PERCENT:9.692550
PERCENT:9.727226
PERCENT:9.763742
PERCENT:9.810225
PERCENT:9.853104
PERCENT:9.910747
PERCENT:9.951141
PERCENT:9.995256
PERCENT:10.040577
PERCENT:10.083592
PERCENT:10.136913
PERCENT:10.181578
PERCENT:10.206372
PERCENT:10.246799
PERCENT:10.280430
PERCENT:10.328043
PERCENT:10.392324
PERCENT:10.472670
PERCENT:10.533674
PERCENT:10.593759
PERCENT:10.647778
PERCENT:10.717702
PERCENT:10.754556
PERCENT:10.824459
PERCENT:10.888666
PERCENT:10.937548
PERCENT:10.983829
PERCENT:11.017809
PERCENT:11.058732
PERCENT:11.094836
PERCENT:11.126088
PERCENT:11.162361
PERCENT:11.225385
PERCENT:11.275323
PERCENT:11.329130
PERCENT:11.394361
PERCENT:11.471062
PERCENT:11.535733
PERCENT:11.612612
PERCENT:11.682283
PERCENT:11.753645
PERCENT:11.836474
PERCENT:11.894647
PERCENT:11.954995
PERCENT:12.034379
PERCENT:12.098396
PERCENT:12.174778
PERCENT:12.242145
PERCENT:12.303551
PERCENT:12.362283
PERCENT:12.429439
PERCENT:12.483446
PERCENT:12.549735
PERCENT:12.612674
PERCENT:12.679227
PERCENT:12.704836
PERCENT:12.753516
PERCENT:12.795972
PERCENT:12.842898
PERCENT:12.888060
PERCENT:12.936762
PERCENT:12.984745
PERCENT:13.025341
PERCENT:13.073324
PERCENT:13.124553
PERCENT:13.179184
PERCENT:13.215287
PERCENT:13.253325
PERCENT:13.301361
PERCENT:13.356119
PERCENT:13.425706
PERCENT:13.482789
PERCENT:13.537082
PERCENT:13.594757
PERCENT:13.650952
PERCENT:13.692056
PERCENT:13.741434
PERCENT:13.777073
PERCENT:13.818260
PERCENT:13.869943
PERCENT:13.917990
PERCENT:13.958998
PERCENT:13.992628
PERCENT:14.019610
PERCENT:14.045769
PERCENT:14.063990
PERCENT:14.090888
PERCENT:14.122478
PERCENT:14.163212
PERCENT:14.184804
PERCENT:14.211777
PERCENT:14.238241
PERCENT:14.269240
PERCENT:14.299003
PERCENT:14.320542
PERCENT:14.349734
PERCENT:14.381219
PERCENT:14.421297
PERCENT:14.447888
PERCENT:14.476689
PERCENT:14.505807
PERCENT:14.535051
PERCENT:14.565448
PERCENT:14.593667
PERCENT:14.620893
PERCENT:14.648340
PERCENT:14.659987
PERCENT:14.683557
PERCENT:14.708509
PERCENT:14.743028
PERCENT:14.775845
PERCENT:14.804307
PERCENT:14.836828
PERCENT:14.867267
PERCENT:14.896427
PERCENT:14.942888
PERCENT:14.988821
PERCENT:15.033634
PERCENT:15.084059
PERCENT:15.140878
PERCENT:15.192380
PERCENT:15.235977
PERCENT:15.291169
PERCENT:15.336923
PERCENT:15.379177
PERCENT:15.422595
PERCENT:15.457980
PERCENT:15.495701
PERCENT:15.519449
PERCENT:15.534785
PERCENT:15.557276
PERCENT:15.573425
PERCENT:15.596920
PERCENT:15.626196
PERCENT:15.658135
PERCENT:15.709142
PERCENT:15.761205
PERCENT:15.805120
PERCENT:15.837376
PERCENT:15.867783
PERCENT:15.898052
PERCENT:15.938902
PERCENT:15.977246
PERCENT:16.006142
PERCENT:16.039043
PERCENT:16.076828
PERCENT:16.118132
PERCENT:16.166315
PERCENT:16.208761
PERCENT:16.260401
PERCENT:16.312073
PERCENT:16.347237
PERCENT:16.377337
PERCENT:16.408558
PERCENT:16.443066
PERCENT:16.475386
PERCENT:16.508106
PERCENT:16.551186
PERCENT:16.600660
PERCENT:16.654604
PERCENT:16.709595
PERCENT:16.751976
PERCENT:16.792297
PERCENT:16.846622
PERCENT:16.886679
PERCENT:16.951826
PERCENT:17.006182
PERCENT:17.058310
PERCENT:17.087934
PERCENT:17.121290
PERCENT:17.155798
PERCENT:17.180391
PERCENT:17.209425
PERCENT:17.241999
PERCENT:17.272343
PERCENT:17.299536
PERCENT:17.333113
PERCENT:17.365623
PERCENT:17.393675
PERCENT:17.424980
PERCENT:17.464888
PERCENT:17.500750
PERCENT:17.533175
PERCENT:17.563910
PERCENT:17.604324
PERCENT:17.648970
PERCENT:17.701307
PERCENT:17.751530
PERCENT:17.804735
PERCENT:17.848850
PERCENT:17.893927
PERCENT:17.942587
PERCENT:17.991415
PERCENT:18.037951
PERCENT:18.073950
PERCENT:18.126234
PERCENT:18.165962
PERCENT:18.231174
PERCENT:18.296015
PERCENT:18.351259
PERCENT:18.411524
PERCENT:18.452785
PERCENT:18.511623
PERCENT:18.551510
PERCENT:18.591894
PERCENT:18.634487
PERCENT:18.682070
PERCENT:18.732018
PERCENT:18.779251
PERCENT:18.827276
PERCENT:18.874636
PERCENT:18.910814
PERCENT:18.941633
PERCENT:18.978233
PERCENT:19.024231
PERCENT:19.062649
PERCENT:19.106775
PERCENT:19.170019
PERCENT:19.247248
PERCENT:19.300409
PERCENT:19.336979
PERCENT:19.373505
PERCENT:19.413414
PERCENT:19.447910
PERCENT:19.491201
PERCENT:19.525360
PERCENT:19.555799
PERCENT:19.588266
PERCENT:19.622511
PERCENT:19.707962
PERCENT:19.824982
PERCENT:19.909735
PERCENT:20.054043
PERCENT:20.103888
PERCENT:20.145952
PERCENT:20.178747
PERCENT:20.227692
PERCENT:20.276680
PERCENT:20.319410
PERCENT:20.351467
PERCENT:20.396681
PERCENT:20.442551
PERCENT:20.496019
PERCENT:20.552658
PERCENT:20.615185
PERCENT:20.686356
PERCENT:20.741388
PERCENT:20.801294
PERCENT:20.849077
PERCENT:20.884579
PERCENT:20.923313
PERCENT:20.957705
PERCENT:20.989529
PERCENT:21.020643
PERCENT:21.050406
PERCENT:21.080051
PERCENT:21.108461
PERCENT:21.135519
PERCENT:21.164604
PERCENT:21.194366
PERCENT:21.223822
PERCENT:21.258045
PERCENT:21.295290
PERCENT:21.327261
PERCENT:21.364559
PERCENT:21.401478
PERCENT:21.437908
PERCENT:21.472544
PERCENT:21.505508
PERCENT:21.536623
PERCENT:21.566385
PERCENT:21.599033
PERCENT:21.634207
PERCENT:21.669043
PERCENT:21.704512
PERCENT:21.736757
PERCENT:21.769459
PERCENT:21.800499
PERCENT:21.835123
PERCENT:21.866282
PERCENT:21.901127
PERCENT:21.933563
PERCENT:21.971867
PERCENT:21.997908
PERCENT:22.042551
PERCENT:22.086973
PERCENT:22.139690
PERCENT:22.182327
PERCENT:22.233143
PERCENT:22.264711
PERCENT:22.300045
PERCENT:22.332554
PERCENT:22.364134
PERCENT:22.406580
PERCENT:22.425795
PERCENT:22.466696
PERCENT:22.509956
PERCENT:22.549652
PERCENT:22.599918
PERCENT:22.638189
PERCENT:22.686426
PERCENT:22.728470
PERCENT:22.751236
PERCENT:22.756985
PERCENT:22.759405
PERCENT:22.772131
PERCENT:22.788090
PERCENT:22.807770
PERCENT:22.824648
PERCENT:22.840786
PERCENT:22.854769
PERCENT:22.868721
PERCENT:22.887300
PERCENT:22.900841
PERCENT:22.916842
PERCENT:22.935781
PERCENT:22.968842
PERCENT:23.005674
PERCENT:23.040932
PERCENT:23.075714
PERCENT:23.109642
PERCENT:23.144773
PERCENT:23.165932
PERCENT:23.194151
PERCENT:23.226324
PERCENT:23.254236
PERCENT:23.288153
PERCENT:23.315125
PERCENT:23.341314
PERCENT:23.364355
PERCENT:23.415319
PERCENT:23.478796
PERCENT:23.524887
PERCENT:23.562788
PERCENT:23.625019
PERCENT:23.669535
PERCENT:23.733932
PERCENT:23.813126
PERCENT:23.890957
PERCENT:23.949467
PERCENT:24.026896
PERCENT:24.090933
PERCENT:24.151756
PERCENT:24.224335
PERCENT:24.296648
PERCENT:24.362429
PERCENT:24.422874
PERCENT:24.487377
PERCENT:24.552755
PERCENT:24.612396
PERCENT:24.678051
PERCENT:24.753504
PERCENT:24.815861
PERCENT:24.870344
PERCENT:24.910707
PERCENT:24.940956
PERCENT:24.980379
PERCENT:25.021873
PERCENT:25.060345
PERCENT:25.115503
PERCENT:25.190819
PERCENT:25.246031
PERCENT:25.311855
PERCENT:25.377510
PERCENT:25.432257
PERCENT:25.482269
PERCENT:25.537006
PERCENT:25.600801
PERCENT:25.676252
PERCENT:25.734795
PERCENT:25.759695
PERCENT:25.795122
PERCENT:25.824356
PERCENT:25.860365
PERCENT:25.880753
PERCENT:25.925852
PERCENT:25.967735
PERCENT:26.007740
PERCENT:26.057795
PERCENT:26.114603
PERCENT:26.180586
PERCENT:26.247742
PERCENT:26.299942
PERCENT:26.359846
PERCENT:26.407354
PERCENT:26.450750
PERCENT:26.497423
PERCENT:26.556948
PERCENT:26.600239
PERCENT:26.659426
PERCENT:26.726591
PERCENT:26.801188
PERCENT:26.851063
PERCENT:26.885750
PERCENT:26.924423
PERCENT:26.969509
PERCENT:26.999853
PERCENT:27.047415
PERCENT:27.092861
PERCENT:27.109295
PERCENT:27.152153
PERCENT:27.203371
PERCENT:27.251026
PERCENT:27.301006
PERCENT:27.339531
PERCENT:27.381226
PERCENT:27.426853
PERCENT:27.513287
PERCENT:27.579679
PERCENT:27.617992
PERCENT:27.653282
PERCENT:27.682951
PERCENT:27.712923
PERCENT:27.759142
PERCENT:27.827208
PERCENT:27.871777
PERCENT:27.915215
PERCENT:27.970638
PERCENT:28.020599
PERCENT:28.066351
PERCENT:28.134796
PERCENT:28.186817
PERCENT:28.270164
PERCENT:28.332289
PERCENT:28.382683
PERCENT:28.415890
PERCENT:28.473925
PERCENT:28.538914
PERCENT:28.601091
PERCENT:28.666546
PERCENT:28.725584
PERCENT:28.779697
PERCENT:28.833038
PERCENT:28.891273
PERCENT:28.924736
PERCENT:28.975245
PERCENT:29.027763
PERCENT:29.074520
PERCENT:29.130630
PERCENT:29.208450
PERCENT:29.275236
PERCENT:29.328926
PERCENT:29.393091
PERCENT:29.454836
PERCENT:29.538458
PERCENT:29.597961
PERCENT:29.638641
PERCENT:29.673275
PERCENT:29.713671
PERCENT:29.763716
PERCENT:29.832762
PERCENT:29.885555
PERCENT:29.938517
PERCENT:29.991171
PERCENT:30.042643
PERCENT:30.103878
PERCENT:30.147993
PERCENT:30.201569
PERCENT:30.260754
PERCENT:30.319719
PERCENT:30.371147
PERCENT:30.421413
PERCENT:30.466501
PERCENT:30.514475
PERCENT:30.561897
PERCENT:30.602249
PERCENT:30.649134
PERCENT:30.692341
PERCENT:30.749752
PERCENT:30.803410
PERCENT:30.864868
PERCENT:30.925852
PERCENT:31.003471
PERCENT:31.067118
PERCENT:31.131071
PERCENT:31.198364
PERCENT:31.263998
PERCENT:31.334694
PERCENT:31.389822
PERCENT:31.448341
PERCENT:31.506069
PERCENT:31.567497
PERCENT:31.624443
PERCENT:31.684803
PERCENT:31.743587
PERCENT:31.784817
PERCENT:31.830286
PERCENT:31.868820
PERCENT:31.916666
PERCENT:31.988419
PERCENT:32.054432
PERCENT:32.115871
PERCENT:32.147610
PERCENT:32.160366
PERCENT:32.163452
PERCENT:32.171116
PERCENT:32.182297
PERCENT:32.217102
PERCENT:32.269154
PERCENT:32.296452
PERCENT:32.357258
PERCENT:32.430584
PERCENT:32.517673
PERCENT:32.580791
PERCENT:32.621544
PERCENT:32.656391
PERCENT:32.664772
PERCENT:32.666801
PERCENT:32.668007
PERCENT:32.668957
PERCENT:32.706509
PERCENT:32.719318
PERCENT:32.770813
PERCENT:32.787045
PERCENT:32.806248
PERCENT:32.813194
PERCENT:32.819702
PERCENT:32.825687
PERCENT:32.838665
PERCENT:32.854813
PERCENT:32.864243
PERCENT:32.872780
PERCENT:32.898041
PERCENT:32.928005
PERCENT:32.956585
PERCENT:32.972816
PERCENT:32.988605
PERCENT:33.010189
PERCENT:33.018559
PERCENT:33.035564
PERCENT:33.059101
PERCENT:33.086552
PERCENT:33.097893
PERCENT:33.124199
PERCENT:33.147110
PERCENT:33.163864
PERCENT:33.195168
PERCENT:33.220978
PERCENT:33.241596
PERCENT:33.264721
PERCENT:33.294590
PERCENT:33.324471
PERCENT:33.353355
PERCENT:33.386448
PERCENT:33.416260
PERCENT:33.446056
PERCENT:33.477909
PERCENT:33.504871
PERCENT:33.534760
PERCENT:33.565762
PERCENT:33.596272
PERCENT:33.627441
PERCENT:33.657055
PERCENT:33.687019
PERCENT:33.718513
PERCENT:33.752598
PERCENT:33.781483
PERCENT:33.811935
PERCENT:33.840355
PERCENT:33.869503
PERCENT:33.899021
PERCENT:33.932949
PERCENT:33.963165
PERCENT:33.991344
PERCENT:34.018093
PERCENT:34.064331
PERCENT:34.114388
PERCENT:34.171207
PERCENT:34.217415
PERCENT:34.222256
PERCENT:34.251995
PERCENT:34.307461
PERCENT:34.364956
PERCENT:34.409367
PERCENT:34.457191
PERCENT:34.504215
PERCENT:34.549431
PERCENT:34.561913
PERCENT:34.563107
PERCENT:34.572544
PERCENT:34.585690
PERCENT:34.602940
PERCENT:34.607708
PERCENT:34.609123
PERCENT:34.618614
PERCENT:34.644012
PERCENT:34.692799
PERCENT:34.815693
PERCENT:34.852474
PERCENT:34.895164
PERCENT:34.933266
PERCENT:34.973396
PERCENT:35.011475
PERCENT:35.036522
PERCENT:35.052345
PERCENT:35.066116
PERCENT:35.078102
PERCENT:35.085659
PERCENT:35.134701
PERCENT:35.192131
PERCENT:35.223255

This chunk of the process looks problematic...
+ echo 'Creating a Base System BOM'
Creating a Base System BOM
/bin/rm ${1}/rawBom.txt > /dev/null 2>&1
+ /bin/rm /tmp/niutemp.ZbrIcFvw/rawBom.txt
/usr/sbin/pkgutil --volume "${sourceVol}" --lsbom com.apple.pkg.BaseSystem > ${1}/rawBom.txt
+ /usr/sbin/pkgutil --volume '/Volumes/Macintosh HD' --lsbom com.apple.pkg.BaseSystem
2011-06-21 14:26:22.185 pkgutil[3344:903] PackageKit: *** Missing bundle identifier: /Volumes/Macintosh HD/Library/Receipts/vpn.pkg
# Look for any files added via a combo or security update
pkgList=`/usr/sbin/pkgutil --volume "${sourceVol}" --group-pkgs "com.apple.dvd-boot.pkg-group"`
/usr/sbin/pkgutil --volume "${sourceVol}" --group-pkgs "com.apple.dvd-boot.pkg-group"
++ /usr/sbin/pkgutil --volume '/Volumes/Macintosh HD' --group-pkgs com.apple.dvd-boot.pkg-group
2011-06-21 14:26:23.417 pkgutil[3345:903] PackageKit: *** Missing bundle identifier: /Volumes/Macintosh HD/Library/Receipts/vpn.pkg
No packages found in group 'com.apple.dvd-boot.pkg-group' on '/Volumes/Macintosh HD'.
The warning from PackageKit indicates that something is possibly wrong with the vpn package.
The next (and larger) problem is the "No packages found in group..." line. This suggests that the volume you are trying to image from (presumably also 10.6.7) was not created using the Combo updater.
I would run the 10.6.7 combo update on "Macintosh HD" and try this again.

Similar Messages

  • System image utility fails "Unknown error has occurred"

    Hi,
    I can create disk images from 10.8.3 clients but when i'm putting them through system utility on the 10.8 server it fails after hours of running.
    The log is set to debug and shows the image creates upto 83% then jumps to 100% and later shows unknown errors and failed to create image from restore souce.
    I've created several disk images and saved them to different locations on the server as the source and final image.
    Below i've put in the debug log. Someone please help!!
    Workflow Started (2012-01-02 13:56:58 +0000)
    OS X Server 10.8.3 (12D78), System Image Utility 10.8.3 (624)
    Starting action: Define Image Source (1.4)
    Finished running action: Define Image Source
    Starting action: Create Image (1.7.2)
    Starting image creation process...
    Create NetRestore Image
    Initiating NetRestore from installed volume.
    progressPrefix="_progress"
    ++ progressPrefix=_progress
    scriptsDebugKey="DEBUG"
    ++ scriptsDebugKey=DEBUG
    imageIsUDIFKey="1"
    ++ imageIsUDIFKey=1
    imageFormatKey="UDZO"
    ++ imageFormatKey=UDZO
    mountPoint=""
    ++ mountPoint=
    ownershipInfoKey="501:20"
    ++ ownershipInfoKey=501:20
    blockCopyDeviceKey="0"
    ++ blockCopyDeviceKey=0
    dmgTarget="NetInstall"
    ++ dmgTarget=NetInstall
    potentialRecoveryDevice="disk3s3"
    ++ potentialRecoveryDevice=disk3s3
    asrSource="ASRInstall.pkg"
    ++ asrSource=ASRInstall.pkg
    destPath="/Volumes/Macintosh HD/Library/NetBoot/NetBootSP0/NetRestore of Macintosh 10-8_2.nbi"
    ++ destPath='/Volumes/Macintosh HD/Library/NetBoot/NetBootSP0/NetRestore of Macintosh 10-8_2.nbi'
    skipReorderingKey="0"
    ++ skipReorderingKey=0
    sourceVol="/Volumes/Macintosh HD 1"
    ++ sourceVol='/Volumes/Macintosh HD 1'
    postInstallHelperKey="1"
    ++ postInstallHelperKey=1
    . "${1}/createCommon.sh"
    + . /tmp/niutemp.YPRmigsL/createCommon.sh
    # createCommon.sh
    # Common functionality for the Image creation process.
    # sourced in by the various SIU scripts
    # Copyright © 2007-2012 Apple Inc. All rights reserved.
    # Using dscl, create a user account
    AddLocalUser()
    # $1 volume whose local node database to modify
    # $2 long name
    # $3 short name
    # $4 isAdminUser key
    # $5 password data
    # $6 password hint
    # $7 user picture path
    # $8 Language string
    local databasePath="/Local/Default/Users/${3}"
    local targetVol="${1}"
    # Find a free UID between 501 and 599
    for ((i=501; i<600; i++)); do
    output=`/usr/bin/dscl -f "${targetVol}/var/db/dslocal/nodes/Default" localonly -search /Local/Default/Users UniqueID $i`
    # If there is already an account dscl returns it, so we're looking for an empty return value.
    if [ "$output" == "" ]; then
    break
    fi
    done
    # Create the user record
    /usr/bin/dscl -f "${targetVol}/var/db/dslocal/nodes/Default" localonly -create $databasePath
    if [ $? != 0 ]; then
    echo "Failed to create '${databasePath}'."
    return 1
    fi
    # Add long name
    /usr/bin/dscl -f "${targetVol}/var/db/dslocal/nodes/Default" localonly -append $databasePath RealName "${2}"
    if [ $? != 0 ]; then
    echo "Failed to set the RealName."
    return 1
    fi
    # Set up the users group information
    /usr/bin/dscl -f "${targetVol}/var/db/dslocal/nodes/Default" localonly -append $databasePath PrimaryGroupID 20
    if [ $? != 0 ]; then
    echo "Failed to set the PrimaryGroupID."
    return 1
    fi
    # Add some additional stuff if the user is an admin
    if [ "${4}" == 1 ]; then
    /usr/bin/dscl -f "${targetVol}/var/db/dslocal/nodes/Default" localonly -append "/Local/Default/Groups/admin" GroupMembership "${3}"
    if [ $? != 0 ]; then
    echo "Failed to add the user to the admin group."
    return 1
    fi
    /usr/bin/dscl -f "${targetVol}/var/db/dslocal/nodes/Default" localonly -append "/Local/Default/Groups/_appserveradm" GroupMembership "${3}"
    if [ $? != 0 ]; then
    echo "Failed to add the user to the _appserveradm group."
    return 1
    fi
    /usr/bin/dscl -f "${targetVol}/var/db/dslocal/nodes/Default" localonly -append "/Local/Default/Groups/_appserverusr" GroupMembership "${3}"
    if [ $? != 0 ]; then
    echo "Failed to add the user to the _appserverusr group."
    return 1
    fi
    fi
    # Add UniqueID
    /usr/bin/dscl -f "${targetVol}/var/db/dslocal/nodes/Default" localonly -append $databasePath UniqueID ${i}
    if [ $? != 0 ]; then
    echo "Failed to set the UniqueID."
    return 1
    fi
    # Add Home Directory entry
    /usr/bin/dscl -f "${targetVol}/var/db/dslocal/nodes/Default" localonly -append $databasePath NFSHomeDirectory /Users/${3}
    if [ $? != 0 ]; then
    echo "Failed to set the NFSHomeDirectory."
    fi
    if [ "${6}" != "" ]; then
    /usr/bin/dscl -f "${targetVol}/var/db/dslocal/nodes/Default" localonly -append $databasePath AuthenticationHint "${6}"
    if [ $? != 0 ]; then
    echo "Failed to set the AuthenticationHint."
    return 1
    fi
    fi
    /usr/bin/dscl -f "${targetVol}/var/db/dslocal/nodes/Default" localonly -append $databasePath picture "${7}"
    if [ $? != 0 ]; then
    echo "Failed to set the picture."
    return 1
    fi
    /usr/bin/dscl -f "${targetVol}/var/db/dslocal/nodes/Default" localonly -passwd $databasePath "${5}"
    if [ $? != 0 ]; then
    echo "Failed to set the passwd."
    return 1
    fi
    # Add shell
    /usr/bin/dscl -f "${targetVol}/var/db/dslocal/nodes/Default" localonly -append $databasePath UserShell "/bin/bash"
    if [ $? != 0 ]; then
    echo "Failed to set the UserShell."
    return 1
    fi
    # Create Home directory
    if [ -e "/System/Library/User Template/${8}.lproj/" ]; then
    /usr/bin/ditto "/System/Library/User Template/${8}.lproj/" "${targetVol}/Users/${3}"
    else
    /usr/bin/ditto "/System/Library/User Template/English.lproj/" "${targetVol}/Users/${3}"
    fi
    if [ $? != 0 ]; then
    echo "Failed to copy the User Template."
    return 1
    fi
    /usr/sbin/chown -R $i:$i "${targetVol}/Users/${3}"
    if [ $? != 0 ]; then
    echo "Failed to set ownership on the User folder."
    return 1
    fi
    # Copies a list of files (full paths contained in the file at $1) from source to the path specified in $2
    CopyEntriesFromFileToPath()
    local theFile="$1"
    local theDest="$2"
    local opt=""
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
    opt="-v"
    fi
    while read FILE
    do
    if [ -e "${FILE}" ]; then
    local leafName=`basename "${FILE}"`
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
    echo "Copying ${FILE}."
    fi
    /usr/bin/ditto $opt "${FILE}" "${theDest}/${leafName}" || return 1
    fi
    done < "${theFile}"
    return 0
    # Copies a list of packages (full path, destination pairs contained in the file at $1) from source to .../System/Installation/Packages/
    CopyPackagesWithDestinationsFromFile()
    local theFile="$1"
    local opt=""
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
    opt="-v"
    fi
    while read FILE
    do
    if [ -e "${FILE}" ]; then
    local leafName=`basename "${FILE}"`
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
    echo "Copying ${FILE}."
    fi
    read SUB_PATH
    /usr/bin/ditto $opt "${FILE}" "${mountPoint}/Packages/${SUB_PATH}${leafName}" || return 1
    fi
    done < "${theFile}"
    return 0
    # Create an installer package in ${1} wrapping the supplied script ${2}
    CreateInstallPackageForScript()
    local tempDir="$1"
    local scriptPath="$2"
    local scriptName=`basename "${scriptPath}"`
    local entryDir=`pwd`
    local opt=""
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
    echo "Create installer for script ${scriptName}"
    opt="-v"
    fi
    # shouldn't exist on entry...
    if [ -e "${tempDir}/emptyDir" ]; then
    /bin/rm -rf "${tempDir}/emptyDir"
    fi
    # make some directories to work in
    /bin/mkdir $opt -p "${tempDir}/${scriptName}.pkg/Contents/Resources" || return 1
    /bin/mkdir $opt "${tempDir}/emptyDir" || return 1
    # Create Archive.pax.gz
    cd "${tempDir}/emptyDir"
    /bin/pax -w -x cpio -f "${tempDir}/${scriptName}.pkg/Contents/Archive.pax" .
    /usr/bin/gzip "${tempDir}/${scriptName}.pkg/Contents/Archive.pax"
    cd "${entryDir}"
    # Create the Archive.bom file
    /usr/bin/mkbom "${tempDir}/emptyDir/" "${tempDir}/${scriptName}.pkg/Contents/Archive.bom" || return 1
    # Create the Info.plist
    /bin/cat > "${tempDir}/${scriptName}.pkg/Contents/Info.plist" << END
    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
    <key>CFBundleIdentifier</key>
    <string>com.apple.SystemImageUtility.${scriptName}</string>
    <key>CFBundleShortVersionString</key>
    <string>1</string>
    <key>IFMajorVersion</key>
    <integer>1</integer>
    <key>IFMinorVersion</key>
    <integer>0</integer>
    <key>IFPkgFlagDefaultLocation</key>
    <string>/tmp</string>
    <key>IFPkgFlagInstallFat</key>
    <false/>
    <key>IFPkgFlagIsRequired</key>
    <false/>
    <key>IFPkgFormatVersion</key>
    <real>0.10000000149011612</real>
    </dict>
    </plist>
    END
    echo "pkmkrpkg1" > "${tempDir}/${scriptName}.pkg/Contents/PkgInfo"
    echo "major: 1\nminor: 0" > "${tempDir}/${scriptName}.pkg/Contents/Resources/package_version"
    # Copy the script
    /bin/cp "$scriptPath" "${tempDir}/${scriptName}.pkg/Contents/Resources/postflight"
    # clean up
    /bin/rm -r "${tempDir}/emptyDir"
    return 0
    # Validate or create the requested directory
    CreateOrValidatePath()
    local targetDir="$1"
    if [ ! -d "${targetDir}" ]; then
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
    echo "Creating working path at ${targetDir}"
    fi
    /bin/mkdir -p "${targetDir}" || return 1
    fi
    # If any exist, apply any user accounts
    CreateUserAccounts()
    # $1 volume whose local node database to modify
    local count="${#userFullName[*]}"
    local targetVol="${1}"
    if [ $count -gt 0 ]; then
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
    echo "Adding $count user account(s) to the image"
    fi
    for ((index=0; index<$count; index++)); do
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
    echo "Adding user ${userFullName[$index]}"
    fi
    #lay down user here
    AddLocalUser "${targetVol}" "${userFullName[$index]}" "${userUnixName[$index]}" "${userIsAdmin[$index]}" "${userPassword[$index]}" "${userPassHint[$index]}" "${userImagePath[$index]}" "${userLanguage[$index]}"
    if [ $? != 0 ]; then
    echo "Failed to create the User '${userUnixName[$index]}'."
    return 1
    fi
    #suppress the Apple ID request
    DisableAppleIDRequestForUser "${targetVol}" "${userUnixName[$index]}"
    done
    # "touch"
    /usr/bin/touch "${targetVol}/private/var/db/.AppleSetupDone"
    /usr/bin/touch "${targetVol}/Library/Receipts/.SetupRegComplete"
    fi
    # retry the hdiutil detach until we either time out or it succeeds
    retry_hdiutil_detach()
    local mount_point="${1}"
    local tries=0
    local forceAt=0
    local limit=24
    local opt=""
    forceAt=$(($limit - 1))
    while [ $tries -lt $limit ]; do
    tries=$(( tries + 1 ))
    /bin/sleep 5
    echo "Attempting to detach the disk image again..."
    /usr/bin/hdiutil detach "${mount_point}" $opt
    if [ $? -ne 0 ]; then
    # Dump a list of any still open files on the mountPoint
    if [ "${scriptsDebugKey}" == "DEBUG" ]; then
    /usr/sbin/lsof +fg "${mount_point}"
    fi
    if [ $tries -eq $forceAt ]; then
    echo "Failed to detach disk image at '${mount_point}' normally, adding -force."
    opt="-force"
    fi
    if [ $tries -eq $limit ]; then
    echo "Failed to detach disk image at '${mount_point}'."
    exit 1
    fi
    else
    tries=$limit
    fi
    done
    # Create the dyld shared cache files
    DetachAndRemoveMount()
    local theMount="${1}"
    local mountLoc=`mount | grep "${theMount}"`
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
    echo "Detaching disk image"
    # Dump a list of any still open files on the mountPoint
    if [ "${scriptsDebugKey}" == "DEBUG" ]; then
    /usr/sbin/lsof +fg "${theMount}"
    fi
    fi
    # Finally detach the mount (if it's actually mounted) and dispose the mountPoint directory
    if [ "${mountLoc}" != "" ]; then
    /usr/bin/hdiutil detach "${theMount}" || retry_hdiutil_detach "${theMount}" || return 1
    fi
    /bin/rmdir "${theMount}" || return 1
    return 0
    # Turn off the Apple ID request that happens on first boot after installing the OS
    DisableAppleIDRequestForUser()
    local targetUserLib="${1}/Users/${2}/Library"
    # Only do this if the file doesn't exist
    if [ ! -e "${targetUserLib}/Preferences/com.apple.SetupAssistant.plist" ]; then
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
    echo "Disabling Apple ID request for user '${2}'"
    fi
    /usr/libexec/PlistBuddy -c "Add :DidSeeCloudSetup bool 1" "${targetUserLib}/Preferences/com.apple.SetupAssistant.plist" > /dev/null 2>&1
    /usr/libexec/PlistBuddy -c "Add :LastSeenCloudProductVersion string 10.8" "${targetUserLib}/Preferences/com.apple.SetupAssistant.plist" > /dev/null 2>&1
    fi
    return 0
    # If the pieces exist, enable remote access for the shell image
    EnableRemoteAccess()
    local srcVol="${1}"
    local opt=""
    if [ -e "${srcVol}/usr/lib/pam/pam_serialnumber.so.2" ]; then
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
    echo "Enabling shell image remote access support"
    opt="-v"
    fi
    # install some things (again which aren't part of BaseSystem) needed for remote ASR installs
    /usr/bin/ditto $opt "${srcVol}/usr/lib/pam/pam_serialnumber.so.2" "${mountPoint}/usr/lib/pam/pam_serialnumber.so.2" || return 1
    if [ -e "${srcVol}/usr/sbin/installer" ]; then
    /usr/bin/ditto $opt "${srcVol}/usr/sbin/installer" "${mountPoint}/usr/sbin/installer" || return 1
    fi
    # copy the sshd config and add our keys to the end of it
    if [ -e "${srcVol}/etc/sshd_config" ]; then
    /bin/cat "${srcVol}/etc/sshd_config" - > "${mountPoint}/etc/sshd_config" << END
    HostKey /private/var/tmp/ssh_host_key
    HostKey /private/var/tmp/ssh_host_rsa_key
    HostKey /private/var/tmp/ssh_host_dsa_key
    END
    fi
    fi
    return 0
    # If it exists, install the sharing names and/or directory binding support to the install image
    HandleNetBootClientHelper()
    local tempDir="${1}"
    local targetVol="${2}"
    local opt=""
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
    opt="-v"
    fi
    if [ -e  "${tempDir}/bindingNames.plist" ]; then
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
    echo "Installing Directory Service binding information"
    fi
    /usr/bin/ditto $opt "${tempDir}/bindingNames.plist" "${targetVol}/etc/bindingNames.plist" || return 1
    /usr/sbin/chown root:wheel "${targetVol}/etc/bindingNames.plist"
    /bin/chmod 644 "${targetVol}/etc/bindingNames.plist"
    fi
    if [ -e  "${tempDir}/sharingNames.plist" ]; then
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
    echo "Installing Sharing Names support"
    fi
    /usr/bin/ditto $opt "${tempDir}/sharingNames.plist" "${targetVol}/etc/sharingNames.plist" || return 1
    /usr/sbin/chown root:wheel "${targetVol}/etc/sharingNames.plist"
    /bin/chmod 644 "${targetVol}/etc/sharingNames.plist"
    fi
    if [ -e  "${tempDir}/NetBootClientHelper" ]; then
    /usr/bin/ditto $opt "${tempDir}/NetBootClientHelper" "${targetVol}/usr/sbin/NetBootClientHelper" || return 1
    /usr/sbin/chown root:wheel "${targetVol}/usr/sbin/NetBootClientHelper"
    /bin/chmod 555 "${targetVol}/usr/sbin/NetBootClientHelper"
    /usr/bin/ditto $opt "${tempDir}/com.apple.NetBootClientHelper.plist" "${targetVol}/System/Library/LaunchDaemons/com.apple.NetBootClientHelper.plist" || return 1
    /usr/sbin/chown root:wheel "${targetVol}/System/Library/LaunchDaemons/com.apple.NetBootClientHelper.plist"
    /bin/chmod 644 "${targetVol}/System/Library/LaunchDaemons/com.apple.NetBootClientHelper.plist"
    # finally, make sure it isn't disabled...
    /usr/libexec/PlistBuddy -c "Delete :com.apple.NetBootClientHelper" "${targetVol}/var/db/launchd.db/com.apple.launchd/overrides.plist" > /dev/null 2>&1
    fi
    return 0
    # If any exist, install configuration profiles to the install image
    InstallConfigurationProfiles()
    local tempDir="${1}"
    local targetVol="${2}"
    local profilesDir="${targetVol}/var/db/ConfigurationProfiles"
    if [ -e  "${tempDir}/configProfiles.txt" ]; then
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
    echo "Installing Configuration Profiles"
    fi
    /bin/mkdir -p "${profilesDir}/Setup" || return 1
    # Make sure the perms are correct
    /usr/sbin/chown root:wheel "${profilesDir}"
    /bin/chmod 755 "${profilesDir}"
    /usr/sbin/chown root:wheel "${profilesDir}/Setup"
    /bin/chmod 755 "${profilesDir}/Setup"
    /usr/bin/touch "${profilesDir}/.profilesAreInstalled"
    CopyEntriesFromFileToPath "${tempDir}/configProfiles.txt" "${profilesDir}/Setup" || return 1
    # Enable MCX debugging
    if [ 1 == 1 ]; then
    if [ -e  "${targetVol}/Library/Preferences/com.apple.MCXDebug.plist" ]; then
    /usr/libexec/PlistBuddy -c "Delete :debugOutput" "${targetVol}/Library/Preferences/com.apple.MCXDebug.plist" > /dev/null 2>&1
    /usr/libexec/PlistBuddy -c "Delete :collateLogs" "${targetVol}/Library/Preferences/com.apple.MCXDebug.plist" > /dev/null 2>&1
    fi
    /usr/libexec/PlistBuddy -c "Add :debugOutput string -2" "${targetVol}/Library/Preferences/com.apple.MCXDebug.plist" > /dev/null 2>&1
    /usr/libexec/PlistBuddy -c "Add :collateLogs string 1" "${targetVol}/Library/Preferences/com.apple.MCXDebug.plist" > /dev/null 2>&1
    fi
    fi
    # Converts a list of scripts (full paths contained in the file at $1) into packages in $3
    InstallScriptsFromFile()
    local tempDir="${1}"
    local theFile="${2}"
    local targetDir="${3}"
    local opt=""
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
    echo "Converting scripts into install packages"
    opt="-v"
    fi
    while read FILE
    do
    if [ -e "${FILE}" ]; then
    # make an installer package out of the script
    CreateInstallPackageForScript "$tempDir" "${FILE}" || return 1
    # copy the resulting package to the Packages directory
    local leafName=`basename "${FILE}"`
    /usr/bin/ditto $opt "${tempDir}/${leafName}.pkg" "${targetDir}/${leafName}.pkg" || return 1
    # clean up
    /bin/rm -r "${tempDir}/${leafName}.pkg"
    fi
    done < "${theFile}"
    return 0
    # Prepare the source by deleting stuff we don't want to copy if sourcing a volume
    PostFlightDestination()
    local tempDir="${1}"
    local destDir="${2}"
    local opt=""
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
    echo "Performing post install cleanup"
    opt="-v"
    fi
    # delete the DS indices to force reindexing...
    if [ -e "${mountPoint}/var/db/dslocal/indices/Default/index" ]; then
    /bin/rm $opt "${mountPoint}/var/db/dslocal/indices/Default/index"
    fi
    # detach the disk and remove the mount folder
    DetachAndRemoveMount "${mountPoint}"
    if [ $? != 0 ]; then
    echo "Failed to detach and clean up the mount at '${mountPoint}'."
    return 1
    fi
    echo "Correcting permissions. ${ownershipInfoKey} $destDir"
    /usr/sbin/chown -R "${ownershipInfoKey}" "$destDir"
    # Prepare the source by deleting stuff we don't want to copy if sourcing a volume
    PreCleanSource()
    local srcVol="$1"
    local opt=""
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
    opt="-v"
    fi
    if [ -e "$srcVol/private/var/vm/swapfile*" ]; then
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
    echo "Removing swapfiles on $1"
    fi
    /bin/rm $opt "$srcVol/private/var/vm/swapfile*"
    fi
    if [ -e "$srcVol/private/var/vm/sleepimage" ]; then
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
    echo "Removing sleepimage on $1"
    fi
    /bin/rm $opt "$srcVol/private/var/vm/sleepimage"
    fi
    if [ -d "$srcVol/private/tmp" ]; then
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
    echo "Cleaning out /private/tmp on $1"
    fi
    /bin/rm -r $opt "$srcVol/private/tmp/*" > /dev/null 2>&1
    fi
    if [ -d "$srcVol/private/var/tmp" ]; then
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
    echo "Cleaning out /private/var/tmp on $1"
    fi
    /bin/rm -r $opt "$srcVol/private/var/tmp/*" > /dev/null 2>&1
    fi
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
    echo "Cleaning out devices and volumes on $1"
    fi
    if [ -d "$srcVol/Volumes" ]; then
    /bin/rm -r $opt "$srcVol/Volumes/*" > /dev/null 2>&1
    fi
    if [ -d "$srcVol/dev" ]; then
    /bin/rm $opt "$srcVol/dev/*" > /dev/null 2>&1
    fi
    if [ -d "$srcVol/private/var/run" ]; then
    /bin/rm -r $opt "$srcVol/private/var/run/*" > /dev/null 2>&1
    fi
    # Copy kernel and build the kext cache on the boot image
    PrepareKernelAndKextCache()
    local srcDir="$1"
    local destDir="$2"
    local opt=""
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
    echo "Preparing the kernel and kext cache for the boot image"
    opt="-v"
    fi
    # Insure the kext cache on our source volume (the boot shell) is up to date
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
    echo "Updating kext cache on source volume"
    fi
    /usr/sbin/kextcache -update-volume "${srcDir}" || return 1
    # Copy the i386 and, if it exists, the x86_64 architecture
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
    echo "Installing the kext cache to the boot image"
    fi
    # make sure this doesn't exist
    if [ -e "${destDir}/i386" ]; then
    /bin/rm -rf "${destDir}/i386"
    fi
    # Install kextcaches to the nbi folder
    if [ "${scriptsDebugKey}" == "VERBOSE" -o "${scriptsDebugKey}" == "DEBUG" ]; then
    echo "Creating a kernelcache for the boot shell"
    fi
    /bin/mkdir -p $opt "${destDir}/i386/x86_64" || return 1
    /usr/sbin/kextcache -arch x86_64 -L -N -S -z -K "${srcDir}/mach_kernel" -c "${destDir}/i386/x86_64/kernelcache" "${srcDir}/System/Library/Extensions" || return 1

    I am seeing a very similar output trying to make a netrestore image of a 10.8.4 Macbook Air on a 10.8.4 Mac Mini running OSX Server.  Gets to 84% and then shows the -1 progress and then just hangs until I cancel it (I haven't tried leaving it over night but left it that way for hours).
    Did you ever figure out what was going on or have a workaround to create an image?
    Thanks!

  • Netinstall error: There was an error creating the image

    I am using Mac OS X Server 10.4.11 and trying to create a NetInstall Image using the System Image Utility 10.4.11. The .dmg image that I am using is a Mac OS X 10.5.6 version. After completing all the steps in Sys Image Itil it iteventually gives me the following error: There was an error creating the image.
    And indicates: error creating image and when I use this NetInstall image the client goes in an eternal reboot.
    It is very frusterating since I was able to make a netinstall image using a dmg from a Mac OS X 10.4 version and I was able to do a complete successful Netinstall. Anybody knows why and how to solve this error.

    Hi
    Mount the .dmg and launch SIU. If it's a valid image it should appear sandwiched between Sources and Workflows. Same process for a client mac connected via firewire or a bootable Installer Disk. Click on it and select NetInstall or NetBoot depending on what you want. You should be presented with Apple's EULA, click Yes/OK and save it to the appropriate folder assuming you've done the necessary in Server Admin. The Admin Manual is actually not too bad:
    http://images.apple.com/server/macosx/docs/SystemImaging_and_SW_Update_Adminv10.5.pdf
    No need to worry about index numbers either as it does it all for you. It's actually a lot easier than 10.4. Bear in mind if you want to customize the image you have to do it at this stage. You can't go back and edit/customize the nbi once it's created.
    You might want to consult the other documentation available for 10.5 Server here:
    http://www.apple.com/server/macosx/resources/
    Tony

  • Sqlplus "start" show error on failure exit on success

    Hi all,
    I have made a "Windows Scripting Host" script that dynamically create a sql script for package compilation and run it with sqlplus.
    Script code
    set scan off
    set define off
    +@<package_path>+
    show error
    pause
    exit
    What I want is that when the package compilation success the script exit, but show errors, pause, exit when fails. Something like this
    Script code
    set scan off
    set define off
    +@<package_path>+
    if fail then
    show error
    pause
    end if
    exit
    I try to use "whenever sqlerror continue" but with no luck
    Script code
    set escchar @
    set scan off
    set define off
    whenever sqlerror continue
    +@C:\Progetti\Net@Siu\Database\SIUMETERING\STOREDS\PKSPEC\old\LET_GEST_ACQUISIZIONE_ESTESA_h.sql+
    exit
    show error
    pause
    exit
    Thanks for your help
    Massimo
    Edited by: maxfid on 29-apr-2010 20.24
    Edited by: maxfid on 30-apr-2010 14.39

    Catching errors directly in sqlplus is tough. Hitting an error after setting "whenever sqlerror exit" and you are done for. No time to pause. You can set a flag on error via a bind variable that a calling program could use to determine what to do next:
    SQL> var err_num number
    SQL> exec :err_num:=9999
    PL/SQL procedure successfully completed.
    SQL> whenever sqlerror exit :err_num
    SQL> select andy from dual;
    select andy from dual
    ERROR at line 1:
    ORA-00904: "ANDY": invalid identifier
    Disconnected from Oracle Database 10g Release 10.2.0.1.0 - Production
    C:\Temp>echo %errorlevel%
    9999But if all your scripts are doing are compiling source code then compilation warnings aren't errors anyway.
    I've seen Laurent Schneider do some fancy things with catching compilation "errors" in this regard: {message:id=2732328}
    If the end goal is to run a lot of scripts and stop when there is an error maybe after each script you could output (spool) a "show errors" to a file and then peek at it before moving onto the next script. If you don't see a "No errors." then pause.

  • Error creating a netboot image with System Image Utility

    Hi all !
    I am trying to create a NetBoot image from my Panther CD, to boot an old iBook.
    I am using System Image Utility version 10.4.11.
    I can create a NetInstall image, but when I create a NetBoot image SIU give me an error.
    I looked in the logs and I can see the error is generated by the script Applications/Server/System Image Utility.app/Contents/Resources/.preinstall
    This command is the culprit:
    /usr/sbin/installer -verbose -lang 'eng' -pkg '/Volumes/Mac OS X Install Disc 1/System/Installation/Packages/OSInstall.mpkg' -target /Library/NetBoot/NetBootSP0/PantBoot3.nbi/mnt -_multiDiscPath /tmp/siuInstallExtras
    The error is (as seen in the logs):
    This package requires authentication to install.
    If I take the command and run it in the terminal using sudo it goes thru, but gives another error:
    installer: Cannot install on volume /Library/NetBoot/NetBootSP0/PantBoot3.nbi/mnt because it is disabled.
    installer: Mac OS X cannot start up from this volume.
    Is this thing supposed to work ?? It seems to me SIU is buggy.
    Any help would be much appreciated.
    Regards
    Mike

    I'm not digging the new SIU at all yet. Maybe I'll get used to it in time. I couldn't get it to accept a Tiger 10.4.6 Install disc the other day to build a NetInstall. Don't know if I was doing something wrong or if it was instinctively rejecting it because I was doing something unsupported.
    I miss NetRestore. I think Mike wants use to use Automator... but I want NetRestore's automated Multicast ASR and Windows image restore. It would take a lot of work to match Mike's shrink-wrapped solution.
    Speaking of NetRestore, its creator Mike Bombich advises against use CCC for mass deployment. This may include what you're doing. It's really a backup tool, but unfortunately a lot of people got into the habit of using it for creating deployment images and these often have problems. It's the best tool for create images that you will deploy onto multiple Macs.

  • System Image Utility Failing Error 2

    I've built my 10.9.4 gold image on a Macbook Pro, created the image with SIU and deployed successfully to the other Macbooks.   When I went to deploy to the iMacs we have I get the error OSX Could not be installed on your computer.  Did some research and found I needed to install the Combo update if I wanted to deploy to multiple hardware, so installed OSXUpdCombo10.9.4  into the gold machine. Now I can no longer import that with System Image Utility.
    System Image log looks like:
    "/Library/NetBoot/NetBootSP0/IMG-OXL-1094-All.nbi/System.dmg"
    created: /Library/NetBoot/NetBootSP0/IMG-OXL-1094-All.nbi/NetInstall.dmg
    ditto: can't get real path for source '/tmp/mnt_bs.aLkzKL2z/System/Library/CoreServices/PlatformSupport.plist'
    Execution of 'createRestoreFromSources.sh' failed. Cleaning up.
    "disk5" unmounted.
    "disk5" ejected.
    Failed to create image from restore source.
    The operation couldn’t be completed. (System Image Utility error 2.)
    Looks like this can happen if the version of Mavericks on the server and client don't match.  So I've installed the combo updater on the server for good measure.  Still getting the same error.
    Server reports it is running 10.9.4 (13E28),client says the same.
    Any idea where to look next?

    Went back through my notes, I read that you should run the 10.6 combo updater before trying to image, and somehow decided that meant 10.9 :/
    Thanks for the info, that makes sense.  I've had to make separate images for each model this round, but I'll add that info to my notes and do it right next time
    Jase

  • System Image Utility (SIU) 10.6.0 to 10.6.2

    I'm using the following workflow; the goal is to build an image based on the 10.6.0 installation DVD and to add the 10.6.2 Combo Update to the image so the clients are deployed with 10.6.2.
    Define Image Source
    Enable Automated Installation
    Add Packages and Post-Install Scripts (Add the 10.6.2 combo update .pkg file)
    Customize Package Selection (10.6.2 Update is selected as Default)
    Create Image
    The image builds cleanly and then I try to NetInstall a client. The install works fine, but in the installer log when it tries to install the 10.6.2 combo update, it throws an error saying that the package is untrusted. Has anyone seen behavior like this and knows of a way to resolve it? Is there a better way to accomplish building a 10.6.2 image from the 10.6.0 DVD and combo update?

    I have a workflow as follows that works:
    Define Image Source (10.6 DVD)
    Add Packages and Post-Install Scripts (with 10.6.2 combo)
    Create Image (NetRestore)
    I have not had any luck yet with any workflow containing Automated Installation in SIU 2.

  • Problem exporting image -- "Hostname Error"

    Hello all --
    I've booted a client from an external drive, and, using System Image Utility, created an install image of the internal drive.
    Now, I'm trying to export the image to my XServe. When the target dialogue comes up, I enter:
    Address: 172.28.40.10
    User Name: admin
    pw: *****
    After a few seconds, SIU tells me:
    "Hostname error. No address associated with hostname."
    I'm assuming that my XServe's DNS is not configured properly. Does this sound right? Any idea what's going on, and how I might get the Export to work?
    Thanks --
    Matt
    X Serve   Mac OS X (10.4.7)  

    sorry,
    discovered that preview (the application in which I opened my shake-output) doesn't recognize shake exported files...
    problem solved.

  • Oracle (JDBC) Thin Driver Ora-00600 Error

    Hi,
    I'm using Oracle9i JDeveloper and trying to access an Oracle 9.2.0.2 database using the oracle thin driver.
    Sometimes I get the error message "SQLException: ORA-00600: internal error code" when I execute queries. When I change the query to select smaller fields, it seems okay.
    Can someone help me out with this?
    Thanks,
    Siu Sem

    Ora-600 errors typically are:
    (1) Accompanied by subsequent error number information
    in square brackets like:
    ORA-600:[12345] [] [] [] []
    (2) A server-side trace file written out
    We need the additional information of that error number in brackets to help you more.

  • Error in starting Adobe Bridge in Photoshop CS2

    I've just installed Photoshop CS2, however upon opening Adobe Bridge this error message appears " The application has failed to start because libagluc28.dll was not found. Reinstalling to application may fix the problem"
    I have reinstalled and click repair but to no avail
    I followed Adobe Support Knowledgebase solution and run CMD and this appears:
    c:Documents and Settings/Jesus M Ferraris>
    then i entered the command
    cacls c:\windows\installer /T /E /C /G administrators:F
    but an error message appears - 'cacls' is not recognized as an internal or external command, operable program or bathc file
    I also entered the next command
    cacls "c:\documents and setting\all users" /Y /E /C /G administrators:F
    still the same error as above appears, Please help, have I miss something or was my procedure correct...
    P4, 512ram, WXP 80gHD

    Very useful.
    Good Luck.
    My
    Si
    tes

  • Windows Vista: Ipod Error Message, no longer read by PCs

    Hello,
    I have a 5th generation black ipod video with 30GB of memory.
    The other day I hooked it up to my laptop (Toshiba, 4 months old) that it's been functioning on with no problems whatsoever. This weird error message flashed twice about it not being able to sync because of some software problem.
    Eversince then, the only thing I can charge my ipod on is the family treadmill in the basement (~_~) as no other computer in the house recognizes it. I can't even charge it through the wall sockets, either.
    I have changed the ipod cord, still no luck. I've also reset the device about 3 or 4 times and uninstalled, restarted the laptop then reinstalled itunes. I would like to reset it back to factory settings but that's impossible as computers/laptops don't pick it up. I live very far from a Mac store...
    What's a girl to do? I can't live without my Busta Rhymes and Wu-Tang Clan!
    Any advice would be greatly appreciated! Thanks!

    you have to update Vista go to this site and up-date http://windowsupdate.microsoft.com

  • Error while offsetting a variable

    Hello Experts
    I want to display the data for last 5 years in my query. So I tried using the SAP exit variable Current Calendar Year (0CYEAR) and the offset it by 5. However, I am getting the following error message for the query "System error in program SAPLRR12 and form REP_ASSIGN_INITIAL_OPT-01"
    Any Help on this is appreciated and points will be assigned.
    Thanks

    Thanks Chetan for your prompt reply. I have assigned points.
    But I would appreciate if you help me clear my understanding of offseting a variable.
    Say if the Current Calendar Year variable returns 2008, then will offseting that variable by 5 return me the data for years 2008, 2007, 2006, 2005 , 2004. Or, will it just return me the data for 2008 - 5 = 2004 only.
    Thanks
    Rishi

  • Safari doesn't open and comes up with this error report.

    Please help.
    Process:         Safari [474]
    Path:            /Applications/Safari.app/Contents/MacOS/Safari
    Identifier:      com.apple.Safari
    Version:         7.0.4 (9537.76.4)
    Build Info:      WebBrowser-7537076004000000~3
    Code Type:       X86-64 (Native)
    Parent Process:  launchd [180]
    Responsible:     Safari [474]
    User ID:         501
    Date/Time:       2014-06-01 17:47:34.928 +0100
    OS Version:      Mac OS X 10.9.3 (13D65)
    Report Version:  11
    Anonymous UUID:  C44E082E-A9DF-3DBD-218D-A6DF6F4FFD83
    Crashed Thread:  17
    Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes: EXC_I386_GPFLT
    External Modification Warnings:
    Thread creation by external task.
    Application Specific Information:
    Process Model:
    Multiple Web Processes
    Thread 0:: Dispatch queue: com.apple.main-thread
    0   com.apple.JavaScriptCore                0x000000010d1b8320 ***::HashTableAddResult<***::HashTableIterator<unsigned long, ***::KeyValuePair<unsigned long, unsigned long>, ***::KeyValuePairKeyExtractor<***::KeyValuePair<unsigned long, unsigned long> >, ***::IntHash<unsigned long>, ***::HashMapValueTraits<***::HashTraits<unsigned long>, ***::HashTraits<unsigned long> >, ***::HashTraits<unsigned long> > > ***::HashTable<unsigned long, ***::KeyValuePair<unsigned long, unsigned long>, ***::KeyValuePairKeyExtractor<***::KeyValuePair<unsigned long, unsigned long> >, ***::IntHash<unsigned long>, ***::HashMapValueTraits<***::HashTraits<unsigned long>, ***::HashTraits<unsigned long> >, ***::HashTraits<unsigned long> >::add<***::HashMapTranslator<***::HashMapValueTraits<***::HashTraits<unsigned long>, ***::HashTraits<unsigned long> >, ***::IntHash<unsigned long> >, unsigned long, unsigned long>(unsigned long const&, unsigned long const&) + 0
    1   com.apple.JavaScriptCore                0x000000010d0e3507 ***::MetaAllocator::incrementPageOccupancy(void*, unsigned long) + 119
    2   com.apple.JavaScriptCore                0x000000010d0e2b9a ***::MetaAllocator::allocate(unsigned long, void*) + 234
    3   com.apple.JavaScriptCore                0x000000010d0e2a46 JSC::ExecutableAllocator::allocate(JSC::VM&, unsigned long, void*, JSC::JITCompilationEffort) + 54
    4   com.apple.JavaScriptCore                0x000000010d0e2990 JSC::LinkBuffer::linkCode(void*, JSC::JITCompilationEffort) + 64
    5   com.apple.JavaScriptCore                0x000000010d0e1d50 JSC::nativeForGenerator(JSC::VM*, JSC::CodeSpecializationKind) + 4320
    6   com.apple.JavaScriptCore                0x000000010d0e0c60 JSC::nativeCallGenerator(JSC::VM*) + 16
    7   com.apple.JavaScriptCore                0x000000010d0e0648 JSC::JITThunks::ctiStub(JSC::VM*, JSC::MacroAssemblerCodeRef (*)(JSC::VM*)) + 104
    8   com.apple.JavaScriptCore                0x000000010d0e05cc JSC::JIT::privateCompileCTINativeCall(JSC::VM*, long long (*)(JSC::ExecState*)) + 28
    9   com.apple.JavaScriptCore                0x000000010d0e0155 JSC::JITThunks::hostFunctionStub(JSC::VM*, long long (*)(JSC::ExecState*), long long (*)(JSC::ExecState*)) + 165
    10  com.apple.JavaScriptCore                0x000000010d0dffc6 JSC::JSFunction::create(JSC::ExecState*, JSC::JSGlobalObject*, int, ***::String const&, long long (*)(JSC::ExecState*), JSC::Intrinsic, long long (*)(JSC::ExecState*)) + 118
    11  com.apple.JavaScriptCore                0x000000010d0dfd9c JSC::FunctionPrototype::addFunctionProperties(JSC::ExecState*, JSC::JSGlobalObject*, JSC::JSFunction**, JSC::JSFunction**) + 108
    12  com.apple.JavaScriptCore                0x000000010d0da5e6 JSC::JSGlobalObject::reset(JSC::JSValue) + 838
    13  com.apple.JavaScriptCore                0x000000010d0fd025 JSGlobalContextCreateInGroup + 533
    14  com.apple.Safari.framework              0x000000010ca2b0e1 Safari::SearchProvidersController::sortSearchProviders(***::Vector<***::RefPtr< Safari::SearchProvider>, 0ul, ***::CrashOnOverflow>&, NSString*) + 47
    15  com.apple.Safari.framework              0x000000010ca2e87a Safari::SearchProvidersController::parseProvidersFromManifest(Safari::CF::Dicti onary const&, ***::Vector<***::RefPtr<Safari::SearchProvider>, 0ul, ***::CrashOnOverflow>&, Safari::SearchProvider const*&, int&) + 576
    16  com.apple.Safari.framework              0x000000010ca2afbc Safari::SearchProvidersController::loadAllProviders(Safari::CF::URL const&) + 120
    17  com.apple.Safari.framework              0x000000010ca2ae9d Safari::SearchProvidersController::SearchProvidersController() + 123
    18  com.apple.Safari.framework              0x000000010ca2adee Safari::SearchProvidersController::shared() + 46
    19  com.apple.Safari.framework              0x000000010c8a95ce -[BrowserWindowControllerMac _defaultSearchProviderDisplayName] + 11
    20  com.apple.Safari.framework              0x000000010c89b6f1 -[BrowserWindowControllerMac unifiedFieldPlaceholderString] + 65
    21  com.apple.Safari.framework              0x000000010c8a9657 -[BrowserWindowControllerMac _updateSearchFieldProviderText] + 61
    22  com.apple.Safari.framework              0x000000010c8a9d90 -[BrowserWindowControllerMac _setUpLocationBar] + 203
    23  com.apple.Safari.framework              0x000000010c899610 -[BrowserWindowControllerMac windowDidLoad] + 907
    24  com.apple.AppKit                        0x00007fff8c1273ac -[NSWindowController _windowDidLoad] + 450
    25  com.apple.Safari.framework              0x000000010cacbc13 -[WindowController _windowDidLoad] + 43
    26  com.apple.AppKit                        0x00007fff8c10dfa6 -[NSWindowController window] + 110
    27  com.apple.Safari.framework              0x000000010c899c9a -[BrowserWindowControllerMac showWindow:] + 50
    28  com.apple.AppKit                        0x00007fff8c1db5f5 -[NSDocument showWindows] + 100
    29  com.apple.Safari.framework              0x000000010c86800b -[BrowserDocument showWindows] + 39
    30  com.apple.AppKit                        0x00007fff8c1da168 -[NSDocumentController openUntitledDocumentAndDisplay:error:] + 458
    31  com.apple.AppKit                        0x00007fff8c1d9f5f -[NSDocumentController newDocument:] + 36
    32  com.apple.Safari.framework              0x000000010c9fb4e3 -[WindowReopener reopenWithArrayOfWindowControllerNames:] + 120
    33  com.apple.Safari.framework              0x000000010c9fb6a4 -[WindowReopener init] + 117
    34  com.apple.Safari.framework              0x000000010c9fb7b3 +[WindowReopener reopenWindows] + 43
    35  com.apple.Safari.framework              0x000000010c7dd0f7 -[AppController _openUntitledFileWhileLaunching:] + 157
    36  com.apple.Safari.framework              0x000000010c7d9fa3 -[AppController applicationOpenUntitledFile:] + 22
    37  com.apple.AppKit                        0x00007fff8c108db0 -[NSApplication _doOpenUntitled] + 447
    38  com.apple.AppKit                        0x00007fff8c02bdf1 __58-[NSApplication(NSAppleEventHandling) _handleAEOpenEvent:]_block_invoke + 254
    39  com.apple.AppKit                        0x00007fff8c02bb80 __95-[NSPersistentUIManager restoreAllPersistentStateRegisteringAsReadyWhenDone:completionHandler:]_block_i nvoke538 + 37
    40  com.apple.AppKit                        0x00007fff8c02bb13 __78-[NSDocumentController(NSInternal) _autoreopenDocumentsWithCompletionHandler:]_block_invoke_2 + 140
    41  com.apple.AppKit                        0x00007fff8c02b6fd -[NSDocumentController(NSInternal) _autoreopenDocumentsWithCompletionHandler:] + 746
    42  com.apple.AppKit                        0x00007fff8c023aa5 -[NSPersistentUIRestorer finishedRestoringWindowsWithZOrder:completionHandler:] + 1714
    43  com.apple.AppKit                        0x00007fff8be980b9 -[NSPersistentUIRestorer restoreStateFromRecords:usingDelegate:completionHandler:] + 2110
    44  com.apple.AppKit                        0x00007fff8be97759 -[NSPersistentUIManager restoreAllPersistentStateRegisteringAsReadyWhenDone:completionHandler:] + 398
    45  com.apple.AppKit                        0x00007fff8be96a56 -[NSApplication _reopenWindowsAsNecessaryIncludingRestorableState:registeringAsReady:completion Handler:] + 398
    46  com.apple.AppKit                        0x00007fff8be96799 -[NSApplication(NSAppleEventHandling) _handleAEOpenEvent:] + 557
    47  com.apple.AppKit                        0x00007fff8be961fb -[NSApplication(NSAppleEventHandling) _handleCoreEvent:withReplyEvent:] + 242
    48  com.apple.Foundation                    0x00007fff95c9bf0a -[NSAppleEventManager dispatchRawAppleEvent:withRawReply:handlerRefCon:] + 294
    49  com.apple.Foundation                    0x00007fff95c9bd7d _NSAppleEventManagerGenericHandler + 106
    50  com.apple.AE                            0x00007fff8e96de1f aeDispatchAppleEvent(AEDesc const*, AEDesc*, unsigned int, unsigned char*) + 381
    51  com.apple.AE                            0x00007fff8e96dc32 dispatchEventAndSendReply(AEDesc const*, AEDesc*) + 31
    52  com.apple.AE                            0x00007fff8e96db36 aeProcessAppleEvent + 315
    53  com.apple.HIToolbox                     0x00007fff91463161 AEProcessAppleEvent + 56
    54  com.apple.AppKit                        0x00007fff8be920d6 _DPSNextEvent + 1026
    55  com.apple.AppKit                        0x00007fff8be918bb -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 122
    56  com.apple.Safari.framework              0x000000010c82cd00 -[BrowserApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 161
    57  com.apple.AppKit                        0x00007fff8be859bc -[NSApplication run] + 553
    58  com.apple.AppKit                        0x00007fff8be707a3 NSApplicationMain + 940
    59  com.apple.Safari.framework              0x000000010c9fec8d SafariMain + 267
    60  libdyld.dylib                           0x00007fff94b0c5fd start + 1
    Thread 1:
    0   libsystem_kernel.dylib                  0x00007fff96d0ae6a __workq_kernreturn + 10
    1   libsystem_pthread.dylib                 0x00007fff9509af08 _pthread_wqthread + 330
    2   libsystem_pthread.dylib                 0x00007fff9509dfb9 start_wqthread + 13
    Thread 2:: Dispatch queue: com.apple.libdispatch-manager
    0   libsystem_kernel.dylib                  0x00007fff96d0b662 kevent64 + 10
    1   libdispatch.dylib                       0x00007fff8eff2421 _dispatch_mgr_invoke + 239
    2   libdispatch.dylib                       0x00007fff8eff2136 _dispatch_mgr_thread + 52
    Thread 3:
    0   libsystem_kernel.dylib                  0x00007fff96d0ae6a __workq_kernreturn + 10
    1   libsystem_pthread.dylib                 0x00007fff9509af08 _pthread_wqthread + 330
    2   libsystem_pthread.dylib                 0x00007fff9509dfb9 start_wqthread + 13
    Thread 4:: Dispatch queue: com.apple.CFURLCACHE_work_queue
    0   libsystem_kernel.dylib                  0x00007fff96d0b422 getdirentriesattr + 10
    1   com.apple.CoreServicesInternal          0x00007fff974cb938 ftsattr_build + 1019
    2   com.apple.CoreServicesInternal          0x00007fff974cadbe ftsattr_read$INODE64 + 377
    3   com.apple.CoreServicesInternal          0x00007fff974c79ba _GetDirectoryURLs(_CFURLEnumerator*) + 1378
    4   com.apple.CoreServicesInternal          0x00007fff974c68dc _URLEnumeratorGetNextURL + 157
    5   com.apple.CFNetwork                     0x00007fff8e52df7a CFURLCacheFS::getFileSystemUsage() const + 178
    6   com.apple.CFNetwork                     0x00007fff8e52dd4a __CFURLCache::GetFileSystemPersistentStoreSizeFromDisk() const + 58
    7   com.apple.CFNetwork                     0x00007fff8e52cdc5 __CFURLCache::OpenDatabase() + 555
    8   com.apple.CFNetwork                     0x00007fff8e52cb3f __CFURLCache::ProcessCacheTasks0(bool) + 1373
    9   com.apple.CFNetwork                     0x00007fff8e52c481 __CFURLCache::ProcessCacheTasks(bool) + 53
    10  com.apple.CFNetwork                     0x00007fff8e52bf56 __CFURLCache::_CFURLCacheTimerCallback0() + 286
    11  com.apple.CFNetwork                     0x00007fff8e52bdd7 __CFURLCache::_CFURLCacheTimerCallback(void*) + 43
    12  com.apple.CFNetwork                     0x00007fff8e52bcff ___ZN12__CFURLCache29SignalWorkerTaskToPerformWorkEv_block_invoke + 18
    13  libdispatch.dylib                       0x00007fff8eff31bb _dispatch_call_block_and_release + 12
    14  libdispatch.dylib                       0x00007fff8eff028d _dispatch_client_callout + 8
    15  libdispatch.dylib                       0x00007fff8eff2673 _dispatch_queue_drain + 451
    16  libdispatch.dylib                       0x00007fff8eff39c1 _dispatch_queue_invoke + 110
    17  libdispatch.dylib                       0x00007fff8eff1f87 _dispatch_root_queue_drain + 75
    18  libdispatch.dylib                       0x00007fff8eff3177 _dispatch_worker_thread2 + 40
    19  libsystem_pthread.dylib                 0x00007fff9509aef8 _pthread_wqthread + 314
    20  libsystem_pthread.dylib                 0x00007fff9509dfb9 start_wqthread + 13
    Thread 5:: WebCore: IconDatabase
    0   libsystem_kernel.dylib                  0x00007fff96d0b962 pread + 10
    1   libsqlite3.dylib                        0x00007fff8b8161d4 unixRead + 100
    2   libsqlite3.dylib                        0x00007fff8b83c5ee readDbPage + 478
    3   libsqlite3.dylib                        0x00007fff8b83b18d sqlite3PagerAcquire + 349
    4   libsqlite3.dylib                        0x00007fff8b8e83a1 checkTreePage + 289
    5   libsqlite3.dylib                        0x00007fff8b8e87ca checkTreePage + 1354
    6   libsqlite3.dylib                        0x00007fff8b863d53 sqlite3VdbeExec + 59651
    7   libsqlite3.dylib                        0x00007fff8b85440a sqlite3_step + 666
    8   com.apple.WebCore                       0x000000010db3bec9 WebCore::SQLiteStatement::step() + 73
    9   com.apple.WebCore                       0x000000010e285d5e WebCore::IconDatabase::checkIntegrity() + 110
    10  com.apple.WebCore                       0x000000010db3b7b1 WebCore::IconDatabase::performOpenInitialization() + 65
    11  com.apple.WebCore                       0x000000010db3b0c3 WebCore::IconDatabase::iconDatabaseSyncThread() + 259
    12  com.apple.JavaScriptCore                0x000000010d0c9f3f ***::wtfThreadEntryPoint(void*) + 15
    13  libsystem_pthread.dylib                 0x00007fff95099899 _pthread_body + 138
    14  libsystem_pthread.dylib                 0x00007fff9509972a _pthread_start + 137
    15  libsystem_pthread.dylib                 0x00007fff9509dfc9 thread_start + 13
    Thread 6:
    0   libsystem_kernel.dylib                  0x00007fff96d0ae6a __workq_kernreturn + 10
    1   libsystem_pthread.dylib                 0x00007fff9509af08 _pthread_wqthread + 330
    2   libsystem_pthread.dylib                 0x00007fff9509dfb9 start_wqthread + 13
    Thread 7:
    0   libsystem_kernel.dylib                  0x00007fff96d0ae6a __workq_kernreturn + 10
    1   libsystem_pthread.dylib                 0x00007fff9509af08 _pthread_wqthread + 330
    2   libsystem_pthread.dylib                 0x00007fff9509dfb9 start_wqthread + 13
    Thread 8:
    0   libsystem_kernel.dylib                  0x00007fff96d0ae6a __workq_kernreturn + 10
    1   libsystem_pthread.dylib                 0x00007fff9509af08 _pthread_wqthread + 330
    2   libsystem_pthread.dylib                 0x00007fff9509dfb9 start_wqthread + 13
    Thread 9:
    0   libsystem_kernel.dylib                  0x00007fff96d0ae6a __workq_kernreturn + 10
    1   libsystem_pthread.dylib                 0x00007fff9509af08 _pthread_wqthread + 330
    2   libsystem_pthread.dylib                 0x00007fff9509dfb9 start_wqthread + 13
    Thread 10:: com.apple.CoreAnimation.render-server
    0   libsystem_kernel.dylib                  0x00007fff96d06a1a mach_msg_trap + 10
    1   libsystem_kernel.dylib                  0x00007fff96d05d18 mach_msg + 64
    2   com.apple.QuartzCore                    0x00007fff961c3377 CA::Render::Server::server_thread(void*) + 195
    3   com.apple.QuartzCore                    0x00007fff961c32ad thread_fun + 25
    4   libsystem_pthread.dylib                 0x00007fff95099899 _pthread_body + 138
    5   libsystem_pthread.dylib                 0x00007fff9509972a _pthread_start + 137
    6   libsystem_pthread.dylib                 0x00007fff9509dfc9 thread_start + 13
    Thread 11:: com.apple.NSURLConnectionLoader
    0   libsystem_kernel.dylib                  0x00007fff96d06a1a mach_msg_trap + 10
    1   libsystem_kernel.dylib                  0x00007fff96d05d18 mach_msg + 64
    2   com.apple.CoreFoundation                0x00007fff96abcfc5 __CFRunLoopServiceMachPort + 181
    3   com.apple.CoreFoundation                0x00007fff96abc5e9 __CFRunLoopRun + 1161
    4   com.apple.CoreFoundation                0x00007fff96abbf25 CFRunLoopRunSpecific + 309
    5   com.apple.Foundation                    0x00007fff95ce1967 +[NSURLConnection(Loader) _resourceLoadLoop:] + 348
    6   com.apple.Foundation                    0x00007fff95ce176b __NSThread__main__ + 1318
    7   libsystem_pthread.dylib                 0x00007fff95099899 _pthread_body + 138
    8   libsystem_pthread.dylib                 0x00007fff9509972a _pthread_start + 137
    9   libsystem_pthread.dylib                 0x00007fff9509dfc9 thread_start + 13
    Thread 12:: com.apple.appkit-heartbeat
    0   libsystem_kernel.dylib                  0x00007fff96d0aa3a __semwait_signal + 10
    1   libsystem_c.dylib                       0x00007fff904bcdc0 nanosleep + 200
    2   libsystem_c.dylib                       0x00007fff904bccb2 usleep + 54
    3   com.apple.AppKit                        0x00007fff8c0f617d -[NSUIHeartBeat _heartBeatThread:] + 2132
    4   com.apple.Foundation                    0x00007fff95ce176b __NSThread__main__ + 1318
    5   libsystem_pthread.dylib                 0x00007fff95099899 _pthread_body + 138
    6   libsystem_pthread.dylib                 0x00007fff9509972a _pthread_start + 137
    7   libsystem_pthread.dylib                 0x00007fff9509dfc9 thread_start + 13
    Thread 13:: JavaScriptCore::BlockFree
    0   libsystem_kernel.dylib                  0x00007fff96d0a716 __psynch_cvwait + 10
    1   libsystem_pthread.dylib                 0x00007fff9509bc3b _pthread_cond_wait + 727
    2   com.apple.JavaScriptCore                0x000000010d0d50f6 ***::ThreadCondition::timedWait(***::Mutex&, double) + 118
    3   com.apple.JavaScriptCore                0x000000010d0d4c15 JSC::BlockAllocator::blockFreeingThreadMain() + 117
    4   com.apple.JavaScriptCore                0x000000010d0c9f3f ***::wtfThreadEntryPoint(void*) + 15
    5   libsystem_pthread.dylib                 0x00007fff95099899 _pthread_body + 138
    6   libsystem_pthread.dylib                 0x00007fff9509972a _pthread_start + 137
    7   libsystem_pthread.dylib                 0x00007fff9509dfc9 thread_start + 13
    Thread 14:: JavaScriptCore::Marking
    0   libsystem_kernel.dylib                  0x00007fff96d0a716 __psynch_cvwait + 10
    1   libsystem_pthread.dylib                 0x00007fff9509bc3b _pthread_cond_wait + 727
    2   com.apple.JavaScriptCore                0x000000010d0d5717 JSC::GCThread::waitForNextPhase() + 119
    3   com.apple.JavaScriptCore                0x000000010d0d55a8 JSC::GCThread::gcThreadMain() + 88
    4   com.apple.JavaScriptCore                0x000000010d0c9f3f ***::wtfThreadEntryPoint(void*) + 15
    5   libsystem_pthread.dylib                 0x00007fff95099899 _pthread_body + 138
    6   libsystem_pthread.dylib                 0x00007fff9509972a _pthread_start + 137
    7   libsystem_pthread.dylib                 0x00007fff9509dfc9 thread_start + 13
    Thread 15:: JavaScriptCore::Marking
    0   libsystem_kernel.dylib                  0x00007fff96d0a716 __psynch_cvwait + 10
    1   libsystem_pthread.dylib                 0x00007fff9509bc3b _pthread_cond_wait + 727
    2   com.apple.JavaScriptCore                0x000000010d0d5717 JSC::GCThread::waitForNextPhase() + 119
    3   com.apple.JavaScriptCore                0x000000010d0d55a8 JSC::GCThread::gcThreadMain() + 88
    4   com.apple.JavaScriptCore                0x000000010d0c9f3f ***::wtfThreadEntryPoint(void*) + 15
    5   libsystem_pthread.dylib                 0x00007fff95099899 _pthread_body + 138
    6   libsystem_pthread.dylib                 0x00007fff9509972a _pthread_start + 137
    7   libsystem_pthread.dylib                 0x00007fff9509dfc9 thread_start + 13
    Thread 16:: JavaScriptCore::Marking
    0   libsystem_kernel.dylib                  0x00007fff96d0a716 __psynch_cvwait + 10
    1   libsystem_pthread.dylib                 0x00007fff9509bc3b _pthread_cond_wait + 727
    2   com.apple.JavaScriptCore                0x000000010d0d5717 JSC::GCThread::waitForNextPhase() + 119
    3   com.apple.JavaScriptCore                0x000000010d0d55a8 JSC::GCThread::gcThreadMain() + 88
    4   com.apple.JavaScriptCore                0x000000010d0c9f3f ***::wtfThreadEntryPoint(void*) + 15
    5   libsystem_pthread.dylib                 0x00007fff95099899 _pthread_body + 138
    6   libsystem_pthread.dylib                 0x00007fff9509972a _pthread_start + 137
    7   libsystem_pthread.dylib                 0x00007fff9509dfc9 thread_start + 13
    Thread 17 Crashed:
    0   libsystem_c.dylib                       0x00007fff904ae4a1 __xvprintf + 106
    Thread 17 crashed with X86 Thread State (64-bit):
      rax: 0x000000015436a864  rbx: 0x00007fff7b840002  rcx: 0x00007fff7b84e940  rdx: 0x00007fff7b84f4a0
      rdi: 0xffffffffffffffff  rsi: 0x0000000000000000  rbp: 0x000000015436ae44  rsp: 0x000000015436a844
       r8: 0x0000000154509c37   r9: 0x000000015436af34  r10: 0x0000000000000000  r11: 0x0000000000000206
      r12: 0x000000000000000a  r13: 0x0000000000000000  r14: 0xffffffffffffffff  r15: 0x00007fff7b84f4a0
      rip: 0x00007fff904ae4a1  rfl: 0x0000000000010202  cr2: 0x0000000154369050
    Logical CPU:     0
    Error Code:      0x00000000
    Trap Number:     13
    Binary Images:
           0x10c7c6000 -        0x10c7c6ffd  com.apple.Safari (7.0.4 - 9537.76.4) <BE71E110-8F31-3710-AC01-96EFEEE5037C> /Applications/Safari.app/Contents/MacOS/Safari
           0x10c7d0000 -        0x10ccd6ffb  com.apple.Safari.framework (9537 - 9537.76.4) <28E2BB7D-87E5-357C-B22E-D4091B5AF7EE> /System/Library/StagedFrameworks/Safari/Safari.framework/Versions/A/Safari
           0x10d0c1000 -        0x10d438ff6  com.apple.JavaScriptCore (9537 - 9537.76.1) <EB1F11D7-80BA-366C-8807-159575F41CE7> /System/Library/StagedFrameworks/Safari/JavaScriptCore.framework/Versions/A/Jav aScriptCore
           0x10d531000 -        0x10d667ffc  com.apple.WebKit (9537 - 9537.76.4) <D3F786EA-9E87-3BFA-9B39-C938C0EC1F5A> /System/Library/StagedFrameworks/Safari/WebKit.framework/Versions/A/WebKit
           0x10d75c000 -        0x10d94dff3  com.apple.WebKit2 (9537 - 9537.76.4) <7753BA2C-1279-396D-8044-AE1D001A5A57> /System/Library/StagedFrameworks/Safari/WebKit2.framework/Versions/A/WebKit2
           0x10db35000 -        0x10e989ff3  com.apple.WebCore (9537 - 9537.76.4) <4DC363A5-28FB-343B-9E56-D261D321D97B> /System/Library/StagedFrameworks/Safari/WebCore.framework/Versions/A/WebCore
           0x15422a000 -        0x154231fff  com.apple.SyncedDefaults (1.3 - 91.30.1) <26F0AD10-86CC-31A4-899C-097269680E05> /System/Library/PrivateFrameworks/SyncedDefaults.framework/SyncedDefaults
        0x7fff686cf000 -     0x7fff68702817  dyld (239.4) <042C4CED-6FB2-3B1C-948B-CAF2EE3B9F7A> /usr/lib/dyld
        0x7fff8abd4000 -     0x7fff8ac01ff2  com.apple.frameworks.CoreDaemon (1.3 - 1.3) <43A137C4-3E72-37DC-945F-92569C12AAD4> /System/Library/PrivateFrameworks/CoreDaemon.framework/Versions/B/CoreDaemon
        0x7fff8ac02000 -     0x7fff8b050fef  com.apple.VideoToolbox (1.0 - 1273.54) <4699BB55-7387-3981-9217-869215F00CA9> /System/Library/Frameworks/VideoToolbox.framework/Versions/A/VideoToolbox
        0x7fff8b051000 -     0x7fff8b052fff  libquit.dylib (161.2) <7B9C07B6-8993-32C8-89C2-23D2E7FA85BA> /usr/lib/libquit.dylib
        0x7fff8b053000 -     0x7fff8b055ff3  libsystem_configuration.dylib (596.15) <4998CB6A-9D54-390A-9F57-5D1AC53C135C> /usr/lib/system/libsystem_configuration.dylib
        0x7fff8b24d000 -     0x7fff8b583fff  com.apple.MediaToolbox (1.0 - 1273.54) <E11683F7-BB60-37EB-98B6-BD519D93CB30> /System/Library/Frameworks/MediaToolbox.framework/Versions/A/MediaToolbox
        0x7fff8b80e000 -     0x7fff8b8f8fff  libsqlite3.dylib (158) <00269BF9-43BE-39E0-9C85-24585B9923C8> /usr/lib/libsqlite3.dylib
        0x7fff8b8f9000 -     0x7fff8b94cfff  com.apple.ScalableUserInterface (1.0 - 1) <CF745298-7373-38D2-B3B1-727D5A569E48> /System/Library/Frameworks/QuartzCore.framework/Versions/A/Frameworks/ScalableU serInterface.framework/Versions/A/ScalableUserInterface
        0x7fff8b94d000 -     0x7fff8ba53ff7  com.apple.ImageIO.framework (3.3.0 - 1043) <C4ADE5B1-A540-34E1-A043-118185489C9D> /System/Library/Frameworks/ImageIO.framework/Versions/A/ImageIO
        0x7fff8ba54000 -     0x7fff8bb0cff7  com.apple.DiscRecording (8.0 - 8000.4.6) <CDAAAD04-A1D0-3C67-ABCC-EFC9E8D44E7E> /System/Library/Frameworks/DiscRecording.framework/Versions/A/DiscRecording
        0x7fff8be6e000 -     0x7fff8c9e4ff7  com.apple.AppKit (6.9 - 1265.20) <D2A7AF23-0FEA-3D7D-9CF5-B4E262224577> /System/Library/Frameworks/AppKit.framework/Versions/C/AppKit
        0x7fff8c9e5000 -     0x7fff8cba3fff  com.apple.GeoServices (1.0 - 702.15.12) <5A4D463F-689F-3822-BF26-A19D51503019> /System/Library/PrivateFrameworks/GeoServices.framework/Versions/A/GeoServices
        0x7fff8cba4000 -     0x7fff8cbb0fff  com.apple.CalendarAgentLink (7.0 - 138.2) <D56910F9-5CC0-32D8-BA85-0631240F9B71> /System/Library/PrivateFrameworks/CalendarAgentLink.framework/Versions/A/Calend arAgentLink
        0x7fff8cbb1000 -     0x7fff8cd69ffb  libicucore.A.dylib (511.32) <A7CE7DAD-D3AD-36A2-BE4F-25C5F21FADBB> /usr/lib/libicucore.A.dylib
        0x7fff8cd83000 -     0x7fff8cea5fff  com.apple.avfoundation (2.0 - 651.12.1) <FF001F98-E198-3B1D-A7EB-A8C48E6E34A3> /System/Library/Frameworks/AVFoundation.framework/Versions/A/AVFoundation
        0x7fff8ceb5000 -     0x7fff8cec6fff  com.apple.idsfoundation (10.0 - 1000) <D3E6646B-4118-30D3-B4F7-DA9A28B396E4> /System/Library/PrivateFrameworks/IDSFoundation.framework/Versions/A/IDSFoundat ion
        0x7fff8ceca000 -     0x7fff8cf15fff  com.apple.ImageCaptureCore (5.0 - 5.0) <F529EDDC-E2F5-30CA-9938-AF23296B5C5B> /System/Library/Frameworks/ImageCaptureCore.framework/Versions/A/ImageCaptureCo re
        0x7fff8cf16000 -     0x7fff8cf18fff  com.apple.Mangrove (1.0 - 1) <72F5CBC7-4E78-374E-98EA-C3700136904E> /System/Library/PrivateFrameworks/Mangrove.framework/Versions/A/Mangrove
        0x7fff8cf19000 -     0x7fff8cf2aff7  libsystem_asl.dylib (217.1.4) <655FB343-52CF-3E2F-B14D-BEBF5AAEF94D> /usr/lib/system/libsystem_asl.dylib
        0x7fff8cf45000 -     0x7fff8d099ff3  com.apple.audio.toolbox.AudioToolbox (1.10 - 1.10) <69B273E8-5A8E-3FC7-B807-C16B657662FE> /System/Library/Frameworks/AudioToolbox.framework/Versions/A/AudioToolbox
        0x7fff8d09a000 -     0x7fff8d0a6ff7  com.apple.KerberosHelper (4.0 - 1.0) <6D64703B-D7A3-3EF7-89AB-16F7F89333FC> /System/Library/PrivateFrameworks/KerberosHelper.framework/Versions/A/KerberosH elper
        0x7fff8d0a7000 -     0x7fff8d0afff3  libCGCMS.A.dylib (599.23.13) <59F7AEED-90EB-35C2-85A6-5BC44CC9B3FA> /System/Library/Frameworks/CoreGraphics.framework/Versions/A/Resources/libCGCMS .A.dylib
        0x7fff8d0ca000 -     0x7fff8d18cff5  com.apple.CoreText (367.20 - 367.20) <B80D086D-93A9-3C35-860E-9C3FDD027F3B> /System/Library/Frameworks/CoreText.framework/Versions/A/CoreText
        0x7fff8d5f4000 -     0x7fff8d5fcff7  com.apple.AppleSRP (5.0 - 1) <ABC7F088-1FD5-3768-B9F3-847F355E90B3> /System/Library/PrivateFrameworks/AppleSRP.framework/Versions/A/AppleSRP
        0x7fff8d5fd000 -     0x7fff8d636ff7  com.apple.QD (3.50 - 298) <C1F20764-DEF0-34CF-B3AB-AB5480D64E66> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ QD.framework/Versions/A/QD
        0x7fff8d637000 -     0x7fff8d638ffb  libremovefile.dylib (33) <3543F917-928E-3DB2-A2F4-7AB73B4970EF> /usr/lib/system/libremovefile.dylib
        0x7fff8d639000 -     0x7fff8d682fff  com.apple.CoreMedia (1.0 - 1273.54) <CAB7303A-9AB2-317A-99C3-BEAA8AE8764B> /System/Library/Frameworks/CoreMedia.framework/Versions/A/CoreMedia
        0x7fff8d689000 -     0x7fff8d692ffd  com.apple.CommonAuth (4.0 - 2.0) <32BA436F-6319-3A0B-B5D2-2EB75FF36B5B> /System/Library/PrivateFrameworks/CommonAuth.framework/Versions/A/CommonAuth
        0x7fff8d693000 -     0x7fff8d6dafff  libFontRegistry.dylib (127) <A77A0480-AA5D-3CC8-8B68-69985CD546DC> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ ATS.framework/Versions/A/Resources/libFontRegistry.dylib
        0x7fff8d6db000 -     0x7fff8d705ff7  libsandbox.1.dylib (278.11) <BD3D8652-8871-36DB-A27D-3BE4F18428B4> /usr/lib/libsandbox.1.dylib
        0x7fff8d706000 -     0x7fff8d874ff7  libBLAS.dylib (1094.5) <DE93A590-5FA5-32A2-A16C-5D7D7361769F> /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.fr amework/Versions/A/libBLAS.dylib
        0x7fff8d8f4000 -     0x7fff8d9a4ff7  libvMisc.dylib (423.32) <049C0735-1808-39B9-943F-76CB8021744F> /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.fr amework/Versions/A/libvMisc.dylib
        0x7fff8d9a5000 -     0x7fff8dbffffd  com.apple.security (7.0 - 55471.14.4) <1D5DA20E-DB48-3E1D-9BF5-BAA694192B25> /System/Library/Frameworks/Security.framework/Versions/A/Security
        0x7fff8dc00000 -     0x7fff8dc25ff7  com.apple.ChunkingLibrary (2.0 - 155.1) <B845DC7A-D1EA-31E2-967C-D1FE0C628036> /System/Library/PrivateFrameworks/ChunkingLibrary.framework/Versions/A/Chunking Library
        0x7fff8dc3e000 -     0x7fff8dc3eff7  libkeymgr.dylib (28) <3AA8D85D-CF00-3BD3-A5A0-E28E1A32A6D8> /usr/lib/system/libkeymgr.dylib
        0x7fff8dc3f000 -     0x7fff8dc4ffff  libbsm.0.dylib (33) <2CAC00A2-1352-302A-88FA-C567D4D69179> /usr/lib/libbsm.0.dylib
        0x7fff8dc50000 -     0x7fff8dd19fff  com.apple.LaunchServices (572.26 - 572.26) <EF8A4A15-0861-35C5-9744-5E1BC5C26DD9> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchS ervices.framework/Versions/A/LaunchServices
        0x7fff8dd1a000 -     0x7fff8dd68ff7  com.apple.opencl (2.3.59 - 2.3.59) <044485A4-A50C-34CE-A1F9-35A50CC68313> /System/Library/Frameworks/OpenCL.framework/Versions/A/OpenCL
        0x7fff8dd69000 -     0x7fff8dd6cff7  com.apple.LoginUICore (3.0 - 3.0) <1ECBDA90-D6ED-3333-83EB-9C8232DFAD7C> /System/Library/PrivateFrameworks/LoginUIKit.framework/Versions/A/Frameworks/Lo ginUICore.framework/Versions/A/LoginUICore
        0x7fff8dd6d000 -     0x7fff8de5cfff  libFontParser.dylib (111.1) <835A8253-6AB9-3AAB-9CBF-171440DEC486> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ ATS.framework/Versions/A/Resources/libFontParser.dylib
        0x7fff8de5d000 -     0x7fff8deaafff  com.apple.AppleVAFramework (5.0.27 - 5.0.27) <608D91BD-9D88-3FAB-9A06-24C1DAEA092D> /System/Library/PrivateFrameworks/AppleVA.framework/Versions/A/AppleVA
        0x7fff8deab000 -     0x7fff8df0effb  com.apple.SystemConfiguration (1.13.1 - 1.13.1) <2C8E1A73-5AD6-3A7D-8ED8-D6755555A993> /System/Library/Frameworks/SystemConfiguration.framework/Versions/A/SystemConfi guration
        0x7fff8e0ce000 -     0x7fff8e0cffff  com.apple.TrustEvaluationAgent (2.0 - 25) <334A82F4-4AE4-3719-A511-86D0B0723E2B> /System/Library/PrivateFrameworks/TrustEvaluationAgent.framework/Versions/A/Tru stEvaluationAgent
        0x7fff8e0d0000 -     0x7fff8e130fff  com.apple.ISSupport (1.9.9 - 57) <E1E343D7-222C-3458-9D1F-FC600B7F1C50> /System/Library/PrivateFrameworks/ISSupport.framework/Versions/A/ISSupport
        0x7fff8e131000 -     0x7fff8e137ff7  com.apple.XPCService (2.0 - 1) <2CE632D7-FE57-36CF-91D4-C57D0F2E0BFE> /System/Library/PrivateFrameworks/XPCService.framework/Versions/A/XPCService
        0x7fff8e138000 -     0x7fff8e519ffe  libLAPACK.dylib (1094.5) <7E7A9B8D-1638-3914-BAE0-663B69865986> /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.fr amework/Versions/A/libLAPACK.dylib
        0x7fff8e51a000 -     0x7fff8e68aff4  com.apple.CFNetwork (673.4 - 673.4) <F3BF6020-99BE-3844-A7B8-352B93AD02F3> /System/Library/Frameworks/CFNetwork.framework/Versions/A/CFNetwork
        0x7fff8e68b000 -     0x7fff8e75cfff  com.apple.QuickLookUIFramework (5.0 - 622.7) <13841701-34C2-353D-868D-3E08D020C90F> /System/Library/Frameworks/Quartz.framework/Versions/A/Frameworks/QuickLookUI.f ramework/Versions/A/QuickLookUI
        0x7fff8e789000 -     0x7fff8e793ff7  com.apple.bsd.ServiceManagement (2.0 - 2.0) <2D27B498-BB9C-3D88-B05A-76908A8A26F3> /System/Library/Frameworks/ServiceManagement.framework/Versions/A/ServiceManage ment
        0x7fff8e794000 -     0x7fff8e7abffa  libAVFAudio.dylib (32.2) <52DA516B-DE79-322C-9E1B-2658019289D7> /System/Library/Frameworks/AVFoundation.framework/Versions/A/Resources/libAVFAu dio.dylib
        0x7fff8e915000 -     0x7fff8e916ff7  libodfde.dylib (20) <C00A4EBA-44BC-3C53-BFD0-819B03FFD462> /usr/lib/libodfde.dylib
        0x7fff8e917000 -     0x7fff8e95fff7  com.apple.ExchangeWebServices (4.0 - 193) <867EDAF0-5863-397E-BA75-855878D68949> /System/Library/PrivateFrameworks/ExchangeWebServices.framework/Versions/A/Exch angeWebServices
        0x7fff8e960000 -     0x7fff8e9bbffb  com.apple.AE (665.5 - 665.5) <BBA230F9-144C-3CAB-A77A-0621719244CD> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/AE.fram ework/Versions/A/AE
        0x7fff8e9bc000 -     0x7fff8e9bcfff  com.apple.AOSMigrate (1.0 - 1) <ABA8F3F2-BC96-3F89-AAF4-1AA459A0BCBD> /System/Library/PrivateFrameworks/AOSMigrate.framework/Versions/A/AOSMigrate
        0x7fff8e9e8000 -     0x7fff8e9ecff7  libheimdal-asn1.dylib (323.92.1) <CAE21FFF-5763-399C-B7C5-EEBFFEEF2242> /usr/lib/libheimdal-asn1.dylib
        0x7fff8e9ed000 -     0x7fff8e9efff7  com.apple.securityhi (9.0 - 55005) <18C42525-688C-3D47-B9C9-1E0F8F58FA64> /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/SecurityHI.fr amework/Versions/A/SecurityHI
        0x7fff8eef7000 -     0x7fff8eef7fff  com.apple.Accelerate.vecLib (3.9 - vecLib 3.9) <F8D0CC77-98AC-3B58-9FE6-0C25421827B6> /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.fr amework/Versions/A/vecLib
        0x7fff8eef8000 -     0x7fff8ef36ff7  libGLImage.dylib (9.6.1) <5E02B38C-9F36-39BE-8746-724F0D8BBFC0> /System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGLImage.dyl ib
        0x7fff8ef37000 -     0x7fff8ef3cfff  com.apple.DiskArbitration (2.6 - 2.6) <A4165553-770E-3D27-B217-01FC1F852B87> /System/Library/Frameworks/DiskArbitration.framework/Versions/A/DiskArbitration
        0x7fff8efef000 -     0x7fff8f009fff  libdispatch.dylib (339.92.1) <C4E4A18D-3C3B-3C9C-8709-A4270D998DE7> /usr/lib/system/libdispatch.dylib
        0x7fff8f014000 -     0x7fff8f020ff7  com.apple.OpenDirectory (10.9 - 173.90.1) <256C265B-7FA6-326D-9F60-18DADF5F3A0E> /System/Library/Frameworks/OpenDirectory.framework/Versions/A/OpenDirectory
        0x7fff8f096000 -     0x7fff8f0bbff7  com.apple.CoreVideo (1.8 - 117.2) <4674339E-26D0-35FA-9958-422832B39B12> /System/Library/Frameworks/CoreVideo.framework/Versions/A/CoreVideo
        0x7fff8f0bc000 -     0x7fff8f180ff7  com.apple.backup.framework (1.5.3 - 1.5.3) <088FEDED-BF5C-33F4-A51A-646C8149BDAA> /System/Library/PrivateFrameworks/Backup.framework/Versions/A/Backup
        0x7fff8f3af000 -     0x7fff8f437ff7  com.apple.CorePDF (4.0 - 4) <92D15ED1-D2E1-3ECB-93FF-42888219A99F> /System/Library/PrivateFrameworks/CorePDF.framework/Versions/A/CorePDF
        0x7fff8f44b000 -     0x7fff8f463ff7  com.apple.openscripting (1.4 - 157) <B3B037D7-1019-31E6-9D17-08E699AF3701> /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/OpenScripting .framework/Versions/A/OpenScripting
        0x7fff8f4ab000 -     0x7fff8f4daff9  com.apple.GSS (4.0 - 2.0) <44E914BE-B0D0-3E05-9451-CA9E539AFA52> /System/Library/Frameworks/GSS.framework/Versions/A/GSS
        0x7fff8f563000 -     0x7fff8f56eff7  com.apple.NetAuth (5.0 - 5.0) <C811E662-9EC3-3B74-808A-A75D624F326B> /System/Library/PrivateFrameworks/NetAuth.framework/Versions/A/NetAuth
        0x7fff8f56f000 -     0x7fff8f5fbff7  com.apple.ink.framework (10.9 - 207) <8A50B893-AD03-3826-8555-A54FEAF08F47> /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/Ink.framework /Versions/A/Ink
        0x7fff8f647000 -     0x7fff8f647fff  com.apple.Accelerate (1.9 - Accelerate 1.9) <509BB27A-AE62-366D-86D8-0B06D217CF56> /System/Library/Frameworks/Accelerate.framework/Versions/A/Accelerate
        0x7fff8f648000 -     0x7fff8f677fd2  libsystem_m.dylib (3047.16) <B7F0E2E4-2777-33FC-A787-D6430B630D54> /usr/lib/system/libsystem_m.dylib
        0x7fff8f69c000 -     0x7fff8f8e4ff7  com.apple.CoreData (107 - 481.3) <E78734AA-E3D0-33CB-A014-620BBCAB2E96> /System/Library/Frameworks/CoreData.framework/Versions/A/CoreData
        0x7fff8f99b000 -     0x7fff902baf43  com.apple.CoreGraphics (1.600.0 - 599.23.13) <3A1952C7-1D67-3DEC-A5AB-5399FF4F2A92> /System/Library/Frameworks/CoreGraphics.framework/Versions/A/CoreGraphics
        0x7fff902c0000 -     0x7fff9038bfff  libvDSP.dylib (423.32) <3BF732BE-DDE0-38EB-8C54-E4E3C64F77A7> /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.fr amework/Versions/A/libvDSP.dylib
        0x7fff9038c000 -     0x7fff9038effb  libutil.dylib (34) <DAC4A6CF-A1BB-3874-9569-A919316D30E8> /usr/lib/libutil.dylib
        0x7fff9038f000 -     0x7fff903edff7  com.apple.corelocation (1486.17 - 1486.24) <9FBB29F0-E000-3190-A96C-9EAA5CCCA2A0> /System/Library/Frameworks/CoreLocation.framework/Versions/A/CoreLocation
        0x7fff903ee000 -     0x7fff90440fff  libc++.1.dylib (120) <4F68DFC5-2077-39A8-A449-CAC5FDEE7BDE> /usr/lib/libc++.1.dylib
        0x7fff90441000 -     0x7fff904caff7  libsystem_c.dylib (997.90.3) <6FD3A400-4BB2-3B95-B90C-BE6E9D0D78FA> /usr/lib/system/libsystem_c.dylib
        0x7fff904cb000 -     0x7fff904cdff7  libquarantine.dylib (71) <7A1A2BCB-C03D-3A25-BFA4-3E569B2D2C38> /usr/lib/system/libquarantine.dylib
        0x7fff904ce000 -     0x7fff90525fff  com.apple.ViewBridge (1.0 - 46.2) <4AF3CB98-7691-39A2-8DC3-ABE5CC55CE7F> /System/Library/PrivateFrameworks/ViewBridge.framework/Versions/A/ViewBridge
        0x7fff90526000 -     0x7fff9052cff7  libsystem_platform.dylib (24.90.1) <3C3D3DA8-32B9-3243-98EC-D89B9A1670B3> /usr/lib/system/libsystem_platform.dylib
        0x7fff9055a000 -     0x7fff90571ff7  com.apple.CFOpenDirectory (10.9 - 173.90.1) <EBC0A1F2-9054-3D39-99AE-A3F655E55D6A> /System/Library/Frameworks/OpenDirectory.framework/Versions/A/Frameworks/CFOpen Directory.framework/Versions/A/CFOpenDirectory
        0x7fff90572000 -     0x7fff90572fff  com.apple.CoreServices (59 - 59) <7A697B5E-F179-30DF-93F2-8B503CEEEFD5> /System/Library/Frameworks/CoreServices.framework/Versions/A/CoreServices
        0x7fff90573000 -     0x7fff9059aff7  libsystem_network.dylib (241.3) <8B1E1F1D-A5CC-3BAE-8B1E-ABC84337A364> /usr/lib/system/libsystem_network.dylib
        0x7fff9059b000 -     0x7fff905a4ffb  libCGInterfaces.dylib (271) <68EFBEFE-7506-3235-99A2-5B69EDBFD7B8> /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vImage.fr amework/Versions/A/Resources/libCGInterfaces.dylib
        0x7fff905a5000 -     0x7fff905d3ff7  com.apple.securityinterface (9.0 - 55047) <0346D8A9-2CAA-38F3-A741-5FBA5E9F1E7C> /System/Library/Frameworks/SecurityInterface.framework/Versions/A/SecurityInter face
        0x7fff905d4000 -     0x7fff905e3ff8  com.apple.LangAnalysis (1.7.0 - 1.7.0) <8FE131B6-1180-3892-98F5-C9C9B79072D4> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ LangAnalysis.framework/Versions/A/LangAnalysis
        0x7fff905e4000 -     0x7fff90614fff  com.apple.IconServices (25 - 25.17) <4751127E-FBD5-3ED5-8510-08D4E4166EFE> /System/Library/PrivateFrameworks/IconServices.framework/Versions/A/IconService s
        0x7fff9061b000 -     0x7fff90674fff  libTIFF.dylib (1043) <D7CAE68F-6087-3B40-9CB8-EC6DB47BF877> /System/Library/Frameworks/ImageIO.framework/Versions/A/Resources/libTIFF.dylib
        0x7fff90675000 -     0x7fff9068bfff  com.apple.CoreMediaAuthoring (2.2 - 947) <F1886A05-1C29-3F88-88C0-4A1013530AD1> /System/Library/PrivateFrameworks/CoreMediaAuthoring.framework/Versions/A/CoreM ediaAuthoring
        0x7fff9068c000 -     0x7fff906dafff  libcorecrypto.dylib (161.1) <F3973C28-14B6-3006-BB2B-00DD7F09ABC7> /usr/lib/system/libcorecrypto.dylib
        0x7fff906db000 -     0x7fff90716fff  com.apple.bom (14.0 - 193.1) <EF24A562-6D3C-379E-8B9B-FAE0E4A0EF7C> /System/Library/PrivateFrameworks/Bom.framework/Versions/A/Bom
        0x7fff9077e000 -     0x7fff907e0ff7  com.apple.WhitePagesFramework (10.7.0 - 141.0) <F95E1174-37B7-300C-8ECE-E67A711B6721> /System/Library/PrivateFrameworks/WhitePages.framework/Versions/A/WhitePages
        0x7fff907e1000 -     0x7fff907e2ffc  com.apple.SafariServices.framework (9537 - 9537.76.4) <33EBCBCD-6A93-3DED-AA0A-5237B878C3FE> /System/Library/PrivateFrameworks/SafariServices.framework/Versions/A/SafariSer vices
        0x7fff907f6000 -     0x7fff90800ff7  com.apple.ProtocolBuffer (1 - 182.1.3) <82E68598-A8AA-3AF1-843E-2A64F19472D4> /System/Library/PrivateFrameworks/ProtocolBuffer.framework/Versions/A/ProtocolB uffer
        0x7fff90801000 -     0x7fff90803ff7  com.apple.diagnosticlogcollection (10.0 - 1000) <5CA6D8A2-DEA6-33C3-91BC-F3B076C0500B> /System/Library/PrivateFrameworks/DiagnosticLogCollection.framework/Versions/A/ DiagnosticLogCollection
        0x7fff90804000 -     0x7fff90d27fff  com.apple.QuartzComposer (5.1 - 319) <8B90921F-911B-3240-A1D5-3C084F3E6A36> /System/Library/Frameworks/Quartz.framework/Versions/A/Frameworks/QuartzCompose r.framework/Versions/A/QuartzComposer
        0x7fff90d28000 -     0x7fff90d28fff  com.apple.quartzframework (1.5 - 1.5) <3B2A72DB-39FC-3C5B-98BE-605F37777F37> /System/Library/Frameworks/Quartz.framework/Versions/A/Quartz
        0x7fff90d29000 -     0x7fff90db2fff  com.apple.ColorSync (4.9.0 - 4.9.0) <B756B908-9AD1-3F5D-83F9-7A0B068387D2> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ ColorSync.framework/Versions/A/ColorSync
        0x7fff90db3000 -     0x7fff90dc0ff4  com.apple.Librarian (1.2 - 1) <F1A2744D-8536-32C7-8218-9972C6300DAE> /System/Library/PrivateFrameworks/Librarian.framework/Versions/A/Librarian
        0x7fff90ded000 -     0x7fff90f1cfef  com.apple.MediaControlSender (2.0 - 200.34.4) <FC24EC8D-2E46-3F76-AF63-749F30857B96> /System/Library/PrivateFrameworks/MediaControlSender.framework/Versions/A/Media ControlSender
        0x7fff90f1d000 -     0x7fff90f4efff  com.apple.MediaKit (15 - 709) <23E33409-5C39-3F93-9E73-2B0E9EE8883E> /System/Library/PrivateFrameworks/MediaKit.framework/Versions/A/MediaKit
        0x7fff90f4f000 -     0x7fff90f9cff2  com.apple.print.framework.PrintCore (9.0 - 428) <8D8253E3-302F-3DB2-9C5C-572CB974E8B3> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ PrintCore.framework/Versions/A/PrintCore
        0x7fff90f9d000 -     0x7fff91271fc7  com.apple.vImage (7.0 - 7.0) <D241DBFA-AC49-31E2-893D-EAAC31890C90> /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vImage.fr amework/Versions/A/vImage
        0x7fff912b1000 -     0x7fff9134efff  com.apple.imcore (10.0 - 1000) <DF924E35-74AB-389C-9279-1828518218F8> /System/Library/PrivateFrameworks/IMCore.framework/Versions/A/IMCore
        0x7fff9134f000 -     0x7fff91378ff7  libc++abi.dylib (49.1) <21A807D3-6732-3455-B77F-743E9F916DF0> /usr/lib/libc++abi.dylib
        0x7fff9138c000 -     0x7fff91397fff  libkxld.dylib (2422.100.13) <67D079F8-6C48-3F42-9FBE-26F1ADA03DC4> /usr/lib/system/libkxld.dylib
        0x7fff91428000 -     0x7fff916d2ff5  com.apple.HIToolbox (2.1.1 - 698) <A388E773-AE7B-3FD1-8662-A98E6E24EA16> /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/HIToolbox.fra mework/Versions/A/HIToolbox
        0x7fff919be000 -     0x7fff919e8ff7  libpcap.A.dylib (42) <91D3FF51-D6FE-3C05-98C9-1182E0EC3D58> /usr/lib/libpcap.A.dylib
        0x7fff919fa000 -     0x7fff91a2fffc  com.apple.LDAPFramework (2.4.28 - 194.5) <4ADD0595-25B9-3F09-897E-3FB790AD2C5A> /System/Library/Frameworks/LDAP.framework/Versions/A/LDAP
        0x7fff91a30000 -     0x7fff91a32fff  com.apple.OAuth (25 - 25) <22D42C60-CA67-31D7-A4A4-AFD8F35408D7> /System/Library/PrivateFrameworks/OAuth.framework/Versions/A/OAuth
        0x7fff91a33000 -     0x7fff91a33fff  com.apple.Carbon (154 - 157) <45A9A40A-78FF-3EA0-8FAB-A4F81052FA55> /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon
        0x7fff91a67000 -     0x7fff91a6bfff  com.apple.CommonPanels (1.2.6 - 96) <6B434AFD-50F8-37C7-9A56-162C17E375B3> /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/CommonPanels. framework/Versions/A/CommonPanels
        0x7fff91a6c000 -     0x7fff91a94ffb  libRIP.A.dylib (599.23.13) <FFE421E6-CB15-3F9D-ADF4-679E26B09892> /System/Library/Frameworks/CoreGraphics.framework/Versions/A/Resources/libRIP.A .dylib
        0x7fff921f2000 -     0x7fff921fafff  libMatch.1.dylib (19) <021293AB-407D-309A-87F5-8E782F46753E> /usr/lib/libMatch.1.dylib
        0x7fff9220b000 -     0x7fff923b8f27  libobjc.A.dylib (551.1) <AD7FD984-271E-30F4-A361-6B20319EC73B> /usr/lib/libobjc.A.dylib
        0x7fff923b9000 -     0x7fff92444fff  libCoreStorage.dylib (380) <DE9B3F8C-045C-3010-9A25-C8CD72F1066B> /usr/lib/libCoreStorage.dylib
        0x7fff92445000 -     0x7fff924b2fff  com.apple.SearchKit (1.4.0 - 1.4.0) <B9B8D510-A27E-36B0-93E9-17146D9E9045> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/SearchK it.framework/Versions/A/SearchKit
        0x7fff924bc000 -     0x7fff924cafff  com.apple.opengl (9.6.1 - 9.6.1) <B22FA400-5824-36AF-9945-5FEC31995A0E> /System/Library/Frameworks/OpenGL.framework/Versions/A/OpenGL
        0x7fff924cb000 -     0x7fff924cefff  com.apple.AppleSystemInfo (3.0 - 3.0) <61FE171D-3D88-313F-A832-280AEC8F4AB7> /System/Library/PrivateFrameworks/AppleSystemInfo.framework/Versions/A/AppleSys temInfo
        0x7fff924cf000 -     0x7fff924ebfff  libresolv.9.dylib (54) <11C2C826-F1C6-39C6-B4E8-6E0C41D4FA95> /usr/lib/libresolv.9.dylib
        0x7fff924ec000 -     0x7fff92531ff6  com.apple.HIServices (1.23 - 468) <5970AF5C-F5BD-3B6A-97C9-95B2CA98D71D> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ HIServices.framework/Versions/A/HIServices
        0x7fff92546000 -     0x7fff92546fff  com.apple.SafariDAVNotifier (1.1.1 - 1) <6FD70177-7044-3EFE-905F-08F1D2D40ECA> /System/Library/PrivateFrameworks/BookmarkDAV.framework/Versions/A/Frameworks/S afariDAVNotifier.framework/Versions/A/SafariDAVNotifier
        0x7fff92547000 -     0x7fff925a4fff  com.apple.imfoundation (10.0 - 1000) <122D84B9-871D-3885-9D8D-840CD529028F> /System/Library/PrivateFrameworks/IMFoundation.framework/Versions/A/IMFoundatio n
        0x7fff925a5000 -     0x7fff925d1ff7  com.apple.framework.SystemAdministration (1.0 - 1.0) <6FD03EF6-32B6-397D-B9D7-D68E89A462F5> /System/Library/PrivateFrameworks/SystemAdministration.framework/Versions/A/Sys temAdministration
        0x7fff9273f000 -     0x7fff92749ff7  com.apple.CrashReporterSupport (10.9 - 539) <B25A09EC-A021-32EC-86F8-05B4837E0EDE> /System/Library/PrivateFrameworks/CrashReporterSupport.framework/Versions/A/Cra shReporterSupport
        0x7fff9274a000 -     0x7fff9275efff  com.apple.aps.framework (4.0 - 4.0) <2D42DCDD-055E-3EE1-97F8-FC447B495D3E> /System/Library/PrivateFrameworks/ApplePushService.framework/Versions/A/ApplePu shService
        0x7fff9275f000 -     0x7fff92760fff  libunc.dylib (28) <62682455-1862-36FE-8A04-7A6B91256438> /usr/lib/system/libunc.dylib
        0x7fff92761000 -     0x7fff9277eff7  com.apple.framework.Apple80211 (9.3.2 - 932.59) <DA61BF63-978E-342D-8F7F-83D0169A7F48> /System/Library/PrivateFrameworks/Apple80211.framework/Versions/A/Apple80211
        0x7fff9277f000 -     0x7fff927dbfff  com.apple.coredav (1.0.1 - 229.6) <6D2B49E8-E81D-36C7-BC24-FD54FA35E5BC> /System/Library/PrivateFrameworks/CoreDAV.framework/Versions/A/CoreDAV
        0x7fff927dc000 -     0x7fff927e0fff  libpam.2.dylib (20) <B93CE8F5-DAA8-30A1-B1F6-F890509513CB> /usr/lib/libpam.2.dylib
        0x7fff927e1000 -     0x7fff92832fff  com.apple.QuickLookFramework (5.0 - 622.7) <17685CEC-C94B-3F83-ADE1-B24840B35E44> /System/Library/Frameworks/QuickLook.framework/Versions/A/QuickLook
        0x7fff92833000 -     0x7fff9284eff7  libsystem_malloc.dylib (23.10.1) <A695B4E4-38E9-332E-A772-29D31E3F1385> /usr/lib/system/libsystem_malloc.dylib
        0x7fff928a4000 -     0x7fff928ebff7  libcups.2.dylib (372.4) <36EA4350-43B4-3A5C-9904-10685BFDA7D4> /usr/lib/libcups.2.dylib
        0x7fff9293f000 -     0x7fff92940ff7  com.apple.print.framework.Print (9.0 - 260) <EE00FAE1-DA03-3EC2-8571-562518C46994> /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/Print.framewo rk/Versions/A/Print
        0x7fff92941000 -     0x7fff92943fff  libCVMSPluginSupport.dylib (9.6.1) <FB37F4C4-1E84-3349-BB03-92CA0A5F6837> /System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libCVMSPluginS upport.dylib
        0x7fff93797000 -     0x7fff937b2ff7  libCRFSuite.dylib (34) <FFAE75FA-C54E-398B-AA97-18164CD9789D> /usr/lib/libCRFSuite.dylib
        0x7fff937b3000 -     0x7fff93804ff3  com.apple.audio.CoreAudio (4.2.0 - 4.2.0) <BF4C2FE3-8BC8-30D1-8347-2A7221268794> /System/Library/Frameworks/CoreAudio.framework/Versions/A/CoreAudio
        0x7fff93805000 -     0x7fff93817ff7  com.apple.MultitouchSupport.framework (245.13 - 245.13) <E51DE5CA-9859-3C13-A24F-37EF4385C1D6> /System/Library/PrivateFrameworks/MultitouchSupport.framework/Versions/A/Multit ouchSupport
        0x7fff93822000 -     0x7fff9382eff3  com.apple.AppleFSCompression (56 - 1.0) <5652B0D0-EB08-381F-B23A-6DCF96991FB5> /System/Library/PrivateFrameworks/AppleFSCompression.framework/Versions/A/Apple FSCompression
        0x7fff9382f000 -     0x7fff9384bfff  com.apple.frameworks.preferencepanes (16.0 - 16.0) <059E99D8-67C2-3B59-B5E7-850DD7A92D75> /System/Library/Frameworks/PreferencePanes.framework/Versions/A/PreferencePanes
        0x7fff93874000 -     0x7fff93878ff7  libsystem_stats.dylib (93.90.3) <4E51D5B0-92A0-3D0D-B90E-495A1ED3E391> /usr/lib/system/libsystem_stats.dylib
        0x7fff93879000 -     0x7fff93ab4fff  com.apple.CalendarPersistence (7.0 - 138.4) <BDD9B054-F274-357F-8343-6F8DAC7B0B36> /System/Library/PrivateFrameworks/CalendarPersistence.framework/Versions/A/Cale ndarPersistence
        0x7fff93ab5000 -     0x7fff93ac7fff  com.apple.ImageCapture (9.0 - 9.0) <BE0B65DA-3031-359B-8BBA-B9803D4ADBF4> /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/ImageCapture. framework/Versions/A/ImageCapture
        0x7fff93ac8000 -     0x7fff93d29fff  com.apple.imageKit (2.5 - 774) <AACDE16E-ED9F-3B3F-A792-69BA1942753B> /System/Library/Frameworks/Quartz.framework/Versions/A/Frameworks/ImageKit.fram ework/Versions/A/ImageKit
        0x7fff93d2a000 -     0x7fff93d51ffb  libsystem_info.dylib (449.1.3) <7D41A156-D285-3849-A2C3-C04ADE797D98> /usr/lib/system/libsystem_info.dylib
        0x7fff93d52000 -     0x7fff93d83ff7  libtidy.A.dylib (15.12) <BF757E3C-733A-3B6B-809A-A3949D46466E> /usr/lib/libtidy.A.dylib
        0x7fff93d84000 -     0x7fff93db8fff  libssl.0.9.8.dylib (50) <B15F967C-B002-36C2-9621-3456D8509F50> /usr/lib/libssl.0.9.8.dylib
        0x7fff93db9000 -     0x7fff93e08ff7  com.apple.framework.internetaccounts (2.1 - 210) <D7175985-03A5-315B-B788-FBDC0019B0EA> /System/Library/PrivateFrameworks/InternetAccounts.framework/Versions/A/Interne tAccounts
        0x7fff941a2000 -     0x7fff941a6ff7  libcache.dylib (62) <BDC1E65B-72A1-3DA3-A57C-B23159CAAD0B> /usr/lib/system/libcache.dylib
        0x7fff941a7000 -     0x7fff941b8ff7  libz.1.dylib (53) <42E0C8C6-CA38-3CA4-8619-D24ED5DD492E> /usr/lib/libz.1.dylib
        0x7fff941b9000 -     0x7fff941d1ff7  com.apple.GenerationalStorage (2.0 - 160.3) <64749B08-0212-3AC8-9B49-73D662B09304> /System/Library/PrivateFrameworks/GenerationalStorage.framework/Versions/A/Gene rationalStorage
        0x7fff941d2000 -     0x7fff941d9ff7  com.apple.phonenumbers (1.1.1 - 105) <767A63EB-244C-34F1-9FFA-D1A6BED60C31> /System/Library/PrivateFrameworks/PhoneNumbers.framework/Versions/A/PhoneNumber s
        0x7fff941da000 -     0x7fff941dbff7  libsystem_sandbox.dylib (278.11) <B46E4040-A8C6-3EBC-91F8-F1CB01106614> /usr/lib/system/libsystem_sandbox.dylib
        0x7fff941dc000 -     0x7fff9446ffff  com.apple.RawCamera.bundle (5.05 - 743) <ACFD986B-59D0-313C-941A-5F239CDF9AA7> /System/Library/CoreServices/RawCamera.bundle/Contents/MacOS/RawCamera
        0x7fff94470000 -     0x7fff94701ff7  com.apple.AOSKit (1.06 - 176) <35525B2F-B02F-31FD-A3B2-FD6AE6D32C11> /System/Library/PrivateFrameworks/AOSKit.framework/Versions/A/AOSKit
        0x7fff94702000 -     0x7fff94709fff  libcompiler_rt.dylib (35) <4CD916B2-1B17-362A-B403-EF24A1DAC141> /usr/lib/system/libcompiler_rt.dylib
        0x7fff9470a000 -     0x7fff94739ff7  com.apple.CoreAVCHD (5.7.0 - 5700.4.3) <404369C0-ED9F-3010-8D2F-BC55285F7808> /System/Library/PrivateFrameworks/CoreAVCHD.framework/Versions/A/CoreAVCHD
        0x7fff9473a000 -     0x7fff94741ff8  liblaunch.dylib (842.90.1) <38D1AB2C-A476-385F-8EA8-7AB604CA1F89> /usr/lib/system/liblaunch.dylib
        0x7fff94742000 -     0x7fff94742ffd  libOpenScriptingUtil.dylib (157) <19F0E769-0989-3062-9AFB-8976E90E9759> /usr/lib/libOpenScriptingUtil.dylib
        0x7fff94743000 -     0x7fff9474cfff  com.apple.DisplayServicesFW (2.8 - 360.8.14) <816A9CED-1BC0-3C76-8103-1B9BE0F723BB> /System/Library/PrivateFrameworks/DisplayServices.framework/Versions/A/DisplayS ervices
        0x7fff94ac5000 -     0x7fff94ae3ff7  com.apple.Accounts (113 - 113) <FEB37642-C973-3CD2-B279-142492266A16> /System/Library/Frameworks/Accounts.framework/Versions/A/Accounts
        0x7fff94ae4000 -     0x7fff94b08fff  libxpc.dylib (300.90.2) <AB40CD57-F454-3FD4-B415-63B3C0D5C624> /usr/lib/system/libxpc.dylib
        0x7fff94b09000 -     0x7fff94b0cff7  libdyld.dylib (239.4) <7C9EC3B7-DDE3-33FF-953F-4067C743951D> /usr/lib/system/libdyld.dylib
        0x7fff94b0d000 -     0x7fff94b15fff  libsystem_dnssd.dylib (522.90.2) <A0B7CF19

    These are the results it gave me andyBall_uk.
    EtreCheck version: 1.9.11 (43) - report generated 2 June 2014 15:10:46 BST
    Hardware Information:
              iMac (21.5-inch, Late 2012)
              iMac - model: iMac13,1
              1 2.7 GHz Intel Core i5 CPU: 4 cores
              8 GB RAM
    Video Information:
              NVIDIA GeForce GT 640M - VRAM: 512 MB
    System Software:
              OS X 10.9.3 (13D65) - Uptime: 0 days 0:5:10
    Disk Information:
              APPLE HDD ST1000LM024 disk0 : (1 TB)
                        EFI (disk0s1) <not mounted>: 209.7 MB
                        Macintosh HD (disk0s2) / [Startup]: 999.35 GB (833.4 GB free)
                        Recovery HD (disk0s3) <not mounted>: 650 MB
    USB Information:
              HP Deskjet 3050A J611 series
              Apple Inc. FaceTime HD Camera (Built-in)
              Apple Inc. BRCM20702 Hub
                        Apple Inc. Bluetooth USB Host Controller
    Thunderbolt Information:
              Apple Inc. thunderbolt_bus
    Gatekeeper:
              Anywhere
    Kernel Extensions:
              [kext loaded] com.Cycling74.driver.Soundflower (1.6.6 - SDK 10.6) Support
              [not loaded] com.makemkv.kext.daspi (1) Support
    Launch Daemons:
              [loaded] com.adobe.fpsaud.plist Support
              [not loaded] com.adobe.SwitchBoard.plist Support
              [loaded] com.genieoinnovation.macextension.client.plist Support
              [loaded] com.google.keystone.daemon.plist Support
              [loaded] com.oracle.java.Helper-Tool.plist Support
              [loaded] com.oracle.java.JavaUpdateHelper.plist Support
    Launch Agents:
              [not loaded] com.adobe.AAM.Updater-1.0.plist Support
              [loaded] com.adobe.CS5ServiceManager.plist Support
              [running] com.genieoinnovation.macextension.plist Support
              [loaded] com.google.keystone.agent.plist Support
              [loaded] com.oracle.java.Java-Updater.plist Support
              [running] org.chromium.chromoting.plist Support
    User Launch Agents:
              [loaded] com.adobe.AAM.Updater-1.0.plist Support
              [loaded] com.valvesoftware.steamclean.plist Support
    User Login Items:
              iTunesHelper
              Google Drive
              Knock
              CrossOver CD Helper
              CrossOver CD Helper
              Android File Transfer Agent
    Internet Plug-ins:
              o1dbrowserplugin: Version: 5.4.1.18709 Support
              Unity Web Player: Version: UnityPlayer version 4.3.5f1 - SDK 10.6 Support
              Default Browser: Version: 537 - SDK 10.9
              Silverlight: Version: 5.1.20513.0 - SDK 10.6 Support
              FlashPlayer-10.6: Version: 13.0.0.214 - SDK 10.6 Support
              LogMeIn: Version: 1.0.961 - SDK 10.7 Support
              Flash Player: Version: 13.0.0.214 - SDK 10.6 Support
              QuickTime Plugin: Version: 7.7.3
              LogMeInSafari32: Version: 1.0.961 - SDK 10.7 Support
              SharePointBrowserPlugin: Version: 14.3.8 - SDK 10.6 Support
              googletalkbrowserplugin: Version: 5.4.1.18709 Support
              JavaAppletPlugin: Version: Java 7 Update 55 Check version
    Audio Plug-ins:
              BluetoothAudioPlugIn: Version: 1.0 - SDK 10.9
              AirPlay: Version: 2.0 - SDK 10.9
              AppleAVBAudio: Version: 203.2 - SDK 10.9
              iSightAudio: Version: 7.7.3 - SDK 10.9
    iTunes Plug-ins:
              Quartz Composer Visualizer: Version: 1.4 - SDK 10.9
    User Internet Plug-ins:
              NPRoblox: Version: 1.0.2.12 - SDK 10.9 Support
              Google Earth Web Plug-in: Version: 7.1 Support
    3rd Party Preference Panes:
              remoting_host_prefpane  Support
              Flash Player  Support
              FUSE for OS X (OSXFUSE)  Support
              Java  Support
    Time Machine:
              Time Machine not configured!
    Top Processes by CPU:
                   1%          fontd
                   1%          mds
                   0%          Google Chrome
                   0%          WindowServer
                   0%          Google Drive
    Top Processes by Memory:
              115 MB          com.apple.IconServicesAgent
              98 MB          mds_stores
              90 MB          Google Chrome
              82 MB          Google Drive
              57 MB          ocspd
    Virtual Memory Information:
              5.66 GB          Free RAM
              1.38 GB          Active RAM
              286 MB          Inactive RAM
              697 MB          Wired RAM
              369 MB          Page-ins
              0 B          Page-outs

  • I click on itunes but doesnt open and says send error report or dont send

    i click on itunes but doesnt open and says send error report or dont send

    You will need to provide more details as we cannot see your computer screen. Does this happen every time you launch LabVIEW? What version of LabVIEW are you using? What version of Windows? Does LabVIEW crash? If so, what were you doing at the time it crashed?

  • If image file not exist in image path crystal report not open and give me exception error problem

    Hi guys my code below show pictures for all employees
    code is working but i have proplem
    if image not exist in path
    crystal report not open and give me exception error image file not exist in path
    although the employee no found in database but if image not exist in path when loop crystal report will not open
    how to ignore image files not exist in path and open report this is actually what i need
    my code below as following
    DataTable dt = new DataTable();
    string connString = "data source=192.168.1.105; initial catalog=hrdata;uid=sa; password=1234";
    using (SqlConnection con = new SqlConnection(connString))
    con.Open();
    SqlCommand cmd = new SqlCommand("ViewEmployeeNoRall", con);
    cmd.CommandType = CommandType.StoredProcedure;
    SqlDataAdapter da = new SqlDataAdapter();
    da.SelectCommand = cmd;
    da.Fill(dt);
    foreach (DataRow dr in dt.Rows)
    FileStream fs = null;
    fs = new FileStream("\\\\192.168.1.105\\Personal Pictures\\" + dr[0] + ".jpg", FileMode.Open);
    BinaryReader br = new BinaryReader(fs);
    byte[] imgbyte = new byte[fs.Length + 1];
    imgbyte = br.ReadBytes(Convert.ToInt32((fs.Length)));
    dr["Image"] = imgbyte;
    fs.Dispose();
    ReportDocument objRpt = new Reports.CrystalReportData2();
    objRpt.SetDataSource(dt);
    crystalReportViewer1.ReportSource = objRpt;
    crystalReportViewer1.Refresh();
    and exception error as below

    First: I created a New Column ("Image") in a datatable of the dataset and change the DataType to System.Byte()
    Second : Drag And drop this image Filed Where I want.
    private void LoadReport()
    frmCheckWeigher rpt = new frmCheckWeigher();
    CryRe_DailyBatch report = new CryRe_DailyBatch();
    DataSet1TableAdapters.DataTable_DailyBatch1TableAdapter ta = new CheckWeigherReportViewer.DataSet1TableAdapters.DataTable_DailyBatch1TableAdapter();
    DataSet1.DataTable_DailyBatch1DataTable table = ta.GetData(clsLogs.strStartDate_rpt, clsLogs.strBatchno_Rpt, clsLogs.cmdeviceid); // Data from Database
    DataTable dt = GetImageRow(table, "Footer.Jpg");
    report.SetDataSource(dt);
    crv1.ReportSource = report;
    crv1.Refresh();
    By this Function I merge My Image data into dataTable
    private DataTable GetImageRow(DataTable dt, string ImageName)
    try
    FileStream fs;
    BinaryReader br;
    if (File.Exists(AppDomain.CurrentDomain.BaseDirectory + ImageName))
    fs = new FileStream(AppDomain.CurrentDomain.BaseDirectory + ImageName, FileMode.Open);
    else
    // if photo does not exist show the nophoto.jpg file
    fs = new FileStream(AppDomain.CurrentDomain.BaseDirectory + ImageName, FileMode.Open);
    // initialise the binary reader from file streamobject
    br = new BinaryReader(fs);
    // define the byte array of filelength
    byte[] imgbyte = new byte[fs.Length + 1];
    // read the bytes from the binary reader
    imgbyte = br.ReadBytes(Convert.ToInt32((fs.Length)));
    dt.Rows[0]["Image"] = imgbyte;
    br.Close();
    // close the binary reader
    fs.Close();
    // close the file stream
    catch (Exception ex)
    // error handling
    MessageBox.Show("Missing " + ImageName + "or nophoto.jpg in application folder");
    return dt;
    // Return Datatable After Image Row Insertion
    Mark as answer or vote as helpful if you find it useful | Ammar Zaied [MCP]

Maybe you are looking for

  • Re: Easy area for comments or complaints or compliment​s

    I am a customer of store #30 at St Louis, Mo. It takes a lot for me to go out of my way to leave a comment about a shopping experience I have had. Today however I had a wonderful experience. I purchased a screen protector for my phone and had difficu

  • Copying Sales Order Form Settings

    Hi, How can i copy the Sales Order Form Settings from one user ot another? Everytime i create a new user code, the form settings are not arranged as same as i set from the customized form settings. Is there any query or solutions that i can use to pr

  • App Store, victim of fraud competitors

    Hello to all, I am a developer and i am confident that fraud competitors ranked my app with one star ! Why ? because its impossible in a couple of hours to get an exact number of 41 one star al over 40 stores worldwide. And it happens to be  over 160

  • HELP!!!! Can't Open Picture attachments on my email on BlackBerry Curve 8530

    I am having many problems with my new blackberry curve 8530.  I just purchased this last week and can't seen to be able to view my pictures that my brother sends me from across the country of my brand new nephew. I NEED HELP!!  I called Bell Mobility

  • Contact software

    I do not use outlook on my pc. I used to own a palmpilot tx which I loved but when I upgraded to the blackberry tour phone i found that contcact management is a pia. I am currently using NICE OFFICE  - ibut I find that if i enter a contact on my blac