Terminal: Stored Remote Connection with non-standard Port?

Hi,
I am new to MacOS and I am amazed by the integrated terminal. However, I sometimes need to connect to servers which use a non-standard SSH port, for example, 2020. I know that I can manually connect, but for convinience, I'd like to have a saved remote connection including the non-standard port. Is this possible somehow?
Thanks,
Felicitus

I did some experimentation, using Terminal.
Terminal -> New Remote Connection -> Service -> [+]
now enter your own new service which includes
/usr/bin/ssh -p 50022
I found I had to enter a bonjour entry to get it to accept my new service, but once I did, I was able to use that new service with the custom -p 50022 port value.
Your mileage may vary. I still prefer iTerm.
Oh yea. In the future, Terminal and Unix oriented questions are better asked in the Mac OS X Technologies > Unix Forum
<http://discussions.apple.com/forum.jspa?forumID=735>

Similar Messages

  • Doing proper NAT to FTP connections on non-standard port

    Router 1712, IOS 12.3
    There is an article from Cisco, "Using Non-Standard FTP Port Numbers with NAT".
    http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a0080094e76.shtml
    It explains how to enable NATting router to perform proper translation of NAT-sensitive protocols, in this case FTP.
    The article assumes that the FTP server in question is on the inside interface of the router.
    The configuration proposed by the article is as follows:
    interface Ethernet0
    ip address 10.1.1.2 255.255.255.0
    ip nat inside
    interface Serial0
    ip address 192.168.10.1 255.255.255.252
    ip nat outside
    ip nat service list 10 ftp tcp port 2021
    ip nat inside source static 10.1.1.1 20.20.20.1
    access-list 10 permit 10.1.1.1
    In my case, the FTP server in question is on the outside interface. The router is performing source NAT for outbound connections. An example of my config is below:
    interface Ethernet0
    ip address 12.34.56.1 255.255.255.0
    ip nat outside
    interface Vlan324
    ip address 10.1.1.2 255.255.255.0
    ip nat inside
    ip nat service list 10 ftp tcp port 2021
    ip nat inside source static 10.1.1.100 12.34.56.100
    access-list 10 permit 12.34.56.200
    With this configuration, Layer 3 NAT is working. I'm able to establish an FTP control channel and issue FTP commands. However, I think that the IP addresses inside FTP control channel are not translated properly (to 12.34.56.100). Therefore, the FTP data channel is not working.
    I tried to enable the following debug, however didn't see any entries related to FTP control channel translation:
    debug ip nat
    debug ip nat detailed
    debug ip snat
    debug ip snat detailed
    debug ip ftp
    debug ftpserver
    My question is:
    Is the "ip nat service list <acl> ftp tcp <port>" command supposed to work when the FTP server in question is on the outside interface of the translating router ?

    Hi,
    I see that this question was asked quite some time ago but I have come across the same issue, i.e when the server is on the outside interface the ip in the "PORT" command from the client is not translated.
    Did you ever get a fix for it?
    Thanks

  • Webstart not working with non standard port

    I am using Java Web Start 1.0.1 coupled with JDK 1.3.1 to access a client application, from behind a firewall.
    Webstart launches correctly, but gives me this error on trying to load the application
    Description
    ======================
    An error occurred while launching/running the application.
    Title: Deal Entry Application - DV17
    Vendor: BP
    Category: Download Error
    Unable to load resource: http://dlw1debs17.bpweb.bp.com:7001/dealentry.jsp
    The problem is that, while i can successfully run and download the sample applications available at Sun's website, i am unable to launch this particular app. i have been assured that the port 7001 is open for connections.
    Here are the rest of the details
    Exception
    ========================================
    JNLPException[category: Download Error : Exception: java.net.ConnectException: Connection refused: connect : LaunchDesc: null ]
         at com.sun.javaws.cache.DownloadProtocol.doDownload(Unknown Source)
         at com.sun.javaws.cache.DownloadProtocol.isLaunchFileUpdateAvailable(Unknown Source)
         at com.sun.javaws.LaunchDownload.getUpdatedLaunchDesc(Unknown Source)
         at com.sun.javaws.Launcher.downloadResources(Unknown Source)
         at com.sun.javaws.Launcher.handleApplicationDesc(Unknown Source)
         at com.sun.javaws.Launcher.handleLaunchFile(Unknown Source)
         at com.sun.javaws.Launcher.run(Unknown Source)
         at java.lang.Thread.run(Unknown Source)
    Wrapped Exception
    ===========================================
    java.net.ConnectException: Connection refused: connect
         at java.net.PlainSocketImpl.socketConnect(Native Method)
         at java.net.PlainSocketImpl.doConnect(Unknown Source)
         at java.net.PlainSocketImpl.connectToAddress(Unknown Source)
         at java.net.PlainSocketImpl.connect(Unknown Source)
         at java.net.Socket.<init>(Unknown Source)
         at java.net.Socket.<init>(Unknown Source)
         at sun.net.NetworkClient.doConnect(Unknown Source)
         at sun.net.www.http.HttpClient.openServer(Unknown Source)
         at sun.net.www.http.HttpClient.openServer(Unknown Source)
         at sun.net.www.http.HttpClient.<init>(Unknown Source)
         at sun.net.www.http.HttpClient.<init>(Unknown Source)
         at sun.net.www.http.HttpClient.New(Unknown Source)
         at sun.net.www.protocol.http.HttpURLConnection.connect(Unknown Source)
         at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
         at java.net.HttpURLConnection.getResponseCode(Unknown Source)
         at com.sun.javaws.util.URLUtil.doesURLExist(Unknown Source)
         at com.sun.javaws.cache.DownloadProtocol.doDownload(Unknown Source)
         at com.sun.javaws.cache.DownloadProtocol.isLaunchFileUpdateAvailable(Unknown Source)
         at com.sun.javaws.LaunchDownload.getUpdatedLaunchDesc(Unknown Source)
         at com.sun.javaws.Launcher.downloadResources(Unknown Source)
         at com.sun.javaws.Launcher.handleApplicationDesc(Unknown Source)
         at com.sun.javaws.Launcher.handleLaunchFile(Unknown Source)
         at com.sun.javaws.Launcher.run(Unknown Source)
         at java.lang.Thread.run(Unknown Source)
    Here's the jnlp file
    <?xml version="1.0" encoding="utf-8"?>
    <jnlp
    spec="1.0+"
    codebase="http://dlw1rdbs17.bpweb.bp.com:7001"
    href="refdata.jsp">
    <information>
    <title>Ref Data Application - DV17</title>
    <vendor>BP</vendor>
    <homepage href="http://global.bpweb.bp.com/"/>
    <description>Ref Data Application - DV17</description>
    <description kind="short">Ref Data Application - DV17</description>
    <icon href="icon.gif"/>
    </information>
    <security>
    <all-permissions/>
    </security>
    <resources>
    <j2se version="1.3.1" initial-heap-size="64M" max-heap-size="96M"/>
    <jar href="rdmain-client.jar"/>
    <jar href="xy.jar"/>
    <jar href="wl61.jar"/>
    <jar href="log4j.jar"/>
    <property name="nextgen.jnlp.url" value="http://dlw1rdbs17.bpweb.bp.com:7001/refdata.jsp"/>
    <property name="java.naming.factory.initial" value="com.bp.ist.arch.client.NextGenContextFactory"/>
    <property name="nextgen.server.addresses" value="London,t3://dlw1rdbs17.bpweb.bp.com:7001" />
    <property name="nextgen.help.url" value="http://dlw1rdbs17.bpweb.bp.com:7001" />
         <property name="compressed" value="true"/>
    <property name="com.bp.ist.environment.envname" value="DV17" />
    <property name="com.bp.ist.environment.serverlocale" value="LONDON" />
    <property name="com.bp.ist.environment.appver" value="R2M3.1_REF_0204" />
    <property name="com.bp.ist.environment.dbschema" value="UNSET" />
    </resources>
    <application-desc main-class="com.bp.ist.refdata.main.swing.RefDataAppController"/>
    </jnlp>
    If anyone has a solution to this, please help out, because i have been stuck on this for almost 3 days now.
    Any suggestions will be sincerely appreciated.
    Thanks
    Karan

    1.0.1 is an older version of Java Web Start, which has since seen versions 1.2, 1.4.2, and now 1.5.
    This is probably a bug in the old (1.0.1) version of Java Web Start. Please try with a newer version.
    /Dietz

  • Ds ftp with non standard port

    I need to send data to a FTP server. I tried to use the "FTP Put Buffer" VI, but most of the time, I get the error 66 (it works without error once in a while). I tried with the data socket functions and it works well. However, I dont seem to be able to use a port other than 21. I tried the following syntax:
            ftp://user:[email protected]:2222/file.txt[text]
    But the DS VI still uses port 21. Is it at all possible to use a different FTP port with the data socket VI?
    Message Edited by jfmorneau on 04-09-2008 04:05 PM
    Message Edited by jfmorneau on 04-09-2008 04:06 PM

    Hello JF,
    Thanks for your response!
    Datasocket VI:
    The following KnowledgeBase document indicates that FTP Control is assigned to Port 21, and that may be the reason that you are having issues using other ports.
    Which Port Numbers Can I Use with TCP and UDP?
    FTP VI:
    You mentioned that you get the error sometimes, but not always.  Could you provide some more details on this? 
    Are you able to ping the ftp server that you are trying to connect to without problems?  I suggest that you try other ftp servers as well and see if this error is specific to that particular server.  It isn't clear yet why you would be seeing this error even though the data appears to be transferred correctly. 
    Have a great day!
    Kameralina
    Ask NI (ni.com/ask)
    Search The KnowledgeBase
    NI Developer Zone
    Measure It. Fix It. ni.com/greenengineering/
    NI Vision ni.com/vision/

  • NAT: Passive FTP with non standard port

    Hi all,
    I have an ASA 5515 and four FTP server. Currently I have everything configured properly for three of the server that I need. For the fourth I have two possibilities:
    1) use the IP configured for the external interface.
    2) use one of the ip used for other FTP but uses another port.
    Is possible option 1? I did not succeed.
    I was then trying to use this configuration:
    <public ip>: 2121 -> <internal ip> 21
    <public ip>: 2120 -> <internal ip> 20
    The problem is that I can just log in but not access to the folders.
    I changed the service policy as well but still not working:
    class-map inspection_default
    match default-inspection-traffic
    class-map FTP-2121
    match port tcp range 2120 2121
    policy-map global_policy
    class inspection_default
      inspect ftp
      inspect esmtp
      inspect h323 h225
      inspect h323 ras
      inspect http
      inspect netbios
      inspect pptp
      inspect rsh
      inspect rtsp
      inspect sip 
      inspect skinny 
      inspect sqlnet
      inspect sunrpc
      inspect tftp
      inspect xdmcp
    class FTP-2121
      inspect ftp
    Here is the output of sh service-policy:
    Global policy:
      Service-policy: global_policy
        Class-map: inspection_default
          Inspect: ftp, packet 186535, lock fail 0, drop 188, reset-drop 0
          Inspect: esmtp _default_esmtp_map, packet 6539637, lock fail 0, drop 0, reset-drop 0
          Inspect: h323 h225 _default_h323_map, packet 0, lock fail 0, drop 0, reset-drop 0
                   tcp-proxy: bytes in buffer 0, bytes dropped 0
          Inspect: h323 ras _default_h323_map, packet 0, lock fail 0, drop 0, reset-drop 0
          Inspect: http, packet 1581437285, lock fail 0, drop 0, reset-drop 0
          Inspect: netbios, packet 105420, lock fail 0, drop 0, reset-drop 0
          Inspect: pptp, packet 0, lock fail 0, drop 0, reset-drop 0
          Inspect: rsh, packet 7, lock fail 0, drop 0, reset-drop 0
          Inspect: rtsp, packet 3857828, lock fail 0, drop 0, reset-drop 0
                   tcp-proxy: bytes in buffer 0, bytes dropped 0
          Inspect: sip , packet 3, lock fail 0, drop 0, reset-drop 0
                   tcp-proxy: bytes in buffer 0, bytes dropped 0
          Inspect: skinny , packet 0, lock fail 0, drop 0, reset-drop 0
                   tcp-proxy: bytes in buffer 0, bytes dropped 0
          Inspect: sqlnet, packet 0, lock fail 0, drop 0, reset-drop 0
          Inspect: sunrpc, packet 0, lock fail 0, drop 0, reset-drop 0
                   tcp-proxy: bytes in buffer 0, bytes dropped 0
          Inspect: tftp, packet 0, lock fail 0, drop 0, reset-drop 0
          Inspect: xdmcp, packet 0, lock fail 0, drop 0, reset-drop 0
        Class-map: FTP-2121
          Inspect: ftp, packet 0, lock fail 0, drop 0, reset-drop 0

    Hi bro
    If you were you, to achieve this requirement, I wouldn't use MPF. To much work, for a simple requirement. What I would do is as shown below;
    static (inside,outside) tcp 202.188.1.14 2120 10.10.10.14 20 netmask 255.255.255.255
    static (inside,outside) tcp 202.188.1.14 2121 10.10.10.14 21 netmask 255.255.255.255
    access-list acl_outside permit tcp any host 202.188.1.14 range 20 21
    access-group acl_outside in interface outside
    Note: Please remove all the MPF commands that you've inserted, back to default.

  • Accessing websites running on non-standard ports or with self-signed ssl certs?

    I've got some sites running using self-signed ssl's that also run on non-standard ports. Firefox home doesn't seem to open these pages it just sits there with the spinner loading and a blank screen...
    Anyone else noticed this?

    If the ASA is using a certificate issued by a CA that is in the client's trusted root CA store, then the ASA identity certificate does not need to be imported by the client.
    That's why it's generally recommend to go the route of using a well-know public CA as they are alreay included in most modern browsers and thus the client doesn't need to know how to import certificates etc.
    If you are using a local CA that is not in the client's trusted root CA store to issue your ASA identity certificate or self-signing certificates on the ASA then you need to take additional steps at the client.
    In the first case, you would import the root CA certificate in the trusted root CA store of the client. After that, any certificates it has issued (i.e the ASA's identity certificate) would automatically be trusted by the client.
    In the second case, the ASA's identity certificate itself would have be installed on the client since it (the ASA) is essentially acting as it's own root CA. I usually install them in my client's Trusted Root CA store but I guess that's technically not required, as long as the client knows to trust that certificate.

  • In FireFox 9, loading secure web pages running on non-standard ports works just fine. In FireFox 10, those same pages do not load and a "The connection was reset" message is displayed.

    How can this be fixed so functionality returns as per FF9 and below?
    This occurs on any secured website running on a non-standard port, with FF10.

    < X-Post from https://support.mozilla.org/en-US/questions/917315#answer-315144 >
    I don't think this is restricted to Firefox. I've noted this behaviour with IE9, Firefox 10.0.2, Opera Mobile (on my phone) and Chrome(latest version) with my Linksys E3000 router (I access it from https://<IP>) and my 3ware RAID card management suite, 3DM2 (I access it from https://localhost:888 ).
    Notably, the only thing amiss that I've been able to see in the certificates (I'm no expert) is that the one from Linksys has issue and expiry dates in 1969 and 1970 respectively. However, I don't think this is the cause since 3DM2 has proper looking issue dates and has the identical problem.
    Coincidentally, I noticed this happening after a fresh reinstall of Windows 7 x64 with virtually nothing installed on it (FF, Office 2007), so I don't think it's something wrong with the other software on the machine.

  • How to use non-standard port for vnc?

    Our Windows users who use RDC to connect to their desktops from off-site come in on a non-standard port number. Part of our security setup.
    I'd like to do the same with Mac users who use screen sharing and vnc to connect remotely.
    How can I specify another port number at both ends to accomplish this?
    I can find nothing in the Network Utility app, or in the KB.
    Surely there's a short sequence of Terminal commands that will do this?

    I haven't tried this so don't know whether it will work. But I think it will. Presuming the target machine is a Mac, see if editing its /etc/services file will do it. Find the two lines that start with "vnc-server" and change the port number there. Launch Terminal.app as an administratively privileged user, sudo pico /etc/services, ^w to search for vnc-server, make the changes, ^x to exit, y to save and overwrite. Also, you will need to have screen sharing enabled in the target machine's System Preferences' Sharing, and the authorized users defined there, too. Reboot. Now, on the remote client, assuming it is also a Mac, the user would type ⌘k in the Finder (or mouse to Finder > Go > Connect to Server), and enter something like vnc://123.45.67.89:55900 where you substitute the actual IP address or host name for where I have entered 123.45.67.89, and where you substitute the actual alternate port number where I have entered 55900. Of course, in the clients' Screen Sharing's Preferences, they should choose to encrypt the entire session, not just the login. Like I said, I haven't tried this because I just tunnel my vnc stuff through ssh, but I'm thinking that this should work.

  • Isakmp peers using non-standard port 4500

    Hello,
    I have a remote site using the Internet to access corporate networks over IPSEC. Set-up is as below:
    Remote Router uses public IP across internet --> hits corporate untrusted nework FW --> NAT'ed to private 10.x.x.x IP --> reaches trusted network router.
    The problem is that the peer keeps hanging and the only way to reset it is to issue 'clear crypto session' on the central trusted router. I have added isakmp keepalives with the aim of forcing some keepalive traffic:
    crypto isakmp keepalive 90 30 periodic
    ...and this works to some degree (with DPD are u there keepalives). However I have noticed that the far end router uses non-standard ports when trying to set up phase-1 tunnel:
    BEVRLY_D_CR184_01#sh crypto isa pee
    Peer: 161.x.x.x Port: 4500 Local: 77.x.x.x
    Phase1 id: 10.2.0.92
    Peer: 161.x.x.x Port: 10456 Local: 77.x.x.x
    Phase1 id: 10.2.0.92
    Peer: 161.x.x.x Port: 10554 Local: 77.x.x.x
    Phase1 id: 10.2.0.92
    Peer: 161.x.x.x Port: 10557 Local: 77.x.x.x
    Phase1 id: 10.2.0.92
    Peer: 161.x.x.x Port: 10580 Local: 77.x.x.x
    Phase1 id: 10.2.0.92
    Peer: 161.x.x.x Port: 10589 Local: 77.x.x.x
    Phase1 id: 10.2.0.92
    Peer: 161.x.x.x Port: 10596 Local: 77.x.x.x
    Phase1 id: 10.2.0.92
    Peer: 161.x.x.x Port: 10600 Local: 77.x.x.x
    Phase1 id: 10.2.0.92
    These ports (non-4500) will be blocked by our firewalls. Why does it use these, and is there a way of stopping the router using anything other than port 4500?
    Thanks
    Phil

    Hello,
    Yes - there's NAT at the trusted central router end our side of the firewall... the config used is below:
    Remote Router end:
    crypto isakmp policy 10
    encr 3des
    hash md5
    authentication pre-share
    group 2
    lifetime 180
    crypto isakmp key address
    crypto isakmp invalid-spi-recovery
    crypto isakmp keepalive 90 30 periodic
    crypto ipsec security-association idle-time 300
    crypto ipsec transform-set BEVERLEY_Transform esp-3des esp-md5-hmac
    crypto ipsec profile VTI
    set security-association lifetime seconds 1800
    set transform-set BEVERLEY_Transform
    interface Tunnel1
    description BEVRLY_CC296_01 F0/8 (10.30.45.29)
    ip address x.x.x.x 255.255.255.252
    ip helper-address 10.91.6.30
    ip helper-address 10.4.162.92
    ip mtu 1400
    ip ospf message-digest-key 1 md5
    load-interval 30
    tunnel source Dialer1
    tunnel destination
    tunnel mode ipsec ipv4
    tunnel protection ipsec profile VTI
    Central Router:
    crypto isakmp policy 10
    encr 3des
    hash md5
    authentication pre-share
    group 2
    lifetime 180
    crypto isakmp key address
    crypto isakmp invalid-spi-recovery
    crypto isakmp keepalive 90 30 periodic
    crypto ipsec security-association idle-time 300
    crypto ipsec transform-set BEVERLEY_Transform esp-3des esp-md5-hmac
    crypto ipsec profile VTI
    set security-association lifetime seconds 1800
    set transform-set BEVERLEY_Transform
    interface Tunnel1
    description link to Beverley via internet (BEVERLY_CR184_01 Tun1)
    ip address x.x.x.x 255.255.255.252
    ip mtu 1400
    ip ospf message-digest-key 1 md5
    load-interval 30
    tunnel source FastEthernet0/1
    tunnel destination
    tunnel mode ipsec ipv4
    tunnel protection ipsec profile VTI
    I believe the DPD keepalives ensure NAT is known and compatible (crypto isakmp keepalive 90 30 periodic) between the peers....
    Any help gladly appreciated....
    thanks
    Phil

  • Using the CSM to setup a HTTPS session on non-standard ports?

    Hi Guys,
    One of our clients wants to setup an SSL connection on a non-standard SSL port i.e. 4444 to begin with. Here the sever handles the SSL encryption / deccryption) instead of the SSL module.
    I've found the following config to work well:
    serverfarm FARM-MOBS-4444
    nat server
    no nat client
    predictor leastconns
    failaction purge
    real 130.194.12.81 4444
    inservice
    real 130.194.12.84 4444
    inservice
    probe MOBS-4444
    sticky 108 netmask 255.255.255.255 timeout 60
    vserver VMOBS-PROD-4444
    virtual 130.194.11.51 tcp https
    serverfarm FARM-MOBS-4444
    sticky 60 group 108
    persistent rebalance
    inservice
    With the above setup the CSM redirects the SSL connections (recieved on 443) to port 4444 on the sever and maintains this for the duration of the session.
    While the above setup works, is it possible to configure the VIP to use a HTTPS port other than 443 (which is default)? This would then allow for separate HTTPS paths to be setup on non-standard ports. I ask this since the client also wants to setup a HTTPS path on port 4443 as well.
    Any ideas would be useful.
    thanks
    Sheldon

    Hi Martin,
    Do you mean using the SSL module to perform the encryption / decryption? If so i've tried this and it does work without an issue.
    I was just wondering if it were possible to have a VIP setup where the HTTPS port is not 443 but say 4443, where the encryption / decryption is done by the real servers themselves.
    thanks
    Sheldon

  • CSS 11501 ftp server setup problem using non-standard port

    Dear Expert,
    we would like to setup FTP server over CSS where our member sever use non-std-port to open both control/data channel (i.e. 6370 as ctrl and 6369 as data this case.) but seems we only get Passive mode FTP mode work only but not for Active mode FTP case for data channel establishement for server back to client...is there any professional advise can help on this case...? here is our setup info FYI
    #  sh ver
    Version:               sg0820501 (08.20.5.01)
    Flash (Locked):        08.10.1.06
    Flash (Operational):   08.20.5.01
    Type:                  PRIMARY
    Licensed Cmd Set(s):   Standard Feature Set
                           Secure Management
    CVDM Version:          cvdm-css-1.0_K9
    !*************** Global
    ftp data-channel-timeout 10
      ftp non-standard-ports
    !************************** SERVICE **************************
    service ftp_ftpgtw
      keepalive maxfailure 2
      keepalive frequency 15
      keepalive retryperiod 2
      keepalive type tcp
      ip address 192.168.52.170
      protocol tcp
      keepalive port 6370
      port 6370
      active
    # sh run group drfusegtwftp_grp 
    !*************************** GROUP ***************************
    group gtwftp_grp
      vip address 192.168.52.28
      add service ftp_ftpgtw
      active
      content ftp_gtwpkg-ftpgtw
        add service ftp_ftpgtw
        vip address 192.168.52.28
        port 21
        protocol tcp
        application ftp-control
        active

    Thanks for your confirmation on no prob found in config level 1st..:P..as to save us a lot of time in isolating problem at this level.
    What we can notice is seems the data port connection is fail to open  for server back to client....for our general sense..... the flow expected should be:
    TCP session A -- Client:1234 --> VIP:21 --> member svr:6370
    TCP session B -- Client: 5678 <--> VIP:20 <--> member Svr: 6379 [on demand generated between server/client]
    but we can only see session B fail  to setup when client side access VIP site on CSS..even we try to put the most standard case as below
    TCP session A -- Client:1234 --> VIP:21 --> member svr:21
    TCP session B -- Client: 5678 <--> VIP:20 <--> member Svr: 20
    we still unable to make the Active mode FTP access work either...hence we got no idea on how CSS handle FTP access when it involve services over multiple tcp ports..
    and from CSS xlate view...the problem is we can only see what NAT IP that used in CSS connect to client...but no way to confirm for which port for VIP using outgoing to client. neither it is dropped by CSS..nor it is never setup from VIP to Client side.

  • Version 8 blocks http on non standard ports i.e. 8080

    Version 7 handled http on both port 8080,8081 and 8082 but only text is passed after version 8 update. Is there a way to re-enable http on non standard ports? If you save the text file to the desktop and load it from there the html is processed correctly? Is there a directive besides "html" that could be place on the web pages to force html rendering on the odd ports. Version 8 works with port 4135 from Jefferson labs speed test.

    See:
    *http://www.mozilla.org/projects/netlib/PortBanning.html
    *http://kb.mozillazine.org/network.security.ports.banned.override

  • Does it Possible? Double non standard-port FTP servers on PAT?

    Hello everyone!
    I need to know how to configure 2 ftp servers for following topology on pic.
    non standard ports
    I can do translation on 1 ftp server (http://www.cisco.com/c/en/us/support/docs/ip/network-address-translation-nat/13776-6.html)
    but when I am trying to add second FTP server I get following:
    #ip nat inside source static 192.168.1.129 46.229.139.130
    % similar static entry (192.168.1.236 -> x.x.y.y) already exists
    Thank you.

    Hello Jody.
    That's is great! Thank you! Just added couple "ip nat service" and now working!
    Also I noticed one thing.. 2 FTP servers is NAS Synology and that FTP servers have been configured slightly different. Look at the screenshot. With checked box "Report external ip in PASV mode".
    When FTP server with marked box it's doesn't work.
    When FTP server with unchecked box it does work.
    I've noticed that different and fixed it.
    Very interesting in the reason of that difference.

  • Reverse proxing on non-standard ports

    Hi,
    I want to create a new Reverse proxy mapping between an application and a GlassFish instance running on non standard port (not 80 / 443). Creating a mapping for HTTP works fine, but I can't find a way to map both the http and the https ports to the mapping.
    I have an application SecurityTest running on instance
    http://links.mycompany.com:38081/rsd/SecurityTest
    https://links.mycompany.com:38182/rsd/SecurityTest
    I want a mapping for the application
    http://www.mycompany.com/rsd/SecurityTest/ -> http://links.mycompany.com:38081/rsd/SecurityTest
    https://www.mycompany.com/rsd/SecurityTest/ -> https://links.mycompany.com:38182/rsd/SecurityTest
    The application is more or less a hello world servlet that is secure (form login) so it switch from HTTP to HTTPS when not logged in to ask for the username / password. Mapping to the http port works for the public page, the redirect gives an error:
    Gateway Timeout
    Processing of this request was delegated to a server that is not functioning properly.
    Can anyone tell me how to configure the Web Server to make it work?
    thanks

    Hi,
    I still get the same error:
    [12/Nov/2007:14:34:50] failure (16473) rsdts.mycomp.com: for host i78473.mycomp.com trying to GET http:/lidip/, service-http reports: HTTP7765: error reading response header (Server closed connection)
    And:
    Bad Gateway
    Processing of this request was delegated to a server that is not functioning properly.
    I don't get any logs on the other side...

  • CFHTTP GET using non-standard ports

    I have an application which goes out and checks links on
    various servers to verify that the link still exists, however I
    have a few links on servers that use non-standard ports (ie 8001,
    7072, 8080, etc). When I dump CFHTTP I get the following:
    struct
    Charset [empty string]
    ErrorDetail I/O Exception: Premature EOF encountered
    Filecontent Connection Failure
    Header [undefined struct element]
    Mimetype Unable to determine MIME type of file.
    Responseheader struct [empty]
    Statuscode Connection Failure. Status code unavailable.
    Text YES
    Any ideas?
    Thanks.
    Mike

    Yup, FaceTime was set up on all devices using my home network. It functions correctly pretty much everywhere except on my internal network at the office.
    I'm pretty sure this is a firewall issue, not a basic FaceTime problem.

Maybe you are looking for