Time doesn't match sampled data?

Hallo all experts,
I write a LV code which reads data from USB 6211 and saves them with time instants in a text file, but the time instants don't correspond the sampled data. The time values are generated by elapsed time, after build array with the data read from DAQ, they are fed to the write to a text file. The test signal is 10 Hz, but the text file yields 0.2 Hz signal. How could I synchronize them?
Any tips are highly appreciated.
win2

Don't use the "elapsed time" express VI for precision timings. It seems to have limited resolution (internally, it converts a timestamp to DBL).
You can use e.g. the tick count to keep track of the time. See the attached comparison. (still there will always be some subtle differences due to the software timings).
LabVIEW Champion . Do more with less code and in less time .
Attachments:
usb6211_forumMOD.vi ‏42 KB

Similar Messages

  • Why my ipad warranty doesn't match with date that i bought? I bought ipad 4 yesterday but as you guys know it was already discontinued.. Has my ipad been used?

    Why my ipad warranty doesn't match with date that i bought? I bought ipad 4 yesterday but as you guys know it was already discontinued.. Has my ipad been used?
    I bought in 14 january 2014 and the expiration said it will be in 5 september 2014
    Is it mean that my ipad had been activated in 5 sept las year?
    But the packaging is good and it looks like very new.
    Please help me....
    I bought in IT plaza in kuala lumpur, malaysia..
    Heeellllppp...

    The merchant told me it is new. And when they opened the box and turn the ipad on, the ipad asked me to activate first.
    Is the 'restore to factory setting' can make us must activate the ipad again??

  • Waterfall plot acquired in real time doesn't match when it is read offline.

    Dear fellow LabVIEW experts,
    I'm in need of help regarding the waterfall plot in LabVIEW. I acquired vibration signals of a CNC router during idling. The accelerometer was attached to the tool spindle in proximity to the rotating tool. Using a LabVIEW program (LV 2010),  I saved my data (using write to spreasheet function) and I also had a waterfall plot showing the vibration spectrum built up as I was collecting the data. I used the Print Screen function on the keyboard to copy the waterfall plot (collected during real time data acquisition) and pasted it in a Word document.  Then, I had another LabVIEW program that was able to read back all the data that I've saved including a waterfall plot that was used to reproduce the vibration spectrum that I've collected. After I read back my data (offline), I compared the vibration spectra between the real time and offline. The vibration spectrum that is collected during real time is supposed to match with the vibration spectrum that is reproduced when reading back the same data.
    My problem is this, when I changed the location of the accelerometer or the vibration sensor to a new location (a bit far up and away from the rotating tool), the real time and offline vibration spectra didn't match in that the offline one showed some additional frequencies or peaks that weren''t there when I was collecting it in real time. Does anyone know why this happens?...Is it something to do with the buffer?
    I've tried my best to explain and I hope someone out there is able to explain this situation.
    Really appreciate any helps.
    Thanks.

    TiTou is right some screen shots would be helpful,
    But these are good references too: http://zone.ni.com/devzone/cda/epd/p/id/5607   http://zone.ni.com/devzone/cda/epd/p/id/1425   http://zone.ni.com/devzone/cda/epd/p/id/5523 
    Sam S
    Applications Engineer
    National Instruments

  • Query for Old Data that does not match New Data within a given time period

    Hello all,
    One of the reports I need to create is for all associates who went from one department to another within a given time period. The way I ran this report in Reportsmith (pulling from our old system) was to compare the dept field from the beginning date to the dept field at the end date and it would give me those associate's that had moved. I had to do it this way b/c dept changes can happen using several different types of actions (supv change, promotion, etc.), none of them exclusive to just dept changes. We are now using Oracle HRMS and I need to create this same report with this system using SQL.
    Does anyone know how to compare data between two different dates and pull the ones that don't match? Your help will be GREATLY appreciated!
    Warm Regards,
    Yasmin E. Alberto
    HRIS Analyst
    [email protected]

    Hi, Yasmin,
    In the sample data you posted, nobody changed departments between May 1 and May 11. In fact, there were no assignments of any kind between January 16 and May 17, so I wouldn't expect any output for that period.
    A person (or rather, a duck) did change deptartments on May 20, so if you change the upper limit of the date range to
    AND    ASG_LAST_UPDATE_DATE < TO_DATE ('05/21/09', 'MM/DD/RR')you should see her.
    You've probably noticed that this site likes to compress white-space.
    To post formatted text (such as table results or indented code) type these 6 characters:
    (small letters only, inside curly brackets) before and after sections of formatted text, to preserve spacing.                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                       

  • I imported a video and when I play it back, the audio does not match the video. When I view the tape in my camera it looks fine. I've tried imported twice and each time it doesn't match. What can I do to fix this?

    I imported a video and when I play it back, the audio does not match the video. When I view the tape in my camera it looks fine. I've tried imported twice and each time it doesn't match. What can I do to fix this?

    The default settings mostly likely use an audio sample rate of 32k. This doesn't work probably in FCP. You're probably better off capturing the tape in iMovie.

  • Reinstalled 10.3.4, now date/time doesn't work or open

    I had a hard drive failure, a company replaced my drive with a new one in my G4. The new hard drive works fine, they reinstalled 10.3.4 from my original disks, but the date/time doesn't work and I can't open that panel even.
    So I just resinstalled from those disks again and it still didn't fix this problem.
    Also my old password for installers doesn't work either, but it lets me bypass it.
    Any suggestions?
    Should I just try upgrading to Tiger and see if that works?
    Thanks

    blackrhino:
    Not sure what the problem is, however, before you go reinstalling or upgrading try this:
    1. Reset PRAM.
    2. a. From a cold start, boot from your installer disk holding down the "C" button. Go to the Installer Menu and open Disk Utility.
    b. Select your Mac OS X startup disk.
    c. Select the First Aid tab in the Disk Utility window.
    d. Select Repair Disk button in Main panel. If problems are found run again and again until no problems are reported.
    e. Select the Repair Disk Permissions button on the First Aid tab.
    f. After Repair Disk Permissions completes, Quit (Command-Q) Disk Utility.
    3. Update Software to 10.3.9 (Go to Apple Menu and select Software Update.
    Post back after these operations.
    Good luck.
    cornelius
    PB G3 Pismo400, 100 GB 5400 Toshiba internal, 1 GB RAM   Mac OS X (10.3.9)   Beige G3 OS 8.6

  • I have been buying apps for a long time  without a problem using my credit card on file. All of a sudden itunes is not recognizing my card which is in good standing. All the info is correct but itunes/apple says it doesn't  match the bank info. Any ideas

    I have been buying apps for a long time  without a problem using my credit card on file. All of a sudden itunes is not recognizing my card which is in good standing. All the info is correct but itunes/apple says it doesn't  match the bank info. Any ideas?

    Answered in your Other post on this Topic...
    https://discussions.apple.com/message/24053626#24053626

  • It seems that the last message sent in imessage doesn't show the date/time.

    When I look at the imessage screen it doesn't show the date/time on last messages.

    Claudia252 wrote:
    Thank you. I cant figure out how to change the lable infront of the number to "iPhone" . It shows "home", "work", "pager", etc. but it doesn't show an "iPhone" option.
    In the Contact, tap Edit.
    Tap the label in front of the number and another Label screen apears.
    Tap the label you want to use.

  • Trying to backup from icloud. Enter username and password - OK. Select backup date - OK. I'm then presented with an old username that of course doesn't match my password. Now what?

    Have a disabled iPad2 that's been wiped. Using current IOS system.  Trying to backup from icloud. Enter username and password - OK. Select backup date - OK. I'm then presented with an old username that of course doesn't match my password. Now what?

    Hi Bluehouse44,
    If you are having difficulty restoring your iPad from an iCloud backup you may want to use the steps in this article to try to get back on track -
    If you can't update or restore your iOS device
    http://support.apple.com/kb/HT1808
    Thanks for using Apple Support Communities.
    Best,
    Brett L

  • HT5624 I am trying to reset my password for my apple id.  When asked I enter my date of birth and I am told it doesn't match what itunes has on file.  HELP!  I am not getting any emails to reset the id either.

    I am trying to reset my password for apple id.  I entered my d.o.b. tells me info doesn't match.  I tried reseting through email but am not
    getting any emails to reset it.  HELP!

    Go to the Apple ID Security site from http://support.apple.com/kb/HT5699 or call the AppleCare support number from http://support.apple.com/kb/HE57 and ask to speak with the Account Security Team...either can help you reset your questions/answers.

  • Audio doesn't match video because repeated half way through

    Hi guys,
    I am currently editing videos from my Canon SLR with Adobe Premiere Elements (Windows).
    In the same project, I have only uploaded videos taken the same day with the same equipment. I have been able to process them all normally apart from one. For some reason, when I play this file with a basic video player, everything works fine but when I import it in the Adobe software and play it either through the small window or in the timeline, I have the same problem:
    Everything works fine (audio and video in sync), until it reaches a specific point (totally random as far as I can tell) when the video keeps going but suddenly the sound repeats itself from the beginning of the file (and the audio which would correspond to the video is replaced by it). For you to understand better the problem:
    Video:   ABCDEF
    Audio:   ABCABC
    I have tried opening it in a different project and somehow it happens exactly at the same point.
    I am totally clueless of what it comes from and getting really frustrated!
    Any idea?
    Cheers
    Babs

    Hello, I'm new to using forums like this.  Is it appropriate for me to post that I'm having the same issue?  Also sounds similar to Audio doesn't match video because repeated half way through as well.
    My situation is:
    Win7 64-bit, i7 920, 2.67GHz, 8GB RAM
    Multiple Nikon D7000 video clips I've taken play back fine except for the following clip.  In Windows Media Viewer, I have no problem, but in PE10, in the timeline editor, this clip repeats the audio from the beginning starting about 6 minutes into the video.  I have Quicktime version 7.7.5 installed which I noticed was mentioned as a possible culprit in the other thread.
    I've been using my camera primarily for stills, but decided to have my mom tell her story before she wasn't able to.  I'm so frustrated with this problem because I know the audio is just fine since I can play it back synchronized throughout the entire clip in WMV.  I've tried cleaning out PE caches as best I can figure them out and created new projects without any better luck.
    Any help would be greatly appreciated.  I'm open to getting a new version of PE or another program if I could believe that I wouldn't run into this issue again.  This seems like such a vanilla problem since all my other clips seem to be fine and this one does too on WMV.
    Thanks for any help you can provide.  I don't really know where else to go to figure this out.
    Joel
    My Premier Elements Project settings are:
    Editing Mode: DSLR
    Timebase: 23.976frames/sec
    Video:
    Framesize: 1920 x 1080
    Pixel Aspect Ratio: Square Pixels (1.0)
    Fields: No Fields (Progressive Scan)
    Display Format: 24fps Timecode
    Audio:
    Sampe Rate: 48000 Hz
    Output from MediaInfo
    General
    Complete name                            : Z:\NikonVideo\MomsStory\JDB_20140702_6537.MOV
    Format                                   : MPEG-4
    Format profile                           : QuickTime
    Codec ID                                 : qt 
    File size                                : 1.46 GiB
    Duration                                 : 10mn 32s
    Overall bit rate                         : 19.8 Mbps
    Encoded date                             : UTC 2014-07-02 18:22:46
    Tagged date                              : UTC 2014-07-15 03:24:05
    NCDT                                     : NCTG
    Video
    ID                                       : 1
    Format                                   : AVC
    Format/Info                              : Advanced Video Codec
    Format profile                           : [email protected]
    Format settings, CABAC                   : Yes
    Format settings, ReFrames                : 2 frames
    Codec ID                                 : avc1
    Codec ID/Info                            : Advanced Video Coding
    Duration                                 : 10mn 32s
    Bit rate                                 : 18.3 Mbps
    Width                                    : 1 920 pixels
    Height                                   : 1 080 pixels
    Display aspect ratio                     : 16:9
    Frame rate mode                          : Constant
    Frame rate                               : 23.976 fps
    Color space                              : YUV
    Chroma subsampling                       : 4:2:0
    Bit depth                                : 8 bits
    Scan type                                : Progressive
    Bits/(Pixel*Frame)                       : 0.368
    Stream size                              : 1.35 GiB (92%)
    Language                                 : English
    Encoded date                             : UTC 2014-07-02 18:22:46
    Tagged date                              : UTC 2014-07-02 18:22:46
    Transfer characteristics                 : BT.470 System M
    Matrix coefficients                      : BT.601
    Audio
    ID                                       : 2
    Format                                   : PCM
    Format settings, Endianness              : Little
    Format settings, Sign                    : Signed
    Codec ID                                 : sowt
    Duration                                 : 10mn 32s
    Bit rate mode                            : Constant
    Bit rate                                 : 1 536 Kbps
    Channel(s)                               : 2 channels
    Channel positions                        : Front: L R
    Sampling rate                            : 48.0 KHz
    Bit depth                                : 16 bits
    Stream size                              : 116 MiB (8%)
    Language                                 : English
    Encoded date                             : UTC 2014-07-02 18:22:46
    Tagged date                              : UTC 2014-07-02 18:22:46

  • Index block dump: "header address" doesn't match rdba

    I did a dump on index leaf block, and I found "header address" doesn't match rdba, what's the "header address"? I also found several leaf blocks have the same "header address".
    buffer tsn: 11 rdba: 0x1684d120 (90/315680)
    ========> 0x1684d120 (1)
    header address 4403265988=0x1067481c4
    ========> 0x1067481c4 (2)
    *** SERVICE NAME:(SYS$USERS) 2009-08-04 04:37:36.335
    *** SESSION ID:(14234.24426) 2009-08-04 04:37:36.335
    Start dump data blocks tsn: 11 file#: 90 minblk 315680 maxblk 315680
    buffer tsn: 11 rdba: 0x1684d120 (90/315680) 
      ========>  0x1684d120  (1)
    scn: 0x0324.dda9ec3d seq: 0x01 flg: 0x04 tail: 0xec3d0601
    frmt: 0x02 chkval: 0xeb2a type: 0x06=trans data
    Hex dump of block: st=0, typ_found=1
    Block header dump:  0x1684d120
    Object id on Block? Y
    seg/obj: 0x7ca10  csc: 0x324.dda9ec3d  itc: 17  flg: O  typ: 2 - INDEX
         fsl: 0  fnx: 0x1684cf72 ver: 0x01
    Itl           Xid                  Uba         Flag  Lck        Scn/Fsc
    Leaf block dump
    ===============
    header address 4403265988=0x1067481c4         
    ========>  0x1067481c4  (2)
    kdxcolev 0
    KDXCOLEV Flags = - - -
    kdxcolok 0
    kdxcoopc 0x90: opcode=0: iot flags=I-- is converted=Y
    kdxconco 2
    kdxcosdc 5
    kdxconro 0
    kdxcofbo 36=0x24
    kdxcofeo 7672=0x1df8
    kdxcoavs 7636
    kdxlespl 0
    kdxlende 0
    kdxlenxt 373579108=0x16445d64
    kdxleprv 377801347=0x1684ca83
    kdxledsz 0
    kdxlebksz 7672
    ----- end of leaf block dump -----Thanks,
    Daniel

    Hi user646745
    You didn't say why you need to do index block dump ?
    Also take are that block structures and dumps some time are different from a ver to ver it 9i and 10g. Unless you now what exectaly you are looking for
    Thanks

  • END ROUTINE to calculate time differnce for two corresponding dates

    Hi All,
    I have to write an END ROUTINE in which I have 2 DATE FIELDS (e.g. DATE_1, DATE_2) and corresponding TIME fields (e.g. TIME_1, TIME_2).
    I have to calculate difference between the TIME fields for the two dates and populate a TIME_DIFF field.
    Can someone pls help me by posting sample code as i am new to BI.
    Thanks in ADVANCE!!!

    End Routine:
    http://help.sap.com/saphelp_nw70/helpdata/EN/e3/732c42be6fde2ce10000000a1550b0/frameset.htm
    End Routine and Expert Routine
    Thanks..
    Shambhu

  • Error: The decapsulated inner packet doesn't match the negotiated policy in the SA

    I upgraded my ASA from 8.2(1) to 8.4(3) as I wanted to try to get Android devices to properly connect via VPN.
    After some effort, I was able to get the Android devices to connect via VPN.  However, my syslog server has a number of errors recorded that look this this:
    %ASA-4-402116: IPSEC: Received an ESP packet (SPI= 0x1E76EFA6, sequence number= 0x1F0) from x.x.x.x (user= testuser) to y.y.y.y.  The decapsulated inner packet doesn't match the negotiated policy in the SA.  The packet specifies its destination as z.z.z.z, its source as a.a.a.a, and its protocol as tcp.  The SA specifies its local proxy as y.y.y.y/255.255.255.255/udp/42246 and its remote_proxy as x.x.x.x/255.255.255.255/udp/0.
    Digging further, it seems this error might be due to a NAT issues with the VPN connections.  VPN previously worked with Cisco's VPN client on Windows, though I did not test to see if that is no longer working.  However, I made no changes in the config, except for those related to additions needed to support L2TP.  With the below config, Android clients can connect to the ASA and access the internal network, but they cannot connect to external addresses.  I'm at a loss.
    The addresses used in the config: 192.168.1.0/24 are on the internal LAN and 192.168.3.0/24 are addresses assigned to VPN clients.
    I noted in the config this line:
    access-list inside_nat0_outbound extended permit ip any 192.168.3.0 255.255.255.0
    The access list is not referenced anywhere, though it was referenced in the 8.2(1) config like this:
    nat (inside) 0 access-list inside_nat0_outbound
    I'm not sure what else changed, but I've looked over the config and I just cannot see what the issue might be.  I'm hoping somebody might be able to point out my error.
    Here's the config file (at least the parts that might be of interest):
    : Saved
    ASA Version 8.4(3)
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.1.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address dhcp setroute
    boot system disk0:/asa843-k8.bin
    object network obj-192.168.3.0
    subnet 192.168.3.0 255.255.255.0
    object network obj_any
    subnet 0.0.0.0 0.0.0.0
    access-list outside_access_in extended permit icmp any interface outside time-exceeded
    access-list outside_access_in extended permit icmp any interface outside echo-reply
    access-list outside_access_in extended permit icmp any interface outside unreachable
    access-list outside_mpc extended permit ip any interface outside
    access-list inside_mpc extended permit ip 192.168.1.0 255.255.255.0 any
    access-list testVPN_splitTunnelAcl extended permit ip 192.168.1.0 255.255.255.0 any
    access-list inside_nat0_outbound extended permit ip any 192.168.3.0 255.255.255.0
    ip local pool VPN-Pool-1 192.168.3.1-192.168.3.254 mask 255.255.255.0
    ip verify reverse-path interface outside
    nat (inside,any) source static any any destination static obj-192.168.3.0 obj-192.168.3.0 no-proxy-arp
    object network obj-192.168.3.0
    nat (outside,outside) dynamic interface
    object network obj_any
    nat (inside,outside) dynamic interface
    access-group outside_access_in in interface outside
    crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANSP esp-aes esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANSP mode transport
    crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANSP esp-des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANSP mode transport
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 10 set ikev1 transform-set ESP-AES-128-SHA-TRANSP ESP-3DES-SHA-TRANSP
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
    crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map outside_map interface outside
    crypto ikev1 enable outside
    crypto ikev1 policy 5
    authentication pre-share
    encryption aes
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 10
    authentication pre-share
    encryption aes-256
    hash sha
    group 2
    lifetime 86400
    group-policy testVPN internal
    group-policy testVPN attributes
    wins-server value 192.168.1.8
    dns-server value 192.168.1.8 192.168.1.4
    vpn-idle-timeout none
    vpn-tunnel-protocol ikev1
    split-tunnel-policy tunnelspecified
    split-tunnel-network-list value testVPN_splitTunnelAcl
    default-domain value test.us
    group-policy testVPNnsl2tp internal
    group-policy testVPNnsl2tp attributes
    wins-server value 192.168.1.8
    dns-server value 192.168.1.8 192.168.1.4
    vpn-idle-timeout none
    vpn-tunnel-protocol l2tp-ipsec
    group-policy testVPNns internal
    group-policy testVPNns attributes
    wins-server value 192.168.1.8
    dns-server value 192.168.1.8 192.168.1.4
    vpn-idle-timeout none
    vpn-tunnel-protocol ikev1
    username testuser password PASSWORD encrypted privilege 15
    username testuser2 password PASSWORD nt-encrypted privilege 15
    tunnel-group DefaultRAGroup general-attributes
    address-pool VPN-Pool-1
    default-group-policy testVPNnsl2tp
    tunnel-group DefaultRAGroup ipsec-attributes
    ikev1 pre-shared-key *****
    tunnel-group DefaultRAGroup ppp-attributes
    authentication ms-chap-v2
    tunnel-group testVPN type remote-access
    tunnel-group testVPN general-attributes
    address-pool VPN-Pool-1
    default-group-policy testVPN
    tunnel-group testVPN ipsec-attributes
    ikev1 pre-shared-key *****
    tunnel-group testVPNns type remote-access
    tunnel-group testVPNns general-attributes
    address-pool VPN-Pool-1
    default-group-policy testVPNns
    tunnel-group testVPNns ipsec-attributes
    ikev1 pre-shared-key *****
    tunnel-group testVPNnsl2tp type remote-access
    tunnel-group testVPNnsl2tp general-attributes
    address-pool VPN-Pool-1
    default-group-policy testVPNnsl2tp
    tunnel-group testVPNnsl2tp ipsec-attributes
    ikev1 pre-shared-key *****
    tunnel-group testVPNnsl2tp ppp-attributes
    authentication ms-chap-v2
    One last question: in order to get the connection from Android to work, I was forced to use "tunnel-group DefaultRAGroup".  Is that actually a limitation, or did I make an error that forced that requirement?  I wanted to use "tunnel-group testVPNnsl2tp".
    Thanks!

    Chris,
    This is still a bit off the mark.  I think I might be confusing the issue by including some of the VPN configuration that I had previously installed and working (e.g., two other VPN tunnel groups with split tunneling on one of them).  Let's just remove that stuff from consideration.  I actually tested the current configs just to see if they are working since the upgrade.  testVPN is working with the split tunneling, but testVPNns (no-split tunneling) does not allow external access.  I guess there is a NAT config issue there, too, but not sure what it is, yet.  I've not investigated that closely.
    I want to solve one problem at a time, though I understand there are some interdependencies.
    What I'd like to focus on right now is just the L2TP VPN connection.
    From what I've been able to understand from the documentation, what I need are these lines:
    crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANSP esp-aes esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANSP mode transport
    crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANSP esp-des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANSP mode transport
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 10 set ikev1 transform-set ESP-AES-128-SHA-TRANSP ESP-3DES-SHA-TRANSP
    crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map outside_map interface outside
    crypto ikev1 enable outside
    group-policy testVPNnsl2tp internal
    group-policy testVPNnsl2tp attributes
    wins-server value 192.168.1.8
    dns-server value 192.168.1.8 192.168.1.4
    vpn-idle-timeout none
    vpn-tunnel-protocol l2tp-ipsec
    tunnel-group DefaultRAGroup general-attributes
    address-pool VPN-Pool-1
    default-group-policy testVPNnsl2tp
    tunnel-group DefaultRAGroup ipsec-attributes
    ikev1 pre-shared-key P74bmqL6rT40bl5
    tunnel-group DefaultRAGroup ppp-attributes
    authentication ms-chap-v2
    crypto ikev1 policy 5
    authentication pre-share
    encryption aes
    hash sha
    group 2
    lifetime 86400
    I still want to assign the IP addresses to VPN clients out of 192.168.3.0/24.
    The tricky part is understanding exactly what NAT rules to insert and to avoid that error message I'm getting relatred to the encapsulated packets.  I tried to introduce the commands you had, but it's missing stuff that I would need for L2TP/IPSec (e.g., "mode transport").  I also don't think I want "pfs group5".  The above config "works" in that I get connected -- all negotiation is done.  It's just that packets from the VPN client are not able to go out to the Internet and I'm seeing that encapsulation error messages when I try to send a packet.
    Paul

  • How to renormalize number of flows in Netflow Sampled data

    Hi,
    I am working on extrapolation(renormalization) of bytes/packets/flows from randomly sampled (1 out of N packets) collected data. I believe bytes/packets can be renormalized by multiplying bytes/packets value in exported flow record by N.
    Now, I am trying to extrapolate number of flows. So far i have not got any information on it. Do you people have any idea on how flows can be renormalized from sampled data ?
    Well, at the same time i have some doubts regarding this concept altogether -
    1. In packet sampling, we do not know how many flows got dropped. Even router cache will not have entries for dropped flows
    2. In flow sampling, router cache will maintain entries of all the flows and there may be some way by which one can know how many actual flows were there. But again there is no way to know values of individual attributes in missed flows like srcip/dstip/srcport/dstport etc.(though they are there in flow cache)
    3. In case of sampling (1 out of N packets), we anyway multiply #packets and #bytes with N to arrive at estimate for total packets and bytes. When we multiply by N, it means we have taken into account all those packets as well which were NOT sampled. So, it means all the packets which flowed between source and destination have been accounted for. Then there are no missed flows, isn't it ? And if there do exist some missed flows then multiplication by N to extrapolate number of packets/bytes is not correct.
    4. What is the use of count of flows anyways. Number of flows may vary depending upon the configuration such as active timeout etc. So, it does not provide any information about the actual flow between source and destination unlike number of packets and bytes.
    Please share your thoughts.
    Thanks,
    Deepak

    The simplest way is to call GetTableCellRangeValues with VAL_ENTIRE_TABLE as the range, next summing array elements.
    But I don't understand your comment on checksum, so this may not be the more correct method for your actual needs: can you explain what do you mean?
    Proud to use LW/CVI from 3.1 on.
    My contributions to the Developer Zone Community
    If I have helped you, why not giving me a kudos?

Maybe you are looking for

  • Open sales orders report

    Hi,      Does anyone know of any open sales orders report ? VA05 ? Table join between VBAP-VBAK ? Thanks

  • Workaround for non-SAP mitigating control reminders

    Dear all, Our business users would like to document mitigating controls in RAR 5.3 regardless of whether they are connected with an SAP report. They would also like to receive email reminders for those controls. Unfortunately, the frequency of the co

  • API to update onhand quantity

    Hi All, Is there any API that I can use to update the onhand quantity of Inventory Item. Thanks, Priya.

  • Why is my Bounce not working?

    I am trying to bounce a project which has a Sibelius file rewired to it.  I have successfully done this before, and it seems to be doing a bounce as usual, but I cannot find the file - either in the audio bin or iTunes or the folder to which I have a

  • Recurring document on transaction code F.14

    Hi All, I got problem with this user complaining on the recurring document when she try to execute on the above transaction code. At first she create few documents with success then when she try to do the next step, which is to create posting documen