Traffic-shaping for delay sensitive traffic

Hello, I would like to verify the use of a traffic-shaping policy within an MQC. I was told that you need to apply a shaping policy in order for QoS to always be engaged and not simply during times of congestion. This apparently is critical when you have apps like VoIP. 
On a similar note, i remember reading up on Ciscopress that you might NOT want to subject VoIP to any form of Shaping as this introdues delay and can cause Jitter.
Below is a sample config. If you can post an authoritative source on CCO that explains this I would greatly appreciate it.
Regards,
-Mike
policy-map QoS-Policy
 class realtime
  priority 512
    police 512000 conform-action transmit  exceed-action drop
 class preferred
  bandwidth remaining percent 40
  random-detect dscp-based
 class missioncritical
  bandwidth remaining percent 39
  random-detect dscp-based
 class trans-apps
  bandwidth remaining percent 16
  random-detect dscp-based
 class general
  bandwidth remaining percent 1
  random-detect dscp-based
 class class-default
  bandwidth remaining percent 4
  random-detect dscp-based
policy-map shape-20MB
 class class-default
  shape average 2000000
  service-policy QoS-Policy
interface Serial0/0/0
 service-policy output shape-20MB

Disclaimer
The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
Liability Disclaimer
In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
Posting
I was told that you need to apply a shaping policy in order for QoS to always be engaged and not simply during times of congestion.
Nope.
You only need to shape when you're dealing with a path where you know the end-to-end bandwidth is less the the egress interface's physical bandwidth and where you cannot manage congestion further downstream along the end-to-end path.
On a similar note, i remember reading up on Ciscopress that you might NOT want to subject VoIP to any form of Shaping as this introdues delay and can cause Jitter.
Semi-true.
The problem can be mitigated by decreasing the shaper's Tc.  Also, if shaper doesn't account for L2 overhead (and I believe many do not), you'll need to shape "slower" than the nominal bandwidth.  The major problem with the latter, L2 overhead varies, as a percentage, based on packet size.  So, you can either allow for worst case, which will best guarantee VoIP service, but tends to give up much of the available bandwidth, or you can shape for average case, which will make VoIP latency and jitter more variable but usually not so much to exceed its service requirements.
You can also bypass shaping for some traffic, but then you need to shape all your other traffic even slower to guarantee the non-shaped traffic bandwidth is always available.  As you're effectively reserving this bandwidth, it then becomes unavailable for your other traffic even when unused.
An example of the latter:
policy-map QoS-Policy
 class preferred
  bandwidth remaining percent 40
  random-detect dscp-based
 class missioncritical
  bandwidth remaining percent 39
  random-detect dscp-based
 class trans-apps
  bandwidth remaining percent 16
  random-detect dscp-based
 class general
  bandwidth remaining percent 1
  random-detect dscp-based
 class class-default
  bandwidth remaining percent 4
  random-detect dscp-based
policy-map shape-20MB
 class realtime
  priority 512
    police 512000 conform-action transmit  exceed-action drop
 class class-default
  shape average 1950000
  service-policy QoS-Policy
interface Serial0/0/0
 service-policy output shape-20MB
NB: BTW, the above doesn't account for L2 overhead, and I wouldn't recommend it for other reasons, but it should show how you can bypass the shaper.

Similar Messages

  • Traffic Shaping for perticular traffic

    class-map match-any SYSLOG-CMAP
    match access-group name SYSLOG-ACL
    policy-map SYSLOG-PMAP
    class SYSLOG-CMAP
      shape average 250000
    interface GigabitEthernet0/1
    ip address 1.1.1.1 255.255.255.252
    ip flow ingress
    load-interval 30
    duplex full
    speed 100
    service-policy output SYSLOG-PMAP
    Router1#show policy-map int GigabitEthernet0/1
    GigabitEthernet0/1
      Service-policy output: SYSLOG-PMAP
        Class-map: SYSLOG-CMAP (match-any)
          712495474 packets, 394564809213 bytes
          30 second offered rate 41000 bps, drop rate 23000 bps
          Match: access-group name SYS-LOG-ACL
            712495474 packets, 394564809696 bytes
            30 second rate 41000 bps
          Queueing
          queue limit 64 packets
          (queue depth/total drops/no-buffer drops) 0/152567902/0
          (pkts output/bytes output) 559927554/295263742429
          shape (average) cir 250000, bc 1000, be 1000
          target shape rate 250000
        Class-map: class-default (match-any)
          3774914087 packets, 1413482437872 bytes
          30 second offered rate 2796000 bps, drop rate 0 bps
          Match: any
          queue limit 64 packets
          (queue depth/total drops/no-buffer drops) 0/19837/0
          (pkts output/bytes output) 3817743535/1477901813111
    =====================================================
    Hi everyone,
    In the above configuration, I configured traffic shaping to shape the syslog traffic to certain limit. My question is, Can I apply traffic shaping to perticular traffic ? What will happen to the remaining traffic ? We have ethernet hand-of to provider but total bandwidth we can use is 8M, which is controlled by ISP. We just send all the traffic without any shaping.
    Thanks

    Traffic shaping only works from the source. there is no way (other than policing - i.e., discard) to shape through the cloud.
    If you tried to pace the traffic through the cloud, it's got to be buffered somewhere, causing latency, and ultimately discarded frames after the buffers fill.
    Policing allows the traffic through until some threshold occurs (traditional frame = DE set at Bc, discard at Be), then the traffic is dropped.
    FWIW
    Scott

  • Traffic shaping for the Mac

    Some routers offer a traffic shaping option to keep uploads from slowing down downloads on asynchronus connections. The Airport Express doesn't? Any software to do it on the Mac?

    No the AirPort Express (AX) does not have this feature.
    Any software to do it on the Mac?
    Of course that would only affect traffic to/from that one specific Mac. You might want to take a look at IPNetTunerX.

  • Traffic shaping for each user

    Hello!
    I want to limit bandwidth to users. Each user must have own speed. For each user I define class-map and policy-map. But I have many users (above 500), but class-map limits 256 :(. How I can resolve my problem?
    My config for only 2 users:
    ip access-list extended u_2175_a
    permit ip any 10.10.10.1 0.0.0.0
    class-map u_2175
    match access-group name u_2175_a
    ip access-list extended u_2204_a
    permit ip any 10.10.10.2 0.0.0.0
    class-map u_2204
    match access-group name u_2204_a
    policy-map UNLIM_USERS
    class u_2175
    shape peak 256000
    class u_2204
    shape peak 512000
    Policy UNLIM_USERS applies to interface.
    Cisco 7200 NPE G2

    You can resolve your issues through enable intelligent traffic control to condition or applications for traffic rate limiting ie NBAR and Rate-limiting / CAR:
    You can designate CAR rate-limiting policies based on physical port, packet classification, IP address, MAC address, application flow, and other criteria specifiable by access lists or extended access lists. CAR rate limits may be implemented either on input or output interfaces or subinterfaces including Frame Relay and ATM subinterfaces.
    An example of use of CAR's rate-limiting capability is application-based rates limiting HTTP World Wide Web traffic to 50 percent of link bandwidth, which ensures capacity for non-Web traffic including mission-critical applications

  • Skype for business traffic shaping

    Good morning,
    I would like to implement Skype Business in my company. We are an international company with contacts in India, Tanzania, Canada and so on... so normal Skype connections are really bad in some countries because of the bandwith they have.
    I have seen the reviews of Skype Business, my question would be, how can i implement a nice traffic shaping for setting up all? I have access to all hardware in all the offices we have but i would need more help about
    Thanks in advance,
    Kind regards
    Celia Espinosa

    Hello Celia,
    I see you are wanting to implement Skype through out your network for making calls via Skype. This is very easy to do, as long as you have Internet access at all locations.  The only thiing I see is that the Internet Connections you have may not be up to our standards.
    The first thing that needs to be done is to run a Traffic Study in each location to determine the quality of the Internet Connection you need.  The simplest way is to run a Voxygen test at each site.  You can have someone at each site log into Voxygen at https://tools.voxygen.co.uk and run the Network Compability Test for Skype. This test will display results after each test to give you recommendations on what you need to have to connect to us.  It will test for up to 50 Channels.
    The next action is to determine what type of equipment you will need at each location.  For that answer, you should contact your IT department for recommendations.
    If you need PBX's or any other type of equipment, Skype can make recommendations via our web site.  http://www.skype.com/intl/en-us/business/skype-connect/
    From there you will need to have a Telecom person help you implement your network to connect to Skype.  Start small to test, then build from there.
    I hope we have answered some of your questions to get you started with Skype Connect.  We are here for your support, so come back anytime.
    Thank You for considering Skype and using the Skype Community Forums.
    Regards,
    Victor S.
    Skype Enterprise Support

  • Firewall for traffic shaping

    Hi all,
    I want one basic firewal which can manage traffic shaping. I am implimenting it in my small office around 15 to 20 users or more. Please suggest me which firewall is suitable for my office?.  thanks

    Hi Sandeep,
    The ASA5505 is a basic firewall which supports traffic shaping and it is suitable for the number of users. Here is more infomration about traffic shaping and QoS
    http://www.cisco.com/en/US/docs/security/asa/asa72/command/reference/s1_72.html
    You can also compare the differente models
    http://www.cisco.com/en/US/products/ps6120/prod_models_comparison.html#~tab-a,
    Thanks,
    Itzcoatl

  • Traffic Shaping on Sub-interfaces

    Hi all,
    On my network i am trying to give preference to certain traffic type A over another traffice type B  over a VSAT link.
    the VSAT link is about 64Kbps/64Kbps and this link is connected to a router subinterface.
    I initially thought of CBWFQ to reserve bandwidth for the differenct traffic types but there are restrictions to using CBWFQ on Sub interfaces.
    Hence I tot of the option of shaping the less preffered traffic to a less than half the bandwidth  say 24K will be a good idea however i worry that the contents of the shaping queue will constitute both the preffered traffic and the less preffered traffic hence introducing more delay to the more preffered traffic. which is not required.
    Any other better ways to achieve this?

    You can use hierarchical qos:
    http://www.cisco.com/en/US/tech/tk543/tk545/technologies_tech_note09186a0080114326.shtml

  • QoS Class-Based Traffic Shaping (what is Be)

    Guys,
    two questions on the output below :
    1. What is the Be, is this an amount per interval that can go over Bc or is it the total amount of data that can be sent?
    ie, i interpret the command to read, Bc is the sustained rate per interval and Be is the sustained rate plus another amount, it I would use sommat like this
    shape average 128000 7936 8500
    this would show that I could send in total up to 8500 bits per interval
    or does it work like this ?
    shape average 128000 7936 564
    this would show that I could send in total up to 8500 bits per interval
    if it is the first one, you would not expect to be able to configure a Be of less than Bc?
    Also, how can you show what traffic is within the Bc and what is in the Be? ie, how much data is being sent out of contract?
    Many kind regards,
    Ken
    Metro2(config-pmap-c)#policy-map test1_cos
    Metro2(config-pmap)# class class-default
    Metro2(config-pmap-c)# shape average ?
    <8000-154400000> Target Bit Rate (bits per second), the value needs to be
    multiple of 8000
    percent % of interface bandwidth for Committed information rate
    Metro2(config-pmap-c)# shape average 128000 ?
    <256-154400000> bits per interval, sustained. Needs to be multiple of 128.
    Recommend not to configure it, the algorithm will find out
    the best value
    <cr>
    Metro2(config-pmap-c)# shape average 128000 7936 ?
    <0-154400000> bits per interval, excess. Needs to be multiple of 128. Bc
    will be used if you don't configure it.
    <cr>
    Metro2(config-pmap-c)# shape average 128000 7936 1000 ?
    <cr>
    Metro2(config-pmap-c)# shape average 128000 7936 1000
    Metro2(config-pmap-c)#^Z
    Metro2#
    Metro2#sh policy-map int fa 0/1 out
    FastEthernet0/1
    Service-policy output: test1_cos
    Class-map: class-default (match-any)
    5476 packets, 1934775 bytes
    30 second offered rate 0 bps, drop rate 0 bps
    Match: any
    Traffic Shaping
    Target/Average Byte Sustain Excess Interval Increment
    Rate Limit bits/int bits/int (ms) (bytes)
    128000/128000 1117 7936 1000 62 992
    Adapt Queue Packets Bytes Packets Bytes Shaping
    Active Depth Delayed Delayed Active
    - 0 5476 1934775 967 1448313 no
    Metro2#
    Metro2# conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    Metro2(config)#policy-map test1_cos
    Metro2(config-pmap)# class class-default
    Metro2(config-pmap-c)# shape average 128000
    Metro2(config-pmap-c)#^Z
    Metro2#sh policy-map int fa 0/1 out
    FastEthernet0/1
    Service-policy output: test1_cos
    Class-map: class-default (match-any)
    5479 packets, 1934955 bytes
    30 second offered rate 0 bps, drop rate 0 bps
    Match: any
    Traffic Shaping
    Target/Average Byte Sustain Excess Interval Increment
    Rate Limit bits/int bits/int (ms) (bytes)
    128000/128000 1984 7936 7936 62 992
    Adapt Queue Packets Bytes Packets Bytes Shaping
    Active Depth Delayed Delayed Active
    - 0 5479 1934955 967 1448313 no
    Metro2#

    Guys,
    this is great stuff and I really apprciate it.
    The thing is this.
    One one URL it says the following :-
    For Class-based Shaping - How it Works
    When the Be size equals 0, the interface sends no more than the burst size every interval, achieving an average rate no higher than the mean rate. However, when the Be size is greater than 0, the interface can send as many as Bc + Be bits in a burst, if in a previous time period the maximum amount was not sent. Whenever less than the burst size is sent during an interval, the remaining number of bits, up to the Be size, can be used to send more than the burst size in a later interval.
    The other URL says :-
    DTS How It Works
    The Be size allows more than the Bc size to be sent during a time interval under certain conditions. Therefore, DTS provides two types of shape commands: average and peak. When shape average is configured, the interface sends no more than the Bc size for each interval, achieving an average rate no higher than the CIR. When the shape peak command is configured, the interface sends Bc plus Be bits in each interval.
    So which one is correct. I am really confused.
    As far as I am aware, I am running CB Shaping and not DTS, but when I go into the router configurations I get both options.
    average and peak ?
    Please see example :-
    Metro2(config)#policy-map test1_cos
    Metro2(config-pmap)#class class-default
    Metro2(config-pmap-c)#shap ?
    adaptive Enable Traffic Shaping adaptation to BECN
    average configure token bucket: CIR (bps) [Bc (bits) [Be (bits)]],
    send out Bc only per interval
    fecn-adapt Enable Traffic Shaping reflection of FECN as BECN
    fr-voice-adapt Enable rate adjustment depending on voice presence
    max-buffers Set Maximum Buffer Limit
    peak configure token bucket: CIR (bps) [Bc (bits) [Be (bits)]],
    send out Bc+Be per interval
    Many kind regards and thx for the help with this :)
    Ken

  • SMTP traffic shaping

    Hello. I'm trying to restrict SMTP bandwidth to ~640kbit. This should be applied to Se0/0 interface, my device is a Cisco 1760.
    IOS (tm) C1700 Software (C1700-K9O3SY7-M), Version 12.3(6a)
    I've tried this:
    class-map match-all match-smtp
    match protocol smtp
    policy-map smtptraffic
    class match-smtp
    shape average 640000 640000 0
    interface Serial0/0
    ip address x.x.x.x 255.255.255.252
    ip access-group in-list in
    ip access-group out-list out
    ip nat outside
    service-policy output smtptraffic
    encapsulation ppp
    ip route-cache flow
    VPN-Bucharest#sh policy-map int Se0/0
    Serial0/0
    Service-policy output: smtptraffic
    Class-map: match-smtp (match-all)
    59977 packets, 83502451 bytes
    5 minute offered rate 0 bps, drop rate 0 bps
    Match: access-group 2
    Traffic Shaping
    Target/Average Byte Sustain Excess Interval Increment
    Rate Limit bits/int bits/int (ms) (bytes)
    640000/640000 80000 640000 0 1000 80000
    Adapt Queue Packets Bytes Packets Bytes Shaping
    Active Depth Delayed Delayed Active
    - 0 0 0 0 0 no
    Class-map: class-default (match-any)
    58902 packets, 33267078 bytes
    5 minute offered rate 17000 bps, drop rate 0 bps
    Match: any
    When the Exchange server (attached on Fa0/0) starts spitting out mails to the Internet the traffic instantly reaches wirespeed (1mbps), and of course all hell breaks loose (latency, etc). The question is what is wrong with the above config that won't keep SMTP traffic at 640kbit.
    I see a "Shaping Active no" there, which doesn't sound good.
    I am definitely missing something.
    Any help is appreciated, thank you.
    --Adrian.

    Hello Adrian,
    there is one strange thing in your show/config given:
    class-map match-all match-smtp
    match protocol smtp
    ----snip----
    Class-map: match-smtp (match-all)
    59977 packets, 83502451 bytes
    5 minute offered rate 0 bps, drop rate 0 bps
    Match: access-group 2
    ----snip----
    Why does ACL 2 show up int the show policy-map command, when you have configured NBAR (match protocol smtp)?
    Are you sure those two outputs are from the same router with the same config? Can you please highlight the underlying reason for this inconsistency? If not a reboot might help ...
    Otherwise you might also leave away the Bc and Be values and just take "shape average 640000".
    Hope this helps! Please rate all posts.
    Regards, Martin

  • Traffic shaping G723 traffic between 2 companies

    Hi,
    Can someone put me on the right way to implement traffic shaping (QoS) for G723 traffic.
    Situation:
    Two companies connected to each other with a vpn tunnel. The hardware is Cisco 2621xm at the sublocation and on the hq location is an 2651XM.
    There is an GRE tunnel configured between the two sites. The GRE tunnel is up and working.
    On both sites there is an telephony system that can use G723 anr/or G711. Both telephony systems are connected to each other.
    Voice is working, but now we want to implement QoS for the VOIP connection.
    Has someone suggestions for me ?

    Hi,
    Appy a policy-map with the desired QoS policy to the tunnel interface.
    First of all, issue 'qos pre-classify' on the the tunnel itself, otherwise the congestion management mechanism will be useless.
    Cheers,
    Gabriel

  • Traffic Shaping - can't get it to work

    Hi
    I’m attempting to create a basic traffic shaping policy in a lab environment but I can’t seem to get it to limit the download rate?
    I can successfully achieve this with policing. I am testing the speed restriction using a broadband speed testing website, policing is clearly impacting the download rate, this is not the case with shaping. Please see below the shaping and policing policies, which I am attaching in turn to the vlan1 interface outbound.
    Further I have messed around with the below shaping policy and set a fixed cir as in the policing policy but it still has no impact on the download speed.
    Finally class SLOW_PC under PM POLICE matches an ACL matching traffic to and from a particular IP address. The speedlimiter is matching all traffic
    Policy Map speedlimiter(Shaping)
        Class class-default
          Average Rate Traffic Shaping
          cir 1%
      Policy Map POLICE
        Class SLOW_PC
         police cir 1048500 bc 32765
           conform-action transmit
           exceed-action drop
    any help appreciated

    Shaping and policing can both can be used for outbound traffic on an interface, but only policing can be used for inbound traffic. If you're trying to use shaping (which works by managing the queue) on inbound traffic (which has no manageable queue) it will have no effect. Policing is the only option in this case.

  • Can Anyone Help Me Configure My Verizon (D-Link) DSL-2750B "Traffic Shaping" (QoS)?

    Well ... I just spent a wonderful hour and a half (not) bouncing around VZ technical support, etc. trying to get assistance regarding configuring my DSL router.* Between the low-quality Skype connection to India and my lack of success, I'm a little bummed out right now.
    Could one of you perhaps help me? I'm trying to configure a single, wire-attached network node (port 4 of the router) so that it can only consume up to 320 Kbps of my 750 Kbps (7.5 Mbps) DSL bandwidth ... no matter what. This results from this node consuming virtually all of the circuit's bandwidth when streaming or during bulk file transfers.
    I have tried to remedy the problem using priority with no discernible impact.
    The Quality of Service (QoS) element called Traffic Shaping (Services | QoS | Traffic Shaping), described on Page 51 of the VZ DSL-2750B User Manual , appears to be the ideal solution to my problem. Repeated attempts at activating this QoS have all resulted in no throttling of bandwidth consumption.
    My most recent attempt was to define the device on Port 4 as the DMZ host ... and then apply a new rule (320 TX, 320 RX) to this interface. Again, no joy.
    Does anyone have any experience with this service on this router?
    Am I chasing my tail trying to configure the router without validating that my circuit is not configured with "Fastpath (PSE) inactive"?
    If the circuit configuration is a potential problem, which office should I ask for at VZ customer service?
    Here is the information from the System page of the Router Control Panel:
      Gateway ID: PX2M1BC000000
      Software Version: 5.4.12.1.44
      Release Date: Feb 19 2012
      Platform: D-Link DSL-2750B
      Board Tag:... Ntag-5_4_12_1_44
      Compilation Flags:... LIC=/home/bat/bat/dlink_bcm96328_5_4_12_1/20120219_1343/conf/jpkg_bcm9636x_dlink.lic CONFIG_RG_PROD_IMG=y DIST=DLINK_DSL2750B
    I'll note that the Router provides a notification that "RX QOS might not operate when Fastpath (PSE) is active" when I update the router configuration page concerning Traffic Shaping. Because Fastpath is not mentioned in the User Manual, I'm guessing that Fastpath (PSE) might be a configurable attribute of the circuit servicing my PoP, but I have no idea if this is the case.
    I searched for relevant messages on this board ... without success. If this has already been addressed, please provide a link, and accept my apologies. (My Google-Fu tends to be weak.)

    The asterisk in the first post refers to the following summary of events:
    10:40 - Attempt to solve my configuration question using VZ chat begins.
    10:49 - VZ chat agent Danish refers me to phone support.  (Chat ID number is 020813176471 if you're with VZ and are interested.)
    10:50 - Call VZ phone support.
    11:02 - Talk with Angel.  Because she has not heard of, nor received training in, "traffic shaping," she says my question about configuring this VZ DSL modem must be addressed by "Premium Technical Support."  She transfers me.
    11:13 - Talk with Pamela.  Premium Technical Support only responds to questions about 3d party products.  Because my question concerns a VZ DSL modem, Basic Technical Support is responsible.  She transfers me.
    11:17 - Talk with Joe.  He says either the vendor (D-Link) or premium technical support is required.  Because I had already tried with D-Link (they referred me to Verizon, as this modem was built exclusively for VZ), I explained what I had already experienced, and described how I wanted "assistance configuring my VZ DSL modem, specifically a feature described on page 51 of the User Manual."  He transfers me.
    11:23 - The automated phone system asks for my 12-digit customer ID.  I wasn't able to find it fast enough, and rolled through to Financial Services.  Eventually Trig picked up, listened to my story, and transferred me to "Technical Support" providing the direct dial number, just in case (866.945.79xx).
    11:32 - Entered the phone queue.  Lots of hissing and clicks.
    11:35 - Talk with Monika.  (The voice clarity from this point onward was on the order of 1st-generation Skype.  Between the horrible language problem -- Monika is in India don'cha know -- and the lousy line quality, this was the most frustrating.)  No matter what I said, I couldn't convey the reason for my call.  I asked to talk with a supervisor, which Monika related was not possible.  She also related that she could not transfer me to an American POC or supervisor.
    12:01 - Hung up the phone ... and started down the path that led to my post immediately above.
    I was repeatedly queried about the account name and number throughout the process.  Conveying this information was especially challenging during the Indian call segment.

  • Traffic Shaping on a 2600 router (IOS ver 12.2.31)

    I have configured traffic shaping on a Fastethernet subinterface as follows;
    f0/0.1
    traffic-shape rate 256000 7936 7936 1000
    After reviewing the management graphs it looks as though the Traffic Shaping is not working as the graph shows a utilization of 800%. Is there a known reason for this and is there a way I can check on the router. I have ran the show commands but nothing is obvious as to the reason for this. The router is a replacement for a 1721. The same config has been applied. This started happening when the routers were changed.

    This is a very vague question, but you may need to add a bandwidth statement to your interface for your application to correctly interpret the utilization.

  • Traffic shaping

    hi, I am trying to configure traffic shaping on 100Mb wan circuit. and normal traffic is 60 Mb on production hour. Not sure how to calculate shaping bit value for 100 meg circuit. can anyone help.

    Disclaimer
    The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
    Liability Disclaimer
    In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
    Posting
    What Paul shows, is a good way to shape.  However, when you say 60 Mbps (of 100 Mbps), I believe most shapers don't account for L2 overhead.  So if you really want to only use 60% of your 100 Mbps, you'll need to shape 5 to 15% slower (unfortunately, L2 overhead percentages varies based on packet size - allowing for average packets sizes is usually "good enough").

  • Traffic shaping combined with queuing

    Without any traffic shaping, queuing(ex: priority or custom) is only invoked when congestion occurs... correct?
    When FRTS shaping is used and custom queuing also specified, is the queuing only invoked when traffic exceeds the shaped speed, or is it always used? ie: If no other traffic present, would traffic specified to use only 50% of shaped bandwidth use 100% of the shaped bandwidth?
    When GTS is used with a GROUP specifing an ACL, is matching traffic always limited to the shaped amount, even if no other traffic on the line? Could non-shaped traffic dominate the line or is GTS-shaped traffic guaranteed the minimum amount?

    1. when you have traffic shapping and the limit
    for the shaped value is exeeeded, all traffic arriving at the interface with
    no token in the token bucket is queued using the configured queue to thier appropriate queue..
    hence any type of queueing is not invoken unless some sort of trafiic conjestion exist either
    via shapping or otherwise.
    2. If you have a granular shaping instruction per protocol per bandwidth. The traffic over
    its shapped value would be queued and sent at maximun shape rate configured. ( that's one of the uses of shaping, to trim rate at which
    a specific traffic is sent). If its just queuing that is enable not shaping, then
    a traffic for a specific queue can use as much bandwidth as availabel when there is no other traffic, hence no congestion.
    3. if you have shaped and non-shaped traffic on an interface using GTS, the shaped traffic can use as much bandwidht as the maximum of the shaped
    value while not-shaped traffic will also use bandwidht on as see bandwidth without the need to be controlled, however non-shaped traffic will use
    all the bandwidht it needs till the interface start droping packet but the shaped traffic would be queued till there is enough token to start outputing
    from that queue. if the there are non-shaped traffic, it could be possible that they may overwelm the interface
    and prevent even shaped traffic from geting enough bandwidht to the shaped value.

Maybe you are looking for

  • Audio Line-in input and BT Headset output not working

    Hi, I'm trying to run the Line-in into my MBPro and route the output to my Logitech H800 BT Headphones at the same time (a pass through), but can't get it to work. I have tried to run the line-in to the Internal Speakers and can not get this to work

  • Check iPad version and release date

    Hello All I would be grateful to have your thoughts and views on this. I am currently intending to buy an iPad from one of my acquaintances as he is upgrading to a later version of iPad. However, when I get the device, is there any way I could possib

  • I can't download updates from hp support assistant

    I have hp pavilion g6 and i can't download updates from hp support assistant, when i press download and install selected updates then i found above downloads is completed then i clicked Next and when i came back i found it still not done, help please

  • Does iMovie '08 store iPhoto videos somewhere?

    I realize that my Camcorder Videos are downloaded to the Hard Drive (I've specified an external HD) but iMovie has also "imported" my iPhoto videos. On iPhoto I have my photos and videos taken with still cameras (can't really call them "still") - OK

  • Permissions error when importing certain CD's

    I've been trying to import a couple CD's into my iTunes 7.6 (29) on a iMac 7,1 but every time I click "Import CD" on it, it says that the Music folder does not allow enough permissions to go through with that function. But It's only with two CD's (To