Traffic shaping/limiting 3560

How can i shape/limit the interface of an cisco 3560 not to allow more than
8mbit of outgoing and ingoing traffic?
Will something like this work:
class-map match-all any
match ip dscp default
policy-map 8mbps
class any
police 8388500 8000 exceed-action drop
interface FastEthernet0/13
switchport access vlan 940
switchport mode access
service-policy input 8mbps
srr-queue bandwidth shape 12 12 12 12
Jo Christian Buvarp

Hi,
your input config is ok and will limit traffic to 8 Mbps. on the output side, traffic is sorted into 4 queues. With shaped output, which you configured, each of the queues will be limited to 1/12 = approx. 8 Mbps. This will give you a total of up to 24 Mbps on output depending on how you sort traffic into the 4 queues.
If you can make sure all traffic is marked as "default", this should give you the desired result. You can also assign traffic to queues following
http://www.cisco.com/en/US/products/hw/switches/ps5528/products_configuration_guide_chapter09186a00801e85dd.html#1163863
with the command
mls qos srr-queue output dscp-map queue queue-id threshold threshold-id dscp1...dscp8
Hope this helps! Please rate all posts.
Regards, Martin

Similar Messages

  • QoS Traffic shaping and peak shaping

    Hi,
    Could somebody tell me what is the difference between traffic shaping and peak shaping?
    Kind Regards.

    Standard traffic shaping (the shape average command) will keep the average rate of the traffic to the limit you specify, which should be the committed rate of your circuit.
    Peak shaping will also do traffic shaping (using queues, etc), guaranteeing a minimum rate, but will allow traffic to levels to burst above your configured (committed) rate.
    From the documentation:
    Traffic shaping limits the rate of transmission of data. In addition to using a specifically configured transmission rate, you can use Generic Traffic Shaping (GTS) to specify a derived transmission rate based on the level of congestion.
    You can specify two types of traffic shaping; average rate shaping and peak rate shaping. Average rate shaping limits the transmission rate to the CIR. Using the CIR ensures that the average amount of traffic being sent conforms to the rate expected by the network.
    Peak rate shaping configures the router to send more traffic than the CIR. To determine the peak rate, the router uses the following formula:
    peak rate = CIR(1 + Be / Bc)
    where:
    •Be is the Excess Burst size.
    •Bc is the Committed Burst size.
    Peak rate shaping allows the router to burst higher than average rate shaping. However, using peak rate shaping, the traffic sent above the CIR (the delta) could be dropped if the network becomes congested.
    If your network has additional bandwidth available (over the provisioned CIR) and the application or class can tolerate occasional packet loss, that extra bandwidth can be exploited through the use of peak rate shaping. However, there may be occasional packet drops when network congestion occurs. If the traffic being sent to the network must strictly conform to the configured network provisioned CIR, then you should use average traffic shaping.
    Examples
    The following example sets the uses average rate shaping to ensure a bandwidth of 256 kbps:
    shape average 256000
    The following example uses peak rate shaping to ensure a bandwidth of 300 kbps but allow throughput up to 512 kbps if enough bandwidth is available on the interface:
    bandwidth 300
    shape peak 512000

  • Traffic shaping on 6509

    I have got a Catalyst 6509 switch with MSFC3 and IOS 12.2(18)SXD3.Can anyone suggest how to implement Layer2 traffic shaping in the MSFC.

    thanks Prashanth
    This helped me alot.This document indicates policing in MSFC is done on IP.But can we implement policing on MAC basis? Because my setup is such that I have a firewall module operationg in routed mode. I create L2 VLANs in MSFC and map the same onto the firewall module.As traffic shaping/policing cant be done on the firewall module i have to do it on the MSFC. Can policing help limiting bandwidth on L2 VLANs in this scenario?
    thanks again
    Ashish

  • Traffic-shaping for delay sensitive traffic

    Hello, I would like to verify the use of a traffic-shaping policy within an MQC. I was told that you need to apply a shaping policy in order for QoS to always be engaged and not simply during times of congestion. This apparently is critical when you have apps like VoIP. 
    On a similar note, i remember reading up on Ciscopress that you might NOT want to subject VoIP to any form of Shaping as this introdues delay and can cause Jitter.
    Below is a sample config. If you can post an authoritative source on CCO that explains this I would greatly appreciate it.
    Regards,
    -Mike
    policy-map QoS-Policy
     class realtime
      priority 512
        police 512000 conform-action transmit  exceed-action drop
     class preferred
      bandwidth remaining percent 40
      random-detect dscp-based
     class missioncritical
      bandwidth remaining percent 39
      random-detect dscp-based
     class trans-apps
      bandwidth remaining percent 16
      random-detect dscp-based
     class general
      bandwidth remaining percent 1
      random-detect dscp-based
     class class-default
      bandwidth remaining percent 4
      random-detect dscp-based
    policy-map shape-20MB
     class class-default
      shape average 2000000
      service-policy QoS-Policy
    interface Serial0/0/0
     service-policy output shape-20MB

    Disclaimer
    The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
    Liability Disclaimer
    In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
    Posting
    I was told that you need to apply a shaping policy in order for QoS to always be engaged and not simply during times of congestion.
    Nope.
    You only need to shape when you're dealing with a path where you know the end-to-end bandwidth is less the the egress interface's physical bandwidth and where you cannot manage congestion further downstream along the end-to-end path.
    On a similar note, i remember reading up on Ciscopress that you might NOT want to subject VoIP to any form of Shaping as this introdues delay and can cause Jitter.
    Semi-true.
    The problem can be mitigated by decreasing the shaper's Tc.  Also, if shaper doesn't account for L2 overhead (and I believe many do not), you'll need to shape "slower" than the nominal bandwidth.  The major problem with the latter, L2 overhead varies, as a percentage, based on packet size.  So, you can either allow for worst case, which will best guarantee VoIP service, but tends to give up much of the available bandwidth, or you can shape for average case, which will make VoIP latency and jitter more variable but usually not so much to exceed its service requirements.
    You can also bypass shaping for some traffic, but then you need to shape all your other traffic even slower to guarantee the non-shaped traffic bandwidth is always available.  As you're effectively reserving this bandwidth, it then becomes unavailable for your other traffic even when unused.
    An example of the latter:
    policy-map QoS-Policy
     class preferred
      bandwidth remaining percent 40
      random-detect dscp-based
     class missioncritical
      bandwidth remaining percent 39
      random-detect dscp-based
     class trans-apps
      bandwidth remaining percent 16
      random-detect dscp-based
     class general
      bandwidth remaining percent 1
      random-detect dscp-based
     class class-default
      bandwidth remaining percent 4
      random-detect dscp-based
    policy-map shape-20MB
     class realtime
      priority 512
        police 512000 conform-action transmit  exceed-action drop
     class class-default
      shape average 1950000
      service-policy QoS-Policy
    interface Serial0/0/0
     service-policy output shape-20MB
    NB: BTW, the above doesn't account for L2 overhead, and I wouldn't recommend it for other reasons, but it should show how you can bypass the shaper.

  • Traffic shaping

    hi, I am trying to configure traffic shaping on 100Mb wan circuit. and normal traffic is 60 Mb on production hour. Not sure how to calculate shaping bit value for 100 meg circuit. can anyone help.

    Disclaimer
    The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
    Liability Disclaimer
    In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
    Posting
    What Paul shows, is a good way to shape.  However, when you say 60 Mbps (of 100 Mbps), I believe most shapers don't account for L2 overhead.  So if you really want to only use 60% of your 100 Mbps, you'll need to shape 5 to 15% slower (unfortunately, L2 overhead percentages varies based on packet size - allowing for average packets sizes is usually "good enough").

  • Traffic shaping combined with queuing

    Without any traffic shaping, queuing(ex: priority or custom) is only invoked when congestion occurs... correct?
    When FRTS shaping is used and custom queuing also specified, is the queuing only invoked when traffic exceeds the shaped speed, or is it always used? ie: If no other traffic present, would traffic specified to use only 50% of shaped bandwidth use 100% of the shaped bandwidth?
    When GTS is used with a GROUP specifing an ACL, is matching traffic always limited to the shaped amount, even if no other traffic on the line? Could non-shaped traffic dominate the line or is GTS-shaped traffic guaranteed the minimum amount?

    1. when you have traffic shapping and the limit
    for the shaped value is exeeeded, all traffic arriving at the interface with
    no token in the token bucket is queued using the configured queue to thier appropriate queue..
    hence any type of queueing is not invoken unless some sort of trafiic conjestion exist either
    via shapping or otherwise.
    2. If you have a granular shaping instruction per protocol per bandwidth. The traffic over
    its shapped value would be queued and sent at maximun shape rate configured. ( that's one of the uses of shaping, to trim rate at which
    a specific traffic is sent). If its just queuing that is enable not shaping, then
    a traffic for a specific queue can use as much bandwidth as availabel when there is no other traffic, hence no congestion.
    3. if you have shaped and non-shaped traffic on an interface using GTS, the shaped traffic can use as much bandwidht as the maximum of the shaped
    value while not-shaped traffic will also use bandwidht on as see bandwidth without the need to be controlled, however non-shaped traffic will use
    all the bandwidht it needs till the interface start droping packet but the shaped traffic would be queued till there is enough token to start outputing
    from that queue. if the there are non-shaped traffic, it could be possible that they may overwelm the interface
    and prevent even shaped traffic from geting enough bandwidht to the shaped value.

  • Packet filtering and traffic shaping during peak h...

    I play the online game World of Tanks and an currently exteriancing severe lagg and disconnects, the problem does not appear to be with the game/service provider but with BT, i need to know does BT  use "packet filtering" and "traffic shaping" during peak hours and if so why has it suddenly started.
    This game use's P2P to keep the latency down for players so have been advised to contact BT and ask them are they limiting these types of connections.
    Most games do not use these types of connections, but World of Tanks one does and again,been told BT just don't like them, due to the amount of connections they attempt to forge in order to have a stable latency.
    I need to know if this is going to continue as pay to play the game, therefore would have to consider changing my ISP to virgin who dont  use "packet filtering" and "traffic shaping" during peak hours .
    Quick advice would be appreciated.

    It's absolutely horrible. i turned off wifi all other devices and every other open program just to reduce my latency for 120ms to 80ms.
    Still suffer from huge packet loss.
    It would be absolutely horrible if they have started throttling worldoftanks.eu servers. Phone support is no help all they torld me to do is restart my router
    I hope this is fixed soon. There are many posts on the WoT eu official forums and everyone that is effected appears to be a BT customer.
    Some have mentioned it could be the damaged undersea cable.
    I don't have any problems with torrents being throttled or anything like that. only worldoftanks.eu being throttled.

  • Traffic shaping G723 traffic between 2 companies

    Hi,
    Can someone put me on the right way to implement traffic shaping (QoS) for G723 traffic.
    Situation:
    Two companies connected to each other with a vpn tunnel. The hardware is Cisco 2621xm at the sublocation and on the hq location is an 2651XM.
    There is an GRE tunnel configured between the two sites. The GRE tunnel is up and working.
    On both sites there is an telephony system that can use G723 anr/or G711. Both telephony systems are connected to each other.
    Voice is working, but now we want to implement QoS for the VOIP connection.
    Has someone suggestions for me ?

    Hi,
    Appy a policy-map with the desired QoS policy to the tunnel interface.
    First of all, issue 'qos pre-classify' on the the tunnel itself, otherwise the congestion management mechanism will be useless.
    Cheers,
    Gabriel

  • Traffic Shaping - can't get it to work

    Hi
    I’m attempting to create a basic traffic shaping policy in a lab environment but I can’t seem to get it to limit the download rate?
    I can successfully achieve this with policing. I am testing the speed restriction using a broadband speed testing website, policing is clearly impacting the download rate, this is not the case with shaping. Please see below the shaping and policing policies, which I am attaching in turn to the vlan1 interface outbound.
    Further I have messed around with the below shaping policy and set a fixed cir as in the policing policy but it still has no impact on the download speed.
    Finally class SLOW_PC under PM POLICE matches an ACL matching traffic to and from a particular IP address. The speedlimiter is matching all traffic
    Policy Map speedlimiter(Shaping)
        Class class-default
          Average Rate Traffic Shaping
          cir 1%
      Policy Map POLICE
        Class SLOW_PC
         police cir 1048500 bc 32765
           conform-action transmit
           exceed-action drop
    any help appreciated

    Shaping and policing can both can be used for outbound traffic on an interface, but only policing can be used for inbound traffic. If you're trying to use shaping (which works by managing the queue) on inbound traffic (which has no manageable queue) it will have no effect. Policing is the only option in this case.

  • Can Anyone Help Me Configure My Verizon (D-Link) DSL-2750B "Traffic Shaping" (QoS)?

    Well ... I just spent a wonderful hour and a half (not) bouncing around VZ technical support, etc. trying to get assistance regarding configuring my DSL router.* Between the low-quality Skype connection to India and my lack of success, I'm a little bummed out right now.
    Could one of you perhaps help me? I'm trying to configure a single, wire-attached network node (port 4 of the router) so that it can only consume up to 320 Kbps of my 750 Kbps (7.5 Mbps) DSL bandwidth ... no matter what. This results from this node consuming virtually all of the circuit's bandwidth when streaming or during bulk file transfers.
    I have tried to remedy the problem using priority with no discernible impact.
    The Quality of Service (QoS) element called Traffic Shaping (Services | QoS | Traffic Shaping), described on Page 51 of the VZ DSL-2750B User Manual , appears to be the ideal solution to my problem. Repeated attempts at activating this QoS have all resulted in no throttling of bandwidth consumption.
    My most recent attempt was to define the device on Port 4 as the DMZ host ... and then apply a new rule (320 TX, 320 RX) to this interface. Again, no joy.
    Does anyone have any experience with this service on this router?
    Am I chasing my tail trying to configure the router without validating that my circuit is not configured with "Fastpath (PSE) inactive"?
    If the circuit configuration is a potential problem, which office should I ask for at VZ customer service?
    Here is the information from the System page of the Router Control Panel:
      Gateway ID: PX2M1BC000000
      Software Version: 5.4.12.1.44
      Release Date: Feb 19 2012
      Platform: D-Link DSL-2750B
      Board Tag:... Ntag-5_4_12_1_44
      Compilation Flags:... LIC=/home/bat/bat/dlink_bcm96328_5_4_12_1/20120219_1343/conf/jpkg_bcm9636x_dlink.lic CONFIG_RG_PROD_IMG=y DIST=DLINK_DSL2750B
    I'll note that the Router provides a notification that "RX QOS might not operate when Fastpath (PSE) is active" when I update the router configuration page concerning Traffic Shaping. Because Fastpath is not mentioned in the User Manual, I'm guessing that Fastpath (PSE) might be a configurable attribute of the circuit servicing my PoP, but I have no idea if this is the case.
    I searched for relevant messages on this board ... without success. If this has already been addressed, please provide a link, and accept my apologies. (My Google-Fu tends to be weak.)

    The asterisk in the first post refers to the following summary of events:
    10:40 - Attempt to solve my configuration question using VZ chat begins.
    10:49 - VZ chat agent Danish refers me to phone support.  (Chat ID number is 020813176471 if you're with VZ and are interested.)
    10:50 - Call VZ phone support.
    11:02 - Talk with Angel.  Because she has not heard of, nor received training in, "traffic shaping," she says my question about configuring this VZ DSL modem must be addressed by "Premium Technical Support."  She transfers me.
    11:13 - Talk with Pamela.  Premium Technical Support only responds to questions about 3d party products.  Because my question concerns a VZ DSL modem, Basic Technical Support is responsible.  She transfers me.
    11:17 - Talk with Joe.  He says either the vendor (D-Link) or premium technical support is required.  Because I had already tried with D-Link (they referred me to Verizon, as this modem was built exclusively for VZ), I explained what I had already experienced, and described how I wanted "assistance configuring my VZ DSL modem, specifically a feature described on page 51 of the User Manual."  He transfers me.
    11:23 - The automated phone system asks for my 12-digit customer ID.  I wasn't able to find it fast enough, and rolled through to Financial Services.  Eventually Trig picked up, listened to my story, and transferred me to "Technical Support" providing the direct dial number, just in case (866.945.79xx).
    11:32 - Entered the phone queue.  Lots of hissing and clicks.
    11:35 - Talk with Monika.  (The voice clarity from this point onward was on the order of 1st-generation Skype.  Between the horrible language problem -- Monika is in India don'cha know -- and the lousy line quality, this was the most frustrating.)  No matter what I said, I couldn't convey the reason for my call.  I asked to talk with a supervisor, which Monika related was not possible.  She also related that she could not transfer me to an American POC or supervisor.
    12:01 - Hung up the phone ... and started down the path that led to my post immediately above.
    I was repeatedly queried about the account name and number throughout the process.  Conveying this information was especially challenging during the Indian call segment.

  • Traffic Shaping for perticular traffic

    class-map match-any SYSLOG-CMAP
    match access-group name SYSLOG-ACL
    policy-map SYSLOG-PMAP
    class SYSLOG-CMAP
      shape average 250000
    interface GigabitEthernet0/1
    ip address 1.1.1.1 255.255.255.252
    ip flow ingress
    load-interval 30
    duplex full
    speed 100
    service-policy output SYSLOG-PMAP
    Router1#show policy-map int GigabitEthernet0/1
    GigabitEthernet0/1
      Service-policy output: SYSLOG-PMAP
        Class-map: SYSLOG-CMAP (match-any)
          712495474 packets, 394564809213 bytes
          30 second offered rate 41000 bps, drop rate 23000 bps
          Match: access-group name SYS-LOG-ACL
            712495474 packets, 394564809696 bytes
            30 second rate 41000 bps
          Queueing
          queue limit 64 packets
          (queue depth/total drops/no-buffer drops) 0/152567902/0
          (pkts output/bytes output) 559927554/295263742429
          shape (average) cir 250000, bc 1000, be 1000
          target shape rate 250000
        Class-map: class-default (match-any)
          3774914087 packets, 1413482437872 bytes
          30 second offered rate 2796000 bps, drop rate 0 bps
          Match: any
          queue limit 64 packets
          (queue depth/total drops/no-buffer drops) 0/19837/0
          (pkts output/bytes output) 3817743535/1477901813111
    =====================================================
    Hi everyone,
    In the above configuration, I configured traffic shaping to shape the syslog traffic to certain limit. My question is, Can I apply traffic shaping to perticular traffic ? What will happen to the remaining traffic ? We have ethernet hand-of to provider but total bandwidth we can use is 8M, which is controlled by ISP. We just send all the traffic without any shaping.
    Thanks

    Traffic shaping only works from the source. there is no way (other than policing - i.e., discard) to shape through the cloud.
    If you tried to pace the traffic through the cloud, it's got to be buffered somewhere, causing latency, and ultimately discarded frames after the buffers fill.
    Policing allows the traffic through until some threshold occurs (traditional frame = DE set at Bc, discard at Be), then the traffic is dropped.
    FWIW
    Scott

  • Traffic shaping for the Mac

    Some routers offer a traffic shaping option to keep uploads from slowing down downloads on asynchronus connections. The Airport Express doesn't? Any software to do it on the Mac?

    No the AirPort Express (AX) does not have this feature.
    Any software to do it on the Mac?
    Of course that would only affect traffic to/from that one specific Mac. You might want to take a look at IPNetTunerX.

  • Traffic Shaping ASR9k in output interface.

    If we configure output traffic shaping  on an ASR 9000 interface the Service Policy is not installed, however in cco we can find that traffic shaping is supported see the next link:
    http://www.cisco.com/en/US/docs/routers/asr9000/software/asr9k_r4.2/qos/configuration/guide/b_qos_cg421asr_chapter_0100.html#ID407
    My configuration is:
    policy-map I4-TEST-OUT
    class class-default
      shape average 300000 bps
    interface GigabitEthernet0/0/1/10
    description <DESCRIPTION . CIRCUIT_ID>
    bandwidth 300
    service-policy input I4-TEST-IN
    service-policy output I4-TEST-OUT
    ipv4 address 1.1.1.1 255.255.255.252
    ipv4 verify unicast source reachable-via rx
    load-interval 30
    ASR9k#show policy-map int g0/0/1/10
    GigabitEthernet0/0/1/10 input: I4-TEST-IN
    Class class-default
      Classification statistics          (packets/bytes)     (rate - kbps)
        Matched             :                   0/0                    0
        Transmitted         : N/A
        Total Dropped       :                   0/0                    0
      Policing statistics                (packets/bytes)     (rate - kbps)
        Policed(conform)    :                   0/0                    0
        Policed(exceed)     :                   0/0                    0
        Policed(violate)    :                   0/0                    0
        Policed and dropped :                   0/0
    GigabitEthernet0/0/1/10 direction output: Service Policy not installed
    RP/0/RSP1/CPU0:CE.HTCHP.RPE01#
    as you can see we got a message "GigabitEthernet0/0/1/10 direction output: Service Policy not installed".
    If I use a class instead of the class class-default the policy-map is correctly installed,  If I use a child policy-map under the class class-default the policy is installed also.
    Do you know if it is a restriction to use traffic shaping in an output interface and using the default class?
    regards
    thanks

    I forgot to post the 15.x otuput; here it is.
    R2#sh policy-map int f0/0
     FastEthernet0/0
      Service-policy output: SHAPE_10M
        Class-map: class-default (match-any)
          14 packets, 1056 bytes
          5 minute offered rate 0000 bps, drop rate 0000 bps
          Match: any
          Queueing
          queue limit 64 packets
          (queue depth/total drops/no-buffer drops) 0/0/0
          (pkts output/bytes output) 14/1056
          shape (average) cir 10000000, bc 40000, be 40000
          target shape rate 10000000

  • Traffic Shaping on a 2600 router (IOS ver 12.2.31)

    I have configured traffic shaping on a Fastethernet subinterface as follows;
    f0/0.1
    traffic-shape rate 256000 7936 7936 1000
    After reviewing the management graphs it looks as though the Traffic Shaping is not working as the graph shows a utilization of 800%. Is there a known reason for this and is there a way I can check on the router. I have ran the show commands but nothing is obvious as to the reason for this. The router is a replacement for a 1721. The same config has been applied. This started happening when the routers were changed.

    This is a very vague question, but you may need to add a bandwidth statement to your interface for your application to correctly interpret the utilization.

  • Traffic shaping: Which is the best solution?

    Hi! I'm running 3 computers on 1 d-link router, 2 of them has an archlinux installed. Wondershaper mostly works for me when the other computers has cfosspeed running on windows, but when both computers run archlinux and wshaper and p2p applications, ping is over 1000ms instead of 10-20ms.
    Which is the best solution of traffic shaping on linux, and is there a howto for them (can be even a gentoo wiki page or similar)?
    Edit: shorewall is not being built from yaourt (x86_64), can't find a usable manual for trickle and niceshaper, (even ubuntu forums has unreplied "threads" about it) and can't start them coz missing config files, it seems, noone cares about ACK priority and ping in the Linux world
    Last edited by Vegita (2010-02-24 19:58:07)

    This config file is being used on 2 computers, and not working, my speed is 8m/1m. Any ideas? I don't want to limit anything, I just want ACK's priority to set to the highest, and same with http, and get p2p apps (opn this computer ktorrent and valknut, on the other ktorrent) priority on lowest. valknut's port is 1412, ktorrents' one is 6881 on this and 24748 on the other computer. Any ideas what to modify for small ping?
    # shaping config script for pyshaper             
    # for more information about pyshaper configuration, refer to the
    # file 'pyshaper.conf.readme', and the examples therein
    # set the connection-scanning period to 15 seconds (which is very
    # aggressive). IF you're more concerned about longer-running
    # connections, set this to a longer value (say, 60-300 seconds).
    period 30
    # declare one network interface, and set its inbound
    # and outbound bandwidth in kbits/sec
    eth0.ip 192.168.0.180
    eth0.in 8096
    eth0.out 1024
    # This is a test scenario - we're throttling all replies
    # from our webserver to max 16kbits/sec, but only if
    # the remote client is shell.sourceforge.net
    # note - the identifiers 'out', 'pri', 'rate', 'ceil' 'http' and 'test'
    # have special meaning (see pyshaper.conf.readme).
    # the identifier 'http' is not significant - you can replace
    # it with anything, as long as your setup is consistent
    # we're setting up a basic 'class' called 'http'
    eth0.http.pri 1
    eth0.http.out.rate 968
    eth0.http.out.ceil 1024
    eth0.http.test raddr=='66.35.250.208' and lport == 80
    eth0.p2p.test (cmd == '/usr/bin/valknut')
    eth0.p2p.test (cmd == '/usr/bin/ktorrent')
    eth0.p2p.pri 3
    # default traffic gets good bandwidth
    eth0.default.out.rate 932
    eth0.default.out.ceil 968

Maybe you are looking for