Tried to download version 4, which replaced old 3.6, but I'm getting a message that version 4 will not work with Mac OS 10 (I have OS 10.4.11). How can I download previous Firefox version?

Tried to download version 4, which replaced old 3.6, but I'm getting a message that version 4 will not work with Mac OS 10 (I have OS 10.4.11). How can I download previous Firefox version?

You can download firefox 3.6.16 here: http://www.mozilla.com/en-US/firefox/all-older.html

Similar Messages

Maybe you are looking for

  • Hi .. . ...... ..  about image management....

    Hi , I am working on a proyect in which I need to separate the background of the image, may I use JAI to realize this operation? Thk PD: I am new in Java Advanced Imaging and all about image management , after i only use java to development other thi

  • Has anyone opened a JPEG 2000 file with actionscript?

    I'm a newbie to flex, and actionscript and I'm on a project where we have to open a jpeg 2000 file.  We have no other file format options.  Has anyone been able to do this is flex/actionscript?  If so could you please provide me some code, or some gu

  • Trying to install itunes

    trying to install itunes and i keep getting error message: there is a promblem with windows installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor. I'm running windows vista

  • Filter 'Last 12 months' error

    Hello, I have udated my iPhoto but the filter 'Last 12 months' on the left seems to be corrupted. It displays some photos taken at the year of 2002,2003... I am using the french version of iPhoto and I have rebuild the database. Any idea ?

  • Asserting the RTS signal for serial ports

    I've posted a few times, about asserting the DTR signal line for the serial ports. To start off with, i have now come to the realization that I was STUPIDLY trying to set the wrong thing... I needed to set the RTS, not the DTR!!! Most of the replies