Virtualized bridge does not forward packets to other interfaces

I'm running OS X as a host with VirtualBox. In VirtualBox I set up an Arch VM with these interfaces:
- enp0s3, which is a plain NAT adapter for internet connectivity.
- enp0s8, which is an internal network made by VBox. Connects to some other VMs.
- enp0s9, which is a host-only adapter connected to OS X.
- 9net, which is tinc connected to a remote network over enp0s3
I can establish connections from any of enp0s8, enp0s9, and 9net to the bridge itself (172.31.2.1),
but I cannot actually access hosts connected on other interfaces, which is the main point of the bridge.
Here are some outputs:
root@bridge# ifconfig
9net: flags=4419<UP,BROADCAST,RUNNING,PROMISC,MULTICAST> mtu 1500
inet6 fe80::cd3:17ff:fece:125 prefixlen 64 scopeid 0x20<link>
ether 0e:d3:17:ce:01:25 txqueuelen 500 (Ethernet)
RX packets 106 bytes 9626 (9.4 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 217 bytes 32956 (32.1 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
9net-bridge: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 172.31.2.1 netmask 255.255.0.0 broadcast 172.31.255.255
inet6 fe80::a00:27ff:feba:1c7d prefixlen 64 scopeid 0x20<link>
ether 08:00:27:ba:1c:7d txqueuelen 0 (Ethernet)
RX packets 268 bytes 34588 (33.7 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 28 bytes 2308 (2.2 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
enp0s3: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 10.0.2.15 netmask 255.255.255.0 broadcast 10.0.2.255
inet6 fe80::5a00:bac1:14b3:a86d prefixlen 64 scopeid 0x20<link>
ether 08:00:27:cf:85:27 txqueuelen 1000 (Ethernet)
RX packets 546 bytes 254262 (248.3 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 1429 bytes 1360430 (1.2 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
enp0s8: flags=4419<UP,BROADCAST,RUNNING,PROMISC,MULTICAST> mtu 1500
inet6 fe80::a00:27ff:fed2:59e prefixlen 64 scopeid 0x20<link>
ether 08:00:27:d2:05:9e txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 279 bytes 39854 (38.9 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
enp0s9: flags=4419<UP,BROADCAST,RUNNING,PROMISC,MULTICAST> mtu 1500
inet6 fe80::a00:27ff:feba:1c7d prefixlen 64 scopeid 0x20<link>
ether 08:00:27:ba:1c:7d txqueuelen 1000 (Ethernet)
RX packets 190 bytes 30844 (30.1 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 108 bytes 10454 (10.2 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10<host>
loop txqueuelen 0 (Local Loopback)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions
root@bridge# brctl show
bridge name bridge id STP enabled interfaces
9net-bridge 8000.080027ba1c7d no 9net
enp0s8
enp0s9

I'm not sure - I'm trying to script Bridge to hand off a file to PShop and run a script using the cross-DOM method. It opens the files, but I can't get it to run the script.
Still working on it - will try messaging method next, I guess.
The samples aren't there, so I'm running blind, a bit.
rickb

Similar Messages

  • ME3600 does not forward frames out one interface in service instance

    Hi,
    I have an issue with ME3600 running 15.3(1)S. I have a BDI used for CPE
    management.
    cisco ME-3600X-24FS-M
    Cisco IOS Software, ME360x Software (ME360x-UNIVERSALK9-M), Version
    15.3(1)S, RELEASE SOFTWARE (fc1)
    This is the BDI and VRF configuration:
    interface Vlan1620
    ip vrf forwarding 65000:1620
    ip address 10.232.28.1 255.255.252.0
    no ip redirects
    ip vrf 65000:1620
    rd 65000:1620
    route-target export 65000:1620
    route-target import 65000:1620
    address-family ipv4 vrf 65000:1620
    redistribute connected
    The MPLS part is working fine, no issues there. There is also a DHCP
    pool handing out IPs to the CPEs.
    ip dhcp pool 65000:1620
    vrf 65000:1620
    network 10.232.28.0 255.255.252.0
    domain-name xyz
    default-router 10.232.28.1
    option 66 ascii 10.232.28.1
    dns-server 8.8.8.8
    lease 0 0 30
    This also works fine and I have verified that CPE has both IP and GW.
    Then for the service instance configuration:
    interface GigabitEthernet0/5
    switchport trunk allowed vlan none
    switchport mode trunk
    service instance 1620 ethernet
    encapsulation dot1q 1620
    rewrite ingress tag pop 1 symmetric
    bridge-domain 1620
    interface GigabitEthernet0/11
    switchport trunk allowed vlan none
    switchport mode trunk
    service instance 1620 ethernet
    encapsulation dot1q 1620
    rewrite ingress tag pop 1 symmetric
    bridge-domain 1620
    Traffic to CPEs behind Gi0/11 works:
    sh ip arp vrf 65000:1620 vlan 1620 | i 29.26
    Internet 10.232.29.26 0 0022.07f3.3450 ARPA Vlan1620
    show mac-address-table address 0022.07f3.3450
    Mac Address Table
    Vlan Mac Address Type Ports
    1620 0022.07f3.3450 DYNAMIC Gi0/11+Efp1620
    Total Mac Addresses for this criterion: 1
    Pinging 10.232.29.26 with 32 bytes of data:
    Reply from 10.232.29.26: bytes=32 time=33ms TTL=61
    Reply from 10.232.29.26: bytes=32 time=32ms TTL=61
    Reply from 10.232.29.26: bytes=32 time=34ms TTL=61
    Reply from 10.232.29.26: bytes=32 time=32ms TTL=61
    Traffic to CPEs behind Gi0/5 does not work.
    sh ip arp vrf 65000:1620 vlan 1620 | i 28.190
    Internet 10.232.28.190 2 0022.07f2.76a6 ARPA Vlan1620
    show mac-address-table address 0022.07f2.76a6
    Mac Address Table
    Vlan Mac Address Type Ports
    1620 0022.07f2.76a6 DYNAMIC Gi0/5+Efp1620
    Total Mac Addresses for this criterion: 1
    Pinging 10.232.28.190 with 32 bytes of data:
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.
    This is also confirmed by looking at counters. There seems to be no
    egress traffic on Gi0/5.
    Service Instance 1620, Interface GigabitEthernet0/11
    Pkts In Bytes In Pkts Out Bytes Out
    31717 2955368 4569808 1709207624
    Service Instance 1620, Interface GigabitEthernet0/5
    Pkts In Bytes In Pkts Out Bytes Out
    4850878 367975447 0 0
    It does work to ping locally from the 3600 though:
    ping vrf 65000:1620 10.232.28.190
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.232.28.190, timeout is 2 seconds:
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
    I'm not sure how to troubleshoot it further. I've also tried setting up
    ERSPAN sessions for RX traffic on Gi0/5 but I don't get anything in
    unless I ping 28.1 which is the IP of the interface on the 3600.
    Any clues?
    Daniel Dib
    CCIE #37149
    Please rate helpful posts.       

    It could not have been caused by a virus, since there are no viruses for Mac OS X. I would guess it was a typo when you first setup the account, and when you set it up again, a user may have gone to Preferences and selected the Outgoing mail server drop down menu and inadvertently selected the typo'd server entry.
    Mulder

  • JDBC-ODBC Bridge does not support Unicode UTF-16

    Hi
    I'm using Jdeveloper 10.0.3 IDE in order to develop an application for data transformation between MS Access 2003 (source) and Oracle 10g (destination). Clients use Windows XP.
    JDBC-ODBC Bridge still does not support Unicode UTF-16 which is the Charest used by MS Access 2000/2003.
    Note that when I changed locale in regional setting, destination Connection to Ora10g failed to open a connection, it works only with English locale, so I can't change my locale information.
    How can I read Unicode from source DB?
    Any help would be appreciated. I look forward to see your response.
    Thanks,

    i also heared that JDBC-ODBC Bridge still does not support Unicode UTF-16,
    but i guess this is not in my case.That's the key in fact. JDBC-ODBC Bridge does not support UTF-16, which is the charset used by MS Access 2000/2003.
    or do i need to use a third party driver for jdbc odbc bridge?Free library at http://jackcess.sourceforge.net/
    Commerical JDBC driver at http://www.hxtt.com/access.html
    Yonghong Zhao
    System Analyst
    www.hxtt.com

  • Bridge Does Not Automatically Bring Up Photoshop When the Photo is Double-Clicked

    I have just purchased CS4 with Bridge for my new MacIntosh.  In Bridge for the PC, when I double click a photo it automatically brings up Photoshop.  On the Mac version, it gives me an error message saying that part of the application is not loaded.  I completely uninstalled the program, and reloaded the application and still get the same message.  So in Bridge on the Mac, to get around this, I right click the picture and go to "Open With" and there are two entries:  "Open with CS4 (default)" and "Open with CS4."  This works if I pick either option.  My Windows version only has "Open with CS4 (default)" as the option.
    I called Adobe support (in India?) with no solution.
    I really like the double click option rather that using the pop-out menu choice.  What is wrong with the Mac install, and how can I fix this issue?

    Thank you for your help.  I updated the software and it "healed" itself.
    Best regards,
    Gregory T. Stramat
    [email protected]
    801-978-4735 (Office - Preferred)
    801-652-0775 (Mobile)
    Omke Oudeman <[email protected]>
    01/22/2010 12:52 AM
    Please respond to
    [email protected]
    To
    Gregory Stramat <[email protected]>
    cc
    Subject
    Bridge Does Not Automatically Bring Up Photoshop When
    the Photo is Double-Clicked
    This might mean that you have either 2 installs of CS4 (one on an other
    disk?) or you did not use the the default application folder on root level
    but have it installed in the user account application folder. Could you
    check this?
    and go to "Open With" and there are two entries:

  • Adobe Lightroom, Photoshop and Bridge does not recognize the raw files from my Canon Mark III 5D Camera.

    Adobe Lightroom, Photoshop and Bridge does not recognize the raw files from my new Canon Mark III 5D Camera.  How can I get my files open to view and edit?  I am using LR3, Photoshop CS3 and Bridge CS3.  Do I need to upgrade these programs or is there another way to get these programs to recognize my files?
    When I try opening the raw images in Lightroom, the thumbnails say "Preview unavailable for this file"  ... when I click "import" an error message pops up that says "The files are from a camera which is not recognized by the raw format support in Lightroom."
    When I try opening the raw images in Photoshop, an error message pops up saying "could not complete your request because photoshop does not recognize this type of file."
    When I try opening the raw images in Bridge, it just shows an icon with the file name and CR2.
    Please help!!!

    Unless I missed an announcement, today, LR6 isn't available, yet, right?  Only Adobe employees and beta testers would know what LR6 does differently at this point and they're all sworn to secrecy.
    LR5 is available as a standalone version.
    PS-CS6 is available as a serial-number-licensed version.
    PS-CC + LR5 are also available as a Photography Plan subscription for $10/month with a minimum OS versions of OSX 10.7 (and probably 10.8, soon) and Windows 7.
    Bridge is part of PS, not a separate program.
    LR5 standalone and LR+PS-CC plan are both available on this page:  http://www.adobe.com/products/catalog/software.html
    PS-CS6 can be found on this page:  Creative Suite 6 which can be found by searching www.adobe.com for Photoshop CS6 and clicking the Buy link in the on-the-fly search results.
    As with any new Adobe software, it might be wise to run it in trial mode for a few days/weeks to see if it works well with your computer, before purchasing and finding out you might need a new computer, first.

  • Adobe Bridge does not accept the NEF files from my new Nikon D800. I use the latest version, there a

    Adobe Bridge does not accept the NEF files from my new Nikon D800. I use the latest version, there are no updates

    Hi,
    CS6
    Van: R_Kelly [email protected]
    Verzonden: maandag 16 september 2013 18:42
    Aan: Hans van Sloten
    Onderwerp: Adobe Bridge does not accept the NEF files from my new Nikon D800. I use the latest version, there a
    Re: Adobe Bridge does not accept the NEF files from my new Nikon D800. I use the latest version, there a
    created by R_Kelly <http://forums.adobe.com/people/R_Kelly>  in Photoshop for Beginners - View the full discussion <http://forums.adobe.com/message/5686078#5686078

  • I am running a TRIAL VERSION of Adobe Photoshop CS6 Extended and Bridge does not open.  Help?

    I am running a TRIAL VERSION of Adobe Photoshop CS6 Extended on MAC and Bridge does not open.  It did open when I first downloaded it - but now a black question mark is over the BR icon and it does not open up.  Any ideas from anyone? 

    Hi Steve -
    I just thought it was interesting and helpful to me to learn that the icon for Bridge does not appear anywhere.  Not in Application Folder.  Not in the Finders Directory Files.  I see your point - if I could locate that icon - I'd be set by dragging it onto my DOCK and launching it from there. 
    So - I'm assuming I need to uninstall CS6.   Please list all the steps for me to uninstall so that I don't miss any CS6 files. 
    When I search in FINDER for CS6 uninstall- I see two icons -  red adobe "UNINSTALL ADOBE PHOTOSHOP CS6" (both files are identical)  Under KIND they both say Alias - with two different dates they were last opened (in November - few minutes apart).  Is that what I use to uninstall completely all the files related to PS CS6 Extended as well as Bridge? 
    Do I need to DEACTIVATE ANYTHING ANYWHERE? 
    DOES ANYTHING NEED TO GO INTO TRASH. 
    I just want to make sure 'everything' related to CS6 Extended is off my computer and out of all the files.  In the event i want to re-install - naturally I don't want to run into any conflicting 'issues'.
    Do you think if I reinstall I will run into this same problem again (BR not launching)?  Is there anything I can do to prevent it?  I note on the forums - going a few years back - that there have been a lot of issues related to this same problem - even in other versions of the Creative Suite.  Is Adobe doing anything to rectify this problem for us Photoshop CS Suite lovers or is all their focus just going into CC? 
    Thank you so much for trying to help me resolve this issue.  It is very frustrating to have an Adobe product that is not completely functional.  Especially when the Creative Suites are so expensive.  I appreciate all the time you've put into this issue. 
    Carole

  • Mini Bridge does not open in InDesign after installing 8.0.2 upgrade

    This question was previously posted in the InDesign forum (http://forums.adobe.com/message/5833991#5833991), but it was suggested that I should cross post it here.
    I installed InDesign CS6 upgrade 8.0.2.  Now I cannot open Mini Bridge.
    If Bridge is not already open,
         - selecting File | Browse in Bridge...  or clicking on the Bridge button: Bridge opens - good!
         - control-click on the Bridge button: I get a Reset Settings error dialog - NOT good!  I cancelled this and Bridge opened fullscreen okay.
         - alt-click on the Bridge button: Two Bridge applications opened fullscreen! - NOT good!
         - shift-click on the Bridge button: Bridge opens, but Mini Bridge does not! - NOT good!
    If Bridge is already open,
         - selecting File | Browse in Bridge... or clicking on the Bridge button: the ruler bars dim and nothing else happens! - NOT good!
         - control-click on the Bridge button: Bridge opens maximized! - good!
         - alt-click on the Bridge button: the already opened Bridge, plus a new Bridge, both open! - is this normal?
         - shift-click on the Bridge button: the ruler bars dim and Mini Bridge does not open! - NOT good!
    I have tried resetting the preferences in Bridge and rebooted after doing so.
    My main concern is that I cannot get Mini Bridge to open at all.  I can ignore the other problems mentioned above, if I can just get Mini Bridge to open.
    This problem does not exist in Photoshop CS6.
    I have restored my C: drive from backup twice and tried the upgrade a total of three times.  The results are the same each time.
    Does anyone have any idea what is causing my problem and how I might correct it?  I am running 64-bit Windows 7 Professional SP1, 3.40 GHz Intel Core i7-3770 CPU, 32.0 GB installed memory.

    Sorry to hear that, forgot to mention the resetting of preferences in InDesign.
    Have you also tried that (ctrlAltShift while starting ID)?
    I'm afraid I have not really more ideas and I am a Mac user and don't know anything relevant about Windows.
    And ultimate you have of course the option to reinstall CS6 after an official uninstall in combination with the Adobe Clean Tool. But before doing so read all instructions and have a proper back up of all relevant customized settings, workspaces etc.
    http://helpx.adobe.com/creative-suite/kb/cs5-cleaner-tool-installation-problems.html

  • Bridge CS6 bug: closing Bridge does NOT end process

    Bridge does NOT started at boot. 
    Windows 7 -64 (all current updates). 
    Photoshop CS6 13.0 extended
    Bridge 5.0.0 399x64
    After closing Bridge by clicking on the Close X or file/exit, the process 'bridge.exe' does not terminate and therefore thereafter trying to restart bridge fails. 
    Have to open up Task Manager, kill the bridge.exe process, in order to restart bridge.
    The bug is so variable that just when it appears repeatable, something changes.
    Any idea of what to look for?

    This is NOT TRUE.  "FYI:  In Windows, to exit a program/application, clicking the Close button in the upper-right corner of the program window is the same as using the File menu, and click Exit."
    If you click the red X you close the window and force close of the program.  Any changes you made to program will not be saved if you have the option "start Bridge at login" checked.   If you click File>Exit the program will go through the procedure to normally close down, and any changes you made will be saved. 
    I tried to follow your steps but was confused on steps 3,4,5,8,10.
    I used 1,2,3,7,9,11.  Bridge was closed.  Perhaps with all your "browse to bridge you are opening multiple copies?
    Hey, how about trying and commenting on my problem with the Find function in CS6?  http://forums.adobe.com/thread/1007726?tstart=0

  • A word document was emailed to me.  I can open the document without a problem.  Is there a way for me to type on the document.... to fill out the form?  When I click the fields, the virtual keyboard does not appear.

    A word document was emailed to me.  I can open the document without a problem on my iPad 2.   Is there a way for me to type on the document.... to fill out the form?  When I click the fields, the virtual keyboard does not appear.

    If you want to edit a word document then you will need an app on your iPad that supports word so that you can copy them to it via 'open in' e.g. Apple's Pages app or a third-party app such as Documents To Go or QuickOffice HD

  • I am having problems opening images renerated in lightroom5 into cs6. Cs6 bridge does not see the lightroom libarary. If I open lightroom and right clik the image, edit in cs6, 6 opens but the picture doesnot follow. What is going on? Give me a hand.

    I am having problems opening images renerated in lightroom5 into cs6. Cs6 bridge does not see the lightroom libarary. If I open lightroom and right clik the image, edit in cs6, 6 opens but the picture doesnot follow. What is going on? Give me a hand, thanks.

    What edition of LR 5? What edition of ACR does PSCS 6 contain. If they are not parallel (same edition number x in [5 or 8].x ), is LR making a tiff or psd rendition of the image?

  • Bridge does not save adjustments in camera raw when I press done

    bridge does not save adjustments in camera raw when I press done

    baines0788,
    Next time, please be precise when asked for details.
    Please read this FAQ for advice on how to ask your questions correctly for quicker and better answers: 
    http://forums.adobe.com/thread/419981?tstart=0
    Thanks!

  • Bridge does not see both external hard drives

    In either CS3 or CS4, Bridge does not recognize my second external hard drive. Photoshop and lightroom see both drives. I am using a laptop and Windows xp.
    Thanks,
    mIKE

    Those directories are modified in the User Preferences tab in the Setup Room.
    When you've got the file tree dialogue box open, you'll need to point Color to the "Volumes" level, once there, you should see your external drive.

  • BRIDGE does not show every PNG with preview

    Hello there,
    my CS4-BRIGDE doesn't show my PNGs with a preview thumbnail.
    I use to export them from Illustrator files but even if I open them in Fireworks or Photoshop to save them again, there is no preview on my PNGs. The explorer preview shows all PNGs only Bridge does not!
    I have some PNG from an unknown source (too long ago to remember) which do have a preview!
    Can anyone please! help?
    greg

    For a quicker response, I reccommend that you post your query on the Bridge forum: http://forums.adobe.com/community/bridge

  • Bridge does not open files. dialog: libmmd.dll missing

    bridge does not open files. dialog: "libmmd.dll missing, reinstall bridge."
    Yet I cannot redownload bridge because when I open creative cloud I see bridge as up to date. How can I redownload installed programs?

    How can I redownload installed programs?
    https://creative.adobe.com/products

Maybe you are looking for

  • Attaching Document in Billing

    Hi gurus, I have a requirement where in currently the invoice document gets converted in pdf and sent as mail.But now i have requirement wherein apart from invoice any other document attached in billing document which is done via going in system-->se

  • Sun-web-app_2_5-0.dtd

    after deploying an application this is the error. any solution or links? warning ( 1644): WEB9200: sun-web.xml DTD Version with public ID = [-//Sun Microsystems, Inc.//DTD Application Server 8.0 Servlet 2.4//EN] and system ID = [http://www.sun.com/so

  • Secure Fields in Oracle 11G

    Version 11.2.0.1 CREATE TABLE test1 ( a number , b clob TABLESPACE TS001 LOB (b) STORE AS SECUREFILE; works fine CLOBS can be set up as securefiles CREATE TABLE test1 ( a number , b bfile TABLESPACE TS001 works fine However: CREATE TABLE test1 ( a nu

  • Can't Edit Valid CSS/HTML page with DW

    I have a page that contains valid HTML and CSS but it is VERY hard to edit with DW-CS3. The formatting in design view looks nothing like the page when displayed in a browser. I can always edit the code directly via the code view but I have users that

  • Western Digital Thunderbolt Duo 8 TB !!!

    I'm not sure if this is the right communities to ask but there go... Just bought a Western Digital ThunderBolt Duo 8TB , the problem is...i cant seems to connect it to 2 mac book pro at the same time. Contacted WD support, they told me it's not possi