What is the wrong with this small code of groupitems

var msg =""
if(app.documents.length > 0)
var pgItems = app.activeDocument.pageItems;
tot_obj=pgItems.length ;
if( pgItems.length > 0 )
  var GroupItem =app.activeDocument.groupItems;
  total_Group = GroupItem.length;
   for(var a = 0;a<total_Group;a++)
    GroupItem[a].hidden=true;

Use this code :
app.activeDocument.groupItems[a].hidden=true;

Similar Messages

  • What's wrong with this small code?

    hi, there,
    I tried to compile the following code and get the error like:
    Can't make static reference to non-static reference in line System.out.println(msg);
    It is wired to me. Could somebody give a hint? Really appreciate!!!
    Jianmin
    import java.awt.*;
    import java.awt.event.*;
    public class fram extends Frame
    String msg="hello";
    public static void main(String arg[])
    fram f=new fram();
    Button b=new Button("Click");
    b.addActionListener( new ActionListener() {
    public void actionPerformed(ActionEvent e) {
    System.out.println(msg);
    f.add(b);
    f.pack();
    f.show();

    Thanks a lot!!! it works.
    msg is non-static, that is 'instance' variable,
    and you can not acces it from static context. Simply
    speaking you have to use b.msg, will not work
    eather though

  • What's the problem with this Ajax code?

    The B.cfm:
    <cfimport taglib="/tags" prefix="Tag">
    <Tag:_ImportprocessingTime>
    <!--- This tag show the time spended--->
    do some long loop......
    <!--- this only needs about 5 seconds--->
    </Tag:_ImportprocessingTime>
    the ajax code to execute the b.cfm:
    function Importxls(url,buttonid,msgid,dbffilename)
    createXMLHttpRequest();
    var url=url+"?importdbffilename="+dbffilename+"&ti="+new
    Date().getTime();
    xmlHttp.open("GET",url,true);
    xmlHttp.onreadystatechange= function()
    if (xmlHttp.readyState < 4)
    document.getElementById(msgid).innerHTML= "importing......";
    document.getElementById(buttonid).disabled=true;
    else if (xmlHttp.readyState == 4)
    if(xmlHttp.status == 200)
    document.getElementById(msgid).innerHTML=xmlHttp.responseText;
    document.getElementById(buttonid).disabled=false;
    else if (xmlHttp.status == 404)
    document.getElementById(msgid).innerHTML="URL error";
    document.getElementById(buttonid).disabled=false;
    else
    document.getElementById(msgid).innerHTML="error,xmlHttp
    state:"+xmlHttp.status+"。";
    document.getElementById(buttonid).disabled=false;
    xmlHttp.send(null);
    when I execute the b.cfm ,the spended time only about
    5 seconds and show the result right now.
    but when I execute the b.cfm through the ajax
    code,after about 60 seconds,it shows the result,why?and how
    to let it show the result after the b.cfm executed?
    Thanks a lot.

    up

  • What is the problem with this simple code?

    import javax.swing.*;
    public class TestThread extends JApplet implements Runnable
    JPanel jp;
    JLabel jb;
    public void init()
    jp=new JPanel();
    jb=new JLabel("Botton");
    getContentPane().add(jp);
    jp.add(jb);
    public static void main(String args[])
    new TestThread().start();
    public void run()
    System.out.println("Jaison");
    Y it not working...help me
    contd............
    <html>
    <head>
    </head>
    <applet
    code=TestThread.class
    width=1450
    height=1680>
    </applet>
    </html>

    Status bar says
    Applet TestThread StartedYou do know that main isn't used by applets? It will not be executed by the browser.
    Kaj

  • What is the wrong with my select query

    HI All,
    TYPES: BEGIN OF t_equi,
             equnr          TYPE equi-equnr,
             aedat          TYPE equi-aedat,
             matnr          TYPE equi-matnr,
             sernr          TYPE equi-sernr,
             kunde          TYPE equi-kunde,
             zzreg_date     TYPE equi-zzreg_date,
             zzin_indic     TYPE equi-zzin_indic,
             zzinvoice_num  TYPE equi-zzinvoice_num,
             zzinvoice_date TYPE equi-zzinvoice_date,
             kund1          TYPE equz-kund1,
          END OF t_equi,
    DATA: it_equi        TYPE TABLE OF t_equi,
      SELECT equnr
             aedat
             matnr
             sernr
             kunde          "Ship to
             zzreg_date
             zzin_indic
             zzinvoice_num
             zzinvoice_date
             kund1            "Sold to
             INTO TABLE it_equi
             FROM equi AS a
             INNER JOIN equz AS b
             ON a~equnr = b~equnr
             WHERE a~equnr      IN s_equnr AND
    *               aedat GE gv_rdate AND
                   a~matnr      IN s_matnr AND
                   a~sernr      IN s_sernr AND
                   a~kunde      IN r_shpbr_kunde AND
                   a~zzin_indic IN s_indic  AND
                   b~datbi      EQ c_datbi  AND 
                   b~kund1     IN r_sldbr_kund1 .
    what is the wrong with this select query.. ?
    its giving me error  "The column name "EQUNR" is unclear ."
    Thanks

    Hi ,
    write  tablename or alias in select also
    SELECT a~equnr and check.
    Regards

  • What's wrong with this simple code?

    What's wrong with this simple code? Complier points out that
    1. a '{' is expected at line6;
    2. Statement expected at the line which PI is declared;
    3. Type expected at "System.out.println("Demostrating PI");"
    However, I can't figure out them. Please help. Thanks.
    Here is the code:
    import java.util.*;
    public class DebugTwo3
    // This class demonstrates some math methods
    public static void main(String args[])
              public static final double PI = 3.14159;
              double radius = 2.00;
              double area;
              double roundArea;
              System.out.println("Demonstrating PI");
              area = PI * radius * radius;
              System.out.println("area is " + area);
              roundArea = Math.round(area);
              System.out.println("Rounded area is " + roundArea);

    Change your code to this:
    import java.util.*;
    public class DebugTwo3
         public static final double PI = 3.14159;
         public static void main(String args[])
              double radius = 2.00;
              double area;
              double roundArea;
              System.out.println("Demonstrating PI");
              area = PI * radius * radius;
              System.out.println("area is " + area);
              roundArea = Math.round(area);
              System.out.println("Rounded area is " + roundArea);
    Klint

  • Please tell me what is the problem with this code

    Hai,
    Iam new to Swings. can any one tell what is the problem with this code. I cant see those controls on the frame. please give me the suggestions.
    I got the frame ,but the controls are not.
    this is the code:
    import javax.swing.*;
    import java.awt.*;
    import java.awt.event.*;
    public class ex2 extends JFrame
    JButton b1;
    JLabel l1,l2;
    JPanel p1,p2;
    JTextField tf1;
    JPasswordField tf2;
    public ex2()
    setDefaultCloseOperation(EXIT_ON_CLOSE);
    setTitle("Another example");
    setSize(500,500);
    setVisible(true);
    b1=new JButton(" ok ");
    p1=new JPanel();
    p1.setLayout(new GridLayout(2,2));
    p2=new JPanel();
    p2.setLayout(new BorderLayout());
    l1=new JLabel("Name :");
    l2=new JLabel("Password:");
    tf1=new JTextField(15);
    tf2=new JPasswordField(15);
    Container con=getContentPane();
    con.add(p1);
    con.add(p2);
    public static void createAndShowGUI()
    ex2.setDefaultLookAndFeelDecorated(true);
    public static void main(String ar[])
    createAndShowGUI();
    new ex2();
    }

    import javax.swing.*;
    import java.awt.*;
    import java.awt.event.*;
    public class ex2 extends JFrame
        JButton b1;
        JLabel l1,l2;
        JPanel p1,p2;
        JTextField tf1;
        JPasswordField tf2;
        public ex2()
            setDefaultCloseOperation(EXIT_ON_CLOSE);
            setTitle("Another example");
            b1=new JButton(" ok ");
            p1=new JPanel();
            p1.add(b1);
            p2=new JPanel();
            p2.setLayout(new GridLayout(2,2));
            l1=new JLabel("Name :");
            l2=new JLabel("Password:");
            tf1=new JTextField(15);
            tf2=new JPasswordField(15);
            p2.add(l1);
            p2.add(tf1);
            p2.add(l2);
            p2.add(tf2);
            Container con=getContentPane();
            con.add(p1, BorderLayout.NORTH);
            con.add(p2, BorderLayout.CENTER);
            pack();
            setVisible(true);
        public static void createAndShowGUI()
            ex2.setDefaultLookAndFeelDecorated(true);
        public static void main(String ar[])
            createAndShowGUI();
            new ex2();
    }

  • Vector, what is the problem with this code?

    Vector, what is the problem with this code?
    63  private java.util.Vector data=new Vector();
    64  Vector aaaaa=new Vector();
    65   data.addElement(aaaaa);
    74  aaaaa.addElement(new String("Mary"));on compiling this code, the error is
    TableDemo.java:65: <identifier> expected
                    data.addElement(aaaaa);
                                   ^
    TableDemo.java:74: <identifier> expected
                    aaaaa.addElement(new String("Mary"));
                                    ^
    TableDemo.java:65: package data does not exist
                    data.addElement(aaaaa);
                        ^
    TableDemo.java:74: package aaaaa does not exist
                    aaaaa.addElement(new String("Mary"));Friends i really got fed up with this code for more than half an hour.could anybody spot the problem?

    I can see many:
    1. i assume your code snip is inside a method. a local variable can not be declare private.
    2. if you didn't import java.util.* on top then you need to prefix package on All occurance of Vector.
    3. String in java are constant and has literal syntax. "Mary" is sufficient in most of the time, unless you purposly want to call new String("Mary") on purpose. Read java.lang.String javadoc.
    Here is a sample that would compile...:
    public class QuickMain {
         public static void main(String[] args) {
              java.util.Vector data=new java.util.Vector();
              java.util.Vector aaaaa=new java.util.Vector();
              data.addElement(aaaaa);
              aaaaa.addElement(new String("Mary"));
    }

  • What is going wrong with this config ??

    Hello guys,
    I am busting my head to find out what is going wrong with this config and cant figure it out since i am not an advanced cisco technician.
    Problem is that i cant access the 94.70.142.127 server that is supposed to be in a DMZ zone.
    I know it is a bit chaotic but would really appreciate any help since i am running on a deadline.
    I am building the config step by step and although it seems to be working access to the server all of the sudden is denied.
    No idea if its a NAT issue a firewall issue or a security audit issue.
    There are 3 vlans.
    Vlan 1 is the inside network.
    Vlan 2 is the DMZ server
    Vlan 3 is the Management Network.
    thanks in advance
    Building configuration...
    Current configuration : 11796 bytes
    ! Last configuration change at 11:28:33 PCTime Fri Jan 4 2013 by admin
    ! NVRAM config last updated at 11:27:51 PCTime Fri Jan 4 2013 by admin
    version 12.4
    no service pad
    service tcp-keepalives-in
    service tcp-keepalives-out
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime msec localtime
    service password-encryption
    service sequence-numbers
    hostname R1
    boot-start-marker
    boot-end-marker
    security authentication failure rate 3 log
    security passwords min-length 8
    logging message-counter syslog
    logging buffered 4096 informational
    enable secret 5 $1$oT7y$BwhdEjMJfAaTQI3dzDVwP.
    no aaa new-model
    memory-size iomem 10
    clock timezone PCTime 2
    clock summer-time PCTime date Mar 30 2003 3:00 Oct 26 2003 4:00
    crypto pki trustpoint TP-self-signed-2567543707
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-2567543707
    revocation-check none
    rsakeypair TP-self-signed-2567543707
    crypto pki certificate chain TP-self-signed-2567543707
    certificate self-signed 01
      30820244 308201AD A0030201 02020101 300D0609 2A864886 F70D0101 04050030
      31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
      69666963 6174652D 32353637 35343337 3037301E 170D3133 30313032 30383431
      35335A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
      4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 35363735
      34333730 3730819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
      8100ABA4 B7FFF4F1 9FBE79D8 2CEBCA68 A14BE3AB DBF770C2 EB35A954 B271AE3E
      F8485837 F2E8566B 66E5EF6B BCFCDFA3 8F6F91F3 FD8E3015 879A67F5 85DD95F5
      C26875C0 2202CA6C CE95888F 545AB4F6 6F708A0E C65E78D1 60967480 5589F5EE
      80505E46 8767CE2C 37C994FE AB555AF0 BA4C4679 63FF7641 34FFF6EF 3EC38006
      46B90203 010001A3 6C306A30 0F060355 1D130101 FF040530 030101FF 30170603
      551D1104 10300E82 0C52312E 646F636E 65742E67 72301F06 03551D23 04183016
      8014F0DE 85318FB3 70C36B4A FEB4B0CA 446025F0 329C301D 0603551D 0E041604
      14F0DE85 318FB370 C36B4AFE B4B0CA44 6025F032 9C300D06 092A8648 86F70D01
      01040500 03818100 5D76D5F4 5FB659C3 1E5B3777 420E1703 CD019889 AE79390D
      A2AA4D26 AD9913B4 B3292277 97ACACDD D7093465 78279B4D 5FAC0A21 EFBF3B74
      6A25BC5B ACFB648F 08F92678 00BB495C 037DEAF7 C5910944 3D2C0643 EA19E9BD
      0AFE5423 AADBB3C2 B2C94296 DABE0D3D 6438F7A8 32B0A92B 3E8E0D26 635070A3
      ACF87E49 65A9E468
          quit
    no ip source-route
    ip cef
    no ip bootp server
    ip domain name docnet.gr
    ip name-server 195.170.0.1
    no ipv6 cef
    username admin privilege 15 view root secret 5 $1$Lny5$et1FhWOpIKOOYRUtN89H10
    archive
    log config
      hidekeys
    ip tcp synwait-time 10
    ip ssh version 2
    class-map type inspect match-any WebService
    match protocol http
    match protocol https
    class-map type inspect match-all sdm-cls-sdm-pol-NATOutsideToInside-1-1
    match class-map WebService
    match access-group name WebServer
    class-map type inspect match-all ccp-cls-sdm-pol-NATOutsideToInside-1-1
    match access-group name Spoofing
    class-map type inspect match-any CCP-Voice-permit
    match protocol h323
    match protocol skinny
    match protocol sip
    class-map type inspect match-any tcp-udp
    match protocol http
    match protocol https
    match protocol dns
    match protocol icmp
    class-map type inspect match-all ccp-cls--3
    match access-group name mng-out
    match class-map tcp-udp
    class-map type inspect match-all ccp-cls--2
    match access-group name mng-self
    class-map type inspect match-all ccp-cls--4
    match access-group name mng-out-drop
    class-map type inspect match-any ccp-cls-insp-traffic
    match protocol cuseeme
    match protocol dns
    match protocol ftp
    match protocol h323
    match protocol https
    match protocol icmp
    match protocol imap
    match protocol pop3
    match protocol netshow
    match protocol shell
    match protocol realmedia
    match protocol rtsp
    match protocol smtp extended
    match protocol sql-net
    match protocol streamworks
    match protocol tftp
    match protocol vdolive
    match protocol tcp
    match protocol udp
    class-map type inspect match-all ccp-insp-traffic
    match class-map ccp-cls-insp-traffic
    class-map type inspect match-any http-https-DMZ
    match protocol http
    match protocol https
    class-map type inspect match-all sdm-cls--2
    match class-map http-https-DMZ
    match access-group name web_server
    class-map type inspect match-any MySQLService
    match protocol mysql
    class-map type inspect match-all sdm-cls--1
    match class-map MySQLService
    match access-group name DMZtoMySQL
    class-map type inspect match-any ccp-cls-icmp-access
    match protocol icmp
    match protocol tcp
    match protocol udp
    class-map type inspect match-all ccp-icmp-access
    match class-map ccp-cls-icmp-access
    class-map type inspect match-all ccp-invalid-src
    match access-group 100
    class-map type inspect match-all sdm-nat-https-1
    match access-group 102
    match protocol https
    class-map type inspect match-all ccp-protocol-http
    match protocol http
    policy-map type inspect ccp-permit-icmpreply
    class type inspect ccp-icmp-access
      inspect
    class class-default
      pass
    policy-map type inspect sdm-pol-NATOutsideToInside-1
    class type inspect ccp-cls-sdm-pol-NATOutsideToInside-1-1
      drop
    class type inspect sdm-cls-sdm-pol-NATOutsideToInside-1-1
      inspect
    class type inspect sdm-nat-https-1
      inspect
    class class-default
      drop
    policy-map type inspect ccp-inspect
    class type inspect ccp-invalid-src
      drop log
    class type inspect ccp-protocol-http
      inspect
    class type inspect ccp-insp-traffic
      inspect
    class type inspect CCP-Voice-permit
      inspect
    class class-default
      drop
    policy-map type inspect ccp-permit
    class class-default
      drop
    policy-map type inspect sdm-policy-sdm-cls--1
    class type inspect sdm-cls--1
      inspect
    class class-default
      drop
    policy-map type inspect ccp-policy-ccp-cls--1
    class class-default
      drop
    policy-map type inspect ccp-policy-ccp-cls--3
    class type inspect ccp-cls--3
      inspect
    class class-default
      drop
    policy-map type inspect sdm-policy-sdm-cls--2
    class type inspect sdm-cls--2
      inspect
    class class-default
      drop
    policy-map type inspect ccp-policy-ccp-cls--2
    class type inspect ccp-cls--2
      inspect
    class class-default
      drop
    policy-map type inspect ccp-policy-ccp-cls--5
    class class-default
      drop
    zone security out-zone
    zone security in-zone
    zone security dmz-zone
    zone security mng
    zone-pair security ccp-zp-self-out source self destination out-zone
    service-policy type inspect ccp-permit-icmpreply
    zone-pair security sdm-zp-NATOutsideToInside-1 source out-zone destination in-zone
    service-policy type inspect sdm-pol-NATOutsideToInside-1
    zone-pair security ccp-zp-in-out source in-zone destination out-zone
    service-policy type inspect ccp-inspect
    zone-pair security ccp-zp-out-self source out-zone destination self
    service-policy type inspect ccp-permit
    zone-pair security zp-dmz-to-outside source dmz-zone destination out-zone
    service-policy type inspect ccp-inspect
    zone-pair security zp-outside-to-dmz source out-zone destination dmz-zone
    service-policy type inspect sdm-pol-NATOutsideToInside-1
    zone-pair security sdm-zp-dmz-zone-in-zone source dmz-zone destination in-zone
    service-policy type inspect sdm-policy-sdm-cls--1
    zone-pair security sdm-zp-in-zone-dmz-zone source in-zone destination dmz-zone
    service-policy type inspect sdm-policy-sdm-cls--2
    zone-pair security sdm-zp-dmz-zone-self source dmz-zone destination self
    service-policy type inspect ccp-policy-ccp-cls--1
    zone-pair security sdm-zp-mng-self source mng destination self
    service-policy type inspect ccp-policy-ccp-cls--2
    zone-pair security sdm-zp-mng-out-zone source mng destination out-zone
    service-policy type inspect ccp-policy-ccp-cls--3
    zone-pair security sdm-zp-out-zone-mng source out-zone destination mng
    service-policy type inspect ccp-policy-ccp-cls--5
    interface Null0
    no ip unreachables
    interface BRI0
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    encapsulation hdlc
    shutdown
    isdn termination multidrop
    interface ATM0
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    no atm ilmi-keepalive
    interface ATM0.1 point-to-point
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    pvc 8/35
      pppoe-client dial-pool-number 1
    interface FastEthernet0
    interface FastEthernet1
    interface FastEthernet2
    switchport access vlan 3
    spanning-tree portfast
    interface FastEthernet3
    switchport access vlan 2
    interface Vlan1
    description $FW_INSIDE$
    ip address 192.168.0.1 255.255.255.0
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    ip nat inside
    ip virtual-reassembly
    zone-member security in-zone
    ip tcp adjust-mss 1412
    interface Vlan2
    description $FW_INSIDE$
    ip address 192.168.1.1 255.255.255.0
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    ip nat inside
    ip virtual-reassembly
    zone-member security dmz-zone
    interface Vlan3
    description $FW_INSIDE$
    ip address 10.0.10.1 255.255.255.0
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    ip nat inside
    ip virtual-reassembly
    zone-member security mng
    interface Dialer0
    description $FW_OUTSIDE$
    ip address negotiated
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip mtu 1452
    ip flow ingress
    ip nat outside
    ip virtual-reassembly max-reassemblies 64
    zone-member security out-zone
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication chap pap callin
    ppp chap hostname [email protected]
    ppp chap password 7 0918425001505245
    ppp pap sent-username [email protected] password 7 13511B4B1359417D
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 Dialer0
    ip route 10.0.10.0 255.255.255.0 Vlan3
    no ip http server
    ip http secure-server
    ip nat inside source list 1 interface Dialer0 overload
    ip nat inside source static 192.168.0.101 94.70.142.113
    ip nat inside source static 192.168.1.102 94.70.142.127
    ip access-list extended DMZtoMySQL
    remark CCP_ACL Category=128
    permit ip host 192.168.1.102 host 192.168.0.101
    ip access-list extended Spoofing
    remark CCP_ACL Category=128
    permit ip 10.0.0.0 0.255.255.255 any
    permit ip 192.168.0.0 0.0.255.255 any
    permit ip 172.16.0.0 0.15.255.255 any
    ip access-list extended VTY_incoming
    remark CCP_ACL Category=1
    permit ip host 10.0.10.2 any
    ip access-list extended WebServer
    remark CCP_ACL Category=128
    permit ip any host 192.168.1.102
    ip access-list extended mng-out
    remark CCP_ACL Category=128
    permit ip 10.0.10.0 0.0.0.255 any
    ip access-list extended mng-out-drop
    remark CCP_ACL Category=128
    permit ip any any
    ip access-list extended mng-self
    remark CCP_ACL Category=128
    permit ip any any
    ip access-list extended web_server
    remark CCP_ACL Category=128
    permit ip 192.168.0.0 0.0.0.255 host 192.168.1.102
    logging 10.0.10.2
    access-list 1 remark INSIDE_IF=Vlan1
    access-list 1 remark CCP_ACL Category=2
    access-list 1 remark VLan 1 Access
    access-list 1 permit 192.168.0.0 0.0.0.255
    access-list 1 remark VLan 3 Access
    access-list 1 permit 10.0.10.0 0.0.0.255
    access-list 1 remark Vlan 2 Access
    access-list 1 permit 192.168.1.0 0.0.0.255
    access-list 100 remark CCP_ACL Category=128
    access-list 100 permit ip host 255.255.255.255 any
    access-list 100 permit ip 127.0.0.0 0.255.255.255 any
    access-list 102 remark CCP_ACL Category=0
    access-list 102 permit ip any host 192.168.0.101
    dialer-list 1 protocol ip permit
    no cdp run
    control-plane
    banner login ^CWARNING!!!This is a highly monitored private system. Access is prohibited!!^C
    line con 0
    no modem enable
    line aux 0
    line vty 0 4
    access-class VTY_incoming in
    password 7 12292504011C5C162E
    login local
    transport input ssh
    scheduler max-task-time 5000
    ntp authentication-key 1 md5 10603D29214711255F106B2677 7
    ntp authenticate
    ntp trusted-key 1
    ntp master 2
    end

    Hello karolos,
    Here is the thing.
    You said you are trying to access 94.70.142.113 and that is a server on the DMZ but based in your configuration that is not true
    ip nat inside source static 192.168.0.101 94.70.142.113
    So 192.168.0.101 is on Vlan 1 witch is the in-zone
    interface Vlan1
    description $FW_INSIDE$
    ip address 192.168.0.1 255.255.255.0
    security in-zone
    If you got confused with  the security zone that the host is assigned to then just add the following and it should work
    ip access-list extended WebServer
    permit ip any host 192.168.0.101
    Regards

  • What is the problem with this Stored Procedure

    Hi ,
    What is the problem with this Stored Procedure ?Why is it giving errors ??
    CREATE or replace  PROCEDURE getEmpName
    *(EMP_FIRST OUT VARCHAR2(255))*
    BEGIN
    SELECT ename INTO EMP_FIRST
    FROM Emp
    WHERE EMPNO = 7369;
    END ;
    */*

    You don't specify precision in procedure arguments.
    (EMP_FIRST OUT VARCHAR2(255))should be
    (EMP_FIRST OUT VARCHAR2)Since you asked what's wrong with it, I could add that it needs formatting and the inconsistent use of upper and lower case is not helping readability.

  • What is the wrong in this PL/SQL  block

    Hi a...
    Can you please tell what is the wrong in this pl/sql block.
    declare
    TYPE TYP_NT_NUM IS TABLE OF NUMBER ;
    v_tab TYP_NT_NUM := TYP_NT_NUM();
    TYPE uname is VARRAY(30) of varchar2(100) ;
    usr uname := uname ( 'u1','u2','u3','u4' );
    TYPE pwd is VARRAY(30) of varchar2(100) ;
    psw pwd := pwd('p1','p2','p3','p4');
    x number(10):=0;
    Cursor fcid IS Select distinct FC_ID From FCMASTER ;
    Begin
    Open fcid ;
    --for ii in usr.first .. usr.last loop
         Loop
              Fetch fcid Into x ;
              Exit When fcid%NOTFOUND ;
              v_tab(fcid%ROWCOUNT) := x ;
         End loop ;
         For iii IN v_tab.FIRST .. v_tab.LAST Loop
              dbms_output.put_line(v_tab(iii).FC_ID) ;
              End loop ;
    End loop; End of outer loop
    End;
    The error is
    Error
    [row:28,col:36] ORA-06550: line 28, column 36:
    PLS-00487: Invalid reference to variable 'NUMBER'
    ORA-06550: line 28, column 4:
    PL/SQL: Statement ignored
    Thanks in advance,
    Pal

    v_tab(iii).FC_ID
    declare
      type typ_nt_num is table of number;
      v_tab typ_nt_num;
    begin
      select distinct object_id bulk collect into v_tab from all_objects where rownum <= 10;
      for i in 1 .. v_tab.count loop
        dbms_output.put_line(v_tab(i)) ;
      end loop ;
    end;
    /

  • My computer died and I had to buy another one.  Now I can't sync my ipod classic.  What is the deal with this?  I added songs about three months ago and it was fine.  Now it won't sync.  It says it has a duplicate file.

    My computer died and I had to buy another one.  Now I can't sync my ipod classic.  What is the deal with this?  I added songs about three months ago and it was fine.  Now it won't sync.  It says it can't sync because there is a duplicate file.

    There are server problems right now with iMessage effecting some users.  See http://www.apple.com/support/icloud/systemstatus/.

  • What's the go with this latest update. Half my apps don't work and the iPad runs slower? How do I go back to the old operating system?

    What's the go with this latest update. Half my apps don't work and the iPad runs slower? How do I go back to the old operating system?

    Make sure your apps are updated.  You might try Settings > iTunes & App Store > Automatic Downloads - Updates = "On".
    You cannot go back to an old operating system.

  • HT202213 My apple TV no longer finding my movies and photos. What's the deal with this?

    My apple TV no longer finding my movies and photos. What's the deal with this?

    That would be awesome, if the nearest service area wasn't 4 hours away.... It would cost me just as much in gas to drive down there as it would just to buy a cheap replacement off of ebay...

  • Trying to set up a linksys router but the cd says it works with OSX 10.6 and later. I am currently running the newest version of mountain lion.... what is the matter with this OSX   update needed?

    trying to set up a linksys router but the cd says it works with OSX 10.6 and later. I am currently running the newest version of mountain lion.... what is the matter with this OSX   update needed?

    Your install disk must look like this
    and not like this.
    Those gray disks are machine specific and will only work with model of Mac that they shipped with.

Maybe you are looking for