What is virtual template interface

hi all
Please explain me what is vitual template interface and when should used.how can someone used it to bind physical intfaces under virtual templte int?

Hi,
A virtual template interface is used to provide the configuration for dynamically created Virtual-Access interfaces. It is created by users and can be saved in nonvolatile RAM (NVRAM).
Once the virtual template interface is created, it can be configured in the same way as a serial interface.
To create a virtual template interface that can be configured and applied dynamically in creating virtual access interfaces, use the interface virtual-template command in global configuration mode.
Virtual template interfaces can be created and applied by various applications such as Virtual Profiles, virtual private dialup networks (VPDN), PPP over ATM, PPP over Frame Relay, protocol translation, and Multichassis Multilink PPP (MMP).
Following are FR and ATM examples:
interface Serial1/0.1 point-to-point
bandwidth 128
frame-relay interface-dlci 51 ppp Virtual-Template1
class FRTS
interface ATM1/0.52 point-to-point
ip vrf forwarding customer
pvc 101/52
abr 167 167
oam-pvc manage
encapsulation aal5ciscoppp virtual-Template 1
http://www.cisco.com/en/US/products/sw/iosswrel/ps1831/products_command_reference_chapter09186a0080080d36.html#wp1017915
HTH, please do rate all helpful replies,
Mohammed Mahmoud.

Similar Messages

  • Virtual template interface vs Dialer interface?

    Hi all,
    I am little confusing about virtual template interface and dialer interface. I understood that both of them are logical interface and will be mapped to physical interface dynamically. What is different? When would I use virtual template interface or dialer interface?
    Please suggest too.
    Thanks a lot,
    Nitass

    hi
    AFAIK we use virtual template in L2TP scenarios where you will have LAC and LNS .
    the configs related to VT comes in LNS which is ur local network server for your remote clients from where the L2 tunnel gets orginated.
    And about your dialer interfaces we use them very frequently in most of the situations like where you require to club 2 Physical isdn lines and to make use them as a single pipe or using single isdn line and connect it to 2 different locations using 2 B channels using 2 dialers...
    if you need to know more about them would suggest to check out this link which will give fair idea about them..
    http://www.cisco.com/en/US/tech/tk801/tsd_technology_support_category_home.html
    hope this helps u out..
    regds

  • Router Dead , when i applied QOS on virtual-temp interface for vpn !!

    hi all ,
    i have a simple brief topology below :
    PSTN======(R1-7206)>F1=======F2>(R2-7604 catalyst)>>>F1=========Internet
    i have two router
    R2========>MLS 7604
    R1======>cisco 7204
    on R2 , Im doing matching to QOS by dscp , im matching acls ips from internet with dscp values :
    here is CONFIG for matching :
    Gateway7600#sh policy-map LLQX
      Policy Map LLQX
        Class YOUTUBE
          set ip dscp af43
        Class FACEBOOKVIDEOS
          set ip dscp af33
        Class HTTP
          set dscp af23
        Class DNSQOS
          set dscp af13
        Class class-default
          set ip dscp af11
    ================
    Gateway7600#sh class-map
    Class Map match-all FACEBOOKVIDEOS (id 7)
       Match access-group name  facebookvideos
    Class Map match-all DNSQOS (id 8)
       Match access-group name  dnsqos
    Class Map match-all HTTP (id 6)
       Match access-group name  browsing
    Class Map match-any class-default (id 0)
       Match any 
    Class Map match-all YOUTUBE (id 5)
       Match access-group name  youtube
    Gateway7600#
    =========================================================
    on this router i applied this policy map  on interfaxce F1 in  direction
    and here matching is well :
    Gateway7600#sh policy-map  interface gigabitEthernet 1/5 in    
    GigabitEthernet1/5
      Service-policy input: LLQX
        class-map: rate-limit (match-all)
          Match: access-group name rate-limit
          police :
            4088000 bps 384000 limit 384000 extended limit
          Earl in slot 1 :
            139044930 bytes
            30 second offered rate 143032 bps
            aggregate-forwarded 134420937 bytes action: transmit
            exceeded 4623993 bytes action: drop
            aggregate-forward 22544 bps exceed 0 bps
        class-map: YOUTUBE (match-all)
          Match: access-group name youtube
          set dscp 38:
          Earl in slot 1 :
            132693939697 bytes
            30 second offered rate 212144928 bps
            aggregate-forwarded 132693939697 bytes
        class-map: FACEBOOKVIDEOS (match-all)
          Match: access-group name facebookvideos
          set dscp 30:
          Earl in slot 1 :
            10726758352 bytes
            30 second offered rate 20682720 bps
            aggregate-forwarded 10726758352 bytes
        class-map: HTTP (match-all)
          Match: access-group name browsing
          set dscp 22:
          Earl in slot 1 :
            56874058537 bytes
            30 second offered rate 92669832 bps
            aggregate-forwarded 56874058537 bytes
        class-map: DNSQOS (match-all)
          Match: access-group name dnsqos
          set dscp 14:
          Earl in slot 1 :
            160308954 bytes
            30 second offered rate 303552 bps
            aggregate-forwarded 160308954 bytes
        class-map: class-default (match-any)
          Match: any
          set dscp 10:
          Earl in slot 1 :
            67394864030 bytes
            30 second offered rate 126884864 bps
            aggregate-forwarded 67394864030 bytes
    =================================================================================
    now the problem is below
    on router 7200 , it is LNS router connected with LAC roiuter for ADSL customers.
    now here is config of policy map on 7200 router:
    R11#sh policy-map
      Policy Map MATCH_MARKS
        Class MATCH_YOUTUBE
          bandwidth 220000 (kbps)
        Class MATCH_FACEBOOKVIDEOS
          bandwidth 20000 (kbps)
        Class MATCH_HTTP
          bandwidth 100000 (kbps)
    =========================================================
    R1#sh class-map
    Class Map match-all MATCH_FACEBOOKVIDEOS (id 2)
       Match ip  dscp af33 (30)
    Class Map match-all MATCH_HTTP (id 3)
       Match ip  dscp af23 (22)
    Class Map match-any class-default (id 0)
       Match any
    Class Map match-all MATCH_YOUTUBE (id 1)
       Match ip  dscp af43 (38)
    ==========================================================
    here is virtual-template interface before i apply the QOS
    R1#sh running-config interface virtual-template 1
    Building configuration...
    Current configuration : 352 bytes
    interface Virtual-Template1
    bandwidth 1000000
    ip unnumbered Loopback0
    ip tcp adjust-mss 1412
    ip policy route-map private
    no logging event link-status
    qos pre-classify
    peer default ip address pool bitsead1 bitsead2
    ppp mtu adaptive
    ppp authentication pap vpdn
    ppp authorization vpdn
    ppp accounting vpdn
    max-reserved-bandwidth 90
    end
    =========================================
    when i apply the command
    (service-poliy output MATCH_MAKRS ) under virtual-template  interface i have console logs :
    Insufficient bandwidth 149760 kbps for the bandwidth guarantee (220000)
    Insufficient bandwidth 149760 kbps for the bandwidth guarantee (220000)
    Insufficient bandwidth 149760 kbps for the bandwidth guarantee (220000)
    also i have
    *Jul  9 22:28:38.242: Interface Virtual-Access2551 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul  9 22:28:38.250: Interface Virtual-Access627 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul  9 22:28:38.258: Interface Virtual-Access786 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul  9 22:28:38.266: Interface Virtual-Access623 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul  9 22:28:38.274: Interface Virtual-Access2559 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul  9 22:28:38.282: Interface Virtual-Access2281 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul  9 22:28:38.290: Interface Virtual-Access142 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul  9 22:28:40.262: %SYS-2-INTSCHED: 'suspend' at level 3 -Process= "VTEMPLATE Background Mgr", ipl= 3, pid= 278,  -Traceback= 0x756FF0z 0x3439C58z 0x2778D70z 0x2CACCD0z 0x2CC63E0z 0x2CC7FF8z 0x2CADC74z 0x2CBE058z 0x2CA0340z 0x2CA04F8z 0x2E0BB18z 0x2D23378z 0x2D1825Cz 0x2D18738z 0x2E66FE0z 0x2D971ACz
    *Jul  9 22:28:40.262: %SYS-2-INTSCHED: 'suspend' at level 3 -Process= "VTEMPLATE Background Mgr", ipl= 3, pid= 278,  -Traceback= 0x756FF0z 0x3439C58z 0x2778D70z 0x2CACD28z 0x2CC63E0z 0x2CC7FF8z 0x2CADC74z 0x2CBE058z 0x2CA0340z 0x2CA04F8z 0x2E0BB18z 0x2D23378z 0x2D1825Cz 0x2D18738z 0x2E66FE0z 0x2D971ACz
    after i apply it ,
    the cpu is 100 %  and the router got down !!!
    now
    what is  the problem ????
    here is ios for 7200 router
    R1#sh version
    Cisco IOS Software, 7200 Software (C7200P-ADVENTERPRISEK9-M), Version 12.4(24)T7, RELEASE SOFTWARE (fc2)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2012 by Cisco Systems, Inc.
    Compiled Tue 28-Feb-12 12:53 by prod_rel_team
    ROM: System Bootstrap, Version 12.4(12.2r)T, RELEASE SOFTWARE (fc1)
    Bras1 uptime is 13 weeks, 1 day, 9 hours, 24 minutes
    System returned to ROM by reload at 16:24:51 GMT+3 Tue Jun 17 2003
    System image file is "disk2:c7200p-adventerprisek9-mz.124-24.T7.bin"
    Last reload reason: Reload Command
    This product contains cryptographic features and is subject to United
    States and local country laws governing import, export, transfer and
    use. Delivery of Cisco cryptographic products does not imply
    third-party authority to import, export, distribute or use encryption.
    Importers, exporters, distributors and users are responsible for
    compliance with U.S. and local country laws. By using this product you
    agree to comply with applicable laws and regulations. If you are unable
    to comply with U.S. and local laws, return this product immediately.
    A summary of U.S. laws governing Cisco cryptographic products may be found at:
    http://www.cisco.com/wwl/export/crypto/tool/stqrg.html
    If you require further assistance please contact us by sending email to
    [email protected].
    Cisco 7206VXR (NPE-G2) processor (revision A) with 917504K/65536K bytes of memory.
    Processor board ID 36858624
    MPC7448 CPU at 1666Mhz, Implementation 0, Rev 2.2
    6 slot VXR midplane, Version 2.11
    Last reset from power-on
    PCI bus mb1 (Slots 1, 3 and 5) has a capacity of 600 bandwidth points.
    Current configuration on bus mb1 has a total of 0 bandwidth points.
    This configuration is within the PCI bus capacity and is supported.
    PCI bus mb2 (Slots 2, 4 and 6) has a capacity of 600 bandwidth points.
    Current configuration on bus mb2 has a total of 0 bandwidth points.
    This configuration is within the PCI bus capacity and is supported.
    Please refer to the following document "Cisco 7200 Series Port Adaptor
    Hardware Configuration Guidelines" on Cisco.com <http://www.cisco.com>
    for c7200 bandwidth points oversubscription and usage guidelines.
    1 FastEthernet interface
    3 Gigabit Ethernet interfaces
    2045K bytes of NVRAM.
    250880K bytes of ATA PCMCIA card at slot 2 (Sector size 512 bytes).
    65536K bytes of Flash internal SIMM (Sector size 512K).
    Configuration register is 0x2102
    ==============================================================================
    wish to Help ASAP
    regards

    hi ,
    i did
    the same issue ,
    i did a TEST policymap that has 30 percent gurantee
    but the same result!!!!!!!!!!!!!!!!
    the router  god down agian !
    here is logs :
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:33.605: Interface Virtual-Access1896 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:33.797: Interface Virtual-Access1317 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:33.809: Interface Virtual-Access993 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:33.817: Interface Virtual-Access1699 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:33.981: Interface Virtual-Access254 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:33.993: Interface Virtual-Access687 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:34.001: Interface Virtual-Access35 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:34.009: Interface Virtual-Access160 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:34.017: Interface Virtual-Access1337 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:34.029: Interface Virtual-Access1670 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:34.037: Interface Virtual-Access1948 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:34.049: Interface Virtual-Access1669 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:34.109: Interface Virtual-Access1334 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:34.117: Interface Virtual-Access151 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:34.125: Interface Virtual-Access761 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:34.137: Interface Virtual-Access810 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:34.197: Interface Virtual-Access1522 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:34.237: Interface Virtual-Access1692 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:34.257: Interface Virtual-Access368 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:34.305: Interface Virtual-Access1758 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:34.317: Interface Virtual-Access2061 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:34.325: Interface Virtual-Access1203 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:34.337: Interface Virtual-Access188 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:34.345: Interface Virtual-Access1975 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:34.357: Interface Virtual-Access1172 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:34.509: Interface Virtual-Access1647 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:34.517: Interface Virtual-Access458 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:34.609: Interface Virtual-Access608 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:34.621: Interface Virtual-Access2128 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:34.633: Interface Virtual-Access1167 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:34.641: Interface Virtual-Access487 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:34.653: Interface Virtual-Access1793 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:34.665: Interface Virtual-Access2280 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:34.769: Interface Virtual-Access839 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:34.781: Interface Virtual-Access2311 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:34.793: Interface Virtual-Access1788 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:34.857: Interface Virtual-Access8 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:34.869: Interface Virtual-Access2243 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:34.881: Interface Virtual-Access580 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:35.057: Interface Virtual-Access6 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:35.065: Interface Virtual-Access1331 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:35.077: Interface Virtual-Access1235 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:35.177: Interface Virtual-Access1748 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:35.189: Interface Virtual-Access2262 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    *Jul 11 02:40:35.205: Interface Virtual-Access2136 max_reserved_bandwidth config will not
    take effect on the queueing features configured via service-policy
    i want to ask a question , could this be from IOS ????

  • Dynamic virtual tunnel interface on 2821

    I tried to configure a dynamic virtual tunnel interface on a Cisco 2821 with release 12.4(9)T1 advanced ip services, aiming to terminate VPN client ipsec tunnels on it.
    The feature is supported by this software release. Documentation says:
    - enter configuration
    - configure a virtual-template interface
    - type "tunnel mode <mode>"
    but the router does not accept this command.
    Any hint?
    Thank you in advance.
    Denis

    Try:
    just have to take a look at the concentrator's configuration.
    http://www.cisco.com/en/US/products/hw/vpndevc/ps2284/products_configuration_example09186a00801ae24c.shtml
    and this one is an example with routers
    http://www.cisco.com/en/US/tech/tk583/tk372/technologies_configuration_example09186a0080143b0a.shtml

  • Cisco 2800 - Multiple VPNs Using Virtual-Template

    Hello List,
    I have a question related to the way of setting up multiple VPNs using
    virtual-template configuration (Cisco calls this Dynamic VPN): how can
    I make my configuration to be a "spoke" type VPN rather than "hub" type
    without using "crypto map" on the physical interface?
    Here is how it works now (the VPN hub config):
    !!! the VPN hub config
    crypto keyring PSKs
    pre-shared-key address <peer_ip> key 6 ************
    crypto isakmp profile ISAKMP_Profile
    keyring PSKs
    self-identity address
    match identity address <peer_ip> 255.255.255.255
    virtual-template 1
    crypto ipsec transform-set Transform_Set esp-3des esp-md5-hmac
    crypto ipsec profile IPSEC_Profile
    set transform-set Transform_Set
    set isakmp-profile ISAKMP_Profile
    interface Loopback1007
    description This is a public IP address from a range routed via my
    gatey IP address (see bellow)
    ip address <my_VPN-hub_ip> 255.255.255.255
    no ip redirects
    interface Multilink1
    description This is my gateway IP address facing the ISP
    ip address <my_public_IP> 255.255.255.252
    no ip redirects
    no ip unreachables
    ip nbar protocol-discovery
    ip nat outside
    ip virtual-reassembly
    rate-limit input access-group 102 8000 1500 2000 conform-action
    transmit exceed-action drop
    ip route-cache flow
    no cdp enable
    ppp multilink
    ppp multilink fragment delay 20
    ppp multilink interleave
    ppp multilink group 1
    ppp multilink multiclass
    service-policy output qos_pm-outbound
    interface Serial0/0/0
    description 1st Serial Interface to ISP
    bandwidth 2048
    no ip address
    encapsulation ppp
    ip route-cache flow
    no fair-queue
    ppp multilink
    ppp multilink group 1
    interface Serial0/0/1
    description 2nd Serial Interface to ISP
    bandwidth 2048
    no ip address
    encapsulation ppp
    ip route-cache flow
    no fair-queue
    ppp multilink
    ppp multilink group 1
    interface Virtual-Template1 type tunnel
    ip unnumbered Loopback1007
    ip access-group vpn_acl-tunnel-encr-in in
    ip access-group vpn_acl-tunnel-encr-out out
    ip mtu 1400
    ip route-cache flow
    tunnel source Loopback1007
    tunnel mode ipsec ipv4
    tunnel sequence-datagrams
    tunnel checksum
    tunnel path-mtu-discovery
    tunnel protection ipsec profile IPSEC_Profile
    service-policy output qos_pm-VPN
    ip access-list extended vpn_acl-tunnel-encr-in
    permit ip 172.20.40.0 0.0.0.255 192.168.2.0 0.0.0.255
    ip access-list extended vpn_acl-tunnel-encr-out
    permit ip 192.168.2.0 0.0.0.255 172.20.40.0 0.0.0.255
    !!! the Spoke VPN is configured by my peers (Cisco routers, PIXes,
    Cisco VPN concentrators)
    !!! all follow the standard crypto map config on the physical
    interface.
    !!! i.e. http://www.vpnc.org/InteropProfiles/cisco-ios.txt
    It is obvious that with my router configured as a VPN hub, if the
    tunnel dies, I need to wait for the peer to reset the tunnel, all this
    time my clients in my network are not able to access the remote sites.
    The reason to use the virtual-template interfaces as suppose to
    traditional "crypto map" way, is that my peers do not want to share the
    same VPN end-point between themselves (different companies all
    together) and they are very strict in regards to ACLs. As I don't have
    a VPN device for each one of them and their number increases (I have 5
    separate tunnels right now with a potential grow to 15 in the next 3
    months), I need to find a way to get rid of the hub config in my end (I
    did not have much choice there when I migrated to this platform from a
    linux box).
    Pros for the Virtual-Template:
    - separate QoS for each tunnel
    - ACLs configured directly on the tunnel interface (grater flexibility)
    - tunnel end-point IP address can be part of a range BGP advertised via
    multiple ISP links
    Cons:
    - hub config, the tunnel needs to be reseted by the peer
    Any help is very much appreciated. Thank you,
    Adrian

    Hope the following link will help you
    http://www.cisco.com/en/US/tech/tk583/tk372/technologies_configuration_example09186a008019d6f7.shtml

  • Interface virtual-template limitations

    I am using 7204 as access concentrator for PPPOA sessions using interface virtual-templates. I want to know the maximum number of supported virtual interfaces. for 12.0, it's stated in cco documents that the maximum number of virtual interfaces is 300. starting from 12.2, it's mentioned that the maximum number is platform dependant. I am runing 12.2(27).
    Thanks in advance...
    Karim.

    Hello Karim,
    I think you can issue the command ´show idb´ to see how many software IDB´s (and the virtual template is a software IDB) are supported by your router.
    Refer to the document below for additional info:
    Maximum Number of Interfaces and Subinterfaces for Cisco IOS Platforms: IDB Limits
    http://www.cisco.com/en/US/products/sw/iosswrel/ps1835/products_tech_note09186a0080094322.shtml
    HTH,
    GP

  • Strange Behavior In Defining A Template Interface -- Bug/RFE

    Hello.
    This is a bit of a bug. I wanted to define a "template" interface. If you follow this sequence of steps, you may see this odd behavior:
    In a class diagram, insert a new Interface.
    Add a template parameter to that interface. Now, the display of the object has not changed.
    Right-click the interface, and under "Show", select "As Icon".
    Right-click again and under "Show" select "As Non-Iconic Class".
    Now the interface is displayed as a "Template Class" on the diagram, with its parameters visible. This comes about since the Modeling Palette only contains a tool to draw a "Template Class", which creates a class only and not an interface.
    Is this behavior somehow intentional or expected?
    Is there any bug reporting tool for such reports? Or is posting on this forum sufficient to constitute feedback on a bug?
    Thanks in advance.
    - Steven Coco.

    Hi.
    I am not aware of another notation: the display given by JSE (after making it display the parameters) is all I would expect -- the UML superstructure just says that a templatable element has the dashed-outline box listing its parameters. Now, the display of the parameters can be suppressed, but I would have expected in that case a more direct "Hide or Show Template Parameters" option for the element. And in fact, I'd say that a display option like this is really what this boils down to: there's no option to hint JSE to display the parameters; and you'd have to go a round-about fashon to make them appear.
    And my display does still show <<interface>> after geting the parameters to appear.
    Thanks!
    - Steev.

  • PPPoX Virtual-Template assignment via Radius Attribute

    I'd like to optionally apply ACLs to PPP users (PPPoX).  I see two strategies: a) apply an ACL directly via radius attributes or b) define the ACL in the Virtual-Template on the BRAS and determine the Virtual-Template ID via radius attribute.  Has anyone done this?  If so, any suggestions on the best way to move forward?  I think I'd prefer option B as I could also use it to assign VRFs etc (one Virtual-Template per VRF).
    TIA

    The only way I could get this to work is have the ACS server reference an ACL configured on the switch via name or number and send in the filter-id attribute.  On the switch I configured the default setting for attribute 11 to apply inbound "
    radius-server attribute 11 default direction in".  If you do a "sh authentication sessions interface gx/x" it'll show the filter-ID setting but if you do a "show ip interface gx/x" it still shows the default-acl being applied.  It works, just a bit confusing because of that default-acl still showing up.  Anyone else experience the same?

  • LLQ on Virtual-Acces Interfaces

    I'm sure this must have been asked before but...
    Given service policies with CBWFQ and LLQ aren't allowed on virtual-access interfaces how can a service provider guarantee bandwidth and latency to VoIP or other priority traffic over a single PPP session?
    I'm looking at this from the point of view of a broadband service provider using L2TP to tunnel customer PPP sessions to the terminating router so there isn't an individual interface for each customer except the for the virtual-access interface.
    I've looked at ppp multilink but I don't see how that can be used in an environment where each customer can only initiate one PPP session?
    I'm assuming the only way to go is to use the
    "ip rtp priority" command on the virtual-template.
    Any ideas on where to look?
    Is CBWFQ likely to make it into the whole VPDN system or is it just too resource hungry?
    Richard Watson

    You can just add 'ip rtp priority' command to the virtual-template. But anyway you will have to shutdown interface and clear virtual-access interface to make it work. Here's the nice description of the command.
    http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/120newft/120t/120t5/iprtp.htm

  • PPP IP address and virtual-access interface

    With what command can I find out what IP address has been bound to which virtual-access interface of a PPP negotiated connection to an IOS router 2811/12.4(17a)?
    Thanks for any hint.
    Mat

    Hi Mat,
    try the command "sh us a" (I think the long version is show users all).
    HTH, regards
    Mark

  • Firefox any version Mac, has a bug were it does not see or ask for the proxy username and password. This happens if you use a virtual tagged interface.

    Firefox any version Mac, has a bug were it does not see or ask for the proxy username and password. This happens if you use a virtual tagged interface. A recent network University policy change. The only way to fix this, is if you use a manual proxy configuration in Firefox. So all 100 + uni iMac's can only use Safari as I would need to do a profile push to all 300 students and I am unsure what file carries the proxy information.

    Firefox any version Mac, has a bug were it does not see or ask for the proxy username and password. This happens if you use a virtual tagged interface. A recent network University policy change. The only way to fix this, is if you use a manual proxy configuration in Firefox. So all 100 + uni iMac's can only use Safari as I would need to do a profile push to all 300 students and I am unsure what file carries the proxy information.

  • Can we create a developersite in O365 SP Online programiatically ? what is the template code for it ?

    Hi
    I am trying to create sites programmatically in O365 SharePoint Online. So, just want to know that can we create a DeveloperSite ?? what is the template code for it viz. Team site- STS#0, etc
    If possible provide me the MSDN link where I can refer for available site templates for O365 SP Online sites creation.
    Thank you 

    http://community.office365.com/en-us/f/154/t/61145.aspx
    Are you meaning to create sites on SharePoint Online by invoking web services in your own program? SharePoint Online indeed provide some web services for custom programming, however, the web methods for creating a new site seems not included in them. Here
    are some resources for the development of SharePoint Online for your reference:
    SharePoint Online for developers
    http://msdn.microsoft.com/en-us/sharepoint/gg153540.aspx
    Code example for SharePoint Online: Accessing Web Services
    http://code.msdn.microsoft.com/office/SharePoint-Online-0bdeb2ca
    As to create a site collection, the parameter "Template" is the name of the template you want to use, as to find the name of the custom site template, you can use the powershell command "Get-SPOWebTemplate",
    it will list all the templates with the names.
    Note, The Template and LocaleId parameters must be a valid combination as returned from the Get-SPOWebTemplate cmdlet.
    Also check
    http://stackoverflow.com/questions/21268629/creating-new-site-collection-in-office-365-from-an-app
    If this helped you resolve your issue, please mark it Answered

  • What is a "Abstract Interface" ?

    According to JavaDoc, <code>HttpSession</code> is described as
    public abstract interface HttpSession.
    What is an "abstract interface" ?

    All interface's are implicitly abstract so declaring an interface abstract is a bit pointless.

  • Prime infrastructure 2.0 - Inventory error with Virtual-Access Interface

    Hi,
    We have recently been trying to resolve a few issues with routers which get partial inventory failures upon discovery. I have managed to narrow this down slightly with the help of the inventory.log file. (With help from this post https://supportforums.cisco.com/thread/2255346 ) I have found the following happnes when this device is added:
    [2014-03-04 14:00:27,537] [ICE Service[ 1]Thread: 29] [inventory] [ERROR] - 172.16.3.202 Object detected as SAME but DB Object obtained from the database is NULL For instance id: 0 For generated POJO: PPPEncapsulation[callBack=false,callIn=false,callOut=false,multilink=false,name=Virtual-Access1,oneTime=false,owningEntityId=69757688_172.16.3.202,preferedAuthType=NONE,deployPending=NONE,name=Virtual-Access1,owningEntityId=69757688_172.16.3.202,instanceId=0,_orderedListOEIndex=<Integer>,_creationOrderIndex=<Integer>,instanceVersion=0]
    I have highlighted above where it mentions the problem with the virtual access interface. The configuration on the router is for PPPoE and the virtual-access1 interface is bound to Dialer0.
    It then goes on to roll back the transaction:
    172.16.3.202 persistObjects called with addList size = 307, updateList size = 6
    172.16.3.202 Exception while persisting: com.cisco.xmp.persistence.common.util.DMMCRUDException:,message=errorId=12,componentName=CRUD Error Create Object Failed
    172.16.3.202 Exception occured while inventory collection for device with id 69757688: com.cisco.xmp.inventory.ice.InventoryException: errorId=12,componentName=CRUD Error Create Object Failed
    172.16.3.202 Done with collection. Total call method time: 15308
    172.16.3.202 Rolling back the transaction
    Has anyone else come accross this issue?
    I have attched the log showing just messages from this device.
    Thanks,
    Mike.

    TAC and I found a bug, CSCum05301.
    May be that is also helpfull for others.
    https://tools.cisco.com/bugsearch/bug/CSCum05301/
    Symptom:
    Inventory collection will fail if following keywords are used as part on description command on the interface config level of IOS device: 1Gbps, 10Mbps etc.
    Following error message is visible on the DWC:
    Inventory Collection Status: Partial Collection Failure
    Collection Status     Failed feature(s)
    Unable to configure DSL, Serial, POS, Ethernet, Loopback, Virtual-Interface, Tunnel, Vlan, Switchport and Service Module interfaces on ISR, ASR and Switches.
    Conditions:
    Speed keywords like 1Gbps, 10Mbps etc. available as part of descrption command in IOS interface level.
    For example:
    interface FastEthernet0/3
    description 10Mbps
    Workaround:
    Use a space character between number and unit keyword, like 1 Gbps.

  • How to create a virtual ethernet interface in arch ?

    I have subscribed to a distant VPN service. My computer acts as a VPN client and creates a new interface tun0 each time the VPN is active.
    I want to only route the ip traffic from Transmission through VPN
    I tried to follow the tutorial from here (sorry it's in french) but this tutorial is for debian-based distribs.
    Since the VPN may have a dynamic IP, this tutorial proposes to create a 2nd virtual ethernet interface with a fixed IP adress. iptable is then used to perform NAT translation between the IP of this 2nd virtual ethernet interface and tun0.
    With debian-based distributions, the creation the this new virtual ethernet interface is managed by adding the following lines to the file /etc/network/interfaces :
    # The secondary loopback network interface
    auto lo:1
    iface lo:1 inet static
    address 192.168.0.1
    netmask 255.255.255.255
    I'm not sure how to perform this in arch. I read a lot about the ip command and I think that the solution may be something like that :
    ip tuntap add dev lo1 mode tap
    but I'm not sure and moreover, I don't know how to give a fixed IP adress (i.e. 192.168.0.1) to this new interface
    Any help would be really appreciated.

    It's just a wild guess, but maybe https://wiki.archlinux.org/index.php/Systemd-networkd would help?

Maybe you are looking for

  • Fetch SSIS error through SQL Server Agent JOB

    Hi, I am trying to fetch eventmessages from catalog.eventmessages view in SSISDB inside a sql job which executes a package. This utility is supposed to send an email with the description of failure reason and step whenever the JOB fails. But I could

  • Problems updating or installing the latest version of itunes

    Has anyone had the following message when either updating or trying to install the latest version of itunes? Runtime Error! Program: C:\Program Files (x86)/iTunes\iTunes.exe R6034 An application has made an attempt to load the C runtime library incor

  • QuickTime Errors During Install

    Looking for help. I recently upgraded to iTunes 6 which included the QuickTime 7 upgrade. Can no longer use iTunes due to error messages during the install of QT7. Receiving the following Errors 1402: Could not find key: HKEYLOCALMACHINE\SOFTWARE\Mic

  • Task manager on windows server 2008 doesn't show the memory from newly installed 2nd CPU

    Hi, We have a dual processor dell power edge t410 running windows server 2008 (64-bit), standard edition. I have recently added a 2nd xeon x5560 quad-core processor (first one is also x5560 with 32GB (4x8) memory) and 16GB ram (4x4). Seems like the n

  • Creating a new monitor profile

    Does anyone know how to Create a new monitor profile...Running Windows 7 with Elemnts 9 and I cant find a Adobe Gamma Wizard on my PC.