Java 7 not working on new (4/2/13) OS 10.8 machine

I downloaded Java 7 and the app is not working.
Checked it on Java site and it is not functioning.
Validated Java is enabled in browser
Cleared Cache...
Not sure what else to do.
Was going to uninstall and re-install with security off, but am not sure how to uninstall. My first Mac....
Thanks in advance.

I had a similar problem running Java with OSX 10.8.3.  Even after performing the latest software update (including Safari 6.0.4) in addition to download and installation of the latest version of Java (version 7 update 21), Java did not work. And the “Java icon” was absent from the “system preferences” menu (should be at the bottom under the tab “other”). Very strange! But I found a solution: 1.) Go to “Library > Internet Plug-Ins”; 2.) Move all JavaAppletPlugins to trash (I moved “JavaAppletPlugin (1.7.10.18).plugin” and “JavaAppletPlugin.plugin”); 3.) Download and run the latest Java update; 4.) re-launch Safari.
That solved my problem and I can run Java applications in Safari. Again......

Similar Messages

  • Java program not working using newer version of scheduler (AutoSys)

    A little background: I'm in the middle of trying to upgrade our AutoSys server (scheduler) to the latest version (version R4 to R11) and have to do regression testing to ensure our jobs will work in the new version. There's a small java program that is not working supposedly due to the following error:
    Exception in thread "Main Thread" java.lang.NoClassDefFoundError: com/f1j/swing/common/JDKAdapter
    at com.f1j.swing.common.Adapter.<clinit>(Adapter.java:86)
    at com.f1j.swing.engine.ss.JBook.<init>(JBook.java:3032)
    at com.f1j.swing.engine.ss.JBook.<init>(JBook.java:3096)
    at com.test.Foo.performScan(Foo.java:122)
    So in the old version (R4), it runs fine. In R11, I get the exception above. The CLASSPATH matches and I've verified that by echoing it in the shell script that calls the java program. Here's how it's called in the shell script.
    echo $CLASSPATH
    ${JAVA_HOME}/bin/java com.test.Foo
    So the Foo class was written by me, which makes use of this external library called f1j11swing.jar (for spreadsheet creation).
    The source of the error is from this line in Foo (line 122):
              book = new com.f1j.swing.engine.ss.JBook();
    The funny part is JDKAdapter (the missing class) is in the same jar file as JBook, so it definitely finds the library in the classpath. But for some reason, this new AutoSys version is spitting out this error. I've exhausted many approaches to resolving this, but I'm still stuck.
    Here's the layout of how things are called (should be same for R4 and R11):
    1. AutoSys server logs into client machine XYZ as user arnold
    2. arnold (AutoSys client) on XYZ executes shell script to call java program
    The only significant difference I see is that the AutoSys server in R4 is HP while the R11 server is Sun. However, it shouldn't matter because the client server they're logging into to execute the script is the same linux server.
    Does anyone have any ideas? I've already started dialogue with the vendor and it seems kind of in limbo at the moment. Please let me know if you need more info. Thanks.

    Hi DrClap,
    I just checked jre/lib/ext of my $JAVA_HOME and verified that there doesn't exist any library with a class named "Adapter." We don't put anything in this directory other than what came with the original installation. I've tried isolating the jars before as well, by doing something like (to no avail):
    java -cp /users/test/lib/f1j11swing.jar:/users/test/lib/Foo.jar com.test.Foo
    If I remove the f1jswing11.jar path in the above command, it will complain about other things. Also, for fun, I tried dropping f1j11swing.jar into the ext folder and removing it from the CLASSPATH and it yielded the original error. Running it directly from the shell and old version of autosys works fine.
    I hope I understood your suggestion correctly and please let me know if you have any other ideas. I'm surprised why java would act differently with a different version of an AutoSys client logging into the same machine and environment. Thanks.
    xiarce - I haven't heard anything regarding this, but I'll bring it up. Thanks.
    Edited by: user4170063 on Apr 13, 2011 2:25 PM

  • Java Applets not working in New Versions of Java

    I have developed a chat program using Applets(developed using jdk1.2),using a Server.Everything is perfectly working.Now,On my client machine i installed jdk1.4, and when i try to download the same applet it is giving Applet ClassNotFound Exception?.
    I have just set the class path to jdk1.4.And trying to call the applet from a browser.
    IS there any changes in writing the applets using the new version of Java?
    Kindly let me know.
    Thanks & Regards.,
    Naveen Kumar

    Sorry can't use em anymore.
    ah, ... perhaps not.
    What class is not found?

  • Web Intelligence Java Applet not working in new Chrome versions (42+)

    Hi all,
    It used to work until recently. Now I encounter the following error when using the Webi Java Applet in Chrome:
    I read about Google quitting some specific Java support. Is anyone experiencing the same issue? What is a recommended workaround/solution except not updating Google Chrome or switching the browser?
    Regards,
    Peter
    The BO platform version is 4.1, Java version is 7 update 67

    Please check SAP Note 2156305.
    You can re-enable NPAPI with the following URL: chrome://flags/#enable-npapi and then click on "Enable" for the NPAPI plugin.

  • Java is not working any more

    The last 6 months Java has not worked at all. I have Java 1.4.2 and 5.0 installed. I have tried re-installation, emptying buffers, resettings safari, using other browsers, created new user account in OSX and so on. I have tried all the tricks in the book and I have talked with other people that have the same problem without being able to find a solution.
    My theory is that everything went wrong with the last java update, and I'm wondering whether Apple will release another update also including Java 1.6. I have waited quite long now, hoping for a update, but it doesn't seem to happen. Does anybody have some ideas on what I can do to get Java working again.

    HI punsk and Welcome to Apple Discussions ...
    Since you're having so much trouble with Java, you might consider backing up your files and doing a complete erase and reinstall. Not an Archive and Install, ERASE and start over. Once you do that, go to Software Updates available from the Apple menu; Apple/Software Updates and start from scratch.
    If you do this, after this is finished, run Disk Utility from your Applications/Utilities folder and Repair Disk Permissions.
    Also, on your iBook. Make sure you have available drive space for updates. Open Disk Utility, select MacintoshHD in the panel on the left, then look down right side of window and you'll see:
    Capacity and Available. Make sure your Available drive space is at least 20% of the total drive.
    Carolyn

  • Java Safari Not Working

    Hi all, I am running 10.4.11 with the new safari but now I believe my java is not working right anymore. I am getting the mug with arrows and no response when I try to upload photos onto places like facebook and costco. I have gone through the software update but it says I am all up to date. As well, I need to access the following site:
    http://www.cra-arc.gc.ca/esrvc-srvce/tx/ndvdls/myccnt/menu-eng.html
    and the following comes up...
    "Java applet unable to load"
    then..
    +On Macintosh Operating Systems:+
    +Mac OS X version 10.4.+
    +Browsers Supported:+
    +Safari 2.0.4 (Webkit 419.3 or higher).+
    +Apple JVM 1.4.2_07 to 1.4.2_16;+
    +Apple JVM 1.5.0_05 or higher.+
    +Safari 3.0.4 (Webkit 523.12 or higher).+
    +Apple JVM 1.4.2_07 to 1.4.2_16;+
    +Apple JVM 1.5.0_05 or higher.+
    Any help?

    Commiserating with you Seanifer - I cannot get Java-based Webinars (Citrix) to load either. As a test of a theory, I tried to load the same webinars in Firefox. It too didn't load - I suspect it's an issue specifically with Java and not necessarily with Safari.
    I too have all software updated - I'm running in Leopard v10.5.6, running Safari v3.2.1 and Java Web Start 12.2.0. Firefox v3.0.6
    We might want to begin with temporarily removing the plist for Java. Do you know how to do this (I do - I'm asking so as to know how detailed my assistance should be for you).
    I have the following Java components loading in this order:
    Java applet versions
    J2SE 5.0 32bit
    Java SE 6 64-bit
    J2SE 5.0 64bit
    J2SE 1.4.2 32-bit
    Java application versions
    J2SE 5.0 32bit
    Java SE 6 64-bit
    J2SE 5.0 64bit
    J2SE 1.4.2 32-bit
    I believe these are the "default" settings as seen in my Java Preferences panel.
    Rolling-up my sleeves on this one! Stay tuned.
    - mp

  • Java apps not working right

    I lately have found problems with Java apps not working correctly. For example, in Yahoo Widgets I cannot get any widget preferences to display; in Apple's Java Preferences for J2SE 5.0 the preference window opens but is blank; and in JBidwatcher the buttons are missing in main and preference windows.
    When I log in as another user I find all those apps work properly, so it seems to be something wrong within my User folder. I tried reinstalling the Java J2SE50ReIease4 but it didn't help. Is there something I can delete and/or reinstall to fix this problem?

    Ditto here,
    I made the mistake of thinking I could throw away the preferences in the Java folder and new pref's would automatically replace the missing pref's, much to my surprise no such thing happened. My settup is the same as yours, except my OS is 10.4.8.
    Someone please help.
    Thanks,
    BJZTX
    G5 D2GHz   Mac OS X (10.4.7)   G4 Notebook 10.3

  • Java does not work at all upon using the update manager to update to firefox 3.6.10 for Ubuntu 9.0.4

    OS: Ubuntu 9.0.4
    Browser: Firefox 3.6.10
    upon updating to firefox 3.6.10, java does not work at all.
    websites that use java do not work at all anymore, when they worked just fine before the updating thru update manager. e.g. hulu website cannot play any of the shows.
    i can give the folder of bookmarked pages i tried.
    how to do that on here, i've yet to see if possible.
    i can even give saved text from the terminal concerning certain attempts.
    when i updated thru update manager, it gave some weird java plugin that wasn't there before "The IcedTea Web Browser Plugin IcedTea6 Java Web Browser Plugin (execution of applets on webpages)".
    i uninstalled this as instructed by an answer found in one of the pages i saved, cuz it was conflicting w/another java program the updater said i needed. right now, i don't remember for sure what it was. it perhaps was realplayer flash or Java itself. w/all the hours/days of searching i put in, it's difficult if not downright impossible for me to remember all the specifics of what i tried.
    i've searched throughout many webpages (including many searches on mozilla, ubuntu, java, etc) for instruction in fixing the problem.
    oh, and incidentally, on the Java site, when i try the verify test of Java, firefox pops up with that yellow bar right below the slew of tabbed website windows, giving the statement "additional plugins are required to display all the media on this page. (w/link to) install missing plugins ." which is what i do, go thru the requesting plugin installation. it comes up with, guess what, the IcedTea Java Plugin. i click on the 'next' in the "Plugin Finder Service" box that pops up, & all it gives me is "No plugins were installed. IcedTea ...Plugin failed. and the link 'find out more about plugins or manually find missing plugins'". the link takes me to some of the very things/plugins that wouldn't install in the first place. the Java test failure is a LOL funny, as what plugin it is saying is required (IcedTea) is a recommended alternate program to display the very test in the first place.
    i followed the given instructions on those many searched pages, in every case (barring what i may have just plain missed), but to no avail.
    i've even gone to the point of trying to reinstall the previous 3.5.13 firefox version, from mozilla site. even that wouldn't install.
    i've tried installing Java for my sys direct from it's site. nada.
    now it's time for me to post the problem & perhaps someone will come up with some kind of "dummy" way to fix it.
    until then many sites a regularly use are totally useless to me on this fast puter.
    the only way i can get to use such sites, are two choices: 1. use a dinosaur laptop, which is slower than molasses & cannot handle to any streaming stuff, or 2. use an available internet access puter at the library. but useage for ea person per day is limited to only one hour a day. and one can end up waiting for an hour or more ( in the busiest periods) to even get to use one.
    so, is there anyone at all, who knows any for-sure working fix for this problem?
    thanks muchly :^D
    p.s. i can't pay anybody any money for such help, as is required in certain sites (e.g. Java website), cuz i don't have any.
    i can pay in labor tho, if there is someway to find someone who can physically be at this puter w/me, taking me step-by-step
    sorry for the 20-pg essay. i hope it was all clearly understood. if, not, well, clear communication is always what is needed, ask away.

    Your above posted system details show outdated plugin(s) with known security and stability risks.
    *Shockwave Flash 9.0 r999
    Update the [[Managing the Flash plugin|Flash]] plugin to the latest version.
    *http://www.adobe.com/software/flash/about/
    In Firefox 3.6 and later versions you need the Next-Generation Java™ Plug-In present in Java 6 U10 and later (Linux: libnpjp2.so; Windows: npjp2.dll).
    http://java.com/en/download/faq/firefox_newplugin.xml
    See also http://java.sun.com/javase/6/webnotes/install/jre/manual-plugin-install-linux.html

  • Flash player does not work with new ICS Android 4.0.4 OS. Has this problem been addressed?

    Flash player does not work with new ICS Android 4.0.4 OS. Has this problem been addressed? I am using Firefox Beta for android and I also tried just Firefox.

    Please check the Play Store app for any Flash updates and install them if present.

  • Home sharing does not work with new mountain lion update.

    home sharing does not work with new mountain lion update. Does anyone else have the same issue. Updated all computers in my home, deauthorized and reauthorized each computer. turn off home sharing and turned it back on. don't know what else to do..please help...

    Our Apple TVs continue to lose connection ever since installing Mountain Lion on the host computer. The only thing that fixes them is to quit and relaunch iTunes, which only works unti the ATV goes to sleep. If a movie is paused for more than a few minutes and the ATV goes to sleep, pressing play again on the remote is greeted with "There are no movies on this computer" or "Turn on Home Sharing."
    If we stop a video on one ATV and attempt to resume it in another room, the error begins again. The other ATV can't connect until iTunes is relaunched.
    My guess is that it has something to do with the new [annoying] security settings. But I still haven't found a fix other than restarting iTunes everytime we want to watch something from our downloads. Fail.

  • HT1338 I installed Mac OSX Snow Leopard 10.6.3 And now my Java is not working, what can I do to fix's this?

    I installed Mac OSX Snow Leopard 10.6.3 And now my Java is not working,what can I do to fix's this?

    Run Software Update to get to 10.6.8 and update Java.

  • HT3917 My apple wireless keyboard is not working after new batteries installed

    My apple wireless keyboard is not working after new batteries installed.

    Do you get a steady green light to say there is a connection.    If not, are the batteries the right way round.   Do you have a monitor to tell the batteries strength. Is there a reading.   Are the batteries good quality ones, Duracell, Energiser or Apple rechargeables.

  • My new Dell PC running Windows 8 does not recognize my iPad or iPhone. Worked OK for iPhone for months but would not work for new iPad.  I removed /relaoded iTunes and now it won't recognize either iPad or iPhone.

    My new Dell PC running Windows 8 does not recognize my iPad or iPhone. Worked OK for iPhone for months but would not work for new iPad.  I removed /relaoded iTunes and now it won't recognize either iPad or iPhone. Got any suggestions?

    Hi there Lizabethfromaz,
    You may find the troubleshooting steps in the article below helpful.
    iOS: Device not recognized in iTunes for Windows
    http://support.apple.com/kb/ts1538
    -Griff W. 

  • Java Plugin not working with firefox 3.o.13  and linux.

    this is my ln -s to the plugin at /usr/lib/mozilla/plugins
    libjavaplugin_oji.so -> /usr/local/jdk1.6.0_16/jre/plugin/i386/ns7/libjavaplugin_oji.so
    Any ideas why java is not working?
    Here's the ln -s again:
    #pwd
    #/usr/lib/mozilla/plugins
    # ls -l
    lrwxrwxrwx 1 root root 63 Sep 28 20:41 libjavaplugin_oji.so -> /usr/local/jdk1.6.0_16/jre/plugin/i386/ns7/libjavaplugin_oji.so
    Here are my java stats:
    # java -version
    java version "1.6.0_16"
    Java(TM) SE Runtime Environment (build 1.6.0_16-b01)
    Java HotSpot(TM) Client VM (build 14.2-b01, mixed mode, sharing)
    Firefox 3.0.13:
    Mozilla/5.0 (X11; U; Linux i686;
    Gentoo Linux:
    # uname -a
    Linux tma 2.6.30-gentoo-r5 #10 SMP Sun Sep 20 21:52:19 PDT 2009 i686 Pentium III (Coppermine) GenuineIntel GNU/Linux
    I installed java from a jdk*.sh file and set the class path in /etc/bash/bashrc (not that it matters.
    The appletviewer does work.

    solved: I knew you all knew I could figure this out.
    #cp -R /usr/lib/mozilla/plugin/ /usr/lib/firefox-mozilla/
    asuming this is true:
    tma plugins # pwd
    /usr/lib/mozilla/plugins
    tma plugins # ls -l
    total 4
    lrwxrwxrwx 1 root root 63 Sep 28 20:41 libjavaplugin_oji.so -> /usr/local/jdk1.6.0_16/jre/plugin/i386/ns7/libjavaplugin_oji.so
    tma plugins #

  • LR 5 not working on new Macbook Pro.

    LR 5 not working on new Macbook Pro.  Have tried 2 CC downloads, 5.6 licensed download and 5.5 licensed download, all result in the same thing.  It comes up with basic screen but no panels and gives an error occurred when changing modules.  Nothing I've tried seems to help.  It also has says "get started with lightroom mobile at top left although it says it is Lr 5.6.  Anybody else having problems?  Calls to adobe result in no help and have to wait till Monday for some technical support.  Surely this should run on a NEW laptop with no other software installed!!!

    Install logs were fine.  Application installed but wouldn't run properly.  Finally got Adobe support and it turns out to be a file permissions error.  Had to add both applications and myself as accessors of Lightroom folder under path ~/Library/Adobe/  and set permissions to read & write (was read only for everything but system) and apply to all enclosed folders.   Runs fine now.  Including this here in case anyone else runs across this issue.

Maybe you are looking for

  • Block Storage location for particular material

    Hi, We gave defined storage location for finished product as follows> 1050 - 2-8° 1040 - RT When I have created one material, wrongly i have created it in 1050 instead of 1040. Then i have extend that material to 1040. Now that material is showing bo

  • How bapi can be used in sd module.

    hi gurus can any one elobarate on Bapi what is the use of it.  how it will be use ful for the sd guys. thanks in advance

  • Downgrading T61 from Vista to XP Display Driver Problem

    Hi, We have recently downgraded a T61 laptop's OS from Windows Vista to Windows XP SP2 using the recovery CDs provided by the vendor. After the downgrade, all the factory default applications and drivers were installed properly, except for the video

  • Adapter type Disabled

    Hi all, In Integration Directory part at the time of creating a Communication channel Adapter type parameter is disabled .I need to specify the adpater type. How to enable the adapter type.I want  to resolve this issue.Can you help me out anyone. Reg

  • General overview of Safari 3.0 Windows

    [BUG] report for Safari 3.0 (522.11.3) on Windows XP and Windows 2000: Test Environment: PIII-650 Intel Speedstep Coppermine, 384 MB SDRAM, 8 MB ATI-RAGE MACH-2 2x AGP in a DELL CPx Test systems : Windows-XP Professional Corporate SP2 Hungarian, and