Keyboard/typing problem

I was trying out the new MacBooks in the Apple Store last night and encountered a weird problem when typing on any MacBook I auditioned. Periodically when I was typing a sentence the cursor would do one of the following:
--- jump up one line and continue typing the current word in the middle of a previously completed line
--- delete the last word I typed
--- delete the last entire line I typed
I'm a very fast typist so it was hard for me to figure out what exactly was going on, but my suspicion is that some part of my hand, in the normal typing motion, is gently brushing some part of the trackpad (or else my pinky finger is inadvertantly pushing on the up/down/right/left arrow keys just to the right of normal typing position), causing these unwanted commands to be executed in the midst of typing.
I tried the same test on the MacBook Pro and never had any problems, so unless there is some technical glitch in all MacBooks (highly unlikely) I suspect it is an ergonomic problem with my (fairly traditional) typing style and the design of the MacBook.
Has anyone else experienced these sorts of issues with their MacBooks? I was thinking of getting one but as its primary purpose would be for writing it's completely out of the question unless I can circumvent this problem... (and the MacBook Pro is a bit pricey for me...)
Thanks...

You're exactly right. The reason the cursor is jumping and misplacing your text is that your hand is brushing the trackpad, which is itself probably set to allow clicking. You can get rid of this behaviour by checking the 'Ignore accidental trackpad input' button in the system preferences panel.
Unfortunately, this is a bit of double-edged sword as checking the box also leaves you with an occasional but nevertheless unpleasant trackpad input lag when, for example, creating or closing Safari tabs.
The MacBook Pros reportedly also had similar issues but some people claim it was remedied with the release of a software update for the keyboard. Who knows. I just know that I never had any such issues with my 12in G4 PB.
MacBook 1.83 13in 2Gb Ram 60Gb HD   Mac OS X (10.4.6)  

Similar Messages

  • 4.1 introduced subtle keyboard/typing problem

    iPhone 4. iOS 4.1
    I have a problem, I haven't had in 3 years of iPhone.
    When I am typing at full speed, when the autocorrect bubble pops up with a suggestion, it sometimes disables typing for about half a second (2-3 taps).
    I cannot reproduce this artificially, it seems to happen often when I don't expect it, but not when I investigate the matter.
    Has anyone else seen this?

    Hi. Sorry for late reply.
    I was not right at all, it seems that the problem is in the new version of packet libxi. Here  http://archlinux.org.ru/forum/viewtopic.php?f=11&t=1368 there was reports that kxkb works fine you reverse to the older version of the packet - libxi-1.1.4-1. Try to find it in you pacman's cache directory. There are some suggestions too: http://bbs.archlinux.org/viewtopic.php?id=65483

  • Weird dreamweaver keyboard mapping problem

    weird dreamweaver keyboard mapping problem:
    Hope this solution helps someone out. If you have q's, ask
    and I will try to help.
    I was having a weird problem in dreamweaver... Whenever I was
    in code view and typed "shift+i" to make a capital "I", instead it
    would paste from the clipboard.
    I finally figured out what was happening. I compared the
    menu.xml in my app support folder in the user library to the
    original menu.xml file that was in the application folder. I went
    through until I came across the diff:
    menu.xml in my library/app support folder:
    <!-- Windows Navigation Shortcuts -->
    <shortcut key="Cmd+Ins" name="Copy2" platform=""
    command="if (dw.canClipCopy()) { dw.clipCopy() }"
    domRequired="FALSE" id="DWShortcuts_HTMLSource_Copy2" />
    <shortcut key="Shift+Ins" name="Paste2" platform=""
    command="if (dw.canClipPaste()) { dw.clipPaste() }"
    domRequired="FALSE" id="DWShortcuts_HTMLSource_Paste2" />
    <shortcut key="Shift+Del" name="Cut2" platform=""
    command="if (dw.canClipCut()) { dw.clipCut() }" domRequired="FALSE"
    id="DWShortcuts_HTMLSource_Cut2" />
    orig menu.xml file:
    <!-- Windows Navigation Shortcuts -->
    <shortcut key="Cmd+Ins" name="Copy2" platform=""
    command="if (dw.canClipCopy()) { dw.clipCopy() }"
    domRequired="FALSE" id="DWShortcuts_HTMLSource_Copy2" />
    <shortcut key="Shift+Ins" name="Paste2" platform=""
    command="if (dw.canClipPaste()) { dw.clipPaste() }"
    domRequired="FALSE" id="DWShortcuts_HTMLSource_Paste2" />
    <shortcut key="Shift+Del" name="Cut2" platform=""
    command="if (dw.canClipCut()) { dw.clipCut() }" domRequired="FALSE"
    id="DWShortcuts_HTMLSource_Cut2" />
    There was a diff in the "platform=" tags. The orig stated
    [platform="win"], my config stated [platform=""] (nothing in
    between the ""'s). So, I reset the platform tag to be
    [platform="win"] in my settings and then relaunched dreamweaver. It
    fixed the problem.
    Not sure how this occurred, but it works now.

  • A possible solution for "foreight language keyboard shortcut" problem...

    Hi(Bonjour)!
    Everyone know the problem of losy keyboard layout when Final Cut is used with foreight language keyboard. We loose the COMMAND-Q shorcut.
    As PieroF suggested in many posts in final cut express forum, there is a workaround:
    "+I just installed Leopard and I ran into this keyboard shortcut problem.+
    +I can confirm that:+
    +a. the problem exists also with the Italian keyboard (in addition to other languages, as pointed by other posters)+
    +b. the workaround I described in my previous answer works fine :+
    +- close FCE (if open)+
    +- open System Preferences/International/Language+
    +- drag English to the first place on top of the other languages+
    +- drag your own language (Italian in my case) again on top of English (at the end the window will show the same original settings, but something happened in the heart of Leopard...)+
    +- close System Preferences+
    +- open FCE: now all shortcuts work as expected, and are correctly listed with their corresponding menu commands+
    +It's a workaround, it's not convenient (I'd better have this bug fixed), but apparently you have to apply it only once for each system startup.+
    Piero "
    As stated by Piero, you have to follow this procedure after each computer startup.
    I found a way to restore the COMMAND-Q shortcut with the keyboard and mouse system pref panel.
    Simply add Final Cut application and add a +custom shotcut+. Be careful to type exactly the "Quit Final Cut Express" menu.
    This solution allows to restart the computer.
    It's work with Final Cut Express and Final Cut Pro under Leopard 10.5.4.
    Michel Boissonneault

    Hi Michel,
    I like your suggestion because the keyboard shortcuts defined in the system preferences do not require redefinition at each startup. So in theory we could define all missing/wrong shortcuts this way, and not only the cmd-Q as you suggested. Boring, but we could do it once for all.
    The only problem is that I don't know how to define shortcuts for submenus, for example "Render Selection/Both": it seems system preferences allows only to define shortcuts for the menu ("Render Selection" - in this case absolutely useless) but not for the submenu.
    Do you know a way ? (I looked in the help, which didn't... help).
    Piero

  • Calling1.4.1 signed applet from Javascript causes keyboard/focus problems

    Pretty sure there's a JRE bug here, but I'm posting to forums before I open one in case I'm missing something obvious :-)
    This issue may be specific to IE, I haven't tested elsewhere yet. Our web application is centered around a signed applet that is initialized with XML data via Javascript. We first noticed the problem when our users started upgrading from the 1.3.x plug-in to the 1.4.x plug-in. The major symptom was that shortcut keys stopped working. I debugged the problem off and on for about a month before I boiled it down to a very simple program that demonstrates the issue (included below). Basically, the program has a function that adds a JButton to a JPanel and registers a keyboard listener (using the new DefaultKeyboardFocusManager class) that prints a message to the console. This function is called by the applet's init() method, as well as by a public method that can be called from Javascript (called callMeFromJavascript()). I also included a very simple HTML file that provides a button that calls the callMeFromJavascript() method. You can test this out yourself: To recreate, compile the class below, JAR it up, sign the JAR, and put in the same dir with the HTML file. Load the HTML file in IE 5.0 or greater, and bring the console up in a window right next to it. Now click the button that says init--you should see the small box appear inside the button that indicates it has the focus. Now press some keys on your keyboard. You should see "KEY PRESSED!!!" appearing in the console. This is proper behavior. Now click the Init Applet from Javascript button. It has removed the button called init, and added one called "javascript". Press this button. Notice there is no focus occurring. Now press your keyboard. No keyboard events are registered.
    Where is gets interesting is that if you go back and make this an unsigned applet, and try it again, everything works fine. This bug only occurs if the applet is signed.
    Furthermore, if you try it in 1.3, signed or unsigned, it also works. So this is almost certainly a 1.4 bug.
    Anyone disagree? Better yet, anyone have a workaround? I've tried everything I could think of, including launching a thread from the init() method that sets up the components, and then just waits for the data to be set by Javascript. But it seems that ANY communication between the method called by Javascript and the code originating in init() corrupts something and we don't get keyboard events. This bug is killing my users who are very reliant on their shortcut keys for productivity, and we have a somewhat unique user interface that relies on Javascript for initialization. Any help or suggestions are appreciated.
    ================================================================
    Java Applet (Put it in a signed JAR called mainapplet.jar)
    ================================================================
    import javax.swing.*;
    import java.awt.*;
    import java.awt.event.*;
    public class MainApplet extends JApplet implements KeyEventDispatcher
        JPanel test;
        public void init()
            System.out.println("init called");
            setUp("init");
        public void callMeFromJavascript()
            System.out.println("callMeFromJavascript called");
            setUp("javascript");
        private void setUp(String label)
            getContentPane().removeAll();
            test = new JPanel();
            getContentPane().add( test );
            JButton button = new JButton(label);
            test.add( button );
            test.updateUI();
            DefaultKeyboardFocusManager.getCurrentKeyboardFocusManager().addKeyEventDispatcher(this);
        public boolean dispatchKeyEvent(KeyEvent e)
            System.out.println("== KEY PRESSED!!! ==");
            return false;
    }================================================================
    HTML
    ================================================================
    <form>
    <APPLET code="MainApplet" archive="mainapplet.jar" align="baseline" id="blah"
         width="200" height="400">
         No Java 2 SDK, Standard Edition v 1.4.1 support for APPLET!!
    </APPLET>
    <p>
    <input type="button" onClick="document.blah.callMeFromJavascript();" value="Init Applet via Javascript">
    </form>

    I tried adding the requestFocus() line you suggested... Same behavior.
    A good thought, but as I mention in my description, the applet has no trouble gaining the focus initially (when init() is called). From what I have seen, it is only when the call stack has been touched by Javascript that I see problems. This is strange though: Your post gave me the idea of popping the whole panel into a JFrame... I tried it, and the keyboard/focus problem went away! It seems to happen only when the component hierarchy is descended from the JApplet's content pane. So that adds yet another variable: JRE 1.4 + Signed + Javascript + components descended from JApplet content pane.
    And yes, signed or unsigned DOES seem to make a difference. Don't ask me to explain why, but I have run this little applet through quite a few single variable tests (change one variable and see what happens). The same JAR that can't receive keyboard events when signed, works just fine unsigned. Trust me, I'm just as baffled as you are.

  • Which part of the machine is related to the keyboard flex problem ?

    Mine is T420s
    And I got a keyboard flex problem.
    Actually which part is related to this problem ?
    Isn't it inclusive to fix this problem in the warranty ?
    thx

    Mine doesn't exhibit any keyboard flex and I don't think it's a common issue with T420s; anyway:
    http://forums.lenovo.com/t5/T400-T500-and-newer-T-series/T420s-Keyboard-Flex/td-p/454851/highlight/t...
    http://forums.lenovo.com/t5/T400-T500-and-newer-T-series/t420s-keyboard-flex/m-p/755255/highlight/tr...
    T420s i5-2520M HD3000 480GB Crucial M500 SSD 8GB RAM Ericsson F5521gw
    T430 i5-3210M HD4000/NVIDIA 5400M 512GB Crucial MX100 SSD 12GB RAM Ericsson H5321gw

  • (foreign) keyboard mapping problems

    Many people, myself included, have voiced problems with keyboard mappings since updating to Leopard. It appears to particularly afflict people with non-US keyboards, but I may be wrong.
    Does anybody out there have a generic fix? Manually modifying the keyboard map as the Latvians did seems to address (some of) the symptoms, not the underlying problem. Accordingly, it doesn't appear to be a general fix, as reported here:
    http://m10lmac.blogspot.com/2007/10/fixing-leopards-latvian-keyboard.html
    Here are some of the other posts I saw/wrote that make me think this is a SIGNIFICANT PROBLEM IN LEOPARD:
    http://discussions.apple.com/thread.jspa?messageID=5794935&#5794935
    http://discussions.apple.com/thread.jspa?messageID=5644709&#5644709
    http://discussions.apple.com/message.jspa?messageID=5688731#5688731
    http://discussions.apple.com/thread.jspa?messageID=5854794
    http://discussions.apple.com/thread.jspa?messageID=5788789

    Does anybody out there have a generic fix?
    There is no generic fix because the problems are unrelated, except to the extent they represent goofs in creating certain files and failure to find these before release.
    The Latvian keyboard issue is caused by errors in a particular .keylayout file. I don't know of any other similar layout with the same problem (In Tiger it was Macedonian and Romanian which had such errors). The Hanin Chinese IM problem is caused by errors in a couple of files particular to it -- all the other Chinese input systems have correct mappings. The X11 keyboard mapping problem concerns a different part of OS X than the others. The issues of QWERTY/AZERTY/QWERTZ in Chinese input were present in a different fashion in Tiger and earlier and many people have switched to a different IM called QIM to solve it. Having a dead Apple key is not related to ordinary character mapping issues.
    Your own issue with ViaVoice is not totally clear to me, will try to respond in that thread.

  • Potential keyboard hardware problem T410

    Dear all,
    since yesterday I have been experiencing a problem with my T410, which is potentially due to
    a hardware issue with the keyboard.
    A few specific keys are not working anymore. These seem to be the Power On key, the Fn key,
    the Alt Gr key, and the ThinkVantage key.
    I am assuming it is a keyboard hardware problem, since I cannot use the Power On button to
    start the laptop. Fortunately, this is possible using the fingerprint reader start-up.
    When the laptop is running (using Windows 7) everything is working fine, except the mentioned
    buttons. I cannot access any Fn button functions (e.g. the reading lamp) or Alt Gr symbols (e.g.
    the @ symbol which is on my keyboard on the 2 button) or power down with the Power button.
    I tried various easy fixes:
    * Making sure all drivers are up to date
    * Remove and reattach the keyboard
    * Static discharge procedure (unplug all power, 10 presses and 30 sec holding of power button)
    * Checking Bios settings
    * Replace battery
    Unfortunately, these did not change the situation.
    I am wondering if the simultaneous malfunctioning of these specific buttons points to a certain
    hardware problem. I hope a replacement of the keyboard might solve this, but it could be an
    issue with the motherboard.
    Any hints would be welcome.
    Thank you,
    MH
    Solved!
    Go to Solution.

    Dear all,
    thank you for your suggestions. Unfortunately, it was not the keyboard. It appears to
    be a more serious problem. In fact, since yesterday the laptop does not boot correctly
    anymore. The boot process is started, but I only end up with a black screen, and some
    randomly colored first few lines at the top of the display.
    It all points to a major malfunction. Unfortunately, the warranty expired 3 months ago...
    Regards,
    mh

  • 4gen ipod touch typing problem.

    Hey guys new user thanks for having me onboard. Just recently having a new problem that i never ever had before dont know if its a ios 6.1.2 update or what but then again just had this problem today and i updated when it came out and never had a problem until today the problem is on my 4 gen ipod touch is that when i try to type in the searching for a song in music or goog on safari or in a app when i start typing the first letter in like the letter t it would type in like 2 or more letters more than my first letter punch and when i try to use backspace it doesn't work whatsoever and i'm 100 % positive that i didn't do anything to the screen so i typed iso 6.1.2 typing problems on another computer and couldn't find anything and was wondering if anyone else has this same problem and no how to fix or what not any help would be greatly appreciated thanks again.
                                      BTW already restored it andsame thing happens.

    Yes, I type in the phone number, I also tried their apple ID or email address and I put in a message. The Send button would not highlight. I'm trying to send a message to 1 particular person who has an Iphone 6. However, I sent one to my Iphone 6 and it worked so I don't think there is a difference in the software. I know this is an older gen ipod but it says it's up to date.

  • Keyboard typing errors

    My recently purchased HP laptop frequently introduces keyboard typing errors.  The cursor will jump to different locations while typing, will introduce unrequested commands, such as erasing, jumping to different pages, etc. I have turned off the fingerpad and the errors continue.  Is there a cure?
    Pavilion dv7t-6c00 CTO Quad Edition Entertainment Notebook PC
    Product Number:
    A1L69AV
    [Personal Information Removed]

    Try this  - Reset the iPad by holding down on the Sleep and Home buttons at the same time for about 10-15 seconds until the Apple Logo appears - ignore the red slider - let go of the buttons. (This is equivalent to rebooting your computer.) No data/files will be erased.
    Frozen or unresponsive iPad
    Resolve these most common issues:
        •    Display remains black or blank
        •    Touch screen not responding
        •    Application unexpectedly closes or freezes
    http://www.apple.com/support/ipad/assistant/ipad/
    iPad Frozen, not responding, how to fix
    http://appletoolbox.com/2012/07/ipad-frozen-not-responding-how-to-fix/
    iPad Frozen? How to Force Quit an App, Reset or Restart Your iPad
    http://ipadacademy.com/2010/11/ipad-frozen-how-to-force-quit-an-app-reset-or-res tart-your-ipad
    Black or Blank Screen on iPad or iPhone
    http://appletoolbox.com/2012/10/black-or-blank-screen-on-ipad-or-iphone/
    What to Do When Your iPad Won't Turn On
    http://ipad.about.com/od/iPad_Troubleshooting/ss/What-To-Do-When-Your-Ipad-Wo-No t-Turn-On.htm
    iOS: Not responding or does not turn on
    http://support.apple.com/kb/TS3281
    Home button not working or unresponsive, fix
    http://appletoolbox.com/2013/04/home-button-not-working-or-unresponsive-fix/
    Fixing an iPad Home Button
    http://tinyurl.com/om6rd6u
    iPad: Basic troubleshooting
    http://support.apple.com/kb/TS3274
     Cheers, Tom

  • Why do Some letters on macbook Keyboard typing other characters?

    Why do Some letters on macbook Keyboard typing other characters?

    This happened to me it was due to the fact that my logic borard had corrosion damage. what Letter types what? It could be you keyboard language. is set to a different on then they layout. For expample your keyboard is QWERTY and its set to AZERTY.

  • Monitor sensor stopped responding alerts and typing problems with external keyboard.

    The past few days I have been getting these alerts. Also, I use my MacBook as a desktop about 60% of the time and like to hook up a full size keyboard. It's worked fine for two years but now I can only type a few words before there is a stall and I can't type anything for 30 seconds. It has happened on both a Kensington keyboard and on a 10-year-old iMac keyboard. They have both worked perfect in the past. Also, both work just fine on an old iBook and on an old iMac slot loader.

    Rudegar wrote:...
    held down the button on the back the on/off button and closed and started it again and all was well again
    try it
    Thanks, Rudegar, for the suggestion. 
    But as I said above, "Mr H, with the magic touch, went to the iMac - opened a new text edit doc and started typing - no problem, opened Google - typed into search field - no problem..." which is to say the problem has solved itself by just regrouping itself after all peripherals were detatched and HDs no longer involved?  We'll see if it reproduces itself next time I do this HD-HD copy.
    I don't know why it's fixed, but since all is well, the permissions are repaired, and I've put it to sleep and awakened it, and it's still running fine (indeed I'm typing on the iMac now), I am loathe to do anything to solve a problem that seems to no longer exist.
    If things go awry I will first try a restart or perhaps just shut down from the Apple menu.  As I said I was worried about doing this fearing I'd have to log in and not be able to do it - but the auto login setting works to my advantage here.
    Anyone else have any ideas on what went wrong???
    Thanks again,
    Mrs H

  • Typing problem - NOT a faulty keyboard. letters I type don't match.

    I have a powermac G5. The oddest thing just started with my keyboard. The letters that I am typing don't match. That is, typing "m" reveals a comma, z shows up on screen as w, and w as a z and several other keystrokes are "wrong" as well. There seems to be no rhyme or reason. I checked preferences but everything looks fine. There was no liquids involved. I have rebooted. I plugged in the keyboard from my G4 and the same problem occurs. It happens in Word, emails, Facebook, just anytime I type regardless of application.  Several keys do work properly. Any clues??

    I'd look at
    apple icon > system preferences > international
    look under input tab.
    See what country is set for keyboard
    apple icon > system preferences > keyboard and mouse
    see if shortcuts got very messed up
    Try
    Try a safe boot.
         Shutdown your machine.  Hold down the shift key.  Poweron.  Wait awhile Wait awhile while you harddrive
           is being checked.
         http://support.apple.com/kb/ht1455

  • How to enable an apple french (azerty) wireless keyboard to type in french whilst retaining the normal inbuilt qwerty keyboard typing in english?

    Hi there, I recently bought an apple wireless azerty French keyboard to go with my English macbook air, as for my degree I often have to type in French. However, upon connecting it to the macbook air it instantly started typing as though it had the qwerty layout and only by going on system preferences and changing the language & text imput sources to French was I able to get it to type in the correct azerty manner.
    The problem I have is that this also changed my macbook's inbuilt qwerty keyboard to the azerty format, and so I wondered if anyone could tell me how I can make the wireless azerty keyboard instantly be recognised as typing in the french format when I turn it on, whilst retaining my inbuilt keyboard's qwerty layout, rather than constantly having to change them both in system preferences?
    Any help would be greatly appreciated!
    Anna

    AnnaW-S wrote:
    I wondered if anyone could tell me how I can make the wireless azerty keyboard instantly be recognised as typing in the french format when I turn it on
    That's not possible.
    But switching keyboard layouts is very simple.  Either use the "flag" menu at the top right of the screen or the keyboard shortcut apple/command plus space.
    If you don't see the ¨flag¨, check the box for Show Input Menu in Menu Bar in the Input Sources pane.
    If the keyboard shortcut doesn´t work, you may have to change the shortcut for Spotlight, which is often the same.

  • Language typing problem

    There was a bangla phonetic typing font named Bangla - onkur in OS 10.8. This is not available in 10.9. How can I get it back. I badly need it. Please help.

    PS  I would be curious to know whether the keyboard provided by Apple called Bangla QWERTY has problems which make you want to install a different one:

Maybe you are looking for

  • How to update XML file through UCCX script ?

    Hi, I have an UCCX script with MENU step. One of the step is for technical support team. When caller chose this step, information about date and time of the call and calling number should be recorded on a XML file located on the web server. This XML

  • Flat-File MA accented character conversion

    Hello, we are using FIM 2010 R2 SP1 (4.1.3599) with a flat file MA to import/sync a csv flat-file generated by a HR system. We are using UTF-8 code page. The HR system has many international people in it, so there are many accented or diacritic chara

  • Fire fox says my printer is not on when it is

    I can not print from a fire fox web site because it says my printer is not connected. When I get on the same webb site in internet explorer I have no problem with printing the information. My printer is connected by wifii. it is s Canon MX870

  • IDCS3 Can't import frt files

    I've been trying to import .rtf files without success into IDCS3. I've only recently switched to InDesign from Quark, so have no idea what to change in preferences etc. I've tried importing with the "show import options" on and off but it doesn't see

  • Liquid Analytics enables the sales force in real-time

    Problem The success of wholesale and manufacturing distribution operations largely hinges on the efficacy of sales teams that must deal with a host of pricing and product challenges. For the sales group, the biggest game changer is their ability to a


HashFlare