Problems with a simple Midlet

Hi , i'm trying to run a simple Midlet with a list, but appear the following errors:
Error running executable C:\WTK22\bin\zayit
java.net.SocketException: No buffer space available (maximum connections reached?): JVM_Bind
     at java.net.PlainSocketImpl.socketBind(Native Method)
     at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:359)
     at java.net.ServerSocket.bind(ServerSocket.java:319)
     at java.net.ServerSocket.<init>(ServerSocket.java:185)
     at java.net.ServerSocket.<init>(ServerSocket.java:97)
     at com.sun.kvem.Lime.runClient(Unknown Source)
     at com.sun.kvem.KVMBridge.runKVM(Unknown Source)
     at com.sun.kvem.KVMBridge.runKVM(Unknown Source)
     at com.sun.kvem.midp.MIDP$4.run(Unknown Source)
the code of the Midlet is so simple and i don't know what happen.
i hope that you can help me
thanks

the code is:
package componentes;
import javax.microedition.lcdui.*;
import javax.microedition.midlet.*;
public class InterfazMid extends MIDlet implements CommandListener {
private Display display;
private List menu;
private List lista;
private TextBox cajaTexto;
private Form form;
private DateField campoFecha;
private Gauge indicador;
private TextField campoTexto;
private Ticker ticker;
private Alert aviso;
private Image imagen;
private Command atras;
private Command menuPrincipal;
private Command salir;
String menuActual = null;
public InterfazMid() {
form = new Form( "Formulario" );
indicador = new Gauge( "Indicador",false,50,20 );
campoTexto = new TextField( "Campo de texto","abc",40,0 );
ticker = new Ticker( "Componentes de la intefaz MIDP" );
aviso = new Alert( "Aviso Sonoro" );
imagen = Image.createImage( "/error.png" );
} catch( Exception e ) {}
atras = new Command( "Atr�s",Command.BACK,0 );
menuPrincipal = new Command( "Men� Ppal",Command.SCREEN,1 );
salir = new Command( "Salir",Command.STOP,2 );
protected void startApp() {
display = Display.getDisplay( this );
menu = new List( "Interfaz MIDP",Choice.IMPLICIT );
menu.append( "Caja de texto",null );
menu.append( "Fecha",null );
menu.append( "Lista",null );
menu.append( "Aviso",null );
menu.append( "Formulario",null );
menu.addCommand( salir );
menu.setCommandListener( this );
menu.setTicker( ticker );
mainMenu();
protected void pauseApp() {}
protected void destroyApp( boolean flag ) {}
public void mainMenu() {
menuActual = "Men� Ppal";
display.setCurrent( menu );
public void testTextBox() {
cajaTexto = new TextBox( "Teclea algo:","",10,TextField.ANY );
cajaTexto.setTicker( new Ticker("Probando TextBox") );
cajaTexto.addCommand( atras );
cajaTexto.setCommandListener( this );
cajaTexto.setString( "ABC" );
display.setCurrent( cajaTexto );
menuActual = "texto";
public void testList() {
lista = new List( "Seleciona:",Choice.MULTIPLE );
lista.setTicker( new Ticker("Probando List") );
lista.addCommand( atras );
lista.setCommandListener( this );
lista.append( "Opci�n 1",null );
lista.append( "Opci�n 2",null );
lista.append( "Opci�n 3",null );
lista.append( "Opci�n 4",null );
display.setCurrent(lista);
menuActual = "lista";
public void testAlert() {
aviso.setType( AlertType.ERROR );
aviso.setImage( imagen );
aviso.setString( " ** ERROR **" );
display.setCurrent( aviso );
public void testDate() {
java.util.Date fecha = new java.util.Date();
campoFecha = new DateField( "Hoy es: ",DateField.DATE );
campoFecha.setDate( fecha );
Form f = new Form( "Fecha" );
f.append( campoFecha );
f.addCommand( atras );
f.setCommandListener( this );
display.setCurrent( f );
menuActual = "fecha";
public void testForm() {
form.append( campoTexto );
form.append( indicador );
form.addCommand( atras );
form.setCommandListener( this );
display.setCurrent( form );
menuActual = "form";
public void commandAction( Command c,Displayable d ) {
String label = c.getLabel();
if( label.equals("Salir") ) {
destroyApp( true );
notifyDestroyed();
else if (label.equals("Atr�s")) {
if( menuActual.equals( "lista" ) ||
menuActual.equals( "texto" ) ||
menuActual.equals( "fecha" ) ||
menuActual.equals( "form" ) ) {
mainMenu();
else {
List l = (List)display.getCurrent();
switch( l.getSelectedIndex() ) {
case 0:
testTextBox();
break;
case 1:
testDate();
break;
case 2:
testList();
break;
case 3:
testAlert();
break;
case 4:
testForm();
break;
the code is so simple. i think that the problem is on the j2me wirless toolkit but i don't know.
thank you
bye

Similar Messages

  • Problems with a simple stop watch program

    I would appreciate help sorting out a problem with a simple stop watch program. The problem is that it throws up inappropriate values. For example, the first time I ran it today it showed the best time at 19 seconds before the actual time had reached 2 seconds. I restarted the program and it ran correctly until about the thirtieth time I started it again when it was going okay until the display suddenly changed to something like '-50:31:30:50-'. I don't have screenshot because I had twenty thirteen year olds suddenly yelling at me that it was wrong. I clicked 'Stop' and then 'Start' again and it ran correctly.
    I have posted the whole code (minus the GUI section) because I want you to see that the program is very, very simple. I can't see where it could go wrong. I would appreciate any hints.
    public class StopWatch extends javax.swing.JFrame implements Runnable {
        int startTime, stopTime, totalTime, bestTime;
        private volatile Thread myThread = null;
        /** Creates new form StopWatch */
        public StopWatch() {
         startTime = 0;
         stopTime = 0;
         totalTime = 0;
         bestTime = 0;
         initComponents();
        public void run() {
         Thread thisThread = Thread.currentThread();
         while(myThread == thisThread) {
             try {
              Thread.sleep(100);
              getEnd();
             } catch (InterruptedException e) {}
        public void start() {
         if(myThread == null) {
             myThread = new Thread(this);
             myThread.start();
        public void getStart() {
         Calendar now = Calendar.getInstance();
         startTime = (now.get(Calendar.MINUTE) * 60) + now.get(Calendar.SECOND);
        public void getEnd() {
         Calendar now1 = Calendar.getInstance();
         stopTime = (now1.get(Calendar.MINUTE) * 60) + now1.get(Calendar.SECOND);
         totalTime = stopTime - startTime;
         setLabel();
         if(bestTime < totalTime) bestTime = totalTime;
        public void setLabel() {
         if((totalTime % 60) < 10) {
             jLabel1.setText(""+totalTime/60+ ":0"+(totalTime % 60));
         } else {
             jLabel1.setText(""+totalTime/60 + ":"+(totalTime % 60));
         if((bestTime % 60) < 10) {
             jLabel3.setText(""+bestTime/60+ ":0"+(bestTime % 60));
         } else {
             jLabel3.setText(""+bestTime/60 + ":"+(bestTime % 60));
        private void ButtonClicked(java.awt.event.ActionEvent evt) {                              
         JButton temp = (JButton) evt.getSource();
         if(temp.equals(jButton1)) {
             start();
             getStart();
         if(temp.equals(jButton2)) {
             getEnd();
             myThread = null;
         * @param args the command line arguments
        public static void main(String args[]) {
         java.awt.EventQueue.invokeLater(new Runnable() {
             public void run() {
              new StopWatch().setVisible(true);
        // Variables declaration - do not modify                    
        private javax.swing.JButton jButton1;
        private javax.swing.JButton jButton2;
        private javax.swing.JLabel jLabel1;
        private javax.swing.JLabel jLabel2;
        private javax.swing.JLabel jLabel3;
        private javax.swing.JPanel jPanel1;
        // End of variables declaration                  
    }

    Although I appreciate this information, it still doesn't actually solve the problem. I can't see an error in the logic (or the code). The fact that the formatting works most of the time suggests that the problem does not lie there. As well, I use the same basic code for other time related displays e.g. countdown timers where the user sets a maximum time and the computer stops when zero is reached. I haven't had an error is these programs.
    For me, it is such a simple program and the room for errors seem small. I am guessing that I have misunderstood something about dates, but I obviously don't know.
    Again, thank you for taking the time to look at the problem and post a reply.

  • Problem with running the midlet class (Error with Installation suite )

    hi everyone...
    i have problem with running the midlet class(BluetoothChatMIDlet.java)
    it keep showing me the same kind of error in the output pane of netbeans...
    which is:
    Installing suite from: http://127.0.0.1:49296/Chat.jad
    [WARN] [rms     ] javacall_file_open: wopen failed for: C:\Users\user\javame-sdk\3.0\work\0\appdb\delete_notify.dat
    i also did some research on this but due to lack of forum that discussing about this,im end up no where..
    from my research i also find out that some of the developer make a changes in class properties..
    where they check the SIGN DISTRIBUTION...and also change the ALIAS to UNTRUSTED..after that,click the EXPORT KEY INTO JAVA ME SDK,PLATFORM,EMULATOR...
    i did that but also didnt work out..
    could any1 teach me how to fix it...
    thanx in advance... :)

    actually, i do my FYP on bluetooth chatting...
    and there will be more than two emulators running at the same time..
    one of my frens said that if u want to run more than one emulator u just simply click on run button..
    and it will appear on the screen..

  • Problem with a simple GRE tunnel

    Hello everyone:
    I have a problem with a simple GRE tunnel, and can not make it work, the problem lies in the instruction "tunnel source loopback-0" if I use this command does not work, now if I use "tunnel source <ip wan >" if it works, someone can tell me why?
    Thanks for your help
    Router 1: 2811
    version 12.4
    no service password-encryption
    hostname cisco2811
    no aaa new-model
    ip cef
    interface Loopback0
    ip address 2.2.2.2 255.255.255.255
    interface Tunnel0
    ip address 10.10.1.1 255.255.255.0
    tunnel source Loopback0
    tunnel destination 217.127.XXX.188
    interface Tunnel1
    ip address 10.10.2.1 255.255.255.0
    tunnel source Loopback0
    tunnel destination 80.32.XXX.125
    interface FastEthernet0/0
    description LOCAL LAN Interface
    ip address 192.168.1.254 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    duplex auto
    speed auto
    interface FastEthernet0/1
    description WAN Interface
    ip address 195.77.XXX.70 255.255.255.248
    ip nat outside
    ip virtual-reassembly
    duplex auto
    speed auto
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 195.77.XXX.65
    ip route 192.168.3.0 255.255.255.0 Tunnel0
    ip route 192.168.4.0 255.255.255.0 Tunnel1
    ip nat inside source route-map salida-fibra interface FastEthernet0/1 overload
    access-list 120 deny ip 192.168.1.0 0.0.0.255 192.168.3.0 0.0.0.255
    access-list 120 deny ip 192.168.1.0 0.0.0.255 192.168.4.0 0.0.0.255
    access-list 120 permit ip 192.168.1.0 0.0.0.255 any
    route-map salida-fibra permit 10
    match ip address 120
    Router 2: 2811
    version 12.4
    service password-encryption
    ip cef
    no ip domain lookup
    multilink bundle-name authenticated
    username admin privilege 15 password 7 104CXXXXx13
    interface Loopback0
    ip address 4.4.4.4 255.255.255.255
    interface Tunnel0
    ip address 10.10.1.2 255.255.255.0
    tunnel source Loopback0
    tunnel destination 195.77.XXX.70
    interface Ethernet0
    ip address 192.168.3.251 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    hold-queue 100 out
    interface ATM0
    no ip address
    no ip route-cache cef
    no ip route-cache
    no atm ilmi-keepalive
    dsl operating-mode auto
    interface ATM0.1 point-to-point
    ip address 217.127.XXX.188 255.255.255.192
    ip nat outside
    ip virtual-reassembly
    no ip route-cache
    no snmp trap link-status
    pvc 8/32
    encapsulation aal5snap
    ip route 0.0.0.0 0.0.0.0 ATM0.1
    ip route 192.168.1.0 255.255.255.0 Tunnel0
    ip nat inside source route-map nonat interface ATM0.1 overload
    access-list 100 permit ip 192.168.3.0 0.0.0.255 192.168.1.0 0.0.0.255
    access-list 120 deny ip 192.168.3.0 0.0.0.255 192.168.1.0 0.0.0.255
    access-list 120 permit ip 192.168.3.0 0.0.0.255 any
    route-map nonat permit 10
    match ip address 120

    Hello, thank you for the answer, as to your question, I have no connectivity within the tunnel, whether from Router 1, I ping 10.10.1.2 not get response ...
    Now both routers remove the loopback, and the interface tunnel 0 change the tunnel source to "tunnel source " tunnel works perfectly, the problem is when I have to use the loopback. Unfortunately achieved when the tunnel work, this will have to endure multicast, and all the examples found carrying a loopback as' source '... but this is a step back ..
    Tunnel0 is up, line protocol is up
    Hardware is Tunnel
    Internet address is 10.10.1.1/24
    MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation TUNNEL, loopback not set
    Keepalive not set
    Tunnel source 2.2.2.2 (Loopback0), destination 217.127.XXX.188
    Tunnel protocol/transport GRE/IP
    Key disabled, sequencing disabled
    Checksumming of packets disabled
    Tunnel TTL 255
    Fast tunneling enabled
    Tunnel transmit bandwidth 8000 (kbps)
    Tunnel receive bandwidth 8000 (kbps)
    Last input 09:04:38, output 00:00:19, output hang never
    Last clearing of "show interface" counters never
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: fifo
    Output queue: 0/0 (size/max)
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    0 packets input, 0 bytes, 0 no buffer
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
    11101 packets output, 773420 bytes, 0 underruns
    0 output errors, 0 collisions, 0 interface resets
    0 unknown protocol drops
    0 output buffer failures, 0 output buffers swapped out

  • Problem with XI simple scinario

    Hi Friends,
    I am new in XI, I am working on simple xi scenario. whn i create sales order i wan to send order confirmation . for that i am using ORDRSP. I had done all the ale settings and able to generaet idoc and send it to XI . Now the problem is that,once the idoc is sent from R/3 system, on the XI system I am not able to see it in transaction SXMB_MONI. I am able to c that idoc in transaction WE02,with error in XI system.
    So please let me knw,how to solve this.
    Regards,
    Brij.....

    hi,
    plz once check in idx5 in xi server..
    if u r able to see u r idoc in that then u can confirm u er IDOC reached to XI server..
    if  IDOC is not there in IDX5, plz do check in RFC destination remote connection, if u get the EASY ACCESS MENU of the XI system, then RFC destination is fine.
    and once check port and partner profile also....
    if u check all these things.. hope u r problem will be solved.
    Thanks,
    Madhav
    Note:Points if useful

  • Problem with a simple Crystal 10 report

    Help please!!
    I am writing what should be a simple report in Crystal 10 which is acting oddly.
    The report is built on 3 tables which sit on a SQL database and are linked through ODBC views. The tables are property, referral and incident and the property table is the one that exists in all cases. All three have a Property ID and the other two tables are linked to the property table through two full outer join connections. A property can have a referral or an incident or both.
    I just want to create a report which lists all the unique properties which have a referral or an incident which has been created within a particular timescale.
    The filter I am using is:
    {est_property.est_address_postalcode} = "AB12 5NX" and
    (({est_referral.CreatedOn}>={?Start date}) and ({est_referral.CreatedOn}<={?End date}))
    or
    (({Incident.CreatedOn}>={?Start date})and ( {Incident.CreatedOn}<={?End date} ))
    Note the 'AB12 5NX' bit is just to speed the testing process up as the databases that I am querying are large.
    The version I am running is 10.0.0.533 although I am currently (very slowly) downloading SP6.
    Thanks,
    John

    I have made some progress on this. I think the problem is because the filter fails when the tables it is querying have Nulls in them.
    I have just tried building the filter again with an "if the 'created on' field in the referral table is NULL then just query on the incident table" type of query:
    if isnull({est_referral.CreatedOn})=FALSE then
        {est_property.est_address_postalcode} = "AB12 5NX" and
        ({?Start date}<={est_referral.CreatedOn} and {est_referral.CreatedOn}<={?End date})
        or
        {est_property.est_address_postalcode} = "AB12 5NX" and
        ({?Start date}<={Incident.CreatedOn}and {Incident.CreatedOn}<={?End date} )
    else
        {est_property.est_address_postalcode} = "AB12 5NX" and
        ({?Start date}<={Incident.CreatedOn}and {Incident.CreatedOn}<={?End date} )
    This seems to work but seems to be very heavy on the processing. It would also require a very complex bit of coding when I start building the proper query which actually requires four sub-tables to be queried rather than ust two!
    So still help required!
    Thanks.

  • Performance problem with relatively simple query

    Hi, I've a statement that takes over 20s. It should take 3s or less. The statistics are up te date so I created an explain plan and tkprof. However, I don't see the problem. Maybe somebody can help me with this?
    explain plan
    SQL Statement which produced this data:
      select * from table(dbms_xplan.display)
    PLAN_TABLE_OUTPUT
    | Id  | Operation               |  Name              | Rows  | Bytes |TempSpc| Cost  |
    |   0 | SELECT STATEMENT        |                    | 16718 |   669K|       | 22254 |
    |   1 |  SORT UNIQUE            |                    | 16718 |   669K|    26M| 22254 |
    |   2 |   FILTER                |                    |       |       |       |       |
    |*  3 |    HASH JOIN            |                    |   507K|    19M|       |  9139 |
    |   4 |     TABLE ACCESS FULL   | PLATE              | 16718 |   212K|       |    19 |
    |*  5 |     HASH JOIN           |                    |   507K|    13M|  6760K|  8683 |
    |*  6 |      HASH JOIN          |                    |   216K|  4223K|       |  1873 |
    |*  7 |       TABLE ACCESS FULL | SDG_USER           |  1007 |  6042 |       |     5 |
    |*  8 |       HASH JOIN         |                    |   844K|    11M|       |  1840 |
    |*  9 |        TABLE ACCESS FULL| SDG                |  3931 | 23586 |       |     8 |
    |  10 |        TABLE ACCESS FULL| SAMPLE             |   864K|  6757K|       |  1767 |
    |* 11 |      TABLE ACCESS FULL  | ALIQUOT            |  2031K|    15M|       |  5645 |
    |  12 |    INDEX UNIQUE SCAN    | PK_OPERATOR_GROUP  |     1 |     5 |       |       |
    |  13 |    INDEX UNIQUE SCAN    | PK_OPERATOR_GROUP  |     1 |     5 |       |       |
    |  14 |    INDEX UNIQUE SCAN    | PK_OPERATOR_GROUP  |     1 |     5 |       |       |
    |  15 |    INDEX UNIQUE SCAN    | PK_OPERATOR_GROUP  |     1 |     5 |       |       |
    Predicate Information (identified by operation id):
       3 - access("SYS_ALIAS_2"."PLATE_ID"="SYS_ALIAS_1"."PLATE_ID")
       5 - access("SYS_ALIAS_3"."SAMPLE_ID"="SYS_ALIAS_2"."SAMPLE_ID")
       6 - access("SYS_ALIAS_4"."SDG_ID"="SDG_USER"."SDG_ID")
       7 - filter("SDG_USER"."U_CLIENT_TYPE"='QC')
       8 - access("SYS_ALIAS_4"."SDG_ID"="SYS_ALIAS_3"."SDG_ID")
       9 - filter("SYS_ALIAS_4"."STATUS"='C' OR "SYS_ALIAS_4"."STATUS"='P' OR "SYS_ALIA
                  S_4"."STATUS"='V')
      11 - filter("SYS_ALIAS_2"."PLATE_ID" IS NOT NULL)
    Note: cpu costing is off
    tkprof
    TKPROF: Release 9.2.0.1.0 - Production on Mon Sep 22 11:09:37 2008
    Copyright (c) 1982, 2002, Oracle Corporation.  All rights reserved.
    Trace file: d:\oracle\admin\nautp\udump\nautp_ora_5708.trc
    Sort options: default
    count    = number of times OCI procedure was executed
    cpu      = cpu time in seconds executing
    elapsed  = elapsed time in seconds executing
    disk     = number of physical reads of buffers from disk
    query    = number of buffers gotten for consistent read
    current  = number of buffers gotten in current mode (usually for update)
    rows     = number of rows processed by the fetch or execute call
    alter session set sql_trace true
    call     count       cpu    elapsed       disk      query    current        rows
    Parse        0      0.00       0.00          0          0          0           0
    Execute      1      0.00       0.00          0          0          0           0
    Fetch        0      0.00       0.00          0          0          0           0
    total        1      0.00       0.00          0          0          0           0
    Misses in library cache during parse: 0
    Misses in library cache during execute: 1
    Optimizer goal: CHOOSE
    Parsing user id: 61 
    SELECT distinct p.name
    FROM lims_sys.sdg sd, lims_sys.sdg_user sdu, lims_sys.sample sa, lims_sys.aliquot a, lims_sys.plate p
    WHERE sd.sdg_id = sdu.sdg_id
    AND sd.sdg_id = sa.sdg_id
    AND sa.sample_id = a.sample_id
    AND a.plate_id = p.plate_id
    AND sd.status IN ('V','P','C')
    AND sdu.u_client_type = 'QC'
    call     count       cpu    elapsed       disk      query    current        rows
    Parse        1      0.09       0.09          0          3          0           0
    Execute      1      0.00       0.00          0          0          0           0
    Fetch        1      7.67      24.63      66191      78732          0         500
    total        3      7.76      24.72      66191      78735          0         500
    Misses in library cache during parse: 1
    Optimizer goal: CHOOSE
    Parsing user id: 61 
    Rows     Row Source Operation
        500  SORT UNIQUE
    520358   FILTER 
    520358    HASH JOIN 
      16757     TABLE ACCESS FULL PLATE
    520358     HASH JOIN 
    196632      HASH JOIN 
       2402       TABLE ACCESS FULL SDG_USER
    834055       HASH JOIN 
       3931        TABLE ACCESS FULL SDG
    864985        TABLE ACCESS FULL SAMPLE
    2037373      TABLE ACCESS FULL ALIQUOT
          0    INDEX UNIQUE SCAN PK_OPERATOR_GROUP (object id 33865)
          0    INDEX UNIQUE SCAN PK_OPERATOR_GROUP (object id 33865)
          0    INDEX UNIQUE SCAN PK_OPERATOR_GROUP (object id 33865)
          0    INDEX UNIQUE SCAN PK_OPERATOR_GROUP (object id 33865)
    select 'x'
    from
    dual
    call     count       cpu    elapsed       disk      query    current        rows
    Parse        1      0.00       0.00          0          0          0           0
    Execute      1      0.00       0.00          0          0          0           0
    Fetch        1      0.00       0.00          0          3          0           1
    total        3      0.00       0.00          0          3          0           1
    Misses in library cache during parse: 1
    Optimizer goal: CHOOSE
    Parsing user id: 61 
    Rows     Row Source Operation
          1  TABLE ACCESS FULL DUAL
    begin :id := sys.dbms_transaction.local_transaction_id; end;
    call     count       cpu    elapsed       disk      query    current        rows
    Parse        1      0.00       0.00          0          0          0           0
    Execute      1      0.00       0.00          0         12          0           1
    Fetch        0      0.00       0.00          0          0          0           0
    total        2      0.00       0.00          0         12          0           1
    Misses in library cache during parse: 1
    Optimizer goal: CHOOSE
    Parsing user id: 61 
    OVERALL TOTALS FOR ALL NON-RECURSIVE STATEMENTS
    call     count       cpu    elapsed       disk      query    current        rows
    Parse        3      0.09       0.09          0          3          0           0
    Execute      4      0.00       0.00          0         12          0           1
    Fetch        2      7.67      24.63      66191      78735          0         501
    total        9      7.76      24.72      66191      78750          0         502
    Misses in library cache during parse: 3
    Misses in library cache during execute: 1
    OVERALL TOTALS FOR ALL RECURSIVE STATEMENTS
    call     count       cpu    elapsed       disk      query    current        rows
    Parse       48      0.00       0.00          0          0          0           0
    Execute     54      0.00       0.01          0          0          0           0
    Fetch       65      0.00       0.00          0        157          0          58
    total      167      0.00       0.01          0        157          0          58
    Misses in library cache during parse: 16
        4  user  SQL statements in session.
       48  internal SQL statements in session.
       52  SQL statements in session.
    Trace file: d:\oracle\admin\nautp\udump\nautp_ora_5708.trc
    Trace file compatibility: 9.00.01
    Sort options: default
           1  session in tracefile.
           4  user  SQL statements in trace file.
          48  internal SQL statements in trace file.
          52  SQL statements in trace file.
          20  unique SQL statements in trace file.
         500  lines in trace file.Edited by: RZ on Sep 22, 2008 2:27 AM

    A few notes:
    1. You seem to have either a VPD policy active or you're using views that add some more predicates to the query, according to the plan posted (the access on the PK_OPERATOR_GROUP index). Could this make any difference?
    2. The estimates of the optimizer are really very accurate - actually astonishing - compared to the tkprof output, so the optimizer seems to have a very good picture of the cardinalities and therefore the plan should be reasonable.
    3. Did you gather index statistics as well (using COMPUTE STATISTICS when creating the index or "cascade=>true" option) when gathering the statistics? I assume you're on 9i, not 10g according to the plan and tkprof output.
    4. Looking at the amount of data that needs to be processed it is unlikely that this query takes only 3 seconds, the 20 seconds seems to be OK.
    If you are sure that for a similar amount of underlying data the query took only 3 seconds in the past it would be very useful if you - by any chance - have an execution plan at hand of that "3 seconds" execution.
    One thing that I could imagine is that due to the monthly data growth that you've mentioned one or more of the tables have exceeded the "2% of the buffer cache" threshold and therefore are no longer treated as "small tables" in the buffer cache. This could explain that you now have more physical reads than in the past and therefore the query takes longer to execute than before.
    I think that this query could only be executed in 3 seconds if it is somewhere using a predicate that is more selective and could benefit from an indexed access path.
    Regards,
    Randolf
    Oracle related stuff blog:
    http://oracle-randolf.blogspot.com/
    SQLTools++ for Oracle (Open source Oracle GUI for Windows):
    http://www.sqltools-plusplus.org:7676/
    http://sourceforge.net/projects/sqlt-pp/

  • Basic (and I mean basic) java problem with a simple hello world script

    I have a simple cut-and-paste html page and java class in my /home/jc158027/java directory.
    jc158027> cat HelloWorld.java
    import java.applet.*;
    import java.awt.*;
    public class HelloWorld extends Applet{
    Label helloLabel = new Label ("Hello World");
    public void init () {
      setBackground (Color.yellow);
      add (helloLabel);
    }Ok, so I javac HelloWorld.java and get HelloWorld.class, so far so good.
    Next I create my html page:
    jc158027> cat hw.html
    <HTML>
    <HEAD>
    <TITLE>Jay's Java Test Page</TITLE>
    <BODY>
    <HR>
    This line of text comes before the applet.<P>
    <APPLET CODE = 'HelloWorld.class" WIDTH=500 Height=90>
    </APPLET>
    <P>
    This line of text comes after the applet.
    </BODY>
    </HTML>The result is that the text lines work, I get a nice grey box with no applet running. Looking at my console I get the following error:
    Caused by: java.io.FileNotFoundException: /home/jc158027/java/HelloWorld/class".class (No such file or directory)
    What I don't understand is the HelloWorld/class".class portion, shouldn't it be just either HelloWorld".class or HelloWorld/class, it is as though it is trying to look in a directory (class) that does not exist.
    What am I missing here?

    And if you put dots in where it expects a class name, it assumes those dots are to separate levels in a package name.
    So it was looking for a class named "class", which would be in a file called class.class, in a package named "HelloWorld". Packages correspond to directories relative to some classpath root, so it looked for the directory HelloWorld to be the parent of the classes in the HelloWorld package.

  • Problem with very simple 2 threads java application

    Hi,
    As fa as i'm concerned this is a thread licecycle:
    1. thread created: it is dead.
    2. thread started: it is now alive.
    3. thread executes its run method: it is alive during this method.
    4. after thread finishes its run method: it is dead.
    No I have simple JUnit code:
    public void testThreads() throws Exception {
    WorkTest work = new WorkTest() {
    public void release() {
    // TODO Auto-generated method stub
    public void run() {
    for (int i=0;i<1000;i++){
    log.debug(i+":11111111111");
    //System.out.println(i+":11111111111");
    WorkTest work2 = new WorkTest() {
    public void release() {
    // TODO Auto-generated method stub
    public void run() {
    for (int i=0;i<1000;i++){
    log.debug(i+":22222222222");
    Thread workerThread = new Thread(work);
    Thread workerThread2 = new Thread(work2);
    workerThread.start();
    //workerThread.join();
    workerThread2.start();
    //workerThread2.join();
    And
    public interface WorkTest extends Runnable {
    public abstract void release();
    And that's it..
    On the console I see 999 iterations of both threads only if i uncomment
    //workerThread.join();
    //workerThread2.join();
    In other case I see random number of iterations - JUNIT finishes and Thread1 made 54 and Thread2 233 iterations - the numbers are different every time i start the JUnit..
    What I want? Not to wait until the first one finishes - I want them to start at the same time and they must FINISH their tasks...
    Please help me asap :(

    This is very simple... Look at your code:
    workerThread.start();
    workerThread.join();
    workerThread2.start();
    workerThread2.join();What are you doing here? You start the first thread, then you call join(), which waits until it finishes. Then after it's finished, you start the second thread and wait until it finishes. You should simply do this:
    workerThread.start();
    workerThread2.start();
    workerThread.join();
    workerThread2.join();I.e., you start the 2 threads and then you wait (first for the first one, then for the second one).

  • Problem with getNodeValue() - simple Java XPath question

    I am trying to extract the node values from a XML file:
    <root>
      <frame>
         <boxes>
           <box>
              <spec>22</spec>
              <spec>2222</spec>
           </box>
           <box>
              <spec id="BA" value="short"/>
              <spec id="BB" value="thin"/>
              <spec id="BC" value="black"/>
              <spec id="BD" value="full"/>
              <spec id="BE" value="7"/>
              <spec id="BF" value="deactive"/>
           </box>                
         </boxes>
         <circles>
           <circle id="CA" value="blue"/>
           <circle id="CB" value="green"/>
         </circles>
      </frame>
    </root>I use this code:
             XPathFactory factory = XPathFactory.newInstance();
             XPath xpath = factory.newXPath();
             XPathExpression xPathExpression = xpath.compile("/root/frame/boxes/box/spec");            
             Object result = xPathExpression.evaluate(doc, XPathConstants.NODESET);
             NodeList nodes = (NodeList) result;
             for (int i = 0; i < nodes.getLength(); i++) {
                 System.out.println(nodes.item(i).getNodeValue());
             }But only:
    null
    null
    null
    null
    null
    null
    null
    null
    get printed. I would have assumed:
    22
    2222
    null
    null
    null
    null
    null
    null
    since the two first spec nodes contains the above numbers. Any ideas?

    change this:
    XPathExpression xPathExpression = xpath.compile("/root/frame/boxes/box/spec");to this:
    XPathExpression xPathExpression = xpath.compile("/root/frame/boxes/box/spec/text()");Need to xpath all the way down to the text of the node.
    You could use
    System.out.println(nodes.item(i).getTextContent());with your current xpath but if the spec node has children, these will also be included in the output.

  • Problem with a simple query

    Hey. I've got a table which contains only one entry:
    Table "users":
    id | date | user | pass | profile | last_logged
    1 | ... | evo | ... | ... | ...
    My query is: "SELECT * FROM users WHERE user=evo". The problem is that im always gettings a null pointer exception, but if I get the data by refering to the id (WHERE id=1) then it works! Why is this?
    I've got a login system which takes the username from the form and attempts to get the id corresponding to the user value. But it just won't work. help appreciated. Thanks.

    Is the user column of type string and evo a string value?
    Which database are you using?
    Don't you have to put single quotes around that?
    String query = "SELECT * FROM users WHERE user = 'evo'"MOD

  • Having Problems With a Simple Thing: ImageIcons

    this is part of my code:
    public void buildToolBar(){
    saveIcon = new ImageIcon("images/save.jpg");
    searchIcon = new ImageIcon("images/search.jpg");
    saveButton = new JButton(saveIcon);
    searchButton = new JButton(searchIcon);
    toolBar = new JToolBar();
    toolBar.setFloatable(false);
    toolBar.add(saveButton);
    toolBar.add(searchButton);
    i'm using NetBeans 5.5, and for some reason this doesn't work. the buttons show up in the toolbar but they do not have the images that i want in them. maybe i'm putting the images in the wrong directory?

    No size has got nothing to do with it. Troubleshooting, I would ask these questions:
    1. What image format are you using? Can Java read it?
    2. Double-check the file name and be careful with upper/lower case.
    3. Make sure it is in the directory you think it should ne in.
    Here's a quick app to see if Java can read and display the file:
    import java.io.*;
    import java.awt.event.*;
    import javax.swing.*;
    public class ImageView {
        public static void main(String[] args) {
            final JLabel label = new JLabel("", SwingConstants.CENTER);
            Action open = new AbstractAction("Open"){
                JFileChooser chooser = new JFileChooser();
                public void actionPerformed(ActionEvent evt) {
                    if (chooser.showOpenDialog(label) == JFileChooser.APPROVE_OPTION) {
                        label.setIcon(new ImageIcon(chooser.getSelectedFile().getPath()));
            JMenu menu = new JMenu("File");
            menu.add(open);
            JMenuBar bar = new JMenuBar();
            bar.add(menu);
            JFrame f = new JFrame("ImageView");
            f.setJMenuBar(bar);
            f.setDefaultCloseOperation(JFrame.EXIT_ON_CLOSE);
            f.getContentPane().add(new JScrollPane(label));
            f.setSize(600,400);
            f.setLocationRelativeTo(null);
            f.setVisible(true);
    }

  • I´m having problems with a simple synchronized move

    When using the "flex_start" function with the parameter AxisOrVectorSpace
    set as 0X00 (MULTIPLE_AXES), is it possible that some axes move ahead of the others or does the Flex Software secure the synchronization?
    I use motion controler 7344.

    Please allow me to clarify my previous statement. Vector spaces greatly simplify synchronized movement across multiple axes because the generated trajectory is done on the vector. It is possible to start and end the moves of multiple axes without using a vector space; however, you will have to use a multi-start and then calculate the appropriate move constraints for each axis that brings it to the end of travel with the other axes.
    The FlexMotion software will attempt to adhere to the calculated trajectory for each axis, and assuming these parameters are properly set such that all axes arrive at their end of travel at the same time, the axes should maintain synchronization. Factors such as one axis facing a significantly greater load than the others m
    ay cause that axis to temporarily get out of sync, but this should only be for one PID loop update period. If you are using a closed-loop stepper system and your motor is missing steps that axis may deviate from its calculated trajectory, and the FlexMotion software will try to compensate for this at the end of the movement by doing up to three pull-in moves.
    I hope this better answers your question. Best wishes!

  • Problem with calling a midlet within another midlet

    hello friends,
    can a create an instance of a midlet within another midlet.i tried to call , but i have got a Security exception. plz comment on this ..
    regards..

    "For security reasons, it is assumed that MIDlets within a MIDletSuite are packaged
    together for a reason and should be able to interoperate. What's implied here is that the
    MIDlets share a name space; in other words, each MIDlet in the MidletSuite can "see" one
    another. Because they can see one another, they can launch one another (Class.forName
    metaphor).
    In contrast, one MIDletSuite cannot launch another MIDletSuite. That's because they do not
    share name spaces. Since the CLDC+MIDP does not have a security manager (too big and
    complex for small devices), the MIDP expert group felt it more prudent to limit the interaction
    of downloaded applications to those that are packaged together by the provider."extract from Sun
    see http://developers.sun.com/mobility/midp/articles/pushreg/ for infos to launch MIDlets...

  • Little problem with a simple schematic

    I was trying the new Multisim 11 and so I decided to reproduce the schematic below, which I took from a book. It should be led flashing at intervals, but I can't get it to work. Can someone kindly tell me why it isn't working(flashing)?
    Message Edited by poldoj on 01-14-2010 06:59 PM
    Solved!
    Go to Solution.
    Attachments:
    Design1.zip ‏51 KB

    Hello Poldoj and Andrew. I agree with Andrew. It didn't work with 470 kOhm (the time is long, but nothing at all happens - even if you wait a long time). It seems that the simulation never reaches the flash-point. I lowered 470 kOhm to 220 kOhm and then it works. In the simulation, the LED will flash (briefly), but it will not discharge the 2.2 uF entirely. I added a 100 Ohm resistor in across the LED to discharge the capacitor more. It is easier to see what happens in the graph then, but is probably not needed in the real circuit. See the two graphs with and without the 100 Ohm.
    W.kr.
    Attachments:
    Design1_b.ms10 ‏61 KB
    Graph.jpg ‏162 KB
    Graph_wo_100.jpg ‏156 KB

Maybe you are looking for

  • Xml data source in db column?

    Hi everybody If I want to use XML data as data source for BI Publisher, can these data be stored in a database column or do I have to store the source data in XML files in a file system? If it can be stored in a db column - is there anything I need t

  • Missing image thumbnail/preview in finder?

    When scrolling through image files (jpg) within finder as organized in "column view," I used to be able to select an image just once (not opening up the preview application) but seeing a little thumbnail in the column view within finder. This was the

  • How to save last import photos

    Hi, I have an iMac and it had HDD failure so Apple replaced it with a new one. Before it happened I imported my iPhone photos and removed the photos from my iPhone. I can view them now in my 'last import' album on my iPhone. Is there any way I can sy

  • RoboDemo skipping last question

    Well, we still have a few RoboDemo files that we are still updating using RoboDemo. But, the OS on my computer was upgraded to XP and my copy of RoboDemo was removed. I have a couple of RoboDemo 5 cds (different builds) but they are all having an iss

  • Command Questions Crystal XI R2

    I have 2 sql commands that run in under 3 minutes in sql as follows, the problem I am having is when I pull them into Crystal they run and hang forever, I have killed it everytime after an hour, I am linking them together on the d.yearmonthnum, I hav