Access user inside of web service stub (or web service)

i am trying to access the current portal user from inside a web service and/or a web service stub. (note, ws is generated using xslt)...
i found in an otn document (http://portalstudio.oracle.com/pls/ops/docs/FOLDER/COMMUNITY/PDK/articles/understanding.web.services.for.portlets.html) the following:
*** begin
By using information specified in the XML provider definition (provider.xml), the renderers allow inputs to a web service to be "wired up" declaratively to any of the following sources of information.
Portlet render request parameters, such as the username, locale and authentication level
*** end
it continues, but the above section seems relevant to me. it indicates that i should be able to get this information to my web service (through the renderer???). can someone please explain how? are there examples of this?
thank you very much.
chris

found it...
http://portalcenter.oracle.com/pls/ops/docs/FOLDER/COMMUNITY/PDK/ARTICLES/HOW.TO.BUILD.WEB.SERVICES.PORTLETS.HTML

Similar Messages

  • How to Access User Parameters in Web Reports

    Hi Friends,
    I am working on Oracle Reports 9i. I am able to access user parameters in Paper Layout by using :user_param1 or &User_param1. But when i am using the same to access user parameters in web source i am not able to access these.
    Actually inside a report i want to create a hyperlink for executing an another report. In this hyperlink i need to pass some user parameters too. But when i am using web source i am unable to access user parameters. Can Somebosy help me on that.
    Thanka in advance
    Regards
    Kamal
    [email protected]

    Hi Kamal,
    For you requirement, the following chapter in the 'Building Reports manual' should help you. Go through the chapter-" Building a Simple Parameter Form for a JSP-based Web Report'. This will help you on how to create a parameterform and to run the report based on the parameter value.
    You can download this manual from the location http://download.oracle.com/docs/html/B10602_01/toc.htm.
    Thanks,
    Vidya

  • Need info on Accessing portal services within a Web Dynpro application

    Hi,
    I need information on Accessing portal services within a Web Dynpro application.I want to explore this topic.Can anyone give useful links?
    Thanks in advance.
    Rajani N

    Hi
    how to reference  a portal service with web dyn pro ?
    https://www.sdn.sap.com/irj/servlet/prt/portal/prtroot/com.sap.km.cm.docs/library/ep/how%20to/how%20to%20access%20a%20portal%20service%20within%20a%20web%20dynpro%20java%20application.pdf
    http://help.sap.com/javadocs/NW04S/current/wd/com/sap/tc/webdynpro/clientserver/portal/WDPortalUtils.html
    Best Regards
    Jakub Krecicki

  • Access users in a Web Dynpro application on different WAS ??????

    Hi,
    Scenario - I have a local WAS on which i have deployed a Web Dynpro Based application.
    There is another WAS on which I have portal installed. I need to access the roles assigned to a particular user in my Web Dynpro application.
    Query -
    I need to know can i access the roles assigned to a user on a different WAS in a Web Dynpro based application running on a different WAS.
    Thanks and Regards,
    Amol Ghodekar.

    Amol,
    as this questions existed twice, I've deleted one.
    As roles are in the UME, you can access them. But why do you want to do this? You could login to that user, but then the question is what you want to do....
    Regards,
    Benny

  • Modifying properties with a file for Web Service Stub used for Oracle Forms

    I have created a stubbed-out web service in JDeveloper (10.1.3.4) and imported into Oracle Forms.
    However, I would like to use a properties file to call the appropriate endpoint based on if the environment is dev, test, UAT or prod. I see that a properties file is referenced in the _Stub class. Here is a snippet of code from that class file:
    public CriticalChangeWS_Soap11_Stub(HandlerChain handlerChain) {
    super(handlerChain);
    setProperty(ENDPOINTADDRESS_PROPERTY, "http://epw-01.gds.graebel.com:8087/CriticalChange.svc/Soap11");
    setSoapVersion(SOAPVersion.SOAP_11);
    setServiceName( new QName("http://tempuri.org/","CriticalChangeService"));
    setPortName( new QName("http://tempuri.org/","CriticalChangeWS_Soap11"));
    setupConfig("wsquery/proxy/runtime/CriticalChangeWS_Soap11_Stub.xml");
    How can I use the XML file to set the ENDPOINT_ADDRESS_PROPERTY?
    Thanks.
    Jim O

    Hi Frank,
    I got the following two lines of code just to check if WebServiceConnection was able to read the connections file alright.
                String urlString = wsc.getWsdlUrlStr();
                System.out.println("WSDL URL: "+urlString);
    I am not using urlString for further processing.
    The output is
    WSDL URL: http://<host>/PSIGW/PeopleSoftServiceListeningConnector/MyService.1.wsdl
    java.lang.NullPointerException
            at java.lang.Class.isAssignableFrom(Native Method)
            at oracle.j2ee.ws.common.jaxws.runtime.GenericJavaType.create(GenericJavaType.java:97)
            at oracle.j2ee.ws.common.jaxws.runtime.GenericJavaType.create(GenericJavaType.java:118)
    The WSDL Url pointed to is the one that I configure in the connection while deploying the App.
    Ran a test and WSDL Url is accessible by the app.

  • Document Literal Web Service Stub Error

    I am using jdeveloper 9.0.3 (necessary because we are doing OAF) and have created a Document Literal Web Service Stub. The stub runs perfectly in Jdeveloper, but when I move it to our 9iAS server (1.0.2.2.2), I get the error that it can not find the class \oracle\jdeveloper\webservices\runtime\WrappedDocLiteralStub.
    On my local machine this file is located in jdev-rt.jar, which is in /jdevbin/jdev/lib. Is there a special way to package the web service so that the jar file is included? Or is there a patch I need to apply to the apps server?
    Any help would be much appreciated.

    I am using jdeveloper 9.0.3 (necessary because we are doing OAF) and have created a Document Literal Web Service Stub. The stub runs perfectly in Jdeveloper, but when I move it to our 9iAS server (1.0.2.2.2), I get the error that it can not find the class \oracle\jdeveloper\webservices\runtime\WrappedDocLiteralStub.
    On my local machine this file is located in jdev-rt.jar, which is in /jdevbin/jdev/lib. Is there a special way to package the web service so that the jar file is included? Or is there a patch I need to apply to the apps server?
    Any help would be much appreciated.

  • Using Oracle AS Web Services stub in portlet?

    I have built a portlet using the jdeveloper plugin wizard, and added a web service stub using the jdeveloper wizard for that. I have added no other code to the portlet than the stub. When running the portlet the classloader throws an class format exception. When using the same stub in a standalone application it runs fine. The libraries mentioned in jdevelopers under the system library "Oracle SOAP" has all been added to the webapplication web-inf/lib. How do I fix it?

    (coworker)
    We have solved the problem. It turned out that the auto generated stub contained code not compatible with the OC4J class loader (but compatible with normakl JVM classload). By modifying the stub a little we got it working. Here is the an extract from one method in the stub. The two line that work comes first and the two next lines contains the auto generated code
    public Integer dispatchFile(byte[] fileContent, Integer programID) throws Exception {
    params.addElement(new Parameter("fileContent", fileContent.getClass(), fileContent, null));
    params.addElement(new Parameter("programID", programID.getClass(), programID, null));
    // params.addElement(new Parameter("fileContent", byte[].class, fileContent, null));
    // params.addElement(new Parameter("programID", Integer.class, programID, null));
    The two original lines compiles into some static class members and a static method that fails to load.
    The new code does not produce any static content.
    We consider this behaviour to be an OC4J error.

  • FlexBuilder Generated Web Service Stubs and requestTimeout

    I generated webservice stubs from a WSDL using Flexbuilder and during an operation I would like the request to timeout after a certain amount of time (say 5 seconds).  How would I get the generated web service stub to generate a timeout fault?  I tried setting the requestTimeout property in the autogenerated BaseService class, but it seems to have no effect

    Can you point me to any documentation that gives more information about this ? Because I came across a scenerio's once wher if I provide Ties it will accept them and it will not re-create them .........
    Both are tow scenerio with "server" = true option :
    Here's when it won't do it :
    If I run wscompile on a config file that provide's "service" tag and include all those ties generated in deployement file it won't re-create the ties.
    Bur here's when it will :
    If I run wscompile on config file that provides "wsdllocation" tag and than include those genertaed files in the deployement than it will re-create the ties again .
    Any idea about that ?
    Prashant

  • Internet Access from Inside to Outside ASA 5510 ver 9.1

    Hi everyone, I need help setting up an ASA 5510 to allow all traffic going from the inside to outside so I can get internet access through it. I have worked on this for days and I have finally got traffic moving between my router and my ASA, but that is it. Everything is blocked because of NAT rules I assume.
    I get errors like this when I try Packet Tracer:
    (nat-xlate-failed) NAT failed
    (acl-drop) Flow is denied by configured rule
    Version Information:
    Cisco Adaptive Security Appliance Software Version 9.1(4)
    Device Manager Version 7.1(5)
    Compiled on Thu 05-Dec-13 19:37 by builders
    System image file is "disk0:/asa914-k8.bin"
    Here is my ASA config, all I want for this exercise is to pass traffic from the inside network to the outside to allow internet access so I can access the internet and then look for specific acl's or nat for specific services:
    Thank You!
    Config:
    ASA5510# sh running-config
    : Saved
    ASA Version 9.1(4)
    hostname ASA5510
    domain-name
    inside.int
    enable password <redacted> encrypted
    xlate per-session deny tcp any4 any4
    xlate per-session deny tcp any4 any6
    xlate per-session deny tcp any6 any4
    xlate per-session deny tcp any6 any6
    xlate per-session deny udp any4 any4 eq domain
    xlate per-session deny udp any4 any6 eq domain
    xlate per-session deny udp any6 any4 eq domain
    xlate per-session deny udp any6 any6 eq domain
    passwd <redacted> encrypted
    names
    dns-guard
    interface Ethernet0/0
    description LAN Interface
    nameif Inside
    security-level 100
    ip address 10.10.1.1 255.255.255.252
    interface Ethernet0/1
    description WAN Interface
    nameif Outside
    security-level 0
    ip address 199.199.199.123 255.255.255.240
    boot system disk0:/asa914-k8.bin
    ftp mode passive
    dns domain-lookup Outside
    dns server-group DefaultDNS
    name-server 199.199.199.4
    domain-name
    inside.int
    object network inside-net
    subnet 10.0.0.0 255.255.255.0
    description Inside Network Object
    access-list USERS standard permit 10.10.1.0 255.255.255.0
    access-list OUTSIDE-IN extended permit ip any any
    access-list INSIDE-IN extended permit ip any any
    pager lines 24
    logging enable
    logging asdm informational
    mtu Inside 1500
    mtu Outside 1500
    mtu management 1500
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-715.bin
    no asdm history enable
    arp timeout 14400
    no arp permit-nonconnected
    nat (Inside,Outside) source dynamic any interface
    object network inside-net
      nat (Inside,Outside) dynamic interface
    access-group INSIDE-IN in interface Inside
    access-group OUTSIDE-IN in interface Outside
    router rip
    network 10.0.0.0
    network 199.199.199.0
    version 2
    no auto-summary
    route Outside 0.0.0.0 0.0.0.0 199.199.199.113 1
    route Inside 172.16.10.0 255.255.255.0 10.10.1.2 1
    route Inside 172.16.20.0 255.255.255.0 10.10.1.2 1
    route Inside 192.168.1.0 255.255.255.0 10.10.1.2 1
    timeout xlate 3:00:00
    timeout pat-xlate 0:00:30
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    user-identity default-domain LOCAL
    aaa authentication ssh console LOCAL
    http server enable
    http 0.0.0.0 0.0.0.0 Inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec security-association pmtu-aging infinite
    crypto ca trustpool policy
    telnet timeout 5
    ssh 0.0.0.0 0.0.0.0 Inside
    ssh timeout 60
    ssh version 2
    ssh key-exchange group dh-group1-sha1
    console timeout 0
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    username <redacted> password <redacted> encrypted privilege 15
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns migrated_dns_map_1
      parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns migrated_dns_map_1
      inspect ftp
      inspect h323 h225
      inspect h323 ras
       inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
      inspect ip-options
    service-policy global_policy global
    prompt hostname context
    no call-home reporting anonymous
    call-home
    profile CiscoTAC-1
      no active
      destination address http
    https://tools.cisco.com/its/service/oddce/services/DDCEService
       destination address email
    [email protected]
      destination transport-method http
      subscribe-to-alert-group diagnostic
      subscribe-to-alert-group environment
      subscribe-to-alert-group inventory periodic monthly
       subscribe-to-alert-group configuration periodic monthly
      subscribe-to-alert-group telemetry periodic daily
    password encryption aes
    Cryptochecksum:
    <redacted>
    : end
    SH NAT:
    ASA5510# sh nat
    Manual NAT Policies (Section 1)
    1 (Inside) to (Outside) source dynamic any interface
        translate_hits = 0, untranslate_hits = 0
    Auto NAT Policies (Section 2)
    1 (Inside) to (Outside) source dynamic inside-net interface
         translate_hits = 0, untranslate_hits = 0
    SH RUN NAT:
    ASA5510# sh run nat
    nat (Inside,Outside) source dynamic any interface
    object network inside-net
    nat (Inside,Outside) dynamic interface
    SH RUN OBJECT:
    ASA5510(config)# sh run object
    object network inside-net
    subnet 10.0.0.0 255.255.255.0
    description Inside Network Object
    Hi all,Hello everyone, I need some help before my head explodes. Idddddddd

    Hello Mitchell,
    First of all how are you testing this:
    interface Ethernet0/0
    description LAN Interface
    nameif Inside
    security-level 100
    ip address 10.10.1.1 255.255.255.252
    Take in consideration that the netmask is /30
    The Twice NAT is good, ACLs are good.
    do the following and provide us the result
    packet-tracer input inside tcp 10.10.1.2 1025 4.2.2.2 80
    packet-tracer input inside tcp 192.168.1.100 1025 4.2.2.2 80
    And provide us the result!
    Looking for some Networking Assistance? 
    Contact me directly at [email protected]
    I will fix your problem ASAP.
    Cheers,
    Julio Carvajal Segura
    Note: Check my website, there is a video about this that might help you.
    http://laguiadelnetworking.com

  • Can I use Web Dynpro to provide Web Services

    I know I can use Adative web services model to consume existing web services.  But I have not seen any example to use Web Dynpro as the web service provider.  Can this be done?  If yes, how?
    Thanks.

    Hi,
    WebDynPro Java/ABAP are primarily User Interface technologies. Webservices are faceless (without UI ) components that provide certain functionality. Using UI technologies like WebDynPro Java/ABAP etc, we can build a face( UI ) to the webservices.
    DnyPro itself means a screen & WebDynPro is for building web based applciations.
    Hope this resolves your question.
    Well, if you still want to use it as provider & if you have an existing web-service, the way to do it is, Right click on your WebDynPro ABAP component & select CREATE->Service Call. Build a Custom Controller or use the Component Controller to get the service using service type = Webservice proxy for your webservice. You can use this Component as a Used component in any other webdynpro components & use this to access webservices.
    Thanks,
    Phani
    Edited by: Phani Rajesh Mullapudi on Oct 8, 2009 10:41 PM

  • Socks services errors in web proxy server

    Using SunOne web proxy server 3.6+sp1, the socks service frequently out of service. Sometime its process is still alive , but can't response the client request; sometime the process is gone! The following is the errors log:
    [25/Oct/2002:11:18:06] 8269 debug: io_loop: killing tunnel after rollover, lastactivity == 1966619898,PR_IntervalNow says 2026622109
    [25/Oct/2002:11:20:31] 8269 debug: io_loop: killing tunnel after rollover, lastactivity == 1981101717,PR_IntervalNow says 2041102282
    [25/Oct/2002:11:20:48] 754 error: unknown request type 0x47 from 10.160.8.159:30 83
    [25/Oct/2002:11:41:07] 14946 debug: ACCEPT RETURNED NULL! io_total = 63 dead =-1
    Any infomation is welcome!

    what's the software name of socks? how i can download it?
    you mean it's not good?
    And the following is the issue in detail:
    The socks service frequently out of service. Sometime its process is still alive , but
    can't response the client request; sometime the process is gone.It occurs once a
    day, and after restart, its go away. And the last issue about must reconnect the gameroom
    is gone now, and was identified as the network's problem.
    mangus.conf:
    #ServerRoot /iPlanet/proxy/proxy-proxy-proxy
    ServerName proxy
    ServerID proxy-proxy
    Address 10.160.1.14
    Port 8080
    User root
    LoadObjects obj.conf
    RootObject default
    ErrorLog /iPlanet/proxy/proxy-proxy-proxy/logs/errors
    LDAPConnPool 5
    SearchDepth 30
    Dyngroups ON
    SearchTimeLimit 30
    BindTimeLimit 15
    LdapCheckUp 30
    CertificateChecking OFF
    PidLog /iPlanet/proxy/proxy-proxy-proxy/logs/pid
    MaxProcs 1024
    ProcessLife 128
    DNS on
    Security off
    Ciphers rc4,rc4export,+rc2,+rc2export,+des,+desede3
    SSL3Ciphers
    rsa_rc4_128_md5,rsa_3des_sha,+rsa_des_sha,+rsa_rc4_40_md5,+rsa_rc2_40
    md5,-rsanull_md5
    ACLFile /iPlanet/proxy/httpacl/generated.proxy-proxy-proxy.acl
    obj.conf
    # Netscape Communications Corporation - obj.conf
    # You can edit this file, but comments and formatting changes
    # might be lost when the admin server makes changes.
    Init funcs="icp-init,icp-route" shlib="/iPlanet/proxy/plugins/icp/icp.so" fn="load-
    modules"
    Init funcs="pa-init-proxy-array,pa-init-parent-array,pa-enforce-internal-routing,pa-set-
    parent-route,pa-set-member-status"
    shlib="/iPlanet/proxy/plugins/parray/parray.so" fn="load-modules"
    Init fn="load-types" mime-types="mime.types"
    Init access="/iPlanet/proxy/proxy-proxy-proxy/logs/access" format.access="%
    Ses->client.ip% - %Req->vars.pauth-user% [%SYSDATE%] \"%Req->reqpb.proxy-
    request%\" %Req->srvhdrs.clf-status% %Req->vars.p2c-cl%" fn="flex-init"
    Init fn="init-proxy" timeout="300" timeout-2="15"
    Init fn="init-dns-cache" status="on" dir="/tmp" semas="4" size="4096"
    expire="28800"
    Init fn="init-cache" status="on" ndirs="256" dir="/iPlanet/proxy/cache"
    Init fn="init-partition" status="on" name="p1" dir="/iPlanet/proxy/cache/p1" max-
    size="8000" min-avail="5"
    Init status="on" dir="/iPlanet/proxy/cache/p2" name="p2" max-size="8000" min-
    avail="5" fn="init-partition"
    Init status="on" dir="/iPlanet/proxy/cache/p3" name="p3" max-size="8000" min-
    avail="5" fn="init-partition"
    Init status="on" dir="/iPlanet/proxy/cache/p4" name="p4" max-size="8000" min-
    avail="5" fn="init-partition"
    Init status="on" dir="/iPlanet/proxy/cache/p5" name="p5" max-size="8000" min-
    avail="5" fn="init-partition"
    Init status="on" dir="/iPlanet/proxy/cache/p6" name="p6" max-size="8000" min-
    avail="5" fn="init-partition"
    Init status="on" dir="/iPlanet/proxy/cache/p7" name="p7" max-size="8000" min-
    avail="5" fn="init-partition"
    Init status="on" dir="/iPlanet/proxy/cache/p8" name="p8" max-size="8000" min-
    avail="5" fn="init-partition"
    Init fn="init-urldb" status="on" dir="/iPlanet/proxy/cache/urldb"
    Init fn="init-batch-update" status="off" dir="/tmp" conf-file="bu.conf"
    Init status="on" dir="/tmp" hash-size="17191" table-size="85955" expire="3600"
    fn="init-pauth-cache"
    Init config_file="icp.conf" status="off" fn="icp-init"
    Init set-status-fn="pa-set-member-status" file="/iPlanet/proxy/proxy-proxy-
    proxy/config/parray.pat" status="off" fn="pa-init-proxy-array"
    Init set-status-fn="pa-set-member-status" file="/iPlanet/proxy/proxy-proxy-
    proxy/config/parent.pat" status="off" fn="pa-init-parent-array"
    <Object name="default">
    NameTrans fn="map" from="file:" to="ftp:" cont="yes"
    NameTrans fn="pfx2dir" from="/ns-icons" dir="/iPlanet/proxy/ns-icons" name="file"
    NameTrans fn="pac-map" from="/" to="/iPlanet/proxy/proxy-proxy-
    proxy/pac/proxy.pac" name="file"
    PathCheck fn="url-check"
    PathCheck fn="check-acl" acl="proxy-proxy-proxy_formgen-READ-ACL_deny-
    5619"
    PathCheck fn="check-acl" acl="proxy-proxy-proxy_formgen-WRITE-ACL_deny-
    5619"
    Service fn="deny-service"
    AddLog fn="flex-log" name="access" iponly="1"
    AddLog fn="urldb-record"
    </Object>
    <Object name="file">
    PathCheck fn="unix-uri-clean"
    PathCheck fn="find-index" index-names="index.html"
    ObjectType fn="type-by-extension"
    ObjectType fn="force-type" type="text/plain"
    Service fn="send-file"
    </Object>
    <Object ppath="ftp://.*">
    ObjectType fn="cache-enable"
    ObjectType fn="cache-setting" max-uncheck="21600"
    Service fn="proxy-retrieve"
    </Object>
    <Object ppath="http://.*">
    ObjectType fn="cache-enable"
    ObjectType fn="cache-setting" max-uncheck="7200" lm-factor="0.100"
    Service fn="proxy-retrieve"
    </Object>
    <Object ppath="https://.*">
    Service fn="proxy-retrieve"
    </Object>
    <Object ppath="gopher://.*">
    ObjectType fn="cache-enable"
    ObjectType fn="cache-setting" max-uncheck="14400"
    Service fn="proxy-retrieve"
    </Object>
    <Object ppath="connect://.*:443">
    Service fn="connect" method="CONNECT"
    </Object>
    <Object ppath="connect://.*:563">
    Service fn="connect" method="CONNECT"
    </Object>
    socks5.conf
    # Netscape Communications Corporation - socks5.conf
    # You can edit this file, but comments and formatting changes
    # might be lost when the admin server makes changes.
    auth 10.160.0.0/255.255.224.0 - -
    auth - - u
    permit u,- - - - - - -
    set SOCKS5_BINDPORT 1080
    set SOCKS5_LOGFILE /iPlanet/proxy/proxy-proxy-proxy/logs/socks5.log
    set SOCKS5_DEBUG 1
    set SOCKS5_WORKERS 100
    set SOCKS5_ACCEPTS 5
    set SOCKS5_NOIDENT
    set SOCKS5_NOREVERSEMAP
    socks5.log
    [19/Nov/2002:11:31:14] 830 debug: request from 10.162.169.176:2305
    [19/Nov/2002:11:31:15] 830 debug: auth: userpass
    [19/Nov/2002:11:31:15] 830 debug: authentication type 2 successful for hs
    [19/Nov/2002:11:31:15] 830 debug: request 1 to jason314.3322.org:21
    [19/Nov/2002:11:31:15] 830 request: hs 5 connect: ok 10.162.169.176:2305 ->
    jason314.3322.org:21
    [19/Nov/2002:11:31:15] 831 debug: request from 10.162.169.176:2306
    [19/Nov/2002:11:31:15] 831 debug: auth: userpass
    [19/Nov/2002:11:31:15] 831 debug: authentication type 2 successful for hs
    [19/Nov/2002:11:31:15] 831 debug: request 1 to jason314.3322.org:21
    [19/Nov/2002:11:31:15] 831 request: hs 5 connect: ok 10.162.169.176:2306 ->
    jason314.3322.org:21
    access
    10.160.115.222 - scy-tl [19/Nov/2002:11:32:33 +0800] "GET
    http://www.eefoo.com/c
    ommunity/images/bbs0gg.gif HTTP/1.0" 200 146
    10.160.115.79 - whh-tl [19/Nov/2002:11:32:33 +0800] "GET
    http://fayhoo.com/image
    /blank HTTP/1.0" 404 276
    10.160.19.151 - lhb [19/Nov/2002:11:32:33 +0800] "POST HTTP://rich-bj.stockstar.
    com:8892/1 HTTP/1.0" 200 81
    10.160.160.130 - gsp-ld [19/Nov/2002:11:32:33 +0800] "GET
    http://images.sohu.com
    /cs/button/sony/12060.swf?clickthru=http://goto.sohu.com/goto.php3?code=sony-
    sh2
    40-fr12050 HTTP/1.0" 200 8302
    10.160.23.141 - wyn [19/Nov/2002:11:32:33 +0800] "POST HTTP://rich-
    bj.stockstar.
    com:8891/1 HTTP/1.0" 200 81
    10.161.159.40 - - [19/Nov/2002:11:32:33 +0800] "PUT http://204.177.92.204/w/getc
    lientid?srv=china_sex&ver=0,0,0,62 HTTP/1.0" 407 271
    10.160.17.108 - weizc [19/Nov/2002:11:32:33 +0800] "GET
    http://www.guosen.com/cg
    i-bin/RHStockGraphics.dll?GetTLine?code=10000001&cx=150&cy=70&am=0
    HTTP/1.0" 200
    1004
    10.161.130.3 - czy-ykj [19/Nov/2002:11:32:34 +0800] "GET http://ad4.sina.com.cn/
    btn/dbtel-tlhp.swf HTTP/1.0" 304 -
    10.161.159.40 - - [19/Nov/2002:11:32:34 +0800] "PUT http://204.177.92.204/w/getc
    lientid?srv=china_sex&ver=0,0,0,62 HTTP/1.0" 407 271
    errors
    [19/Nov/2002:11:33:13] failure: for host 10.160.80.148 trying to GET http://myjh
    xp.com/bbs/forums.cgi?forum=4, retrieve-exit-routine reports: proxy retrieve fai
    led: Proxy server's network connection was refused by the server: myjhxp.com.
    The server may not be accepting connections or may be busy. Try connecting
    agai
    n later.
    [19/Nov/2002:11:33:13] warning: last-modified in future (not caching): Tue Nov 1
    9 03:51:01 2002
    [19/Nov/2002:11:33:13] failure: for host 10.160.80.148 trying to GET http://myjh
    xp.com/bbs/forums.cgi?forum=4, retrieve-exit-routine reports: proxy retrieve fai
    led: Proxy server's network connection was refused by the server: myjhxp.com.
    The server may not be accepting connections or may be busy. Try connecting
    agai
    n later.
    [19/Nov/2002:11:33:13] failure: for host 10.162.101.73 trying to GET ftp://202.1
    15.144.37/software/special/WinPE-9down.rar, retrieve-exit-routine reports: proxy
    retrieve failed: Proxy server's network connection was refused by the server:
    202.115.144.37. The server may not be accepting connections or may be busy. Tr
    y connecting again later.
    [19/Nov/2002:11:33:13] warning: last-modified in future (not caching): Tue Nov 1
    9 18:21:00 2002
    [19/Nov/2002:11:33:13] warning: last-modified in future (not caching): Tue Nov 1
    9 03:51:01 2002
    The logs is so large, i only can give you some of them typically.
    and the types of log's record when problem occurs i have supplied to you, also i
    pasted here
    [25/Oct/2002:11:18:06] 8269 debug: io_loop: killing tunnel after rollover, lastactivity
    == 1966619898,PR_IntervalNow says 2026622109
    [25/Oct/2002:11:20:31] 8269 debug: io_loop: killing tunnel after rollover, lastactivity
    == 1981101717,PR_IntervalNow says 2041102282
    [25/Oct/2002:11:20:48] 754 error: unknown request type 0x47 from
    10.160.8.159:30 83
    [25/Oct/2002:11:41:07] 14946 debug: ACCEPT RETURNED NULL! io_total = 63
    dead =-1
    ------------------------------------------------------------------

  • Calling Enterprise Services through xMII Web Service action block

    Hi All,
    I'm calling some Enterprise Service through xMII Web Service action block.
    After providing URL and user credentials, I'm getting error "SOAP Service could not be loaded: The element type 'p' must be terminated by the matching end-tag '</p>'."
    Can anyone point out what might be the reason ?
    Thanks,
    Sumit

    If you haven't already, try using the browser from the xMII server machine rather than your own (client).
    The error that you recieve usually means that instead of a WSDL an HTML is being returned when you use the WebService action block.
    Possible reasons - as Jeremy pointed out - improper credentials or some error with the webservice itself.
    Another thing you can possibly try out - use some web service analyser to access the webservice . There's one that goes by the name StrikeIron which is a freeware.Pretty neat tool.

  • External Users not able to login to Essbase Admin Services.

    Hi,
    We are facing strange problem in one of our Essbase 9x environments. In this environment, we installed Shared Services, Essbase Admin Services in one server and Essbase in another server.
    We configured MSAD and provisioned some users. Now, these users are able to login to Essbase, Shared Services without any issues but not to EAS. Whats more strange is, Native users are not facing any issue while logging to EAS, Essbase. Just externally authenticated users are having this problem.
    We checked the logs, but nothing to deduct from them. The EAS screen is just hanging as soon as credentials are entered. We did lot of troubleshooting and even Oracle Support is working
    and is of the opinion that the issue is because we installed EAS Console on Virtual Machine which is out of their policy.
    Any suggestions are welcome!!
    Thanks,
    PM

    Guys,
    I found something that may help or you may have seen this and rectified it already.
    When i started the services in foreground, External users are able to login.
    This is what i got in the cmd prompt.
    INFO: Installing web application at context path /hbrlauncher from URL jar:file:
    F:\Hyperion\AnalyticAdministrationServices\deployments\Tomcat\5.0.28\webapps\hbr
    launcher.war!/
    Jan 6, 2012 11:17:29 AM org.apache.coyote.http11.Http11Protocol start
    INFO: Starting Coyote HTTP/1.1 on http-10080
    Jan 6, 2012 11:17:29 AM org.apache.coyote.http11.Http11Protocol start
    INFO: Starting Coyote HTTP/1.1 on http-10090
    Jan 6, 2012 11:17:29 AM org.apache.catalina.startup.Catalina start
    INFO: Server startup in 18952 ms
    !!!Setting HBR appname to : HBR:XYZSERVER
    2012-01-06 11:19:39,843 WARN http-10080-Processor23 com.hyperion.hbr.core.Access
    ControlManagerServer - Error authenticating user in UserServerManager.
    2012-01-06 11:19:39,843 WARN http-10080-Processor23 com.hyperion.hbr.core.UserMa
    nagerServer - Error authenticating user in UserServerManager.
    PM

  • How to make Service call document web enabled

    A technician would be accessing Service call form through the web browser over the internet. He would be mentioning the CALLID and will be entering the user defined fields that are dispatch date, technician out date and time to name a few from the web browser through a web page, which should get populated into SAP Business One database.  We are going for SAP Business One 2007B version with SQL server 2005 database. I went through the web tools web services and I could not find a web service related to service module. Can you please advise me how to go about with this scenario?

    Hello,
    Look at the thread on page two with the name: Join a service call and one serial number?
    Hopefully this will help you further
    Tim

  • Cannot start the Web Service i created via Services

    Hi there,
    I appreciate if someone could assist me please?
    I have created a service, i can see the service i have created in the "Services". I am using Windows 8.1.
    However when i try to start the service i get the error:
    "Windows couldn't start the service on the Local Computer. Error 5: Access is denied".
    I followed the guide below to ensure the user is part of the admin group but i still get the above error:
    Fix: Access Is Denied error with Local Services in Windows 8.1
    Kind Regards,

    Hi IndusKing,
    >>"Windows couldn't start the service on the Local Computer. Error 5: Access is denied".
    Based on your description, it seems that you have hosted the WCF Service using the Windows Service. In my mind it is the permission issue, please try to check this article for more information:
    http://www.dotnetspider.com/resources/45390-Windows-could-not-start-service-local-computer-Error-5-Access-denied.aspx .
    Best Regards,
    Amy Peng
    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click
    HERE to participate the survey.
    Thanks for replying to me. I got my service to start!
    I did this by copying the contents of the App.config that i have in my web service project to the app.config in the Windows Service application that hosts my service. 
    I then ran the following command in VS2012 command prompt:
    installutil.exe "Full Path To Window Service Host Exe"
    Went into "Services" then I did right click > start. The service started up.

Maybe you are looking for

  • Image in a DataGrid

    Hello, I want to introduce a image in one datagrid column but I don't know why. I'm trying doing that: private var columns:ArrayCollection = new ArrayCollection([                             {headerText: 'Image', dataField: 'column1', itemRenderer:'x

  • Bluetooth: Not Available / PRAM RESET does not help

    I can see that many people have been having issues with BLUETOOTH going off-line since the last software update, but the solutions are working for me. I have restarted x2, resetting the PRAM, but the problem persists. Also, BT is not showing up in th

  • Too stupid and/or lazy for anything but Arch?

    Many times during the last 15 years, I made an effort to use GNU/Linux, mostly so-called "beginner-friendly" distributions, as my main operating system but never successfully. There were always some issues that I was too stupid or too lazy to underst

  • Locking options in MDM ABAP API

    Hi, In our project, we have a BSP application screen, through which the end-users create/modify material master data and post it in MDM, through MDM ABAP APIs. If one user is editing material data, through our BSP screen, related to a particular mate

  • Dynamic screen field values

    Hi, One quick question, I have created a screen with reference to a custome table fields and it is working fine. When I enter values for the first time, the values look ok in debug but when I change the values on the screen, the new values are not up