BMP bean with finalizers, performance issue?

Hi Guys,
I am using BMP 1.1, websphere 6.1, and have been reading up on profiling my application.
Reading through the JProfiler manual, I found the following suggestion.
[http://resources.ej-technologies.com/jprofiler/help/doc/indexRedirect.html?http&&&resources.ej-technologies.com/jprofiler/help/doc/helptopics/config/finalizers.html]
I have about 5 BMP that would be closing connections via finalizers, and there would be thousands of calls to these BMP finders when the app is busy.
My question is, what do you guys think about the above link.
And what would the best way to implement this daemon thread, I am not sure where to put it in my code.
Thanks

I am not sure if this is an issue or not.
I think the try-catch-finally executed synchronously and explicitly, and this is what is in my BMP beans.
And the problem in the above link is only pertaining to overriding.
protected void finalize () throws Throwable {}

Similar Messages

  • Treeview datawindow with icon - performance issue

    Hi all,
    i have a treeview dw and have set the "use tree node icon" property with 2 different icons (bmp) at the first level (when the level is expanded or collapsed)
    Then a different icon (ico) file is used for the second level
    Unfortunately, this is causing a huge performance issue when i run the application.
    If i disable the "use tree node icon" property, everything works fine.
    Is there any known issues on the treeview dw with icons? any work around?
    am using pb11.2
    thanking you in advance,
    -a

    First question is which jdev version you are using?
    I made a quick test and did not see a long busy state.
    Run your app with -Djba.debugoutout=console as java option. You get more output in the log window, but may be some hint about what's going on.
    Timo

  • Help with Video Performance Issues using Flash

    Asking on behalf of a customer who has been unable to get any answers so far - are you able to help?
    Background:
    We have a port of our Game Development Kit which allows us to recompile all our games using Crossbridge (http://adobe-flash.github.io/crossbridge/) into SWF without any code modifications.
    Overview:
    Our framework is using OpenGL for rendering and we have successfully ported it along with the audio and video to run in Flash.
    We are experiencing performance issues using Video. We cannot use image sequence as some of the video animations are too long and would increase the download to an unacceptable size.  Assets vary between 256x256 - 1024x1024 videos.

    Here's the rest of the story.  Let me know if you can see any resolution, and I will connect him to the forums.  Thank you.
    Current Video Solution:
    We create an instance of NetConnection, NetStream, and Video according to most samples out there, and invoke draw to rasterize the Video DisplayObject into a BitmapData instance.
    The BitmapData instance has a fixed color component layout which is not compatible with Stage3D texture and is therefore has to be reformatted before uploaded to Stage3D Texture (See Code Listing below).
    Our Problems:
    Performance issues with RGBA conversion (either using copyChannel or manually reformatting is not fast enough) natively in as3; this required for stage3d texture.Copying each channel individual using bitmapdata.Copychannel seems faster, but not significantly faster.
    Cannot detect when video frame has been updated, therefore we may copy pixels that are not needed in enterframe (processpixel).
    Looping video, our current solution uses the NET_STATUS event Buffer empty; Is there a better way to loop videos than checking buffer and seeking to 0.
    Stepping video, loading FLV or MP4 side by side assets from HTTP or embedded does not support stepping? Is there another way?
    ActionScript Code Listing:
    video_nc = new NetConnection();
    video_nc.addEventListener(NetStatusEvent.NET_STATUS , onConnect);
    video_nc.addEventListener(AsyncErrorEvent.ASYNC_ERROR , trace);
    video_nc.connect(null);
    // OnConnect Event:
    this.ns = new NetStream(e.target as NetConnection);
    eventclient = new Object();
    eventclient.onMetaData = onMetaData;
    this.ns.client = eventclient;
    ns.play(flvfile);
    ns.pause();
    //onMetaData event:
    this.width = infoObject.width;
    this.height = infoObject.height;
    this.textureWidth = NextPowerOfTwo(this.width);
    this.textureHeight = NextPowerOfTwo(this.height);
    cliprect = new Rectangle(0, 0, this.width ,this.height);
    cliprect.x = 0;
    cliprect.y = 0;
    cliprect.width = this.textureWidth;
    cliprect.height = this.textureHeight;
    totalFrames = infoObject.duration * infoObject.fps;
    this.hasAlpha = true;
    if(infoObject.videocodecid == 5)
    this.hasAlpha = true;
    this.bitmapData = new BitmapData(this.textureWidth, this.textureHeight, hasAlpha, 0xff000000);
    this.video = new Video(this.width, this.height);
    this.video.attachNetStream(ns);
    this.video.addEventListener(Event.ENTER_FRAME, processPixels);
    // processPixel method:
    BitmapData.draw(video);
    GLAPI.instance.glBindTexture(GLAPI.GL_TEXTURE_2D,this.textureId);
    var fmt:uint = GLAPI.GL_ARGB;
    // converting pixels using copychannel or loop through pixels
    GLAPI.instance.glBindTexture(GLAPI.GL_TEXTURE_2D,this.textureId);
    GLAPI.instance.glTexImage2D(GLAPI.GL_TEXTURE_2D, 0, fmt, this.textureWidth, this.textureHeight, 0,fmt, GLAPI.GL_UNSIGNED_BYTE, 0, convBitmapData.getPixels(cliprect));

  • WLS 10.3.4 with ADF - Performance issues

    Hi,
    I'm doing some performance tuning on our ADF app on WLS 10.3.4. I ran JRockit Mission Control for 1 minute and it's telling me that 113,503 exceptions were thrown! 70,000 ClassNotFoundException, 27,000 NoSuchMethodException etc.
    Stupid question maybe, but is this normal? Debugging shows no particular class is missing, there are many.
    Thanks.
    Edited by: 918121 on 01-Mar-2012 06:05

    I'd try posting this in the ADF forum, perhaps with some examples of the observations you are seeing.
    -steve-

  • Applet with SSL Performance Issue

    Hi All,
    I tried posting this in the general java forum but I think it's more relavant in the Applet section. I have a program where JavaScript invokes an Applet which uses PrintService to retrieve a list of all the printers on the network and returns that string, the JS then does something with that String. The problem I'm seeing is that when a user tests this functionality without SSL enabled there are no issues. However, with SSL enabled, the first invocation of this functionality is successful but the second invocation always causes the CPU to spike to 50%. Any ideas what's happening here? Why is it spiking on the second call to this applet? Workarounds? Would it be possible to retrieve a list of printers directly with JS?
    Thanks for your feedback.
    Message was edited by:
    javajiggs

    what do you mean the sniffer trace is normal ?
    Do you have the decrypted trace ?
    It's important to know if the server sent an error message, or if the css corrupted the server response.
    This should be seen in the trace.
    Also, is the same client always having issue ?
    Is it the only one ?
    Can this client browse different webpages ?
    Gilles.

  • Tethering with lightroom: performance issue

    hi guys,
    i am shooting raw, tethered from a canon 5d mark II, directly into lightroom 2 on a macbook pro.
    even though i am maxed out on RAM and, running no extra processes, and using a USB2.0 cable
    the whole setup is slooooooooow as hell...
    my questions are:
    - what is holding the system back? is lightroom simply not optimized for tethering?
    - are there ways to improve performance for the mac?
    moreover,
    has anyone created a comparison table to show the options for tethering, with cost, benefits and drawbacks?
    if not, maybe we can do so here with this post.
    best wishes,
    ~nir pengas.

    nir.pengas wrote:
    - what is holding the system back?
    It's the Mac implementation of Canon's software and the Apple USB 2 connection. Want to seriously speed up tethering on a Mac? Install Bootcamp and run Windows. And, if you think I'm kidding, I'm not...it's what Martin Evening does. On a Mac (running OS X), a Canon 1Ds MIII takes about 9 seconds to transfer. On Windows (on the exact same Mac mind you), the transfer speed is just a bit under 2 seconds...
    So, go ask Apple and Canon what's up with the USB 2 connections under OS X...

  • Performance issue with using MAX function in pl/sql

    Hello All,
    We are having a performance issue with the below logic wherein MAX is being used in order to get the latest instance/record for a given input variable ( p_in_header_id).. the item_key is having the format as :
    p_in_header_id - <number generated from a sequence>
    This query to fetch even 1 record takes around 1 minutes 30 sec..could someone please help if there is a better way to form this logic & to improve performance in this case.
    We want to get the latest record for the item_key ( this we are getting using MAX (begin_date)) for a given p_in_header_id value.
    Query 1 :
    SELECT item_key FROM wf_items WHERE item_type = 'xxxxzzzz'
    AND SUBSTR (item_key, 1, INSTR (item_key, '-') - 1) =p_in_header_id
    AND root_activity ='START_REQUESTS'
    AND begin_date =
    (SELECT MAX (begin_date) FROM wf_items WHERE item_type = 'xxxxzzzz'
    AND root_activity ='START_REQUESTS'
    AND SUBSTR (item_key, 1, INSTR (item_key, '-') - 1) =p_in_header_id);
    Could someone please help us with this performance issue..we are really stuck because of this
    regards

    First of all Thanks to all gentlemen who replied ..many thanks ...
    Tried the ROW_NUMBER() option but still it is taking time...have given output for the query and tkprof results as well. Even when it doesn't fetch any record ( this is a valid cased because the input header id doesn't have any workflow request submitted & hence no entry in the wf_items table)..then also see the time it has taken.
    Looked at the RANK & DENSE_RANK options which were suggested..but it is still taking time..
    Any further suggestions or ideas as to how this could be resolved..
    SELECT 'Y', 'Y', ITEM_KEY
    FROM
    ( SELECT ITEM_KEY, ROW_NUMBER() OVER(ORDER BY BEGIN_DATE DESC) RN FROM
    WF_ITEMS WHERE ITEM_TYPE = 'xxxxzzzz' AND ROOT_ACTIVITY = 'START_REQUESTS'
    AND SUBSTR(ITEM_KEY,1,INSTR(ITEM_KEY,'-') - 1) = :B1
    ) T WHERE RN <= 1
    call count cpu elapsed disk query current rows
    Parse 0 0.00 0.00 0 0 0 0
    Execute 1 0.00 1.57 0 0 0 0
    Fetch 1 8700.00 544968.73 8180 8185 0 0
    total 2 8700.00 544970.30 8180 8185 0 0
    many thanks

  • BPC 7 performance issue with Microsoft 2003 vs Microsoft 2007

    Hi All,
    Needs some help with our performance issues with BPC 7 on Microsoft 2007.  We have noticed a significant difference between the two versions.  When running the same report on BPC 7 MS 2003 it takes roughly around 5-6 min.  When running the same report in BPC 7 MS 2007 the report takes roughly 15-20 min.  We've tried numerous things to figure out what can be causing this but does anyone have the same issue or shed some light as to what i can do to eliminate this problem?
    Thanks,
    Elmer

    Hi,
    Did you install the following component on your application server (which is a prerequisite for running Excel 2007)? This note is part of the installation guide:
    In order for the software to function correctly in Excel 2007, you must install the Microsoft Office 2007 system driver Data Connectivity Components, which you can get from the Microsoft web site. The components must be installed on the Application server. We recommend that you install all of the latest Microsoft Windows hotfixes prior to installing the Administration client. For information about which hotfixes to install, see http://www.microsoft.com/downloads/details.aspx?FamilyID=7554F536-8C28-4598-9B72-EF94E038C891&DisplayLang=en.
    Hope this will help.
    Kind Regards,
    Patrick

  • Performance Issue Executing a BEx Query in Crystal Report E 4.0

    Dear Forum
    I'm working for a customer with big performance issue Executing a BEx Query in Crystal via transient universe.
    When query is executed directly against BW via RSRT query returns results in under 2 seconds.
    When executed in crystal, without the use of subreports multiple executions (calls to BICS_GET_RESULTS) are seen. Runtimes are as long as 60 seconds.
    The Bex query is based on a multiprovider without ODS.
    The RFC trace shows BICS connection problems, CS as BICS_PROV_GET_INITIAL_STATE takes a lot of time.
    I checked the note 1399816 - Task name - prefix - RSDRP_EXECUTE_AT_QUERY_DISP, and itu2019s not applicable because the customer has the BI 7.01 SP 8 and it has already
                domain RSDR0_TASKNAME_LONG in package RSDRC with the
                description: 'BW Data Manager: Task name - 32 characters', data
                type: CHAR; No. Characters: 32, decimal digits: 0
                data element RSDR0_TASKNAME_LONG in package RSDRC with the
                description 'BW Data Manager: Task name - 32 characters' and the
                previously created domain.
    as described on the message
    Could you suggest me something to check, please?
    Thanks en advance
    Regards
    Rosa

    Hi,
    It would be great if you would quote the ADAPT and tell the audience when it is targetted for a fix.
    Generally speaking, CR for Enteprise  isn't as performant as WebI,  because uptake was rather slow .. so i'm of the opinion that there is improvements to be gained.   So please work with Support via OSS.
    My onlt recommendations can be :
    - Patch up to P2.12 in bi 4.0
    -  Define more default values on the Bex query variables.
    - Implement this note in the BW 1593802    Performance optimization when loading query views 
    Regards,
    H

  • Oracle SOA 11g Performance Issue

    Hi,
    We have set up Oracle SOA Suite on AIX environment. Java which we are using is IBM Jdk 1.6. Recently we are hit with performance issue. Frequently we are getting out of memory exception and we need to restart the server and sometimes physically reboot the machine, because out of 16 GB of RAM 4GB we have given as heap space to Admin Server, 7 GB to SOA Server but it is taking more than 7 GB as heap space. On stopping or killing both the services memory is not getting released
    SOA Suite Version : 11.1.1.3
    Instance Node: Single Node
    I collected the logs and tried to analyze in Thread Dump Analyzer and i could see objects(Reserved) is taking 100% of the CPU Utilization.
    We are getting the following error highlighed in the analyzer. There are about 200+ threads got stuck.
    "HTTPThreadGroup-42" prio=10 tid=0x6382ba28 nid=0x20bf4 waiting on condition [0x6904f000..0x6904fb94]
    at sun.misc.Unsafe.park(Native Method)
    at java.util.concurrent.locks.LockSupport.parkNanos(LockSupport.java:146)
    at java.util.concurrent.locks.AbstractQueuedSynchronizer.doAcquireNanos(AbstractQueuedSynchronizer.java:772)
    at java.util.concurrent.locks.AbstractQueuedSynchronizer.tryAcquireNanos(AbstractQueuedSynchronizer.java:1087)
    at java.util.concurrent.SynchronousQueue$Node.waitForPut(SynchronousQueue.java:291)
    at java.util.concurrent.SynchronousQueue.poll(SynchronousQueue.java:443)
    at java.util.concurrent.ThreadPoolExecutor.getTask(ThreadPoolExecutor.java:475)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:674)
    at java.lang.Thread.run(Thread.java:595)
    "HTTPThreadGroup-41" prio=10 tid=0x6ae3cce0 nid=0x20bf0 waiting on condition [0x68d8f000..0x68d8fc14]
    at sun.misc.Unsafe.park(Native Method)
    at java.util.concurrent.locks.LockSupport.parkNanos(LockSupport.java:146)
    at java.util.concurrent.locks.AbstractQueuedSynchronizer.doAcquireNanos(AbstractQueuedSynchronizer.java:772)
    at java.util.concurrent.locks.AbstractQueuedSynchronizer.tryAcquireNanos(AbstractQueuedSynchronizer.java:1087)
    at java.util.concurrent.SynchronousQueue$Node.waitForPut(SynchronousQueue.java:291)
    at java.util.concurrent.SynchronousQueue.poll(SynchronousQueue.java:443)
    at java.util.concurrent.ThreadPoolExecutor.getTask(ThreadPoolExecutor.java:475)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:674)
    at java.lang.Thread.run(Thread.java:595)
    Has anyone faced same issue? We are badly hit with this performance issue in UAT
    Please concider this on high priority and someone please help us
    Regards,
    Sundar

    Always raise a case with Oracle Support for such issues.
    Regards,
    Anuj

  • CAT4900M and NetApp - Performance issue

    Hi,
    I'm struggling with a performance issue between our two NetApp Fas3170-devices.
    The setup is quite simple: Each NetApp is connected via two TenGig interfaces to a CAT4900M. The 4900M's are also connected via two TenGig interfaces. Each pair of connections are bundled into an Layer2-etherchannel, configured as a dot.1q trunk. Mode is set to 'ON' on both the 4900 and the NetApp. According to NetApp documentation, this configuration is supported. Across each etherchannel, the vlans 219 and 220 are allowed. Two partitions are configured on the NetApp's, one being active in our primary datacenter and another in our secondary datacenter. Vlan219 and Vlan220 are configured for each the two partitions, using HSRP for gateway redundancy.
    None of the interfaces nor the etherchannels shows any signs of misconfiguration. All links are up and etherchannels working as expected, well almost. Nothing indicates packet loss, crc-errors, Input/Output queue-drops or anything the would impact performance. Jumboframe is not configured, although this has been discussed.
    The problem is, that we're unable to achieve satisfactory performance, when for instance, performing a volume copy between the two NetApp partitions. Even though we have a teoretical bandwidth of 20Gbps end-to-end, we never climb above 75-80 Mbytes of actual transfer-rate between the two NetApps. So performancewise, is almost looks as if we're "scaled" down to a 1Gig link. No QoS or other kind of ratelimiting has been implemented on the 4900's, so from a network point of view, the NetApps can go full-throttle. NetApp sw has been updated and configurations for both NetApp and 4900's have been revised by NetApp engineers and given a "clean bill of health".
    The configuration for the 4900->NetApp etherchannel/interfaces is as follows:
    interface TenGigabitEthernet1/5
    description *** Trunk NetAPP DC1 ***
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 219,220
    switchport mode trunk
    udld port aggressive
    channel-group 2 mode on
    spanning-tree bpdufilter enable
    interface TenGigabitEthernet1/6
    description *** Trunk NetAPP DC1 ***
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 219,220
    switchport mode trunk
    udld port aggressive
    channel-group 2 mode on
    spanning-tree bpdufilter enable
    interface Port-channel2
    description *** Trunk Etherchannel DC1 ***
    switchport
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 219,220
    switchport mode trunk
    spanning-tree bpdufilter enable
    spanning-tree link-type point-to-point
    Configuration for 4900->4900 interfaces/etherchannel is as follows:
    interface TenGigabitEthernet1/1
    description *** Site-to-Site trunk ***
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 10,219,220
    switchport mode trunk
    udld port aggressive
    channel-group 1 mode on
    interface TenGigabitEthernet1/2
    description *** Site-to-Site trunk ***
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 10,219,220
    switchport mode trunk
    udld port aggressive
    channel-group 1 mode on
    interface Port-channel1
    description *** Site-to-Site trunk ***
    switchport
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 10,219,220
    switchport mode trunk
    spanning-tree link-type point-to-point
    Vlan10 used for mngt-purpose.
    Does anyone have similar experiences or suggestions as to why we're having theese performanceissues?
    Thanks
    /Ulrich
    Message was edited by: UHansen1976

    Hi,
    Thanks for your reply.
    I take it, that you mean baseline performance between the two NetApp's. Well, that's really out of my hands, as another department is responsible for the NetApp's. I'm not aware of any baseline performance, nor have I seen any benchmark tests or anything, that could give me hint.
    Just as you suggest, I've gone through the switch-setup systematically. Basically, starting with the physical layer and working my way up. So far, I've found nothing that would indicate a physical problem. The switchport/etherchannel setup has been verified by my peers and also verified by NetApp according to the configuration on the NetApps, as well as the various best-practice documentation availible. Futhermore, I haven't seen any signs of packets drops, crc-errors, massive re-transmissions or anything like not, neither on the switches nor the NetApps.
    Recently we had a status-meeting with our NetApp-partner and it looks to me like they're persuing the logical setup on the NetApps, as the're apparently a number of settings etc. that needs adjustment. Also, we're waiting for NetApp tech-support to comment on the traces, config-dump etc. we've send to them.
    /Ulrich

  • ITunes 7.3.2.6 and Windows Vista Performance Issues

    I recently purchased an 80GB iPod, and downloaded iTunes promptly, disregarding all the negative attention about how "iTunes crashes your computer" or "iTunes kills Windows". So far, the only real problem I've had with iTunes is the amazingly poor performance it has on my computer. When iTunes is minimized to the system tray, or compressed into Mini Player mode, it runs better, but not well.
    Running in the full mode, the player bogs down my computer substantially. Knowing my laptop isn't a powerhouse, I expected a slight bit of slowdown, since there is some evident with QuickTime.
    UPDATE: I've just stumbled across something. Apparently, wiggling my mouse over the iTunes program, iTunes runs about two or three times faster. The moment I stop moving the mouse cursor over the window, the speeds return to slow. It seems to only do this during the "Processing Album Artwork" phase. Bizarre? Very. Any explanations?
    I find this to be very annoying, especially when syncing. Syncing my library (which is about five or six gigabytes) takes an amazingly long time. Are there any workarounds, registry hacks, or anything else that can be done? Thanks!
    Message was edited by: Atlink

    Do you have ReadyBoost enabled on the PC? If so, by way of experiment, try disabling that as per the instructions from the following document:
    Troubleshooting iTunes for Windows Vista video playback performance issues
    ... any help at all with the performance issues?

  • Performance issue at Webi/Universe

    Hi BO Experts,
    I am new to Business objects.
    I have developed a new universe and webi reports, but I am facing some performance issues at webi side. Below I am furnishing my development details; please let me know how I can overcome with the performance issues.
    1. Created a Query on Multiprovider (query is having nearly 125 objects (Info objects (restricted with hierarchies), navigational attributes & restricted key figures).
    2. Developed a new universe on the query.
    3. As part of performance- restricted the some fields at query filters and also applied conditions at universe level.
    4. Created a webi report and it is generating the results for 8 fields (4 characteristics (hierarchy levels) + 4 restricted key figures) and also I used 5 conditions at webi report filters.
    Finally, my Webi results are matching with BW query results, but Webi report is taking more time ( approximately 15 min. ) when I compare with BW query results( approximately 1min. ) and MDX query(approximately 2 min.) results. Requesting t you to please let me know, if I need to do any changes at universe or webi or bw query level  to overcome with this performance issue.
    Awaiting for your response.
    Regards,
    PRK

    Hi,
    Here are few steps to improve the performance:
    Try to build the aggrregrates at Cube leve for those Characterstics which u are using frequenlty in WEBI Reports.
    As you are using Hierarchy, the report performance will be always not good.
    I suggest this can be best handled in BI Modelling Level only instead of handling the same at WEBI Report Level as at WEBI Reports we dont have much options to improve the performance
    Also, I suggest you to look into the Query performance at BEX Level and then use the Query for further connections
    Regards
    Sindhu

  • Info Package in Process Chain - Performance Issue

    Dear All,
    We have some Info Package in Process Chain which when triggered initially turns red, then again yellow, after sometime red/green. These status keeps changing and finally results in green status. These infopackage takes 15-30 mins to complete.
    And the info package error message shows "Processing time overdue". The chain runs daily and this issue also occurs on a daily basis.
    Does anyone one of you have an idea of how to deal with this performance issue?
    Regards.

    Hi
    As you said--
    "initially time out time was set to 10 mins, so it was turning red at 10 mins. Later i changed it to 30 mins, then it is turning red at 30 mins, this info package takes maximum 20 mins to complete.
    thatsy i asked whether there will be any problem if we remove this time out time."
    I guess, its not mandatory to include the timeout value. Just try to execute the IP without entering the timeout value.
    It should work.
    Let me know if this helps.
    Regards
    SaiPrasad

  • Performance issues with LOV bindings in 3-tier BC4J architecture

    We are running BC4J and JClient (Jdeveloper 9.0.3.4/9iAS 9.0.2) in a 3-tier architecture, and have problems with the performance.
    One of our problems are comboboxes with LOV bindings. The view objects that provides data for the LOV bindings contains simple queries from tables with only 4-10 rows, and there are no view links or entity objects to these views.
    To create the LOV binding and to set the model for the combobox takes about 1 second for each combobox.
    We have tried most of tips in http://otn.oracle.com/products/jdev/tips/muench/jclientperf/index.html, but they do not seem to help on our problem.
    The performance is OK (if not great) when the same code is running as 2-tier.
    Does anyone have any good suggestions?

    I can recommend that you look at the following two bugs in Metalink: Bug 2640945 and Bug 3621502
    They are related to the disabling of the TCP socket-level acknowledgement which slows down remote communications for EJB components using ORMI (the protocol used by Oracle OC4J) to communicate between remote EJB client and server.
    A BC4J Application Module deployed as an EJB suffers this same network latency penalty due to the TCP acknowledgement.
    A customer sent me information (that you'll see there as a part of Bug# 3621502) like this on a related issue:
    We found our application runs very slow in 3-Tier mode (JClient, BC4J deployed
    as EJB Session Bean on 9iAS server 9.0.2 enterprise edition). We spent a lot
    of time to tune up our codes but that helped very little. Eventually, we found
    the problem seemed to happen on TCP level. There is a 200ms delay in TCP
    level. After we read some documents about Nagle Algorithm,  we disabled a
    registry key (TcpDelAckTicks) in windows2000  on both client and server. This
    makes our program a lot faster.
    Anyway, we think we should provide our clients a better solution other than
    changing windows registry for them, for example, there may be a way to disable
    that Nagle's algorithm through java.net.Socket.setTcpNoDelay(true), in BC4J,
    or anywhere in our codes. We have not figured out yet.
    Bug 2640945 was fixed in Oracle Application Server 10g (v9.0.4) and it now disables this TCP Acknowledgement on the server side in that release. In the BugDB, I see backport patches available for earlier 9.0.3 and 9.0.2 releases of IAS as well.
    Bug 3621502 is requesting that that same disabling also be performed on the client side by the ORMI code. I have received a test patch from development to try out, but haven't had the chance yet.
    The customer's workaround in the interim was to disable this TCP Acknowledgement at the OS level by modifying a Windows registry setting as noted above.
    See Also http://support.microsoft.com/default.aspx?kbid=328890
    "New registry entry for controlling the TCP Acknowledgment (ACK) behavior in Windows XP and in Windows Server 2003" which documents that the registry entry to change disable this acknowledgement has a different name in Windows XP and Windows 2003.
    Hope this info helps. It would be useful to hear back from you on whether this helps your performance issue.

Maybe you are looking for

  • How to create a mail user agent by using JAVA...

    my lecturer has asked me to create a mail user agent by using JAVA , i have no idea how to start this assignment......

  • PROBLEM WITH ROWNUM

    Hello everybody, I'm using oracle 8i server. And I'm trying to get two rows out of many, that have largest value for 1st column of the table. I.E Ist and 2nd maximum value. The problem is when I'm using "select * from table where rownum <= 2 order by

  • Error with HTTP scenario

    Hey guys i m doing a FIle to HTTP scenario and posting an XML file to one of our client who is outside our landscape. in MONI i see chequered flag but they are not getting the XML file,they are using Business connector on their side,they side they go

  • How can I make the skin like rock ?

    How can I make the skin of a dramatic BW image of a Boxer look like peeling lava skin ?  I know that's a funny way to say it, but I want to make him look like rock and lava with hard cracks and such. Anyone have some ideas ?

  • Javax.transaction.TransactionRolledbackException: CORBA TRANSACTION_ROLLEDB

    Hi!!! I have a problem while I'm trying to create CMP Entity Beans. I got these CMP Entity Beans using Netbeans IDE 5.0, getting the beans from an SQL Server 2000 database. I got this error: HTTP Status 500 - type Exception report message description