Celsius to Farenheit and viceversa

Hello everyone, I hope someone can help me with a project I am working on.
I need to do a simple VI that converts from degrees C to degrees F and viceversa. In the front panel, the user should be able to convert from one to the other. For example, if there are 2 thermometers and the user slides the Celsius degrees down to 0, the other thermometer should move to 32 degrees. However, the user should ALSO be able to go the opposite direction while the VI is running. In other words, the user should be able to change the temperature in EITHER thermometer and the OTHER should change accordingly. I am only able to go ONE direction because I think I should be able to have some sort of control that also works as an indicator. Please let me know if there is a way to do this!!! THANKS.

You can also use "units" for each control (degF and degC, resp.), no more conversion math needed.
Message Edited by altenbach on 02-18-2007 07:51 PM
LabVIEW Champion . Do more with less code and in less time .
Attachments:
DualT.vi ‏14 KB
DualT.png ‏6 KB

Similar Messages

  • How to know corresponding info object for R/3 field and viceversa

    Hi....
    How to know corresponding object for a filed in r/3 data source and viceversa..While defining transformations.
    We can't do mapping of all objects to fields with the definition......!!!
    In 'rsosfieldmap'' what information we should give to know the proper tranformation...?
    thank u.....

    Hi,
    There are two ways to know the corresponding info objects in R/3 fields:
    1)  goto se11 t-code, enter RSOSFIELDMAP and enter display button. in the next screen click contents and give the field name or info object name as per your requirement, and excute.
    2)  first go through the field description in r/3 and identify the similar description in BI. For your easy understanding use excel sheet , in that you can copy the data source fields and target info objects ( master data or transaction data ). then it will be easy to identify the similar description.
    Thank you.

  • Vendor as customer and viceversa

    Hello,
    My scenario is that i have several vendors that are customers at the same time. And viceversa, several customers that are vendors too. I have made the customizing, into the customer I have put the vendor nr and the check 'clearing with vendor', and into the vendor the customer nr and the check 'clearing...'. I have anyway two problems:
    1) When i execute f-28 (incoming payments) or f-53 (outgoing payments), i see the items of the customer/vendor both. No problem.  But i can't clear different amounts. I have:
    Customer: +232 EUR
    Vendor:    -136 EUR
    And i can't clear these.
    2) My second problem comes when i execute F110 (automatic payments). At the end of the process i see the payment to make to vendor and one exeption for the customer incoming payment.
    > Bank details are being checked                                       
    >   System reads house banks and checks if they are allowed            
    > Our bank DUMMY is being checked                                      
    > Bank different from the specified bank AA in master record or items  
    >   House bank is selected ...                                         
    > No permitted payment method exists                                   
    Information re. vendor 1 / customer 2 / paying company code 01 ...
    ... payment not possible because of reported error            
    Thank you all the experts.

    In the example you have a payment will need to be received sent - therefore a payment method needs to be applied to the customer and vendor master.
    If you want to offset the customer invoice against the vendor invoice - you can clear it via F-32, and then add other items "K" for account group and then the Vendor number.

  • After having updated Ipad2 to IOS7 I can't change Video to Photo and viceversa on photocamera. Solutions?

    After having updated Ipad2 to IOS7 I can't change Video to Photo and viceversa on photocamera. Solutions?

    Have you tried swiping up or down on the screen in the photos app? When you swipe up or down, that cycles through the Photo, Video and Square modes in the app. The current mode appears in yellow type.
    The screen on the iPad in photos App is going to look different that what you see if you click on the link that was posted for you above - that link shows what the screen will look like on the iPhone, but they are similar.

  • Read and write(control should act as indicator and viceversa)

    control(input) should act as indicator(output) and viceversa for a string transmission.is it possible
    kudos welcome
    Solved!
    Go to Solution.

    Yes you can.  But property nodes are much slower than local variables.  For simple programs, you won't notice the difference.  But sooner or later, you will encounter a case where too many property nodes will noticeably slow down the code.  It is considered bad programming style to use property nodes instead of local variables.  Property Nodes work through the UI thread.  Locals do not.  So locals present a lot less overhead. 
    It is best to not get into a bad habit from the start.  Use local variables instead of property nodes.
    I do use local variables and think it is ok but there are the people on here that think they are the worst thing ever invented. Also it is not bad to show a couple of different way to do things so the OP can learn different ways to do things. Property nodes are something that you will inevitably have to learn if the OP wants to do real programming.
    Tim
    Johnson Controls
    Holland Michigan

  • BCD to decimal and viceversa

    Hi,
    Am working on conversion of decimal to BCD (Binary coded decimal) and viceversa. I require BCD for calling Cobol from Java using JNI.
    Can anybody help me out in giving a pointer or an algorithm for doing the same.
    I Googled on the web for any info on BCD conversion, but all in vain. Even Java Forums here in Sun also donot have any info on the same.
    Please help me out.
    TIA,
    Prashanth Babu.

    You'll have to adjust this to do put the output where you want. Surely not the only (and maybe not elegant):
       /** Write specified string into stream as two Binary-Coded Decimal (BCD)
        *     digits.
       private static void writeTwoBCDDigits(DataOutputStream stream,
                                             String           twoDigits)
              throws IOException
          // Convert two digits to Binary-Coded Decimal (BCD).
          // The "write(int)" function writes a numeric value in binary to the
          //    stream.
          // If the twoDigits string is parsed as a hexadecimal integer, then
          //    writing the equivalent decimal integer using "write(int)" will
          //    generate the correct BCD numbers.
          // For example, if twoDigits is "54", parsing this as the hexadecimal
          //    integer 54 results in twoBCDDigits as the decimal integer 84.
          //    Then, "write(84)" will write the correct bits to the stream:
          //    "0101 0100" (space not included).
          //    "0101" = BCD '5' and "0100" = BCD '4'.
          int twoBCDDigits = Integer.parseInt(twoDigits, 16);
          // Write out the numeric value of twoBCDDigits in one byte.
          stream.write(twoBCDDigits);
       }

  • Mail suddenly marks as spam what is not and viceversa. It has worked perfectly until a few days ago. How can I restore the old junk "learnt" list? Where is it to be found?

    Mail suddenly marks as spam what is not and viceversa.
    It has worked perfectly until a few days ago. How can I restore the old junk "learnt" list, since it is marking as SPAM senders who have been my correspondants for years?? Where is the old junk pref file to be found?

    Why start a new and very similar thread to your other one which you have not responded to (have you read the replies?)
    I suggest that no response is made to this duplicate thread. 

  • Send information from Oracle DB - PI - NW 7.0 BI and viceversa

    Hello,
    I need to send information from Oracle DB to SAP NW 7.0 BI passing through a SAP PI and viceversa.
    Ho can I do that?
    I need help
    Best Regards...
    Pablo Mortera.

    As the sender is ORacle you can use a sender adapter which is JDBC in XI.
    As the receiver is BI system, try to use either Proxy or RFC or Idoc as a receiver adapter.
    Regards
    Krish

  • Why does my mac wake up from sleep while it is closed when I plug in the charger and viceversa (plug or unplug)?? It is latest 13 Pro with disk drive 2012-2013

         I dont know why it happens. I clos my mac, it goes to sleep and when it is already sleeping if i plug the charger then it wakes up, or at least the fans and the white led light near to the infrared thing turns on. And this also happens if it is sleeping with the charger plugged and whenever i want to quit the plug cause its already charged it turns on. All this happens with the lid (top cover) closed and only when it is sleeping and I unplug when it is pluged, or plug if it is not. I have some more Macbook pro olders 2010, and 2009-8 with 10.9.2, and this thing does not happen to them. Please if someone knows tell me??? If it is not clear is the Macbook Pro 13 with 3.0 usb, disk drive, the latest that apple announced with the disk drive, so i think it is late 2012 or 2013

    There are two distinct sets of settings for Energy-Saver items -- one for Battery, one for Power Adapter.
    When you plug in the adapter, it needs to wake up and change over to the other settings -- sort of like the hospital waking you up to be sure you get your sleeping pill.
    The later versions of Power Management are more sophisticated than older versions, so they are more likely to do this "correctly" -- to wake up and change over.

  • Cannot open Acrobat 6 Pro after opening Reader 8 and viceversa

    There is a compatibility issue between Acrord32.exe and Acrobat.exe files?
    My Acrobat 6 Professional does not open while viewing a PDF in Reader 8, get a empty Reader 8 window instead of Acrobat 6.
    When trying the opposite, the Reader 8 shows the following error message:
    "The Adobe Acrobat/Reader that is running can not be used to view PDF files in a Web Browser. Please exit Adobe Acrobat/Reader and try again."
    Operating system is Windows XP Professional and browser is Internet Explorer 7.

    Reader leaves a resident part running, even after you close it. To open Acrobat, you must first shut down the resident part from the task list.

  • Gregorian to hijri and viceversa javascript

    I have a Javascript for a Hijri / Gregorian calendar.
    I need to get it into Adobe Acrobat PDF.
    The business requirements for this are easy. Just take the script i give you and get it to work in Adobe Acrobat PDF.
    The technical side is tricky. I haven't been able to make it work. When I do it, the conversion works 1 time when you first open the document. then, it only works one way after that. (from gregorian to hijri, never the other way around.)
    1. This MUST be done in Acrobat XI, Not LiveCycle.
    2. I'm using Adobe Acrobat XI Pro. I can't use any other version right now. So this must be able to work on XI and then people need to be able to open and execute this in Reader.
    Here is the code I have written from a HTM file..
    <SCRIPT LANGUAGE="JavaScript">
      function setDateToToday()
        var today = new Date();
        var y = today.getYear();
        var y = today.getYear();
        if (y < 1000) {
            y += 1900;
        document.myform.CYear.value = y;
        document.myform.CMonth.selectedIndex = today.getMonth();
        document.myform.CDay.value = today.getDate();
    // Travis added the following method call to fix the bug where the Hijri date was not set to today by default   
        chrToIsl(0);
    //  LEAP_GREGORIAN  --  Is a given year in the Gregorian calendar a leap year ?
    function leap_gregorian(year)
        return ((year % 4) == 0) &&
                (!(((year % 100) == 0) && ((year % 400) != 0)));
    //  GREGORIAN_TO_JD  --  Determine Julian day number from Gregorian calendar date
    function gregorian_to_jd(year, month, day)
        var GREGORIAN_EPOCH = 1721425.5;
        return (GREGORIAN_EPOCH - 1) +
               (365 * (year - 1)) +
               Math.floor((year - 1) / 4) +
               (-Math.floor((year - 1) / 100)) +
               Math.floor((year - 1) / 400) +
               Math.floor((((367 * month) - 362) / 12) +
               ((month <= 2) ? 0 :
                                   (leap_gregorian(year) ? -1 : -2)
               ) +
               day);
    function mod(a, b)
        return a - (b * Math.floor(a / b));
    function jd_to_gregorian(jd) {
        var wjd, depoch, quadricent, dqc, cent, dcent, quad, dquad,
            yindex, dyindex, year, yearday, leapadj;
        var GREGORIAN_EPOCH = 1721425.5;
        wjd = Math.floor(jd - 0.5) + 0.5;
        depoch = wjd - GREGORIAN_EPOCH;
        quadricent = Math.floor(depoch / 146097);
        dqc = mod(depoch, 146097);
        cent = Math.floor(dqc / 36524);
        dcent = mod(dqc, 36524);
        quad = Math.floor(dcent / 1461);
        dquad = mod(dcent, 1461);
        yindex = Math.floor(dquad / 365);
        year = (quadricent * 400) + (cent * 100) + (quad * 4) + yindex;
        if (!((cent == 4) || (yindex == 4))) {
            year++;
        yearday = wjd - gregorian_to_jd(year, 1, 1);
        leapadj = ((wjd < gregorian_to_jd(year, 3, 1)) ? 0
                      (leap_gregorian(year) ? 1 : 2)
        month = Math.floor((((yearday + leapadj) * 12) + 373) / 367);
        day = (wjd - gregorian_to_jd(year, month, 1)) + 1;
              document.myform.CDay.value = day;
              document.myform.CMonth.value = month;
              document.myform.CYear.value = year;
    function intPart(floatNum){
    if (floatNum< -0.0000001){
               return Math.ceil(floatNum-0.0000001)
    return Math.floor(floatNum+0.0000001)
    function weekDay(wdn){
    // Stubbed this out because we have no interest in showing the days of the week.
      return ""  }
    function chrToIsl(NumberofDays) {
              //alert("Month:" + document.myform.CMonth.value)
              d=parseInt(document.myform.CDay.value)
              m=parseInt(document.myform.CMonth.value)
              y=parseInt(document.myform.CYear.value)
                                                      if ((y>1582)||((y==1582)&&(m>10))||((y==1582)&&(m==10)&&(d>14)))
                                                                jd=intPart((1461*(y+4800+intPart((m-14)/12)))/4)+intPart((3 67*(m-2-12*(intPart((m-14)/12))))/12)-
              intPart( (3* (intPart(  (y+4900+    intPart( (m-14)/12)     )/100)    )   ) /4)+d-32075
                                                                else
                                                                jd = 367*y-intPart((7*(y+5001+intPart((m-9)/7)))/4)+intPart((275*m)/9)+d+1729777
                                                      jd = jd + NumberofDays
                                                      //Stubbed out the weekday/epoch names below to remove them from the HTML page.  jd = epoch time wd = weekday
                                                      //document.myform.JD.value=jd
                                                      //document.myform.wd.value=weekDay(jd%7)
                                                      l=jd-1948440+10632
                                                      n=intPart((l-1)/10631)
                                                      l=l-10631*n+354 
                                                      j=(intPart((10985-l)/5316))*(intPart((50*l)/17719))+(intPart(l/5 670))*(intPart((43*l)/15238))
                                                      l=l-(intPart((30-j)/15))*(intPart((17719*j)/50))-(intPart(j/16)) *(intPart((15238*j)/43))+29
                                                      m=intPart((24*l)/709)
                                                      d=l-intPart((709*m)/24)
                                                      y=30*n+j-30
              jd_to_gregorian(jd)
              document.myform.HDay.value=d
              document.myform.HMonth.value=m
              document.myform.HYear.value=y
    function islToChr( NumberofDays) {
              d=parseInt(document.myform.HDay.value)
              m=parseInt(document.myform.HMonth.value)
              y=parseInt(document.myform.HYear.value)
              jd=intPart((11*y+3)/30)+354*y+30*m-intPart((m-1)/2)+d+1948440-385
              jd = jd + NumberofDays
              //Stubbed out the weekday/epoch names below to remove them from the HTML page.  jd = epoch time wd = weekday
              //document.myform.JD.value=jd
              //document.myform.wd.value=weekDay(jd%7)
                                                      if (jd> 2299160 )
                                                                 l=jd+68569
                                                                 n=intPart((4*l)/146097)
                                                                l=l-intPart((146097*n+3)/4)
                                                                 i=intPart((4000*(l+1))/1461001)
                                                                l=l-intPart((1461*i)/4)+31
                                                                 j=intPart((80*l)/2447)
                                                                d=l-intPart((2447*j)/80)
                                                                l=intPart(j/11)
                                                                m=j+2-12*l
                                                                y=100*(n-49)+i+l
                                                      else
                                                                 j=jd+1402
                                                                 k=intPart((j-1)/1461)
                                                                 l=j-1461*k
                                                                 n=intPart((l-1)/365)-intPart(l/1461)
                                                                 i=l-365*n+30
                                                                j=intPart((80*i)/2447)
                                                                d=i-intPart((2447*j)/80)
                                                                i=intPart(j/11)
                                                                m=j+2-12*i
                                                                y=4*k+n+i-4716
              document.myform.CDay.value=d
              document.myform.CMonth.value=m
              document.myform.CYear.value=y
    </SCRIPT>
        <FORM NAME="myform">
    <strong>gregorian</strong>
      <select size="1" name="CMonth" onChange="chrToIsl(0);">
        <option selected value="1">1</option>
        <option value="2">2</option>
        <option value="3">3</option>
        <option value="4">4</option>
        <option value="5">5</option>
        <option value="6">6</option>
        <option value="7">7</option>
        <option value="8">8</option>
        <option value="9">9</option>
        <option value="10">10</option>
        <option value="11">11</option>
        <option value="12">12</option>
      </select>
    <select size="1" name="CDay"  onChange="chrToIsl(0);">
        <option selected value="1">1</option>
        <option value="2">2</option>
        <option value="3">3</option>
        <option value="4">4</option>
        <option value="5">5</option>
        <option value="6">6</option>
        <option value="7">7</option>
        <option value="8">8</option>
        <option value="9">9</option>
        <option value="10">10</option>
        <option value="11">11</option>
        <option value="12">12</option>
        <option value="13">13</option>
        <option value="14">14</option>
        <option value="15">15</option>
        <option value="16">16</option>
        <option value="17">17</option>
        <option value="18">18</option>
        <option value="19">19</option>
        <option value="20">20</option>
        <option value="21">21</option>
        <option value="22">22</option>
        <option value="23">23</option>
        <option value="24">24</option>
        <option value="25">25</option>
        <option value="26">26</option>
        <option value="27">27</option>
        <option value="28">28</option>
        <option value="29">29</option>
        <option value="30">30</option>
        <option value="31">31</option>
      </select>
    <INPUT TYPE="text" NAME="CYear" VALUE="" SIZE="4" onChange="chrToIsl(0);" onKeyUp="chrToIsl(0);" >
      </p>
    <strong>hijri</strong>
    <select size="1" name="HMonth" onChange="islToChr(0);">
        <option selected value="1">1</option>
        <option value="2">2</option>
        <option value="3">3</option>
        <option value="4">4</option>
        <option value="5">5</option>
        <option value="6">6</option>
        <option value="7">7</option>
        <option value="8">8</option>
        <option value="9">9</option>
        <option value="10">10</option>
        <option value="11">11</option>
        <option value="12">12</option>
      </select>
    <select size="1" name="HDay" onChange="islToChr(0);">
        <option selected value="1">1</option>
        <option value="2">2</option>
        <option value="3">3</option>
        <option value="4">4</option>
        <option value="5">5</option>
        <option value="6">6</option>
        <option value="7">7</option>
        <option value="8">8</option>
        <option value="9">9</option>
        <option value="10">10</option>
        <option value="11">11</option>
        <option value="12">12</option>
        <option value="13">13</option>
        <option value="14">14</option>
        <option value="15">15</option>
        <option value="16">16</option>
        <option value="17">17</option>
        <option value="18">18</option>
        <option value="19">19</option>
        <option value="20">20</option>
        <option value="21">21</option>
        <option value="22">22</option>
        <option value="23">23</option>
        <option value="24">24</option>
        <option value="25">25</option>
        <option value="26">26</option>
        <option value="27">27</option>
        <option value="28">28</option>
        <option value="29">29</option>
        <option value="30">30</option>
      </select>
    <INPUT TYPE="text" NAME="HYear" VALUE="1430" SIZE="4" onChange="islToChr(0);" onKeyUp="islToChr(0);">
    <script>
    setDateToToday();
    </script>
    I just need the functionality if it can be achieved with a better script.

    Hi,
    Issue 1 - it doesn't convert to Hijri date, only Julian date for Hijri (doesn't show the Hijri date but does show two Gregorian dates).
    I am sorry I don't actually know how to convert between the dates, I only used the code that you provided in your initial post and called that from the Acrobat PDF form,
    The sample I provided is how to call the code above using Acrobat.
    Issue 2 -  I want to be able to have the dates default (if blank) to today's date
    That is easy enough to do in that you just use JavaScript to get the current date and time using the Date object.
    And it can convert dynamically as you could just attach the code to the change or exit events of the objects that you are using to select the date and run the code.
    I kept my sample simple and used buttons so it is easy for everyone to see how the code is called as you can look at the preferences of each button to see the JavaScript that is used.
    Regards
    Malcolm

  • People are not receiving all my texts and viceversa

        I just changed this week to the Galaxy Nexus from a 3G phone. Before I had no problems with sending text messages and pictures through stock messages but with the new phone, several of my messages are not being received in the other side. It appears that it has been sent but they just do not arrive. Same with some messages and pictures they send me, some just do not reach my phone. I changed from stck sms (android default) to 3rd party (Handcent or something) still, i do not receive some messages... anyway, same problem. Is this a 4G problem? a Samsung problem? or a Google problem? Is being resolved?
    Is worth to mention that the person I send most sms is on a Metro PCS blackberry, but still I had no problems with my android LG Ally before. Just after I changed to the Nexus. What is the problem here? how do I resolve it?
    Thanks,

    Stito85, thank you for your post. I certainly want to make sure we get your text messages working. I have not seen this issue as a known issue on the Nexus. Is this happening with different people? Are you using any special characters, graphics, signatures, etc in the messages that do not send? Try deleting your SMS thread with the number it is happening with mostly and try sending text messages again. If the issue is still occurring, we may need to submit a trouble ticket to our network team. In that case, we'll need the dates and times that the messages were sent and from which number so we can further investigate.
    Let me know if you need additional assistance.
      MarquiaF_VZW
    Follow us on Twitter @VZWSupport

  • Front panel indicators used as controllers and viceversa

    It is possible to use indicators also as controllers?
    I would like to load data from a file and then to be able to edit that data.
    Kind regards

    Hi vick217
    this is the Spanish board. But I think  a "Local Variable" or a Value "Property Node"
    could work for you.
    Regards.

  • No traffic from Outside1 (Security level 100) attached Networks to DMZ and Viceversa

    I have an ASA5510, i configured an Outside, 1 DMZ and 2 interfaces 100 security level (Outside1 and Inside). I can ping and have fluid traffic between DMZ and Inside interface, but don't have any kind of traffic between DMZ and the Outside1. I wrote the same configuration for both 100 Security Level interfaces. Also I have connected a Cisco 892 router to Outside1. When i have attached a computer instead of 892, traffic between Outside1 and DMZ is fluid. i need to have fluid traffic between networks connected to 892
    Someone can help me? Here are the 2 configs:
    ASA5510:
    : Saved
    ASA Version 8.2(1)
    hostname ASAFCHFW
    domain-name a.b.c
    enable password 6Jfo5anznhoG00fM encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    interface Ethernet0/0
     nameif Outside
     security-level 0
     ip address x.y.z.162 255.255.255.248
    interface Ethernet0/1
     nameif Outside1
     security-level 100
     ip address 192.168.2.1 255.255.255.0
    interface Ethernet0/2
     nameif DMZ
     security-level 10
     ip address 172.16.31.1 255.255.255.0
    interface Ethernet0/3
     nameif Inside
     security-level 100
     ip address 192.168.0.1 255.255.255.0
    interface Management0/0
     nameif management
     security-level 100
     ip address 192.168.1.1 255.255.255.0
     management-only
    boot system disk0:/asa821-k8.bin
    ftp mode passive
    dns server-group DefaultDNS
     domain-name farmaciachavez.com.bo
    same-security-traffic permit inter-interface
    same-security-traffic permit intra-interface
    access-list dmz_in extended permit tcp host 172.16.31.2 any eq domain
    access-list dmz_in extended permit tcp host 172.16.31.2 any eq smtp
    access-list dmz_in extended permit tcp host 172.16.31.2 any eq www
    access-list dmz_in extended permit tcp host 172.16.31.2 any eq https
    access-list dmz_in extended permit tcp host 172.16.31.2 any eq 3000
    access-list dmz_in extended permit tcp host 172.16.31.2 any eq 1000
    access-list Inside extended permit ip any any
    access-list Inside extended permit icmp any any
    access-list 100 extended permit tcp any host x.y.z.163 eq smtp
    access-list 100 extended permit udp any host x.y.z.163 eq domain
    access-list 100 extended permit tcp any host x.y.z.163 eq https
    access-list 100 extended permit tcp any host x.y.z.163 eq www
    access-list 100 extended permit tcp any host x.y.z.163 eq 3000
    access-list 100 extended permit tcp any host x.y.z.163 eq 1000
    pager lines 24
    logging enable
    logging buffered debugging
    logging asdm informational
    mtu Outside 1500
    mtu Outside1 1500
    mtu DMZ 1500
    mtu Inside 1500
    mtu management 1500
    icmp unreachable rate-limit 1 burst-size 1
    icmp permit host 192.168.0.22 Outside
    icmp permit 192.168.0.0 255.255.255.0 Outside1
    icmp permit 192.168.2.0 255.255.255.0 Outside1
    icmp permit 172.16.31.0 255.255.255.0 Outside1
    icmp permit 192.168.2.0 255.255.255.0 DMZ
    icmp permit 192.168.2.0 255.255.255.0 Inside
    icmp permit 192.168.0.0 255.255.255.0 Inside
    icmp permit 172.16.31.0 255.255.255.0 Inside
    asdm image disk0:/asdm-647.bin
    asdm history enable
    arp timeout 14400
    global (Outside) 101 interface
    nat (Outside1) 101 0.0.0.0 0.0.0.0
    nat (DMZ) 101 0.0.0.0 0.0.0.0
    nat (Inside) 101 0.0.0.0 0.0.0.0
    static (DMZ,Outside) x.y.z.163 172.16.31.0 netmask 255.255.255.255
    static (DMZ,Inside) 172.16.31.0 172.16.31.0 netmask 255.255.255.0
    static (Outside1,Inside) 192.168.2.0 192.168.2.0 netmask 255.255.255.0
    static (Inside,DMZ) 192.168.0.0 192.168.0.0 netmask 255.255.255.0
    static (Inside,Outside1) 192.168.0.0 192.168.0.0 netmask 255.255.255.0
    static (Outside1,Inside) 172.1.1.0 172.1.1.0 netmask 255.255.255.0
    static (DMZ,Outside1) 172.16.31.0 172.16.31.0 netmask 255.255.255.0
    static (Outside1,DMZ) 192.168.2.0 192.168.2.0 netmask 255.255.255.0
    static (Outside1,Inside) 172.1.2.0 172.1.2.0 netmask 255.255.255.0
    static (Outside1,Inside) 172.1.3.0 172.1.3.0 netmask 255.255.255.0
    static (Outside1,Inside) 192.168.3.0 192.168.3.0 netmask 255.255.255.0
    static (Outside1,DMZ) 172.1.1.0 172.1.1.0 netmask 255.255.255.0
    access-group dmz_in in interface DMZ
    route Outside 0.0.0.0 0.0.0.0 x.y.z.161 20
    route Outside1 172.1.1.0 255.255.255.0 192.168.2.2 1
    route Outside1 172.1.2.0 255.255.255.0 192.168.2.2 1
    route Outside1 172.1.3.0 255.255.255.0 192.168.2.2 1
    route Outside1 192.1.0.0 255.255.192.0 192.168.2.2 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    dynamic-access-policy-record DfltAccessPolicy
    http server enable
    http 192.168.1.0 255.255.255.0 management
    http 192.168.0.0 255.255.255.0 Inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    telnet 192.168.0.0 255.255.255.0 Inside
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    dhcpd address 192.168.1.2-192.168.1.254 management
    dhcpd enable management
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    class-map inspection_default
     match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
     parameters
      message-length maximum 512
    policy-map global_policy
     class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
    service-policy global_policy global
    prompt hostname context
    Cryptochecksum:7441424d1fcf87c3eb837b569e84aa9e
    : end
    Cisco 892:
    Current configuration : 3296 bytes
    ! Last configuration change at 01:15:13 UTC Tue Apr 29 2014 by eguerra
    version 15.2
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname RouterHQFCH
    boot-start-marker
    boot-end-marker
    enable secret 4 
    no aaa new-model
    ip cef
    no ipv6 cef
    multilink bundle-name authenticated
    crypto pki trustpoint TP-self-signed-1580540949
     enrollment selfsigned
     subject-name cn=IOS-Self-Signed-Certificate-1580540949
     revocation-check none
     rsakeypair TP-self-signed-1580540949
    crypto pki certificate chain TP-self-signed-1580540949
     certificate self-signed 01
      3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
      31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
      69666963 6174652D 31353830 35343039 3439301E 170D3134 30343134 31393433
      30315A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
      4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 35383035
      34303934 3930819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
      8100BC61 7D5F7F47 65203EC9 1207B83F 19EC7AC3 00404F99 A89FD64B 1F0F659F
      E99062C2 3BB1E517 075BAF59 D361FFC9 4F872A14 A7528061 CF936F40 D03F234B
      5641147F D2B4AB7D 9E10F36A 087F511B F68ABC6E 98F96C74 8EF5084B F490D91B
      0EC05671 D8C5B7DD EE8F48C2 CD76F7C9 B8405DD6 42375B3C 8D04FDEF 555D0FA0
      0FDF0203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
      551D2304 18301680 14FCB587 54EE2C1B 2B6DB648 A6FC0ECF 85062C8F 6A301D06
      03551D0E 04160414 FCB58754 EE2C1B2B 6DB648A6 FC0ECF85 062C8F6A 300D0609
      2A864886 F70D0101 05050003 81810033 A196E361 A273E890 146EF605 D7AB9235
      52BA28F8 A526D8AE CD903257 E4E81C76 C85FBCD4 201DFF90 11FB1617 9210037E
      B66299B3 FB2173D2 AFEC9B52 D2221BEA 9B8CC180 BE36F3AB D5811F9F 401043B0
      4BDA8647 897D8FE7 6D753C4F 3C76A493 2C260C22 24E966EB BEE54A2A 51D58F21
      23080B9D 9C5FD690 62C6B0C9 30C3AA
            quit
    license udi pid C892FSP-K9 sn FTX180484TB
    username servicios privilege 15 password 7 
    username eguerra privilege 15 password 7 
    interface GigabitEthernet0
     no ip address
    interface GigabitEthernet1
     switchport access vlan 2
     no ip address
    interface GigabitEthernet2
     no ip address
    interface GigabitEthernet3
     no ip address
    interface GigabitEthernet4
     no ip address
    interface GigabitEthernet5
     no ip address
    interface GigabitEthernet6
     no ip address
    interface GigabitEthernet7
     no ip address
    interface GigabitEthernet8
     ip address 172.1.1.1 255.255.255.0
     duplex auto
     speed auto
    interface GigabitEthernet9
     ip address 172.1.2.1 255.255.255.0
     duplex auto
     speed auto
    interface Vlan1
     ip address 192.168.2.2 255.255.255.0
    interface Vlan2
     ip address 192.168.100.200 255.255.255.0
    ip forward-protocol nd
    ip http server
    ip http authentication local
    ip http secure-server
    ip route 172.16.31.0 255.255.255.0 192.168.2.1
    ip route 192.168.0.0 255.255.255.0 192.168.2.1
    control-plane
    line con 0
     password 7 
     login
     no modem enable
    line aux 0
    line vty 0 4
     password 7 
     login local
     transport input all
    scheduler allocate 20000 1000
    end
    Thanks in advance

    Maybe I did not understand what you are trying to accomplish. What I mentioned was to make your ACL configuration better, meaning more secure. Changing the security level just helps understand that you are not coming from a site that does not require ACLs, thus from lower to higher security interfaces you need to place ACLs, then there is a hole other world regarding NAT/PAT that involve same security interfaces that sometimes confuse customers so I also wanted to avoid that for you.
    To enforce security between interfaces you need to know what protocols and ports are being used by servers that reside behind the higher security interface so you only open what is needed then block the rest to that higher security interface.

  • Hi, i've a question, how to comunicate from servlet to a JSP and viceversa?

    i would like to know how to do this and if its possible an example i'll appretiate it much. thanks

    You have a mechanism called "forwarding", with which you can pass control from one resource (servlet/jsp) to another resource (servlet/jsp). You do this using a RequestDispatcher, which you can get from the HttpServletRequest object. If for example you want to forward to "index.jsp" which is in the root of your web application, you would do this in your servlet:
    RequestDispatcher rd = request.getRequestDispatcher("/index.jsp");
    rd.forward(request, response);
    return;(watch the return statement, you must manually return after a forward, or else the servlet will continue executing!). A forward will NOT create a new request, the same request is passed to the new resource (to create a new request, use a redirect in stead, also done with the RequestDispatcher).
    To pass objects between the two resources when doing a forward, use request.setAttribute(), request.getAttribute() and jsp:useBean.

Maybe you are looking for

  • Non confirmed PO

    Hi, Could you please comment on this .. 1.Once I issued the PO to vendor, I will mention the Confirmation of vendor in the PO(ME22N) . Is there any standard report in SAP that can provide the list of non confirmed PO by the vendor ? 2.We can maintain

  • Repeating Sections on Group By displayed as drop downs

    Hi All, We have a requirement to build an interactive report using the Web Layout Editor. We have a Repeating Section based on Group By to be displayed within the report. These are currently displayed as drop downs and currently it is not displaying

  • Send pdf and xml  to URL on one click

    My scenario is: -online Adobe form in ZCI layout with XML based interface created in webdynpro. -In webdynpro (form is embedded) Vendor fills out the form with the requested Payment, clicks the button and the form is saved at URL. -Then Approver will

  • Iphoto sync with apple tv crash itunes

    When I try to sync my photos using iphoto to my apple tv, itunes latest version crashes. I have been able to sync the photos without using iphoto, any ideas. I think that this is a bug.

  • Cover flow sluggish

    So I updated to iTunes 10.4 this evening on my windows 7 64 bit machine. All working ok but noticed cover flow is now pretty laggy/sluggish. Anyone else get the same. It was fine on 10.3. To my really fussy eye I do think it's a bit sluggish especial