Changing msec to hh:mm:ss

How can I change msec to hh:mm:ss.
ex. int msec = 45667 to hh:mm:ss
thank you

import java.util.*;
import java.text.*;
public class FormatTime {
public static void main(String[] args){
     try{
     //DateFormat df=DateFormat.getTimeInstance(DateFormat.SHORT);
     SimpleDateFormat sf=new SimpleDateFormat("hh:mm:ss");
     System.out.println(sf.format(new Date(0,0,0,4,56,67)));
     }catch(Exception exe){
          exe.printStackTrace();
U can either give the msec distinctely the way i have given it to the Date constructor, or use a string representation .
Hope this helps
Arathi.

Similar Messages

  • How to change CUE ip address?

    Hi,
    We moved to a new location and using comcast as ISP. I was setting up the phone system today and met a few problems.
    1. First of all, all the phones are connected and working(total of 4), but I can only see 3 of them showing up in the CCA. Whats happening here?
    2. I wanted to change the user name which appears on the phone using the CCA, CCA told me that the settings were successfully sent to UC520, I restarted the phone and uc520, but the names on the phones remain unchanged?
    3. I forgot the password of the voicemail for one of the phone, and wanted to changed in the CUE. so I went to 10.1.10.1,but some comcast login page showed up instead of CUE. so I want to know how to change the IP address of CUE? I don`t know the CLI commands so please teach me if it can only be done with CLI. I have only used CCA in the past. Could this be the reason why for problem 1 and 2? I`m feeling wierd because all the phones can be used to call in/out.
    my data vlan is 192.168.0.0 and voice vlan is 192.168.2.0 let me know if you need any other info.
    need help urgently as I want to resolve this problem asap.
    Thanks in advance.
    Building configuration...
    Current configuration : 31483 bytes
    ! Last configuration change at 19:39:02 EST Mon Jan 27 2014 by admin
    version 15.1
    parser config cache interface
    no service pad
    no service timestamps debug uptime
    service timestamps log datetime msec
    service password-encryption
    service internal
    service compress-config
    service sequence-numbers
    hostname UC_520
    boot-start-marker
    boot-end-marker
    no logging buffered
    no logging rate-limit
    enable secret 4 X4ZqtPJ///KxuEWxHSsJrv3beQVnz2ise/xj8fF6eFU
    aaa new-model
    aaa authentication login default local
    aaa session-id common
    clock timezone EST -5 0
    clock summer-time EDT recurring
    crypto pki token default removal timeout 0
    crypto pki trustpoint TP-self-signed-3885458945
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-3885458945
    revocation-check none
    rsakeypair TP-self-signed-3885458945
    crypto pki certificate chain TP-self-signed-3885458945
    certificate self-signed 01
      3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
      31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
      69666963 6174652D 33383835 34353839 3435301E 170D3133 30383136 32303534
      32305A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
      4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 38383534
      35383934 3530819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
      8100E470 89FBE9D2 67ED2223 338A6991 0CF59918 BDEF6020 545DFCAF 93A17C39
      BEE49E0E 4EDEE26B CCE65E3E 44443BFC E1CE6B5E FE8906DA 3290C015 450721F3
      8FB997D1 74A9EAD1 2FB11EAF 7E346F69 4AF873DE A93DCCC0 0607406E 09C0D5D4
      47552B50 34398AF9 A5F9CC57 1A2CBCE8 D8DCE2E9 6702F3DD 77505122 2284BDC8
      96730203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
      551D2304 18301680 14F3FB0C E861F89C 588B7B22 97DCB6B8 95F52EAF 3F301D06
      03551D0E 04160414 F3FB0CE8 61F89C58 8B7B2297 DCB6B895 F52EAF3F 300D0609
      2A864886 F70D0101 05050003 81810067 7B14BD34 CF6FE9A5 C2B125A9 347023AD
      58DAB6CB E64FA260 41DA2B0B 1921A21D BAED2A0F 47172233 A589F64D 74D70BB5
      2790DE19 B905BCFF 18DB2EE5 F397C92D 7522DEB0 B4968E27 0F2CCF98 DCCE40C5
      4BF1736A 1C945AFA E0EF7A33 E529F94C CC99549A 051CA1BD E33495DB 0B79451C
      5666954E 10E691DF 5D5CCC50 CB72D2
          quit
    dot11 syslog
    dot11 ssid cisco-data
    vlan 1
    authentication open
    dot11 ssid cisco-voice
    vlan 100
    authentication open
    ip source-route
    ip cef
    ip dhcp relay information trust-all
    ip dhcp excluded-address 192.168.0.1 192.168.0.99
    ip dhcp excluded-address 192.168.0.151 192.168.0.255
    ip dhcp excluded-address 192.168.2.1 192.168.2.9
    ip dhcp excluded-address 192.168.2.241 192.168.2.255
    ip dhcp excluded-address 192.168.2.99
    ip dhcp pool phone
    network 192.168.2.0 255.255.255.0
    default-router 192.168.2.99
    option 150 ip 192.168.2.99
    ip name-server 205.152.111.23
    ip name-server 205.152.144.23
    ip inspect WAAS flush-timeout 10
    ip inspect name SDM_LOW dns
    ip inspect name SDM_LOW ftp
    ip inspect name SDM_LOW h323
    ip inspect name SDM_LOW https
    ip inspect name SDM_LOW icmp
    ip inspect name SDM_LOW imap
    ip inspect name SDM_LOW pop3
    ip inspect name SDM_LOW netshow
    ip inspect name SDM_LOW rcmd
    ip inspect name SDM_LOW realaudio
    ip inspect name SDM_LOW rtsp
    ip inspect name SDM_LOW esmtp
    ip inspect name SDM_LOW sqlnet
    ip inspect name SDM_LOW streamworks
    ip inspect name SDM_LOW tftp
    ip inspect name SDM_LOW tcp router-traffic
    ip inspect name SDM_LOW udp router-traffic
    ip inspect name SDM_LOW vdolive
    no ipv6 cef
    multilink bundle-name authenticated
    stcapp ccm-group 1
    stcapp
    trunk group ALL_FXO
    max-retry 5
    voice-class cause-code 1
    hunt-scheme longest-idle
    voice call send-alert
    voice rtp send-recv
    voice service voip
    allow-connections h323 to h323
    allow-connections h323 to sip
    allow-connections sip to h323
    allow-connections sip to sip
    supplementary-service h450.12
    sip
      no update-callerid
    voice class codec 1
    codec preference 1 g711ulaw
    codec preference 2 g729r8
    voice class cause-code 1
    no-circuit
    voice register global
    mode cme
    source-address 192.168.2.99 port 5060
    max-dn 88
    max-pool 22
    load 9971 sip9971.9-2-2
    load 9951 sip9951.9-2-2
    load 8961 sip8961.9-2-2
    timezone 12
    create profile sync 0423457390373118
    voice hunt-group 1 parallel
    final 201
    list 201,223,227,239,301
    timeout 16
    pilot 511
    voice translation-rule 1000
    rule 1 /.*/ //
    voice translation-rule 1112
    rule 1 /^9/ //
    voice translation-rule 2001
    voice translation-rule 2002
    rule 1 /^6/ //
    voice translation-rule 2222
    rule 1 /^91900......./ //
    rule 2 /^91976......./ //
    voice translation-profile CALLER_ID_TRANSLATION_PROFILE
    translate calling 1111
    voice translation-profile CallBlocking
    translate called 2222
    voice translation-profile OUTGOING_TRANSLATION_PROFILE
    translate called 1112
    voice translation-profile XFER_TO_VM_PROFILE
    translate redirect-called 2002
    voice translation-profile nondialable
    translate called 1000
    voice-card 0
    fax interface-type fax-mail
    license udi pid UC520W-16U-4FXO-K9 sn FTX1251Y0DC
    archive
    log config
      logging enable
      logging size 600
      hidekeys
    username admin privilege 15 secret 4 X4ZqtPJ///KxuEWxHSsJrv3beQVnz2ise/xj8fF6eFU
    ip tftp source-interface Loopback0
    class-map match-all _class_Voice0
    match ip dscp ef
    class-map match-all _class_Voice1
    match ip dscp cs3
    policy-map Voice
    class _class_Voice0
      set cos 6
    class _class_Voice1
      set cos 3
    bridge irb
    interface Loopback0
    description $FW_INSIDE$
    ip address 10.1.10.2 255.255.255.252
    ip access-group 101 in
    ip nat inside
    ip virtual-reassembly in
    interface FastEthernet0/0
    description $ETH-WAN$
    no ip address
    ip virtual-reassembly in
    load-interval 30
    duplex auto
    speed auto
    pppoe enable group global
    pppoe-client dial-pool-number 1
    interface Integrated-Service-Engine0/0
    description cue is initialized with default IMAP group
    ip unnumbered Loopback0
    ip nat inside
    ip virtual-reassembly in
    service-module ip address 10.1.10.1 255.255.255.252
    service-module ip default-gateway 10.1.10.2
    interface FastEthernet0/1/0
    switchport voice vlan 100
    no ip address
    macro description cisco-phone
    spanning-tree portfast
    interface FastEthernet0/1/1
    switchport voice vlan 100
    no ip address
    macro description cisco-phone
    spanning-tree portfast
    interface FastEthernet0/1/2
    switchport voice vlan 100
    no ip address
    macro description cisco-phone
    spanning-tree portfast
    interface FastEthernet0/1/3
    switchport voice vlan 100
    no ip address
    macro description cisco-phone
    spanning-tree portfast
    interface FastEthernet0/1/4
    switchport voice vlan 100
    no ip address
    macro description cisco-phone
    spanning-tree portfast
    interface FastEthernet0/1/5
    switchport voice vlan 100
    no ip address
    macro description cisco-phone
    spanning-tree portfast
    interface FastEthernet0/1/6
    switchport voice vlan 100
    no ip address
    macro description cisco-phone
    spanning-tree portfast
    interface FastEthernet0/1/7
    switchport voice vlan 100
    no ip address
    macro description cisco-phone
    spanning-tree portfast
    interface FastEthernet0/1/8
    switchport mode trunk
    switchport voice vlan 100
    no ip address
    macro description cisco-switch
    interface Dot11Radio0/5/0
    no ip address
    ssid cisco-data
    ssid cisco-voice
    speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
    station-role root
    antenna receive right
    antenna transmit right
    service-policy output Voice
    interface Dot11Radio0/5/0.1
    encapsulation dot1Q 1 native
    bridge-group 1
    bridge-group 1 subscriber-loop-control
    bridge-group 1 spanning-disabled
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    interface Dot11Radio0/5/0.100
    encapsulation dot1Q 100
    bridge-group 100
    bridge-group 100 subscriber-loop-control
    bridge-group 100 spanning-disabled
    bridge-group 100 block-unknown-source
    no bridge-group 100 source-learning
    no bridge-group 100 unicast-flooding
    interface Vlan1
    no ip address
    bridge-group 1
    bridge-group 1 spanning-disabled
    interface Vlan100
    no ip address
    bridge-group 100
    bridge-group 100 spanning-disabled
    interface Dialer0
    description $FW_OUTSIDE$
    ip address negotiated
    ip access-group 109 in
    ip mtu 1452
    ip nat outside
    ip inspect SDM_LOW out
    ip virtual-reassembly in
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication chap pap callin
    ppp chap hostname [email protected]
    ppp chap password 7 121D001B1E535E56
    ppp pap sent-username [email protected] password 7 121D001B1E535E56
    ppp ipcp dns request
    interface BVI1
    ip address 192.168.0.55 255.255.255.0
    ip access-group 104 in
    ip access-group 108 out
    ip helper-address 192.168.0.99
    ip nat inside
    ip virtual-reassembly in
    ip tcp adjust-mss 1412
    interface BVI100
    description $FW_INSIDE$
    ip address 192.168.2.99 255.255.255.0
    ip access-group 102 in
    ip access-group 107 out
    ip nat inside
    ip virtual-reassembly in
    ip tcp adjust-mss 1412
    ip forward-protocol nd
    ip http server
    ip http authentication local
    ip http secure-server
    ip http path flash:/gui
    ip dns server
    ip nat inside source list 1 interface Dialer0 overload
    ip route 0.0.0.0 0.0.0.0 192.168.0.99
    ip route 10.1.10.1 255.255.255.255 Integrated-Service-Engine0/0
    access-list 1 remark SDM_ACL Category=2
    access-list 1 permit 10.1.1.0 0.0.0.255
    access-list 1 permit 192.168.0.0 0.0.0.255
    access-list 1 permit 10.1.10.0 0.0.0.3
    access-list 100 remark auto generated by SDM firewall configuration
    access-list 100 remark SDM_ACL Category=1
    access-list 100 permit ip 192.168.10.0 0.0.0.255 any
    access-list 100 deny   ip host 255.255.255.255 any
    access-list 100 deny   ip 127.0.0.0 0.255.255.255 any
    access-list 100 permit ip any any
    access-list 101 remark auto generated by SDM firewall configuration##NO_ACES_6##
    access-list 101 remark SDM_ACL Category=1
    access-list 101 permit tcp 192.168.2.0 0.0.0.255 eq 2000 any
    access-list 101 permit udp 192.168.2.0 0.0.0.255 eq 2000 any
    access-list 101 permit ip 192.168.2.0 0.0.0.255 any
    access-list 101 deny   ip host 255.255.255.255 any
    access-list 101 deny   ip 127.0.0.0 0.255.255.255 any
    access-list 101 permit ip any any
    access-list 102 remark auto generated by SDM firewall configuration##NO_ACES_6##
    access-list 102 remark SDM_ACL Category=1
    access-list 102 permit tcp 10.1.10.0 0.0.0.3 any eq 2000
    access-list 102 permit udp 10.1.10.0 0.0.0.3 any eq 2000
    access-list 102 permit ip 10.1.10.0 0.0.0.3 any
    access-list 102 deny   ip host 255.255.255.255 any
    access-list 102 deny   ip 127.0.0.0 0.255.255.255 any
    access-list 102 permit ip any any
    access-list 103 remark SDM_ACL Category=64
    access-list 103 permit ip any any
    access-list 104 remark SDM_ACL Category=64
    access-list 104 permit ip any any
    access-list 105 remark SDM_ACL Category=64
    access-list 105 permit ip any any
    access-list 106 remark SDM_ACL Category=64
    access-list 106 permit ip any any
    access-list 107 remark SDM_ACL Category=64
    access-list 107 permit ip any any
    access-list 108 remark SDM_ACL Category=64
    access-list 108 permit ip any any
    access-list 109 remark auto generated by SDM firewall configuration##NO_ACES_14##
    access-list 109 remark SDM_ACL Category=1
    access-list 109 permit ip 10.1.10.0 0.0.0.3 any
    access-list 109 permit ip 192.168.2.0 0.0.0.255 any
    access-list 109 permit udp host 205.152.111.23 eq domain any
    access-list 109 permit udp host 205.152.144.23 eq domain any
    access-list 109 permit icmp any any echo-reply
    access-list 109 permit icmp any any time-exceeded
    access-list 109 permit icmp any any unreachable
    access-list 109 permit ip 10.0.0.0 0.255.255.255 any
    access-list 109 deny   ip 172.16.0.0 0.15.255.255 any
    access-list 109 permit ip 192.168.0.0 0.0.255.255 any
    access-list 109 deny   ip 127.0.0.0 0.255.255.255 any
    access-list 109 deny   ip host 255.255.255.255 any
    access-list 109 permit ip host 0.0.0.0 any
    access-list 109 permit ip any any
    dialer-list 1 protocol ip permit
    snmp-server community public RO
    tftp-server flash:/phones/521_524/cp524g-8-1-17.bin alias cp524g-8-1-17.bin
    tftp-server flash:/phones/7916/B016-1-0-4.SBN alias B016-1-0-4.SBN
    tftp-server flash:/phones/7937/apps37sccp.1-4-4-0.bin alias apps37sccp.1-4-4-0.bin
    tftp-server flash:/phones/7940_7960/P00308010200.bin alias P00308010200.bin
    tftp-server flash:/phones/7940_7960/P00308010200.loads alias P00308010200.loads
    tftp-server flash:/phones/7940_7960/P00308010200.sb2 alias P00308010200.sb2
    tftp-server flash:/phones/7940_7960/P00308010200.sbn alias P00308010200.sbn
    tftp-server flash:/phones/7941_7961/apps41.9-1-1TH1-16.sbn alias apps41.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7941_7961/cnu41.9-1-1TH1-16.sbn alias cnu41.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7941_7961/cvm41sccp.9-1-1TH1-16.sbn alias cvm41sccp.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7941_7961/dsp41.9-1-1TH1-16.sbn alias dsp41.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7941_7961/jar41sccp.9-1-1TH1-16.sbn alias jar41sccp.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7941_7961/SCCP41.9-1-1SR1S.loads alias SCCP41.9-1-1SR1S.loads
    tftp-server flash:/phones/7941_7961/term41.default.loads alias term41.default.loads
    tftp-server flash:/phones/7941_7961/term61.default.loads alias term61.default.loads
    tftp-server flash:/phones/7942_7962/apps42.9-1-1TH1-16.sbn alias apps42.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7942_7962/cnu42.9-1-1TH1-16.sbn alias cnu42.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7942_7962/cvm42sccp.9-1-1TH1-16.sbn alias cvm42sccp.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7942_7962/dsp42.9-1-1TH1-16.sbn alias dsp42.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7942_7962/jar42sccp.9-1-1TH1-16.sbn alias jar42sccp.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7942_7962/SCCP42.9-1-1SR1S.loads alias SCCP42.9-1-1SR1S.loads
    tftp-server flash:/phones/7942_7962/term42.default.loads alias term42.default.loads
    tftp-server flash:/phones/7942_7962/term62.default.loads alias term62.default.loads
    tftp-server flash:/phones/7945_7965/apps45.9-1-1TH1-16.sbn alias apps45.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7945_7965/cnu45.9-1-1TH1-16.sbn alias cnu45.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7945_7965/cvm45sccp.9-1-1TH1-16.sbn alias cvm45sccp.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7945_7965/dsp45.9-1-1TH1-16.sbn alias dsp45.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7945_7965/jar45sccp.9-1-1TH1-16.sbn alias jar45sccp.9-1-1TH1-16.sbn
    tftp-server flash:/phones/7945_7965/SCCP45.9-1-1SR1S.loads alias SCCP45.9-1-1SR1S.loads
    tftp-server flash:/phones/7945_7965/term45.default.loads alias term45.default.loads
    tftp-server flash:/phones/7945_7965/term65.default.loads alias term65.default.loads
    tftp-server flash:/ringtones/Analog1.raw alias Analog1.raw
    tftp-server flash:/ringtones/Analog2.raw alias Analog2.raw
    tftp-server flash:/ringtones/AreYouThere.raw alias AreYouThere.raw
    tftp-server flash:/ringtones/DistinctiveRingList.xml alias DistinctiveRingList.xml
    tftp-server flash:/ringtones/RingList.xml alias RingList.xml
    tftp-server flash:/ringtones/AreYouThereF.raw alias AreYouThereF.raw
    tftp-server flash:/ringtones/Bass.raw alias Bass.raw
    tftp-server flash:/ringtones/CallBack.raw alias CallBack.raw
    tftp-server flash:/ringtones/Chime.raw alias Chime.raw
    tftp-server flash:/ringtones/Classic1.raw alias Classic1.raw
    tftp-server flash:/ringtones/Classic2.raw alias Classic2.raw
    tftp-server flash:/ringtones/ClockShop.raw alias ClockShop.raw
    tftp-server flash:/ringtones/Drums1.raw alias Drums1.raw
    tftp-server flash:/ringtones/Drums2.raw alias Drums2.raw
    tftp-server flash:/ringtones/FilmScore.raw alias FilmScore.raw
    tftp-server flash:/ringtones/HarpSynth.raw alias HarpSynth.raw
    tftp-server flash:/ringtones/Jamaica.raw alias Jamaica.raw
    tftp-server flash:/ringtones/KotoEffect.raw alias KotoEffect.raw
    tftp-server flash:/ringtones/MusicBox.raw alias MusicBox.raw
    tftp-server flash:/ringtones/Piano1.raw alias Piano1.raw
    tftp-server flash:/ringtones/Piano2.raw alias Piano2.raw
    tftp-server flash:/ringtones/Pop.raw alias Pop.raw
    tftp-server flash:/ringtones/Pulse1.raw alias Pulse1.raw
    tftp-server flash:/ringtones/Ring1.raw alias Ring1.raw
    tftp-server flash:/ringtones/Ring2.raw alias Ring2.raw
    tftp-server flash:/ringtones/Ring3.raw alias Ring3.raw
    tftp-server flash:/ringtones/Ring4.raw alias Ring4.raw
    tftp-server flash:/ringtones/Ring5.raw alias Ring5.raw
    tftp-server flash:/ringtones/Ring6.raw alias Ring6.raw
    tftp-server flash:/ringtones/Ring7.raw alias Ring7.raw
    tftp-server flash:/ringtones/Sax1.raw alias Sax1.raw
    tftp-server flash:/ringtones/Sax2.raw alias Sax2.raw
    tftp-server flash:/ringtones/Vibe.raw alias Vibe.raw
    tftp-server flash:/Desktops/CampusNight.png
    tftp-server flash:/Desktops/TN-CampusNight.png
    tftp-server flash:/Desktops/CiscoFountain.png
    tftp-server flash:/Desktops/TN-CiscoFountain.png
    tftp-server flash:/Desktops/CiscoLogo.png
    tftp-server flash:/Desktops/TN-CiscoLogo.png
    tftp-server flash:/Desktops/Fountain.png
    tftp-server flash:/Desktops/TN-Fountain.png
    tftp-server flash:/Desktops/MorroRock.png
    tftp-server flash:/Desktops/TN-MorroRock.png
    tftp-server flash:/Desktops/NantucketFlowers.png
    tftp-server flash:/Desktops/TN-NantucketFlowers.png
    tftp-server flash:Desktops/320x212x16/List.xml
    tftp-server flash:Desktops/320x212x12/List.xml
    tftp-server flash:Desktops/320x216x16/List.xml
    tftp-server flash:/bacdprompts/en_bacd_allagentsbusy.au alias en_bacd_allagentsbusy.au
    tftp-server flash:/bacdprompts/en_bacd_disconnect.au alias en_bacd_disconnect.au
    tftp-server flash:/bacdprompts/en_bacd_enter_dest.au alias en_bacd_enter_dest.au
    tftp-server flash:/bacdprompts/en_bacd_invalidoption.au alias en_bacd_invalidoption.au
    tftp-server flash:/bacdprompts/en_bacd_music_on_hold.au alias en_bacd_music_on_hold.au
    tftp-server flash:/bacdprompts/en_bacd_options_menu.au alias en_bacd_options_menu.au
    tftp-server flash:/bacdprompts/en_bacd_welcome.au alias en_bacd_welcome.au
    tftp-server flash:/bacdprompts/en_bacd_xferto_operator.au alias en_bacd_xferto_operator.au
    radius-server attribute 31 send nas-port-detail
    control-plane
    bridge 1 route ip
    bridge 100 route ip
    voice-port 0/0/0
    shutdown
    caller-id enable
    voice-port 0/0/1
    shutdown
    caller-id enable
    voice-port 0/0/2
    shutdown
    caller-id enable
    voice-port 0/0/3
    shutdown
    caller-id enable
    voice-port 0/1/0
    trunk-group ALL_FXO 64
    connection plar 201
    shutdown
    caller-id enable
    voice-port 0/1/1
    trunk-group ALL_FXO 64
    connection plar opx 511
    description Configured by CCA 4 FXO-0/1/1-Custom-BG
    caller-id enable
    voice-port 0/1/2
    trunk-group ALL_FXO 64
    connection plar opx 511
    description Configured by CCA 4 FXO-0/1/2-Custom-BG
    caller-id enable
    voice-port 0/1/3
    trunk-group ALL_FXO 64
    connection plar 204
    shutdown
    caller-id enable
    voice-port 0/4/0
    auto-cut-through
    signal immediate
    input gain auto-control -15
    description Music On Hold Port
    sccp local Loopback0
    sccp ccm 192.168.2.99 identifier 1 version 3.1
    sccp
    sccp ccm group 1
    associate ccm 1 priority 1
    dial-peer cor custom
    name internal
    name local
    name local-plus
    name international
    name national
    name national-plus
    name emergency
    name toll-free
    dial-peer cor list call-internal
    member internal
    dial-peer cor list call-local
    member local
    dial-peer cor list call-local-plus
    member local-plus
    dial-peer cor list call-national
    member national
    dial-peer cor list call-national-plus
    member national-plus
    dial-peer cor list call-international
    member international
    dial-peer cor list call-emergency
    member emergency
    dial-peer cor list call-toll-free
    member toll-free
    dial-peer cor list user-internal
    member internal
    member emergency
    dial-peer cor list user-local
    member internal
    member local
    member emergency
    member toll-free
    dial-peer cor list user-local-plus
    member internal
    member local
    member local-plus
    member emergency
    member toll-free
    dial-peer cor list user-national
    member internal
    member local
    member local-plus
    member national
    member emergency
    member toll-free
    dial-peer cor list user-national-plus
    member internal
    member local
    member local-plus
    member national
    member national-plus
    member emergency
    member toll-free
    dial-peer cor list user-international
    member internal
    member local
    member local-plus
    member international
    member national
    member national-plus
    member emergency
    member toll-free
    dial-peer voice 1 pots
    port 0/0/0
    no sip-register
    dial-peer voice 2 pots
    port 0/0/1
    no sip-register
    dial-peer voice 3 pots
    port 0/0/2
    no sip-register
    dial-peer voice 4 pots
    port 0/0/3
    no sip-register
    dial-peer voice 5 pots
    description ** MOH Port **
    destination-pattern ABC
    port 0/4/0
    no sip-register
    dial-peer voice 6 pots
    description 鬰atch all dial peer for BRI/PRI�
    translation-profile incoming nondialable
    incoming called-number .%
    direct-inward-dial
    dial-peer voice 50 pots
    description ** incoming dial peer **
    incoming called-number ^AAAA$
    port 0/1/0
    dial-peer voice 51 pots
    description ** incoming dial peer **
    incoming called-number ^AAAA$
    port 0/1/1
    dial-peer voice 52 pots
    description ** incoming dial peer **
    incoming called-number ^AAAA$
    port 0/1/2
    dial-peer voice 53 pots
    description ** incoming dial peer **
    incoming called-number ^AAAA$
    port 0/1/3
    dial-peer voice 54 pots
    description ** FXO pots dial-peer **
    destination-pattern A0
    port 0/1/0
    no sip-register
    dial-peer voice 55 pots
    description ** FXO pots dial-peer **
    destination-pattern A1
    port 0/1/1
    no sip-register
    dial-peer voice 56 pots
    description ** FXO pots dial-peer **
    destination-pattern A2
    port 0/1/2
    no sip-register
    dial-peer voice 57 pots
    description ** FXO pots dial-peer **
    destination-pattern A3
    port 0/1/3
    no sip-register
    dial-peer voice 2000 voip
    description ** cue voicemail pilot number **
    translation-profile outgoing XFER_TO_VM_PROFILE
    destination-pattern 396
    b2bua
    session protocol sipv2
    session target ipv4:10.1.10.1
    voice-class sip outbound-proxy ipv4:10.1.10.1 
    dtmf-relay sip-notify
    codec g711ulaw
    no vad
    dial-peer voice 2001 voip
    description ** cue auto attendant number **
    translation-profile outgoing PSTN_CallForwarding
    destination-pattern 398
    b2bua
    session protocol sipv2
    session target ipv4:10.1.10.1
    voice-class sip outbound-proxy ipv4:10.1.10.1 
    dtmf-relay sip-notify
    codec g711ulaw
    no vad
    dial-peer voice 2012 voip
    description ** cue prompt manager number **
    translation-profile outgoing PSTN_CallForwarding
    destination-pattern 240
    b2bua
    session protocol sipv2
    session target ipv4:10.1.10.1
    voice-class sip outbound-proxy ipv4:10.1.10.1 
    dtmf-relay sip-notify
    codec g711ulaw
    no vad
    dial-peer voice 58 pots
    trunkgroup ALL_FXO
    corlist outgoing call-emergency
    description **CCA*North American-7-Digit*Emergency**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 5
    destination-pattern 9911
    forward-digits all
    no sip-register
    dial-peer voice 59 pots
    trunkgroup ALL_FXO
    corlist outgoing call-emergency
    description **CCA*North American-7-Digit*Emergency**
    preference 5
    destination-pattern 911
    forward-digits all
    no sip-register
    dial-peer voice 60 pots
    trunkgroup ALL_FXO
    corlist outgoing call-local
    description **CCA*North American-7-Digit*10-Digit Local**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 5
    destination-pattern 9[2-9].........
    forward-digits all
    no sip-register
    dial-peer voice 61 pots
    trunkgroup ALL_FXO
    corlist outgoing call-local
    description **CCA*North American-7-Digit*Service Numbers**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 5
    destination-pattern 9[2-9]11
    forward-digits all
    no sip-register
    dial-peer voice 62 pots
    trunkgroup ALL_FXO
    corlist outgoing call-national
    description **CCA*North American-7-Digit*Long Distance**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 5
    destination-pattern 91[2-9]..[2-9]......
    forward-digits all
    no sip-register
    dial-peer voice 63 pots
    trunkgroup ALL_FXO
    corlist outgoing call-international
    description **CCA*North American-7-Digit*International**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 5
    destination-pattern 9011T
    forward-digits all
    no sip-register
    dial-peer voice 64 pots
    trunkgroup ALL_FXO
    corlist outgoing call-toll-free
    description **CCA*North American-7-Digit*Toll-Free**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 5
    destination-pattern 91800.......
    forward-digits all
    no sip-register
    dial-peer voice 65 pots
    trunkgroup ALL_FXO
    corlist outgoing call-toll-free
    description **CCA*North American-7-Digit*Toll-Free**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 5
    destination-pattern 91888.......
    forward-digits all
    no sip-register
    dial-peer voice 66 pots
    trunkgroup ALL_FXO
    corlist outgoing call-toll-free
    description **CCA*North American-7-Digit*Toll-Free**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 5
    destination-pattern 91877.......
    forward-digits all
    no sip-register
    dial-peer voice 67 pots
    trunkgroup ALL_FXO
    corlist outgoing call-toll-free
    description **CCA*North American-7-Digit*Toll-Free**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 5
    destination-pattern 91866.......
    forward-digits all
    no sip-register
    dial-peer voice 68 pots
    trunkgroup ALL_FXO
    corlist outgoing call-toll-free
    description **CCA*North American-7-Digit*Toll-Free**
    translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
    preference 5
    destination-pattern 91855.......
    forward-digits all
    no sip-register
    no dial-peer outbound status-check pots
    telephony-service
    video
    authentication credential admin admin
    fxo hook-flash
    max-ephones 22
    max-dn 88
    ip source-address 192.168.2.99 port 2000
    max-redirect 20
    auto assign 1 to 1 type bri
    calling-number initiator
    service phone videoCapability 1
    service phone ehookenable 1
    service phone SPA525-wifi-on yes
    service phone SPA525-protocol SPCP
    service phone SPA525-auto-detect-sccp yes
    service phone SPA525-http-write yes
    service phone SPA525-SSID cisco-voice
    service phone SPA525-readonly no
    service phone SPA525-Encryption-type DISABLE
    service dnis overlay
    service dnis dir-lookup
    service dss
    timeouts interdigit 5
    system message ZFI Engi & Const
    url services http://10.1.10.1/voiceview/common/login.do
    url authentication http://10.1.10.2/CCMCIP/authenticate.asp 
    cnf-file location flash:
    cnf-file perphone
    load 7916-12 B016-1-0-4
    load 7916-24 B016-1-0-4
    load 7937 apps37sccp.1-4-4-0
    load 7960-7940 P00308010200
    load 7941 SCCP41.9-1-1SR1S
    load 7941GE SCCP41.9-1-1SR1S
    load 7942 SCCP42.9-1-1SR1S
    load 7945 SCCP45.9-1-1SR1S
    load 7961 SCCP41.9-1-1SR1S
    load 7961GE SCCP41.9-1-1SR1S
    load 7962 SCCP42.9-1-1SR1S
    load 7965 SCCP45.9-1-1SR1S
    load 521G-524G cp524g-8-1-17
    time-zone 12
    keepalive 30 auxiliary 4
    voicemail 396
    max-conferences 8 gain -6
    call-forward pattern .T
    call-forward system redirecting-expanded
    hunt-group logout HLog
    moh flash:/media/music-on-hold.au
    multicast moh 239.10.16.16 port 2000
    web admin system name cisco secret 5 $1$AJGT$FDYMK5h1/Tiz2VQKQe2fS.
    dn-webedit
    time-webedit
    transfer-system full-consult dss
    transfer-pattern 9.T
    transfer-pattern .T
    transfer-pattern 6... blind
    secondary-dialtone 9
    night-service day Sun 00:00 23:59
    night-service day Mon 17:00 08:00
    night-service day Tue 17:00 08:00
    night-service day Wed 17:00 08:00
    night-service day Thu 17:00 08:00
    night-service day Fri 17:00 08:00
    night-service day Sat 00:00 23:59
    night-service date Jan 1 00:00 23:59
    night-service date Nov 25 00:00 23:59
    night-service date Dec 25 00:00 23:59
    fac standard
    create cnf-files version-stamp Jan 01 2002 00:00:00
    ephone-template  15
    url services 1 http://10.1.10.1/voiceview/common/login.do VoiceviewExpress
    softkeys remote-in-use  Newcall
    softkeys idle  Redial Newcall Cfwdall Pickup Gpickup Dnd HLog Login
    softkeys seized  Cfwdall Endcall Redial Pickup Gpickup Callback
    softkeys connected  Hold Endcall Trnsfer TrnsfVM Confrn Acct Park
    button-layout 7931 2
    ephone-template  16
    url services 1 http://10.1.10.1/voiceview/common/login.do VoiceviewExpress
    softkeys remote-in-use  Newcall
    softkeys idle  Redial Newcall Cfwdall Pickup Gpickup Dnd HLog Login
    softkeys seized  Cfwdall Endcall Redial Pickup Gpickup Callback
    softkeys connected  Hold Endcall Trnsfer TrnsfVM Confrn Acct Park
    ephone-template  17
    url services 1 http://10.1.10.1/voiceview/common/login.do VoiceviewExpress
    softkeys remote-in-use  CBarge Newcall
    softkeys idle  Redial Newcall Cfwdall Pickup Gpickup Dnd HLog Login
    softkeys seized  Cfwdall Endcall Redial Pickup Gpickup Callback
    softkeys connected  Hold Endcall Trnsfer TrnsfVM Confrn Acct Park
    ephone-template  18
    url services 1 http://10.1.10.1/voiceview/common/login.do VoiceviewExpress
    softkeys remote-in-use  CBarge Newcall
    softkeys idle  Redial Newcall Cfwdall Pickup Gpickup Dnd HLog Login
    softkeys seized  Cfwdall Endcall Redial Pickup Gpickup Callback
    softkeys connected  Hold Endcall Trnsfer TrnsfVM Confrn Acct Park
    button-layout 7931 2
    ephone-dn  9
    number BCD no-reg primary
    description MoH
    moh out-call ABC
    ephone-dn  81  octo-line
    number 301 no-reg primary
    pickup-group 1
    name wpb wpb
    call-forward busy 396
    call-forward noan 396 timeout 20
    ephone-dn  82  octo-line
    number 227 no-reg primary
    pickup-group 1
    name Robert Stewart
    call-forward busy 396
    call-forward noan 396 timeout 20
    ephone-dn  83  octo-line
    number 239 no-reg primary
    pickup-group 1
    name Conf Room
    call-forward busy 396
    call-forward noan 396 timeout 20
    ephone-dn  84  octo-line
    number 223 no-reg primary
    pickup-group 1
    label 223
    description George Guo
    name Caroline Wang
    call-forward busy 396
    call-forward noan 396 timeout 20
    ephone-dn  85  octo-line
    ring external
    number 201 no-reg primary
    pickup-group 1
    label 201
    description Caroline Wang
    name Cari Adamonis
    call-forward busy 396
    call-forward noan 396 timeout 20
    ephone-dn  86
    number 6... no-reg primary
    description ***CCA XFER TO VM EXTENSION***
    call-forward all 396
    ephone-dn  87
    number A801... no-reg primary
    mwi off
    ephone-dn  88
    number A800... no-reg primary
    mwi on
    ephone  1
    device-security-mode none
    mac-address 0015.6276.7240
    ephone-template 16
    username "mdeng" password 123456
    type 7940
    button  1:82
    ephone  2
    device-security-mode none
    mac-address 0015.6278.9118
    ephone-template 16
    username "jespinal" password 123456
    type 7940
    button  1:83
    ephone  3
    device-security-mode none
    mac-address 0015.6269.5B0C
    ephone-template 16
    username "wpb" password 123456
    mtp
    type 7940
    button  1:81
    ephone  5
    device-security-mode none
    mac-address 0012.4362.0B1E
    ephone-template 16
    username "GGuo" password 123456
    type 7940
    button  1:84
    ephone  6
    device-security-mode none
    mac-address 0015.6286.AE4F
    ephone-template 16
    username "cwang" password 123456
    type 7940
    missed-calls all
    button  1:85
    alias exec cca_voice_mode PBX
    alias exec cca_vm_notification schedule from_time=00 to_time=24
    banner login ^Cbanner login ^Cisco Configuration Assistant. Version: 3.2 (3). Sat Aug 24 11:52:57 EDT 2013^^C
    line con 0
    line aux 0
    line 2
    no activation-character
    no exec
    transport preferred none
    transport input all
    line vty 0 4
    transport preferred none
    transport input all
    line vty 5 100
    transport preferred none
    transport input all
    ntp master
    end

    how to change local ip address?Via an operating system command.
    It's not the sort of thing an application should be doing at all. IP addresses these days are assigned via DHCP. Why would you want to change it from within an application? It would probably disconnect all sockets for all running applications, invalidate the login, all kinds of bad effects.
    What is the actual requirement?

  • How do I get an event-based response to a graph cursor change?

    I want to respond to the user moving a cursor on a data (X-Y) graph. (LV 7.0)
    What I really want is an event called "Graph.Cursor.Value Change", which would supply me with the new coordinates, but I see no such event.
    If I use the MOUSE MOVE event to trigger obtaining the cursor values, it does not give me an event, until the cursor has stopped moving, the button is up, and the mouse moves off the cursor line.
    Sure, I could use a TIMEOUT event, and read it every 100 mSec, but I don't like the time lag.
    What I did was to set a flag TRUE on Graph.MouseDown and FALSE on Graph.MouseUp. I then choose an event timeout of 10 mSec or -1, depending on that flag.
    That works, but is there a more direct way that I'm missing?
    Steve Bird
    Culverson Software - Elegant software that is a pleasure to use.
    Culverson.com
    Blog for (mostly LabVIEW) programmers: Tips And Tricks

    No, unfortunately there is not.
    To code around this limitation, I typically use the timeout event in a more complex way as follows:
    The timeout is wired to a shift register that is initialized with "-1" (no timeout). The value from the shift register then crosses the event structure and feeds to the shift register on the right in almost all event cases.
    I add two special event cases:
    (1) "graph-mouse down" puts a small number (e.g. 10ms) in the right timeout shift register
    (2) "graph-mouse up" puts again a -1 in the right timeout shift register
    (x) All other event cases (incl. timeout) wire the current timeout straight across to the right shift register.
    The timeout event contains the logic to read the graph cursors and associated actions.
    This way there is normally infinite timeout. Once the mouse goes down on the graph, the timeout executes at relatively rapid succession until the mouse is raised again. At which point everything quiets down.
    LabVIEW Champion . Do more with less code and in less time .

  • How do I reduce the time from the detection of a input threshold to changing the output?

    Hi,
    I am using LabWindows 8.1 and a PXI-4461 with Vista (home) on a 2.81 GHz Dual Core Processor.  I wrote code to do the following:
    (1) output a ramp, input a signal concurrently (precise sychronization of these two is not important at this point)
    (2) if the input signal rises above 0.5 V, hold the output constant for 2 seconds, while continuing the input
    (3) finish the ramp
    More info: I do a continuous sampling, with 4 samples per Write, to do the output.  The input is read and analyzed with RegisterEveryNSamples (where N = 4).  The communication between the tasks is through a global variable "trap," which is set to 1 when threshold is reached.  I achieve holding the output constant by stopping the task (maintain existing value = true), and then restarting after the pause.  At 40kHz and 4 samples per Write, the limit imposed by the discrete data blocks would be  0.1 msec, but in fact I am getting delays of about 2.5 msec.  My write buffer is 120x4 samples, just so that there is space for me to write.  I do need to save the input data after the
    acquisition, preferably the whole sweep, but most importantly the data
    while the output is held constant.  
    So my questions are:
    (a) Does it really take 2 ms to stop a task? When I put in "Timer()"  functions as below, I get a difference of 0.002, which is of course limited to the resolution of the Timer() function. Returning from a function (the EveryN callback) should not take that long, right?
    (b) Can you suggest any better ways of doing this?
    /*****begin excerpt *****/
    DAQmxErrChk (DAQmxRegisterEveryNSamplesEvent(inputTaskHandle,DAQmx_Val_Acquired_Into_Buffer,4 ,0,EveryNCallback,NULL));
    DAQmxErrChk (DAQmxWriteAnalogF64(outputTaskHandle,480,0,10.0,DAQmx_Val_GroupByChannel,outData,&written, NULL));
    DAQmxErrChk (DAQmxStartTask(inputTaskHandle));
    DAQmxErrChk (DAQmxStartTask(outputTaskHandle));
        for (count =120;count<10000; count++)
            if (trap==0) {
                DAQmxErrChk (DAQmxWriteAnalogF64(gTaskHandle,4,0,10.0,DAQmx_Val_GroupByChannel,&outData[count*sampsToWrite],&written,NULL));
            } else {
                    DAQmxErrChk (DAQmxStopTask(outputTaskHandle));
                    time2 = Timer();
                    done = 1;
                    ProcessDrawEvents();
                    ProcessSystemEvents();
                    Delay (2.0);
                    trap = 0;
                    count++;
                    DAQmxErrChk (DAQmxWriteAnalogF64(outputTaskHandle,480,0,10.0,DAQmx_Val_GroupByChannel,&outData[count*4],&written,NULL));
                    count = count+119;
                    DAQmxErrChk (DAQmxStartTask(outputTaskHandle));
    /*****end excerpt *****/
    int32 CVICALLBACK EveryNCallback(TaskHandle taskHandle, int32 everyNsamplesEventType, uInt32 nSamples,void *callbackData)
        DAQmxErrChk (DAQmxReadAnalogF64(taskHandle,nSamples,10.0,DAQmx_Val_GroupByScanNumber,&readData[inCount*nSamples],nSamples,&numRead,NULL));
        if (trap == 0 && done == 0) {
            for (i=0; i<nSamples; i++) {
                if (readData[inCount*nSamples+i] > 0.5) {
                    trap = 1;
                    time1 = Timer();
                    break;
        } else done = 1;
        inCount++;
    Error:
        return 0;
    I would appreciate any help or advice! Thanks.  (Sorry about oddities in the code.)

    There are a number of applictations like Carbonite, Aperture, Entourage, VM Fusion, Parellels, etc that treat any change to the application as a complete change to application's database.
    So, if you make one small email change in Entourage for example, the entire database is backed up on the next pass. As you might imagine, this can fill up a Time Capsule very quickly.
    Suggest that you download a utility like BackupLoupe to find out exactly what is being backed up on each pass. Then you can exclude that item from backups if you wish.
    http://soma-zone.com/BackupLoupe/

  • How can I change the Number (Increase) automatically daily at 12:00 am?

    Hi,
    Can someone help me out to sove this problem, please? I have a text box movie clip called Text_mc.
    The Text_mc contains the number "1".
    I need this number to be updated daily at 12:00am by adding "1" to the existing number.
    Actually it is like a counter, but it counts days from the number given in Text_mc.
    Daily it adds a number to the existing number at 12:00am.
    What is the code for this counter, please.
    Thanks.

    If the file will be opened and closed, then you need some other means to determine how many days, which can be easily done as shown below.  The alternative would be to store the value in a database, but in neither case could you change the value from the swf file at a specific time.
    You can use the Date class to assign a specific starting date/time to mark the kick off point, and then use it again to determine the current time and then determine how many days have passed between those two times.
    // set start day/time as November 1, 2010, 0 hour.
    var startDate:Date = new Date(2010,10,1,0,0,0,0);
    var startTime = startDate.getTime();
    // establish current date/time
    var today:Date = new Date();
    var todayTime = today.getTime();
    // calculate time difference and convert into days (from msecs)
    var fullDaysElapsed = Math.floor((todayTime - startTime)/(1000 * 60 * 60 * 24));
    trace(fullDaysElapsed);

  • Dot11Radio0 stuck in reset status after changing the station role

    Hi Everyone.
    I've got a AIR-AP1231G-A-K9 router. IOS has been upgraded to the latest version c1200-k9w7-mx.123-8.JED. Everything worked fine before I change the station role from root to repeater or workgroup bridge. Following is my configuration:
    ap#sh run
    Building configuration...
    Current configuration : 1224 bytes
    version 12.3
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname ap
    enable secret 5 $1$KHHu$bN/odUmHdmb.0cwa57GYs1
    ip subnet-zero
    no aaa new-model
    dot11 syslog
    dot11 ssid Lanyard
    authentication open
    username Cisco password 7 123A0C041104
    bridge irb
    interface Dot11Radio0
    no ip address
    no ip route-cache
    ssid Lanyard
    speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
    station-role root
    bridge-group 1
    bridge-group 1 subscriber-loop-control
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    bridge-group 1 spanning-disabled
    interface FastEthernet0
    no ip address
    no ip route-cache
    duplex auto
    speed auto
    bridge-group 1
    no bridge-group 1 source-learning
    bridge-group 1 spanning-disabled
    interface BVI1
    ip address 11.11.11.1 255.255.255.0
    no ip route-cache
    ip http server
    no ip http secure-server
    ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
    ip radius source-interface BVI1
    bridge 1 route ip
    line con 0
    line vty 0 4
    login local
    line vty 5 15
    login
    end
    ap#sh ip int bri
    Interface IP-Address OK? Method Status Protocol
    BVI1 11.11.11.1 YES NVRAM up up
    Dot11Radio0 unassigned YES NVRAM up up
    FastEthernet0 unassigned YES NVRAM up down
    ap#
    Then I changed the station role
    ap#conf t
    ap(config)#int dot 0
    ap(config-if)#station-role repeater
    ap(config-if)#end
    ap#sh ip int brie
    Interface IP-Address OK? Method Status Protocol
    BVI1 11.11.11.1 YES NVRAM down down
    Dot11Radio0 unassigned YES NVRAM reset down
    FastEthernet0 unassigned YES NVRAM up down
    ap#
    Interface Dot11Radio0 stuck in reset. No matter I reload or powercycle the AP, I still get the same reset status on Dot11Radio0.
    Please help! Any input will be appreciated.

    In order to get either the repeater or the workgroup bridge functionality working, you would likely need to have a Cisco AP as root. This is because the repeater and workgroup-bridge functionalities require Cisco Aironet Information Element (IE), which requires a Cisco root AP. There is no standard for interoperability for these functionalities (not part of any 802.11 standards). You can always try to connect them, making sure that they are using the same authentication/encryption configuration. However, it is unlikely to work.

  • Changing colors of an image in real time

    Hi,
    I am trying to get an image raw data in an int[] array using getRGB() in order to change the color of the image.
    But it is working fine in simulator for any image. if i install it in real device say Nokia 6600 the getRGB() method is not working for large .png image like size (88X57) because the device gets hang while we are using large image but it is working fine for small image.
    Pls give me some idea how to use getRGB() for large image.
    Following is the sample code
    int imageWidth = img.getWidth(); 
    int imageHeight = img.getHeight();
    int[] raw = new int[imageWidth*imageHeight];
    img.getRGB(raw, 0, imageWidth, 0, 0, imageWidth, imageHeight);Thanks in advance

    Use the AI CONFIG to set up your acquisition.
    Use AI CLOCK config to set up your timing.
    Use AI TRIGGER CONFIG to set up your trigger.
    Use AI CONTROL to start the DAQ (use TOTAL SCANS TO ACQUIRE = 0 for unlimited scanning.
    repeat (While loop)
    Use AI READ with a NUMBER of SCANS TO READ = 0. This tells you the backlog (how many scans in the buffer)
    Use AI READ with NUMBER OF SCANS TO READ = to the backlog number from above. (this empties the buffer)
    Process the scans received into your image - append to previous data and re-display.
    If you are doing a fixed number of scans, add this backlog number to the total done so far, and see if you're done. If you're doing continuous, skip this step.
    Wait 100 mSec if you can, 10 m
    Sec if you can't.
    Loop (until # scans done >= # scans wanted OR Quit button, whatever).
    Use AI CONTROL to stop the DAQ.
    The idea is that the DAQ operation happens in the background. You just ask how many are available, and then read that many and use them.
    You wait 100 mSec to allow the display update to happen.
    Steve Bird
    Culverson Software - Elegant software that is a pleasure to use.
    Culverson.com
    Blog for (mostly LabVIEW) programmers: Tips And Tricks

  • Poll Interval, Msecs To wait before modification checks & Queue Name in CC

    Hi All,
    I have 3 inter-related interfaces which is having 3 File Sender Communication channels as below charasteristics;
    All 3 ccs are running on a common Queue Name inorder to cater the business scenario;
    so PI should consume the files in the same sequance of files are copping into the locations;
    (time gap between incoming files is around 1-3 secs)
    Existing Values in Production system
    IF086
    Poll Interval                                                                        1 secs
    Msecs To wait before modification checks                      10000
    Queue Name                                                                     XI_QUE1
    run sequance must be 1
    IF913
    Poll Interval                                                                        1 secs
    Msecs To wait before modification checks                      10000
    Queue Name                                                                     XI_QUE1
    run sequance must be 2
    IF084
    Poll Interval                                                                        1 secs
    Msecs To wait before modification checks                      10000
    Queue Name                                                                     XI_QUE1
    run sequance must be 3
    we are having PI Alert email configured in the system;
    when we get a big files into the locations, we get an unwanted Alert emails saying Error;
    when I check PI, Overall file transfer is successful,
    but we have the below error in the Message Display Audit log as
    "Channel CC_Cxxx: Attempt to send file 'T201_200909141702' failed because file was modified during processing. 0 bytes expected, 1202248 bytes found. Trying to resend file" 
    but Overall file transfer is successful;
    Does anyone can explain the reason for this error; ?
    Also to remove this error & unwanted Alert email (since final status is successfull), I changed the Poll Interval to 3 for all 3 above CCs; Now I dont get the above error;
    Do you think there might be a sequance issue due to this change;?
    (time gap between incoming files is around 1-3 secs)
    quite lengthy to explain sorry;
    Appreciate your help please
    thanks
    Iver

    Hello Iver
    Question 3 in the note #821267 FAQ: XI 3.0 / PI 7.0/ PI 7.1 File Adapter, explains what is happening here. This answers your first question.
    The file in question was being written to by another process when the file adapter attempted to send it. Depending on the length of time/amount of data that is being written to these files, increasing the polling interval to 3 seconds will help.
    Regards
    Mark

  • How to change Delta_X value in SignalExpr​ess?

    Hello all,
    I'm acquiring a thermocouple (type T) reading using SignalExpress and NI9211 data acquisition + NI USB-9162 converter. 1 reading every 100 msec. Very simple setup.
    Anyhow, when I export the data using the built-in function, I get a file where the Delta_X value is set to 3 seconds (so I get a datapoint every 3 seconds eventhough I recorded way more datapoints than that).
    Is there a way to change this behavior?
    Thanks!

    Hi kerlutin,
    The Delta_X value in SignalExpress should be equal to 1/ rate you have selected in the configuration tab. So, can you check that your rate is 10Hz?
    If you are still having this problem, can you post your project?
    I hope this helps,
    Charlotte F. | CLAD
    National Instruments France
    #adMrkt{text-align: center;font-size:11px; font-weight: bold;} #adMrkt a {text-decoration: none;} #adMrkt a:hover{font-size: 9px;} #adMrkt a span{display: none;} #adMrkt a:hover span{display: block;}
    >> "Du 11 octobre au 17 novembre, 2 sessions en parallèle : bien démarrer - approfondir vos connais...

  • Can't boot from CD to change passwords

    Hi all,
    We have a Mac Mini running in the office as a web server. However we no longer know the password for administrator access. As I have physical access and the original installation CD [I assume this is labled Mac mini Mac OS X Install Disc 1] I was hoping I could simply boot from the CD and change the password.
    However whatever I try it always boots to the main login page.
    I am using a Windows keyboard (UK) and am wondering if this could be the problem, though it is recognised and can type into the login boxes. I have tried holding C while booting and also tried to boot into single user mode with S and every combination of key to try and find the command key.
    I borrowed a friends IBook and was able to boot into single user mode the first time I tried, so I do think it's me doing something stupid!
    So my question, is it possible that it could be the keyboard in which case I need to source one from somewhere or would it be possible for the server to have been configured not to be able to boot in any other mode other than the hard drive.
    Thanks for the help.
    Mac Mini   Mac OS X (10.4.2)  

    You computer may have the Open Firmware Password set. See:
    <http://docs.info.apple.com/article.html?artnum=106482>
    The article does not list the G4 Mini, but I don't see why it should be different. Maybe you have the Intel Mini. If you don't know an administrator or firmware password you may be able to get the firmware password using FWSucker from
    <http://www.msec.net/software/>
    If you get the password but it contains punctuation, it may not work with the UK keyboard layout. See:
    <http://docs.info.apple.com/article.html?artnum=107577>
    If you can't get the password, try:
    <http://www.msec.net/advisories/ofpwdbypass.html>
    You may have a problem if your Mini has all its RAM in one module. You would have to find a different size RAM module. Maybe it would work with no RAM.

  • Can the load order of subforms be changed?

    I have a form with two subforms.  Subform A is a datasheet which has a Form_Current event which is suppose to call a subroutine in the main form, which in turn tries to change a control in Subform B.
    However, on startup, Subform B has not loaded and an error occurs ("You entered an expression that has an invalid reference to the property Form/Report").
    Is there a way that I can force Subform B to load before Subform A?
    b.hata

    Not that I know of. Trying to change this default behavior is a recipe for disaster.
    You COULD have an error handler in that function that ignores the specific error because not there yet. Or you could re-think the whole thing and perhaps trigger it from the main form.
    On rare occasion, and I am reluctant to even mention it, I would tick a 1 msec timer and upon Form_Timer do my thing. This event is pretty much guaranteed to happen AFTER everything is loaded and is settling down.
    -Tom. Microsoft Access MVP
    I have had situations in the past where things were working fine and then after some changes, I would get errors similar to my current database development problem.  Somehow the order of subform loading would change.  There must be something in
    Access that determines the order in which subforms (and parent form) gets loaded.  I can't imagine it should matter to Access what the order would be.  I was hoping there was some way I could change it.
    re: error handlers... I typically don't like to do much in error handlers.  I much prefer to prevent errors from happening in the first place, such as setting an "Initialization Flag" during Form_Open and testing it in "Form_Current".
    re: timer... I wouldn't want to use Form_Timer as it is not full proof. 
    b.hata

  • Change default EFXS to DID

    Hi Cisco techs,
    I wrote a discussion about 3 weeks ago but had no replies. Perhaps I didn't word it correctly via 
    https://supportforums.cisco.com/discussion/12353726/did-and-channels-sh-voice-port-summary
    I am aware that EFXS is created automatically for ephones.
    I would like to change the automatic EFXS connection that a phone uses to connect to too DID instead.
    Is this possible?
    Let me explain.
    sh voice port summary output is below
    cme_router#sh voice port summary
                                               IN       OUT
    PORT            CH   SIG-TYPE   ADMIN OPER STATUS   STATUS   EC
    =============== == ============ ===== ==== ======== ======== ==
    1/0/0           --  did-in-imd  up    dorm idle     idle     y
    1/0/1           --  did-in-wnk  up    up   seized   idle     y
    50/0/1          1      efxs     up    dorm on-hook  idle     y
    50/0/1          2      efxs     up    dorm on-hook  idle     y
    50/0/2          1      efxs     up    up   on-hook  idle     y
    50/0/2          2      efxs     up    up   on-hook  idle     y
    50/0/3          1      efxs     up    up   on-hook  idle     y
    When I pick up the receiver and dial 02xxxxxxxx via debug vpm signal
    cme_router#
    cme_router#debug vpm signal
    Voice Port Module signaling debugging is enabled
    cme_router#
    Mar  1 05:06:25.339: htsp_process_event: [50/0/1.1, EFXS_ONHOOK, E_DSP_SIG_1100]                                              efxs_onhook_offhook htsp_setup_ind
    Mar  1 05:06:25.339: [50/0/1.1] get_local_station_id calling num=0300 calling na                                              me=John Cheetley calling time=02/28 06:06  orig called=
    Mar  1 05:06:25.343: htsp_process_event: [50/0/1.1, EFXS_WAIT_SETUP_ACK, E_HTSP_                                              SETUP_ACK]efxs_check_auto_call
    Mar  1 05:06:32.399: htsp_digit_ready(50/0/1.1): digit = x
    Mar  1 05:06:32.903: htsp_digit_ready(50/0/1.1): digit = x
    Mar  1 05:06:33.659: htsp_digit_ready(50/0/1.1): digit = x
    Mar  1 05:06:34.163: htsp_digit_ready(50/0/1.1): digit = x
    Mar  1 05:06:34.667: htsp_digit_ready(50/0/1.1): digit = x
    Mar  1 05:06:34.667: htsp_digit_ready(50/0/1.1): digit = x
    Mar  1 05:06:35.171: htsp_digit_ready(50/0/1.1): digit = x
    Mar  1 05:06:35.423: htsp_digit_ready(50/0/1.1): digit = x
    Mar  1 05:06:45.423: htsp_timer_stop3
    Mar  1 05:06:45.423: htsp_process_event: [50/0/1.1, EFXS_OFFHOOK, E_HTSP_PROCEED                                              ING]efxs_offhook_proceeding
    Mar  1 05:06:45.423: [50/0/1.1] set signal state = 0x8 timestamp = 0htsp_setup_r                                              eq
    Mar  1 05:06:45.427: htsp_process_event: [1/0/0, DID_ONHOOK, E_HTSP_SETUP_REQ]
    Mar  1 05:06:45.431: htsp_process_event: [1/0/0, DID_ONHOOK, E_HTSP_RELEASE_REQ]                                              did_onhook_release  did_onhook
    Mar  1 05:06:45.431: [1/0/0] set signal state = 0x4 timestamp = 0
    Mar  1 05:06:59.363: htsp_process_event: [50/0/1.1, EFXS_OFFHOOK, E_DSP_SIG_0100                                              ]efxs_offhook_onhook
    Mar  1 05:06:59.363: htsp_timer - 10 msec
    Mar  1 05:06:59.375: htsp_process_event: [50/0/1.1, EFXS_OFFHOOK, E_HTSP_EVENT_T                                              IMER]efxs_offhook_timer
    Mar  1 05:06:59.375: htsp_process_event: [50/0/1.1, EFXS_ONHOOK, E_HTSP_RELEASE_                                              REQ]efxs_onhook_release
    Mar  1 05:06:59.375: htsp_timer_stop
    Mar  1 05:06:59.375: [50/0/1.1] set signal state = 0x4 timestamp = 0
    The session gets dial tone but doesn't connect.
    Does DID use a channel similar to EFXS does?
    Thanks again in advance

    The solution is so simple and straightforward that I feel like a fool for asking.
    Only when you already know it. There's no documentation that really states it. It's one of those long time Mac behaviors a person just needs to learn.

  • Disp+ work process changes from green to disabled

    Hi all,
    I want to install the SAP Netweaver 2004 server(ABAP + Java ) on windows box with MSSQL 2000 as backend.
    I wanted to know the sequnce that needs to be followed to install the component.
    I went in the following:
    a)I installed the MSSQL Server 2004 SP4
    b)I installed the ABAP part.
    Now when i tried to start the server from the SAP Console ,the process
    (disp + work) changes from green to disable.
    If i check the logs i get the following
    Thu Jun 28 16:26:07 2007
    ERROR => W0 (pid 2912) died [dpxxdisp.c 12170]
    ERROR => W1 (pid 2600) died [dpxxdisp.c 12170]
    my types changed after wp death/restart 0xbf --> 0xbe
    ERROR => W2 (pid 2392) died [dpxxdisp.c 12170]
    my types changed after wp death/restart 0xbe --> 0xbc
    ERROR => W3 (pid 156) died [dpxxdisp.c 12170]
    my types changed after wp death/restart 0xbc --> 0xb8
    ERROR => W4 (pid 2188) died [dpxxdisp.c 12170]
    ERROR => W5 (pid 2684) died [dpxxdisp.c 12170]
    my types changed after wp death/restart 0xb8 --> 0xb0
    ERROR => W6 (pid 796) died [dpxxdisp.c 12170]
    my types changed after wp death/restart 0xb0 --> 0xa0
    ERROR => W7 (pid 1888) died [dpxxdisp.c 12170]
    my types changed after wp death/restart 0xa0 --> 0x80
    DP_FATAL_ERROR => DpWPCheck: no more work processes
    DISPATCHER EMERGENCY SHUTDOWN ***
    increase tracelevel of WPs
    killing W0-2912 (SIGUSR2)
    ERROR => DpWpKill(2912, SIGUSR2) failed [dpxxtool.c 2468]
    killing W1-2600 (SIGUSR2)
    ERROR => DpWpKill(2600, SIGUSR2) failed [dpxxtool.c 2468]
    killing W2-2392 (SIGUSR2)
    ERROR => DpWpKill(2392, SIGUSR2) failed [dpxxtool.c 2468]
    killing W3-156 (SIGUSR2)
    ERROR => DpWpKill(156, SIGUSR2) failed [dpxxtool.c 2468]
    killing W4-2188 (SIGUSR2)
    ERROR => DpWpKill(2188, SIGUSR2) failed [dpxxtool.c 2468]
    killing W5-2684 (SIGUSR2)
    ERROR => DpWpKill(2684, SIGUSR2) failed [dpxxtool.c 2468]
    killing W6-796 (SIGUSR2)
    ERROR => DpWpKill(796, SIGUSR2) failed [dpxxtool.c 2468]
    killing W7-1888 (SIGUSR2)
    ERROR => DpWpKill(1888, SIGUSR2) failed [dpxxtool.c 2468]
    NiWait: sleep (10000 msecs) ...
    NiISelect: timeout 10000 ms
    NiISelect: maximum fd=1629
    NiISelect: read-mask is NULL
    NiISelect: write-mask is NULL
    Thu Jun 28 16:26:17 2007
    NiISelect: TIMEOUT occured (10000 ms)
    dump system status
    Workprocess Table (long) Thu Jun 28 10:56:17 2007
    ========================
    No Ty. Pid Status Cause Start Err Sem CPU Time Program Cl User Action Table
    0 DIA 2912 Ended no 1 0 0
    1 DIA 2600 Ended no 1 0 0
    2 UPD 2392 Ended no 1 0 0
    3 ENQ 156 Ended no 1 0 0
    4 BTC 2188 Ended no 1 0 0
    5 BTC 2684 Ended no 1 0 0
    6 SPO 796 Ended no 1 0 0
    7 UP2 1888 Ended no 1 0 0
    Dispatcher Queue Statistics Thu Jun 28 10:56:17 2007
    ===========================
    --------++++--
    +
    Typ
    now
    high
    max
    writes
    reads
    --------++++--
    +
    NOWP
    0
    3
    2000
    10
    10
    --------++++--
    +
    DIA
    5
    5
    2000
    5
    0
    --------++++--
    +
    UPD
    0
    0
    2000
    0
    0
    --------++++--
    +
    ENQ
    0
    0
    2000
    0
    0
    --------++++--
    +
    BTC
    0
    0
    2000
    0
    0
    --------++++--
    +
    SPO
    0
    0
    2000
    0
    0
    --------++++--
    +
    UP2
    0
    0
    2000
    0
    0
    --------++++--
    +
    max_rq_id 13
    wake_evt_udp_now 0
    wake events total 9, udp 7 ( 77%), shm 2 ( 22%)
    since last update total 9, udp 7 ( 77%), shm 2 ( 22%)
    Dump of tm_adm structure: Thu Jun 28 10:56:17 2007
    =========================
    Term uid man user term lastop mod wp ta a/i (modes)
    Workprocess Comm. Area Blocks Thu Jun 28 10:56:17 2007
    =============================
    Slots: 300, Used: 1, Max: 0
    --------++--
    +
    id
    owner
    pid
    eyecatcher
    --------++--
    +
    0
    DISPATCHER
    -1
    WPCAAD000
    NiWait: sleep (5000 msecs) ...
    NiISelect: timeout 5000 ms
    NiISelect: maximum fd=1629
    NiISelect: read-mask is NULL
    NiISelect: write-mask is NULL
    Thu Jun 28 16:26:22 2007
    NiISelect: TIMEOUT occured (5000 ms)
    Shutdown server ...
    DpModState: buffer in state MBUF_PREPARED
    NiBufSend starting
    NiIWrite: write 110, 1 packs, MESG_IO, hdl 3, data complete
    MsINiWrite: sent 110 bytes
    MsIModState: change state to SHUTDOWN
    DpModState: change server state from STARTING to SHUTDOWN
    Switch off Shared memory profiling
    ShmProtect( 57, 3 )
    ShmProtect(SHM_PROFILE, SHM_PROT_RW
    ShmProtect( 57, 1 )
    ShmProtect(SHM_PROFILE, SHM_PROT_RD
    DpWakeUpWps: wake up all wp's
    Stop work processes...
    Stop gateway
    killing process (432) (SOFT_KILL)
    Stop icman
    killing process (2124) (SOFT_KILL)
    Terminate gui connections
    [DpProcDied] Process lives (PID:432 HANDLE:1600)
    waiting for termination of gateway
    NiWait: sleep (1000 msecs) ...
    NiISelect: timeout 1000 ms
    NiISelect: maximum fd=1629
    NiISelect: read-mask is NULL
    NiISelect: write-mask is NULL
    Thu Jun 28 16:26:23 2007
    NiISelect: TIMEOUT occured (1000 ms)
    Thu Jun 28 16:26:24 2007
    [DpProcDied] Process died (PID:432 HANDLE:1600)
    [DpProcDied] Process lives (PID:2124 HANDLE:1588)
    waiting for termination of icman
    NiWait: sleep (1000 msecs) ...
    NiISelect: timeout 1000 ms
    NiISelect: maximum fd=1629
    NiISelect: read-mask is NULL
    NiISelect: write-mask is NULL
    Thu Jun 28 16:26:25 2007
    NiISelect: TIMEOUT occured (1000 ms)
    [DpProcDied] Process died (PID:2124 HANDLE:1588)
    DpHalt: cancel all lcom connections
    MPI CancelAll 2 -> 0
    MPI DeleteAll 2 -> 0
    NiIMyHostName: hostname = 'pun-idmqa-vm1'
    AdGetSelfIdentRecord: > <
    AdCvtRecToExt: opcode 60 (AD_SELFIDENT), ser 0, ex 0, errno 0
    AdCvtRecToExt: opcode 4 (AD_STARTSTOP), ser 0, ex 0, errno 0
    DpConvertRequest: net size = 163 bytes
    NiBufSend starting
    NiIWrite: write 562, 1 packs, MESG_IO, hdl 3, data complete
    MsINiWrite: sent 562 bytes
    send msg (len 110+452) to name -, type 4, key -
    detach from message server
    ***LOG Q0M=> DpMsDetach, ms_detach () [dpxxdisp.c 9945]
    NiBufSend starting
    NiIWrite: write 110, 1 packs, MESG_IO, hdl 3, data complete
    MsINiWrite: sent 110 bytes
    MsIDetach: send logout to msg_server
    MsIDetach: call exit function
    DpMsShutdownHook called
    NiSelClear: removed hdl 3 from selectset
    MBUF state OFF
    AdGetSelfIdentRecord: > <
    AdCvtRecToExt: opcode 60 (AD_SELFIDENT), ser 0, ex 0, errno 0
    AdCvtRecToExt: opcode 40 (AD_MSBUF), ser 0, ex 0, errno 0
    AdCvtRecToExt: opcode 40 (AD_MSBUF), ser 0, ex 0, errno 0
    blks_in_queue/wp_ca_blk_no/wp_max_no = 1/300/8
    LOCK WP ca_blk 1
    make DISP owner of wp_ca_blk 1
    DpRqPutIntoQueue: put request into queue (reqtype 1, prio LOW, rq_id 19)
    MBUF component DOWN
    NiBufClose: clear extensions for hdl 3
    NiBufSetStat: bufstat of hdl 3 changed from OK to OFF
    NiICloseHandle: shutdown and close hdl 3 / socket 1608
    MsIDetach: detach MS-system
    EsCleanup ....
    ***LOG Q05=> DpHalt, DPStop ( 3520) [dpxxdisp.c 8478]
    Good Bye .....
    What can be the problem.
    Best Regards
    Manoj

    what is the name of your hostname? 'pun-idmqa-vm1'?
    Try changing the hostname for another one with 8 characters...
    good luck,

  • 5508 WLC HA pair - change management interface settings

    Hi,
    We have a pair of 5508 WLC's in a HA configuration that is working well at the moment, however I have noticed that the management interface is configured as untagged. I would like to change this to tagged and change the attached switch to trunk for these devices but if I try and edit the management interface through the GUI the VLAN and IP address section is greyed out and cannot be changed. While I could attempt it through the CLI and am comfortable doing that, the fact that it cannot be changed through the GUI implies that this should not be changed and so I am after further information. I don't have any lab equipment other than the HA pair in production so I cannot try changing it through the CLI at the moment. 
    The WLC's are in LAG mode if that makes any difference. I realise there may be downtime required for making this change but I am trying to work out the steps to get this done without having to drastically reconfigure things. 
    Any assistance would be appreciated. 

    Introduction of New Interfaces for HA Interaction
    Redundancy Management Interface
    The IP address on this interface should be configured in the same subnet as the management interface. This interface will check the health of the Active WLC via network infrastructure once the Active WLC does not respond to Keepalive messages on the Redundant Port. This provides an additional health check of the network and Active WLC, and confirms if switchover should or should not be executed. Also, the Standby WLC uses this interface in order to source ICMP ping packets to check gateway reachability. This interface is also used in order to send notifications from the Active WLC to the Standby WLC in the event of Box failure or Manual Reset. The Standby WLC will use this interface in order to communicate to Syslog, the NTP server, and the TFTP server for any configuration upload.
    Redundancy Port
    This interface has a very important role in the new HA architecture. Bulk configuration during boot up and incremental configuration are synced from the Active WLC to the Standby WLC using the Redundant Port. WLCs in a HA setup will use this port to perform HA role negotiation. The Redundancy Port is also used in order to check peer reachability sending UDP keep-alive messages every 100 msec (default timer) from the Standby WLC to the Active WLC. Also, in the event of a box failure, the Active WLC will send notification to the Standby WLC via the Redundant Port. If the NTP server is not configured, a manual time sync is performed from the Active WLC to the Standby WLC on the Redundant Port. This port in case of standalone controller and redundancy VLAN in case of WISM-2 will be assigned an auto generated IP Address where last 2 octets are picked from the last 2 octets of Redundancy Management Interface (the first 2 octets are always 169.254).

  • XML Gallery: Change from MouseEvent to automatic?

    I am trying to edit an old XML gallery that I made so that it will scroll through the images automatically, without any user interaction at all. Currently it's set to scroll through them one at a time and is controlled by mouse clicks. I can't figure out how to change it. Any help would be greatly appreciated!!
    Here's my code:
    var xmlRequest:URLRequest = new URLRequest("homeImages.xml");
    var xmlLoader:URLLoader = new URLLoader(xmlRequest);
    var imgData:XML;
    var imageLoader:Loader;
    var rawImage:String;
    var rawH:String;
    var rawW:String;
    var imgNum:Number = 0;
    var checkSec:Timer = new Timer(100);
    var numberOfChildren:Number;
    xmlLoader.addEventListener(Event.COMPLETE, xmlLoaded);
    Images_mc.addEventListener(MouseEvent.CLICK, nextImgF);
    Images_mc.buttonMode = true;
    function xmlLoaded(event:Event):void
    checkSec.start();
    checkSec.addEventListener(TimerEvent.TIMER, checkerF);
    imgData = new XML(event.target.data);
    function packagedF():void
    checkSec.removeEventListener(TimerEvent.TIMER, checkerF);
    rawImage = imgData.image[imgNum].imgURL;
    numberOfChildren = imgData.*.length();
    rawW = imgData.image[imgNum].imgW;
    rawH = imgData.image[imgNum].imgH;
    imageLoader = new Loader;
    imageLoader.load(new URLRequest(rawImage));
    Images_mc.addChild(imageLoader);
    imageLoader.x = (Images_mc.width - Number(rawW)) /2;
    imageLoader.y = (Images_mc.height - Number(rawH)) /2;
    function checkerF(event:TimerEvent):void
    if(imgNum == 0)
      packagedF();
    else if(imgNum < numberOfChildren)
      imageLoader.unload();
      packagedF();
    else
      imageLoader.unload();
      imgNum = 0;
      packagedF();
    function nextImgF(event:MouseEvent):void
    checkSec.addEventListener(TimerEvent.TIMER, checkerF);
    imgNum++;

    You should be able to incorporate a second Timer object that you use for the automatic advancing....
    var autoTimer:Timer = new Timer(2000); // adjust for desired msec
    autoTimer.addEventListener(TimerEvent.TIMER, nextImgF);
    Since you are loading images with each call to that function, you may end up needing to incorporate more control of the timer and not have it firing repeatedly on its own, which means adding a listener for loading completion, putting a limit on the number of repeats to once, and assign a new Timer each time thru... var autoTimer:Timer;  .... autoTimer = new Timer(2000, 1);....

Maybe you are looking for

  • Apps for client and fees management

    Hi As an architect I require the following in an application. Any developer can help. 1) to maintain client database which includes a) under what category he/she comes under (residential, housing, commercial, etc) B) statement of requirements ( also

  • IWeb "Domain" File Not Opening in Mavericks

    I just bought a new Mac Pro and converted everything over from my early 2008 Mac Pro.  However, my iWeb Domain file will not open in the new Mac.  It defaults to the start up iWeb page asking me to choose a new template.  Facts: 1- Both systems are r

  • Need Help With Download For Airport Express

    Ok, computer dummy here needing help with airport express. We were given airport express last night from a friend who recently purchased a newer gadget. He told us we would need to come here to download the operating system. I see lots of links to up

  • Who can I have permanent Internet connection on my iPad

    Hi my boss just got a new iPod touch and he is upset that he can't have a permanent Internet connection on this and he has told me to sort it out. I am good but not sure if I am that good to find a solution for hi . Please helpppppp

  • Can't automatically start appserver 8.2 under Solaris 10

    Hi, I have recently installed Sun Java Application Server 8.2 on Solaris 10 6/06 under a user other than root. I'm interested in making domain1 start-automatically after booting. I tried for the first time a script that used asadmin start-domain doma