Datastore id and flat class mapping

Hi,
I have
- an abstract persistent class A with 2 concrete persistent subclasses A1
and A2. I'm using datastore identity and flat class mapping.
- a class B that has a field fb with a one-many mapping to A1 objects
(Hashset).
- a class C that has a field fc with a one-many mapping to A objects
(Hashset).
- an instance a1 of A1 (id = 5)
- an instance b of B in which fb contains a1
- an instance c of C in which fc contains a1
When loading b and then c, i happen to have 2 instances representing a1 in
the same persistent manager. the one loaded in b has A1-5 as ObjectId and
the one loaded in c has A-5 as ObjectId. Thus those two objects have a
different object id while they represents the same data.
I would expect to find only one.
Do you have any idea ?
Thanks,
Laurent Czinczenheim

I found the problem! There is no more jdo-1.0.1.jar in the kodo rar :-)
Czinczenheim wrote:
I have only kodo in the rar. If i put the kodo rar 3.1.3, i can deploy it.
if i put the kodo rar 3.2.0, i cannot and get the previous exception. Is
there any difference in the packages used by kodo 3.2.0 (other than kodo
packages) that could interfer with the one i could have in my jboss lib
directories ?
thanks
laurent
Stephen Kim wrote:
Kodo should either not be in the classpath and only in the rar or
viceversa. It still seems like a classpath issue. Can you inspect your
kodo-jdo-runtime.jars for the existence of kodo/util/FatalUserException?
Czinczenheim wrote:
I have only one version of Kodo in my classpath. Therefore, when i
replace
the rar by the one from version 3.1.3 (or any older version), i don'thave
any problem to deploy the kodo resource adapter.
Stephen Kim wrote:
It appears that you may be having classpath problems. Do you have
multiple versions of Kodo in the classpath or ear/rar?
Czinczenheim wrote:
Marc,
i wanted to try it with the new 3.2 beta version but i can't even deploy
kodo 3.2.b1 in JBoss 3.2.3. Here is the stacktrace i get when deploying
the rar (My kodo-ds.xml is the same as the one i used with kodo 3.1.3):
11:47:52,975 INFO [RARDeployment] Starting
11:47:53,036 WARN [ServiceController] Problem starting service
jboss.jca:service=ManagedConnectionFactory,name=jdo/pmf/prisma01
java.lang.NoClassDefFoundError: kodo/util/FatalUserException
     at java.lang.Class.getDeclaredConstructors0(Native Method)
     at java.lang.Class.privateGetDeclaredConstructors(Class.java:1610)
     at java.lang.Class.getConstructor0(Class.java:1922)
     at java.lang.Class.newInstance0(Class.java:278)
     at java.lang.Class.newInstance(Class.java:261)
     at
org.jboss.resource.connectionmanager.RARDeployment.startService(RARDeployment.java:533)
>>>
     at
org.jboss.system.ServiceMBeanSupport.start(ServiceMBeanSupport.java:192)
     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
     at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
     at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>>>
     at java.lang.reflect.Method.invoke(Method.java:324)
     at
org.jboss.mx.capability.ReflectedMBeanDispatcher.invoke(ReflectedMBeanDispatcher.java:284)
>>>
     at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:546)
     at
org.jboss.system.ServiceController$ServiceProxy.invoke(ServiceController.java:976)
>>>
     at $Proxy12.start(Unknown Source)
     at org.jboss.system.ServiceController.start(ServiceController.java:394)
     at sun.reflect.GeneratedMethodAccessor6.invoke(Unknown Source)
     at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>>>
     at java.lang.reflect.Method.invoke(Method.java:324)
     at
org.jboss.mx.capability.ReflectedMBeanDispatcher.invoke(ReflectedMBeanDispatcher.java:284)
>>>
     at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:546)
     at org.jboss.mx.util.MBeanProxyExt.invoke(MBeanProxyExt.java:177)
     at $Proxy4.start(Unknown Source)
     at org.jboss.deployment.SARDeployer.start(SARDeployer.java:226)
     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
     at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
     at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>>>
     at java.lang.reflect.Method.invoke(Method.java:324)
     at
org.jboss.mx.capability.ReflectedMBeanDispatcher.invoke(ReflectedMBeanDispatcher.java:284)
>>>
     at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:546)
     at
org.jboss.mx.util.JMXInvocationHandler.invoke(JMXInvocationHandler.java:177)
     at $Proxy18.start(Unknown Source)
     at org.jboss.deployment.XSLSubDeployer.start(XSLSubDeployer.java:231)
     at org.jboss.deployment.MainDeployer.start(MainDeployer.java:824)
     at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:632)
     at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:605)
     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
     at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
     at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>>>
     at java.lang.reflect.Method.invoke(Method.java:324)
     at
org.jboss.mx.capability.ReflectedMBeanDispatcher.invoke(ReflectedMBeanDispatcher.java:284)
>>>
     at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:546)
     at org.jboss.mx.util.MBeanProxyExt.invoke(MBeanProxyExt.java:177)
     at $Proxy6.deploy(Unknown Source)
     at
org.jboss.deployment.scanner.URLDeploymentScanner.deploy(URLDeploymentScanner.java:302)
>>>
     at
org.jboss.deployment.scanner.URLDeploymentScanner.scan(URLDeploymentScanner.java:476)
>>>
     at
org.jboss.deployment.scanner.AbstractDeploymentScanner$ScannerThread.doScan(AbstractDeploymentScanner.java:201)
>>>
     at
org.jboss.deployment.scanner.AbstractDeploymentScanner.startService(AbstractDeploymentScanner.java:274)
>>>
     at
org.jboss.system.ServiceMBeanSupport.start(ServiceMBeanSupport.java:192)
     at sun.reflect.GeneratedMethodAccessor5.invoke(Unknown Source)
     at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>>>
     at java.lang.reflect.Method.invoke(Method.java:324)
     at
org.jboss.mx.capability.ReflectedMBeanDispatcher.invoke(ReflectedMBeanDispatcher.java:284)
>>>
     at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:546)
     at
org.jboss.system.ServiceController$ServiceProxy.invoke(ServiceController.java:976)
>>>
     at $Proxy0.start(Unknown Source)
     at org.jboss.system.ServiceController.start(ServiceController.java:394)
     at sun.reflect.GeneratedMethodAccessor6.invoke(Unknown Source)
     at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>>>
     at java.lang.reflect.Method.invoke(Method.java:324)
     at
org.jboss.mx.capability.ReflectedMBeanDispatcher.invoke(ReflectedMBeanDispatcher.java:284)
>>>
     at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:546)
     at org.jboss.mx.util.MBeanProxyExt.invoke(MBeanProxyExt.java:177)
     at $Proxy4.start(Unknown Source)
     at org.jboss.deployment.SARDeployer.start(SARDeployer.java:226)
     at org.jboss.deployment.MainDeployer.start(MainDeployer.java:824)
     at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:632)
     at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:605)
     at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:589)
     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
     at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
     at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>>>
     at java.lang.reflect.Method.invoke(Method.java:324)
     at
org.jboss.mx.capability.ReflectedMBeanDispatcher.invoke(ReflectedMBeanDispatcher.java:284)
>>>
     at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:546)
     at org.jboss.mx.util.MBeanProxyExt.invoke(MBeanProxyExt.java:177)
     at $Proxy5.deploy(Unknown Source)
     at org.jboss.system.server.ServerImpl.doStart(ServerImpl.java:384)
     at org.jboss.system.server.ServerImpl.start(ServerImpl.java:291)
     at org.jboss.Main.boot(Main.java:150)
     at org.jboss.Main$1.run(Main.java:388)
     at java.lang.Thread.run(Thread.java:534)
Thanks for your help since the initial bug i described is critical forus.
Laurent
Marc Prud'hommeaux wrote:
Laurent-
I believe I have seen that problem, but I can't recall the exact
symptoms (or the exact bug number). However, I do think that it was
fixed for Kodo 3.2. Can you download the 3.2 beta and see if the
problem
still occurs?
If it does still happen, can you provide us with your .jdo, .mapping,
and .java files for the classes so we can take a look?
In article <[email protected]>, Czinczenheim wrote:
Hi,
I have
- an abstract persistent class A with 2 concrete persistent subclasses
A1
and A2. I'm using datastore identity and flat class mapping.
- a class B that has a field fb with a one-many mapping to A1 objects
(Hashset).
- a class C that has a field fc with a one-many mapping to A objects
(Hashset).
- an instance a1 of A1 (id = 5)
- an instance b of B in which fb contains a1
- an instance c of C in which fc contains a1
When loading b and then c, i happen to have 2 instances representing
a1
in
the same persistent manager. the one loaded in b has A1-5 as ObjectIdand
the one loaded in c has A-5 as ObjectId. Thus those two objects have a
different object id while they represents the same data.
I would expect to find only one.
Do you have any idea ?
Thanks,
Laurent Czinczenheim
Marc Prud'hommeaux
SolarMetric Inc.
Steve Kim
[email protected]
SolarMetric Inc.
http://www.solarmetric.com
Steve Kim
[email protected]
SolarMetric Inc.
http://www.solarmetric.com

Similar Messages

  • Horizontal Mapping and Flat mapping with Metadata Value Indicator

    Hi
    I have an abstract class B which itself extends another abstract class A.
    There is no table for A. The fields in A are mapped to B. I believe this
    is called "horizontal mapping"
    C and D inherit off B. There's a also a table named B (mapped to class B),
    but none for C or D. Instances of C and D are recorded in table B. I
    believe this is called "flat mapping"
    B has a field foo whose possible values are 'fred' and 'wilma'.
    If foo='fred', then the record is of type C
    If foo='wilma', then the record is of type D
    I believe this is called "class indicator" of type metadata.
    To express this, I have package.jdo which says
    <class name="A"/>
    <class name="B" persistence-capable-superclass="A"/>
    <class name="C" persistence-capable-superclass="B"/>
    <class name="D" persistence-capable-superclass="B"/>
    In B.mapping, I have
    <mapping>
    <package name="domain">
    <class name="B">
    <jdbc-class-map type="horizontal"/>
    <jdbc-class-ind type="metadata-value" column="foo"/>
    </class>
    </package>
    </mapping>
    B.java has a private String foo.
    In C.mapping, I have
    <mapping>
    <package name="domain">
    <class name="C">
    <jdbc-class-map type="flat"/>
    <jdbc-class-ind-value value="fred"/>
    field mappings for C
    </class>
    </package>
    </mapping>
    and similarly in D for value='wilma'
    My questions are...
    1. Is this kind of mapping supported by kodo?
    2. If so, is this configuration correct? I guess not, since I don't
    specify the table name anywhere. Where should it go?
    3. If I remove the "class indicator" mapping and run a simple test I get
    kodo.util.FatalUserException: There is no superclass mapping for mapping
    for "class domain.D".
         at
    kodo.jdbc.meta.FlatClassMapping.assertParentMapping(FlatClassMapping.java:49)
         at kodo.jdbc.meta.FlatClassMapping.getTable(FlatClassMapping.java:85)
         at
    kodo.jdbc.meta.OneToManyFieldMapping.fromMappingInfo(OneToManyFieldMapping.java:87)
         at
    kodo.jdbc.meta.RuntimeMappingProvider.getFieldMapping(RuntimeMappingProvider.java:160)
         at
    kodo.jdbc.meta.MappingRepository.getFieldMapping(MappingRepository.java:443)
         at
    kodo.jdbc.meta.AbstractClassMapping.getFieldMapping(AbstractClassMapping.java:949)
    4. If I run a simple test with the horizontal, flat and class-indicator
    mappings, I get
    kodo.jdbc.meta.MappingInfoNotFoundException: The "class-column"
    attribute/extension for the class indicator on type
    "domain.B.<class-indicator>" is missing or names a column that does not
    exist.
         at kodo.jdbc.meta.Mappings.invalidMapping(Mappings.java:135)
         at kodo.jdbc.meta.Mappings.invalidMapping(Mappings.java:121)
         at
    kodo.jdbc.meta.ColumnClassIndicator.fromMappingInfo(ColumnClassIndicator.java:95)
         at
    kodo.jdbc.meta.RuntimeMappingProvider.initialize(RuntimeMappingProvider.java:135)
         at
    kodo.jdbc.meta.MappingRepository.getMappingInternal(MappingRepository.java:378)
    What am I doing wrong?
    Thanks in advance
    Srini

    I solved this problem by removing the identifier field from the
    class/mapping (kodo support).
    Thanks
    Srini
    Stephen Kim wrote:
    Do you have two fields mapped to the same column? Did you make sure you
    set everything which maps to the column?
    Srinivasan Ranganathan wrote:
    I found what was wrong with this, fixed it and got a different (more
    sensible) error. To correct this mapping, I specified B's mapping type as
    "base" and gave its table and pk names. Also, I moved the common field
    mappings to B.mapping so C.mapping and D.mapping only have fields that are
    specific to each.
    Now when I run a simple test, I get
    testC:
    kodo.util.FatalUserException: Attempt to set column "B.FOO" to two
    different values: (java.lang.Object)"java.lang.Object@2f608ac2",
    (java.lang.String)"fred" This can occur when you fail to set both sides of
    a two-sided relation between objects, or when you map different fields to
    the same column, but you do not keep the values of these fields in synch.
         at kodo.jdbc.runtime.VRow.setObjectInternal(VRow.java(Compiled Code))
         at kodo.jdbc.sql.AbstractRow.setObject(AbstractRow.java(Compiled Code))
         at
    kodo.jdbc.meta.ColumnClassIndicator.insert(ColumnClassIndicator.java:143)
         at kodo.jdbc.runtime.UpdateManagerImpl.insert(UpdateManagerImpl.java:216)
         at kodo.jdbc.runtime.UpdateManagerImpl.insert(UpdateManagerImpl.java:219)
         at kodo.jdbc.runtime.UpdateManagerImpl.flush(UpdateManagerImpl.java:108)
         at kodo.jdbc.runtime.UpdateManagerImpl.flush(UpdateManagerImpl.java:73)
    testD:
    kodo.util.FatalUserException: Attempt to set column "B.FOO" to two
    different values: (java.lang.Object)"java.lang.Object@2f608ac2",
    (java.lang.String)"wilma" This can occur when you fail to set both sides
    of a two-sided relation between objects, or when you map different fields
    to the same column, but you do not keep the values of these fields in
    synch.
         at kodo.jdbc.runtime.VRow.setObjectInternal(VRow.java(Compiled Code))
         at kodo.jdbc.sql.AbstractRow.setObject(AbstractRow.java(Compiled Code))
         at
    kodo.jdbc.meta.ColumnClassIndicator.insert(ColumnClassIndicator.java:143)
         at kodo.jdbc.runtime.UpdateManagerImpl.insert(UpdateManagerImpl.java:216)
         at kodo.jdbc.runtime.UpdateManagerImpl.insert(UpdateManagerImpl.java:219)
         at kodo.jdbc.runtime.UpdateManagerImpl.flush(UpdateManagerImpl.java:108)
         at kodo.jdbc.runtime.UpdateManagerImpl.flush(UpdateManagerImpl.java:73)
    I've checked for the two possible errors to the best of my knowledge. Any
    input to resolve this issue is appreciated.
    Thanks in advance
    Srini
    Srinivasan Ranganathan wrote:
    Hi
    I have an abstract class B which itself extends another abstract class A.
    There is no table for A. The fields in A are mapped to B. I believe this
    is called "horizontal mapping"
    C and D inherit off B. There's a also a table named B (mapped to class B),
    but none for C or D. Instances of C and D are recorded in table B. I
    believe this is called "flat mapping"
    B has a field foo whose possible values are 'fred' and 'wilma'.
    If foo='fred', then the record is of type C
    If foo='wilma', then the record is of type D
    I believe this is called "class indicator" of type metadata.
    To express this, I have package.jdo which says
    <class name="A"/>
    <class name="B" persistence-capable-superclass="A"/>
    <class name="C" persistence-capable-superclass="B"/>
    <class name="D" persistence-capable-superclass="B"/>
    In B.mapping, I have
    <mapping>
    <package name="domain">
    <class name="B">
    <jdbc-class-map type="horizontal"/>
    <jdbc-class-ind type="metadata-value" column="foo"/>
    </class>
    </package>
    </mapping>
    B.java has a private String foo.
    In C.mapping, I have
    <mapping>
    <package name="domain">
    <class name="C">
    <jdbc-class-map type="flat"/>
    <jdbc-class-ind-value value="fred"/>
    field mappings for C
    </class>
    </package>
    </mapping>
    and similarly in D for value='wilma'
    My questions are...
    1. Is this kind of mapping supported by kodo?
    2. If so, is this configuration correct? I guess not, since I don't
    specify the table name anywhere. Where should it go?
    3. If I remove the "class indicator" mapping and run a simple test I get
    kodo.util.FatalUserException: There is no superclass mapping for mapping
    for "class domain.D".
         at
    kodo.jdbc.meta.FlatClassMapping.assertParentMapping(FlatClassMapping.java:49)
         at kodo.jdbc.meta.FlatClassMapping.getTable(FlatClassMapping.java:85)
         at
    kodo.jdbc.meta.OneToManyFieldMapping.fromMappingInfo(OneToManyFieldMapping.java:87)
    >>
         at
    kodo.jdbc.meta.RuntimeMappingProvider.getFieldMapping(RuntimeMappingProvider.java:160)
    >>
         at
    kodo.jdbc.meta.MappingRepository.getFieldMapping(MappingRepository.java:443)
         at
    kodo.jdbc.meta.AbstractClassMapping.getFieldMapping(AbstractClassMapping.java:949)
    >>
    >>
    >>
    >>
    4. If I run a simple test with the horizontal, flat and class-indicator
    mappings, I get
    kodo.jdbc.meta.MappingInfoNotFoundException: The "class-column"
    attribute/extension for the class indicator on type
    "domain.B.<class-indicator>" is missing or names a column that does not
    exist.
         at kodo.jdbc.meta.Mappings.invalidMapping(Mappings.java:135)
         at kodo.jdbc.meta.Mappings.invalidMapping(Mappings.java:121)
         at
    kodo.jdbc.meta.ColumnClassIndicator.fromMappingInfo(ColumnClassIndicator.java:95)
    >>
         at
    kodo.jdbc.meta.RuntimeMappingProvider.initialize(RuntimeMappingProvider.java:135)
    >>
         at
    kodo.jdbc.meta.MappingRepository.getMappingInternal(MappingRepository.java:378)
    >>
    >>
    >>
    What am I doing wrong?
    Thanks in advance
    Srini
    Steve Kim
    [email protected]
    SolarMetric Inc.
    http://www.solarmetric.com

  • ZBF Class-map and different way of doing them

    Hi People just though i would ask a question on how to set up a ZBF. (question at the end of example config's)
    i have been playing with this for a while now and like to get advice over what way is the recomended way of doing multiple matchs
    ok we we all know the basic
    class-map type inspect match-any ZBF_CM_ICMP
    match protocol icmp
    policy-map type inspect ZBF_PM_EXTERNAL->DMZ
    class type inspect ZBF_CM_ICMP
      inspect
    and then the ZP dont need to show, this is a simple map using nbar fair enough
    then we could a mulitiple matches
    class-map type inspect match-any ZBF_CM_STD_DMZ_PORTS
    match protocol icmp
    match protocol http
    match protocol dns
    match protocol https
    policy-map type inspect ZBF_PM_DMZ->EXTERNAL
    class type inspect ZBF_CM_STD_DMZ_PORTS
      inspect
    Ok still easy to understand but now come the bit that a little more copmplex non NBAR matches
    ip access-list extended AL_RDP_PORT
    permit tcp any any eq 3389
    class-map type inspect match-all ZBF_CM_RDP
    match access-group name AL_RDP_PORT
    policy-map type inspect ZBF_PM_EXTERNAL->DMZ
    class type inspect ZBF_CM_RDP
      inspect
    This config is now using an access list because NBAR dosent have the protocol in it then map the AL to the CM then CM to PM. next is example is what i setup to get more non NBAR ports and only for 1 host
    ip access-list extended AL_HOST_IP_IN
    permit ip any host 11.11.11.11
    ip access-list extended AL_ISATAP
    permit 41 any any
    ip access-list extended AL_TEREDO
    permit udp any any eq 3544
    class-map type inspect match-ANY ZBF_CM_DirectAccess_Protocols
    description Nested Class Map
    match access-group name AL_ISATAP
    match access-group name AL_TEREDO
    match protocol https
    class-map type inspect match-ALL ZBF_CM_APP_IN
    match access-group name AL_HOST_IP_IN
    match access-group name ZBF_CM_DirectAccess_Protocols
    policy-map type inspect ZBF_PM_EXTERNAL->DMZ
    class type inspect ZBF_CM_APP_IN
      inspect                                                                                                      (or pass with rule for other direction)
    THis is what i setup and it works not for this example but the rule flow i then was having issues with DMVPN and ZBF (turned out to be an iso bug annoying me) but i used CiscoCP to setup the ZBF automaticly forthe DMVPN and it ZBF rule where  same proceduare as below.
    ip access-list extended AL_HOST_IP_IN
    permit ip any host 11.11.11.11
    ip access-list extended AL_ISATAP
    permit 41 any any
    ip access-list extended AL_TEREDO
    permit udp any any eq 3544
    class-map type inspect match-ANY CM_ISATAP
    match access-group name AL_ISATAP
    class-map type inspect match-ANY CM_TEREDO
    match access-group name AL_TEREDO
    class-map type inspect match-ANY ZBF_CM_DirectAccess_Protocols
    description Nested Class Map
    match class-map CM_ISATAP
    match class-map CM_TEREDO
    match protocol https
    class-map type inspect match-ALL ZBF_CM_APP_IN
    match access-group name AL_HOST_IP_IN
    match access-group name ZBF_CM_DirectAccess_Protocols
    policy-map type inspect ZBF_PM_EXTERNAL->DMZ
    class type inspect ZBF_CM_APP_IN
      inspect
    So what Cisco CP did was make yet another level of nesting rather then the match-all class map having the match access list command then made a cm with access list then the main class map had only other match class maps in it..
    QUESTION:
    Why did CiscoCP do the extra nesting
    both ways worked but i would like to know why the cisco CP did the same thing with the other layer of CM did it do this for best practise or dose this make changed later easier i cant understand whats the advange to doing it this way... but if there is a valid reason then ill great jjust trying to understand.
    thanks
    regards
    A very sore headed
    Dave

    When people say "use as few classes as possible", it's usually related not to optimize heap usage, but jar size.
    But it's true that some smart use of OOP can save a lot of memory during runtime (and even jar size in some cases). Using an interface in my GUI library helps make the architecture a lot simpler and more compact, to the point that even if all the GUI widgets are being used (so the "just loading the code you need at the moment" argument is moot) memory use is still smaller because I need a lot less hacks to glue everything together.
    It still is worth noting that often memory fragmentation is the true cause of running-out-of-memory-errors, and in this case loading many small classes will achieve exactly the opposite.
    shmoove

  • Class-Map and Policy-Map Configuration in CM Confusion

    Hi,
    I'm implementing a green field WAAS deployment for a customer. We currently have a Proof-of-Concept up and running.
    I've got some questions regarding custom class-map and policy-map configuration in the CM. I'd like to nail-down the custom class-map and policy-map configuration (and understanding) in the PoC before cutting over the PoC branches to the production WAAS environment.
    Assuming a typical WAAS Deployment using WCCP for off-path interception, branch to DC.
     ==> 61 in LAN (BRANCH ROUTER) <== 62 in WAN        (WAN CLOUD)        ==> 61 in WAN (DC ROUTER) <== 62 in LAN
    We are using two distinct device groups, BRANCH and DATA CENTER.
    If the customer has traffic that we need to classify in order to provide TFO only optimisation, should the single class-map include the traffic in both directions? Ie., (assume the SERVER is 10.1.1.1 TCP Port 443). Should the class-map be configured as:
    Class-Map
    Line 1: DST IP 10.1.1.1 DST Port 443
    Line 2: SRC IP 10.1.1.1 SRC Port 443
    Or in this case is only the DST line required? And in which Device Group should the custom policy be applied? Or should it be applied to both Device Groups? If it should be applied to both Device Groups, then would it make more sense to have the policy-map in the Branch DG configured to match the DST traffic, and on the Data Center DG have a different class-map match the SRC traffic?
    My confusion is how to classify the traffic (SRC or DST or Both - Separate classes for each or different lines within the same class-map), and where to apply the appropriate policy (both Device Groups, just Branch, just DC) and why...
    I tried to apply a custom policy and the impact in the PoC was that the TCP Summary report stopped reporting the individual traffic classes showed 'other traffic' only. Can anyone explain why this may have occurred?
    I hope this makes sense.

    for instance like this:
    policy-map police-in
    class class-default
    police rate 10 mpbs <optionally set burst>
    policy-map shape-out-parent
    class class-default
    shape 10 mpbs <optional burst config>
    service-policy shape-out-child
    policy-map shape-out-child
    class class-default
    queue-limit 10 packets
    int g 0/0/0/0
    service-policy police-in in
    service-policy shape-out-parent out
    also have a look at CL 2013/2014 (orlando/sanfran) ID 2904 for more QOS details
    and the support forum article of "asr9000 quality of service architecture"
    xander

  • Maps and Separate Classes

    Hi again :D hehe
    Any idea how I can transfer the file reading into an empty java class say ReadFile.java. And access the Map set from the first main gui java class (im using netbeans, if this helps :D)
    Thank you!
    steve
    p.s. the txt file it reads if the following flights.txt - e.g. aberdeen,london,50 (start,destination,cost) aberdeen,manchester,21 - london,brighton,12
        Map<String,Map<String,Integer>> flights = new HashMap<String,Map<String,Integer>>();
        private void buttonOpenFileActionPerformed(java.awt.event.ActionEvent evt) {                                              
                       // load the first line from a file into the firstlineBox textbox
            JFileChooser fileChooser = new JFileChooser();      // create a file chooser
            int returnVal = fileChooser.showOpenDialog(this); // show an open file dialogue
            if (returnVal == JFileChooser.APPROVE_OPTION) {   // was it successful (not cancelled)
                File file = fileChooser.getSelectedFile();    // if so, get selected file
                try {                                         // catch I/O errors
                    FileReader fr = new FileReader(file);       // set up file reader
                    LineNumberReader input = new LineNumberReader(fr); // line number reader supports readLine
                    // all set up, now we can read!
                while (true) {
                        String line = input.readLine();     // read first line
                        if (line==null)
                            break;
                        String[] s = line.split(",");
                        Map<String,Integer> cityMap = flights.get(s[0]);
                        if (cityMap==null)
                            cityMap=new HashMap<String,Integer>();
                            flights.put(s[0],cityMap);
                        cityMap.put(s[1],Integer.parseInt(s[2]));
                } catch (IOException ex) {                    // catch I/O errors
                    JOptionPane.showMessageDialog(this,"I/O error: " + ex.toString());  // show error message
        }

    ... i worked it out myself with the help of your code... works a treat
    cheers
    here is the answer:
        private void buttonOpenFileActionPerformed(java.awt.event.ActionEvent evt) {                                              
            // load the first line from a file into the firstlineBox textbox
            JFileChooser fileChooser = new JFileChooser();      // create a file chooser
            int returnVal = fileChooser.showOpenDialog(this); // show an open file dialogue
            if (returnVal == JFileChooser.APPROVE_OPTION) {   // was it successful (not cancelled)
                File file = fileChooser.getSelectedFile();    // if so, get selected file
                try {                                         // catch I/O errors
                    FileReader fr = new FileReader(file);       // set up file reader
                    MyFileReader readFile = new MyFileReader();
                    readFile.readFile(fr);
                } catch (IOException ex) {                    // catch I/O errors
                      IOErrorMsg(ex);                 // show error message
        }  

  • Number of class maps (QOS) supported on 7200 and 7600

    Hi,
    Have few queries on class maps for QOS, putting forward for your comments/inputs.
    1. Want to know if there are any limitation (s) on the number of class maps (to be applied inbound/outbound) that can be configured on the 7200 and 7600 routers.
    2. Is there any imitation on the numbers (of class maps) in general or will it depend on the sum total of BW configured in the classes? I mean which one will be the deciding factor i.e. if the limit is wrt to the configured classes or the number of classes can't go beyond the consolidated bandwidth configured on the interface.
    Kindly share details on the same and if there are any recommendations.
    Thanks! in advance.

    From: http://www.cisco.com/en/US/tech/tk543/tk545/technologies_q_and_a_item09186a00800cdfab.shtml
    "Q. How many classes does a Quality of Service (QoS) policy support?
    A. In Cisco IOS versions earlier than 12.2 you could define a maximum of only 256 classes, and you could define up to 256 classes within each policy if the same classes are reused for different policies. If you have two policies, the total number of classes from both policies should not exceed 256. If a policy includes Class-Based Weighted Fair Queueing (CBWFQ) (meaning it contains a bandwidth [or priority] statement within any of the classes), the total number of classes supported is 64.
    In Cisco IOS versions 12.2(12),12.2(12)T, and 12.2(12)S, this limitation of 256 global class-maps was changed, and it is now possible to configure up to 1024 global class-maps and to use 256 class-maps inside the same policy-map."

  • Class mapping sample code error

    Hi !
    There is an error in a Developers guide mapping sample code: p.156-157.
    (Examples 7.11,7.12 and 7.13).
    For example, in 7.12 we have:
    <class name="Tabloid" persistence-capable-superclass="Magazine">
    <extension vendor-name="kodo" key="jdbc-class-map" value="flat"/>
    .... indicator extensions ...
    .... field metadata ...
    </class>
    instead of jdbc-use-class-map in the key attrribute of the extention tag.
    Please, fix it.
    Best regards,
    Alex.

    Actually the sample is correct. It shows the mapping information if you
    are using metadata extensions in place of .mapping files. To map a class
    via metadata extensions, you use the "jdbc-class-map" extension key.
    This is distinct from the "jdbc-use-class-map" key, which you can use to
    tell the mapping tool what kind of mapping it should create. So in sum:
    jdbc-class-map: Used at runtime by the MetaDataMappingFactory to map a
    class to its schema.
    jdbc-use-class-map: Used at dev time by the MappingTool to indicate that
    the user wants a specific type of mapping to be installed.

  • A problem with ACL in the class-map on the ACE module

                      Hi all,
    I configured the following on the ACE module:
    object-group network test
      host 192.168.1.21
      host 192.168.1.22
      host 192.168.1.23
    object-group service port
      tcp eq www
      tcp eq 8080
    access-list T line 8 extended permit object-group port object-group test any
    I tried to configure a class-map for matching this ACL:
    ACE-4710-2/Lab-OPT-11(config)# class-map match-any TEST_C
    ACE-4710-2/Lab-OPT-11(config-cmap)# match access-list T
    Error: Cannot associate acl having object-group ACEs in class-map.
    So couldn't I  configure the class-map by using ACL with object-groups involved? Is it the bug or the normal behaviour? Because the customer uses object-groups in ACLs and he has to configure ACL without object-groups for the traffic classification. It is horrible.
    Thank you
    Roman

    Hi Roman,
    I'm afraid it's the expected behavior. You cannot use an ACL with object-groups inside a class-map.
    Regards
    Daniel

  • Flat File  mapping issue

    Hello All,
    I am trying to an extract using flat file method in BI 7.0. I have some 150 fields in my CSV file but i wanted is just about 10 which are scattered around in the CSV file.When i Read Preview Data in the Preview tab i see incorrect data in there.And that too all under one tab, basically all under one field , though in the extraction tab for  Data Seperator i have been using ; and also tried checking the HEX box, for escape i have the ", tried HEX for this aswell.For rows to ignore i have 1.
    One thing i would like to know is how will the BI infoobject know where is the position of the flat file field in the  CSV file and where will it be mapped.i know it can be mapped in the Transformations but that is from the flat file datasource, i am asking about the CSV file.
    Please help me out and tell me what am i doing incorrectly.
    Thanks for your help.Points will be assigned.

    hi,
    use ,and ; as the escape signs.
    system takes care of it when u speicfy the path and name of the file and format as CSV.
    always the system checks the one to one mapping of the falt file fields with the infoobject in the datasource.
    options for u
    1. arrange the neccessary fields in the flat file that exactly maps with infoobjects for mapping. then start loading.
    2. keep as such and load with scattered field and in transformation map the required fields alone.
    second option consumes more memory space unneccessarily.
    For BI 7.0 basic step to laod data from flat (excel files) files for this follow the beloww step-by step directions ....
    Uploading of master data
    Log on to your SAP
    Transaction code RSA1—LEAD YOU TO MODELLING
    1. Creation of Info Objects
    • In left panel select info object
    • Create info area
    • Create info object catalog ( characteristics & Key figures ) by right clicking the created info area
    • Create new characteristics and key figures under respective catalogs according to the project requirement
    • Create required info objects and Activate.
    2. Creation of Data Source
    • In the left panel select data sources
    • Create application component(AC)
    • Right click AC and create datasource
    • Specify data source name, source system, and data type ( master data attributes, text, hierarchies)
    • In general tab give short, medium, and long description.
    • In extraction tab specify file path, header rows to be ignored, data format(csv) and data separator( , )
    • In proposal tab load example data and verify it.
    • In field tab you can you can give the technical name of info objects in the template and you not have to map during the transformation the server will automatically map accordingly. If you are not mapping in this field tab you have to manually map during the transformation in Info providers.
    • Activate data source and read preview data under preview tab.
    • Create info package by right clicking data source and in schedule tab click star to load data to PSA.( make sure to close the flat file during loading )
    3. Creation of data targets
    • In left panel select info provider
    • Select created info area and right click to select Insert Characteristics as info provider
    • Select required info object ( Ex : Employee ID)
    • Under that info object select attributes
    • Right click on attributes and select create transformation.
    • In source of transformation , select object type( data source) and specify its name and source system Note: Source system will be a temporary folder or package into which data is getting stored
    • Activate created transformation
    • Create Data transfer process (DTP) by right clicking the master data attributes
    • In extraction tab specify extraction mode ( full)
    • In update tab specify error handling ( request green)
    • Activate DTP and in execute tab click execute button to load data in data targets.
    4. Monitor
    Right Click data targets and select manage and in contents tab select contents to view the loaded data. Alternatively monitor icon can be used.
    BW 7.0
    Uploading of Transaction data
    Log on to your SAP
    Transaction code RSA1—LEAD YOU TO MODELLING
    5. Creation of Info Objects
    • In left panel select info object
    • Create info area
    • Create info object catalog ( characteristics & Key figures ) by right clicking the created info area
    • Create new characteristics and key figures under respective catalogs according to the project requirement
    • Create required info objects and Activate.
    6. Creation of Data Source
    • In the left panel select data sources
    • Create application component(AC)
    • Right click AC and create datasource
    • Specify data source name, source system, and data type ( Transaction data )
    • In general tab give short, medium, and long description.
    • In extraction tab specify file path, header rows to be ignored, data format(csv) and data separator( , )
    • In proposal tab load example data and verify it.
    • In field tab you can you can give the technical name of info objects in the template and you not have to map during the transformation the server will automatically map accordingly. If you are not mapping in this field tab you have to manually map during the transformation in Info providers.
    • Activate data source and read preview data under preview tab.
    • Create info package by right clicking data source and in schedule tab click star to load data to PSA.( make sure to close the flat file during loading )
    7. Creation of data targets
    • In left panel select info provider
    • Select created info area and right click to create ODS( Data store object ) or Cube.
    • Specify name fro the ODS or cube and click create
    • From the template window select the required characteristics and key figures and drag and drop it into the DATA FIELD and KEY FIELDS
    • Click Activate.
    • Right click on ODS or Cube and select create transformation.
    • In source of transformation , select object type( data source) and specify its name and source system Note: Source system will be a temporary folder or package into which data is getting stored
    • Activate created transformation
    • Create Data transfer process (DTP) by right clicking the master data attributes
    • In extraction tab specify extraction mode ( full)
    • In update tab specify error handling ( request green)
    • Activate DTP and in execute tab click execute button to load data in data targets.
    8. Monitor
    Right Click data targets and select manage and in contents tab select contents to view the loaded data. There are two tables in ODS new table and active table to load data from new table to active table you have to activate after selecting the loaded data . Alternatively monitor icon can be used
    Ramesh

  • Flat file mapping problem.

    Hi,
    I've just created a file mapping, and i'm trying to split a flat file field into 3 subfields for a xml record, but i have the following message:
    Before the process run, i've tested the message mapping and the interface mapping, and the log result said that the mapping has been successfully ended, so, Have you ever seen this problem before?
    I appreciate your help, thanks.
    Marzolla.

    Hi Jorge,
              Check your XML input. Try to put the same xml instance in the message mapping transformation and test it out.
    Regards,
    Dhana

  • Idoc to flat file mapping using XSLT

    Hi,
    i am using XSLT mapping. my requirement is mapping between idoc and flat file(xml to text). as i do not want to use FCC, i have opted for xslt mapping. please let me know any article which would be helpful for this.
    regards,
    Meenakshi

    Hi Meenakshi,
    Two things:
    1. Achieving this functionality  using XSLT is very difficult.
    2. Secondly you may not be able to find a direct document to convert IDoc-XML to flat file using XSLT in sdn. Try google.
    I found one link like that may be you can get some idea from there
    http://www.stylusstudio.com/SSDN/default.asp?action=9&read=6453&fid=48
    Also if you have a XSLT editor like XMLSPY or stylus studio then creating your specific XSLT will b much more simpler
    Regards
    Suraj

  • Cyrillic characters in Layer-7 Class Maps statements ?

    Hi,
    For a specific implementation, I need the ACE to parse URIs with cyrillic characters in a Layer-7 class-map. Does the ACE-4710 support it ?
    If yes, how to enter them in a L7 class-map statement like : match http url /Искусство.*
    Thank you for any hints
    Yves

    Hi Yves,
    I cannot find anything regarding this and i don't see a way to put that in there. I tried pasting it in my ACE and it didn't take it. I would suggest to open a TAC case for official confirmation.
    Regards,
    Kanwal
    Note: Please mark answers if they are helpful.

  • ACE SSL Sticky class-map generic vs class default differences.

    There was a thread recently titled "ACE 3.0(0) SW / LB with SSL Session-ID" where Giles Dufour outlined a configuration for an ACE performing sticky based on SSL Session ID.
    Can anyone explain the benefits and differences of using a specific class-map generic such as this:
    class-map type generic match-any SSL-v3-32
      2 match layer4-payload regex "\x16\x03\x00..\x01.*"
      3 match layer4-payload regex "\x16\x03\x01..\x01.*"
    Versus just matching class default?
    So if I have a configuration such as this:
    policy-map type loadbalance generic first-match SSL-v3-Sticky
    class SSL-v3-32
       sticky-serverfarm ssl-v3
    vs
    policy-map type loadbalance generic first-match SSL-v3-Sticky
    class class-default
       sticky-serverfarm ssl-v3
    What's the benefit or drawback?

    The SSL session id is only available in version 3.0.1 and 3.1.1
    So you can match this particular version and then attempt to do stickyness.
    You are guaranteed to find what you're looking for.
    If you match a class-default it means you apply stickyness to any version of ssl packet.
    So there is a risk to misinterpret the content of the packet and stick on something else than the session id.
    Gilles.

  • [SOLVED] TeXLive: Installing font package and updating font map fails

    I am trying to install the newtx package, which is available here at CTAN [1].
    Since I don't want to mess with my TeXLive installation, I am trying to do that as a local user only.
    So I placed the package into ~/texmf/tex/latex/. , ran texhash on texmf/ to update my local ls-R, and so far everything works nicely; for example, the .sty files in that package can be seen:
    $ texhash texmf
    texhash: Updating /home/$USER/texmf/ls-R...
    texhash: Done.
    $ kpsewhich newtxmath.sty
    /home/$USER/texmf/tex/latex/newtx/newtxmath.sty
    Now, following the packages README [2], I need to update the my TeX font maps. Seems like 'updmap' is the right tool to do that for my user only:
    $ updmap --enable Map=ntx.map
    copy /etc/texmf/web2c/updmap.cfg => /home/$USER/.texlive/texmf-config/web2c/updmap.cfg
    Config file: "/home/$USER/.texlive/texmf-config/web2c/updmap.cfg"
    dvips output dir: "/home/$USER/.texlive/texmf-var/fonts/map/dvips/updmap"
    pdftex output dir: "/home/$USER/.texlive/texmf-var/fonts/map/pdftex/updmap"
    dvipdfm output dir: "/home/$USER/.texlive/texmf-var/fonts/map/dvipdfm/updmap"
    pxdvi output dir: "/home/$USER/.texlive/texmf-var/fonts/map/pxdvi/updmap"
    /usr/bin/updmap is creating new map files
    using the following configuration:
    LW35 font names : URWkb
    prefer outlines : true
    texhash enabled : true
    download standard fonts (dvips) : true
    download standard fonts (pdftex) : true
    create a mapfile for pxdvi : false
    Scanning for LW35 support files [ 3 files]
    Scanning for MixedMap entries [ 36 files]
    Scanning for KanjiMap entries [ 0 files]
    Scanning for Map entries [129 files]
    ERROR: The following map file(s) couldn't be found:
    ntx.map
    Did you run mktexlsr?
    You can delete non-existent map entries using the option
    --syncwithtrees.
    That's my problem: it can't find ntx.map, although I ran mktexlsr (which is texhash). So what to do?
    1: http://www.ctan.org/pkg/newtx
    2: http://ftp.uni-erlangen.de/mirrors/CTAN … wtx/README
    SOLUTION: The trick consists in placing all files into the necessary folders: *.map goes to fonts/map/newtx/, *.vf to fonts/vf/newtx/, and *.tfm to fonts/tfm/newtx/. Also, *.pfb needs to be placed in fonts/pfb/newtx/. *.enc files go to fonts/enc/newt/, and everything else remains in tex/latex/newtx/.
    Last edited by Stalafin (2012-06-20 12:32:16)

    ConnorBehan wrote:Oh it's part of the mlocate package. It will search your entire filesystem for a filename but there are other programs that do the same. I just meant, can you find ntx.map yourself? If so, you could put it in a new directory or let tex know with the TEXINPUTS environment variable.
    I really don't think that this makes a lot of sense as regards TeXlive; I have checked (with kpsewhich --var-value) if indeed all variables TEXMFHOME, TEXMFVAR, and TEXMFCONFIG are pointing to reasonable places, and indeed they do.
    I have found this guide:
    http://people.debian.org/~preining/TeX/ … n/ch4.html
    Although it is Debian, I figure one can easily adapt it. So I tried that, and placed ntx.map in TEXMFHOME/fonts/map/$SYNTAX/newtx/ntx.map . I wasn't sure about $SYNTAX, so I just tried it with dvips. This time, $ updmap --enable Map=ntx.map did actually work, and there were not errors:
    $ updmap --enable Map=ntx.map
    copy /etc/texmf/web2c/updmap.cfg => /home/janis/.texlive/texmf-config/web2c/updmap.cfg
    Config file: "/home/$USER/.texlive/texmf-config/web2c/updmap.cfg"
    dvips output dir: "/home/$USER/.texlive/texmf-var/fonts/map/dvips/updmap"
    pdftex output dir: "/home/$USER/.texlive/texmf-var/fonts/map/pdftex/updmap"
    dvipdfm output dir: "/home/$USER/.texlive/texmf-var/fonts/map/dvipdfm/updmap"
    pxdvi output dir: "/home/$USER/.texlive/texmf-var/fonts/map/pxdvi/updmap"
    /usr/bin/updmap is creating new map files
    using the following configuration:
    LW35 font names : URWkb
    prefer outlines : true
    texhash enabled : true
    download standard fonts (dvips) : true
    download standard fonts (pdftex) : true
    create a mapfile for pxdvi : false
    Scanning for LW35 support files [ 3 files]
    Scanning for MixedMap entries [ 36 files]
    Scanning for KanjiMap entries [ 0 files]
    Scanning for Map entries [130 files]
    Generating output for dvipdfm...
    Generating output for ps2pk...
    Generating output for dvips...
    Generating output for pdftex...
    Files generated:
    /home/$USER/.texlive/texmf-var/fonts/map/dvips/updmap:
    11493 2012-06-19 21:57:22 builtin35.map
    15956 2012-06-19 21:57:22 download35.map
    523074 2012-06-19 21:57:22 psfonts_pk.map
    747564 2012-06-19 21:57:22 psfonts_t1.map
    747559 2012-06-19 21:57:22 ps2pk.map
    14 2012-06-19 21:57:24 psfonts.map -> psfonts_t1.map
    /home/$USER/.texlive/texmf-var/fonts/map/pdftex/updmap:
    747566 2012-06-19 21:57:23 pdftex_dl14.map
    745992 2012-06-19 21:57:23 pdftex_ndl14.map
    15 2012-06-19 21:57:24 pdftex.map -> pdftex_dl14.map
    /home/$USER/.texlive/texmf-var/fonts/map/dvipdfm/updmap:
    339 2012-06-19 21:57:22 kanjix.map
    Transcript written on "/home/$USER/.texlive/texmf-var/web2c/updmap.log".
    /usr/bin/updmap: Updating ls-R files.
    There indeed now is a 'Map ntx.map' at ~/.texlive/texmf-config/web2c/updmap.cfg . However, compilation of a document containg `\usepackage{newtx}` still fails (see the bttom of this wall of text):
    pdflatex test.tex
    This is pdfTeX, Version 3.1415926-2.3-1.40.12 (TeX Live 2012/dev/Arch Linux)
    restricted \write18 enabled.
    entering extended mode
    (./test.tex
    LaTeX2e <2011/06/27>
    Babel <v3.8m> and hyphenation patterns for english, dumylang, nohyphenation, ge
    rman-x-2011-07-01, ngerman-x-2011-07-01, afrikaans, ancientgreek, ibycus, arabi
    c, armenian, basque, bulgarian, catalan, pinyin, coptic, croatian, czech, danis
    h, dutch, ukenglish, usenglishmax, esperanto, estonian, ethiopic, farsi, finnis
    h, french, galician, german, ngerman, swissgerman, monogreek, greek, hungarian,
    icelandic, assamese, bengali, gujarati, hindi, kannada, malayalam, marathi, or
    iya, panjabi, tamil, telugu, indonesian, interlingua, irish, italian, kurmanji,
    lao, latin, latvian, lithuanian, mongolian, mongolianlmc, bokmal, nynorsk, pol
    ish, portuguese, romanian, russian, sanskrit, serbian, serbianc, slovak, sloven
    ian, spanish, swedish, turkish, turkmen, ukrainian, uppersorbian, welsh, loaded
    (/usr/share/texmf-dist/tex/latex/base/minimal.cls
    Document Class: minimal 2001/05/25 Standard LaTeX minimal class
    ) (/usr/share/texmf-dist/tex/latex/libertine/libertine.sty
    (/usr/share/texmf-dist/tex/latex/graphics/keyval.sty)
    (/usr/share/texmf-dist/tex/generic/ifxetex/ifxetex.sty)
    (/usr/share/texmf-dist/tex/generic/oberdiek/ifluatex.sty)
    (/usr/share/texmf-dist/tex/latex/lettrine/lettrine.sty
    Loading lettrine.cfg
    (/usr/share/texmf-dist/tex/latex/lettrine/lettrine.cfg))
    (/usr/share/texmf-dist/tex/latex/tools/calc.sty)
    (/usr/share/texmf-dist/tex/latex/libertine/fxl.inc)
    (/usr/share/texmf-dist/tex/latex/libertine/fxb.inc)
    (/usr/share/texmf-dist/tex/latex/libertine/fxk.inc)
    (/usr/share/texmf-dist/tex/latex/libertine/fxi.inc))
    (/usr/share/texmf-dist/tex/latex/base/fontenc.sty
    (/usr/share/texmf-dist/tex/latex/base/t1enc.def))
    (/usr/share/texmf-dist/tex/latex/mh/mathtools.sty
    (/usr/share/texmf-dist/tex/latex/mh/mhsetup.sty)
    (/usr/share/texmf-dist/tex/latex/amsmath/amsmath.sty
    For additional information on amsmath, use the `?' option.
    (/usr/share/texmf-dist/tex/latex/amsmath/amstext.sty
    (/usr/share/texmf-dist/tex/latex/amsmath/amsgen.sty))
    (/usr/share/texmf-dist/tex/latex/amsmath/amsbsy.sty)
    (/usr/share/texmf-dist/tex/latex/amsmath/amsopn.sty)))
    (/home/janis/texmf/tex/latex/newtx/newtxmath.sty
    `newtxmath' v0.96, 2012/06/05 Math macros based on txfonts (msharpe)
    (/usr/share/texmf-dist/tex/generic/kastrup/binhex.tex)
    (/usr/share/texmf-dist/tex/latex/xkeyval/xkeyval.sty
    (/usr/share/texmf-dist/tex/generic/xkeyval/xkeyval.tex))) (./test.aux)
    (/home/janis/texmf/tex/latex/newtx/omlntxmi.fd)
    (/home/janis/texmf/tex/latex/newtx/omsntxsy.fd)
    (/home/janis/texmf/tex/latex/newtx/omxntxex.fd)
    (/home/janis/texmf/tex/latex/newtx/untxexa.fd)
    (/usr/share/texmf-dist/tex/latex/libertine/t1fxl.fd)
    (/usr/share/texmf-dist/tex/latex/graphics/graphicx.sty
    (/usr/share/texmf-dist/tex/latex/graphics/graphics.sty
    (/usr/share/texmf-dist/tex/latex/graphics/trig.sty)
    (/usr/share/texmf-dist/tex/latex/latexconfig/graphics.cfg)
    (/usr/share/texmf-dist/tex/latex/pdftex-def/pdftex.def
    (/usr/share/texmf-dist/tex/generic/oberdiek/infwarerr.sty)
    (/usr/share/texmf-dist/tex/generic/oberdiek/ltxcmds.sty)
    (/usr/share/texmf-dist/tex/context/base/supp-pdf.mkii
    [Loading MPS to PDF converter (version 2006.09.02).]
    ))) (/usr/share/texmf-dist/tex/generic/oberdiek/pdftexcmds.sty
    (/usr/share/texmf-dist/tex/generic/oberdiek/ifpdf.sty))
    (/usr/share/texmf-dist/tex/latex/oberdiek/epstopdf-base.sty
    (/usr/share/texmf-dist/tex/latex/oberdiek/grfext.sty
    (/usr/share/texmf-dist/tex/generic/oberdiek/kvdefinekeys.sty))
    (/usr/share/texmf-dist/tex/latex/oberdiek/kvoptions.sty
    (/usr/share/texmf-dist/tex/generic/oberdiek/kvsetkeys.sty
    (/usr/share/texmf-dist/tex/generic/oberdiek/etexcmds.sty)))
    (/usr/share/texmf-dist/tex/latex/latexconfig/epstopdf-sys.cfg)))
    kpathsea: Running mktextfm ntxmi
    /usr/share/texmf/web2c/mktexnam: Could not map typeface abbreviation tx for ntxmi.
    /usr/share/texmf/web2c/mktexnam: Need to update /usr/share/texmf-dist/fonts/map/fontname/special.map?
    mktextfm: Running mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input ntxmi
    This is METAFONT, Version 2.718281 (TeX Live 2012/dev/Arch Linux)
    kpathsea: Running mktexmf ntxmi
    ! I can't find file `ntxmi'.
    <*> ...e:=ljfour; mag:=1; nonstopmode; input ntxmi
    Please type another input file name
    ! Emergency stop.
    <*> ...e:=ljfour; mag:=1; nonstopmode; input ntxmi
    Transcript written on mfput.log.
    grep: ntxmi.log: No such file or directory
    mktextfm: `mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input ntxmi' failed to make ntxmi.tfm.
    kpathsea: Appending font creation commands to missfont.log.
    ! Font OML/ntxmi/m/it/10=ntxmi at 10.0pt not loadable: Metric (TFM) file not fo
    und.
    <to be read again>
    relax
    l.13 \begin{equation*}
    EDIT: Of course, everything else from the newtx pacakge was still in TEXMFHOME/tex/latex/newtx/ .
    Last edited by Stalafin (2012-06-19 20:08:30)

  • The class-default class map

    According to Cisco dumentation (http://www.cisco.com/en/US/docs/security/asa/asa81/config/guide/mpc.html)
    , the ASA is equipped with two default class-maps
    class-map inspection_default
    match default-inspection-traffic
    and
    class-map class-default
    match any
    The first makes perfect sense, but what is the class-default used for? Cisco says
    "This class map appears at the end of all Layer 3/4 policy maps and essentially tells the adaptive security appliance to not perform any actions on all other traffic. You can use the class-default class map if desired, rather than making your own
    match any class map. In fact, some features are only available for class-default."
    But I see stuff like this:
    policy-map MyPolicy
    class class-default
      inspect tfp MyFTPpolicy
    Obviously it is being used here to act on traffic! So I am confused.
    I also noticed that when you upgrade from 8.2 to 8.4, all default class-maps are removed from the configuration: you have to re-create everything (strange)

    Hello Collin,
    This is Mike. I dont think it is well documented. Basically it is just a class map (that does not appear on the configuration unless an action is specified) that will match all traffic passing through the ASA firewall. Some features like NSEL (Netflow) and Traffic shaping are only allowed to use this kind of class maps because they dont support any other match command.
    The one that you currently have (and God I hope its not applied)  will look for tftp traffic on every IP packet passing across the ASA.
    This specific type of policy you have there can only be applied on the interface (as it is not a layer 7 inspection policy) you can check if it is applied or not by running the show "run service-policy command"
    Mike

Maybe you are looking for

  • How to see Navigation attribute in Report

    Hi ,   I am working on BI7.0.   In my Query , material is a characteristic which has 3-4 Navigation attributes. But when I execute the report , I can only see Material data displayed (because only material is in the rows). I also want to see data of

  • Still unable to get both listeners working

    I did the modification (as advised by Ravi : Many thanks to Ravi) but I am only able to get one listener running at a time. When I use "lsnrctl start listener_ss01", listener_ss01 gets started and is assigned a service handler. However, when I next e

  • CF Can't Connect To Mail Server

    I have been running CF 8 since release and generally no problems. Now, it can't connect to our mail server and there appears to be no reason. Here's the setup: We have CF 8 Standard on Win 2003 server. The same box runs SmarterMail 4.3. When I try to

  • Runtime error CX_BSP_HOST_NOT_QUALIFIED

    Dear All, Have anybode had this runtime error? Users get it but I cannot reproduce and I cannot find any OSS notes Any help appreciated Thanks Ioan

  • Mac OS X Version 10.5.8 iPhone 5

    Anyway I can connect my iPhone 5 to my MacBook with out upgarding to Snow Leapord?