Exception while accessing com port from servlet

I am trying to access communication port from a Servlet using java communications api's.
But Following exception was thrown
Caught java.lang.NullPointerException:name can't be null while loading driver com.sun.comm.Win32Driver
The SecurityManager do not allow that opeartion.
java.security AccessControlException:access denied (java.io.FilePermission c:\j2sdk1.4.1\jre\lib\javax.comm.properties delete)
at java.security.AccessControlContext.java:270) at java.security.AccessController.checkPermission(SecurityManager.java)
at java.lang.SecurityManager.checkDelete()
at java.comm.CommPortIdentifier.getPortIdentifiers(CommportIdentifier.java)
Please help me.Tell me what to do.how to successfully access a communication port from a Servlet.

Hi there. I am also facing the problem accessing com port via servlet. if u have the solution, kindly forward to me at [email protected]
many thanks

Similar Messages

  • Security Exception while accessing com port from servlet

    I am trying to access communication port from a Servlet using java communications api's.
    But Following exception was thrown
    Caught java.lang.NullPointerException:name can't be null while loading driver com.sun.comm.Win32Driver
    The SecurityManager do not allow that opeartion.
    java.security AccessControlException:access denied (java.io.FilePermission c:\j2sdk1.4.1\jre\lib\javax.comm.properties delete)
    at java.security.AccessControlContext.java:270) at java.security.AccessController.checkPermission(SecurityManager.java)
    at java.lang.SecurityManager.checkDelete()
    at java.comm.CommPortIdentifier.getPortIdentifiers(CommportIdentifier.java)
    Please help me.Tell me what to do.how to successfully access a communication port from a Servlet.

    Well, have you tried the obvious to add the following permission to your web server's policy file?
    grant "file:<wherever my servlet resides>\myservlet.jar" {
    permission java.io.FilePermission "c:\j2sdk1.4.1\jre\lib\javax.comm.properties", "write,delete";
    }

  • Exception while accessing a com port from servlet

    I am trying to access communication port from a Servlet using java communications api's.
    But Following exception was thrown
    Caught java.lang.NullPointerException:name can't be null while loading driver com.sun.comm.Win32Driver
    The SecurityManager do not allow that opeartion.
    java.security AccessControlException:access denied (java.io.FilePermission c:\j2sdk1.4.1\jre\lib\javax.comm.properties delete)
    at java.security.AccessControlContext.java:270) at java.security.AccessController.checkPermission(SecurityManager.java)
    at java.lang.SecurityManager.checkDelete()
    at java.comm.CommPortIdentifier.getPortIdentifiers(CommportIdentifier.java)
    Please help me.Tell me what to do.how to successfully access a communication port from a Servlet.

    Solved!!. Just make sure u r placing neccessary files (comm.jar, win32com.dll and javax.comm.properties)onto the right JVM folders. Since JVM may be installed in many different location in your PC, U might want to do some search around looking for java.exe elsewhere in the system. Good luck!

  • Error while accessing bean created from servlet

    Hi there
    I have a jsp page form home.jsp where i am collecting user name and password and then directing to a LoginServlet.Here if the user is validated then i create a accMasterBean and store it in Session object which i create here and then redirect to profile.jsp
    In the profile.jsp page i am using bean as follows:--
    <jsp:useBean id="accMasterBean" scope="session" class="AccountMaster">
    <jsp:setProperty name="accMasterBean" property="*"/>
    </jsp:useBean>
    i am fetching the properties of this bean in profile.jsp itself and try to display as shown below:---
    <%=accMasterBean.getAccountNumber() %>
    where accountNumber is a property defined inside AccountMaster class
    but it gives an error as follows :---
    <input type="text" name="emailAddress" value="Exception generated ---javax.servlet.ServletException: Exception thrown on line '205' from page 'D:\\Program Files\\Allaire\\JRun\\servers\\default\\emtech2\\jsp\\members\\profile.jsp'.
    Plz note if remove the above line of fetching the property of bean in profile.jsp page then there is no error
    Hoping to get a reply soon
    Thanking u
    Mumtaz
    The code for LoginServelt is given below
    ====================================
    import javax.servlet.*;
    import javax.servlet.http.*;
    import java.io.*;
    import java.sql.*;
    public class LoginServlet extends HttpServlet{
         private Connection conn=null;
         public void init(ServletConfig config)throws ServletException{
              super.init(config);
         public void doPost(HttpServletRequest request,HttpServletResponse response)throws ServletException,IOException{
         try{
              Class.forName("sun.jdbc.odbc.JdbcOdbcDriver");
              conn=DriverManager.getConnection("jdbc:odbc:emt");
         }catch(ClassNotFoundException e){System.out.println("Error loading database driver");}
         catch(SQLException e){     System.out.println("SQL Exception in Databse driver");     }
         PrintWriter out = null;
         out=response.getWriter();
         response.setContentType("text/html");
         Statement st=null;
         ResultSet rs=null;
         String aN=null;
         String pN=null;
         String accountNumber1=null;
         String pinNumber1=null;
         String alternatePassword1=null;
         String emailAddress1=null;
         String firstName1=null;
         String lastName1=null;
         String address1=null;
         String zipPostalCode1=null;
         String city1=null;
         String state1=null;
         String country1=null;
         String companyName1=null;
         String title1=null;
         String homePhone1=null;
         String workPhone1=null;
         String mobilePhone1=null;
         String pager1=null;
         String faxNo1=null;
         String website1=null;
                        //Date dob;
         String dateOfBirth1=null;
         String gender1=null;
         String securityStatus1=null;
                        //Date doreg;
         String dateOfRegistration1=null;
         int noOfAccounts1=0;
         int noOfAttempts1=0;
         String remarks1=null;
         try{
              aN=request.getParameter("accountNumber");
              pN=request.getParameter("pinNumber");
              st=conn.createStatement(); // creating a statement to execute
              rs=st.executeQuery("SELECT * FROM ACCOUNT_MASTER where AccountNumber=\'" + aN + "\' and PinNumber= \'"+pN +"\' ;");
              while (rs.next())
                        accountNumber1=rs.getString("AccountNumber");
                        pinNumber1=rs.getString("PinNumber");
                                                           //alternatePassword1=rs.getString("alternatePassword");
                        emailAddress1=rs.getString("EmailAddress");
                        firstName1=rs.getString("FirstName");
                        lastName1=rs.getString("LastName");
                        address1=rs.getString("Address");
                        zipPostalCode1=rs.getString("ZipPostalCode");
                        city1=rs.getString("City");
                        state1=rs.getString("State");
                        country1=rs.getString("Country");
                        companyName1=rs.getString("CompanyName");
                        title1=rs.getString("Title");
                        homePhone1=rs.getString("HomePhone");
                        workPhone1=rs.getString("WorkPhone");
                        mobilePhone1=rs.getString("MobilePhone");
                        pager1=rs.getString("Pager");
                        faxNo1=rs.getString("FaxNo");
                        website1=rs.getString("WebSite");
                        gender1=rs.getString("Gender");
                        break ;
         // closing the connection
         rs=null;
         st=null;
         conn.close();
    if((accountNumber1.equals(aN))&&(pinNumber1.equals(pN))){
         // create all beans address and userprofile
         HttpSession session=request.getSession();// creating the session
         AccountMaster accMasterBean=new AccountMaster();
         accMasterBean.setAccountNumber(accountNumber1);
         accMasterBean.setPinNumber(pinNumber1);
         accMasterBean.setEmailAddress(emailAddress1);
         accMasterBean.setFirstName(firstName1);
         accMasterBean.setLastName(lastName1);
         accMasterBean.setAddress(address1);
         accMasterBean.setZipPostalCode(zipPostalCode1);
         accMasterBean.setCity(city1);
         accMasterBean.setState(state1);
         accMasterBean.setCountry(country1);
         accMasterBean.setCompanyName(companyName1);
         accMasterBean.setTitle(title1);
         accMasterBean.setHomePhone(homePhone1);
         accMasterBean.setMobilePhone(mobilePhone1);
         accMasterBean.setWorkPhone(workPhone1);
         accMasterBean.setPager(pager1);
         accMasterBean.setFaxNo(faxNo1);
         accMasterBean.setWebsite(website1);
         accMasterBean.setGender(gender1);
    session.setAttribute("accMasterBean",accMasterBean);// setting the account bean in the session attribute
         getServletConfig().getServletContext().getRequestDispatcher("/jsp/members/profile.jsp").forward(request,response);
    }else{
         // do some processing for account field and pasword field not set and return back to main page
         getServletConfig().getServletContext().getRequestDispatcher("/jsp/signup.jsp").forward(request,response);
    }// end of try
    catch(SQLException e){out.println("SQL Exception generated in LoginServlet---"+e);}
    catch(Exception e1){ out.println("Exception generated in LoginServlet---" + e1);}
    finally{
    try{
         if(conn!=null) conn=null;
         if (rs!=null) rs=null;
         if(st!=null) st=null;
    }catch(Exception e){out.println("Exception closing database connections "+e);}
    } // end of doPost
         public void destroy(){
              try {
                   if(conn!=null) conn=null;
         catch (Exception e) { System.out.println("Error closing database connection"); }
         public void doGet(HttpServletRequest request,HttpServletResponse response)throws ServletException,IOException{ doPost( request, response);}
    }//end of loginservlet
    =======================================

    Hi everyone
    I have got the solution
    Thanks
    Mumtaz

  • Getting exception while accessing External WebServices from Portal Componen

    Hi,
    We are using one external Temperature WebService and calling it from the proxy which is called by a Portal Component. My proxy name is TempService and portal component name is TempComponent.While calling the web service from portal component we are getting the exception. When I checked with log file, I got that invokeMethod() is failing and following exception is occuring :
    Caused by: com.sap.engine.services.webservices.jaxm.soap.accessor.NestedSOAPException: IOError while working with the message. Check the nested Exception.
         at com.sapportals.portal.prt.service.soap.SOAPService.call(SOAPService.java:197)
         at com.sapportals.portal.prt.service.soap.PRTSOAPCall.invokeMethod(PRTSOAPCall.java:209)
         at com.sap.portal.tutorial.translation.TempService.getTemp(TempService.java:158)
         at com.sap.portal.tutorial.TempComponent.TempComponent.doContent(TempComponent.java:18)
    Can some one help us to resolve it.
    Thanks in advance,
    ajay

    As far as I know, webservices are working pretty well from SP2 Patch4. On patch3 hf2 I've had problems creating the proxy classes (especially for consuming .net webservices) and also gotten some runtime exception (cannot remember what they were).
    Suggest you open an OSS against SAP with your specific problem.

  • Getting Servlet Exception while accessing servlets after deployment

    Hi,
    Iam getting a Servlet Exception while accessing servlets after deploying into weblogic 8.1
    Error 500--Internal Server Error
    javax.servlet.ServletException: [HTTP:101249][ServletContext(id=9599010,name=MyWeb,context-path=)]: Servlet class LoginServlet for servlet LoginServlet could not be loaded because the requested class was not found in the classpath F:\bea\weblogic81\samples\domains\examples\MyWeb\WEB-INF\classes;F:\bea\weblogic81\samples\domains\examples\.\examplesServer\.wlnotdelete\extract\examplesServer_MyWeb_MyWeb.
    java.lang.UnsupportedClassVersionError: LoginServlet (Unsupported major.minor version 49.0).
         at weblogic.servlet.internal.ServletStubImpl.prepareServlet(ServletStubImpl.java:834)
         at weblogic.servlet.internal.ServletStubImpl.getServlet(ServletStubImpl.java:535)
         at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java:373)
         at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java:315)
         at weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.run(WebAppServletContext.java:6718)
         at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)
         at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:121)
         at weblogic.servlet.internal.WebAppServletContext.invokeServlet(WebAppServletContext.java:3764)
         at weblogic.servlet.internal.ServletRequestImpl.execute(ServletRequestImpl.java:2644)
         at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:219)
         at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:178)
    My Folder Structureis like this,
    F:\bea\weblogic81\samples\domains\examples\MyWeb
    MyWeb is the projectName
    F:\bea\weblogic81\samples\domains\examples\MyWeb\WEB-INF
    Inside WEB-INF, i have web.xml and weblogic.xml, and classes directory with servlet classes.
    Any help will be appreciated.
    Thanx in advance.
    Regards
    Ram

    Hi,
    Thanks for the reply.
    Yes you are correct, i compiled using jdk1.5.
    but my servlet code will not compile in jdk1.4 version since i used advanced vaector classes in that.
    Is there any settings like script file that need to be changed so that i can point to my jdk1.5 compiler rather than the default one pointed by weblogic.
    Thanks in advance
    Ram

  • "Access Violation" exception while accessing PDEImage in outside of the class as a parameter

    Hi,
    In our project, we are retrieving PDEImage content from PDF Page by using below line of code in our Plugin project:
    But we are getting "Access Violation" exception while accessing retrieved PDEImage in outside of the class as a parameter.
    This issue is happening only in Windows 8.1 and Acrobat 11 combination.
    If we remove the above highlighted lines from the method then no exception and working fine.
    But we don't know why these lines are added, because we are not updating any of the PDF content here.
    We are planning to remove these highlighted lines from the method.
    We want to know whether the removing of these lines will impact the application.
    Kindly help us to resolve the issue.

    And will removing the lines impact the application? Certainly. If you do not call PDPageReleasePDEContent you will have a memory leak at best, or may prevent other activity from completing (such as saving or closing the file). The first two lines, however, are redundant since you do not seem to be actually changing the page.
    You must call PDPageReleasePDEContent  when you have finished with the content, in every case.

  • How to access COM+ Objects From JSP

    Friends,
    We have a requirement to access COM+ objects from JSP. Please guide me on this.
    Thanks in advance.
    Tarani

    Sanyam wrote:
    if there is any .dll extension file, how can we read that file in labview?
    You can use Call Library Function node to call that dll file and use it in LabVIEW. Read the help and you will get more details.

  • 'Class Cast Exception' while invoking a EJB from a Servlet

              Hi,
              I am working on J2EE applications.I am using Webgain studio and weblogic server.I
              got a problem while invoking EJB from the servlet.
              While calling an EJB from the servlet, it is giving that "Class Cast Exception".This
              is because, the remote home reference is not able to type casted to the"Home Interface"
              of the EJB, even if I type casted explicitly. It is creating the context and able
              to identify the EJB with the JNDI name.
              Could please help me in solving this problem.I am pasting the code here.
              Thanks in advance,
              Dharma
              public void doGet(HttpServletRequest req, HttpServletResponse resp)
                   throws ServletException, IOException
                        resp.setContentType("text/html");
                        PrintWriter out = new PrintWriter(resp.getOutputStream());
              try
              Context context=getInitialContext();
              Object reference=context.lookup("ArlProjContractorAppletSession");
              ArlProjContractorAppletSessionHome home=(ArlProjContractorAppletSessionHome)PortableRemoteObject.narrow(reference,ArlProjContractorAppletSessionHome.class);
              //Exception is occuring in the above statement. It is unable
              //to cast to the home interface          
                        ArlProjContractorAppletSession the_ejb=null;
              try
              the_ejb=home.create();
              System.out.println("the_ejb = " + the_ejb.toString());
              catch(Exception e)
              e.printStackTrace();
              catch(Exception e)
              e.printStackTrace();
                        // to do: code goes here.
                        out.println("<HTML>");
                        out.println("<HEAD><TITLE>Contractor TimeTracker</TITLE></HEAD>");
                        out.println("<BODY>");
                        // to do: your HTML goes here.
                        out.println("</BODY>");
                        out.println("</HTML>");
                        out.close();
              

              I came across this kind of problem once. My problem went away after I upgraded
              from 5.1 SP6 to 5.1 SP8.
              "Dharma" <[email protected]> wrote:
              >
              >Hi,
              >
              >I am working on J2EE applications.I am using Webgain studio and weblogic
              >server.I
              >got a problem while invoking EJB from the servlet.
              >
              >While calling an EJB from the servlet, it is giving that "Class Cast
              >Exception".This
              >is because, the remote home reference is not able to type casted to the"Home
              >Interface"
              >of the EJB, even if I type casted explicitly. It is creating the context
              >and able
              >to identify the EJB with the JNDI name.
              >
              >Could please help me in solving this problem.I am pasting the code here.
              >
              >Thanks in advance,
              >Dharma
              >
              >
              >public void doGet(HttpServletRequest req, HttpServletResponse resp)
              >     throws ServletException, IOException
              >     {
              >          resp.setContentType("text/html");
              >          PrintWriter out = new PrintWriter(resp.getOutputStream());
              >
              > try
              > {
              >
              > Context context=getInitialContext();
              >
              > Object reference=context.lookup("ArlProjContractorAppletSession");
              >
              > ArlProjContractorAppletSessionHome home=(ArlProjContractorAppletSessionHome)PortableRemoteObject.narrow(reference,ArlProjContractorAppletSessionHome.class);
              >
              >//Exception is occuring in the above statement. It is unable
              >//to cast to the home interface          
              >
              >          ArlProjContractorAppletSession the_ejb=null;
              >
              > try
              > {
              > the_ejb=home.create();
              >
              > System.out.println("the_ejb = " + the_ejb.toString());
              >
              > }
              > catch(Exception e)
              > {
              > e.printStackTrace();
              > }
              > }
              > catch(Exception e)
              > {
              > e.printStackTrace();
              > }
              >          // to do: code goes here.
              >
              >          out.println("<HTML>");
              >          out.println("<HEAD><TITLE>Contractor TimeTracker</TITLE></HEAD>");
              >          out.println("<BODY>");
              >
              >          // to do: your HTML goes here.
              >
              >          out.println("</BODY>");
              >          out.println("</HTML>");
              >          out.close();
              >     }
              >
              >
              >
              >
              >
              

  • Getting atg.servlet.pagecompile.PageCompileException: can't load class: _dasadmin_3__UTF_s8._index Exception while accessing merch server dynamo

    Hi Experts,
    I am getting following error while accessing merch server dynamo,
    18:10:17,334 ERROR [STDERR] java.lang.UnsupportedClassVersionError: _dasadmin_3__UTF_s8/_index : Unsupported major.minor version 51.0
    18:10:17,335 ERROR [STDERR]     at java.lang.ClassLoader.defineClass1(Native Method)
    18:10:17,335 ERROR [STDERR]     at java.lang.ClassLoader.defineClassCond(Unknown Source)
    18:10:17,335 ERROR [STDERR]     at java.lang.ClassLoader.defineClass(Unknown Source)
    18:10:17,335 ERROR [STDERR]     at atg.servlet.pagecompile.ReusableClassLoader.findClass(ReusableClassLoader.java:330)
    18:10:17,335 ERROR [STDERR]     at atg.servlet.pagecompile.ReusableClassLoader.findClass(ReusableClassLoader.java:286)
    18:10:17,335 ERROR [STDERR]     at java.lang.ClassLoader.loadClass(Unknown Source)
    18:10:17,335 ERROR [STDERR]     at atg.servlet.pagecompile.ReusableClassLoader.loadClass(ReusableClassLoader.java:602)
    18:10:17,335 ERROR [STDERR]     at java.lang.ClassLoader.loadClass(Unknown Source)
    18:10:17,336 ERROR [STDERR]     at atg.servlet.pagecompile.PageProcessor.loadClass(PageProcessor.java:2704)
    18:10:17,336 ERROR [STDERR]     at atg.servlet.pagecompile.PageProcessor.loadClass(PageProcessor.java:2605)
    18:10:17,336 ERROR [STDERR]     at atg.servlet.pagecompile.PageProcessor.compilePageClass(PageProcessor.java:2479)
    18:10:17,336 ERROR [STDERR]     at atg.servlet.pagecompile.PageProcessor.getPageInfo(PageProcessor.java:1787)
    18:10:17,336 ERROR [STDERR]     at atg.servlet.pagecompile.jsp12.Jsp12PageProcessor.getPageInfo(Jsp12PageProcessor.java:324)
    18:10:17,336 ERROR [STDERR]     at atg.servlet.minimal.MinimalServletContainer.compileServlet(MinimalServletContainer.java:153)
    18:10:17,336 ERROR [STDERR]     at atg.servlet.pagecompile.PageCompileServlet.service(PageCompileServlet.java:303)
    18:10:17,336 ERROR [STDERR]     at atg.servlet.DynamoServlet.service(DynamoServlet.java:148)
    18:10:17,336 ERROR [STDERR]     at atg.servlet.pipeline.PipelineableServletImpl.passRequest(PipelineableServletImpl.java:160)
    18:10:17,336 ERROR [STDERR]     at atg.droplet.DropletEventServlet.service(DropletEventServlet.java:657)
    18:10:17,336 ERROR [STDERR]     at atg.servlet.pipeline.PipelineableServletImpl.service(PipelineableServletImpl.java:267)
    18:10:17,336 ERROR [STDERR]     at atg.servlet.pipeline.DispatcherPipelineServletImpl.service(DispatcherPipelineServletImpl.java:253)
    18:10:17,336 ERROR [STDERR]     at atg.servlet.pipeline.PipelineableServletImpl.passRequest(PipelineableServletImpl.java:157)
    18:10:17,337 ERROR [STDERR]     at atg.servlet.pipeline.MimeTyperPipelineServlet.service(MimeTyperPipelineServlet.java:228)
    18:10:17,337 ERROR [STDERR]     at atg.servlet.pipeline.PipelineableServletImpl.passRequest(PipelineableServletImpl.java:157)
    18:10:17,337 ERROR [STDERR]     at atg.servlet.pipeline.FileFinderPipelineServlet.service(FileFinderPipelineServlet.java:729)
    18:10:17,337 ERROR [STDERR]     at atg.servlet.pipeline.PipelineableServletImpl.passRequest(PipelineableServletImpl.java:157)
    18:10:17,337 ERROR [STDERR]     at atg.servlet.pipeline.DispatcherPipelineServletImpl.service(DispatcherPipelineServletImpl.java:275)
    18:10:17,337 ERROR [STDERR]     at atg.servlet.pipeline.PipelineableServletImpl.passRequest(PipelineableServletImpl.java:157)
    18:10:17,337 ERROR [STDERR]     at atg.servlet.pipeline.ServletPathPipelineServlet.service(ServletPathPipelineServlet.java:208)
    18:10:17,337 ERROR [STDERR]     at atg.servlet.pipeline.PipelineableServletImpl.passRequest(PipelineableServletImpl.java:157)
    18:10:17,337 ERROR [STDERR]     at atg.security.ExpiredPasswordAdminServlet.service(ExpiredPasswordAdminServlet.java:312)
    18:10:17,337 ERROR [STDERR]     at atg.servlet.pipeline.PipelineableServletImpl.passRequest(PipelineableServletImpl.java:157)
    18:10:17,337 ERROR [STDERR]     at atg.servlet.pipeline.BasicAuthenticationPipelineServlet.service(BasicAuthenticationPipelineServlet.java:513)
    18:10:17,337 ERROR [STDERR]     at atg.servlet.pipeline.PipelineableServletImpl.passRequest(PipelineableServletImpl.java:157)
    18:10:17,338 ERROR [STDERR]     at atg.servlet.pipeline.DynamoPipelineServlet.service(DynamoPipelineServlet.java:491)
    18:10:17,338 ERROR [STDERR]     at atg.servlet.pipeline.PipelineableServletImpl.passRequest(PipelineableServletImpl.java:157)
    18:10:17,338 ERROR [STDERR]     at atg.dtm.TransactionPipelineServlet.service(TransactionPipelineServlet.java:249)
    18:10:17,338 ERROR [STDERR]     at atg.servlet.pipeline.PipelineableServletImpl.passRequest(PipelineableServletImpl.java:157)
    18:10:17,338 ERROR [STDERR]     at atg.servlet.pipeline.HeadPipelineServlet.passRequest(HeadPipelineServlet.java:1271)
    18:10:17,338 ERROR [STDERR]     at atg.servlet.pipeline.HeadPipelineServlet.service(HeadPipelineServlet.java:952)
    18:10:17,338 ERROR [STDERR]     at atg.servlet.pipeline.PipelineableServletImpl.service(PipelineableServletImpl.java:272)
    18:10:17,338 ERROR [STDERR]     at atg.nucleus.servlet.NucleusProxyServlet.service(NucleusProxyServlet.java:237)
    18:10:17,338 ERROR [STDERR]     at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
    18:10:17,338 ERROR [STDERR]     at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
    18:10:17,338 ERROR [STDERR]     at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
    18:10:17,338 ERROR [STDERR]     at org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)
    18:10:17,338 ERROR [STDERR]     at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
    18:10:17,339 ERROR [STDERR]     at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
    18:10:17,339 ERROR [STDERR]     at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:235)
    18:10:17,339 ERROR [STDERR]     at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
    18:10:17,339 ERROR [STDERR]     at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:183)
    18:10:17,339 ERROR [STDERR]     at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:95)
    18:10:17,339 ERROR [STDERR]     at org.jboss.web.tomcat.security.SecurityContextEstablishmentValve.process(SecurityContextEstablishmentValve.java:126)
    18:10:17,339 ERROR [STDERR]     at org.jboss.web.tomcat.security.SecurityContextEstablishmentValve.invoke(SecurityContextEstablishmentValve.java:70)
    18:10:17,339 ERROR [STDERR]     at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
    18:10:17,339 ERROR [STDERR]     at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
    18:10:17,339 ERROR [STDERR]     at org.jboss.web.tomcat.service.jca.CachedConnectionValve.invoke(CachedConnectionValve.java:158)
    18:10:17,339 ERROR [STDERR]     at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
    18:10:17,339 ERROR [STDERR]     at org.jboss.web.tomcat.service.request.ActiveRequestResponseCacheValve.internalProcess(ActiveRequestResponseCacheValve.java:74)
    18:10:17,340 ERROR [STDERR]     at org.jboss.web.tomcat.service.request.ActiveRequestResponseCacheValve.invoke(ActiveRequestResponseCacheValve.java:47)
    18:10:17,340 ERROR [STDERR]     at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:330)
    18:10:17,340 ERROR [STDERR]     at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:829)
    18:10:17,340 ERROR [STDERR]     at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:599)
    18:10:17,340 ERROR [STDERR]     at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:451)
    18:10:17,340 ERROR [STDERR]     at java.lang.Thread.run(Unknown Source)
    18:10:17,340 ERROR [PageCompileServlet] Error compiling page: /index.jhtml : can't load class: _dasadmin_3__UTF_s8._index
    atg.servlet.pagecompile.PageCompileException: can't load class: _dasadmin_3__UTF_s8._index
    Can You please suggest me to fix this issue.
    Thanks & Regards,
    Murali

    I cleanedup pagebuild in both merch1 server and home path,
    Even I'm getting same error.
    10:50:40,098 ERROR [PageCompileServlet] Error compiling page: /index.jhtml : can't load class: _dasadmin_3__UTF_s8._index
    atg.servlet.pagecompile.PageCompileException: can't load class: _dasadmin_3__UTF_s8._index
      at atg.servlet.pagecompile.PageProcessor.compilePageClass(PageProcessor.java:2482)
      at atg.servlet.pagecompile.PageProcessor.getPageInfo(PageProcessor.java:1787)
      at atg.servlet.pagecompile.jsp12.Jsp12PageProcessor.getPageInfo(Jsp12PageProcessor.java:324)
      at atg.servlet.minimal.MinimalServletContainer.compileServlet(MinimalServletContainer.java:153)
      at atg.servlet.pagecompile.PageCompileServlet.service(PageCompileServlet.java:303)
      at atg.servlet.DynamoServlet.service(DynamoServlet.java:148)
      at atg.servlet.pipeline.PipelineableServletImpl.passRequest(PipelineableServletImpl.java:160)
      at atg.droplet.DropletEventServlet.service(DropletEventServlet.java:657)
      at atg.servlet.pipeline.PipelineableServletImpl.service(PipelineableServletImpl.java:267)
      at atg.servlet.pipeline.DispatcherPipelineServletImpl.service(DispatcherPipelineServletImpl.java:253)
      at atg.servlet.pipeline.PipelineableServletImpl.passRequest(PipelineableServletImpl.java:157)
      at atg.servlet.pipeline.MimeTyperPipelineServlet.service(MimeTyperPipelineServlet.java:228)
      at atg.servlet.pipeline.PipelineableServletImpl.passRequest(PipelineableServletImpl.java:157)
      at atg.servlet.pipeline.FileFinderPipelineServlet.service(FileFinderPipelineServlet.java:729)
      at atg.servlet.pipeline.PipelineableServletImpl.passRequest(PipelineableServletImpl.java:157)
      at atg.servlet.pipeline.DispatcherPipelineServletImpl.service(DispatcherPipelineServletImpl.java:275)
      at atg.servlet.pipeline.PipelineableServletImpl.passRequest(PipelineableServletImpl.java:157)
      at atg.servlet.pipeline.ServletPathPipelineServlet.service(ServletPathPipelineServlet.java:208)
      at atg.servlet.pipeline.PipelineableServletImpl.passRequest(PipelineableServletImpl.java:157)
      at atg.security.ExpiredPasswordAdminServlet.service(ExpiredPasswordAdminServlet.java:312)
      at atg.servlet.pipeline.PipelineableServletImpl.passRequest(PipelineableServletImpl.java:157)
      at atg.servlet.pipeline.BasicAuthenticationPipelineServlet.service(BasicAuthenticationPipelineServlet.java:513)
      at atg.servlet.pipeline.PipelineableServletImpl.passRequest(PipelineableServletImpl.java:157)
      at atg.servlet.pipeline.DynamoPipelineServlet.service(DynamoPipelineServlet.java:491)
      at atg.servlet.pipeline.PipelineableServletImpl.passRequest(PipelineableServletImpl.java:157)
      at atg.dtm.TransactionPipelineServlet.service(TransactionPipelineServlet.java:249)
      at atg.servlet.pipeline.PipelineableServletImpl.passRequest(PipelineableServletImpl.java:157)
      at atg.servlet.pipeline.HeadPipelineServlet.passRequest(HeadPipelineServlet.java:1271)
      at atg.servlet.pipeline.HeadPipelineServlet.service(HeadPipelineServlet.java:952)
      at atg.servlet.pipeline.PipelineableServletImpl.service(PipelineableServletImpl.java:272)
      at atg.nucleus.servlet.NucleusProxyServlet.service(NucleusProxyServlet.java:237)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:235)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
      at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:183)
      at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:95)
      at org.jboss.web.tomcat.security.SecurityContextEstablishmentValve.process(SecurityContextEstablishmentValve.java:126)
      at org.jboss.web.tomcat.security.SecurityContextEstablishmentValve.invoke(SecurityContextEstablishmentValve.java:70)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
      at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
      at org.jboss.web.tomcat.service.jca.CachedConnectionValve.invoke(CachedConnectionValve.java:158)
      at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
      at org.jboss.web.tomcat.service.request.ActiveRequestResponseCacheValve.internalProcess(ActiveRequestResponseCacheValve.java:74)
      at org.jboss.web.tomcat.service.request.ActiveRequestResponseCacheValve.invoke(ActiveRequestResponseCacheValve.java:47)
      at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:330)
      at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:829)
      at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:599)
      at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:451)
      at java.lang.Thread.run(Unknown Source)
    Can You please suggest any other solution.
    I'm using JBOSS version : jboss-eap-5.1.2
                  JDK version      : jdk1.6.0_31
    Thanks & Regards,
    Murali

  • Exception while accessing web application

    Hi All,
    I have deployed my web application on OC4J 10.1.3. But while accessing application i am geeting NullPointer Exception below is the complete stack trace for the same.
    java.lang.NullPointerException
    at org.mortbay.servlet.jetty.IncludableGzipFilter$IncludableGzipStream.setContentEncodingGzip(IncludableGzipFilter.java:54)
    at org.mortbay.servlet.GzipFilter$GzipStream.doGzip(GzipFilter.java:482)
    at org.mortbay.servlet.GzipFilter$GzipStream.checkOut(GzipFilter.java:531)
    at org.mortbay.servlet.GzipFilter$GzipStream.write(GzipFilter.java:465)
    at com.evermind[Oracle Containers for J2EE 10g (10.1.3.3.0) ].server.http.EvermindJSPWriter.writeOut(EvermindJSPWriter.java:539)
    at com.evermind[Oracle Containers for J2EE 10g (10.1.3.3.0) ].server.http.EvermindJSPWriter.jspflush(EvermindJSPWriter.java:436)
    at com.evermind[Oracle Containers for J2EE 10g (10.1.3.3.0) ].server.http.EvermindJSPWriter.assureSpace(EvermindJSPWriter.java:922)
    at com.evermind[Oracle Containers for J2EE 10g (10.1.3.3.0) ].server.http.EvermindJSPWriter.javaCharsToAL32UTF8(EvermindJSPWriter.java:1058)
    at com.evermind[Oracle Containers for J2EE 10g (10.1.3.3.0) ].server.http.EvermindJSPWriter.print(EvermindJSPWriter.java:849)
    at org.apache.taglibs.standard.tag.common.fmt.MessageSupport.doEndTag(Unknown Source)
    at public.login._jspService(_login.java:1817)
    at com.orionserver[Oracle Containers for J2EE 10g (10.1.3.3.0) ].http.OrionHttpJspPage.service(OrionHttpJspPage.java:59)
    at oracle.jsp.runtimev2.JspPageTable.service(JspPageTable.java:462)
    at oracle.jsp.runtimev2.JspServlet.internalService(JspServlet.java:594)
    at oracle.jsp.runtimev2.JspServlet.service(JspServlet.java:518)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:856)
    at com.zimbra.webClient.servlet.JspServlet.service(JspServlet.java:38)
    at com.evermind[Oracle Containers for J2EE 10g (10.1.3.3.0) ].server.http.ResourceFilterChain.doFilter(ResourceFilterChain.java:65)
    at com.zimbra.webClient.filters.SetHeaderFilter.doFilter(SetHeaderFilter.java:264)
    at com.evermind[Oracle Containers for J2EE 10g (10.1.3.3.0) ].server.http.EvermindFilterChain.doFilter(EvermindFilterChain.java:15)
    at org.mortbay.servlet.UserAgentFilter.doFilter(UserAgentFilter.java:81)
    at org.mortbay.servlet.GzipFilter.doFilter(GzipFilter.java:132)
    at com.evermind[Oracle Containers for J2EE 10g (10.1.3.3.0) ].server.http.EvermindFilterChain.doFilter(EvermindFilterChain.java:17)
    at oracle.security.jazn.oc4j.JAZNFilter$1.run(JAZNFilter.java:396)
    at java.security.AccessController.doPrivileged(Native Method)
    at javax.security.auth.Subject.doAs(Subject.java:396)
    at oracle.security.jazn.oc4j.JAZNFilter.doFilter(JAZNFilter.java:415)
    at com.evermind[Oracle Containers for J2EE 10g (10.1.3.3.0) ].server.http.ServletRequestDispatcher.invoke(ServletRequestDispatcher.java:621)
    at com.evermind[Oracle Containers for J2EE 10g (10.1.3.3.0) ].server.http.ServletRequestDispatcher.forwardInternal(ServletRequestDispatcher.java:370)
    at com.evermind[Oracle Containers for J2EE 10g (10.1.3.3.0) ].server.http.HttpRequestHandler.doProcessRequest(HttpRequestHandler.java:871)
    at com.evermind[Oracle Containers for J2EE 10g (10.1.3.3.0) ].server.http.HttpRequestHandler.processRequest(HttpRequestHandler.java:453)
    at com.evermind[Oracle Containers for J2EE 10g (10.1.3.3.0) ].server.http.AJPRequestHandler.run(AJPRequestHandler.java:302)
    at com.evermind[Oracle Containers for J2EE 10g (10.1.3.3.0) ].server.http.AJPRequestHandler.run(AJPRequestHandler.java:190)
    at oracle.oc4j.network.ServerSocketReadHandler$SafeRunnable.run(ServerSocketReadHandler.java:260)
    at com.evermind[Oracle Containers for J2EE 10g (10.1.3.3.0) ].util.ReleasableResourcePooledExecutor$MyWorker.run(ReleasableResourcePooledExecutor.java:303)
    at java.lang.Thread.run(Thread.java:595)

    I am having the same issue has anyone found a solution to this I have deployed a WAR file to the server an I am getting this error when I try to run the application. I would appreciate some input as this is a PRODUCITON issue
    the following statement is where this problems
    ps = conn1.prepareStatement("<string variable>");
    09/12/14 13:42:07 sfrracl: Servlet error
    java.lang.NullPointerException
    at sfrracl.SfrraclUpd.doPost(SfrraclUpd.java:269)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:760)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
    at com.evermind[Oracle Application Server Containers for J2EE 10g (10.1.2.3.0)].server.http.ServletRequestDispatcher.invoke(ServletRequestDispatcher.java:835)
    at com.evermind[Oracle Application Server Containers for J2EE 10g (10.1.2.3.0)].server.http.ServletRequestDispatcher.forwardInternal(ServletRequestDispatcher.java:341)
    at com.evermind[Oracle Application Server Containers for J2EE 10g (10.1.2.3.0)].server.http.HttpRequestHandler.processRequest(HttpRequestHandler.java:816)
    at com.evermind[Oracle Application Server Containers for J2EE 10g (10.1.2.3.0)].server.http.AJPRequestHandler.run(AJPRequestHandler.java:231)
    at com.evermind[Oracle Application Server Containers for J2EE 10g (10.1.2.3.0)].server.http.AJPRequestHandler.run(AJPRequestHandler.java:136)
    at com.evermind[Oracle Application Server Containers for J2EE 10g (10.1.2.3.0)].util.ReleasableResourcePooledExecutor$MyWorker.run(ReleasableResourcePooledExecutor.java:192)
    at java.lang.Thread.run(Thread.java:534)
    ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

  • Security Exception while Accessing a Secure Webservice

    Hi,
    I am getting security error, when I try to ivoke a Web Service of HP Select Access. The HP Select Access is installed in different machine and its web service is running in Jetty Server. I am trying to access this service from a WebSphere application server. The exception details are below:
    Caused by: javax.net.ssl.SSLException: Unsupported record version Unknown 114.49
         at com.ibm.jsse2.a.b(Unknown Source)
         at com.ibm.jsse2.a.a(Unknown Source)
         at com.ibm.jsse2.bf.a(Unknown Source)
         at com.ibm.jsse2.bf.unwrap(Unknown Source)
         at com.ibm.ws.ssl.channel.impl.SSLUtils.handleHandshake(SSLUtils.java:630)
         at com.ibm.ws.ssl.channel.impl.SSLConnectionLink.readyOutbound(SSLConnectionLink.java:707)
         at com.ibm.ws.ssl.channel.impl.SSLConnectionLink.connect(SSLConnectionLink.java:877)
         at com.ibm.wsspi.channel.base.OutboundProtocolLink.connect(OutboundProtocolLink.java:73)
         at com.ibm.ws.http.channel.outbound.impl.HttpOutboundLink.connect(HttpOutboundLink.java:305)
         at com.ibm.ws.channel.framework.impl.OutboundVirtualConnectionImpl.connect(OutboundVirtualConnectionImpl.java:74)
         at com.ibm.ws.webservices.engine.transport.http.HttpOutboundChannelConnection.connect(HttpOutboundChannelConnection.java:1081)
         at com.ibm.ws.webservices.engine.transport.http.HttpsOutboundChannelConnection.connect(HttpsOutboundChannelConnection.java:166)
         at com.ibm.ws.webservices.engine.transport.channel.OutboundConnectionGroup.createConnection(OutboundConnectionGroup.java:122)
         at com.ibm.ws.webservices.engine.transport.channel.OutboundConnectionCache.findGroupAndGetConnection(OutboundConnectionCache.java:414)
         at com.ibm.ws.webservices.engine.transport.http.HTTPSender.invoke(HTTPSender.java:318)
         at com.ibm.ws.webservices.engine.PivotHandlerWrapper.invoke(PivotHandlerWrapper.java:218)
         at com.ibm.ws.webservices.engine.PivotHandlerWrapper.invoke(PivotHandlerWrapper.java:218)
         at com.ibm.ws.webservices.engine.WebServicesEngine.invoke(WebServicesEngine.java:274)
         at com.ibm.ws.webservices.engine.client.Connection.invokeEngine(Connection.java:727)
         at com.ibm.ws.webservices.engine.client.Connection.invoke(Connection.java:648)
         at com.ibm.ws.webservices.engine.client.Connection.invoke(Connection.java:609)
         at com.ibm.ws.webservices.engine.client.Connection.invoke(Connection.java:446)
         at com.ibm.ws.webservices.engine.client.Stub$Invoke.invoke(Stub.java:732)
         at com.hp.openview.WsadminSoapBindingStub.refreshValidators(WsadminSoapBindingStub.java:649)
         at com.hp.openview.WsadminProxy.refreshValidators(WsadminProxy.java:94)
         at com.ibm._jsp._Result._jspService(_Result.java:489)
         at com.ibm.ws.jsp.runtime.HttpJspBase.service(HttpJspBase.java:88)
         at javax.servlet.http.HttpServlet.service(HttpServlet.java:856)
         at com.ibm.ws.webcontainer.servlet.ServletWrapper.service(ServletWrapper.java:1212)
         at com.ibm.ws.webcontainer.servlet.ServletWrapper.handleRequest(ServletWrapper.java:629)
         at com.ibm.wsspi.webcontainer.servlet.GenericServletWrapper.handleRequest(GenericServletWrapper.java:117)
         at com.ibm.ws.jsp.webcontainerext.JSPExtensionServletWrapper.handleRequest(JSPExtensionServletWrapper.java:171)
         at com.ibm.ws.webcontainer.webapp.WebApp.handleRequest(WebApp.java:2837)
         at com.ibm.ws.webcontainer.webapp.WebGroup.handleRequest(WebGroup.java:220)
         at com.ibm.ws.webcontainer.VirtualHost.handleRequest(VirtualHost.java:204)
         at com.ibm.ws.webcontainer.WebContainer.handleRequest(WebContainer.java:1681)
         at com.ibm.ws.webcontainer.channel.WCChannelLink.ready(WCChannelLink.java:77)
         at com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.handleDiscrimination(HttpInboundLink.java:421)
         at com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.handleNewInformation(HttpInboundLink.java:367)
         at com.ibm.ws.http.channel.inbound.impl.HttpICLReadCallback.complete(HttpICLReadCallback.java:94)
         at com.ibm.ws.tcp.channel.impl.WorkQueueManager.requestComplete(WorkQueueManager.java:548)
         at com.ibm.ws.tcp.channel.impl.WorkQueueManager.attemptIO(WorkQueueManager.java:601)
         at com.ibm.ws.tcp.channel.impl.WorkQueueManager.workerRun(WorkQueueManager.java:934)
         at com.ibm.ws.tcp.channel.impl.WorkQueueManager$Worker.run(WorkQueueManager.java:1021)
         at com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.java:1332)Please help me to solve this problem.
    Thanks,
    Francis

    Caused by: javax.net.ssl.SSLException: Unsupported record version Unknown 114.49
    +     at com.ibm.jsse2.a.b(Unknown Source)+
    it's an old post but,..you are running IBM code with the IBMJSSE2 provider and you should check IBM JSSE doc and forums :
    http://www.ibm.com/developerworks/forums/forum.jspa?forumID=178
    There, you will see that IBM has a lightly different idea of JSSE and the error codes are also different.
    Your error is related to handshake, and usually happens when talking with the wrong protocol version (SSLv3 or TLS with a server only talking SSLv2). IBMJSSE2 only implements SSLv3 and TLS.
    NephYliM.

  • Security Exception while accessing Administration Portal Page

    Hi all
    I am getting following exception while trying to access the login page of WebLogic Administration Portal. Please help me out
    Error 500--Internal Server Error
    java.security.AccessControlException: access denied (java.io.FilePermission C:\bea\weblogic81\samples\domains\portal\portalServer\.wlnotdelete\EJBCompilerCache\-w3xmqrhp3amn\com\bea\p13n\usermgmt\profile\ProfileFactory.class read)
         at java.security.AccessControlContext.checkPermission(AccessControlContext.java:269)
         at java.security.AccessController.checkPermission(AccessController.java:401)
         at java.lang.SecurityManager.checkPermission(SecurityManager.java:524)
         at java.lang.SecurityManager.checkRead(SecurityManager.java:863)
         at java.io.File.exists(File.java:678)
         at weblogic.utils.classloaders.ClasspathClassFinder.getSourcesInternal(ClasspathClassFinder.java:311)
         at weblogic.utils.classloaders.ClasspathClassFinder.getSource(ClasspathClassFinder.java:266)
         at weblogic.utils.classloaders.MultiClassFinder.getSource(MultiClassFinder.java:80)
         at weblogic.utils.classloaders.MultiClassFinder.getSource(MultiClassFinder.java:69)
         at weblogic.utils.classloaders.CodeGenClassFinder.getSource(CodeGenClassFinder.java:30)
         at weblogic.utils.classloaders.MultiClassFinder.getClassSource(MultiClassFinder.java:61)
         at weblogic.utils.classloaders.CodeGenClassFinder.getClassSource(CodeGenClassFinder.java:24)
         at weblogic.utils.classloaders.GenericClassLoader.findLocalClass(GenericClassLoader.java:383)
         at weblogic.utils.classloaders.GenericClassLoader.findClass(GenericClassLoader.java:182)
         at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
         at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
         at weblogic.utils.classloaders.GenericClassLoader.loadClass(GenericClassLoader.java:224)
         at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:302)
         at com.bea.p13n.servlets.PortalServletFilter.doFilter(PortalServletFilter.java:266)
         at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:27)
         at weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.run(WebAppServletContext.java:6724)
         at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)
         at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:121)
         at weblogic.servlet.internal.WebAppServletContext.invokeServlet(WebAppServletContext.java:3764)
         at weblogic.servlet.internal.ServletRequestImpl.execute(ServletRequestImpl.java:2644)
         at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:219)
         at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:178)
    Thanks

    Well, have you tried the obvious to add the following permission to your web server's policy file?
    grant "file:<wherever my servlet resides>\myservlet.jar" {
    permission java.io.FilePermission "c:\j2sdk1.4.1\jre\lib\javax.comm.properties", "write,delete";
    }

  • SAPGUI Failed error while accessing CAD Desktop from UnigraphicsApplication

    Hello,
    Experiencing errors while accessing the CAD Desktop from the Unigragraphics application. Log throws "RFC_ERROR_LOGON_FAILURE" error.
    Error details are as given below:
    PLM++
              E02225 The following error occured in the XML Handler: Start 'sapgui' failed..
                        plm.sess.Process_XMLFunctionHandler.executeProcess(Process_XMLFunctionHandler.java:794)
                        plm.sess.Process_XMLFunctionHandler.execute(Process_XMLFunctionHandler.java:500)
                        plm.sess.PlmCommHandler.fileOccured(PlmCommHandler.java:927)
                        plm.sess.PlmCommHandler.access$100(PlmCommHandler.java:236)
                        plm.sess.PlmCommHandler$FileWatcherTask.run(PlmCommHandler.java:1027)
                        java.util.TimerThread.mainLoop(Timer.java:432)
                        java.util.TimerThread.run(Timer.java:382)
                             com.sap.mw.jco.JCO$Exception
                                  com.sap.mw.jco.rfc.MiddlewareRFC$Client.nativeConnect(Native Method)
                                  com.sap.mw.jco.rfc.MiddlewareRFC$Client.connect(MiddlewareRFC.java:1098)
                                  com.sap.mw.jco.JCO$Client.connect(JCO.java:2986)
                                  cadagent.sap.conn.jco.tm.Transaction.sapLogon(Transaction.java:561)
                                  cadagent.sap.conn.jco.tm.Transaction.init(Transaction.java:380)
    I would appreciate your answer to resolve this issue.
    Thanks
    Chandra

    hi chandra ,
    In the Unigragraphics application screen in the from popwindo goto
    sap ---> option ---> configuration and check
    then u see the screen that content folders then select --> local configuration inthat
    select --> logon  and check the settings
    if all setting r ok then goto sm59 and check RFC coneection or ask basis team for check RFC coneection
    thanx
    sunil jawalkar

  • Cannot access forwarded ports from the internet

    Hi all,
    I have a Cisco 800 Series router that i configured to do some port forwarding. However i must have done something wrong, because i am unable to access the ports .
    Here is the configuration file of the router.
    Sorry it i pasted too much info, i'm new working with Cisco routers
    Building configuration...
    Current configuration : 9429 bytes
    ! Last configuration change at 13:39:12 PCTime Thu Jan 5 2006 by xxx
    ! NVRAM config last updated at 19:45:42 PCTime Mon Jan 2 2006 by xxx
    version 15.0
    no service pad
    service tcp-keepalives-in
    service tcp-keepalives-out
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime msec localtime show-timezone
    service password-encryption
    service sequence-numbers
    hostname pbr.mtn.w
    boot-start-marker
    boot system tftp c860-universalk9-mz.153-3.M.bin 255.255.255.255
    boot-end-marker
    logging buffered 51200
    logging console critical
    enable secret 5 xxx
    no aaa new-model
    memory-size iomem 10
    clock timezone PCTime 2
    crypto pki trustpoint TP-self-signed-2673109117
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-2673109117
    revocation-check none
    rsakeypair TP-self-signed-2673109117
    crypto pki certificate chain TP-self-signed-2673109117
    certificate self-signed 01
      30820250 308201B9 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
      31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
      69666963 6174652D 32363733 31303931 3137301E 170D3036 30313032 31373232
      35395A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
      4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 36373331
      30393131 3730819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
      8100CD17 E55A2286 3F4D2F14 98499254 8DE9B540 7413A05A C229BD7E 72C6E7AA
      7BD657C2 D824C6E4 0C0FD8AB 5EF6871B A28F298C 391DA225 FA4C92D7 5E3C6B06
      B3447494 EA058319 72A69FEA 305751EE B7D7087A 406216C3 6CC14AB8 056B52F4
      117366AD 531E0515 6801228D 7DAA8454 A00A880D 4023B8B3 983DE19C FB00F077
      32450203 010001A3 78307630 0F060355 1D130101 FF040530 030101FF 30230603
      551D1104 1C301A82 18706272 2E6D746E 2E772E79 6F757264 6F6D6169 6E2E636F
      6D301F06 03551D23 04183016 80148E65 3A8C9B6B E552653E EA96DCD1 F13DD1F1
      8198301D 0603551D 0E041604 148E653A 8C9B6BE5 52653EEA 96DCD1F1 3DD1F181
      98300D06 092A8648 86F70D01 01040500 03818100 B6F568EE 3AFBBF7A B4DEC150
      B6B8860B D953E444 8925C26C 4186AED4 8EAF9F2F D2F335E4 916F941C 1E831EEE
      77C5A9A2 EB7EB7AA 540FF094 8FA28668 91C39BB2 2852DEB9 414DD37B EE984C20
      CE755A14 37C41233 B0B93B55 52E15783 089B59AA AAE54620 352D3820 59DD24A3
      F1E3EC91 CCDE72AA 7544C9C6 1C12EDAF 95767D97
          quit
    no ip source-route
    ip dhcp excluded-address 10.10.10.1
    ip dhcp excluded-address 192.168.1.1 192.168.1.219
    ip dhcp excluded-address 192.168.1.241 192.168.1.254
    ip dhcp excluded-address 10.10.10.21 10.10.10.254
    ip dhcp pool ccp-pool1
       import all
       network 10.10.10.0 255.255.255.0
       default-router 10.10.10.1
    ip dhcp pool GuestPool
       import all
       network 192.168.1.0 255.255.255.0
       default-router 192.168.1.80
       dns-server 217.14.128.50 212.99.2.8 212.108.200.77 212.82.225.7
       lease 7
    ip cef
    no ip bootp server
    ip domain name yourdomain.com
    ip name-server 196.44.250.214
    ip name-server 196.44.250.215
    ip name-server 41.223.226.30
    ip name-server 212.118.241.1
    ip name-server 213.157.176.2
    ip name-server 62.128.175.14
    license udi pid CISCO861W-GN-E-K9 sn FCZ161392V5
    username xxx privilege 15 secret 5 xxx
    ip tcp synwait-time 10
    ip ssh time-out 60
    ip ssh version 2
    class-map type inspect match-any ccp-cls-insp-traffic
    match protocol cuseeme
    match protocol dns
    match protocol ftp
    match protocol h323
    match protocol https
    match protocol icmp
    match protocol imap
    match protocol pop3
    match protocol shell
    match protocol realmedia
    match protocol rtsp
    match protocol smtp
    match protocol sql-net
    match protocol streamworks
    match protocol tftp
    match protocol vdolive
    match protocol tcp
    match protocol udp
    class-map type inspect match-all ccp-insp-traffic
    match class-map ccp-cls-insp-traffic
    class-map type inspect match-any ccp-cls-icmp-access
    match protocol icmp
    match protocol tcp
    match protocol udp
    class-map type inspect match-all ccp-invalid-src
    match access-group 100
    class-map type inspect match-all ccp-icmp-access
    match class-map ccp-cls-icmp-access
    class-map type inspect match-all ccp-protocol-http
    match protocol http
    policy-map type inspect ccp-permit-icmpreply
    class type inspect ccp-icmp-access
      inspect
    class class-default
      drop
    policy-map type inspect ccp-inspect
    class type inspect ccp-invalid-src
      drop log
    class type inspect ccp-protocol-http
      inspect
    class type inspect ccp-insp-traffic
      inspect
    class class-default
      drop
    policy-map type inspect ccp-permit
    class class-default
      drop
    zone security out-zone
    zone security in-zone
    zone-pair security ccp-zp-self-out source self destination out-zone
    service-policy type inspect ccp-permit-icmpreply
    zone-pair security ccp-zp-in-out source in-zone destination out-zone
    service-policy type inspect ccp-inspect
    zone-pair security ccp-zp-out-self source out-zone destination self
    service-policy type inspect ccp-permit
    interface Null0
    no ip unreachables
    interface FastEthernet0
    interface FastEthernet1
    interface FastEthernet2
    interface FastEthernet3
    interface FastEthernet4
    description $ES_WAN$$FW_OUTSIDE$
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    duplex auto
    speed auto
    pppoe-client dial-pool-number 1
    interface wlan-ap0
    description Service module interface to manage the embedded AP
    ip unnumbered Vlan1
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nbar protocol-discovery
    ip flow ingress
    ip flow egress
    arp timeout 0
    interface Wlan-GigabitEthernet0
    description Internal switch interface connecting to the embedded AP
    switchport mode trunk
    interface Vlan1
    description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$ES_LAN$$FW_INSIDE$
    ip address 192.168.1.80 255.255.255.0
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nbar protocol-discovery
    ip flow ingress
    ip flow egress
    ip nat inside
    ip virtual-reassembly
    zone-member security in-zone
    ip tcp adjust-mss 1412
    interface Dialer0
    description $FW_OUTSIDE$
    ip address negotiated
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip mtu 1452
    ip flow ingress
    ip nat outside
    ip virtual-reassembly
    zone-member security out-zone
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication chap pap callin
    ppp chap hostname xxx
    ppp chap password 7 xxx
    ppp pap sent-username xxx password 7 xxx
    no cdp enable
    ip forward-protocol nd
    ip http server
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    ip flow-top-talkers
    top 20
    sort-by bytes
    cache-timeout 20
    ip nat inside source list 1 interface Dialer0 overload
    ip nat inside source static tcp 192.168.1.25 8890 interface Dialer0 8890
    ip nat inside source static tcp 192.168.1.25 80 interface Dialer0 80
    ip nat inside source static tcp 192.168.1.45 21 41.186.26.35 21 extendable
    ip route 0.0.0.0 0.0.0.0 Dialer0
    logging trap debugging
    access-list 1 remark INSIDE_IF=Vlan1
    access-list 1 remark CCP_ACL Category=2
    access-list 1 permit 192.168.1.0 0.0.0.255
    access-list 100 remark CCP_ACL Category=128
    access-list 100 permit ip host 255.255.255.255 any
    access-list 100 permit ip 127.0.0.0 0.255.255.255 any
    dialer-list 1 protocol ip permit
    no cdp run
    control-plane
    banner exec ^C
    % Password expiration warning.
    Cisco Configuration Professional (Cisco CP) is installed on this device
    and it provides the default username "cisco" for  one-time use. If you have
    already used the username "cisco" to login to the router and your IOS image
    supports the "one-time" user option, then this username has already expired.
    You will not be able to login to the router with this username after you exit
    this session.
    It is strongly suggested that you create a new username with a privilege level
    of 15 using the following command.
    username <myuser> privilege 15 secret 0 <mypassword>
    Replace <myuser> and <mypassword> with the username and password you
    want to use.
    ^C
    banner login ^C---------------------------------------------------------------------------
                                  NOTICE TO USERS
    THIS IS A PRIVATE COMPUTER SYSTEM.  Unauthorized or improper use of this
    system may result in administrative or disciplinary action and civil and
    criminal penalties.
    Any or all uses of this system and all files on this system are monitored,
    and recorded.
    This system is the property of xxx .
    Disconnect IMMEDIATELY if you are not an authorized user!
    ^C
    line con 0
    login local
    no modem enable
    transport output telnet
    line aux 0
    login local
    transport output telnet
    line 2
    no activation-character
    no exec
    transport preferred none
    transport input all
    line vty 0 4
    privilege level 15
    login local
    transport preferred telnet
    transport input telnet
    scheduler max-task-time 5000
    scheduler allocate 4000 1000
    scheduler interval 500
    end

    You need...
    Either a Fixed IP from your ISP, or a service like no-ip.org to look up your current IP.
    How to find the "Outside" IP on that machine go here...
    http://www.whatsmyip.org/
    If there's a Router involved at home then incoming ports must be directed to the proper local IP.
    Setup Sharing on the home Mac.

Maybe you are looking for