External Webserver to access CallManager

Hi,
i've heard that the Tomcat server installaed on on CUCM should not be touched to develop Webservices. So, i would take an external WebServer and buildt on that. Question:
What are the different access methods i hae?
There are the XML Objects available on IP Phones, then there is the AXL browser and there is the SDK. What shall be used for what?
May be some links to documents would be great,
Kind regards, Patrick

This (http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/devguide/6_0_1/cucm_devguide.html) lists all XML interfaces you have on Callmanager and what they do (all are XML/SOAP based webservices so you connect to the callmanager using http(s))
Then you have the CTI interfaces TAPI and JTAPI and connect to the CCM using the dedicated TCP port(s) for the protocol (see the guides http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/jtapi_dev/6_0_1/jtapi-dev.html and http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/tapi_dev/6_0_1/tapidev.html)
Finally you have applications that run on the phone (more here http://www.cisco.com/en/US/docs/voice_ip_comm/cuipph/all_models/xsi/6_0/english/programming/guide/XSIbook.html)
which can make use of the abovementioned technologies if necessary, or which can be completely separate and offer some kind of interaction with the user on the phone (whereas the other APIs are basially independent.. although you could put some information on the screen using a CTI API. Those have nothing to do with the callmanager except that you define an url to a webpage (which then returns XML that the phones understand, rather than html) on the callmanager so the phone knows what to list if you press the services button, and where to make a request when you select a service.
If you need to know more, I suggest you read through the documents I linked to.
And if you have an older Callmanager version and want to use an XML API or (J)TAPI here's the page with guides for all versions:
http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_programming_reference_guides_list.html

Similar Messages

  • HTTPS connection from portal to external webserver

    Hi,
    I am looking for a way to open a HTTPS connection from portal server to an external webserver. According to <a href="http://help.sap.com/saphelp_nw04/helpdata/en/e2/71c83edf72e16be10000000a114084/content.htm">SAP</a> the code should look like
    KeyStore keystoreCAs = ...
    SecureConnectionFactory factory = new SecureConnectionFactory(keystoreCAs, null);
    HttpURLConnection con = factory.createURLConnection("https://www.mycompany.com");
    Does not look difficult, <b>but how do I create the keystore object</b>? The keystore object should somehow be connected to the portal server's keystore which manages the certificates of trusted Certificate Authorities.
    Any ideas?
    Regards,
    Martin

    Hi,
    meanwhile I solved the problem by my own. The solution slightly simplified is given below.
    javax.naming.InitialContext ctx = new javax.naming.InitialContext();
    java.lang.Object o = ctx.lookup("keystore");          
    com.sap.engine.services.keystore.interfaces.KeystoreManagerWrapper_Stub manager = (com.sap.engine.services.keystore.interfaces.KeystoreManagerWrapper_Stub) o;
    java.security.KeyStore keystoreCAs = manager.getKeystore("TrustedCAs");     
    com.sap.security.core.server.https.SecureConnectionFactory factory = new SecureConnectionFactory(keystoreCAs, null);
    java.net.HttpURLConnection con = factory.createURLConnection("https://www.mycompany.com");
    For connecting via a proxy the host name and port number of the proxy have to be set as System properties using "https.proxyHost" and "https.proxyPort".
    java.util.Properties systemSettings = System.getProperties();
              systemSettings.put("proxySet", "true");
              systemSettings.put("https.proxyHost","192.168.0.1") ;
              systemSettings.put("https.proxyPort", "80") ;
    Additionally you have to make sure that the server's certificate is issued by a trusted Certification Authority (Must have an entry in your Keystore "TrustedCAs"). To verify this use the Visual Administrator and view service "Key Storage".
    Regards,
    Martin

  • Allow external traffic to access internal computers

    We have an ASA 5505 running version 8.4. We are having problems allowing external traffic to access computers behind the firewall. Our current config is:
    ASA Version 8.4(3)
    hostname ciscoasa
    domain-name default.domain.invalid
    names
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
    nameif inside
    security-level 100
    ip address 10.2.1.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address 152.18.75.132 255.255.255.240
    boot system disk0:/asa843-k8.bin
    ftp mode passive
    dns server-group DefaultDNS
    domain-name default.domain.invalid
    object network a-152.18.75.133
    host 152.18.75.133
    object network a-10.2.1.2
    host 10.2.1.2
    object-group network ext-servers
    network-object host 142.21.53.249
    network-object host 142.21.53.251
    network-object host 142.21.53.195
    object-group network ecomm_servers
    network-object 142.21.53.236 255.255.255.255
    object-group network internal_subnet
    network-object 10.2.1.0 255.255.255.0
    access-list extended extended permit ip any any
    access-list extended extended permit icmp any any
    access-list extended extended permit ip any object-group ext-servers
    access-list acl_out extended permit tcp any object-group ecomm_servers eq https
    access-list outside_in extended permit ip any host 10.2.1.2
    pager lines 24
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    icmp unreachable rate-limit 1 burst-size 1
    icmp permit any echo-reply inside
    icmp permit 10.2.1.0 255.255.255.0 inside
    icmp permit any echo-reply outside
    icmp permit any outside
    asdm image disk0:/asdm-523.bin
    no asdm history enable
    arp timeout 14400
    nat (inside,outside) source static a-10.2.1.2 a-152.18.75.133
    route outside 0.0.0.0 0.0.0.0 152.18.75.129 1
    timeout xlate 3:00:00
    timeout pat-xlate 0:00:30
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    user-identity default-domain LOCAL
    http server enable
    http 10.2.1.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    telnet timeout 5
    ssh 10.2.1.2 255.255.255.255 inside
    ssh 122.31.53.0 255.255.255.0 outside
    ssh 122.28.75.128 255.255.255.240 outside
    ssh timeout 30
    console timeout 0
    dhcpd auto_config outside
    dhcpd address 10.2.1.2-10.2.1.254 inside
    dhcpd enable inside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
      inspect icmp
      inspect ip-options
    service-policy global_policy global
    prompt hostname context
    no call-home reporting anonymous
    call-home
    profile CiscoTAC-1
      no active
      destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
      destination address email [email protected]
      destination transport-method http
      subscribe-to-alert-group diagnostic
      subscribe-to-alert-group environment
      subscribe-to-alert-group inventory periodic monthly
      subscribe-to-alert-group configuration periodic monthly
      subscribe-to-alert-group telemetry periodic daily
    Cryptochecksum:c7d7009a051cb0647b402f4acb9a3915
    : end
    ciscoasa(config)# sh nat
    Manual NAT Policies (Section 1)
    1 (inside) to (outside) source static a-10.2.1.2 a-152.18.75.133
        translate_hits = 1, untranslate_hits = 112
    ciscoasa(config)# sh nat
    Manual NAT Policies (Section 1)
    1 (inside) to (outside) source static a-10.2.1.2 a-152.18.75.133
        translate_hits = 1, untranslate_hits = 113
    ciscoasa(config)#

    Okay I will bite.
    Assuming you have
    a.  dynamic pat rule for lan users-devices to reach the internet
    (missing ???????????????
    (should look like a nat rule that makes two entries when you make the one rule)
    (with router set at defaults it may make this rule for you already in place)
    -object bit  
    object network obj_any_inside
    subnet 0.0.0.0 0.0.0.0
    and rule bit
    object network obj_any_inside
    nat (inside,outside) dynamic interface
    b.  route rule - tells asa next hop is IP gateway address
    route outside 0.0.0.0 0.0.0.0 152.18.75.129 1
    c.  Nat rule for port forwarding- Using objects it creates two entries (lets say i call it natforward4server)
    object bit
    object network natforward4server
    host 10.2.1.2
    Nat bit
    object network natforward4server
    nat (inside,outside) static interface service tcp 443 443
    d. Nat for translated ort.
    If you had wanted to translate a port, lets say you have external users that can only use port 80 but need to access https
    object bitobject network natfortransl4server
    host 10.2.1.2
    Nat bit
    object network natfortransl4server
    nat (inside,outside) static interface service tcp 443 80

  • Using AirPort Time Capsule as an external drive with access to files by guest account

    Is it possible to use my AirPort Time Capsule as an external drive with access to files by a guest account?
    I would like to store a large number of folders containg photographs on my AirPort Time Capsule and allow anyone with a password to access the photographs - at the time of viewing the Time Capsule would be connected to the internet but I wouldn't want users to actually access anything other than the files on the Time Capsule - is this possible?  if so any help in configuring it would be really helpful.

    No it is not possible.. Guest is just that.. a guest that is allowed permission to access the internet but none of the local files.
    To give a person access to the TC they must have password to access your normal network..
    From there it is up to you how you do this.. people cannot actually access files on your computers unless you give them share and password permissions for that.. you can even setup accounts on the TC although I recommend against it.. if you want shared photos anyway. All security on a TC is illusion.. merely pressing the reset and it is all blown away.. so if you are concerned about security don't put stuff on the TC people should not access.. or like your TM backups ensure they are encrypted.
    A person can then access you TC and the photos.. but what else on the network??

  • I use Djay for my Apple and I would like to use TC as an external hd to access from Djay, however when I look for my external T1 drive I cannot find it in iTunes so I can load onto Djay? Any help?

    I use Djay for my Apple and I would like to use TC as an external hd to access from Djay, however when I look for my external T1 drive I cannot find it in iTunes so I can load onto Djay? Any help?

    Initially, you asked if you can hardwire your MBA to the TC. The answer is yes, by using the optional USB Ethernet adapter that Apple provides. However, in order for your MBA to access the TC's internal or USB-attached HDD, it would need to establish a network connection to it. This would be true of any NAS device on an Ethernet network. Therein, lies the problem. Your MBA cannot connect to two networks simultaneously.
    One option then, would be to have two separate iTunes Media folders; one on the MBA & the other on the TC. This way, you can download the music to your MBA when connected to the Internet at the AirPort lounge, and then use iTunes Consolidate Library feature to transfer the audio files to the TC's iTunes Media Folder location. A great program to help maintain multiple iTunes Librarys and/or Media Folders, that you may want to consider, is PowerTunes.

  • I have files on my external harddisk and access is denied because 'I am not authorized?

    I have files on my external harddisk and access is denied because 'I am not authorized?

    Itunes copy protected files? Login into your Intunes account to access Itunes media that is tied to the account that purchased those audio or video files.

  • Can't set up an iPhoto library on external hard drive: access privileges

    Hi all
    I am trying to set up an extra iPhoto library on an external hard-drive to store some of my photos.
    I get the following message: 'iPhoto cannot create a new library in this location because you do not have enough access privileges.'
    The external hard drive is Formatted: Mac OS Extended (Journaled), is 500g capacity and is empty. Also 'Ignore ownership on this volume' is ticked.
    I am the administrator of this computer (imac) which is running Yosemite 10.10.1
    Any clues as to what I need to do to make this happen? I'm not much of a techie!
    Cheers
    Finella

    Once you've confirmed that the EHD is formatted correctly and all is well (run Disk Utility and repair the disk) try the following to create an almost "duplicate"  library on the EHD:
    Using iPhoto Library Manager  to Rebuild Your iPhoto Library
    1 - download iPhoto Library Manager and launch.>Click on the Add Library button,
    2 -  select the library you want to add from those in the selection window.
    3 - make sure that in the rebuild window the checkbox  "Scavange orphaned photos" is checked.
    4 - now that the library is listed in the left hand pane of iPLM, click on your library and go to the Library ➙ Rebuild Library menu option
    5 - in the next  window name the new library and select the EHD as the location where you want it to be placed. Click on the Create button.
    Note 1: This creates a new library based on the LIbraryData.xml file in the library and will recover Events, Albums, keywords, titles and comments. However, books, calendars, cards and slideshows will be lost.
    Note 2:  Your current library will be left untouched for further attempts at a fix if so desired.

  • Configure a sharepoint 2013 site for external and internal access

    I need to configure a local install of sharepoint 2013 so that users can access it internally and externally using windows/AD authentication. The internal and external addresses are different.
    I have bound an external ip to the domain for external access.
    I have created Alternate Access mapping, and bound the host header but I get a file not found message for external access.
    Have I missed something here? why the error and how can it be fixed. Step by step process would be appreciated.

    Hi Luis,
    According to your description, my understanding is that the error occurred when accessing the site externally.
    The most common cause for this is that the IIS host header is configured incorrectly. The 404 will appear because we are hitting a different IIS web site and not the one we are intended to.
    Here is a similar issue for you to take a look:
    http://stackoverflow.com/questions/14953322/sharepoint-2013-404-not-found-while-accessing-site-collection-from-outside
    More references:
    http://technet.microsoft.com/en-us/library/cc261814(v=office.15).aspx
    http://technet.microsoft.com/en-us/library/cc263208(v=office.15).aspx
    Best regards.
    Thanks
    Victoria Xia
    TechNet Community Support

  • External TimeCapsule Disk Access

    Hello.
    For a while now I have been trying to use Apple Script to connect to my built in Time Capsule Disk.
    I have set up a domain through DynDNS which forwards to my public IP address.
    I used the AppleScript:
    +mount volume ¬+
    +"afp://MY-DOMAIN.KICKS-***.NET" as user name "My Name" with password "DiskPassw0rd"+
    I didn't ever manage to test it as where I work they have blocked the domain range.
    However, when I run this script internally on my home network, the AppleScript "Result" is:
    +file "MAC-BACKUP:"+ which is the name of my disk.
    So all looks well, (presuming that is the correct response from AppleScript.) However, yesterday I purchased an external hard disk to connect to the USB on the timecapsule.
    How do I access this externally? I presumed I just had to change the AFP address to
    "afp://MY-DOMAIN.KICKS-***.NET/Photos"
    but that doesn't work and I get a "Connection Failed" dialogue box and then a "Network Permission Error" from AppleScript.
    Any thoughts on how I get this working? It seems that the external AFP port forwards straight to the internal disk.
    Cheers
    Joe

    What you should do is to tell the two computers where your music is located. After you move the music into the external hard drive open iTunes. Go to iTunes>Preferences>Advanced. You can change the location there. Do that for both computers. Now iTunes of both computers will look for music at the new location.

  • Best practice for external but secure access to internal data?

    We need external customers/vendors/partners to access some of our company data (view/add/edit).  It’s not so easy as to segment out those databases/tables/records from other existing (and put separate database(s) in the DMZ where our server is).  Our
    current solution is to have a 1433 hole from web server into our database server.  The user credentials are not in any sort of web.config but rather compiled in our DLLs, and that SQL login has read/write access to a very limited number of databases.
    Our security group says this is still not secure, but how else are we to do it?  Even if a web service, there still has to be a hole in somewhere.  Any standard best practice for this?
    Thanks.

    Security is mainly about mitigation rather than 100% secure, "We have unknown unknowns". The component needs to talk to SQL Server. You could continue to use http to talk to SQL Server, perhaps even get SOAP Transactions working but personally
    I'd have more worries about using such a 'less trodden' path since that is exactly the areas where more security problems are discovered. I don't know about your specific design issues so there might be even more ways to mitigate the risk but in general you're
    using a DMZ as a decent way to mitigate risk. I would recommend asking your security team what they'd deem acceptable.
    http://pauliom.wordpress.com

  • External SOAP client Accessing Webservice using built in Java Data type

    We have built a webservice and deployed it on WLS. We accessed this from a swing
    client it works fine.The webservice methods uses non-built in JAVA data types
    as parameters.These are Value Objects and the JAVA Serializer and Deserializer
    classes are generated using Ant task itself.The client coding uses Value objects
    given by the Client_jar (generated using <Clientgen> ant task) to pass to the
    webservice. We dont want to go by this way.Is there anyway were in we can pass
    parameters to the method which expects non-built in java datatypes?
    Why i am asking this is, i want to know how an external client (.Net client )
    will be able to exceute my webservice (i.e., passing the required Object which
    the method is expecting)?

    Hi Anish,
    Well first off, your web service doesn't send or receive "objects". It only sends
    and recieves XML, which is in turn converted to/from Java objects at invocation
    time. Second, a .NET (or Perl, or Python, or C++) client will be able to call
    your web service, because the wsdl.exe tool (for .NET) will generate "programming
    language specific" objects from the <types><schema> elements, in the WSDL of your
    web service :-) The wsdl.exe tool will create C# objects from the WSDL, that will
    convert XML to/from C# when your web service is called. That's the beauty of XML
    schema - it's a "universal typing system", so it's not tied to a particular programming
    language. The only issue is whether or not the web services platform vendor's
    XML Schema/WSDL processor, can successfully process the WSDL. Some vendors have
    more complete implementations of the WSDL and XML Schema specs than others, so
    expect varying success here. The one in WLS 7.0 is pretty good, so you shouldn't
    have too many problems consuming WSDL generated by .NET tools (or any other tool
    for that matter).
    Regards,
    Mike Wooten
    "Anish" <[email protected]> wrote:
    >
    We have built a webservice and deployed it on WLS. We accessed this from
    a swing
    client it works fine.The webservice methods uses non-built in JAVA data
    types
    as parameters.These are Value Objects and the JAVA Serializer and Deserializer
    classes are generated using Ant task itself.The client coding uses Value
    objects
    given by the Client_jar (generated using <Clientgen> ant task) to pass
    to the
    webservice. We dont want to go by this way.Is there anyway were in we
    can pass
    parameters to the method which expects non-built in java datatypes?
    Why i am asking this is, i want to know how an external client (.Net
    client )
    will be able to exceute my webservice (i.e., passing the required Object
    which
    the method is expecting)?

  • Data sync to external SQL from Access Web App

    Hi all
    Am I dreaming or does creating a table in an Access Web app based on an external SQL Azure database table (not the intrinsic one) end up being an import not a sync?  It doesn't even seem to update when i open the external table and refresh it?
    I am adding new records at the external SQL source and they are not updating in the table in the WebApp
    Is anyone having similar problems?
    Cheers
    Sally

    Hi Sally,
    >> I am adding new records at the external SQL source and they are not updating in the table in the WebApp
    Do you mean that you import a table from an external SQL Azure database into Access Web app, the data in Access Web app did not update after you change the an external SQL Azure database data? In my option, this is expected behavior if you are using import
    table. Importing from another database would not achieve that, and it only achieves copying data from another database. I am afraid that you could not achieve your requirement from Access Web app.
    As far as I know, the database of Access web app is Azure DB, I think you could sync the Access web app Azure DB and External Azure DB, you could refer the link below for more information.
    Reference:
    http://azure.microsoft.com/en-us/documentation/articles/sql-database-get-started-sql-data-sync/
    I am not familiar with Azure DB, and if you have issues about Azure DB, I will recommend you go to the link below for help.
    Reference:
    http://social.technet.microsoft.com/Forums/en-US/home?forum=ssdsgetstarted
    Thanks for your understanding.
    Best Regards,
    Edward
    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click
    HERE to participate the survey.

  • Air 1.0, Externally Loaded SWF Accessing Camera

    Hello.
    I am building a touch screen kiosk Air App using Flash CS3 and Air 1.0.
    I have my application downloading external SWFs for different advertisements, one of which will need access to the webcam built into the kiosk.
    By itself, the advertisement accesses the camera just fine, however Camera.getCamera() returns null when it the SWF loaded into the kiosk app. Both the main kiosk app and the advertisement app are compiled using Air 1.0.
    It appears that I'm getting a security sandbox violation, however I'd like to avoid completely rewriting my app using the sandbox bridge architecture just so one of my ad pieces can access a webcam.
    Does anyone have any suggestions or know of any work-arounds for allowing webcam accesss from within an embedded SWF in Air?
    Would upgrading to CS5 / Air 2.5 help?
    Thanks for any resposes.
    -John Berman

    I was able to find a workaround of the security sandbox using Loader.loadBytes();
    Aleksandar Andreev's Loader class really helped:
    http://blog.aleksandarandreev.com/?p=42

  • External links in access

    Hi guys
    I`m trying to create a sort of social networking site and i
    want its members to be able to add an image, and to save space
    would like them to upload the image to a free image host and then
    add the link to there profile.
    I`m using access at the moment and trying to add he external
    link to the database and show it.
    Is there a way to do this?

    Hi guys
    I`m trying to create a sort of social networking site and i
    want its members to be able to add an image, and to save space
    would like them to upload the image to a free image host and then
    add the link to there profile.
    I`m using access at the moment and trying to add he external
    link to the database and show it.
    Is there a way to do this?

  • RV110W + IPv6 Webserver Inbound access

    Model : RV110W      Firmware : 1.2.0.9
    Hi!
    I'm studying the RV110W IPv6 Firewall in the context of a long IPv6 study / Blog post ( 30+ posts yet ).
    The RV110W IPv6 Firewall got me totally puzzled.
    I've remade all the tests, and this appears :
    To allow external access to an IPv6 Web Server located on the Lan side of the RV110W, it seems that :
    creating an inbound allow rule is useless and unneeded.
    creating a Single Port Forwarding rule is compulsory and sufficient.
    1. Can anybody confirm this ?
    2. Does this IPv6 Single Port Forwarding rule actually automatically creates an ' invisible ' IPv6 Firewall allow in rule ?
    3. How comes an IPv6 Firewall allow in rule is not enough ?
    4. could anybody explain me this misterious sentence, from the RV110W admin guide :
        " Port forwarding is not appropriate for servers on the LAN, since there is a dependency on the LAN device making an outgoing connection before incomming ports are opened. Some applications require ... ... "
       What is appropriate for servers on the LAN then ? Isn't LAN the place for servers ? isn't port forwarding the historical way to make Lan servers accessible to the outside world ? This sentence seems to describe Statefull Firewall functionning, so is the sentence mistyped, and actually should be ' Port Forwarding IS appropriate for servers on the LAN, since ... " ?
    Thanks for any help
    PS. I also found an IPv6 Firewall ICMPv6 quirk, that I put on another thread

    Hi computerone1, thank you for using our forum, my name is Luis I am part of the Small business Support community.
    Well as you know Port forwarding and the Access List are different, the Port forwarding forward the port and the Access list create a rule to provide access or deny it. I this case I will recommend you to use both protocols in order provide control of the access to your server.
    I hope you find this answer useful
    Greetings,
    Luis Arias.
    Cisco Network Support Engineer.

Maybe you are looking for

  • ISE, MAB issue

    I'm working with the following lab: ISE 1.1.3.124 3560 running c3560-ipservicesk9-mz.122-55.SE Cisco AP (1131, 1231). I'm attempting MAB. The AP is being profiled correctly and I'm seeing successful authen and authz. But the device (AP/whatever) cann

  • Save As windows takes a long time to come up.

    After selecting File > Save As the Save As window takes about 15 seconds to come up. This is a brand new computer and a new installation of Adobe Acrobat XI v. 11.0.6. Has anyone ran into an issue like this before?

  • Expand my Macbook hard drive using WiFI?

    My MacBook hard drive was full so I moved some photos onto an external drive.  This has created additional space but to access those photos, I now need to plug the external drive back into the MacBook and change the iphoto library.  Is there a better

  • How can I calibrate the colors in my 3g iphone

    I noticed that when I watch the videos in my iphone 3g the colors are saturaded, who knows how to calibrate the colors?

  • Impossible to see the lyrics on my iPad1. Will it be solved quickly?

    All the lyrics I need are in iTunes. I see them perfectly well on my Macintosh in iTunes and on my iPhone! Why is it now impossible to see them comfotably as before on the iPad? It was much nicer to work with it but it is now impossible. Who found a