Help needed in funciton module

can any one please tell how this fm can be used in the pgm
input/opt fileds and all
CONVERT_TO_LOCAL_CURRENCY
CONVERT_TO_FOREIGN_CURRENCY

Hi Arun,
<b>Try this code.</b>
data: IV_EXCH_RATE_DATE TYPE  CNVT_EXCH_RATE_DATE,
IV_EXCH_RATE_TYPE TYPE  CNVT_EXCH_RATE_TYPE,
IV_EXCH_RATE TYPE  CNVT_EXCH_RATE,
IV_FOREIGN_CURRENCY TYPE  CNVT_FOREIGN_CURRENCY_UNIT,
IV_LOCAL_CURRENCY TYPE  CNVT_LOCAL_CURRENCY_UNIT,
IV_AMOUNT TYPE  CNVT_CURRENCY_AMOUNT.
  perform check_convert_to_local using iv_exch_rate_date
                                       iv_exch_rate_type
                                       iv_exch_rate
                                       iv_amount
                                       iv_foreign_currency
                                       iv_local_currency.
*&      Form  check_convert_to_local
      text
form check_convert_to_local
     using uv_exch_date        type cnvt_exch_rate_date
           uv_exch_type        type cnvt_exch_rate_type
           uv_exch_rate        type cnvt_exch_rate
           uv_foreign_amount   type cnvt_foreign_currency_amount
           uv_foreign_currency type cnvt_foreign_currency_unit
           uv_local_currency   type cnvt_local_currency_unit.
variables for ABAP call
  data: lv_local_amount_abap      type cnvt_foreign_currency_amount,
        lv_local_amount_abap2(16) type p decimals 3,
        lv_local_amount_java      type cnvt_local_currency_amount.
  write: / text-101 color 7.
  write: / text-009,
           uv_foreign_amount,
           text-010,
           text-013,
           uv_foreign_currency,
           text-011,
           text-012,
           uv_local_currency.
call ABAP
  call function 'CONVERT_TO_LOCAL_CURRENCY'
    exporting
  CLIENT                  = SY-MANDT
      date                    = uv_exch_date
      foreign_amount          = uv_foreign_amount
      foreign_currency        = uv_foreign_currency
      local_currency          = uv_local_currency
      rate                    = uv_exch_rate
      type_of_rate            = uv_exch_type
  READ_TCURR              = 'X'
    importing
    exchange_rate           = lv_erate
  FOREIGN_FACTOR          =
      local_amount            = lv_local_amount_abap
  LOCAL_FACTOR            =
  EXCHANGE_RATEX          =
  FIXED_RATE              =
  DERIVED_RATE_TYPE       =
     exceptions
       no_rate_found           = 1
       overflow                = 2
       no_factors_found        = 3
       no_spread_found         = 4
       derived_2_times         = 5
       others                  = 6.
  if sy-subrc <> 0.
    message id sy-msgid type sy-msgty number sy-msgno
            with sy-msgv1 sy-msgv2 sy-msgv3 sy-msgv4
            into gv_message.
    write: / gv_message.
  endif.
  lv_local_amount_abap2 = lv_local_amount_abap. "rounding
endform.                    "check_convert_to_local
<b>Reward points if it solves ur query or answer is helpful</b>
Thanks
Chinmay

Similar Messages

  • Help needed in PS module on CJ9ECP/CJ20N for revaluating CCR??

    help needed in PS module on CJ9ECP/CJ20N for revaluating CCR??
    How to handle method on_costing_component_to_outtab which belongs to badi gui_itemization_ck. This is to revaluate CCR in CJ20N.
    From sale transaction(va01/va02) i need to call cj20n/cj9ecp for revaluating cost estimates. Can anyone say how to proceed with this thing.
    Can any one say how to handle pop up window in CJ20N/CJ9ECP when clicked edit ecp button. Later how to revaluate cost estimates. For this should i need to go for call transaction or is there any method available. If so how to handle method for revaluating cost estimates for ECP of WBS elements

    Thanks Amol for the advice.
    My friend doesn't belong to an engineering background and had not worked in a manufacturing environment.
    He holds an MBA degree specialised in systems and has worked in software companies supporting software projects and the functions(like HR,Procurement in the same setup) as a software quality guy.
    Moreover the modules mentioned by you requires engineering background with manufacturing exposure.
    He had enquired for the course at siemens and they said that he may not be suitable for any of the modules offered by them as per the above reasons.They also mentioned that they have to check with SAP Labs for expert opinion.
    Please provide your inputs.
    regards,
    Zubair.

  • Help needed for SAP modules

    Hi all
    I want to learn the SAP modules...like MM, SD, PP, FICO, SCM etc...
    where from shall i get the help?
    plz give me some references.
    Thanx in advance,
    Yours
    Ramu

    Hi Ram,
    Pl refer the following site which will give u helpful pdf files.all modules are available in this easy market place site.
    it is better to concentrate on any one module which ur background and interest supports.
    For MM:
    http://help.sap.com/printdocu/core/Print46c/en/data/pdf/PSMAT/PSMAT.pdf
    http://help.sap.com/printdocu/core/Print46c/en/data/pdf/CAARCMM/CAARCMM.pdf
    http://help.sap.com/printdocu/core/Print46c/en/data/pdf/MYSAP/SR_MM.pdf
    http://help.sap.com/printdocu/core/Print46c/en/data/pdf/MYSAP/SR_MM.pdf
    For PP:
    http://help.sap.com/printdocu/core/Print46c/en/data/pdf/MYSAP/SR_PP.pdf
    http://help.sap.com/printdocu/core/Print46c/en/data/pdf/CAARCPP/CAARCPP.pdf
    http://help.sap.com/printdocu/core/Print46c/en/data/pdf/BCBMTWFMPP/BCBMTWFMPP.pdf
    http://help.sap.com/printdocu/core/Print46c/en/data/pdf/PPBDBOM/PPBDBOM.pdf
    http://help.sap.com/printdocu/core/Print46c/en/data/pdf/PPCRP/PPCRP.pdf
    http://help.sap.com/printdocu/core/Print46c/en/data/pdf/PPPDC/PPPDC.pdf
    http://help.sap.com/printdocu/core/Print46c/en/data/pdf/PPKAB/PPKAB.pdf
    http://help.sap.com/printdocu/core/Print46c/en/data/pdf/PPPIPCS/PPPIPCS.pdf
    http://help.sap.com/printdocu/core/Print46c/en/data/pdf/PPSFC/PPSFC.pdf
    http://help.sap.com/printdocu/core/Print46c/en/data/pdf/PPBDWKC/PPBDWKC.pdf
    D.K.VIJAYABHASKAR

  • Help needed with mx Modules...

    Hello guys!
    So, here´s the deal.... i have developed  a little application using flex which works just fine. I made some  stress tests an didn´t had any kind of failure.
    Then, i  decide to modularize my application.... i created a new application  (type <mx:Application> ) and transformed the old application into a  module (<mx:Module>) . Let´s calll this ModuleOne.
    I used as a basis for the development an example that  exists at the adobe site regarding ModuleLoader. (   http://livedocs.adobe.com/flex/3/html/modular_6.html#170736   )
    So,  now i have my Application, the ModuleLoader and my Modules. I have  created another module (ModuleTwo) in order to test and make some  troubleshooting.
    And now gets tricky. When i load ModuleOne, he works  fine, no problems... just like his old application type used to work.  When i load the ModuleTwo, he wors fine also. When i try to come back to  ModuleOne, loading it once again, the problems come.
    After  this second time load of ModuleOne, he doesn´t filll the ComboBoxes  with my database data. The clock cursor keeps running, as if he is  waiting for something... on my point of view, he is waiting for the  comboboxes to get filled.
    I read on several websites  that Modules sometimes don´t get unloaded or garbage collected due to  some references problems of Flex itself. Unfortunately, i´m not any kind  of pro. I´m still learning and trying to get things done.
    If you see the ModuleLoader webpage at adobe, you´ll se the exact code that i use to load, unload and reload the Modules.
    Below, i´ll post the code.
    I thank very much anyone for any help!
    Regards,
    BlknD
    Application Code
    <?xml version="1.0"?>
    <!-- modules/General.mxml -->
    <mx:Application xmlns="*" xmlns:mx="http://www.adobe.com/2006/mxml"  width="1020" height="644" layout="absolute" backgroundColor="#ffffff"  verticalScrollPolicy="off" horizontalScrollPolicy="off">
         <mx:Script>
             <![CDATA[
                 import mx.effects.easing.*;
                 import mx.modules.*;
                 [Bindable]
                 public var selectedItem:Object;
             ]]>
         </mx:Script>
        <mx:Object id="FormObj" label="Mapa" module="Form.swf"/>
         <mx:Object id="NewObj" label="News" module="News.swf"/>
          <mx:Button id="FormButton" label="Form" click="selectedItem=FormObj"  x="12.5" y="504" width="157.5" height="90" cornerRadius="20"  mouseUpEffect="bounceEffect"/>
          <mx:Button id="NewsButton" label="News"  click="selectedItem=NewObj" x="11.25" y="210" width="157.5" height="90"  cornerRadius="20" />
          <CustomModuleLoader id="mod" width="100%" height="100%" url="{selectedItem.module}" />
    </mx:Application>
    ModuleOne code
    <mx:Module  xmlns:mx="http://www.adobe.com/2006/mxml" paddingBottom="0"  layout="absolute" backgroundColor="#ffffff" initialize="{init()}"  width="820" height="584" dropShadowEnabled="false">
        <mx:Script source="Filler.as" />
            <mx:Text x="10" y="151" text="Form" fontWeight="normal"/>
             <mx:ComboBox x="10" y="167" width="134" id="Field01" labelField="name" />
    </mx:Module>
    ModuleLoader code
    Just like from Adobe site: http://livedocs.adobe.com/flex/3/html/modular_6.html#170736

    Hello harUI,
    well, i´m using Flex Builder 3 with Eclipse for the development.... and there is something weird....
    for my Internet Browser, the Flash Player version 10.1 is been used... but when i run the swf as stand-alone, the screen says it is running in Flash Player 9... do you have any tip about this?
    Regarding the JavaRemote.as file, he is as described below....
    As you can see, the "clock cursor running forever" seems happen on the function JAVARemote... since the cursor gets stuck after the module reload...
    After some test, i found some more weird thigs.... when the alert.show("Constructor") is on (not commented), the cursor don´t get stuck, but neither the combobox is filled... i have no idea what i´m facing here... i´m kind of desperate to find out what´s the issue....
    Regards!
    package ConnectRO {
        import mx.controls.Alert;
        import mx.rpc.AsyncToken;
        import mx.rpc.Responder;
        import mx.rpc.events.FaultEvent;
        import mx.rpc.remoting.mxml.RemoteObject;
        //Class used to perfome remote calls to the java classes methods.
        public class JAVARemote extends RemoteObject {
            public function JAVARemote(){
                super();
                this.showBusyCursor = true;
                //Alert.show("Constructor");
            public function get getConnection():RemoteObject {
                return this;
            public function call(Method:AsyncToken, NewResult:Function):void {
                var L_Async:AsyncToken;
                L_Async = Method;
                L_Async.addResponder (new Responder(NewResult, DefaultFaultHandler));
            private function DefaultFaultHandler (Result:FaultEvent):void {
                Alert.show(Result.fault.faultString, "Error");
        }// ActionScript file

  • Help needed on Function module  COM_PROD_MATERIAL_MAINTAIN_API

    Hi Gurus,
    I am using <b>COM_PROD_MATERIAL_MAINTAIN_API  </b> to update the set type attributes for a product master.
    I tried but still i am not getting any solution.
    Can someone please help me out.
    Thanks in advance.
    Regards,
    Manoj Tiwari

    Can someone please reply me.
    Thanks in Advance.
    Regards,
    Manoj

  • Need help with SAP SD module

    Hi i am new to this forum, i need help with SAP SD module. Can you please provide me pointers or links to get started SAP SD module and start facing the interviews.

    Hi Aditya,
    For understanding the SD module itself, the link - http://help.sap.com/saphelp_erp2005/helpdata/en/8c/df293581dc1f79e10000009b38f889/frameset.htm is the ultimate one.
    Again you can also refer to the mateial "Implementing R/3 S&D BY GLYNN C.WILLIAMS".
    For Cracking interview, You can refer to "SAP SD Interview Questions, Answers, and Explanations By: Jim Stewart" which is available in the market.
    Regards,
    SARTHAK

  • EDI IDOC generation for interface with Vendor software help needed.

    EDI IDOC help needed.
    We are NOT an EDI shop, but have a project to output data to Sales Force.com
    Sales Force requests IDOC output - eg. 810 Outbound Invoice.
    We will need to do a historical load of Orders/Quotes/Invoices from the past 2 years.
    Is there a function module or series of FM's that are used to generate the E2EDKxxxxx type segments?
    I have been testing using the IDOC_OUTPUT_INVOIC and IDOC_OUTPUT_ORDRSP FM's, but they generate segments begining with E1EDKxxxxx.
    Basicall we have a report program that the user enteres in the date range of Order/Quotes/Invoices they wish to extract, the the program needs to output a flat file (.txt) on the server which is then picked up by Sales Force.com.
    Also, is there a way to have in the Partner Profile a generic Partner under the "Type KU" that can be used for all orders/invoices so I don't have to create a KU Partner Type for each and every Sold-To customer we have?
    I am very new to EDI so any help would be greatly appreciated.
    Thanks.
    Scott.

    Hi Scott,
    We will need to do a historical load of Orders/Quotes/Invoices from the past 2 years.
    I know it's very tempting to use an interface for such loads if you anyhow have to create one. However, often the volume alone speaks against interface usage for such scenarios.
    Is there a function module or series of FM's that are used to generate the E2EDKxxxxx type segments? I have been testing using the IDOC_OUTPUT_INVOIC and IDOC_OUTPUT_ORDRSP FM's, but they generate segments begining with E1EDKxxxxx.
    Well, the E2* segments basically reflect the external name of the IDoc segment, whereas the function modules you're referring to basically just create an internal version of the IDoc. Once the IDoc framework then passes the IDocs to the partner, the segment names usually (depends on how the IDocs are passed on) get converted to their external name. If there are multiple versions of a segment, then the version number will be appended to the segment name.
    Note that IDoc segment definitions are only partially stored in the data dictionary. If you want to see all versions you should always use transaction WE31 to look at segments. There you can also see for example for E1EDK01 the several versions and when you then use in SE37 function module SEGMENT_EXTERNAL_NAME_GET you will see what SAP produces as the external name for segment E1EDK01. This function module is basically the one that handles the segment name translations.
    Ignore the comments for subsystem, this is basically an option in SAP to possibly trigger further external tools (e.g. mapping etc.) for handling the outbound IDocs.
    Again, the funny thing is that via the WE30 transaction, if i put in INVOIC02 as the Obj. name and see the segments, i can see that E2EDK01 there is a version 005, but if i go to SE11 and put in E2EDK01005 structure line and i get a "not found". We just have up to E2EDK01002.
    In the old days SAP used to generate E1, E2 and E3* structures in the data dictionary (SE11). The E1* structure reflected the character type representation of an IDoc segment, whereas the other two (definition and documentation) contained actual references to data elements (e.g. if you used a quantity field). However, in newer releases those dictionary structures (E2* & E3*) are no longer generated, because they're superfluous (meta data defined via WE31 is sufficient).
    Cheers, harald

  • Need a function module to create production order with reference

    Hi
    I need a function module to create a production order with reference to an existing order. There is no BAPI available for SAP 4.7 release. I found that the function module CO_ZF_PRODUCTIONORDER_CREATE does not create with reference to an existing order.
    Any help will be rewarded.
    Pavan

    Dear Pavan,
    Unfortunately there is no FM for this..
    Cheers
    Nitesh

  • Help needed in configuring Dynamic F4

    Hi All
    I am trying to configure Dynamic F4 help for Actvities appln.
    In Actvities Appln I have the Partners tab.In this Partner tab I have partner function and partner Id fields. When I make a search for partner Id  I need to launch  the search screen based on thepartner function selected.
    I guess we can use dynamic F4 help but how to achieve this I am not sure. If anyone has done simliar stuff please do give your inputs.
    Thanks
    Regards
    Senthil

    Hi Senthil,
    You can use Search Help Exit for your problem.
    <b>Search help exit</b> : A search help exit is a function module for making the input help process described by the search help more flexible than possible with the standard version.
    This function module must have the same interface as function module F4IF_SHLP_EXIT_EXAMPLE. The search help exit may also have further optional parameters (in particular any EXPORTING parameters).
    A search help exit is called at certain time points in the input help process.
    <b>Note:</b> The source text and long documentation of the above-specified function module (including the long documentation about the parameters) contain information about using search help exits.
    Function modules are provided in the function library for operations that are frequently executed in search help exits. The names of these function modules begin with the prefix F4UT_. These function modules can either be used directly as search help exits or used within other search help exits. You can find precise instructions for use in the long documentation for the corresponding function module.
    A search help exit is called repeatedly in connection with several
    Events during the F4 process. The relevant step of the process is passed on in the CALLCONTROL step. If the module is intended to perform only a few modifications before the step, CALLCONTROL-STEP should remain unchanged.
    However, if the step is performed completely by the module, the following step must be returned in CALLCONTROL-STEP.
    For more detailed information please refer to the documentation describing the concept of the search help exit.
    The module must react with an immediate EXIT to all steps that it does not know or does not want to handle.
    <b>Time Points</b> :
    During the input help process, a number of time points are defined that each define the beginning of an important operation of the input help process.
    If the input help process is defined with a search help having a search help exit, this search help exit is called at each of these time points. If required, the search help exit can also influence the process and even determine that the process should be continued at a different time point.
    The following time points are defined:
    <b>1. SELONE</b>
    Call before selecting an elementary search help. The possible elementary search helps are already in SHLP_TAB. This time point can be used in a search help exit of a collective search help to restrict the selection possibilities for the elementary search helps.
    Entries that are deleted from SHLP_TAB in this step are not offered in the elementary search help selection. If there is only one entry remaining in SHLP_TAB, the dialog box for selecting elementary search helps is skipped. You may not change the next time point.
    The time point is not accessed again if another elementary search help is to be selected during the dialog.
    <b>2. PRESEL1</b>
    After selecting an elementary search help. Table INTERFACE has not yet been copied to table SELOPT at this time point in the definition of the search help (type SHLP_DESCR_T). This means that you can still influence the attachment of the search help to the screen here. (Table INTERFACE contains the information about how the search help parameters are related to the screen fields).
    <b>3. PRESEL</b>
    Before sending the dialog box for restricting values.
    This time point is suitable for predefining the value restriction or for completely suppressing or copying the dialog.
    <b>4. SELECT</b>
    Before selecting the values. If you do not want the default selection, you should copy this time point with a search help exit. DISP should be set as the next time point.
    <b>5. DISP</b>
    Before displaying the hit list. This time point is suitable for restricting the values to be displayed, e.g. depending on authorizations.
    <b>6. RETURN</b> (usually as return value for the next time point)
    The RETURN time point should be returned as the next step if a single hit was selected in a search help exit.
    It can make sense to change the F4 flow at this time point if control of the process sequence of the Transaction should depend on the selected value (typical
    example: setting SET/GET parameters). However, you should note that the process will then depend on whether a value was entered manually or with an input help.
    <b>7. RETTOP</b>
    You only go to this time point if the input help is controlled by a collective search help. It directly follows the time point RETURN. The search help exit of the collective search help, however, is called at time point RETTOP.
    <b>8. EXIT</b> (only for return as next time point)
    The EXIT time point should be returned as the next step if the user had the opportunity to terminate the dialog within the search help exit.
    <b>9. CREATE</b>
    The CREATE time point is only accessed if the user selects the function "Create new values". This function is only available if field CUSTTAB of the control string CALLCONTROL was given a value not equal to SPACE earlier on.
    The name of the (customizing) table to be maintained is normally entered there. The next step returned after CREATE should be SELECT so that the newly entered value can be selected and then displayed.
    10. <b>APP1, APP2, APP3</b>
    If further pushbuttons are introduced in the hit list with function module F4UT_LIST_EXIT, these time points are introduced. They are accessed when the user presses the corresponding pushbutton.
    <b>Note:</b> If the F4 help is controlled by a collective search help, the search help exit of the collective search help is called at time points SELONE and RETTOP. (RETTOP only if the user selects a value.) At all other time points the search help exit of the selected elementary search help is called.
    If the F4 help is controlled by an elementary search help, time point RETTOP is not executed. The search help exit of the elementary search help is called at time point SELONE (at the moment). This search help exit should not do anything at this time point. Any preparatory work should be carried out at time point PRESEL1.
    <b>Steps for creating search help :</b>
    1. Run Transaction SE11
    2. Give search help name
    3. Click on Create
    4. Make selection for Elementary or Collective search
       Help
    <b>For Elementary Search Help</b>
    5. Elementary search Help screen.  
    6. Give short description.
    7. Dialog type specifies the data display in the hit
       list.
    8. Give selection method
    A] Search for database tables
    B] Search for Views
    9. Hot key specifies the letter or number displayed with every elementary search help. 
    10. Search help Exit: Specify the function module developed for the search of data for the elementary search help.
    11. Search help parameter
    A] Specify the input and output fields in the search help parameter column.
    B] IMP column is input parameter for the search help.
    C] EXP column is output parameter of the search help, to be displayed in the Hit list after selection.
    D] LPos specifies the order in which fields are displayed in the hit list.
    E] SPos specifies the order in which fields are displayed in the search help pop up screen.
    F] Specify Data element in the field.
    G] Specify the default value for any field required.
    <b>For Collective Search Help :</b>
    12. Search help exit: Specify the function module developed for the search of data for the elementary search help.
    13. Search help parameter: Specify the import and export parameters.          
    14. Search help: Specify the elementary search help and the short text.
    15. Parameter Assignment: Select the elementary search help and click on the parameter assignment. System proposes fields. User has to select the fields as per requirement, fields to be displayed in the output
    hit list. Parameter assignment has to be done compulsorily for every elementary search help designed for the collective search help.   
    <b>Please reward points if it helps.</b>
    Regards,
    Amit Mishra

  • Need BAPI function module to change routing (CA12 Tcode)

    Hi Freinds,
       i have bapi function module to create bapi_routing_create,
       but i need bapi function module  to ROUTE CHANGE.
    tcode is ca12
       pls help me out .....it's urgent to me
    mail to me :[email protected]
    regards
    madhu

    Thanks Jitendra,
    I have tried to use it but I am not able to obtain a good result. I have set values for PLKO_DI_TAB and MAPL_DI_TAB, but it does not work…
    What is missing?

  • 1941W configuration help needed

    Our Deployment Scenario:-
    1941W Gigabit Ethernet 0/0 is connected to the PPOE connection of the ISP.
    Gigabit Ethernet 0/1 is connected to the wired LAN
    I have created 2 wireless radio Cisco_Kamran_BGN which is operating at 2.4 Ghz Devices and Cisco_Kamran_A which is operating at 5Ghz Devices.
    I have created 2 VLans for the Wireless.
    Vlan 10 for Cisco_Kamran_A        192.168.10.x
    Vlan 11 for Cisco _Kamran_BGN   192.168.11.X
    The problem is the Wireless users are not getting the IP address from the respective DHCP server which has been configured on the Router.
    Can please any from the community help me and show me where I am missing the configuration.
    Please find my router  & ap configuration below.
    Router Configuration
    Router#
    sh run
    Building configuration...
    Current configuration : 3022 bytes
    ! No configuration change since last restart
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname Router
    boot-start-marker
    boot-end-marker
    enable secret 5 $1$TdQt$npYeaf/W0kRElcfMggzJ31
    no aaa new-model
    service-module wlan-ap 0 bootimage autonomous
    no ipv6 cef
    ip source-route
    ip cef
    ip dhcp excluded-address 192.168.1.1 192.168.1.50
    ip dhcp excluded-address 192.168.10.1 192.168.10.10
    ip dhcp excluded-address 192.168.11.1 192.168.11.10
    ip dhcp pool DHCP
    network 192.168.1.0 255.255.255.0
    default-router 192.168.1.1
    dns-server 195.229.241.222 213.42.20.20
    ip dhcp pool Cisco_Kamran_A
    network 192.168.11.0 255.255.255.0
    default-router 192.168.11.1
    dns-server 195.229.241.222 213.42.20.20
    ip dhcp pool Cisco_Kamran_BGN
    network 192.168.10.0 255.255.255.0
    default-router 192.168.10.1
    dns-server 195.225.241.222 213.42.20.20
    multilink bundle-name authenticated
    crypto pki token default removal timeout 0
    license udi pid CISCO1941W-E/K9 sn FCZ1553C1VK
    hw-module ism 0
    redundancy
    bridge irb
    interface Embedded-Service-Engine0/0
    no ip address
    shutdown
    interface GigabitEthernet0/0
    ip address 192.168.1.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly in
    duplex auto
    speed auto
    interface wlan-ap0
    description Service module interface to manage the embedded AP
    ip unnumbered GigabitEthernet0/0
    arp timeout 0
    no mop enabled
    no mop sysid
    interface GigabitEthernet0/1
    no ip address
    duplex auto
    speed auto
    pppoe enable group global
    pppoe-client dial-pool-number 1
    interface Wlan-GigabitEthernet0/0
    description Internal switch interface connecting to the embedded AP
    switchport mode trunk
    no ip address
    interface Vlan1
    no ip address
    interface Vlan10
    ip address 192.168.10.1 255.255.255.0
    ip access-group DSL_ACCESSLIST in
    ip nat inside
    ip virtual-reassembly in
    interface Vlan11
    ip address 192.168.11.1 255.255.255.0
    ip access-group DSL_ACCESSLIST in
    ip nat inside
    ip virtual-reassembly in
    interface Dialer1
    ip address negotiated
    ip nat outside
    ip virtual-reassembly in
    encapsulation ppp
    dialer pool 1
    ppp authentication pap callin
    ppp pap sent-username xxxxxx password 0 xxxxxx
    ppp ipcp route default
    ip forward-protocol nd
    no ip http server
    no ip http secure-server
    ip nat inside source list DSL_ACCESSLIST interface Dialer1 overload
    ip access-list extended DSL_ACCESSLIST
    permit ip 192.168.0.0 0.0.255.255 any
    control-plane
    line con 0
    password xxxxxx
    login
    line aux 0
    line 2
    no activation-character
    no exec
    transport preferred none
    transport input all
    transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
    stopbits 1
    line 67
    no activation-character
    no exec
    transport preferred none
    transport input all
    transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
    line vty 0 4
    password xxxxxx
    login
    transport input all
    scheduler allocate 20000 1000
    end
    Router#
    Router#
    Router#
    Access Point Configuration
    ap#
    ap#
    ap#
    sh run
    Building configuration...
    Current configuration : 2603 bytes
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname ap
    enable secret 5 $1$JxdQ$a2/00bWJuhUKP9QLC94YD/
    no aaa new-model
    dot11 syslog
    dot11 ssid Cisco_Kamran_A
       authentication open
       authentication key-management wpa
       guest-mode
       wpa-psk ascii 7 1045081417161C5A555C7A7B
    dot11 ssid Cisco_Kamran_BGN
       authentication open
       authentication key-management wpa
       guest-mode
       wpa-psk ascii 7 020D05561907017015165949
    username Cisco password 7 14341B180F0B
    bridge irb
    interface Dot11Radio0
    description 802.11bgn radio
    no ip address
    no ip route-cache
    encryption mode ciphers aes-ccm
    broadcast-key change 3600
    ssid Cisco_Kamran_BGN
    antenna gain 0
    station-role root
    bridge-group 11
    bridge-group 11 subscriber-loop-control
    bridge-group 11 block-unknown-source
    no bridge-group 11 source-learning
    no bridge-group 11 unicast-flooding
    bridge-group 11 spanning-disabled
    interface Dot11Radio1
    description 802.11a radio
    no ip address
    no ip route-cache
    encryption mode ciphers aes-ccm
    ssid Cisco_Kamran_A
    antenna gain 0
    no dfs band block
    channel dfs
    station-role root
    bridge-group 10
    bridge-group 10 subscriber-loop-control
    bridge-group 10 block-unknown-source
    no bridge-group 10 source-learning
    no bridge-group 10 unicast-flooding
    bridge-group 10 spanning-disabled
    interface GigabitEthernet0
    description the embedded AP GigabitEthernet 0 is an internal interface connecting AP with the host router
    no ip address
    no ip route-cache
    bridge-group 1
    no bridge-group 1 source-learning
    bridge-group 1 spanning-disabled
    interface GigabitEthernet0.10
    description 802.11a bridge
    encapsulation dot1Q 10
    no ip route-cache
    bridge-group 10
    bridge-group 10 subscriber-loop-control
    bridge-group 10 block-unknown-source
    no bridge-group 10 source-learning
    no bridge-group 10 unicast-flooding
    bridge-group 10 spanning-disabled
    interface GigabitEthernet0.11
    description 802.11bgn bridge
    encapsulation dot1Q 11
    no ip route-cache
    bridge-group 11
    bridge-group 11 subscriber-loop-control
    bridge-group 11 block-unknown-source
    no bridge-group 11 source-learning
    no bridge-group 11 unicast-flooding
    bridge-group 11 spanning-disabled
    interface BVI1
    ip address dhcp client-id GigabitEthernet0
    no ip route-cache
    ip http server
    no ip http secure-server
    ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
    bridge 1 route ip
    line con 0
    no activation-character
    line vty 0 4
    login local
    end
    ap#
    ap#
    ap#

    Hi Stepehen,
    Did the configuration as per your advice  but i am getting the below mentioned error which i have highlighted it in red. Please advice what needs to be done.
    Home
    Re: 1941W configuration help needed
    created by Stephen Rodriguez in Getting     Started with Wireless - View the full discussion
    conf t
    interface     Dot11Radio0
    no ssid     Cisco_Kamran_BGN
    no encryption mode     ciphers aes-ccm
    exit
    interface     Dot11Radio1
    no encryption mode     ciphers aes-ccm
    no ssid     Cisco_Kamran_A
    exit
    dot11 ssid     Cisco_Kamran_A
    vlan 10
    dot11 ssid     Cisco_Kamran_BGN
    vlan 11
    exit
    interface     Dot11Radio0
    encryption vlan 11     mode ciphers aes
    ssid     Cisco_Kamran_BGN
    exit
    interface     dot11radio0.1
    encapsulation     dot1q 1 native
    bridge-group 1
    interface     dot11radio 0.11
    encapsulation     dot1q 11
    bridge-group 11
    Configuration of     subinterfaces and main interface
    within the same bridge     group is not permitted
    exit
    interface     Dot11Radio1
    encryption vlan 10     mode ciphers aes-ccm
    ssid     Cisco_Kamran_A
    interface     dot11radio1.1
    encapsulation     dot1q 1 native
    bridge-group 1
    interface     dot11radio1.10
    encapuslation     dot1q 10
    bridge-group 10
    Configuration of subinterfaces and main     interface
    within the same bridge     group is not permitted
    end
    wr
    Reply to this message by going to Home
    Start a new discussion in Getting Started with Wireless at Home

  • Why Do We Need Java Adapter module ???

    Hi All,
    Why Do We Need Java Adapter module ???
    What is the Use of it ????
    Where we Write the code for this
    Regards
    Vamsi

    Hi Vamsi,
    Adapter modules are required to enhance the functionality of SAP XI.
    Enhancements like.
    1. Converting the payload (not covered with standards)
    2. Changing encoding
    3. Encryption and decryption
    4. Creating and merging of additional attachments
    Please follow the links below.
    <a href="https://www.sdn.sap.comhttp://www.sdn.sap.comhttp://www.sdn.sap.com/irj/sdn/go/portal/prtroot/docs/library/uuid/f013e82c-e56e-2910-c3ae-c602a67b918e">How to Create Modules for the J2EE Adapter Engine</a>
    <a href="https://www.sdn.sap.comhttp://www.sdn.sap.comhttp://www.sdn.sap.com/irj/sdn/go/portal/prtroot/docs/library/uuid/e21106cc-0c01-0010-db95-dbfc0ffd83b3">Adapter Module Development  - Presentation</a>
    *Reward points if helpful*
    Regards,
    Sushil.

  • User Exit for Material Group...Urgent help needed

    Does anybody have an idea of which user exit can be used to capture the changes made to material group in MM02(Material)..... Urgent help needed...

    See  the below user exit and this will trigger under MM01,MM02 and MM17 Transaction
    Enhancement name : MGA00001
    Function module :EXIT_SAPLMGMU_001
    Include : ZXMG0U02
    Reward Points if it is helpful.
    Thanks
    Seshu

  • How to use WS_DOWNLOAD funciton module in back ground (Batch Job)

    Hi all,
        Can any one tell,
    How to use WS_DOWNLOAD funciton module in back ground (Batch Job)
    Thanks,
    Ravi Kumar.

    As disussed above you can use DATASET techniques to write the file to the application server. Then you could do a bdc call to Transaction CG3Y to transfer the file to the presentation server.
    Just F1 help on keyword DATASET in SE80 for more information.
    BDC Call Info found here: <a href="http://www.sap-img.com/bdc.htm">http://www.sap-img.com/bdc.htm</a>
    Regards,
    Philip Johannesen

  • Documentation Help on E-Recruitment module implementation

    Hi Experts,
    I need Documentation related to implementation of E-recruitment Module in EP and also its features and benefits.
    Help needed urgently.
    Thanks & Regards,
    Shailesh Nagar

    It depends upon the Business packages you are using, E-recruitment version and the application modes (webdynpro and BSP's).
    If you are using mySAP ERP 2005 Business Package version 1.0, check this [documentation|http://help.sap.com/saphelp_erp2005/helpdata/en/31/3a1665fe7741d5b6501cd505a6bd82/frameset.htm]
    The above documentation is based on webdynpro version.
    Check this [documentation|http://help.sap.com/saphelp_erp2005/helpdata/en/43/0fa05e9e242a8be10000000a1553f6/frameset.htm] for BSP application modes.
    Regards,
    Anil Kumar

Maybe you are looking for

  • Unable to create a folder in lower levels of root folder

    It appears to me I cannot create a new folder in the lower levels of root folder. Currently, I have to create a new folder right below root folder and then drag it to lower level folder. Why I can't do it in one go. Thanks!

  • How to call external js file to custom master page

    Hi all, I have created custom master page and i need to call external .js to master page. i tried every aspect of including this in master page. but this js is not running.  <script src="test.js" type="text/javascript"></script> i have put the abov

  • Server Proxy

    File ---> XI --> R/3 From File I am sending PERNR AND Employee Name. This needs to be stored in a Z Table. I want to Develop a proxy for that? XI Repository 1) Create Data Type for File, 2) Create Data Type for Ztable, 3) Create Message Type for File

  • Mail crash now won't launch

    I was opening a Mail attachment (a PowerPoint file from a trusted source) last night when my BlackBook suddenly restarted itself for no reason. I happen to think that fact is coincidental to the problem, but at least it gives some background. After a

  • Multiple Revision Levels for a Material

    Today, Tyco Electronics has many manufacturing sites located around the world.  A given material may be manufactured in multiple locations.  When Engineering determines that a given material must change revision level, they determine a date that this