How to organise cache structure in distributed and fault tolerant way?

Suppose I have two caches - cacheA that contains objects of type A and cacheB containing objects of type B; caches are distributed across several physical servers.
B-objects should listen to updates of objects in cacheA.
How should the objects be implemented? In particular - how to organize subscription? For example, if in JVM1 I create Object B and subscribe to ObjectA, then launch JVM2 in the same cluster, then shut down JVM1, ObjectB will be available in CacheB on JVM 2 but will not receive any updates about ObjectA anymore.
How can this problem be solved?

That does not answer my question unfortunately. Let's say that I have something that listens to all updates to all objects in the cache that is distributed across several physical servers. The requirements are
- whenever an object in the cache is changed the change is handled somehow
- the code that handles the update should have read/write access to the cache
- there must be one and only one notification of that kind
- network traffic is minimized, i.e. there is no single dedicated JVM that listens to all updates, ideally each node in a cluster serves updates for its local data
I'm thinking about setting up a listener to backing map, but not so sure

Similar Messages

  • UOO sequencing along with WLS high availability cluster and fault tolerance

    Hi WebLogic gurus.
    My customer is currently using the following Oracle products to integrate Siebel Order Mgmt to Oracle BRM:
    * WebLogic Server 10.3.1
    * Oracle OSB 11g
    They use path service feature of a WebLogic clustered environment.
    They have configured EAI to use the UOO(Unit Of Order) Weblogic 10.3.1 feature to preserve the natural order of subsequent modifications on the same entity.
    They are going to apply UOO to a distributed queue for high availability.
    They have the following questions:
    1) When during the processing of messages having the same UOO, the end point becomes unavailable, and another node is available in order to migrate, there is a chance the UOO messages exist in the failed endpoint.
    2) During the migration of the initial endpoint, are these messages persisted?
    By persisted we mean that when other messages arrive with the same UOO in the migrated endpoint this migrated resource contains also the messages that existed before the migration?
    3) During the migration of endpoints is the client receiving error messages or not?
    I've found an entry on the WLS cluster documentation regarding fault tolerance of such solution.
    Special Considerations For Targeting a Path Service
    When the path service for a cluster is targeted to a migratable target, as a best practice, the path
    service and its custom store should be the only users of that migratable target.
    When a path service is targeted to a migratable target its provides enhanced storage of message
    unit-of-order (UOO) information for JMS distributed destinations, since the UOO information
    will be based on the entire migratable target instead of being based only on the server instance
    hosting the distributed destinations member.
    Do you have any feedback to that?
    My customer is worry about loosing UOO sequencing during migration of endpoints !!
    best regards & thanks,
    Marco

    First, if using a distributed queue the Forward Delay attribute controls the number of seconds WebLogic JMS will wait before trying to forward the messages. By default, the value is set to −1, which means that forwarding is disabled. Setting a Forward Delay is incompatible with strictly ordered message processing, including the Unit-of-Order feature.
    When using unit-of-order with distributed destinations, you should always send the messages to the distributed destination rather than to one of its members. If you are not careful, sending messages directly to a member destination may result in messages for the same unit-of-order going to more than one member destination and cause you to lose your message ordering.
    When unit-of-order messages are processed, they will be processed in strict order. While the current unit-of-order message is being processed by a message consumer, the next message in the unit-of-order will not be delivered unless it is to the same transaction or session. If no message associated with a particular unit-of-order is processing, then a message associated with that unit-of-order may go to any session that’s consuming from the message’s destination. This guarantees that all messages will be processed one at a time and in order, and any rollback or recover will not prevent ordered processing of the messages.
    The path service uses a persistent store to save the state of which member destination a particular unit-of-order is currently using. When a Path Service receives the first message for a particular unit-of-order bound for a distributed destination, it uses the normal JMS load balancing heuristics to select which member destination will handle the unit and writes that information into its persistent store. The Path Service ensures that a new UOO, or an old UOO that has no messages currently on any destination, can be enqueued anywhere in the cluster. Adding and removing member destinations will not disrupt any existing unit-of-order because the routing decision is made dynamically and those decisions are persistent.
    If the Path Service is unavailable, any requests to create new units-of-order will throw the JMSOrderException until the Path Service is available. Information about existing units-of-order are cached in the connection factory and destination servers so the Path Service availability typically will not prevent existing unit-of-order messages from being sent or processed.
    Hope this helps.

  • Load balancing and fault tolerance in BPEL PM

    BPEL documentation talks about the ability of clustering processes in BPEL PM Server for fault tolerance and Load balancing. Can anybody tell me how is it done?
    Thanks

    Have you seen these links?
    http://www.oracle.com/technology/products/ias/hi_av/BPEL_HA_Paper.pdf
    http://download-uk.oracle.com/docs/cd/B31017_01/integrate.1013/b28980/clusteringsoa.htm#CHDCGIEJ

  • How to implement hierarchical structure of managers and reportees using jdeveloper adf

    I want to display hierarchical structure(which can be expanded and compressed) with 3 columns(Employeeid, fist Name,lastname) of managers and his reportees on selecting a top level manager.
    In this i'm going to use programmatic view objects.
    I have employees table.
    Here is my detailed requirement:
    On selecting a user from drop down list, i want to display the list of users reporting to him.
    From the displayed list on selecting a manager, list of users reporting to him has to be displayed in a tree format with the correspoding just being listed below the current selected manager
    Example :
    Top Manger  has been selected from dropdown and clicked submit.
    Output(a table as mentioned below):
    Manager1
    Manager2
    NonManager1
    Manger 3
    On clicking manager1,
    output:
    Manger 1
      Manger11
      Manasger12
      Nonmanager11
    Manger 2
    NonManger1
    Manger3
    on clicking manager1 again, tree has to be compressed and the output has to be just the same as first output.
    Please help me on this by sharing information or any references on how can i achieve this implementation using Jdeveloper adf concepts.
    Will be waiting for the inputs.
    Thank You,
    Dev

    Obviously, you can only display one picture.  So then the question becomes which picture to show.  Therefore, you will have to create some sort of preference of one pattern over another.
    I would use a FOR loop so that you can loop through your available patters and their possible results.  Use the Conditional Terminal on the FOR loop so that you can stop the loop on the first match.  Then you just wire up the selected value for the ring outside of the loop.
    There are only two ways to tell somebody thanks: Kudos and Marked Solutions
    Unofficial Forum Rules and Guidelines

  • Dual ADSL Load Balancing and Fault tolerance

    Just wonder if this is doable with for example 2 WIC-1ADSL cards on say a 2800 series platform. The application would be simple internet access. If so could someone provide a sample config? Just a note...this application would include two static ip ADSL services. Thanks, Shawn

    That is definitely doable. Here's a sample config:
    ip cef
    interface atm1/0.32
    ip address 255.255.255.252
    ip nat outside
    pvc 1/32
    oam-pvc manage
    interface atm2/0.32
    ip address 255.255.255.252
    ip nat outside
    pvc 1/32
    oam-pvc manage
    interface GigabitEthernet0/0
    ip address 10.1.1.1 255.255.255.0
    ip nat inside
    ip route 0.0.0.0 0.0.0.0 atm1/0.32
    ip route 0.0.0.0 0.0.0.0 atm2/0.32
    ip nat inside source route-map ISP1-map interface atm1/0.32
    ip nat inside source route-map ISP2-map interface atm2/0.32
    route-map ISP11-map permit 10
    match interface atm1/0.32
    route-map ISP12-map permit 10
    match interface atm2/0.32
    Explanation:
    - the use of two static routes will allow you to load-balance over the two links and provide redundancy at the same time
    - the NAT config will dynamically choose the NAT'ed address depending on which interface CEF has chosen to send the packet out of...
    Hope that helps - pls rate the post if it does.
    Regards,
    Paresh

  • NonBlocking invoke and fault tolerance behavior

    If I have an operation of a partnerlink being invoked synchronously, and I am utilizing the nonBlockingInvoke for that invocation, what is the expected behavior if my server goes down during that synchronous call before the web service can return (more specifically, I have initiated the nonBlocking invocation, see that invocation in the audit trail, then the server goes down before the synchrounous response comes back to the bpel process)?
    Will that process instance perform that synchronous invocation again? Or does something else happen?
    Thx...
    Cheers,
    -Dustin

    Hi Veeru
    I had checked that link. My question was basically to know where should I include ora-terminate action in Fault policy file to make this work.
    If you see my fault policy file I am calling aia-ora-java incase of retryFailureAction so that it can send out the error notification email once the retry limit is exceeded.
    <Action id="ora-retry">
    <retry>
    <retryCount>3</retryCount>
    <retryInterval>2</retryInterval>
    <exponentialBackoff/>
    <retryFailureAction ref="aia-ora-java"/>
    </retry>
    </Action>
    Also under aia-ora-java the defaultAction is ora-rethrow-fault so that once the error email has been sent by oracle.apps.aia.core.eh.CompositeJavaAction class, it will rethrow the fault back to the BPEL.
    <Action id="aia-ora-java">
    <javaAction className="oracle.apps.aia.core.eh.CompositeJavaAction" defaultAction="ora-rethrow-fault">
    <returnValue value="REPLAY" ref="ora-terminate"/>
    <returnValue value="RETHROW" ref="ora-rethrow-fault"/>
    <returnValue value="ABORT" ref="ora-terminate"/>
    <returnValue value="RETRY" ref="aia-ora-retry"/>
    <returnValue value="MANUAL" ref="ora-human-intervention"/>
    </javaAction>
    </Action>
    So where should the ora-terminate action be included in this case ?
    Regards
    Subhankar

  • How can I prevent a PDF file from being copied, printed or downloaded? Students should only be able to view the text and and not distribute it in any way.

    How can I prevent a PDF file from being copied, printed or downloaded? Students should only be able to view the text and and not distribute it in any way.

    You can prevent it from being printed by applying a security policy to it
    in Acrobat. The rest can't be prevented, unless you spend  a LOT of money
    on DRM protection.

  • How to retreive data from a table and a structure

    Hi experts,
    I have a requirement to create an ALV report. I have to include fields from two tables 'PA0001' and 'CATSDB' and from one structure 'CATSAPPR'. I am able to retrieve data from tables using INNERJOIN. But i have no idea how to deal with Structure.
    I know that structure does not contain any data.
    But  i am not able to find any transparent table which has field 'ORDERTEXT' . I found field 'ORDERTEXT' only in structure 'CATSAPPR'.
    So please anyone tell me, either any transparent table which has field 'ORDERTEXT' or please tell me how to deal with structure, in this case.
    Please help me,
    Thanks in advance
    Anu

    check this
      Table-Fields                     Short descriptn
      AUFK- KTEXT          Order master data
    COCH- KTXT              Process Management: Control Recipe Header
    COCHP- KTXT             PI sheet: Control Recipe Header
    COMPHDR- KTEXT    OCM: Comparison results, indiv. records for order headers
    HIKO- KTEXT              Order master data history
    MAAVC_MDO-  KTEXT      MPO: Individual Master Data for Orders
    MCHPVS- AUFTEXT                           Batch Record: Shadow Table for Link to Archive
    OCMHOMO_ARCH- KFELD          Backup Table of Homogeneity List in Case of Archiving
    PSJHIEDATA- KTEXT                       Hierarchy data to test LDB PSJ
    TEWOCODEST- DESCRIPTION                      Order Codes (Texts)
    TEWOCODET- KTEXT           Allocation of Message Codes to Order 
    VLCSMORDER- KTEXT                                                   VELO : Service Order
    VSAUFK_CN- KTEXT               Version: Order master data
    Yogesh N

  • How to define the Structure and FCC parameters for EDI file format.

    Hi All,
    I have a  EDI file(FTP)-->XI-->IDOC
    the source file content is as follows
    PR H01PHUPS         
    FH   SHP  0.0.5    
    H1   S0022323                            
    W6   7752508853                     D
    PT   1Z58R7070341111111           
    PT   1Z58R7070342222222           
    PT   1Z58R7070353333333          
    N1ST ZZ 142222                            
    N3ST 8827 D OLD
    N4ST MARCY                        
    N1WH ZZ 2070                              
    N3WH 401 QUALITY
    N4WH HARRIS
    DTENT20111206
    DTSHP201112061754
    N9LL BN20700033333333                               
    N9NT
    CD   CP      UPS
    IT026
    P1GD    VN A1111 
    PD   Product ID 1                   
    QTORD000000000000010CA
    QTSHP000000000000010CA
    AM U  000000000000000000M
    AM X  000000000000000000
    LTLT 1112811111                                       
    AM G  000000000000000000
    AM N  000000000000000000
    AM TAX000000000000000000
    AM SVC000000000000000000
    AM COD000000000000000000
    ST   00000000100000000010000000000000000000000000008500LB
    Can any body share me how to declare the structure in DataType.
    The first two characters in each record is constant , so this would be the keyfields right?
    ex:- PR,FH,H1,W6,PT,AM,N1,N3,N4......
    In Comm channel the FCC parameters
    i need to go for fieldFixedLengths?
    Thanks&Regards
    Sai_SHA

    Hi.
    if you need to convert an EDI to XML you need to use an Adapter specific (e.g Seeburger) because PI doesn't support EDI files.
    Also if you use a FCC , this configuration is for  two level Header and Detail.
    Check this.
    http://help.sap.com/saphelp_nw04/helpdata/en/bc/bb79d6061007419a081e58cbeaaf28/frameset.htm
    Regards
    Luis Ortiz

  • How to copy a dir structure with files and subdir's in to another dir

    Hi there.
    How can i copy a dir structure with files and subdirs to another dir structure
    ie., all files and dirs in side the dir c:\aDir to c:\copyDir so i should get like c:\copyDir\aDir(all the files and subdirs of adir here)
    Thanks in advance
    Muthu

    File f = new File(dirName);
    if(f1.isDirectory()) {
    String list = f.list();
    then u have perform file io for each file and copy them to dir u want
    [email protected]

  • TS3408 how to clean cache and cookies?

    hi i just wanna know how to clean cache and cokies in my system..coz looks like it causes delayed in loading web pages.

    Try Safari > Reset Safari and then peruse the checkboxes.  In particular, consider "Remove all website data".

  • How to export iPhoto Album in iMAC and have similar folder structure(with Timestamps) which can be viewed in finder

    How to export iPhoto Album in iMAC and have similar folder structure(with Timestamps) which can be viewed in finder
    In simple terms, I wanted to view the photos in Windows system, similar strcture of iPhotos

    If you want to copy all of your photos to a Windows machine and have them in folders representing the iPhoto Events the were in quickly and easily just do the following:
    1  - open the library with the Finder as shown in this screenshot:
    2 - COPY the Originals/Masters folder to the Desktop.
    3 - copy the Originals/Masters folder to the Windows machine.
    This will give you all of your original image file in their Event folder on the Windows machine.
    NOTE:  With iPhoto 8 or newer the Event folders in the Masters folder will be titled by date (EXIF) if imported from a camera.  If imported from a folder the event folder will have the same title as the source folder.  If imported singularly or in a group without a folder the title will be a date, either the EXIF date or import date.
    With iPhoto 7 (08) and earlier the Event folders in the Originals folder will have the same title as the Event has in the library.
    This method would be quicker but not provide the additional metadata you might have added in iPhoto like keywords, titles, descriptions that exporting out of iPhoto with Format=JPEG and the checkboxes selected to include keywords, titles, places, etc, checked.
    OT

  • How to see all structure and key figures

    HI friends,
    I can not to see in query designer all structure, all calculated and restricted key figure than I have create.
    How can I do??
    Thanks
    bye bye

    May be something wrong with authorisations... Trace it in SU53.
    Or this is one of numerous bugs of BEx. Try relogon...
    Foolish question: Are you sure that you are using the same infoprovider?

  • How to clear cache and cookies

    Hi guys,
    I am new to jsf. And I have one problem in jsf, How to clear cache and cookies.
    Please help me to solve this..

    clearing Java cache and cookies is different from clearing IE cache and cookies. Usually when you powercycle your computer it is automatically cleared. To clear manually:
    go to start--> settings--> control panel--> double click on Java icon. Click on "delete files" under temporary internet files or 'clear cache' in the 'cache' tab. It depends on which version of java and which OS you use on how these will show up.
    If you were having issues with java crashing or making your freezing up, this should resolve the issue. It is strongly suggested that you powercycle the computer as well after clearing the java cache.

  • How to clear cache and cookies on an iphone

    Hi, can you please tell how to clear cache and cookies on an iPhone, thanks

    Settings > Safari > Clear Cache/Cookies

Maybe you are looking for

  • Music on my iPhone 5s is not loading!!!

    My music won't sync onto my iPhone 5s. I just downloaded the new iTunes update and it didn't help. I have about 30 songs on my phone that are not loading and I don't know what to do to fix this. Some songs from my iTunes on my computer won't even sho

  • Diff between Seeburger Adapter and File Adapter

    Hi All,          My company needs to interact with some banks and the banks are particular that they want SFTP, which is not supported by  File Adapter, so we have decided to go with Seeburger adapter. Now what are the differences between File adapte

  • High RFC response time in SAP BW system

    Hello all, How to analyze and fine tune high RFC response time in SAP BW system ? Regards, Archana

  • HT4623 How can I receive blocked calls on my phone

    I am a hospital driver.  The hospital number is a withheld number.  They cannot leave voicemail messages for me.

  • Help with reducing the size of an image but keeping the quality

    Hello, I am wondering how do I resize an image but keep the quality. I am creating a folder design for work and I want to include 6 images on the back each of 156px x 118px. The images I have are slightly different in size but for example sake one of