How to rate-limit different IP's entering/leaving an Interface?

Hi There,
We are an ISP and have an interconnect with say Provider A. Customers of ours use Provider A for layer 2 and us for Layer 3 (IP/Internet).
Customer #1 to #100 --- (10Mb) --> Provider A ---> ISP ---> Internet
We'd like to rate limit some customers to 2mb/sec (in/out) on our end because at present they have a 10mb/sec connection coming from Provider A.
The config we use to peer with Provider A is this:
interface GigabitEthernet0/1.120
description Interconnect with Provider A
bandwidth 400000
encapsulation dot1Q 120
ip address A.B.C.1 255.255.255.252
Customers of ours are simply routed out through this interface like so:
Customer #1:
ip route W.X.Y.Z. 255.255.255.255 A.B.C.2
Customer #2:
ip route J.K.L.M 255.255.255.255 A.B.C.2
Is there a way to rate limit both these customers without needing to create a separate class map for each like so:
class-map match-all CUSTOMER-1-2MB
match access-group name ACL-CUSTOMER-1
class-map match-all CUSTOMER-2-2MB
match access-group name ACL-CUSTOMER-2
policy-map POLICY-RATE-LIMIT
class CUSTOMER-1-2MB
police 2000000 375000 750000
class CUSTOMER-2-2MB
police 2000000 375000 750000
interface GigabitEthernet0/1.120
service-policy input POLICY-RATE-LIMIT
service-policy output POLICY-RATE-LIMIT
I've done this in the lab and I know it works, so Customer #1 ends up with 2mb/sec and Customer #2 gets 2mb/sec too.
But in production, I'm talking about 100's of customers which we simply route out of this interface. I can't imagine having to configure 100's of class maps and policy maps for each customer to rate limit them to 2mb/sec like in the config above.
Is there a better way to do this on the router???
Thanks.
Andy

Hi All,
Doing what Laurent suggested works great. We are able to rate-limit the desired customers by having a separate class-map for each customer that needs to be rate limited under the single policy-map.
But now we're finding that the CPU utilization has increased by 20% because of this.
We're pushing about 400M through this interface and rate limiting 7 customers on it.
Given the large traffic flow through this interface (400M), is it common to see an increase in CPU utilisation by 20%???
When we take the service-policy off the interface, sure enough the CPU drops by 20%.
Here's the MQC applied:
interface GigabitEthernet0/1.120
bandwidth 400000
encapsulation dot1Q 120
ip address 203.17.x.x 255.255.255.252
ip flow ingress
service-policy input RATE-LIMIT
service-policy output RATE-LIMIT
class-map match-all CLASS-TCS-200338
description Customer #1 rate limited to 4mb/sec
match access-group name ACL-TCS-200338
class-map match-all CLASS-TCS-200208
description Customer #2 rate limited to 2mb/sec
match access-group name ACL-TCS-200208
class-map match-all CLASS-TCS-205593
description Customer #3 rate limited to 3mb/sec
match access-group name ACL-TCS-205593
class-map match-all CLASS-TCS-205679
description Customer #4 rate limited to 4mb/sec
match access-group name ACL-TCS-205679
class-map match-all CLASS-TCS-200441
description Customer #5 rate limited to 4mb/sec
match access-group name ACL-TCS-200441
class-map match-all CLASS-TCS-200005
description Customer #6 rate limited to 2mb/sec
match access-group name ACL-TCS-200005
class-map match-all CLASS-TCS-205560
description Customer #7 rate limited to 4mb/sec
match access-group name ACL-TCS-205560
policy-map RATE-LIMIT
class CLASS-TCS-200005
police 2000000 375000 750000 conform-action transmit exceed-action transmit violate-action drop
class CLASS-TCS-200208
police 2000000 375000 750000 conform-action transmit exceed-action transmit violate-action drop
class CLASS-TCS-200441
police 4000000 750000 1500000 conform-action transmit exceed-action transmit violate-action drop
class CLASS-TCS-200338
police 4000000 750000 1500000 conform-action transmit exceed-action transmit violate-action drop
class CLASS-TCS-205679
police 4000000 750000 1500000 conform-action transmit exceed-action transmit violate-action drop
class CLASS-TCS-205560
police 4000000 750000 1500000 conform-action transmit exceed-action transmit violate-action drop
class CLASS-TCS-205593
police 3000000 562500 1125000 conform-action transmit exceed-action transmit violate-action drop
Is this the correct behaviour of applying the service-policy to the interface whereby the CPU increases by 20% or can the MQC be fine tuned to have less of an impact on the CPU?
Is the router just overloaded, taking into account it's only pushing about 400M? Should it be able to do more than this??
Thanks.
Andy

Similar Messages

  • Rate limit a certain pvc on an ATM interface on DSLAM

    Dear Sir
    I want to rate limit a certain pvc on an ATM interface on DSLAM 6260, Taking into consideration that i have tried all the kind of configuration using the rx-cttr and tx-cttr but all was useless.
    Could you please guide me how to do that, especially if i have a multiple pvcs on the same ATM interfaces and i need each not to raise above certain limit?
    Thanks in advance

    Dear Sir
    First thank you for your reply and concern.
    Here is the version 12.2(12)DA8 as i told you it is a Cisco DSLAM 6260 with NI-2, and as i got from the TAC that it is the latest (as far as i know).
    Thanks a lot

  • How can i limit the user to enter only A to Z and space in JFormattedText

    dear
    i want to use JFormatedTextField in two manners
    1.Limit the no of charecters.means in a text field only 20 charecters r allowed.
    2.and also check the enterd charecter must be a to z and space not other chareters r allowed.
    3.same for numbers means 0 to 9 and decimal.
    how can i do by using the JFormated TextFilef.

    Probably lacks in some cases but what the hell.
    * Filename:           JSMaskedTextField.java
    * Creation date:      22-mei-2004
    * Author:                Kevin Pors
    package jsupport.swingext;
    import java.awt.event.KeyEvent;
    import java.util.Arrays;
    import javax.swing.JTextField;
    * A masked textfield is a textfield which allows only a specific mask of
    * characters to be typed. If characters typed do not occur in the mask
    * provided, the typed character will not be 'written' at all. The default mask
    * for this <code>JSMaskedTextField</code> is <code>MASK_ALPHA_NUMERIC</code>
    * @author Kevin Pors
    * @version 1.32
    public class JSMaskedTextField extends JTextField {
        /** Masking for alphabetical lowercase characters only. */
        public static final String MASK_ALPHA_LCASE = "abcdefghijklmnopqrstuvwxyz ";
        /** Masking for alpha-numeric characters (lcase/ucase) only. */
        public static final String MASK_ALPHA_NUMERIC = "0123456789abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ ";
        /** Masking for alphabetical uppercase characters only. */
        public static final String MASK_ALPHA_UCASE = "ABCDEFGHIJKLMNOPQRSTUVWXYZ ";
        /** Masking for numbers only. */
        public static final String MASK_NUMERIC = "0123456789";
        /** Masking for hexadecimals. */
        public static final String MASK_HEXADECIMAL = "0123456789ABCDEF";
         * An array of keyevent constants defining which keys are always to be
         * allowed, no matter what.
        private final int[] ALWAYS_ALLOWED = new int[] { KeyEvent.VK_BACK_SPACE,
                KeyEvent.VK_DELETE, KeyEvent.VK_UP, KeyEvent.VK_DOWN,
                KeyEvent.VK_LEFT, KeyEvent.VK_RIGHT, KeyEvent.VK_SHIFT,
                KeyEvent.VK_HOME, KeyEvent.VK_END};
        /** Boolean specifying whether casing should be ignored. */
        private boolean ignoringCase = true;
        /** Specifying whether the maskin is enabled */
        private boolean isMaskingEnabled = true;
        /** The mask for the textfield. */
        private String mask = MASK_ALPHA_NUMERIC;
         * Creates a default number field.
        public JSMaskedTextField() {
            super(null, null, 0);
            Arrays.sort(ALWAYS_ALLOWED);
         * Creates a number field, with a specified number of columns.
         * @param columns The columnnumber.
        public JSMaskedTextField(int columns) {
            super(null, null, columns);
            Arrays.sort(ALWAYS_ALLOWED);
         * Creates a JSMaskedTextField with a masking.
         * @param mask The masking to be used.
        public JSMaskedTextField(String mask) {
            super(null, null, 0);
            Arrays.sort(ALWAYS_ALLOWED);
            setMask(mask);
         * Gets the masking for this masked textfield.
         * @return Returns the mask.
        public String getMask() {
            return this.mask;
         * Gets whether this JSMaskedTextField should be ignoring casing.
         * @return Returns if the component should be ignoring casing.
        public boolean isIgnoringCase() {
            return this.ignoringCase;
         * Checks whether masking is enabled. Default should be true.
         * @return Returns true if masking is enabled, false if not.
        public boolean isMaskingEnabled() {
            return this.isMaskingEnabled;
         * Sets whether it should be ignoring casing when checking for alpha-chars.
         * @param ignoringCase The ignoringCase to set.
        public void setIgnoringCase(boolean ignoringCase) {
            this.ignoringCase = ignoringCase;
         * Sets the masking for this textfield. The masking will determine which
         * characters can be typed. If the characters in de <code>mask</code> do
         * not occur in the typed character, it won't be typed.
         * @param mask The mask to set.
        public void setMask(String mask) {
            this.mask = mask;
         * Sets the masking enabled. If <code>false</code> this component will
         * behave just like a normal textfield.
         * @param isMaskingEnabled true if masking should be enabled.
        public void setMaskingEnabled(boolean isMaskingEnabled) {
            this.isMaskingEnabled = isMaskingEnabled;
         * Sets text of this textfield. If the blah blah.
         * @see javax.swing.text.JTextComponent#setText(java.lang.String)
        public void setText(String text) {
            for (int i = 0; i < text.length(); i++) {
                if (getMask().indexOf(text.charAt(i)) < 0) { // does not occur
                    return;
            super.setText(text);
         * @see javax.swing.JComponent#processKeyEvent(java.awt.event.KeyEvent)
        protected void processKeyEvent(KeyEvent e) {
            if (!isMaskingEnabled()) {
                return;
            char typed = e.getKeyChar();
            int code = e.getKeyCode();
            for (int i = 0; i < ALWAYS_ALLOWED.length; i++) {
                if (ALWAYS_ALLOWED[i] == code) {
                    super.processKeyEvent(e);
                    return;
            if (typed == KeyEvent.VK_BACK_SPACE) {
                super.processKeyEvent(e);
            if (isIgnoringCase()) {
                String tString = new String(typed + "");
                String ucase = tString.toUpperCase();
                String lcase = tString.toLowerCase();
                if (getMask().indexOf(ucase) < 0 || getMask().indexOf(lcase) < 0) {
                    e.consume();
                } else {
                    super.processKeyEvent(e);
                    return;
            } else { // not ignoring casing
                if (getMask().indexOf(typed) < 0) {
                    e.consume();
                } else {
                    super.processKeyEvent(e);
    }

  • How to fix the limit of the date entering in a parameters

    How to fix the limit of the date entering in a parameters,
    I.e i want to make parameters doesnot exceed 31.12.9999 in date and another parameter which is used to add no of days to this so it should not allow to add the no of days to given date as 31.12.9999

    parameter : p_date like sy-datum 
    at selection-screen on date1.
    if date1 GT 31.12.9999.
    message(e01).
    end if.
    reward with points if helpful.

  • Per user bandwidth rate limit.

                       How to configure per user bandwidth rate limit for wireless guest client, authentication server is ISE 1.2 & wireless controller is 5760.

    The Cisco 5760 WLC supports better QoS than other c
    ontrollers, allowing prioritization of mission-crit
    ical
    applications:

    The Cisco 5760 WLC supports four wireless hardware
    queues and priority-based queuing compared to
    software-based queuing in existing controllers.

    The Cisco 5760 WLC follows MQC based commands, allo
    wing usage of exact commands for configuring
    QoS on different types of network devices.

    The Cisco 5760 WLC supports QoS policies to be appl
    ied in a hierarchical fashion with more granularity
    per SSID per radio, while on the current controller
    s granularity is per WLAN.

    The Cisco 5760 WLC supports approximate fair bandwi
    dth to make sure of fairness at client, SSID, and
    radio levels for Non-Real Time (NRT) traffic. There
    fore, if one user consumes excessive bandwidth, we
    can
    limit the amount of bandwidth that user receives an
    d thereby not deprive other users.

  • WLC user rate limit on guest ssid anchor controller

    Hi,
    I have been looking through the forums & some cisco documents but not found a good example similar to what I am seeking to do so now I am turning to the expertise of my peers.
    We have been deploying 3502 APs remotely to locations with full T1s that backhaul to where I sit at HQ.
    Both the foreign and anchor controller are here at my location.
    I am seeking to rate limit per user the bandwidth each client will get on the guest internet ssid.
    As you know this traffic is encapsulated in capwap between the AP and the controller so I cant use a standard ACL on the switch or router.
    We are trying to keep the guest internet access usage in check on the T1 at any given site so the other ssid's & local lan traffic is not overly competing for the bandwidth.
    I found the place to edit the default profiles in the controller but the documentation really isnt clear on best practices.
    So I put it to you my fellow wireless engineers to suggest how you are implementing bandwidth management on your wireless guest internet.
    Thanks guys!           
    Oh and here is my hardware & software levels.
    5508wlc - forgeign
    4402wlc - anchor
    Software Version
    7.0.230.0

    Amjad,
    Thank you for taking the time to respond as well as the document link.
    It was pretty clear on the steps and what it would impact.
    Two things that push me for a different solution (assuming their is one).
    Note The values that you configure for the per-user bandwidth contracts affect only the amount of bandwidth going downstream (from the access point to the wireless client). They do not affect the bandwidth for upstream traffic (from the client to the access point).
    As you can see from the above note taken out of the linked document the roll based rate limit doesnt really rate limit the T1 traffic any guest user consumes it only limits usage from the AP down to the client.
    #1 I am looking for a solution that limits the users up & down streams (if possible) & also before it leaves the AP for the T1.
    The idea is to limit WAN utilization.
    #2 I read in the forums here others asking about the "user role" and saw some comments saying it is not considered "best practice" to use user roles.
    Let me clarify that our guest ssid's are using the http webpage pass through for authentication and it is really only the tic mark to indicate they understand the terms and conditions of using our internet as a guest service. No actual user accounts are used on the guest ssid's.
    ***One last question about this and any other changes***
    Will any change I make be on the "Foreign, Anchor" or both Controllers?

  • Service-Policy Or Bandwidth Rate Limit for IP

    Hii Netpros,
    Is this possible to configure the Service Policy(for Bandwidth) or Bandwidth Rate Limit for Single IP. For eg: If we want to configure the Service Policy(for Bandwidth) or Bandwidth Rate Limit of 2Mb for only IP " 10.10.10.3" on network  i.e the Host or device which is configured with this IP can access upto 2Mb only.
    Actual Network :-   We need this to configure this for wireless customers, Actually we have created one Vlan 2 (IP:- 10.10.10.1/29 @ our end router) , 10.10.10.2 on Basestation wiresss device (Vlan 2 allowed on this wireless device) and this wireless device is working as point to multipoint wireless. i.e 2 or more then 2 wireless customers or last mile will connect to this basestation wireless.  Wireless customer-1 is 10.10.10.3 (2Mb bandwidth)  and Wireless Customer-2  10.10.10.4 (512Kb).
    Hence we require to limit the bandwidth for this 2 wireless customers having different bandwidth. how to acheive & control bandwidth @ our end router for them. please suggest.
    Thanks

    This topic is probably better suited in another Infrastructure forum, but I suppose it depends on which features are supported by your Cisco hardware and software. This doc discusses a variety of options:
    http://www.cisco.com/en/US/docs/ios/12_2/qos/configuration/guide/qcfpolsh.html
    For example, with the older CAR (committed access rate) approach:
    interface FastEthernet5/0
         rate-limit input access-group 101 20000000 [normal burst size] [excess burst size] conform-action transmit exceed-action drop
         rate-limit input access-group 102 5120000 [normal burst size] [excess burst size] conform-action transmit exceed-action drop
    access-list 101 permit ip 10.10.10.3 0.0.0.0
    access-list 102 permit ip 10.10.10.4 0.0.0.0
    You can observe CAR in action with "show interfaces fa5/0 rate-limit" for example.

  • Wireless rate limit

    Hi,
    My network infrastructure as simple as following:
    LAN(edge switches 3560).......>Aggregator switch(3750)........>Firewall(ASA 5510)........>Router.......>Internet
    I define 3 wireless VLANs with 3 SSIDs on the Aggregator switch(3750):
    1. one SSID for company employees.
    2. one SSID for wireless IP phones.
    3. one SSID for company guest which access only internet.
    And the wireless APs connected to the LAN(edge switches) direct with trunks.
    My question is how to apply a rate limit for SSID for company guest to access internet with B.W. of 128kbps only.
    I tried policy map to be applied on the aggregator switch(3750) on the VLAN interface, but, it is not working.
    So, any suggested help, please.

    Hi Ahmed:
    With autonomous APs, rate limiting isn't possible.  All the autonomous APs support is QoS and that's pretty iffy.  At the core of the issue, you're dealing with radio waves and which ones arrive at the radio first, and who was prevented from talking because someone else was talking.  Dealing with these QoS and traffic shaping/policing issues are really tough with wireless because the transmission medium itself is unreliable.
    The "Configuring QoS" chapter of the autonomous AP configuration guide
      http://tools.cisco.com/squish/5aCf1
    will show you how you can map priority tagging to an SSID so that in that path from radio receiver to outbound on the fastethernet interface toward the rest of the network, you can control which SSID's packets get up into the network first, but the reverse path is a different story.  Because the wireless medium is half-duplex acknowledged, you can have a high priority packet out there on the radio interface trying to be beamed out to the client, and if the client isn't sending their ACK or what have you, it's going to sit and retry until its 63 retries are done before it gets out of the way to let the next high priority packet have a turn at getting transmitted out.
    Once the traffic gets past the edge switch, the fact that it was at one time wireless is irrelevant.  You should look at it as a general "rate limiting one VLAN's traffic over another" and check with the routing protocols or traffic shaping folks.
    Sincerely,
    Rollin Kibbe
    Network Management Systems Team

  • High cpu - Rate-limit cisco 6500

    Hello,
    my device is cisco 6509.
    Explanation of the case:
    Received to interface vlan (L3) 600M traffic (configured with Rate limit - 50 M).
    Result : 
    1. 100 % cpu
    2. the traffic was limited to 50M
    How can I prevent High Cpu in this situation ?
    Thanks.

    I would suggest opening a case, or asking in a different forum.  This form is for discussion about existing bugs for which a bugid has been identified.

  • How to redirect to different page after login in APEX 4.1

    Dear All,
    Here my Requirement is,When the users login,
    when they entered their username and password and pressed login button,
    they have to redirected to different pages based on the type of user.
    Here my LOGIN_TABLE has following 3 columns,
    1.Username
    2.Password
    3.Type.
    The TYPE has 2 values, employee and admin.
    when the type is admin they should be redirected to page 2,
    reaining i.e employee users has to be redirected to page 3.
    How can I do this? please give some suggestion.
    Thank you.
    regards,
    Gurujothi

    Dear Christian,
    Thank you for your reply,
    I would like to explain something,
    When I using the following function,
    *create or replace FUNCTION custom_auth_g (
    p_username IN VARCHAR2,
    p_password IN VARCHAR2)
    RETURN BOOLEAN IS
    BEGIN
    FOR c1 IN (SELECT 1
    FROM login_table
    WHERE upper(username) = upper(p_username)
    AND upper(password) = upper(p_password))
    LOOP
    RETURN TRUE;
    END LOOP;
    RETURN FALSE;
    END;*
    When login, It checks in the login_table table and if the username is exist with the pass word it successfully entered inside the application.
    for all users only one page which we set.
    My Login_table also contains type which has 2 type as I mentined above.
    But As I mentioned earliar based on the user type it has to be redirected to 2 different page.
    I found this Package but I cant understand,Can you please Explain?
    *create or replace PACKAGE app_security_pkg
    AS
    PROCEDURE add_user
    p_username IN VARCHAR2
    ,p_password IN VARCHAR2
    PROCEDURE login
    p_uname IN VARCHAR2
    ,p_password IN VARCHAR2
    ,p_session_id IN VARCHAR2
    ,p_flow_page IN VARCHAR2
    FUNCTION get_hash
    p_username IN VARCHAR2
    ,p_password IN VARCHAR2
    RETURN VARCHAR2;
    PROCEDURE valid_user2
    p_username IN VARCHAR2
    ,p_password IN VARCHAR2
    FUNCTION valid_user
    p_username IN VARCHAR2
    ,p_password IN VARCHAR2
    RETURN BOOLEAN;
    END app_security_pkg;*
    *create or replace PACKAGE BODY app_security_pkg
    AS
    PROCEDURE login
    p_uname IN VARCHAR2
    ,p_password IN VARCHAR2
    ,p_session_id IN VARCHAR2
    ,p_flow_page IN VARCHAR2
    IS
    lv_goto_page NUMBER DEFAULT 1;
    BEGIN
    -- This logic is a demonstration of how to redirect
    -- to different pages depending on who successfully
    -- authenticates. In my example, it simply demonstrates
    -- the ADMIN user going to page 1 and all other users going
    -- to page 2. Add you own logic here to detrmin which page
    -- a user should be directed to post authentication.
    IF UPPER(p_uname) = 'ADMIN'
    THEN
    lv_goto_page := 1;
    ELSE
    lv_goto_page := 2;
    END IF;
    APEX_UTIL.SET_SESSION_STATE('FSP_AFTER_LOGIN_URL');
    wwv_flow_custom_auth_std.login
    p_uname => p_uname,
    p_password => p_password,
    p_session_id => p_session_id,
    p_flow_page => p_flow_page || ':' || lv_goto_page
    EXCEPTION
    WHEN OTHERS
    THEN
    RAISE;
    END login;
    PROCEDURE add_user
    p_username IN VARCHAR2
    ,p_password IN VARCHAR2
    AS
    BEGIN
    INSERT INTO app_users (username, PASSWORD)
    VALUES (UPPER (p_username),
    get_hash (TRIM (p_username), p_password));
    COMMIT;
    EXCEPTION
    WHEN OTHERS
    THEN
    ROLLBACK;
    RAISE;
    END add_user;
    -- Function to Perform a oneway hash of the users
    -- passwords. This cannot be reversed. This exmaple
    -- is a very week hash and if been used on a production
    -- system, you may want to use a stronger hash algorithm.
    -- Read the Documentation for more info on DBMS_CRYPTO as
    -- this is the supported package from Oracle and
    -- DBMS_OBFUSCATION_TOOLKIT is now depricated.
    FUNCTION get_hash (p_username IN VARCHAR2, p_password IN VARCHAR2)
    RETURN VARCHAR2
    AS
    BEGIN
    RETURN DBMS_OBFUSCATION_TOOLKIT.md5 (
    input_string => UPPER (p_username)
    || '/'
    || UPPER (p_password));
    END get_hash;
    PROCEDURE valid_user2 (p_username IN VARCHAR2, p_password IN VARCHAR2)
    AS
    v_dummy VARCHAR2 (1);
    BEGIN
    SELECT '1'
    INTO v_dummy
    FROM app_users
    WHERE UPPER (username) = UPPER (p_username)
    AND PASSWORD = get_hash (p_username, p_password);
    EXCEPTION
    WHEN NO_DATA_FOUND
    THEN raise_application_error (-20000, 'Invalid username / password.');
    END valid_user2;
    FUNCTION valid_user (p_username IN VARCHAR2, p_password IN VARCHAR2)
    RETURN BOOLEAN
    AS
    BEGIN
    valid_user2 (UPPER (p_username), p_password);
    RETURN TRUE;
    EXCEPTION
    WHEN OTHERS
    THEN RETURN FALSE;
    END valid_user;
    END app_security_pkg;*
    And you said "assign an URL to FSP_AFTER_LOGIN_URL, depending on the Type column",
    Where to assign,Could you please Explain?
    Thank you.

  • Exchange rate is different between records in OB08 and records in document.

    Hi Gurus,
    The exchange rate is different between records in OB08 and records in calculated amount in line item. How does it happen? Not all of the documents in the same period has this problem.
    For example, a document A created by FB05 on Jun 30 2010.
    In OB08, the exchange rate is 6.80000. This rate was the same in the header of document A.
    In the line item of doc A, I calculated the amount for line itme 1 and 2. Line itme 1 shows the exchange rate is 7.90000. Line item 2 shows the exchange rate is 16.0000. ( The exchange rate is not that exactly an interger. I put a similar exchange rate as an example.)
    Could you please throw some light on these? Why some documents are okay but for some, the exchange rate is so different?
    I just found that the exchange rate of some of the document line item calculated is from another currency. It shows in the line item (in question) button "More Data". Shall I know how the exchange rate was got from another currency exchange rate?
    Thank you.
    Emma
    Edited by: qun yang on Aug 2, 2010 10:49 AM

    Issue solved by below solution:
    Existing:
          append lines of vit_final to s_s_if-maxsize to e_t_data.
          delete vit_final to s_s_if-maxsize.
        else.
          append lines of vit_final to s_s_if-maxsize to e_t_data.
          delete vit_final to s_s_if-maxsize.
    New:
          append lines of vit_final to e_t_data.
          delete vit_final to s_s_if-maxsize.
        else.
          append lines of vit_final to e_t_data.
          delete vit_final to s_s_if-maxsize.

  • In KA02 screen how can I get different functional area like (Production, Sales, Adminstration etc)

    In KA02 screen how can I get different functional area like (Production, Sales, Adminstration etc)

    Hi,
    Please check below configuration for defining functional areas for cost elements
    SPRO> FI > FI Global settings> company code> cost of sales accounting>Functional area > enter functional area
    Regards,
    Jyoti

  • With the new IOS7 I get every email in my inbox. How can I limit to the last 50 like it was before the upgrade?

    With the new IOS7 I get every email in my inbox. How can I limit to the last 50 like it was before the upgrade?

    You can set the pref <b>browser.urlbar.formatting.enabled</b> to <i>false</i> on the <b>about:config</b> page.
    To open the <i>about:config</i> page, type <b>about:config</b> in the location (address) bar and press the "<i>Enter</i>" key, just like you type the url of a website to open a website.<br />
    If you see a warning then you can confirm that you want to access that page.<br />
    *Use the Filter bar at to top of the about:config page to locate a preference more easily.
    *Preferences that have been modified show as bold(user set).
    *Preferences can be reset to the default or changed via the right-click context menu.

  • Bandwidth Rate-Limit -w- WWR-Queue

    How would one convert a layer-2 port's "switchport rate-limit" bandwidth statement, on a 6509 -w- WS-X6748-SFP ports, to a routed/layer-3 "wrr-queue" bandwidth statement policy? Basically trying to hard-core the port's speed to 20MB.  Current/tested layer-2 port bandwidth setting:
    rate-limit input 20000000 5000 5000 conform-action transmit exceed-action drop
    rate-limit output 20000000 5000 5000 conform-action transmit exceed-action drop
    Got lost in how to use/configure all WRR's four queues... just need to limit the port's bandwidth to 20MB.  Any suggestions would be appreciated.
    Thanks, Kevin

    1) Enabled QoS globally...
    2960(config)#mls qos
    2) Configure an ACL to define the matched traffic...
    2960(config)#access-list 111 permit ip any any
    3) Configure a class map for the matched traffic...
    2960(config)#class-map traffic
    2960(config-cmap)#match access 111
    4) Configure a policy-map to define action...
    2960(config)#policy-map Control
    2960(config-pmap)#class traffic
    2960(config-pmap-c)#police 10000000 8000 exceed-action drop
    5) Attached the policy-map to the interface.
    a) Example
    -In this case, I'll attach the policy map to port_1....
    2960(config)#int fa0/1
    2960(config-if)#service-policy input Control
    >>>>>> This will rate-limit traffic coming from the PC

  • WLC 5508 and Anchor/GuestNet rate limit traffic?

    Running WLCs 5508s 7.0.116.0 with GuestNet and Anchor setup, how can I limit the bandwidth on the GuestNet SSDI to 2 Mbps, etc?
    The DMZ WLC (Anchor) runs thru a ASA 5508 7x, can I rate limit traffic via ASA?

    That's really a matter of preference.  This document describes things to keep in mind when altering these QoS profile configurations, FYI.
    http://www.cisco.com/en/US/partner/docs/wireless/controller/7.0MR1/configuration/guide/cg_controller_setting.html#wp1254532
    It really depends on how many guests, what type of traffic, etc, to make a judgement call as to where you should set these.  I'm sorry but I don't have any examples from existing configurations, but hopefully the document explains how to best alter these settings.

Maybe you are looking for